PlayStation(R)Mobile SDK トップページ

Contents

  • このドキュメントについて
  • 開発ガイド
  • APIの概要
  • APIリファレンス
  • そのほかの情報

このドキュメントについて

PSM SDK ( PlayStation(R)Mobile Software Development Kit ) は、ソニー・コンピュータエンタテインメントが提供する、アプリケーション開発・実行環境です。

このドキュメントは、PSM SDK を使ってPSMアプリケーションを開発するための情報を提供します。

初めてPSM SDKで開発を行う方は 「PlayStation(R)Mobileとは」「開発環境の設定」をご覧ください。

すでに開発をおこなったことのある方は リリースノート で変更点をご確認ください。

開発ガイド

PSM SDKについて

プログラミングガイド

UI Toolkit

マスターの作成と提出

サンプル一覧

そのほかの情報

APIの概要

標準ライブラリの概要

Coreの概要

Graphicsの概要

Audioの概要

Inputの概要

Imagingの概要

Environmentの概要

Servicesの概要

Deviceの概要

HighLevel.UIの概要

HighLevel.Modelの概要

HighLevel.GameEngine2Dの概要

HighLevel.Physics2Dの概要

APIリファレンス

ネームスペース一覧

クラス一覧

クラス階層

クラスインデックス

そのほかの情報

バグ情報

リリースノート

SDKのロードマップ

SDKの使用上の注意

ライセンス情報

Copyright(C) 2014 Sony Computer Entertainment Inc. All Rights Reserved.


PlayStation(R)Mobileとは

この文書では、PlayStation(R)Mobileの概要について説明します。

Contents

  • PlayStation(R)Mobileとは
    • 開発環境
    • PSMアプリケーションが実行可能なデバイス
  • PlayStation(R)Mobile開発の概要
    • 開発に使用するツール
  • API
    • Core API
    • HighLevel API

PlayStation(R)Mobileとは

PlayStation(R)Mobile SDK(PlayStation(R)Mobile Software Development Kit)は、PlayStation(R)Vitaで実行可能なアプリケーションの開発環境です。

またPSM SDKは、プロトタイプ開発環境としてWindows上でのシミュレータをサポートしており、各デバイス上で動作させる前に、Windows PC上でシミュレーションしながら効率的に開発を進めることができます。

開発環境

  • PSMアプリはWindows PC上で開発をおこないます。OSはWindows 7とWindows 8をサポートしています。

PSMアプリケーションが実行可能なデバイス

PSMアプリケーションは以下のデバイスで実行可能です。

  • PlayStation(R)Vita
  • Windows PC(OpenGL 3.0 以上をサポートしたビデオカードが必要。)

PlayStation(R)Mobile開発の概要

  • PSM SDKでは統合開発環境PSM Studio上で、C#を用いて開発を行います。
  • C#のソースコードはC#コンパイラでマネージドコード(PSMアプリケーション)にコンパイルします。
  • 作成されたPSMアプリケーションをPSM Studioから各デバイスに転送します。
  • 転送されたPSMアプリケーションを、Monoランタイムと呼ばれる.NET Framework互換の仮想マシンがJITコンパイル(Just In Time Compile)を行い、プログラムを実行します。

図1 PSMアプリケーションと仮想マシン

開発に使用するツール

PSM Studio

統合開発環境(IDE)として、PSM Studioを使用します。

ソースコードの編集、ビルド、デバイスへのPSMアプリの転送、デバッグなどの作業をPSM Studioで一括して行うことができます。

UI Toolkit, PSM UI Composer

UI Toolkit は、PSM 上でユーザーインターフェースを作成するための仕組みやウィジェット(GUI部品)をまとめたライブラリです。

PSM UI Composer (以降、本SDKドキュメントではUI Composerと略記します) は、ユーザーインタフェースのデザインを支援するためのツールで、ボタンやラベルなどのウィジェットをレイアウトしたり、各ウィジェットのプロパティを設定することが可能です。

詳しくは UI Toolkit をご覧ください。

Publishing Utility

Publishing UtilityはPSMアプリのメタデータ(app.xml)の設定、マスターパッケージの作成、鍵の管理などをおこなうツールです。

API

PSM SDKのAPI(Application Programming Interface) は C#ベースのクラスライブラリとして提供されます。

Core API

Sce.PlayStation.Coreでは、描画やサウンド再生などのゲーム開発の基盤となるAPIが提供されます。

HighLevel API

Sce.PlayStation.HighLevelでは、3Dモデルの描画や物理エンジンといった高度な機能を持つAPIが提供されます。

図2 ライブラリの階層

APIの詳細については APIリファレンスを参照してください。


開発環境の設定

この文書では、PSM SDKインストール後、最初におこなう設定について説明します。

Contents

  • 統合開発環境 PSM Studio の設定
    • PSM Studioの起動
  • サンプルをビルド・実行する
    • ソリューションを開く
    • ビルドする
    • 実行するプラットフォームの選択

統合開発環境 PSM Studio の設定

ここでは統合開発環境である PSM Studio の設定を行います。

※ アンチウィルスソフトをオンにしていると、実行に必要なexeファイルをアンチウィルスソフトが削除してしまう場合がありますのでご注意ください。

PSM Studioの起動

まず、デスクトップに配置されているPSM Studioのアイコンをダブルクリックして起動します。

PSM Studioを起動すると以下の画面が現れます。

サンプルをビルド・実行する

ここでは サンプルを用いて、PSMアプリケーションをビルドし、実行する方法を説明します。

ソリューションを開く

まず、ソリューションファイルを開きます。

ソリューションファイルとは、プロジェクトの構成を記述したファイルで、拡張子にslnがついています。

PSM Studioのメニュー - [File] - [Open] を選択し、ダイアログから sample/Graphics/TriangleSample を選択し、 TriangleSample.sln を開いてください。

Sampleはデフォルトで以下の場所にインストールされています。

  • Windows 7/8の場合: "C:/Users/Public/Documents/PSM/"

※ 開発用PCの言語設定が英語の場合、「Yen」の文字は「バックスラッシュ」で表示されます。

ビルドする

PSM Studioのメニュー - [Build] - [Build All] を選択する、もしくはF8キーを押すと、ビルドを実行します。

ビルド結果のログをみるには、ウィンドウ左下の Build successful の部分をクリックし、[Build Output]ボタンを押してください。

ウィンドウ左下にBuild successfulと表示されたら、ビルド成功です。

実行するプラットフォームの選択

ビルドが成功したのを確認したら、ビルドされたPSMアプリケーションを実行してみましょう。

まず、どのプラットフォームで実行するかを指定します。

最初はWindowsで実行してみましょう。

  1. マウスカーソルをツールバーの領域に置き、右クリックし、PSMにチェックをいれてドロップダウンリストを表示します。
  2. ドロップダウンリスト コントロールで [PlayStation Mobile Simulator] を選択します。
  3. メニュー - [Run] - [Debug] を選択、もしくは F5キーを押すと、アプリケーションが起動します。

アプリケーションが出力する文字列は PSM Studioの[Application Output] ウィンドウに出力されます。

※ Application Outputウィンドウは メニュー - [View] - [Pads] - [Application Output]で表示します。

  4. アプリケーションを終了するには、ウィンドウ右上の×ボタン、もしくは Shift + F5 キーを押してください。


実機でPSMアプリを実行するための準備

この文書ではPSMアプリを実機上で実行するため手順について説明します。

Contents

  • 手順
    • 1. パブリッシャライセンスの取得
    • 2. 鍵の作成
  • プロキシサーバーの設定

手順

1. パブリッシャライセンスの取得

PSMアプリを実機(PS Vita)で実行するためには、パブリッシャライセンスが必要です。

弊社のサイト DevPortal でパブリッシャライセンスを取得してください。

https://psm.playstation.net

※ パブリッシャライセンスの申請から承認まで数日かかる場合があります。

2. 鍵の作成

PS Vitaで実行するためには鍵を作成する必要があります。

※ このドキュメントで「鍵」とは、パブリッシャ鍵、デバイスシード、アプリ鍵を意味します。

次の手順で鍵を作成します。

  1. PCをインターネットに接続できる状態にしておきます。
※ 社内LAN環境などでプロキシサーバーを利用している場合は、下記の「プロキシサーバーの設定」を参照して、設定を行ってください。
  2. PSM Studioで実行したいPSMアプリのソリューションファイルを開いた状態にします。
  3. 次に PS Vitaで実行するための設定 に進みます。

プロキシサーバーの設定

社内LAN環境などでプロキシサーバーを経由してネットワークに接続している場合、次の手順で設定を行います。

  1. デスクトップ上の [Publishing Utility]のアイコンをダブルクリックしてPublishing Utilityを起動してください。

図3 Publishing Utility

  2. [メニュー] - [ファイル] - [プロキシサーバーの設定]を選択します。ダイアログが表示されるので、環境に合わせた設定をおこなってください。

図4 プロキシサーバーの設定


PlayStation(R)Vita で実行するための設定

この文書ではPlayStation(R)VitaでPSMアプリケーションを実行するための手順を説明します。

なお、PlayStation(R)Vitaで実行するためにはメモリーカード、及び無線(Wi-Fi/3G)でネットワークに接続できる環境が必要となります。

Contents

  • PS Vitaの準備と設定
    • PlayStation(R)Mobile Development AssistantをPS Vitaにダウンロードする
    • PS Vitaの設定
  • 鍵の作成
  • 実行
  • 補足事項

PS Vitaの準備と設定

PlayStation(R)Mobile Development AssistantをPS Vitaにダウンロードする

最初にPlayStation(R)Mobile Development AssistantをPS Vitaにダウンロードします。

Development AssistantはPS Vita上でPSMアプリの開発をおこなうために使用するアプリケーションです。

以下の手順でダウンロードをおこなってください。なおダウンロード済みの場合、LiveArea(TM)に表示されるオレンジ色の[アップデート]アイコンで更新を行ってください。

  1. PlayStation(R)Vitaにメモリーカードを入れておきます。

  2. PS Vita本体に登録してあるPSN(SM) (Sony Entertainment Network)アカウントで、DevPortalにてデベロッパ登録をおこないます。

  3. デベロッパ登録が完了するとPlayStation(R)StoreでDevelopment Assistantのダウンロードが可能になります。PS Vitaのホーム画面からPlayStation(R)Storeアプリを起動してください。

  4. 右下のボタンをタップして現れるメニューからダウンロードリストを選択します。

  5. 上部のタブから[ゲーム]を選択します。

  6. [PlayStation(R)Mobile Development Assistant]を探して、その右側にある[ダウンロード]をタップして、ダウンロード&インストールします。

  7. ダウンロード&インストールに成功すると、PS Vitaのホーム画面に以下のアイコンが現れます。

PS Vitaの設定

  1. 開発用PCとPlayStation(R)Vitaを付属のUSBケーブルで接続します。
  2. PS Vitaのホーム画面で、[Settings]アイコンをタップし、[Date & Time] - [Date & Time Settings] - [Set via Internet]を選択し、でネットワークから自動で時刻を所得するようにしておきます。
  3. PS Vitaで時刻の取得が完了したら、開発用PCの時刻をPS Vitaの時刻に合わせておきます。

鍵の作成

PSMアプリを実機で実行するためにはアプリ鍵を作成する必要があります。以下ではアプリ鍵の作成手順を説明します。

  1. 実機でPSMアプリを実行するための準備 で準備を済ましておいてください。
  2. PSM Studioで実行させたいPSMアプリのソリューションファイルを開きます。
  3. PlayStation(R)Vitaホーム画面上の「PSM Dev」アイコンをタップしてDevAssistant を起動します。
  4. PCに接続されているデバイスがドロップダウンリストに表示されるので、対象の PS Vita ( xxxxxx ) を選択します。

図1 Vitaの選択

※ ( xxxxxx )にはPlayStation(R)VitaのID番号が表示されます。IDはPlayStaion(R)Vitaごとに異なります。

※ ドロップダウンリストにOFFと表示されている場合、DevAssistantが起動していないことを表しています。 PlayStation(R)Vitaホーム画面上の「PSM Dev」アイコンをタップしてDevAssistant を起動してください。

  4. メニューの [Key] - [Update Device Seed and App Key] を選択を選択し、デバイスシードとアプリ鍵を作成します。

図2 デバイスシードとアプリ鍵の更新

  5. ダイアログが表示されるので、指示に従って入力を行ってください。初回はパブリッシャ鍵の作成を求められますので、作成してください。
  6. アプリ鍵の作成に成功したら準備は完了です。

実行

  1. 鍵を作成後、メニューの[Build] - [Rebuild All]でプロジェクトをリビルドします。

  2. Vitaを無線でネットワークに接続できる状態にしておきます。PSMアプリ起動時に弊社のサーバーに接続して認証が行われます。

    ※ PlayStation(R)Vitaでは、認証が成功すると、以降24時間は認証処理は省略されます。

  3. メニューの [Run] - [Debug] を選択、もしくは F5キーを押すと開発用PCからPlayStation(R)Vitaのメモリーカードに関連ファイルが転送され、アプリケーションが起動します。

補足事項

  • 鍵についての詳しい情報は 鍵管理 を参照してください。
  • PlayStation(R)Mobile Development Assistant については、 PlayStation(R)Mobile Development Assistant について を参照してください。


新しいプロジェクトの作成

この文書では、新しいプロジェクトを作成するための手順について説明します。

Contents

  • PSMソリューションの作成

PSMソリューションの作成

ここではPSMソリューションを新しく作成する方法を紹介します。
  1. PSM StudioのWelcomeページで Start a New Solution を選択、もしくは メニューの [File] - [New] - [Solution..]を選択します。

※日本語版では [ファイル] - [新規] - [ソリューション..]になります。

  2. ダイアログの左側のツリービューから[C#] > [PlayStation(R)Mobile]を選択し、中央のウィンドウのリストから[PlayStation(R)Mobile Application]を選択します。

[PlayStation Mobile Application]では、プログラムを実行するための一通りのファイルを含んだプロジェクトを作成します。

プロジェクト名および作成場所は任意で設定してください。設定が完了したらOKボタンを押します。

  3. 設定が完了すると、新しいPSMのプロジェクトが作成されます。

実行するには、前章で述べたように、ビルドを行い、F5を押してください。

成功すると以下のような画面が表示されます。


1. プログラムの構造

この文書では簡単な2Dシューティングゲームの作成を通じて、ゲームアプリケーションの基本的な仕組みや、PSM SDKでの開発手法を説明していきます。

Contents

  • 最小のPSMプログラム
  • PSMアプリケーションの基本的な構造
  • 処理の流れ
    • ダブルバッファ
    • 用語の定義
なお、このドキュメントは以下のような方を想定して書かれています。
対象読者
  • ゲームアプリケーションを初めて開発する方。
  • C#の基本的な仕様を理解している方。

最小のPSMプログラム

最初に、最小のPSMプログラムを実行してみましょう。

PSM Studioを起動し、[File] - [Open..] でSample/Tutorialフォルダーを開いてください。

Sample/Tutorialはデフォルトで以下の場所にインストールされています。

  • Windows 7/8の場合: "C:/Users/Public/Documents/Psm/"

sample/Tutorial/Sample01

拡張子slnの付いたファイルはソリューションファイルといい、プロジェクトファイルの構成が記述されています。

拡張子csprojの付いたファイルはプロジェクトファイルといい、ソースコード(csファイル)の構成やビルド方法などが記述されています。

アプリケーションを構築するためのSample01フォルダー以下を「プロジェクト」といいます。

※「プロジェクトファイル csproj」と「プロジェクト」は意味が違うので注意してください。

図1 ソリューションファイルとプロジェクトファイルの構成関係

ソリューションファイルがプロジェクトの起点になりますので、アプリケーションの開発を始める時はこのファイルを開いてください。

ソリューションファイルを開いたら、ビルドを行い、F5キーで実行します。

おめでとうございます！ ただ、このプログラムは真っ黒な画面が表示されるだけで、他には何も起こりません。 ウィンドウ右上の×ボタンをクリックするか、PSM StudioでShift+F5キーを押してプログラムを終了してください。

PSMアプリケーションの基本的な構造

では、ソースコードをみてみましょう。 ソースコードを見るには、左側のソリューションエクスプローラ内のAppMain.csをダブルクリックしてください。

public class AppMain
{
    static protected GraphicsContext graphics;

    public static void Main (string[] args)
    {
        Initialize ();

        while (true) {
            SystemEvents.CheckEvents();
            Update ();
            Render ();
        }
    }

    public static void Initialize ()
    {
        graphics = new GraphicsContext();
    }

    public static void Update ()
    {

    }

    public static void Render ()
    {
        graphics.Clear();

        graphics.SwapBuffers();

    }
}

ここでは、Main()、Initialize()、SystemEvents.CheckEvents()、Update()、Render()、SwapBuffers()に注目します。

Main()

  • プログラムはまずMain()から始まります。どのアプリケーションでも必ずひとつのMain()関数が必要になります。2つ以上あるとビルドエラーになります。

Initialize()

  • Initialize()の中では主に初期化の処理を記述します。このプログラムの構造では起動時に一度だけこの処理を行います。

while

  • 次にwhileでループに入ります。つまりこの中でSystemEvents.CheckEvents()とUpdate()、Render()を繰り返し処理します。

    SystemEvents.CheckEvents()

    • SystemEvents.CheckEvents ()でOS依存のイベントをチェックします。Windowsではウィンドウメッセージの処理などをここで検知します。

    Update()

    • 主にCPUに任せる計算処理などをUpdate()内に記述します。

    Render()

    • 主に描画処理やGPUに任せる処理などをRender()内に記述します。Render()内では最初にgraphics.Clear()でフレームバッファをクリアします。

    SwapBuffers()

    • SwapBuffers()は垂直同期のタイミングでフレームバッファを切り替えます。

一番最後の「垂直同期のタイミングでフレームバッファを切り替える」ですが、この部分を詳しく説明します。

プログラムがどのように動いているのかを分かりやすくするために、プログラムを以下のように変えてみます。 <-の箇所を追加します。

public class AppMain
{
    static protected GraphicsContext graphics;
    static int colorValue=0;    //<- here.

    public static void Main (string[] args)
    {
        Initialize ();

        while (true) {
            SystemEvents.CheckEvents ();
            Update ();
            Render ();
        }
    }

    public static void Initialize ()
    {
        graphics = new GraphicsContext();
    }

    public static void Update ()
    {
        colorValue++;       //<- here.
        if(colorValue>255)  //<- here.
            colorValue=0;   //<- here.

        graphics.SetClearColor(colorValue, colorValue, colorValue, 255);//<- here.
    }

    public static void Render ()
    {
        graphics.Clear();

        graphics.SwapBuffers();
    }
}

このプログラムを実行すると、画面の背景色がどんどん白くなって、また黒に切り替わります。

graphics.SetClearColor(int r, int g, int b, int a)は引数で渡した色で画面をクリアします。

r=255, g=255, b=255は白になります。

aはアルファと呼ばれ、透明の度合いを表します。0で完全な透明、255で完全な不透明になります。

つまりcolorValue++;が何度も繰り返し処理されていることがわかりますね。

この数値はシミュレータでは1秒間に60回更新、つまり約16.6ミリ秒に1度更新されます。

処理の流れ

ダブルバッファ

処理の流れを図で表すと以下のようになります。

ディスプレイに表示するビデオメモリの領域のことを フレームバッファ といいます。

ゲームアプリケーションでは一般的に画面に表示される画像の領域を２つもっており、これをダブルバッファ方式と呼びます。

描画は以下の手順で流れていきます。

  1. まずを後ろの領域(back)を r=1, g=1, b=1でクリアします（上の図では分かりやすくするため、白さを強調しています）。
  2. 描画が完了したら16ミリ秒が経つまで待ちます。
  3. 16ミリ秒が経過したら、r=1, g=1, b=1でクリアした領域を前（front）にします。
  4. 今度は後ろになった領域にr=2, g=2, b=2でクリアします。
  5. 描画が完了したら16ミリ秒が経つまで待ちます。
  6. 16ミリ秒が経過したら、r=2, g=2, b=2でクリア領域を前（front）にします。

この処理を繰り返しながらプログラムが進行していきます。

領域を切り替えて表示するのは、描画途中の画面を表示してしまうと画面が乱れて見えてしまうので、これを避けるためです。

ディスプレイの更新のタイミングに合わせることを「画面の垂直同期を待つ（合わせる）」といいます。

ディスプレイの更新のタイミングが約16.6ミリ秒(注1)なので、フレームバッファの切り替えもこれに合わせた数字になっています。

この一連の処理を行っている箇所が、SwapBuffers()です。

SwapBuffers()で画面の切り替えを待つまでの1コマを 1フレーム と呼びます。

1秒間にフレームを更新する回数を表す単位としてfps(Frame Per Second: フレーム/秒)を用います。 1秒間に60回フレームを更新するとき、60fpsと表記します。

用語の定義

似たような用語がいくつか出てきたので、混乱を避けるために用語の整理をしておきます。

  • 「ディスプレイ」とはハードウェア的な表示装置を指します。
  • 「スクリーン」とはソフトウェア的な画面を指します。
  • 「フレームバッファ」とは、ビデオメモリ上に確保された、スクリーン用の領域を指します。

この章で説明した処理と用語は以降の章でも出てきますので、覚えておきましょう。


2. 画像を表示する

この文書ではスクリーンに画像を表示する手順について説明します。

Contents

  • 画像表示の手順
    • 画像ファイルの登録
    • シェーダープログラムの登録
    • テクスチャの生成とシェーダープログラムの初期化
  • 頂点バッファの作成
    • 頂点バッファの設定
    • 座標系の変換
    • ポリゴンの描画を実行
  • 簡易版スプライトクラスを定義する

画像表示の手順

次は画像を表示してみましょう。 フォルダー Tutorial/Sample02_01/のソリューションを開いてください。

画像を表示するには以下の手順を踏みます。

画像ファイルの登録

表示したい画像ファイルをプロジェクトに登録します。

  1. PSM Studioのソリューションエクスプローラで、resourcesフォルダーを選択し、右クリック - [追加] - [ファイルを追加] で表示したい画像ファイルを選択します。

  2. ファイルを登録したら、右クリック - [ビルドアクション] で [Content]を選択しておきます(PNGの場合、デフォルトでContentが設定されます）。
    • ビルドアクションが「None」のままだと実機 (PS Vita) に転送されませんのでご注意ください。
    • 画像ファイルはPNG、BMP、JPEG、GIF, DDS形式に対応しています。PNG形式は透明色に対応しているので、抜き色を使いたい場合は、この形式を使うと良いでしょう。
    • フォルダーはresourcesでなく、任意の場所でも構いません。

詳しくは「ビルドアクションについて」をご覧ください。

シェーダープログラムの登録

シェーダープログラムをプロジェクトに登録します。

  • ここでは頂点シェーダーSprite.vcgとフラグメントシェーダーSprite.fcgをプロジェクトに登録しています。

  • ファイルを登録したら、右クリック - [ビルドアクション] で ShaderProgramを設定しておきます。ビルドアクションにShaderProgramを設定しておくと、ビルド時にSprite.vcgとSprite.fcgをバイナリ形式のSprite.cgxファイルに変換してくれます。

テクスチャの生成とシェーダープログラムの初期化

画像ファイルとシェーダープログラムをプロジェクトに登録したら、プログラムで以下のように初期化処理を行ってください。

Sample02_01/AppMain.cs
public static void Initialize ()
{
    graphics = new GraphicsContext();
    ...

    texture = new Texture2D("/Application/resources/Player.png", false);
    shaderProgram = new ShaderProgram("/Application/shaders/sprite.cgx");

    ...
}

Texture2D

texture = new Texture2D("/Application/resources/Player.png", false);では、テクスチャを作成しています。 「テクスチャを作成する」とはビデオメモリ上に画像のイメージを作成することを意味します。

ShaderProgram

プログラムでシェーダープログラムを読むときは、生成されたSprite.cgxを指定します。

shaderProgram = new ShaderProgram("/Application/shaders/sprite.cgx");では引数で指定したシェーダープログラムを実行時コンパイルします。 あとはshaderProgramからメソッドを使って処理を行うことができます。

頂点バッファの作成

次は、テクスチャを描画するための頂点バッファを設定します。 ここでは次のように3角のポリゴンを2枚書いて4角形にすることにします。

ソースコードを見ていきましょう。

頂点座標、テクスチャ座標、頂点色、インデックスを保持する領域を4頂点ぶん用意します。

  • 頂点座標はx,y,z の3つが必要なので、floatの配列で12個確保しています。zは奥行きを指定するのに使用します。
  • テクスチャ座標はu,vの2つが必要なので、floatの配列で8個確保します。
  • 頂点の色は、r,g,b,aの4つが必要なので、floatの配列で16個確保します。
  • インデックスは4つ確保します。インデックスは頂点描画の順番を指定するのに使用します。

AppMain.cs

public class AppMain
{
    ...
    static float[] vertices=new float[12];

    static float[] texcoords = {
        0.0f, 0.0f, // 0 top left.
        0.0f, 1.0f, // 1 bottom left.
        1.0f, 0.0f, // 2 top right.
        1.0f, 1.0f, // 3 bottom right.
    };

    static float[] colors = {
        1.0f,   1.0f,   1.0f,   1.0f,   // 0 top left.
        1.0f,   1.0f,   1.0f,   1.0f,   // 1 bottom left.
        1.0f,   1.0f,   1.0f,   1.0f,   // 2 top right.
        1.0f,   1.0f,   1.0f,   1.0f,   // 3 bottom right.
    };

    const int indexSize = 4;
    static ushort[] indices;
    ...

頂点の座標はInitialize()で画像ファイルを読み込んだ後、設定します。

AppMain.cs
public static void Initialize ()
{
    graphics = new GraphicsContext();
    ImageRect rectScreen = graphics.Screen.Rectangle;

    texture = new Texture2D("/Application/resources/Player.png", false);
    shaderProgram = new ShaderProgram("/Application/shaders/Sprite.cgx");
    shaderProgram.SetUniformBinding(0, "u_ScreenMatrix");

    vertices[0]=0.0f;   // x0
    vertices[1]=0.0f;   // y0
    vertices[2]=0.0f;   // z0

    vertices[3]=0.0f;   // x1
    vertices[4]=texture.Height; // y1
    vertices[5]=0.0f;   // z1

    vertices[6]=texture.Width;  // x2
    vertices[7]=0.0f;   // y2
    vertices[8]=0.0f;   // z2

    vertices[9]=texture.Width;  // x3
    vertices[10]=texture.Height;    // y3
    vertices[11]=0.0f;  // z3
    ...

頂点バッファの設定

次に頂点バッファを設定します。VertexBuffer()の最初の引数で頂点のサイズ4を指定しています。

public static void Initialize ()
{
    ...
    //                                              vertex pos,               texture,       color
    vertexBuffer = new VertexBuffer(4, indexSize, VertexFormat.Float3, VertexFormat.Float2, VertexFormat.Float4);
    ...
    vertexBuffer.SetVertices(0, vertices);
    vertexBuffer.SetVertices(1, texcoords);
    vertexBuffer.SetVertices(2, colors);

    vertexBuffer.SetIndices(indices);
    graphics.SetVertexBuffer(0, vertexBuffer);

vertexBuffer.SetVertices()で頂点データを頂点バッファにコピーします。

graphics.SetVertexBuffer()で描画に使用する頂点バッファを指定します。

座標系の変換

次にピクセル単位の座標系を、デフォルトのスクリーンの座標系に変換する行列を設定します。

public static void Initialize ()
{
    ...
    ImageRect rectScreen = graphics.Screen.Rectangle;
    ...
    screenMatrix = new Matrix4(
         2.0f/rectScreen.Width, 0.0f,       0.0f, 0.0f,
         0.0f,   -2.0f/rectScreen.Height,   0.0f, 0.0f,
         0.0f,   0.0f, 1.0f, 0.0f,
         -1.0f,  1.0f, 0.0f, 1.0f
    );
}

ImageRect rectScreen = graphics.Screen.Rectangle;でスクリーンの大きさを取得します。

２次元のゲームの座標系は、左上を原点とし、スクリーン下方向をY軸のプラスとするものが一般的です。 かつ、ディスプレイ解像度の1ピクセルを1単位とします。

それに対してデフォルトのスクリーンの座標系は、スクリーン中央を原点とし、スクリーン右側を1.0、左側を-1.0、上側を1.0、下側を-1.0、とします。

2Dゲームの座標系(左)とスクリーンの座標系(右)

そのため２次元のゲームの座標系（以下、ピクセルの座標系）で指定したポリゴンをスクリーンで表示するには、頂点をスクリーンの座標系に変換しなければなりません。

Matrix4()で設定されている値は、この変換を行うためのものです。

ポリゴンの描画を実行

各要素を指定したら、あとは描画命令を実行します。

public static void Render ()
{
    graphics.Clear();

    graphics.SetShaderProgram(shaderProgram);
    graphics.SetTexture(0, texture);
    shaderProgram.SetUniformValue(0, ref screenMatrix);

    graphics.DrawArrays(DrawMode.TriangleStrip, 0, indexSize);

    graphics.SwapBuffers();
}

DrawArrays()が描画実行の関数です。

実行すると、スクリーンに画像が表示されます。

簡易版スプライトクラスを定義する

この章で使った画像表示のコードをクラスとして再利用できるようにしておきましょう。 クラスとして定義したものをTutoLib/SimpleSprite.csに記述しています。

※このSimpleSpriteクラスはプログラミングガイドの説明のためにつくった簡易的なもので、描画に最適な処理にはなっていません。 高速に描画する場合、 スプライトの効率的な描画について をご参照ください。


3. ユーザー入力

この文書ではユーザー入力について説明します。

Contents

  • ユーザー入力を検出する
    • コントローラの入力を検出する
    • キーボードの割り当て

ユーザー入力を検出する

表示したスプライトをコントローラで操作できるようにしてみましょう。

Sample/Tutorial/Sample03_01を開いてください。

Sample/Tutorial/Sample03_01/AppMain.cs

public static void Initialize ()
{
        graphics = new GraphicsContext();

        shaderProgram = new ShaderProgram("/Application/shaders/sprite.cgx");
        shaderProgram.SetUniformBinding(0, "u_WorldMatrix");

        ImageRect rectScreen = graphics.Screen.Rectangle;

        texture = new Texture2D("/Application/resources/Player.png", false);
        spritePlayer = new SimpleSprite(graphics, texture);
        spritePlayer.Position.X = rectScreen.Width/2.0f;
        spritePlayer.Position.Y = rectScreen.Height/2.0f;
        spritePlayer.Position.Z = 0.0f;

        unitScreenMatrix = new Matrix4(
                 2.0f/rectScreen.Width, 0.0f,   0.0f, 0.0f,
                 0.0f, -2.0f/rectScreen.Height, 0.0f, 0.0f,
                 0.0f,  0.0f, 1.0f, 0.0f,
                -1.0f, 1.0f, 0.0f, 1.0f
        );
}

前の章で定義したSimpleSpriteを使って、スプライトを表示しています。Spriteのコンストラクタには、GraphicsContextとTexture2Dのインスタンスへの参照を渡してください。SimpleSpriteのインスタンスを生成したら、Positionに値を代入し、座標を指定します。

コントローラの入力を検出する

コントローラの入力を検出するにはGamePad.GetData()を使います。 Update()の中で入力を検出します。

Sample/Tutorial/Sample03_01/AppMain.cs

public static void Update ()
{
        gamePadData = GamePad.GetData(0);

        int speed = 4;

        if((gamePadData.Buttons & GamePadButtons.Left) != 0)
        {
                spritePlayer.Position.X -= speed;
        }
        if((gamePadData.Buttons & GamePadButtons.Right) != 0)
        {
                spritePlayer.Position.X += speed;
        }
        if((gamePadData.Buttons & GamePadButtons.Up) != 0)
        {
                spritePlayer.Position.Y -= speed;
        }
        if((gamePadData.Buttons & GamePadButtons.Down) != 0)
        {
                spritePlayer.Position.Y += speed;
        }
}

GamePad.GetData(0)の引数はデバイス番号を指定しています。通常は0でよいでしょう。 各キー入力状態をif文で判定し、押されていればspritePlayer.Positionの値を変え、プレイヤー(飛行機の画像)の座標を更新します。

キーボードの割り当て

PCシミュレータで実行する場合、ゲームパッドのボタンはキーボードの各キーに割り当てられています。

ゲームパット上のキー | シミュレータ上のキー割り当て
方向キーの左 | カーソルキー：←
方向キーの上 | カーソルキー：↑
方向キーの右 | カーソルキー：→
方向キーの下 | カーソルキー：↓
□ボタン | Aキー
△ボタン | Wキー
○ボタン | Dキー
×ボタン | Sキー
SELECT ボタン | Zキー
START ボタン | Xキー
L ボタン | Qキー
R ボタン | Eキー

詳しくは PlayStation(R)Mobileシミュレータについて をご覧ください。

ビルドして実行してみましょう。 方向キーでプレイヤーが操作可能になっています。


4. オブジェクト指向的にプログラムを組む

この文書ではオブジェクト指向的な手法を使ってプログラミングする方法を説明します。

Contents

  • ゲームフレームワークのクラスをつくる
  • 処理時間の計測
  • アクターモデル
  • Actorクラスを派生させる
    • フレームワークへの参照
    • Playerクラスの定義
    • 条件コンパイル
    • Starクラスの定義
    • アクターの登録

ゲームフレームワークのクラスをつくる

「プログラムの構造」の章では、一般的なPSMプログラムの構造を説明しました。 PSMでプログラムを組む場合、この構造はほぼ同じになります。

そこでプログラムの構造(フレームワーク)を基底クラスとして作成し、継承して使いまわせるようにしてみましょう。

Sample/Tutorial/Sample04_01を開き、TutoLibプロジェクトのGameFramework.csを見てください。

Sample/Tutorial/TutoLib/GameFramework.cs

public class GameFramework : IDisposable
{
    ...
    public void Run(string[] args)
    {
        Initialize();

        while (loop)
        {
            time[0] = (int)stopwatch.ElapsedTicks;// start
            SystemEvents.CheckEvents();
            Update();
            time[1] = (int)stopwatch.ElapsedTicks;
            Render();
        }

        Terminate();
    }
    ...
}

GameFrameworkクラスを定義しています。 前のソースコードでMain()に入っていたUpdate()やRender()をRun()の中で処理しています。 このGameFrameworkクラスのインスタンスを作成し、Run()メソッドを呼び出し、ループに入る、という仕組みになります。

time[0] = (int)stopwatch.ElapsedTicksとtime[1] = (int)stopwatch.ElapsedTicksの行は処理時間計測のための処理です。処理時間の計測は、どのプログラムでも必要になるものなので、使いまわせるようにしています。これは後で説明します。

このGameFrameworkクラスを継承してGameFrameworkSampleクラスを実装します。 以下が継承している部分です。

Sample/Tutorial/Sample04_01/GameFrameworkSample.cs

public class GameFrameworkSample: GameFramework
{
    Int32 counter=0;
    public ImageRect rectScreen;

    SimpleSprite spritePlayer;

    public override void Initialize()
    {
        base.Initialize();

        rectScreen = graphics.Screen.Rectangle;

        Texture2D texturePlayer = new Texture2D("/Application/resources/Player.png", false);

        spritePlayer = new SimpleSprite(graphics, texturePlayer);
        spritePlayer.Position.X = rectScreen.Width/2.0f;
        spritePlayer.Position.Y = rectScreen.Height/2.0f;
        spritePlayer.Position.Z = 0.0f;
    }

    public override void Update()
    {
        base.Update();

    #if DEBUG
        debugString.WriteLine("counter "+counter);
        debugString.WriteLine("Buttons="+PadData.Buttons);
    #endif

        int speed = 4;

        if((PadData.Buttons & GamePadButtons.Left) != 0)
        {
            spritePlayer.Position.X -= speed;
        }
        if((PadData.Buttons & GamePadButtons.Right) != 0)
        {
            spritePlayer.Position.X += speed;
        }
        if((PadData.Buttons & GamePadButtons.Up) != 0)
        {
            spritePlayer.Position.Y -= speed;
        }
        if((PadData.Buttons & GamePadButtons.Down) != 0)
        {
            spritePlayer.Position.Y += speed;
        }

        ++counter;
    }

    public override void Render()
    {
        graphics.Clear();

        graphics.Enable(EnableMode.DepthTest);

        spritePlayer.Render();

        base.Render();
    }
}

プレイヤーの操作など、このプログラムで独自の部分を上書き（override:オーバーライド)して実装しています。

base.Initialize()、base.Update()、base.Render()は基底クラスGameFrameworkで定義した処理を呼び出しています。

気をつける必要があるのは、base.Initialize()は、継承したInitialize()の冒頭、base.Update()は、継承したUpdate()の冒頭、base.Render()は、継承したRender()の最後で呼ぶことです。

base.Update()、base.Render()を実装し忘れると、基底クラスで行っている処理が行われず、うまく動きませんので注意してください。

作成したGameFrameworkSampleクラスは以下のようにして使います。

Sample/Tutorial/Sample04_01/AppMain.cs

public class AppMain
{
    public static void Main(string[] args)
    {
        using( GameFrameworkSample game = new GameFrameworkSample())
        {
            game.Run(args);
        }
    }
}

GameFrameworkSampleのインスタンスを生成し、Run()の呼び出しを行うと、前と同じようにプログラムが進行します。

プログラムを実行してみましょう。

プレイヤーは以前と同じように動きます。

今度は左上に数字が出ていますね。

UpdateとRenderは1フレームの処理時間に占める割合を表しています。

FPSは1秒間で画面が何回描きかえられているかを表しています。

managedMemoryはPSMアプリが使用しているマネージドメモリの量を表しています。

次はこれについて説明します。

処理時間の計測

ゲームアプリケーションでは、「どの場所でどれくらいの処理時間がかかっているか」を把握することが、とても重要です。 コンソールアプリケーションなどでは処理時間が10ミリ秒から50ミリ秒になってもそれほど問題にはなりませんが、ゲームでは画面の切り替えに間に合わないと処理落ちが発生し、見た目に顕著な問題が現れます。

Sample04_01を実行すると、画面左上でUpdate、Renderの文字列の横に数字が表示されるようになります。 これは画面の切り替わるタイミングである16ミリ/秒を100%とし、それぞれの処理にどれだけ処理時間がかかっているかを表したものです。

ここの数字は実行するマシンの性能によって変化しますが、私のPCではだいたいUpdate= 0.50%、Render= 25.00%を推移しています。

Updateはほとんど処理時間がかかっていませんね。Update()内は簡単な条件判定と足し算だけなので、処理が軽い、といえるでしょう。

Renderは25%なので結構処理時間がかかっていますね。

※ 描画の仕組みはデバイスによって異なるため、Renderの処理時間はあくまで目安となります。

Update+Renderの処理時間が100%を越えてしまうと、画面の切り替えに間に合わなくなり、処理落ちすることになります。

処理時間を計測している箇所はGameFramework.csにあります。その部分を見てみましょう。

Sample/Tutorial/TutoLib/GameFramework.cs

virtual public void Initialize()
{
    Console.WriteLine("Initialize()");

    stopwatch = new Stopwatch();
    stopwatch.Start();

Stopwatchクラスは経過時間を計測するクラスです。stopwatch.Start()で計測を開始します。

while (loop)
{
    time[0] = (int)stopwatch.ElapsedTicks;// start
    SystemEvents.CheckEvents();
    Update();
    time[1] = (int)stopwatch.ElapsedTicks;
    Render();
}

stopwatch.ElapsedTicksは経過時間です。

フレームの最初の時間がほしいのでループの冒頭でtime[0] = (int)stopwatch.ElapsedTicksのようにして時間を保持しておきます。

次はUpdate()が終了した場所で、time[1] = (int)stopwatch.ElapsedTicks;のようにして経過時間を保持しておきます。time[1]-time[0]の差が経過時間となります。

次も同じようにtime[2] = (int)stopwatch.ElapsedTicks;でRender()終了後の経過時間を保持しています。

      virtual public void Render()
      {
#if DEBUG
          if(drawDebugString==true)
              debugString.Render();
#endif

          time[2] = (int)stopwatch.ElapsedTicks;

          graphics.SwapBuffers();

          ...

          preTime=(int[])time.Clone();
      }

preTime=(int[])time.Clone();は計測した時間を配列にコピーする処理です。

あとは各経過時間を計算して、DebugStringで表示します。DebugStringはスクリーン上にアスキー文字を表示するクラスです。Console.Write()のように引数に文字列を指定して使用します。

void CalculateProcessTime()
{
    float fps = 60.0f;

    float ticksPerFrame = Stopwatch.Frequency / fps;
    timePercent[0]=(preTime[1]-preTime[0])/ticksPerFrame;
    timePercent[1]=(preTime[2]-preTime[1])/ticksPerFrame;

    debugString.WriteLine(string.Format("Update={0,6:N}%", timePercent[0] * 100));
    debugString.WriteLine(string.Format("Render={0,6:N}%", timePercent[1] * 100));
    debugString.WriteLine(string.Format("FPS={0,5:N}", fps));

    ...
}

現在計測中のフレームは表示できないので、preTimeに保持しておいた、ひとつ前のフレームの計測時間を表示しています。

処理時間のかかっている箇所をより詳しく知りたい方は、time[]の配列のサイズを増やしてから、time[*] = (int)stopwatch.ElapsedTicks;を増やしてみるとよいでしょう。

デバッグフォントのON/OFFを切り替えたい場合は、Lボタンを押しながらRボタンを、キーボートならQキーを押しながらEキーを押してください。

アクターモデル

ゲームに必要なキャラクタをどんどん実装していきましょう。

  • 星。
  • 自分が発射する弾。
  • 敵。
  • 弾が命中したときに出す爆発。

ところで、上のキャラクタをバラバラに実装していくと、どんどんプログラムが煩雑になってしまいそうです。 種類が５つ程度ならなんとかなりそうですが、種類が大量に増えるとプログラムの管理で収拾がつかなくなるでしょう。

ゲーム上で使うキャラクタの共通要素を取り出して、それを使いまわすと管理がしやすくなります。

共通の要素をもつ基底クラスを作成し、プレイヤーや敵・星・弾をそこから派生させてみましょう。

Sample/Tutorial/Sample04_02を開いてください。

ここではアクターモデルと呼ばれる手法を用います。 プレイヤーや星・弾のひとつひとつをアクター（役者）にみたて、彼らに命令を与えるようにしてプログラムを実行します。

アクターの基底クラスを定義します。

Sample/Tutorial/TutoLib/Actor.cs

public class Actor
{
    public string Name { get; set; }

    public enum ActorStatus
    {
        Action,
        UpdateOnly,
        RenderOnly,
        Rest,
        NoUse,
        Dead,
    }

    ActorStatus status;
    public ActorStatus Status
    {
        get { return status; }
        set
        {
            status = value;
            StatusNextFrame = value;
        }
    }

    public ActorStatus StatusNextFrame;

    protected Int32 level=0;

    protected List<Actor> children = new List<Actor>();

    public List<Actor> Children
    {
        get { return children;}
    }

    public Actor()
    {
        this.Name = "no_name";
        this.Status = ActorStatus.Action;
    }

    public Actor(string name)
    {
        this.Name = name;
        this.Status = ActorStatus.Action;
    }

    virtual public void Update()
    {
        foreach( Actor actorChild in children)
        {
            if(actorChild.Status == ActorStatus.Action || actorChild.Status == ActorStatus.UpdateOnly)
                actorChild.Update();
        }
    }

    virtual public void Render()
    {
        foreach( Actor actorChild in children)
        {
            actorChild.Render();
        }
    }

    virtual public void AddChild(Actor actor)
    {
        children.Add(actor);
        actor.level = this.level+1;
    }

各メソッドをvirtualで仮想関数として実装しているところがミソです。 継承したクラスで仮想関数を上書きすると、上書きしたメソッドを呼んでくれます。

アクターにはAddChild()で子のアクターを所属させることができます。 AddChild()は次のようなイメージです。

  1. 最初にルート（おおもと）になるアクターを作ります。
  2. root.AddChild(player)でplayerを所属させます。
  3. root.AddChild(starManager)で星のひとつひとつを管理するstarManagerを所属させます。
  4. 今度はstarManagerを親にして、starManager.AddChild(star0)でstar0を、starManager.AddChild(star1)でstar1を所属させます。

アクターはツリー上の構造にしたほうが、単純な線形で繋げていくより何かと都合がよくなります。

そしてMain()内のUpdate()とRender()内にroot.Update()、root.Render()と記述しておくと、あとはツリーに所属している全てのアクターをたどって処理を実行してくれます。

Actorクラスを派生させる

フレームワークへの参照

アクターはフレームワークと常に連絡をとることになるので、フレームワークへの参照を保持しておけるようにしましょう。

Actorクラスを継承してGameActorクラスを定義します。

Sample/Tutorial/Sample04_02/GameActor.cs

public class GameActor : Actor
{
    protected GameFrameworkSample gs;
    protected SimpleSprite sprite;

    public GameActor(GameFrameworkSample gs, string name) : base(name)
    {
        this.gs = gs;
    }

    public override void Render ()
    {
        if(sprite!=null)
            sprite.Render();

        base.Render ();
    }
}

クラスのメンバーにGameFrameworkSample gsとSimpleSprite spriteを追加しています。 ゲームに使うキャラクターのアクターはこのGameActorクラスから派生させるようにします。

Playerクラスの定義

GameActorクラスを継承してPlayerクラスを定義します。

Sample/Tutorial/Sample04_02/Player.cs

public class Player : GameActor
{
    public Player(GameFrameworkSample gs, string name, Texture2D textrue) : base(gs, name)
    {
        sprite = new SimpleSprite(gs.Graphics, textrue);
        sprite.Position.X=gs.rectScreen.Width/2;
        sprite.Position.Y=gs.rectScreen.Height/2;
        sprite.Center.X = 0.5f;
        sprite.Center.Y = 0.5f;
        sprite.Position.Z=0.5f;
    }

    public override void Update ()
    {
  #if DEBUG
        gs.debugString.WriteLine(string.Format("Position=({0},{1})\n", sprite.Position.X, sprite.Position.Y));
  #endif

        int speed = 4;

        if((gs.PadData.Buttons & GamePadButtons.Left) != 0)
        {
            sprite.Position.X -= speed;
            if(sprite.Position.X < sprite.Width/2.0f)
                sprite.Position.X=sprite.Width/2.0f;
        }

        if((gs.PadData.Buttons & GamePadButtons.Right) != 0)
        {
            sprite.Position.X += speed;
            if(sprite.Position.X> gs.rectScreen.Width - sprite.Width/2.0f)
                sprite.Position.X=gs.rectScreen.Width - sprite.Width/2.0f;
        }

        if((gs.PadData.Buttons & GamePadButtons.Up) != 0)
        {
            sprite.Position.Y -= speed;
            if(sprite.Position.Y < sprite.Height/2.0f)
                sprite.Position.Y =sprite.Height/2.0f;
        }

        if((gs.PadData.Buttons & GamePadButtons.Down) != 0)
        {
            sprite.Position.Y += speed;
            if(sprite.Position.Y > gs.rectScreen.Height - sprite.Height/2.0f)
                sprite.Position.Y=gs.rectScreen.Height - sprite.Height/2.0f;
        }

        base.Update();
    }
}

コントローラからの入力は以前と同じですが、プレイヤーが画面の外に出ないようにしています。 注意したいのはoverrideでメソッドを上書きしたら、base.Update()とbase.Render()を忘れずに呼び出すことです。 呼び出すのを忘れると、自分の子が処理されなくなってしまいます。

条件コンパイル

#if DEBUG～#endifの箇所ではプレイヤーの座標を表示しています。

ビルドの設定がDebugのときのみ、この箇所が有効になります。 ビルドの設定をReleaseにするとこの箇所は消えてくれるので、開発中のみ表示したいデバッグ出力があれば、このように書いておくと便利です。

Starクラスの定義

次にStarクラスを定義しましょう。やり方はPlayerクラスと同じです。

Sample/Tutorial/Sample04_02/Star.cs

public class Star : GameActor
{
    float speed;

    public Star(GameFrameworkSample gs, string name, Texture2D textrue, Vector3 position, Vector4 color, float speed) : base(gs, name)
    {
        sprite = new SimpleSprite(gs.Graphics, textrue);
        sprite.Position = position;
        sprite.SetColor( color);
        this.speed = speed;
    }

    public override void Update()
    {
        sprite.Position.Y += speed;

        if (sprite.Position.Y > gs.rectScreen.Height )
        {
            sprite.Position.Y = 0.0f;
            sprite.Position.X = (int)(gs.rectScreen.Width * gs.rand.NextDouble());
        }

        base.Update();
    }
}

Update()で毎フレームごとspeedを加算して座標を更新しています。これで星が上から下に向かって移動していきます。 画面の外に出たらY座標を0.0fにし、かつX座標をランダムで指定して、再び画面の上から出すようにします。

アクターの登録

あとは定義したクラスのインスタンスを作成し、root.AddChild()でアクターのツリーに登録しましょう。 ソースコードは以下のようになります。

Sample/Tutorial/Sample04_02/GameFrameworkSample.cs

public override void Initialize()
{
    base.Initialize();

    rectScreen = graphics.GetViewport();

    root = new Actor("root");

    Texture2D texturePlayer = new Texture2D("/Application/resources/Player.png", false);
    root.AddChild(new Player(this, "Player", texturePlayer));

    Texture2D textureStar = new Texture2D("/Application/resources/Star.png", false);
    Actor starManager = new Actor("starManager");

    ...

    Star star;
    for( int i=0; i< 20; ++i)
    {
        star= new Star(this, "star"+i, textureStar,
            new Vector3((float)(rectScreen.Width * rand.NextDouble()),(float)(rectScreen.Height* rand.NextDouble()),0.7f),
            starColors[ i % starColors.Length],
            (float)(1.0f * (rand.NextDouble() + 0.5f)));

        starManager.AddChild(star);
    }
    root.AddChild(starManager);
}

これでアクターのツリーは下の図のような状態になります。

あとはフレームワーク側でroot.Update()とroot.Render()を呼び出せば、登録されている全てのアクターを処理してくれます。

Sample/Tutorial/Sample04_02/GameFrameworkSample.cs

    public override void Update()
    {
        base.Update();

#if DEBUG
        debugString.WriteLine("counter "+counter);
        debugString.WriteLine("Buttons="+PadData.Buttons);
#endif

        root.Update();

        ++counter;
    }

    public override void Render()
    {
        graphics.Clear();

        graphics.Enable(EnableMode.DepthTest);

        root.Render();

        base.Render();
    }

ソースコードが以前に比べて、すっきりしましたね。ソースコードを簡潔に書くことは、大きなプログラムを作っていく上でとても重要なことです。

ビルドして実行してみましょう。 画面上に星が現れました。

実行してみると、

  • プレイヤーはPlayerクラスで定義した、コントローラの入力を座標に反映させるUpdate()
  • 星はStarクラスで定義した、星を上から下に移動させるUpdate()

が呼び出されていることが確認できます。 このような動作のことをオブジェクト指向では「多態性」と呼びます。


5. 統合開発環境PSM Studioの基本的な使い方

この文書では統合開発環境PSM Studioの基本的な使い方を説明します。

Contents

  • プログラムをデバッグするには
    • ブレークポイントの配置
    • ステップ実行
    • 変数の内容をみる
    • 呼出し履歴 (コールスタック)をみる
  • ライブラリを作成・利用する
    • ライブラリを作成する
    • ライブラリのプロジェクトファイルをソリューションに追加する
    • コンパイル済みのライブラリ (dll) をソリューションに追加する

プログラムをデバッグするには

ブレークポイントの配置

プログラムをデバッグするには、まずブレークポイントを配置します。

ブレークポイントをセットするには、コードエディタ上で配置したい箇所の左側の領域をクリックします。クリックすると赤い丸が表示されます。

ブレークポイントをセットしたら、[メニュー] - [実行] - [デバッグ] でプログラムを実行します（F5キーでもデバッグ実行できます）。

プログラムを実行すると、ブレークポイントを配置した箇所で停止します。

ステップ実行

プログラムが停止したら、F10キーを押すことで1行づつプログラムを実行できます（これをステップ実行といいます）。

関数を呼び出しているコードでF11キーを押すと、処理を関数の中に進めます。Shift+F11なら処理を外に進めます。

プログラムを再開するにはF5キーを押してください。

変数の内容をみる

変数の内容をみるには、[メニュー] - [ビュー] - [デバッグウィンドウ] - [ローカル変数] を選択してください。

ウィンドウ内のリストをクリックすることで変数の内容を見ることができます。

呼出し履歴 (コールスタック)をみる

関数の呼出し履歴をみるには、[メニュー] - [ビュー] - [デバッグウィンドウ] - [コールスタック] を選択してください。

ウィンドウ内に関数の呼出し履歴が表示されます。

ライブラリを作成・利用する

ライブラリを作成する

ライブラリの新規作成は、以下の手順で行います。

  1. [メニュー] - [File] - [New] - [Solution...] を選択します。
  2. ダイアログ画面内の左側のツリービューで [C#] - [PlayStation Mobile] を選択し、右側のコントロールから[PlayStation Mobile Library Project] を選択します。
  3. ライブラリ名をつけ、OKボタンを押します。

ライブラリのプロジェクトファイルをソリューションに追加する

作成したライブラリのプロジェクトファイルをソリューションに追加するには、以下の手順で行います。

  1. ソリューションウィンドウで、[ソリューション] を選択し、[右クリック] - [Add] - [Add Existing Project...]を選択します。
  2. ダイアログで追加したいプロジェクトファイルを選択し、[Open]ボタンを押します。これでソリューションにプロジェクトファイルが追加されます。
  3. 次に元のプロジェクトファイルにライブラリへの参照を設定します。ソリューションウィンドウで、元からあるプロジェクトファイルの [References] を選択し、[右クリック] - [Edit References] を選択します。
  4. ダイアログ画面でProjects タブを選択し、追加したプロジェクトファイルのチェックボックスをチェックし、OKボタンを押します。
  5. あとはusingでライブラリの名前空間をソースコードに追加すれば、そのライブラリのAPIが使用可能になります。
 using System;
 using TestLib; //<--here

namespace TestApp
{
    public class AppMain
    {
      ...

コンパイル済みのライブラリ (dll) をソリューションに追加する

ここではコンパイル済みのライブラリをソリューションに追加する方法を説明します。

  1. ソリューションウィンドウで、プロジェクトファイルの [References] を選択し、[右クリック] - [Edit References] を選択します。
  2. ダイアログ画面で [.Net Assembly] タブを選択します。追加したいライブラリを選択し、[Add] ボタンを押します。

なお、PSM SDKが標準で提供しているUIや物理ライブラリなどを利用する場合は、[All] タブを選択し、利用するライブラリにチェックをいれます。

  3. あとはusingでライブラリの名前空間をソースコードに追加すれば、そのライブラリのAPIが使用可能になります。


6. 音を出す

この文書では、効果音(サウンドエフェクト)およびBGMを再生する手順について説明します。

Contents

  • 音を鳴らす手順
    • ファイルをプロジェクトに登録する
    • サウンドの初期化
    • サウンドの再生
  • 弾の発射

音を鳴らす手順

では、プログラム開始時にBGMをループ再生し、ボタンを押したときに効果音を鳴らすようにしてみましょう。

ファイルをプロジェクトに登録する

まず、再生したい効果音ファイルとBGMファイルをプロジェクトに登録します。

sample/Tutorial/Sample06_01/Sample06_01.slnを開いてください。

  1. PSM Studioのソリューションエクスプローラで、soundフォルダーを選択し、右クリック - [追加] - [ファイル]を追加 で再生したいファイルを選択します。
  2. ファイルを登録したら、ファイルを右クリックし、[Build Action] - [Content] を選択しておきます。
  • 現在、効果音のファイル形式はWAV形式のみ対応しています。
  • 現在、BGMのファイル形式はmp3形式のみ対応しています。
  • ファイルを登録するフォルダーはsoundでなく、任意の場所でも構いません。

サウンドの初期化

効果音

効果音の再生にはSoundクラスとSoundPlayerクラスを使用します。

Sound soundBullet;
public SoundPlayer soundPlayerBullet;
...
soundBullet = new Sound("/Application/sound/Bullet.wav");
soundPlayerBullet = soundBullet.CreatePlayer();

Soundクラスは効果音のデータを表すクラスです。

SoundPlayer クラスは、効果音の再生用のクラスです。

1つのSoundクラスに対して、複数のSoundPlayerを使用することにより、1種類の効果音を複数同時に再生することができます。

BGM

BGMの再生には、BgmクラスとBgmPlayerクラスを使用します。

Bgm bgm;
public BgmPlayer bgmPlayer;
...
//@j BGMの初期化。
bgm = new Bgm("/Application/sound/GameBgm.mp3");
bgmPlayer = bgm.CreatePlayer();
bgmPlayer.Loop = true;

Bgm クラスはBGMのデータを表すクラスです。

BgmPlayer クラスは、BGMの再生を行うためのクラスです。

Bgm は同時に1つだけしか再生することができません。そのため BgmPlayer を複数作成することはできません。

ここではBGMが終了したときループ再生するように、bgmPlayer.Loopにtrueを設定しています。

サウンドの再生

効果音を鳴らすには、SoundPlayerのPlay()を呼び出します。 以下の例では○ボタンまたは×ボタンを押したときに発射音が鳴ります。

sample/Tutorial/Sample06_01/Player.cs

if((gs.PadData.ButtonsDown & (GamePadButtons.Circle | GamePadButtons.Cross)) != 0)
{
    gs.soundPlayerBullet.Play();
    ...
}

BGMを再生するにはBgmPlayer.Play() を呼び出します。

sample/Tutorial/Sample06_01/GameFrameworkSample.cs

bgmPlayer.Play();

弾の発射

ついでにボタンを押したとき、弾を発射できるようにしておきましょう。

星と同じ要領で弾のクラスを作ります。

sample/Tutorial/Sample06_01/Bullet.cs

public class Bullet : GameActor
{
    static int idNum=0;
    float speed=6;

    Vector2 trans;

    public Bullet(GameFrameworkSample gs, string name,  Texture2D textrue, Vector3 position, float speed, float direction) : base (gs, name)
    {
        Name = name + idNum.ToString();
        this.sprite = new SimpleSprite( gs.Graphics, textrue);
        this.sprite.Position = position;
        this.sprite.Center.X = 0.5f;
        this.sprite.Center.Y = 0.5f;

        this.speed = speed;

        this.trans.X= FMath.Cos((direction-90.0f)/180*FMath.PI);
        this.trans.Y= FMath.Sin((direction-90.0f)/180*FMath.PI);

        idNum++;
    }

    public override void Update()
    {
        sprite.Position.X = sprite.Position.X+trans.X * speed;
        sprite.Position.Y = sprite.Position.Y+trans.Y * speed;

        if (sprite.Position.X < 0 || gs.rectScreen.Width < sprite.Position.X ||
            sprite.Position.Y < 0  || gs.rectScreen.Height < sprite.Position.Y)
        {
            this.Status = Actor.ActorStatus.Dead;
        }

        base.Update();

    }

}

Playerクラス内のUpdate()で、ボタンを押したときにBulletクラスのインスタンスを生成し、アクターのツリーに登録するようにします。

sample/Tutorial/Sample06_01/Player.cs

if((gs.PadData.ButtonsDown & (GamePadButtons.Circle | GamePadButtons.Cross)) != 0)
{
    gs.soundPlayerBullet.Play();
    gs.Root.Search("bulletManager").AddChild(new Bullet(gs, "bullet", gs.textureBullet,
        new Vector3(this.Sprite.Position.X, this.Sprite.Position.Y, 0.4f), 6.0f, 0.0f));
}

実行してみると、ゲーム開始時にBGMが再生されます。 また、ボタンを押したときに効果音が再生され、弾が発射されるようになっています。


7. ガベージコレクションとインスタンスの解放

この文書ではガベージコレクションとインスタンスの解放について説明します。

Contents

  • 不要になったインスタンスの解放
  • アクターシステムにインスタンス解放の仕組みを実装する
  • 強制的にガベージコレクションを呼び出す
  • 意図どおり解放されているか確認するには
  • アンマネージドリソースを解放する
    • アンマネージドリソースとは

不要になったインスタンスの解放

前の章では自機から発射される弾を実装しました。 しかし、画面外に出て不要になった弾をそのまま放置していると、次から次に発射される弾でメモリがどんどん消費されていってしまいます。

そのためメモリの消費を抑えるために、不要になった弾のインスタンスを解放する必要があります。

C++ではnewで確保したメモリをdeleteを呼び出して解放します。 それに対して、C#ではC++のように明示的に解放するのではなく、そのインスタンスへの参照をプログラム上のどこからも参照されないようにし、ガベージコレクションに解放してもらうようにします。

C#でのインスタンスの解放は以下のイメージになります。

弾を発射したとき、アクターツリーは以下の状態になっています。

弾を発射したときのアクターツリー

画面外に出たbulltet0を解放したいとします。 この場合、親のbulletManager内のchildrenがbulltet0を参照している箇所を削除すればよいわけです。

bulltet0への参照を削除

children内の参照を削除すると、bullet0はどこからも参照されていない状態になります。 この状態で、ガベージコレクションが発動すると、bullet0のメモリが回収され、メモリ領域が再び利用可能になります。

ガベージコレクションの発動で、インスタンスを解放

アクターシステムにインスタンス解放の仕組みを実装する

では、不要になったインスタンスを解放する仕組みをアクターシステムに実装してみましょう。

まず、アクターの状態を表す列挙型変数を用意します。

sample/Tutorial/TutoLib/Actor.cs

public enum ActorStatus
{
    Action,
    UpdateOnly,
    RenderOnly,
    Rest,
    NoUse,
    Dead,
}

public ActorStatus Status;

行動中の場合、ActorStatus StatusにActorStatus.Actionを、不要になった場合はActorStatus.Deadを代入するようにします。

次にActorStatus.Deadの状態のアクターをList<Actor> childrenから削除するメソッドを実装します。

sample/Tutorial/TutoLib/Actor.cs

virtual public void CheckStatus()
{
    if (this.status != this.StatusNextFrame)
        this.status = this.StatusNextFrame;

    if( this.Status == ActorStatus.Dead)
    {
        foreach(Actor actorChild in children)
        {
            actorChild.Status = ActorStatus.Dead;
        }
    }

    foreach(Actor actorChild in children)
    {
        actorChild.CheckStatus();
    }

    children.RemoveAll(CheckDeadActor);
}

static bool CheckDeadActor(Actor actor)
{
    //@j この条件で真になる要素を削除。
    //@e Delete the elements to be proper with this condition.
    return actor.Status == ActorStatus.Dead;
}

RemoveAll()はリストから要素を削除するメソッドです。 上の例では、引数に渡したCheckDeadActor()メソッドで条件判定し、真の場合、リストからその要素を削除します。

次に、このCheckStatus()をGameFrameworkSample.csのUpdate()内で呼び出します。

sample/Tutorial/Sample06_01/GameFrameworkSample.cs

public override void Update()
{
    base.Update();

    ...

    Root.Update();

    Root.CheckStatus();//<--here

    ...
}

こうしておくと、毎フレームごとにCheckStatus()がアクターツリーを巡回し、死亡フラグのたっているアクターをツリーから削除してくれます。

弾のクラスを見てみましょう。

sample/Tutorial/Sample06_01/Bullet.cs

public class Bullet : GameActor
{
    static int idNum=0;
    float speed=8;

    public Bullet(GameFrameworkSample gs, string name, Texture2D textrue, Vector3 position) : base (gs, name)
    {
        Name = name + idNum.ToString();
        this.sprite = new SimpleSprite( gs.Graphics, textrue);
        this.sprite.Center.X = 0.5f;
        this.sprite.Center.Y = 0.5f;

        idNum++;

        this.sprite.Position = position;
    }

    public override void Update()
    {
        sprite.Position.Y -= speed;

        if (sprite.Position.Y < 0 )//<--here
        {
            this.Status = Actor.ActorStatus.Dead;   //<--here
        }

        base.Update();
    }
}

<--hereの部分に注目してください。 毎フレーム座標を更新し、画面の外に出た場合(つまりsprite.Position.Y < 0が真のとき)、Statusに死亡フラグを立てます。 こうしておくと、CheckStatus()がこのアクターを自動的にリストから削除してくれます。

強制的にガベージコレクションを呼び出す

ゲームのプレイ中にガベージコレクションが発生すると、メモリ回収のために処理時間が割かれ、処理落ちしてしまうことがあります。

C#にはSystem.GC.Collect()という関数が用意されており、これを呼び出すと強制的にガベージコレクションを呼び出すことができます。

ステージとステージの合間にSystem.GC.Collect()を呼び出せば、ゲームプレイ中のガベージコレクションの発生を低減させることができます。

System.GC.Collect()の実装は次章で行います。

意図どおり解放されているか確認するには

ところで今の状態では、インスタンスをリストから削除するところまでは確認できますが、ガベージコレクションが意図どおりインスタンスを解放してくれているかは確認できません。 これは少し不安なので、確認する方法を例示しておきます。

クラスにデストラクタを実装しておくと、ガベージコレクションがインスタンスを解放するとき、デストラクタを呼び出します。 そこでActorにデストラクタを実装して確認の処理を書いておけば、解放されたことが確認できます。

sample/Tutorial/TutoLib/Actor.cs

#if DEBUG
        /// <summary>
        /// デストラクタ。
        /// </summary>
        ~Actor()
        {
            Console.WriteLine("~"+Name);
        }
#endif

上のように処理を書いておくと、ガベージコレクションが発動してインスタンスが解放されたとき、出力ウィンドウに ~bullet01のように文字列が出力されます。

ガベージコレクションが発生したのに文字列が出力されない場合、そのインスタンスがどこかから参照されていることが考えられますので、ソースコードを見直してみましょう。

なお、この処理は確認用のものなので、解放されていることが確認できたらコメントアウトしておきましょう。

※ このサンプルでは、インスタンスの解放を例示するためにインスタンスの生成と解放を繰り返しています。 しかし処理時間のことを考慮にいれると、生成と解放を繰り返すのではなく、不要になったインスタンスをそのまま保持しておき、インスタンスが必要になったら値を初期化して使いまわしたほうが効率はよくなります。

アンマネージドリソースを解放する

アンマネージドリソースとは

C#ではマネージドメモリ(C#のnewで確保したメモリ)以外のリソースのことをアンマネージドリソースと呼びます。

アンマネージドリソースを確保するクラスで、PSMアプリでよく利用されるものには次のものがあります。

  • Texture2D
  • Sound, SoundPlayer
  • Bgm, BgmPlayer
  • Image

アンマネージドリソースはマネージドメモリとは違い、プログラムからの参照がなくなっても、基本的にガベージコレクションによって回収されません。そのためこれらのクラスを利用した場合、明示的にリソースを解放する必要があります。

これらのクラスはIDisposableインタフェースを継承しており、リソースを解放するためのDisposeメソッドが実装されています。

IDisposableインタフェースを継承しているクラスは、不要になった時点でDisposeメソッドを呼び出し、確保したリソースを解放してください。

sample/Tutorial/Sample06_01/GameFrameworkSample.cs

public override void Terminate()
{
    texturePlayer.Dispose();
    textureStar.Dispose();
    textureBullet.Dispose();

    soundBullet.Dispose();
    soundPlayerBullet.Dispose();

    bgm.Dispose();
    bgmPlayer.Dispose();

    base.Terminate();
}

上の例ではプログラム終了時にDispose()を呼び出し、確保したアンマネージドリソースの解放をおこなっています。

このサンプルではアンマネージドリソースの利用が少ないのでリソース不足になる恐れはほとんどありませんが、テクスチャの作成を頻繁におこなうプログラムでDispose()の解放を忘れると、容易にリソース不足になります。リソースが枯渇するとプログラムが異常終了するので、Dispose()の呼び出しを忘れないよう注意してください。

※ プログラムが終了すると、アンマネージドリソースは自動的に解放されます。


8. ゲームの完成

この文書では2Dシューティングゲームの完成まで説明します。

Contents

  • 敵・敵弾・敵のコマンダー
    • Enemyクラス
    • EnemyBulletクラス
    • EnemyCommanderクラス
  • あたり判定と爆発エフェクト
    • CollisionCheck
    • Playerクラスの改造
  • ゲームの進行を管理するクラス
    • GameManager
    • ステージの合間にガベージコレクションを呼び出す
    • アクターツリーの完成形
  • ゲームの完成

敵・敵弾・敵のコマンダー

ではゲームに必要なキャラクターのクラスをどんどん実装していきましょう。

クラスの実装は星や自機の弾と同じ要領でおこなえば大丈夫です。

sample/Tutorial/Sample08_01/Sample08_01.slnを開いてください。

Enemyクラス

まずは敵のクラスです。

public class Enemy : GameActor
{
    static int idNum=0;

    float speed=4;
    Int32 cnt=0;

    public Enemy(GameFrameworkSample gs, string name, Texture2D textrue, Vector3 position) : base (gs, name)
    {
        Name = name + idNum.ToString();
        this.sprite = new SimpleSprite( gs.Graphics, textrue );
        this.sprite.Center.X = 0.5f;
        this.sprite.Center.Y = 0.5f;

        idNum++;

        this.sprite.Position = position;
    }

    public override void Update()
    {
        sprite.Position.Y += speed;

        if (sprite.Position.Y > gs.rectScreen.Height + sprite.Height )
        {
            this.Status = Actor.ActorStatus.Dead;//画面外にでたら死亡。
        }

        // 弾発射。
        if(cnt == 60)
        {
            GameActor player =(GameActor)gs.Root.Search("Player");

            Vector2 direction;
            direction.X= player.Sprite.Position.X - this.sprite.Position.X;
            direction.Y= player.Sprite.Position.Y - this.sprite.Position.Y;
            direction=direction.Normalize();

            gs.Root.Search("enemyBulletManager").AddChild(new EnemyBullet(gs, "enemyBullet", gs.textureEnemyBullet,
                new Vector3(this.sprite.Position.X,this.sprite.Position.Y, 0.5f), direction));
        }

        ++cnt;

        base.Update();
    }
}

出現から60フレーム経過したら、自機に向かって弾を発射するようにしています。

direction=direction.Normalize()で方向ベクトルを単位ベクトルにしています。

画面外に出たら死亡フラグを立てます。

EnemyBulletクラス

次に敵弾のクラスです。

public class EnemyBullet : GameActor
{
    static int idNum=0;

    float speed=6;

    Vector3 trans;

    public EnemyBullet(GameFrameworkSample gs, string name, Texture2D textrue, Vector3 position, Vector2 direction) : base (gs, name)
    {
        Name = name + idNum.ToString();
        this.sprite = new SimpleSprite( gs.Graphics, textrue );
        this.sprite.Center.X = 0.5f;
        this.sprite.Center.Y = 0.5f;

        idNum++;

        this.trans.X=direction.X*speed;
        this.trans.Y=direction.Y*speed;
        this.trans.Z=0.0f;

        this.sprite.Position = position;
    }

    public override void Update()
    {
        sprite.Position += trans;

        if (sprite.Position.X < 0 -sprite.Width ||
            sprite.Position.Y < 0 -sprite.Height||
            gs.rectScreen.Width + sprite.Width < sprite.Position.X ||
            gs.rectScreen.Height + sprite.Height < sprite.Position.Y  )
        {
            this.Status = Actor.ActorStatus.Dead;
        }

        base.Update();
    }
}

引数の方向ベクトルに速度を乗算して移動ベクトルを算出し、Update()で毎フレーム移動ベクトルを加算しています。

画面外に出たら死亡フラグを立てます。

EnemyCommanderクラス

次は敵を出現させる管理クラスです。

public class EnemyCommander : GameActor
{
    public EnemyCommander(GameFrameworkSample gs, string name) : base (gs, name)    {}

    public override void Update()
    {
        if( gs.appCounter % 30 == 0)
        {
            Vector3 position;

            position.X = (int)(gs.rectScreen.Width * gs.rand.NextDouble());
            position.Y = 0.0f;
            position.Z = 0.2f;

            gs.Root.Search("enemyManager").AddChild(new Enemy(gs, "enemy", gs.textureEnemy, position));
        }

        base.Update();
    }
}

30フレームに一度、画面上方向から敵を出現させるようにしています。

あとはGameFrameworkSample.csで次のようにアクターツリーを構成します。

では実行してみましょう。

敵が画面上から出現し、自機に向けて弾を撃ってきます。

まだあたり判定をつけていないので弾が素通りしていますね。

あたり判定と爆発エフェクト

CollisionCheck

次はあたり判定をつけ、命中したら爆発エフェクトを出すようにしましょう。

sample/Tutorial/Sample08_01/Sample08_02.slnを開いてください。

sample/Tutorial/Sample08_02/CollisionCheck.cs

//@j あたり判定をおこなうクラス。
public class CollisionCheck : GameActor
{
    public CollisionCheck(GameFrameworkSample gs, string name) : base (gs, name){}

    public override void Update()
    {
        Player player =(Player)gs.Root.Search("Player");
        Actor bulletManager=gs.Root.Search("bulletManager");
        Actor enemyManager =gs.Root.Search("enemyManager");
        Actor bulletEnemyManager=gs.Root.Search("enemyBulletManager");
        Actor effectManager =gs.Root.Search("effectManager");

        //@j 弾と敵のあたり判定。
        foreach( Bullet bullet in  bulletManager.Children)
        {
            if(bullet.Status == Actor.ActorStatus.Action)
            {
                foreach( Enemy enemy in  enemyManager.Children)
                {
                    if(enemy.Status ==  Actor.ActorStatus.Action &&
                       Math.Abs(bullet.Sprite.Position.X -enemy.Sprite.Position.X ) < 30 &&
                        Math.Abs(bullet.Sprite.Position.Y -enemy.Sprite.Position.Y ) < 30
                            )
                    {
                        bullet.Status = Actor.ActorStatus.Dead;
                        enemy.Status = Actor.ActorStatus.Dead;
                        effectManager.AddChild(new Explosion(gs, "explosion", gs.textureExplosion,
                            new Vector3(enemy.Sprite.Position.X, enemy.Sprite.Position.Y, 0.3f)));

                        gs.Score += 100;
                        gs.soundPlayerExplosion.Play();
                    }
                }
            }
        }

        if(player.playerStatus== Player.PlayerStatus.Normal)
        {
            //@j 自機と敵のあたり判定。
            foreach( Enemy enemy in  enemyManager.Children)
            {
                if(enemy.Status ==  Actor.ActorStatus.Action &&
                   Math.Abs(player.Sprite.Position.X -enemy.Sprite.Position.X ) < 42 &&
                    Math.Abs(player.Sprite.Position.Y -enemy.Sprite.Position.Y ) < 42
                        )
                {

                    effectManager.AddChild(new Explosion(gs, "explosion", gs.textureExplosion,
                        new Vector3(player.Sprite.Position.X, player.Sprite.Position.Y, 0.3f)));

                    player.playerStatus = Player.PlayerStatus.Explosion;

                    gs.soundPlayerExplosion.Play();

                    gs.NumShips--;
                }
            }

            //@j 自機と敵弾のあたり判定。
            foreach( EnemyBullet enemyBullet in  bulletEnemyManager.Children)
            {
                if(enemyBullet.Status ==  Actor.ActorStatus.Action &&
                   Math.Abs(player.Sprite.Position.X -enemyBullet.Sprite.Position.X ) < 26 &&
                    Math.Abs(player.Sprite.Position.Y -enemyBullet.Sprite.Position.Y ) < 26
                        )
                {
                    enemyBullet.Status = Actor.ActorStatus.Dead;
                    effectManager.AddChild(new Explosion(gs, "explosion", gs.textureExplosion,
                        new Vector3(player.Sprite.Position.X, player.Sprite.Position.Y, 0.3f)));

                    player.playerStatus = Player.PlayerStatus.Explosion;
                    gs.soundPlayerExplosion.Play();
                    gs.NumShips--;
                }
            }
        }

        base.Update();
    }
}

あたり判定を行う各アクターのManagerクラスをアクターツリーの中から検索し、foreachでそれぞれの座標をもとに命中判定をおこなっています。

Managerクラスでツリー状に管理しておくと、あたり判定を行わなくてよいアクター（星、爆発エフェクト）を始めから除外できるので、処理効率がよいといえるでしょう。

命中判定が真ならそのアクターに死亡フラグを立て、爆発エフェクトを発生させます。

爆発エフェクトの発生も、他と同じ要領で行えばよいでしょう。

Playerクラスの改造

ところで、自機が爆発したときやその後の無敵時間のときは、あたり判定を行う必要がありません。

そのためPlayerの状態を表す変数を実装しておき、処理の場合分けを行いましょう。

sample/Tutorial/Sample08_02/Player.cs

public enum PlayerStatus
{
    Normal,
    Explosion,
    Invincible,
    GameOver,
};

public PlayerStatus playerStatus;

あとはあたり判定時にplayerStatusを見て、処理を行うとよいでしょう。

ゲームの進行を管理するクラス

GameManager

あとは、簡単なオープニング画面とゲームオーバー画面、点数表示をつくっておきましょう。

ここではゲームの進行を管理するクラスをつくります。

sample/Tutorial/Sample08_02/GameManager.cs

public class GameManager : GameActor
{
    Int32 cnt=0;

    SimpleSprite spriteTitle;
    SimpleSprite spritePressStart;
    SimpleSprite spriteGameOver;

    public GameManager(GameFrameworkSample gs, string name) : base (gs, name)
    {
        spriteTitle=new SimpleSprite(gs.Graphics, gs.textureTitle);
        spriteTitle.Position.X = gs.rectScreen.Width/2-gs.textureTitle.Width/2;
        spriteTitle.Position.Y = gs.rectScreen.Height/2-gs.textureTitle.Height;

        spritePressStart=new SimpleSprite(gs.Graphics, gs.texturePressStart);
        spritePressStart.Position.X = gs.rectScreen.Width/2-gs.texturePressStart.Width/2;
        spritePressStart.Position.Y = gs.rectScreen.Height/2+gs.texturePressStart.Height;

        spriteGameOver=new SimpleSprite(gs.Graphics, gs.textureGameOver);
        spriteGameOver.Position.X = gs.rectScreen.Width/2-gs.textureGameOver.Width/2;
        spriteGameOver.Position.Y = gs.rectScreen.Height/2-gs.textureGameOver.Height;
    }

    public override void Update()
    {
        gs.debugStringScore.Clear();
        gs.debugStringShip.Clear();

        string str = String.Format("Score: {0:d8}", gs.Score);
        gs.debugStringScore.SetPosition(new Vector3( gs.rectScreen.Width/2-(str.Length*10/2), 2, 0));
        gs.debugStringScore.WriteLine(str);

        str = String.Format("Ships:{0}", gs.NumShips);
        gs.debugStringShip.SetPosition(new Vector3( gs.rectScreen.Width-(str.Length*10), 2, 0));
        gs.debugStringShip.WriteLine(str);

        switch(gs.Step)
        {
        case GameFrameworkSample.StepType.Opening:
            gs.debugString.WriteLine("Opening");

            if((gs.PadData.ButtonsDown & GamePadButtons.Start) != 0  )
            {
                Player player =(Player)gs.Root.Search("Player");
                player.Status = Actor.ActorStatus.Action;
                player.Initilize();

                gs.GameCounter=0;
                gs.NumShips=3;
                gs.Score=0;
                gs.soundPlayerButton.Play();
                gs.bgmPlayer.Play();
                gs.Step= GameFrameworkSample.StepType.GamePlay;
            }

            break;
        case GameFrameworkSample.StepType.GamePlay:
            gs.debugString.WriteLine("GamePlay");

            //@j 残機が0になったらゲームオーバーへ。
            //@e Game over when player stock falls to zero.
            if(gs.NumShips <= 0)
            {
                gs.Step= GameFrameworkSample.StepType.GameOver;
                gs.bgmPlayer.Stop();
                cnt=0;
            }

            ++gs.GameCounter;

            break;
        case GameFrameworkSample.StepType.GameOver:
            gs.debugString.WriteLine("GameOver");

            if((gs.PadData.ButtonsDown & GamePadButtons.Start) != 0 || ++cnt > 300)
            {
                gs.Step= GameFrameworkSample.StepType.Opening;
                System.GC.Collect(2);
            }

            break;
        default:
            throw new Exception("default in StepType.");

        }

        base.Update();
    }

    public override void Render ()
    {
        gs.debugStringScore.Render();
        gs.debugStringShip.Render();

        switch(gs.Step)
        {
        case GameFrameworkSample.StepType.Opening:
            spriteTitle.Render();
            spritePressStart.Render();
            break;
        case GameFrameworkSample.StepType.GamePlay:

            break;
        case GameFrameworkSample.StepType.GameOver:
            spriteGameOver.Render();
            break;
        default:
            throw new Exception("default in StepType.");

        }

        base.Render ();
    }
}

GameManager クラスでは、以下の流れでゲームを進行させます。

  • オープニング画面で、ボタンを押してゲーム開始。
  • ゲーム中、残機が0になったらゲームオーバー。
  • ゲームオーバー画面で一定時間経過、もしくはボタンが押されたら、再びオープニング画面へ。

ステージの合間にガベージコレクションを呼び出す

ゲームオーバー画面からオープニング画面に移行するとき、System.GC.Collect(2)でガベージコレクションを強制的に呼び出し、メモリを回収しています。画面が遷移する場所ならガベージコレクションによる処理落ちが発生してもそれほど気になりません。また、ここで呼び出しておくことでプレイ中のガベージコレクションの発生を低減させることができます。

アクターツリーの完成形

アクターツリーの完成形は以下のようなイメージになります。

ゲームの完成

ようやくゲームの完成です。F5を押して実行してみてください。

sample/Tutorial/Sample08_02 は、app.xmlにマスターパッケージを作成するための設定がなされています。マスターパッケージを作成するときの参考にしてみてください。

シンプルなゲームですが、ゲームの進行に必要な構造はひと通りそろっているので、あとは好みに応じてどんどん改造していくとよいでしょう。


スプライトの効率的な描画について

この文書ではスプライトの効率的な描画の方法について説明します。

Contents

  • DrawArraysの呼び出し回数を減らす
  • 複数のテクスチャを一体化する
  • サンプル

DrawArraysの呼び出し回数を減らす

各スプライトの描画ごとにDrawArrays()を呼び出すと、描画ステートの切り替えに多くの処理時間がかかるため、GPUが効率よく描画処理を行えません。

対策として連続した頂点バッファを用意しておき、そこにスプライトのデータを配置してからDrawArrays()を呼び出すようにします。そうすればGPUが連続して処理を行うことができるため、効率的に描画が行えます。

図1 連続した頂点バッファにデータを配置したあとで、DrawArrays()を呼び出す。

複数のテクスチャを一体化する

複数のテクスチャをツールで一体化しておけば、テクスチャごとにSetTexture()で切り替えをおこなわなくて済み、効率的に描画処理が行えます。

テクスチャ一体化ツールの使い方と運用方法

ここではテクスチャ一体化ツール UnifyTexture.exe の使い方とプログラム側での運用方法を説明します。

UnifyTexture.exe概要

  • UnifyTexture.exeは複数のテクスチャファイルを1枚にまとめるツールです。
  • UnifyTexture.exeはコンソールアプリケーションです。
  • ツールの配置場所は %SCE_PSM_SDK%/tools/UnifyTexture.exe です。

※ %SCE_PSM_SDK% は環境変数です。 デフォルトでインストールした場合、Windows 7/8 64bitなら C:/Program Files (x86)/SCE/PSM、Windows 7/8 32bitならC:/Program Files/SCE/PSM です。

UnifyTexture.exeのオプション

  • -o,--output [name] : 出力ファイル名。
  • -p,--pow : 出力される画像ファイルの大きさを2の乗数倍にあわせます。
  • -m,--margin [number] : 画像ファイル間の間隔。デフォルトで1が指定されています。
  • -r,--red_line : 画像ファイル境界線に赤い線を引く。テスト用。

使い方

  • 一体化したいテクスチャを引数に渡します。
  • --output で出力するファイル名のベース名を渡します。

  1. コンソール画面で次のように入力してください。

    "%SCE_PSM_SDK%/tools/UnifyTexture.exe" --output image/unified_texture  image/BrackSmoke.png  image/Bullet.png  image/Enemy.png  image/EnemyBullet.png  image/GameOver.png  image/GraySmoke.png  image/Player.png

    実行例をsample/Tutorial/Sample09_01/unify_texture.batに記述しておきましたので、参考にしてみてください。

  2. 成功すると、一体化されたテクスチャと、テクスチャ内での配置位置を記したxmlファイルが出力されます。

    図2 テクスチャの一体化と生成される2つのファイル

    以下はxmlファイルの内容です。

    <?xml version="1.0" encoding="utf-8"?>
<root version="1.0">
  <info w="512" h="512" />
  <textures>
    <texture filename="image/map_spaceA.png" x="0" y="0" w="256" h="351" />
    <texture filename="image/background.png" x="256" y="0" w="192" h="128" />
    <texture filename="image/boss.png" x="0" y="351" w="296" h="80" />
    <texture filename="image/SimpleShooting.png" x="0" y="431" w="373" h="48" />
    <texture filename="image/GameOver.png" x="256" y="128" w="248" h="41" />
    <texture filename="image/GraySmoke.png" x="256" y="169" w="64" h="64" />
    <texture filename="image/Enemy.png" x="320" y="169" w="64" h="64" />
    <texture filename="image/Player.png" x="256" y="233" w="64" h="64" />
    <texture filename="image/PressStart.png" x="320" y="233" w="170" h="23" />
    <texture filename="image/bullet_green.png" x="448" y="0" w="32" h="48" />
    <texture filename="image/myship.png" x="448" y="48" w="32" h="32" />
    <texture filename="image/particle.png" x="448" y="80" w="32" h="32" />
    <texture filename="image/BrackSmoke.png" x="256" y="297" w="32" h="32" />
    <texture filename="image/bullet_red.png" x="480" y="0" w="16" h="16" />
    <texture filename="image/mybullet.png" x="496" y="0" w="8" h="8" />
    <texture filename="image/EnemyBullet.png" x="480" y="16" w="8" h="8" />
    <texture filename="image/Bullet.png" x="488" y="16" w="2" h="8" />
    <texture filename="image/Star.png" x="480" y="24" w="2" h="2" />
  </textures>
</root>

プログラム側での処理手順

次に、一体化したテクスチャをプログラム側で利用する手順を説明します。

Sample09_01.slnを開いてください。

  1. まず生成されたunified_texture.pngとunified_texture.xmlをプロジェクトに追加します。

登録後、ビルドアクションに [Content] を指定してください。

図3 unified_texture.pngとunified_texture.xmlをプロジェクトに登録する

※ 一体化テクスチャを追加すれば、個別のテクスチャはプロジェクトから削除しても構いません。

  2. unified_texture.xmlファイルを メソッド UnifiedTexture.GetDictionaryTextureInfo() で初期化します。

それぞれのテクスチャの情報をUnifiedTextureInfoに格納しています。ここでは、ファイル名で各テクスチャにアクセスできるようDictionaryクラスを利用して管理しています。

テクスチャは以前と同じようにnew Texture2D()で作成します。

dicTextureInfo = UnifiedTexture.GetDictionaryTextureInfo("/Application/image/unified_texture.xml");
textureUnified=new Texture2D("/Application/image/unified_texture.png", false);

  3. テクスチャの情報にアクセスするには dicTextureInfo["image/Player.png"] ようにおこないます。なお、SpriteBクラスを利用すればUnifiedTextureInfoの情報をそのまま利用できます。

    UnifiedTextureInfo textureInfo=dicTextureInfo["image/Player.png"]
Console.WriteLine("w="+textureInfo.w);
Console.WriteLine("h="+textureInfo.h);
spriteB = new SpriteB(textureInfo);

  4. あとは描画時に SetTexture() で一体化テクスチャを指定して描画を実行します。

    graphics.SetTexture(0, this.textureUnified);
spriteB.Render();

サンプル

Sample09_01は上記の各ヒントを実装した例です。参考にしてみてください。

図4 Sample09_01


最適化のヒント

この文書では最適化のヒントに関して説明します。

Contents

  • 実機での正しいパフォーマンスを知るには
  • 最適化オプションの有効化
  • データをロードする時間の短縮

実機での正しいパフォーマンスを知るには

実機での正しいパフォーマンスを知るには次の設定でPSMアプリを実行してください。

  • Releaseモードでビルドする。
  • PSMアプリのデプロイ後、実機のDevAssistant のメニューからPSMアプリを立ち上げてください。( PSM Studioから起動すると、実機とPCの間で通信が行われるため、オーバーヘッドがかかります。)

最適化オプションの有効化

最適化オプションを有効にすると、処理速度の向上をはかることができます。

最適化オプションを有効にするには次の設定を行ってください。

  • [メニュー] - [Project] ? [(project name) Options] ? [Build] ? [Compiler] ? [Enable optimizations]にチェックをいれます。

    図1 最適化オプション

データをロードする時間の短縮

プロジェクトにデータファイルを登録すると、署名と暗号化を行う設定がファイルに対してデフォルトでなされます。

この「署名と暗号化」の設定から「平文」の設定に変更すると、ファイルのロード時に行われる復号と署名の処理が省略されて、処理時間が短縮されます。

ロード時間を短縮したい場合、平文の設定に変更することを検討してください。

なお「平文」の設定は次のように行います。

  1. ソリューションエクスプローラでファイルを右クリックし、[Properties] を選択します。
  2. [Properties]ウィンドウが表示されるので、その中の[Content Protection]を[SignedAndEncrypted]から[Plain]に変更します。

図2 平文の設定


GameEngine2D の使い方

この文書ではハイレベルライブラリであるSce.PlayStation.HighLevel.GameEngine2Dについて説明します。

GameEngine2Dは、シンプルな2Dゲームを開発するのに必要な基本的機能を提供します。

Contents

  • GameEngine2Dについて
  • 基本的な使い方
  • シーングラフについて
  • スプライトの動かし方
  • SpriteUV, SpriteTile, SpriteList, RawSpriteTileの選択
  • テクスチャについて
  • フォント
  • Dispose()について
  • 画面遷移 (transitions) について
  • サンプル
  • Sce.PlayStation.HighLevel.GameEngine2D.Base の基本的な概要
  • 外部リソースと参考サイト

GameEngine2Dについて

ゲームエンジン2Dがカバーしているもの:

GameEngine2Dのライブラリは2つの名前空間に分割されています。

Sce.PlayStation.HighLevel.GameEngine2D.Base

Sce.PlayStation.HighLevel.GameEngine2D.Base は、拡張数学ライブラリ、描画機能（スプライトの描画とイミーディエイトモード)、入力支援、カメラ、フォントマップ、行列スタックといった、様々な2Dの機能を含んでいます。

Sce.PlayStation.HighLevel.GameEngine2D

Sce.PlayStation.HighLevel.GameEngine2D は、Sce.PlayStation.HighLevel.GameEngine2D.Baseの上に構築された、いわゆるゲームエンジン(シーングラフ、スケジューラ、アクションなど)を含んでいます。

ゲームエンジン2DライブラリのHighLevelは、Cocos2D (http://www.cocos2d-iphone.org/) を参考に作られています。とりわけ、Director, Scheduler, ActionManager クラスはCocos2Dに相似したつくりになっています。

ゲームエンジン2Dライブラリはソースコードが提供されていますので、併せてご覧ください。

ゲームエンジン2Dがカバーしていないもの:

  • ゲームエンジン2Dは、Sce.PlayStation.HighLevel.GameEngine2D.Base.Math内にある2、3のシンプルな汎用ルーチンを除き、衝突判定を提供していません。
  • 物理エンジン、サウンド、ネットワークなどの機能は提供していません。。
  • UIシステムは提供していません。（ただし、サンプルで示されている例のように、シンプルなテキスト表示機能やスプライト描画機能の能力を使って、UI要素は容易に実装することができます）。

基本的な使い方

ライブラリをソリューションに登録する

GameEngine2Dを利用するには、ライブラリ Sce.PlayStation.HighLevel.GameEngine2D をソリューションに追加します。

ライブラリをソリューションに追加する方法は、 統合開発環境PSM Studioの基本的な使い方 - コンパイル済みのライブラリ (dll) をソリューションに追加する を参照してください。

初期化

HelloSprite サンプルでは基本的な使い方を説明します。

最初のステップはDirectorの初期化です。 Directorは、Directorのインスタンスを経由して、全てのゲームエンジン2Dのグローバルオブジェクトにアクセスするためのシングルトンクラスです。

//グラフィックスコンテキストを作成します。（選択可)
Sce.PlayStation.Core.Graphics.GraphicsContext context
     = new Sce.PlayStation.Core.Graphics.GraphicsContext();

// 利用予定の最大スプライト数(パーティクルは含みません)。
uint sprites_capacity = 500;

// デバッグ描画で利用することのできる最大頂点数。
uint draw_helpers_capacity = 400;

// 外部からのコンテキストを通じて、GameEngine2Dシングルトンクラスの初期化します。
Director.Initialize( sprites_capacity, draw_helpers_capacity, context );

空のシーンを作る

初期化後、シーングラフが必要になります。最もシンプルなシーンは、ルートノードとなる、ひとつのシーンオブジェクトで構成されます。

var scene = new Scene();

ループ

シーンを実行する用意ができました。下記のソースコードでメインループを実行します。

Director.Instance.RunWithScene( scene );

進化したループ

もう一つの方法として、ループを手動で扱うこともできます。この場合、DirectorインスタンスのUpdate()とRender()、PostSwap()を適切な順番で呼び出す必要があります。

Director.Instance.RunWithScene( scene, true );

while ( true )
{
    Sce.PlayStation.Core.Environment.SystemEvents.CheckEvents();

    Director.Instance.Update();
    Director.Instance.Render();

    Director.Instance.GL.Context.SwapBuffers();
    Director.Instance.PostSwap();
}

シーングラフについて

一般的な構造

ゲームエンジン2Dのシーングラフは、ゲーム世界のノード階層を保持したり、描画対象を巡回したりするのに使用します。その他の用途には使用しません。例えば、Update()関数を呼び出すための巡回機能はありません（これはSchedulerで行います）

それぞれのシーングラフのルートノードは、Sceneノードです。Sceneのナビゲーションは、Directorのインスタンスシングルトン経由でシーンスタックにより扱われます。

加えてゲームエンジン2Dでは、Directorオブジェクトは、ゲームエンジン2Dライブラリで利用する、他のグローバルオブジェクトの多くを保持します。

基本的なNodeオブジェクトは子ノードのリストと多くとも一つの親ノードを持っています。子ノードはChildrenプロパティを経由してアクセス可能であり、親ノードはParentプロパティを経由してアクセス可能です。ParentプロパティやChildrenプロパティは、AddChild()、RemoveChild()、RemoveAllChidren()を使って操作します。

ノードの更新

各ノードは「アクション」を持つことができます。アクションはActionManagerインスタンスによって管理されますが、主にNodeのメンバ関数を経由して実行されます。

各ノードは、インスタンスに対するUpdate関数といった、スケジュール関数を持つことができます。スケジュール関数はSchedulerインスタンスによって管理されますが、主にNodeのメンバ関数を経由して実行されます。

ゲームエンジン2DのActionManagerとSchedulerはCocos2DのActionManagerとSchedulerに相当します。

ノードの位置プロパティ

NodeはPosition/Rotation/Scale/Skew(歪曲)からなる2D変換行列を持ちます。PivotはRotation/Scale/Skewを行う際に、中心軸として利用されます。この「ローカル」の変換行列はGetTransform()によって取得します。 ソースコードでは、ノードの変換行列は次に相当します。

  Matrix3.Translation( Position )
* Matrix3.Translation( Pivot )
* Matrix3.Rotation( Rotation )
* Matrix3.Scale( Scale )
* Matrix3.Skew( new Vector2( FMath.Tan( Skew.X ), FMath.Tan( Skew.Y ) ) )
* Matrix3.Translation( -Pivot )

上のプロパティの設定を行うと、ノードとその配下のサブツリーが移動、回転、拡縮、歪曲します。

ノードオブジェクトの階層構造

次の図は、シーングラフノードの階層図です。灰色のノードは、直接利用しない中間タイプのノードです。

スプライトの動かし方

SpriteUVとSpriteTiledを使うと、ノードから派生した個々のスプライトオブジェクトを操作することができます。

ベースノードの変換行列プロパティ（それはスプライトノードへの機能でもある）に加えて、SpriteUVとSpriteTiledは、幾何情報を決定するQuadプロパティを持ちます。

TRSオブジェクト (移動(T), 回転(R) スケーリング(S))であるQuadプロパティは、スプライトに対する第2のローカル変換行列とみなすこともできます。

しかし、明確化のため、それをQuadの「幾何情報」と宣言します。

スケジューラを使ってノードを移動させる

たいてい場合、スケジュール関数の内部でノードオブジェクトを動かします。

与えられたノードに対して、毎フレーム呼び出す関数を登録する簡単な方法は、Scheduler内のNode.Scheduleを使ってラムダ関数を登録することです。

sprite = new SpriteUV();

// 初期位置の設定。
sprite.Position = new Vector2(2,3);

sprite.Schedule( ( dt ) =>
    {
        // 毎フレーム呼び出す。
        float period_in_seconds = 3.0f;
        float wave = ( ( 1.0f + FMath.Sin( (float)Director.Instance.CurrentScene.SceneTime
                    * Math.Pi / period_in_seconds ) ) * 0.5f );

        sprite.Rotation = Vector2.Rotation( Math.Pi * 2.0f * wave );
        sprite.Scale = new Vector2( 1.0f + 2.0f * wave );
    }
);

ノード関数を毎フレーム呼び出すもう一つの方法は、Spriteクラスからクラスを派生させ、Update()関数をオーバーライドし、Node.ScheduleUpdate()でそれをスケジュールすることです。

アクションを使ってノードを移動させる

アクションはノードを移動させるのに使用します。次のソースコードでは、スプライトを0.1秒で座標(10,5)に移動させるアニメーションをキック（起動）しています。

sprite.RunAction( new MoveTo( new Vector2(10.0f,5.0f), 0.1f ) );

特殊アクションであるTweenプロパティを設定することで、補間曲線を変更することができます。

sprite.RunAction( new MoveTo( new Vector2(10.0f,5.0f), 0.1f ) { Tween = (t) => Math.PowEaseIn(t,4.0f) } );

Cocos2DのMoveTo, MoveBy, ScaleTo, ScaleByなどに相当するアクションや、より一般的なActionTweenGenericVector2, ActionTweenGenericVector4, ActionTweenGenericVector2Scale, ActionTweenGenericVector2Rotationといったアクションも、位置プロパティに影響を与えます。

スプライトの幾何情報について :TRS

スプライトのQuadプロパティ（TRSオブジェクト）を使用すると、ノードのローカル空間のサイズ、位置と向きを設定することにより、スプライトの幾何情報を指定することができます。

  • Tプロパティ（Tは移動の略）は、四角形の"左下"ポイントの座標です。
  • Sプロパティ（Sはスケールの略）は、矩形のサイズです。
  • Rプロパティ（Rは回転の略）の四角形の向きを表します。これは四角形のローカルx軸とみなすことができます。

TRSの回転は、角度をあわわしたスカラーではなく、単位ベクトルとして直接あらわされることに注意してください。(ただし、角度としてのRを設定、取得するインターフェースも存在します。)

TRSはRを正規化しません。正規化するかどうかは、開発者が判断します。Rの代わりにRotationNormalize経由でRプロパティの設定し、正規化を行います。

No rotationはRが(1,0)、すなわちX軸に設定されていることを意味します。

T、R、Sの量が何を意味しているか、例をあげておきます。 これらの画像では、ワールド座標系のxとy軸が太い黒線で表示されています。 スプライトのコンテキストでは、これらのラインをノードのローカル座標系（すなわちGetTransform()のあとに来る空間として）として見ることもできます。

最も単純なTRSは、おそらく TRS.Quad0_1 と呼ばれる単位クワッドです。

TRS trs = TRS.Quad0_1; // the unit quad

次は回転の例です。

TRS trs = new TRS()
{
    T = new Vector2( 5.0f,-3.0f ),
    R = Vector2.Rotation(  Math.Deg2Rad( 45.0f ) ),
    S = new Vector2( 1.0f, 2.0f ) * FMath.Sqrt(2.0f)
};

スプライトとシーングラフの変換

グラフの巡回時に連結されていく変換行列情報は、Node.GetTranform()のみです。 スプライトオブジェクトのQuadプロパティは子の位置に影響を与えません。影響をあたえるのはスプライトの幾何情報(長方形)のみです。

SpriteUV, SpriteTile, SpriteList, RawSpriteTileの選択

どのスプライトタイプを使うか

SpriteUVは、手動で頂点UVを設定できるスプライトのノードを提供します。

SpriteTiledは、スプライトのアニメーションを行うため、グリッド上に規則的に配置された画像を扱うのに利用します。 これは2Dゲームでは効率的といえます。

パフォーマンス

しかしSpriteUVとSpriteTiledは、「独立的」に描画処理を行います。これは、セットアップのために大きなオーバーヘッドがかかり、かつ高価なオブジェクトであることを意味します。

パフォーマンス的に賢明なのは、一つのスプライトを描画するのにいちいちDrawArraysを呼び出さないようにすることです。可能な限り、描画を一括しておこなうことが重要になります。

これはつまり、同じcolor/texture/blend モードを使って描画するという制約のもとで、SpriteListを実行することです。

これを行うには、SpriteUVとSpriteTiledオブジェクトをグループ化し、SpriteListオブジェクトに少数の子として配置します。

SpriteListオブジェクトのすべての子が、一度のDrawArraysの呼び出しで描画されます。

個別の描画処理:

一括化された描画処理:

SpriteListについては、次の制限事項に注意してください。

  • SpriteListノードの子のあとに、シーングラフの階層構造を1レベル継続すると、不安定な動作になります。
  • SpriteListノードの子は、SpriteUVかSpriteTiledのみにしてください。

次の図は、無効なシーングラフです:

一括して描画するときに、スプライトの一部がCPU上で変換する必要があることに注意してください。しかし、これは個別にスプライトを描画するためのコストと比較して、安価であるといえます。

余分なCPU変換はスキップすることもできます。その場合、配置するスプライトのクワッド・プロパティに依存する必要があります。

SpriteListパフォーマンスが優れている場合でも、ノードのオブジェクトとして各スプライトを処理するのは、いくつかのケースでは無駄かもしれません。なぜなら、ノードが比較的重いオブジェクトであるためです。

RawSpriteTileは、スプライトごとに、はるかに軽いデータ構造を持つスプライトのリストをレンダリングすることができます。

テクスチャについて

TextureInfoはGameEngine2Dのテクスチャ情報を格納するためのオブジェクトです。これは、Texture2Dオブジェクトとそれに関連付けられたタイル情報を格納します。タイルグリッドのソース領域は、UV領域内で、任意の向きの長方形にすることができます。ほとんどの場合、これは（0,0）から（1,1）の長方形となります。

TextureInfoは、コンストラクタから渡されるTexture2Dオブジェクトの所有権を取得します。そのため、自身のDispose()関数で、Texture2Dオブジェクトを破棄します。

作成したTextureInfoオブジェクトは、開発者が廃棄(Dispose)する責任があります。

タイル

TextureInfoコンストラクタは、2Dタイルのサイズ、および必要に応じてUVソース領域（デフォルトではフルのUV領域、単位正方形）を取ります。

TextureInfo test_texture = new TextureInfo( new Texture2D("data/king_water_drop.png", false)
              , new Vector2i(3,4), TRS.Quad0_1 );

以下は、ソース領域がTRS.Quad0_1（フルスプライト）という状態で、3x4のタイル（上記のコード）のタイルのインデックスです。

フォント

文字のリストとフォントオブジェクトを含むテキストがわかれば、テクスチャと描画に使用するUVテーブルを格納した、フォントマップオブジェクトを構築することができます。 テキスト全体のイメージを毎フレーム生成するわけにはいかないので、フォントマップが必要です。 フォントマップのコンストラクタには、フォントマップを使ってテキストをレンダリングする際に使用される予定のすべての文字を渡す必要があります。

同じようにTextureInfoは渡されるTexture2Dの所有権を取得し、フォントマップは、そのコンストラクタに渡されたFontオブジェクトの所有権を取得します。

また、TextureInfoのように、作成したフォントマップオブジェクトは開発者が廃棄する責任があります。

Dispose()について

オブジェクトを破棄し忘れると、すぐにメモリ不足のエラーにつながります。例えば、シーンを頻繁に切り替えたのに、適切にグラフィックリソースを解放するのを忘れたりする場合です。

次のクラスは、作成したオブジェクトを開発者が破棄する責任があります。

  • TextureInfo
  • FontMap
  • ParticleSystem
  • 全てのシェーダー。

GameEngine2Dは、Director.Terminate()関数で全てのリソース(デフォルトのシェーダー、内部的なテクスチャや頂点バッファ）を破棄します。

例えば、オブジェクトを破棄するための合理的なタイミングは、シーンのOnExit()にあります。 ノードのRegisterDisposeOnExit()関数を使用すると、そのノードのOnExit()内で、廃棄するオブジェクトのDispose()呼び出しをスケジュールすることができます。 廃棄イベントの登録を忘れるリスクを減らすために、RegisterDisposeOnExitRecursive()は配下のツリーを巡回し、RegisterDisposeOnExit()で出くわした全ての破棄ノードを登録します。 ノードの廃棄イベントのリストは、呼び出された後、クリアします。もしこの動作を望まない場合、OnExit()をオーバーライドすることができます。

画面遷移 (transitions) について

画面遷移とは？

画面遷移を使うと、前のシーンと次のシーンを様々な視覚効果でクロスフェードさせることができます。

使い方

次のコードでは、現在のシーンをすぐに停止し、next_sceneに置き換えます（遷移なし）：

Director.Instance.ReplaceScene( next_scene );

以下のコードは、スムーズな画面遷移を実行する例です。 遷移時に、両方のシーンはアクティブになり、かつ（必要に応じて/関連して）オフスクリーンバッファに描画されます。 後は遷移の様々なタイプを実装するためのテクスチャとして利用されます。

Director.Instance.ReplaceScene( new TransitionCrossFade( next_scene )
                    { Duration = 2.0f, Tween = (x) => Math.PowEaseOut( x, 3.0f )} );

Director.Instance.ReplaceScene( new TransitionSolidFade( next_scene )
                    { Duration = 1.0f, Tween = (x) => Math.PowEaseOut( x, 3.0f )} );

Director.Instance.ReplaceScene( new TransitionDirectionalFade( next_scene )
                    { Duration = 2.0f, Tween = (x) => Math.PowEaseOut( x, 3.0f )} );

サンプル

Several samples are provided with the library: いくつかのサンプルが、ライブラリとともに提供されています。

  • HelloSprite ではメインループとスプライトの描画を説明しています。
  • ActionGameDemo は、アリーナスタイルのシンプルなアクションゲームです。
  • FeatureCatalog はライブラリの特徴をデモンストレーションしています。
  • PuzzleGameDemo はシンプルなパズルゲームです。

Sce.PlayStation.HighLevel.GameEngine2D.Base の基本的な概要

Sce.PlayStation.HighLevel.GameEngine2Dは以下のオブジェクトの上に構築されています。

Maths

Curves

いくつかの曲線に関連する関数（タンジェント評価を含む）

Vector2i

2整数のベクトル

Vector3i

3整数のベクトル

Bounds2i

2D、整数の境界領域（Vector2i 最小値、最大値）

Bounds2

2D、float型の境界領域（Vector2の最小値、最大値）

Plane2

2次元平面

Sphere2

2次元の球

ConvexPoly2

2D凸型のポリゴン

RandGenerator

ベクトル乱数の生成のために、拡張されたSystem.Random。

Matrix3x3

2次元変換のための3x3の行列。

MatrixStack

行列スタックは、GraphicsContextAlpha内のプロジェクションやモデル、ビュー行列のスタックといった、OpenGL風の実装に使用されます。

PitchRoll, RollPitch

3Dティルト(傾斜)機能

TRS

2Dの移動/回転/スケールのデータ。矩形の方向を示したり、簡単な変換のために使用されます。

描画ヘルパー

EmbeddedDebugFonts.cs

埋め込まれたフォントデータ。デバッグ用。

ImmediateMode<T>

OpenGLのダイレクトモードに類似した、即時描画クラス。

ImmediateModeQuads<T>

OpenGLのダイレクトモードに類似した、即時描画クラス(Quadsに特化)。

SpriteRenderer

ImmediateModeQuads<T>の上に構築されたスプライト描画クラス。（また、埋め込まれたフォントデータを使用して、デバッグテキストの描画機能を持っています）

DrawHelpers

ImmediateMode<T>の上に構築された、デバッグ描画のための即時モード。

Camera2D

2Dカメラ。

Camera3D

2D APIの使いやすさを維持した、シンプルな3Dカメラ。

外部リソースと参考サイト

[1] http://www.cocos2d-iphone.org/ Cocos2D API
[2] http://www.lostgarden.com/2007/05/dancs-miraculously-flexible-game.html Daniel Cook's PlanetCute assets
[3] http://opengameart.org/content/isometric-64x64-outside-tileset isometric tiles asset by Yar


２次元物理シミュレーションPhysics2Dライブラリの基本的な使い方

この文書では２次元物理シミュレーションPhysics2Dライブラリの基本的な使い方について説明します。

Contents

  • 物理シミュレーションシーンを作る最小限の流れ
    • 剛体オブジェクトの初期配置
    • 衝突形状データを作成する
      • ボックス形状の設定例
      • 球形状の設定例
      • 凸多角形の設定例
      • 衝突形状の数の設定例
    • 衝突形状データと関連付けた剛体オブジェクトを作成する
      • Dynamic剛体
      • Static剛体
      • Kinematic剛体
      • Trigger剛体
      • 剛体の初期設定に良く使われる属性値
      • Static剛体の設定例
      • Dynamic剛体の設定例
      • Kinematic剛体の設定例
      • シーンの特性の設定
      • 剛体のスリープについて
    • 剛体オブジェクトの描画ついにて
      • 頂点バッファの準備
      • 衝突形状PhysicsShapeの構造
      • 球の場合の頂点データの取得
      • ボックスや一般の凸多角形の場合の頂点データの取得
      • 剛体形状の描画コード
    • デバッグ情報の描画について
      • 衝突点のデバッグ描画
      • バウンディングボックスのデバッグ描画
  • ２次元物理シミュレーションPhysics2Dライブラリ各機能の使い方
    • ジョイントの設定
      • 回転方向、並進方向ともに固定の例
      • 回転方向における角度制約の例
      • 垂直方向における移動制約の例
      • 水平方向における移動制約の例

物理シミュレーションシーンを作る最小限の流れ

２次元物理シミュレーションPhysics2Dライブラリの基本的な使い方を学ぶためにサンプルシーンPrimitiveSceneを例に物理シーンの設定方法を見ていきます。

"sample/Physics2D/Physics2DSample/BasicScene/PrimitiveScene.cs"を参照してください。

物理シミュレーションのシーンを作る最小限の流れは以下の形になります。

  1. PhysicsSceneを継承したシーンクラスを作る
  2. 継承したシーンクラスにおいてInitScene()をオーバーライドする
  3. InitScene()が継承したシーンクラスのコンストラクタで呼ばれるようにする

実際にPrimitiveSceneを例としてシーン生成のコードの流れを見てみます。

  1. PhysicsSceneを継承したクラスを作る
using System;
using System.Text;

using Sce.PlayStation.Core;
using Sce.PlayStation.Core.Graphics;
using Sce.PlayStation.Core.Input;
using Sce.PlayStation.Core.Environment;

// Include 2D Physics Framework
using Sce.PlayStation.HighLevel.Physics2D;

public class PrimitiveScene : PhysicsScene
{

}
  2. 継承したシーンクラスにおいてInitScene()をオーバーライドする
using System;
using System.Text;

using Sce.PlayStation.Core;
using Sce.PlayStation.Core.Graphics;
using Sce.PlayStation.Core.Input;
using Sce.PlayStation.Core.Environment;

// Include 2D Physics Framework
using Sce.PlayStation.HighLevel.Physics2D;

public class PrimitiveScene : PhysicsScene
{
        public override void InitScene ()
        {
                // Create an empty simulation scene
                base.InitScene();
        }
}
  3. InitScene()が継承したシーンクラスのコンストラクタで呼ばれるようにする
using System;
using System.Text;

using Sce.PlayStation.Core;
using Sce.PlayStation.Core.Graphics;
using Sce.PlayStation.Core.Input;
using Sce.PlayStation.Core.Environment;

// Include 2D Physics Framework
using Sce.PlayStation.HighLevel.Physics2D;

public class PrimitiveScene : PhysicsScene
{
        public PrimitiveScene()
        {
            InitScene();
        }

        public override void InitScene ()
        {
                // Create an empty simulation scene
                base.InitScene();
        }
}
以上で最小限の物理シミュレーションシーンのセットアップは完了です。

ただし、このままでは物理オブジェクトをシーンの中に何も配置していないので、シミュレーションは何も行われません。
そこで実際にはInitScene()の中で、必要な剛体オブジェクトの初期配置が必要になります。

それでは、InitScene()での剛体オブジェクトの初期配置を見ていきます。

剛体オブジェクトの初期配置

剛体オブジェクトの初期配置の基本的な流れは以下の形になります。

  1. 衝突形状データを作成する
  2. 衝突形状データと関連付けた剛体オブジェクトを作成する

衝突形状データを作成する

衝突形状として設定可能なのは基本的に凸形状のみです。球、ボックス、凸多角形などを含みます。
凸多角形の頂点数の制限は30頂点に設定されています。ただし、これはソースコードを改変することで上限を変えることは可能です。
しかしながら、頂点数が増えるほど、衝突判定のための計算コストは大きくなりますので気をつけてください。

凹形形状は直接に衝突形状に設定することはできません。
凹形状を衝突形状として持つ剛体オブジェクトは剛体を複合させる必要があります。
シーンの衝突形状はシーンのメンバ変数sceneShapesに登録をしていきます。
また、その際、シーンに登録されている衝突形状の数をnumShapeに設定するのを忘れないようにしてください。

それでは実際にPrimitiveSceneではどのように形状を設定していくのかを見ていきます。
public override void InitScene ()
{
        // Create an empty simulation scene
        base.InitScene();

        ...
        ...
        ...

        // Box Shape Setting PhysicsShape( "width", "height" )
        Vector2 wall_width = new Vector2(50, 8);
        sceneShapes[0] = new PhysicsShape(wall_width);

        Vector2 wall_height = new Vector2(8, 30);
        sceneShapes[1] = new PhysicsShape(wall_height);

        Vector2 box_width = new Vector2(2.0f, 2.0f);
        sceneShapes[2] = new PhysicsShape(box_width);

        // Sphere Shape Setting PhysicsShape( "radius" )
        float sphere_width = 2.0f;
        sceneShapes[3] = new PhysicsShape(sphere_width);

        Vector2[] test_point = new Vector2[10];

        for (int i = 0; i < 10; i++)
        {
            test_point[i] = new Vector2(rand_gen.Next(-1000, 1000), rand_gen.Next(-1000, 1000)) * 2.0f / 1000.0f;
        }

        // Convex Shape Setting (by using random points)
        sceneShapes[4] = PhysicsShape.CreateConvexHull(test_point, 10);

        numShape = 5;

        ...
        ...
        ...
}

ボックス形状の設定例

ボックスの縦横半分の長さをPhysicsShapeコンストラクタの引数に与えます。

Vector2 wall_width = new Vector2(50, 8);
sceneShapes[0] = new PhysicsShape(wall_width);

球形状の設定例

球の半径を設定したfloat値をPhysicsShapeコンストラクタの引数に与えます。

float sphere_width = 2.0f;
sceneShapes[3] = new PhysicsShape(sphere_width);

凸多角形の設定例

ランダムな頂点を10個作り、ランダムな10個の頂点をもとに凸包を作って凸多角形を生成しています。

Vector2[] test_point = new Vector2[10];

for (int i = 0; i < 10; i++)
{
        test_point[i] = new Vector2(rand_gen.Next(-1000, 1000), rand_gen.Next(-1000, 1000)) * 2.0f / 1000.0f;
}

sceneShapes[4] = PhysicsShape.CreateConvexHull(test_point, 10);

ここでCreateConvexHullは任意の頂点列を与えて、凸包を生成するAPIです。

衝突形状の数の設定例

１つずつ衝突形状を登録するたびにnumShapeをインクリメントしてもいいですが、PrimitiveSceneでは衝突形状を登録した後でnumShapeを設定しています。

numShape = 5;
以上で、シーンPrimitiveSceneにおける衝突形状の登録が完了です。

ただし、ここまでは衝突形状を登録しただけで、実際の剛体が存在している訳ではありません。
次に登録された衝突形状にもとづいて、剛体オブジェクトの作成を行っていきます。

衝突形状データと関連付けた剛体オブジェクトを作成する

まず、剛体にはいくつかのタイプがあります。

Dynamic剛体

  • 通常の良く使われる剛体です
  • 速度や加速度を持ち、シーンの中を移動します

Static剛体

  • シーンの開始から終了まで全く動かない剛体です
  • 無限大の質量を持つと仮定して計算されます

Kinematic剛体

  • 一時的に強制的に静止状態、または意図的に移動させられる剛体です
  • 一時的に無限大の質量を持つと仮定して計算されます

Trigger剛体

  • シーンの中のある領域に入ったかどうかの検出目的に用いられる特殊な剛体です
  • 衝突判定はありますが、衝突による反発計算は行われません
まずは上記どのタイプの剛体を作りたいのかを明確にしておく必要があります。
動かない壁や床を作る時にはStatic剛体を用い、床の上を転がる球を作る時にはDynamic剛体を用いることになります。

剛体を生成する際には上記の剛体のタイプと、以下の値を設定して初期配置することが一般的です。

剛体の初期設定に良く使われる属性値

  • 質量
  • 位置
  • 角度
  • 速度（並進方向の速度）
  • 角速度（回転方向の速度）
それでは実際にPrimitiveSceneではどのように剛体オブジェクトを初期配置していくのかを見ていきます。
まずはシーンの中に壁、床、天井となる剛体オブジェクトをStatic剛体として生成します。これらの剛体はシーンの開始から終了まで動かないためです。

Static剛体の設定例

public override void InitScene()
{
        ...
        ...
        ...

    // Create static walls to limit the range of action of active rigid sceneBodies
    {
        // new PhysicsBody( "shape of the body",  "mass of the body(kg)" )
        sceneBodies[numBody] = new PhysicsBody(sceneShapes[0], PhysicsUtility.FltMax);

        // Set the position & the rotation
        sceneBodies[numBody].position = new Vector2(0, -wall_height.Y);
        sceneBodies[numBody].rotation = 0;

        // Make shapeIndex consistent with what we set as convex shape
        sceneBodies[numBody].shapeIndex = 0;
        numBody++;

        sceneBodies[numBody] = new PhysicsBody(sceneShapes[1], PhysicsUtility.FltMax);
        sceneBodies[numBody].position = new Vector2(wall_width.X, 0);
        sceneBodies[numBody].rotation = 0;
        sceneBodies[numBody].shapeIndex = 1;
        numBody++;

        sceneBodies[numBody] = new PhysicsBody(sceneShapes[1], PhysicsUtility.FltMax);
        sceneBodies[numBody].position = new Vector2(-wall_width.X, 0);
        sceneBodies[numBody].rotation = 0;
        sceneBodies[numBody].shapeIndex = 1;
        numBody++;

        sceneBodies[numBody] = new PhysicsBody(sceneShapes[0], PhysicsUtility.FltMax);
        sceneBodies[numBody].position = new Vector2(0, wall_height.Y);
        sceneBodies[numBody].rotation = 0;
        sceneBodies[numBody].shapeIndex = 0;
        numBody++;
    }

        ...
        ...
        ...
}

ここでは床となるStatic剛体の設定を行っています。
sceneBodies[numBody] = new PhysicsBody(sceneShapes[0], PhysicsUtility.FltMax);
sceneBodies[numBody].position = new Vector2(0, -wall_height.Y);
sceneBodies[numBody].rotation = 0;
sceneBodies[numBody].shapeIndex = 0;
numBody++;
  1. 衝突形状のボックス形状sceneShape[0]、およびStaticタイプであるため質量無限大PhysicsUtility.FltMaxを引数としてPhysicsBodyのコンストラクタを呼び出す
  2. position属性として位置にVector2(0, -wall_height.Y)を設定
  3. rotation属性として角度に0を設定
  4. shapeIndexとしてPhysicsBodyのコンストラクタに与えた形状のインデックスを与えています
  5. シーン中の剛体オブジェクトの数を保持する変数numBodyをインクリメントしておきます
壁、天井となるStatic剛体の設定も同様です。

ここで床と天井の剛体の衝突形状は同じなので、関連付けられている衝突形状が同じになります。
衝突形状は複数の剛体と関連付けることが可能ですので、同じ衝突形状を複数作成しないように気をつけてください。

次にシーンの中に自由に動き回れる球、ボックス、凸多角形のDynamic剛体を作っていきます。

Dynamic剛体の設定例

// Create dynamic rigid sceneBodies
{
    // Create a box-shaped dynamic rigid body
    {
        sceneBodies[numBody] = new PhysicsBody(sceneShapes[2], 1.0f);
        sceneBodies[numBody].position = new Vector2(-10.0f, -5.0f);
        sceneBodies[numBody].rotation = PhysicsUtility.GetRadian(30.0f);
        sceneBodies[numBody].shapeIndex = 2;
        numBody++;
    }

    // Create a sphere-shaped dynamic rigid body
    {
        sceneBodies[numBody] = new PhysicsBody(sceneShapes[3], 1.0f);
        sceneBodies[numBody].position = new Vector2(0.0f, -5.0f);
        sceneBodies[numBody].rotation = 0;
        sceneBodies[numBody].shapeIndex = 3;
        sceneBodies[numBody].colFriction = 0.01f;
        numBody++;
    }

    // Create a convex-shaped dynamic rigid body
    {
        sceneBodies[numBody] = new PhysicsBody(sceneShapes[4], 1.0f);
        sceneBodies[numBody].position = new Vector2(10.0f, -5.0f);
        sceneBodies[numBody].rotation = 0;
        sceneBodies[numBody].shapeIndex = 4;
        numBody++;
    }
}

ここではボックスとなるDynamic剛体の設定を行っています。

sceneBodies[numBody] = new PhysicsBody(sceneShapes[2], 1.0f);
sceneBodies[numBody].position = new Vector2(-10.0f, -5.0f);
sceneBodies[numBody].rotation = PhysicsUtility.GetRadian(30.0f);
sceneBodies[numBody].shapeIndex = 2;
numBody++;
  1. 衝突形状となるボックス形状sceneShape[2]、および質量1.0fを引数としてPhysicsBodyのコンストラクタを呼び出す
  2. position属性として位置にVector2(-10.0f, -5.0f)を設定
  3. rotation属性として角度にPhysicsUtility.GetRadian(30.0f)を設定（ラジアン指定）
  4. shapeIndexとしてPhysicsBodyのコンストラクタに与えた形状のインデックスを与える
  5. シーン中の剛体オブジェクトの数を保持する変数numBodyをインクリメント
球、凸多角形の形状を持つDynamic剛体の設定も同様です。

ここでは球となるDynamic剛体の設定を行っています。
sceneBodies[numBody] = new PhysicsBody(sceneShapes[3], 1.0f);
sceneBodies[numBody].position = new Vector2(0.0f, -5.0f);
sceneBodies[numBody].rotation = 0;
sceneBodies[numBody].shapeIndex = 3;
sceneBodies[numBody].colFriction = 0.01f;
numBody++;
  1. 衝突形状となるボックス形状sceneShape[3]、および質量1.0fを引数としてPhysicsBodyのコンストラクタを呼び出す
  2. position属性として位置にVector2(0.0f, -5.0f)を設定
  3. rotation属性として角度に0を設定
  4. shapeIndexとしてPhysicsBodyのコンストラクタに与えた形状のインデックスを与える
  5. 衝突摩擦係数0.01fを設定
  6. シーン中の剛体オブジェクトの数を保持する変数numBodyをインクリメント

ここでは凸多角形となるDynamic剛体の設定を行っています。
sceneBodies[numBody] = new PhysicsBody(sceneShapes[4], 1.0f);
sceneBodies[numBody].position = new Vector2(10.0f, -5.0f);
sceneBodies[numBody].rotation = 0;
sceneBodies[numBody].shapeIndex = 4;
numBody++;
  1. 衝突形状となるボックス形状sceneShape[4]、および質量1.0fを引数としてPhysicsBodyのコンストラクタを呼び出す
  2. position属性として位置にVector2(10.0f, -5.0f)を設定
  3. rotation属性として角度に0を設定
  4. shapeIndexとしてPhysicsBodyのコンストラクタに与えた形状のインデックスを与える
  5. シーン中の剛体オブジェクトの数を保持する変数numBodyをインクリメント
なお、Dynamic剛体の場合、質量を含む剛体のスケールについては注意が必要です。

質量差の激しい剛体同士が衝突した場合には、計算の不安定性が生じることがあります。
Dynamic剛体の場合、大まかな目安として以下の範囲で剛体を生成することが望ましいです。
  • 質量スケール : 0.2[Kg] - 20.0[Kg]
  • 長さスケール : 0.2[m] - 20.0[m]
では、次に一時的に強制的に静止されられたりするKinematic剛体を作っていきます。

Kinematic剛体の設定例

 // Create a kinematic rigid body whose shape is box
{
    sceneBodies[numBody] = new PhysicsBody(sceneShapes[2], 1.0f);
    sceneBodies[numBody].position = new Vector2(-10.0f, 15.0f);
    sceneBodies[numBody].rotation = PhysicsUtility.GetRadian(30.0f);
    sceneBodies[numBody].shapeIndex = 2;
    sceneBodies[numBody].SetBodyKinematic();
    index0 = numBody++;
}

// Create a sphere-shaped kinematic rigid body
{
    sceneBodies[numBody] = new PhysicsBody(sceneShapes[3], 1.0f);
    sceneBodies[numBody].position = new Vector2(0.0f, 15.0f);
    sceneBodies[numBody].rotation = 0;
    sceneBodies[numBody].shapeIndex = 3;
    sceneBodies[numBody].colFriction = 0.01f;
    sceneBodies[numBody].SetBodyKinematic();
    index1 = numBody++;
}

// Create a convex-shaped kinematic rigid body
{
    sceneBodies[numBody] = new PhysicsBody(sceneShapes[4], 1.0f);
    sceneBodies[numBody].position = new Vector2(10.0f, 15.0f);
    sceneBodies[numBody].rotation = 0;
    sceneBodies[numBody].shapeIndex = 4;
    sceneBodies[numBody].SetBodyKinematic();
    index2 = numBody++;
}
ここではボックスとなるKinematic剛体の設定を行っていますが、実はDynamic剛体の設定とほぼ同じ手順です。違いはSetBodyKinematic()を呼び出す部分です。
sceneBodies[numBody] = new PhysicsBody(sceneShapes[2], 1.0f);
sceneBodies[numBody].position = new Vector2(-10.0f, 15.0f);
sceneBodies[numBody].rotation = PhysicsUtility.GetRadian(30.0f);
sceneBodies[numBody].shapeIndex = 2;
sceneBodies[numBody].SetBodyKinematic();
index0 = numBody++;
  1. 衝突形状となるボックス形状sceneShape[2]、および質量1.0fを引数としてPhysicsBodyのコンストラクタを呼び出す
  2. position属性として位置にVector2(-10.0f, 15.0f)を設定
  3. rotation属性として角度にPhysicsUtility.GetRadian(30.0f)を設定（ラジアン指定）
  4. shapeIndexとしてPhysicsBodyのコンストラクタに与えた形状のインデックスを与える
  5. Kinematic剛体にするためにSetBodyKinematic()を呼び出すことでDynamic剛体として一度設定された情報を退避する
  6. シーン中の剛体オブジェクトの数を保持する変数numBodyをインクリメント
球、凸多角形の形状を持つKinematic剛体の設定も同様です。

なお、Kinematic剛体と設定された剛体はDynamic剛体に戻す（退避した情報）ことが可能です。

PrimitiveSceneではボタン入力によって一度Kinematic剛体に設定された剛体をDynamic剛体に戻したり、再びKinematic剛体にしたりしています。
Kinematic剛体の設定でindex0にインデックスを保存していたのはこのためです。
// Game controller handling
public override void KeyboradFunc(GamePadButtons button)
{
    switch (button)
    {
        case GamePadButtons.Square:

                //
            // isKinematicOrStatic() checks the mass of the rigid body and determines whether a body is kinematic or static
            // backToDynamic() cannot be called for rigid sceneBodies not set up with setKinematic()
            //

            if (sceneBodies[index0].IsKinematic())
                sceneBodies[index0].BackToDynamic();
            else
                sceneBodies[index0].SetBodyKinematic();

            if (sceneBodies[index1].IsKinematic())
                sceneBodies[index1].BackToDynamic();
            else
                sceneBodies[index1].SetBodyKinematic();

            if (sceneBodies[index2].IsKinematic())
                sceneBodies[index2].BackToDynamic();
            else
                sceneBodies[index2].SetBodyKinematic();

            break;
        default:
            break;
    }
}
IsKinematic APIによって剛体がKinematic剛体であるかを判定して、Kinematic剛体であれば、退避していた情報を戻してDynamic剛体に変化させています。
退避していた情報を戻すためにもKinamtic剛体も最初はDynamic剛体に設定しておく必要があります。Dynamic剛体に戻す可能性がない剛体は最初からStatic剛体として設定してください。

シーンの特性の設定

さて、InitScene()の中で剛体の初期配置について見てきましたが、InitScene()で使われているシーンの特性の設定について説明します。

public override void InitScene ()
{
        // Create an empty simulation scene
        base.InitScene();
        sceneName = "PrimitiveScene";

        // Set the restitution coefficient a bit stronger
        this.restitutionCoeff = 0.8f;

sceneNameはシーン名を保持する文字列の変数で"PrimitiveScene"をセットしています。

this.restitutionCoeff = 0.8f;

シーンの特性である反発に対する反発係数の設定をしていて、反発をきちんと生じるシーンに設定しています。

シーン内での衝突の特性を決めるパラメータとしては以下の値が設定可能です。

  • float penetrationRepulse (default 0.2f) ... めり込みに対する反発力の加速係数
  • float penetLimit (default 0.03f) ... めり込みに対する許容度
  • float tangentFriction (default 0.3f) ... 反発に対する接線方向の摩擦係数
  • float restitutionCoeff (default 0.0f) ... 反発に対する反発係数
これらの値を変えることで、反発のしやすいシーンになったり、反発のしにくいシーンになったり、摩擦のないシーンにすることが可能です。
シーンの特性のパラメータについては"sample/Physics2D/Physics2DSample/TutorialScene/ScenePropertyScene.cs"にサンプルがありますので、参考にしてください。

剛体のスリープについて

計算コストを抑えるため、剛体がほぼ動いておらず静止していると見なせる状態になっている時には、剛体はスリープ状態に入ります。
剛体がスリープに入っている状態では、衝突点検出、衝突反発の計算は行われなくなります。

PrimitiveSceneにおいても床と接触している剛体の間の衝突点計算がスリープ状態に入ると行われなくなります。
しかし、新たな衝突が発生して速度を生じる時点で剛体はスリープ状態から抜けだします。

なお、Static剛体やKinematic剛体については強制的に静止状態になっている時は、常にスリープ状態と見なされます。

剛体オブジェクトの描画ついにて

剛体オブジェクトの描画について簡単に解説をします。描画方法そのものについての説明はGraphicsサンプルのドキュメントを参照してください。
ここではPhysics2Dと関係のある部分についてのみ解説します。

通常、剛体オブジェクトの描画は剛体に設定された衝突形状にもとづいて描画されます。
例で見てきた通り、衝突形状オブジェクトはsceneShapesに保存されていました。sceneShapesはPhsyicsShapeの配列です。

頂点バッファの準備

まずはシェーダープログラムに与える頂点バッファが必要になります。

public class PrimitiveScene : PhysicsScene
{
    // Vertex Buffer for Body Rendering
    private VertexBuffer[] vertices = new VertexBuffer[100];
PrimitiveSceneでは100個の衝突形状は出てきませんが、ここではとりあえず100個分の衝突形状を描画できるように頂点バッファを宣言します。
なお、頂点バッファは剛体ごとに使用するのではなく、同じ衝突形状を持つ剛体間でシェアしています。
これはPrimitiveSceneのためであり、テクスチャを剛体ごとに変える場合には剛体ごとに頂点バッファを確保する必要になることもあります。

次に頂点バッファのコンストラクタで頂点数、頂点のフォーマットを指定して頂点バッファを作成します。
public PrimitiveScene()
{
    // Simulation Scene Set Up
    InitScene();

    // Setup for Rendering Object
    for (int i = 0; i < numShape; i++)
    {
        if (sceneShapes[i].numVert == 0)
        {
            vertices[i] = new VertexBuffer(37, VertexFormat.Float3);
        }
        else
        {
            vertices[i] = new VertexBuffer(sceneShapes[i].numVert + 1, VertexFormat.Float3);
        }

衝突形状PhysicsShapeの構造

ここでPhysicsShapeの構造を確認しておきます。

public partial class PhysicsShape
{
    public int numVert;

    public Vector2[] vertList = new Vector2[30];
        ...
        ...
        ...
}
これは定義の一部ですが、PhysicsShapeは頂点数を保存するnumVertと、実際に頂点列を保存するvertListを保持しています。
この頂点列の情報にもとづいて描画をすれば良いのですが、numVert==0の場合は球として設定されており、vertList[0].Xに半径が保存されている点に注意が必要です。

PhysicsShapeの構造にもとづき、頂点バッファに頂点をセットしている部分は以下です。

// Line Rendering for Object
private void MakeLineListConvex(PhysicsShape con, VertexBuffer vertices)
{

    if (con.numVert == 0)
    {
        float[] vertex = new float[3 * 37];

        int i = 0;
        float rad = con.vertList[0].X;

        for (float th1 = 0.0f; th1 < 360.0f; th1 = th1 + 10.0f)
        {
            float th1_rad = th1 / 180.0f * PhysicsUtility.Pi;

            float x1 = rad * (float)Math.Cos(th1_rad);
            float y1 = rad * (float)Math.Sin(th1_rad);

            vertex[3 * i + 0] = x1;
            vertex[3 * i + 1] = y1;
            vertex[3 * 　i + 2] = 0.0f;
            i++;
        }

        vertex[3 * i + 0] = vertex[3 * 0 + 0];
        vertex[3 * i + 1] = vertex[3 * 0 + 1];
        vertex[3 * i + 2] = vertex[3 * 0 + 2];

        vertices.SetVertices(0, vertex);

    }
    else
    {
        float[] vertex = new float[3 * (con.numVert + 1)];

        int i;

        for (i = 0; i < con.numVert; i++)
        {
            Vector2 v1;
            v1 = con.vertList[i];

            vertex[3 * i + 0] = v1.X;
            vertex[3 * i + 1] = v1.Y;
            vertex[3 * i + 2] = 0.0f;
        }

        vertex[3 * i + 0] = vertex[3 * 0 + 0];
        vertex[3 * i + 1] = vertex[3 * 0 + 1];
        vertex[3 * i + 2] = vertex[3 * 0 + 2];

        vertices.SetVertices(0, vertex);
    }
}
con.numVert == 0の場合と、それ以外で場合分けをしています。これは述べたように、球の場合は特殊な形で情報が保持されているからです。
球の場合は半径の情報のみがPhysicsShapeインスタンスに保存されているため、自分で描画用の頂点列を生成しなければなりません。
そこで半径をもとに円周上に何点か頂点をピックアップすることで頂点列を作ります。
ここでは0度から350度までの10度刻みの36頂点と、最後に最初の頂点と同じ座標に頂点を生成しているので合計37頂点になります。

一方、ボックスや一般の凸多角形ではPhysicsShapeインスタンスに保持されている頂点列を頂点バッファにセットします。

球の場合の頂点データの取得

if (con.numVert == 0)
{
    float[] vertex = new float[3 * 37];

    int i = 0;
    float rad = con.vertList[0].X;

    for (float th1 = 0.0f; th1 < 360.0f; th1 = th1 + 10.0f)
    {
        float th1_rad = th1 / 180.0f * PhysicsUtility.Pi;

        float x1 = rad * (float)Math.Cos(th1_rad);
        float y1 = rad * (float)Math.Sin(th1_rad);

        vertex[3 * i + 0] = x1;
        vertex[3 * i + 1] = y1;
        vertex[3 * i + 2] = 0.0f;
        i++;
    }

    vertex[3 * i + 0] = vertex[3 * 0 + 0];
    vertex[3 * i + 1] = vertex[3 * 0 + 1];
    vertex[3 * i + 2] = vertex[3 * 0 + 2];

    vertices.SetVertices(0, vertex);

}
描画のために使用する頂点のバッファは3次元の頂点座標を持ちますが、Z方向を無視するために常に0.0fをZ座標に指定しています。
形状をライン描画するために最後の頂点として最初の頂点と同じ座標を与えています。

ボックスや一般の凸多角形の場合の頂点データの取得

else
{
    float[] vertex = new float[3 * (con.numVert + 1)];

    int i;

    for (i = 0; i < con.numVert; i++)
    {
        Vector2 v1;
        v1 = con.vertList[i];

        vertex[3 * i + 0] = v1.X;
        vertex[3 * i + 1] = v1.Y;
        vertex[3 * i + 2] = 0.0f;
    }

    vertex[3 * i + 0] = vertex[3 * 0 + 0];
    vertex[3 * i + 1] = vertex[3 * 0 + 1];
    vertex[3 * i + 2] = vertex[3 * 0 + 2];

    vertices.SetVertices(0, vertex);
}

形状をライン描画するために最後の頂点として最初の頂点と同じ座標を与えています。

剛体形状の描画コード

実際のシーンの描画は、単に形状を描画するだけでなく、剛体オブジェクトの各フレームにおける位置や角度の変化に合わせて描画する必要があります。
そのため、剛体オブジェクトのposition, rotation, localPosition, localRotationの値を使って、描画に用いられる変換行列を設定する必要があります。
この行列とは、もとの形状を示す頂点列から実際に剛体の位置、角度などを反映した頂点列に変換するための行列です。
複合形状でなければ、localPositionとlocalRotationは考えなくて良く、position, rotationのみの考慮でかまいません。

// Draw objects
public override void DrawAllBody(ref GraphicsContext graphics, ref ShaderProgram program, Matrix4 renderMatrix, int click_index)
{
    for (int j = 0; j < numShape; j++)
    {
        graphics.SetVertexBuffer(0, vertices[j]);

        for (int i = 0; i < numBody; i++)
        {
            uint index = sceneBodies[i].shapeIndex;

            if (j != index) continue;

            Matrix4 rotationMatrix = Matrix4.RotationZ(sceneBodies[i].rotation);

            Matrix4 transMatrix = Matrix4.Translation(
                new Vector3(sceneBodies[i].position.X, sceneBodies[i].position.Y, 0.0f));

            Matrix4 local_rotationMatrix = Matrix4.RotationZ(sceneBodies[i].localRotation);

            Matrix4 local_transMatrix = Matrix4.Translation(
                new Vector3(sceneBodies[i].localPosition.X, sceneBodies[i].localPosition.Y, 0.0f));

            Matrix4 WorldMatrix = renderMatrix * transMatrix * rotationMatrix * local_transMatrix * local_rotationMatrix;

            program.SetUniformValue(0, ref WorldMatrix);

            if (i == click_index)
            {
                Vector3 color = new Vector3(1.0f, 0.0f, 0.0f);
                program.SetUniformValue(1, ref color);
            }
            else
            {
                Vector3 color = new Vector3(0.0f, 1.0f, 1.0f);
                program.SetUniformValue(1, ref color);
            }

            if (sceneShapes[index].numVert == 0)
                graphics.DrawArrays(DrawMode.LineStrip, 0, 37);
            else
                graphics.DrawArrays(DrawMode.LineStrip, 0, sceneShapes[index].numVert + 1);

        }

    }
}

順番に内容を見ていきます。前半はシェーダープログラムの設定のためのワールド行列やビュー行列の設定になっています。
シェーダープログラムそのものの設定方法についてはGraphicsサンプルを参照してください。

Matrix4 rotationMatrix = Matrix4.RotationZ(sceneBodies[i].rotation);

Matrix4 transMatrix = Matrix4.Translation(
    new Vector3(sceneBodies[i].position.X, sceneBodies[i].position.Y, 0.0f));

Matrix4 local_rotationMatrix = Matrix4.RotationZ(sceneBodies[i].localRotation);

Matrix4 local_transMatrix = Matrix4.Translation(
    new Vector3(sceneBodies[i].localPosition.X, sceneBodies[i].localPosition.Y, 0.0f));

Matrix4 WorldMatrix = renderMatrix * transMatrix * rotationMatrix * local_transMatrix * local_rotationMatrix;

program.SetUniformValue(0, ref WorldMatrix);
上記の行列演算において、(transMatrix * rotationMatrix * local_transMatrix * local_rotationMatrix)で乗算が行われています。
複合形状でなければ、(transMatrix * rotationMatrix)のみの考慮でかまいません。

描画において剛体に設定された衝突形状の元の各頂点は次の順で乗算が行われ、現在の剛体の位置や角度などを反映した頂点に変換されることになります。
  1. local_rotationMatrix
  2. local_transMatrix
  3. rotationMatrix
  4. transMatrix

変換の行列を設定したら、後は元の衝突形状の頂点をシェーダーに与えて描画を行うだけで良いのです。

if (sceneShapes[index].numVert == 0)
    graphics.DrawArrays(DrawMode.LineStrip, 0, 37);
else
    graphics.DrawArrays(DrawMode.LineStrip, 0, sceneShapes[index].numVert + 1);

デバッグ情報の描画について

正しく物理シミュレーションが行われているかデバッグ描画を行って状態を確認したい場合があります。
デバッグ描画に良く使われるのが衝突点の位置情報です。他にもオブジェクトのバウンディングボックスやジョイントの情報がデバッグ描画に良く使われます。

衝突点のデバッグ描画

剛体Ａと剛体Ｂが衝突している状態の時、衝突点の情報は剛体Ａと剛体Ｂのそれぞれに生成されます。
通常は剛体Ａと剛体Ｂの衝突点情報の位置座標はほぼ同じですが、強い外力などにより、
一瞬、剛体Ａと剛体Ｂの間にめり込みが生じた場合は、剛体Ａと剛体Ｂに対する衝突点情報の位置座標にずれが生じます。

実際に衝突点を描画するコードを見てます。まずは衝突点を描画するために、小さい正方形をデバッグ描画用の頂点バッファにセットしておきます。

public class PrimitiveScene : PhysicsScene
    {
            ...
            ...
            ...

    private VertexBuffer colVert = null;

            ...
            ...
            ...

    public PrimitiveScene()
    {

            ...
            ...
            ...

        // VertexBuffer for contact points debug rendering
        {
            colVert = new VertexBuffer(4, VertexFormat.Float3);

            const float scale = 0.2f;

            float[] vertex = new float[]
            {
                -1.0f, -1.0f, 0.0f,
                1.0f, -1.0f, 0.0f,
                1.0f, 1.0f, 0.0f,
                -1.0f, 1.0f, 0.0f
            };

            for (int i = 0; i < 12; i++)
                vertex[i] = vertex[i] * scale;

            colVert.SetVertices(0, vertex);
        }
衝突点を描画するための描画オブジェクトは正方形でなくとも良いのですが、ここでは簡易な情報でかまわないので正方形としています。
// Debug rendering for contact points(RigidBody A <=> RigidBody B) and AABB(Axis Aligned Bounding Box)
public override void DrawAdditionalInfo(ref GraphicsContext graphics, ref ShaderProgram program, Matrix4 renderMatrix)
{
    // Draw contact points
    graphics.SetVertexBuffer(0, colVert);

    for (uint i = 0; i < numPhysicsSolverPair; i++)
    {
        // Collision point for RigidBody A
        {
            Matrix4 transMatrix = Matrix4.Translation(
                new Vector3(solverPair[i].resA.X, solverPair[i].resA.Y, 0.0f));

            Matrix4 WorldMatrix = renderMatrix * transMatrix;
            program.SetUniformValue(0, ref WorldMatrix);

            Vector3 color = new Vector3(1.0f, 0.0f, 0.0f);
            program.SetUniformValue(1, ref color);

            graphics.DrawArrays(DrawMode.TriangleFan, 0, 4);
        }

        // Collision point for RigidBody B
        {
            Matrix4 transMatrix = Matrix4.Translation(
                new Vector3(solverPair[i].resB.X, solverPair[i].resB.Y, 0.0f));

            Matrix4 WorldMatrix = renderMatrix * transMatrix;
            program.SetUniformValue(0, ref WorldMatrix);

            Vector3 color = new Vector3(1.0f, 0.0f, 0.0f);
            program.SetUniformValue(1, ref color);

            graphics.DrawArrays(DrawMode.TriangleFan, 0, 4);
        }
    }
シーン中の衝突点の数はnumPhysicsSolverPairに保存さており、衝突点の情報はsolverPair配列に保存されているので
numPhysicsSolverPairの回数だけ衝突点の描画処理を順番に行っていきます。

衝突点情報における剛体Ａ側の衝突点の位置は以下によって取得しています。

Matrix4 transMatrix = Matrix4.Translation(
    new Vector3(solverPair[i].resA.X, solverPair[i].resA.Y, 0.0f));
衝突点情報における剛体Ｂ側の衝突点の位置は以下によって取得しています。
Matrix4 transMatrix = Matrix4.Translation(
    new Vector3(solverPair[i].resB.X, solverPair[i].resB.Y, 0.0f));

バウンディングボックスのデバッグ描画

次にバウンディングボックス情報をデバッグ描画している部分について見ていきます。
バウンディングボックスとはX軸、Y軸に平行であり、かつ剛体オブジェクトを包む最小限のボックスのことです。
まず衝突点描画と同様に、バウンディングボックスを描画するための頂点バッファを最初に用意します。
public class PrimitiveScene : PhysicsScene
    {
            ...
            ...
            ...

    private VertexBuffer aabbVert = null;

            ...
            ...
            ...

    public PrimitiveScene()
    {

            ...
            ...
            ...

        // VertexBuffer for AABB debug rendering
        {
            aabbVert = new VertexBuffer(5, VertexFormat.Float3);

            float[] vertex = new float[]
            {
                0.0f, 0.0f, 0.0f,
                1.0f, 0.0f, 0.0f,
                1.0f, 1.0f, 0.0f,
                0.0f, 1.0f, 0.0f,
                0.0f, 0.0f, 0.0f,
            };

            aabbVert.SetVertices(0, vertex);
        }

バウンディングボックスはライン描画を行うために頂点としては5点用意しておき、最後の頂点を最初の頂点と同じにしています。

// Debug rendering for contact points(RigidBody A <=> RigidBody B) and AABB(Axis Aligned Bounding Box)
public override void DrawAdditionalInfo(ref GraphicsContext graphics, ref ShaderProgram program, Matrix4 renderMatrix)
{

        ...
        ...
        ...

    // Draw AABB Bounding Box
    graphics.SetVertexBuffer(0, aabbVert);

    for (uint i = 0; i < numBody; i++)
    {

        Matrix4 scaleMatrix = new Matrix4(
             sceneBodies[i].aabbMax.X - sceneBodies[i].aabbMin.X, 0.0f, 0.0f, 0.0f,
             0.0f, sceneBodies[i].aabbMax.Y - sceneBodies[i].aabbMin.Y, 0.0f, 0.0f,
             0.0f, 0.0f, 1.0f, 0.0f,
             0.0f, 0.0f, 0.0f, 1.0f
         );

        Matrix4 transMatrix = Matrix4.Translation(
            new Vector3(sceneBodies[i].aabbMin.X, sceneBodies[i].aabbMin.Y, 0.0f));

        Matrix4 WorldMatrix = renderMatrix * transMatrix * scaleMatrix;
        program.SetUniformValue(0, ref WorldMatrix);

        Vector3 color = new Vector3(1.0f, 1.0f, 0.0f);
        program.SetUniformValue(1, ref color);

        graphics.DrawArrays(DrawMode.LineStrip, 0, 5);
    }
バウンディングボックスの大きさや位置は剛体によって変わってきます。バウンディングボックスの角度は剛体によらず常にX軸、Y軸に平行になります。
sceneBodies配列に剛体の状態が保存されており、aabbMaxおよびaabbMinの値にバウンディングボックスの大きさの情報が保存されていますので、それを利用して描画していきます。

バウンディングボックスの大きさの取得

Matrix4 scaleMatrix = new Matrix4(
     sceneBodies[i].aabbMax.X - sceneBodies[i].aabbMin.X, 0.0f, 0.0f, 0.0f,
     0.0f, sceneBodies[i].aabbMax.Y - sceneBodies[i].aabbMin.Y, 0.0f, 0.0f,
     0.0f, 0.0f, 1.0f, 0.0f,
     0.0f, 0.0f, 0.0f, 1.0f
 );

バウンディングボックスの位置の取得

Matrix4 transMatrix = Matrix4.Translation(
    new Vector3(sceneBodies[i].aabbMin.X, sceneBodies[i].aabbMin.Y, 0.0f));

バウンディングボックスの大きさを調整した後に、正しい位置に描画するため、以下の順番で描画のための行列の設定を行います。

  1. scaleMatrix
  2. transMatrix
Matrix4 WorldMatrix = renderMatrix * transMatrix * scaleMatrix;
なお、これらのデバッグ描画用に用意した頂点バッファなどのリソースはシーンの終了や切り替え時に解放することを忘れないようにしてください。
PrimitiveSceneでは以下において剛体描画用の頂点バッファ、デバッグ情報描画用の頂点バッファの解放を行っています。
public override void ReleaseScene()
{
    for (int i = 0; i < numShape; i++)
        if(vertices[i] != null)
            vertices[i].Dispose();

    if(aabbVert != null) aabbVert.Dispose();
    if(colVert != null) colVert.Dispose();
}

以上でPrimitiveSceneの概要を見てきましたが、実際にいろいろな値を変えたりすることで、 結果がどのように変わるのかを試してみることをお勧めします。

２次元物理シミュレーションPhysics2Dライブラリ各機能の使い方

ジョイントの設定

ジョイントの設定の例としてサンプルシーンJointSceneを見ていきます。
"sample/Physics2D/Physics2DSample/BasicScene/JointScene.cs"

ジョイントとは２つの剛体の間に設定する拘束のことです。２つの剛体間の拘束には並進方向と回転方向の拘束があります。
  1. 回転方向の拘束（回転が自由、固定、制約付き自由）
  2. 並進方向の拘束（並進移動が自由、固定、制約付き自由）
なお、Static剛体とStatic剛体の間のジョイントは意味を成さないため、設定をしないように気をつけてください。
ジョイント接続においては、どの点で剛体と剛体を接続するかのアンカーポイントの設定と、
回転方向の拘束の指定、および、並進方向の拘束の指定が必要になります。

回転方向の拘束とは、ジョイントで結合された剛体Ａと剛体Ｂがアンカーポイントを中心として、

  • 自由に回転できる
  • 完全に固定されている
  • 角度制約の範囲内で自由に回転できる

を設定します。

並進方向の拘束とは、ジョイントで結合された剛体Ａと剛体Ｂがアンカーポイントを中心として、

  • 自由に移動できる
  • 完全に固定されている
  • 移動制約の範囲内で自由に移動できる

を設定します。

並進方向の拘束にはお互いに直行する２つの軸に対して設定を行います。通常はX軸とY軸に対して指定しますが、
X軸とY軸でなくとも、お互いに直行する２つの軸であれば設定できます。例えばVector2(1, 1)の方向とVector2(-1, 1)の方向。

回転方向、並進方向ともに固定の例

public override void InitScene ()
{

        ...
        ...
        ...

        // Link a box rigid body to the scene with a fixed joint.
        // If you just want to fix a rigid body to the scene perfectly, it is best simply making a static rigidbody.
        {
                sceneBodies[numBody] = new PhysicsBody(sceneShapes[2], 10.0f);
                sceneBodies[numBody].position = new Vector2(-30.0f, 0.0f);
                sceneBodies[numBody].shapeIndex = 2;
                numBody++;

                PhysicsBody b1 = sceneBodies[0];
                PhysicsBody b2 = sceneBodies[numBody-1];
                sceneJoints[numJoint] = new PhysicsJoint(b1, b2, (b2.position), 0, (uint)numBody-1);
                sceneJoints[numJoint].axis1Lim = new Vector2(1, 0);
                sceneJoints[numJoint].axis2Lim = new Vector2(0, 1);
                sceneJoints[numJoint].angleLim = 1;
                numJoint++;
        }
ここでは0番目の剛体と(numBody-1)番目の剛体の間にジョイントを生成しています。0番目の剛体はシーン内の床のStatic剛体です。

ジョイントの生成方法としては、ジョイントを作る剛体ペアの指定と、アンカーポイントの指定が必要になります。
PhysicsBody b1 = sceneBodies[0];
PhysicsBody b2 = sceneBodies[numBody-1];
sceneJoints[numJoint] = new PhysicsJoint(b1, b2, (b2.position), 0, (uint)numBody-1);
ここでアンカーポイントは(b2.position)と指定しているので、(numBody-1)番目の剛体の中心をアンカーポイントにしています。
ジョイントを生成した後に拘束条件の指定をしている部分が以下です。
sceneJoints[numJoint].axis1Lim = new Vector2(1, 0);
sceneJoints[numJoint].axis2Lim = new Vector2(0, 1);
sceneJoints[numJoint].angleLim = 1;
  1. Vector2(1, 0)方向を固定
  2. Vector2(0, 1)方向を固定
  3. 回転方向を固定

の順で指定が行われています。

ここで仮に

sceneJoints[numJoint].angleLim = 0;

と指定していたなら、回転方向は自由になります。

同様に仮に

sceneJoints[numJoint].axis1Lim = new Vector2(0, 0);

と指定していたなら、X軸方向の拘束がなくなり自由移動になります。

同様に仮に

sceneJoints[numJoint].axis2Lim = new Vector2(0, 0);

と指定していたなら、Y軸方向の拘束がなくなり自由移動になります。

もしも仮に

sceneJoints[numJoint].axis1Lim = new Vector2(0, 0);
sceneJoints[numJoint].axis2Lim = new Vector2(0, 0);
sceneJoints[numJoint].angleLim = 0;

とするならば、ジョイントの拘束条件を何も指定していないことになるので、ジョイントを設定していないのと同じになります。

回転方向における角度制約の例

public override void InitScene ()
{

...
...
...

        // Link a box rigid body to the scene with a rotation joint（with angle constraints)
        {
                sceneBodies[numBody] = new PhysicsBody(sceneShapes[2], 10.0f);
                sceneBodies[numBody].position = new Vector2(-20.0f, 0.0f);
                sceneBodies[numBody].shapeIndex = 2;
                numBody++;

                PhysicsBody b1 = sceneBodies[0];
                PhysicsBody b2 = sceneBodies[numBody-1];
                sceneJoints[numJoint] = new PhysicsJoint(b1, b2, (b2.position), 0, (uint)numBody-1);
                sceneJoints[numJoint].axis1Lim = new Vector2(1, 0);
                sceneJoints[numJoint].axis2Lim = new Vector2(0, 1);
                sceneJoints[numJoint].angleLim = 1;
                sceneJoints[numJoint].angleLower = PhysicsUtility.GetRadian(-45.0f);
                sceneJoints[numJoint].angleUpper = PhysicsUtility.GetRadian(45.0f);
                numJoint++;
        }

-45度から45度の制約付き角度制限を行っているのは以下の部分です。

sceneJoints[numJoint].angleLim = 1;
sceneJoints[numJoint].angleLower = PhysicsUtility.GetRadian(-45.0f);
sceneJoints[numJoint].angleUpper = PhysicsUtility.GetRadian(45.0f);
回転方向の制限がかかっていますが、angleLimだけでなくangleLowerとangleUpperも指定されており、
それぞれ-45度と45度が指定されています。angleLowerとangleUpperは角度制限の下限と上限を設定する変数です。
なお、角度はラジアンで指定する必要があります。

垂直方向における移動制約の例

public override void InitScene ()
{

...
...
...

        // Link a box rigid body to the scene with a horizontal slider joint (with movement constraints)
        {
                sceneBodies[numBody] = new PhysicsBody(sceneShapes[2], 10.0f);
                sceneBodies[numBody].position = new Vector2(0.0f, 0.0f);
                sceneBodies[numBody].shapeIndex = 2;
                numBody++;

                PhysicsBody b1 = sceneBodies[0];
                PhysicsBody b2 = sceneBodies[numBody-1];
                sceneJoints[numJoint] = new PhysicsJoint(b1, b2, (b2.position), 0, (uint)numBody-1);
                sceneJoints[numJoint].axis1Lim = new Vector2(1, 0);
                sceneJoints[numJoint].axis2Lim = new Vector2(0, 1);
                sceneJoints[numJoint].axis2Lower = -10.0f;
                sceneJoints[numJoint].axis2Upper = 10.0f;
                sceneJoints[numJoint].angleLim = 1;
                numJoint++;
        }

-10mから+10mまでのＹ軸方向の制約付き拘束を行っているのは以下の部分です。

sceneJoints[numJoint].axis2Lim = new Vector2(0, 1);
sceneJoints[numJoint].axis2Lower = -10.0f;
sceneJoints[numJoint].axis2Upper = 10.0f;
Y軸方向の拘束がありますが、axis2Limだけでなく、axis2Lowerとaxis2Upperも指定されています。
これによりアンカーポイントより-10mから+10mまではY軸方向に制約付きで自由に動けるようになっています。
axis2Lowerとaxis2Upperは並進移動制限の下限と上限を設定する変数です。

水平方向における移動制約の例

public override void InitScene ()
{

...
...
...

// Link a box rigid body to the scene with a horizontal slider joint (with movement constraints)
{
        sceneBodies[numBody] = new PhysicsBody(sceneShapes[2], 10.0f);
        sceneBodies[numBody].position = new Vector2(0.0f, 0.0f);
        sceneBodies[numBody].shapeIndex = 2;
        numBody++;

        PhysicsBody b1 = sceneBodies[0];
        PhysicsBody b2 = sceneBodies[numBody-1];
        sceneJoints[numJoint] = new PhysicsJoint(b1, b2, (b2.position), 0, (uint)numBody-1);
        sceneJoints[numJoint].axis1Lim = new Vector2(1, 0);
        sceneJoints[numJoint].axis1Lower = -10.0f;
        sceneJoints[numJoint].axis1Upper = 10.0f;
        sceneJoints[numJoint].axis2Lim = new Vector2(0, 1);
        sceneJoints[numJoint].angleLim = 1;
        numJoint++;

    // The horizontal slider joint is quite slippy,
    // so to make the rigid body stop we add some air friction
        b2.airFriction = 0.01f;
}

垂直方向における移動制約の例と同様に水平方向の移動制約の設定を行っています。

sceneJoints[numJoint].axis1Lim = new Vector2(1, 0);
sceneJoints[numJoint].axis1Lower = -10.0f;
sceneJoints[numJoint].axis1Upper = 10.0f;
これによりアンカーポイントより-10[m]から+10[m]まではX軸方向に制約付きで自由に動けるようになっています。

ここで水平方向に制約付きで移動を許可した場合、水平方向には重力がかからないため、水平方向に動いている物体がなかなか静止しない
ということが生じる可能性があるため、空気抵抗を剛体に与えるように設定しています。

// The horizontal slider joint is quite slippy,
// so to make the rigid body stop we add some air friction
b2.airFriction = 0.01f;
(numBody-1)番目の剛体に対して空気抵抗係数0.01fを与え、空気抵抗によって水平方向に微小に滑り続けるのを防止しています。


アプリ内課金

この文書ではアプリ内課金について説明します。

Contents

  • アプリ内課金とは
    • プロダクトとは
    • チケットとは
  • エンドユーザーから見た購入の流れ
  • プログラム処理の流れ
  • 開発の手順
    • 1. Publishing Utilityでプロダクトのデータを作成する
    • 2. PSMアプリに課金処理を実装する
    • 3. マスターパッケージの作成と提出
    • 4. DevPortalでプロダクトに価格を設定する
  • 購入フローの実装
    • 通常型プロダクトの例
    • 消費型プロダクトの例
    • エラー処理について
    • ユーザーへの通知について

アプリ内課金とは

アプリ内課金とは、PSMアプリ内でエンドユーザーが有料のコンテンツ(以下、プロダクト)を購入する仕組みをいいます。

プロダクトとは

プロダクトとは、エンドユーザーが有料で購入するコンテンツのことをいいます。

プロダクトの例 : 回復ドリンクや薬草などのアイテム、ゲーム内の架空貨幣、体験版アプリを正式版に更新する権利、壁紙、追加ステージ、追加キャラクタなど。

プロダクトには通常型、消費型の2種類があります。

  • 通常型は、購入は一度のみで、消費することはできません。
  • 消費型は、プロダクトを消費することが可能です。何度でも購入できます。

チケットとは

チケットとは、エンドユーザーが購入によって得た、プロダクトの使用権のことをいいます。チケットはソフトウェア的なデータとしてPSMアプリに保持されます。

エンドユーザーから見た購入の流れ

エンドユーザーは以下のようにしてプロダクトを購入します。

サンプル sample/Services/InAppPurchaseSample2 を開いてください。

  1. プロダクトを選択する。

  2. 決定してプロダクトを購入する。

プログラム処理の流れ

アプリ内課金のプログラム処理は、InAppPurchaseDialogクラスを利用して行います。

以下、処理の流れを説明します。

  1. InAppPurchaseDialogクラスのインスタンスを作成します。

インスタンス作成時、app.info(app.xml)に記述されているプロダクトのラベルや名前など(後述)がインスタンスに読み込まれます。

図1

  2. InAppPurchaseDialog.GetProductInfo()を使い、価格などプロダクト情報を弊社のサーバーから取得します。

    図2

  3. InAppPurchaseDialog.GetTicketInfo()を使い、購入ずみのチケット情報を弊社のサーバーから取得します。

    図3

  4. InAppPurchaseDialog.Purchase()を使い、指定のプロダクトを購入します。

プロダクトを購入すると、プロダクトに対応するチケットがOkになり、そのプロダクトを使用できるようになります。

図4

  5. 消費型のプロダクトの場合、InAppPurchaseDialog.Consume()を使い、指定のプロダクトを消費します。

消費型のプロダクトの使用状態は、チケット内では数値で保持されています。

図5

開発の手順

アプリ内課金をPSMアプリに実装する場合、以下の手順で作業を行います。

1. Publishing Utilityでプロダクトのデータを作成する

まずPublishing Utilityでプロダクトのデータを作成します。

  1. Publishing Utilityは [スタートメニュー] - [すべてのプログラム] - [PlayStation Mobile] - [Publishing Utility]から起動してください。

プロダクトデータの設定については、 Publishing Utilityの使い方 を参照してください。

なお、価格の設定はPublishing Utilityでなく、後述のDevPortalで行います。

  2. 編集したapp.xmlを保存します。
app.xml
<purchase>
    <product_list>
        <product label="SWD001" type="normal">
            <name>
                <localized_item locale="en-US" value="sword" />
                <localized_item locale="ja-JP" value="刀" />
            </name>
        </product>

        <product label="MONY01" type="consumable">
            <name>
                <localized_item locale="en-US" value="100gold" />
                <localized_item locale="ja-JP" value="金１００" />
            </name>
        </product>
    </product_list>
</purchase>

プロジェクトのビルド時に、app.xmlが自動的にapp.infoに変換されます。

2. PSMアプリに課金処理を実装する

サンプル sample/Services/InAppPurchaseSample、sample/Services/InAppPurchaseSample2 を参考にして課金処理を実装してください。

3. マスターパッケージの作成と提出

マスターパッケージを作成し、弊社に提出します。

マスターパッケージの作成は、 マスターの作成と提出 概要 を参照してください。

4. DevPortalでプロダクトに価格を設定する

弊社のWebサイトDevPortalにアクセスし、プロダクトの価格を設定します。

購入フローの実装

通常型プロダクトの例

一度購入すれば何度でも利用できるアイテムなど、通常型プロダクトの購入フローは、たとえば以下のように実装することができます。

  • アプリ内課金のための、専用のシーンを用意する。
  • ユーザーの操作にしたがって、アプリ内課金のシーンに移動する。
  • アプリ内課金のシーンのみで、アプリ内課金ダイアログにアクセスする。
  • 購入ずみ確認または購入処理が成功したとき、アイテムを利用可能にする。
  • なんらかのエラーが発生した場合は、エラーを表示して前のシーンに移動する。

この方法には以下の利点があります。

  • アプリ内課金ダイアログの管理が、簡単に実装できる。
  • エラーが発生した場合、ユーザー操作で簡単にリトライできる。
  • ネットワーク接続できれば、別のデバイスでも購入ずみアイテムを利用できる。

しかし以下の点に注意が必要です。

  • 購入ずみアイテムを利用する場合でも、ネットワークアクセスが必要。
  • ネットワーク接続できない場合は、購入ずみアイテムでも利用できない。

ネットワーク接続できない状態でも購入ずみアイテムを利用できるようにするために、セーブデータを使用して実装することが推奨されます。

  • 購入ずみアイテムの情報を、セーブデータに保存する。
  • ユニーク ID を使用して、セーブデータを暗号化する。

セーブデータを暗号化することで、ある程度不正コピーを防ぐことができます。ユニーク ID はアカウント情報から取得することができます (Sce.PlayStation.Core.Services AccountInformation)

消費型プロダクトの例

何度でも購入できその数に応じて利用できるコインなど、消費型プロダクトの購入フローは、たとえば以下のように実装することができます。

  • 通常型プロダクトと同様に、アプリ内課金のための専用のシーンを用意する。
  • ユーザーの操作にしたがって、アプリ内課金のシーンに移動する。
  • アプリ内課金のシーンのみで、アプリ内課金ダイアログにアクセスする。
  • Purchase と Consume を実行してそれらが成功したら、コイン数を増やす。
  • なんらかのエラーが発生した場合は、エラーを表示して前のシーンに移動する。

この方法ではセーブデータを使用することが必要です。

  • 購入ずみコイン数の情報を、セーブデータに保存する。
  • ユニーク ID を使用して、セーブデータを暗号化する。

なお以下の点に注意が必要です。

  • 通常型プロダクトと異なり、別のデバイスでは購入ずみコインを利用できない。
  • Purchase と Consume を実行する必要があり、エラー処理がやや複雑。

エラー処理について

開発者環境ではアプリ内課金のエラーをシミュレートすることができます。アプリ内課金ダイアログの "OK" "Cancel" "Error" ボタンを使用してアプリの挙動に問題がないことを確認してください。

以下のケースのエラー処理は、とくに注意が必要です。

  • ネットワークエラーが発生して、長時間ネットワークが復旧しないケース。
  • ネットワークエラーが発生したが、サーバーの処理は成功しているケース。

長時間ネットワークが復旧しないケースでは、もし自動的にアプリ内課金のリトライを実行すると、アプリケーションが進行不能になる可能性があります。そのため、ユーザーの操作にしたがってリトライを実行することが推奨されます。

またネットワークエラーが発生すると、サーバー処理の成否が不確定になる可能性があります。通常型プロダクトについては、ネットワークが復旧しさえすれば正確に情報を更新できますが、消費型プロダクトについては、購入処理前後の状態の比較が必要となる場合があります。そのため、購入処理中のチケット状態をセーブデータに保存することが理想的です。このケースは、PC シミュレータ上のアプリ内課金ダイアログの "Abort" ボタンでシミュレートすることができます。

ユーザーへの通知について

商品の情報と購入の結果は、なるべく明確にユーザーに通知してください。

  • 商品リストに関する、ある程度の情報
  • 商品内容に関する、ある程度の情報
  • 各商品について、購入ずみ／未購入の表示
  • 購入を開始する場合の、予告表示
  • 購入が成功した場合の、結果表示
  • 購入が失敗した場合の、エラー表示


PlayStation(R)Mobileシミュレータについて

ここではPlayStation(R)Mobileシミュレータ上で開発する際の注意点を解説します。

Contents

  • 概要
  • 入力デバイス
  • スクリーンの解像度を変えるには
  • 制限事項
  • キー割り当て一覧

概要

PlayStation(R)Mobileシミュレータは、PSMアプリをWindows上で実行するプロトタイプ開発環境です。

PSMアプリを実機で動作させる前にシミュレータで動作を確認することで、開発を効率的に進めることができます。

入力デバイス

シミュレータ上では、キーボードを使用することにより GamePad の機能を実現しています。

GamePad クラスを利用する場合、割り当てられているキーを押下することにより GamePadButtons の入力情報を取得することができます。

スクリーンの解像度を変えるには

シミュレータのスクリーン解像度を変えるには、ツールバーにある画面解像度プルダウンメニューを使用してください。

現在のバージョンでは 960x544, 800x480, 1280x800 が選択可能であり、デフォルトの解像度は 960x544 です。

制限事項

  • リモートデスクトップ上では動作しません。
  • モーションセンサーはサポートしていません。
  • マルチタッチには対応していません。マウスクリックによる一点タッチのみ対応しています。

キー割り当て一覧

ゲームパット上のキー | シミュレータ上のキー割り当て
方向キー 左 | カーソルキー：←
方向キー 上 | カーソルキー：↑
方向キー 右 | カーソルキー：→
方向キー 下 | カーソルキー：↓
□ボタン | Aキー
△ボタン | Wキー
○ボタン | Dキー
×ボタン | Sキー
SELECT ボタン | Zキー
START ボタン | Xキー
L ボタン | Qキー
R ボタン | Eキー


ビルドアクションについて

この文書ではビルドアクションについて説明します。

Contents

  • ビルドアクションとは
  • 埋め込みを指定したファイルの利用

ビルドアクションとは

ビルドアクションとは、プロジェクトに登録されたファイルに対して、ビルド時に実行する処理のことをいいます。

図1 右クリックでビルドアクションを設定する

図2 プロパティウィンドウでビルドアクションを設定する

PSM Studioでは、ファイルに次のビルドアクションを設定することができます。

ビルドアクション | 説明
Compile | ソースコードとしてコンパイルします。
Content | ファイルに変更は加えませんが、実機に転送を行います。
ShaderProgram | シェーダープログラムとしてコンパイルします。
None | ファイルに対して何も行いません。実機にも転送しません。
EmbeddedResource | ファイルをアセンブリに埋め込みます。
EmbeddedShaderProgram | シェーダープログラムとしてコンパイルし、アセンブリに埋め込みます。
PsmMetadata | app.xml に対し設定します。

以下のファイルをプロジェクトに登録する場合、自動的にビルドアクションが設定されます。

ファイル名が「osc.cfg」または 拡張子が「*.png, *.jpg, *.bmp, *.gif, *.dds, *.wav, *.mp3, *.mdx」のファイル。

ビルドアクションに "Content" が設定されます。

拡張子が「*.fcg, *.vcg, *.fp.cg, *.vp.cg」のファイル。

ビルドアクションに "ShaderProgram" が設定されます。

ファイル名が「app.xml」のファイル。

ビルドアクションに "PsmMetadata" が設定されます。

埋め込みを指定したファイルの利用

ビルドアクションに埋め込み(EmbeddedResourceまたはEmbeddedShaderProgram)を設定した場合、埋め込まれたファイルは次のようにして利用します。

sample/Tutorial/TutoLib/SimpleSprite.cs
private static ShaderProgram CreateSimpleSpriteShader()
{
    //@j 埋め込まれたファイル名。
    //@e Embedded file name.
    string resourceName = "TutoLib.shaders.SimpleSprite.cgx";

    Assembly resourceAssembly = Assembly.GetExecutingAssembly();
    if (resourceAssembly.GetManifestResourceInfo(resourceName) == null)
    {
        throw new FileNotFoundException("File not found.", resourceName);
    }

    //@j ファイルストリームの取得とメモリの確保。
    //@e Get filestream and allocate dataBuffer.
    Stream fileStream = resourceAssembly.GetManifestResourceStream(resourceName);
    Byte[] dataBuffer = new Byte[fileStream.Length];

    //@j ファイルをメモリに読み込む。
    //@e Read files into the dataBuffer.
    fileStream.Read(dataBuffer, 0, dataBuffer.Length);

    //@j メモリに配置されたデータを利用する。
    //@e use data.
    var shaderProgram = new ShaderProgram(dataBuffer);
    shaderProgram.SetUniformBinding(0, "u_WorldMatrix");

    return shaderProgram;
}

ここではEmbeddedShaderProgramでアセンブリに埋め込まれたファイルの読み込みを行っています。


アプリ開発の注意点

この文書ではPSMアプリを開発する上での注意点について説明します。

Contents

  • ネットワーク環境の差異について
  • ネットワークのプロキシ設定について
  • ファイル名の大文字小文字について
  • プログラム終了に関する注意
    • データを保存する際の工夫
    • Write() 一回でファイルを作成する
    • 保存データ作成時、前回の保存データを一時的にとっておく
    • PersistentMemory クラスを使用する
    • ハッシュ値を使って、破損を検出する

ネットワーク環境の差異について

HTTP や Socket などの API を使用して、携帯電話ネットワークにアクセスする場合は、以下の点にご注意ください。

  • 20MB を超えるファイルをダウンロードしない。

現在のところ、デバイスが Wifi と 携帯電話ネットワークのどちらを使用しているのかを取得する API が提供されていません。

この API については、今後の SDK で追加する予定です。

ネットワークのプロキシ設定について

PlayStation(R)Mobile シミュレータでネットワークに接続するアプリケーションは、必要に応じてプロキシの設定を行って下さい。

設定方法は、コントロールパネルにある「インターネットオプション」から「接続」タブを選択し、「LANの設定」から「プロキシ サーバー」の設定を行って下さい。

また、PlayStation(R)Mobile Simulatorは「自動構成」で設定された値は利用しません。プロキシを利用の際は「プロキシ サーバー」へ設定を行って下さい。

ファイル名の大文字小文字について

PSM アプリは様々なプラットフォーム上で動作するため、ファイル名の大文字小文字を区別する環境 (case-sensitive) と、大文字小文字を区別しない環境 (case-insensitive) の両方で動作するよう配慮してください。

両方の環境で動作させるには、ソースコード中で記述するファイル名と、ストレージに存在するファイル名の大文字小文字が一致するようにコーディングします。

例:

ストレージに存在する foo.txt ファイルを読む。

// A
StreamReader r = new StreamReader("Foo.txt");

// B
StreamReader r = new StreamReader("foo.txt");

case-insensitive な環境では、どちらもファイルの読み込みに成功しますが、case-sensitive な環境では A の記述だと読み込みに失敗します。そのため、B のように大文字小文字を一致させて記述してください。

プログラム終了に関する注意

PSMアプリは、システムから通知を受けることなく終了する場合があります。

例: PS Vitaで、PSボタンを押した後に、アプリを「はがす」動作を行った場合。

そのため、アプリケーションの実行が突然中断しても安全性を確保できるように、アプリケーションを実装してください。

データを保存する際の工夫

データを保存するとき、以下のいずれかの方法をとると、安全性を高めることができます。

Write() 一回でファイルを作成する

StreamWriterやBinaryWriterのWrite()は一度呼び出されると、アプリケーションの終了処理によって中断されることはありません。そのデータの書き出しを完全に完了するか、データの書き出しを全く行わないかの、いずれかの結果になります。

そのため、Write()を複数回呼び出してデータを書きだすのではなく、バッファにデータを確保した後で一度にデータを書きだす方法をとると、中途半端なデータを作成してしまう危険性を低くすることができます。

保存データ作成時、前回の保存データを一時的にとっておく

以下のような手順で、保存データを作成すると、安全性を高めることができます。

  1. 保存データを一時的なファイルとして作成する。
  2. 作成が完了してから、File.Move()で一時的なファイルを正式な保存データに置き換える。

PersistentMemory クラスを使用する

PersistentMemory は、アプリケーションが使用できる不揮発性のメモリ領域です。

PersistentMemory に保存されたメモリー内容は、次回アプリケーション起動時に自動的に復元されるため、アプリケーション動作中に逐一 PersistentMemory にアプリケーションの状態を保存しておき、次回アプリケーション起動時にその内容から前回アプリケーション終了時の状態を復元する、などの使い方ができます。

しかし、アプリケーション実行中にシステムの予期せぬ異常終了が発生した時など、特定の場合において PersistentMemory の内容は初期化されることがあります。 そのため、アプリケーションの進行状況など、失われることでユーザーに大きな損失となるような情報は、セーブデータとして Documents/* 配下に保存してください。

PersistentMemory にセーブデータと依存のある情報を配置する場合は、PersistentMemory が失われてしまう場合の対策として、同じ情報をセーブデータ側でも持つようにし、アプリケーション起動時や動作中の適切なタイミングで Persistent Memory とセーブデータの情報の同期をとるようにすることをおすすめします。

ハッシュ値を使って、破損を検出する

保存データにハッシュ値を保持しておくと、ロード時に破損を検出することができます。

以下は実装例です。3つのランキングデータとハッシュ値のWrite/Readを行っています。

using System.IO;
...
const string SAVE_FILE = "/Documents/savedata.dat";
const string TEMP_FILE = "/Documents/temp.dat";

const Int32 numOfRanking=3;
Int32[] ranking=new Int32[numOfRanking];

void SaveData()
{
    Console.WriteLine("==SaveData()==");

    ranking[0]=10000;
    ranking[1]=9000;
    ranking[2]=8000;

    int bufferSize=sizeof(Int32)* (numOfRanking+1);
    byte[] buffer = new byte[bufferSize];

    Int32 sum=0;
    for(int i=0; i<numOfRanking; ++i)
    {
        Console.WriteLine("ranking[i]="+ranking[i]);
        Buffer.BlockCopy(ranking, sizeof(Int32)*i, buffer, sizeof(Int32)*i, sizeof(Int32));
        sum+=ranking[i];
    }

    Int32 hash=sum.GetHashCode();
    Console.WriteLine("sum={0},hash={1}",sum,hash);

    Buffer.BlockCopy(BitConverter.GetBytes(hash), 0, buffer, numOfRanking * sizeof(Int32), sizeof(Int32));

    using (System.IO.FileStream hStream = System.IO.File.Open(@TEMP_FILE, FileMode.Create))
    {
        hStream.SetLength((int)bufferSize);
        hStream.Write(buffer, 0, (int)bufferSize);
        hStream.Close();
    }

    if(File.Exists(@SAVE_FILE))
        File.Delete(@SAVE_FILE);

    File.Move(@TEMP_FILE, @SAVE_FILE);
}

bool LoadData()
{
    Console.WriteLine("==LoadData()==");

    if ( System.IO.File.Exists(@SAVE_FILE)==false &&  System.IO.File.Exists(@TEMP_FILE)==true)
    {
        File.Move(@TEMP_FILE, @SAVE_FILE);
    }

    if ( System.IO.File.Exists(@SAVE_FILE)==true )
    {
        using (System.IO.FileStream hStream = System.IO.File.Open(@SAVE_FILE, FileMode.Open))
        {
            if (hStream != null)
            {
                long size = hStream.Length;
                byte[] buffer = new byte[size];
                hStream.Read(buffer, 0, (int)size);

                Int32 sum=0;
                for(int i=0; i<numOfRanking; ++i)
                {
                    Buffer.BlockCopy(buffer, sizeof(Int32)*i, ranking, sizeof(Int32)*i,  sizeof(Int32));
                    Console.WriteLine("ranking[i]="+ranking[i]);
                    sum+=ranking[i];
                }

                Int32 hash=BitConverter.ToInt32( buffer, numOfRanking * sizeof(Int32) );

                hStream.Close();

                if(sum.GetHashCode()==hash)
                {
                    Console.WriteLine("Correct Data.");
                    return true;
                }
                else
                {
                    Console.WriteLine("Incorrect Data.");
                    return false;
                }
            }
        }
    }

    return false;
}


PSMアプリのフォルダー構成について

この文書ではPSMアプリのフォルダー構成について説明します。

Contents

  • 概要
  • フォルダーの種類と特徴
  • 制限事項

概要

  • PSMアプリ内のフォルダー構成は、以下のような構成になります。

例: \psm\sample\Graphics\TriangleSample

Application/
    app.exe
    SampleLib.dll
    app.info
    test.png
    shaders/
        VertexColor.cgx
Documents/
Temp/

※ 末尾の/はフォルダーを表します。

  • PSMアプリ内のフォルダー構成は、全てのプラットフォームで同じ構成が利用されます。
  • PSMアプリにパッケージするファイルは、Application/ フォルダーの中に配置する必要があります。

フォルダーの種類と特徴

PSMアプリ内のフォルダーは次のような特徴を持っています。

Application

/Application/ はアプリケーションの実行ファイル、リソースファイルなど、読み込み専用のファイルを配置するフォルダーです。

Documents

/Documents/ は永続的なファイルを配置するフォルダーです。このフォルダーに配置したファイルはPSMアプリを終了した後でも削除されずに残されます。

また、このフォルダーのファイルは読み込み・書き込みが可能です。

Temp

/Temp/ は、PSMアプリの起動の度に削除される、一時的なファイルを配置するフォルダーです。

このフォルダーのファイルは読み込み・書き込みが可能です。

制限事項

フォルダーは6段まで掘ることができます。それ以上は掘ることができません。


署名と暗号化の設定

この文書ではファイルの署名と暗号化について説明します。

Contents

  • コンテンツの保護について
  • 署名・暗号化の対象
  • PSM Studio での設定方法
  • 注意点

コンテンツの保護について

PSMの開発・実行環境では、コンテンツの保護のために、ファイルを署名・暗号化する処理を行っています。

署名・暗号化を行うことにより、ファイルの解析やデータの改竄、違法なコピーからコンテンツを保護することができます。

なお、署名・暗号化のプロセスは実機が対象です。PCシミュレータ上では行われません。

署名・暗号化の対象

アセンブリファイル (実行ファイル、dll) は必ず署名・暗号化されます。アセンブリファイルから署名・暗号化の設定を外すことはできません。

開発者が署名・暗号化の設定を選択できるのは次のファイルです。

  • 画像ファイル、音楽ファイル、テキストファイルなど。
  • シェーダープログラム (Plain は選択不可)

PSM Studio での設定方法

ファイルに対する署名・暗号化の設定は、以下の手順で行います。

  1. Solutionウィンドウでファイルを選択し、[右クリック] - [Properties] を選択し、プロパティウィンドウを開きます。

図1

  2. プロパティウィンドウの [PSM Option] - [Content Protection]から、次のいずれかを選択します。
List Item | 説明
Plain | ファイルに対して署名も暗号化も行いません。
Signed | ファイルに対して署名のみ行います。
SignedAndEncrypted | ファイルに対して署名と暗号化を行います。

注意点

署名・暗号化されたファイルの読み込み時間は、Plainのファイルに比べて若干長くなります。 読み込みにかかる時間は、SignedAndEncrypted > Signed > Plain の順です。

なお、処理時間に影響があるのはファイルの読み込み時のみです。メモリ上に展開されたデータにアクセスする時間には影響はありません。


PS3(TM)のワイヤレスコントローラドライバをインストールする

この文書ではPCシミュレータ上の開発でPS3(TM)のワイヤレスコントローラを利用する方法を説明します。

Contents

  • 概要
  • インストール
  • アンインストール
  • トラブルシューティング

概要

ワイヤレスコントローラドライバ for Windowsは、PS3(TM)のワイヤレスコントローラをWindows環境で使用するためのドライバです。本ドライバをインストールすることにより、Windows PCにワイヤレスコントローラを接続し、USBゲームコントローラとして使用できるようになります。

※ 現在、ワイヤレスコントローラをサポートしているのはPCシミュレータのみです。

インストール

以下の手順でワイヤレスコントローラドライバをインストールしてください。

  1. ワイヤレスコントローラをUSBケーブルでPCに接続してください。
  2. [コントロールパネル] - [システム] を開き、[ハードウェア]タブの[デバイスマネージャ]を開いてください。
  3. [ヒューマン インターフェース デバイス]のリストに列挙されている[USB ヒューマン インターフェイス デバイス]のプロパティを順に開き、[詳細]タブでハードウェアIDに次の文字列が含まれているデバイスを探してください。
USB\VID_054C&PID_0268
  4. 上で探したデバイスの[ドライバ]タブに移動し、[ドライバの更新]ボタンを押してください。
  5. ウィザードが起動するので、次のように操作してください。
  1. "いいえ、今回は接続しません"
  2. "一覧または特定の場所からインストールする(詳細)"
  3. "検索しないで、インストールするドライバを選択する"
  4. ("全てのデバイスを表示")
  6. ドライバの選択画面になるので、[ディスク使用]ボタンを押し、本ドライバのsixaxis.infがあるフォルダー %SCE_PSM_SDK%/tools/driver/sixaxis_driver/ を選択してください。
  7. モデル名に[Wireless controller for PlayStation(R)3]と表示されるので、選択して、次に進んでください。
  8. Windowsロゴテストに合格していない旨の警告が表示されますが、無視して[続行]してください。
  9. 以上でインストールの完了です。[コントロールパネル] - [ゲームコントローラ]を開いて、正しく動作していることを確認してください。

アンインストール

ワイヤレスコントローラドライバのアンインストールは、以下の手順で行ってください。

  1. ワイヤレスコントローラをPCから取り外してください。
  2. "C:/WINDOWS/system32/drivers/sixaxis.sys"を削除してください(Windowsを別のドライブにインストールした場合はパスが異なります)。
  3. レジストリエディタ等で、レジストリの以下のキーを削除してください。
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\Vid_054c&Pid_0268
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\sixaxis

トラブルシューティング

  • インストール処理が正しく終了せず、「デバイスをインストール中にエラーが発生しました。このINFのサービスインストールセクションは無効です。」などのエラーメッセージが表示される。

-> ドライバファイルsixaxis.sys（32bit版または64bit版）を以下のディレクトリに手動でコピーしてから、インストール手順を再試行してください。"C:/WINDOWS/system32/drivers" ("C:/WINDOWS"にWindowsをインストールしている場合)

-> ワイヤレスコントローラ SIXAXIS(TM)をPCから外し、背面のリセットスイッチを押してから接続し直してください(ワイヤレスコントローラ（DUALSHOCK 3）にはリセットスイッチはありません)。

  • ドライバがインストールされている状態で、ワイヤレスコントローラ SIXAXIS(TM)からの入力を認識しない。
  • デバイスマネージャで確認すると、デバイスは認識されているが「!」アイコンが表示され使用不可である。
-> ワイヤレスコントローラ SIXAXIS(TM)をPCから外し、背面のリセットスイッチを押してから接続し直してください(ワイヤレスコントローラ（DUALSHOCK 3）にはリセットスイッチはありません)。


鍵管理

この文書では、PSMアプリを実機上で実行するために必要な鍵の作成手順、および鍵の依存関係について説明します。

Contents

  • 鍵について
  • Publishing Utilityでの鍵の作成手順
    • 1. パブリッシャ鍵の作成
    • 2. デバイスシードの作成
    • 3. アプリ鍵の作成
  • 鍵の依存関係
    • 鍵の更新に関する注意事項
  • Application IDのアスタリスク指定
  • 補足事項
    • PSMアプリの実行に関する補足事項
    • パブリッシャ鍵の補足事項
    • デバイスシードの補足事項
    • アプリ鍵の補足事項
    • チーム開発での鍵管理

鍵について

この文書内で「鍵」とは、パブリッシャ鍵、デバイスシード、アプリ鍵を意味します。

実機でPSMアプリを実行するためには、次の手順で鍵を作成します。

  • パブリッシャ鍵を作成する。
  • 実行したい実機からデバイスシードを作成する。
  • 実行したいPSMアプリのApplicationIDを登録し、パブリッシャ鍵とデバイスシードをもとに、アプリ鍵を作成する。

※ 鍵の作成にはSony Entertainment Network(旧 PlayStation(R)Network) のアカウントと、パブリッシャライセンスが必要です。パブリッシャライセンスは弊社のサイト DevPortal で取得してください。

https://psm.playstation.net

Publishing Utilityでの鍵の作成手順

鍵の作成は、以下の手順でおこないます。

※ この手順で作成される鍵は、PSM Studioのメニュー - [Key] - [Update Device Seed and App Key] で自動作成されるものと同じです。

図1 鍵の作成手順

1. パブリッシャ鍵の作成

パブリッシャ鍵とは、パブリッシャライセンスを持つ人に割り当てられる鍵です。

パブリッシャ鍵の作成は以下の手順で行います。

  1. デスクトップ上の [Publishing Utility]のアイコンをダブルクリックしてPublishing Utilityを起動してください。

図2 Publishing Utility

  2. 鍵の作成時に弊社のサーバーと通信をおこなうため、PCをインターネットに接続しておきます。社内LAN環境などでプロキシサーバーを利用している場合、[メニュー] - [ファイル] - [プロキシサーバーの設定]を選択し、接続の設定をおこなってください。
  3. Publishing Utilityで[Key Management]パネルを選択し、[Generate Publisher Key]ボタンを押します。

図3 [Generate Publisher Key]ボタン

  4. 表示されるダイアログの指示に従って入力をおこなってください。
  5. 作成に成功すると、Key NameとDate of Creation の欄にパブリッシャ鍵のデータが表示されます。

2. デバイスシードの作成

デバイスシードとはアプリ鍵を作成するために使用されるデータです。デバイスシードはデバイスから取得し、デバイスごとに異なる値を持ちます。

デバイスシードの作成は以下の手順で行います。

  1. デバイスをUSBケーブルでPCに接続します。接続するとそのデバイスが[Device List & App Key]リストに表示されます。
  2. PS Vita上でDevAssistantを起動しておきます。
  3. 対象のデバイスを選択し、[Generate Device Seed]ボタンを押すと、デバイスシードの作成を開始します。

図4 デバイスシードの作成

  4. デバイスシードの作成に成功すると、[Seed]の列に種のアイコンが表示されます。

※ なお、デバイスシードを削除するには、デバイスシードを選択し、 [右クリック] - [Delete Device Seed]を選択して削除します。

3. アプリ鍵の作成

アプリ鍵はPSMアプリを実機で実行するために使用される鍵です。

  • アプリ鍵は各ApplicationIDと各デバイスごとに作成する必要があります。
  • アプリ鍵はパブリッシャ鍵とデバイスシード、PSMアプリのApplicationIDを元に作成されます。
  • アプリ鍵には「アプリ開発鍵」と「アプリ実行鍵」の２つがあります。アプリ鍵を作成すると、この２つが自動的に作成されます。
    • アプリ開発鍵はプロジェクトのビルド時に使用されます。
    • アプリ実行鍵は実機に転送され、PSMアプリの実行時に使用されます。

アプリ鍵の作成は以下の手順で行います。

  1. まず実機で実行したいPSMアプリのApplicationIDを登録します。鍵管理パネルの[+]ボタンを押してください。

図5 Application IDの登録

  2. ダイアログが表示されるので[...]ボタンを押し、PSMプロジェクトのapp.xmlを選択します。[OK]ボタンを押すとapp.xml内の Application ID がリストボックスに登録されます。

図6 Application ID

図7 プロジェクト内のapp.xmlを開く

  3. リストボックス内に表示されている ApplicationIDとデバイスを選択し、[Generate App Key]ボタンを押します。

図8 [Generate App Key]ボタン

  3. 表示されるダイアログの指示に従って入力をおこなってください。
  4. アプリ鍵の作成に成功すると[App Key]の列にアプリ鍵が表示され、作業完了です。

図9 App Key

  5. アプリ鍵作成後、ソリューションをリビルドしてください。以降、アプリ鍵が作成されているPSMアプリが、そのデバイス上で実行可能になります。

※ なお、アプリ鍵を削除するには、アプリ鍵を選択し [右クリック] - [Delete App Key]を選択して削除します。

鍵の依存関係

鍵の依存関係は以下の図のようになります。親の要素を更新した場合、依存関係をもつ子の要素を更新する必要があります。

図10 鍵の依存関係

鍵の更新に関する注意事項

  • パブリッシャ鍵・アプリ鍵・デバイスシードは、作成ごとに毎回違うものが作成されます。
  • 実機にインストールするDevAssistant のバージョンが更新されると、デバイスシード、アプリ鍵を再作成する必要があります。

例:

  • パブリッシャ鍵を作り直した。-> アプリ鍵を削除し、アプリ鍵を再作成します。
  • デバイスシードを作り直した。 -> アプリ鍵を削除し、アプリ鍵を再作成します。

Application IDのアスタリスク指定

Application IDにアスタリスク"*"を指定することで、複数のプロジェクトで使いまわしが可能なアプリ鍵を作成することができます。

アスタリスクのアプリ鍵を作成しておくと、PSMアプリごとにアプリ鍵をつくる手間を省くことができます。

※ ただし、マスターパッケージの作成時には"*"は使用できません。

※ 新しいソリューションを作成すると、Application IDはデフォルトで"*"に設定されています。

アスタリスクの指定は以下の手順で行います。

  1. Publishing Utilityを起動し、MetaDataタブを選択します。
  2. [メニュー] - [File] - [Load] で任意のapp.xmlを開きます。
  3. [Application ID] に [*] 一文字を入力し、セーブします。

図11 アスタリスクの指定

  4. 次に[Key Management]パネルを選択し、[+]ボタンを押します。

図12 ApplicationIDの登録ボタン

  5. 上記でアスタリスクを指定したapp.xmlを選択します。
  6. リストボックス内に表示されている ApplicationIDとデバイスを選択し、[Update Device Seed & App Key]ボタンを押します。
  7. アプリ鍵の作成に成功すると [App Key]列にアプリ鍵のアイコンが表示されます。以後、ApplicationIDに[*]が付けられたプロジェクトは、アプリ鍵を作成することなく、その実機でアプリを実行することができます。

図13 作成されたアプリ鍵

補足事項

PSMアプリの実行に関する補足事項

  • PSMアプリが実行可能な実機は、ひとつのSony Entertainment Networkアカウントにつき100台までです。

    • PS Vita で実行する場合、ひとつのSony Entertainment Networkアカウントにつき使用出来る台数の上限は2台までとなります。

      参考: http://manuals.playstation.net/document/jp/psvita/psn/aboutactivate.html

  • PCシミュレータで実行する場合、パブリッシャライセンスおよび鍵は必要ありません。

パブリッシャ鍵の補足事項

  • パブリッシャ鍵の作成は1度だけで構いません。SDKバージョンが更新されても継続して使用することができます。
  • パブリッシャ鍵に有効期限はありません。
  • パブリッシャ鍵は作成時にSCEサーバーに登録されます。
  • パブリッシャ鍵はひとつのSony Entertainment Networkアカウントに対して、最後に作成されたひとつのパブリッシャ鍵のみ有効です。
  • Sony Entertainment Networkアカウントとパブリッシャ鍵をチームで共有するときは、パブリッシャ鍵の上書きに注意してください。
例:
  1. 開発メンバーAが、SENアカウント P_team でパブリッシャ鍵 A_pub_key を作成。
  2. その後、開発メンバーBが、同じアカウントでパブリッシャ鍵 B_pub_keyを作成。このとき、B_pub_keyが有効になり、上書きされた A_pub_key は無効になります。またこのとき、パブリッシャ鍵 A_pub_keyで作成したアプリ鍵も無効になります。

この場合、開発メンバーBは パブリッシャ鍵 B_pub_key をエクスポートして、開発メンバーAに渡してください。

  • 開発者が保持するパブリッシャ鍵の有効性は、[Check Publisher Key]コマンドで確認することができます。
  • PSM Studio なら- [Menu] - [Key] - [Check Publisher Key]で実行。
  • Publishing Utilityなら - [Key Management]パネル - [Check Publisher Key]で実行。

デバイスシードの補足事項

  • DevAssistant の新しいバージョンをインストールした場合、それ以前に作成したデバイスシードは無効になります。デバイスシードを削除後、新しいデバイスシードを作成してください。

アプリ鍵の補足事項

  • アプリ鍵はSDKを再インストールすると使えなくなります。再インストール時、鍵を削除するダイアログが表示されるので、[はい]を選択して削除し、再作成してください。
  • アプリ鍵の有効期限は3ヶ月です。

チーム開発での鍵管理

複数人で鍵を運用する場合は、 チーム開発での鍵管理 をご覧ください。


チーム開発での鍵管理

この文書ではチーム開発での鍵の運用方法に関して説明します。

Contents

  • 用語の定義
  • 作業手順
    • 開発メンバーの手順 1
    • 管理者の手順
    • 開発メンバーの手順 2

用語の定義

管理者 ： ここでは、パブリッシャライセンスを購入し、Sony Entertainment Networkアカウント(以下SENアカウント)とそのパスワードを管理する人を管理者とよびます。

開発メンバー ： SENアカウントとパスワードをもたない人を開発メンバーと呼びます。

作業手順

開発メンバーの手順 1

  1. 開発メンバーのPCでPublishing Utilityを起動し、左側の[Key Management]パネルを選択します。

  2. PS Vitaの電源をONにし、USBケーブルでPCに接続してください。DevAssistant が起動されていない場合、PS Vitaのアイコンが灰色に表示されます。この時点ではデバイスシードを作成することはできません。

  3. DevAssistant を起動すると、PS Vitaのアイコンは黒に切りかわります。アイコンが黒い状態なら、デバイスシードを作成できます。

  4. デバイスリストでデバイスを選択し、[Generate Device Seed]ボタンを押すと、デバイスシードの作成を開始します。

  5. デバイスシードの作成に成功したら、[Export Device Seed]ボタンをクリックしてください。

  6. ニックネームの入力を求められるので、任意で入力してください。

  7. 適当な場所にデバイスシードをセーブします。

※ セーブ時、ファイル名は変更しないでください。

  8. 7でセーブしたデバイスシードのファイルを管理者に渡します。

管理者の手順

  1. 開発メンバーと共有したいPSMアプリのApplicationIDを登録します。[Key Management]パネルの[+]ボタンを押してください。

  2. ダイアログが開くので、共有したいプロジェクト内のapp.xmlを選択します。成功するとApplication IDリストにApplication IDが表示されます。

  3. [デバイスシードのインポート]を選択します。

  4. 開発メンバーのデバイスシードを選択してください。成功するとダイアログが表示されます。

  5. デバイスシードのインポートが完了すると以下のように表示されます。

  6. 次は、リスト内のApplicationIDとデバイスシードを選択し、[アプリ鍵の作成]ボタンを押します。

  8. OKを押し、Sony Entertainment Network IDとパスワードを入力します。

  9. アプリ鍵の作成に成功すると次のように表示されます。

  10. [パブリッシャ鍵のエクスポート]ボタンを押し、適当な場所にセーブします。

  11. [Export App Key Ring]ボタンを押し、適当な場所にセーブします。
  12. パブリッシャ鍵とアプリ鍵束を開発メンバーに渡します。

開発メンバーの手順 2

  1. 管理者から渡されたパブリッシャ鍵をインポートします。

  2. 管理者から渡されたアプリ鍵束をインポートします。

  3. 作業が完了すると次のように表示されます。

  4. PSM Studioでプロジェクトを開き、リビルドします。

  5. 以上の作業で、PSMアプリを実機で実行することができます。

※ パブリッシャ鍵やデバイスシードを更新すると、鍵の整合性がとれなくなり、実行時にエラーが発生するのでご注意ください。パブリッシャ鍵やデバイスシードを更新した場合、アプリ鍵束を削除し、鍵を再作成してください。


アンインストールについて

この文書ではアンインストールについて説明します。

Contents

  • PSM SDKのアンインストール
  • その他ソフトウェアのアンインストール

PSM SDKのアンインストール

PSM SDKをアンインストールする場合、[スタートメニュー ] - [すべてのプログラム] - [PlayStation(R)Mobile] - [Uninstall]を選択するか、[コントロールパネル] - [プログラムと機能](Windows 7の場合)からアンインストールしてください。

なお、開発者が作成したフォルダーとファイルは削除されません。アンインストール後にフォルダーやファイルが残っている場合、手動で削除してください。

その他ソフトウェアのアンインストール

PSM SDKのインストール時、開発用PCに以下のソフトウェアがインストールされていない場合、これらのソフトウェアをインストールしています。

  • .NET Framework 4
  • Visual C++ 2010 Redistributable
  • Gtk# 2.12.25
  • DirectX

PSM SDKをアンインストールしても、これらのソフトウェアはアンインストールされません。

これらのソフトウェアのアンインストールを行う場合、他のアプリケーションで使われていないことを確認の上、[コントロールパネル] - [プログラムと機能]でアンインストールしてください。


トラブルシューティング

この文書では、開発上よく発生するトラブルとその解決方法について説明します。

Contents

  • PCとPS Vitaの通信ができなくなった
  • PSM Studio
    • PSM Studioが起動できない
  • PSMアプリの実行
    • PlayStation(R)Vita 上でのアプリケーションの実行に失敗する
  • Publishing Utility
    • デバイスシードの作成に失敗する (PlayStation(R)Vita)
    • アプリ鍵の作成に失敗する

PCとPS Vitaの通信ができなくなった

PCとPS Vitaの通信ができなくなった場合、次の確認と対処をおこなってください。

確認事項

  • PCとPS Vitaが付属のUSBケーブルで正しく接続されてるか。
  • PS Vita上でPSM DevAssistantが起動しているか。
  • PS VitaのデバイスドライバがPCに正しくインストールされているか。

なお、デバイスドライバは以下の手順で確認できます。

  1. [コントロールパネル] - [デバイスマネージャ]を開きます。
  2. PSM DevAssistantを起動していない状態なら、[ポータブルデバイス]にPlayStation(R)Vitaが表示されます。
  3. PSM DevAssistantを起動している状態なら、[ポート(COMとLPT)]にPSM USB Debug(COM1～256)が表示されます。

対処

  1. PS VitaでPSM DevAssistantを終了させます。
  2. PCでPSM Studio、Publishing Utilityを終了させます。
  3. PCでPsmDevice.exeを終了させます。
  • Ctrl+Shift+Escキーを押し、タスクマネージャを開きます。
  • [プロセス]タブを選択します。
  • [イメージ名]内のPsmDevice.exeを選択し、[プロセスの終了]をおこなってください。

PSM Studio

PSM Studioが起動できない

開発用PCに複数のGTK#がインストールされていると、PSM Studioが起動しないことがあります。

PSM Studioの起動に失敗する場合、以下の事項について確認してください。

回避方法

  • GTK# 2.12.25以外のGTK#をアンインストールし、C:/Program Files (x86)/SCE/PSM/software/gtk-sharp-2.12.25.msiに配置されているGTK# 2.12.25を再びインストールしてください。
  • 環境変数PATHに記述されているGTK#へのパス C:/Program Files (x86)/GtkSharp/2.12/bin を以前のバージョンのパスより前に移動させてください。

例:

環境変数PATH修正前

C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\GtkSharp\1.00\bin;C:\Program Files (x86)\GtkSharp\2.12\bin

修正後

C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\GtkSharp\2.12\bin;C:\Program Files (x86)\GtkSharp\1.00\bin;

PSMアプリの実行

PlayStation(R)Vita 上でのアプリケーションの実行に失敗する

PlayStation(R)Vita 上でのアプリケーションの実行に失敗した場合、以下のようなダイアログまたはエラーメッセージが表示されます。

  • "An error has occurred. [16進数エラーコード]"

主に発生しうるエラーダイアログの内容を以下に記載します。

  • "Failed to connect the network." ... ネットワーク接続が確立できず、SCEの認証サーバーへのアクセスに失敗した。
  • "Failed the authentication to execute application. Please re-create a Device Seed and App Key using with PSM Studio or Publishing Utility." ... アプリケーションを実行する際の鍵の認証に失敗した。デバイスシード及びアプリ鍵の再作成が必要です。

Publishing Utility

デバイスシードの作成に失敗する (PlayStation(R)Vita)

PlayStation(R)Vitaでデバイスシードの作成に失敗する場合、以下の事項について確認してください。

  • PlayStation(R)Vita用PSM DevAssistantがPS Vitaにインストール、および起動されていること。

上記を実行しても症状が改善しない場合、Windows タスクマネージャから以下のプロセスを一度終了して、再度実行してください。

  • PsmDevice.exe
  • PsmStudio.exe
  • PublishingUtility.exe

アプリ鍵の作成に失敗する

アプリ鍵の作成に失敗する場合、以下の事項について確認してください。

  • サーバーに登録されているパブリッシャ鍵と開発用PC上に配置しているパブリッシャ鍵が同一であること。

回避方法

Publishing Utility を用いて、パブリッシャ鍵を作成しなおしてください。

作成し直すことで、サーバーに登録されているパブリッシャ鍵も同時に更新されるため、 チームで同一のSony Entertainment Networkアカウントを使用している場合、作成しなおした鍵を再配布する必要があるので、ご注意ください。


UI Toolkit について

UI Toolkit は、PSM 上でユーザーインターフェース (UI) を作成するための仕組みや部品(Widget)をまとめたライブラリとツールです。ボタンやテキストといった汎用的なWidget(図1)に加え、PSM独自のWidgetも用意しており、それぞれカスタマイズして利用できます。

図1 UI Toolkit で利用できるWidgetの例

UI Toolkit プログラミングガイドでは、UI Tookit を利用したアプリケーションの実装方法について解説しています。


UI Composer について

UI Composer は、UI Toolkitを利用したユーザーインターフェースを簡単に作成するためのツールです。このツールを利用することで、デバイスの画面上に表示させるUI部品のレイアウトやプロパティの指定などを行うことができます。ツールは、レイアウトやプロパティ指定に関する情報をC#のソースコードとして出力することが可能です(図2)。

図2 UI Composerを利用したUI開発の流れ

UI Composer ユーザーガイドで詳細な利用方法を解説しています。


はじめに

Contents

  • UI Toolkit とは？
  • 他のライブラリとの関係
  • UI Composer との連携
  • ファイル構成

UI Toolkit とは？

UI Toolkit は、PSM 上でユーザーインターフェース (UI) を作成するための仕組みや部品をまとめたライブラリです。 ゲームのメニューやヘッドアップディスプレイで利用したり、UI Toolkit 単独でもゲーム以外の一般的なアプリケーションも構築できるように設計・実装されています。

UI Toolkit の主要機能は下記の通りです。

  • UI部品(Widget)
  • アニメーション効果(Effect, Transition)
  • タッチ入力のジェスチャ解析
  • 画像アセットの管理
  • UI部品の 3D シーングラフ
  • ゲームと組み合わせた描画

Widget や Effect、Transition には、標準的な部品や効果に加えて、PSM 独自のものも用意しています。

他のライブラリとの関係

UI Toolkit は、Sce.PlayStation.Core ライブラリの上位に位置するライブラリで、Sce.PlayStation.Core ライブラリと Mono の標準ライブラリにのみ依存します(図1)。

図1 PSM のアセンブリスタック

UI Composer との連携

UI Toolkit には、レイアウトを行うツール UI Composer が付属しています。このツールを利用することで、ボタンやテキストなどの Widget のレイアウトやプロパティ設定、多言語対応など、UI 画面のデザイン作業を効率よく進めることが可能になります。 ツールで作業した結果は C# のソースコードとして出力され、ゲームやアプリケーションのプロジェクトに簡単に取り込むことが可能です(図2)。

図2 UI Composer を利用した UI 開発の流れ

ファイル構成

UI Toolkit のアセンブリ、サンプルプログラム、ソースコード、既定の画像アセットはそれぞれ標準で下記の場所にあります。

  • アセンブリ

    • Windows 7/8 32-bit: "C:/Program Files/SCE/PSM/mono/lib/psm/Sce.PlayStation.HighLevel.UI.dll"
    • Windows 7/8 64-bit: "C:/Program Files (x86)/SCE/PSM/mono/lib/psm/Sce.PlayStation.HighLevel.UI.dll"

  • サンプル

    • Windows 7/8: "C:/Users/Public/Documents/PSM/sample/UI/"

  • アセンブリのソースコード

    • Windows 7/8: "C:/Users/Public/Documents/PSM/source/UI/"


クイックスタート

ここでは UI Toolkit を使用したもっとも簡単なアプリケーションの作成方法から動作確認までを解説します。

開発には PSM SDK 付属の PSM Studio を使用します。 事前に 開発環境の設定 を参照して PSM Studio の開発環境を設定してください。

Contents

  • プロジェクトの作成
  • UI Toolkit のコードを記述
  • 実行とデバッグ

プロジェクトの作成

PSM SDK 付属の PSM Studio には、 UI Toolkit アプリケーションを作成するためのプロジェクトテンプレートが用意されています。このテンプレートを使用してプロジェクトを作成します。

制限事項

現在、UI Toolkit アプリケーションのテンプレートは準備中です。以下の手順で UI Toolkit アプリケーションの プロジェクトを作成してください。

  • PSM Studio を起動します。

  • PSM Studio のメインメニューから [ファイル] ([File]) > [新規] ([New]) > [ソリューション...] ([Solution...]) を選択してください(図1)。

    図1 ソリューションの新規作成

  • [新しいソリューション] ([New Solution]) ダイアログで [C#] - [PlayStation Mobile] - [PlayStation Application] を選択し、任意のプロジェクト名を入力して [OK] を選択して新しい PSM アプリケーションのソリューションを作成してください(図2)。

    図2 ソリューションの新規作成ダイアログ

  • 次に、参照するアセンブリを追加します。PSM Studio のソリューションパネルの[参照] ([References]) を右クリックし、[参照アセンブリの編集...] ([Edit References...]) を選択してください (図3)。

    図3 参照するアセンブリの追加

  • [Edit References] ダイアログで [Packages] タブを選択し、[Sce.PlayStation.Highlevel.UI] のチェックボックスを有効にしてください(図4)。

    図4 参照するアセンブリを追加した後のソリューション構成

  • AppMain.cs を開き以下のコードを上書きしてください。

    • これが UI Toolkit を使用する最低限のコードになります。
    • このコードを適宜カスタマイズして使用してください。
    using System;
using System.Collections.Generic;

using Sce.PlayStation.Core;
using Sce.PlayStation.Core.Environment;
using Sce.PlayStation.Core.Graphics;
using Sce.PlayStation.Core.Input;
using Sce.PlayStation.HighLevel.UI;

namespace UIToolkitApp
{
    public class AppMain
    {
        private static GraphicsContext graphics;

        public static void Main (string[] args)
        {
            Initialize ();

            while (true) {
                SystemEvents.CheckEvents ();
                Update ();
                Render ();
            }
        }

        public static void Initialize ()
        {
            // Set up the graphics system
            graphics = new GraphicsContext ();

            // Initialize UI Toolkit
            UISystem.Initialize(graphics);

            // TODO: Create scenes and call UISystem.SetScene
            // Scene myScene = new Sce.PlayStation.HighLevel.UI.Scene();
            // UISystem.SetScene(myScene, null);
        }

        public static void Update ()
        {
            // Query gamepad for current state
            var gamePadData = GamePad.GetData (0);

            // Query touch for current state
            List<TouchData> touchDataList = Touch.GetData (0);

            // Update UI Toolkit
            UISystem.Update(touchDataList);
        }

        public static void Render ()
        {
            // Clear the screen
            graphics.SetClearColor (0.0f, 0.0f, 0.0f, 0.0f);
            graphics.Clear ();

            // Render UI Toolkit
            UISystem.Render ();

            // Present the screen
            graphics.SwapBuffers ();
        }
    }
}

UI Toolkit のコードを記述

文字列を表示するウィジェットを一つ配置したシーンを作成し、UI Toolkit にそのシーンを設定します。

AppMain.cs を開いてください。main メソッドの最初の方に以下のコメントが記述されています。

// TODO: Create scenes and call UISystem.SetScene
// Scene myScene = new Sce.PlayStation.HighLevel.UI.Scene();
// UISystem.SetScene(myScene, null);

このコメントの部分を以下のように書き換えてください。

// Create scene
Scene scene = new Sce.PlayStation.HighLevel.UI.Scene();
Label label = new Label();
label.X = 10.0f;
label.Y = 50.0f;
label.Text = "Hello World!";
scene.RootWidget.AddChildLast(label);
// Set scene
UISystem.SetScene(scene, null);

AppMain.cs の全体のコードは以下のようになります。

using System;
using System.Collections.Generic;

using Sce.PlayStation.Core;
using Sce.PlayStation.Core.Environment;
using Sce.PlayStation.Core.Graphics;
using Sce.PlayStation.Core.Input;
using Sce.PlayStation.HighLevel.UI;

namespace UIToolkitApp
{
    public class AppMain
    {
        private static GraphicsContext graphics;

        public static void Main (string[] args)
        {
            Initialize ();

            while (true) {
                SystemEvents.CheckEvents ();
                Update ();
                Render ();
            }
        }

        public static void Initialize ()
        {
            // Set up the graphics system
            graphics = new GraphicsContext ();

            // Initialize UI Toolkit
            UISystem.Initialize(graphics);

            // Create scene
            Scene scene = new Sce.PlayStation.HighLevel.UI.Scene();
            Label label = new Label();
            label.X = 10.0f;
            label.Y = 50.0f;
            label.Text = "Hello World!";
            scene.RootWidget.AddChildLast(label);
            // Set scene
            UISystem.SetScene(scene, null);
        }

        public static void Update ()
        {
            // Query gamepad for current state
            var gamePadData = GamePad.GetData (0);

            // Query touch for current state
            List<TouchData> touchDataList = Touch.GetData (0);

            // Update UI Toolkit
            UISystem.Update(touchDataList);
        }

        public static void Render ()
        {
            // Clear the screen
            graphics.SetClearColor (0.0f, 0.0f, 0.0f, 0.0f);
            graphics.Clear ();

            // Render UI Toolkit
            UISystem.Render ();

            // Present the screen
            graphics.SwapBuffers ();
        }
    }
}

実行とデバッグ

作成したコードを PC 上のシミュレータで実行します。

実行方法は 開発環境の設定 の実行とデバッグと同じです。以下の手順に沿って実行またはデバッグ実行を行ってください。

  • PSM Studio のメインメニューから [ビルド] ([Build]) > [全てビルド] ([Build All]) を選択し、アプリケーションをビルドします。右下のステータスバーでエラーがないことを確認してください。

  • PSM Studio のメインメニューから [プロジェクト] ([Project]) > [PSM Device Target] が [PlayStation Mobile Simulator] になっていることを確認してください。

  • PSM Studio のメインメニューから [実行] ([Run]) > [実行] ([Run]) または [デバッグ] ([Debug]) を選択すると、シミュレータで 実行 または デバッグ実行 することができます(図5)。

    図5 シミュレータ上で実行した様子


基本概念

この章では、UI Toolkit の基本概念を解説します。

UI Toolkit のプロジェクトの作成方法は UI Toolkit プログラミングガイド - クイックスタート を参照してください。

Contents

  • UI Toolkit のクラス構成
  • アプリケーションのライフサイクル
  • シーングラフ
  • レイアウト
  • ピクセル密度
  • 画面の向き
  • アニメーション
  • 画像アセット
  • モーダルダイアログ
  • タッチイベントの配信
  • ゲームパッドによる操作
  • キーイベントの配信
  • モーションイベントの配信
  • マルチスレッド

UI Toolkit のクラス構成

UI Toolkit を使用したアプリケーションでの主なオブジェクトの種類と関係を図1と表1に示します。

図1 UI Toolkit を使用したアプリケーションの主要オブジェクト

表1 主要オブジェクトの一覧
オブジェクト | 説明
UISystem | UI Toolkit のシステム全体を管理するオブジェクト
シーン (Scene) | 画面を表すオブジェクト
ウィジェット (Widget) | ユーザーインターフェースを構成する部品（ボタンやラベルなど）
コンテナウィジェット (Container widget) | 内部に別のウィジェットを格納することが出来るウィジェット（パネルやダイアログなど）

UISystem は UI Toolkit のシステム全体を管理するオブジェクトで、UI Toolkit の初期化やフレームの更新、描画、画面の遷移などを行います。UISystem は静的クラスになっており、ひとつのアプリケーション上で複数の UI Toolkit システムを使うことは出来ません。

シーンは画面を表しており、UISystem に設定することで画面が表示されます。ひとつのアプリケーションで複数のシーンを作成することができ、UISystemに設定するシーンを切り替えれば画面遷移を行えます。なお、通常は同時にひとつのシーンしか表示できません。

シーンには複数のウィジェットを配置することが出来ます。コンテナウィジェットはウィジェットの一種で、内部に別のウィジェットを配置することが出来ます。このコンテナウィジェットを用いることで、ウィジェットのツリー構造を構築できます。Scene 内の Widget のレイアウトは UI Composer を使用することで、視覚的に行うことが出来ます。

アプリケーションのライフサイクル

ここでは UI Toolkit を利用したアプリケーションが開始してから終了するまでのフローを説明します(図2)。

図2 UI Toolkit を使用したアプリケーションのライフサイクル

青のブロックが UI Toolkit の処理、白のブロックがロジックやゲームなどのその他の処理になります。

まず初めにアプリケーション側の初期化処理、および UISystem の初期化処理が行われます。次にシーンが作成され、そのシーンへのウィジェットのレイアウトも行われます。その後、メインループに入り、各フレームの更新と描画処理が行われます。更新の際にウィジェットなどからイベントが発行され、各イベントハンドラが実行されます。最後に、アプリケーションが終了状態になると、メインループから抜けてアプリケーションが終了します。

UISystem の描画の前にアプリケーション側の描画を行うことで、ゲームと UI を重ねて描画することも可能です。

シーングラフ

UI Toolkit では以下のようなシーングラフを構成しています(図3)。

図3 UI Toolkit のシーングラフ

  • Scene

    画面をあらわしています。ひとつのアプリケーションで複数のシーンを作成することができますが、通常は同時にひとつのシーンしか表示できません。

  • Widget

    ユーザーインターフェースを構成する部品 (ウィジェット) です。ボタンやラベルなどにあたります。ウィジェットはツリー構造を構築でき、シーンひとつにこのツリーがひとつ配置されています。複数のウィジェットをまとめてひとつのウィジェットとして扱うことも出来ます。標準のウィジェットについての詳細は UI Toolkit プログラミングガイド - ウィジェット を参照してください。

  • RootWidget

    ウィジェットのツリーのルートとなる特殊なウィジェットです。シーンにひとつだけ存在します。RootWidgetのオブジェクトはユーザーが作成することはできず、シーンの作成時に自動で作られます。画面に表示する場合はこのルートウィジェットに表示したいウィジェットをぶら下げる必要があります。

  • UIElement

    描画要素です。UIElement もツリー構造を構築できます。ウィジェットは この UIElement のツリーで構成されています。

  • RootUIElement

    UIElement のツリーのルートとなる UIElement です。ウィジェットにひとつだけ表示されます。

シーングラフの描画順序

ルートウィジェットから深さ優先で描画されます。末端のウィジェットが一番手前に表示されます。ウィジェットが描画される際には UIElement ルートの UIElement から順に描画されます。

先ほどのシーングラフの例では次の順番で描画されます(図4)。

図4 描画順序

レイアウト

ウィジェットを配置する際の座標系は、左上が原点となります。

また、ウィジェットがツリーを構築している場合、子ウィジェットの座標は親ウィジェットからの相対座標になります(図5)。

図5 ウィジェットの座標系

ウィジェットを3次元で配置することも可能です。詳細は UI Toolkit プログラミングガイド - UI Toolkitの描画の仕組み を参照してください。

シーンやパネルなどのコンテナウィジェットは、内部に配置したウィジェットのサイズや、マージンを動的に調節する機能を持っています(レイアウトアンカー機能)。

例えば、背景などに用いるパネルはマージンを固定にし、サイズを自動的に変化するように設定しておけば、異なるディバイスごとにレイアウトを指定する必要はありません(図6)。

図6 マージンを固定にした Panel を異なるサイズの Scene に配置した例

レイアウトアンカーはウィジェットの Anchors プロパティで指定可能です。

コードでは以下のように、Top, Bottom, Left, Right, Width, Height のうちどのサイズを固定するかを指定します。

widget.Anchos = Anchors.Top | Anchors.Left | Anchors.Width | Anchors.Height;

以下に代表的なパターンを示します(図7)。

図7 Anchorsの設定例

ピクセル密度

ピクセル密度を指定し、スクリーンサイズをスケーリングさせる方法について説明します。

レイアウトアンカー機能をもちいてディスプレイのサイズに合わせてウィジェットの位置やサイズを変更した場合でも、同じインチサイズで異なる解像度のディスプレイでは、フォントサイズや9-patch 画像の見た目が変わってしまいます（図8）。

図8 解像度の異なるディスプレイで表示した例

ピクセル密度を指定すると、UI Toolkit上での仮想的なディスプレイサイズをスケーリングすることができます。

例えば、ディスプレイのサイズが1280x720ピクセルのディバイスでピクセル密度に1.5に指定すると、UI Toolkit上では仮想的に853x480ピクセルのディスプレイとして扱われます。

ウィジェットの位置やサイズ、フォントサイズなども853x480ピクセルのディスプレイで配置する場合と同じ値になり、最終的にディスプレイに描画されるときに1.5倍されます。

ピクセル密度はUI Toolkitの初期化時に指定します。以下のコードを参考に、ピクセル密度を算出して指定してください。

// AppMain.cs

public static void Initialize ()
{
    // Set up the graphics system
    graphics = new GraphicsContext ();

    // Get pixel-density
    float pixelDensity = getPixelDensity(graphics);

    // Initialize UI Toolkit with pixelDensity
    UISystem.Initialize (graphics, pixelDensity);
}

// get pixel-density from actual screen size and DPI
static float getPixelDensity(GraphicsContext graphics)
{
    float pixelDensity;

    float w = graphics.Screen.Width / SystemParameters.DisplayDpiX;
    float h = graphics.Screen.Height / SystemParameters.DisplayDpiY;
    float inchDiagSq = w * w + h * h;

    if (inchDiagSq < 6 * 6)
    {
        // normal size display ( < 6 inch)
        if (SystemParameters.DisplayDpiX < 300)
        {
            // normal resolution
            pixelDensity = 1.0f;
        }
        else
        {
            // high resolution
            pixelDensity = 1.5f;
        }
    }
    else
    {
        // large size display ( > 6 inch)
        if (SystemParameters.DisplayDpiX < 200)
        {
            // normal resolution
            pixelDensity = 1.0f;
        }
        else
        {
            // high resolution
            pixelDensity = 1.5f;
        }
    }
    return pixelDensity;
}

なお、UI Toolkit上でFontクラスやTexture2Dクラスを直接扱う場合、ピクセル密度の値を考慮する必要があるので注意してください。

画面の向き

画面の向きを変更する方法を説明します。

図9のようにデバイスの把持方向に応じた画面表示ができます。

図9 ディバイスの方向に応じた画面の向き

Scene クラスの ScreenOrientation プロパティを設定することによって、シーンごとに表示する方向を変更できます。

以下のコード例では、ScreenOrientation プロパティを設定後、UI Composerで出力したメソッドを利用して再レイアウトし、UISystem.SetScene を呼び出しています。

// Set ScreenOrientation property
TargetScene.ScreenOrientation = ScreenOrientation.Portrait;

// Relayout (UI Composer output method)
TargetScene.SetWidgetLayout(LayoutOrientation.Vertical);

// Set this scene
UISystem.SetScene(TargetScene);

ScreenOrientation の各設定値の表示結果は以下のようになります(図10)。

図10 ScreenOrientation の表示例

ScreenOrientation を指定すると、座標系、タッチパネルの座標、方向キーの向き、モーションセンサーの向きも同時に変更されます。

UISystem.FramebufferWidth、FramebufferHeight プロパティの値は ScreenOrientation に依存せず、常に Landscape 状態の値を返します。

また、Transition も Landscape を基準に動作します。たとえば、Portraite のシーンから ReversePortrait のシーンに PushTransition の Left を実行すると、それぞれのシーンは Portraite、ReversePortrait で表示されますが、遷移アニメーションは Landscape 状態で左方向に移動します。

制限事項

  • 現在表示中のシーンの ScreenOrientation は変更できません。あらかじめ Scene.ScreenOrientation プロパティを設定したあとに UISystem.SetScene をしてください。
  • UI Toolkit 以外で描画しているもの（テキスト入力ダイアログ、オンスクリーンコントローラーなど）は回転しません。
  • シミュレータのウインドウは回転しません。内部の画面が回転します。

アニメーション

アニメーションを実現する機能として Effect があります。 Effect はアニメーションを部品として扱い、ウィジェットなどのアニメーションを簡単に行うことが出来ます。

標準で用意されている Effect については、 UI Toolkit プログラミングガイド - Effect と Transition を参照してください。また、Effect クラスを派生することによって、ユーザー独自のアニメーションを作成することが出来ます。

Effect とは別に、画面遷移の際のアニメーションである Transition があります。UISystem に新しいシーンを設定する際に指定することで、画面遷移にアニメーションを適用できます。標準の Transition の詳細については、 UI Toolkit プログラミングガイド - Effect と Transition を参照してください。

画像アセット

UI Toolkit で画像を扱う場合は ImageAsset オブジェクトを使用します。

ImageAsset オブジェクトは以下のような特徴があります。

  • 画像ファイルのキャッシュ
  • 画像ファイルの非同期読み込み
  • システム組み込みの画像の読み込み
  • Texture2D オブジェクトの生成と解放

ウィジェットへ画像（テクスチャ）を設定する場合はすべて ImageAsset オブジェクトで行います。また、ウィジェット内部の描画要素である UIElement への設定も ImageAsset オブジェクトで行います。

ImageAsset オブジェクトは、画像ファイルのパス、Image オブジェクト、Texture2D オブジェクトから作ることが出来ます。

// Create from the image filepath.
ImageAsset imageAsset1 = new ImageAsset("/Application/assets/photo01.png");

// Create from Image object.
Image image = new Image("/Application/assets/photo02.png");
ImageAsset imageAsset2 = new ImageAsset(image);
image.Dispose();

// Create from Texture2D object.
Texture2D texture2d = new Texture2D("/Application/assets/photo03.png", false)
ImageAsset imageAsset3 = new ImageAsset(texture2d);
texture2d.Dispose();

ファイルパスは "/Application/(プロジェクトファイルからの相対パス)" と指定してください。

SampleApp/
    SampleApp.csproj
    AppMain.cs
    app.cfg
    MyClass.cs

    assets/
        photo01.png    : アセットファイル

上記のようなファイル構成のプロジェクトの場合、アセットファイルのパスは以下のようになります。

"/Application/assets/photo01.png"

モーダルダイアログ

モーダルなダイアログウィンドウを表示するためには Dialog ウィジェットを使用します。

Dialog ウィジェット、およびその派生クラスのウィジェットは他のウィジェットと異なり、シーンに登録することなく画面上に表示することが出来ます。

Dialog dialog = new Dialog();
dialog.Show();

タッチイベントの配信

UI Toolkit のタッチイベント配信フローについて説明します。

図11 UI Toolkit のタッチイベント配信フロー

図11のオレンジ矢印が指1本分のタッチデータの流れを示しており、下記のように処理が進みます。

  1. タッチ操作が行われると、画面内にある Widget とヒット判定が行われます。
  2. ヒットした Widget に登録されている GestureDetector にイベントが配信されます。
  3. ジェスチャが認識された場合、ジェスチャイベントが発行され、GestureDetector に登録されているイベントハンドラに配信されます。
  4. GestureDetector による判定後、TouchEventReceived イベントハンドラにタッチイベントが配信されます。

ヒット判定は、指毎に行われ、同じ Widget を複数の指でタッチしていれば、タッチデータはまとめて配信されます。ヒット判定はタッチダウンしたときにのみ行い、タッチパネルから指が離されるか、キャンセルされるまで同じ Widget にタッチイベントが配信されます。指で Widget をドラッグする際などに、Widget 領域から指が外れた場合でも、指が離されるまではその Widget にタッチイベントが配信され続けることになります。

複数の指のタッチデータは TouchEventCollection にまとめて配信されます。TouchEventCollection.PrimaryTouchEvent に一番最初にその Widget に触れた指のタッチデータが格納されていますので、一本分の指のタッチデータだけで処理を行いたい場合はこちらをお使いください。

通常、子Widget にイベントが配信されると、親Widget には配信されません。タッチされている Widget にのみ配信されます。ただし、子Widget のタッチイベントをフックすることも可能です。Widget.HookChildTouchEvent でフックを有効にするかを指定可能で、有効にすると子Widget に配信される前に親Widget のタッチイベント処理が行われます。配信された TouchEventCollection の Forward フラグを変更することで、子Widget に配信するかどうかを制御できます。

Widget に GestureDetector を登録することで、Widget 対して行われたジェスチャイベントを処理することができます。一つの Widget には複数の GestureDetector を登録することができますが、同一の GestureDetector を複数の Widget に登録することはできません。

public class SampleScene : Scene
{
    ImageBox imageBox;

    public SampleScene ()
    {
        imageBox = new ImageBox();

        DragGestureDetector drag = new DragGestureDetector();
        drag.DragDetected += DragEventHandler;
        imageBox.AddGestureDetector(drag);

        FlickGestureDetector flick = new FlickGestureDetector();
        flick.FlickDetected += FlickEventHandler;
        imageBox.AddGestureDetector(flick);

        this.RootWidget.AddChildLast(imageBox);
    }

    private void DragEventHandler(object sender, DragEventArgs e)
    {
        DoSomething(e);
    }

    private void FlickEventHandler(object sender, FlickEventArgs e)
    {
        DoSomething(e);
    }
}

Widget に TouchEventReceived イベントハンドラを登録することで、Widget に配信されたタッチイベントを処理することができます。

public class SampleScene : Scene
{
    ImageBox imageBox;

    public SampleScene ()
    {
        imageBox = new ImageBox();
        imageBox.TouchEventReceived += new EventHandler<TouchEventArgs>(ImageBoxTouchEventReceived);
        this.RootWidget.AddChildLast(imageBox);
    }

    private void ImageBoxTouchEventReceived (object sender, TouchEventArgs eventArgs)
    {
        TouchEventCollection touchEvents = eventArgs.TouchEvents;

        // With single finger
        {
            TouchEvent e = touchEvents.PrimaryTouchEvent;
            DoSomething(e);
        }

        // With multi-fingers
        {
            foreach (TouchEvent e in touchEvents)
            {
                DoSomething(e);
            }
        }

        touchEvents.Forward = true;
    }
}

カスタムウィジェットを作成した場合は、Widget.OnTouchEvent() をオーバーライドすることによってタッチイベントを処理することができます。

public class SampleWidget : Widget
{
    protected internal override void OnTouchEvent(TouchEventCollection touchEvents)
    {
        base.OnTouchEvent(touchEvents);

        // With single finger
        {
            TouchEvent e = touchEvents.PrimaryTouchEvent;
            DoSomething(e);
        }

        // With multi-fingers
        {
            foreach (TouchEvent e in touchEvents)
            {
                DoSomething(e);
            }
        }

        touchEvents.Forward = true;
    }
}

なお、タッチイベントを使用する場合は、Main Loop の中で UISystem.Update メソッドを List<TouchData> を含む引数付きで呼び出してください。

ゲームパッドによる操作

ここではゲームパッドによるUI操作を行う方法や注意点について説明します。

UI Toolkitでゲームパッドキーによる操作を有効にするには、UISystem.Update メソッドを呼び出す際に、 引数にGamePadData を含めるようにしてください。GamePadDataを含めることで、方向キーによるフォーカス操作、Enter、Backボタン(×または○ボタン)による操作が有効になります。

// in main loop
public static void Update ()
{
    GamePadData gamePadData = GamePad.GetData (0);
    List<TouchData> touchDataList = Touch.GetData (0);

    // Update UI Toolkit
    UISystem.Update(touchDataList, gamePadData);
}

フォーカスが非アクティブな状態（フォーカスが表示されていない状態）でいずれかのゲームパッドのボタンを押すとフォーカスがアクティブ（フォーカスが表示された状態）になり、ゲームパッドでの操作が可能になります。フォーカスがアクティブな状態で一定時間経過するか、画面をタッチするとフォーカスが非アクティブになります。

  • 方向キーによる操作

    フォーカスがアクティブな状態で方向キーを操作すると通常はフォーカスが移動します。ただし、表2 に示すウィジェットでは方向キーでフォーカスが移動しない場合があるので、ウィジェットのレイアウトに注意してください。

    表2 レイアウトに注意が必要なウィジェット

    ウィジェット

    方向キーによる操作

    レイアウトの注意事項

    Slider(水平表示)

    左右キーで値が変化します。

    Sliderの左右にフォーカスの当たるウィジェットを配置しないようにして下さい。

    Slider(垂直表示)

    上下キーで値が変化します。

    Sliderの上下にフォーカスの当たるウィジェットを配置しないようにして下さい。

    DatePicker / TimePicker

    上下キーで値が変化し、左右キーで列および左右のウィジェットへフォーカスが移動します。

    DatePickerとTimePickerの上下にフォーカスの当たるウィジェットを配置しないようにして下さい。

    ListPanel / GridListPanel（垂直表示）

    上下キーでアイテムのフォーカスが移動し、上端下端ではスクロールします。フォーカスが最下端か最上端のアイテムにある場合は上下のウィジェットに移動します。

    アイテム数が多い場合、ListPanelやGridListPanelの上下にはフォーカスの当たるウィジェットを配置しないようにして下さい。

    GridListPanel（水平表示）

    左右キーでアイテムのフォーカスが移動し、右端左端ではスクロールします。フォーカスが最右端か最左端のアイテムにある場合は左右のウィジェットに移動します。

    アイテム数が多い場合、GridListPanelの左右にはフォーカスの当たるウィジェットを配置しないようにして下さい。

    ScrollPanel

    方向キーで内部に配置したウィジェットのフォーカスが移動できる場合はフォーカスが移動し、それ以外の場合はスクロールします。スクロールが端までいった場合には上下左右のウィジェットに移動します。

    スクロール量が多い場合はScrollPanelのスクロール方向にフォーカスの当たるウィジェットを配置しないようにして下さい。

    PagePanel

    方向キーで内部に配置したウィジェットのフォーカスが移動し、右端か左端ではページが切り替わります。最初または最後のページではページパネルの左右のウィジェットにフォーカスが移動します。

    PagePanelの左右にフォーカスの当たるウィジェットを配置しないようにして下さい。

    図12 Sliderのレイアウト例

  • Enter、Backボタンによる操作

    Button や PopupList などのタップで操作できるウィジェットは、フォーカスのあたっている状態で Enter (×または○) ボタンを押すとタップ相当の操作ができます。

    ダイアログは、Back (○または×) ボタンを押すとダイアログが閉じます。

    ナビゲーションシーンは、Back ボタンを押すと前のシーンに戻ります。

フォーカスやキー操作のカスタマイズについては、 UI Toolkit プログラミングガイド - キーイベントとフォーカス を参照してください。

キーイベントの配信

UI Toolkit のキーイベント配信とそのフローについて説明します。

キーイベントの種類は図13の4つと EachFrameRepeat があります。

図13 キーイベントの種類とタイミング

また、キーイベントは GamePadButton クラスと異なり、各ボタンごとにイベントが配信されます。

キーイベントの配信フローはフォーカスがアクティブかどうかによって変わります。

  • フォーカスがアクティブな場合

    カレントシーンの RootWidget からウィジェットツリーに沿って現在フォーカスがあるウィジェットまでプレビューキーイベントが配信されます。そのあと、方向キーのイベントがフォーカスように処理され、今度はフォーカスがあるウィジェットから RootWidget に向けて通常のキーイベントが配信されます(図14)。

    図14 キーイベントの配信フロー

    プレビューキーイベントと通常のキーイベントをハンドルするには、ウィジェットの OnPreviewKeyEvent および OnKeyEvent メソッドをオーバーライドするか、PreviewKeyEventReceived および KeyEventReceived イベントにイベントハンドラを登録してください。

    {
    // add event handler
    anyWidget.KeyEventReceived += new EventHandler<KeyEventArgs>(KeyEventReceivedHandler);
}

void KeyEventReceivedHandler(object sender, KeyEventArgs e)
{
    switch (e.KeyEventType)
    {
        case KeyEventType.Up:
            if (e.KeyType == KeyType.Triangle)
            {
                DoSomething();
                e.Handled = true;
            }
            break;

        case KeyEventType.Down:
        case KeyEventType.LongPress:
        case KeyEventType.Repeat:
        default:
            break;
    }
}

    各イベントハンドラでイベント引数の Handled プロパティを true に設定すると、それ以降のツリーの配信は行わなくなります(図15)。ただし、Handled プロパティは異なるキーやキーイベントの種類、および異なるフレームのキーイベントに対して影響を与えません。

    図15 キーイベントのハンドルによる配信中断

  • フォーカスが非アクティブな場合

    カレントシーンの RootWidget にプレビューキーイベントが配信され、このイベントがハンドルされなかった場合は、フォーカス用にイベントがハンドルされ、フォーカスがアクティブになります。

より詳細なキーイベントの扱い方については、 UI Toolkit プログラミングガイド - キーイベントとフォーカス を参照してください。

モーションイベントの配信

UI Toolkit のモーションイベント配信フローについて説明します。

デバイスに内蔵された加速度センサー等の値が変化した場合に、現在の Scene に登録されている Widget のうち、Widget.OnMotionEvent をオーバーライドしている、もしくは、Widget.MotionEventReceived にイベントハンドラが登録されている Widget 全てにモーションイベントが配信されます。

Widget に MotionEventReceived イベントハンドラを登録することで、Widget に配信されたモーションイベントを処理することができます。

public class SampleScene : Scene
{
    ImageBox imageBox;

    public SampleScene ()
    {
        imageBox = new ImageBox();
        imageBox.MotionEventReceived += new EventHandler<MotionEventArgs>(ImageBoxMotionEventReceived);
        this.RootWidget.AddChildLast(imageBox);
    }

    private void ImageBoxMotionEventReceived (object sender, MotionEventArgs eventArgs)
    {
        DoSomething(eventArgs):
    }
}

カスタムウィジェットを作成した場合は、Widget.OnMotionEvent() をオーバーライドすることによってモーションイベントを処理することができます。

public class SampleWidget : Widget
{
    protected internal override void OnMotionEvent(MotionEvent motionEvent)
    {
        base.OnMotionEvent(motionEvent);

        DoSomething(motionEvent);
    }
}

なお、モーションイベントを使用する場合は、Main Loop の中で UISystem.Update メソッドを MotionData を含む引数付きで呼び出してください。

マルチスレッド

UI Toolkit では、AnimationUtility クラスを除くすべてのクラスにおいてスレッドセーフではありません。

UISystem やウィジェットなどのメンバを操作する場合はメインスレッドから行うようにしてください。これは、Scene の OnUpdate メソッドなどを用い、フレーム毎にサブスレッドを監視して処理を行うことで実現できます。なお、Sce.PlayStation.Core.Graphics 名前空間に対する処理も同様にメインスレッドから行うようにしてください。

class MyScene : Scene
{
    Label label;
    object SysncObject;
    string AsyscText;

    protected internal override void OnUpdate(float elapsedTime)
    {
        base.OnUpdate(elapsedTime);

        lock (SyncObject)
        {
            if (AsyncText != label.Text)
            {
                label.Text = AsyncText;
            }
        }
    }

    // Initialize and Multithread processing
    .....

}


ウィジェット

この章では、UI Toolkit に標準で組み込まれているウィジェットの概要を紹介します。

Contents

  • ウィジェットツリー
    • Widget
    • RootWidget
  • 汎用ウィジェット
    • Label
    • ImageBox
    • Button
    • CheckBox
    • Slider
    • ProgressBar
    • EditableText
    • BusyIndicator
    • AnimationImageBox
    • PopupList
    • DatePicker
    • TimePicker
  • コンテナウィジェット
    • ContainerWidget
    • Panel
    • ScrollPanel
    • PagePanel
    • ListPanel、ListPanelItem
    • GridListPanel、ListPanelItem
  • ダイアログウィジェット
    • Dialog
    • MessageDialog
  • Live ウィジェット
    • LiveListPanel
    • LiveJumpPanel
    • LiveFlipPanel
    • LiveScrollPanel
    • LiveSphere
    • LiveSpringPanel

ウィジェットツリー

シーンを構成するウィジェットは RootWidget をルートにしたツリー構造になっています(図1)。

図1 シーンを構成するウィジェットの構造

Widget

Widget クラスはすべての ウィジェット (ユーザーインターフェース部品) の基底となる抽象クラスです。

すべての種類のウィジェットに共通した機能である、位置やサイズ、表示・非表示などを取得、設定することが出来ます。

Widget widget = new ConcreteWidget();
widget.X = 100.0f;
widget.Y = 50.0f;
widget.Width = 200.0f;
widget.Height = 100.0f;
widget.Visible = false;
widget.Anchors = Anchors.Top |
                 Anchors.Bottom |
                 Anchors.Left |
                 Anchors.Right;

Anchors プロパティについては「基本概念」の「レイアウト」節を参照してください。

独自のウィジェットを作成するためには、 Widget クラス、または派生クラスの ContainerWidget クラス、 Dialog クラスなどを継承してください。詳しくは カスタムウィジェットの作成方法 を参照してください。

RootWidget

シーンを構成するウィジェットツリーのルートになる特殊なウィジェットです。

シーンを作成したときに自動的に作成され、 Scene の RootWidget プロパティで取得することが出来ます。アプリケーションから RootWidget クラスのインスタンスを作成することは出来ません。

ウィジェットを画面に表示する場合は、このルートウィジェットの子供に配置する必要があります。

Scene scene = new Scene();
Label label = new Label();
label.SetPosition(10.0f, 50.0f);
label.Text = "Hello World!";
scene.RootWidget.AddChildLast(label);

RootWidget オブジェクトの 幅 (Width) と高さ (Height) はスクリーンバッファのサイズに一致し、変更することが出来ません。また、位置 (X, Y) は (0, 0) で変更できません。

汎用ウィジェット

Label

テキストを表示するためのウィジェットです。

テキストは文字列中の改行コードを反映して表示されますが、それでもテキストがラベルの幅に収まらない場合、LineBreak プロパティを設定することでテキストを折り返して表示することが出来ます。各設定値の表示結果は以下のようになります。

図2 Label の LineBreak プロパティ

改行しても矩形内に収まらない場合、最終行の右端の表示方法は TextTrimming プロパティで指定することが出来ます。各設定値の表示結果は図3 のようになります。

図3 Label の TextTrimming プロパティ

Label label1 = new Label();
label1.SetPosition(0.0f, 0.0f);
label1.SetSize(100.0f, 80.0f);
label1.Font = new UIFont(FontAlias.System, 32, FontStyle.Regular);
label1.TextColor = new UIColor(0, 255, 0, 255);
label1.TextTrimming = TextTrimming.EllipsisCharacter;
label1.LineBreak = LineBreak.Word;
label1.Text = "Hello world!";

ImageBox

画像を表示するためのウィジェットです。

画像は ImageAsset クラスのオブジェクトとして設定します。

ImageBox imageBox1 = new ImageBox();
imageBox1.Image = new ImageAsset("/Application/assets/img.png");

画像を表示する際のスケーリング方法を図4 の5パターンで指定できます。 スケーリングを行う場合の画像は 96dpi で作成することを推奨します。

図4 画像のスケーリング方法

9-patch 画像では、NinePatchMargin プロパティを指定する事で四隅を固定してスケーリングできます(図5)。

ImageBox imageBox1 = new ImageBox();
imageBox1.Image = new ImageAsset("/Application/assets/img.png");
imageBox1.ImageScaleType = ImageScaleType.NinePatch;
imageBox1.NinePatchMargin = new NinePatchMargin(24, 24, 24, 24);

図5 ImageBox の 9-patch によるスケーリング

Button

タッチ操作に反応するボタンウィジェットです。

ボタンには画像か1行のテキストを表示することが出来ます(図6)。

図6 テキストを表示したButtonと、画像を表示したButton

Button textButton = new Button();
textButton.Text = "OK";

Button imageButton = new Button();
imageButton.IconImage = new ImageAsset("/Application/assets/img.png");

このウィジェットをタップするか Enterキーを押下すると、任意のコードを実行できます。

ボタンが押された場合に実行するコードは ButtonAction イベントを使用します。以下のように、実行したいコードを記述したイベントハンドラを用意し、ButtonAction イベントに登録します。

Button button1 = new Button();
button1.Text = "Start";
button1.ButtonAction += HandleButton1ButtonAction;

void HandleButton1ButtonAction(object sender, TouchEventArgs e)
{
    button1.Text = "Stop";
}

なお、PSM Studio のコードテンプレート機能を使用すれば、イベントの代入式を記述するだけで自動でイベントハンドラを生成可能です(図7)。

図7 イベントハンドラの自動生成

ボタンの背景画像を変更したい場合は、CustomButtonSettings プロパティを使用します。通常、押下、無効の３つの状態の背景画像と、これらの9-patch のマージンを指定できます(図8)。

Button customButton = new Button();
customButton.Text = "Custom Button";
CustomImageSettings customImage =  new CustomImageSettings();
customImage.BackgroundNormalImage = new ImageAsset("/Application/assets/BackgroundNormalImage.png");
customImage.BackgroundPressedImage = new ImageAsset("/Application/assets/BackgroundPressedImage.png");
customImage.BackgroundDisabledImage = new ImageAsset("/Application/assets/BackgroundDisabledImage.png");
customImage.BackgroundNinePatchMargin = new NinePatchMargin(10,10,10,10);
customButton.CustomImage = customImage;
customButton.Style = ButtonStyle.Custom;

図8 背景画像をカスタマイズしたButton

CheckBox

いわゆるチェックボックスやラジオボタン用のウィジェットで、真偽値を保持します(図9)。

図9 CheckBox

このウィジェットをタップするか Enterキーを押下すると、真偽値が切り替わります。

真偽値は Checked プロパティで取得と設定ができます。また、Style プロパティによってチェックボックスかラジオボタンの画像を切り替えることが出来ます。

CheckBox check1 = new CheckBox();
check1.Checked = true;
check1.CheckedChanged += HandleCheck1CheckedChange;

CheckBox radio1 = new CheckBox();
radio1.Style = CheckBoxStyle.RadioButton;
radio1.CheckedChange += HandleRadio1CheckedChange;

Slider

数値などの調整を行うためのウィジェットです(図10)。

図10 Slider

中央のノブをドラッグして動かすか左右（または上下）キーを押下することによって値を調整できます。この値は Value プロパティで取得することができます。値の範囲は MinValue および MaxValue プロパティで設定することができ、ノブが左端にある場合に最小値となります。

Orientation プロパティでスライダーを縦方向にすることができ、この場合、ノブが下に来たときに Value が最小値となります。

値が変更になった場合のイベントは、ValueChanged と ValueChanging の2種類あります。ValueChanged イベントは、ノブをドラッグして指が離されたとき、および アプリケーションコードから Value プロパティの値を変更したときに発行されます。ValueChanging イベントは、ValueChanged イベントの発行タイミングに加えて、ノブをドラッグ中でも値が変更されていれば毎フレーム発行されます。

アプリケーションコードから Value プロパティを設定する場合など、ValueChanged および ValueChanging イベントを一時的に発行させたくない場合は、ValueChangeEventEnabled プロパティを false に設定してください。

左右キー（縦方向表示の場合は上下キー）ではフォーカスが移動されないので、このウィジェットの左右にフォーカスのあたるウィジェットを配置しないようにしてください。

Slider slider1 = new Slider();
slider1.Orientation = SliderOrientation.Horizontal;
slider1.MinValue = -127;
slider1.MaxValue = 128;
slider1.ValueStep = 1;
slider1.Value = 0;
slider1.ValueChanged += HandleSlider1ValueChanged;
slider1.ValueChanging += HandleSlider1ValueChanging;

ProgressBar

進捗の度合いを表示するウィジェットです(図11)。

図11 ProgressBar

表示のスタイルは通常とアニメーションの2種類あり、Style プロパティで設定できます。アニメーションのスタイルは、進捗の比較的遅い処理を行う際に有用です。

進捗度合いは Progress プロパティに 0 から 1 の範囲で設定します。

progressBar = new ProgressBar();
progressBar.Style = ProgressBarStyle.Animation;

void OnUpdate()
{
    progressBar.Progress = (float)processedItemCount / allItemCount;
}

EditableText

テキストの表示と編集ができるウィジェットです(図12)。

図12 EditableText

このウィジェットをタップするか Enterキーを押下すると、システム標準のオンスクリーンキーボードが起動し、テキストの入力や編集ができます。

テキスト未入力時のデフォルトテキストの表示、パスワード入力用のマスク表示、オンスクリーンキーボードの入力モードの選択ができます。

EditableText progressBar = new EditableText();
EditableText.Text = "";

BusyIndicator

何らかの処理が進行中であることを表示するウィジェットです(図13)。

図13 BusyIndicator

初期状態では非表示になっています。Start メソッドを呼ぶことで表示され、処理中を示すアニメーションを行います。また、Stop メソッドで非表示になります。

初期化後からインジケータを表示させておきたい場合は、インスタンスの作成時に autoStart 引数をとるコンストラクタを使用し、autoStart に true を設定してください。

AnimationImageBox

コマ送りのアニメーションイメージを表示するウィジェットです(図14)。

使用するアセット画像は、各コマの画像をまとめて一つの画像にする必要があります。各コマは左上から右方向に並べ、列数や行数に制約はありません。コマ数、およびコマの幅と高さは、それぞれ、FrameCount, FrameWidth, FrameHeight プロパティで指定します。

図14 AnimationImageBox 用アセット画像の例

Start メソッドでアニメーションを開始し、Stop メソッドで停止します。コマの表示間隔は FrameInterval プロパティにミリ秒単位で指定できます。

PopupList

PopupList は複数の選択肢の中から1つを選ぶために利用する部品です(図15)。

図15 PopupList

PopupList をタップするか Enterキーを押下すると、タイトルとリストを持つ Dialog が表示されます。リストの中から１つを選択(タップ / 上下およびEnterキー)すると、Dialog が閉じ、選択した項目が PopupList に表示されます。Dialogの外側をタップするか Backキーを押下すると選択がキャンセルされて Dialog が閉じます。

リストに表示する中身は、ListItems プロパティで設定できます。また、Dialog のタイトルは、ListTitle プロパティで設定できます。

DatePicker

日付を選択するためのウィジェットです(図16)。

図16 DatePicker

アイテムを上下にドラッグするか、各列にフォーカスを合わせて上下キーを押すことで日付を変更できます。

上下キーではフォーカスが移動されないので、このウィジェットの上下にフォーカスのあたるウィジェットを配置しないようにしてください。

TimePicker

時刻を選択するためのウィジェットです(図17)。

図17 TimePicker

DatePickerと同じ操作ができます。

コンテナウィジェット

ContainerWidget

任意のウィジェットを載せることの出来るウィジェットの基底クラスです。

AddChildFirst、AddChildLast メソッドで Widget を先頭および末尾に追加することが出来ます。追加された子ウィジェットは Children プロパティで取得することが出来ます。登録されている子ウィジェットは最後に追加されたのもが前面に表示されます。

一旦登録した子ウィジェットを削除したい場合は RemoveChild を使用します。単純に子ウィジェットを非表示にするのみであれば Visible プロパティを使用してください。

同じウィジェットのインスタンスを複数のコンテナウィジェットに所属させることは出来ません。

コンテナウィジェットに所属する子ウィジェットはアンカーを使用することができます。アンカーについての詳細は UI Composer のドキュメントを参照してください。

Panel

任意の UI 部品を載せることができるコンテナウィジェットです。

もっともシンプルなコンテナウィジェットで、背景色を指定することが出来ます。

ScrollPanel

スクロール可能な領域を持つパネルです(図18)。

図18 ScrollPanel

子ウィジェットとして Panel を一つ持っており、その一部分をクリッピングして表示します。タッチ操作で上下や左右方向にスクロールさせることが可能です。スクロール可能な方向を制限することも可能です。

panel1 = new ScrollPanel();
panel1.X = 300.0f;
panel1.Y = 0.0f;
panel1.Width = 400.0f;
panel1.Height = 280.0f;
panel1.PanelWidth = 400.0f;
panel1.PanelHeight = 2000.0f;
panel1.PanelColor = new UIColor(0.2f, 0.2f, 0.2f, 0.8f);
panel1.PanelX = 10.0f;
panel1.PanelY = 10.0f;
panel1.ScrollBarVisibility = ScrollBarVisibility.Visible;
panel1.HorizontalScroll = false;

Label label1 = new Label();
panel1.AddChildLast(label1);
label1.X = 310;
label1.Y = 10;
label1.Width = 340.0f;
label1.Height = 1000.0f;
label1.Text  = " ... ";

PagePanel

ページ単位でスクロールすることのできるパネルです(図19)。

図19 PagePanel

PagePanel は AddPageLast メソッドにより複数のページを追加でき、ページごとにPanelオブジェクトを持ちます。GetPage メソッドで指定したページのパネルを取得できます。

pagePanel = new PagePanel();
pagePanel.X = 0.0f;
pagePanel.Y = 0.0f;
pagePanel.Width = 800.0f;
pagePanel.Height = 400.0f;

MyCustomPanel panelA = new MyCustomPanel("Tokyo");
MyCustomPanel panelB = new MyCustomPanel("London");
pagePanel.AddPageLast(panelA);
pagePanel.AddPageLast(panelB);

ListPanel、ListPanelItem

縦方向のみスクロール可能なリストウィジェットです。各項目に表示する内容は ListPanelItem またはその派生クラスで指定します。

ListPanelItem のインスタンスは、ListPanel に一度に表示される個数しか作成されません。スクロールにより隠れた項目は次に表示される項目に再利用されます。そのため、ListPanel には、各項目で共通に用いる ListPanelItem オブジェクトを生成するデリゲートメソッドと、各項目に特化した内容に更新するデリゲートメソッドを登録する必要があります。登録には ListPanel の SetListItemCreator/SetListItemUpdate メソッドを呼び出して下さい。

項目数とセクションのタイトル文字列は ListPanel の Sections プロパティで設定してください。

項目が選択されたことをハンドルする場合は SelectItemChanged イベントを使用してください。

// data to show on the items
itemTextList = new string[] {
    "Item 0-0", "Item 0-1", "Item 0-2", "Item 1-0", "Item 1-1" };

listPanel = new ListPanel();
// set the section titles and item counts
listPanel.Sections = new ListSectionCollection {
        new ListSection("Section1", 3),
        new ListSection("Section2", 2)};

// set the creator delegate
listPanel.SetListItemCreator(() => new MyListPanelItem());
// set the updater delegate
listPanel.SetListItemUpdater((item) =>
    ((MyListPanelItem)item).label.Text = itemTextList[item.Index]);

listPanel.SelectItemChanged += (sender, e) =>
    Console.WriteLine("selected index:{0}", e.Index);

class MyListPanelItem : ListPanelItem
{
    public Label label;
    public MyListPanelItem()
    {
        this.Height = 60;
        label = new Label();
        this.AddChildLast(label);
    }
}

GridListPanel、ListPanelItem

縦方向もしくは横方向にスクロール可能で、格子状に項目が並ぶリストウィジェットです。写真の一覧画面などで利用することを想定しています。各項目に表示する内容は ListPanelItem で指定します。

ListPanel と同様の方法で、ListPanelItem を 生成/更新するデリゲートメソッドを設定して使用して下さい。

GridListPanel にはセクションがないため、ListPanelItem の SectionIndex と IndexInSection プロパティは使用されません。

gridListPanel = new GridListPanel();
gridListPanel.SetListItemCreator(ListItemCreator);
gridListPanel.SetListItemUpdater(ListItemUpdator);
gridListPanel.ItemCount = 100;

ダイアログウィジェット

ダイアログはモーダルなダイアログを表示することの出来る特殊なウィジェットです。

ダイアログのみシーンに登録せずに画面に表示することができます。

Dialog

モーダルなダイアログボックスを表示するためのコンテナウィジェットです(図20)。Panel と同様に任意のUI部品を格納することが可能です。

図20 Dialog

ダイアログが表示されている際に Backボタンを押すとダイアログが閉じます。また、HideOnTouchOutsideプロパティをtrueにしておけば、ダイアログの外側をタップするとダイアログが閉じます。Backボタンかダイアログの外側をタップして閉じた場合は、Result プロパティが Cancel になります。

表示/非表示にする際のアニメーション効果(Effect)を指定することが可能です。

Dialog dialog = new Dialog();
dialog.ShowEffect = new BunjeeJumpEffect(dialog, 0.4f);
dialog.HideEffect = new TiltDropEffect();
dialog.Show();

MessageDialog

警告メッセージの表示や、処理実行の確認などを行うためのダイアログです(図21)。

図21 MessageDialog

タイトルテキスト、メッセージテキスト、OK/キャンセルボタンがあります。

dialog = new MessageDialog();
dialog.Title = "Title";
dialog.Message = "This is a samle message.";
dialog.Style = MessageDialogStyle.OkCancel;
dialog.ButtonPressed += new EventHandler<MessageDialogButtonEventArgs>(ButtonDownHandler);

Live ウィジェット

Live ウィジェットは、さまざまなインタラクションが実装された PSM 独自のウィジェットです。

LiveListPanel

タッチした項目に対して、時間差を伴って他の項目がスクロールするリストウィジェットです(図22)。

図22 LiveListPanel

LiveJumpPanel

パネル内に配置したウィジェットを画面手前にジャンプさせることのできるパネルウィジェットです。 加速度センサーの値変化やボタンの押下など任意のタイミングで子ウィジェットをジャンプさせることが可能です。

LiveFlipPanel

左右のフリックで回転するパネルウィジェットです(図23)。表と裏のウィジェットを指定することが可能です。

図23 LiveFlipPanel

LiveScrollPanel

タッチした点を起点として、ゆがみながらスクロールするパネルウィジェットです(図24)。

図24 LiveScrollPanel

LiveSphere

球体状のウィジェットです(図25)。左右にフリックすることで回転できます。またタップに対するイベントハンドラも定義されており、ボタンとしても利用できます。

図25 LiveSphere

LiveSpringPanel

加速度センサーやパネルの動きに応じて子ウィジェットが揺れるパネルです(図26)。

図26 LiveSpringPanel

ウィジェット毎にばね定数や減衰定数を指定することが可能です。

liveSpringPanel = new LiveSpringPanel();
liveSpringPanel.ReflectSensorAcceleration = true;
liveSpringPanel.ReflectMotionAcceleration = true;
liveSpringPanel.SetPosition(0.0f, 0.0f);
liveSpringPanel.SetSize(200.0f, 200.0f);

button = new Button();
liveSpringPanel.AddChildLast(button);
liveSpringPanel.SetSpringConstant(button, SpringType.All, 0.5f);
liveSpringPanel.SetDampingConstant(button, SpringType.All, 0.3f);


エフェクトとトランジション

Effect クラス、Transition クラスの概要と使用方法について解説します。 CatalogSample も並行して参照してください。

Contents

  • Effects
    • SlideInEffect, SlideOutEffect
    • FadeInEffect, FadeOutEffect
    • ZoomEffect
    • JumpFlipEffect
    • BunjeeJumpEffect
    • TiltDropEffect
    • FlipBoardEffect
  • Transitions
    • SlideTransition
    • PushTransition
    • CrossFadeTransition
    • JumpFlipTransition
    • BunjeeJumpTransition
    • TiltDropTransition
    • FlipBoardTransition

Effects

Effect は、Scene に配置されている個々の Widget に対して、スライドアニメーションやフェードインといった演出効果を付与するためのクラスです。

Effect は下記のようにして利用します。

SlideOutEffect effect = new SlideOutEffect(this, 300);
effect.EffectStopped += HandleEffectEffectStopped;
effect.Start();

Effect オブジェクトの Start() メソッドを呼び出すと、UISystem にその Effect オブジェクトが登録されます。

UISystem は、UISystem.Update() が呼び出されるタイミングで、登録済みの Effect オブジェクトの更新処理を行います。各 Effect が終了条件に達すると、Effect の終了ハンドラ EffectStopped() が呼び出され、UISystem への登録が解除されます。なお、このタイミングでは Effect に対して明示的に Dispose() メソッドは呼び出されません。

また、Effect に対して、明示的に Stop() メソッドを呼び出した場合も同様で、終了ハンドラ EffectStopped() の呼び出しと UISystem からの登録解除が行われます。

Effect クラスは独自に作成・カスタマイズすることも可能です。以下では、標準で用意している Effect について説明していきます。

SlideInEffect, SlideOutEffect

SlideInEffect は、指定した Widget を画面の外から X、Y プロパティで指定した位置に移動させる Effect です(図1)。SlideOutEffect は逆に、指定した Widget を X Y プロパティで指定した位置から画面の外へ移動させる Effect です(図1)。 Visible プロパティが false の時は ture に変更されて Effect が実行されます。 移動する際のアニメーションカーブは変更可能です。

SlideInEffect slideInEffect = new SlideInEffect();
slideInEffect.Start();

図1 SlideInEffect と SlideOutEffect

FadeInEffect, FadeOutEffect

いわゆるフェードイン、フェードアウトを行う Effect です(図2)。 Alpha プロパティが現在の値から 255 もしくは 0 に遷移します。 FadeInEffect の場合、現在の Visible プロパティは true にします。 FadeOutEffect の場合、Effect 終了時には、Visible プロパティを false にし、Alpha プロパティは 255 にリセットされます。

図2 FadeInEffect と FadeOutEffect

ZoomEffect

指定した拡大率に Widget を拡大・縮小させる Effect です(図3)。 拡大・縮小にかける時間と、補間関数を指定することが可能です。

図3 ZoomEffect

JumpFlipEffect

currentWidget と nextWidget の2つの Widget を指定可能な Effect で、currentWidget が画面手前方向にジャンプして回転し、nextWidget に切り替わります(図4)。

図4 JumpFlipEffect

BunjeeJumpEffect

指定した Widget が画面外上方から、Widget を配置した位置に向かってスライドして移動する Effect です(図5)。 バンジージャンプのように、ある程度跳ねた後に、配置した位置に静止します。 跳ねる度合いを Elasticity の値で調節することが可能です。 Dialog などを表示する際に利用することを想定しています。

図5 BunjeeJumpEffect

TiltDropEffect

指定した Widget が傾きながら落下するように移動する Effect です(図6)。 落下する方向も指定することができます。 BunjeeJumpEffect で表示した Dialog を、TiltDropEffect で画面外に移動させる、というように組み合わせても面白いでしょう。

図6 TiltDropEffect

FlipBoardEffect

currentWidget と nextWidget の2つの Widget を指定することが可能な Effect で、フリップ時計のように、currentWidget が上下の中心で半分に折れ、回転し、nextWidget が裏から現れます(図7)。 時計やテキスト表示、写真のスライドショーなどへの応用を想定しています。

図7 FlipBoardEffect

Transitions

Transition は、Scene を切り替える際に演出効果を付与するためのクラスです。

Transition は下記のようにして利用します。

Scene nextScene = new Scene();

CrossFadeTransition transition = new CrossFadeTransition();
transition.TransitionStopped += HandleTransitionStopped;

UISystem.SetScene(nextScene, transition);

もしくは下記のようにしても利用可能です。

Scene nextScene = new Scene();

CrossFadeTransition transition = new CrossFadeTransition();
transition.TransitionStopped += HandleTransitionStopped;
nextScene.Transition = transition;

UISystem.SetScene(nextScene);

Transition クラスは独自に作成・カスタマイズすることも可能です。以下では、標準で用意している Transition について説明していきます。

SlideTransition

SlideInEffect、SlideOutEffect と同様の効果を持つ Transition です。

PushTransition

現在表示されている Scene を押し出すように新しい Scene が移動する Transition です。

CrossFadeTransition

現在表示されている Scene がフェードアウトすると同時に、新しい Scene がフェードインする Transition です。 現在表示されている Scene と新しい Scene のどちらを前面にするかを、NextSceneForward プロパティで設定することが可能です。

JumpFlipTransition

JumpFlipEffect と同様の効果を持つ Transition で、画面手前方向にジャンプして回転して新しい Scene に切り替わります。

BunjeeJumpTransition

BunjeeJumpEffect と同様の効果を持つ Transition です。

TiltDropTransition

TiltDropEffect と同様の効果を持つ Transition です。

FlipBoardTransition

FlipBoardEffect と同様の効果を持つ Transition です。


カスタムウィジェットの作成

この章では、ユーザー独自のウィジェットを作成する方法と、その際に必要な機能を解説します。

UIToolkitのソースもSDKに同梱されていますので、そちらも参考にしてください。

新しいウィジェットを作成するためには、Widget クラス または Widget クラスを派生したクラスを継承する必要があります。

Contents

  • ウィジェットの構成
  • 描画要素の作成
  • UISprite
  • イベント処理
  • 毎フレームごとの更新処理

ウィジェットの構成

ウィジェットはいくつかの描画要素 (UIElement) から構成されています。 描画要素はツリー構造になっています。

また、別のウィジェットを子供として保持することも出来ます。

以下のような、背景画像、アイコン画像、テキストからなるウィジェットの場合、2つの描画要素と Label ウィジェットで構成できます。

描画要素の作成

描画要素の UIElement には、標準で RootUIElement と UIPrimitive、 UISprite の3種類があります(表1)。

表1 UIElement の種類
UIElement | 描画要素の基底抽象クラスです。UIElementには1つのテクスチャを設定することが出来ます。
RootUIElement | UIElement のツリー構造のルートになるクラスです。ウィジェットのオブジェクトの生成時に一つだけ生成されます。Widget.RootUIElement プロパティから取得することが出来ます。
UISprite | 矩形の描画要素です。一つの UISprite に複数の矩形を含めることが出来ます。
UIPrimitive | ポリゴンやラインを表示することが出来る描画要素です。

UISprite

UISprite は矩形を表示する描画要素で、もっとも簡単な描画要素になります。

一つの UISprite で複数の矩形を表示することが出来ます。

１つの矩形をあらわすのが、 UISpriteUnit です。

UISpriteUnit は左上の位置と幅、高さ、上下左右のテクスチャ座標を指定することが出来ます。

UISprite オブジェクトを作成する場合は、コンストラクタで UISpriteUnit の最大数を設定します。

ImageAsset image = new ImageAsset("/Application/img.png");

sprite = new UISprite(1);
sprite.ShaderType = ShaderType.TextureArgb;
sprite.Image = image;

UISpriteUnit unit = sprite.GetUnit(0);
unit.X = 0.0f;
unit.Y = 0.0f;
unit.Width  = image.Width;
unit.Height = image.Height;

this.RootUIElement.AddChildLast(sprite);

イベント処理

タッチイベントに対する処理を記述する場合は、OnTouchEvent メソッドをオーバーライドして下さい。

タッチ点とウィジェットのヒット判定をカスタマイズする場合は、HitTest メソッドをオーバーライドしてください。

同様に、キーイベントに対する処理を記述する場合は、OnKeyEvent メソッドをオーバーライドし、モーションイベントに対する処理を記述する場合は、OnMotionEvent メソッドをオーバーライドしてください。

毎フレームごとの更新処理

毎フレームごとの更新処理が必要な場合は OnUpdate メソッドを使用します。

そのウィジェットに特化したアニメーションを作成する場合などに使用することが出来ます。 なお、汎用的なアニメーションを作成する場合はEffectクラスを使用することを推奨しています。

更新処理を記述したい場合には OnUpdate メソッドをオーバーライドし、必要な処理を記述します。 OnUpdate メソッドはフレーム毎に一回呼ばれます。

ただし、Visible プロパティが False の場合は、OnUpdate メソッドは実行されません。


カスタムエフェクト/トランジションの作成

この章では、ユーザー独自のカスタムエフェクトを作成する方法を解説します。

UI Toolkit のソースコードも SDK に同梱されていますので、そちらも参考にしてください。

Contents

  • Effect の処理の流れ
  • カスタムエフェクトの作成
  • Effect クラスのプロパティとイベントハンドラ
  • Transition のライフサイクル
  • カスタムトランジションの作成
  • Transition 実行中の描画
  • Transition クラスのプロパティとイベントハンドラ
  • 補間関数

Effect の処理の流れ

まず、Effect のライフサイクル(図1)について説明します。

図1 エフェクトのライフサイクル

Effect は下記の3つのステップに沿って処理が進められます。

1.開始処理

Effect の動作を開始させるには、Effect.Start メソッドを呼ぶ必要があります。 Effect.Start メソッド内では、以下の処理が行われます。

  • UISystem に Effect を登録
  • Effect.OnStart ハンドラの呼び出し

2.フレーム毎の処理

UISystem に Effect が登録されている場合、UISystem.Update メソッド内で下記の更新処理が行われます。

  • Effect.OnUpdate ハンドラの呼び出し
  • Effect.OnUpdate ハンドラの戻り値を判定と、終了処理(必要に応じて)

3.終了処理

Effect.OnUpdate の戻り値が Finish のとき、または、Effect.Stop メソッドが呼ばれた場合、下記の終了処理が行われます。

  • Effect.OnStop ハンドラの呼び出し
  • UISystem から Effect の登録を解除
  • EffectStopped イベントの発行

開始処理のあと、描画が行われる前にフレームの更新処理が行われる場合と、一度描画された後にフレームの更新処理が行われる場合があります。前者は、Scene.OnUpdate メソッドや Widget.OnAnimation メソッドで Effect.Start メソッドが呼ばれた場合になります。また、後者は Effect.OnUpdate や Widget.Render メソッドで Effect.Start メソッドが呼ばれた場合になります。

カスタムエフェクトの作成

カスタムエフェクトを作成するには、Effect クラスの派生クラスを作成し、以下のメソッドをオーバーライドする必要があります。

OnStart

カスタムエフェクトが UISystem に登録された後、初期化される際の処理を記述します。OnUpdate が実行される前に描画されても正常に描画されるように記述して下さい。

OnUpdate

カスタムエフェクトの更新処理を記述します。フレーム毎に呼び出され、引数 elapsedTime には前回更新されてから経過した時間（ミリ秒）が格納されています。戻り値 TransitionUpdateResponse でエフェクトを継続(TransitionUpdateResponse.Continue)するか終了(TransitionUpdateResponse.Finish)するかを指定する必要があります。

OnStop

カスタムエフェクトの終了時の処理を記述します。エフェクトを途中で終了させても正常な状態で終了するように記述して下さい。

Effect クラスのプロパティとイベントハンドラ

IsPlaying プロパティ

OnStart が呼ばれて、現在アニメーション中かどうかを表すプロパティです。

Widget プロパティ

エフェクトの対象となるウィジェットを保持します。Effect クラスを使ってバックグラウンドで何らかの処理をさせる場合など、必ずしも使用する必要はありません。 複数の Widget を対象する、UIElement を対象にする場合などは、別途プロパティを定義して下さい。

TotalElapsedTime プロパティ

OnStart が呼ばれてから現在までの経過時間（ミリ秒）を保持しています。

EffectStopped イベントハンドラ

OnStop が呼ばれた際に呼ばれるイベントハンドラです

Transition のライフサイクル

Effect とほぼ同様のライフサイクルになります(図2)。

図2 トランジションのライフサイクル

1.開始処理

UISystem.SetScene メソッドが呼び出されると、以下の処理が行われます。 - UISystem に Transition を登録される - NextScene に遷移先の Scene がセットされる - CurrentScene と NextScene にイベントを配信しないように設定（scene.IgnoreEvent プロパティに true を設定) - Transition.OnStart メソッドが呼ばれる

2.フレーム毎の処理

UISystem.SetScene が呼び出された後、UISystem.Update メソッド内で以下の処理が行われます。 - Transition.OnUpdate が呼ばれる - Transition.OnUpdate の戻り値を判定し、終了なら終了処理を行う

3.終了処理

Transition.OnUpdate の戻り値が TransitionUpdateResponse.Finish のとき、または、別の画面が SetScene された場合は以下の処理が行われます。 - Transition.OnStop メソッドが呼ばれる - CurrentScene に NextScene を設定する - CurrentScene へのイベント配信再開 - UISystem からその Transition が登録解除される - TransitionStopped イベントを発行する

カスタムトランジションの作成

カスタムトランジションを作成するには、Transition クラスの派生クラスを作成し、以下のメソッドをオーバーライドする必要があります。

OnStart

カスタムトランジションを開始する際の処理を記述します。必要に応じてトランジションの更新処理中の描画順序を指定します。描画順序は TransitionDrawOrder 列挙体で指定することが可能です。

OnUpdate

カスタムトランジションの更新処理を記述します。引数 elapsedTime は前回の Update からの経過時間（ミリ秒）を保持しています。戻り値でトランジションを継続(TransitionUpdateResponse.Update)するか終了(TransitionUpdateResponse.Finish)するかを指定する必要があります。

OnStop

カスタムトランジションを停止させる際の処理を記述します。トランジションを途中で終了させても正常な状態で終了するように記述して下さい。

Transition 実行中の描画

通常は一つの Scene しか表示することはできませんが、Transition の更新処理が実行されている際は CurrentScene（遷移元のシーン）、NextScene（遷移先のシーン）、TransitionUIElement を表示することが可能です。

Transition クラスのプロパティとイベントハンドラ

TransitionUIElement プロパティ

Transition 実行中にのみ使用できる遷移元・遷移先のどちらのシーンにも属さない RootUIElement です。Transition の更新処理中にのみ、ある UIElement を描画したいときはこの TransitionUIElement の子要素として追加してください。例えば、遷移元や遷移先のシーンをテクスチャ化して効果を与えたい場合などは、そのテクスチャを描画する UIElement を TransitonUIElement の子要素に追加して下さい。

TransitionDrawOrder プロパティ

CurrentScene、NextScene、TransitionUIElement の３つの描画順序を設定するプロパティです。TransitionDrawOrder 列挙体で指定して下さい。

TransitionStopped イベントハンドラ

画面遷移終了時(OnStop が呼ばれた時)に呼び出されるイベントハンドラです。

補間関数

AnimationUtility に static な補間関数をいくつか用意しており、アニメーションなどに利用することが可能です。

以下に補間関数の使用例を示します。

widget.X = AnimationUtility.EaseOutQuadInterpolator(fromPosX, toPosX, time / totalTime);

図3 に AnimationUtility の各補間関数を示します。

図3 AnimationUtilityの補間関数


キーイベントとフォーカス

この章では、キーイベントおよびフォーカスの詳細を解説します。基本的な事項は UI Toolkit プログラミングガイド - 基本概念 の ゲームパッドによる操作 と キーイベントの配信 を参照してください。

Contents

  • フォーカスの移動方法
    • フォーカスの移動対象
    • もっとも近いウィジェットの探し方
  • フォーカスの移動をカスタマイズする
    • FocusCustomSetting を使用する方法
    • 事前キーイベントをハンドルする方法
  • フォーカスのデザイン
    • フォーカスの描画方法
    • フォーカスイメージのカスタマイズ
    • フォーカスデザインの高度なカスタマイズ
  • その他のキーイベント、フォーカスの使用方法
    • ボタンを組み合わせて使う場合
    • フォーカス状態に関係なくキーイベントをハンドルする場合
    • フォーカス機能を使用せずにキーイベント使用する場合
  • 関連するAPIの一覧

フォーカスの移動方法

フォーカスは方向キーを押すことで自動でウィジェットを移動します。ここでは、方向キーが押されたときに、どのウィジェットにフォーカスが移動するかを解説します。

フォーカスの移動対象

フォーカスが移動する対象となるウィジェットは以下の全てを満たす必要があります。

  • 画面内に表示されている
  • Focusable プロパティが true
  • 親を含むすべての Enabled プロパティが true

たとえば、親ウィジェットにクリップされて完全に見えないウィジェットや、Visible が false のウィジェットにはフォーカスは移動しません。

Focusable プロパティは親ウィジェットが false でも子ウィジェットが true であれば、この子ウィジェットにフォーカスが移動することができます。Button ウィジェットなどキー操作できるウィジェットはデフォルトで Focusable が true になっています。逆に ImageBox や Label、Panel ウィジェット、および Widget 基底クラスなどは Focusable が false になっているので、必要に応じて値を設定してください。

方向キーが押された場合、これらのウィジェットのうち、そのキーの方向にもっとも近いウィジェットにフォーカスが移ります。

もっとも近いウィジェットの探し方

次にキーの方向にもっとも近いウィジェットの探索方法を解説します。これ以降は、右キーが押された場合のみを解説しますが、その他の方向キーも同等に動作します。

距離の求め方は、現在フォーカスのあるウィジェット(以降 「フォーカスウィジェット」とします)と検索対象のウィジェットの位置関係によって以下の3種類に分類されます。

  1. フォーカスウィジェットの内側にあるウィジェット
  2. フォーカスウィジェットを内包するウィジェット
  3. フォーカスウィジェットと重ならないウィジェット

図1 ウィジェットの位置関係の分類

フォーカスウィジェットの内側にウィジェットが存在する場合(1)はこれらのウィジェットが優先的にフォーカスの移動対象になります。それ以外の場合は、距離が最も短いものにフォーカスが移動します。

それぞれのウィジェットの距離の求め方は以下の通りです。

  1. フォーカスウィジェットの内側にあるウィジェット

    中心点が、フォーカスウィジェットの中心から角度が上下50度の範囲（図2 の Focus Target Area）に含まれているウィジェットがフォーカスの移動対象のウィジェットになります。

    フォーカスウィジェットとの中心点の距離が最も短いものがフォーカスの移動先になります。

    図2 フォーカスウィジェットの内側にあるウィジェットの距離

  2. フォーカスウィジェットを内包するウィジェット

    中心点が、フォーカスウィジェットの中心から角度が上下50度の範囲（図3 の Focus Target Area）に含まれているウィジェットがフォーカスの移動対象のウィジェットになります。

    右辺とフォーカスウィジェットの右辺の最短距離（図3 の矢印の距離）が最も短いものがフォーカスの移動先になります。

    図3 フォーカスウィジェットを内包するウィジェットの距離

  3. フォーカスウィジェットと重ならないウィジェット

    左辺が、フォーカスウィジェットの角度が上下50度の範囲（図4 の Focus Target Area）に少しでも含まれているウィジェットのみがフォーカスの移動対象のウィジェットになります。

    左辺とフォーカスウィジェットの右辺との距離（図4 の矢印の距離）が最も短いものがフォーカスの移動先になります。

    ただし、同一の距離のウィジェットが複数ある場合は、中心点どうしの距離が一番短いものが優先されます。

    図4 フォーカスウィジェットと重ならないウィジェットの距離

フォーカスの移動をカスタマイズする

FocusCustomSetting を使用する方法

ウィジェットの FocusCustomSettings プロパティを使用することで、ウィジェットごとにフォーカスに関する機能をカスタマイズすることができます。

FocusCustomSettings の LeftCandidate、RightCandidate、UpCandidate、DownCandidate プロパティにウィジェットを設定すると、対応する方向キーが押された場合にそのウィジェットにフォーカスが移動します。

FocusCustomSetting の初期値は null なので、以下のようにインスタンスを設定してから、各値を設定してください。

button1.FocusCustomSetting = new FocusCustomSetting();
button1.FocusCustomSetting.RightCandidate = button2;

この例では、button1 にフォーカスがあるときに右キーが押されると、button2にフォーカスが移動します。

xxxCandidate に設定されたウィジェットは同一のシーンに存在し手入れさえすれば、Focusable や Visible が false でもそのウィジェットにフォーカスが移動します。

事前キーイベントをハンドルする方法

ウィジェットの PreviewKeyEventReceived イベント、または OnPreviewKeyEvent メソッドで方向キーをハンドルすることで、フォーカスの移動先を変更することもできます。

フォーカスを移動するには移動させたいウィジェットの SetFocus メソッドを呼び出してください。

以下の例では、前述の FocusCustomSetting.RightCandidate を設定する場合と同じ挙動になりますが、より複雑な移動アルゴリズムを作成することもできます。

button1.PreviewKeyEventReceived = (sender, e) => {

    if (e.KeyEventType == KeyEventType.Down ||
        e.KeyEventType == KeyEventType.Repeat)
    {
        if (e.KeyType == KeyType.Left)
        {
            button2.SetFocus(true);
            e.Handled = true;
        }
    }
}

フォーカスのデザイン

フォーカスのデザインとそのカスタマイズ方法について説明します。

フォーカスの描画方法

初期状態ではフォーカスのイメージは青色が乗算され、かつ加算描画されます(図5)。これらは、それぞれ UISystem.FocusFilterColor、UISystem.FocusBlendMode プロパティで変更することができます。

図5 フォーカスの描画方法

フォーカスイメージのカスタマイズ

フォーカスのイメージは標準で4種類用意されており、ウィジェットの FocusStyle プロパティを指定することで変更できます(図6)。

図6 FocusStyle のデザイン

FocusStyle 以外のイメージを使用する場合は、FocusCustomSettings.FocusImage を使用してください。また、フォーカスのサイズはウィジェットのWidthとHeightを基準にしますが、ウィジェットの FocusCustomSettings.FocusImageRectangle プロパティを指定して変更することもできます。

フォーカスデザインの高度なカスタマイズ

フォーカスのデザインはシーンやダイアログの最前面に表示されます。またウィジェットが変形している場合は、外接する矩形として表示されます(図7)。

図7 フォーカスの表示のされ方

フォーカスのイメージをウィジェットの背面に表示したり、ウィジェットの変形に合わせる必要がある場合は、カスタムウィジェットを作成して独自に描画する必要があります。この場合、FocusStyle を None に設定して、ウィジェット自身にフォーカス用の描画要素を追加し、OnFocusChangedをハンドルしてその描画要素の表示を切り替えてください。

その他のキーイベント、フォーカスの使用方法

ボタンを組み合わせて使う場合

ボタンを組み合わせて使いたい場合は UISytem.GamePadData プロパティを使用して以下のようにハンドルしてください。UISytem.GamePadData プロパティの値は、UISytem.Update の引数で渡された GamePadData の値がそのまま取得できます。

// handle "L" + "Triangle" key
void KeyEventReceivedHandler(object sender, KeyEventArgs e)
{
    // check "L" button as alternate key
    if (UISystem.GamePadData.Buttons.HasFlag(GamePadButtons.L))
    {
        if (e.KeyType == KeyType.Triangle && e.KeyEventType == KeyEventType.Down)
        {
            DoSomething();
            e.Handled = true;
        }
    }
}

フォーカス状態に関係なくキーイベントをハンドルする場合

あるキーを押したとき、シーン内のどのウィジェットにフォーカスが当たっているか関係なく操作を行いたい場合は、RootWidget の KeyEventReceived または PreviewKeyEventReceived イベントにイベントハンドラを登録してください。

フォーカス機能を使用せずにキーイベント使用する場合

UISystem.EnabledFocus プロパティを false にすることで、フォーカスの機能を無効にすることができます。この場合、方向キーによるフォーカスの操作や、フォーカスの表示は出来ませんが、RootWidget へのイベント配信は行われます。さらに、Widget.SetFocus メソッドを用いて手動でフォーカス設定をすれば、そのウィジェットと親ウィジェットに対してキーイベントが配信されます。

関連するAPIの一覧

表1 キーイベントに関連するAPI一覧

クラス名 | メンバー名 | 説明
UISystem | Update | キーイベントを有効にするために、メインループから引数に GamePadData を指定して呼び出す必要があります。
GamePadData | Update で渡された GamePadData を返すプロパティです。
Widget | OnPreviewKeyevent | 事前キーイベントを受け取った時に呼び出される仮想関数です。
PreviewKeyEventReceived | 事前キーイベントを受け取った時に呼び出されるイベントです。
OnKeyEvent | キーイベントを受け取った時に呼び出される仮想関数です。
KeyEventReceived | キーイベントを受け取った時に呼び出されるイベントです。

表2 キーフォーカスに関連するAPI一覧

クラス名 | メンバー名 | 説明
UISystem | FocusActive | フォーカスが現在アクティブかどうかを設定するプロパティです。
EnabledFocus | フォーカス機能を有効にするかどうかを設定するプロパティです。
SuppressFocusKeyEvent | フォーカスのキーイベント配信を一時停止させるかどうかを設定するプロパティです。
FocusFilterColor | フォーカスイメージのフィルターカラーを設定するプロパティです。
FocusBlendMode | フォーカスイメージのブレンドモードを設定するプロパティです。
Scene | FocusWidget | 現在このシーンでフォーカスが当たっているウィジェットを取得するプロパティです。
DefaultFocusWidget | 最初にフォーカスが当たるウィジェットを設定するプロパティです。
Widget | Focused | 現在自分にフォーカスが当たっているかどうかを取得するプロパティです。
Focusable | フォーカスが当たるかどうかを設定するプロパティです。
SetFocus | 自分自身にフォーカスをあてるメソッドです。
SearchNextFocus | 次にフォーカスの当たるウィジェットを探すメソッドです。
SearchNextFocusFromChild | 子ウィジェットの中から次にフォーカスの当たるウィジェットを探すメソッドです。
OnFocusChanged | フォーカスを取得または喪失したときに呼び出される仮想関数です。
FocusChanged | フォーカスを取得または喪失したときに呼び出されるイベントです。
FocusStyle | フォーカスの表示スタイルを設定するプロパティです。
FocusCustomSettings | ウィジェットごとにフォーカスをカスタマイズするための情報のプロパティです。
FocusCustomSettings | LeftCandidate | 左キーを押した場合のフォーカスの移動先ウィジェットを指定するプロパティです。
RightCandidate | 右キーを押した場合のフォーカスの移動先ウィジェットを指定するプロパティです。
UpCandidate | 上キーを押した場合のフォーカスの移動先ウィジェットを指定するプロパティです。
DownCandidate | 下キーを押した場合のフォーカスの移動先ウィジェットを指定するプロパティです。
SearchHintRectangle | フォーカスを検索する場合の矩形を指定するプロパティです。
FocusImageRectangle | フォーカスを表示する際の矩形(位置とサイズ)を指定するプロパティです。
FocusImage | フォーカスのカスタムイメージを指定するプロパティです。
FocusImageNinePatchMargin | フォーカスのカスタムイメージの9パッチマージンを指定するプロパティです。
FocusImagePadding | フォーカスのカスタムイメージを外側に広げる大きさを指定するプロパティです。


UI Toolkit の描画の仕組み

UI Toolkit の描画の仕組みについて解説します。

Contents

  • Widget や UIElement の3D 配置の方法
  • 3D 描画で使用される座標系
  • 3D 描画時の制約
    • Widget のクリッピング領域
    • Widget のヒット判定
  • ZSort プロパティについて
  • 描画処理の流れ
  • GraphicsContext について

Widget や UIElement の3D 配置の方法

UI Toolkit では、従来通りの平面的なウィジェットの中に、部分的に立体的な表現を混在させることができます。

Widget や UIElement を 3D 座標系で配置する場合は、Transform3D プロパティや Z プロパティを使用して位置を設定します。

3D 座標系で Widget と UIElement の位置設定を行うコード例を以下に示します。

// set position Z

// Widget
Matrix4 mat = widget.Transform3D;
mat.M43 = -100.0f;
widget.Transform3D = mat;
// another way
widget.Transform3D = Matrix4.Translation(new Vector3(widget.X, widget.Y, -100.0f));

// UIElement (UISprite and UIPrimitive)
Matrix4 mat2 = uiElement.Transform3D;
mat2.M43 = -100.0f;
uiElement.Transform3D = mat2;

// UISpriteUnit
UISpriteUnit unit = uiSprt.GetUnit(0);
unit.Z = -100.0f;

// UIPrimitiveVertex
UIPrimitiveVertex vertex = uiPrimitive.GetVertex(0);
vertex.Z = -100.0f;

3D 描画で使用される座標系

3D 描画で使用される座標系は、以下のような右手座標系になっています(図1)。

  • 画面右方向が X 軸の正の方向

  • 画面下方向が Y 軸の正の方向

  • 画面奥方向が Z 軸の正の方向

    図1 UI Toolkit の使用する 3D 座標系

3D 描画時の制約

Widget や UIElement の 3D 表現を行う際は、以下の点に注意してください。

Widget のクリッピング領域

Widget のクリッピング領域は X、Y 座標と幅と高さのみ使って決定されるため、3D 座標系で配置された Widget や UIElement は正しくクリッピングされません。

Widgetを3D座標系で配置する際は、Clip プロパティに false を設定してクリッピングをオフにしてください。

Widget のヒット判定

Widget のヒット判定もクリッピング領域同様に、X、Y座標と幅、高さのみで決定されます。

Widget を 3D 座標系で配置する際は、TouchResponse プロパティに false を設定してヒット判定を切るか、HitTest メソッドをオーバーライドして正しいヒット判定処理を記述してください。

ZSort プロパティについて

3D 配置されている描画要素の前後関係が時間と共に変化する場合は、正しい描画を行うために、画面上での Z 座標が大きい要素（奥にあるもの）から順に描画する必要があります。

Widget や UIElement の ZSort プロパティを true にすると、true にした対象が 3D 描画される際に、自動的に画面の奥方向から手前の順にソートされて、描画が行われます。

また、ZSort 指定された Widget や UIElement に対して、ZSort 指定されていない子要素はひとまとまりとしてソートされます。

図2 に UIElement に ZSort が指定された際のグループの例を示します。

図2 ソート時の UIElement のグループ分けの例

描画処理の流れ

UI Toolkit では、図3 のような手順で描画処理を行います。

図3 UIToolkit の描画処理の流れ

GraphicsContext について

UI Toolkit では、初期化処理時（UISystem.Initialize）と描画処理時（UISystem.Render）に、以下の Sce.PlayStation.Core.Graphics.GraphicsContext のステートを変更しますので、UI Toolkit 以外でも描画処理を行う場合には注意してください。

UISystem.Initialize 呼び出し時に変更されるステート

  • EnableMode.Blend（trueに設定されます）
  • EnableMode.ScissorTest（trueに設定されます）
  • FrameBuffer（nullに設定されます）
  • BrendFunc（BlendFuncMode.Add, BlendFuncFactor.SrcAlpha, BlendFuncFactor.OneMinusSrcAlphaに設定されます）

UISystem.Render 呼び出し時に変更されるステート

  • Scissor
  • ShaderProgram
  • Texture
  • VertexBuffer
  • Viewport（全画面に設定されます）
  • FrameBuffer（nullに設定されます）

なお、これ以外のステートに関しても描画処理時に変更する場合がありますが、描画処理終了後に適切に復元されます。


Adobe Flashとの連動

この章では、Adobe Flash を利用してウィジェットアニメーションを制作する方法を解説します。

Contents

  • Adobe Flashとの連動
  • モーションデータの利用方法
  • アニメーションデータの利用方法
  • 注意点

Adobe Flashとの連動

UIToolkit では、Adobe Flash で制作されたモーション(動き)を Widget に適用することや、アニメーション(複数の画像とモーションのセット)を専用 Player を用いて再生することができます。

モーションやアニメーションを定義するための専用バイナリフォーマットとして、uim フォーマット、uia フォーマットを用意しています。

uim フォーマットは、モーションを定義するためのフォーマットです。UIMotion クラスを用いて uim ファイルをロードし、Widget にモーションを適用することができます。

uia フォーマットは、アニメーションを定義するためのフォーマットです。UIAnimationPlayer を用いて uia ファイルをロードし、アニメーションを再生することができます。

PSM SDK に付属の AnimationConverter ツール を使用すれば、Adobe Flash で制作されたデータを uim、uia ファイルにコンバートすることができます。

モーションデータの利用方法

モーションデータを利用する手順を解説します(図1)。

図1 モーションデータの利用手順

  1. Adobe Flash を用いてモーションを制作

  2. モーションをモーションプリセットファイル(*.xml)として保存

    2-1. 保存したいモーションを選択し、右クリック > [モーションプリセットとして保存] を選択

    2-2. プリセット名を入力し、[OK] を選択

    2-3. [ウィンドウ] > [モーションプリセット] にチェックマークを追加

    2-4. モーションプリセットウィンドウで保存したいプリセットを選択し、右クリック > [書き出し] を選択

    2-5. xml の名前を入力し、[保存] を選択

  3. AnimationConverter ツールを用いて uim ファイルに変換

    以下のコマンドを利用し、2. で保存した xml ファイルを uim ファイルに変換

    cd %SCE_PSM_SDK%/tools/AnimationConverter/
AnimationConverter.exe <XML file path>

    uim ファイルへの変換時に AnimationConverter ツールで使用できるオプションは表1 の通りです。

    表1 uim の変換時に使用できるオプション

    オプション

    説明

    -o, --output-filename

    出力ファイル名を指定する。指定がなかった場合、入力ファイル名の拡張子を *.uim に変換したものを出力ファイル名として使用する。

    --help

    ヘルプ情報を表示する。

    --version

    バージョン情報を表示する。

  4. UIMotion クラスを用いて、3. で作成した uim ファイルをロードし、Widget にモーションを追加

    uim ファイルを UIMotion クラスを用いて読み込み、Button にモーションを適用するサンプルコード

    Button button = new Button();
button.SetPosition(100.0f, 100.0f);
scene.RootWidget.AddChildLast(button);

UIMotion.CreateAndStart(button, "/Application/sample.uim");

アニメーションデータの利用方法

アニメーションデータを利用する手順を解説します(図2)。

図2 アニメーションデータの利用手順

  1. Adobe Flash を用いてアニメーションを制作

  2. 制作したアニメーションを xfl 形式で保存

    2-1. [ファイル] > [名前を付けて保存] を選択

    2-2. ファイルの種類 として、[Flash CS5.5 非圧縮ドキュメント (*.xfl)] もしくは、[Flash CS5 非圧縮ドキュメント (*.xfl)] を選択し、[保存] を選択

  3. AnimationConverter ツールを用いて uia ファイルに変換

    以下のコマンドを利用し、2. で保存した xfl ファイルを uia ファイルに変換

    cd %SCE_PSM_SDK%/tools/AnimationConverter/
AnimationConverter.exe <XFL file path>

    uia ファイルへの変換時に AnimationConverter ツールで使用できるオプションは表2 の通りです。

    表2 uia の変換時に使用できるオプション

    オプション

    説明

    -o, --output-filename

    出力ファイル名を指定する。指定がなかった場合、入力ファイル名の拡張子を *.uia に変換したものを出力ファイル名として使用する。

    -c, --config

    設定ファイルを指定する。

    --create-config

    デフォルトの設定ファイル(default.config)を生成する。このオプションを指定した場合は、他のオプションはすべて無視される。

    --help

    ヘルプ情報を表示する。

    --version

    バージョン情報を表示する。

    AnimationConverter では、Adobe Flash のムービークリップ単位でアニメーションをループするかしないかを制御することができます。

    ループの制御を行う場合は、以下のような設定ファイルを用意し、uia ファイルに変換する際に指定してください。

    _root,loop=off
sampleA,loop=on
sampleB,loop=off
sampleC,loop=on

    設定ファイルは、csv 形式で記述し、先頭フィールドにムービークリップ名、二番目のフィールドにループの on/off を指定してください。

    ループの指定がなかった場合は、デフォルトでループします。

    ムービークリップ名として "_root" を指定した場合は、アニメーション全体をループ再生するかどうかを指定できます。

  4. UIAnimationPlayer クラスを用いて、3. で作成した uia ファイルをロードし、アニメーションを再生

    uia ファイルを UIAnimationPlayer クラスを用いて読み込み、アニメーションを再生するサンプルコード

    UIAnimationPlayer uiaPlayer = new UIAnimationPlayer("/Application/sample.uia");
uiaPlayer.SetPosition(100.0f, 100.0f);
scene.RootWidget.AddChildLast(uiaPlayer);

uiaPlayer.Play();

注意点

  • AnimationConverter ツールは、現在、Adobe Flash CS5 以降で制作されたデータにのみ対応しています。
  • Adobe Flash のアートワーク(bmp, jpeg, png, gif)、モーショントゥイーンのみに対応しています。クラシックトゥイーン、シェイプトゥイーン、フレームアニメーション、ベクターグラフィックス、テキスト、サウンド、ビデオ、ActionScript等には対応していません。
  • モーショントゥイーンで使用可能なプロパティは、基本モーション(X、Y、Z、回転 X、回転 Y、回転 Z)、変形(伸縮 X、伸縮 Y)、カラー効果(アルファ)のみです。傾斜変形、フィルター等には対応していません。
  • アニメーションのイージングカーブは、現時点では完全に再現できていない場合があります。また、カスタムイージングカーブには対応していません。
  • 複数シーンには対応していません。


はじめに

Contents

  • UI Composer とは？
  • UI Composerを利用したUI開発の流れ

UI Composer とは？

UI Composer は、UI Toolkit を利用してGUIを実装する際の「画面レイアウト」をサポートするためのツールです(図1)。

視覚的にWidgetのレイアウトやプロパティの設定を行うことが可能で、作業結果は UI Toolkit 用のソースコードに出力されます。

図1 UI Composer全体図

UI Composerを利用したUI開発の流れ

図2 UI Composerを利用したUI開発の流れ

UI Composer を利用する開発の流れは下記のような流れになります。

  1. UI Composer を使用して、Widgetの配置やプロパティの設定を行います。
  2. レイアウトなどの情報は C# のソースコードとして出力されます。レイアウト情報を格納したソースコードと、アプリケーションロジックやイベントハンドラを実装するためのソースコードが別々に出力されます。
  3. 出力されたソースコードを作成するアプリケーションのプロジェクトに取り込み、アプリケーションロジックやイベントハンドラなどのコードを追加します。
  4. アプリケーションをビルドし、シミュレータもしくはデバイス上でテストを行います。


クイックスタート

この章では、UI Composer によるレイアウト作業を概観できるように、シンプルなアプリケーションの作成を例に解説していきます。

レイアウトした内容をソースコードとして出力し、 UI Toolkit プログラミングガイド - クイックスタート に記載されているプロジェクト(以下、PSM Studio プロジェクトとします)に取り込むまでの流れを説明します。 事前に UI Toolkit プログラミングガイド - クイックスタート に沿って PSM Studio プロジェクトを作成してください。

Contents

  • UI Composer のプロジェクト作成
  • レイアウトの作成
  • ウィジェットの配置・編集
  • C# ソースコードの出力
  • PSM Studioプロジェクトへの追加

UI Composer のプロジェクト作成

まず、UI Composer のプロジェクトを新規に作成します。 UI Composerを起動し、メインメニューから [ファイル] - [プロジェクトの新規作成] を選択します(図1)。

図1 UI Composer プロジェクトの新規作成

新規プロジェクト作成用のダイアログの各項目に以下のように入力してください(図2)。

  • 「プロジェクト名」には PSM Studio プロジェクトのプロジェクト名と同じ名前を入力します。この例では SampleApp とします。
  • 「ファイルパス」には PSM Studio プロジェクトファイル (csprojファイル) のあるフォルダーを入力します。この例では C:\Projects\SampleApp\SampleApp とします。

図2 プロジェクト名、フォルダーの入力

レイアウトの作成

プロジェクトの新規作成ダイアログで「OK」ボタンを選択すると、次に、レイアウト新規作成ダイアログが表示されます(図3)。

図3 レイアウトの新規作成ダイアログ

ここでは、ウィジェットの配置先となるレイアウトを作成し、レイアウト作業を行うための画面であるレイアウトキャンバスを作成します。 レイアウは後で追加していくことが可能で、１つのレイアウトが出力される１つのクラスに対応しています。

レイアウトの新規作成ダイアログの各項目に以下のように入力してください(図4)。

  • 「レイアウトするクラス」にはデフォルトで Scene が選択されています。この例ではここは変更しません。
  • 「クラス名」には自動生成されるクラスの名前を入力します。この例では SampleScene と入力します。
  • 「画面サイズ」にはレイアウトするクラスの幅と高さを入力します。いくつかの設定がプリセットとして用意されており、その中から選択することも可能です。この例ではプリセットから 幅 854 px、高さ 480 px を指定します。

図4 レイアウトの設定項目の入力

「OK」ボタンを選択するとレイアウトウィンドウに新規にレイアウトキャンバスが表示されます(図5)。

図5 新規に作成されたレイアウトキャンバス

ウィジェットの配置・編集

Label、Button、ImageBox の3つのWidgetを利用したGUI画面をレイアウトします。

まず、WidgetList ウィンドウから Label をレイアウトキャンバス上にドラッグアンドドロップして配置します(図6)。

図6 Labelの配置

Label を選択すると、プロパティウィンドウに Label プロパティが表示されます。 Textプロパティを編集することで、Label に表示させるテキストを編集することができます(図7)。

図7 LabelのTextプロパティの編集

続いて Label と同様に、Button を ウィジェットリストウィンドウからレイアウトキャンバス上にドラッグアンドドロップして配置します。

最後に ImageBox を配置します。

まず アセットウィンドウで 「Import image」ボタンから表示したい画像ファイルを選択し、画像ファイルをアセットとして読み込みます。この例では image.png ファイルを追加しています(図8)。

図8 画像ファイルの読み込み

次に アセットウィンドウで読み込まれた画像を選択し、レイアウトキャンバス上にドラッグアンドドロップして配置します(図9)。

図9 ImageBox の配置

これでレイアウト作業は完成です(図10)。

図10 レイアウトを行ったSampleScene

C# ソースコードの出力

レイアウトした内容をソースコードとして出力します。

UI Composer のメインメニューから [ファイル] - [ビルド] を選択し、プロジェクトをビルドします(図11)。

図11 UI Composer プロジェクトのビルド

初期設定では、UI Composer のプロジェクトファイルと同じフォルダーに C# のソースコードが生成されます。 この例では、SampleScene.cs、SampleScene.composer.cs および UIStringTable.cs という３つのファイルが生成されます。

SampleScene.cs と SampleScene.composer.cs は SampleScene クラスの部分クラス定義(partial class definition)になっており、前節で行ったレイアウト作業の内容は、全て SampleScene.composer.cs に定義されています。SampleScene.composer.cs はビルドする度に上書きされますので、ボタンを押した際のイベントハンドラなどは、SampleScene.cs に記述して下さい。SampleScene.cs は既に存在する場合、生成されません。

ここまでで UI Composer の操作は終了です。

PSM Studioプロジェクトへの追加

PSM Studio プロジェクトを、レイアウトしたSampleSceneが表示されるように変更します。

まず、PSM Studio プロジェクトに UI Composer の出力結果、およびアセットファイルを取り込みます。

PSM Studio プロジェクトを開き、前節で出力した C# のファイル（SampleScene.cs、SampleScene.composer.cs および UIStringTable.cs）とアセットファイル(image.png) を追加します(図12)。

図12 PSM Studio プロジェクトにファイルを追加

アセットファイルを追加した際に、「Add File to Folder」ダイアログが表示されたら、「Keep」を選択してください(図13)。

図13 UI アセットファイルの追加方法の確認ダイアログ

追加後の PSM Studio プロジェクトは以下のようになります(図14)。

図14 UI Composer の出力結果を取り込んだ PSM Studio プロジェクト

次に、メインロジック内の初期化コードを修正します。

UI Toolkit プログラミングガイド - クイックスタート で AppMain.cs に以下のように記載した箇所を変更します。

// Create scene
Scene scene = new Sce.PlayStation.HighLevel.UI.Scene();
Label label = new Label();
label.X = 10.0f;
label.Y = 50.0f;
label.Text = "Hello World!";
scene.RootWidget.AddChildLast(label);
// Set scene
UISystem.SetScene(scene, null);

上記の箇所を以下のように変更します。 UI Composer で作成したクラス名、Namespace が異なる場合はそれに合わせてください。

// Create scene
var MyScene = new SampleApp.SampleScene();
// Set scene
UISystem.SetScene(MyScene, null);

また、背景色が白色になるように、AppMain.cs ファイルの以下の箇所を修正します。

// Clear the screen
graphics.SetClearColor (0.0f, 0.0f, 0.0f, 0.0f);
graphics.Clear ();

上記の箇所を以下のように変更します。

// Clear the screen
graphics.SetClearColor (1.0f, 1.0f, 1.0f, 1.0f);
graphics.Clear ();

この状態で UI Toolkit プログラミングガイド - クイックスタート と同様にビルド、実行することで、レイアウトした通りの画面が表示されます(図15)。

図15 シミュレータ上でのアプリケーションの実行結果


基本構成

UI Composerは、PlayStation(R)Mobile(PSM)上で動作するアプリケーション（ウィンドウやメニューなど）のGUIをレイアウトするためのツールです。

ウィジェットや画像などのオブジェクトをドラッグ操作で直感的にレイアウトすることが可能です。

また、各オブジェクトの位置、サイズ、および属性の設定を行うことができます。

本章では、UI Composer の構成、各画面の役割および機能について説明します。

Contents

  • ファイル構成
  • ツールの構成
  • レイアウトウィンドウ
  • ウィジェットリストウィンドウ
  • プロパティウィンドウ
  • オブジェクトツリーウィンドウ
  • アセットウィンドウ
  • オーバービューウィンドウ
  • 言語テーブルウィンドウ
  • ツールバー
  • 各種設定画面
    • プロジェクト設定
    • ツールの環境設定

ファイル構成

UI Composer は複数の画面を1つのプロジェクトファイル( xxxxx.uic )にまとめて管理します。各画面のレイアウト情報に加えて、クラス出力先のフォルダー設定やクラスが属する namespace の情報もこのファイルに保存されます。UI Composer を利用してアプリケーションを実装する場合のファイル構成は下記のようになります。:

SampleApp/
          SampleApp.csproj

          SampleApp.uic               : UI Composer プロジェクトファイル
          SampleApp_LanguageTable.csv : 文字列データの格納ファイル(ユーザー編集用)

          AppMain.cs                  : アプリケーションのメインロジック

          SampleA.cs                  : ユーザー定義クラスA
          SampleB.cs                  : ユーザー定義クラスB
          SampleC.cs                  : ユーザー定義クラスC

          SampleScene.cs              : SampleScene のロジック、イベントハンドラを定義したファイル (UI Composer が出力)
          SampleScene.composer.cs     : SampleScene のレイアウト情報を定義したファイル (UI Composer が出力)
          SamplePanel.cs              : SamplePanel のロジック、イベントハンドラを定義したファイル (UI Composer が出力)
          SamplePanel.composer.cs     : SamplePanel のレイアウト情報を定義したファイル (UI Composer が出力)
          SampleDialog.cs             : SampleDialog のロジック、イベントハンドラを定義したファイル (UI Composer が出力)
          SampleDialog.composer.cs    : SampleDialog のレイアウト情報を定義したファイル (UI Composer が出力)
          UIStringTable.cs            : 文字列管理クラス (UI Composer が出力)

          assets/                     : UI Composer が参照するアセットフォルダー
                 AAA.png
                 BBB.png

ツールの構成

UI Composer は 複数のウィンドウから構成されています(図1, 表1)。各ウィンドウはタブの部分をドラッグすることで、ドッキングもしくはドッキングの解除が可能です。以下、順に各ウィンドウについて説明していきます。

図1 ツール全体図

表1 各ウィンドウの一覧
名称 | 内容
メインメニュー (Main Menu) | メインメニューです。
ツールバー (Toolbar) | よく使う機能をまとめたボタン群です。
レイアウトウィンドウ (Layout Window) | ウィジェットをレイアウトするためのウィンドウです。
ウィジェットリストウィンドウ (Widget List Window) | レイアウトキャンバス上に配置できるウィジェットが表示されます。
プロパティウィンドウ (Property Window) | 各ウィジェットのプロパティ設定が表示されます。
オブジェクトツリーウィンドウ (Object Tree Window) | レイアウトキャンバス上に配置されたウィジェットをツリー状に表示します。
アセットウィンドウ (Asset Window) | アセットディレクトリ内にあるイメージアセットが表示されます。
オーバービューウィンドウ (Overview Window) | レイアウトキャンバスの俯瞰図を表示します。
言語テーブルウィンドウ (Language Table Window) | 多言語に対応したGUIを作成する際に使用します。

レイアウトウィンドウ

レイアウトウィンドウは、レイアウトキャンバス上に各種ウィジェットを配置し、アプリケーションの画面を構成していくための画面です。ウィジェットリストウィンドウ(後述)からドラッグアンドドロップして追加したウィジェットを自由に配置することが可能です。

レイアウトウィンドウは下記のような構成となっています(図2, 表2)。

図2 レイアウトウィンドウの概要

表2 レイアウトウィンドウの説明
名称 | 説明
ガイド (Guide) | ウィジェットの位置を揃えるためのガイド線です。ガイド線を任意に設定することが可能です。
スマートガイド (Smart Guide) | レイアウトキャンバスに配置されているウィジェットを基準として揃えるためのガイド線です。
グリッド (Grid) | キャンバスに表示されているグリッド線です。

レイアウトウィンドウでは、ウィジェットのレイアウト編集、操作などを行うことができます。

ウィジェットを選択するとリサイズハンドルが表示されます(図3)。リサイズハンドルをドラッグすることでサイズの変更が可能です。

図3 Widget Select

またウィジェットを選択し配置を調整する際に、ガイドやスマートガイドにウィジェットを吸着させることも可能です(図4)。

図4 ガイド線への吸着

レイアウトを整列する機能としてツールバーなどにウィジェット の水平方向、垂直方向の位置ぞろえや等間隔機能などの機能を提供しています。

より詳細な解説は、 UI Composer ユーザーガイド - レイアウトガイド を参照して下さい。

ウィジェットリストウィンドウ

ウィジェットリストウィンドウは、レイアウトキャンバス上に配置できるウィジェットの一覧です。ここからドラッグアンドドロップすることで、画面を作成します。

PSM UI Toolkitには様々なウィジェットが用意されています。UI Composer でレイアウトできるウィジェットはこのウィジェットリストウィンドウに一覧表示されます(図5)。

ウィジェットリストウィンドウ上のウィジェットを選択し、レイアウトキャンバスへ向かってドラッグアンドドロップすることで、選択したウィジェットを配置することができます。

図5 ウィジェットリストウィンドウ

ウィジェットは下記の種類にグループ分けされて表示されています。

  • 標準ウィジェット (ButtonやLabelなどの広く一般的なウィジェット)
  • パネルウィジェット (標準ウィジェットなどを格納するウィジェット)
  • PSM オリジナルウィジェット (PSM UI Toolkit独自のウィジェット)
  • すべてのウィジェット（上記ウィジェットを全て表示します）

ウィジェットのラインナップや詳細については UI Toolkitプログラミングガイド - ウィジェット を参照して下さい。

プロパティウィンドウ

プロパティウィンドウには、各ウィジェットに対して設定可能なプロパティが、全ウィジェット共通項目とウィジェット固有項目に分かれて表示されます(図6)。

プロパティウィンドウ上での設定値が変更されると、レイアウトキャンバス上のウィジェットの表示もそれに伴って変化します。ただし、一部設定値がレイアウトキャンバス上に反映されない属性もあります。

図6 プロパティウィンドウ

各ウィジェットの設定項目については UI Composer ユーザーガイド - ウィジェット を参照して下さい。

オブジェクトツリーウィンドウ

オブジェクトツリーウィンドウは、プロジェクト内に存在するウィジェットをレイアウト画面ごとにツリー表示するウィンドウです(図7, 表3)。

各レイアウト画面内のウィジェットの関係を俯瞰し、ツリー内の構成の編集や、表示の切り替えを行うことができます。

図7 オブジェクトツリーウィンドウ

表3 オブジェクトツリーウィンドウの説明
名称 | 説明
レイアウト画面 (Layout Screen) | プロジェクト内に存在するレイアウトのクラス名が表示されています。
ウィジェット (Widget) | 各レイアウトに配置されているウィジェットの変数名が表示されています。
表示アイコン (Visible Icon)

レイアウトキャンバス上で表示するかどうかを表しています。クリックすることで切り替えることができます。

  • visible-image : 表示
  • invisible-image : 非表示
  • invisible-by-parent-image : 親ウィジェットが非表示
ロックアイコン (Lock Icon)

レイアウトキャンバス上でウィジェットを選択できるかどうかを表しています。クリックすることで切り替えることができます。

  • lock-image : ロック状態
  • unlock-image : アンロック状態

ツリー内の順序は、Zオーダーに対応しており、下にあるウィジェットほどレイアウト画面で手前に表示されます。

オブジェクトツリー内で、ウィジェットをドラッグアンドドロップすることで、Zオーダーの変更や親子関係の変更を行うことができます。また、コンテキストメニューから複製、切り取り、貼り付け、削除などの操作を行うことができます。

なお、表示アイコンはプロパティウィンドウのVisibleとは異なり、出力されるコードには影響しません。

アセットウィンドウ

アセットウィンドウは、アセットフォルダーの中に保存されている画像データを表示します(図8)。

図8 アセットウィンドウ

(プロジェクトファイルのあるフォルダー)/assets を参照しています。そのため、OS側から　*(プロジェクトファイルのあるフォルダー)/assets* 以下にアセットを追加した場合でもアセットリストの表示に反映されます。

対応している画像フォーマットは .jpg .png です。

アセットウィンドウは、表4の3つの表示から構成されています。

表4 アセットウィンドウの説明
名称 | 説明
画像データのプレビュー | 選択した画像データのプレビュー表示です。プレビューとリストの間にあるセパレーターを調整することで、プレビュー画像の大きさが変化します。
画像データの一覧 | プロジェクト設定で指定されたアセットフォルダーを参照し、そのフォルダー内の画像データをツリー形式で表示しています。
各種操作ボタン | アセットフォルダーへの画像/フォルダーの追加・削除を行うためのボタンです。

通常、レイアウト画面にImage Boxを追加する場合、ウィジェットリストウィンドウからレイアウトキャンバスに配置し、Imageプロパティに任意の画像を設定することになります。アセットウィンドウを利用するとこの一連の作業を簡易化することが可能で、画像データの一覧から直接レイアウトキャンバスにドラッグアンドドロップすることで、Imageプロパティに選択した画像が割り当てられたImage Boxをレイアウト画面に追加することが可能になります。

オーバービューウィンドウ

オーバービューウィンドウは、レイアウトキャンバスの全体を俯瞰するためのウィンドウです。

レイアウトウィンドウ内のレイアウトキャンバスの拡大率を制御したり、レイアウトキャンバスの表示する領域を変更することが可能です。

オーバービューウィンドウは下記2つの要素で構成されています(図9)。

  • レイアウトキャンバスの俯瞰図
  • 拡大/縮小率変更用のコントロール

図9 オーバービューウィンドウ

レイアウトキャンバスの俯瞰図には、レイアウトウィンドウに表示される領域(View Area)を青枠線で表示しています。俯瞰図上でクリックもしくはドラッグ操作を行うことで、レイアウトキャンバスの表示領域を変更することができます。

拡大/縮小率を変更するには、既定値を選択するためのドロップダウンリストとユーザーが自由に倍率を変更できるスライダーが利用可能です。ドロップダウンリストに直接倍率を入力することも可能です。

言語テーブルウィンドウ

他の言語をサポートするアプリケーションの開発用に各種文字列を表示するために文字列を管理するためのウィンドウです。

そのために、言語テーブルウィンドウは、アプリケーションの中で使用する文字列を複数設定するための画面です。

初期状態では英語の文字列設定をすることが可能です。また、その他の言語を拡張して設定することができます。

言語テーブルウィンドウは下記2つの要素で構成されています(図10)。

  • 言語テーブル
  • 各種ボタン

行には各言語、列には文字列IDが表示され、各行と列に対応したセルに文字列IDに対応した各言語の文字列が表示されます。

図10 言語テーブルウィンドウ

言語テーブルでは、文字列IDとそれに対応する文字列を入力・編集することができます。文字列IDと表示する文字列の追加削除、対応する言語の追加削除を行うことができます。 また、csvファイルの読み込み・書き出しをサポートしています。

詳細は、 UI Composer ユーザーガイド - アプリケーションの多言語対応 を参照して下さい。

ツールバー

すべての操作はメニューから操作することが可能ですが、特によく使う機能は、ツールバーにも機能が用意されています。

ツールバーでは各操作を迅速に使うことができます。表5に用意されている機能の説明を行います。

表5 ツールバーの説明
アイコン 名称 説明
Arrow Cursor Cursor ツールにて、Widgetの拡大、縮小、移動などの操作をすることができます
HandModeButton Hand ツールにて、キャンバスの移動をすることができます
Save レイアウトした結果を UI Composer プロジェクトファイルに保存します
Open 既存の UI Composer プロジェクトファイルを開きます
New 新しい Layout を作ることができます
Cut キャンバス上のウィジェットを Cut します
Copy キャンバス上のウィジェットを Copy します
Paste コピーしたウィジェットを Paste します
Undo キャンバス上の操作を一つ前の操作に戻します
Redo キャンバス上で一つ戻した操作を前の操作に戻します
Align Left 二つ以上のウィジェットを選んだ状態で左合わせの状態にします
Align Center (Horizontal) 二つ以上のウィジェットを選んだ状態で横方向の中央合わせの状態にします
Align Right 二つ以上のウィジェットを選んだ状態で右合わせの状態にします
Align Top 二つ以上のウィジェットを選んだ状態で上合わせの状態にします
Align Center (Vertical) 二つ以上のウィジェットを選んだ状態で縦方向の中央合わせの状態にします
Align Bottom 二つ以上のウィジェットを選んだ状態で下合わせの状態にします
Align Horizontal Center in Container ウィジェットを親のウィジェットの水平方向の中央に合わせます
Align Vertical Center in Container ウィジェットを親のウィジェットの上下方向の中央に合わせます
Make Same Width 二つ以上のウィジェットの幅を同じにします。
Make Same Height 二つ以上のウィジェットの高さを同じにします
Make Same Size 二つ以上のウィジェットのサイズを同じにします
Make Horizontal Space Equal 三つ以上のウィジェットの横の間隔を同じにします
Make Vertical Space Equal 三つ以上のウィジェットの縦の間隔を同じにします
Send to Back ウィジェットの重なる順番を一番下にします
Send to Front ウィジェットの重なる順番を一番上にします
Send Backward ウィジェットの重なる順番を一つ下にします
Send Forward ウィジェットの重なる順番を一つ上にします

各種設定画面

本アプリケーションには、プロジェクト設定とツールの環境設定の２つの画面があります。

下記に各設定画面で設定できるものの説明を行います。

プロジェクト設定

メインメニューから [ファイル] - [プロジェクト設定] を選択し、プロジェクトの環境設定を行うことができます(図11, 表6)。

図11 Project Property

表6 プロジェクト設定の説明
設定項目 | 説明
Sources output folder | ビルド時に生成されるソースファイルが出力されるフォルダーを指定できます。
namespace | 出力されるクラスの namespace が指定できます。

ツールの環境設定

メインメニューから [ファイル] - [環境設定] を選択し、ツールの環境設定を行うことができます(図12, 表7)。

図12 ツールの環境設定

表7 ツールの環境設定の説明
設定項目 | 説明
ガイド線の色 | ユーザーが任意の場所に設定できるガイド線の色です。
スマートガイド線の色 | ウィジェットをドラッグ＆ドロップする際などに自動的に表示されるスマートガイドの色です。
グリッド線の色 | レイアウトキャンバスに等間隔で表示されるグリッド線の色です。
グリッド線の間隔 | グリッド線の間隔を設定することができます。
レイアウトキャンバスの背景色 | レイアウトキャンバスの背景色を設定できます。
レイアウトキャンバスの境界線の表示 | レイアウトキャンバスの境界線の表示の有無を設定できます。
UI 表示言語 | UIComposer 内の UI の表示文言の言語を設定できます。


Application Development Scenario

UI Composer では、Scene、Dialog、Panel、ListPanelItem の4つのクラスをレイアウトすることが可能です。

この章では、これら4つをどのようなシナリオで利用するかについて順に説明していきます(図1)。

図1 4つのシナリオ

Contents

  • Scene
  • Dialog
  • PagePanel
  • ListPanel

Scene

Sceneのレイアウトについて説明します。

Scene に ImageBox や Button を配置したシンプルな画面レイアウトを作成します(図2)。

図2 Scene のレイアウト概要

まず、UI Composer で Scene を新規作成します(図3)。

図3 Scene の新規作成

作成した Scene に ImageBox と Button を配置します(図4)。

図4 Scene のレイアウト結果

この状態で Build すると 下記のようなコードが出力されます。

partial class MyScene
{
    ImageBox ImageBox_1;
    Button Button_1;

    private void InitializeWidget()
    {
        InitializeWidget(LayoutOrientation.Horizontal);
    }

    private void InitializeWidget(LayoutOrientation orientation)
    {
        ImageBox_1 = new ImageBox();
        ImageBox_1.Name = "ImageBox_1";
        Button_1 = new Button();
        Button_1.Name = "Button_1";

        // ImageBox_1
        ImageBox_1.Image = new ImageAsset("/Application/assets/photo05.png");

        // Button_1
        Button_1.TextColor = new UIColor(0f / 255f, 0f / 255f, 0f / 255f, 255f / 255f);
        Button_1.TextFont = new UIFont( FontAlias.System, 25, FontStyle.Regular);
        Button_1.BackgroundColor = new UIColor(255f / 255f, 255f / 255f, 255f / 255f, 255f / 255f);

        // Scene
        this.RootWidget.AddChildLast(ImageBox_1);
        this.RootWidget.AddChildLast(Button_1);

        SetWidgetLayout(orientation);

        UpdateLanguage();
    }

    private LayoutOrientation _currentLayoutOrientation;
    public void SetWidgetLayout(LayoutOrientation orientation)
    {
        switch (orientation)
        {

// --snip--

        default:
            this.DesignWidth = 854;
            this.DesignHeight = 480;

            ImageBox_1.SetPosition(212, 45);
            ImageBox_1.SetSize(429, 286);
            ImageBox_1.Anchors = Anchors.Top | Anchors.Height | Anchors.Left | Anchors.Width;
            ImageBox_1.Visible = true;

            Button_1.SetPosition(319, 374);
            Button_1.SetSize(214, 56);
            Button_1.Anchors = Anchors.Top | Anchors.Height | Anchors.Left | Anchors.Width;
            Button_1.Visible = true;

            break;
        }
        _currentLayoutOrientation = orientation;
    }

// --snip--

}

作成したレイアウトを使用する場合は、Program.cs の Main関数内に下記のように記述します。

public class AppMain
{

// --snip--

    public static void Initialize ()
    {
        // Set up the graphics system
        graphics = new GraphicsContext ();

        // Initialize UI Toolkit
        UISystem.Initialize(graphics);

        // Create scene
        var scene = new MyScene();
        // Set scene
        UISystem.SetScene(scene, null);
    }

// --snip--

}

この状態でビルド、実行することで、レイアウトした通りエミュレータ上で動作します(図5)。

図5 エミュレーター上での実行結果

Dialog

Dialog のレイアウトとその利用方法について説明します。

Scene に配置された Button を押すと、レイアウトした Dialog を表示する例を示します(図6)。

図6 Dialog 表示の例

前節と同様に、Scene と Dialog をそれぞれ作成します(図7)。

図7 Dialog のレイアウト結果

これらを Build すると、下記のソースコードが出力されます。
  • MyScene.cs
  • MyScene.composer.cs
  • MyDialog.cs
  • MyDialog.composer.cs

MyScene に配置した Button を押すと Dialog を表示するように、MyScene.cs に以下のように記述します。

MyScene に MyDialog を追加します。

public partial class MyScene : Scene
{
    static private MyDialog dialog;

    public MyScene()
    {
        InitializeWidget();

        dialog = new MyDialog();
    }
}

Button_1 に dialog を表示するためのイベントを追加します。

public partial class MyScene : Scene
{
    MyDialog dialog;

    public MyScene()
    {
        InitializeWidget();

        dialog = new MyDialog();

        Button_1.ButtonAction += HandleButton_1ButtonAction;
    }

    void HandleButton_1ButtonAction (object sender, TouchEventArgs e)
    {
        dialog.Show();
    }
}

MyDialog の Button についても同様にイベントを登録します。

public partial class MyDialog : Dialog
{
    public MyDialog()
        : base(null, null)
    {
        InitializeWidget();

        Button_1.ButtonAction += HandleButton_1ButtonAction;
    }

    void HandleButton_1ButtonAction (object sender, TouchEventArgs e)
    {
        this.Hide();
    }
}

前節同様に MyScene を表示させ、Buttonをタップすると Dialog が表示されます(図8)。

図8 エミュレータ上での実行結果

PagePanel

PagePanel を使用して複数の Panel を表示する例について説明します(図9)。

図9 PagePanel概要図

MyScene、MyPanel1、MyPanel2を作成します(図10)。

MyScene には PagePanel を配置します。

MyPanel1、MyPanel2は、PagePanel の大きさに合わせ新規作成します(図11)。

図10 PagePanel のレイアウト結果

図11 Panel の新規作成

MyScene に配置した PagePanel に MyPanel1、MyPanel2 を設定します。PagePanel のプロパティウィンドウに作成した Panel を設定します。(図12)。

図12 作成した Panel の指定方法

Buildすると、下記のソースコードが出力されます。
  • MyScene.cs
  • MyScene.composer.cs
  • MyPanel1.cs
  • MyPanel1.composer.cs
  • MyPanel2.cs
  • MyPanel2.composer.cs

MyScene.composer.cs で PagePanelで表示する MyPanel1、MyPanel2 が指定されます。

private void InitializeWidget()
{

// --snip--

    // PagePanel_1
    PagePanel_1.AddPageLast(new MyPanel1());
    PagePanel_1.AddPageLast(new MyPanel2());

}

ビルドし実行すると レイアウト通り PagePanel が動作します(図13)。

図13 エミュレーター上での実行結果

ListPanel

Listのレイアウトとその利用方法について説明します(図14)。

図14 ListPanel の概要図

前節の PagePanel 同様、MyScene に ListPanel を配置します。

ListPanel に配置する要素 MyListPanelItem を作成します(図15)。

図15 List のレイアウト結果

ListPanel に作成した MyListPanelItem を設定します(図16)。

図16 作成した ListPanelItem の指定方法

Build すると、下記のソースコードが出力されます。
  • MyScene.cs
  • MyScene.composer.cs
  • MyListPanelItem.cs
  • MyListPanelItem.composer.cs

MyScene.composer.cs で ListPanel_1 で表示する MyListPanelItem が指定されます。

private void InitializeWidget(LayoutOrientation orientation)
{

// --snip--

    // ListPanel_1
    ListPanel_1.ScrollBarVisibility = ScrollBarVisibility.Visible;
    ListPanel_1.SetListItemCreator(MyListPanelItem.Creator);

}

MyListPanelItem.composer.cs には Creator メソッドが自動生成されます。

partial class MyListPanelItem
{

// --snip--

    public static ListPanelItem Creator()
    {
        return new MyListPanelItem();
    }
}

MyListPanelItem の更新とListPanel_1のアイテム数を指定するために、MyScene.cs に以下のようなに記述します。 MyListPanelItem の更新内容に関する記述は、ListItemUpdater 内に追加します。ここでは、Label の文字列として数字を表示する例を示します。

public partial class MyScene : Scene
{
    public MyScene()
    {
        InitializeWidget();

        ListPanel_1.SetListItemUpdater(ListItemUpdater);
        ListPanel_1.Sections = new ListSectionCollection { new ListSection("Section", 10) };

    }

    void ListItemUpdater(ListPanelItem item)
    {
        Label label = null;
        foreach (var w in item.Children)
        {
            label = w as Label;
            if (label != null) break;
        }
        if (label != null)
        {
            label.Text = item.Index.ToString();
        }
    }
}

ビルドし実行すると レイアウト通り ListPanel が動作します(図17)。

図17 エミュレーター上での実行結果


ウィジェット

この章では、UI Toolkitで利用可能なウィジェットについて説明します。

各プロパティの詳細については UI Toolkit プログラミングガイド - ウィジェット を参照してください。

Contents

  • レイアウトのルートとして使用できるウィジェット
    • Scene
    • Panel
    • Dialog
    • ListPanelItem
  • 汎用ウィジェット
    • Widget
    • Label
    • ImageBox
    • Button
    • CheckBox
    • Slider
    • ProgressBar
    • Editable Text
    • BusyIndicator
    • PopupList
    • Date/TimePicker
  • コンテナウィジェット
    • Panel
    • ScrollPanel
    • PagePanel
    • ListPanel
    • GridListPanel
  • Live ウィジェット
    • LiveListPanel
    • LiveJumpPanel
    • LiveFlipPanel
    • LiveScrollPanel
    • LiveSphere
    • LiveSpringPanel

レイアウトのルートとして使用できるウィジェット

内部に他のウィジェットをレイアウト可能なレイアウトのルートとなるウィジェットは、Scene、Panel、Dialog、ListPanelItemの４つです。

Scene

ユーザーインターフェースの"画面"を司るウィジェットです。

Panel

任意のUI部品を載せることができるコンテナウィジェットです。レイアウトのルートとして使用できるだけでなく、他の汎用ウィジェットなどをグルーピングする用途にも利用可能です。

Dialog

モーダルなダイアログボックスを表示するためのコンテナウィジェットです。Panel と同様に任意のUI部品を格納することが可能です。

図1 Dialog

ListPanelItem

ListPanelの各項目に表示する内容をレイアウトするためのウィジェットです。

汎用ウィジェット

Widget

Widget クラスはすべての ウィジェット (ユーザーインターフェース部品) の基底となる抽象クラスです。このクラスのプロパティは全ての ウィジェット で設定可能です。

図2 Widgetのプロパティ

Variable Name は、ソースコードを出力した際の、対象の Widget のインスタンス名として利用されます。

Widget の Position の欄には、Position Selectorで選択した位置の座標が表示されます。

図3 Position Selector

逆に、Position の欄に数字を入力した場合、その値は、Position Selector で選択した対象に対して適用されます。例えば、Position Selector で中心を選択し(上図(C))、Position の欄に任意の数字を入力することで、対象のウィジェットの中心の座標を直接指定することが可能です。ちなみに、最終的に出力されるソースコードでは、左上隅の座標が自動的に算出され、X、Y プロパティの値として指定されます。

Scene や Panel のサイズが変わった際に、UISystem は AnchorFlag の設定に基づいて Scene や Panel 内部のウィジェットをレイアウトします。AnchorFlag では、上下左右のマージンを固定にするかどうか、幅・高さを自動的にリサイズするかどうかを設定することが可能です。UI Composer を利用すると、AnchorFlag を視覚的に設定することが可能です。

図4 AnchorFlag Customizer

AnchorFlag Customizerは、6つのトグルスイッチ群になっています。ウィジェットの親ウィジェットがリサイズされたときの挙動は、Previewer にアニメーションで表示されます。アニメーションは、マウスカーソルが AnchorFlag Customizer の上にあるときにのみ再生されます。

UI Composer で設定した内容と、出力されるソースコードで指定される AnchorFlag の値の関係は下図のようになります。

図5 アンカー設定とウィジェットのオートリサイズされた結果

Effectは、ウィジェットが画面に登場する際のアニメーションを設定することができます。例えば、ButtonにSlideInEffectを設定した場合には、下記のようなコードが自動生成されます。ただし、レイアウトのルートとして使用したウィジェットの子ウィジェットにのみ有効です。子ウィジェット以外はユーザーコード側で制御してください。

// ...
partial class MyScene
{
    Button Button_1;
    Button Button_2;

    // ...

    private void InitializeWidget(LayoutOrientation orientation)
    {
        // ...

        // Scene
        this.RootWidget.AddChildLast(Button_1);
        this.RootWidget.AddChildLast(Button_2);
        this.Showing += new EventHandler(onShowing);
        this.Shown += new EventHandler(onShown);

        UpdateLanguage();
    }

    // ...

    private void onShowing(object sender, EventArgs e)
    {
        switch (_currentLayoutOrientation)
        {
            case LayoutOrientation.Vertical:
            {
                Button_2.Visible = false;
            }
            break;

            default:
            {
                Button_2.Visible = false;
            }
            break;
        }
    }

    private void onShown(object sender, EventArgs e)
    {
        switch (_currentLayoutOrientation)
        {
            case LayoutOrientation.Vertical:
            {
                new SlideInEffect()
                {
                    Widget = Button_2,
                    MoveDirection = FourWayDirection.Left,
                }
                .Start();
            }
            break;

            default:
            {
                new SlideInEffect()
                {
                    Widget = Button_2,
                    MoveDirection = FourWayDirection.Left,
                }
                .Start();
            }
            break;
        }
    }
    // ...

Label

Label はテキスト表示用の部品です。単一行と、複数行を表示することが可能です。

ImageBox

画像を表示するためのウィジェットです。

画像を表示する際のスケーリング方法を指定できます。

図6 画像のスケーリング方法

Button

タッチ操作に反応するボタンウィジェットです。

ボタンには画像か1行のテキストを表示することが出来ます。

図7 テキストを表示したButtonと、画像を表示したButton

ボタンの背景画像のカスタマイズもUI Composerで可能です。

図8 背景画像をカスタマイズしたButton

図9 Buttonのプロパティウィンドウ

CheckBox

いわゆるチェックボックスやラジオボタン用のウィジェットで、真偽値を保持します。

図10 CheckBox

Slider

数値などの調整を行うためのウィジェットです。

図11 Slider

最大値、最小値、初期値、値が変化する際のステップなどを設定することが可能です。

ProgressBar

進捗の度合いを表示するウィジェットです。

図12 ProgressBar

Editable Text

テキストの表示と編集ができるウィジェットです。

図13 EditableText

テキスト未入力時のデフォルトテキストの表示、パスワード入力用のマスク表示、オンスクリーンキーボードの入力モードの選択ができます。

BusyIndicator

何らかの処理が進行中であることを表示するウィジェットです。

図14 BusyIndicator

PopupList

PopupList は複数の選択肢の中から1つを選ぶために利用する部品です。

図15 PopupList

PopupListに表示する選択肢をUI Composerで設定することが可能です。

Date/TimePicker

日付もしくは時刻を選択するためのウィジェットです。

表示スタイルは2つあり、日付のみ選択できるスタイル、時刻のみ選択できるスタイルの中から選択可能です。それぞれ、DatePicker、TimePicker ウィジェットが生成されます。

図16 Date/TimePicker

コンテナウィジェット

Panel

任意のUI部品を載せることができるコンテナウィジェットです。

ScrollPanel

スクロール可能な領域を持つパネルです。子ウィジェットとしてPanelを一つ持っており、その一部分をクリッピングして表示します。タッチ操作で上下や左右方向にスクロールさせることが可能です。スクロール可能な方向を制限することも可能です。

図17 ScrollPanel

ユーザーがレイアウトしたPanelクラスをScrollPanelに追加することが可能です。

PagePanel

ページ単位でスクロールすることのできるパネルです。

図18 PagePanel

ユーザーがレイアウトしたPanelクラスをPagePanelに追加することが可能です。

ListPanel

縦方向のみスクロール可能なリストウィジェットです。各項目に表示する内容は ListPanelItem で指定します。 ユーザーがレイアウトしたListPanelItemを設定することが可能です。

GridListPanel

縦方向もしくは横方向にスクロール可能で、格子状に項目が並ぶリストウィジェットです。

Live ウィジェット

Live ウィジェットは、さまざまなインタラクションが実装された PSM 独自のウィジェットです。

LiveListPanel

タッチした項目に対して、時間差を伴って他の項目がスクロールするリストウィジェットです。

LiveJumpPanel

パネル内に配置したウィジェットを画面手前にジャンプさせることのできるパネルウィジェットです。 加速度センサーの値変化やボタンの押下など任意のタイミングで子ウィジェットをジャンプさせることが可能です。

LiveFlipPanel

左右のフリックで回転するパネルウィジェットです。表と裏のウィジェットを指定することが可能です。

LiveScrollPanel

タッチした点を起点として、ゆがみながらスクロールするパネルウィジェットです。

LiveSphere

球体状のウィジェットです。左右にフリックすることで回転できます。またタップに対するイベントハンドラも定義されており、ボタンとしても利用できます。

LiveSpringPanel

加速度センサーやパネルの動きに応じて子ウィジェットが揺れるパネルです。


レイアウトガイド

本章では、アプリケーションのレイアウトを効率よく作成するためのTipsを紹介します。

Contents

  • ガイド線
    • ユーザー定義ガイド
    • スマートガイド
    • グリッド
  • レイアウトアンカー機能
  • デバイスの把持方向に応じた画面レイアウト
  • プレビュー機能
  • カスタムウィジェットのレイアウト
    • 制限事項

ガイド線

UI Composerでは、ウィジェットを簡単に整列させるための機能としてガイド線とグリッド線を提供しています。 ガイド線、グリッド線への吸着や表示/非表示は、メニューで設定可能です。また、ガイド線・グリッドの色設定、グリッド幅は、メニューの[ファイル]-[環境設定]で行うことができます。 ガイド線には「ユーザー定義ガイド」「スマートガイド」の2種類があります。

ユーザー定義ガイド

特定の座標にウィジェットを配置した場合に有効なガイド線で、レイアウトウィンドウのルーラーからマウスでドラッグし引き出し、自由に設定することができます。 メニューからガイド線の追加、削除を行うことも可能です(図1)。

図 1 ユーザー定義ガイド

スマートガイド

レイアウトキャンバスに配置されているウィジェットとマウスで操作しているウィジェットの整列を補助するためのガイド線です(図2)。

配置されているウィジェットと操作しているウィジェットの上下左右の端、もしくは中央が揃った場合に表示されます。

図 2 スマートガイド

グリッド

レイアウトキャンバス上に格子状に引かれた線がグリッド線です(図3)。

図 3 グリッドガイド

レイアウトアンカー機能

UIToolkit で作成されたアプリケーションは解像度の異なるデバイス上で動作することが可能です。そのため、UI Composerでレイアウトした Scene のサイズと、実機で描画される際の Scene のサイズが異なる場合があります。

Scene や Panel のサイズが変わった際に、UISystem はレイアウトアンカー( Anchor )の設定に基づいて Scene や Panel 内部のウィジェットをレイアウトします。Anchor では、上下左右のマージンを固定にするかどうか、幅・高さを自動的にリサイズするかどうかを設定することが可能です。UI Composer を利用すると、Anchor を視覚的に設定することが可能です(図4)。

図 4 Anchor Customizer

Anchor Customizerは、6つのトグルスイッチ群になっています。ウィジェットの親ウィジェットがリサイズされたときの挙動は、Previewer にアニメーションで表示されます。アニメーションは、マウスカーソルが Anchor Customizer の上にあるときにのみ再生されます。

UI Composer で設定した内容と、出力されるソースコードで指定される Anchor の値の関係は下図のようになります。

図 5 レイアウトアンカーの設定と、ウィジェットがオートリサイズされた結果

ちなみに、Panelクラスのレイアウトを行っている場合(レイアウトキャンバスの表示がPanelである場合)は、レイアウトのルートとなるPanelのレイアウトアンカーを設定することはできません(別のレイアウトキャンバス上にレイアウトする際は可能です)。インスタンス化するタイミングで適切なレイアウトアンカーを設定するようにして下さい。

デバイスの把持方向に応じた画面レイアウト

デバイスの把持方向によって異なる画面レイアウトを指定することが可能です。

メニューの[表示]-[キャンバスの向き]を選択すると、レイアウトキャンバスの方向が切り替わります(図6)。

図 6 レイアウトキャンバスの方向切替

ウィジェットはレイアウトキャンバスの方向毎に それぞれ位置・サイズなどのプロパティを指定できる ようになっています。つまりデバイスの向きを縦にした場合と横にした場合のそれぞれの状態に対して画面のレイアウトを行うことが可能です。

出力されるソースコードには、画面レイアウトを切り替えるメソッドが生成されます(下記ソースコード参照)。デバイスの把持方向が変わったタイミングなどでそのメソッドを呼び出すことで、適切なレイアウトを指定することが可能です。

把持方向に合わせて初期化することができ、指定しない場合は、水平方向のレイアウトとなります。

partial class MyScene
{
    // ...

    private void InitializeWidget()
    {
        InitializeWidget(LayoutOrientation.Horizontal);
    }

    private void InitializeWidget(LayoutOrientation orientation)
    {
        // create instance

        SetWidgetLayout(orientation);

        // set property

        // update language
    }

    private LayoutOrientation _currentLayoutOrientation;
    public void SetWidgetLayout(LayoutOrientation orientation)
    {
        switch (orientation)
        {
        case LayoutOrientation.Vertical:
            this.DesignWidth = 400;
            this.DesignHeight = 600;

            sceneBackgroundPanel.SetPosition(0, 0);
            sceneBackgroundPanel.SetSize(400, 600);
            sceneBackgroundPanel.Anchors = Anchors.Top | Anchors.Bottom | Anchors.Left | Anchors.Right;
            sceneBackgroundPanel.Visible = true;

            ImageBox_1.SetPosition(0, 10);
            ImageBox_1.SetSize(400, 264);
            ImageBox_1.Anchors = Anchors.Top | Anchors.Height | Anchors.Left | Anchors.Width;
            ImageBox_1.Visible = true;

            Label_3.SetPosition(23, 282);
            Label_3.SetSize(353, 268);
            Label_3.Anchors = Anchors.Top | Anchors.Height | Anchors.Left | Anchors.Width;
            Label_3.Visible = true;

            break;

        default:
            this.DesignWidth = 600;
            this.DesignHeight = 400;

            sceneBackgroundPanel.SetPosition(0, 0);
            sceneBackgroundPanel.SetSize(600, 400);
            sceneBackgroundPanel.Anchors = Anchors.Top | Anchors.Bottom | Anchors.Left | Anchors.Right;
            sceneBackgroundPanel.Visible = true;

            ImageBox_1.SetPosition(0, 0);
            ImageBox_1.SetSize(600, 400);
            ImageBox_1.Anchors = Anchors.Top | Anchors.Height | Anchors.Left | Anchors.Width;
            ImageBox_1.Visible = true;

            Label_3.SetPosition(0, 398);
            Label_3.SetSize(214, 36);
            Label_3.Anchors = Anchors.Top | Anchors.Height | Anchors.Left | Anchors.Width;
            Label_3.Visible = false;

            break;
        }
        _currentLayoutOrientation = orientation;
    }

UIComposer で出力するコードは水平方向（LayoutOrientation.Horizontal）のレイアウトがデフォルトとなっています。

もし、垂直方向（LayoutOrientation.Vertical）を起動時のデフォルトとしたい場合は、コンストラクタ内でInitializeWidget(LayoutOrientation)を使うように書き換える必要があります。

プレビュー機能

UIComposerではユーザーが作成したレイアウト（Scene、Panel、Dialog、ListPanelItem）をシミュレータ上でプレビューすることが可能です。

プレビューはツール上で現在編集中のレイアウトに対して行われ、レイアウトのサイズと同じサイズで表示されます。

プレビューで確認できるのは以下の項目です。Buttonを押したときの動作などはプレビューできません。ツールのプレビューで確認できるのは見た目に関する項目のみです。

  • ツール上で配置したWidgetのレイアウト
  • 文字、画像等のツール上で設定したWidgetの状態
  • SceneのTransitionやWidgetのEffectなどのアニメーション

プレビューの利用手順

  • メニューから[ファイル]-[プレビュー]を選択してください。

プレビュー機能の特記事項

  • ListPanel、GridListPanel、LiveListPanelは設定されたListPanelItemを自動で100個追加して表示します。

プレビュー例

図 7 レイアウトキャンバス上での表示 (LiveSphere)

図 8 プレビューでの表示 (LiveSphere)

図 9 レイアウトキャンバス上での表示 (GridListPanel)

図 10 プレビューでの表示 (GridListPanel)

カスタムウィジェットのレイアウト

標準のウィジェットには含まれないユーザーが独自に作成したウィジェットをレイアウトすることができます。

他のウィジェットと同様に WidgetList ウインドウから CustomWidget をレイアウトキャンバス上にドラッグアンドドロップしてレイアウトします（図11）。

図 11 カスタムウィジェットのレイアウトキャンバスへの配置

図 12 カスタムウィジェットのレイアウトキャンバス上での表示

CustomWidget を選択すると、プロパティウィンドウに NameSpace プロパティと ClassName プロパティが表示されます。

NameSpace プロパティを編集することで、CustomWidget のネームスペースを、ClassName プロパティを編集することで、CustomWidget のクラスを設定することができます（図13）。

図 13 カスタムウィジェットのプロパティ

ただし、レイアウトキャンバス上での表示には何も反映されません。

制限事項

  • CustomWidget は、ユーザーが独自に作成したウィジェットであるため、どのようなプロパティが存在するかは不明です。そのため、UIComposer では CustomWidget のプロパティについては編集を行うことはできません。
  • CustomWidget は、ユーザーが独自に作成したウィジェットであるため、どのような表示をされるのかは不明です。そのため、UIComposer では CustomWidget のダミーを表示をすることでプレビューできるようにしています（図14）。

図 14 カスタムウィジェットのプレビュー表示

  • 「カスタムウィジェットのレイアウト」機能の追加に伴い、今までの「カスタムパネルのレイアウト」機能は廃止となりました。


アプリケーションの多言語対応

本章では、UI上の文字列を多言語化するための機能について説明します。

Contents

  • 多言語対応について
    • 言語テーブルウィンドウの基本操作
    • 文字列データの使用
    • 表示言語の切替
    • CSVファイルへの出力、CSVファイルからの読み込み
    • ソースコードへの出力

多言語対応について

UI Composer にはアプリケーションの多言語対応 (Localization) をサポートする仕組みがあります。この仕組を利用するには、言語テーブルウィンドウを使用します。

言語テーブルウィンドウでは、文字列IDと各言語の文字列を対応づけた文字列データを作成することが可能です。 プロパティウィンドウなどで文字列ID を利用することで、設定言語に応じた文字列データをウィジェットの表示に利用できます。

言語テーブルウィンドウの基本操作

言語テーブルウィンドウは表と各種ボタンから構成されます。

表の1行が1つの文字列データセットになっています。1列目には文字列IDが入り、2列目以降の各列にアプリケーションで対応する各言語に対応する文字列が入ります。言語テーブルウィンドウ上で文字列データの編集も可能ですが、CSVファイルの入出力にも対応しており、他のツールでCSVファイルを編集し、その結果を読み込むことも可能です。

図1 言語テーブルウィンドウ

文字列データを編集する際の操作は表1の通りです。

表1 データの編集操作
行の追加 | ID列以外の列に文字列を入力した時点で、自動で下に1行追加されます。
行の削除 | 右クリックでコンテキストメニューを表示し、「Delete Row」を選択すると、マウス直下にある行が削除されます。
列の追加 | 右クリックでコンテキストメニューを表示し、「Add Column」を選択します。ダイアログに言語名を入力すると、入力した言語の列が追加されます。
列の削除 | 右クリックでコンテキストメニューを表示し、「Delete Column」を選択すると、マウス直下にある列が削除されます。

また、下部のボタンでは表2の操作が行えます。

表2 言語テーブルウィンドウのボタン
Load | エクスプローラからcsvファイルを指定し、言語テーブルに読み込みます。
Reload | 現在指定されているcsvファイルを言語テーブルに再読み込みします。
Apply to layout | 言語テーブルの文字列データをレイアウトキャンバス上の表示に反映させます。

Loadを使用し、プロジェクトフォルダー外のcsvファイルを指定した場合、プロジェクトフォルダー内にcsvファイルがコピーされます。同一ファイル名のcsvファイルが存在する場合は、上書きコピーできません。 なお、言語テーブルに入力可能な文字には制限があります。「"(ダブルクオーテーション)」は、「\"」とエスケープされます。ただし、既に「\"」とエスケープされている場合はエスケープを行いません。また、制御文字などは削除されます。

文字列データの使用

文字列をプロパティウィンドウなどで利用するには、「@」で文字列IDを囲んでください。例えば、Button の Text プロパティに「@文字列ID@」のように指定することで、設定されている言語に応じた文字列が表示されます。

図2 文字列IDの適用

表示言語の切替

プロジェクト設定画面で言語設定の変更が可能です。 言語テーブルの列名をクリックすることで言語設定の変更が可能です。

図3 言語の切替

CSVファイルへの出力、CSVファイルからの読み込み

言語テーブルは、文字列データをCSVファイルへ書き出したり、逆に、CSVファイルからの文字列データ読み込むことが可能です(表3)。

これにより、UI Composer 以外のツールで文字列データの作成・編集を行うことができ、編集結果をUI Composerに反映させることが可能となります。

表3 CSVファイルの操作
書き出し | Ctrl-Sなど、プロジェクトを保存する際に自動的に書き出しが行われます。
読み込み | Load ボタンを押し、csvファイルを選択し読み込むと、言語テーブルに 文字列データが表示されます。

ソースコードへの出力

UI Composer でビルドを行うと、言語テーブルの内容は、"UIStringTable.cs"として出力されます。Scene や Panel などとは別のクラスとして出力されることになります。

// "UIStringTable.cs"
public static class UIStringTable
{
    static string[] currentTable;
    static UILanguage currentLanguageId;
    static UILanguage defaultLanguageId;
    static string[][] textTable;

    public static string Get(UIStringID id)
    {
        return currentTable[(int)id];
    }

    public static UILanguage UILanguage
    {
        get { return currentLanguageId; }
        set
        {
            currentLanguageId = value;
            currentTable = textTable[(int)currentLanguageId];
        }
    }

    static UIStringTable()
    {
        textTable = new string[][]
        {
            new string[]
            {
                "OK",
                "Cancel",
                "Hello",
                "",
            },
            new string[]
            {
                "はい",
                "いいえ",
                "こんにちは",
                "",
            },
            new string[]
            {
                "Oui",
                "Non",
                "Bonjour",
                "",
            }
        };
        defaultLanguageId = UILanguage.English;
        currentLanguageId = defaultLanguageId;
        currentTable = textTable[(int)currentLanguageId];
    }
}

public enum UIStringID : int
{
    ID_OK = 0,
    ID_Cancel = 1,
    ID_Hello = 2,
    RESID1 = 3,
}

public enum UILanguage : int
{
    English = 0,
    Japanese = 1,
    French = 2,
}

レイアウトを行った Scene や Panel では下記のようなコードが生成されます。

// "SampleScene.composer.cs" : sample Scene which uses UIStringTable.cs
partial class SampleScene
{
    Button Button_1;
    Label Label_1;

    // --snip--
    public void UpdateLanguage()
    {
        Button_1.Text = UIStringTable.Get(UIStringID.ID_OK);
        Label_1.Text = UIStringTable.Get(UIStringID.ID_Hello);
    }
    // --snip--
}


PSM Studioとの連動

PSM Studio のプロジェクトで、UI Composer が出力したファイルを利用する際の注意点について説明します。

Contents

  • アプリケーションのプロジェクト構成
  • クラス定義ファイル
  • イメージアセットファイル

アプリケーションのプロジェクト構成

UI Composer が出力するソースファイル(下記の「*」の付いたファイル)、および追加したイメージアセットファイル(「**」の付いたファイル)を SampleApp.csproj に追加してビルドを行って下さい。:

SampleApp/
          SampleApp.csproj

          SampleApp.uic
          SampleApp_LanguageTable.csv

          AppMain.cs

          SampleA.cs
          SampleB.cs
          SampleC.cs

          SampleScene.cs             *
          SampleScene.composer.cs    *
          SamplePanel.cs             *
          SamplePanel.composer.cs    *
          SampleDialog.cs            *
          SampleDialog.composer.cs   *

          UIStringTable.cs           *

          assets/
                 AAA.png             **
                 BBB.png             **

クラス定義ファイル

UI Composer は、ユーザーがレイアウトした「画面」毎に、クラス定義を自動生成します。1つのクラスをxxx.composer.cs と xxx.cs に分けて partial class として自動生成します。

  • xxx.composer.cs には、配置したウィジェットのレイアウト情報（X,Y 座標） やプロパティの設定値を設定するメソッドが定義されます。常に上書きされます。
  • xxx.cs にはクラスのコンストラクタが定義され、その中で、xxx.composer.cs 内に定義されている初期化メソッド呼び出しが記述されます。既に存在する場合は生成されません。

例えば、２つの「画面」をレイアウトした場合、下記のファイルが出力されます。

  • SampleScene.composer.cs : レイアウト定義
  • SampleScene.cs : イベントハンドラやロジックの実装用ファイル
  • SamplePanel.composer.cs : レイアウト定義
  • SamplePanel.cs : イベントハンドラやロジックの実装用ファイル
  • UIStringTable.cs : 言語毎に「画面」に応じた文言を表示するための文言テーブル

出力された .cs ファイルを PSM Studio のプロジェクトに取り込むことで UI Composer で行った作業を利用することが可能です。UI Composer で「画面」レイアウトを手直しした場合、SampleScene.cs や SamplePanel.cs は上書きされませんが、 xxx.composer.cs は常に上書きされる ことに注意して下さい。このファイルは編集しないことを推奨します。イベントハンドラなどの実装は xxxxx.cs に対して行ってください。また、xxxxx.csが既に存在する場合は、このファイルは上書きされないため、途中で名前空間を変更した場合は手動でxxxxx.csの名前空間を変更する必要があります。

イメージアセットファイル

UI Composer で使用しているイメージアセットファイルは、PSM Studio のプロジェクトに「コンテンツ」として登録する必要があります。

  • イメージアセットファイルの登録方法
    • PSM Studio で対象のソリューションファイルを開きます。
    • ソリューションパネルで、対象のプロジェクトを右クリックし、[追加 (Add)] > [AddExistingFolder...] を選択します。
    • フォルダーの選択ダイアログで「assets」フォルダーを選択し、[開く (Open)」を押します。
    • ファイルの選択ダイアログでイメージアセットファイルを選択します。
    • ソリューションパネルの追加されたイメージアセットファイルを右クリックし、[ビルドアクション (Build Action)] > [コンテンツ (Content)] を選択します。（pngファイルはデフォルトでビルドアクションがコンテンツになります。）


Appendix

Appendix A: UI Composer Shortcut Key Guide

UI Composer で 利用することができるショートカットキーの一覧です。

表1 レイアウトウィンドウにおけるショートカットキー一覧

Function | ShortCut | Description
Create New Scene | Ctrl+N | 新たなシーンを作成します。
Close Current Scene | Ctrl+W | 開いているシーンを閉じます。
Create New Project | Shift+Ctrl+N | 新たなプロジェクトを作成します。
Open Existing Scene | Ctrl+O | 既存のシーンを開きます。
Save | Ctrl+S | 開いているシーンを保存します。
Build | F5 | コードの生成を行います。
Preview | F12 | シミュレータを起動し、シーンのプレビューを行います。
Undo | Ctrl+Z | 一つ前の状態に戻します。
Redo | Ctrl+Shift+Z | Undo の操作を一つ戻します。
Cut | Ctrl+X | Widget を Cut する
Copy | Ctrl+C | Widget を Copy する
Paste | Ctrl+V | Cut または Copy した Widget を 貼り付ける
Delete | Del | Widgetを削除する
Select All | Ctrl+A | Canvas 上の Widget をすべて選ぶ
Show Grid | Ctrl+G | Grid 線を表示する。
Arrow Cursor | v | Widget選択モードにする
Hand Cursor | h | スクリーン選択モードにする
Canvas Scale : 100% | Ctrl+0 | キャンバスの倍率を100%にします。
PlayStation(R)Mobile Documents | F1 | ドキュメントを開きます。

表2 オブジェクトツリービューにおけるショートカットキー一覧

Function | ShortCut | Description
Cut | Ctrl+X | Widget を Cut する
Copy | Ctrl+C | Widget を Copy する
Paste | Ctrl+V | Cut または Copy した Widget を貼り付ける


用語集

用語 | 意味
レイアウトキャンバス (Layout Canvas) | ウィジェットを配置するエリア。複数追加することができ、レイアウトウィンドウのタブで表示するレイアウトキャンバスを切り替えることができる。
ウィジェット (Widget) | UI Toolkit で扱う UI 部品の単位。
レイアウトウィンドウ (Layout Window) | 開発するユーザーインターフェースのレイアウトを作成するためのウィンドウ。レイアウトキャンバスが表示される。
アセットウィンドウ (Asset Window) | 開発するユーザーインターフェースで使用するアセットフォルダー内を表示するウィンドウ。
オブジェクトツリー (Object Tree Window) | レイアウトキャンバス上に配置されている UI 部品をツリー状に表示するウィンドウ。
ウィジェットリストウィンドウ (Widget List Window) | UI Composer 内で配置できるウィジェットをリスト状に表示するウィンドウ。
オーバービューウィンドウ (Overview Window) | レイアウトウィンドウに現在表示しているレイアウトキャンバスの全体像と表示領域を表示するウィンドウ。
プロパティウィンドウ (Property Window) | 各ウィジェットで設定可能な項目を表示するウィンドウ。
言語テーブルウィンドウ (Language Table Window) | 複数言語の文字列を ID 管理するためのウィンドウ。
ビルド (Build) | 作成したレイアウトが .cs ファイルのコードとして出力される。
xxx.composer.cs ファイル | レイアウト情報が記述された C# のソースコードファイル。
xxx.cs ファイル | イベントハンドラなどを記述するための.C# のソースコードファイル。ユーザーが作成していなければ、ビルド時に自動で作成される。
xxx.uic ファイル | UI Composer のプロジェクトファイル。プロジェクトの設定や、各レイアウト情報などが保存されている。
ガイド (Guide) | ユーザーが設定するガイド線。ウィジェットを整列させる際に使用される。
スマートガイド (Smart Guide) | ウィジェット間に表示されるガイド線。すでにレイアウトキャンバス内に配置されているウィジェットに対して位置やサイズを揃える際に有効な機能。
グリッド (Grid) | レイアウトキャンバス上に表示される格子状の線。


PlayStation(R)Mobile Development Assistant について

この文書では実機でPSMアプリケーションを実行するために必要となる PlayStation(R)Mobile Development Assistant (PSM DevAssistant) について説明します。

Contents

  • 概要
    • PS Vita版 PlayStation(R)Mobile Development Assistant

概要

PlayStation(R)Mobile Development Assistant (PSM DevAssistant) とは、PS Vita上でPSMアプリの開発を行うためのアプリケーションです。

アプリケーションの実行に先立って各デバイスに事前にインストールされている必要があります。

また、各デバイス上での実行に先立って Publishing Utility を用いてプロジェクトに対応する鍵の作成とネットワークに接続できる環境が必要となります。

インストールを含む各デバイスでの設定、及び鍵作成の詳細についてはそれぞれ以下のドキュメントを参照してください。

  • PlayStation(R)Vitaで実行するための設定
  • 実機でPSMアプリを実行するための鍵の作成について

PS Vita版 PlayStation(R)Mobile Development Assistant

PS Vita版 PlayStation(R)Mobile Development Assistant は、以下のような画面になります。

図1 PS Vita版 PlayStation(R)Mobile Development Assistant

図1の右下のメニューを選択することで、PS Vita版 PlayStation(R)Mobile Development Assistant のオプション一覧が表示されます。

各メニューは以下のような機能を提供します。

項目名 | 概要
Delete Applications | インストール済みのPSMアプリを削除します。
Intellectual Property Notices | PlayStation(R)Mobile Development Assistant の権利表記を表示します。
Go to the Developer Forums | ウェブブラウザーを起動して、Devloper Forums ページを開きます。
Debug Settings | 各種デバッグ項目を表示します。

[Debug Settings] 内の項目には、以下のようなものが存在します。

項目名 | 概要
Delete Documents | インストール済みの全てのPSMアプリのセーブデータ(Documents)を削除します。
Reset Ticket Information | アプリ内課金機能について、インストール済みの全てのPSMアプリの購入情報をクリアします。
Show Build Information | PlayStation(R)Mobile Development Assistant のビルド情報を表示します。

また、設定アプリケーション＞[システム]＞[PS Vita本体のボタンで操作する]の項目が有効になっている場合、PS Vita 本体のボタンで操作が可能です。

PlayStation(R)Mobile Development Assistant 上での決定ボタンアサインは、システムソフトウェア上での決定ボタンと同じボタンが割り当てられます。


マスターの作成と提出

この文書では完成したPSMアプリをマスターパッケージとして作成する方法と、それを弊社に提出する方法について説明します。

Contents

  • マスター、マスターパッケージとは
  • マスターの作成と提出の手順
    • PSMアプリケーション開発ガイドライン
    • SDKバージョン間におけるマスターパッケージ更新の制限
    • Publishing Utility
    • マスターパッケージを作成する
    • マスターを提出する
    • DevPortalでの作業

マスター、マスターパッケージとは

マスターパッケージとは、PSMアプリをPS Storeで配信するために必要なファイル群をひとまとめにしたファイルをいいます。

マスターパッケージは、単にマスターと略して呼ばれることがあります。

弊社には、このマスターパッケージ形式でPSMアプリを提出します。

マスターの作成と提出の手順

マスターの作成と提出は以下の手順で行います。

  1. PSMアプリケーション開発ガイドラインを読み、PSMアプリに求められる要件をあらかじめ確認しておきます。
  2. PSMアプリを作成します。
  3. 作成したPSMアプリがPSMアプリケーション開発ガイドラインの条項を遵守しているか確認します。
  4. Publishing Utilityでアプリケーション情報 app.xml のMetaDataカテゴリを設定します。
  5. PSMアプリに対応するアプリ鍵を作成し、実機での動作を確認します。
  6. PSM Studioで、PSMアプリをマスターパッケージ形式でビルドします。
  7. マスターパッケージを弊社に提出します。
  8. DevPortalでPSMアプリおよびアプリ内課金の価格を設定します。

※ sample/Tutorial/Sample08_02 は、app.xmlにマスターパッケージを作成するための設定がなされています。マスターパッケージを作成するときの参考にしてください。

※ マスターパッケージは、パブリッシャライセンスを購入し、銀行口座情報の確認が完了してからでないと作成できません。

PSMアプリケーション開発ガイドライン

PSMアプリケーション開発ガイドライン(以下、ガイドライン)は、PSMアプリに求められる要件をまとめたドキュメントです。

PSMアプリをPS Storeで配信する場合、このガイドラインの条項を遵守する必要あります。

マスターの提出前にガイドラインの条項を満たしていることを確認の上、マスターを提出してください。

SDKバージョン間におけるマスターパッケージ更新の制限

PSM SDK 1.xで作成されたタイトルがすでに販売されている場合、PSM SDK 2.xで作成した同じApplication IDのマスターパッケージは提出できません。 そのタイトルを更新したい場合、PSM SDK 1.xを使ってマスターパッケージを作成・提出してください。

また、PSM SDK 2.xで作成されたタイトルがすでに販売されている場合、PSM SDK 1.xで作成した同じApplication IDのマスターパッケージは提出できません。 そのタイトルを更新したい場合、PSM SDK 2.xを使ってマスターパッケージを作成・提出してください。

PSM SDKで作成されたタイトルがすでに販売されている場合、Unity for PSMで作成した同じApplication IDのマスターパッケージは提出できません。

Publishing Utility

Publishing Utilityでアプリケーション情報 app.xmlのMetaDataカテゴリを設定します。

Publishing Utilityの詳細は Publishing Utilityの使い方 を参照してください。

マスターパッケージを作成する

アプリケーション情報 app.xmlの設定が完了したら、マスターパッケージを作成します。

※1 マスターパッケージの作成前に、PSMアプリに対応するアプリ鍵を作成し、実機での動作を確認しておいてください。

※2 銀行口座の登録とその後のSCEによる手続きが完了するまで、マスターパッケージを作成することはできません。

マスターパッケージを作成するには、PSM Studioを起動し、ビルド設定で[Release]を選択し、 [メニュー] - [Project] - [Compose PSM Master Package]を選択します。

図1 マスターパッケージの作成

ビルドが成功すると、プロジェクトのbin/Release フォルダー内に、拡張子psmpの付いたマスターパッケージが作成されます。

注意 : マスターパッケージを提出する時、SENアカウントとパブリッシャ鍵はマスターパッケージ作成時に利用したものと同じものである必要があります。またPlayStation(R)StoreでPSMアプリの配信が開始されるまで、パブリッシャ鍵を更新しないよう注意してください。

マスターを提出する

マスターを提出するには、[メニュー] - [Project] - [Submit PSM Master Package]を選択します。ダイアログが表示されるので、指示に従って入力をおこなってください。

図2 マスターパッケージの提出

DevPortalでの作業

マスター提出が完了したら、DevPortalで以下の設定を行ってください。 https://psm.playstation.net

  • 提出したPSMアプリの価格設定。
  • アプリ内課金の価格設定。
  • スクリーンショットの設定。
  • バナーの設定。


Publishing Utilityの使い方

この文書ではPublishing Utilityの使い方について説明します。

Contents

  • Publishing Utilityとは
  • Publishing Utility の起動
  • 機能とカテゴリ
  • Metadata カテゴリ
    • Metadata カテゴリ概要
    • Common Property
    • Application Nameの設定
    • イメージ
    • Rating Checkの設定
    • In-App Purchaseの設定
  • Key Management カテゴリ
  • Package & App カテゴリ
    • カテゴリ概要
    • 機能一覧

Publishing Utilityとは

Publishing Utilityは、アプリ情報ファイル(app.xml)の編集、実機開発に用いる鍵の管理、マスターパッケージの管理等の、開発・テスト・販売のための情報設定などの広範に渡る作業を行うGUIツールです。

Publishing Utility の起動

デスクトップ上の [Publishing Utility]のアイコンをダブルクリックしてPublishing Utilityを起動してください。

図1 Publishing Utility

あるいは PSM Studio 内から app.xml を右クリックし、[Edit with PSM Publishing Utility] を選んでください(app.xml を読み込んでの起動)。

図2 PSM StudioからPublishing Utilityを起動

機能とカテゴリ

Publishing Utiliry は、複数の機能群を３つのカテゴリに分類して提供します

  • Metadata カテゴリ： アプリ情報ファイル(app.xml)の値の設定を行います
  • Key Management カテゴリ： 実機上でアプリを動かす為の鍵の管理を行います
  • Package & App カテゴリ： デバイスへのアプリのインストール・実行等を行います

カテゴリボタンをクリックして、アクティブなカテゴリを切り替えてください。

図3 カテゴリの切り替え

Metadata カテゴリ

Metadata カテゴリ概要

主にアプリを販売する為に必要な情報を編集します。

app.xmlを開く

アプリ情報は、各PSMプロジェクト内のapp.xmlに記述されています。

アプリ情報を編集するには、[メニュー] - [File] - [Load]でapp.xmlを開きます。

設定が完了したら、[Save]ボタンを押して保存します。

なお、app.xmlは、プロジェクトをビルドする時、app.infoに変換されます。app.infoはバイナリ版app.xmlで、アプリ実行時に使用されます。

Common Property

Common Propertyタブでは共通で使用される情報を設定します。

各項目をクリックして値を入力します。ウィンドウの下部に項目を補足する注釈が表示されます。参考にして下さい。

図4 Common Property

開発

最初は開発に関連するフィールドです。

メモリサイズ設定

項目名 | 概要 | 設定値
Managed Heap | アプリ内で動的に確保可能なメモリサイズ | 単位は KiB。デフォルト値は 32768 (32MiB)
Resource Heap | オーディオのデータやイメージのデータ、 テクスチャなどに割り当てるメモリサイズ | 単位は KiB。デフォルト値は 65536 (64MiB)

※ managed_heap_size と resource_heap_size の合計が 96MiB を超えることはできません。

最大スクリーンサイズ

項目名 | 概要 | 設定値
Max Screen Size | スクリーンの最大サイズを指定します。 最大サイズ以上のディスプレイ解像度をもつ実機でPSMアプリを実行した場合、 スクリーンはスケーリングされて表示されます。 | 1280x800, 1920x1200。 デフォルト値は1280x800

カメラの最大解像度

項目名 | 概要 | 設定値
Max Camera Resolution Size | カメラのプレビュー画面で表示される画像の最大サイズを指定します。 | 800x600, 2048x1536。 デフォルト値は800x600

入力デバイス設定

項目名 | 概要 | 設定値 (使用:True / 不使用:False)
GamePad | ゲームパッドの有効/無効を設定します。 | デフォルト値は True
Touch | タッチパネルの有効/無効を設定します。 | デフォルト値は True
Motion | モーションセンサーの有効/無効を設定します。 | デフォルト値は False
Location | 位置センサーの有効/無効を設定します。 | デフォルト値は False
Camera | カメラの有効/無効を設定します。 | デフォルト値は False
PS Vita TV | PS Vita TVの有効/無効を設定します。 | デフォルト値は False

アプリ

Application ID

アプリを表す識別子として用いられます。

  • DevPortal 上に登録したアプリを識別する為に用います。[a-zA-Z0-9_-] の文字セットで識別しやすい名前を付けてください。
  • コンテンツ保護機構にも関係します。開発中のみ * という一文字の値を用いる事が出来ます。（参照： Application IDのワイルドカード機能 ）

Version

アプリのバージョンを指定して下さい。1.00-99.99 の値で小数点以下二桁です。 既にストア上にて販売しているバージョンがある場合は、それと比較し数字を上げなければなりません。 一方、申請中のアプリを一旦取り下げたり、または弊社審査にて差し戻しがあった後に、再度マスター提出をする場合には必ずしも数字をあげる必要はありません。

Default Locale

ストア上で用いられる標準言語を指定します。エンドユーザーのストアの表示言語設定がアプリ側で言語が未定義だった場合にのみ用いられます。可能な限り "en-US" を選んでください。

ジャンル

ストア上で取り扱われるジャンルを指定します。Primary と Secondary があり、Primary は設定必須です。

Primary Genre

ストア内で分類と検索に用いられます。

Secondary Genre

設定可能ですが、現在使用されていません。ストア内の検索に用いられる予定です。

開発者

Website

ストア上で表示されるアプリ・開発者のサポート用のウェブサイトを指定して下さい。

Copyright

著作権情報を記述したUTF-8テキストファイル(上限 64 KiB)を指定します。開発者の情報、および付随して記述すべき著作権情報を記載してください。 後ほど、弊社、また PSM SDK に関連する著作権情報が自動で末尾に追加されます。

Copyright Short

ストア上で単行表示される開発元の著作権表記を記入して下さい。

例:

Copyright (C) 2013 Foo Bar Inc. All Rights Reserved.

Application Nameの設定

Application Nameタブでは対応言語ごとにアプリ名を設定します。

図5 Application Name

対応言語ごとにLong Name、Short Nameを入力してください。

  • Long Nameはこのアプリの正式名称です。ストア上などで表示されます。
    •

  • Short NameはPSMアプリのアイコンとともに表示される表記です。
    •

  • Long NameとShort Nameは同じでも構いません。
    •

Localeの略称は次の言語に対応しています。

Locale
 | 言語

en-US
 | 英語(アメリカ)

en-GB
 | 英語(イギリス)

ja-JP
 | 日本語

fr-FR
 | フランス語

es-ES
 | スペイン語

de-DE
 | ドイツ語

it-IT
 | イタリア語

nl-NL
 | オランダ語

pt-PT
 | ポルトガル語

pt-BR
 | ポルトガル語(ブラジル)

ru-RU
 | ロシア語

ko-KR
 | 韓国語

zh-Hant
 | 中国語 繁体字

zh-Hans
 | 中国語 簡体字

fi-FI
 | フィンランド語

sv-SE
 | スウェーデン語

da-DK
 | デンマーク語

nb-NO
 | ノルウェー語

pl-PL
 | ポーランド語

イメージ

画像ファイルを指定します。

図6 Image

Icon

  • Icon欄の画像ファイルには、 32bit full color PNG 形式のファイルを指定します。サイズは 512x512, 256x256, 128x128 の３種類です。
    •

  • Icon欄で指定した画像ファイルは、PSMアプリのアイコンや、ストアでの表示などに利用されます。
    •

  • アイコンに使用するPNG形式ファイルのアルファ値は、すべて0xFF(不透明)でなければいけません。
    •

Splash

  • Splash欄には、 854x480 8bit Index Color PNG 形式のファイルを指定します。
    •

  • Splash欄で指定した画像ファイルは、PS Vita の Live Area にて Gate (中央ボタン) をタップしてからゲームが起動するまでの間に表示されます。
    •

Rating Checkの設定

Rating CheckタブではPSMアプリのレーティングを設定します。

図7 Rating Check

レーティングは次の3つのチェックツールで判定します。

  • PEGI Express(Pan European Game Information)。欧州のレーティング。
    •

  • ESRB Short Form (Entertainment Software Rating Board)。北米のレーティング。
    •

  • PlayStation(R)Mobile Age Rating System。弊社のレーティングシステム。
    •

[Common Property] - [3. Genre]で指定したジャンルがゲームの場合、上記の3つのレーティングチェックを全ておこなう必要があります。指定したジャンルがゲームでない場合、PlayStation(R)Mobile Age Rating Systemでのみレーティングチェックをおこなってください。

タブ内のURLまたはボタンをクリックし、各サイトでレーティングの判定をおこなってください。

3つの判定結果のうち、一番高い数値がそのPSMアプリのレーティングとして適用されます。

判定が完了したら判定結果を各フィールドに入力します。

PEGI express レーティング結果の入力

PEGI expressのWebサイトでレーティングチェックが完了すると、PEGIlicense_XXX.pdfというファイルが取得できます。

そのファイルに、Age Rating Logo、Registered Number、Content Descriptorsの情報が記載されているので、その情報をもとに対応する各フィールドに値を入力してください。

図8 PEGI

ESRB Short Form レーティング結果の入力

ESRB Short FormのWebサイトでレーティングチェックが完了すると、xxx.pdfというファイルが取得できます。

そのファイルに、Ratign Category、Certificate Codeの情報が記載されているので、その情報をもとに対応する各フィールドに値を入力してください。

図9 ESRB Short Form

PlayStation(R)Mobile Age Rating System

弊社のレーティングシステムでチェックを行うには [Start Rating Check]ボタンをクリックします。

そして、ウィザードに表示される設問に回答してゆくと判定が完了します。

図10 PlayStation(R)Mobile Age Rating System

In-App Purchaseの設定

In-App Purchaseタブではアプリ内課金のプロダクトデータを作成・編集します。

ここではアイテムの定義と各国語での名称の設定を行い、価格の設定は別途 DevPortal より行います。

図11 In-App Purchase

  1. Support Localeで、対応言語のチェックボックスにチェックを入れます。
    2.

  2. Product Labelにプロダクトのラベル名を入力します。
    3.

ラベル名の命名には次の規約があります。

  • ラベル名に使用できる文字は、数字と大文字のアルファベットのみです。
    •

  • ラベル名の文字数は6文字固定です。
    •

  • 000000は予約されているので使用できません。
    •

  3. 入力したラベル名が規約を満たしていれば、[Add Product]ボタンが使用可能になります。プロダクトを追加するにはボタンを押してください。
    4.

  4. プロダクトが追加されるので、各対応言語で名称を入力します。消費型のプロダクトにする場合、Consumableのチェックボックスをチェックしてください。
    5.

制限事項

プロダクトを作成するときは、以下の点に注意してください。

  • プロダクトは合計20個まで作成することができます。それ以上は作成することができません。
    •

  • マスター提出後、プロダクトが正式に登録されると、以降そのプロダクトのラベル名を変更・削除することはできません。変更・削除した場合、データの正当性チェックでエラーが発生します。
    •

  • プロダクトが正式に登録されたあとには、プロダクトのローカル名の変更・削除はできません。
    •

  • プロダクトが正式に登録されたあとでも、プロダクト、ローカル名の追加は可能です。
    •

Key Management カテゴリ

詳細は 実機でPSMアプリを実行するための鍵の作成について をご覧ください

Package & App カテゴリ

カテゴリ概要

アプリパッケージのインストール、アンインストール、実行、停止等が行えます。
その他、パッケージファイルの展開、アプリの文字列出力の表示が行えます。

図12 Package&Appカテゴリ

機能一覧

画面左の [Online Devices] リストよりデバイスを選択すると、そのデバイス上にインストールされたアプリが画面右の [Installed Apps] リストに表示されます。

図13 アプリ操作ボタン

アプリのインストール ： [Online Devices] で選択したデバイスにアプリをインストールします。この時に、鍵も同時にインストールされます。

アプリのアンインストール： [Installed Apps] で選択したアプリを、デバイスからアンインストールします。この時、アプリの データも消去される 点にご注意ください。

アプリの実行： [Installed Apps] で選択したアプリを起動します。

アプリの停止： [Online Devices] で選択したデバイス上で動いているアプリを停止します。

タブ内の機能

コンソール出力： 画面下部のタブを選択すると、[Online Devices] で選択したデバイスの文字列出力が表示されます。

パッケージの展開： 画面下部のタブを選択し、その中の左側のパネルにパッケージ (.psmp/.psdp) をドラッグ＆ドロップして下さい。
入力パッケージの横に .extracted という拡張子が付いたディレクトリとして展開されます。

図14 コンソール出力とパッケージの展開


PlayStation(R)Mobile MDX ファイル形式の概要

PlayStation(R)Mobile MDX ファイル形式は、モデルデータを格納するファイル形式です。

Contents

  • MDX ファイル形式
    • モデルデータ
    • ブロック構造
    • 文法
    • テキスト形式
    • バイナリ形式
  • ブロック
    • File
    • Model
    • Bone
    • Part
    • Mesh
    • Arrays
    • Material
    • Layer
    • Texture
    • Motion
    • FCurve
  • 共通コマンド
    • FileName
    • FileImage
    • BoundingBox
    • BoundingSphere
  • Bone コマンド
    • ParentBone
    • Visibility
    • Pivot
    • Translate
    • Rotate
    • RotateXYZ/YZX/ZXY/XZY/YXZ/ZYX
    • Scale
    • BlendBone
    • DrawPart
  • Mesh コマンド
    • SetMaterial
    • SetArrays
    • BlendIndices
    • DrawArrays
  • Material コマンド
    • Diffuse
    • Ambient
    • Specular
    • Emission
    • Opacity
    • Shininess
  • Layer コマンド
    • SetTexture
  • Texture コマンド
    • UVTranslate
    • UVScale
  • Motion コマンド
    • FrameLoop
    • FrameRate
    • FrameRepeat
    • Animate
  • 列挙定数
    • BlockType
    • CommandType
    • VertexFormat
    • InterpType
    • ExtrapType
    • DrawMode
    • RepeatMode

MDX ファイル形式

モデルデータ

MDX ファイルは、以下の機能をもつモデルデータを格納できます。

  • 階層ノード (トランスフォーメーション、ビジビリティ、スキニング)
  • 形状データ (ポイント、ライン、トライアングル)
  • 頂点データ (位置、法線、カラー、UV、ウェイト、インデックス)
  • マテリアル設定 (レガシーマテリアル)
  • テクスチャマッピング (シングルレイヤー)
  • テクスチャ画像 (DDS, PNG, JPG, BMP, GIF）
  • アニメーション (トランスフォーメーション、マテリアル、UV)

モデルデータのデフォルト設定は、以下のようになっています。

  • 3D 座標 : 右手系 (Ｙ＝上)
  • UV 座標 : 左上原点
  • 行列順序 : Column-major
  • 面カリング : CCW が表面
  • 法線ベクトル : 表面方向

ブロック構造

MDX ファイルは、以下のような階層的なブロックで構成されます。

File            // ファイル本体 (バイナリ形式のみ)
  Model         // モデル本体
    Bone        // 階層ノード
    Part        // 形状データ
      Mesh      // 描画メッシュ
      Arrays    // 頂点データ
    Material    // マテリアル設定
      Layer     // テクスチャマッピング
    Texture     // テクスチャ画像
    Motion      // アニメーション集合
      FCurve    // アニメーションカーブ

テキスト形式の単純なモデルデータの例を、以下に示します。

.MDS 1.00

Model "model-0" {
    Bone "bone-0" {
        Translate 0.000000 0.000000 0.000000
        RotateYXZ 0.000000 0.000000 0.000000
        DrawPart "part-0"
    }
    Part "part-0" {
        Mesh "mesh-0" {
            SetMaterial "material-0"
            SetArrays "arrays-0"
            DrawArrays TRIANGLES 3 1 0 1 2
        }
        Arrays "arrays-0" POSITION|NORMAL 0 3 {
            0.000000 0.577350 0.000000 0.000000 0.000000 1.000000
            -0.500000 -0.288675 0.000000 0.000000 0.000000 1.000000
            0.500000 -0.288675 0.000000 0.000000 0.000000 1.000000
        }
    }
    Material "material-0" {
        Diffuse 0.000000 0.000000 1.000000
        Specular 1.000000 1.000000 1.000000
        Opacity 1.000000
        Shininess 10.000000
    }
}

文法

MDX ファイルは、ヘッダ、ブロック、コマンドの組み合わせで記述されます。

FormatSignature $version

BlockType $name $arg1 $arg2 ... {
    CommandType $arg1 $arg2 ...
    CommandType $arg1 $arg2 ...

    BlockType $name $arg1 $arg2 ... {
        CommandType $arg1 $arg2 ...
        CommandType $arg1 $arg2 ...
    }

    BlockType $name $arg1 $arg2 ... {
        $data0 $data1 $data2 ...
    }
}
ヘッダ
ヘッダはファイルフォーマットをあらわします。フォーマットシグネチャとバージョンが記述されます。
ブロック
ブロックは一群のデータ集合をあらわします。ブロックタイプ、名前および引数が記述されます。 ブロックの子要素として、複数のコマンドや複数のブロックを格納することができます。 さらに、ブロックデータとして単純な値の配列を格納することもできます。
コマンド
コマンドは単純なデータをあらわします。コマンドタイプと引数が記述されます。

コマンド引数、ブロック引数、ブロックデータに含まれる要素の型は、以下のとおりです。

型 | データ | 記述例 1 | 記述例 2
ref | ブロックへの参照 | "bone-0" | "Bone::bone-0" (ブロックタイプつき)
enum | 列挙定数 | POSITION | POSITION|NORMAL (論理和)
string | 8bit ゼロ終端文字列 | "texture.png"
float | 32bit 浮動小数点数 | 10.0
half | 16bit 浮動小数点数 | 10.0
int | 32bit 符号つき整数 | 10
uint | 32bit 符号なし整数 | 10
short | 16bit 符号つき整数 | 10
ushort | 16bit 符号なし整数 | 10
byte | 8bit 符号つき整数 | 10
ubyte | 8bit 符号なし整数 | 10

テキスト形式

テキスト形式では、モデルデータがテキスト表現で格納されます。

  • ファイル名の拡張子は ".MDS" です。
  • フォーマットシグネチャは ".MDS" です。
  • キャラクタのサイズは 8bit です。
  • File ブロックは省略されます
  • Arrays ブロックの頂点ストライドは 0 になります

バイナリ形式

バイナリ形式では、モデルデータがバイナリ表現で格納されます。

  • ファイル名の拡張子は ".MDX" です。
  • フォーマットシグネチャは '.MDX' です。
  • バイトオーダーはリトルエンディアンです
  • File ブロックが出力されます
  • Arrays ブロックの頂点ストライドは計算された値になります

ヘッダ、ブロック、コマンドは、以下のような構造体に格納されます。

struct MdxHeader {
    uint Signature ;        // フォーマットシグネチャ ( 0x2e4d4458 )
    uint Version ;          // フォーマットバージョン ( 0x312e3030 )
    uint Style ;            // フォーマットスタイル   ( 0x0050534d )
    uint Option ;           // フォーマットオプション ( 0x00000000 )
}

struct MdxBlock {
    ushort Type ;           // ブロックタイプ
    ushort NameEnd ;        // ブロック名の終了位置
    uint ArgsEnd ;          // ブロック引数の終了位置
    uint DataEnd ;          // ブロックデータの終了位置
    uint ChildEnd ;         // 子要素の終了位置

    // ブロック名
    // ブロック引数
    // ブロックデータ
    // 子要素
}

struct MdxCommand {
    ushort Type ;           // コマンドタイプ | 0x8000
    ushort ArgsEnd ;        // コマンド引数の終了位置

    // コマンド引数
}
  • 構造体とその要素の位置は、４バイト単位でアラインされています。
  • ある要素の開始位置は、直前の要素の終了位置から計算できます。
  • ある要素の終了位置は、構造体先頭からのオフセットとして、構造体に格納されています。

コマンド引数、ブロック引数、ブロックデータに含まれる値の位置は、それぞれのデータ型のサイズでアラインされています。ブロックへの参照は以下のようなビットフィールド値として格納されます。

struct MdxReference {
    uint Bits ;

    // ブロックのタイプ
    int Type { get { return (int)( Bits >> 16 ) & 0xffff ; } }
    // ブロックの相対レベル
    int Level { get { return (int)( Bits >> 12 ) & 0x000f ; } }
    // 同じ階層内の同タイプブロック内のブロック番号
    int Index { get { return (int)( Bits >> 0 ) & 0x0fff ; } }
}

ブロック

File

[概要]

    ファイル本体をあらわすブロック

[書式]

    File $name {
        ...
    }

[引数]

    string $name                ブロック名

[要素]

    Model

Model

[概要]

    モデル本体をあらわすブロック

[書式]

    Model $name {
        ...
    }

[引数]

    string $name                ブロック名

[要素]

    BoundingBox
    BoundingSphere
    Bone                        (複数可)
    Part                        (複数可)
    Material                    (複数可)
    Texture                     (複数可)
    Motion                      (複数可)

Bone

[概要]

    階層ノードをあらわすブロック

[書式]

    Bone $name {
        ...
    }

[引数]

    string $name                ブロック名

[要素]

    BoundingBox
    BoundingSphere
    ParentBone
    Visibility
    Pivot
    Translate
    Rotate*
    Scale
    BlendBone                   (複数可)
    DrawPart                    (複数可)

Part

[概要]

    形状データをあらわすブロック

[書式]

    Part $name {
        ...
    }

[引数]

    string $name                ブロック名

[要素]

    BoundingBox
    BoundingSphere
    Mesh                        (複数可)
    Arrays                      (複数可)

Mesh

[概要]

    描画メッシュをあらわすブロック

[書式]

    Mesh $name {
        ...
    }

[引数]

    string $name                ブロック名

[要素]

    BoundingBox
    BoundingSphere
    SetMaterial
    SetArrays
    BlendIndices
    DrawArrays                  (複数可)

Arrays

[概要]

    頂点データをあらわすブロック

[書式]

    Arrays $name $format $stride $count {
        ...
    }

[引数]

    string $name                ブロック名
    enum VertexFormat $format   頂点フォーマット
    int $stride                 頂点ストライド
    int $count                  頂点数

[データ]

    頂点データは (１頂点のデータ x 頂点数) で構成されます。
    ------------------------------------------------
    Position Normal Color TexCoord Weights Indices  // Data for one vertex
    Position Normal Color TexCoord Weights Indices  // Data for one vertex
    Position Normal Color TexCoord Weights Indices  // Data for one vertex
    ...
    ------------------------------------------------

    頂点データの内容は、頂点フォーマットの論理和で定義されます。

    頂点フォーマットと、対応する頂点要素は以下のとおりです。
    ------------------------------------------------
    POSITION    float x 3   位置座標
    NORMAL      float x 3   法線ベクトル
    COLOR       float x 4   頂点カラー
    TEXCOORD    float x 2   テクスチャ座標
    WEIGHTn     float x n   ブレンドウェイト
    INDICES     ubyte x n   ブレンドインデックス
    ------------------------------------------------

Material

[概要]

    マテリアル設定をあらわすブロック

[書式]

    Material $name {
        ...
    }

[引数]

    string $name                ブロック名

[要素]

    Diffuse
    Ambient
    Specular
    Emission
    Opacity
    Shininess
    Layer                       (複数可)

Layer

[概要]

    テクスチャマッピングをあらわすブロック

[書式]

    Layer $name {
        ...
    }

[引数]

    string $name                ブロック名

[要素]

    SetTexture

Texture

[概要]

    テクスチャ画像をあらわすブロック

[書式]

    Texture $name {
        ...
    }

[引数]

    string $name                ブロック名

[要素]

    FileName
    FileImage
    UVTranslate
    UVScale

Motion

[概要]

    アニメーション集合をあらわすブロック

[書式]

    Motion $name {
        ...
    }

[引数]

    string $name                ブロック名

[要素]

    FrameLoop
    FrameRate
    FrameRepeat
    Animate                     (複数可)
    FCurve                      (複数可)

FCurve

[概要]

    アニメーションカーブをあらわすブロック

[書式]

    FCurve $name $interp $extrap $dimCount $keyCount {
        ...
    }

[引数]

    string $name                ブロック名
    enum InterpType $interp     内挿タイプ
    enum ExtrapType $extrap     外挿タイプ
    int $dimCount               次元数
    int $keyCount               キーフレーム数

[データ]

    アニメーションカーブは (１キーフレームのデータ x キーフレーム数) で構成されます。

    基本的には、１つのキーフレームにはフレームとキー値が格納されます。要素数は (次元数 + 1) になります。
    ------------------------------------------------
    Frame Values[n]  // Data for one key-frame
    Frame Values[n]  // Data for one key-frame
    Frame Values[n]  // Data for one key-frame
    ...
    ------------------------------------------------

    内挿タイプが HERMITE の場合、さらに接線ベクトルの Y 成分が格納されます。要素数は (次元数 x 3 + 1) となります。
    ------------------------------------------------
    Frame Values[n] InTangentY[n] OutTangentY[n]
    Frame Values[n] InTangentY[n] OutTangentY[n]
    Frame Values[n] InTangentY[n] OutTangentY[n]
    ...
    ------------------------------------------------

    内挿タイプが CUBIC の場合、さらに接線ベクトルの X 成分が格納されます。要素数は (次元数 x 5 + 1) となります。
    ------------------------------------------------
    Frame Values[n] InTangentY[n] OutTangentY[n] InTangentX[n] OutTangentX[n]
    Frame Values[n] InTangentY[n] OutTangentY[n] InTangentX[n] OutTangentX[n]
    Frame Values[n] InTangentY[n] OutTangentY[n] InTangentX[n] OutTangentX[n]
    ...
    ------------------------------------------------

共通コマンド

FileName

[概要]

    ファイル名

[書式]

    FileName $name

[引数]

    string $name                ファイル名

FileImage

[概要]

    ファイルイメージ

[書式]

    FileImage $size $data ...

[引数]

    uint $size                  サイズ (単位＝バイト)
    uint $data ...              データ (32bit ごと)

BoundingBox

[概要]

    バウンディングボックス

[書式]

    BoundingBox $minX $minY $minZ $maxX $maxY $maxZ

[引数]

    float $minX                 最小 X
    float $minY                 最小 Y
    float $minZ                 最小 Z
    float $maxX                 最大 X
    float $maxY                 最大 Y
    float $maxZ                 最大 Z

BoundingSphere

[概要]

    バウンディングスフィア

[書式]

    BoundingSphere $centerX $centerY $centerZ $radius

[引数]

    float $centerX              中心 X
    float $centerY              中心 Y
    float $centerZ              中心 Z
    float $radius               半径

Bone コマンド

ParentBone

[概要]

    親ボーン

[書式]

    ParentBone $bone

[引数]

    ref Bone $bone              親ボーンへの参照

Visibility

[概要]

    ビジビリティ

[書式]

    Visibility $visibility

[引数]

    uint $visibility            ビジビリティ

Pivot

[概要]

    ピボット

[書式]

    Pivot $x $y $z

[引数]

    float $x                    X
    float $y                    Y
    float $z                    Z

Translate

[概要]

    トランスレーション

[書式]

    Translate $x $y $z

[引数]

    float $x                    X
    float $y                    Y
    float $z                    Z

Rotate

[概要]

    ローテーション (四元数)

[書式]

    Rotate $x $y $z $w

[引数]

    float $x                    X
    float $y                    Y
    float $z                    Z
    float $w                    W

RotateXYZ/YZX/ZXY/XZY/YXZ/ZYX

[概要]

    ローテーション (オイラー角)

[書式]

    RotateXYZ $x $y $z
    RotateYZX $x $y $z
    RotateZXY $x $y $z
    RotateXZY $x $y $z
    RotateYXZ $x $y $z
    RotateZYX $x $y $z

[引数]

    float $x                    X (単位＝度)
    float $y                    Y (単位＝度)
    float $z                    Z (単位＝度)

Scale

[概要]

    スケーリング

[書式]

    Scale $x $y $z

[引数]

    float $x                    X
    float $y                    Y
    float $z                    Z

BlendBone

[概要]

    頂点ブレンドボーン

[書式]

    BlendBone $bone $m11 $m12 $m13 $m14 \
                    $m21 $m22 $m23 $m24 \
                    $m31 $m32 $m33 $m34 \
                    $m41 $m42 $m43 $m44

[引数]

    ref Bone $bone              頂点ブレンドボーンへの参照
    float $m11 ... $m14         オフセット行列の 1 列目
    float $m21 ... $m24         オフセット行列の 2 列目
    float $m31 ... $m34         オフセット行列の 3 列目
    float $m41 ... $m44         オフセット行列の 4 列目

DrawPart

[概要]

    描画パート

[書式]

    DrawPart $part

[引数]

    ref Part $part              描画パートへの参照

Mesh コマンド

SetMaterial

[概要]

    マテリアル設定

[書式]

    SetMaterial $material

[引数]

    ref Material $material      マテリアル設定への参照

SetArrays

[概要]

    頂点データ

[書式]

    SetArrays $arrays

[引数]

    ref Arrays $arrays          頂点データへの参照

BlendIndices

[概要]

    頂点ブレンドインデックス

[書式]

    BlendIndices $count $index ...

[引数]

    int $count                  頂点ブレンド数
    int $index ...              頂点ブレンドインデックス

DrawArrays

[概要]

    描画プリミティブ

[書式]

    DrawArrays $mode $vertCount $primCount $index ...

[引数]

    enum DrawMode $mode         描画モード
    int $vertCount              頂点数
    int $primCount              プリミティブ数
    ushort $index ...           頂点インデックス

Material コマンド

Diffuse

[概要]

    ディフューズカラー

[書式]

    Diffuse $r $g $b

[引数]

    float $r                    R
    float $g                    G
    float $b                    B

Ambient

[概要]

    アンビエントカラー

[書式]

    Ambient $r $g $b

[引数]

    float $r                    R
    float $g                    G
    float $b                    B

Specular

[概要]

    スペキュラーカラー

[書式]

    Specular $r $g $b

[引数]

    float $r                    R
    float $g                    G
    float $b                    B

Emission

[概要]

    エミッションカラー

[書式]

    Emission $r $g $b

[引数]

    float $r                    R
    float $g                    G
    float $b                    B

Opacity

[概要]

    不透明度

[書式]

    Opacity $opacity

[引数]

    float $opacity              不透明度

Shininess

[概要]

    スペキュラー指数

[書式]

    Shininess $shininess

[引数]

    float $shininess            スペキュラー指数

Layer コマンド

SetTexture

[概要]

    テクスチャ画像

[書式]

    SetTexture $texture

[引数]

    ref Texture $texture        テクスチャへの参照

Texture コマンド

UVTranslate

[概要]

    UV トランスレーション

[書式]

    UVTranslate $u $v

[引数]

    float $u                    U
    float $v                    V

UVScale

[概要]

    UV スケーリング

[書式]

    UVScale $u $v

[引数]

    float $u                    U
    float $v                    V

Motion コマンド

FrameLoop

[概要]

    ループ範囲

[書式]

    FrameLoop $start $end

[引数]

    $start                      開始フレーム
    $end                        終了フレーム

FrameRate

[概要]

    フレームレート

[書式]

    FrameRate $fps

[引数]

    float $fps                  フレームレート (単位＝フレーム毎秒)

FrameRepeat

[概要]

    繰り返しモード

[書式]

    FrameRepeat $mode

[引数]

    enum RepeatMode $mode       繰り返しモード

Animate

[概要]

    アニメーション

[書式]

    Animate $block $command $option $fcurve

[引数]

    ref Block $block            ブロックへの参照
    enum CommandType $command   コマンドタイプ
    int $option                 オプション
    ref FCurve $fcurve          アニメーションカーブへの参照

列挙定数

BlockType

File            = 0x0002
Model           = 0x0010
Bone            = 0x0011
Part            = 0x0012
Mesh            = 0x0013
Arrays          = 0x0014
Material        = 0x0016
Layer           = 0x0017
Texture         = 0x0018
Motion          = 0x001b
FCurve          = 0x001c

CommandType

FileName        = 0x0080
FileImage       = 0x0081
BoundingBox     = 0x0082
BoundingSphere  = 0x0083
ParentBone      = 0x0440
Visibility      = 0x0441
Pivot           = 0x0442
Translate       = 0x0443
Rotate          = 0x0444
RotateXYZ       = 0x0445
RotateYZX       = 0x0446
RotateZXY       = 0x0447
RotateXZY       = 0x0448
RotateYXZ       = 0x0449
RotateZYX       = 0x044a
Scale           = 0x044b
BlendBone       = 0x0460
DrawPart        = 0x047f
SetMaterial     = 0x04c0
SetArrays       = 0x04c1
BlendIndices    = 0x04c2
DrawArrays      = 0x04e0
Diffuse         = 0x0581
Ambient         = 0x0582
Specular        = 0x0583
Emission        = 0x0584
Opacity         = 0x0588
Shininess       = 0x0589
SetTexture      = 0x05c0
UVTranslate     = 0x0621
UVScale         = 0x0623
FrameLoop       = 0x06c0
FrameRate       = 0x06c1
FrameRepeat     = 0x06c2
Animate         = 0x06e0

VertexFormat

POSITION        = 1 << 0
NORMAL          = 1 << 1
COLOR           = 1 << 3
TEXCOORD        = 1 << 5
WEIGHTn         = n << 8
INDICES         = 1 << 16

InterpType

CONSTANT        = 0x0000
LINEAR          = 0x0001
HERMITE         = 0x0002
CUBIC           = 0x0003
SPHERICAL       = 0x0004

ExtrapType

HOLD            = 0x0000
CYCLE           = 0x0011
SHUTTLE         = 0x0022
HOLD_HOLD       = 0x0000
HOLD_CYCLE      = 0x0001
HOLD_SHUTTLE    = 0x0002
CYCLE_HOLD      = 0x0010
CYCLE_CYCLE     = 0x0011
CYCLE_SHUTTLE   = 0x0012
SHUTTLE_HOLD    = 0x0020
SHUTTLE_CYCLE   = 0x0021
SHUTTLE_SHUTTLE = 0x0022

DrawMode

POINTS          = 0x0000
LINES           = 0x0001
LINE_STRIP      = 0x0002
TRIANGLES       = 0x0003
TRIANGLE_STRIP  = 0x0004
TRIANGLE_FAN    = 0x0005

RepeatMode

HOLD            = 0x0000
CYCLE           = 0x0001


バグ情報

現在のバージョンで確認されているバグに関する情報をお知らせします。

Contents

  • スレッドの生成と削除について
  • System.Net.WebConnectionStream について

スレッドの生成と削除について

詳細

PSM SDK 1.20.00 において、PS Vita でスレッドを頻繁に生成・削除すると一部の同期オブジェクトがリークし、およそ 420 回の反復でプログラムがハングアップする場合があるという不具合が確認されています。

回避方法

一定数のスレッドを再利用するようにして、スレッドの無制限な生成・削除を避けてください。

System.Net.WebConnectionStream について

詳細

PSM SDK 1.20.00 において、 System.Net.WebConnectionStream.Read() を呼び出すと一部の同期オブジェクトがリークし、およそ 500 回の反復でプログラムがハングアップする場合があるという不具合が確認されています。

( WebConnectionStream クラスは通常 WebResponse.GetResponseStream() などの戻り値として取得されます )

回避方法

一度に読み込むサイズを大きくして Read() を呼び出す回数を減らしてください。さらに定期的に GC.Collect() を呼び出してガベージコレクションを強制実行してください。


リリースノート

リリースノートでは、バージョンごとに新規追加・変更された項目を記載しています。

Contents

  • ver 2.00.00
  • ver 1.21.02
  • ver 1.21.01
  • ver 1.21.00
  • ver 1.20.00
  • ver 1.11.01
  • ver 1.11.00
  • ver 1.10.00 ベータ版

ver 2.00.00

全体

新規/変更点

  • PSM SDK 2.00.00以降、マスター提出が可能なプラットフォームはPS Vita, PS Vita TVのみとなりました。
    • PSM SDK 1.xで作成されたタイトルがすでに販売されている場合、PSM SDK 2.xで作成した同じApplication IDのマスターパッケージは提出できません。そのタイトルを更新したい場合、PSM SDK 1.xを使ってマスターパッケージを作成・提出してください。詳しくは「マスターの作成と提出」 - 「SDKバージョン間におけるマスターパッケージ更新の制限」をご覧ください。

  • インストールするGtk#のバージョンを2.12.10から2.12.25に変更しました。

Graphics

新規/変更点

  • テクスチャがリソースヒープを消費しないようにしました。グラフィクスメモリ (96MiB) だけを消費するようになり、テクスチャの最大量が大幅に増加します。詳しくは [API 概要] - [Graphics 概要] - [リソースヒープとグラフィクスメモリ] を参照してください。

  • DDS ファイルおよび DXT 圧縮形式が利用可能になりました。現在のバージョンではピクセルフォーマットが DXT の場合、幅と高さは２のべき乗である必要があります。

  • 頂点テクスチャフェッチが利用可能になりました。頂点シェーダーでテクスチャを使用できます。

  • インスタンス描画が利用可能になりました。以下の API を追加しました。
    • GraphicsContext.DrawArraysInstanced(DrawMode,int,int,int,int)
    • VertexBuffer.VertexBuffer(int,int,int,VertexFormat[])
    • VertexBuffer.InstanceDivisor

Model

新規/変更点

  • モデルコンバータが FBX ファイルのフレームレートを反映するようにしました。
  • モデルコンバータが DDS ファイルのテクスチャを読み込むようにしました。

Input

新規/変更点

  • 背面タッチパネルのデータを取得する以下の API を追加しました。PC Simulator 環境においては、該当 API を呼び出しても入力がないものとして扱われます。
    • Touch.GetRearTouchData()

Services

新規・変更点

  • スコアボードの機能は、非サポートとなります。
    • 関連クラスにはobsolete 属性がついており、ビルド時に警告が表示されますので、使わないようにしてください。
    • サンプル、ドキュメントは削除しました。

Mono(Standard Library)

新規/変更点

  • PlayStation(R)Vita でタイマー (System.Threading.Timer) が遅れる問題を修正しました。
  • SSL 通信に時間がかかる問題を修正しました。

PSM Studio

新規・変更点

  • PlayStation(R)Vita を複数台接続済みのPCにおいて、PSM Studioからアプリケーションを実行する際にタイムアウトエラーとなってしまう問題を修正しました。
  • バージョン管理の機能を削除しました。

Publishing Utility

新規・変更点

  • PS Vita TV設定フラグを追加しました。

PSM Development Assistant (for PlayStation(R)Vita)

新規・変更点

  • PSM SDK 2.00.00 に対応する PSM Development Assistant (for PlayStation(R)Vita) をパッチパッケージとしてリリースしました。PS Vita 本体のシステムソフトウェアを最新のものにアップデートしてご利用ください。
  • アプリケーションの削除を複数選択できるように変更しました。
  • アプリケーションのインストール/アンインストール/メニューからの削除時に、プログレスバーで進捗率を表示するようにしました。
  • アプリケーションの著作権情報 (Copyright) のプレビュー機能を追加しました。
  • 設定アプリケーション＞[システム]＞[PS Vita本体のボタンで操作する]の項目が有効になっている場合、PS Vita 本体のボタンで操作できるようにしました。
  • Publishing Utility を用いてアイコン画像を設定した状態でアプリケーションをビルド、インストールした際に、リストメニューにその画像を表示するように変更しました。設定されていない場合、デフォルトの画像が表示されます。
  • Publishing Utility を用いてスプラッシュ画像を設定した状態でアプリケーションをビルド、インストールした際に、起動時にその画像を表示するように変更しました。設定されていない場合、デフォルトの画像が表示されます。
  • PSM Studio, Publishing Utility との USB 接続が確立した際に、ノーティフィケーションを表示するようにしました。
  • PSM Studio, Publishing Utility からアプリケーションのインストールや鍵の設定/転送が行われる際に、自動的に対応するランタイムのバージョンに切り替えるようにしました。これに伴い、[Debug Settings] - [Switch Development Assistant] のメニュー及び右上のバージョン表記を削除しました。
  • ビルド情報を表示するメニューを追加しました。

サンプル

新規・変更点

  • 以下のサンプルを追加しました。

    • Graphics/TextureSample
    • Graphics/SpriteSample2
    • Graphics/SpriteSample3

ver 1.21.02

全体

新規・変更点

  • アプリケーション動作時の互換性の問題を修正しました。

PSM Development Assistant (for PlayStation(R)Vita)

新規・変更点

  • PSM SDK 1.21.02 に対応する PSM Development Assistant (for PlayStation(R)Vita) をパッチパッケージとしてリリースしました。PlayStation(R)Vita本体のシステムソフトウェアを最新のものにアップデートしてご利用ください。

サンプル

新規・変更点

  • TwitterStreamingSampleの以下の不具合を修正しました。

    • 検索してもツイートが表示されない場合がある
    • Twitterアカウントのユーザー情報設定でタイムゾーンが正しく設定されていないと、プログラムが強制終了する場合がある

  • TwitterSampleとTwitterStreamingSampleのProxy設定に関する仕様を変更しました。詳細は各サンプルのドキュメントを参照して下さい。

ソースコード

新規・変更点

  • 次のソースコードを修正しました。

    • TweetSharp

ver 1.21.01

全体

新規・変更点

  • アプリケーション動作時の安定性の問題を修正しました。

PSM Development Assistant (for PlayStation(R)Vita)

新規・変更点

  • PSM SDK 1.21.01 に対応する PSM Development Assistant (for PlayStation(R)Vita) をパッチパッケージとしてリリースしました。PlayStation(R)Vita本体のシステムソフトウェアを最新のものにアップデートしてご利用ください。

ver 1.21.00

全体

新規・変更点

  • Android 4.3 (Jelly Bean MR2) に対応しました。
  • TweetSharp を PSM に移植し、ソースコードと新規サンプルを追加しました。
  • 一部のAndroid デバイスで、PS3(TM)のワイヤレスコントローラ使用時に、キーが正しくアサインされない不具合を修正しました。

Audio

新規・変更点

  • BgmPlayerを長時間使用するとリソースリークが発生する問題を修正しました。

ドキュメント

新規・変更点

  • 次のドキュメントを新規追加・修正しました。

    • [Services.Network 概要]
    • [そのほかの情報] - [バグ情報]

サンプル

新規・変更点

  • Network/TwitterSample
  • Network/TwitterStreamingSample

ソースコード

新規・変更点

  • TweetSharp

PSM Development Assistant (for PlayStation(R)Vita)

新規・変更点

  • PSM SDK 1.21.00 に対応する PSM Development Assistant (for PlayStation(R)Vita) をパッチパッケージとしてリリースしました。PSM Development Assistant (for PlayStation(R)Vita) for PSM SDK 1.21.00 を使用するには、PlayStation(R)Vita本体のシステムソフトウェアを最新のものにアップデートする必要があります。
  • PSM SDK 1.21.00 では、PSM Development Assistant の動作モードを切り替えるメニューは無効化されています。

ver 1.20.00

全体

新規・変更点

  • スコアボードの機能を追加しました。
  • LuaInterface を PSM に移植し、ソースコードと新規サンプルを追加しました。
  • 鍵作成の利便性を改善しました。
  • Windows 8 をSDKのオフィシャルサポート対象に加えました。合わせて、Windows XP をオフィシャルサポート対象外としました。
  • Android 4.2 (Jelly Bean) から追加されたマルチユーザー機能に対応しました。
  • Android でアプリケーションが非表示になった時に、アプリケーションが終了しないようにしました。

ドキュメント

新規・変更点

  • 次のドキュメントを新規追加・修正しました。

    • [Services.Network 概要]
    • [PlayStation(R)Mobile Development Assistant について]
    • [UI Toolkit] - [UI Toolkitプログラミングガイド] - [基本概念] - [画面の向き]
    • [ユーザーガイド] - [最適化のヒント]
    • [ユーザーガイド] - [アプリ内課金] - [購入フローの実装]

サンプル

新規・変更点

  • 次のサンプルを新規追加・修正しました。各サンプルの概要については[サンプル一覧] をご覧ください。

    • Scoreboard/ScoreboardSample
    • Scoreboard/NewActionGameDemo
    • Script/LuaSample
    • Script/LuaTriangleSample
    • UI/ScreenOrientation
    • Environment/PersistentMemorySample
    • Tips/Compatibility/SoundDelaySample
    • Tips/Compatibility/TouchDelaySample
    • Tips/Performance/LoadingThreadSample
    • Tips/Performance/SpriteThreadSample
    • Graphics/SpriteSample

ソースコード

新規・変更点

  • 次のソースコードを新規追加しました。

    • LuaInterface
    • JsonHelper
    • ModelConverter

Graphics

新規・変更点

  • PS Vita上でのミップマップ生成のパフォーマンスを改善しました。
  • PS Vita上での頂点バッファ生成・削除のパフォーマンスを改善しました。
  • PS Vita上で深度ステンシルバッファのクリアが正しく動作していなかった問題を解決しました。
  • PS Vita上でステンシルテストの一部のパラメータが正しく動作していなかった問題を解決しました。

Audio

新規・変更点

  • オーディオ再生で、再生位置を正確な精度で設定できるように改善しました。
  • オーディオ再生で、スタート位置と終了位置を正確な精度で設定できるよう改善しました。

Environment

新規・変更点

  • 以下のクラスを再度追加しました。

    • PersistentMemory

  • Android でアプリケーションが非表示になった時に、SystemEvents.OnMinimized のイベントが通知されるようになりました。

  • SystemMemory.Dump() において、フォントファイルを読み込んだ状態で呼び出した場合にクラッシュする可能性がある問題を修正しました。

Services

新規・変更点

  • 開発者環境において、PlayStation(R)Vita 上でのアプリ内課金機能使用時のダイアログ表示を1枚に変更し、[Error occurred ?] ダイアログの表示を廃止しました。

  • スコアボードの機能を追加しました。

    • スコアボードを利用するアプリケーションの開発方法については、[API 概要] - [Services.Network 概要]を参照してください。

Device

新規・変更点

  • Location.GetData() において、Bearing の値が PlayStation(R)Vita 上では正しく取得できていなかった問題を修正しました。

Imaging

新規・変更点

  • Image.Export() において、ファイル名に制限を超える文字数を指定できてしまう問題を修正しました。

UI Toolkit

新規・変更点

  • 縦画面表示に対応しました。
    • 詳しくは [UI Toolkit プログラミングガイド] - [基本概念] - [画面の向き] および、ScreenOrientationサンプルを参照してください。

PSM Studio

新規・変更点

  • メニュー - [Key]を新規追加しました。PSM Studioから鍵の作成・管理を行えるようにしました。
  • メニュー - [Key] - [Update Device Seed and App Key]を新規追加。デバイスシードからアプリ鍵の作成をひとつのコマンドで行うことができるようにしました。
  • Application/ ディレクトリ配下に 7段以上のサブディレクトリ(ファイルを含む)を作成した場合、ビルドエラーとするように仕様変更しました。
  • PSM Studioのソリューションツリーから"osc.cfg"を開く際、ファイル名にスペースが含まれていても"osc.cfg"ファイルを開く事ができるようになりました。
  • PSM Studioにアセットを新規追加する時、ファイル名または拡張子からビルドアクションを自動的に変更する様に修正しました。
  • マルチユーザー機能に対応したAndroidデバイスを利用している場合、ユーザー毎にデバイスシードを作成する必要があります。デバイスシードを作成していないユーザーに切り替えた場合は、Publishing Utilityによりデバイスシードを再作成してください。

PSM Publishing Utility

新規・変更点

  • [Key Management]パネルのボタン、レイアウトを変更しました。詳しくはドキュメント [ユーザーガイド] - [鍵管理]をご参照ください。
  • 「Package & App」の Installed Apps でアプリケーションのファイル数が多い場合に、アプリケーションリストの取得でタイムアウトが発生する可能性があった問題を修正しました。
  • PSM SDK 1.11.01 以前にインストールしたアプリケーションは 「Package & App」の Installed Apps の Size に "N/A" と表示されます。 1.20.00 以降にインストールしたアプリケーションは「Package & App」の Installed Apps の Size にはアプリーケーションのサイズが表示されます。
  • PSM Age Rating Systemの質問項目を一部変更しました。 -> オンラインコミュニケーション機能 Q4

PSM Development Assistant (for PlayStation(R)Vita)

新規・変更点

  • PSM SDK 1.20.00 に対応する PSM Development Assistant (for PlayStation(R)Vita) をパッチパッケージとしてリリースしました。PSM Development Assistant (for PlayStation(R)Vita) for PSM SDK 1.20.00 を使用するには、PlayStation(R)Vita本体のシステムソフトウェアを最新のものにアップデートする必要があります。
  • [Debug Settings] - [Switch Development Assistant] を選択した場合、PSM SDK 1.11.01 に対応する PSM Development Assistant と PSM SDK 1.20.00 に対応する PSM Development Assistant を切り替え可能です。PSM Publishing Utility によるデバイスシード・鍵の作成、及びアプリケーションをインストール場合には、現在アクティブな PSM Development Assistant のバージョンと 使用する PSM SDK Installer のバージョンを合わせておく必要があります。
  • [Debug Settings]画面に、インストール済みのアプリケーション全てのセーブデータを一括して削除するメニュー[Delete Documents]を追加しました。

PSM Development Assistant (for Android)

新規・変更点

  • [Debug Settings] 画面にPSN(SM) に接続するアカウントを設定するためのメニュー[SignIn] を追加しました。

インストーラ

制限事項

  • お使いのPCがWindows 8で、かつ.NET Framework 3.5がインストールされていない場合、PSM SDKのインストール時にgtk# 2.12.10のインストールが行われません。その場合、PSM SDKのインストール終了後、次の作業をおこなってください。
    1. マイクロソフトのWebサイトから.NET Framework 3.5をインストールします。
    2. C:/Program Files/SCE/PSM/software/に配置されているgtk-sharp-2.12.10.msiをダブルクリックし、gtk# 2.12.10をインストールします。
  • お使いのPCにgtk# 2.12.20以上がインストールされていると、PSM Studioが正しく動作しません。その場合、以下の作業をおこなってください。
    1. [コントロールパネル] - [プログラムと機能] でgtk# 2.12.20を選択し、アンインストールします。
    2. [コントロールパネル] - [プログラムと機能] でgtk# 2.12.10を選択し、アンインストールします。
    3. Windows 7 - 64bitの場合、C:/Program Files (x86)/SCE/PSM/software/gtk-sharp-2.12.10.win32.msiをインストールします。Windows 7 - 32bitの場合、C:/Program Files/SCE/PSM/software/gtk-sharp-2.12.10.win32.msiをインストールします。

その他

新規・変更点

  • テクスチャ一体化ツール UnifyTexture.exe にオプション指定を追加しました。詳しくは[スプライトの効率的な描画について] - [UnifyTexture.exeのオプション]を参照してください。

ver 1.11.01

全体

重要な不具合を修正する SDK リリースです

Graphics

新規・変更点

  • オフスクリーンレンダリングに使用された Texture2D が、FrameBuffer にアタッチされたまま削除されると、リソースリークが発生する問題を修正しました。

PSM Publishing Utility

新規・変更点

  • ファイルサイズの大きなマスターパッケージ、またはネットワーク環境によっては、Publishing Utility からのマスターパッケージの提出に失敗する可能性があった問題を修正しました。

PSM Development Assistant (for PlayStation(R)Vita)

新規・変更点

  • PSM SDK 1.11.01 に対応する PSM Development Assistant (for PlayStation(R)Vita) をパッチパッケージとしてリリースしました。PSM Development Assistant (for PlayStation(R)Vita) for PSM SDK 1.11.01 を使用するには、PlayStation(R)Vita本体のシステムソフトウェアを最新のものにアップデートする必要があります。
  • サブスレッドを用いてアプリケーションを作成した際の安定性を向上しました。

ver 1.11.00

全体

新規・変更点

  • ver 1.11.00はver 1.10.00のオフィシャル版です。
  • マスターパッケージの提出が可能になりました。

制限事項

  • アセンブリ名を"files"もしくは"system"にすると、PSM Development Assistant やPublishing Utility のアプリケーションリストに該当アプリケーションが表示されなくなくなりますので別の名前をお使いください。

ドキュメント

新規・変更点

  • 次のドキュメントを新規追加・修正しました。

    • 「トラブルシューティング」
    • 「チーム開発での鍵管理」
    • 「アプリ開発の注意点」
    • 「7. ガベージコレクションとインスタンスの解放」に「強制的にガベージコレクションを呼び出す」「アンマネージドリソースを解放する」の項目を追加しました。
    • 「PlayStation(R)Mobile MDX ファイル形式」

Graphics

新規・変更点

  • SDK 1.10 で増加していたグラフィクスメモリ消費量を削減しました。

制限事項

  • PlayStation(R)Vita では現在、以下の制限があります。
    • GraphicsContext.SetClearDepth() は正しく機能しません。クリア深度は 1.0 になります。
    • Texture2D.GenerateMipmap() は SDK 1.00 より低速になっています。

Audio

新規・変更点

  • BgmPlayer.Stop() 直後に BgmPlayer.Play() を呼び出した際に、冒頭にノイズが入る問題を修正しました。

制限事項

  • BgmPlayerでループ開始時刻とループ終了時刻を設定して再生する場合、VBR(Variable Bit Rate:可変ビットレート)形式のmp3ファイルを使用すると、設定した時刻がずれて再生されることがあります。

Services

新規・変更点

  • 以下のクラスを追加しました。
    • AccountInformation

Device

新規・変更点

  • Location.GetData() において、Altitude/Speed の値が PlayStation(R)Vita 上で正しく取得できていなかった問題を修正しました。

制限事項

  • Location.GetData() において、Bearing の値が PlayStation(R)Vita 上では正しく取得できません。

PSM Studio

新規・変更点

  • RootNamespace ( デフォルト ネームスペース ) と AssemblyName ( アセンブリ名 ) が異なる場合にマスターパッケージの作成に失敗する問題を修正しました。

制限事項

  • Windows XPではソリューションツリー内の"osc.cfg"ファイルを[右クリック] - [OSC Customize Toolで開く]によるOSC設定ファイルの編集をする事ができません。 OSC Customize Tool メニューの[File(F)] - [Load(L)]からプロジェクトの"osc.cfg"ファイルを選択後、編集してください。

Publishing Utility

新規・変更点

  • [Metadata]パネル - [Common Property]タブに[Max Camera Resolution Size]のカテゴリを追加しました。

制限事項

  • [Key Management]パネル - [デバイスシードのエクスポート]を実行時、Nicknameを変更すると正しく鍵が作成されない不具合があります。Nicknameは変更せず、そのままの値でエクスポートを行ってください。

PSM Development Assistant (for PlayStation(R)Vita)

新規・変更点

  • PSM SDK 1.11.00 に対応する PSM Development Assistant (for PlayStation(R)Vita) をパッチパッケージとしてリリースしました。PSM Development Assistant (for PlayStation(R)Vita) for PSM SDK 1.11.00 を使用するには、PlayStation(R)Vita本体のシステムソフトウェアを 2.05 以上にアップデートする必要があります。
  • PSM SDK 1.11.00 では、PSM Development Assistant の動作モードを切り替えるメニューは無効化されています。
  • PSMアプリケーションを削除する機能に関して、UIを調整しました。

ver 1.10.00 ベータ版

全体

新規・変更点

  • Sce.PlayStation.HighLevelのソースコードがデフォルトでインストールされる場所を、c:/Program Files (x86)/SCE/PSM/source から c:/Users/Public/Documents/PSM に移動しました。
  • Windows上でのPCシミュレータで、PS3(TM)のワイヤレスコントローラを使用できるようになりました。

制限事項

  • このSDK 1.10.00 はベータ版のため、マスターパッケージを提出することはできません。このバージョンで作成されたアプリケーションをマスター提出する場合、次回リリース予定の正式版でマスターパッケージを再作成し、提出をおこなうことになります。
  • 正式版のリリースまでにマスターパッケージの提出を希望する方は、ひとつ前のバージョンであるSDK 1.00.00をお使いください。

ドキュメント

新規・変更点

  • 次のドキュメントを追加しました。
    • ドキュメント「5. 統合開発環境PSM Studioの基本的な使い方」に「ライブラリを作成・利用する」の項目を追加。
    • ドキュメント「スプライトの効率的な描画について」を追加。

Core

新規・変更点
  • 以下の API に Vector2 を引数にとるオーバーロードを追加しました。
    • Matrix4.Transformation()
    • Matrix4.Translation()
    • Matrix4.Scale()
  • 以下の構造体を追加しました。
    • Rectangle
    • Half Half2 Half3 Half4
    • Byte2 Byte3 Byte4 UByte2 UByte3 UByte4
    • Short2 Short3 Short4 UShort2 UShort3 UShort4
    • ByteN Byte2N Byte3N Byte4N UByteN UByte2N UByte3N UByte4N
    • ShortN Short2N Short3N Short4N UShortN UShort2N UShort3N UShort4N

Graphics

新規・変更点

  • PlayStation(R)Vita での、互換性と CPU パフォーマンスを改善しました。

  • PC シミュレータのウィンドウサイズを、PSM Studio で指定できるようになりました。従来のように、GraphicsContext() のパラメータで指定することはできませんのでご注意ください。

  • スクリーンを任意のサイズで初期化できるようになりました。指定されたサイズがデバイスのディスプレイ解像度と異なる場合、指定されたサイズの仮想的なスクリーンが作成され、描画された内容がスケーリングされて表示されます。スクリーンのアスペクト比は保持され、必要に応じてピラーボックスまたはレターボックスが表示されます。

  • スクリーンサイズは最大サイズ以下に制限されます。最大サイズのデフォルト値は 1280x800 です。最大サイズは PublishingUtility で指定できます。アプリケーションはスクリーンサイズが最大サイズに等しい場合でも正しく動作することが要求されます。

  • 以下の API を追加しました。
    • GraphicsContext.GetEnableMode()
    • GraphicsContext.SetEnableMode()
    • ShaderProgram.GetAttributeStream()
    • ShaderProgram.SetAttributeStream()

制限事項

  • PlayStation(R)Vita では現在、以下の制限があります。
    • GraphicsContext.SetClearDepth() は正しく機能しません。クリア深度は 1.0 になります。
    • GraphicsContext.SetCullFace() はオフスクリーン描画で正しく機能しません。
    • GraphicsContext.ReadPixels() は正しく機能しません。
    • Texture2D.GenerateMipmap() が 1024x1024 より大きいテクスチャを処理できません。
    • Texture2D.GenerateMipmap() は SDK 1.00 より低速になっています。
    • Texture2D が、横幅 4 ピクセル以下の場合に正しく表示されません。

Audio

新規・変更点

  • Sound クラスで ADPCM も使用可能になりました。

  • BGM と SE の再生時刻が設定および取得できるようになりました。

  • BGM と SE の再生時間が取得できるようになりました。

  • BGM の一部分がループ再生できるようなりました。

  • 以下の API を追加しました。
    • SoundPlayer.Time
    • SoundPlayer.Duration
    • BgmPlayer.Time
    • BgmPlayer.Duration
    • BgmPlayer.LoopStart
    • BgmPlayer.LoopEnd
  • 以下の API を削除しました。
    • BgmPlayer.Position

制限事項

  • SoundPlayer.Time, SoundPlayer.Duration は、SoundPlayer の停止中には使用できません。
  • SoundPlayer.Time は、SoundPlayer.Play() が呼び出されるまで更新されません。。
  • SoundPlayer.Duration は、SoundPlayer が停止している間はゼロにリセットされます。
  • これらの挙動は、今後のバージョンで変更される可能性があります。

Environment

新規・変更点

  • SystemEvents.OnRestored イベントがPlayStation(R)Vita上で正しく取得できなかった問題を修正しました。
  • システムのメモリの状態を取得する SystemMemory クラスを追加しました。

Services

新規・変更点

  • 開発者環境において、ネットワークエラー発生時のアプリ内課金の挙動を、PlayStation(R)Vita および Android でもテストできるようになりました。PlayStation(R)Vita の場合 [Error occurred ?] ダイアログ表示時に [Yes] ボタンを押下するとエラー発生時の挙動となります。
  • 開発者環境において、プロダクト価格文字列にプロダクトラベル文字列を格納するように、アプリ内課金の動作を変更しました。これは価格表示の間違いを避けるための予防措置です。

Device

新規・変更点

  • Sce.PlayStation.Core ネームスペースに Device ネームスペースを追加して以下の機能を追加しました。
    • カメラ
    • 写真インポートダイアログ
    • ロケーション

  • 各機能については PlayStation(R)Mobile SDK ドキュメントに記載されている API の概要の中の Device の概要をお読みください。

制限事項

  • PlayStation(R)Vita では現在、以下の制限があります。
    • サンプルの CameraPreviewSample を実行したときに、プレビュー解像度を何回も変更すると、まれにエラーが発生することがあります。

UI Toolkit

新規・変更点

  • ListPanel と PopupList にフォント関連のAPI追加しました。
  • ListPanelItem の HookChildTouchEvent プロパティの初期値を true に変更しました。
  • フォーカスのデザインとフォーカス移動のアルゴリズムを修正しました。
  • レイアウトアンカー機能の計算アルゴリズムを修正しました。

UI Composer

新規・変更点

  • レイアウトの切替をできないようしました。
    • UI ToolKit で縦レイアウトについて正式対応され次第切り替えられるようにします。
  • プレビュー機能について変更を行いました。
    • キーフォーカスが利用できるようになりました。
    • 背景色をUIComposerの設定と同じ色になるようにしました。

Model

新規・変更点

  • 頂点データに BLENDINDICES を格納できるようにしました。スキニングされたモデル表示の CPU パフォーマンスが向上する可能性があります。

  • 古いランタイムで表示するために、BLENDINDICES を格納したくない場合は、ModelConverter のコマンドライン引数に -B オプションを指定してください。

  • BasicProgram で使用する、既定のシェーダーの変数を一部変更しました。 独自のシェーダーを作成して使用している場合は、ご注意ください。

  • 以下の API を追加しました。
    • BasicProgram.ShallowClone()
    • BasicParameters.SetVertexWeightCount()

  • 一部のグラフィクスカードに関する不具合を修正しました。

Physics2D

新規・変更点

  • Simulate関数の引数を変更しました。
    • シミュレーションを別スレッドで実行する場合を考慮しての変更。

  • Raycastの機能、サンプルを追加しました。

  • Springの機能、サンプルを追加しました。

  • アニメーション、テクスチャがどのように物理オブジェクトにマッピングできるかのサンプルを追加しました。

  • 剛体削除、ジョイント削除機能を追加しました。

  • シミュレーションの内部アルゴリズムの計算順序に変更があります。
    • Scene::UpdateFuncBeforeSim、Scene:UpdateFuncAfterSim、剛体のスリープ状態の扱いによっては再調整が必要になる場合があります。

  • GameEngine2Dと組み合わせる方法のサンプルを追加しました。

  • シミュレーションをメインとは別のスレッドで処理するサンプルを追加しました。

Network

新規・変更点

  • HTTPS通信時に Unhandled Exception: System.Net.WebException: Error: ConnectFailure が発生する不具合を修正しました。

HttpWebRequestクラス

  • HTTP非同期通信時に指定するコールバックメソッドがコールされない不具合を修正しました。

制限事項

  • SocketSampleでは現在、以下の制限があります。
    • 右の[Connect]ボタンを押した時、Statusが[Connecting]のままとなり、Statusが[Connected]へ移行しない場合があります。 この場合、[Disconnect]ボタンを押してStatusを[None]に変更し、正常な状態に戻してから操作を行ってください。

PSM Studio

新規・変更点

  • プロジェクト(*.csproj)と同ディレクトリに app.xml が含まれていない場合、ビルドエラーとするように仕様変更しました。
  • PlayStation(R)Vita で実行する場合において、PSM Studio からのデバッグ起動時に PSM Development Assistant (for PlayStation(R)Vita) を PS ボタンから終了すると、PSMStudio が終了を認識しない問題を修正しました。

制限事項

  • マスターパッケージの作成時、プロジェクトファイルcsprojのRootNameSpaceとAssemblyNameが異なると、マスターパッケージの作成に失敗します。その場合、テキストエディタなどでプロジェクトファイルcsproj内のRootNameSpaceとAssemblyNameが同じになるよう修正してください。

PSM Publishing Utility

新規・変更点

  • [Metadata]パネル - [Common Property]タブに[Max Screen Size]のカテゴリを追加しました。
  • Android デバイスに対してアプリ一覧を取得した場合に、デバイスで実行中のアプリを終了させてしまう問題を修正しました。

PSM Development Assistant (for Android)

新規・変更点

  • Debug Settings画面を追加しました。
  • InAppPurchaseDialogにあった[Reset]ボタンをなくし、代わりにDebug Settings画面に[Reset Ticket Information]ボタンを設けました。
  • メニューに[Debug Settings] を追加しました。
  • PSMアプリケーションのリストにコンテキストメニューを追加し、インストールしたPSMアプリケーションを削除する機能を追加しました。

PSM Development Assistant (for PlayStation(R)Vita)

新規・変更点

  • PSM SDK 1.10.00 に対応する PSM Development Assistant (for PlayStation(R)Vita) をパッチパッケージとしてリリースしました。PSM Development Assistant (for PlayStation(R)Vita) for PSM SDK 1.10.00 を使用するには、PlayStation(R)Vita本体のシステムソフトウェアを 2.05 以上にアップデートする必要があります。
  • PSM Development Assistant の動作モードを切り替えるメニューを追加しました。 [Debug Settings] - [Switch Development Assistant] を選択した場合、PSM SDK 1.00.00 に対応する PSM Development Assistant と PSM SDK 1.10.00 に対応する PSM Development Assistant を切り替え可能です。 PSM Publishing Utility によるデバイスシード・鍵の作成、及びアプリケーションをインストール場合には、現在アクティブな PSM Development Assistant のバージョンと 使用する PSM SDK Installer のバージョンを合わせておく必要があります。
  • インストールしたPSMアプリケーションを削除する機能を追加しました。
  • インストール直後に、PSMアプリケーション一覧リストを更新するようにしました。
  • [Debug Settings] - [Reset Ticket Information] を選択した場合に、確認ダイアログを出すようにしました。
  • PSM Studio から PlayStation(R)Vita にアプリケーションをデプロイして実行する場合、[停止]を選択した際に LiveArea(TM) ではなくリストメニューに遷移するように動作を変更しました。


リリースノート (0.96 - 1.00.02)

Contents

  • ver 1.00.02
  • ver 1.00.01
  • ver 1.00.00
  • ver 0.99.20
  • ver 0.99.11
  • ver 0.99.10
  • ver 0.99
  • ver 0.98
  • ver 0.97
  • ver 0.96

ver 1.00.02

全体

軽微な不具合を修正する SDK リリースです

ver 1.00.01

全体

重要な不具合を修正する SDK リリースです

新規・変更点

  • Windows Simulator 上で、app.xml が正しく読み込めていなかった問題を修正しました。

ver 1.00.00

全体

  • 本バージョンより、コンテンツ保護機構が個別の鍵を使用するになりました。この変更により、鍵を事前に準備しないとデバイス向けのアプリのビルド、実行が行えなくなりました。鍵の作成についての詳細はドキュメントをご覧ください。

PSM Studio

新規・変更点

  • 0.99.20 での制限事項であった PlayStation(R)Vitaでデバッグ実行を行った場合、[実行] - [停止] ボタンを選択すると、PlayStation(R)Vita 本体がクラッシュ、あるいは正常に終了した場合でも次回起動時に PSM Studio がターゲットとして認識しない場合がある問題を修正しました。

制限事項

  • PlayStation(R)Vitaターゲットに対し、PSM Studio からデバッグ有実行を行い、その後アプリを PSボタンより終了させると、PSM Studio が終了を検知できず状態の不整合が起こります。アプリの停止は PSM Studio 側から行う様にしてください。もし問題が起こった場合はPSM Studio 側も手動でデバッグを終了させてください。

PSM Publishing Utility

新規・変更点

  • 0.99 にて提供した app.xml の編集機能のほか、以下の機能を新たに提供します。

    • コンテンツ保護用の鍵管理機能
    • パッケージ・アプリ管理機能
    • マスターパッケージ提出機能

  • app.xml Copyright の内容に対し、SCEのdefault_copyright.txt が自動で付加されるようになりました（マスターパッケージ作成時）。0.99 の時のように手作業でコピー&ペーストする必要ありません。

制限事項

  • Android デバイスに対してアプリ一覧を取得すると、デバイスで実行中のアプリを終了させてしまう問題があります。
  • PlayStation(R)VitaをUSBに接続するタイミングに依存して、 Publishing Utitlity が インストール済のアプリを正常に取得できなくなる問題が発生する場合があります。 この問題から回復するには、 PlayStation(R)Vita を再起動してください。
PSM Development Assistant (for PlayStation(R)Vita)

新規・変更点

  • PSM SDK 1.00.00 に対応する PSM Development Assistant (for PlayStation(R)Vita) をパッチパッケージとしてリリースしました。 PSM Development Assistant (for PlayStation(R)Vita) for PSM SDK 1.00.00 を使用するには、PlayStation(R)Vita本体のシステムソフトウェアを 1.80 以上にアップデートする必要があります。

ver 0.99.20

全体

重要な不具合を修正する SDK リリースです

新規・変更点

  • Android と Windows で、アプリケーション終了時にサブスレッドが停止しない問題を修正しました。

PSM Studio

制限事項

[Important Note]

  • PlayStation(R)Vita ターゲットでデバッグ実行を行った場合、[実行] > [停止] ボタンを選択すると、PlayStation(R)Vita 本体がクラッシュ、あるいは正常に終了した場合でも次回起動時に PSM Studio がターゲットとして認識しない場合があります。 この問題の回避方法として、PSM Studio からの終了処理は PlayStation(R)Vita の PSボタンから LiveArea(TM) をはがすことにより行なってください。

    なお、デバッグなし実行の場合は、この問題は再現しません。

PSM Development Assistant (for PlayStation(R)Vita)

新規・変更点

  • PSM SDK 0.99.20 に対応する PSM Development Assistant (for PlayStation(R)Vita) をパッチパッケージとしてリリースしました。
  • 特定の条件下で Mono 内でクラッシュする問題を修正しました。

Services

新規・変更点

  • Android の開発環境で InAppPurchaseDialog の購入記録が保存されない問題を修正しました。 (ただし購入記録をリセットするボタンが動作しない問題は修正されていません。 購入記録をリセットするには、アプリケーションを再インストールしてください。)

Environment

新規・変更点

  • デバイスによって GamePadButtonMeaning の値が正しく返らない問題を修正しました。

ver 0.99.11

全体

新規・変更点

  • アプリケーション動作時の安定性の問題を修正しました。

ver 0.99.10

全体

重要な不具合を修正する SDK リリースです

Services

新規・変更点

  • InAppPurchaseDialog の複数のインスタンスを同時に作成できないようにしました。

UI Composer

新規・変更点

  • 「管理者として実行」からでしか起動できないという制限事項がなくなりました。

PSM Publishing Utility

新規・変更点

  • レーティングチェックを未実施の時には Master Package を作成できないようにしました。
  • In-App Purchase の Product を一つも登録していない時に、Master Package の生成に失敗する不具合を修正しました。
  • app.xml の再読み込み時に Managed Heap が 32MiB以下にクリップされてしまう不具合を修正しました。
  • Managed Heap の最小値を 5MiB に変更しました。
  • Parental Lock Level の仕様についての不具合を修正しました。

ver 0.99

全体

Ver 0.98で作成したプロジェクトをVer 0.99へ移行する上での注意

  • アプリケーション設定ファイル "app.xml" を導入しました。 それに伴い、"app.cfg" を廃止します。

    • 上記の変更に伴い、 .cs, .csproj app.cfg を変換するバッチファイル project_conv_098to099.bat を提供します。プロジェクトを変換するために、以下のどちらかを行ってください。

    コンソール画面で実行する方法

    1. [スタートメニュー] - [すべてのプログラム] - [アクセサリ] -[コマンドプロンプト] を開きます
    2. cd "%SCE_PSM_SDK%/tools/" と入力し、カレントディレクトリを移動します。
    3. project_conv_098to099.batに変換したいプロジェクトのトップフォルダー [sample098_project_folder] を指定して、実行します。

    > project_conv_098to099.bat [sample098_project_folder]

    エクスプローラーで実行する方法

    1. エクスプローラー上で、[sample098_project_folder] を project_conv_098to099.bat に ドラッグ&ドロップ します。

新規・変更点

  • SDKの名称を、"PlayStation(R)Suite SDK" から、"PlayStation(R)Mobile SDK" に変更しました。

  • API の 名前空間を、"Sce.Pss" から "Sce.PlayStation" に変更しました。

  • アプリケーションのパッケージに含まれるファイルの署名検証/暗号化をサポートしました。

  • Application/, Documents/, Temp/ ディレクトリ配下に作成可能なサブディレクトリ段数(ファイルを含む)を 5段 から 6段 までに変更しました。

    • "/Application/1/2/3/4/5/6.dat" -> OK (Documents/, Temp/ も同様)
    • "/Application/1/2/3/4/5/6/7.dat" -> NG (Documents/, Temp/ も同様)

Audio

新規・変更点

  • BgmPlayer クラスに Position プロパティを追加しました。

Environment

新規・変更点

  • 以下のクラスを廃止しました。

    • PersistentMemory

制限事項

  • SystemEvents.OnRestored イベントは現在PlayStation(R)Vita上では正しく動作しません。

Graphics

新規・変更点

  • デフォルトのスクリーンサイズを PlayStation(R)Vita と同じ 960x544 に変更しました。
  • TextureWrapMode の値を変更しました。

制限事項

  • PlayStation(R)Vita では現在、以下の制限があります。
    • GraphicsContext.SetVertexBuffer() は最初の VertexBuffer だけを適用します。
    • GraphicsContext.SetPolygonOffset() は未対応です。指定されたパラメータは無視されます。
    • Texture2D.GenerateMipmap() は正しく動作しない場合があります。
    • TextureCube は未対応です。作成時に例外が発生します。

Input

新規・変更点

  • GamePad で、アナログスティックの中央付近に、不感帯 (Dead-Band) を設けました。

Imaging

新規・変更点

  • Image クラスに ReadBuffer メソッドを追加しました。

Model

新規・変更点

  • MDX ファイルフォーマットを修正し、バージョンを 1.00 に変更しました。

  • 古いフォーマットの MDX ファイルは、そのままでは使用できません。もし使用する場合は、Model API のビルドずみアセンブリのかわりにソースコードプロジェクトを使用し、プロジェクトに含まれる MdxLoader.cs を MdxLoader095.cs に交換してください。

  • 以下の機能を実装しました。
    • ブロック名、バウンディングスフィアの読み込み
    • モーショントランジション、モーション反復モード
    • UV オフセット／スケール、UV アニメーション
    • テクスチャなしマテリアル
  • コンバータが使用するツールキットを更新しました。
    • Crosswalk 2013.0
    • FBXSDK 2011.3

Services

新規・変更点

  • Sce.PlayStation.Core.Services 名前空間を新設しました。
  • In-App Purchase のための API InAppPurchaseDialog を新設しました。

UI Composer

新規・変更点

  • ユーザー任意のウィジェットを配置することができるカスタムウィジェット機能を追加しました

  • 0.98までにあったカスタムパネル機能を廃止しました
    • カスタムパネルが配置されたUICファイルについてはカスタムパネルをカスタムウィジェットに置き換えるように内部で変換されます
    • WidgetListへのカスタムパネルの追加については無効となります

  • 起動しているUIComposerに対してプロジェクトファイル（*.uic）をドラッグ＆ドロップすることでファイルを開けるようになりました。

  • WidgetのAnchorの初期値がAnchor.Noneになりました。
    • ただし、CheckBox、DateTimerPicker、Slider、ProgressBar、PopupList のようにサイズの変換に制限があるものは、その限りではありません。

制限事項

  • 「管理者として実行」からでしか起動できません

UI Toolkit

新規・変更点

  • ゲームパッドでフォーカス操作する機能を追加しました。
    • 詳しくは [UI Toolkit プログラミングガイド] - [基本概念] - [ゲームパッドによる操作] を参照してください。
  • キーイベントの配信機構を変更しました。
    • 詳しくは [UI Toolkit プログラミングガイド] - [基本概念] - [キーイベントの配信] を参照してください。
  • ピクセル密度を指定する機能を追加しました。
    • 詳しくは [UI Toolkit プログラミングガイド] - [基本概念] - [ピクセル密度] を参照してください。

  • 各ウィジェットの Font型のプロパティを UIFont 型に変更しました。

  • Dialog の Hiding、Hiddenイベントの型を EventHandler から EventHandler<DialogEventArgs> に変更しました。

  • スクロール方向の異なるウィジェットを親子で配置した際に正しくスクロールできない不具合を修正しました。

  • ListPanel.Move メソッドでアイテムのインスタンスが作られすぎる不具合を修正しました。

  • ダイアログを閉じた直後に別のダイアログを表示した際に、表示できない不具合を修正しました。

  • ver 0.98 で Obsolete であったAPIを削除しました。

PSM Studio

新規・変更点

  • ベースを MonoDevelop 2.8.8.4 に変更しました。
  • PlayStation(R)Vita でデバッグ実行を行った場合、アプリケーション出力ウィンドウに文字列が表示されない不具合を修正しました。
  • PSM Publishing Utility と連携して app.xml の編集を行います。
  • 署名検証/暗号化の機能追加。File の Property より、Content Protection (Plain, Signed, SignedAndEncrypted) が選べるようになりました。

制限事項

  • まれに app.exe.mdb がプロセスに占有され、ビルドが失敗する不具合があります。発生した場合、PSM Studio を再起動して下さい。
  • プロジェクトのオープンに失敗する事があります。一旦閉じて開き直して下さい。

PSM Publishing Utility

新規・変更点

  • 新規リリース
  • メタデータの作成、マスターパッケージの作成を行います。

PSM Development Assistant (for PlayStation(R)Vita)

新規・変更点

  • SDKの名称変更に追従して、"PlayStation Mobile Development Assistant" に名称を変更しました。

  • PSM Development Assistant (for PlayStation(R)Vita) 0.99 をパッチパッケージとしてリリースしました。 PSM Development Assistant (for PlayStation(R)Vita) 0.98 の LiveArea(TM) 上に表示されるアップデートアイコンを選択し適用することで、0.99 にバージョンを上げることが可能です。 なお、PSM Development Assistant (for PlayStation(R)Vita) 0.99 を使用するには、PlayStation(R)Vita本体のシステムソフトウェアを 1.69 以上にアップデートする必要があります。

  • SDK 0.98 でリリースされた PSM Studio (旧名称 : PSS Studio) と PSM Development Assistant (for PlayStation(R)Vita) 0.99 の組み合わせでは正しく実行することができませんのでご注意ください。必ず、SDKバージョンと等しい PSM Development Assistant (for PlayStation(R)Vita) を使用してください。

    • 正常に動作する組み合わせ:
      • SDK 0.98 の PSM Studio & PSM Development Assistant (for PlayStation(R)Vita) 0.98
      • SDK 0.99 の PSM Studio & PSM Development Assistant (for PlayStation(R)Vita) 0.99
    • 正常に動作しない組み合わせ(インストール時にエラーとなります):
      • SDK 0.98 の PSM Studio & PSM Development Assistant (for PlayStation(R)Vita) 0.99
      • SDK 0.99 の PSM Studio & PSM Development Assistant (for PlayStation(R)Vita) 0.98

  • 画像アセットを変更しました。

  • PSM Studio からのインストール時に "Installing..." というビジーダイアログを表示するようにしました。 また、インストール中は PSボタンをロックするようにしました。

  • オプションメニュー内に デバッグ設定の項目, 及び Developer Forum ウェブサイトへのリンクを配置しました。 [Debug Settings]-[Reset Ticket Information] を選択することで、PlayStation(R)Vita 上での InAppPurchaseDialog のチケット情報をリセットします。

  • Intellectual Property Notices ページの文言内容、スクロール動作を調整しました。

ドキュメント

新規・変更点

  • 次のドキュメントを追加しました。
    • GameEngine2Dの使い方 (日本語訳)
    • ２次元物理シミュレーションPhysics2Dライブラリの基本的な使い方
    • アプリ内課金
    • ビルドアクションについて
    • PSMアプリのフォルダー構成について
    • アプリケーションの安全な実装方法
    • 署名と暗号化の設定
    • アンインストールについて
    • マスターの作成と提出 概要
    • Publishing Utilityの使い方

ver 0.98

全体

新規・変更点

  • PSM アプリケーションの PlayStation(R)Vita 上での開発・実行ができるようになりました。 詳しくはドキュメントの「PlayStation(R)Vita で実行するための手順」を参照してください。

  • 下記のクラスのコピーコンストラクタを廃止し、代わりにShallowClone()メソッドを追加しました。

    • Texture2D
    • TextureCube
    • VertexBuffer
    • Image
    • Font

  • ディレクトリ構造の変更を行いました。 アプリケーションのパッケージ中のファイルは、Application/ ディレクトリの中に配置する必要があります。 ( "texture/foo.jpg" -> "/Application/texture/foo.jpg" )

    また、Application/, Documents/, Temp/ ディレクトリ配下に作成可能なサブディレクトリ段数(ファイルを含む)は5段までです。

    • "/Application/1/2/3/4/5.dat" -> OK (Documents/, Temp/ も同様)
    • "/Application/1/2/3/4/5/6.dat" -> NG (Documents/, Temp/ も同様)

  • Sampleをデフォルトで以下の場所にインストールするようにしました。

    • Windows XPの場合 "C:/Documents and Settings/All Users/Documents/psm/"
    • Windows 7の場合 "C:/Users/Public/Documents/psm/"

  • デバイス上で PSM アプリケーションを実行するためのプログラムの名称が変更となり、PlayStation(R)Mobile Development Assistant に変わりました。

  • デバイス上で PSM アプリケーションを起動する方法が変更となりました。

    • サインインが不要となりました。
    • ネットワーク接続は必要です。

制限事項

  • Windows XPの場合、PS Vitaとの初回接続時にUSBドライバを手動でインストールする必要があります。詳しくはドキュメントの「PlayStation(R)Vita で実行するための設定」を参照してください。

Core

新規・変更点

  • 以下の API を追加しました。
    • Matrix4.InverseAffine()
    • Matrix4.MultiplyAffine()
    • Matrix4.TransformProjection()
    • Quaternion.Lerp()
    • Quaternion.Log()
    • Quaternion.Exp()
    • Quaternion.Transform()

Environment

新規・変更点

  • 以下のクラスを廃止しました。

    • Storage

Graphics

新規・変更点

  • 以下の API を追加しました。
    • ShaderProgram の、ShaderProgramOption を引数にとるコンストラクタ
  • 以下の API は廃止予定になりました。
    • VertexBuffer に Primitive[] を格納する関数
    • TextureWrapMode の MirroredRepeat モード

制限事項

  • PlayStation(R)Vita では現在、以下の制限があります。
    • GraphicsContext.SetVertexBuffer() は最初の VertexBuffer だけを適用します。
    • GraphicsContext.SetPolygonOffset() は未対応です。指定されたパラメータは無視されます。
    • ShaderProgramOption は未対応です。指定されたパラメータは無視されます。
    • Texture2D.GenerateMipmap() は正しく動作しない場合があります。
    • TextureCube は未対応です。作成時に例外が発生します。

Imaging

新規・変更点

  • Image クラスに、ビットマップイメージを受け取るバージョンのコンストラクタを追加しました。
  • Image クラスの、コンストラクタ Image(ImageSize size, ImageColor color, ImageMode mode) の引数の順序を変更し、Image(ImageMode mode, ImageSize size, ImageColor color) に変更しました。

UI Toolkit

新規・変更点

  • Widget と UIElement クラスの Dispose() を仮想関数から非仮想関数に変更し、新たに Dispose(bool) と DisposeSelf() を仮想関数として追加しました。
  • Widget クラスに RenderToFrameBuffer メソッドを追加しました。
  • ImageAsset クラスに UnloadFromCache のインスタンスメソッドを追加しました。
  • Labelの文字列に改行コードが含まれていると正しく表示されない不具合を修正しました。
  • DragEventArgs の WorldPosition と LocalPosition の値が逆になっている不具合を修正しました。
  • SlideTransition の MoveTarget の値が逆になっている不具合を修正しました。

PSM UI Composer

新規・変更点

  • プレビュー機能を追加しました。
    • 詳しくはドキュメントの「レイアウトガイド」を参照してください。

  • そのほか、細かな調整や不具合を修正しました。

PSM Studio

制限事項

  • PlayStation(R)Vita ターゲットでデバッグ実行を行った場合、アプリケーション出力パッドに文字列が出力されません。デバッグ無し実行を行った場合には、文字列の出力は正しく機能します。
  • Windows 7 上での不具合で、メニュー項目が選択されたときに、淡い背景色に白い文字となり、項目が判読し辛くなります。
  • None や Resource のビルドアクションでは、ファイルがデバイスにコピーされなくなりました。Contents を使用して下さい。

Model

制限事項

  • モデルファイル形式は開発中のものです。今後のバージョンで変更される可能性があります。
  • HighLevel.Model は開発中のものです。まだすべての機能は実装されていません。

ver 0.97

新規・変更点

Vector/Matrix

  • 参照引数をとる API に引数の制限を追加しました。this/ref 引数のいずれかと同じ変数を、out 引数に指定することを禁止します。

Graphics

  • グラフィクスの概要に、シェーダー記述の制限事項を追記しました。

Input

  • GamePadButtons に Enter と Back を追加しました。○×ボタンを GamePadButtonMeaning に従って抽象化した値が取得されます。また、これによって Android の Back ボタンの状態を取得できるようになりました。

Imaging

  • Font クラスに、別の Font オブジェクトを受け取るバージョンのコンストラクタを追加しました。

GameEngine2D

  • GameEngine2D を新規に追加しました。2Dのゲームエンジンです。

UI Toolkit

  • アニメーションフォーマット (*.uim, *.uia) を再生する機能を追加しました。 - motion XMLもしくはXFL(XML形式のFlashプロジェクトファイル) からコンバートしたアニメーションを再生することができます。 - 詳しくはドキュメントの「Adobe Flashとの連動」を参照してください。
  • Widget、UIElement に座標変換系のAPIを追加しました。 - Widget、UIElement に LocalToWorld プロパティを追加しました。 - Widget に ConvertScreenToLocal、ConvertLocalToScreen、ConvertLocalToOtherWidget メソッドを追加しました。
  • SpinBoxを廃止し、代わりにDatePickerとTimePickerを追加しました。
  • Effect に一時停止、リピート機能を追加しました。 - Pause、Resume、OnPause、OnResume、OnRepeat メソッドを追加しました。 - Effect にPaused、Repeating プロパティを追加しました。
  • Effect.IsPlay プロパティを Playing にリネームしました。
  • Button.BackgroundColor プロパティを BackgroundFilterColor にリネームしました。 - Dialog.BackgroundFilterColor プロパティを追加しました。
  • PopupList に ListItems の変更を通知する ListItemsChanged イベント追加しました。 - ListItems プロパティの型を PopupListItemCollection に変更しました。
  • ヒット判定のAPIを追加変更しました。 - UISystem.FindHitWidget メソッドを追加しました。 - Widget.HitTest メソッドを protected から public に変更しました。

PSM UI Composer

  • オブジェクトツリーで、ウィジェットのロック/アンロックをできるようにしました。
  • オブジェクトツリーで、ウィジェットをレイアウトキャンバスに表示するかどうかを切り替えられるようにしました。
  • UI Composer の表示言語(英語/日本語)を、環境設定で変更できるようにしました。
  • そのほか、細かな調整や修正を行いました。

Physics2D

  • クラス名を整理しました。BodyPss から Body のように、クラス名の末尾のPssを削除しました。

Model

  • モデルファイル形式は開発中のものです。今後のバージョンで変更される可能性があります。
  • HighLevel.Model は開発中のものです。まだすべての機能は実装されていません。
  • モデルコンバータが *.x ファイルを読み込めるようになりました。

Mono

  • CoreCLR セキュリティモデルを有効にしました。
  • マネージドヒープが枯渇したときにクラッシュしてしまうケースが合ったのを修正しました。
  • BCLのAPI界面を削減しました。
  • 終了処理まわりのさまざまな問題を修正しました。
  • Win32上での mono_100ns_ticks の計算のオーバーフローの問題を修正しました。

PSM Studio

  • PSM Studio の Welcome 画面に、Developer Community サイトへのリンクを配置しました。
  • 無効にするBreak Point が存在しない場合でも、メニューの "Disable All Break points" という項目が選択可能になっていた問題を修正しました。
  • マルチディスプレイ環境での、PSM Studio のウインドウのレイアウトや挙動を調整しました。
  • すでにPSMプログラムをデバイス上で実行しているときに、PSM Studio から別のプログラムを起動しても、正しく起動しなかった問題を修正しました。
  • メニューの [Window] > [Split Vertically] / [Split Horizontally] でエラーが発生する問題を修正しました。
  • そのほか、細かな調整や修正を行いました。

OSC Customize Tool

  • 新規リリースです。

その他

  • psschecker.apk を廃止し psslauncher.apk へ統合しました。
  • chm形式のドキュメントを用意しました。

ver 0.96

最初の公開バージョン。

制限事項

Imaging
  • Image.Export() を用いてAndroid上に画像ファイルを保存しても、Galleryアプリケーションはその画像を自動的に検出しません。SDカードをマウントしなおすなどして、メディアスキャンを行う必要があります。
Model
  • モデルファイル形式は開発中のものです。今後のバージョンで変更される可能性があります。
  • HighLevel.Model は開発中のものです。まだすべての機能は実装されていません。
UI Composer
  • Widget の "Position Selector" の設定に関わらず、Position プロパティを変更すると左上の座標が変化します。
  • 一部のプロパティの設定 UI が正しく表示されないため、ツールで設定できないものがあります。
  • Scene などのレイアウトの削除が正しく Undo/Redo できません。


SDKのロードマップ

この文書では、将来のSDKで追加される機能およびサービスを記載しています。

Contents

  • 将来追加予定の機能

将来追加予定の機能

将来のSDKのバージョンアップによって、以下のような機能およびサービスを追加することを計画しています。

  • Visual Studio を使った開発環境。
  • Maya 以外の 3D ツール からのモデルデータ出力のサポート。
  • 低レベルなオーディオAPI。
  • 動画再生


ライセンス情報

この文書では、PSM SDKで利用されている権利物のライセンス情報について記載しています。

Contents

  • SDKの中で使用しているソフトウェア

SDKの中で使用しているソフトウェア

このSDKでは、以下のソフトウェアを使用しています。 それぞれのソフトウェアの詳細な著作権情報については、doc/license ディレクトリの中のそれぞれのファイルを参照してください。

  • libYAML
  • Freetype
  • libjpeg
  • giflib
  • Mono
  • Gtk#
  • MP3 Decoder
  • OpenAL
  • pthread win32
  • .NET Standard Libs
  • PSM Studio(MonoDevelop)
  • Python
  • NVIDIA cgc
  • AvalonDock
  • A WPF custom control for zooming and panning
  • Art
  • Microsoft Expression Blend Software Development Kit (SDK) for .NET 4
  • Sample Font Chooser
  • OpenCOLLADA SDK
  • libXML
  • MathMLSolver
  • pcre
  • OFL Fonts
  • PlanetCute art
  • HamCorossam graphic data
  • Isometric 64x64 Outside Tileset
  • DirectX
  • Autodesk Crosswalk
  • Autodesk FBX SDK
  • OpenSSL
  • LuaInterface
  • KopiLua
  • TweetSharp
  • Hammock
  • Newtonsoft.JSON


標準ライブラリの概要

この文書では標準ライブラリについて説明します。

Contents

  • 標準ライブラリ

標準ライブラリ

PSM SDKには以下の標準ライブラリが付属しています。

  • mscorlib.dll
  • System.dll
  • System.Core.dll
  • System.Dynamic.dll
  • System.Json.dll
  • System.Runtime.Serialization.dll
  • System.ServiceModel.dll
  • System.ServiceModel.Web.dll
  • System.Web.Services.dll
  • System.Xml.dll
  • System.Xml.Linq.dll

他社製または独自に作成したdllを利用する場合、dllをプロジェクトのディレクトリに配置し、PSM Studioでアセンブリ参照を設定してください。


Coreの概要

Sce.PlayStation.Core は数学関数などゲームプログラムの基本となる機能を提供します。

Contents

  • 数学関数
  • ベクトル型
  • パックされた型
  • 単位と座標系
  • 使用例
  • 使用例２
  • 引数の制限について
  • 関連項目

数学関数

FMathは数学関数のラッパー関数とコンビニエンス関数を提供するスタティッククラスです。float用の数学関数や、いくつかの便利な関数が定義されています。

ベクトル型

Matrix4 Vector4 Vector3 Vector2 Quaternion Rectangleはfloat要素を持つベクトル型を表す構造体です。４次元行列、４次元以下のベクトル、クオータニオン、および矩形が定義されています。

パックされた型

Rgb* Half* Short* UShort* Byte* UByte*はグラフィクスで使用されるデータ型を表す構造体です。整数表現のカラー型、半精度の浮動小数点型、および固定小数点型が定義されています。

単位と座標系

角度はラジアン単位で表されます。行列は右手座標系で表されます。また行列の乗算順序はparent*child, matrix*vectorのようになります。Cgシェーダー言語とは行列の乗算順序が逆になることに注意してください。たとえばCgシェーダー言語のセマンティクスにおけるWorldViewProjectionは、Sce.PlayStation.Coreではprojection*view*worldのように計算されます。

使用例

以下のコードは、行列の生成と計算と要素アクセスの例です。

Matrix4 m4 = m1.Inverse() ;               // member function
Matrix4 m5 = m1.Multiply( m2 ) ;          // member function
Matrix4 m6 = m1 * m2 ;                    // operator

float f1 = m4.M11 ;                       // attribute
Vector4 v1 = m4.ColumnX ;                 // property

使用例２

もし望むならば、メンバー関数のかわりにスタティック関数を使用できます。

また性能向上のために、参照引数をとるオーバーロード関数も使用できます。

Matrix4.Inverse( ref m1, out m4 ) ;
Matrix4.Multiply( ref m1, ref m2, out m5 ) ;

引数の制限について

参照引数をとる関数を使用する場合、this 引数や ref 引数と同じ変数を out 引数に指定すると正しい結果が計算されません。

とくに、以下の関数には注意が必要です。

  • Matrix4.Transpose()
    •

  • Matrix4.Inverse*()
    •

  • Matrix4.Multiply*()
    •

  • Matrix4.Transform*()
    •

  • Vector3.Cross()
    •

  • Vector3.Rotate*()
    •

  • Vector3.Perpendicular()
    •

  • Vector2.Rotate()
    •

  • Vector2.Perpendicular()
    •

  • Quaternion.Multiply()
    •

  • Quaternion.Transform()
    •

関連項目

  • Sce.PlayStation.Core
    •

  • Sce.PlayStation.Core.FMath
    •

  • Sce.PlayStation.Core.Matrix4
    •

  • Sce.PlayStation.Core.Vector4
    •

  • Sce.PlayStation.Core.Vector3
    •

  • Sce.PlayStation.Core.Vector2
    •

  • Sce.PlayStation.Core.Quaternion
    •

  • Sce.PlayStation.Core.Rectangle
    •

  • Sce.PlayStation.Core.Rgba
    •

  • Sce.PlayStation.Core.Rgba4444
    •

  • Sce.PlayStation.Core.Rgba5551
    •

  • Sce.PlayStation.Core.Rgb565
    •

  • Sce.PlayStation.Core.Half4
    •

  • Sce.PlayStation.Core.Half3
    •

  • Sce.PlayStation.Core.Half2
    •

  • Sce.PlayStation.Core.Half
    •

  • Sce.PlayStation.Core.Short4
    •

  • Sce.PlayStation.Core.Short3
    •

  • Sce.PlayStation.Core.Short2
    •

  • Sce.PlayStation.Core.UShort4
    •

  • Sce.PlayStation.Core.UShort3
    •

  • Sce.PlayStation.Core.UShort2
    •

  • Sce.PlayStation.Core.Byte4
    •

  • Sce.PlayStation.Core.Byte3
    •

  • Sce.PlayStation.Core.Byte2
    •

  • Sce.PlayStation.Core.UByte4
    •

  • Sce.PlayStation.Core.UByte3
    •

  • Sce.PlayStation.Core.UByte2
    •

  • Sce.PlayStation.Core.Short4N
    •

  • Sce.PlayStation.Core.Short3N
    •

  • Sce.PlayStation.Core.Short2N
    •

  • Sce.PlayStation.Core.ShortN
    •

  • Sce.PlayStation.Core.UShort4N
    •

  • Sce.PlayStation.Core.UShort3N
    •

  • Sce.PlayStation.Core.UShort2N
    •

  • Sce.PlayStation.Core.UShortN
    •

  • Sce.PlayStation.Core.Byte4N
    •

  • Sce.PlayStation.Core.Byte3N
    •

  • Sce.PlayStation.Core.Byte2N
    •

  • Sce.PlayStation.Core.ByteN
    •

  • Sce.PlayStation.Core.UByte4N
    •

  • Sce.PlayStation.Core.UByte3N
    •

  • Sce.PlayStation.Core.UByte2N
    •

  • Sce.PlayStation.Core.UByteN
    •


Graphicsの概要

Sce.PlayStation.Core.Graphics はグラフィクス描画のための機能を提供します。機能モデルとしてOpenGL ES 2.0をベースとしています。

Contents

  • グラフィクスコンテキスト
  • シェーダープログラム
  • 頂点バッファ
  • テクスチャ
  • フレームバッファ
  • カラーバッファとデプスバッファ
  • 機能制限について
  • シェーダー記述について
  • リソースヒープとグラフィクスメモリ
  • 関連項目

グラフィクスコンテキスト

GraphicsContextはグラフィクス描画全体を制御するクラスであり、OpenGLにおけるグラフィクスコンテキストを表します。このクラスのコンストラクタでグラフィクスデバイスとスクリーンの初期化をおこない、このクラスのメンバー関数でグラフィクス描画をおこないます。

GraphicsContextはグラフィクスデバイスとスクリーンをシステムの標準的な設定で初期化します。必要ならば引数でスクリーンサイズとピクセル形式を指定することができます。グラフィクスデバイスの能力や実際のスクリーンサイズとピクセル形式は初期化後に取得することができます。

グラフィクス描画をおこなうには、以下で説明するグラフィクスオブジェクトをあらかじめ作成しておき、GraphicsContextのメンバー関数を使用して、グラフィクスオブジェクトやレンダーステートを設定してプリミティブを描画します。

シェーダープログラム

ShaderProgramはシェーダー機能を制御するクラスであり、OpenGLにおけるプログラムオブジェクトを表します。頂点シェーダーとフラグメントシェーダーの組み合わせによって構成され、それらのシェーダープログラムが格納されたファイルから作成します。

ShaderProgramは複数のユニフォーム変数と複数のアトリビュート変数を保持します。ユニフォーム変数には値を設定することができ、アトリビュート変数には頂点データを連続的に転送することができます。これらの変数は番号によってアクセスされます。必要ならばアプリケーションに便利なように、これらの変数を特定の番号にバインドすることもできます。

シェーダーファイルの拡張子は.cgxで、Cg言語で記述されたソースコードから変換されたバイナリです。ソースコードの拡張子は.vcg .fcgまたは.vp.cg .fp.cgとしてください。ソースコードの拡張子が.vcg .fcgならば同じ名前の頂点シェーダーとフラグメントシェーダーが１つのファイルに格納されます。

頂点バッファ

VertexBufferは頂点データを格納するクラスであり、OpenGLにおける頂点バッファオブジェクトを表します。必要に応じて複数の頂点配列、一つのインデックス配列を格納することができ、サイズと形式を指定して作成します。

VertexBufferはGraphicsContextに複数設定することができます。頂点配列はそれぞれ順番にShaderProgramのアトリビュート変数に関連づけられます。

複数のインデックス配列が有効な場合は、最後のものが使用されます。

テクスチャ

Textureはピクセルデータを格納するクラスであり、OpenGLにおけるテクスチャオブジェクトを表します。Texture2D、TextureCubeなどの派生クラスがあり、画像ファイルから作成するかサイズと形式を指定して作成します。

TextureはGraphicsContextに複数設定することができます。テクスチャはそれぞれ順番にShaderProgramのサンプラーに関連づけられます。

利用可能な画像フォーマットはDDS, PNG, JPG, BMP, GIF(ただしアニメーションGIFは非対応)です。

フレームバッファ

FrameBufferはレンダリング結果の格納先を制御するクラスであり、OpenGLにおけるフレームバッファオブジェクトを表します。レンダリング結果の格納先をスクリーン以外の別のバッファに変更することでオフスクリーンレンダリングをおこなうことができます。

FrameBufferにはカラーの格納先とデプスの格納先を設定することができます。ColorBufferはカラーの格納先に、DepthBufferはデプスの格納先に設定することができます。Textureは生成時にRenderableオプションが指定されていれば、カラーの格納先に設定することができます。

カラーの格納先とデプスの格納先の組み合わせによってはレンダリングできない場合があります。現在の組み合わせがレンダリング可能かどうかはFrameBuffer.Statusプロパティで確認することができます。

カラーバッファとデプスバッファ

ColorBuffer、DepthBufferはレンダリング結果を格納するクラスであり、OpenGLにおけるレンダバッファオブジェクトを表します。ColorBufferにはカラー値を、DepthBufferにはデプス値とステンシル値を格納することができ、サイズと形式を指定して作成します。

ColorBuffer、DepthBufferはGraphicsContextに設定することはできません。これらはFrameBufferに設定して使用します。

機能制限について

現在のバージョンでは、以下の機能は使用できません。

  • ２のべき乗でないテクスチャのリピートモード
  • ２のべき乗でない圧縮テクスチャ
  • 深度テクスチャ
  • 3Dテクスチャ
  • half floatテクスチャへのレンダリング
  • luminance alphaテクスチャへのレンダリング

またデバイス性能は、以下の値に制限されます。

  • MaxTextureSize 2048
  • MaxCubeMapTextureSize 2048
  • MaxRenderbufferSize 2048
  • MaxVertexUniformVectors 128
  • MaxFragmentUniformVectors 64
  • MaxVertexAttribs 8
  • MaxVaryingVectors 8
  • MaxTextureImageUnits 8
  • MaxAliasedLineWidth 8
  • MaxAliasedPointSize 128

シェーダー記述について

シェーダー記述には、通常の Cg 言語に比べて以下のような制限があります。

  • GLSL や Cg の予約語と、同じ名前の変数や関数は使用できません。
  • 一部の予約語は case-insensitive であり注意が必要です (Texture, Matrix, Vector など)。
  • vertex shader の出力と fragment shader の入力には、セマンティクスの指定が必要です。
  • vertex shader の出力と fragment shader の入力は、名前とセマンティクスの両方が一致する必要があります。
  • fragment shader の出力には、COLOR セマンティクスの指定が必要です。
  • 一つのシェーダー内で、重複する TEXUNIT セマンティクスは使用できません。
  • 一部のセマンティクスでは、変数の型が制限されます (NORMAL, PSIZE, FOG など)
  • ループの反復回数の最大値は、定数である必要があります。
  • ループの反復回数を制御する場合は、break 文でループを中断してください。
  • attribute, varying, sampler 変数の配列は使用できません。
  • uniform float2/3/4 の xyzw への、uniform int による配列アクセスは使用できません。
  • uniform float4x4 の columns への、uniform int による配列アクセスは使用できません。
  • スカラー変数に対する swizzle は使用できません (f.xxxx など)。
  • PSIZE がない場合、varying 変数は 8 packed vectors まで使用可能です (POSITION を除く)。
  • PSIZE がある場合、varying 変数は 8 vectors まで使用可能です (POSITION, PSIZE を除く)。

vertex shader の入力に指定可能なセマンティクスは以下のとおりです

  • POSITION
  • NORMAL
  • TEXCOORD0-7
  • COLOR0-1
  • DIFFUSE
  • SPECULAR
  • TANGENT
  • BINORMAL
  • BLENDWEIGHT
  • BLENDINDICES
  • FOGCOORD
  • POINTSIZE

vertex shader の出力に指定可能なセマンティクスは以下のとおりです

  • POSITION ( HPOS )
  • TEXCOORD0-7 ( TEX0-7 )
  • COLOR0-1 ( COL0-1 )
  • FOGC ( FOG )
  • PSIZE ( PSIZ )

fragment shader の入力に指定可能なセマンティクスは以下のとおりです

  • TEXCOORD0-7 ( TEX0-7 )
  • COLOR0-1 ( COL0-1 )
  • FOGC ( FOG )
  • POINTCOORD
  • WPOS
  • FACE

fragment shader の出力に指定可能なセマンティクスは以下のとおりです

  • COLOR

リソースヒープとグラフィクスメモリ

グラフィクスオブジェクトは、アプリケーションが管理するリソースヒープに加えて、デバイスドライバが管理するグラフィクスメモリを消費します。VertexBuffer, ShaderProgram などのオブジェクトは、リソースヒープとグラフィクスメモリを必要とします。

一方 Texture2D, TextureCube, ColorBuffer, DepthBuffer などの PixelBuffer オブジェクトは、SDK 1.20 まではリソースヒープを必要としていましたが、SDK 2.00 からは不要となりました。現在のバージョンではグラフィクスメモリだけを必要とします。

グラフィクスメモリの容量はおよそ 96 MiB です。このサイズを変更することはできません。

図1 リソースヒープとグラフィクスメモリ

関連項目

  • Sce.PlayStation.Core.Graphics
  • Sce.PlayStation.Core.Graphics.GraphicsContext
  • Sce.PlayStation.Core.Graphics.ShaderProgram
  • Sce.PlayStation.Core.Graphics.VertexBuffer
  • Sce.PlayStation.Core.Graphics.PixelBuffer
  • Sce.PlayStation.Core.Graphics.Texture
  • Sce.PlayStation.Core.Graphics.Texture2D
  • Sce.PlayStation.Core.Graphics.TextureCube
  • Sce.PlayStation.Core.Graphics.FrameBuffer
  • Sce.PlayStation.Core.Graphics.ColorBuffer
  • Sce.PlayStation.Core.Graphics.DepthBuffer


Audioの概要

Sce.PlayStation.Core.Audio は、効果音やBGMを再生するための機能を提供します。

Contents

  • 効果音
  • BGM
  • 関連項目

効果音

Sound クラスは、効果音のデータを表すクラスです。SoundPlayer クラスは、効果音の再生用のクラスです。1つのSoundクラスに対して、複数のSoundPlayerを使用することにより、1種類の効果音を複数同時に再生することができます。

Sound は、wav ファイルから作成します。Sound.CreatePlayer() を呼び出すことにより、この Sound オブジェクトに関連づいた SoundPlayer が作成されます。SoundPlayer.Play() を呼ぶことにより、効果音を再生します。

Sound クラスで使用可能なファイルフォーマットは以下のいずれかになります。

  • RIFF 形式のリニア PCM、サンプリング周波数 22050Hz もしくは 44100Hz、量子化ビット数16ビット、チャンネル数は１チャンネルもしくは２チャンネルのデータ
  • RIFF 形式のMicrosoft ADPCM、サンプリング周波数 22050Hz もしくは 44100Hz、量子化ビット数16ビット、チャンネル数は１チャンネルもしくは２チャンネルのデータ

BGM

Bgm クラスは、BGMのデータを表すクラスです。BgmPlayer クラスは、BGMの再生を行うためのクラスです。Bgm は同時に1つだけしか再生することができません。そのため BgmPlayer を複数作成することはできません。

Bgm は、mp3 ファイルから作成します。Bgm.CreatePlayer() を呼び出すことにより、この Bgm オブジェクトに関連づいた BgmPlayer が作成されます。BgmPlayer.Play() を呼ぶことにより、音楽を再生します。

Bgm クラスで使用可能ファイルフォーマットは MPEG-1 Audio Layer-3、ビットレート 128-320 kbps (CBR, VBR)、サンプリング周波数 44100Hz もしくは 48000Hz、チャンネル数は１チャンネルもしくは２チャンネルのデータです。

関連項目

  • Sce.PlayStation.Core.Audio
  • Sce.PlayStation.Core.Audio.Sound
  • Sce.PlayStation.Core.Audio.SoundPlayer
  • Sce.PlayStation.Core.Audio.Bgm
  • Sce.PlayStation.Core.Audio.BgmPlayer


Inputの概要

Sce.PlayStation.Core.Input は、入力デバイスの情報を取得するための機能を提供します。

GamePad クラスはゲームパッド、Touch クラスはタッチパネル、Motion クラスはモーションセンサーを表します。いずれも、static なクラスです。

Contents

  • ゲームパッド
  • タッチパネル
    • Touch IDについて
    • マルチタッチが認識される最大数
  • モーションセンサー
  • 関連項目

ゲームパッド

GamePad.GetData() は、ゲームパッドの状態を格納した GamePadData 構造体を返します。GamePad.GetData() を定期的に呼び出し、ゲームパッドの状態に応じてアプリケーションを制御します。

なお、ゲームパッドの有効/無効を設定する場合、Publishing Utilityでapp.xmlを編集してください。

タッチパネル

Touch.GetData() / Touch.GetRearTouchData() は、タッチパネルの前面/背面に触れている指の状態を格納した TouchData 構造体の配列を返します。タッチパネルに複数の指が触れている場合には、配列に複数の TouchData 構造体が格納されて返ります。Touch.GetData() / Touch.GetRearTouchData() を定期的に呼び出し、タッチパネルの状態に応じてアプリケーションを制御します。

なお、タッチパネルの有効/無効を設定する場合、Publishing Utilityでapp.xmlを編集してください。

Touch IDについて

Touch IDの割り振り方式は、実行するデバイスによって異なるので注意が必要です。

ただし、タッチパネル前面/背面それぞれにおいて、同時に押している複数の指の間で、IDが重複することはありません。

マルチタッチが認識される最大数

マルチタッチが最大何点まで認識されるかは、デバイスによって異なります。

PS Vitaでは、タッチパネル前面については 6点 / 背面については 4点 までサポートしています。

モーションセンサー

Motion.GetData() は、モーションセンサーが検出している加速度と角速度の値を格納した MotionData 構造体を返します。Motion.GetData() を定期的に呼び出し、モーションセンサーの状態に応じてアプリケーションを制御します。

なお、モーションセンサーの有効/無効を設定する場合、Publishing Utilityでapp.xmlを編集してください。

関連項目

  • Sce.PlayStation.Core.Input
  • Sce.PlayStation.Core.Input.GamePad
  • Sce.PlayStation.Core.Input.GamePadData
  • Sce.PlayStation.Core.Input.Touch
  • Sce.PlayStation.Core.Input.TouchData
  • Sce.PlayStation.Core.Input.Motion
  • Sce.PlayStation.Core.Input.MotionData


Imagingの概要

Sce.PlayStation.Core.Imaging は、画像処理関連の機能を提供します。画像ファイルをロードしたり、画像の中に文字をレンダリングしたりすることができます。

Contents

  • 画像
  • フォントと文字の描画
    • PSMが標準で搭載しているフォントを使う
    • フォントを指定して使う
    • 文字の情報
  • 関連項目

画像

Image クラスは、画像を表すクラスです。Image は、PNG, JPG, BMP, GIF画像ファイル(ただしアニメーションGIFは非対応)から作成したり、色とサイズから単色で塗られた画像を作成することができます。

Image.Resize() や Image.Crop() など、画像を変換するメソッドが提供されます。また、Image.DrawText() や Image.DrawImage() など、画像の中に文字や他の画像を貼り付けるメソッドが提供されます。

Imageからテクスチャを作成するには、Image.ToBuffer()を使用して画像のメモリイメージを取得し、Texture2D.SetPixels()に渡します。

フォントと文字の描画

Image.DrawText() を呼び出すことで、画像の中に文字を描画することができます。Image.DrawText() に Font オブジェクトを渡して、文字の描画に使用するフォントを指定することができます。

フォントの利用には次の２つの方法があります。

  • PSMが標準で搭載しているフォントを使う。
  • フォントを指定して使う。

PSMが標準で搭載しているフォントを使う

PSMが標準で搭載しているフォントを使うには、Fontクラスのインスタンスを生成する時、FontのコンストラクタにFontAlias.Systemを指定します。現在、システムフォントとして提供されているのはFontAlias.System のみです。

例: new Font(FontAlias.System, size, FontStyle.Regular),

フォントを指定して使う

フォントを指定して使うには以下のようにします。

  1. 使用したいTrueType形式のフォントファイルをプロジェクトに登録し、ビルドアクションにContentを設定します。
  2. Fontクラスのコンストラクタ Font( string filename, int size, FontStyle style ) を使い、filenameにフォントファイル名を渡してインスタンスを生成します。

文字の情報

Font.GetTextWidth() は、文字の描画に必要な画像の横幅を取得するメソッドです。文字列の長さに応じて、画像のサイズを決定するためにこのメソッドを使用します。

また、Font.GetTextMetrics() は、文字ごとのメトリクス情報(尺情報)を取得するメソッドです。これは文字ごとの幅や高さなどを取得するために使用します。

図1 文字のメトリクス情報(尺情報)

詳しくは、 Sce.PlayStation.Core.Imaging.CharMetrics 、 Sce.PlayStation.Core.Imaging.FontMetrics をご覧ください。

関連項目

  • Sce.PlayStation.Core.Imaging
  • Sce.PlayStation.Core.Imaging.Image
  • Sce.PlayStation.Core.Imaging.Font
  • Sce.PlayStation.Core.Imaging.CharMetrics
  • Sce.PlayStation.Core.Imaging.FontMetrics


Environmentの概要

Sce.PlayStation.Core.Environment は、データを保存したり、アプリケーションの動作環境の状態を取得したり、他のアプリケーションを呼び出したりするための機能を提供します。

Contents

  • SystemEvents クラス
  • SystemParameters クラス
  • SystemMemory クラス
  • PersistentMemory クラス
  • Shell クラス
  • コモンダイアログ
  • クリップボード
  • 関連項目

SystemEvents クラス

SystemEvents クラスは、システムから来るイベントを受け取るためのクラスです。アプリケーションが最小化状態から復帰したときのイベントなどを扱います。

アプリケーションは、SystemEvents.CheckEvents() を毎フレーム明示的に呼び出す必要があります。CheckEvents() の呼び出しによって、システムからのイベントをチェックし、内部状態を更新します。

SystemEvents.OnRestored などのイベントハンドラを登録することで、アプリケーションの状態変化の通知を受け取ることができます。

SystemParameters クラス

SystemParameters クラスは、システムの設定を取得するためのクラスです。SystemParameters.Language や SystemParameters.GamePadButtonMeaning などのプロパティによって、言語設定や○×ボタンの意味などを取得することができます。

SystemMemory クラス

SystemMemory クラスは、システムのメモリの状態を取得するためのクラスです。 SystemMemory.Dump() の呼び出しにより、リソースヒープの全体量、使用量、空き容量およびメモリを使用しているオブジェクトの一覧をコンソール画面に出力します。

PersistentMemory クラス

PersistentMemory クラスは、アプリケーションの状態を自動的に保存／復帰させるための永続的なメモリを提供します。メモリサイズは 64KByte です。

PersistentMemory クラスが提供するメモリに書き込まれたデータは、アプリケーションが終了するタイミングで自動的に不揮発な領域に保存され、アプリケーションが再起動したタイミングで、自動的にメモリに読み込まれます。

※PSM Studio からアプリケーションを終了させた場合は、データが保存されません。PersistentMemory の動作を確認する場合は、PlayStation(R)Vita 上でアプリケーションを終了させてください。

Shell クラス

Shell クラスは、他のアプリケーションの起動などの、シェルの機能を呼び出すクラスです。Shell.Action.BrowserAction() などによって、特定の呼び出し内容を表す Action 構造体を作成し、Shell.Execute() に その Action構造体 を渡すことで、シェルの機能を呼び出します。

コモンダイアログ

コモンダイアログは、アプリケーションが一般的に利用するダイアログを表示するための機能です。

ICommonDialog インターフェースは、コモンダイアログを表すクラスの共通のインターフェースです。ICommonDialog には、Open() メソッド や State プロパティ など、コモンダイアログに共通のインターフェースが宣言されています。

TextInputDialog は、文字入力ダイアログを表示するためのコモンダイアログクラスです。TextInputDialog を使って、文字の入力を行うための、モーダルなダイアログを表示することができます。

クリップボード

Clipboard クラスを使用すると、動作環境のクリップボードのテキストを取得したり、クリップボードにテキストを格納したりすることができます。

関連項目

  • Sce.PlayStation.Core.Environment
  • Sce.PlayStation.Core.Environment.SystemEvents
  • Sce.PlayStation.Core.Environment.SystemParameters
  • Sce.PlayStation.Core.Environment.SystemMemory
  • Sce.PlayStation.Core.Environment.PersistentMemory
  • Sce.PlayStation.Core.Environment.Shell
  • Sce.PlayStation.Core.Environment.Shell.Action
  • Sce.PlayStation.Core.Environment.ICommonDialog
  • Sce.PlayStation.Core.Environment.TextInputDialog
  • Sce.PlayStation.Core.Environment.Clipboard


Servicesの概要

Sce.PlayStation.Core.Services はネットワークサービスのための機能を提供します。

Contents

  • アカウント情報
  • アプリ内課金ダイアログ
  • 開発者環境について
  • 関連項目

アカウント情報

AccountInformation はネットワークアカウントに関する情報をあらわす static クラスです。

AccountInformation は各アカウントに対してユニークな 16 バイトの数字を保持しています。この値はアカウントの識別やセーブデータの暗号化などに利用することができます。なお PC シミュレータではユーザー名をベースにしたダミーの値が返されますのでご注意ください。

アプリ内課金ダイアログ

InAppPurchaseDialog はアプリ内課金を処理するダイアログクラスであり、ICommonDialog インターフェースを継承しています。アプリ内課金は主にサーバーへのアクセスによって処理されますが、必要に応じて課金内容の表示やユーザー入力の処理もおこないます。

InAppPurchaseDialog はプロダクトのリストを保持します。これはメタデータ(app.xml)から読み込まれますが、価格やチケットなどapp.xmlに含まれない情報は読み込まれません。それらの情報はサーバーから取得する必要があります。

InAppPurchaseDialog はダイアログを開くことでサーバーにアクセスすることができます。ダイアログを開くには GetProductInfo(), GetTicketInfo(), Purchase(), Consume() 関数を使用してください。なお Open() 関数は使用できませんのでご注意ください。

  • GetProductInfo() : プロダクト情報を取得します (購入前に必要)
  • GetTicketInfo() : チケット情報を取得します (購入前と消費前に必要)
  • Purchase() : プロダクトを購入します
  • Consume() : チケットを消費します

ダイアログ処理が完了するのを待ち、ダイアログ処理が成功したかどうか確認するなど、基本的な使用方法は ICommonDialog インターフェースと同じです。ダイアログ処理が成功すると、プロダクトのリストに格納された情報が更新されます。

もしダイアログ処理の結果が Error または Aborted であっても、購入や消費はサーバーに処理されている可能性があります。これは、たとえばリクエスト送信後のネットワーク切断などによって発生します。そのため、ダイアログ処理の結果が Error または Aborted の場合、あらためて GetTicketInfo() でチケット情報を取得して、購入や消費がサーバーに処理されたかどうかを確認してください。

開発者環境について

InAppPurchaseDialog は、開発者環境ではエンドユーザー環境と異なる挙動をおこないます。

  • サーバーに接続されない。
  • 購入情報がローカルファイルに記録される。
  • API が呼び出されるたびにユーザー入力が求められる。
  • ダイアログのエラーボタンでエラーを発生させることができる。
  • プロダクト価格文字列にプロダクトラベル文字列が格納される。

開発者環境では、アプリ内課金は擬似的なエミュレーションとして動作します。サーバー接続はおこなわれず、ローカルファイルに状態が記録されます。開発者環境において購入情報をクリアするためには、次の操作を実行してください。

  • PC シミュレータ : APIが呼び出されたときに表示されるダイアログの[Reset]ボタンを押してください。
  • PlayStation(R)Vita : PlayStation(R)Mobile Development Assistantのメニューを使用してください。

さらに、開発者環境では API が呼び出されるたびにユーザー入力が求められます。ダイアログのエラーボタンを押すことで、ネットワークエラー発生時のアプリケーションの挙動を確認することができます。なお、エンドユーザー環境では必要な場合のみユーザー入力が求められます。

また、開発者環境では価格表示の間違いを避けるため、プロダクト価格文字列にプロダクトラベル文字列が格納されます。

関連項目

  • Sce.PlayStation.Core.Services
  • Sce.PlayStation.Core.Services.AccountInformation
  • Sce.PlayStation.Core.Services.InAppPurchaseDialog
  • Sce.PlayStation.Core.Services.InAppPurchaseProduct
  • Sce.PlayStation.Core.Services.InAppPurchaseProductList
  • アプリ内課金


Deviceの概要

Sce.PlayStation.Core.Device は、以下の機能を提供します。

  • カメラデバイスから画像データを取得するための機能を提供します。また、カメラで撮影した写真ファイルの保存および読み込みを手軽に行うためのダイアログ機能も合わせて提供します。
  • GPSやWi-Fi、3Gネットワークを利用した位置情報を取得するための機能を提供します。

Contents

  • カメラ
    • Camera クラス
  • 写真インポートダイアログ
    • CameraImportDialog クラス
    • PhotoImportDialog クラス
  • ロケーション
    • Location クラス
    • GPSエミュレーション機能
  • 関連項目

カメラ

カメラデバイスの映像データをリアルタイムに取得することができます。 AR アプリや、独自のカメラアプリを実装する場合などに利用します。

Camera クラス

Camera クラスはカメラデバイスをコントロールするためのクラスです。 またカメラデバイスの様々な情報を取得することもできます。

  • カメラデバイスの数を取得する。
  • カメラデバイスの向きや利用できる解像度を取得する。
  • 解像度を指定して映像データをリアルタイムに取得する。
  • 写真を撮影する。撮影した写真はファイルとしてローカルストレージに保存されます。

なお映像データの取得は非同期に実行されます。

写真インポートダイアログ

エンドユーザーが撮影・選択した写真ファイルを、PSM アプリケーションからアクセス可能なローカルストレージへ取り込むことができます。

写真インポートダイアログには次の２つの種類があります。

  • CameraImportDialog
  • PhotoImportDialog

CameraImportDialog クラス

  写真撮影画面を表示します。 　上記の画面にてエンドユーザーが撮影した写真は、ファイルとしてローカルストレージへ取り込まれます。

  カメラの撮影結果を手軽に取得したい場合に便利です。

PhotoImportDialog クラス

  デバイスに保存されている写真の一覧画面を表示します。 　上記の画面にてエンドユーザーが選択した写真は、ファイルとしてローカルストレージへ取り込まれます。

  PSM 外で撮影・保存された写真を取得したい場合に使用します。

  また、このダイアログを使用することで Image.Export() によって出力された画像ファイルを、再びアプリに取り込む手段をエンドユーザーに提供することができます。

ロケーション

GPSやWi-Fi、3Gネットワークを利用した位置情報を取得します。 ロケーション情報を取得するには、Publishing Utilityの[Common Property]タブ - [Location]をtrueに設定してください。

Location クラス

Location クラスは位置情報を取得するためのクラスです。

  • Location.Start() : 位置情報取得を開始する
  • Location.GetData() : 位置情報の取得する
  • Location.Stop() : 位置情報取得を終了する

GPSエミュレーション機能

PlayStation(R)Mobileシミュレータ環境では、GPSエミュレーションファイルによる位置情報のエミュレーション機能を提供しています。 %SCE_PSM_SDK%/tools/Location/gpsdata.nma ファイルを自動的に読み込んで、擬似的に位置情報が更新します。

関連項目

  • Sce.PlayStation.Core.Device.Camera
  • Sce.PlayStation.Core.Device.CameraImportDialog
  • Sce.PlayStation.Core.Device.PhotoImportDialog
  • Sce.PlayStation.Core.Device.Location


HighLevel.UI の概要

Sce.PlayStation.HighLevel.UI は、UI を実現するための仕組みである UI Toolkit を提供します。UI Toolkit 上で動作する UI の部品やアニメーションも含まれます。

Sce.PlayStation.HighLevel.UI.dll をロードすることで使用可能になります。

ボタンやダイアログの表示が簡単に行え、また付属のレイアウトツールによりUI 部品の配置も簡単に行うことができます。

詳細は UI ToolKit プログラミングガイド および Sce.PlayStation.HighLevel.UI APIリファレンス を参照してください。

Contents

  • UISystem クラス
  • 関連項目

UISystem クラス

UISystem クラスは、UI Toolkit の提供する機能を使用するためのStaticなクラスです。

関連項目

  • Sce.PlayStation.HighLevel.UI
  • Sce.PlayStation.HighLevel.UI.UISystem
  • Sce.PlayStation.HighLevel.UI.Widget


HighLevel.Modelの概要

Sce.PlayStation.HighLevel.Model は基本的なモデル表示の機能を提供します。

Contents

  • モデル
  • プログラム
  • パラメータ
  • プログラムコンテナ
  • テクスチャコンテナ
  • コンバータの使用方法について
  • コンバータのオプションについて
  • コンバータの入力ファイルについて
  • モデルファイルフォーマットについて
  • 関連項目

モデル

BasicModelは基本的なモデルデータを表すクラスであり、モデルデータが格納されたファイルをロードして作成します。

BasicModelにはワールド行列設定、カレントモーション設定、アニメーション計算、行列計算、グラフィクス描画などのAPIがあり、それらを呼び出すことでモデルを表示することができます。

モデルファイルの拡張子は .mdx であり、FBX XSI X COLLADA などの一般的なモデルデータから変換されたバイナリ形式です。 モデルファイルには階層構造、形状データ、マテリアル、テクスチャ、アニメーションなどの情報が格納されています。

プログラム

BasicProgramは基本的なシェーダープログラムを表すクラスであり、ライティング、フォグ、スキニングなど基本的な効果を適用することができます。

BasicProgramには行列、マテリアル、ライト、フォグ、描画モードなどのパラメータがあり、それらを設定することでシェーダー機能を制御することができます。

シェーダーファイルは設定されたパラメータに応じて自動的にロードされます。そのため、BasicProgramが必要とするすべてのシェーダーファイルをアプリケーションのディレクトリにコピーしておく必要があります。

パラメータ

BasicParametersはBasicProgramのパラメータを管理するクラスであり、上述のパラメータはこのクラスに格納されています。

BasicProgramは一つのBasicParametersを持ちますが、必要ならば、複数のBasicProgramが一つのBasicParametersを共有することもできます。これはカメラやライトなどグローバルなパラメータの設定に便利です。

プログラムコンテナ

BasicProgramContainerはロードずみのプログラムを管理するクラスであり、文字列をキーとする辞書にプログラムを登録することができます。

モデルをロードした後、このクラスを使用してプログラムをモデルに関連づけます。 それにより、キー文字列に応じて適切なプログラムをモデルに適用することができ、またロードずみのプログラムを複数のモデルが共有することができます。

テクスチャコンテナ

BasicTextureContainerはロードずみのテクスチャを管理するクラスであり、文字列をキーとする辞書にテクスチャを登録することができます。

モデルをロードした後、このクラスを使用してテクスチャをモデルに関連づけます。 それにより、キー文字列に応じて適切なテクスチャをモデルに適用することができ、またロードずみのテクスチャを複数のモデルが共有することができます。

コンバータの使用方法について

ModelConverter と ModelViewer は、以下のフォルダーにあります。

%SCE_PSM_SDK%/tools/ModelConverter

ModelConverter と ModelViewer のショートカットをデスクトップに作成してください。

ModelConverter に入力ファイルをドラッグ＆ドロップすると、同じフォルダーに出力ファイルが作成されます。

ModelViewer に出力ファイルをドラッグ＆ドロップすると、モデルデータを表示することができます。

モデルを変換するとき、もし存在すれば、テクスチャの画像ファイルが読み込まれ、出力ファイルに格納されます。

画像ファイルは、入力モデルファイルの中で記述されたテクスチャファイル名のフォルダーだけでなく、入力モデルファイルが存在するフォルダーからも検索されます。画像ファイル拡張子は、入力モデルファイルの中で指定されたテクスチャファイル名の拡張子にかかわらず、DDS, PNG, JPG, BMP, GIF など利用可能な拡張子から自動的に選択されます。

コンバータのオプションについて

コントロールキーを押しながらドラッグ＆ドロップすると、プロンプトが表示されキー入力が可能になります。

そこで、以下のようなオプションを指定することができます。

-o <filename>
出力ファイル名を指定します。
-s <scale>
モデルデータのサイズをスケールします。
-t <scale>
アニメーションの速度をスケールします。
-S
テキスト形式で出力します。拡張子は .mds です。
-N
最適化をおこないません。
-B
BLENDINDICES を使用しません。
-models
複数ファイルのモデルを、一つのファイルに出力します。
-motions
複数ファイルのモーションを、一つのファイルに出力します。

コンバータの入力ファイルについて

以下のファイル形式が利用可能です。

FBX
動作確認は Autodesk Maya 2013 でおこなっています。利用可能であることが確認されているフォーマットバージョンは FBX 2013 です。コンバータが使用しているツールキットは Autodesk FBXSDK 2011.3 です。 なお FBX ファイルに対応する Maya ASCII ファイルが同じフォルダーにあれば、さらにいくつかのパラメータを取得できます。
XSI
動作確認は Autodesk SoftImage 2013 でおこなっています。利用可能であることが確認されているフォーマットバージョンは 3.6 と 6.0 です。コンバータが使用しているツールキットは Autodesk Crosswalk 2013.0 です。 なお XSI ファイルを変換するには、Autodesk Crosswalk 2013.0 が PC にインストールされている必要があります。
X
動作確認は NewTek LightWave 11 でおこなっています。利用可能であることが確認されているフォーマットバージョンは 3.3 (DirectX8 形式) です。コンバータが使用しているツールキットは Microsoft DirectX SDK (June 2010) です。
COLLADA
動作確認は Autodesk Maya 2009 でおこなっています。利用可能であることが確認されているフォーマットバージョンは COLLADA 1.4.1 です。コンバータが使用しているツールキットは OpenCOLLADA 2011 です。
MDX / MDS
これらのファイル形式は、入出力が可能です。

テストデータは、以下のフォルダーにあります。

%SCE_PSM_SDK%/tools/ModelConverter/testdata

変換可能なモデルパラメータは、以下のとおりです。

"Maya ASCII" と書かれたパラメータは、同じフォルダーにある Maya ASCII ファイルから取得することができます。

モデルファイルフォーマットについて

モデルファイルフォーマットについての詳細は、以下のページに記述されています。

PlayStation(R)Mobile MDX ファイル形式

関連項目

  • Sce.PlayStation.HighLevel.Model
  • Sce.PlayStation.HighLevel.Model.BasicModel
  • Sce.PlayStation.HighLevel.Model.BasicProgram
  • Sce.PlayStation.HighLevel.Model.BasicParameters
  • Sce.PlayStation.HighLevel.Model.BasicProgramContainer
  • Sce.PlayStation.HighLevel.Model.BasicTextureContainer


HighLevel.Physics2Dの概要

Sce.PlayStation.HighLevel.Physics2Dは基本的な２次元物理シミュレーションの機能を提供します。

Contents

  • PhysicsBody
  • PhysicsShape
  • PhysicsJoint
  • PhysicsSpring
  • PhysicsScene
  • PhysicsSolverPair
  • PhysicsUtility
  • 関連項目

PhysicsBody

PhysicsBodyは基本的な２次元剛体を表すクラスで、速度、加速度など剛体の様々な属性を保持します。

PhysicsShape

PhysicsShapeは基本的な２次元衝突形状を表すクラスで、３０個の頂点を上限とした凸形状です。ただし、球については頂点０個の凸形状として例外として扱います。

PhysicsJoint

PhysicsJointは基本的なジョイント接続を表すクラスで、剛体ペアに対して角度、位置の制限をかけます。ボールジョイント、スライダージョイントなどを作成することができます。

PhysicsSpring

PhysicsSpringは基本的なスプリング接続を表すクラスで、剛体ペアに対して長さの制限をかけます。

PhysicsScene

PhysicsSceneは２次元物理シミュレーションシーンを表すクラスです。シミュレーションはシーン単位で実行されます。レイキャスト用の計算RaycastHitもこのシーンクラスで提供されています。

PhysicsSolverPair

PhysicsSolverPairはSolver Phaseに渡される衝突情報であり、剛体ペアの衝突情報を保持しています。

PhysicsUtility

PhysicsUtilityは計算内部で使用される定数や、関数などが定義されています。

関連項目

  • Sce.PlayStation.HighLevel.Physics2D
  • Sce.PlayStation.HighLevel.PhysicsBody
  • Sce.PlayStation.HighLevel.PhysicsShape
  • Sce.PlayStation.HighLevel.PhysicsJoint
  • Sce.PlayStation.HighLevel.PhysicsSpring
  • Sce.PlayStation.HighLevel.PhysicsScene
  • Sce.PlayStation.HighLevel.PhysicsSolverPair
  • Sce.PlayStation.HighLevel.PhysicsUtility


HighLevel.GameEngine2Dの概要

Sce.PlayStation.HighLevel.GameEngine2D は、2Dのゲームエンジンを提供します。スプライトやパーティクル、タイルといった、2次元のゲームを実現するために必要な機能を持っています。 Director や Action、TransitionScene といった一部のクラスは、Cocos2d (http://www.cocos2d-iphone.org/) に似たインターフェースを備えています。

Contents

  • ベースライブラリ
  • Director クラス
  • Action クラス
  • Node クラス
  • Scene クラス
  • SpriteUV クラス
  • SpriteList クラス
  • SpriteTile クラス
  • Label クラス
  • ParticleSystem クラス
  • TransitionScene クラス
  • 関連項目

ベースライブラリ

Sce.PlayStation.HighLevel.GameEngine2D.Base 名前空間は、数学関係やグラフィックスシステムといった、2Dゲームエンジンの基礎的なクラスを提供します。

Director クラス

Director はゲームエンジン全体を制御するクラスです。Scene の管理やメインループ関連の機能を持っています。

Action クラス

Action は、オブジェクトの移動や回転、拡大縮小、色の変化などのさまざまな操作を、一定期間にわたって実行するための機能です。

Node クラス

Node は、シーングラフのノードを表すベースクラスです。Node を継承したクラスには、Scene、SpriteUV、ParticleSystem といった、さまざまなクラスがあります。

Scene クラス

Scene は、シーングラフのルートノードを表すクラスです。

SpriteUV クラス

SpriteUV は、単一のスプライトを表示するための、単純なクラスです。スプライトで表示するテクスチャの範囲を指定することができます。

SpriteList クラス

SpriteList は、たくさんのスプライトを１度の描画命令で表示するためのクラスです。描画パフォーマンスのためには、できるだけスプライトをまとめて描画するのが適切です。

SpriteTile クラス

SpriteTile は、タイル状に並んだマップを描画するためのクラスです。

Label クラス

Label は、文字列を描画するためのクラスです。

ParticleSystem クラス

ParticleSystem は、小さなパーティクルの集合を描画することで、炎や煙、雨といった視覚効果を実現するためのクラスです。パーティクルの動きを制御するために、さまざまなパラメータが公開されています。

TransitionScene クラス

TransitionScene は、シーンを置き換える際の、いくつかの視覚効果を提供します。

関連項目

  • Sce.PlayStation.HighLevel.GameEngine2D
  • Sce.PlayStation.HighLevel.GameEngine2D.Base
  • Sce.PlayStation.HighLevel.GameEngine2D.Director
  • Sce.PlayStation.HighLevel.GameEngine2D.Node
  • Sce.PlayStation.HighLevel.GameEngine2D.Scene
  • Sce.PlayStation.HighLevel.GameEngine2D.SpriteUV
  • Sce.PlayStation.HighLevel.GameEngine2D.SpriteList
  • Sce.PlayStation.HighLevel.GameEngine2D.SpriteTile
  • Sce.PlayStation.HighLevel.GameEngine2D.Label
  • Sce.PlayStation.HighLevel.GameEngine2D.ParticleSystem
  • Sce.PlayStation.HighLevel.GameEngine2D.TransitionScene


パッケージ Sce.PlayStation.Core

パッケージ

package | Audio
package | Device
package | Environment
package | Graphics
package | Imaging
package | Input
package | Services

構成

class | FMath
math wrapper and convenience functions [詳細]
struct | Matrix4
matrix of 16 floats [詳細]
struct | Vector4
vector of 4 floats [詳細]
struct | Vector3
vector of 3 floats [詳細]
struct | Vector2
vector of 2 floats [詳細]
struct | Quaternion
quaternion [詳細]
struct | Rectangle
rectangle [詳細]
struct | Rgba
32 bit color struct, with 8 bits per channel [詳細]
struct | Rgba4444
16 bit color struct with 4 bits per channel [詳細]
struct | Rgba5551
16 bit color struct with 5 bits per channel for R, G, and B. and 1 bit for A [詳細]
struct | Rgb565
16 bit color struct with 5 bits for R, 6 bits for G, and 5 bits for G [詳細]
struct | Half4
vector of 4 halfs [詳細]
struct | Half3
vector of 3 halfs [詳細]
struct | Half2
vector of 2 halfs [詳細]
struct | Half
a scalar half [詳細]
struct | Short4
vector of 4 signed shorts [詳細]
struct | Short3
vector of 3 signed shorts [詳細]
struct | Short2
vector of 2 signed shorts [詳細]
struct | UShort4
vector of 4 unsigned shorts [詳細]
struct | UShort3
vector of 3 unsigned shorts [詳細]
struct | UShort2
vector of 2 unsigned shorts [詳細]
struct | Byte4
vector of 4 signed bytes [詳細]
struct | Byte3
vector of 3 signed bytes [詳細]
struct | Byte2
vector of 2 signed bytes [詳細]
struct | UByte4
vector of 4 unsigned bytes [詳細]
struct | UByte3
vector of 3 unsigned shorts [詳細]
struct | UByte2
vector of 2 unsigned shorts [詳細]
struct | Short4N
vector of 4 normalized signed shorts [詳細]
struct | Short3N
vector of 3 normalized signed shorts [詳細]
struct | Short2N
vector of 2 normalized signed shorts [詳細]
struct | ShortN
a scalar normalized signed short [詳細]
struct | UShort4N
vector of 4 normalized unsigned shorts [詳細]
struct | UShort3N
vector of 3 normalized unsigned shorts [詳細]
struct | UShort2N
vector of 2 normalized unsigned shorts [詳細]
struct | UShortN
a scalar normalized unsigned short [詳細]
struct | Byte4N
vector of 4 normalized signed bytes [詳細]
struct | Byte3N
vector of 3 normalized signed bytes [詳細]
struct | Byte2N
vector of 2 normalized signed bytes [詳細]
struct | ByteN
a scalar normalized signed byte [詳細]
struct | UByte4N
vector of 4 normalized unsigned bytes [詳細]
struct | UByte3N
vector of 3 normalized unsigned bytes [詳細]
struct | UByte2N
vector of 2 normalized unsigned bytes [詳細]
struct | UByteN
a scalar normalized unsigned byte [詳細]
©2014 Sony Computer Entertainment Inc. All Rights Reserved.


パッケージ Sce.PlayStation.Core.Audio

構成

class | BgmPlayer
音楽再生機能を提供するクラス [詳細]
class | Bgm
音楽データ [詳細]
class | SoundPlayer
効果音再生機能を提供するクラス [詳細]
class | Sound
効果音データ [詳細]

列挙型

enum | BgmStatus { Stopped = 0, Playing, Paused }

音楽の状態を表す列挙子

[詳細]
enum | SoundStatus { Stopped = 0, Playing }

効果音の状態を表す列挙子

[詳細]

列挙型

enum BgmStatus

音楽の状態を表す列挙子

列挙型の値:
Stopped

停止

Playing

再生中

Paused

一時停止

enum SoundStatus

効果音の状態を表す列挙子

列挙型の値:
Stopped

停止

Playing

再生中


  • Sce
  • PlayStation
  • Core
  • Audio
  • Bgm
Public メソッド

クラス Bgm

音楽データ [詳細]

すべてのメンバ一覧

Public メソッド

Bgm (string filename)
Bgm のコンストラクタ (ファイル名から)
Bgm (byte[] fileImage)
Bgmのコンストラクタ(ファイルイメージから)
void Dispose ()
Bgm のアンマネージドリソースを解放する
BgmPlayer CreatePlayer ()
このBgmを再生するための BgmPlayer オブジェクトを作成する

説明

音楽データ

音楽データとしては、mp3 ファイルを使用することができます。

コンストラクタとデストラクタ

Bgm ( string filename )

Bgm のコンストラクタ (ファイル名から)

引数:
filename 音楽データのファイル名
Bgm ( byte[] fileImage )

Bgmのコンストラクタ(ファイルイメージから)

引数:
fileImage 音楽データのファイルイメージ

メソッド

BgmPlayer CreatePlayer ( )

このBgmを再生するための BgmPlayer オブジェクトを作成する

戻り値:
音楽データに関連付けられたBgmPlayerオブジェクト


クラス BgmPlayer

音楽再生機能を提供するクラス [詳細]

すべてのメンバ一覧

Public メソッド

void | Dispose ()
BgmPlayer のアンマネージドリソースを解放する
void | Play ()
音楽を再生する
void | Stop ()
音楽を停止する
void | Pause ()
音楽プレイヤを一時停止する
void | Resume ()
音楽プレイヤの一時停止を解除する

プロパティ

BgmStatus | Status [get]
音楽プレイヤの状態
float | Volume [get, set]
ボリューム (0.0-1.0)
bool | Loop [get, set]
ループ再生
float | PlaybackRate [get, set]
再生速度係数とピッチ(0.25-4.0)
double | Time [get, set]
再生時刻 (単位＝秒)
double | Duration [get]
再生時間 (単位＝秒)
double | LoopStart [get, set]
ループ開始時刻 (単位＝秒)
double | LoopEnd [get, set]
ループ終了時刻 (単位＝秒)

説明

音楽再生機能を提供するクラス


  • Sce
  • PlayStation
  • Core
  • Audio
  • Sound
Public メソッド

クラス Sound

効果音データ [詳細]

すべてのメンバ一覧

Public メソッド

Sound (string filename)
Sound のコンストラクタ (ファイル名から)
Sound (byte[] fileImage)
Soundのコンストラクタ(ファイルイメージから)
void Dispose ()
Sound の アンマネージドリソースを解放する
SoundPlayer CreatePlayer ()
この効果音を再生するための SoundPlayer オブジェクトを作成する

説明

効果音データ

効果音データとしては、wav ファイルを使用することができます。

コンストラクタとデストラクタ

Sound ( string filename )

Sound のコンストラクタ (ファイル名から)

引数:
filename 効果音のファイル名
Sound ( byte[] fileImage )

Soundのコンストラクタ(ファイルイメージから)

引数:
fileImage 効果音のファイルイメージ

メソッド

SoundPlayer CreatePlayer ( )

この効果音を再生するための SoundPlayer オブジェクトを作成する

戻り値:
効果音データに関連付けられたSoundPlayerオブジェクト


クラス SoundPlayer

効果音再生機能を提供するクラス [詳細]

すべてのメンバ一覧

Public メソッド

void | Dispose ()
SoundPlayer のアンマネージドリソースを解放する
void | Play ()
効果音を再生する
void | Stop ()
効果音を停止する

プロパティ

SoundStatus | Status [get]
効果音の状態
float | Volume [get, set]
ボリューム (0.0-1.0)
float | Pan [get, set]
音声の左右の位置(-1.0-1.0)
bool | Loop [get, set]
ループ再生
float | PlaybackRate [get, set]
再生速度およびピッチ(0.25-4.0)
double | Time [get, set]
再生時刻 (単位＝秒)
double | Duration [get]
再生時間 (単位＝秒)

説明

効果音再生機能を提供するクラス


パッケージ Sce.PlayStation.Core.Device

構成

struct | LocationData
位置情報 [詳細]
class | Location
位置情報を表すクラス [詳細]
struct | CameraSize
カメラの画像の解像度 [詳細]
struct | CameraInfo
カメラの詳細情報 [詳細]
class | Camera
カメラを表すクラス [詳細]
class | CameraImportDialog
写真を撮影するコモンダイアログクラス [詳細]
class | PhotoImportDialog
写真を選択するコモンダイアログクラス [詳細]

列挙型

enum LocationDeviceType {
None = 0, Gps = 1 << 0, Wifi = 1 << 1, Cell3G = 1 << 2,
Unknown = 0x80000000
}

ロケーションデバイスのタイプ

[詳細]
enum | CameraFacing { Back = 0, Front = 1 }

カメラの向き

[詳細]
enum | CameraImageFormat { Rgb565 = 0, Rgba8888 = 1 }

ストリームのデータフォーマット

[詳細]
enum | CameraState { Closed = 0, Stopped = 1, Running = 2, TakingPicture = 3 }

カメラの動作状態

[詳細]
enum | PictureState { Idle = 0, Running = 1, Finishied = 2, Failed = -1 }

写真の撮影状況

[詳細]

列挙型

enum CameraFacing

カメラの向き

列挙型の値:
Back

背面カメラ

Front

フロントカメラ

enum CameraImageFormat

ストリームのデータフォーマット

列挙型の値:
Rgb565

RGB565 フォーマット

Rgba8888

RGBA8888 フォーマット

enum CameraState

カメラの動作状態

列挙型の値:
Closed

ストリームを開いていない

Stopped

ストリームが流れていない

Running

ストリームが流れている

TakingPicture

写真を撮影中

enum LocationDeviceType

ロケーションデバイスのタイプ

列挙型の値:
None

位置計測可能なデバイスがない、もしくはONになっていない

Gps

GPS.

Wifi

Wi-Fi.

Cell3G

3G

Unknown

不明なデバイス

enum PictureState

写真の撮影状況

列挙型の値:
Idle

まだ写真を撮影していない

Running

写真を撮影中

Finishied

写真を撮影した

Failed

写真の撮影に失敗した


クラス Camera

カメラを表すクラス [詳細]

すべてのメンバ一覧

構成

class | FrameChangedEventArgs
ストリームの画像のフレームが変化したときに発生するイベントで渡される引数クラス [詳細]
class | PictureStateChangedEventArgs
写真の撮影状況が変化したときに発生するイベントで渡される引数クラス [詳細]

Public メソッド

Camera (int cameraId)
カメラを起動してインスタンスを作成するコンストラクタ
インスタンスは Dispose メソッドで破棄しなければならない
カメラは一つしか使用することができないため、別のカメラを使用するときは 現在のインスタンスを破棄してから新しいインスタンスを作成しなければならない
void | Dispose ()
カメラのインスタンスを破棄する
void | Open ()
デフォルトの解像度でストリームを開く
void | Open (int sizeId)
指定した解像度でストリームを開く
void | Close ()
ストリームを閉じる
void | Start ()
画像のストリーミングを開始する
FrameChanged イベントが設定されているときは非同期にデータをバッファに読み込む
void | Stop ()
画像のストリーミングを停止する
void | Read ()
ストリームのデータをバッファに読み込む
void | TakePicture (int sizeId)
写真を撮影する
撮影した写真のフォーマットは JPEG である
撮影した写真はファイルに保存される
このメソッドは画像をストリーミングしているときにのみ呼び出すことができる

Static Public メソッド

static int | GetNumberOfCameras ()
カメラの数を取得する
static CameraInfo | GetCameraInfo (int cameraId)
カメラの詳細情報を取得する

Protected メソッド

void | Dispose (bool disposing)
カメラのインスタンスを破棄する

プロパティ

CameraState | CameraState [get]
カメラの動作状態を取得する
PictureState | PictureState [get]
写真の撮影状況を取得する
CameraSize | CurrentPreviewSize [get]
現在設定されているストリームの画像の解像度を取得する
CameraImageFormat | CurrentPreviewImageFormat [get]
現在設定されているストリームのデータフォーマットを取得する
string | PictureFilename [get]
撮影した写真のファイルパスを取得する

イベント

EventHandler
< FrameChangedEventArgs > 		FrameChanged
ストリームの画像のフレームが変化したときに発生するイベント
Start メソッドを呼び出したスレッドとは別のスレッドで非同期に発生する
EventHandler
< PictureStateChangedEventArgs > 		PictureStateChanged
写真の撮影状況が変化したときに発生するイベント
TakePicture メソッドを呼び出したスレッドとは別のスレッドで非同期に発生する

説明

カメラを表すクラス

コンストラクタとデストラクタ

Camera ( int cameraId )

カメラを起動してインスタンスを作成するコンストラクタ
インスタンスは Dispose メソッドで破棄しなければならない
カメラは一つしか使用することができないため、別のカメラを使用するときは 現在のインスタンスを破棄してから新しいインスタンスを作成しなければならない

引数:
cameraId カメラの番号

メソッド

void Dispose ( bool disposing ) [protected]

カメラのインスタンスを破棄する

引数:
disposing インスタンスを破棄している途中かどうか
static CameraInfo GetCameraInfo ( int cameraId ) [static]

カメラの詳細情報を取得する

引数:
cameraId カメラの番号
戻り値:
カメラの詳細情報
static int GetNumberOfCameras ( ) [static]

カメラの数を取得する

戻り値:
カメラの数
void Open ( int sizeId )

指定した解像度でストリームを開く

引数:
sizeId ストリームに使用する画像の解像度の番号
void TakePicture ( int sizeId )

写真を撮影する
撮影した写真のフォーマットは JPEG である
撮影した写真はファイルに保存される
このメソッドは画像をストリーミングしているときにのみ呼び出すことができる

引数:
sizeId 撮影に使用する画像の解像度の番号


  • Sce
  • PlayStation
  • Core
  • Device
  • Camera
  • FrameChangedEventArgs
プロパティ

クラス Camera.FrameChangedEventArgs

ストリームの画像のフレームが変化したときに発生するイベントで渡される引数クラス [詳細]

すべてのメンバ一覧

プロパティ

byte[] | FrameBuffer [get, set]
フレームのデータを格納したバッファ
long | FrameCount [get, set]
ストリーミングを開始したときからのフレームの番号

説明

ストリームの画像のフレームが変化したときに発生するイベントで渡される引数クラス


  • Sce
  • PlayStation
  • Core
  • Device
  • Camera
  • PictureStateChangedEventArgs
プロパティ

クラス Camera.PictureStateChangedEventArgs

写真の撮影状況が変化したときに発生するイベントで渡される引数クラス [詳細]

すべてのメンバ一覧

プロパティ

PictureState PictureState [get, set]
写真の撮影状況

説明

写真の撮影状況が変化したときに発生するイベントで渡される引数クラス


クラス CameraImportDialog

写真を撮影するコモンダイアログクラス [詳細]

CameraImportDialogに対する継承グラフ
ICommonDialog

すべてのメンバ一覧

Public メソッド

CameraImportDialog ()
コンストラクタ
void | Dispose ()
写真撮影コモンダイアログオブジェクトを破棄する
void | Open ()
写真撮影コモンダイアログを開く
void | Abort ()
写真撮影コモンダイアログを途中で終了する

Protected メソッド

virtual void | Dispose (bool disposing)
写真撮影コモンダイアログオブジェクトを破棄する

プロパティ

string | Filename [get, set]
ローカルに保存したコンテンツのファイルパスを取得する
CommonDialogState | State [get]
写真撮影コモンダイアログの状態を取得する
CommonDialogResult | Result [get]
写真撮影コモンダイアログの結果を取得する

説明

写真を撮影するコモンダイアログクラス

メソッド

virtual void Dispose ( bool disposing ) [protected, virtual]

写真撮影コモンダイアログオブジェクトを破棄する

引数:
disposing オブジェクトを破棄している途中かどうか


  • Sce
  • PlayStation
  • Core
  • Device
  • Location
Static Public メソッド

クラス Location

位置情報を表すクラス [詳細]

すべてのメンバ一覧

Static Public メソッド

static bool | Start ()
位置情報の取得を開始する
static bool | Stop ()
位置情報の取得を停止する
static LocationData | GetData ()
位置情報を取得する
static LocationDeviceType | GetEnableDevices ()
位置情報を計測可能なデバイスを取得する

説明

位置情報を表すクラス

メソッド

static LocationData GetData ( ) [static]

位置情報を取得する

戻り値:
位置情報
参照:
LocationData
static LocationDeviceType GetEnableDevices ( ) [static]

位置情報を計測可能なデバイスを取得する

戻り値:
デバイス情報(LocationDeviceType)
static bool Start ( ) [static]

位置情報の取得を開始する

戻り値:
初期化が正しく行われていない場合に false になります。app.xml にLocationの記載がない場合など。
static bool Stop ( ) [static]

位置情報の取得を停止する

戻り値:
初期化が正しく行われていない場合に false になります。


クラス PhotoImportDialog

写真を選択するコモンダイアログクラス [詳細]

PhotoImportDialogに対する継承グラフ
ICommonDialog

すべてのメンバ一覧

Public メソッド

PhotoImportDialog ()
コンストラクタ
void | Dispose ()
写真選択コモンダイアログオブジェクトを破棄する
void | Open ()
写真選択コモンダイアログを開く
void | Abort ()
写真選択コモンダイアログを途中で終了する

Protected メソッド

virtual void | Dispose (bool disposing)
写真選択コモンダイアログオブジェクトを破棄する

プロパティ

string | Filename [get, set]
ローカルに保存したコンテンツのファイルパスを取得する
CommonDialogState | State [get]
写真選択コモンダイアログの状態を取得する
CommonDialogResult | Result [get]
写真選択コモンダイアログの結果を取得する

説明

写真を選択するコモンダイアログクラス

メソッド

virtual void Dispose ( bool disposing ) [protected, virtual]

写真選択コモンダイアログオブジェクトを破棄する

引数:
disposing オブジェクトを破棄している途中かどうか


  • Sce
  • PlayStation
  • Core
  • Device
  • CameraInfo
Public 変数

構造体 CameraInfo

カメラの詳細情報 [詳細]

すべてのメンバ一覧

Public 変数

CameraFacing Facing
カメラの向き
List< CameraSize > | SupportedPreviewSizes
ストリームに指定できる画像の解像度一覧
List< CameraSize > | SupportedPictureSizes
写真撮影に指定できる画像の解像度一覧

説明

カメラの詳細情報


構造体 CameraSize

カメラの画像の解像度 [詳細]

すべてのメンバ一覧

Public メソッド

CameraSize (int width, int height)
画像の幅と高さを指定してインスタンスを作成する

Public 変数

int | Width
画像の幅 (pixel)
int | Height
画像の高さ (pixel)

説明

カメラの画像の解像度

コンストラクタとデストラクタ

CameraSize | ( | int | width,
 |  | int | height
 | ) |  |

画像の幅と高さを指定してインスタンスを作成する

引数:
width | 画像の幅を指定する (pixel)
height | 画像の幅を指定する (pixel)


  • Sce
  • PlayStation
  • Core
  • Device
  • LocationData
プロパティ

構造体 LocationData

位置情報 [詳細]

すべてのメンバ一覧

プロパティ

bool | HasLatitude [get, set]
緯度の計測可否
double | Latitude [get, set]
緯度(deg) 有効な値は-90～+90
bool | HasLongitude [get, set]
経度の計測可否
double | Longitude [get, set]
経度(deg) 有効な値は-180～+180
bool | HasAltitude [get, set]
高度の計測可否
double | Altitude [get, set]
高度(m)
bool | HasSpeed [get, set]
速度の計測可否
double | Speed [get, set]
速度(km/h)
bool | HasTime [get, set]
時刻の計測可否
long | Time [get, set]
時刻(msec) 1970年1月1日 0時0分0秒からのUTC時刻
bool | HasBearing [get, set]
方角の計測可否
double | Bearing [get, set]
方角 北から時計回りの角度 有効な値は 0～360
bool | HasAccuracy [get, set]
精度の計測可否
double | Accuracy [get, set]
精度(m)
LocationDeviceType | DeviceType [get, set]
計測可能なデバイス

説明

位置情報


パッケージ Sce.PlayStation.Core.Environment

構成

class | Clipboard
クリップボードにアクセスするためのクラス [詳細]
interface | ICommonDialog
コモンダイアログ共通のインターフェース [詳細]
class | TextInputDialog
テキスト入力ダイアログ [詳細]
class | PersistentMemory
永続的なメモリ領域を提供するクラス [詳細]
class | Shell
システムの機能を呼び出すためのクラス [詳細]
class | RestoredEventArgs
最小化からの復帰イベントに渡ってくるデータ [詳細]
class | MinimizedEventArgs
最小化イベントで渡ってくるデータ [詳細]
class | SystemEvents
システムからのイベントを受け取るためのクラス [詳細]
class | SystemMemory
システムのメモリの状態を取得するクラス [詳細]
class | SystemParameters
システムのパラメタを受け取るためのクラス [詳細]

列挙型

enum | CommonDialogState { None = 0, Running = 1, Finished = 2 }

コモンダイアログの状態

[詳細]
enum | CommonDialogResult { OK = 0, Canceled = 1, Aborted = 2, Error = 3 }

コモンダイアログの動作結果

[詳細]
enum | TextInputMode { Normal, BasicLatin, Password }

テキスト入力の動作モード

[詳細]
enum | GamePadButtonMeaning { CrossIsEnter, CircleIsEnter }

○×ボタンの意味

[詳細]
enum | YesNoLayout { YesIsLeft, YesIsRight }

メッセージダイアログなどのYesとNoの位置

[詳細]

列挙型

enum CommonDialogResult

コモンダイアログの動作結果

列挙型の値:
OK

成功

Canceled

ユーザーによってキャンセルされた

Aborted

プログラムによって中断された

Error

エラーが発生した

enum CommonDialogState

コモンダイアログの状態

列挙型の値:
None

使われていない状態

Running

動作中

Finished

終了した

enum GamePadButtonMeaning

○×ボタンの意味

列挙型の値:
CrossIsEnter

×ボタンが決定

CircleIsEnter

○ボタンが決定

enum TextInputMode

テキスト入力の動作モード

列挙型の値:
Normal

通常の文字入力モード

BasicLatin

ASCIIのみの入力モード

Password

パスワード入力モード

enum YesNoLayout

メッセージダイアログなどのYesとNoの位置

列挙型の値:
YesIsLeft

Yesが左

YesIsRight

Yesが右


  • Sce
  • PlayStation
  • Core
  • Environment
  • Clipboard
Static Public メソッド

クラス Clipboard

クリップボードにアクセスするためのクラス [詳細]

すべてのメンバ一覧

Static Public メソッド

static void | SetText (string text)
クリップボードにテキストを格納する
static string | GetText ()
クリップボードのテキストを取得する

説明

クリップボードにアクセスするためのクラス

メソッド

static string GetText ( ) [static]

クリップボードのテキストを取得する

戻り値:
クリップボードの文字列
static void SetText ( string text ) [static]

クリップボードにテキストを格納する

引数:
text 格納する文字列


クラス MinimizedEventArgs

最小化イベントで渡ってくるデータ [詳細]

説明

最小化イベントで渡ってくるデータ


  • Sce
  • PlayStation
  • Core
  • Environment
  • PersistentMemory
Static Public メソッド

クラス PersistentMemory

永続的なメモリ領域を提供するクラス [詳細]

すべてのメンバ一覧

Static Public メソッド

static void | Write (byte[] data)
永続メモリにデータを書き込む
static byte[] | Read ()
永続メモリにデータを読み出す

説明

永続的なメモリ領域を提供するクラス

メソッド

static byte [] Read ( ) [static]

永続メモリにデータを読み出す

戻り値:
読み出したデータ (64KB)
static void Write ( byte[] data ) [static]

永続メモリにデータを書き込む

引数:
data 書き込み内容 (最大64KB)


クラス RestoredEventArgs

最小化からの復帰イベントに渡ってくるデータ [詳細]

説明

最小化からの復帰イベントに渡ってくるデータ


クラス Shell

システムの機能を呼び出すためのクラス [詳細]

すべてのメンバ一覧

構成

struct | Action
システム機能の呼び出し内容を表す構造体 [詳細]

Static Public メソッド

static void | Execute (ref Action action)
システム機能の呼び出しを実行する

説明

システムの機能を呼び出すためのクラス

メソッド

static void Execute ( ref Action action ) [static]

システム機能の呼び出しを実行する

引数:
action システム機能の呼び出し内容


  • Sce
  • PlayStation
  • Core
  • Environment
  • Shell
  • Action
Static Public メソッド

構造体 Shell.Action

システム機能の呼び出し内容を表す構造体 [詳細]

すべてのメンバ一覧

Static Public メソッド

static Action BrowserAction (string url)
ブラウザを呼ぶためのAction構造体を生成する

説明

システム機能の呼び出し内容を表す構造体

メソッド

static Action BrowserAction ( string url ) [static]

ブラウザを呼ぶためのAction構造体を生成する

引数:
url ブラウザで開くURL
戻り値:
ブラウザ呼び出しを意味するAction構造体


クラス SystemEvents

システムからのイベントを受け取るためのクラス [詳細]

すべてのメンバ一覧

Public メソッド

delegate void | RestoredEventHandler (object sender, RestoredEventArgs e)
最小化からの復帰イベントハンドラの型
delegate void | MinimizedEventHandler (object sender, MinimizedEventArgs e)
最小化イベントハンドラの型

Static Public メソッド

static void | CheckEvents ()
システムのイベントをチェックして状態を更新する

イベント

static RestoredEventHandler | OnRestored
最小化からの復帰イベントハンドラ
static MinimizedEventHandler | OnMinimized
最小化イベントハンドラ

説明

システムからのイベントを受け取るためのクラス

メソッド

delegate void MinimizedEventHandler | ( | object | sender,
 |  | MinimizedEventArgs | e
 | ) |  |

最小化イベントハンドラの型

引数:
sender | 送信元オブジェクト
e | イベントデータ
delegate void RestoredEventHandler | ( | object | sender,
 |  | RestoredEventArgs | e
 | ) |  |

最小化からの復帰イベントハンドラの型

引数:
sender | 送信元オブジェクト
e | イベントデータ


  • Sce
  • PlayStation
  • Core
  • Environment
  • SystemMemory
Static Public メソッド

クラス SystemMemory

システムのメモリの状態を取得するクラス [詳細]

すべてのメンバ一覧

Static Public メソッド

static void Dump ()
デバッグ情報を出力します(内容は将来変更される場合があります)。

説明

システムのメモリの状態を取得するクラス


  • Sce
  • PlayStation
  • Core
  • Environment
  • SystemParameters
プロパティ

クラス SystemParameters

システムのパラメタを受け取るためのクラス [詳細]

すべてのメンバ一覧

プロパティ

static string | Language [get]
システムの言語設定
static GamePadButtonMeaning | GamePadButtonMeaning [get]
○×ボタンの意味
static YesNoLayout | YesNoLayout [get]
メッセージダイアログなどのYesとNoの位置
static float | DisplayDpiX [get]
ディスプレイのインチ毎のドット数 (X軸方向)
static float | DisplayDpiY [get]
ディスプレイのインチ毎のドット数 (Y軸方向)

説明

システムのパラメタを受け取るためのクラス

プロパティ

GamePadButtonMeaning GamePadButtonMeaning [static, get]

○×ボタンの意味

○と×のボタンの意味は、地域によって異なります。このプロパティで、システムに設定されている○×ボタンの意味を取得することができます。

string Language [static, get]

システムの言語設定

このプロパティが取りうる値は以下の通りです。

  • ja-JP : 日本語
  • en-US : 英語(US)
  • en-GB : 英語(UK)
  • fr-FR : フランス語
  • es-ES : スペイン語
  • de-DE : ドイツ語
  • it-IT : イタリア語
  • nl-NL : オランダ語
  • pt-PT : ポルトガル語
  • pt-BR : ポルトガル語(ブラジル)
  • ru-RU : ロシア語
  • ko-KR : 韓国語
  • zh-Hant : 中国語(繁体字)
  • zh-Hans : 中国語(簡体字)
  • fi_FI : フィンランド語
  • sv-SE : スウェーデン語
  • da-DK : デンマーク語
  • nb-NO : ノルウェー語
  • pl-PL : ポーランド語

将来新たな言語をサポートするためにこの範囲が拡張され、アプリケーションにとって未知の値が返るようになる可能性があります。アプリケーションは、このプロパティが未知の値であった場合でも、正常に動作するように記述してください。

YesNoLayout YesNoLayout [static, get]

メッセージダイアログなどのYesとNoの位置

動作プラットフォームによって、メッセージダイアログなどの肯定的な意味のボタンと、否定的な意味のボタンの左右の位置が、異なります。このプロパティで、動作プラットフォームの自然なレイアウトを取得することができます。


クラス TextInputDialog

テキスト入力ダイアログ [詳細]

TextInputDialogに対する継承グラフ
ICommonDialog

すべてのメンバ一覧

Public メソッド

TextInputDialog ()
TextInputDialog のコンストラクタ
void | Dispose ()
TextInputDialog のアンマネージドリソースを解放する
void | Open ()
テキスト入力ダイアログを開く
void | Abort ()
テキスト入力ダイアログを中断する

プロパティ

CommonDialogState | State [get]
ダイアログの状態
CommonDialogResult | Result [get]
ダイアログの動作結果
TextInputMode | Mode [get, set]
テキスト入力モード
string | Text [get, set]
編集対象のテキスト

説明

テキスト入力ダイアログ

メソッド

void Abort ( )

テキスト入力ダイアログを中断する

メインスレッドでのみ呼び出すことができます。

ICommonDialogを実装しています。

void Open ( )

テキスト入力ダイアログを開く

メインスレッドでのみ呼び出すことができます。

ICommonDialogを実装しています。

プロパティ

CommonDialogResult Result [get]

ダイアログの動作結果

メインスレッドでのみ取得することができます。

ICommonDialogを実装しています。

CommonDialogState State [get]

ダイアログの状態

メインスレッドでのみ取得することができます。

ICommonDialogを実装しています。

string Text [get, set]

編集対象のテキスト

Open()を呼び出す前に Text を設定しておくことで、テキスト入力ダイアログの初期状態の文字列を指定することができます。また、State が Finished になり、かつ Result が OK であることを確認した後に Text を取得することで、テキストの編集結果を取得することができます。


インタフェース ICommonDialog

コモンダイアログ共通のインターフェース [詳細]

ICommonDialogに対する継承グラフ
CameraImportDialog PhotoImportDialog TextInputDialog InAppPurchaseDialog

すべてのメンバ一覧

Public メソッド

void | Open ()
コモンダイアログを開く
void | Abort ()
コモンダイアログを中断する

プロパティ

CommonDialogState | State [get]
コモンダイアログの状態
CommonDialogResult | Result [get]
コモンダイアログの動作結果

説明

コモンダイアログ共通のインターフェース

メソッド

void Abort ( )

コモンダイアログを中断する

メインスレッドでのみ呼び出すことができます。

TextInputDialog, InAppPurchaseDialog, CameraImportDialog, と PhotoImportDialogで実装されています。

void Open ( )

コモンダイアログを開く

メインスレッドでのみ呼び出すことができます。

TextInputDialog, InAppPurchaseDialog, CameraImportDialog, と PhotoImportDialogで実装されています。

プロパティ

CommonDialogResult Result [get]

コモンダイアログの動作結果

メインスレッドでのみ取得することができます。

TextInputDialog, InAppPurchaseDialog, CameraImportDialog, と PhotoImportDialogで実装されています。

CommonDialogState State [get]

コモンダイアログの状態

メインスレッドでのみ取得することができます。

TextInputDialog, InAppPurchaseDialog, CameraImportDialog, と PhotoImportDialogで実装されています。


パッケージ Sce.PlayStation.Core.Graphics

構成

class | GraphicsContext
グラフィクスコンテキストを表すクラス [詳細]
struct | Primitive
プリミティブを表す構造体 [詳細]
struct | CullFace
バックフェースカリングを表す構造体 [詳細]
struct | BlendFunc
アルファブレンド関数を表す構造体 [詳細]
struct | DepthFunc
デプステスト関数を表す構造体 [詳細]
struct | PolygonOffset
ポリゴンオフセットを表す構造体 [詳細]
struct | StencilFunc
ステンシルテスト関数を表す構造体 [詳細]
struct | StencilOp
ステンシルテスト操作を表す構造体 [詳細]
struct | GraphicsCaps
グラフィクス能力を表すクラス [詳細]
class | ShaderProgram
シェーダープログラムを表すクラス [詳細]
class | ShaderProgramOption
シェーダープログラムの作成オプションを表すクラス [詳細]
class | VertexBuffer
頂点バッファを表すクラス [詳細]
class | PixelBuffer
ピクセルバッファを表す基底クラス [詳細]
class | Texture
テクスチャを表す基底クラス [詳細]
class | Texture2D
2Dテクスチャを表すクラス [詳細]
class | TextureCube
キューブテクスチャを表すクラス [詳細]
class | ColorBuffer
カラーバッファを表すクラス [詳細]
class | DepthBuffer
デプスバッファを表すクラス [詳細]
struct | TextureFilter
テクスチャフィルタを表す構造体 [詳細]
struct | TextureWrap
テクスチャラップを表す構造体 [詳細]
class | FrameBuffer
フレームバッファを表すクラス [詳細]
struct | RenderTarget
レンダリング結果の格納先を表す構造体 [詳細]

列挙型

enum ClearMask {
None = 0x00, Color = 0x01, Depth = 0x02, Stencil = 0x04,
All = 0x07
}

バッファのクリアマスク

[詳細]
enum DrawMode {
Points, Lines, LineStrip, Triangles,
TriangleStrip, TriangleFan
}

プリミティブの描画モード

[詳細]
enum EnableMode {
None = 0x00000000, ScissorTest = 0x00000001, CullFace = 0x00000002, Blend = 0x00000004,
DepthTest = 0x00000008, PolygonOffsetFill = 0x00000010, StencilTest = 0x00000020, Dither = 0x00000040,
All = 0x0000007f
}

有効または無効にするグラフィクス機能

[詳細]
enum | CullFaceMode { None, Front, Back, FrontAndBack }

バックフェースカリングのモード

[詳細]
enum | CullFaceDirection { Cw, Ccw }

バックフェースカリングの表面方向

[詳細]
enum | BlendFuncMode { Add, Subtract, ReverseSubtract }

アルファブレンド関数のモード

[詳細]
enum BlendFuncFactor {
Zero, One, SrcColor, OneMinusSrcColor,
SrcAlpha, OneMinusSrcAlpha, DstColor, OneMinusDstColor,
DstAlpha, OneMinusDstAlpha, SrcAlphaSaturate
}

アルファブレンド関数の係数

[詳細]
enum DepthFuncMode {
Always, Never, Equal, NotEqual,
Less, Greater, LEqual, GEqual
}

デプステスト関数のモード

[詳細]
enum StencilFuncMode {
Always, Never, Equal, NotEqual,
Less, Greater, LEqual, GEqual
}

ステンシルテスト関数のモード

[詳細]
enum StencilOpMode {
Keep, Zero, Replace, Invert,
Incr, Decr, IncrWrap, DecrWrap
}

ステンシルテスト操作のモード

[詳細]
enum ColorMask {
None = 0x00, R = 0x01, G = 0x02, B = 0x04,
A = 0x08, Rgb = 0x07, Rgba = 0x0f
}

カラーの書き込みマスク

[詳細]
enum ShaderUniformType {
None = 0x0000, Float = 0x0100, Float2 = 0x0101, Float3 = 0x0102,
Float4 = 0x0103, Float2x2 = 0x0111, Float3x3 = 0x0122, Float4x4 = 0x0133,
Int = 0x0400, Int2 = 0x0401, Int3 = 0x0402, Int4 = 0x0403,
Bool = 0x0300, Bool2 = 0x0301, Bool3 = 0x0302, Bool4 = 0x0303,
Sampler2D = 0x8001, SamplerCube = 0x8002
}

ユニフォーム変数のタイプ

[詳細]
enum ShaderAttributeType {
None = 0x0000, Float = 0x0100, Float2 = 0x0101, Float3 = 0x0102,
Float4 = 0x0103
}

アトリビュート変数のタイプ

[詳細]
enum VertexFormat {
None = 0x0000, Float = 0x0100, Float2 = 0x0101, Float3 = 0x0102,
Float4 = 0x0103, Half = 0x0200, Half2 = 0x0201, Half3 = 0x0202,
Half4 = 0x0203, Short = 0x0600, Short2 = 0x0601, Short3 = 0x0602,
Short4 = 0x0603, UShort = 0x0700, UShort2 = 0x0701, UShort3 = 0x0702,
UShort4 = 0x0703, Byte = 0x0800, Byte2 = 0x0801, Byte3 = 0x0802,
Byte4 = 0x0803, UByte = 0x0900, UByte2 = 0x0901, UByte3 = 0x0902,
UByte4 = 0x0903, ShortN = 0x1600, Short2N = 0x1601, Short3N = 0x1602,
Short4N = 0x1603, UShortN = 0x1700, UShort2N = 0x1701, UShort3N = 0x1702,
UShort4N = 0x1703, ByteN = 0x1800, Byte2N = 0x1801, Byte3N = 0x1802,
Byte4N = 0x1803, UByteN = 0x1900, UByte2N = 0x1901, UByte3N = 0x1902,
UByte4N = 0x1903
}

頂点フォーマット

[詳細]
enum PixelBufferType {
None, Texture2D, TextureCube, ColorBuffer,
DepthBuffer
}

ピクセルバッファのタイプ

[詳細]
enum | PixelBufferOption { None = 0x00, Renderable = 0x01 }

ピクセルバッファの作成オプション

[詳細]
enum PixelFormat {
None, Rgba, RgbaH, Rgba4444,
Rgba5551, Rgb565, LuminanceAlpha, LuminanceAlphaH,
Luminance, LuminanceH, Alpha, AlphaH,
Depth16, Depth24, Depth16Stencil8, Depth24Stencil8,
Dxt1, Dxt2, Dxt3, Dxt4,
Dxt5
}

ピクセルフォーマット

[詳細]
enum | TextureFilterMode { Nearest, Linear, Disabled }

テクスチャフィルタのモード

[詳細]
enum | TextureWrapMode { ClampToEdge, Repeat }

テクスチャラップのモード

[詳細]
enum TextureCubeFace {
PositiveX, NegativeX, PositiveY, NegativeY,
PositiveZ, NegativeZ
}

キューブテクスチャの面

[詳細]
enum | MultiSampleMode { None, Msaa2x, Msaa4x }

マルチサンプルモード

[詳細]

列挙型

enum BlendFuncFactor

アルファブレンド関数の係数

列挙型の値:
Zero

( 0, 0, 0, 0 )

One

( 1, 1, 1, 1 )

SrcColor

( Rs, Gs, Bs, As )

OneMinusSrcColor

( 1-Rs, 1-Gs, 1-Bs, 1-As )

SrcAlpha

( As, As, As, As )

OneMinusSrcAlpha

( 1-As, 1-As, 1-As, 1-As )

DstColor

( Rd, Gd, Bd, Ad )

OneMinusDstColor

( 1-Rd, 1-Gd, 1-Bd, 1-Ad )

DstAlpha

( Ad, Ad, Ad, Ad )

OneMinusDstAlpha

( 1-Ad, 1-Ad, 1-Ad, 1-Ad )

SrcAlphaSaturate

( min(As,1-Ad), min(As,1-Ad), min(As,1-Ad), 1 )

enum BlendFuncMode

アルファブレンド関数のモード

列挙型の値:
Add

Sc*Sf+Dc*Df.

Subtract

Sc*Sf-Dc*Df.

ReverseSubtract

Dc*Df-Sc*Sf.

enum ClearMask

バッファのクリアマスク

列挙型の値:
None

なし

Color

カラーバッファ

Depth

デプスバッファ

Stencil

ステンシルバッファ

All

すべてのバッファ

enum ColorMask

カラーの書き込みマスク

列挙型の値:
None

なし

R

R要素

G

G要素

B

B要素

A

A要素

Rgb

RGB要素

Rgba

RGBA要素

enum CullFaceDirection

バックフェースカリングの表面方向

列挙型の値:
Cw

時計回り

Ccw

反時計回り

enum CullFaceMode

バックフェースカリングのモード

列挙型の値:
None

なし

Front

表面

Back

裏面

FrontAndBack

両面

enum DepthFuncMode

デプステスト関数のモード

列挙型の値:
Always

つねに合格

Never

つねに不合格

Equal

デプス値 == デプスバッファ値ならば合格

NotEqual

デプス値 != デプスバッファ値ならば合格

Less

デプス値 < デプスバッファ値ならば合格

Greater

デプス値 > デプスバッファ値ならば合格

LEqual

デプス値 <= デプスバッファ値ならば合格

GEqual

デプス値 >= デプスバッファ値ならば合格

enum DrawMode

プリミティブの描画モード

列挙型の値:
Points

ポイントリスト

Lines

ラインリスト

LineStrip

ラインストリップ

Triangles

三角形リスト

TriangleStrip

三角形ストリップ

TriangleFan

三角形ファン

enum EnableMode

有効または無効にするグラフィクス機能

列挙型の値:
None

なし

ScissorTest

シザーテスト

CullFace

バックフェースカリング

Blend

アルファブレンド

DepthTest

デプステスト

PolygonOffsetFill

ポリゴンオフセット

StencilTest

ステンシルテスト

Dither

ディザリング

All

すべての機能

enum MultiSampleMode

マルチサンプルモード

列挙型の値:
None

マルチサンプルなし

Msaa2x

マルチサンプルx2

Msaa4x

マルチサンプルx4

enum PixelBufferOption

ピクセルバッファの作成オプション

列挙型の値:
None

なし

Renderable

レンダリング可能

enum PixelBufferType

ピクセルバッファのタイプ

列挙型の値:
None

なし

Texture2D

2Dテクスチャ

TextureCube

キューブテクスチャ

ColorBuffer

カラーバッファ

DepthBuffer

デプスバッファ

enum PixelFormat

ピクセルフォーマット

列挙型の値:
None

なし

Rgba

RGBA (byte)

RgbaH

RGBA (half float)

Rgba4444

RGBA (ushort 4:4:4:4)

Rgba5551

RGBA (ushort 5:5:5:1)

Rgb565

RGB (ushort 5:6:5)

LuminanceAlpha

輝度とアルファ (byte)

LuminanceAlphaH

輝度とアルファ (half float)

Luminance

輝度 (byte)

LuminanceH

輝度 (half float)

Alpha

アルファ (byte)

AlphaH

アルファ (half float)

Depth16

デプス 16bit

Depth24

デプス 24bit

Depth16Stencil8

デプス 16bit ステンシル 8bit

Depth24Stencil8

デプス 24bit ステンシル 8bit

Dxt1

S3TC 圧縮テクスチャ (DXT1)

Dxt2

S3TC 圧縮テクスチャ (DXT2)

Dxt3

S3TC 圧縮テクスチャ (DXT3)

Dxt4

S3TC 圧縮テクスチャ (DXT4)

Dxt5

S3TC 圧縮テクスチャ (DXT5)

enum ShaderAttributeType

アトリビュート変数のタイプ

列挙型の値:
None

なし

Float

スカラ (float)

Float2

2次元ベクトル (float)

Float3

3次元ベクトル (float)

Float4

4次元ベクトル (float)

enum ShaderUniformType

ユニフォーム変数のタイプ

列挙型の値:
None

なし

Float

スカラ (float)

Float2

2次元ベクトル (float)

Float3

3次元ベクトル (float)

Float4

4次元ベクトル (float)

Float2x2

2次元行列 (float)

Float3x3

3次元行列 (float)

Float4x4

4次元行列 (float)

Int

スカラ (int)

Int2

2次元ベクトル (int)

Int3

3次元ベクトル (int)

Int4

4次元ベクトル (int)

Bool

スカラ (bool)

Bool2

2次元ベクトル (bool)

Bool3

3次元ベクトル (bool)

Bool4

4次元ベクトル (bool)

Sampler2D

2Dテクスチャサンプラ

SamplerCube

キューブテクスチャサンプラ

enum StencilFuncMode

ステンシルテスト関数のモード

列挙型の値:
Always

つねに合格

Never

つねに不合格

Equal

参照値 == ステンシルバッファ値ならば合格

NotEqual

参照値 != ステンシルバッファ値ならば合格

Less

参照値 < ステンシルバッファ値ならば合格

Greater

参照値 > ステンシルバッファ値ならば合格

LEqual

参照値 <= ステンシルバッファ値ならば合格

GEqual

参照値 >= ステンシルバッファ値ならば合格

enum StencilOpMode

ステンシルテスト操作のモード

列挙型の値:
Keep

ステンシルバッファ値を維持する

Zero

ステンシルバッファ値をゼロにセットする

Replace

ステンシルバッファ値を参照値にセットする

Invert

ステンシルバッファ値をビットごとに反転する

Incr

ステンシルバッファ値をインクリメントする (クランプあり)

Decr

ステンシルバッファ値をデクリメントする (クランプあり)

IncrWrap

ステンシルバッファ値をインクリメントする (クランプなし)

DecrWrap

ステンシルバッファ値をデクリメントする (クランプなし)

enum TextureCubeFace

キューブテクスチャの面

列挙型の値:
PositiveX

X軸の正方向

NegativeX

X軸の負方向

PositiveY

Y軸の正方向

NegativeY

Y軸の負方向

PositiveZ

Z軸の正方向

NegativeZ

Z軸の負方向

enum TextureFilterMode

テクスチャフィルタのモード

列挙型の値:
Nearest

ニアレストモード

Linear

リニアモード

Disabled

無効

enum TextureWrapMode

テクスチャラップのモード

列挙型の値:
ClampToEdge

クランプモード

Repeat

リピートモード

enum VertexFormat

頂点フォーマット

列挙型の値:
None

なし

Float

スカラ (float)

Float2

2次元ベクトル (float)

Float3

3次元ベクトル (float)

Float4

4次元ベクトル (float)

Half

スカラ (half float)

Half2

2次元ベクトル (half float)

Half3

3次元ベクトル (half float)

Half4

4次元ベクトル (half float)

Short

スカラ (short)

Short2

2次元ベクトル (short)

Short3

3次元ベクトル (short)

Short4

4次元ベクトル (short)

UShort

スカラ (ushort)

UShort2

2次元ベクトル (ushort)

UShort3

3次元ベクトル (ushort)

UShort4

4次元ベクトル (ushort)

Byte

スカラ (sbyte)

Byte2

2次元ベクトル (sbyte)

Byte3

3次元ベクトル (sbyte)

Byte4

4次元ベクトル (sbyte)

UByte

スカラ (byte)

UByte2

2次元ベクトル (byte)

UByte3

3次元ベクトル (byte)

UByte4

4次元ベクトル (byte)

ShortN

スカラ (normalized short)

Short2N

2次元ベクトル (normalized short)

Short3N

3次元ベクトル (normalized short)

Short4N

4次元ベクトル (normalized short)

UShortN

スカラ (normalized ushort)

UShort2N

2次元ベクトル (normalized ushort)

UShort3N

3次元ベクトル (normalized ushort)

UShort4N

4次元ベクトル (normalized ushort)

ByteN

スカラ (normalized sbyte)

Byte2N

2次元ベクトル (normalized sbyte)

Byte3N

3次元ベクトル (normalized sbyte)

Byte4N

4次元ベクトル (normalized sbyte)

UByteN

スカラ (normalized byte)

UByte2N

2次元ベクトル (normalized byte)

UByte3N

3次元ベクトル (normalized byte)

UByte4N

4次元ベクトル (normalized byte)


クラス ColorBuffer

カラーバッファを表すクラス [詳細]

ColorBufferに対する継承グラフ
PixelBuffer

すべてのメンバ一覧

Public メソッド

ColorBuffer (int width, int height, PixelFormat format)
カラーバッファを作成する
override Object ShallowClone ()
カラーバッファを複製する

Protected メソッド

ColorBuffer (ColorBuffer buffer)
カラーバッファを複製する

説明

カラーバッファを表すクラス

コンストラクタとデストラクタ

ColorBuffer | ( | int | width,
 |  | int | height,
 |  | PixelFormat | format
 | ) |  |

カラーバッファを作成する

引数:
width | カラーバッファの幅
height | カラーバッファの高さ
format | ピクセルフォーマット

カラーバッファを作成します。ピクセルフォーマットには Rgba, Rgba4444, Rgba5551, Rgb565 が指定できます。

ColorBuffer ( ColorBuffer buffer ) [protected]

カラーバッファを複製する

引数:
buffer カラーバッファ

カラーバッファを複製します。複製されたカラーバッファはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

メソッド

override Object ShallowClone ( ) [virtual]

カラーバッファを複製する

戻り値:
カラーバッファの複製

カラーバッファを複製します。複製されたカラーバッファはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

PixelBufferを再定義しています。


クラス DepthBuffer

デプスバッファを表すクラス [詳細]

DepthBufferに対する継承グラフ
PixelBuffer

すべてのメンバ一覧

Public メソッド

DepthBuffer (int width, int height, PixelFormat format)
デプスバッファを作成する
override Object ShallowClone ()
デプスバッファを複製する

Protected メソッド

DepthBuffer (DepthBuffer buffer)
デプスバッファを複製する

説明

デプスバッファを表すクラス

コンストラクタとデストラクタ

DepthBuffer | ( | int | width,
 |  | int | height,
 |  | PixelFormat | format
 | ) |  |

デプスバッファを作成する

引数:
width | デプスバッファの幅
height | デプスバッファの高さ
format | ピクセルフォーマット

デプスバッファを作成します。ピクセルフォーマットには Depth16, Depth24, Depth16Stencil8, Depth24Stencil8 が指定できます。指定されたフォーマットがデバイスで利用可能でない場合は、指定されたフォーマットに近い別のフォーマットが使用されます。

DepthBuffer ( DepthBuffer buffer ) [protected]

デプスバッファを複製する

引数:
buffer デプスバッファ

デプスバッファを複製します。複製されたデプスバッファはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

メソッド

override Object ShallowClone ( ) [virtual]

デプスバッファを複製する

戻り値:
デプスバッファの複製

デプスバッファを複製します。複製されたデプスバッファはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

PixelBufferを再定義しています。


クラス FrameBuffer

フレームバッファを表すクラス [詳細]

ScreenBufferに継承されています。

すべてのメンバ一覧

Public メソッド

FrameBuffer ()
フレームバッファを作成する
virtual Object | ShallowClone ()
フレームバッファを複製する
void | Dispose ()
フレームバッファのアンマネージドリソースを解放する
RenderTarget GetColorTarget ()
カラーの格納先を取得する
void | SetColorTarget (RenderTarget target)
カラーの格納先を設定する
void | SetColorTarget (ColorBuffer buffer)
カラーの格納先を設定する (カラーバッファ用)
void | SetColorTarget (Texture2D texture, int level)
カラーの格納先を設定する (2Dテクスチャ用)
void | SetColorTarget (TextureCube texture, int level, TextureCubeFace cubeFace)
カラーの格納先を設定する (キューブテクスチャ用)
RenderTarget GetDepthTarget ()
デプスの格納先を取得する
void | SetDepthTarget (RenderTarget target)
デプスの格納先を設定する
void | SetDepthTarget (DepthBuffer buffer)
デプスの格納先を設定する (デプスバッファ用)

Protected メソッド

FrameBuffer (FrameBuffer buffer)
フレームバッファを複製する

プロパティ

bool | Status [get]
フレームバッファの状態 (レンダリング可能ならばtrue)
int | Width [get]
フレームバッファの幅
int | Height [get]
フレームバッファの高さ
float | AspectRatio [get]
フレームバッファのアスペクト比 (width/height)
ImageRect | Rectangle [get]
フレームバッファの全体サイズ矩形 (0,0,width,height)
PixelFormat | ColorFormat [get]
フレームバッファのカラーフォーマット
PixelFormat | DepthFormat [get]
フレームバッファのデプスフォーマット
MultiSampleMode | MultiSampleMode [get]
フレームバッファのマルチサンプルモード

説明

フレームバッファを表すクラス

コンストラクタとデストラクタ

FrameBuffer ( )

フレームバッファを作成する

フレームバッファを作成します。カラーやデプスの格納先を設定して使用してください。

FrameBuffer ( FrameBuffer buffer ) [protected]

フレームバッファを複製する

引数:
buffer フレームバッファ

フレームバッファを複製します。複製されたフレームバッファはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

メソッド

RenderTarget GetColorTarget ( )

カラーの格納先を取得する

戻り値:
カラーの格納先を表す構造体
RenderTarget GetDepthTarget ( )

デプスの格納先を取得する

戻り値:
デプスの格納先を表す構造体
void SetColorTarget | ( | TextureCube | texture,
 |  | int | level,
 |  | TextureCubeFace | cubeFace
 | ) |  |

カラーの格納先を設定する (キューブテクスチャ用)

引数:
texture | キューブテクスチャ (nullならば解除)
level | ミップマップレベル (0～LevelCount-1)
cubeFace | キューブ面

カラーの格納先にキューブテクスチャを設定します。テクスチャは Renderable オプションを指定して作成されている必要があります。

void SetColorTarget | ( | Texture2D | texture,
 |  | int | level
 | ) |  |

カラーの格納先を設定する (2Dテクスチャ用)

引数:
texture | 2Dテクスチャ (nullならば解除)
level | ミップマップレベル (0～LevelCount-1)

カラーの格納先に2Dテクスチャを設定します。テクスチャは Renderable オプションを指定して作成されている必要があります。

void SetColorTarget ( RenderTarget target )

カラーの格納先を設定する

引数:
target カラーの格納先を表す構造体

カラーの格納先を構造体で設定します。テクスチャを格納先に設定する場合は、テクスチャが Renderable オプションを指定して作成されている必要があります。

void SetColorTarget ( ColorBuffer buffer )

カラーの格納先を設定する (カラーバッファ用)

引数:
buffer カラーバッファ (nullならば解除)

カラーの格納先にカラーバッファを設定します。

void SetDepthTarget ( RenderTarget target )

デプスの格納先を設定する

引数:
target デプスの格納先を表す構造体

デプスの格納先を構造体で設定します。

void SetDepthTarget ( DepthBuffer buffer )

デプスの格納先を設定する (デプスバッファ用)

引数:
buffer デプスバッファ (nullならば解除)

デプスの格納先にデプスバッファを設定します。

virtual Object ShallowClone ( ) [virtual]

フレームバッファを複製する

戻り値:
フレームバッファの複製

フレームバッファを複製します。複製されたフレームバッファはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。


クラス GraphicsContext

グラフィクスコンテキストを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

GraphicsContext ()
グラフィクスコンテキストを作成する
GraphicsContext (int width, int height, PixelFormat colorFormat, PixelFormat depthFormat, MultiSampleMode multiSampleMode)
グラフィクスコンテキストを作成する (スクリーンパラメータあり)
void | Dispose ()
グラフィクスコンテキストのアンマネージドリソースを解放する
void | SwapBuffers ()
スクリーンを更新する
void | Clear ()
フレームバッファをクリアする
void | Clear (ClearMask mask)
フレームバッファをクリアする (マスクあり)
void | DrawArrays (DrawMode mode, int first, int count)
プリミティブを描画する
void | DrawArrays (DrawMode mode, int first, int count, int repeat)
プリミティブを描画する (複数プリミティブ用)
void | DrawArrays (Primitive[] primitives)
プリミティブを描画する (プリミティブ配列用)
void | DrawArrays (Primitive[] primitives, int first, int count)
プリミティブを描画する (プリミティブ配列用、範囲あり)
void | DrawArraysInstanced (DrawMode mode, int first, int count, int instFirst, int instCount)
プリミティブを描画する (インスタンス描画用)
void | ReadPixels (byte[] pixels, PixelFormat format, int sx, int sy, int sw, int sh)
フレームバッファのピクセルを読み出す
void | ReadPixels (Texture2D texture, int level, int dx, int dy, int sx, int sy, int sw, int sh)
フレームバッファのピクセルを読み出す (2Dテクスチャにコピー)
void | ReadPixels (TextureCube texture, int level, TextureCubeFace cubeFace, int dx, int dy, int sx, int sy, int sw, int sh)
フレームバッファのピクセルを読み出す (キューブテクスチャにコピー)
ShaderProgram GetShaderProgram ()
シェーダープログラムを取得する
void | SetShaderProgram (ShaderProgram program)
シェーダープログラムを設定する
VertexBuffer | GetVertexBuffer (int index)
頂点バッファを取得する
void | SetVertexBuffer (int index, VertexBuffer buffer)
頂点バッファを設定する
Texture | GetTexture (int index)
テクスチャを取得する
void | SetTexture (int index, Texture texture)
テクスチャを設定する
FrameBuffer GetFrameBuffer ()
フレームバッファを取得する
void | SetFrameBuffer (FrameBuffer buffer)
フレームバッファを設定する
EnableMode GetEnableMode ()
各グラフィクス機能が有効かどうかをあらわすフラグの論理和を取得する
void | SetEnableMode (EnableMode mode)
各グラフィクス機能が有効かどうかをあらわすフラグの論理和を設定する
bool | IsEnabled (EnableMode mode)
指定されたグラフィクス機能が有効かどうかを取得する
void | Enable (EnableMode mode, bool status)
指定されたグラフィクス機能を有効または無効にする
void | Enable (EnableMode mode)
指定されたグラフィクス機能を有効にする
void | Disable (EnableMode mode)
指定されたグラフィクス機能を無効にする
ImageRect GetScissor ()
シザーテストの矩形を取得する
void | SetScissor (ImageRect rectangle)
シザーテストの矩形を設定する
void | SetScissor (int x, int y, int w, int h)
シザーテストの矩形を設定する
ImageRect GetViewport ()
ビューポートの矩形を取得する
void | SetViewport (ImageRect rectangle)
ビューポートの矩形を設定する
void | SetViewport (int x, int y, int w, int h)
ビューポートの矩形を設定する
Vector2 GetDepthRange ()
デプス値の範囲を取得する
void | SetDepthRange (Vector2 range)
デプス値の範囲を設定する
void | SetDepthRange (float min, float max)
デプス値の範囲を設定する
Vector4 GetClearColor ()
フレームバッファのクリアで使用されるカラーを取得する
void | SetClearColor (Vector4 color)
フレームバッファのクリアで使用されるカラーを設定する
void | SetClearColor (float r, float g, float b, float a)
フレームバッファのクリアで使用されるカラーを設定する
void | SetClearColor (int r, int g, int b, int a)
フレームバッファのクリアで使用されるカラーを設定する
float | GetClearDepth ()
フレームバッファのクリアで使用されるデプス値を取得する
void | SetClearDepth (float depth)
フレームバッファのクリアで使用されるデプス値を設定する
int | GetClearStencil ()
フレームバッファのクリアで使用されるステンシル値を取得する
void | SetClearStencil (int stencil)
フレームバッファのクリアで使用されるステンシル値を設定する
CullFace GetCullFace ()
バックフェースカリングを取得する
void | SetCullFace (CullFace face)
バックフェースカリングを設定する
void | SetCullFace (CullFaceMode mode, CullFaceDirection direction)
バックフェースカリングを設定する
BlendFunc GetBlendFunc ()
アルファブレンド関数を取得する
void | SetBlendFunc (BlendFunc func)
アルファブレンド関数を設定する
void | SetBlendFunc (BlendFuncMode mode, BlendFuncFactor srcFactor, BlendFuncFactor dstFactor)
アルファブレンド関数を設定する
BlendFunc GetBlendFuncRgb ()
アルファブレンド関数を取得する (RGBチャンネル用)
void | SetBlendFuncRgb (BlendFunc func)
アルファブレンド関数を設定する (RGBチャンネル用)
void | SetBlendFuncRgb (BlendFuncMode mode, BlendFuncFactor srcFactor, BlendFuncFactor dstFactor)
アルファブレンド関数を設定する (RGBチャンネル用)
BlendFunc GetBlendFuncAlpha ()
アルファブレンド関数を取得する (アルファチャンネル用)
void | SetBlendFuncAlpha (BlendFunc func)
アルファブレンド関数を設定する (アルファチャンネル用)
void | SetBlendFuncAlpha (BlendFuncMode mode, BlendFuncFactor srcFactor, BlendFuncFactor dstFactor)
アルファブレンド関数を設定する (アルファチャンネル用)
DepthFunc GetDepthFunc ()
デプステスト関数を取得する
void | SetDepthFunc (DepthFunc func)
デプステスト関数を設定する
void | SetDepthFunc (DepthFuncMode mode, bool writeMask)
デプステスト関数を設定する
PolygonOffset GetPolygonOffset ()
ポリゴンオフセットを取得する
void | SetPolygonOffset (PolygonOffset offset)
ポリゴンオフセットを設定する
void | SetPolygonOffset (float factor, float units)
ポリゴンオフセットを設定する
StencilFunc GetStencilFunc ()
ステンシルテスト関数を取得する
void | SetStencilFunc (StencilFunc func)
ステンシルテスト関数を設定する
void | SetStencilFunc (StencilFuncMode mode, int reference, int readMask, int writeMask)
ステンシルテスト関数を設定する
StencilOp GetStencilOp ()
ステンシルテスト操作を取得する
void | SetStencilOp (StencilOp op)
ステンシルテスト操作を設定する
void | SetStencilOp (StencilOpMode fail, StencilOpMode zFail, StencilOpMode zPass)
ステンシルテスト操作を設定する
StencilFunc GetStencilFuncFront ()
ステンシルテスト関数を取得する (表面用)
void | SetStencilFuncFront (StencilFunc func)
ステンシルテスト関数を設定する (表面用)
void | SetStencilFuncFront (StencilFuncMode mode, int reference, int readMask, int writeMask)
ステンシルテスト関数を設定する (表面用)
StencilOp GetStencilOpFront ()
ステンシルテスト操作を取得する (表面用)
void | SetStencilOpFront (StencilOp op)
ステンシルテスト操作を設定する (表面用)
void | SetStencilOpFront (StencilOpMode fail, StencilOpMode zFail, StencilOpMode zPass)
ステンシルテスト操作を設定する (表面用)
StencilFunc GetStencilFuncBack ()
ステンシルテスト関数を取得する (裏面用)
void | SetStencilFuncBack (StencilFunc func)
ステンシルテスト関数を設定する (裏面用)
void | SetStencilFuncBack (StencilFuncMode mode, int reference, int readMask, int writeMask)
ステンシルテスト関数を設定する (裏面用)
StencilOp GetStencilOpBack ()
ステンシルテスト操作を取得する (裏面用)
void | SetStencilOpBack (StencilOp op)
ステンシルテスト操作を設定する (裏面用)
void | SetStencilOpBack (StencilOpMode fail, StencilOpMode zFail, StencilOpMode zPass)
ステンシルテスト操作を設定する (裏面用)
ColorMask GetColorMask ()
カラーの書き込みマスクを取得する
void | SetColorMask (ColorMask mask)
カラーの書き込みマスクを設定する
float | GetLineWidth ()
ライン幅を取得する
void | SetLineWidth (float width)
ライン幅を設定する

プロパティ

static ImageSize[] | ScreenSizes [get]
初期化時に指定できるスクリーンサイズの配列
FrameBuffer | Screen [get]
デフォルトのスクリーンを表すフレームバッファ
GraphicsCaps | Caps [get]
グラフィクス能力を表すクラス

説明

グラフィクスコンテキストを表すクラス

コンストラクタとデストラクタ

GraphicsContext ( )

グラフィクスコンテキストを作成する

標準的な設定でグラフィクスコンテキストを作成します。なお、複数のグラフィクスコンテキストを作成することはできません。

GraphicsContext | ( | int | width,
 |  | int | height,
 |  | PixelFormat | colorFormat,
 |  | PixelFormat | depthFormat,
 |  | MultiSampleMode | multiSampleMode
 | ) |  |

グラフィクスコンテキストを作成する (スクリーンパラメータあり)

引数:
width | スクリーンの幅 (0ならばデフォルト)
height | スクリーンの高さ (0ならばデフォルト)
colorFormat | スクリーンのカラーフォーマット (PixelFormat.Noneならばデフォルト)
depthFormat | スクリーンのデプスフォーマット (PixelFormat.Noneならばデフォルト)
multiSampleMode | スクリーンのマルチサンプルモード (MultiSampleMode.Noneならばデフォルト)

指定されたパラメータでグラフィクスコンテキストを作成します。カラーフォーマットには Rgba, Rgba4444, Rgba5551, Rgb565 が指定できます。デプスフォーマットには Depth16, Depth24, Depth16Stencil8, Depth24Stencil8 が指定できます。なお、複数のグラフィクスコンテキストを作成することはできません。

指定されたスクリーンサイズがデバイスのディスプレイ解像度と異なる場合は、指定されたサイズの仮想的なスクリーンが作成され、描画された内容がスケーリングされて表示されます。スクリーンのアスペクト比は保持され、必要に応じてピラーボックスまたはレターボックスが表示されます。

なおスクリーンサイズは最大サイズ以下に制限されます。最大サイズのデフォルト値は 1280x800 です。最大サイズは PublishingUtility で指定できます。アプリケーションはスクリーンサイズが最大サイズに等しい場合でも正しく動作することが要求されます。

指定されたフォーマットがデバイスで利用可能でない場合は、指定されたフォーマットに近い別のフォーマットが使用されます。

メソッド

void Clear ( ClearMask mask )

フレームバッファをクリアする (マスクあり)

引数:
mask バッファのクリアマスク
void Disable ( EnableMode mode )

指定されたグラフィクス機能を無効にする

引数:
mode 有効または無効にするグラフィクス機能
void DrawArrays ( Primitive[] primitives )

プリミティブを描画する (プリミティブ配列用)

引数:
primitives プリミティブ配列
void DrawArrays | ( | Primitive[] | primitives,
 |  | int | first,
 |  | int | count
 | ) |  |

プリミティブを描画する (プリミティブ配列用、範囲あり)

引数:
primitives | プリミティブ配列
first | プリミティブの開始番号
count | プリミティブの数
void DrawArrays | ( | DrawMode | mode,
 |  | int | first,
 |  | int | count
 | ) |  |

プリミティブを描画する

引数:
mode | プリミティブの描画モード
first | プリミティブの開始頂点
count | プリミティブの頂点数
void DrawArrays | ( | DrawMode | mode,
 |  | int | first,
 |  | int | count,
 |  | int | repeat
 | ) |  |

プリミティブを描画する (複数プリミティブ用)

引数:
mode | プリミティブの描画モード
first | プリミティブの開始頂点
count | プリミティブの頂点数
repeat | プリミティブの数

複数プリミティブを描画します。

void DrawArraysInstanced | ( | DrawMode | mode,
 |  | int | first,
 |  | int | count,
 |  | int | instFirst,
 |  | int | instCount
 | ) |  |

プリミティブを描画する (インスタンス描画用)

引数:
mode | プリミティブの描画モード
first | プリミティブの開始頂点
count | プリミティブの頂点数
instFirst | インスタンスの開始番号
instCount | インスタンスの数

１プリミティブの複数インスタンスを描画します。インスタンスごとのパラメータを転送するには、インスタンス除数を指定して作成された頂点バッファを使用してください。インスタンス除数が 0 の場合、各頂点データは頂点ごとに転送されます。インスタンス除数が 1 の場合、各頂点データはインスタンスごとに転送されます。

void Enable | ( | EnableMode | mode,
 |  | bool | status
 | ) |  |

指定されたグラフィクス機能を有効または無効にする

引数:
mode | 有効または無効にするグラフィクス機能
status | 有効ならばtrue
void Enable ( EnableMode mode )

指定されたグラフィクス機能を有効にする

引数:
mode 有効または無効にするグラフィクス機能
BlendFunc GetBlendFunc ( )

アルファブレンド関数を取得する

戻り値:
アルファブレンド関数を表す構造体
BlendFunc GetBlendFuncAlpha ( )

アルファブレンド関数を取得する (アルファチャンネル用)

戻り値:
アルファブレンド関数を表す構造体
BlendFunc GetBlendFuncRgb ( )

アルファブレンド関数を取得する (RGBチャンネル用)

戻り値:
アルファブレンド関数を表す構造体
Vector4 GetClearColor ( )

フレームバッファのクリアで使用されるカラーを取得する

戻り値:
カラー
float GetClearDepth ( )

フレームバッファのクリアで使用されるデプス値を取得する

戻り値:
デプス値 (0.0f～1.0f)
int GetClearStencil ( )

フレームバッファのクリアで使用されるステンシル値を取得する

戻り値:
ステンシル値 (0～255)
ColorMask GetColorMask ( )

カラーの書き込みマスクを取得する

戻り値:
カラーの書き込みマスク
CullFace GetCullFace ( )

バックフェースカリングを取得する

戻り値:
バックフェースカリングを表す構造体
DepthFunc GetDepthFunc ( )

デプステスト関数を取得する

戻り値:
デプステスト関数を表す構造体
Vector2 GetDepthRange ( )

デプス値の範囲を取得する

戻り値:
デプス値の範囲
EnableMode GetEnableMode ( )

各グラフィクス機能が有効かどうかをあらわすフラグの論理和を取得する

戻り値:
各グラフィクス機能が有効かどうかをあらわすフラグの論理和
FrameBuffer GetFrameBuffer ( )

フレームバッファを取得する

戻り値:
フレームバッファ
float GetLineWidth ( )

ライン幅を取得する

戻り値:
ライン幅
PolygonOffset GetPolygonOffset ( )

ポリゴンオフセットを取得する

戻り値:
ポリゴンオフセットを表す構造体
ImageRect GetScissor ( )

シザーテストの矩形を取得する

戻り値:
シザーテストの矩形
ShaderProgram GetShaderProgram ( )

シェーダープログラムを取得する

戻り値:
シェーダープログラム
StencilFunc GetStencilFunc ( )

ステンシルテスト関数を取得する

戻り値:
ステンシルテスト関数を表す構造体
StencilFunc GetStencilFuncBack ( )

ステンシルテスト関数を取得する (裏面用)

戻り値:
ステンシルテスト関数を表す構造体
StencilFunc GetStencilFuncFront ( )

ステンシルテスト関数を取得する (表面用)

戻り値:
ステンシルテスト関数を表す構造体
StencilOp GetStencilOp ( )

ステンシルテスト操作を取得する

戻り値:
ステンシルテスト操作を表す構造体
StencilOp GetStencilOpBack ( )

ステンシルテスト操作を取得する (裏面用)

戻り値:
ステンシルテスト操作を表す構造体
StencilOp GetStencilOpFront ( )

ステンシルテスト操作を取得する (表面用)

戻り値:
ステンシルテスト操作を表す構造体
Texture GetTexture ( int index )

テクスチャを取得する

引数:
index テクスチャ番号 (0～7)
戻り値:
テクスチャ
VertexBuffer GetVertexBuffer ( int index )

頂点バッファを取得する

引数:
index 頂点バッファ番号 (0～3)
戻り値:
頂点バッファ
ImageRect GetViewport ( )

ビューポートの矩形を取得する

戻り値:
ビューポートの矩形
bool IsEnabled ( EnableMode mode )

指定されたグラフィクス機能が有効かどうかを取得する

引数:
mode 有効または無効にするグラフィクス機能
戻り値:
有効ならばtrue
void ReadPixels | ( | byte[] | pixels,
 |  | PixelFormat | format,
 |  | int | sx,
 |  | int | sy,
 |  | int | sw,
 |  | int | sh
 | ) |  |

フレームバッファのピクセルを読み出す

引数:
pixels | ピクセルデータの格納先
format | ピクセルフォーマット
sx | 転送元のX座標
sy | 転送元のY座標
sw | 転送元の幅
sh | 転送元の高さ

指定された配列にフレームバッファのピクセルをコピーします。ピクセルフォーマットには Rgba またはフレームバッファと同じフォーマットが指定できます。

void ReadPixels | ( | Texture2D | texture,
 |  | int | level,
 |  | int | dx,
 |  | int | dy,
 |  | int | sx,
 |  | int | sy,
 |  | int | sw,
 |  | int | sh
 | ) |  |

フレームバッファのピクセルを読み出す (2Dテクスチャにコピー)

引数:
texture | 2Dテクスチャ
level | ミップマップレベル (0～LevelCount-1)
dx | 転送先のX座標
dy | 転送先のY座標
sx | 転送元のX座標
sy | 転送元のY座標
sw | 転送元の幅
sh | 転送元の高さ

指定された2Dテクスチャにフレームバッファのピクセルをコピーします。利用可能なテクスチャフォーマットは Rgba, Rgba4444, Rgba5551, Rgb565 です。なお、アルファ成分がないフレームバッファからアルファ成分があるテクスチャにはコピーできません。

void ReadPixels | ( | TextureCube | texture,
 |  | int | level,
 |  | TextureCubeFace | cubeFace,
 |  | int | dx,
 |  | int | dy,
 |  | int | sx,
 |  | int | sy,
 |  | int | sw,
 |  | int | sh
 | ) |  |

フレームバッファのピクセルを読み出す (キューブテクスチャにコピー)

引数:
texture | キューブテクスチャ
level | ミップマップレベル (0～LevelCount-1)
cubeFace | キューブ面
dx | 転送先のX座標
dy | 転送先のY座標
sx | 転送元のX座標
sy | 転送元のY座標
sw | 転送元の幅
sh | 転送元の高さ

指定されたキューブテクスチャにフレームバッファのピクセルをコピーします。利用可能なテクスチャフォーマットは Rgba, Rgba4444, Rgba5551, Rgb565 です。なお、アルファ成分がないフレームバッファからアルファ成分があるテクスチャにはコピーできません。

void SetBlendFunc ( BlendFunc func )

アルファブレンド関数を設定する

引数:
func アルファブレンド関数を表す構造体
void SetBlendFunc | ( | BlendFuncMode | mode,
 |  | BlendFuncFactor | srcFactor,
 |  | BlendFuncFactor | dstFactor
 | ) |  |

アルファブレンド関数を設定する

引数:
mode | アルファブレンド関数のモード
srcFactor | アルファブレンド関数のソース係数
dstFactor | アルファブレンド関数のデスティネーション係数
void SetBlendFuncAlpha ( BlendFunc func )

アルファブレンド関数を設定する (アルファチャンネル用)

引数:
func アルファブレンド関数を表す構造体
void SetBlendFuncAlpha | ( | BlendFuncMode | mode,
 |  | BlendFuncFactor | srcFactor,
 |  | BlendFuncFactor | dstFactor
 | ) |  |

アルファブレンド関数を設定する (アルファチャンネル用)

引数:
mode | アルファブレンド関数のモード
srcFactor | アルファブレンド関数のソース係数
dstFactor | アルファブレンド関数のデスティネーション係数
void SetBlendFuncRgb | ( | BlendFuncMode | mode,
 |  | BlendFuncFactor | srcFactor,
 |  | BlendFuncFactor | dstFactor
 | ) |  |

アルファブレンド関数を設定する (RGBチャンネル用)

引数:
mode | アルファブレンド関数のモード
srcFactor | アルファブレンド関数のソース係数
dstFactor | アルファブレンド関数のデスティネーション係数
void SetBlendFuncRgb ( BlendFunc func )

アルファブレンド関数を設定する (RGBチャンネル用)

引数:
func アルファブレンド関数を表す構造体
void SetClearColor ( Vector4 color )

フレームバッファのクリアで使用されるカラーを設定する

引数:
color カラー
void SetClearColor | ( | int | r,
 |  | int | g,
 |  | int | b,
 |  | int | a
 | ) |  |

フレームバッファのクリアで使用されるカラーを設定する

引数:
r | カラーのR値 (0～255)
g | カラーのG値 (0～255)
b | カラーのB値 (0～255)
a | カラーのA値 (0～255)
void SetClearColor | ( | float | r,
 |  | float | g,
 |  | float | b,
 |  | float | a
 | ) |  |

フレームバッファのクリアで使用されるカラーを設定する

引数:
r | カラーのR値 (0.0f～1.0f)
g | カラーのG値 (0.0f～1.0f)
b | カラーのB値 (0.0f～1.0f)
a | カラーのA値 (0.0f～1.0f)
void SetClearDepth ( float depth )

フレームバッファのクリアで使用されるデプス値を設定する

引数:
depth デプス値 (0.0f～1.0f)
void SetClearStencil ( int stencil )

フレームバッファのクリアで使用されるステンシル値を設定する

引数:
stencil ステンシル値 (0～255)
void SetColorMask ( ColorMask mask )

カラーの書き込みマスクを設定する

引数:
mask カラーの書き込みマスク
void SetCullFace | ( | CullFaceMode | mode,
 |  | CullFaceDirection | direction
 | ) |  |

バックフェースカリングを設定する

引数:
mode | バックフェースカリングのモード
direction | バックフェースカリングの表面方向
void SetCullFace ( CullFace face )

バックフェースカリングを設定する

引数:
face バックフェースカリングを表す構造体
void SetDepthFunc ( DepthFunc func )

デプステスト関数を設定する

引数:
func デプステスト関数を表す構造体
void SetDepthFunc | ( | DepthFuncMode | mode,
 |  | bool | writeMask
 | ) |  |

デプステスト関数を設定する

引数:
mode | デプステスト関数のモード
writeMask | デプステスト関数の書き込みマスク
void SetDepthRange ( Vector2 range )

デプス値の範囲を設定する

引数:
range デプス値の範囲
void SetDepthRange | ( | float | min,
 |  | float | max
 | ) |  |

デプス値の範囲を設定する

引数:
min | デプス値の最小値 (0.0f～1.0f)
max | デプス値の最大値 (0.0f～1.0f)
void SetEnableMode ( EnableMode mode )

各グラフィクス機能が有効かどうかをあらわすフラグの論理和を設定する

引数:
mode 各グラフィクス機能が有効かどうかをあらわすフラグの論理和
void SetFrameBuffer ( FrameBuffer buffer )

フレームバッファを設定する

引数:
buffer フレームバッファ (nullならば解除)
void SetLineWidth ( float width )

ライン幅を設定する

引数:
width ライン幅
void SetPolygonOffset ( PolygonOffset offset )

ポリゴンオフセットを設定する

引数:
offset ポリゴンオフセットを表す構造体
void SetPolygonOffset | ( | float | factor,
 |  | float | units
 | ) |  |

ポリゴンオフセットを設定する

引数:
factor | ポリゴンオフセットのスケーリング係数
units | ポリゴンオフセットのオフセット係数
void SetScissor | ( | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h
 | ) |  |

シザーテストの矩形を設定する

引数:
x | シザーテストの矩形のX座標の最小値
y | シザーテストの矩形のY座標の最小値
w | シザーテストの矩形の幅
h | シザーテストの矩形の高さ
void SetScissor ( ImageRect rectangle )

シザーテストの矩形を設定する

引数:
rectangle シザーテストの矩形
void SetShaderProgram ( ShaderProgram program )

シェーダープログラムを設定する

引数:
program シェーダープログラム (nullならば解除)
void SetStencilFunc ( StencilFunc func )

ステンシルテスト関数を設定する

引数:
func ステンシルテスト関数を表す構造体
void SetStencilFunc | ( | StencilFuncMode | mode,
 |  | int | reference,
 |  | int | readMask,
 |  | int | writeMask
 | ) |  |

ステンシルテスト関数を設定する

引数:
mode | ステンシルテスト関数のモード
reference | ステンシルテスト関数の参照値 (0～255)
readMask | ステンシルテスト関数の読み込みマスク (0～255)
writeMask | ステンシルテスト関数の書き込みマスク (0～255)
void SetStencilFuncBack | ( | StencilFuncMode | mode,
 |  | int | reference,
 |  | int | readMask,
 |  | int | writeMask
 | ) |  |

ステンシルテスト関数を設定する (裏面用)

引数:
mode | ステンシルテスト関数のモード
reference | ステンシルテスト関数の参照値 (0～255)
readMask | ステンシルテスト関数の読み込みマスク (0～255)
writeMask | ステンシルテスト関数の書き込みマスク (0～255)
void SetStencilFuncBack ( StencilFunc func )

ステンシルテスト関数を設定する (裏面用)

引数:
func ステンシルテスト関数を表す構造体
void SetStencilFuncFront ( StencilFunc func )

ステンシルテスト関数を設定する (表面用)

引数:
func ステンシルテスト関数を表す構造体
void SetStencilFuncFront | ( | StencilFuncMode | mode,
 |  | int | reference,
 |  | int | readMask,
 |  | int | writeMask
 | ) |  |

ステンシルテスト関数を設定する (表面用)

引数:
mode | ステンシルテスト関数のモード
reference | ステンシルテスト関数の参照値 (0～255)
readMask | ステンシルテスト関数の読み込みマスク (0～255)
writeMask | ステンシルテスト関数の書き込みマスク (0～255)
void SetStencilOp | ( | StencilOpMode | fail,
 |  | StencilOpMode | zFail,
 |  | StencilOpMode | zPass
 | ) |  |

ステンシルテスト操作を設定する

引数:
fail | ステンシルテスト操作のステンシル不合格モード
zFail | ステンシルテスト操作のデプス不合格モード
zPass | ステンシルテスト操作のデプス合格モード
void SetStencilOp ( StencilOp op )

ステンシルテスト操作を設定する

引数:
op ステンシルテスト操作を表す構造体
void SetStencilOpBack | ( | StencilOpMode | fail,
 |  | StencilOpMode | zFail,
 |  | StencilOpMode | zPass
 | ) |  |

ステンシルテスト操作を設定する (裏面用)

引数:
fail | ステンシルテスト操作のステンシル不合格モード
zFail | ステンシルテスト操作のデプス不合格モード
zPass | ステンシルテスト操作のデプス合格モード
void SetStencilOpBack ( StencilOp op )

ステンシルテスト操作を設定する (裏面用)

引数:
op ステンシルテスト操作を表す構造体
void SetStencilOpFront | ( | StencilOpMode | fail,
 |  | StencilOpMode | zFail,
 |  | StencilOpMode | zPass
 | ) |  |

ステンシルテスト操作を設定する (表面用)

引数:
fail | ステンシルテスト操作のステンシル不合格モード
zFail | ステンシルテスト操作のデプス不合格モード
zPass | ステンシルテスト操作のデプス合格モード
void SetStencilOpFront ( StencilOp op )

ステンシルテスト操作を設定する (表面用)

引数:
op ステンシルテスト操作を表す構造体
void SetTexture | ( | int | index,
 |  | Texture | texture
 | ) |  |

テクスチャを設定する

引数:
index | テクスチャ番号 (0～7)
texture | テクスチャ (nullならば解除)
void SetVertexBuffer | ( | int | index,
 |  | VertexBuffer | buffer
 | ) |  |

頂点バッファを設定する

引数:
index | 頂点バッファ番号 (0～3)
buffer | 頂点バッファ (nullならば解除)
void SetViewport | ( | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h
 | ) |  |

ビューポートの矩形を設定する

引数:
x | ビューポートの矩形のX座標の最小値
y | ビューポートの矩形のY座標の最小値
w | ビューポートの矩形の幅
h | ビューポートの矩形の高さ
void SetViewport ( ImageRect rectangle )

ビューポートの矩形を設定する

引数:
rectangle ビューポートの矩形

プロパティ

GraphicsCaps Caps [get]

グラフィクス能力を表すクラス

パラメータの許容範囲やサポートする拡張機能などを取得するために使用します。

FrameBuffer Screen [get]

デフォルトのスクリーンを表すフレームバッファ

デフォルトのスクリーンをフレームバッファに設定したり、スクリーンサイズやピクセルフォーマットを取得するために使用します。このフレームバッファは読み取り専用であり、カラーターゲットやデプスターゲットを変更することはできません。

ImageSize [] ScreenSizes [static, get]

初期化時に指定できるスクリーンサイズの配列

グラフィクスコンテキストを作成する時に指定するスクリーンサイズを決定するために使用します。このプロパティはスタティックプロパティであり、グラフィクスコンテキストを作成する前でも利用可能です。


クラス PixelBuffer

ピクセルバッファを表す基底クラス [詳細]

PixelBufferに対する継承グラフ
ColorBuffer DepthBuffer Texture Texture2D TextureCube

すべてのメンバ一覧

Public メソッド

virtual Object | ShallowClone ()
ピクセルバッファを複製する
void | Dispose ()
ピクセルバッファのアンマネージドリソースを解放する
int | GetMipmapWidth (int level)
指定されたミップマップレベルの幅を取得する
int | GetMipmapHeight (int level)
指定されたミップマップレベルの高さを取得する

プロパティ

PixelBufferType | Type [get]
ピクセルバッファのタイプ
PixelBufferOption | Option [get]
ピクセルバッファの作成オプション
PixelFormat | Format [get]
ピクセルフォーマット
int | Width [get]
ピクセルバッファの幅
int | Height [get]
ピクセルバッファの高さ
int | LevelCount [get]
ミップマップレベル数
bool | IsRenderable [get]
レンダリング可能ならばtrue
bool | IsPowerOfTwo [get]
幅と高さが２のべき乗ならばtrue

説明

ピクセルバッファを表す基底クラス

メソッド

int GetMipmapHeight ( int level )

指定されたミップマップレベルの高さを取得する

引数:
level ミップマップレベル (0～LevelCount-1)
戻り値:
指定されたミップマップレベルの高さ
int GetMipmapWidth ( int level )

指定されたミップマップレベルの幅を取得する

引数:
level ミップマップレベル (0～LevelCount-1)
戻り値:
指定されたミップマップレベルの幅
virtual Object ShallowClone ( ) [virtual]

ピクセルバッファを複製する

戻り値:
ピクセルバッファの複製

ピクセルバッファを複製します。複製されたピクセルバッファはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

Texture, Texture2D, TextureCube, ColorBuffer, と DepthBufferで再定義されています。


クラス ShaderProgram

シェーダープログラムを表すクラス [詳細]

ShaderProgramに対する継承グラフ
BasicProgram

すべてのメンバ一覧

Public メソッド

ShaderProgram (string fileName)
シェーダープログラムを作成する (ファイルから)
ShaderProgram (string vpFileName, string fpFileName)
シェーダープログラムを作成する (ファイルから)
ShaderProgram (string fileName, ShaderProgramOption option)
シェーダープログラムを作成する (ファイルから、オプションあり)
ShaderProgram (string vpFileName, string fpFileName, ShaderProgramOption option)
シェーダープログラムを作成する (ファイルから、オプションあり)
ShaderProgram (byte[] fileImage)
シェーダープログラムを作成する (ファイルイメージから)
ShaderProgram (byte[] vpFileImage, byte[] fpFileImage)
シェーダープログラムを作成する (ファイルイメージから)
ShaderProgram (byte[] fileImage, ShaderProgramOption option)
シェーダープログラムを作成する (ファイルイメージから、オプションあり)
ShaderProgram (byte[] vpFileImage, byte[] fpFileImage, ShaderProgramOption option)
シェーダープログラムを作成する (ファイルイメージから、オプションあり)
virtual Object | ShallowClone ()
シェーダープログラムを複製する
void | Dispose ()
シェーダープログラムのアンマネージドリソースを解放する
int | FindUniform (string name)
ユニフォーム変数を名前で検索する
int | FindAttribute (string name)
アトリビュート変数を名前で検索する
string | GetUniformBinding (int index)
ユニフォーム変数のバインディングを取得する
void | SetUniformBinding (int index, string name)
ユニフォーム変数のバインディングを設定する
string | GetAttributeBinding (int index)
アトリビュート変数のバインディングを取得する
void | SetAttributeBinding (int index, string name)
アトリビュート変数のバインディングを設定する
ShaderUniformType | GetUniformType (int index)
ユニフォーム変数のタイプを取得する
ShaderAttributeType | GetAttributeType (int index)
アトリビュート変数のタイプを取得する
string | GetUniformName (int index)
ユニフォーム変数の名前を取得する
string | GetAttributeName (int index)
アトリビュート変数の名前を取得する
int | GetUniformSize (int index)
ユニフォーム変数の配列サイズを取得する
int | GetAttributeSize (int index)
アトリビュート変数の配列サイズを取得する
void | SetUniformValue (int index, ref Matrix4 value)
ユニフォーム変数の値をセットする
void | SetUniformValue (int index, ref Vector4 value)
ユニフォーム変数の値をセットする
void | SetUniformValue (int index, ref Vector3 value)
ユニフォーム変数の値をセットする
void | SetUniformValue (int index, ref Vector2 value)
ユニフォーム変数の値をセットする
void | SetUniformValue (int index, float value)
ユニフォーム変数の値をセットする
void | SetUniformValue (int index, int value)
ユニフォーム変数の値をセットする
void | SetUniformValue (int index, float[] value)
ユニフォーム変数の値をセットする
void | SetUniformValue (int index, int[] value)
ユニフォーム変数の値をセットする
void | SetUniformValue (int index, int offset, ref Matrix4 value)
ユニフォーム変数の値をセットする (オフセットあり)
void | SetUniformValue (int index, int offset, ref Vector4 value)
ユニフォーム変数の値をセットする (オフセットあり)
void | SetUniformValue (int index, int offset, ref Vector3 value)
ユニフォーム変数の値をセットする (オフセットあり)
void | SetUniformValue (int index, int offset, ref Vector2 value)
ユニフォーム変数の値をセットする (オフセットあり)
void | SetUniformValue (int index, int offset, float value)
ユニフォーム変数の値をセットする (オフセットあり)
void | SetUniformValue (int index, int offset, int value)
ユニフォーム変数の値をセットする (オフセットあり)
void | SetUniformValue (int index, int offset, float[] value)
ユニフォーム変数の値をセットする (オフセットあり)
void | SetUniformValue (int index, int offset, int[] value)
ユニフォーム変数の値をセットする (オフセットあり)
void | SetUniformValue (int index, Matrix4[] value, int to, int from, int count)
ユニフォーム変数の値をセットする (配列データ用)
void | SetUniformValue (int index, Vector4[] value, int to, int from, int count)
ユニフォーム変数の値をセットする (配列データ用)
void | SetUniformValue (int index, Vector3[] value, int to, int from, int count)
ユニフォーム変数の値をセットする (配列データ用)
void | SetUniformValue (int index, Vector2[] value, int to, int from, int count)
ユニフォーム変数の値をセットする (配列データ用)
void | SetUniformValue (int index, float[] value, int to, int from, int count)
ユニフォーム変数の値をセットする (配列データ用)
void | SetUniformValue (int index, int[] value, int to, int from, int count)
ユニフォーム変数の値をセットする (配列データ用)
void | SetAttributeValue (int index, params float[] value)
アトリビュート変数のデフォルト値をセットする
int | GetUniformTexture (int index)
ユニフォーム変数のテクスチャ番号を取得する
int | GetAttributeStream (int index)
アトリビュート変数の頂点ストリーム番号を取得する
void | SetAttributeStream (int index, int stream)
アトリビュート変数の頂点ストリーム番号を設定する

Protected メソッド

ShaderProgram (ShaderProgram program)
シェーダープログラムを複製する
void | SwapShader (ShaderProgram program)
シェーダーを変更する
virtual internal void | UpdateShader ()
シェーダーの状態を更新する

プロパティ

int | UniformCount [get]
ユニフォーム変数の数
int | AttributeCount [get]
アトリビュート変数の数

説明

シェーダープログラムを表すクラス

コンストラクタとデストラクタ

ShaderProgram ( string fileName )

シェーダープログラムを作成する (ファイルから)

引数:
fileName シェーダーのファイル名

指定されたファイルからシェーダープログラムを作成します。利用可能なファイルフォーマットは CGX です。

ShaderProgram | ( | string | vpFileName,
 |  | string | fpFileName
 | ) |  |

シェーダープログラムを作成する (ファイルから)

引数:
vpFileName | 頂点シェーダーのファイル名
fpFileName | フラグメントシェーダーのファイル名

指定されたファイルからシェーダープログラムを作成します。利用可能なファイルフォーマットは CGX です。

ShaderProgram | ( | string | fileName,
 |  | ShaderProgramOption | option
 | ) |  |

シェーダープログラムを作成する (ファイルから、オプションあり)

引数:
fileName | シェーダーのファイル名
option | シェーダープログラムの作成オプション

指定されたファイルからシェーダープログラムを作成します。利用可能なファイルフォーマットは CGX です。

ShaderProgram | ( | string | vpFileName,
 |  | string | fpFileName,
 |  | ShaderProgramOption | option
 | ) |  |

シェーダープログラムを作成する (ファイルから、オプションあり)

引数:
vpFileName | 頂点シェーダーのファイル名
fpFileName | フラグメントシェーダーのファイル名
option | シェーダープログラムの作成オプション

指定されたファイルからシェーダープログラムを作成します。利用可能なファイルフォーマットは CGX です。

ShaderProgram ( byte[] fileImage )

シェーダープログラムを作成する (ファイルイメージから)

引数:
fileImage シェーダーのファイルイメージ

指定されたファイルイメージからシェーダープログラムを作成します。利用可能なファイルフォーマットは CGX です。

ShaderProgram | ( | byte[] | vpFileImage,
 |  | byte[] | fpFileImage
 | ) |  |

シェーダープログラムを作成する (ファイルイメージから)

引数:
vpFileImage | 頂点シェーダーのファイルイメージ
fpFileImage | フラグメントシェーダーのファイルイメージ

指定されたファイルイメージからシェーダープログラムを作成します。利用可能なファイルフォーマットは CGX です。

ShaderProgram | ( | byte[] | fileImage,
 |  | ShaderProgramOption | option
 | ) |  |

シェーダープログラムを作成する (ファイルイメージから、オプションあり)

引数:
fileImage シェーダーのファイルイメージ

指定されたファイルイメージからシェーダープログラムを作成します。利用可能なファイルフォーマットは CGX です。

ShaderProgram | ( | byte[] | vpFileImage,
 |  | byte[] | fpFileImage,
 |  | ShaderProgramOption | option
 | ) |  |

シェーダープログラムを作成する (ファイルイメージから、オプションあり)

引数:
vpFileImage | 頂点シェーダーのファイルイメージ
fpFileImage | フラグメントシェーダーのファイルイメージ

指定されたファイルイメージからシェーダープログラムを作成します。利用可能なファイルフォーマットは CGX です。

ShaderProgram ( ShaderProgram program ) [protected]

シェーダープログラムを複製する

引数:
program シェーダープログラム

シェーダープログラムを複製します。複製されたシェーダープログラムはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

メソッド

int FindAttribute ( string name )

アトリビュート変数を名前で検索する

引数:
name アトリビュート変数の名前
戻り値:
アトリビュート変数の番号 (-1ならば失敗)

アトリビュート変数を名前で検索します。指定した変数が見つからない場合は-1を返します。

int FindUniform ( string name )

ユニフォーム変数を名前で検索する

引数:
name ユニフォーム変数の名前
戻り値:
ユニフォーム変数の番号 (-1ならば失敗)

ユニフォーム変数を名前で検索します。指定した変数が見つからない場合は-1を返します。

string GetAttributeBinding ( int index )

アトリビュート変数のバインディングを取得する

引数:
index アトリビュート変数の番号 (0～AttributeCount-1)
戻り値:
アトリビュート変数の名前 (nullならばデフォルト)
string GetAttributeName ( int index )

アトリビュート変数の名前を取得する

引数:
index アトリビュート変数の番号 (0～AttributeCount-1)
戻り値:
アトリビュート変数の名前
int GetAttributeSize ( int index )

アトリビュート変数の配列サイズを取得する

引数:
index アトリビュート変数の番号 (0～AttributeCount-1)
戻り値:
アトリビュート変数の配列サイズ
int GetAttributeStream ( int index )

アトリビュート変数の頂点ストリーム番号を取得する

引数:
index アトリビュート変数の番号 (0～AttributeCount-1)
戻り値:
頂点ストリーム番号 (-1ならば無効)
ShaderAttributeType GetAttributeType ( int index )

アトリビュート変数のタイプを取得する

引数:
index アトリビュート変数の番号 (0～AttributeCount-1)
戻り値:
アトリビュート変数のタイプ
string GetUniformBinding ( int index )

ユニフォーム変数のバインディングを取得する

引数:
index ユニフォーム変数の番号 (0～UniformCount-1)
戻り値:
ユニフォーム変数の名前 (nullならばデフォルト)
string GetUniformName ( int index )

ユニフォーム変数の名前を取得する

引数:
index ユニフォーム変数の番号 (0～UniformCount-1)
戻り値:
ユニフォーム変数の名前
int GetUniformSize ( int index )

ユニフォーム変数の配列サイズを取得する

引数:
index ユニフォーム変数の番号 (0～UniformCount-1)
戻り値:
ユニフォーム変数の配列サイズ
int GetUniformTexture ( int index )

ユニフォーム変数のテクスチャ番号を取得する

引数:
index ユニフォーム変数の番号 (0～UniformCount-1)
戻り値:
ユニフォーム変数のテクスチャ番号 (-1ならば無効)

ユニフォーム変数のテクスチャ番号を取得します。指定した変数がサンプラーでない場合は-1を返します。

ShaderUniformType GetUniformType ( int index )

ユニフォーム変数のタイプを取得する

引数:
index ユニフォーム変数の番号 (0～UniformCount-1)
戻り値:
ユニフォーム変数のタイプ
void SetAttributeBinding | ( | int | index,
 |  | string | name
 | ) |  |

アトリビュート変数のバインディングを設定する

引数:
index | アトリビュート変数の番号
name | アトリビュート変数の名前 (nullならばデフォルト)

アトリビュート変数を特定の番号に関連づけます。指定された変数の古いバインディングは解除されます。バインディングがない変数はそれぞれ未使用の番号に割り当てられます。

index には AttributeCount 以上の番号を指定することもできます。その場合は、空の変数が挿入されて AttributeCount の値が増加します。

void SetAttributeStream | ( | int | index,
 |  | int | stream
 | ) |  |

アトリビュート変数の頂点ストリーム番号を設定する

引数:
index | アトリビュート変数の番号 (0～AttributeCount-1)
stream | 頂点ストリーム番号 (-1ならば無効)

アトリビュート変数の頂点ストリーム番号を設定します。初期値はアトリビュート変数の番号です。この設定により、指定されたアトリビュート変数に任意の頂点ストリームを転送することができます。さらに、特定の頂点ストリームを無効にしたり、一つの頂点ストリームを複数のアトリビュート変数に転送することもできます。

void SetAttributeValue | ( | int | index,
 |  | params float[] | value
 | ) |  |

アトリビュート変数のデフォルト値をセットする

引数:
index | アトリビュート変数の番号 (0～AttributeCount-1)
value | 配列データ (float)
void SetUniformBinding | ( | int | index,
 |  | string | name
 | ) |  |

ユニフォーム変数のバインディングを設定する

引数:
index | ユニフォーム変数の番号
name | ユニフォーム変数の名前 (nullならばデフォルト)

ユニフォーム変数を特定の番号に関連づけます。指定された変数の古いバインディングは解除されます。バインディングがない変数はそれぞれ未使用の番号に割り当てられます。

index には UniformCount 以上の番号を指定することもできます。その場合は、空の変数が挿入されて UniformCount の値が増加します。

void SetUniformValue | ( | int | index,
 |  | int | offset,
 |  | float | value
 | ) |  |

ユニフォーム変数の値をセットする (オフセットあり)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
offset | 配列変数のオフセット
value | スカラ (float)
void SetUniformValue | ( | int | index,
 |  | int | offset,
 |  | ref Vector4 | value
 | ) |  |

ユニフォーム変数の値をセットする (オフセットあり)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
offset | 配列変数のオフセット
value | 4次元ベクトル (float)
void SetUniformValue | ( | int | index,
 |  | int | offset,
 |  | ref Matrix4 | value
 | ) |  |

ユニフォーム変数の値をセットする (オフセットあり)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
offset | 配列変数のオフセット
value | 4次元行列 (float)
void SetUniformValue | ( | int | index,
 |  | int[] | value
 | ) |  |

ユニフォーム変数の値をセットする

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | 配列データ (int)

ユニフォーム変数の値をセットします。このオーバーロードはintスカラー変数だけでなく、int2,int3,int4...のようなintベクトル変数にも値をセットすることができます。ただし、配列データのサイズはベクトルサイズの倍数である必要があります。

void SetUniformValue | ( | int | index,
 |  | float[] | value
 | ) |  |

ユニフォーム変数の値をセットする

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | 配列データ (float)

ユニフォーム変数の値をセットします。このオーバーロードはfloatスカラー変数だけでなく、float2,float3,float4...のようなfloatベクトルや行列の変数にも値をセットすることができます。ただし、配列データのサイズはベクトルや行列のサイズの倍数である必要があります。

void SetUniformValue | ( | int | index,
 |  | int | offset,
 |  | int | value
 | ) |  |

ユニフォーム変数の値をセットする (オフセットあり)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
offset | 配列変数のオフセット
value | スカラ (int)
void SetUniformValue | ( | int | index,
 |  | ref Matrix4 | value
 | ) |  |

ユニフォーム変数の値をセットする

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | 4次元行列 (float)
void SetUniformValue | ( | int | index,
 |  | float[] | value,
 |  | int | to,
 |  | int | from,
 |  | int | count
 | ) |  |

ユニフォーム変数の値をセットする (配列データ用)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | 配列データ (float)
to | 転送先のオフセット
from | 転送元のオフセット
count | 転送されるデータ数

ユニフォーム変数の値をセットします。このオーバーロードはfloatスカラー変数だけでなく、float2,float3,float4...のようなfloatベクトルや行列の変数にも値をセットすることができます。ただし、オフセットとカウント引数はベクトルや行列の単位で数えることに注意してください。

void SetUniformValue | ( | int | index,
 |  | ref Vector3 | value
 | ) |  |

ユニフォーム変数の値をセットする

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | 3次元ベクトル (float)
void SetUniformValue | ( | int | index,
 |  | Matrix4[] | value,
 |  | int | to,
 |  | int | from,
 |  | int | count
 | ) |  |

ユニフォーム変数の値をセットする (配列データ用)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | 4次元行列の配列 (float)
to | 転送先のオフセット
from | 転送元のオフセット
count | 転送されるデータ数
void SetUniformValue | ( | int | index,
 |  | ref Vector4 | value
 | ) |  |

ユニフォーム変数の値をセットする

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | 4次元ベクトル (float)
void SetUniformValue | ( | int | index,
 |  | int | offset,
 |  | float[] | value
 | ) |  |

ユニフォーム変数の値をセットする (オフセットあり)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
offset | 配列変数のオフセット
value | 配列データ (float)

ユニフォーム変数の値をセットします。このオーバーロードはfloatスカラー変数だけでなく、float2,float3,float4...のようなfloatベクトルや行列の変数にも値をセットすることができます。ただし、配列データのサイズはベクトルや行列のサイズの倍数である必要があります。オフセット引数はベクトルや行列の単位で数えることに注意してください。

void SetUniformValue | ( | int | index,
 |  | Vector3[] | value,
 |  | int | to,
 |  | int | from,
 |  | int | count
 | ) |  |

ユニフォーム変数の値をセットする (配列データ用)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | 3次元ベクトルの配列 (float)
to | 転送先のオフセット
from | 転送元のオフセット
count | 転送されるデータ数
void SetUniformValue | ( | int | index,
 |  | int | offset,
 |  | ref Vector3 | value
 | ) |  |

ユニフォーム変数の値をセットする (オフセットあり)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
offset | 配列変数のオフセット
value | 3次元ベクトル (float)
void SetUniformValue | ( | int | index,
 |  | ref Vector2 | value
 | ) |  |

ユニフォーム変数の値をセットする

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | 2次元ベクトル (float)
void SetUniformValue | ( | int | index,
 |  | float | value
 | ) |  |

ユニフォーム変数の値をセットする

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | スカラ (float)
void SetUniformValue | ( | int | index,
 |  | int | value
 | ) |  |

ユニフォーム変数の値をセットする

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | スカラ (int)
void SetUniformValue | ( | int | index,
 |  | int | offset,
 |  | int[] | value
 | ) |  |

ユニフォーム変数の値をセットする (オフセットあり)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
offset | 配列変数のオフセット
value | 配列データ (int)

ユニフォーム変数の値をセットします。このオーバーロードはintスカラー変数だけでなく、int2,int3,int4...のようなintベクトル変数にも値をセットすることができます。ただし、配列データのサイズはベクトルサイズの倍数である必要があります。オフセット引数はベクトル単位で数えることに注意してください。

void SetUniformValue | ( | int | index,
 |  | int[] | value,
 |  | int | to,
 |  | int | from,
 |  | int | count
 | ) |  |

ユニフォーム変数の値をセットする (配列データ用)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | 配列データ (int)
to | 転送先のオフセット
from | 転送元のオフセット
count | 転送されるデータ数

ユニフォーム変数の値をセットします。このオーバーロードはintスカラー変数だけでなく、int2,int3,int4...のようなintベクトル変数にも値をセットすることができます。ただし、オフセットとカウント引数はベクトル単位で数えることに注意してください。

void SetUniformValue | ( | int | index,
 |  | Vector4[] | value,
 |  | int | to,
 |  | int | from,
 |  | int | count
 | ) |  |

ユニフォーム変数の値をセットする (配列データ用)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | 4次元ベクトルの配列 (float)
to | 転送先のオフセット
from | 転送元のオフセット
count | 転送されるデータ数
void SetUniformValue | ( | int | index,
 |  | Vector2[] | value,
 |  | int | to,
 |  | int | from,
 |  | int | count
 | ) |  |

ユニフォーム変数の値をセットする (配列データ用)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
value | 2次元ベクトルの配列 (float)
to | 転送先のオフセット
from | 転送元のオフセット
count | 転送されるデータ数
void SetUniformValue | ( | int | index,
 |  | int | offset,
 |  | ref Vector2 | value
 | ) |  |

ユニフォーム変数の値をセットする (オフセットあり)

引数:
index | ユニフォーム変数の番号 (0～UniformCount-1)
offset | 配列変数のオフセット
value | 2次元ベクトル (float)
virtual Object ShallowClone ( ) [virtual]

シェーダープログラムを複製する

戻り値:
シェーダープログラムの複製

シェーダープログラムを複製します。複製されたシェーダープログラムはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

BasicProgramで再定義されています。

void SwapShader ( ShaderProgram program ) [protected]

シェーダーを変更する

引数:
program シェーダープログラム

指定されたシェーダープログラムのシェーダーをこのシェーダープログラムにセットします。この関数は内部的にシェーダーを切り替える場合に使用します。

virtual internal void UpdateShader ( ) [protected, virtual]

シェーダーの状態を更新する

プリミティブ描画前にグラフィックスコンテキストから呼び出される仮想関数です。この関数はクラス内にキャッシュされた状態をシェーダーに反映する場合に使用します。

BasicProgramで再定義されています。


クラス ShaderProgramOption

シェーダープログラムの作成オプションを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

ShaderProgramOption ()
シェーダープログラムの作成オプションを表すクラスを作成する

Public 変数

Dictionary< string, int > ConstantValues
コンパイル時に書きかえる定数値

説明

シェーダープログラムの作成オプションを表すクラス

変数

Dictionary<string,int> ConstantValues

コンパイル時に書きかえる定数値

コンパイル時に変数を定数に書きかえるために使用します。 "uniform int" を "static const int" に、"uniform bool" を "static const bool" にそれぞれ書きかえることができます。各変数の宣言は一行で完結している必要があります。なお、変数を定数に書きかえたあとでその値を変更することはできません。


  • Sce
  • PlayStation
  • Core
  • Graphics
  • Texture
Public メソッド

クラス Texture

テクスチャを表す基底クラス [詳細]

Textureに対する継承グラフ
PixelBuffer Texture2D TextureCube

すべてのメンバ一覧

Public メソッド

override Object | ShallowClone ()
テクスチャを複製する
TextureFilter GetFilter ()
テクスチャフィルタを取得する
void | SetFilter (TextureFilter filter)
テクスチャフィルタを設定する
void | SetFilter (TextureFilterMode mode)
テクスチャフィルタを設定する
void | SetFilter (TextureFilterMode mag, TextureFilterMode min, TextureFilterMode mip)
テクスチャフィルタを設定する
TextureWrap GetWrap ()
テクスチャラップを取得する
void | SetWrap (TextureWrap wrap)
テクスチャラップを設定する
void | SetWrap (TextureWrapMode mode)
テクスチャラップを設定する
void | SetWrap (TextureWrapMode s, TextureWrapMode t)
テクスチャラップを設定する
float | GetMaxAnisotropy ()
異方性フィルタの最大値を取得する
void | SetMaxAnisotropy (float anisotropy)
異方性フィルタの最大値を設定する

説明

テクスチャを表す基底クラス

メソッド

TextureFilter GetFilter ( )

テクスチャフィルタを取得する

戻り値:
テクスチャフィルタを表す構造体
float GetMaxAnisotropy ( )

異方性フィルタの最大値を取得する

戻り値:
異方性フィルタの最大値 (1.0f～)
TextureWrap GetWrap ( )

テクスチャラップを取得する

戻り値:
テクスチャラップを表す構造体
void SetFilter ( TextureFilterMode mode )

テクスチャフィルタを設定する

引数:
mode テクスチャフィルタのモード

テクスチャフィルタを設定します。デバイスが非対応の場合、half float テクスチャのリニアフィルタは機能しませんのでご注意ください。

void SetFilter | ( | TextureFilterMode | mag,
 |  | TextureFilterMode | min,
 |  | TextureFilterMode | mip
 | ) |  |

テクスチャフィルタを設定する

引数:
mag | 拡大テクスチャフィルタのモード
min | 縮小テクスチャフィルタのモード
mip | ミップマップテクスチャフィルタのモード

テクスチャフィルタを設定します。デバイスが非対応の場合、half float テクスチャのリニアフィルタは機能しませんのでご注意ください。

void SetFilter ( TextureFilter filter )

テクスチャフィルタを設定する

引数:
filter テクスチャフィルタを表す構造体

テクスチャフィルタを設定します。デバイスが非対応の場合、half float テクスチャのリニアフィルタは機能しませんのでご注意ください。

void SetMaxAnisotropy ( float anisotropy )

異方性フィルタの最大値を設定する

引数:
anisotropy 異方性フィルタの最大値 (1.0f～)

異方性フィルタの最大値を設定します。デバイスが非対応の場合、異方性フィルタは機能しませんのでご注意ください。

void SetWrap | ( | TextureWrapMode | s,
 |  | TextureWrapMode | t
 | ) |  |

テクスチャラップを設定する

引数:
s | S座標のテクスチャラップのモード
t | T座標のテクスチャラップのモード

テクスチャラップを設定します。２のべき乗でないテクスチャは、つねにクランプモードで動作しますのでご注意ください。

void SetWrap ( TextureWrapMode mode )

テクスチャラップを設定する

引数:
mode テクスチャラップのモード

テクスチャラップを設定します。２のべき乗でないテクスチャは、つねにクランプモードで動作しますのでご注意ください。

void SetWrap ( TextureWrap wrap )

テクスチャラップを設定する

引数:
wrap テクスチャラップを表す構造体

テクスチャラップを設定します。２のべき乗でないテクスチャは、つねにクランプモードで動作しますのでご注意ください。

override Object ShallowClone ( ) [virtual]

テクスチャを複製する

戻り値:
テクスチャの複製

テクスチャを複製します。複製されたテクスチャはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

PixelBufferを再定義しています。

Texture2D, と TextureCubeで再定義されています。


クラス Texture2D

2Dテクスチャを表すクラス [詳細]

Texture2Dに対する継承グラフ
Texture PixelBuffer

すべてのメンバ一覧

Public メソッド

Texture2D (int width, int height, bool mipmap, PixelFormat format)
2Dテクスチャを作成する
Texture2D (int width, int height, bool mipmap, PixelFormat format, PixelBufferOption option)
2Dテクスチャを作成する (オプションあり)
Texture2D (string fileName, bool mipmap)
2Dテクスチャを作成する (ファイルから)
Texture2D (string fileName, bool mipmap, PixelFormat format)
2Dテクスチャを作成する (ファイルから、フォーマット変換あり)
Texture2D (byte[] fileImage, bool mipmap)
2Dテクスチャを作成する (ファイルイメージから)
Texture2D (byte[] fileImage, bool mipmap, PixelFormat format)
2Dテクスチャを作成する (ファイルイメージから、フォーマット変換あり)
override Object | ShallowClone ()
2Dテクスチャを複製する
void | SetPixels (int level, Array pixels)
ピクセルデータをセットする
void | SetPixels (int level, Array pixels, int dx, int dy, int dw, int dh)
ピクセルデータをセットする (範囲あり)
void | SetPixels (int level, Array pixels, int offset, int pitch)
ピクセルデータをセットする (バイトオフセットあり)
void | SetPixels (int level, Array pixels, PixelFormat format)
ピクセルデータをセットする (フォーマット変換あり)
void | SetPixels (int level, Array pixels, PixelFormat format, int offset, int pitch, int dx, int dy, int dw, int dh)
ピクセルデータをセットする (フォーマット変換あり、バイトオフセットあり、範囲あり)
void | GenerateMipmap ()
ミップマップ画像を自動生成する

Protected メソッド

Texture2D (Texture2D texture)
2Dテクスチャを複製する

説明

2Dテクスチャを表すクラス

コンストラクタとデストラクタ

Texture2D | ( | int | width,
 |  | int | height,
 |  | bool | mipmap,
 |  | PixelFormat | format
 | ) |  |

2Dテクスチャを作成する

引数:
width | テクスチャの幅
height | テクスチャの高さ
mipmap | ミップマップの有無
format | ピクセルフォーマット

指定されたパラメータで2Dテクスチャを作成します。ピクセルフォーマットには Rgba, Rgba4444, Rgba5551, Rgb565, LuminanceAlpha, Luminance, Alpha, RgbaH, LuminanceAlphaH, LuminanceH, AlphaH, Dxt1, Dxt2, Dxt3, Dxt4, Dxt5 が指定できます。

なおピクセルフォーマットが DXT の場合、幅と高さは２のべき乗である必要があります。

Texture2D | ( | int | width,
 |  | int | height,
 |  | bool | mipmap,
 |  | PixelFormat | format,
 |  | PixelBufferOption | option
 | ) |  |

2Dテクスチャを作成する (オプションあり)

引数:
width | テクスチャの幅
height | テクスチャの高さ
mipmap | ミップマップの有無
format | ピクセルフォーマット
option | ピクセルバッファの作成オプション

指定されたパラメータで2Dテクスチャを作成します。ピクセルフォーマットには Rgba, Rgba4444, Rgba5551, Rgb565, LuminanceAlpha, Luminance, Alpha, RgbaH, LuminanceAlphaH, LuminanceH, AlphaH, Dxt1, Dxt2, Dxt3, Dxt4, Dxt5 が指定できます。ただし Renderable オプションを指定した場合は Rgba, Rgba4444, Rgba5551, Rgb565 のみが指定できます。

なおピクセルフォーマットが DXT の場合、幅と高さは２のべき乗である必要があります。

Texture2D | ( | string | fileName,
 |  | bool | mipmap
 | ) |  |

2Dテクスチャを作成する (ファイルから)

引数:
fileName | ファイル名
mipmap | ミップマップの有無

指定されたファイルから2Dテクスチャを作成します。利用可能なファイルフォーマットはDDS, PNG, JPG, BMP, GIF(ただしアニメーションGIFは非対応)です。

なお DDS ファイルの場合 mipmap 引数は無視されます。ピクセルフォーマットが DXT の場合、幅と高さは２のべき乗である必要があります。

Texture2D | ( | string | fileName,
 |  | bool | mipmap,
 |  | PixelFormat | format
 | ) |  |

2Dテクスチャを作成する (ファイルから、フォーマット変換あり)

引数:
fileName | ファイル名
mipmap | ミップマップの有無
format | ピクセルフォーマット

指定されたファイルから2Dテクスチャを作成します。利用可能なファイルフォーマットはDDS, PNG, JPG, BMP, GIF(ただしアニメーションGIFは非対応)です。ピクセルフォーマットには Rgba, Rgba4444, Rgba5551, Rgb565, LuminanceAlpha, Luminance, Alpha, RgbaH, LuminanceAlphaH, LuminanceH, AlphaH が指定できます。

なお DDS ファイルの場合 mipmap, format 引数は無視されます。ピクセルフォーマットが DXT の場合、幅と高さは２のべき乗である必要があります。

Texture2D | ( | byte[] | fileImage,
 |  | bool | mipmap
 | ) |  |

2Dテクスチャを作成する (ファイルイメージから)

引数:
fileImage | ファイルイメージ
mipmap | ミップマップの有無

指定されたファイルイメージから2Dテクスチャを作成します。利用可能なファイルフォーマットはDDS, PNG, JPG, BMP, GIF(ただしアニメーションGIFは非対応)です。

なお DDS ファイルの場合 mipmap 引数は無視されます。ピクセルフォーマットが DXT の場合、幅と高さは２のべき乗である必要があります。

Texture2D | ( | byte[] | fileImage,
 |  | bool | mipmap,
 |  | PixelFormat | format
 | ) |  |

2Dテクスチャを作成する (ファイルイメージから、フォーマット変換あり)

引数:
fileImage | ファイルイメージ
mipmap | ミップマップの有無
format | ピクセルフォーマット

指定されたファイルイメージから2Dテクスチャを作成します。利用可能なファイルフォーマットはDDS, PNG, JPG, BMP, GIF(ただしアニメーションGIFは非対応)です。ピクセルフォーマットには Rgba, Rgba4444, Rgba5551, Rgb565, LuminanceAlpha, Luminance, Alpha, RgbaH, LuminanceAlphaH, LuminanceH, AlphaH が指定できます。

なお DDS ファイルの場合 mipmap, format 引数は無視されます。ピクセルフォーマットが DXT の場合、幅と高さは２のべき乗である必要があります。

Texture2D ( Texture2D texture ) [protected]

2Dテクスチャを複製する

引数:
texture 2Dテクスチャ

2Dテクスチャを複製します。複製された2Dテクスチャはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

メソッド

void GenerateMipmap ( )

ミップマップ画像を自動生成する

現在のゼロレベル画像からミップマップ画像を自動生成します。ミップマップが存在しない場合は何も行いません。DXT ピクセルフォーマットのミップマップ生成には対応していません。

なおピクセルフォーマットが DXT の場合も何も行いません。

void SetPixels | ( | int | level,
 |  | Array | pixels,
 |  | int | dx,
 |  | int | dy,
 |  | int | dw,
 |  | int | dh
 | ) |  |

ピクセルデータをセットする (範囲あり)

引数:
level | ミップマップレベル (0～LevelCount-1)
pixels | ピクセルデータ
dx | 転送先のX座標
dy | 転送先のY座標
dw | 転送先の幅
dh | 転送先の高さ

指定されたミップマップレベルにピクセルデータをセットします。

なおピクセルフォーマットが DXT の場合 dx, dy, dw, dh は４の倍数である必要があります。

void SetPixels | ( | int | level,
 |  | Array | pixels,
 |  | PixelFormat | format,
 |  | int | offset,
 |  | int | pitch,
 |  | int | dx,
 |  | int | dy,
 |  | int | dw,
 |  | int | dh
 | ) |  |

ピクセルデータをセットする (フォーマット変換あり、バイトオフセットあり、範囲あり)

引数:
level | ミップマップレベル (0～LevelCount-1)
pixels | ピクセルデータ
format | ピクセルフォーマット
offset | ピクセルデータのバイトオフセット
pitch | ピクセルデータのバイトピッチ
dx | 転送先のX座標
dy | 転送先のY座標
dw | 転送先の幅
dh | 転送先の高さ

指定されたミップマップレベルにピクセルデータをセットします。ピクセルフォーマットには Rgba またはテクスチャと同じフォーマットが指定できます。

なおピクセルフォーマットが DXT の場合 dx, dy, dw, dh は４の倍数である必要があります。DXT ピクセルフォーマットの変換には対応していません。

void SetPixels | ( | int | level,
 |  | Array | pixels,
 |  | PixelFormat | format
 | ) |  |

ピクセルデータをセットする (フォーマット変換あり)

引数:
level | ミップマップレベル (0～LevelCount-1)
pixels | ピクセルデータ
format | ピクセルフォーマット

指定されたミップマップレベルにピクセルデータをセットします。ピクセルフォーマットには Rgba またはテクスチャと同じフォーマットが指定できます。

なお DXT ピクセルフォーマットの変換には対応していません。

void SetPixels | ( | int | level,
 |  | Array | pixels,
 |  | int | offset,
 |  | int | pitch
 | ) |  |

ピクセルデータをセットする (バイトオフセットあり)

引数:
level | ミップマップレベル (0～LevelCount-1)
pixels | ピクセルデータ
offset | ピクセルデータのバイトオフセット
pitch | ピクセルデータのバイトピッチ

指定されたミップマップレベルにピクセルデータをセットします。

void SetPixels | ( | int | level,
 |  | Array | pixels
 | ) |  |

ピクセルデータをセットする

引数:
level | ミップマップレベル (0～LevelCount-1)
pixels | ピクセルデータ

指定されたミップマップレベルにピクセルデータをセットします。

このオーバーロードは指定されたミップマップレベルのすべてのピクセルにデータをセットします。配列のサイズが必要なサイズと異なる場合は例外をスローします。配列のサイズが必要なサイズより大きい場合は、別のオーバーロードを使用してください。

override Object ShallowClone ( ) [virtual]

2Dテクスチャを複製する

戻り値:
2Dテクスチャの複製

2Dテクスチャを複製します。複製された2Dテクスチャはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

Textureを再定義しています。


クラス TextureCube

キューブテクスチャを表すクラス [詳細]

TextureCubeに対する継承グラフ
Texture PixelBuffer

すべてのメンバ一覧

Public メソッド

TextureCube (int width, bool mipmap, PixelFormat format)
キューブテクスチャを作成する
TextureCube (int width, bool mipmap, PixelFormat format, PixelBufferOption option)
キューブテクスチャを作成する (オプションあり)
TextureCube (string fileName, bool mipmap)
キューブテクスチャを作成する (ファイルから)
TextureCube (string fileName, bool mipmap, PixelFormat format)
キューブテクスチャを作成する (ファイルから、フォーマット変換あり)
TextureCube (byte[] fileImage, bool mipmap)
キューブテクスチャを作成する (ファイルイメージから)
TextureCube (byte[] fileImage, bool mipmap, PixelFormat format)
キューブテクスチャを作成する (ファイルイメージから、フォーマット変換あり)
override Object | ShallowClone ()
キューブテクスチャを複製する
void | SetPixels (int level, TextureCubeFace cubeFace, Array pixels)
ピクセルデータをセットする
void | SetPixels (int level, TextureCubeFace cubeFace, Array pixels, int dx, int dy, int dw, int dh)
ピクセルデータをセットする (範囲あり)
void | SetPixels (int level, TextureCubeFace cubeFace, Array pixels, int offset, int pitch)
ピクセルデータをセットする (バイトオフセットあり)
void | SetPixels (int level, TextureCubeFace cubeFace, Array pixels, PixelFormat format)
ピクセルデータをセットする (フォーマット変換あり)
void | SetPixels (int level, TextureCubeFace cubeFace, Array pixels, PixelFormat format, int offset, int pitch, int dx, int dy, int dw, int dh)
ピクセルデータをセットする (フォーマット変換あり、バイトオフセットあり、範囲あり)
void | GenerateMipmap ()
ミップマップ画像を自動生成する

Protected メソッド

TextureCube (TextureCube texture)
キューブテクスチャを複製する

説明

キューブテクスチャを表すクラス

コンストラクタとデストラクタ

TextureCube | ( | int | width,
 |  | bool | mipmap,
 |  | PixelFormat | format
 | ) |  |

キューブテクスチャを作成する

引数:
width | テクスチャの幅
mipmap | ミップマップの有無
format | ピクセルフォーマット

指定されたパラメータでキューブテクスチャを作成します。テクスチャの幅は2のべき乗である必要があります。ピクセルフォーマットには Rgba, Rgba4444, Rgba5551, Rgb565, LuminanceAlpha, Luminance, Alpha, RgbaH, LuminanceAlphaH, LuminanceH, AlphaH, Dxt1, Dxt2, Dxt3, Dxt4, Dxt5 が指定できます。

TextureCube | ( | int | width,
 |  | bool | mipmap,
 |  | PixelFormat | format,
 |  | PixelBufferOption | option
 | ) |  |

キューブテクスチャを作成する (オプションあり)

引数:
width | テクスチャの幅
mipmap | ミップマップの有無
format | ピクセルフォーマット
option | ピクセルバッファの作成オプション

指定されたパラメータでキューブテクスチャを作成します。テクスチャの幅は2のべき乗である必要があります。ピクセルフォーマットには Rgba, Rgba4444, Rgba5551, Rgb565, LuminanceAlpha, Luminance, Alpha, RgbaH, LuminanceAlphaH, LuminanceH, AlphaH, Dxt1, Dxt2, Dxt3, Dxt4, Dxt5 が指定できます。ただし Renderable オプションを指定した場合は Rgba, Rgba4444, Rgba5551, Rgb565 のみが指定できます。

TextureCube | ( | string | fileName,
 |  | bool | mipmap
 | ) |  |

キューブテクスチャを作成する (ファイルから)

引数:
fileName | ファイル名
mipmap | ミップマップの有無

指定されたファイルからキューブテクスチャを作成します。利用可能なファイルフォーマットはDDS, PNG, JPG, BMP, GIF(ただしアニメーションGIFは非対応)です。テクスチャの幅は2のべき乗である必要があります。画像の短辺は2のべき乗、長辺は短辺の6倍である必要があります。

なお DDS ファイルの場合、画像はキューブマップである必要があり、mipmap 引数は無視されます。

TextureCube | ( | string | fileName,
 |  | bool | mipmap,
 |  | PixelFormat | format
 | ) |  |

キューブテクスチャを作成する (ファイルから、フォーマット変換あり)

引数:
fileName | ファイル名
mipmap | ミップマップの有無
format | ピクセルフォーマット

指定されたファイルからキューブテクスチャを作成します。利用可能なファイルフォーマットはDDS, PNG, JPG, BMP, GIF(ただしアニメーションGIFは非対応)です。テクスチャの幅は2のべき乗である必要があります。画像の短辺は2のべき乗、長辺は短辺の6倍である必要があります。ピクセルフォーマットには Rgba, Rgba4444, Rgba5551, Rgb565, LuminanceAlpha, Luminance, Alpha, RgbaH, LuminanceAlphaH, LuminanceH, AlphaH が指定できます。

なお DDS ファイルの場合、画像はキューブマップである必要があり、mipmap, format 引数は無視されます。

TextureCube | ( | byte[] | fileImage,
 |  | bool | mipmap
 | ) |  |

キューブテクスチャを作成する (ファイルイメージから)

引数:
fileImage | ファイルイメージ
mipmap | ミップマップの有無

指定されたファイルイメージからキューブテクスチャを作成します。利用可能なファイルフォーマットはDDS, PNG, JPG, BMP, GIF(ただしアニメーションGIFは非対応)です。テクスチャの幅は2のべき乗である必要があります。画像の短辺は2のべき乗、長辺は短辺の6倍である必要があります。

なお DDS ファイルの場合、画像はキューブマップである必要があり、mipmap 引数は無視されます。

TextureCube | ( | byte[] | fileImage,
 |  | bool | mipmap,
 |  | PixelFormat | format
 | ) |  |

キューブテクスチャを作成する (ファイルイメージから、フォーマット変換あり)

引数:
fileImage | ファイルイメージ
mipmap | ミップマップの有無
format | ピクセルフォーマット

指定されたファイルイメージからキューブテクスチャを作成します。利用可能なファイルフォーマットはDDS, PNG, JPG, BMP, GIF(ただしアニメーションGIFは非対応)です。テクスチャの幅は2のべき乗である必要があります。画像の短辺は2のべき乗、長辺は短辺の6倍である必要があります。ピクセルフォーマットには Rgba, Rgba4444, Rgba5551, Rgb565, LuminanceAlpha, Luminance, Alpha, RgbaH, LuminanceAlphaH, LuminanceH, AlphaH が指定できます。

なお DDS ファイルの場合、画像はキューブマップである必要があり、mipmap, format 引数は無視されます。

TextureCube ( TextureCube texture ) [protected]

キューブテクスチャを複製する

引数:
texture キューブテクスチャ

キューブテクスチャを複製します。複製されたキューブテクスチャはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

メソッド

void GenerateMipmap ( )

ミップマップ画像を自動生成する

現在のゼロレベル画像からミップマップ画像を自動生成します。ミップマップが存在しない場合は何も行いません。

なおピクセルフォーマットが DXT の場合も何も行いません。

void SetPixels | ( | int | level,
 |  | TextureCubeFace | cubeFace,
 |  | Array | pixels,
 |  | int | dx,
 |  | int | dy,
 |  | int | dw,
 |  | int | dh
 | ) |  |

ピクセルデータをセットする (範囲あり)

引数:
level | ミップマップレベル (0～LevelCount-1)
cubeFace | キューブ面
pixels | ピクセルデータ
dx | 転送先のX座標
dy | 転送先のY座標
dw | 転送先の幅
dh | 転送先の高さ

指定されたミップマップレベルのキューブ面にピクセルデータをセットします。

なおピクセルフォーマットが DXT の場合 dx, dy, dw, dh は４の倍数である必要があります。

void SetPixels | ( | int | level,
 |  | TextureCubeFace | cubeFace,
 |  | Array | pixels,
 |  | PixelFormat | format,
 |  | int | offset,
 |  | int | pitch,
 |  | int | dx,
 |  | int | dy,
 |  | int | dw,
 |  | int | dh
 | ) |  |

ピクセルデータをセットする (フォーマット変換あり、バイトオフセットあり、範囲あり)

引数:
level | ミップマップレベル (0～LevelCount-1)
cubeFace | キューブ面
pixels | ピクセルデータ
format | ピクセルフォーマット
offset | ピクセルデータのバイトオフセット
pitch | ピクセルデータのバイトピッチ
dx | 転送先のX座標
dy | 転送先のY座標
dw | 転送先の幅
dh | 転送先の高さ

指定されたミップマップレベルのキューブ面にピクセルデータをセットします。ピクセルフォーマットには Rgba またはテクスチャと同じフォーマットが指定できます。

なおピクセルフォーマットが DXT の場合 dx, dy, dw, dh は４の倍数である必要があります。DXT ピクセルフォーマットの変換には対応していません。

void SetPixels | ( | int | level,
 |  | TextureCubeFace | cubeFace,
 |  | Array | pixels,
 |  | PixelFormat | format
 | ) |  |

ピクセルデータをセットする (フォーマット変換あり)

引数:
level | ミップマップレベル (0～LevelCount-1)
cubeFace | キューブ面
pixels | ピクセルデータ
format | ピクセルフォーマット

指定されたミップマップレベルのキューブ面にピクセルデータをセットします。ピクセルフォーマットには Rgba またはテクスチャと同じフォーマットが指定できます。

なお DXT ピクセルフォーマットの変換には対応していません。

void SetPixels | ( | int | level,
 |  | TextureCubeFace | cubeFace,
 |  | Array | pixels,
 |  | int | offset,
 |  | int | pitch
 | ) |  |

ピクセルデータをセットする (バイトオフセットあり)

引数:
level | ミップマップレベル (0～LevelCount-1)
cubeFace | キューブ面
pixels | ピクセルデータ
offset | ピクセルデータのバイトオフセット
pitch | ピクセルデータのバイトピッチ

指定されたミップマップレベルのキューブ面にピクセルデータをセットします。

void SetPixels | ( | int | level,
 |  | TextureCubeFace | cubeFace,
 |  | Array | pixels
 | ) |  |

ピクセルデータをセットする

引数:
level | ミップマップレベル (0～LevelCount-1)
cubeFace | キューブ面
pixels | ピクセルデータ

指定されたミップマップレベルのキューブ面にピクセルデータをセットします。

このオーバーロードは指定されたミップマップレベルのキューブ面のすべてのピクセルにデータをセットします。配列のサイズが必要なサイズと異なる場合は例外をスローします。配列のサイズが必要なサイズより大きい場合は、別のオーバーロードを使用してください。

override Object ShallowClone ( ) [virtual]

キューブテクスチャを複製する

戻り値:
キューブテクスチャの複製

キューブテクスチャを複製します。複製されたキューブテクスチャはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

Textureを再定義しています。


クラス VertexBuffer

頂点バッファを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

VertexBuffer (int vertexCount, params VertexFormat[] formats)
頂点バッファを作成する
VertexBuffer (int vertexCount, int indexCount, params VertexFormat[] formats)
頂点バッファを作成する (インデックス配列あり)
VertexBuffer (int vertexCount, int indexCount, int instDivisor, params VertexFormat[] formats)
頂点バッファを作成する (インデックス配列あり、インスタンス除数あり)
virtual Object | ShallowClone ()
頂点バッファを複製する
void | Dispose ()
頂点バッファのアンマネージドリソースを解放する
void | SetVertices (Array vertices)
頂点データをセットする
void | SetVertices (Array vertices, int to, int from, int count)
頂点データをセットする (範囲あり)
void | SetVertices (int stream, Array vertices)
頂点データをセットする (単一ストリーム用)
void | SetVertices (int stream, Array vertices, int to, int from, int count)
頂点データをセットする (単一ストリーム用、範囲あり)
void | SetVertices (int stream, Array vertices, int offset, int stride)
頂点データをセットする (単一ストリーム用、バイトオフセットあり)
void | SetVertices (int stream, Array vertices, VertexFormat format, Vector4 trans, Vector4 scale)
頂点データをセットする (単一ストリーム用、フォーマット変換あり)
void | SetVertices (int stream, Array vertices, VertexFormat format, Vector4 trans, Vector4 scale, int offset, int stride, int to, int from, int count)
頂点データをセットする (単一ストリーム用、フォーマット変換あり、バイトオフセットあり、範囲あり)
void | SetIndices (ushort[] indices)
インデックスデータをセットする
void | SetIndices (ushort[] indices, int to, int from, int count)
インデックスデータをセットする (範囲あり)

Protected メソッド

VertexBuffer (VertexBuffer buffer)
頂点バッファを複製する

プロパティ

VertexFormat[] | Formats [get]
頂点フォーマット
int | VertexCount [get]
頂点数
int | IndexCount [get]
インデックス数
int | StreamCount [get]
ストリーム数
int | InstanceDivisor [get]
インスタンス除数

説明

頂点バッファを表すクラス

コンストラクタとデストラクタ

VertexBuffer | ( | int | vertexCount,
 |  | params VertexFormat[] | formats
 | ) |  |

頂点バッファを作成する

引数:
vertexCount | 頂点数 (0ならば頂点配列なし)
formats | 頂点フォーマット

頂点バッファを作成します。頂点フォーマットには頂点ストリームごとのデータ型を指定してください。

VertexBuffer | ( | int | vertexCount,
 |  | int | indexCount,
 |  | params VertexFormat[] | formats
 | ) |  |

頂点バッファを作成する (インデックス配列あり)

引数:
vertexCount | 頂点数 (0ならば頂点配列なし)
indexCount | インデックス数 (0ならばインデックス配列なし)
formats | 頂点フォーマット

頂点バッファを作成します。インデックス数を指定することでインデックス配列が使用可能になります。頂点フォーマットには頂点ストリームごとのデータ型を指定してください。

VertexBuffer | ( | int | vertexCount,
 |  | int | indexCount,
 |  | int | instDivisor,
 |  | params VertexFormat[] | formats
 | ) |  |

頂点バッファを作成する (インデックス配列あり、インスタンス除数あり)

引数:
vertexCount | 頂点数 (0ならば頂点配列なし)
indexCount | インデックス数 (0ならばインデックス配列なし)
instDivisor | インスタンス除数 (0または1)
formats | 頂点フォーマット

頂点バッファを作成します。インデックス数を指定することでインデックス配列が使用可能になります。頂点フォーマットには頂点ストリームごとのデータ型を指定してください。

インスタンス除数はインスタンス描画に使用されます。詳しくは GraphicsContext.DrawArraysInstanced() を参照してください。

VertexBuffer ( VertexBuffer buffer ) [protected]

頂点バッファを複製する

引数:
buffer 頂点バッファ

頂点バッファを複製します。複製された頂点バッファはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

メソッド

void SetIndices ( ushort[] indices )

インデックスデータをセットする

引数:
indices インデックスデータ

インデックスデータをセットします。

このオーバーロードはすべてのインデックスに対してデータをセットします。配列のサイズが必要なサイズと異なる場合は例外をスローします。配列のサイズが必要なサイズより大きい場合は、別のオーバーロードを使用してください。

void SetIndices | ( | ushort[] | indices,
 |  | int | to,
 |  | int | from,
 |  | int | count
 | ) |  |

インデックスデータをセットする (範囲あり)

引数:
indices | インデックスデータ
to | 転送先のインデックス番号
from | 転送元のインデックス番号
count | 転送されるインデックス数

インデックスデータをセットします。

void SetVertices | ( | int | stream,
 |  | Array | vertices,
 |  | VertexFormat | format,
 |  | Vector4 | trans,
 |  | Vector4 | scale
 | ) |  |

頂点データをセットする (単一ストリーム用、フォーマット変換あり)

引数:
stream | ストリーム番号 (0～StreamCount-1)
vertices | 頂点データ
format | 頂点フォーマット
trans | トランスレーション値
scale | スケール値

指定されたストリームに頂点データをセットします。頂点フォーマットには、頂点バッファと同じフォーマットまたは同じ次元数のfloatベクトルフォーマットを指定できます。頂点フォーマットにfloatベクトルフォーマットを指定した場合は、頂点データを(vertex-trans)/scaleの計算式で変換することができます。

void SetVertices | ( | Array | vertices,
 |  | int | to,
 |  | int | from,
 |  | int | count
 | ) |  |

頂点データをセットする (範囲あり)

引数:
vertices | 頂点データ
to | 転送先の頂点番号
from | 転送元の頂点番号
count | 転送される頂点数

頂点データをセットします。頂点データはインターリーブ形式で指定してください。

void SetVertices | ( | int | stream,
 |  | Array | vertices,
 |  | int | to,
 |  | int | from,
 |  | int | count
 | ) |  |

頂点データをセットする (単一ストリーム用、範囲あり)

引数:
stream | ストリーム番号 (0～StreamCount-1)
vertices | 頂点データ
to | 転送先の頂点番号
from | 転送元の頂点番号
count | 転送される頂点数

指定されたストリームに頂点データをセットします。

void SetVertices | ( | int | stream,
 |  | Array | vertices
 | ) |  |

頂点データをセットする (単一ストリーム用)

引数:
stream | ストリーム番号 (0～StreamCount-1)
vertices | 頂点データ

指定されたストリームに頂点データをセットします。

このオーバーロードはすべての頂点に対してデータをセットします。配列のサイズが必要なサイズと異なる場合は例外をスローします。配列のサイズが必要なサイズより大きい場合は、別のオーバーロードを使用してください。

void SetVertices ( Array vertices )

頂点データをセットする

引数:
vertices 頂点データ

頂点データをセットします。頂点データはインターリーブ形式で指定してください。

このオーバーロードはすべての頂点にデータをセットします。配列のサイズが必要なサイズと異なる場合は例外をスローします。配列のサイズが必要なサイズより大きい場合は、別のオーバーロードを使用してください。

void SetVertices | ( | int | stream,
 |  | Array | vertices,
 |  | int | offset,
 |  | int | stride
 | ) |  |

頂点データをセットする (単一ストリーム用、バイトオフセットあり)

引数:
stream | ストリーム番号 (0～StreamCount-1)
vertices | 頂点データ
offset | 頂点データのバイトオフセット
stride | 頂点データのバイトストライド

指定されたストリームに頂点データをセットします。

void SetVertices | ( | int | stream,
 |  | Array | vertices,
 |  | VertexFormat | format,
 |  | Vector4 | trans,
 |  | Vector4 | scale,
 |  | int | offset,
 |  | int | stride,
 |  | int | to,
 |  | int | from,
 |  | int | count
 | ) |  |

頂点データをセットする (単一ストリーム用、フォーマット変換あり、バイトオフセットあり、範囲あり)

引数:
stream | ストリーム番号 (0～StreamCount-1)
vertices | 頂点データ
format | 頂点フォーマット
trans | トランスレーション値
scale | スケール値
offset | 頂点データのバイトオフセット
stride | 頂点データのバイトストライド
to | 転送先の頂点番号
from | 転送元の頂点番号
count | 転送される頂点数

指定されたストリームに頂点データをセットします。頂点フォーマットには、頂点バッファと同じフォーマットまたは同じ次元数のfloatベクトルフォーマットを指定できます。頂点フォーマットにfloatベクトルフォーマットを指定した場合は、頂点データを(vertex-trans)/scaleの計算式で変換することができます。

virtual Object ShallowClone ( ) [virtual]

頂点バッファを複製する

戻り値:
頂点バッファの複製

頂点バッファを複製します。複製された頂点バッファはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。


構造体 BlendFunc

アルファブレンド関数を表す構造体 [詳細]

すべてのメンバ一覧

Public メソッド

BlendFunc (BlendFuncMode mode, BlendFuncFactor srcFactor, BlendFuncFactor dstFactor)
アルファブレンド関数を表す構造体を作成する
void | Set (BlendFuncMode mode, BlendFuncFactor srcFactor, BlendFuncFactor dstFactor)
アルファブレンド関数を表す構造体に値をセットする

プロパティ

BlendFuncMode | Mode [get, set]
アルファブレンド関数のモード
BlendFuncFactor | SrcFactor [get, set]
アルファブレンド関数のソース係数
BlendFuncFactor | DstFactor [get, set]
アルファブレンド関数のデスティネーション係数

説明

アルファブレンド関数を表す構造体

コンストラクタとデストラクタ

BlendFunc | ( | BlendFuncMode | mode,
 |  | BlendFuncFactor | srcFactor,
 |  | BlendFuncFactor | dstFactor
 | ) |  |

アルファブレンド関数を表す構造体を作成する

引数:
mode | アルファブレンド関数のモード
srcFactor | アルファブレンド関数のソース係数
dstFactor | アルファブレンド関数のデスティネーション係数

メソッド

void Set | ( | BlendFuncMode | mode,
 |  | BlendFuncFactor | srcFactor,
 |  | BlendFuncFactor | dstFactor
 | ) |  |

アルファブレンド関数を表す構造体に値をセットする

引数:
mode | アルファブレンド関数のモード
srcFactor | アルファブレンド関数のソース係数
dstFactor | アルファブレンド関数のデスティネーション係数


構造体 CullFace

バックフェースカリングを表す構造体 [詳細]

すべてのメンバ一覧

Public メソッド

CullFace (CullFaceMode mode, CullFaceDirection direction)
バックフェースカリングを表す構造体を作成する
void | Set (CullFaceMode mode, CullFaceDirection direction)
バックフェースカリングを表す構造体に値をセットする

プロパティ

CullFaceMode | Mode [get, set]
バックフェースカリングのモード
CullFaceDirection | Direction [get, set]
バックフェースカリングの表面方向

説明

バックフェースカリングを表す構造体

コンストラクタとデストラクタ

CullFace | ( | CullFaceMode | mode,
 |  | CullFaceDirection | direction
 | ) |  |

バックフェースカリングを表す構造体を作成する

引数:
mode | バックフェースカリングのモード
direction | バックフェースカリングの表面方向

メソッド

void Set | ( | CullFaceMode | mode,
 |  | CullFaceDirection | direction
 | ) |  |

バックフェースカリングを表す構造体に値をセットする

引数:
mode | バックフェースカリングのモード
direction | バックフェースカリングの表面方向


構造体 DepthFunc

デプステスト関数を表す構造体 [詳細]

すべてのメンバ一覧

Public メソッド

DepthFunc (DepthFuncMode mode, bool writeMask)
デプステスト関数を表す構造体を作成する
void | Set (DepthFuncMode mode, bool writeMask)
デプステスト関数を表す構造体に値をセットする

プロパティ

DepthFuncMode | Mode [get, set]
デプステスト関数のモード
bool | WriteMask [get, set]
デプステスト関数の書き込みマスク

説明

デプステスト関数を表す構造体

コンストラクタとデストラクタ

DepthFunc | ( | DepthFuncMode | mode,
 |  | bool | writeMask
 | ) |  |

デプステスト関数を表す構造体を作成する

引数:
mode | デプステスト関数のモード
writeMask | デプステスト関数の書き込みマスク

メソッド

void Set | ( | DepthFuncMode | mode,
 |  | bool | writeMask
 | ) |  |

デプステスト関数を表す構造体に値をセットする

引数:
mode | デプステスト関数のモード
writeMask | デプステスト関数の書き込みマスク


  • Sce
  • PlayStation
  • Core
  • Graphics
  • GraphicsCaps
プロパティ

構造体 GraphicsCaps

グラフィクス能力を表すクラス [詳細]

すべてのメンバ一覧

プロパティ

int | MaxViewportWidth [get]
ビューポートの最大幅
int | MaxViewportHeight [get]
ビューポートの最大高さ
int | MaxTextureSize [get]
テクスチャの最大幅と高さ
int | MaxCubeMapTextureSize [get]
キューブテクスチャの最大幅と高さ
int | MaxRenderbufferSize [get]
レンダバッファの最大幅と高さ
int | MaxVertexUniformVectors [get]
頂点シェーダーのユニフォーム変数の最大ベクトル数
int | MaxFragmentUniformVectors [get]
フラグメントシェーダーのユニフォーム変数の最大ベクトル数
int | MaxVertexAttribs [get]
頂点アトリビュートの最大ベクトル数
int | MaxVaryingVectors [get]
varying変数の最大ベクトル数
int | MaxTextureImageUnits [get]
フラグメントシェーダーのテクスチャユニットの最大数
float | MaxTextureMaxAnisotropy [get]
テクスチャフィルタの異方性の最大値
float | MinAliasedLineWidth [get]
ラインの最小幅
float | MaxAliasedLineWidth [get]
ラインの最大幅
float | MinAliasedPointSize [get]
ポイントの最小サイズ
float | MaxAliasedPointSize [get]
ポイントの最大サイズ
bool | SupportTextureFilterAnisotropic [get]
テクスチャに異方性フィルタを適用できる
bool | SupportVertexHalfFloat [get]
half float形式の頂点バッファを作成できる
bool | SupportTextureHalfFloat [get]
half float形式のテクスチャを作成できる
bool | SupportTextureHalfFloatLinear [get]
half float形式のテクスチャのテクスチャフィルタにリニアモードを適用できる
bool | SupportRgb8Rgba8 [get]
RGBA 8bit形式のカラーバッファを作成できる
bool | SupportDepth24 [get]
デプス 24bit形式のデプスバッファを作成できる
bool | SupportPackedDepthStencil [get]
デプスステンシル 24bit+8bit形式のデプスバッファを作成できる

説明

グラフィクス能力を表すクラス


構造体 PolygonOffset

ポリゴンオフセットを表す構造体 [詳細]

すべてのメンバ一覧

Public メソッド

PolygonOffset (float factor, float units)
ポリゴンオフセットを表す構造体を作成する
void | Set (float factor, float units)
ポリゴンオフセットを表す構造体に値をセットする

Public 変数

float | Factor
ポリゴンオフセットのスケーリング係数
float | Units
ポリゴンオフセットのオフセット係数

説明

ポリゴンオフセットを表す構造体

コンストラクタとデストラクタ

PolygonOffset | ( | float | factor,
 |  | float | units
 | ) |  |

ポリゴンオフセットを表す構造体を作成する

引数:
factor | ポリゴンオフセットのスケーリング係数
units | ポリゴンオフセットのオフセット係数

メソッド

void Set | ( | float | factor,
 |  | float | units
 | ) |  |

ポリゴンオフセットを表す構造体に値をセットする

引数:
factor | ポリゴンオフセットのスケーリング係数
units | ポリゴンオフセットのオフセット係数


構造体 Primitive

プリミティブを表す構造体 [詳細]

すべてのメンバ一覧

Public メソッド

Primitive (DrawMode mode, int first, int count, int userData)
プリミティブを表す構造体を作成する
void | Set (DrawMode mode, int first, int count, int userData)
プリミティブを表す構造体に値をセットする

Public 変数

DrawMode Mode
プリミティブの描画モード
ushort | First
プリミティブの開始頂点
ushort | Count
プリミティブの頂点数
ushort | UserData
ユーザーデータ

説明

プリミティブを表す構造体

コンストラクタとデストラクタ

Primitive | ( | DrawMode | mode,
 |  | int | first,
 |  | int | count,
 |  | int | userData
 | ) |  |

プリミティブを表す構造体を作成する

引数:
mode | プリミティブの描画モード
first | プリミティブの開始頂点
count | プリミティブの頂点数
userData | ユーザーデータ

メソッド

void Set | ( | DrawMode | mode,
 |  | int | first,
 |  | int | count,
 |  | int | userData
 | ) |  |

プリミティブを表す構造体に値をセットする

引数:
mode | プリミティブの描画モード
first | プリミティブの開始頂点
count | プリミティブの頂点数
userData | ユーザーデータ


構造体 RenderTarget

レンダリング結果の格納先を表す構造体 [詳細]

すべてのメンバ一覧

Public メソッド

RenderTarget (ColorBuffer buffer)
レンダリング結果の格納先を表す構造体を作成する
RenderTarget (DepthBuffer buffer)
レンダリング結果の格納先を表す構造体を作成する
RenderTarget (Texture2D texture, int level)
レンダリング結果の格納先を表す構造体を作成する
RenderTarget (TextureCube texture, int level, TextureCubeFace cubeFace)
レンダリング結果の格納先を表す構造体を作成する
void | Set (ColorBuffer buffer)
レンダリング結果の格納先を表す構造体に値をセットする
void | Set (DepthBuffer buffer)
レンダリング結果の格納先を表す構造体に値をセットする
void | Set (Texture2D texture, int level)
レンダリング結果の格納先を表す構造体に値をセットする
void | Set (TextureCube texture, int level, TextureCubeFace cubeFace)
レンダリング結果の格納先を表す構造体に値をセットする

Public 変数

PixelBuffer Buffer
レンダリング結果を格納するピクセルバッファ
int | Level
レンダリング結果を格納するテクスチャのミップマップレベル
TextureCubeFace CubeFace
レンダリング結果を格納するキューブテクスチャのキューブ面

説明

レンダリング結果の格納先を表す構造体

コンストラクタとデストラクタ

RenderTarget ( ColorBuffer buffer )

レンダリング結果の格納先を表す構造体を作成する

引数:
buffer カラーバッファ (nullならば解除)
RenderTarget ( DepthBuffer buffer )

レンダリング結果の格納先を表す構造体を作成する

引数:
buffer デプスバッファ (nullならば解除)
RenderTarget | ( | Texture2D | texture,
 |  | int | level
 | ) |  |

レンダリング結果の格納先を表す構造体を作成する

引数:
texture | 2Dテクスチャ (nullならば解除)
level | テクスチャのミップマップレベル (0～LevelCount-1)
RenderTarget | ( | TextureCube | texture,
 |  | int | level,
 |  | TextureCubeFace | cubeFace
 | ) |  |

レンダリング結果の格納先を表す構造体を作成する

引数:
texture | キューブテクスチャ (nullならば解除)
level | テクスチャのミップマップレベル (0～LevelCount-1)
cubeFace | キューブテクスチャのキューブ面

メソッド

void Set ( ColorBuffer buffer )

レンダリング結果の格納先を表す構造体に値をセットする

引数:
buffer カラーバッファ (nullならば解除)
void Set | ( | TextureCube | texture,
 |  | int | level,
 |  | TextureCubeFace | cubeFace
 | ) |  |

レンダリング結果の格納先を表す構造体に値をセットする

引数:
texture | キューブテクスチャ (nullならば解除)
level | テクスチャのミップマップレベル (0～LevelCount-1)
cubeFace | キューブテクスチャのキューブ面
void Set | ( | Texture2D | texture,
 |  | int | level
 | ) |  |

レンダリング結果の格納先を表す構造体に値をセットする

引数:
texture | 2Dテクスチャ (nullならば解除)
level | テクスチャのミップマップレベル (0～LevelCount-1)
void Set ( DepthBuffer buffer )

レンダリング結果の格納先を表す構造体に値をセットする

引数:
buffer デプスバッファ (nullならば解除)


構造体 StencilFunc

ステンシルテスト関数を表す構造体 [詳細]

すべてのメンバ一覧

Public メソッド

StencilFunc (StencilFuncMode mode, int reference, int readMask, int writeMask)
ステンシルテスト関数を表す構造体を作成する
void | Set (StencilFuncMode mode, int reference, int readMask, int writeMask)
ステンシルテスト関数を表す構造体に値をセットする

プロパティ

StencilFuncMode | Mode [get, set]
ステンシルテスト関数のモード
int | Reference [get, set]
ステンシルテスト関数の参照値 (0～255)
int | ReadMask [get, set]
ステンシルテスト関数の読み込みマスク (0～255)
int | WriteMask [get, set]
ステンシルテスト関数の書き込みマスク (0～255)

説明

ステンシルテスト関数を表す構造体

コンストラクタとデストラクタ

StencilFunc | ( | StencilFuncMode | mode,
 |  | int | reference,
 |  | int | readMask,
 |  | int | writeMask
 | ) |  |

ステンシルテスト関数を表す構造体を作成する

引数:
mode | ステンシルテスト関数のモード
reference | ステンシルテスト関数の参照値 (0～255)
readMask | ステンシルテスト関数の読み込みマスク (0～255)
writeMask | ステンシルテスト関数の書き込みマスク (0～255)

メソッド

void Set | ( | StencilFuncMode | mode,
 |  | int | reference,
 |  | int | readMask,
 |  | int | writeMask
 | ) |  |

ステンシルテスト関数を表す構造体に値をセットする

引数:
mode | ステンシルテスト関数のモード
reference | ステンシルテスト関数の参照値 (0～255)
readMask | ステンシルテスト関数の読み込みマスク (0～255)
writeMask | ステンシルテスト関数の書き込みマスク (0～255)


構造体 StencilOp

ステンシルテスト操作を表す構造体 [詳細]

すべてのメンバ一覧

Public メソッド

StencilOp (StencilOpMode fail, StencilOpMode zFail, StencilOpMode zPass)
ステンシルテスト操作を表す構造体を作成する
void | Set (StencilOpMode fail, StencilOpMode zFail, StencilOpMode zPass)
ステンシルテスト操作を表す構造体に値をセットする

プロパティ

StencilOpMode | Fail [get, set]
ステンシルテスト操作のステンシル不合格モード
StencilOpMode | ZFail [get, set]
ステンシルテスト操作のデプス不合格モード
StencilOpMode | ZPass [get, set]
ステンシルテスト操作のデプス合格モード

説明

ステンシルテスト操作を表す構造体

コンストラクタとデストラクタ

StencilOp | ( | StencilOpMode | fail,
 |  | StencilOpMode | zFail,
 |  | StencilOpMode | zPass
 | ) |  |

ステンシルテスト操作を表す構造体を作成する

引数:
fail | ステンシルテスト操作のステンシル不合格モード
zFail | ステンシルテスト操作のデプス不合格モード
zPass | ステンシルテスト操作のデプス合格モード

メソッド

void Set | ( | StencilOpMode | fail,
 |  | StencilOpMode | zFail,
 |  | StencilOpMode | zPass
 | ) |  |

ステンシルテスト操作を表す構造体に値をセットする

引数:
fail | ステンシルテスト操作のステンシル不合格モード
zFail | ステンシルテスト操作のデプス不合格モード
zPass | ステンシルテスト操作のデプス合格モード


構造体 TextureFilter

テクスチャフィルタを表す構造体 [詳細]

すべてのメンバ一覧

Public メソッド

TextureFilter (TextureFilterMode mag, TextureFilterMode min, TextureFilterMode mip)
テクスチャフィルタを表す構造体を作成する
void | Set (TextureFilterMode mag, TextureFilterMode min, TextureFilterMode mip)
テクスチャフィルタを表す構造体に値をセットする

プロパティ

TextureFilterMode | Mag [get, set]
拡大テクスチャフィルタのモード
TextureFilterMode | Min [get, set]
縮小テクスチャフィルタのモード
TextureFilterMode | Mip [get, set]
ミップマップテクスチャフィルタのモード

説明

テクスチャフィルタを表す構造体

コンストラクタとデストラクタ

TextureFilter | ( | TextureFilterMode | mag,
 |  | TextureFilterMode | min,
 |  | TextureFilterMode | mip
 | ) |  |

テクスチャフィルタを表す構造体を作成する

引数:
mag | 拡大テクスチャフィルタのモード
min | 縮小テクスチャフィルタのモード
mip | ミップマップテクスチャフィルタのモード

メソッド

void Set | ( | TextureFilterMode | mag,
 |  | TextureFilterMode | min,
 |  | TextureFilterMode | mip
 | ) |  |

テクスチャフィルタを表す構造体に値をセットする

引数:
mag | 拡大テクスチャフィルタのモード
min | 縮小テクスチャフィルタのモード
mip | ミップマップテクスチャフィルタのモード


構造体 TextureWrap

テクスチャラップを表す構造体 [詳細]

すべてのメンバ一覧

Public メソッド

TextureWrap (TextureWrapMode s, TextureWrapMode t)
テクスチャラップを表す構造体を作成する
void | Set (TextureWrapMode s, TextureWrapMode t)
テクスチャラップを表す構造体に値をセットする

プロパティ

TextureWrapMode | S [get, set]
S座標のテクスチャラップのモード
TextureWrapMode | T [get, set]
T座標のテクスチャラップのモード

説明

テクスチャラップを表す構造体

コンストラクタとデストラクタ

TextureWrap | ( | TextureWrapMode | s,
 |  | TextureWrapMode | t
 | ) |  |

テクスチャラップを表す構造体を作成する

引数:
s | S座標のテクスチャラップのモード
t | T座標のテクスチャラップのモード

メソッド

void Set | ( | TextureWrapMode | s,
 |  | TextureWrapMode | t
 | ) |  |

テクスチャラップを表す構造体に値をセットする

引数:
s | S座標のテクスチャラップのモード
t | T座標のテクスチャラップのモード


パッケージ Sce.PlayStation.Core.Imaging

構成

struct | FontMetrics
フォントのメトリクス情報 [詳細]
struct | CharMetrics
文字ごとのメトリクス情報 [詳細]
class | Font
フォント [詳細]
struct | ImageSize
画像のサイズ [詳細]
struct | ImagePosition
画像の中の座標 (左上原点) [詳細]
struct | ImageRect
画像の中の矩形領域 [詳細]
struct | ImageColor
画素の色 [詳細]
class | Image
画像 [詳細]

列挙型

enum | FontAlias { System = 0 }

フォントの別名

[詳細]
enum | FontStyle { Regular = 0, Bold = 1<<0, Italic = 1<<1 }

フォントのスタイル

[詳細]
enum | ImageMode { Rgba, A }

画像のモード(ピクセルの形式)

[詳細]

列挙型

enum FontAlias

フォントの別名

列挙型の値:
System

システム標準のフォント

enum FontStyle

フォントのスタイル

列挙型の値:
Regular

通常のスタイル

Bold

太字

Italic

斜体

enum ImageMode

画像のモード(ピクセルの形式)

列挙型の値:
Rgba

R G B A それぞれ 8bit ずつ、合わせて 32bit のモード

A

アルファのみ 8bit のモード


クラス Font

フォント [詳細]

すべてのメンバ一覧

Public メソッド

Font (string filename, int size, FontStyle style)
Fontのコンストラクタ(ファイル名とサイズとスタイルから)
Font (FontAlias alias, int size, FontStyle style)
Fontのコンストラクタ(別名とサイズとスタイルから)
virtual Object | ShallowClone ()
Fontのコンストラクタ(別のFontオブジェクトからコピー)
void | Dispose ()
Fontのアンマネージドリソースを解放する
int | GetTextWidth (string text)
与えられた文字列をこのフォントで描画するときに必要な横幅を計算する (文字列全体)
int | GetTextWidth (string text, int offset, int len)
与えられた文字列をこのフォントで描画するときに必要な横幅を計算する (文字列の一部)
CharMetrics[] | GetTextMetrics (string text)
与えられた文字列の1文字ごとのメトリクス情報を取得する (文字列全体)
CharMetrics[] | GetTextMetrics (string text, int offset, int len)
与えられた文字列の1文字ごとのメトリクス情報を取得する (文字列の一部)

Protected メソッド

Font (Font font)
Fontのコンストラクタ(別のFontオブジェクトからコピー)

プロパティ

string | Name [get]
フォント名
int | Size [get]
サイズ
FontStyle | Style [get]
スタイル
FontMetrics | Metrics [get]
フォントメトリックス

説明

フォント

コンストラクタとデストラクタ

Font | ( | string | filename,
 |  | int | size,
 |  | FontStyle | style
 | ) |  |

Fontのコンストラクタ(ファイル名とサイズとスタイルから)

引数:
filename | フォントのファイル名
size | サイズ
style | スタイル

引数 size は 1～1024 の範囲に収まっている必要があります。またフォントによって小さすぎるサイズで生成できない場合があります。

Font | ( | FontAlias | alias,
 |  | int | size,
 |  | FontStyle | style
 | ) |  |

Fontのコンストラクタ(別名とサイズとスタイルから)

引数:
alias | フォントの別名
size | サイズ
style | スタイル

引数 size は 1～1024 の範囲に収まっている必要があります。またフォントによって小さすぎるサイズで生成できない場合があります。

Font ( Font font ) [protected]

Fontのコンストラクタ(別のFontオブジェクトからコピー)

引数:
font コピー元のFontオブジェクト

別のFontオブジェクトをコピーして、新しいFontオブジェクトを生成します。ただしFontの実体はコピーされず、1つのアンマネージドリソースが共有されます。Fontのアンマネージドリソースを解放するために、コピーされた全てのFontオブジェクトに関して、Dispose() を呼び出す必要があります。

メソッド

CharMetrics [] GetTextMetrics ( string text )

与えられた文字列の1文字ごとのメトリクス情報を取得する (文字列全体)

引数:
text 文字列
戻り値:
1文字ごとのメトリクス情報の配列
CharMetrics [] GetTextMetrics | ( | string | text,
 |  | int | offset,
 |  | int | len
 | ) |  |

与えられた文字列の1文字ごとのメトリクス情報を取得する (文字列の一部)

引数:
text | 文字列全体
offset | 文字列のメトリクス情報の取得を行う部分のオフセット
len | 文字列のメトリクス情報の取得を行う部分の長さ
戻り値:
1文字ごとのメトリクス情報の配列
int GetTextWidth ( string text )

与えられた文字列をこのフォントで描画するときに必要な横幅を計算する (文字列全体)

引数:
text 文字列
戻り値:
横幅
int GetTextWidth | ( | string | text,
 |  | int | offset,
 |  | int | len
 | ) |  |

与えられた文字列をこのフォントで描画するときに必要な横幅を計算する (文字列の一部)

引数:
text | 文字列全体
offset | 文字列の横幅計算に使用する部分のオフセット
len | 文字列の横幅計算に使用する部分の長さ
戻り値:
横幅
virtual Object ShallowClone ( ) [virtual]

Fontのコンストラクタ(別のFontオブジェクトからコピー)

引数:
font コピー元のFontオブジェクト

別のFontオブジェクトをコピーして、新しいFontオブジェクトを生成します。ただしFontの実体はコピーされず、1つのアンマネージドリソースが共有されます。Fontのアンマネージドリソースを解放するために、コピーされた全てのFontオブジェクトに関して、Dispose() を呼び出す必要があります。


クラス Image

画像 [詳細]

すべてのメンバ一覧

Public メソッド

Image (string filename)
Imageのコンストラクタ(ファイル名から)
Image (byte[] fileImage)
Imageのコンストラクタ(ファイルイメージから)
Image (ImageMode mode, ImageSize size, ImageColor color)
Imageのコンストラクタ(画像のモードとサイズと色から)
Image (ImageMode mode, ImageSize size, byte[] buffer)
Imageのコンストラクタ(画像のモードとサイズとバッファから)
virtual Object | ShallowClone ()
Imageオブジェクトのコピー
void | Dispose ()
Image のアンマネージドリソースを解放する
void | Decode ()
画像をデコードする
byte[] | ToBuffer ()
画像のメモリイメージを取得する
void | ReadBuffer (byte[] buffer)
与えられたバッファに画像のメモリイメージを読み出す
Image | Resize (ImageSize size)
画像をスケールした新しいImageオブジェクトを作成する
Image | Crop (ImageRect rect)
画像の一部を切り出した新しいImageオブジェクトを作成する
void | DrawImage (Image source, ImagePosition position)
画像の中に別の画像を貼り付ける
void | DrawRectangle (ImageColor color, ImageRect rect)
画像の中に単色で矩形を描画する
void | DrawText (string text, ImageColor color, Font font, ImagePosition position)
画像の中にテキストを描画する (string全体)
void | DrawText (string text, int offset, int len, ImageColor color, Font font, ImagePosition position)
画像の中にテキストを描画する (stringの一部)
void | Export (string albumname, string filename)
画像を指定したファイル名で保存する
void | SaveAs (string path)
画像を指定したファイルパスに保存する

Protected メソッド

Image (Image image)
Imageのコンストラクタ(別のImageオブジェクトからコピー)

プロパティ

ImageSize | Size [get]
画像のサイズ
ImageSize | DecodeSize [set]
画像のデコード時のサイズ

説明

画像

コンストラクタとデストラクタ

Image ( string filename )

Imageのコンストラクタ(ファイル名から)

引数:
filename 画像のファイル名

画像ファイルからImageを生成した直後は、画像は実際にはデコードされていません。画像をデコードするには Decode() を呼ぶ必要があります。ただし画像がデコードされていない場合でも、Size などを取得することはできます。 現在対応している画像ファイルのフォーマットは、PNG形式/BMP形式/JPG形式/GIF形式です。

Image ( byte[] fileImage )

Imageのコンストラクタ(ファイルイメージから)

引数:
fileImage 画像のファイルイメージ

画像ファイルからImageを生成した直後は、画像は実際にはデコードされていません。画像をデコードするには Decode() を呼ぶ必要があります。ただし画像がデコードされていない場合でも、Size などを取得することはできます。 現在対応している画像ファイルのフォーマットは、PNG形式/BMP形式/JPG形式/GIF形式です。

Image | ( | ImageMode | mode,
 |  | ImageSize | size,
 |  | ImageColor | color
 | ) |  |

Imageのコンストラクタ(画像のモードとサイズと色から)

引数:
mode | 画像のモード
size | 画像のサイズ
color | 色

引数 size に与える幅と高さは、それぞれ 0～4096 の範囲に収まっている必要があります。

Image | ( | ImageMode | mode,
 |  | ImageSize | size,
 |  | byte[] | buffer
 | ) |  |

Imageのコンストラクタ(画像のモードとサイズとバッファから)

引数:
mode | 画像のモード
size | 画像のサイズ
buffer | 色

引数 size に与える幅と高さは、それぞれ 0～4096 の範囲に収まっている必要があります。

Image ( Image image ) [protected]

Imageのコンストラクタ(別のImageオブジェクトからコピー)

引数:
image コピー元のImageオブジェクト

別のImageオブジェクトをコピーして、新しいImageオブジェクトを生成します。ただしImageの実体はコピーされず、1つのアンマネージドリソースが共有されます。Imageのアンマネージドリソースを解放するために、コピーされた全てのImageオブジェクトに関して、Dispose() を呼び出す必要があります。

メソッド

Image Crop ( ImageRect rect )

画像の一部を切り出した新しいImageオブジェクトを作成する

引数:
rect 切り出す矩形の範囲
戻り値:
切りだされた画像
void DrawImage | ( | Image | source,
 |  | ImagePosition | position
 | ) |  |

画像の中に別の画像を貼り付ける

引数:
source | 貼り付ける画像
position | 貼り付け位置の座標(左上)
void DrawRectangle | ( | ImageColor | color,
 |  | ImageRect | rect
 | ) |  |

画像の中に単色で矩形を描画する

引数:
color | 矩形の色
rect | 矩形
void DrawText | ( | string | text,
 |  | ImageColor | color,
 |  | Font | font,
 |  | ImagePosition | position
 | ) |  |

画像の中にテキストを描画する (string全体)

引数:
text | 文字列
color | 文字の色
font | フォント
position | 画像の中の座標(文字列の左上)

DrawTextは、透明なImageにテキストを描画することを想定した動作になっています。RGB値は引数 color に与えた色で上書きし、Alpha値はブレンド処理されます。 不透明なImageに対してDrawTextを呼び出した場合は、期待した結果を得ることはできません。

void DrawText | ( | string | text,
 |  | int | offset,
 |  | int | len,
 |  | ImageColor | color,
 |  | Font | font,
 |  | ImagePosition | position
 | ) |  |

画像の中にテキストを描画する (stringの一部)

引数:
text | 文字列
offset | 文字列の中の描画に使用する位置のオフセット
len | 文字列の中の描画に使用する長さ
color | 文字の色
font | フォント
position | 画像の中の座標(文字列の左上)

DrawTextは、透明なImageにテキストを描画することを想定した動作になっています。RGB値は引数 color に与えた色で上書きし、Alpha値はブレンド処理されます。 不透明なImageに対してDrawTextを呼び出した場合は、期待した結果を得ることはできません。

void Export | ( | string | albumname,
 |  | string | filename
 | ) |  |

画像を指定したファイル名で保存する

引数:
albumname | 出力アルバム名
filename | 出力ファイル名

引数は A-Za-z0-9!#$%&'()+,-.;=@[]^_`{} 以外の文字を使用することはできません。また64文字以上使用することはできません。 現在保存対象として有効な画像ファイルは、PNG形式(.png)/JPG形式(.jpg)/BMP形式(.bmp)です。引数 filename に保存したい画象フォーマットの拡張子を含めて指定する必要があります。 Windowsシミュレータ上で実行した場合、"My Pictures"フォルダー以下に保存されます。

void ReadBuffer ( byte[] buffer )

与えられたバッファに画像のメモリイメージを読み出す

引数:
buffer 読み出し先のバッファ
Image Resize ( ImageSize size )

画像をスケールした新しいImageオブジェクトを作成する

引数:
size スケール後の画像のサイズ
戻り値:
スケールされた画像
void SaveAs ( string path )

画像を指定したファイルパスに保存する

引数:
path 出力ファイルパス

引数は / および、A-Za-z0-9!#$%&'()+,-.;=@[]^_`{} 以外の文字を使用することはできません。 現在保存対象として有効な画像ファイルは、PNG形式(.png)/JPG形式(.jpg)/BMP形式(.bmp)です。引数 path に保存したい画象フォーマットの拡張子を含めて指定する必要があります。

virtual Object ShallowClone ( ) [virtual]

Imageオブジェクトのコピー

別のImageオブジェクトをコピーして、新しいImageオブジェクトを生成します。ただしImageの実体はコピーされず、1つのアンマネージドリソースが共有されます。Imageのアンマネージドリソースを解放するために、コピーされた全てのImageオブジェクトに関して、Dispose() を呼び出す必要があります。

byte [] ToBuffer ( )

画像のメモリイメージを取得する

戻り値:
画像のメモリイメージ

プロパティ

ImageSize DecodeSize [set]

画像のデコード時のサイズ

Decode()を呼び出す前にDecodeSizeを設定しておくことで、画像を拡大・縮小しながらデコードすることができます。


  • Sce
  • PlayStation
  • Core
  • Imaging
  • CharMetrics
Public 変数

構造体 CharMetrics

文字ごとのメトリクス情報 [詳細]

すべてのメンバ一覧

Public 変数

float | X
文字の基準位置のX座標
float | Y
文字の基準位置のY座標
float | Width
文字の幅
float | Height
文字の高さ
float | HorizontalBearingX
基準位置から文字の左端の距離(右が正)
float | HorizontalBearingY
基準位置から文字の上端の距離(上が正)
float | HorizontalAdvance
この文字から次の文字の基準位置への距離

説明

文字ごとのメトリクス情報


構造体 FontMetrics

フォントのメトリクス情報 [詳細]

すべてのメンバ一覧

Public 変数

int | Ascent
ベースラインから文字の上端までの高さ
int | Descent
ベースラインから文字の下端までの高さ
int | Leading
行間

プロパティ

int | Height [get]
二つの行のベースライン間の距離

説明

フォントのメトリクス情報


構造体 ImageColor

画素の色 [詳細]

すべてのメンバ一覧

Public メソッド

ImageColor (int r, int g, int b, int a)
ImageColorのコンストラクタ

Public 変数

int | R
赤成分 (0-255)
int | G
緑成分 (0-255)
int | B
青成分 (0-255)
int | A
アルファ値 (0-255)

説明

画素の色

コンストラクタとデストラクタ

ImageColor | ( | int | r,
 |  | int | g,
 |  | int | b,
 |  | int | a
 | ) |  |

ImageColorのコンストラクタ

引数:
r | 赤成分 (0-255)
g | 緑成分 (0-255)
b | 青成分 (0-255)
a | アルファ値 (0-255)


構造体 ImagePosition

画像の中の座標 (左上原点) [詳細]

すべてのメンバ一覧

Public メソッド

ImagePosition (int x, int y)
ImagePositionのコンストラクタ

Public 変数

int | X
X座標
int | Y
Y座標

説明

画像の中の座標 (左上原点)

コンストラクタとデストラクタ

ImagePosition | ( | int | x,
 |  | int | y
 | ) |  |

ImagePositionのコンストラクタ

引数:
x | X座標
y | Y座標


構造体 ImageRect

画像の中の矩形領域 [詳細]

すべてのメンバ一覧

Public メソッド

ImageRect (int x, int y, int width, int height)
ImageRectのコンストラクタ

Public 変数

int | X
X座標
int | Y
Y座標
int | Width
幅
int | Height
高さ

説明

画像の中の矩形領域

コンストラクタとデストラクタ

ImageRect | ( | int | x,
 |  | int | y,
 |  | int | width,
 |  | int | height
 | ) |  |

ImageRectのコンストラクタ

引数:
x | X座標
y | Y座標
width | 幅
height | 高さ


構造体 ImageSize

画像のサイズ [詳細]

すべてのメンバ一覧

Public メソッド

ImageSize (int width, int height)
ImageSizeのコンストラクタ

Public 変数

int | Width
幅
int | Height
高さ

説明

画像のサイズ

コンストラクタとデストラクタ

ImageSize | ( | int | width,
 |  | int | height
 | ) |  |

ImageSizeのコンストラクタ

引数:
width | 幅
height | 高さ


パッケージ Sce.PlayStation.Core.Input

構成

struct | GamePadData
ゲームパッドのデータ [詳細]
class | GamePad
ゲームパッドデバイスを表すクラス [詳細]
struct | MotionData
モーションセンサーのデータ [詳細]
class | Motion
モーションセンサーを表すクラス [詳細]
struct | TouchData
タッチパネルの指ひとつ分のタッチ情報 [詳細]
class | Touch
タッチパネルデバイスを表すクラス [詳細]

列挙型

enum GamePadButtons {
Left = 1 << 0, Up = 1 << 1, Right = 1 << 2, Down = 1 << 3,
Square = 1 << 4, Triangle = 1 << 5, Circle = 1 << 6, Cross = 1 << 7,
Start = 1 << 8, Select = 1 << 9, L = 1 << 10, R = 1 << 11,
Enter = 1 << 16, Back = 1 << 17
}

ゲームパッドのボタンの列挙子

[詳細]
enum TouchStatus {
None = 0, Down = 1, Up = 2, Move = 3,
Canceled = 4
}

タッチパネルの指データの状態

[詳細]

列挙型

enum GamePadButtons

ゲームパッドのボタンの列挙子

列挙型の値:
Left

方向キーの左

Up

方向キーの上

Right

方向キーの右

Down

方向キーの下

Square

□ ボタン

Triangle

△ ボタン

Circle

○ ボタン

Cross

× ボタン

Start

STARTボタン

Select

SELECTボタン

L

L ボタン

R

R ボタン

Enter

Enter ボタン

SystemParameters.GamePadButtonMeaning の値を加味して、○×ボタンのうちの[決定]を意味するボタンが、Enterボタンとして抽象化されて通知されます。

Back

Back ボタン

SystemParameters.GamePadButtonMeaning の値を加味して、○×ボタンのうちの[戻る]を意味するボタンが、Backボタンとして抽象化されて通知されます。

enum TouchStatus

タッチパネルの指データの状態

列挙型の値:
None

押されていない

Down

押された

Up

離された

Move

移動した

Canceled

キャンセルされた


  • Sce
  • PlayStation
  • Core
  • Input
  • GamePad
Static Public メソッド

クラス GamePad

ゲームパッドデバイスを表すクラス [詳細]

すべてのメンバ一覧

Static Public メソッド

static GamePadData GetData (int deviceIndex)
ゲームパッドのデータを取得する

説明

ゲームパッドデバイスを表すクラス

メソッド

static GamePadData GetData ( int deviceIndex ) [static]

ゲームパッドのデータを取得する

引数:
deviceIndex デバイスの番号(0～)
戻り値:
ゲームパッドのデータ
参照:
GamePadData


  • Sce
  • PlayStation
  • Core
  • Input
  • Motion
Static Public メソッド

クラス Motion

モーションセンサーを表すクラス [詳細]

すべてのメンバ一覧

Static Public メソッド

static MotionData GetData (int deviceIndex)
モーションセンサーのデータを取得する

説明

モーションセンサーを表すクラス

メソッド

static MotionData GetData ( int deviceIndex ) [static]

モーションセンサーのデータを取得する

引数:
deviceIndex デバイスの番号(0～)
戻り値:
モーションセンサーのデータ
参照:
MotionData


  • Sce
  • PlayStation
  • Core
  • Input
  • Touch
Static Public メソッド

クラス Touch

タッチパネルデバイスを表すクラス [詳細]

すべてのメンバ一覧

Static Public メソッド

static List< TouchData > | GetData (int deviceIndex)
タッチパネル(前面)のデータを取得する
static List< TouchData > | GetRearTouchData (int deviceIndex)
タッチパネル(背面)のデータを取得する

説明

タッチパネルデバイスを表すクラス

メソッド

static List<TouchData> GetData ( int deviceIndex ) [static]

タッチパネル(前面)のデータを取得する

引数:
deviceIndex デバイスの番号(0～)
戻り値:
タッチパネル(前面)のデータ
参照:
TouchData
static List<TouchData> GetRearTouchData ( int deviceIndex ) [static]

タッチパネル(背面)のデータを取得する

引数:
deviceIndex デバイスの番号(0～)
戻り値:
タッチパネル(背面)のデータ
参照:
TouchData


  • Sce
  • PlayStation
  • Core
  • Input
  • GamePadData
Public 変数

構造体 GamePadData

ゲームパッドのデータ [詳細]

すべてのメンバ一覧

Public 変数

bool | Skip
後続の処理がこの入力データを無視するかどうかを制御するフラグ
GamePadButtons Buttons
現在のボタンの状態
GamePadButtons ButtonsPrev
前回のボタンの状態
GamePadButtons ButtonsDown
今回押し込まれたボタン
GamePadButtons ButtonsUp
今回離されたボタン
float | AnalogLeftX
左アナログのX軸 (-1.0～1.0)
float | AnalogLeftY
左アナログのY軸 (-1.0～1.0)
float | AnalogRightX
右アナログのX軸 (-1.0～1.0)
float | AnalogRightY
右アナログのY軸 (-1.0～1.0)

説明

ゲームパッドのデータ

変数

bool Skip

後続の処理がこの入力データを無視するかどうかを制御するフラグ

この入力データが、すでに他のオブジェクトによって消費されたものであるかを保存／取得するために、このフラグを使用します。


  • Sce
  • PlayStation
  • Core
  • Input
  • MotionData
Public 変数

構造体 MotionData

モーションセンサーのデータ [詳細]

すべてのメンバ一覧

Public 変数

bool Skip
後続の処理がこの入力データを無視するかどうかを制御するフラグ
Vector3 Acceleration
加速度
Vector3 AngularVelocity
角速度

説明

モーションセンサーのデータ

変数

Vector3 Acceleration

加速度

加速度センサーのデータです。ディスプレイの右方向がX軸の正、上方向がY軸の正、手前方向がZ軸の正です。単位は G です。たとえば、ディスプレイを上に向けてデバイスが静止しているとき、(0,0,-1) になります。ディスプレイを地面と垂直に立てて静止しているとき、(0,-1,0) になります。

Vector3 AngularVelocity

角速度

ジャイロセンサーのデータです。デバイスによっては、取得されません。

bool Skip

後続の処理がこの入力データを無視するかどうかを制御するフラグ

この入力データが、すでに他のオブジェクトによって消費されたものであるかを保存／取得するために、このフラグを使用します。


  • Sce
  • PlayStation
  • Core
  • Input
  • TouchData
Public 変数

構造体 TouchData

タッチパネルの指ひとつ分のタッチ情報 [詳細]

すべてのメンバ一覧

Public 変数

bool | Skip
後続の処理がこの入力データを無視するかどうかを制御するフラグ
int | ID
指のID
TouchStatus Status
指の状態
float | X
タッチ位置のX座標
float | Y
タッチ位置のY座標

説明

タッチパネルの指ひとつ分のタッチ情報

変数

bool Skip

後続の処理がこの入力データを無視するかどうかを制御するフラグ

この入力データが、すでに他のオブジェクトによって消費されたものであるかを保存／取得するために、このフラグを使用します。


パッケージ Sce.PlayStation.Core.Services

構成

class | AccountInformation
アカウント情報をあらわす static クラス [詳細]
class | InAppPurchaseDialog
アプリ内課金を処理するためのダイアログをあらわすクラス [詳細]
class | InAppPurchaseProduct
アプリ内課金で購入可能なプロダクトをあらわすクラス [詳細]
class | InAppPurchaseProductList
アプリ内課金で購入可能なプロダクトのリストをあらわすクラス [詳細]
class | NetworkStreamReader
ストリーム リーダー クラス [詳細]
class | NetworkResponse
ネットワーク レスポンス クラス [詳細]
class | NetworkRequest
ネットワーク リクエスト クラス [詳細]
class | Network
スコアボード使用をハンドルするネットワーク クラス [詳細]

列挙型

enum InAppPurchaseCommand {
None = 0, GetProductInfo = 1, GetTicketInfo = 2, Purchase = 3,
Consume = 4
}

アプリ内課金の動作コマンド

[詳細]
enum | InAppPurchaseTicketType { Normal = 0, Consumable = 1 }

アプリ内課金のチケットタイプ

[詳細]
enum | NetworkRequestType

ネットワーク リクエストの種類

enum NetworkState {
NotConnected = 0, SignedOut, SignedIn, Online,
AuthRequested, AuthRequestReady, AuthRequestFailed, NetworkServerIdle,
NetworkServerRequested, NetworkServerReady, NetworkServerFailed
}

ネットワークの状態

[詳細]

列挙型

enum InAppPurchaseCommand

アプリ内課金の動作コマンド

列挙型の値:
None

なし

GetProductInfo

プロダクト情報をサーバーから取得する

GetTicketInfo

チケット情報をサーバーから取得する

Purchase

プロダクトを購入する

Consume

チケットを消費する

enum InAppPurchaseTicketType

アプリ内課金のチケットタイプ

列挙型の値:
Normal

通常型

Consumable

消費型

enum NetworkState

ネットワークの状態

列挙型の値:
NotConnected

接続がありません(PSN)

SignedOut

サインアウトしました(PSN)

SignedIn

サインインしました(PSN)

Online

オンライン(PSN)

AuthRequested

チケット リクエスト完了(PSN)

AuthRequestReady

チケットを受信しました(PSN)

AuthRequestFailed

承認エラー(PSN)

NetworkServerIdle

接続してください(ネットワークサービスサーバー)

NetworkServerRequested

request has been sent (Network Services server)

NetworkServerReady

リクエスト送付準備完了(ネットワークサービスサーバー)

NetworkServerFailed

認証エラー(ネットワークサービスサーバー)


  • Sce
  • PlayStation
  • Core
  • Services
  • AccountInformation
プロパティ

クラス AccountInformation

アカウント情報をあらわす static クラス [詳細]

すべてのメンバ一覧

プロパティ

static byte[] UniqueID [get]
ユニーク ID

説明

アカウント情報をあらわす static クラス

プロパティ

byte [] UniqueID [static, get]

ユニーク ID

16 バイトの数字を取得します。これは各アカウントに対してユニークな値となります。


クラス InAppPurchaseDialog

アプリ内課金を処理するためのダイアログをあらわすクラス [詳細]

InAppPurchaseDialogに対する継承グラフ
ICommonDialog

すべてのメンバ一覧

Public メソッド

InAppPurchaseDialog ()
ダイアログを作成する
void | Dispose ()
ダイアログのアンマネージドリソースを解放する
void | GetProductInfo (string[] labels)
ダイアログを開き、プロダクト情報をサーバーから取得する
void | GetTicketInfo ()
ダイアログを開き、チケット情報をサーバーから取得する
void | Purchase (string label)
ダイアログを開き、プロダクトを購入する
void | Consume (string label)
ダイアログを開き、チケットを消費する
void | Open ()
ダイアログを開く (この関数はサポートされません)
void | Abort ()
ダイアログを中断する (現在未対応です)

プロパティ

CommonDialogState | State [get]
ダイアログ処理の状態
CommonDialogResult | Result [get]
ダイアログ処理の結果
InAppPurchaseCommand | Command [get]
ダイアログ処理のコマンド
string[] | Arguments [get]
ダイアログ処理の引数
InAppPurchaseProductList | ProductList [get]
プロダクトのリスト
bool | IsProductInfoComplete [get]
プロダクト情報がすべて取得されているかどうか
bool | IsTicketInfoComplete [get]
チケット情報がすべて取得されているかどうか

説明

アプリ内課金を処理するためのダイアログをあらわすクラス

コンストラクタとデストラクタ

InAppPurchaseDialog ( )

ダイアログを作成する

ダイアログクラスが作成され、プロダクトのリストがメタデータから読み込まれます。

メソッド

void Abort ( )

ダイアログを中断する (現在未対応です)

ダイアログの処理を中断して、ダイアログを閉じます。

ICommonDialogを実装しています。

void Consume ( string label )

ダイアログを開き、チケットを消費する

引数:
label プロダクトのラベル

ダイアログを開いてサーバーに接続し、指定されたプロダクトのチケットを消費します。なお、あらかじめチケット情報を取得しておく必要があります。以下の場合には例外が発生します。

  • 指定されたプロダクトがリストに登録されていない
  • チケット情報が取得されていない
  • 指定されたプロダクトが消費型ではない
  • 指定されたプロダクトの残り回数がゼロ

ダイアログ処理が完了すると、結果が OK の場合はチケット情報がすべて更新されます。結果が Error または Aborted の場合はチケット情報は更新されず、IsTicketInfoComplete プロパティが false になります。その場合、あらためて GetTicketInfo 関数でチケット情報を取得し、処理が成功したか失敗したかを確認してください。

void Dispose ( )

ダイアログのアンマネージドリソースを解放する

ダイアログのアンマネージドリソースを解放します。

void GetProductInfo ( string[] labels )

ダイアログを開き、プロダクト情報をサーバーから取得する

引数:
labels プロダクトのラベルの配列 (nullならばすべて選択)

ダイアログを開いてサーバーに接続し、指定されたプロダクトのプロダクト情報を取得します。この関数はプロダクトごとにサーバーにリクエストを送信するため、一度に大量の情報を取得する場合は非常に時間がかかる可能性がありますのでご注意ください。

void GetTicketInfo ( )

ダイアログを開き、チケット情報をサーバーから取得する

ダイアログを開いてサーバーに接続し、すべてのプロダクトのチケット情報を取得します。

void Open ( )

ダイアログを開く (この関数はサポートされません)

この関数はサポートされません。ダイアログを開くには GetProductInfo, GetTicketInfo, Purchase, Consume 関数を使用してください。

ICommonDialogを実装しています。

void Purchase ( string label )

ダイアログを開き、プロダクトを購入する

引数:
label プロダクトのラベル

ダイアログを開いてサーバーに接続し、指定されたプロダクトを購入します。なお、あらかじめプロダクト情報とチケット情報を取得しておく必要があります。以下の場合には例外が発生します。

  • 指定されたプロダクトがリストに登録されていない
  • プロダクト情報かチケット情報が取得されていない
  • 指定されたプロダクトが通常型かつ購入ずみ

ダイアログ処理が完了すると、結果が OK の場合はチケット情報がすべて更新されます。結果が Error または Aborted の場合はチケット情報は更新されず、IsTicketInfoComplete プロパティが false になります。その場合、あらためて GetTicketInfo 関数でチケット情報を取得し、処理が成功したか失敗したかを確認してください。

プロパティ

string [] Arguments [get]

ダイアログ処理の引数

最後に実行されたダイアログ処理の引数を取得します。

InAppPurchaseCommand Command [get]

ダイアログ処理のコマンド

最後に実行されたダイアログ処理のコマンドを取得します。

bool IsProductInfoComplete [get]

プロダクト情報がすべて取得されているかどうか

プロダクト情報がすべて取得されていれば true を返します。

bool IsTicketInfoComplete [get]

チケット情報がすべて取得されているかどうか

チケット情報がすべて取得されていれば true を返します。チケット情報がまだ取得されていない場合、またはエラーによって最新状態に更新できなかった場合は false を返します。

InAppPurchaseProductList ProductList [get]

プロダクトのリスト

購入可能なプロダクトのリストを取得します。

CommonDialogResult Result [get]

ダイアログ処理の結果

最後に実行されたダイアログ処理の結果を取得します。

ICommonDialogを実装しています。

CommonDialogState State [get]

ダイアログ処理の状態

最後に実行されたダイアログ処理の状態を取得します。

ICommonDialogを実装しています。


  • Sce
  • PlayStation
  • Core
  • Services
  • InAppPurchaseProduct
プロパティ

クラス InAppPurchaseProduct

アプリ内課金で購入可能なプロダクトをあらわすクラス [詳細]

すべてのメンバ一覧

プロパティ

string | Label [get]
プロダクトのラベル
string | Name [get]
プロダクトの名前
string | Price [get]
プロダクトの価格 (GetProductInfo で取得される)
InAppPurchaseTicketType | TicketType [get]
チケットのタイプ
bool | IsTicketValid [get]
チケットが有効かどうか (GetTicketInfo で取得される)
int | ConsumableTicketCount [get]
チケットの消費可能な残り回数 (GetTicketInfo で取得される)

説明

アプリ内課金で購入可能なプロダクトをあらわすクラス


クラス InAppPurchaseProductList

アプリ内課金で購入可能なプロダクトのリストをあらわすクラス [詳細]

すべてのメンバ一覧

Public メソッド

int | IndexOf (string label)
指定されたラベルをもつ要素の番号を返す (なければ -1)
bool | Contains (string label)
指定されたラベルをもつ要素が存在するかどうかを判定する
IEnumerator< InAppPurchaseProduct > | GetEnumerator ()
列挙子を返す

プロパティ

int | Count [get]
要素数
InAppPurchaseProduct | this [int index] [get]
インデクサ (番号またはラベルによる)

説明

アプリ内課金で購入可能なプロダクトのリストをあらわすクラス

メソッド

bool Contains ( string label )

指定されたラベルをもつ要素が存在するかどうかを判定する

引数:
label 要素のラベル
戻り値:
要素が存在すれば true
IEnumerator<InAppPurchaseProduct> GetEnumerator ( )

列挙子を返す

戻り値:
列挙子
int IndexOf ( string label )

指定されたラベルをもつ要素の番号を返す (なければ -1)

引数:
label 要素のラベル
戻り値:
要素の番号 (なければ -1)

プロパティ

int Count [get]

要素数

リストに格納された要素の数を返します。

InAppPurchaseProduct this [get]

インデクサ (番号またはラベルによる)

リストに格納された要素を取得します。


クラス Network

スコアボード使用をハンドルするネットワーク クラス [詳細]

すべてのメンバ一覧

Static Public メソッド

static void | Initialize (string applicationToken)
スコアボード クラスをアプリケーションデータで初期化
static NetworkState | AuthGetTicket ()
起動時またはチケット期限切れの際にネットワーク サービス サーバーからチケットを受信
static NetworkRequest | CreateRequest (NetworkRequestType type, string function, string json)
ネットワーク リクエストを新規作成

プロパティ

static string | ServerTicket [get]
ネットワーク サービス サーバーのチケットを得る
static NetworkState | State [get]
サーバーの状態を戻す　状態がNetworkServerReadyなら、スコアボードにクエリに送ることができる

説明

スコアボード使用をハンドルするネットワーク クラス

メソッド

static NetworkState AuthGetTicket ( ) [static]

起動時またはチケット期限切れの際にネットワーク サービス サーバーからチケットを受信

戻り値:
サーバーの状態
static NetworkRequest CreateRequest | ( | NetworkRequestType | type,
 |  | string | function,
 |  | string | json
 | ) |  | [static]

ネットワーク リクエストを新規作成

引数:
type | リクエスト タイプ
function | ネットワーク サービス タイプ
json | 有効なJsonストリング
戻り値:
リクエスト
static void Initialize ( string applicationToken ) [static]

スコアボード クラスをアプリケーションデータで初期化

引数:
applicationToken アプリケーション トークン

プロパティ

NetworkState State [static, get]

サーバーの状態を戻す　状態がNetworkServerReadyなら、スコアボードにクエリに送ることができる

戻り値:
サーバーの状態


  • Sce
  • PlayStation
  • Core
  • Services
  • NetworkRequest
Public メソッド

クラス NetworkRequest

ネットワーク リクエスト クラス [詳細]

すべてのメンバ一覧

Public メソッド

NetworkResponse GetResponse ()
サーバーからレスポンスをブロッキングで受信
IAsyncResult | BeginGetResponse (AsyncCallback callback)
サーバーからレスポンスを非同期で受信
NetworkResponse | EndGetResponse (IAsyncResult result)
リクエストをフェッチする
void | Dispose ()
オブジェクトの廃棄

説明

ネットワーク リクエスト クラス

メソッド

IAsyncResult BeginGetResponse ( AsyncCallback callback )

サーバーからレスポンスを非同期で受信

引数:
callback コールバック関数
戻り値:
ハンドル
NetworkResponse EndGetResponse ( IAsyncResult result )

リクエストをフェッチする

引数:
callback リクエストのハンドル
戻り値:
レスポンス
NetworkResponse GetResponse ( )

サーバーからレスポンスをブロッキングで受信

戻り値:
レスポンス。エラーの場合はnull


  • Sce
  • PlayStation
  • Core
  • Services
  • NetworkResponse
Public メソッド

クラス NetworkResponse

ネットワーク レスポンス クラス [詳細]

すべてのメンバ一覧

Public メソッド

void Dispose ()
クラスの廃棄
NetworkStreamReader GetStreamReader ()
ストリーム リーダーの新規作成

説明

ネットワーク レスポンス クラス

メソッド

NetworkStreamReader GetStreamReader ( )

ストリーム リーダーの新規作成

戻り値:
ストリーム リーダー


  • Sce
  • PlayStation
  • Core
  • Services
  • NetworkStreamReader
Public メソッド

クラス NetworkStreamReader

ストリーム リーダー クラス [詳細]

すべてのメンバ一覧

Public メソッド

void | Dispose ()
オブジェクトの廃棄
int | Read (byte[] buffer, int offset, int count)
ストリームのリード
string | ReadToEnd ()
ストリームの最後までリード
void | Close ()
ストリームのクローズ

説明

ストリーム リーダー クラス

メソッド

int Read | ( | byte[] | buffer,
 |  | int | offset,
 |  | int | count
 | ) |  |

ストリームのリード

引数:
buffer | バッファ
offset | バッファのオフセット
count | リードするバイト数
戻り値:
リードしたバイト数
string ReadToEnd ( )

ストリームの最後までリード

戻り値:
ストリームの残り文字列


クラス FMath

math wrapper and convenience functions [詳細]

すべてのメンバ一覧

Static Public メソッド

static float | Radians (float x)
convert from degrees to radians
static float | Degrees (float x)
convert from radians to degrees
static float | Sin (float x)
equivalent to (float)Math.Sin(x)
static float | Cos (float x)
equivalent to (float)Math.Cos(x)
static float | Tan (float x)
equivalent to (float)Math.Tan(x)
static float | Asin (float x)
equivalent to (float)Math.Asin(x)
static float | Acos (float x)
equivalent to (float)Math.Acos(x)
static float | Atan (float x)
equivalent to (float)Math.Atan(x)
static float | Atan2 (float x, float y)
equivalent to (float)Math.Atan2(x,y)
static float | Sqrt (float x)
equivalent to (float)Math.Sqrt(x)
static float | Pow (float x, float y)
equivalent to (float)Math.Pow(x,y)
static float | Exp (float x)
equivalent to (float)Math.Exp(x)
static float | Log (float x)
equivalent to (float)Math.Log(x)
static float | Log10 (float x)
equivalent to (float)Math.Log10(x)
static float | Abs (float x)
equivalent to Math.Abs(x)
static int | Sign (float x)
equivalent to Math.Sign(x)
static float | Min (float x, float y)
equivalent to Math.Min(x,y)
static float | Max (float x, float y)
equivalent to Math.Max(x,y)
static float | Floor (float x)
equivalent to (float)Math.Floor(x)
static float | Ceiling (float x)
equivalent to (float)Math.Ceiling(x)
static float | Round (float x)
equivalent to (float)Math.Round(x)
static float | Truncate (float x)
equivalent to (float)Math.Truncate(x)
static float | Clamp (float x, float min, float max)
clamp between two values
static float | Repeat (float x, float min, float max)
repeat between two values
static float | Mirror (float x, float min, float max)
repeat shuttlewise between two values
static float | Lerp (float x1, float x2, float f)
lerp between two values
static float | MoveTo (float x1, float x2, float amount)
move one value to another value by specified amount
static float | Step (float edge, float x)
step function returning 0 or 1
static float | LinearStep (float min, float max, float x)
linear step function returning a value between 0 and 1
static float | SmoothStep (float min, float max, float x)
smooth step function returning a value between 0 and 1

Public 変数

const float | E = (float)Math.E
E.
const float | PI = (float)Math.PI
PI.
const float | DegToRad = (float)( Math.PI / 180.0 )
conversion ratio from degrees to radians
const float | RadToDeg = (float)( 180.0 / Math.PI )
conversion ratio from radians to degrees

説明

math wrapper and convenience functions

メソッド

static float Abs ( float x ) [static]

equivalent to Math.Abs(x)

引数:
x the value to take the absolute value of
戻り値:
the absolute value of x
static float Acos ( float x ) [static]

equivalent to (float)Math.Acos(x)

引数:
x the value to take the acos of
戻り値:
the acos of x
static float Asin ( float x ) [static]

equivalent to (float)Math.Asin(x)

引数:
x the value to take the asin of
戻り値:
the asin of x
static float Atan ( float x ) [static]

equivalent to (float)Math.Atan(x)

引数:
x the value to take the atan of
戻り値:
the atan of x
static float Atan2 | ( | float | x,
 |  | float | y
 | ) |  | [static]

equivalent to (float)Math.Atan2(x,y)

引数:
x | the x coordinate to take the atan2 of
y | the y coordinate to take the atan2 of
戻り値:
the atan2 of (x,y)
static float Ceiling ( float x ) [static]

equivalent to (float)Math.Ceiling(x)

引数:
x the value to take the ceil of
戻り値:
the ceil of x
static float Clamp | ( | float | x,
 |  | float | min,
 |  | float | max
 | ) |  | [static]

clamp between two values

引数:
x | the value to clamp
min | the min to clamp against
max | the max to clamp against
戻り値:
x clamped between min and max
static float Cos ( float x ) [static]

equivalent to (float)Math.Cos(x)

引数:
x the value to take the cos of
戻り値:
the cos of x
static float Degrees ( float x ) [static]

convert from radians to degrees

引数:
x the value to convert
戻り値:
value converted from radians to degrees
static float Exp ( float x ) [static]

equivalent to (float)Math.Exp(x)

引数:
x the value to take the exp of
戻り値:
the exp of x
static float Floor ( float x ) [static]

equivalent to (float)Math.Floor(x)

引数:
x the value to take the floor of
戻り値:
the floor of x
static float Lerp | ( | float | x1,
 |  | float | x2,
 |  | float | f
 | ) |  | [static]

lerp between two values

引数:
x1 | value 1
x2 | value 2
f | lerp amount
戻り値:
the result of lerping f between x1 and x2
static float LinearStep | ( | float | min,
 |  | float | max,
 |  | float | x
 | ) |  | [static]

linear step function returning a value between 0 and 1

引数:
min | the min to be compared
max | the max to be compared
x | the value to be compared
戻り値:
0.0f if x<min, 1.0f if x>max, linearly interpolated if min<=x<=max
static float Log ( float x ) [static]

equivalent to (float)Math.Log(x)

引数:
x the value to take the log of
戻り値:
the log of x
static float Log10 ( float x ) [static]

equivalent to (float)Math.Log10(x)

引数:
x the value to take the log 10 of
戻り値:
the log 10 of x
static float Max | ( | float | x,
 |  | float | y
 | ) |  | [static]

equivalent to Math.Max(x,y)

引数:
x | first input to max
y | second input to max
戻り値:
the max of x and y
static float Min | ( | float | x,
 |  | float | y
 | ) |  | [static]

equivalent to Math.Min(x,y)

引数:
x | first input to min
y | second input to min
戻り値:
the min of x and y
static float Mirror | ( | float | x,
 |  | float | min,
 |  | float | max
 | ) |  | [static]

repeat shuttlewise between two values

引数:
x | the value to repeat
min | the min to repeat over
max | the max to repeat over
戻り値:
x repeated shuttlewise between min and max
static float MoveTo | ( | float | x1,
 |  | float | x2,
 |  | float | amount
 | ) |  | [static]

move one value to another value by specified amount

引数:
x1 | value 1
x2 | value 2
amount | step amount
戻り値:
value moved to another value by specified amount
static float Pow | ( | float | x,
 |  | float | y
 | ) |  | [static]

equivalent to (float)Math.Pow(x,y)

引数:
x | the value to raise
y | the power to raise to
戻り値:
x to y power
static float Radians ( float x ) [static]

convert from degrees to radians

引数:
x the value to convert
戻り値:
value converted from degrees to radians
static float Repeat | ( | float | x,
 |  | float | min,
 |  | float | max
 | ) |  | [static]

repeat between two values

引数:
x | the value to repeat
min | the min to repeat over
max | the max to repeat over
戻り値:
x repeated between min and max
static float Round ( float x ) [static]

equivalent to (float)Math.Round(x)

引数:
x the value to take the round of
戻り値:
the round of x
static int Sign ( float x ) [static]

equivalent to Math.Sign(x)

引数:
x the value to take the sign of
戻り値:
the sign of x
static float Sin ( float x ) [static]

equivalent to (float)Math.Sin(x)

引数:
x the value to take the sin of
戻り値:
the sin of x
static float SmoothStep | ( | float | min,
 |  | float | max,
 |  | float | x
 | ) |  | [static]

smooth step function returning a value between 0 and 1

引数:
min | the min to be compared
max | the max to be compared
x | the value to be compared
戻り値:
0.0f if x<min, 1.0f if x>max, smoothly interpolated if min<=x<=max
static float Sqrt ( float x ) [static]

equivalent to (float)Math.Sqrt(x)

引数:
x the value to take the square root of
戻り値:
the square root of x
static float Step | ( | float | edge,
 |  | float | x
 | ) |  | [static]

step function returning 0 or 1

引数:
edge | the edge to be compared
x | the value to be compared
戻り値:
0.0f if x<edge, 1.0f if x>=edge
static float Tan ( float x ) [static]

equivalent to (float)Math.Tan(x)

引数:
x the value to take the tan of
戻り値:
the tan of x
static float Truncate ( float x ) [static]

equivalent to (float)Math.Truncate(x)

引数:
x the value to take the trunc of
戻り値:
the trunc of x

変数

const float DegToRad = (float)( Math.PI / 180.0 )

conversion ratio from degrees to radians

const float E = (float)Math.E

E.

const float PI = (float)Math.PI

PI.

const float RadToDeg = (float)( 180.0 / Math.PI )

conversion ratio from radians to degrees


構造体 Byte2

vector of 2 signed bytes [詳細]

すべてのメンバ一覧

Public メソッド

Byte2 (int x, int y)
constructor taking 2 scalar integers
Byte2 (Vector2 v)
constructor taking a Vector2
Vector2 ToVector2 ()
return the vector as a Vector2
bool | Equals (Byte2 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Byte2 v1, Byte2 v2)
equality operator
static bool | operator!= (Byte2 v1, Byte2 v2)
not equals operator

Public 変数

sbyte | X
X.
sbyte | Y
Y.

説明

vector of 2 signed bytes

コンストラクタとデストラクタ

Byte2 | ( | int | x,
 |  | int | y
 | ) |  |

constructor taking 2 scalar integers

引数:
x | x value to init with
y | y value to init with
Byte2 ( Vector2 v )

constructor taking a Vector2

引数:
v the vector to init with

メソッド

bool Equals ( Byte2 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Byte2 | v1,
 |  | Byte2 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Byte2 | v1,
 |  | Byte2 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector2 ToVector2 ( )

return the vector as a Vector2

戻り値:
the vector as a Vector2

変数

sbyte X

X.

sbyte Y

Y.


構造体 Byte2N

vector of 2 normalized signed bytes [詳細]

すべてのメンバ一覧

Public メソッド

Byte2N (float x, float y)
constructor taking 2 scalar floats
Byte2N (Vector2 v)
constructor taking a Vector2
Vector2 ToVector2 ()
return the vector as a Vector2
bool | Equals (Byte2N v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Byte2N v1, Byte2N v2)
equality operator
static bool | operator!= (Byte2N v1, Byte2N v2)
not equals operator

Public 変数

ByteN X
X.
ByteN Y
Y.

説明

vector of 2 normalized signed bytes

コンストラクタとデストラクタ

Byte2N | ( | float | x,
 |  | float | y
 | ) |  |

constructor taking 2 scalar floats

引数:
x | x value to init with
y | y value to init with
Byte2N ( Vector2 v )

constructor taking a Vector2

引数:
v the vector to init with

メソッド

bool Equals ( Byte2N v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Byte2N | v1,
 |  | Byte2N | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Byte2N | v1,
 |  | Byte2N | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector2 ToVector2 ( )

return the vector as a Vector2

戻り値:
the vector as a Vector2

変数

ByteN X

X.

ByteN Y

Y.


構造体 Byte3

vector of 3 signed bytes [詳細]

すべてのメンバ一覧

Public メソッド

Byte3 (int x, int y, int z)
constructor taking 3 scalar integers
Byte3 (Vector3 v)
constructor taking a Vector3
Vector3 ToVector3 ()
return the vector as a Vector3
bool | Equals (Byte3 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Byte3 v1, Byte3 v2)
equality operator
static bool | operator!= (Byte3 v1, Byte3 v2)
not equals operator

Public 変数

sbyte | X
X.
sbyte | Y
Y.
sbyte | Z
Z.

説明

vector of 3 signed bytes

コンストラクタとデストラクタ

Byte3 | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |

constructor taking 3 scalar integers

引数:
x | x value to init with
y | y value to init with
z | z value to init with
Byte3 ( Vector3 v )

constructor taking a Vector3

引数:
v the vector to init with

メソッド

bool Equals ( Byte3 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Byte3 | v1,
 |  | Byte3 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Byte3 | v1,
 |  | Byte3 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector3 ToVector3 ( )

return the vector as a Vector3

戻り値:
the vector as a Vector3

変数

sbyte X

X.

sbyte Y

Y.

sbyte Z

Z.


構造体 Byte3N

vector of 3 normalized signed bytes [詳細]

すべてのメンバ一覧

Public メソッド

Byte3N (float x, float y, float z)
constructor taking 3 scalar floats
Byte3N (Vector3 v)
constructor taking a Vector3
Vector3 ToVector3 ()
return the vector as a Vector3
bool | Equals (Byte3N v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Byte3N v1, Byte3N v2)
equality operator
static bool | operator!= (Byte3N v1, Byte3N v2)
not equals operator

Public 変数

ByteN X
X.
ByteN Y
Y.
ByteN Z
Z.

説明

vector of 3 normalized signed bytes

コンストラクタとデストラクタ

Byte3N | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  |

constructor taking 3 scalar floats

引数:
x | x value to init with
y | y value to init with
z | z value to init with
Byte3N ( Vector3 v )

constructor taking a Vector3

引数:
v the vector to init with

メソッド

bool Equals ( Byte3N v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Byte3N | v1,
 |  | Byte3N | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Byte3N | v1,
 |  | Byte3N | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector3 ToVector3 ( )

return the vector as a Vector3

戻り値:
the vector as a Vector3

変数

ByteN X

X.

ByteN Y

Y.

ByteN Z

Z.


構造体 Byte4

vector of 4 signed bytes [詳細]

すべてのメンバ一覧

Public メソッド

Byte4 (int x, int y, int z, int w)
constructor taking 4 scalar integers
Byte4 (Vector4 v)
constructor taking a Vector4
Vector4 ToVector4 ()
return the vector as a Vector4
bool | Equals (Byte4 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Byte4 v1, Byte4 v2)
equality operator
static bool | operator!= (Byte4 v1, Byte4 v2)
not equals operator

Public 変数

sbyte | X
X.
sbyte | Y
Y.
sbyte | Z
Z.
sbyte | W
W.

説明

vector of 4 signed bytes

コンストラクタとデストラクタ

Byte4 | ( | int | x,
 |  | int | y,
 |  | int | z,
 |  | int | w
 | ) |  |

constructor taking 4 scalar integers

引数:
x | x value to init with
y | y value to init with
z | z value to init with
w | w value to init with
Byte4 ( Vector4 v )

constructor taking a Vector4

引数:
v the vector to init with

メソッド

bool Equals ( Byte4 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Byte4 | v1,
 |  | Byte4 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Byte4 | v1,
 |  | Byte4 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector4 ToVector4 ( )

return the vector as a Vector4

戻り値:
the vector as a Vector4

変数

sbyte W

W.

sbyte X

X.

sbyte Y

Y.

sbyte Z

Z.


構造体 Byte4N

vector of 4 normalized signed bytes [詳細]

すべてのメンバ一覧

Public メソッド

Byte4N (float x, float y, float z, float w)
constructor taking 4 scalar floats
Byte4N (Vector4 v)
constructor taking a Vector4
Vector4 ToVector4 ()
return the vector as a Vector4
bool | Equals (Byte4N v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Byte4N v1, Byte4N v2)
equality operator
static bool | operator!= (Byte4N v1, Byte4N v2)
not equals operator

Public 変数

ByteN X
X.
ByteN Y
Y.
ByteN Z
Z.
ByteN W
W.

説明

vector of 4 normalized signed bytes

コンストラクタとデストラクタ

Byte4N | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | float | w
 | ) |  |

constructor taking 4 scalar floats

引数:
x | x value to init with
y | y value to init with
z | z value to init with
w | w value to init with
Byte4N ( Vector4 v )

constructor taking a Vector4

引数:
v the vector to init with

メソッド

bool Equals ( Byte4N v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Byte4N | v1,
 |  | Byte4N | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Byte4N | v1,
 |  | Byte4N | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector4 ToVector4 ( )

return the vector as a Vector4

戻り値:
the vector as a Vector4

変数

ByteN W

W.

ByteN X

X.

ByteN Y

Y.

ByteN Z

Z.


構造体 ByteN

a scalar normalized signed byte [詳細]

すべてのメンバ一覧

Public メソッド

ByteN (float f)
constructor taking a float to convert to normalized signed byte
float | ToFloat ()
return the float value of this
bool | Equals (ByteN v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of float value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (ByteN v1, ByteN v2)
equality operator
static bool | operator!= (ByteN v1, ByteN v2)
not equals operator
static implicit | operator float (ByteN v)
float casting operator
static | operator ByteN (float f)
normalized signed byte casting operator

Public 変数

sbyte | Bits
the byte data

説明

a scalar normalized signed byte

コンストラクタとデストラクタ

ByteN ( float f )

constructor taking a float to convert to normalized signed byte

引数:
f the float to convert

メソッド

bool Equals ( ByteN v )

equality test

引数:
v the value to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static operator ByteN ( float f ) [explicit, static]

normalized signed byte casting operator

引数:
f the float to convert to normalized signed byte
戻り値:
the normalized signed byte value
static implicit operator float ( ByteN v ) [static]

float casting operator

引数:
v the value to convert to float
戻り値:
the float value
static bool operator!= | ( | ByteN | v1,
 |  | ByteN | v2
 | ) |  | [static]

not equals operator

引数:
v1 | value 1
v2 | value 2
戻り値:
true if value 1 != value 2, false otherwise
static bool operator== | ( | ByteN | v1,
 |  | ByteN | v2
 | ) |  | [static]

equality operator

引数:
v1 | value 1
v2 | value 2
戻り値:
true if value 1 == value 2, false otherwise
float ToFloat ( )

return the float value of this

戻り値:
the float value of this
override string ToString ( )

get the string representation of float value

戻り値:
the string representation of float value

変数

sbyte Bits

the byte data


構造体 Half

a scalar half [詳細]

すべてのメンバ一覧

Public メソッド

Half (float f)
constructor taking a float to convert to half
float | ToFloat ()
return the float value of this
bool | Equals (Half h)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of float value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Half h1, Half h2)
equality operator
static bool | operator!= (Half h1, Half h2)
not equals operator
static implicit | operator float (Half h)
float casting operator
static | operator Half (float f)
half casting operator

Public 変数

ushort | Bits
the half data

説明

a scalar half

コンストラクタとデストラクタ

Half ( float f )

constructor taking a float to convert to half

引数:
f the float to convert

メソッド

bool Equals ( Half h )

equality test

引数:
h the half to compare this to
戻り値:
true if this == h, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static implicit operator float ( Half h ) [static]

float casting operator

引数:
h the half to convert to float
戻り値:
the float value of the half
static operator Half ( float f ) [explicit, static]

half casting operator

引数:
f the float to convert to half
戻り値:
the half value of the float
static bool operator!= | ( | Half | h1,
 |  | Half | h2
 | ) |  | [static]

not equals operator

引数:
h1 | half 1
h2 | half 2
戻り値:
true if half 1 != half 2, false otherwise
static bool operator== | ( | Half | h1,
 |  | Half | h2
 | ) |  | [static]

equality operator

引数:
h1 | half 1
h2 | half 2
戻り値:
true if half 1 == half 2, false otherwise
float ToFloat ( )

return the float value of this

戻り値:
the float value of this
override string ToString ( )

get the string representation of float value

戻り値:
the string representation of float value

変数

ushort Bits

the half data


構造体 Half2

vector of 2 halfs [詳細]

すべてのメンバ一覧

Public メソッド

Half2 (float x, float y)
constructor taking 2 scalar floats
Half2 (Vector2 v)
constructor taking a Vector2
Vector2 ToVector2 ()
return the vector as a Vector2
bool | Equals (Half2 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Half2 v1, Half2 v2)
equality operator
static bool | operator!= (Half2 v1, Half2 v2)
not equals operator

Public 変数

Half X
X.
Half Y
Y.

説明

vector of 2 halfs

コンストラクタとデストラクタ

Half2 | ( | float | x,
 |  | float | y
 | ) |  |

constructor taking 2 scalar floats

引数:
x | x value to init with
y | y value to init with
Half2 ( Vector2 v )

constructor taking a Vector2

引数:
v the vector to init with

メソッド

bool Equals ( Half2 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Half2 | v1,
 |  | Half2 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Half2 | v1,
 |  | Half2 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector2 ToVector2 ( )

return the vector as a Vector2

戻り値:
the vector as a Vector2

変数

Half X

X.

Half Y

Y.


構造体 Half3

vector of 3 halfs [詳細]

すべてのメンバ一覧

Public メソッド

Half3 (float x, float y, float z)
constructor taking 3 scalar floats
Half3 (Vector3 v)
constructor taking a Vector3
Vector3 ToVector3 ()
return the vector as a Vector3
bool | Equals (Half3 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Half3 v1, Half3 v2)
equality operator
static bool | operator!= (Half3 v1, Half3 v2)
not equals operator

Public 変数

Half X
X.
Half Y
Y.
Half Z
Z.

説明

vector of 3 halfs

コンストラクタとデストラクタ

Half3 | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  |

constructor taking 3 scalar floats

引数:
x | x value to init with
y | y value to init with
z | z value to init with
Half3 ( Vector3 v )

constructor taking a Vector3

引数:
v the vector to init with

メソッド

bool Equals ( Half3 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Half3 | v1,
 |  | Half3 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Half3 | v1,
 |  | Half3 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector3 ToVector3 ( )

return the vector as a Vector3

戻り値:
the vector as a Vector3

変数

Half X

X.

Half Y

Y.

Half Z

Z.


構造体 Half4

vector of 4 halfs [詳細]

すべてのメンバ一覧

Public メソッド

Half4 (float x, float y, float z, float w)
constructor taking 4 scalar floats
Half4 (Vector4 v)
constructor taking a Vector4
Vector4 ToVector4 ()
return the vector as a Vector4
bool | Equals (Half4 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Half4 v1, Half4 v2)
equality operator
static bool | operator!= (Half4 v1, Half4 v2)
not equals operator

Public 変数

Half X
X.
Half Y
Y.
Half Z
Z.
Half W
W.

説明

vector of 4 halfs

コンストラクタとデストラクタ

Half4 | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | float | w
 | ) |  |

constructor taking 4 scalar floats

引数:
x | x value to init with
y | y value to init with
z | z value to init with
w | w value to init with
Half4 ( Vector4 v )

constructor taking a Vector4

引数:
v the vector to init with

メソッド

bool Equals ( Half4 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Half4 | v1,
 |  | Half4 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Half4 | v1,
 |  | Half4 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector4 ToVector4 ( )

return the vector as a Vector4

戻り値:
the vector as a Vector4

変数

Half W

W.

Half X

X.

Half Y

Y.

Half Z

Z.


構造体 Matrix4

matrix of 16 floats [詳細]

すべてのメンバ一覧

Public メソッド

Matrix4 (float m11, float m12, float m13, float m14, float m21, float m22, float m23, float m24, float m31, float m32, float m33, float m34, float m41, float m42, float m43, float m44)
matrix constructor taking 16 scalar floats
Matrix4 (Vector4 x, Vector4 y, Vector4 z, Vector4 w)
matrix constructor initializing the 4 matrix column vectors
Matrix4 (Vector3 x, Vector3 y, Vector3 z, Vector3 w)
matrix constructor initializing the 4 matrix column vectors
float | Determinant ()
return the determinant of this matrix
Matrix4 Transpose ()
get the transpose of the matrix
void | Transpose (out Matrix4 result)
get the transpose of the matrix
Matrix4 Inverse ()
inverse for a matrix
void | Inverse (out Matrix4 result)
inverse for a matrix
Matrix4 InverseAffine ()
inverse for an affine matrix
void | InverseAffine (out Matrix4 result)
inverse for an affine matrix
Matrix4 InverseOrthonormal ()
inverse for a orthonormal martix
void | InverseOrthonormal (out Matrix4 result)
inverse for a orthonormal matrix
Matrix4 Orthonormalize ()
orthonormalize a matrix
void | Orthonormalize (out Matrix4 result)
orthonormalize a matrix
Vector4 | Transform (Vector4 v)
return this * v
void | Transform (ref Vector4 v, out Vector4 result)
result = this * v
Vector3 | TransformPoint (Vector3 v)
return this * v (X,Y,Z,1)
void | TransformPoint (ref Vector3 v, out Vector3 result)
result = this * v (X,Y,Z,1)
Vector2 | TransformPoint (Vector2 v)
return this * v (X,Y,0,1)
void | TransformPoint (ref Vector2 v, out Vector2 result)
result = this * v (X,Y,0,1)
Vector3 | TransformVector (Vector3 v)
return this * v (X,Y,Z,0)
void | TransformVector (ref Vector3 v, out Vector3 result)
result = this * v (X,Y,Z,0)
Vector2 | TransformVector (Vector2 v)
return this * v (X,Y,0,0)
void | TransformVector (ref Vector2 v, out Vector2 result)
result = this * v (X,Y,0,0)
Vector4 | TransformProjection (Vector4 v)
return this * v ( divided by W )
void | TransformProjection (ref Vector4 v, out Vector4 result)
result = this * v ( divided by W )
Vector3 | TransformProjection (Vector3 v)
return this * v ( divided by W )
void | TransformProjection (ref Vector3 v, out Vector3 result)
result = this * v ( divided by W )
Vector2 | TransformProjection (Vector2 v)
return this * v ( divided by W )
void | TransformProjection (ref Vector2 v, out Vector2 result)
result = this * v ( divided by W )
Matrix4 | Add (Matrix4 m)
return this + m
void | Add (ref Matrix4 m, out Matrix4 result)
result = this + m
Matrix4 | Subtract (Matrix4 m)
return this - m
void | Subtract (ref Matrix4 m, out Matrix4 result)
result = this - m
Matrix4 | Multiply (Matrix4 m)
return this * m
void | Multiply (ref Matrix4 m, out Matrix4 result)
result = this * m
Matrix4 | MultiplyAffine (Matrix4 m)
return this * m ( for affine matrices )
void | MultiplyAffine (ref Matrix4 m, out Matrix4 result)
result = this * m ( for affine matrices )
Matrix4 | Multiply (float f)
return this * f
void | Multiply (float f, out Matrix4 result)
result = this * f
Matrix4 | Divide (float f)
return this / f
void | Divide (float f, out Matrix4 result)
result = this / f
Matrix4 Negate ()
return -this
void | Negate (out Matrix4 result)
result = -this
bool | IsOrthonormal (float epsilon)
test to determine if a matrix is orthonormal
bool | IsIdentity ()
test if this is an identity matrix
bool | IsInfinity ()
test if any elements of this are Infinity
bool | IsNaN ()
test if any elements of this are NaN
bool | Equals (Matrix4 m, float epsilon)
equality test with an epsilon
bool | Equals (Matrix4 m)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
convert matrix to string for printing
override int | GetHashCode ()
gets the hash code for this vector

Static Public メソッド

static Matrix4 | Transformation (Vector3 translation, Quaternion rotation, Vector3 scale)
gets translation matrix times rotation matrix times scale matrix
static void | Transformation (ref Vector3 translation, ref Quaternion rotation, ref Vector3 scale, out Matrix4 result)
gets translation matrix times rotation matrix times scale matrix
static Matrix4 | Transformation (Vector2 translation, float rotation, Vector2 scale)
gets translation matrix times rotation matrix times scale matrix
static void | Transformation (ref Vector2 translation, float rotation, ref Vector2 scale, out Matrix4 result)
gets translation matrix times rotation matrix times scale matrix
static Matrix4 | Transformation (Vector3 translation, Vector3 scale)
gets translation matrix times scale matrix
static void | Transformation (ref Vector3 translation, ref Vector3 scale, out Matrix4 result)
gets translation matrix times scale matrix
static Matrix4 | Transformation (Vector2 translation, Vector2 scale)
gets translation matrix times scale matrix
static void | Transformation (ref Vector2 translation, ref Vector2 scale, out Matrix4 result)
gets translation matrix times scale matrix
static Matrix4 | Translation (float x, float y, float z)
get a matrix for translating a point
static void | Translation (float x, float y, float z, out Matrix4 result)
get a matrix for translating a point
static Matrix4 | Translation (Vector3 translation)
get a matrix for translating a point
static void | Translation (ref Vector3 translation, out Matrix4 result)
get a matrix for translating a point
static Matrix4 | Translation (Vector2 translation)
get a matrix for translating a point
static void | Translation (ref Vector2 translation, out Matrix4 result)
get a matrix for translating a point
static Matrix4 | RotationAxis (Vector3 axis, float angle)
gets the matrix for rotating about an axis
static void | RotationAxis (ref Vector3 axis, float angle, out Matrix4 result)
gets the matrix for rotating about an axis
static Matrix4 | RotationX (float angle)
gets a matrix for rotating around the x axis
static void | RotationX (float angle, out Matrix4 result)
gets a matrix for rotating around the x axis
static Matrix4 | RotationY (float angle)
gets a matrix for rotating around the y axis
static void | RotationY (float angle, out Matrix4 result)
gets a matrix for rotating around the y axis
static Matrix4 | RotationZ (float angle)
gets a matrix for rotating around the z axis
static void | RotationZ (float angle, out Matrix4 result)
gets a matrix for rotating around the z axis
static Matrix4 | RotationZyx (float x, float y, float z)
create a new matrix from three euler angles
static void | RotationZyx (float x, float y, float z, out Matrix4 result)
create a new matrix from three euler angles
static Matrix4 | RotationZyx (Vector3 angles)
create a new matrix from three euler angles
static void | RotationZyx (ref Vector3 angles, out Matrix4 result)
create a new matrix from three euler angles
static Matrix4 | RotationYxz (float x, float y, float z)
create a new matrix from three euler angles
static void | RotationYxz (float x, float y, float z, out Matrix4 result)
create a new matrix from three euler angles
static Matrix4 | RotationYxz (Vector3 angles)
create a new matrix from three euler angles
static void | RotationYxz (ref Vector3 angles, out Matrix4 result)
create a new matrix from three euler angles
static Matrix4 | RotationXzy (float x, float y, float z)
create a new matrix from three euler angles
static void | RotationXzy (float x, float y, float z, out Matrix4 result)
create a new matrix from three euler angles
static Matrix4 | RotationXzy (Vector3 angles)
create a new matrix from three euler angles
static void | RotationXzy (ref Vector3 angles, out Matrix4 result)
create a new matrix from three euler angles
static Matrix4 | RotationXyz (float x, float y, float z)
create a new matrix from three euler angles
static void | RotationXyz (float x, float y, float z, out Matrix4 result)
create a new matrix from three euler angles
static Matrix4 | RotationXyz (Vector3 angles)
create a new matrix from three euler angles
static void | RotationXyz (ref Vector3 angles, out Matrix4 result)
create a new matrix from three euler angles
static Matrix4 | RotationYzx (float x, float y, float z)
create a new matrix from three euler angles
static void | RotationYzx (float x, float y, float z, out Matrix4 result)
create a new matrix from three euler angles
static Matrix4 | RotationYzx (Vector3 angles)
create a new matrix from three euler angles
static void | RotationYzx (ref Vector3 angles, out Matrix4 result)
create a new matrix from three euler angles
static Matrix4 | RotationZxy (float x, float y, float z)
create a new matrix from three euler angles
static void | RotationZxy (float x, float y, float z, out Matrix4 result)
create a new matrix from three euler angles
static Matrix4 | RotationZxy (Vector3 angles)
create a new matrix from three euler angles
static void | RotationZxy (ref Vector3 angles, out Matrix4 result)
create a new matrix from three euler angles
static Matrix4 | Scale (float x, float y, float z)
get a matrix for scaling a point
static void | Scale (float x, float y, float z, out Matrix4 result)
get a matrix for scaling a point
static Matrix4 | Scale (Vector3 scale)
get a matrix for scaling a point
static void | Scale (ref Vector3 scale, out Matrix4 result)
get a matrix for scaling a point
static Matrix4 | Scale (Vector2 scale)
get a matrix for scaling a point
static void | Scale (ref Vector2 scale, out Matrix4 result)
get a matrix for scaling a point
static Matrix4 | Perspective (float fovy, float aspect, float n, float f)
gets a perspective matrix
static void | Perspective (float fovy, float aspect, float n, float f, out Matrix4 result)
gets a perspective matrix
static Matrix4 | Frustum (float l, float r, float b, float t, float n, float f)
gets a perspective matrix
static void | Frustum (float l, float r, float b, float t, float n, float f, out Matrix4 result)
gets a perspective matrix
static Matrix4 | Ortho (float l, float r, float b, float t, float n, float f)
gets an orthographic matrix
static void | Ortho (float l, float r, float b, float t, float n, float f, out Matrix4 result)
gets an orthographic matrix
static Matrix4 | LookAt (Vector3 eye, Vector3 center, Vector3 up)
gets the matrix for a viewing transformation
static void | LookAt (ref Vector3 eye, ref Vector3 center, ref Vector3 up, out Matrix4 result)
gets the matrix for a viewing transformation
static float | Determinant (Matrix4 m)
static function equivalent to Determinant()
static float | Determinant (ref Matrix4 m)
static function equivalent to Determinant()
static Matrix4 | Transpose (Matrix4 m)
static function equivalent to Transpose()
static void | Transpose (ref Matrix4 m, out Matrix4 result)
static function equivalent to Transpose(out Matrix4)
static Matrix4 | Inverse (Matrix4 m)
static function equivalent to Inverse()
static void | Inverse (ref Matrix4 m, out Matrix4 result)
static function equivalent to Inverse(out Matrix4)
static Matrix4 | InverseAffine (Matrix4 m)
static function equivalent to InverseAffine()
static void | InverseAffine (ref Matrix4 m, out Matrix4 result)
static function equivalent to InverseAffine(out Matrix4)
static Matrix4 | InverseOrthonormal (Matrix4 m)
static function equivalent to InverseOrthonormal()
static void | InverseOrthonormal (ref Matrix4 m, out Matrix4 result)
static function equivalent to InverseOrthonormal(out Matrix4)
static Matrix4 | Orthonormalize (Matrix4 m)
static function equivalent to Orthonormalize()
static void | Orthonormalize (ref Matrix4 m, out Matrix4 result)
static function equivalent to Orthonormalize(out Matrix4)
static Vector4 | Transform (Matrix4 m, Vector4 v)
static function equivalent to Transform(Vector4)
static void | Transform (ref Matrix4 m, ref Vector4 v, out Vector4 result)
static function equivalent to Transform(ref Vector4, out Vector4)
static Vector3 | TransformPoint (Matrix4 m, Vector3 v)
static function equivalent to TransformPoint(Vector3)
static void | TransformPoint (ref Matrix4 m, ref Vector3 v, out Vector3 result)
static function equivalent to TransformPoint(ref Vector3, out Vector3)
static Vector2 | TransformPoint (Matrix4 m, Vector2 v)
static function equivalent to TransformPoint(Vector2)
static void | TransformPoint (ref Matrix4 m, ref Vector2 v, out Vector2 result)
static function equivalent to TransformPoint(ref Vector2, out Vector2)
static Vector3 | TransformVector (Matrix4 m, Vector3 v)
static function equivalent to TransformVector(Vector3)
static void | TransformVector (ref Matrix4 m, ref Vector3 v, out Vector3 result)
static function equivalent to TransformVector(ref Vector3, out Vector3)
static Vector2 | TransformVector (Matrix4 m, Vector2 v)
static function equivalent to TransformVector(Vector2)
static void | TransformVector (ref Matrix4 m, ref Vector2 v, out Vector2 result)
static function equivalent to TransformVector(ref Vector2, out Vector2)
static Vector4 | TransformProjection (Matrix4 m, Vector4 v)
static function equivalent to TransformProjection(Vector4)
static void | TransformProjection (ref Matrix4 m, ref Vector4 v, out Vector4 result)
static function equivalent to TransformProjection(ref Vector4, out Vector4)
static Vector3 | TransformProjection (Matrix4 m, Vector3 v)
static function equivalent to TransformProjection(Vector3)
static void | TransformProjection (ref Matrix4 m, ref Vector3 v, out Vector3 result)
static function equivalent to TransformProjection(ref Vector3, out Vector3)
static Vector2 | TransformProjection (Matrix4 m, Vector2 v)
static function equivalent to TransformProjection(Vector2)
static void | TransformProjection (ref Matrix4 m, ref Vector2 v, out Vector2 result)
static function equivalent to TransformProjection(ref Vector2, out Vector2)
static Matrix4 | Add (Matrix4 m1, Matrix4 m2)
static function equivalent to Add(Matrix4)
static void | Add (ref Matrix4 m1, ref Matrix4 m2, out Matrix4 result)
static function equivalent to Add(ref Matrix4, out Matrix4)
static Matrix4 | Subtract (Matrix4 m1, Matrix4 m2)
static function equivalent to Subtract(Matrix4)
static void | Subtract (ref Matrix4 m1, ref Matrix4 m2, out Matrix4 result)
static function equivalent to Subtract(ref Matrix4, out Matrix4)
static Matrix4 | Multiply (Matrix4 m1, Matrix4 m2)
static function equivalent to Multiply(Matrix4)
static void | Multiply (ref Matrix4 m1, ref Matrix4 m2, out Matrix4 result)
static function equivalent to Multiply(ref Matrix4, out Matrix4)
static Matrix4 | MultiplyAffine (Matrix4 m1, Matrix4 m2)
static function equivalent to MultiplyAffine(Matrix4)
static void | MultiplyAffine (ref Matrix4 m1, ref Matrix4 m2, out Matrix4 result)
static function equivalent to MultiplyAffine(ref Matrix4, out Matrix4)
static Matrix4 | Multiply (Matrix4 m, float f)
static function equivalent to Multiply(float)
static void | Multiply (ref Matrix4 m, float f, out Matrix4 result)
static function equivalent to Multiply(float, out Matrix4)
static Matrix4 | Divide (Matrix4 m, float f)
static function equivalent to Divide(float)
static void | Divide (ref Matrix4 m, float f, out Matrix4 result)
static function equivalent to Divide(float, out Matrix4)
static Matrix4 | Negate (Matrix4 m)
static function equivalent to Negate()
static void | Negate (ref Matrix4 m, out Matrix4 result)
static function equivalent to Negate(out Matrix4)
static bool | operator== (Matrix4 m1, Matrix4 m2)
operator to test if two matrices are equal
static bool | operator!= (Matrix4 m1, Matrix4 m2)
operator to test if two matrices are not equal
static Matrix4 | operator+ (Matrix4 m1, Matrix4 m2)
operator adding each element of matrix 1 to the corresponding element of matrix 2
static Matrix4 | operator- (Matrix4 m1, Matrix4 m2)
operator subtracting each element of matrix 2 from the corresponding element of matrix 1
static Matrix4 | operator- (Matrix4 m)
unary minus operator
static Matrix4 | operator* (Matrix4 m1, Matrix4 m2)
operator multiplying a matrix by a matrix
static Matrix4 | operator* (Matrix4 m, float f)
operator multiplying each matrix element by a scalar float value
static Matrix4 | operator* (float f, Matrix4 m)
operator multiplying each matrix element by a scalar float value
static Vector4 | operator* (Matrix4 m, Vector4 v)
operator multiplying a matrix by a vector
static Matrix4 | operator/ (Matrix4 m, float f)
operator dividing each matrix element by a scalar float value

Public 変数

float | M11
column 1, element 1
float | M12
column 1, element 2
float | M13
column 1, element 3
float | M14
column 1, element 4
float | M21
column 2, element 1
float | M22
column 2, element 2
float | M23
column 2, element 3
float | M24
column 2, element 4
float | M31
column 3, element 1
float | M32
column 3, element 2
float | M33
column 3, element 3
float | M34
column 3, element 4
float | M41
column 4, element 1
float | M42
column 4, element 2
float | M43
column 4, element 3
float | M44
column 4, element 4

Static Public 変数

static readonly Matrix4 | Zero = new Matrix4(Vector4.Zero, Vector4.Zero, Vector4.Zero, Vector4.Zero)
a matrix of all zeroes
static readonly Matrix4 | Identity = new Matrix4(Vector4.UnitX, Vector4.UnitY, Vector4.UnitZ, Vector4.UnitW)
identity matrix

プロパティ

Vector4 | ColumnX [get, set]
the first column in the matrix
Vector4 | ColumnY [get, set]
the second column in the matrix
Vector4 | ColumnZ [get, set]
the third column in the matrix
Vector4 | ColumnW [get, set]
the fourth column in the matrix
Vector4 | RowX [get, set]
the first row in the matrix
Vector4 | RowY [get, set]
the second row in the matrix
Vector4 | RowZ [get, set]
the third row in the matrix
Vector4 | RowW [get, set]
the fourth row in the matrix
Vector3 | AxisX [get, set]
XYZ components of ColumnX.
Vector3 | AxisY [get, set]
XYZ components of ColumnY.
Vector3 | AxisZ [get, set]
XYZ components of ColumnZ.
Vector3 | AxisW [get, set]
XYZ components of ColumnW.

説明

matrix of 16 floats

コンストラクタとデストラクタ

Matrix4 | ( | float | m11,
 |  | float | m12,
 |  | float | m13,
 |  | float | m14,
 |  | float | m21,
 |  | float | m22,
 |  | float | m23,
 |  | float | m24,
 |  | float | m31,
 |  | float | m32,
 |  | float | m33,
 |  | float | m34,
 |  | float | m41,
 |  | float | m42,
 |  | float | m43,
 |  | float | m44
 | ) |  |

matrix constructor taking 16 scalar floats

引数:
m11 | value to initialize column 1 element 1 with
m12 | value to initialize column 1 element 2 with
m13 | value to initialize column 1 element 3 with
m14 | value to initialize column 1 element 4 with
m21 | value to initialize column 2 element 1 with
m22 | value to initialize column 2 element 2 with
m23 | value to initialize column 2 element 3 with
m24 | value to initialize column 2 element 4 with
m31 | value to initialize column 3 element 1 with
m32 | value to initialize column 3 element 2 with
m33 | value to initialize column 3 element 3 with
m34 | value to initialize column 3 element 4 with
m41 | value to initialize column 4 element 1 with
m42 | value to initialize column 4 element 2 with
m43 | value to initialize column 4 element 3 with
m44 | value to initialize column 4 element 4 with
Matrix4 | ( | Vector4 | x,
 |  | Vector4 | y,
 |  | Vector4 | z,
 |  | Vector4 | w
 | ) |  |

matrix constructor initializing the 4 matrix column vectors

引数:
x | vector to initialize matrix column 1 with
y | vector to initialize matrix column 2 with
z | vector to initialize matrix column 3 with
w | vector to initialize matrix column 4 with
Matrix4 | ( | Vector3 | x,
 |  | Vector3 | y,
 |  | Vector3 | z,
 |  | Vector3 | w
 | ) |  |

matrix constructor initializing the 4 matrix column vectors

引数:
x | vector to initialize matrix column 1 with
y | vector to initialize matrix column 2 with
z | vector to initialize matrix column 3 with
w | vector to initialize matrix column 4 with

メソッド

Matrix4 Add ( Matrix4 m )

return this + m

引数:
m matrix
戻り値:
this + m
static Matrix4 Add | ( | Matrix4 | m1,
 |  | Matrix4 | m2
 | ) |  | [static]

static function equivalent to Add(Matrix4)

引数:
m1 | matrix 1
m2 | matrix 2
戻り値:
m1 + m2
static void Add | ( | ref Matrix4 | m1,
 |  | ref Matrix4 | m2,
 |  | out Matrix4 | result
 | ) |  | [static]

static function equivalent to Add(ref Matrix4, out Matrix4)

引数:
m1 | matrix 1
m2 | matrix 2
result | m1 + m2
void Add | ( | ref Matrix4 | m,
 |  | out Matrix4 | result
 | ) |  |

result = this + m

引数:
m | matrix
result | this + m
static float Determinant ( Matrix4 m ) [static]

static function equivalent to Determinant()

引数:
m matrix
戻り値:
the determinant of this matrix
float Determinant ( )

return the determinant of this matrix

戻り値:
the determinant of this matrix
static float Determinant ( ref Matrix4 m ) [static]

static function equivalent to Determinant()

引数:
m matrix
戻り値:
the determinant of this matrix
Matrix4 Divide ( float f )

return this / f

引数:
f scalar
戻り値:
this / f
void Divide | ( | float | f,
 |  | out Matrix4 | result
 | ) |  |

result = this / f

引数:
f | scalar
result | this / f
static Matrix4 Divide | ( | Matrix4 | m,
 |  | float | f
 | ) |  | [static]

static function equivalent to Divide(float)

引数:
m | matrix
f | scalar
戻り値:
m / f
static void Divide | ( | ref Matrix4 | m,
 |  | float | f,
 |  | out Matrix4 | result
 | ) |  | [static]

static function equivalent to Divide(float, out Matrix4)

引数:
m | matrix
f | scalar
result | m / f
bool Equals | ( | Matrix4 | m,
 |  | float | epsilon
 | ) |  |

equality test with an epsilon

引数:
m | the matrix to compare this to
epsilon | the epsilon to use in comparison
戻り値:
true if for every element n, abs(this[n] - m[n]) <= epsilon, false otherwise
bool Equals ( Matrix4 m )

equality test

引数:
m the matrix to compare this to
戻り値:
true if this == m, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
static void Frustum | ( | float | l,
 |  | float | r,
 |  | float | b,
 |  | float | t,
 |  | float | n,
 |  | float | f,
 |  | out Matrix4 | result
 | ) |  | [static]

gets a perspective matrix

引数:
l | coordinates for the left vertical clip plane
r | coordinates for the right vertical clip plane
b | coordinates for the bottom horizontal clip plane
t | coordinates for the top horizontal clip plane
n | distance to the near clip plane
f | distance to the far clip plane
result | perspective matrix
static Matrix4 Frustum | ( | float | l,
 |  | float | r,
 |  | float | b,
 |  | float | t,
 |  | float | n,
 |  | float | f
 | ) |  | [static]

gets a perspective matrix

引数:
l | coordinates for the left vertical clip plane
r | coordinates for the right vertical clip plane
b | coordinates for the bottom horizontal clip plane
t | coordinates for the top horizontal clip plane
n | distance to the near clip plane
f | distance to the far clip plane
戻り値:
perspective matrix
override int GetHashCode ( )

gets the hash code for this vector

戻り値:
integer hash code
Matrix4 Inverse ( )

inverse for a matrix

戻り値:
matrix inverse
void Inverse ( out Matrix4 result )

inverse for a matrix

引数:
result matrix inverse
static Matrix4 Inverse ( Matrix4 m ) [static]

static function equivalent to Inverse()

引数:
m matrix
戻り値:
matrix inverse
static void Inverse | ( | ref Matrix4 | m,
 |  | out Matrix4 | result
 | ) |  | [static]

static function equivalent to Inverse(out Matrix4)

引数:
m | matrix
result | matrix inverse
Matrix4 InverseAffine ( )

inverse for an affine matrix

戻り値:
matrix inverse
void InverseAffine ( out Matrix4 result )

inverse for an affine matrix

引数:
result matrix inverse
static Matrix4 InverseAffine ( Matrix4 m ) [static]

static function equivalent to InverseAffine()

引数:
m matrix
戻り値:
matrix inverse
static void InverseAffine | ( | ref Matrix4 | m,
 |  | out Matrix4 | result
 | ) |  | [static]

static function equivalent to InverseAffine(out Matrix4)

引数:
m | matrix
result | matrix inverse
Matrix4 InverseOrthonormal ( )

inverse for a orthonormal martix

戻り値:
matrix inverse
void InverseOrthonormal ( out Matrix4 result )

inverse for a orthonormal matrix

引数:
result matrix inverse
static Matrix4 InverseOrthonormal ( Matrix4 m ) [static]

static function equivalent to InverseOrthonormal()

引数:
m matrix
戻り値:
matrix inverse
static void InverseOrthonormal | ( | ref Matrix4 | m,
 |  | out Matrix4 | result
 | ) |  | [static]

static function equivalent to InverseOrthonormal(out Matrix4)

引数:
m | matrix
result | matrix inverse
bool IsIdentity ( )

test if this is an identity matrix

戻り値:
true if this is an identity matrix, false otherwise
bool IsInfinity ( )

test if any elements of this are Infinity

戻り値:
true if any elements of this are Infinity, false otherwise
bool IsNaN ( )

test if any elements of this are NaN

戻り値:
true if any elements of this are NaN, false otherwise
bool IsOrthonormal ( float epsilon )

test to determine if a matrix is orthonormal

引数:
epsilon epsilon for testing if vectors are unit vectors
戻り値:
true if the matrix is orthonormal, false otherwise
static Matrix4 LookAt | ( | Vector3 | eye,
 |  | Vector3 | center,
 |  | Vector3 | up
 | ) |  | [static]

gets the matrix for a viewing transformation

引数:
eye | position of the eye point
center | position of the reference point
up | the up vector
戻り値:
viewing transformation matrix
static void LookAt | ( | ref Vector3 | eye,
 |  | ref Vector3 | center,
 |  | ref Vector3 | up,
 |  | out Matrix4 | result
 | ) |  | [static]

gets the matrix for a viewing transformation

引数:
eye | position of the eye point
center | position of the reference point
up | the up vector
result | viewing transformation matrix
void Multiply | ( | ref Matrix4 | m,
 |  | out Matrix4 | result
 | ) |  |

result = this * m

引数:
m | matrix
result | this * m
Matrix4 Multiply ( Matrix4 m )

return this * m

引数:
m matrix
戻り値:
this * m
static Matrix4 Multiply | ( | Matrix4 | m1,
 |  | Matrix4 | m2
 | ) |  | [static]

static function equivalent to Multiply(Matrix4)

引数:
m1 | matrix 1
m2 | matrix 2
戻り値:
m1 * m2
static void Multiply | ( | ref Matrix4 | m1,
 |  | ref Matrix4 | m2,
 |  | out Matrix4 | result
 | ) |  | [static]

static function equivalent to Multiply(ref Matrix4, out Matrix4)

引数:
m1 | matrix 1
m2 | matrix 2
result | m1 * m2
static Matrix4 Multiply | ( | Matrix4 | m,
 |  | float | f
 | ) |  | [static]

static function equivalent to Multiply(float)

引数:
m | matrix
f | scalar
戻り値:
m * f
void Multiply | ( | float | f,
 |  | out Matrix4 | result
 | ) |  |

result = this * f

引数:
f | scalar
result | this * f
static void Multiply | ( | ref Matrix4 | m,
 |  | float | f,
 |  | out Matrix4 | result
 | ) |  | [static]

static function equivalent to Multiply(float, out Matrix4)

引数:
m | matrix
f | scalar
result | m * f
Matrix4 Multiply ( float f )

return this * f

引数:
f scalar
戻り値:
this * f
Matrix4 MultiplyAffine ( Matrix4 m )

return this * m ( for affine matrices )

引数:
m matrix
戻り値:
this * m
void MultiplyAffine | ( | ref Matrix4 | m,
 |  | out Matrix4 | result
 | ) |  |

result = this * m ( for affine matrices )

引数:
m | matrix
result | this * m
static Matrix4 MultiplyAffine | ( | Matrix4 | m1,
 |  | Matrix4 | m2
 | ) |  | [static]

static function equivalent to MultiplyAffine(Matrix4)

引数:
m1 | matrix 1
m2 | matrix 2
戻り値:
m1 * m2
static void MultiplyAffine | ( | ref Matrix4 | m1,
 |  | ref Matrix4 | m2,
 |  | out Matrix4 | result
 | ) |  | [static]

static function equivalent to MultiplyAffine(ref Matrix4, out Matrix4)

引数:
m1 | matrix 1
m2 | matrix 2
result | m1 * m2
static void Negate | ( | ref Matrix4 | m,
 |  | out Matrix4 | result
 | ) |  | [static]

static function equivalent to Negate(out Matrix4)

引数:
m | matrix
result | -m
void Negate ( out Matrix4 result )

result = -this

引数:
result -this
Matrix4 Negate ( )

return -this

戻り値:
-this
static Matrix4 Negate ( Matrix4 m ) [static]

static function equivalent to Negate()

引数:
m matrix
戻り値:
-m
static bool operator!= | ( | Matrix4 | m1,
 |  | Matrix4 | m2
 | ) |  | [static]

operator to test if two matrices are not equal

引数:
m1 | matrix 1
m2 | matrix 2
戻り値:
true if not equal, false otherwise
static Matrix4 operator* | ( | Matrix4 | m1,
 |  | Matrix4 | m2
 | ) |  | [static]

operator multiplying a matrix by a matrix

引数:
m1 | matrix 1
m2 | matrix 2
static Matrix4 operator* | ( | Matrix4 | m,
 |  | float | f
 | ) |  | [static]

operator multiplying each matrix element by a scalar float value

引数:
m | the matrix to multiply
f | the scalar float to multiply each matrix element by
static Matrix4 operator* | ( | float | f,
 |  | Matrix4 | m
 | ) |  | [static]

operator multiplying each matrix element by a scalar float value

引数:
f | the scalar float to multiply each matrix element by
m | the matrix to multiply
static Vector4 operator* | ( | Matrix4 | m,
 |  | Vector4 | v
 | ) |  | [static]

operator multiplying a matrix by a vector

引数:
m | the matrix to multiply
v | the vector to multiply the matrix by
static Matrix4 operator+ | ( | Matrix4 | m1,
 |  | Matrix4 | m2
 | ) |  | [static]

operator adding each element of matrix 1 to the corresponding element of matrix 2

引数:
m1 | matrix 1
m2 | matrix 2
static Matrix4 operator- | ( | Matrix4 | m1,
 |  | Matrix4 | m2
 | ) |  | [static]

operator subtracting each element of matrix 2 from the corresponding element of matrix 1

引数:
m1 | matrix 1
m2 | matrix 2
戻り値:
matrix 1 - matrix 2
static Matrix4 operator- ( Matrix4 m ) [static]

unary minus operator

引数:
m matrix to negate
戻り値:
unary minus applied to each member of m
static Matrix4 operator/ | ( | Matrix4 | m,
 |  | float | f
 | ) |  | [static]

operator dividing each matrix element by a scalar float value

引数:
m | the matrix to divide
f | the scalar float to divide each element by
static bool operator== | ( | Matrix4 | m1,
 |  | Matrix4 | m2
 | ) |  | [static]

operator to test if two matrices are equal

引数:
m1 | matrix 1
m2 | matrix 2
戻り値:
true is equal, false otherwise
static Matrix4 Ortho | ( | float | l,
 |  | float | r,
 |  | float | b,
 |  | float | t,
 |  | float | n,
 |  | float | f
 | ) |  | [static]

gets an orthographic matrix

引数:
l | coordinates for the left vertical clip plane
r | coordinates for the right vertical clip plane
b | coordinates for the bottom horizontal clip plane
t | coordinates for the top horizontal clip plane
n | distance to the near clip plane
f | distance to the far clip plane
戻り値:
orthographic matrix
static void Ortho | ( | float | l,
 |  | float | r,
 |  | float | b,
 |  | float | t,
 |  | float | n,
 |  | float | f,
 |  | out Matrix4 | result
 | ) |  | [static]

gets an orthographic matrix

引数:
l | coordinates for the left vertical clip plane
r | coordinates for the right vertical clip plane
b | coordinates for the bottom horizontal clip plane
t | coordinates for the top horizontal clip plane
n | distance to the near clip plane
f | distance to the far clip plane
result | orthographic matrix
Matrix4 Orthonormalize ( )

orthonormalize a matrix

戻り値:
orthonormalized matrix
void Orthonormalize ( out Matrix4 result )

orthonormalize a matrix

引数:
result orthonormalized matrix
static Matrix4 Orthonormalize ( Matrix4 m ) [static]

static function equivalent to Orthonormalize()

引数:
m matrix
戻り値:
orthonormalized matrix
static void Orthonormalize | ( | ref Matrix4 | m,
 |  | out Matrix4 | result
 | ) |  | [static]

static function equivalent to Orthonormalize(out Matrix4)

引数:
m | matrix
result | orthonormalized matrix
static Matrix4 Perspective | ( | float | fovy,
 |  | float | aspect,
 |  | float | n,
 |  | float | f
 | ) |  | [static]

gets a perspective matrix

引数:
fovy | field of view angle in the y direction
aspect | aspect ratio
n | distance from the viewer to the near clip
f | distance from the viewer to the far clip
戻り値:
perspective matrix
static void Perspective | ( | float | fovy,
 |  | float | aspect,
 |  | float | n,
 |  | float | f,
 |  | out Matrix4 | result
 | ) |  | [static]

gets a perspective matrix

引数:
fovy | field of view angle in the y direction
aspect | aspect ratio
n | distance from the viewer to the near clip
f | distance from the viewer to the far clip
result | perspective matrix
static Matrix4 RotationAxis | ( | Vector3 | axis,
 |  | float | angle
 | ) |  | [static]

gets the matrix for rotating about an axis

引数:
axis | the axis to rotate around
angle | the angle to rotate
戻り値:
rotation matrix
static void RotationAxis | ( | ref Vector3 | axis,
 |  | float | angle,
 |  | out Matrix4 | result
 | ) |  | [static]

gets the matrix for rotating about an axis

引数:
axis | the axis to rotate around
angle | the angle to rotate
result | rotation matrix
static Matrix4 RotationX ( float angle ) [static]

gets a matrix for rotating around the x axis

引数:
angle the angle to rotate
戻り値:
rotation matrix
static void RotationX | ( | float | angle,
 |  | out Matrix4 | result
 | ) |  | [static]

gets a matrix for rotating around the x axis

引数:
angle | the angle to rotate
result | rotation matrix
static void RotationXyz | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Matrix4 | result
 | ) |  | [static]

create a new matrix from three euler angles

引数:
x | x angle
y | y angle
z | z angle
result | a new matrix from the three euler angles
static Matrix4 RotationXyz | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

create a new matrix from three euler angles

引数:
x | x angle
y | y angle
z | z angle
戻り値:
a new matrix from the three euler angles
static Matrix4 RotationXyz ( Vector3 angles ) [static]

create a new matrix from three euler angles

引数:
angles the x, y, z euler angles used to create the matrix
戻り値:
a new matrix from the three euler angles
static void RotationXyz | ( | ref Vector3 | angles,
 |  | out Matrix4 | result
 | ) |  | [static]

create a new matrix from three euler angles

引数:
angles | the x, y, z euler angles used to create the matrix
result | a new matrix from the three euler angles
static void RotationXzy | ( | ref Vector3 | angles,
 |  | out Matrix4 | result
 | ) |  | [static]

create a new matrix from three euler angles

引数:
angles | the x, z, y euler angles used to create the matrix
result | a new matrix from the three euler angles
static Matrix4 RotationXzy | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

create a new matrix from three euler angles

引数:
x | x angle
y | y angle
z | z angle
戻り値:
a new matrix from the three euler angles
static void RotationXzy | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Matrix4 | result
 | ) |  | [static]

create a new matrix from three euler angles

引数:
x | x angle
y | y angle
z | z angle
result | a new matrix from the three euler angles
static Matrix4 RotationXzy ( Vector3 angles ) [static]

create a new matrix from three euler angles

引数:
angles the x, z, y euler angles used to create the matrix
戻り値:
a new matrix from the three euler angles
static Matrix4 RotationY ( float angle ) [static]

gets a matrix for rotating around the y axis

引数:
angle the angle to rotate
戻り値:
rotation matrix
static void RotationY | ( | float | angle,
 |  | out Matrix4 | result
 | ) |  | [static]

gets a matrix for rotating around the y axis

引数:
angle | the angle to rotate
result | rotation matrix
static void RotationYxz | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Matrix4 | result
 | ) |  | [static]

create a new matrix from three euler angles

引数:
x | x angle
y | y angle
z | z angle
result | a new matrix from the three euler angles
static void RotationYxz | ( | ref Vector3 | angles,
 |  | out Matrix4 | result
 | ) |  | [static]

create a new matrix from three euler angles

引数:
angles | the y, x, z euler angles used to create the matrix
result | a new matrix from the three euler angles
static Matrix4 RotationYxz ( Vector3 angles ) [static]

create a new matrix from three euler angles

引数:
angles the y, x, z euler angles used to create the matrix
戻り値:
a new matrix from the three euler angles
static Matrix4 RotationYxz | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

create a new matrix from three euler angles

引数:
x | x angle
y | y angle
z | z angle
戻り値:
a new matrix from the three euler angles
static Matrix4 RotationYzx ( Vector3 angles ) [static]

create a new matrix from three euler angles

引数:
angles the y, z, x euler angles used to create the matrix
戻り値:
a new matrix from the three euler angles
static Matrix4 RotationYzx | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

create a new matrix from three euler angles

引数:
x | x angle
y | y angle
z | z angle
戻り値:
a new matrix from the three euler angles
static void RotationYzx | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Matrix4 | result
 | ) |  | [static]

create a new matrix from three euler angles

引数:
x | x angle
y | y angle
z | z angle
result | a new matrix from the three euler angles
static void RotationYzx | ( | ref Vector3 | angles,
 |  | out Matrix4 | result
 | ) |  | [static]

create a new matrix from three euler angles

引数:
angles | the y, z, x euler angles used to create the matrix
result | a new matrix from the three euler angles
static Matrix4 RotationZ ( float angle ) [static]

gets a matrix for rotating around the z axis

引数:
angle the angle to rotate
戻り値:
rotation matrix
static void RotationZ | ( | float | angle,
 |  | out Matrix4 | result
 | ) |  | [static]

gets a matrix for rotating around the z axis

引数:
angle | the angle to rotate
result | rotation matrix
static Matrix4 RotationZxy ( Vector3 angles ) [static]

create a new matrix from three euler angles

引数:
angles the z, x, y euler angles used to create the matrix
戻り値:
a new matrix from the three euler angles
static Matrix4 RotationZxy | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

create a new matrix from three euler angles

引数:
x | x angle
y | y angle
z | z angle
戻り値:
a new matrix from the three euler angles
static void RotationZxy | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Matrix4 | result
 | ) |  | [static]

create a new matrix from three euler angles

引数:
x | x angle
y | y angle
z | z angle
result | a new matrix from the three euler angles
static void RotationZxy | ( | ref Vector3 | angles,
 |  | out Matrix4 | result
 | ) |  | [static]

create a new matrix from three euler angles

引数:
angles | the z, x, y euler angles used to create the matrix
result | a new matrix from the three euler angles
static void RotationZyx | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Matrix4 | result
 | ) |  | [static]

create a new matrix from three euler angles

引数:
x | x angle
y | y angle
z | z angle
result | a new matrix from the three euler angles
static Matrix4 RotationZyx | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

create a new matrix from three euler angles

引数:
x | x angle
y | y angle
z | z angle
戻り値:
a new matrix from the three euler angles
static void RotationZyx | ( | ref Vector3 | angles,
 |  | out Matrix4 | result
 | ) |  | [static]

create a new matrix from three euler angles

引数:
angles | the z, y, x euler angles used to create the matrix
result | a new matrix from the three euler angles
static Matrix4 RotationZyx ( Vector3 angles ) [static]

create a new matrix from three euler angles

引数:
angles the z, y, x euler angles used to create the matrix
戻り値:
a new matrix from the three euler angles
static Matrix4 Scale ( Vector3 scale ) [static]

get a matrix for scaling a point

引数:
scale a vector containing the x, y, z scale values
戻り値:
scaling matrix
static Matrix4 Scale | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

get a matrix for scaling a point

引数:
x | x scale
y | y scale
z | z scale
戻り値:
scaling matrix
static void Scale | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Matrix4 | result
 | ) |  | [static]

get a matrix for scaling a point

引数:
x | x scale
y | y scale
z | z scale
result | scaling matrix
static Matrix4 Scale ( Vector2 scale ) [static]

get a matrix for scaling a point

引数:
scale a vector containing the x, y scale values
戻り値:
scaling matrix
static void Scale | ( | ref Vector3 | scale,
 |  | out Matrix4 | result
 | ) |  | [static]

get a matrix for scaling a point

引数:
scale | a vector containing the x, y, z scale values
result | scaling matrix
static void Scale | ( | ref Vector2 | scale,
 |  | out Matrix4 | result
 | ) |  | [static]

get a matrix for scaling a point

引数:
scale | a vector containing the x, y scale values
result | scaling matrix
static void Subtract | ( | ref Matrix4 | m1,
 |  | ref Matrix4 | m2,
 |  | out Matrix4 | result
 | ) |  | [static]

static function equivalent to Subtract(ref Matrix4, out Matrix4)

引数:
m1 | matrix 1
m2 | matrix 2
result | m1 - m2
static Matrix4 Subtract | ( | Matrix4 | m1,
 |  | Matrix4 | m2
 | ) |  | [static]

static function equivalent to Subtract(Matrix4)

引数:
m1 | matrix 1
m2 | matrix 2
戻り値:
m1 - m2
Matrix4 Subtract ( Matrix4 m )

return this - m

引数:
m matrix
戻り値:
this - m
void Subtract | ( | ref Matrix4 | m,
 |  | out Matrix4 | result
 | ) |  |

result = this - m

引数:
m | matrix
result | this - m
override string ToString ( )

convert matrix to string for printing

戻り値:
matrix as string
Vector4 Transform ( Vector4 v )

return this * v

引数:
v vector
戻り値:
this * v
void Transform | ( | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  |

result = this * v

引数:
v | vector
result | this * v
static Vector4 Transform | ( | Matrix4 | m,
 |  | Vector4 | v
 | ) |  | [static]

static function equivalent to Transform(Vector4)

引数:
m | matrix
v | vector
戻り値:
m * v
static void Transform | ( | ref Matrix4 | m,
 |  | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Transform(ref Vector4, out Vector4)

引数:
m | matrix
v | vector
result | m * v
static Matrix4 Transformation | ( | Vector3 | translation,
 |  | Quaternion | rotation,
 |  | Vector3 | scale
 | ) |  | [static]

gets translation matrix times rotation matrix times scale matrix

引数:
translation | x, y, z translation values
rotation | quaternion rotation values
scale | x, y, z scale values
戻り値:
translation matrix times rotation matrix times scale matrix
static Matrix4 Transformation | ( | Vector2 | translation,
 |  | Vector2 | scale
 | ) |  | [static]

gets translation matrix times scale matrix

引数:
translation | x, y translation values
scale | x, y scale values
戻り値:
translation matrix times scale matrix
static void Transformation | ( | ref Vector2 | translation,
 |  | ref Vector2 | scale,
 |  | out Matrix4 | result
 | ) |  | [static]

gets translation matrix times scale matrix

引数:
translation | x, y translation values
scale | x, y scale values
result | translation matrix times scale matrix
static Matrix4 Transformation | ( | Vector3 | translation,
 |  | Vector3 | scale
 | ) |  | [static]

gets translation matrix times scale matrix

引数:
translation | x, y, z translation values
scale | x, y, z scale values
戻り値:
translation matrix times scale matrix
static void Transformation | ( | ref Vector2 | translation,
 |  | float | rotation,
 |  | ref Vector2 | scale,
 |  | out Matrix4 | result
 | ) |  | [static]

gets translation matrix times rotation matrix times scale matrix

引数:
translation | x, y translation values
rotation | z rotation angle
scale | x, y scale values
result | translation matrix times rotation matrix times scale matrix
static void Transformation | ( | ref Vector3 | translation,
 |  | ref Quaternion | rotation,
 |  | ref Vector3 | scale,
 |  | out Matrix4 | result
 | ) |  | [static]

gets translation matrix times rotation matrix times scale matrix

引数:
translation | x, y, z translation values
rotation | quaternion rotation values
scale | x, y, z scale values
result | translation matrix times rotation matrix times scale matrix
static void Transformation | ( | ref Vector3 | translation,
 |  | ref Vector3 | scale,
 |  | out Matrix4 | result
 | ) |  | [static]

gets translation matrix times scale matrix

引数:
translation | x, y, z translation values
scale | x, y, z scale values
result | translation matrix times scale matrix
static Matrix4 Transformation | ( | Vector2 | translation,
 |  | float | rotation,
 |  | Vector2 | scale
 | ) |  | [static]

gets translation matrix times rotation matrix times scale matrix

引数:
translation | x, y translation values
rotation | z rotation angle
scale | x, y scale values
戻り値:
translation matrix times rotation matrix times scale matrix
static void TransformPoint | ( | ref Matrix4 | m,
 |  | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to TransformPoint(ref Vector2, out Vector2)

引数:
m | matrix
v | vector
result | m * v (X,Y,0,1)
Vector3 TransformPoint ( Vector3 v )

return this * v (X,Y,Z,1)

引数:
v vector
戻り値:
this * v (X,Y,Z,1)
void TransformPoint | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  |

result = this * v (X,Y,0,1)

引数:
v | vector
result | this * v (X,Y,0,1)
void TransformPoint | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  |

result = this * v (X,Y,Z,1)

引数:
v | vector
result | this * v (X,Y,Z,1)
static Vector2 TransformPoint | ( | Matrix4 | m,
 |  | Vector2 | v
 | ) |  | [static]

static function equivalent to TransformPoint(Vector2)

引数:
m | matrix
v | vector
戻り値:
m * v (X,Y,0,1)
static Vector3 TransformPoint | ( | Matrix4 | m,
 |  | Vector3 | v
 | ) |  | [static]

static function equivalent to TransformPoint(Vector3)

引数:
m | matrix
v | vector
戻り値:
m * v (X,Y,Z,1)
static void TransformPoint | ( | ref Matrix4 | m,
 |  | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to TransformPoint(ref Vector3, out Vector3)

引数:
m | matrix
v | vector
result | m * v (X,Y,Z,1)
Vector2 TransformPoint ( Vector2 v )

return this * v (X,Y,0,1)

引数:
v vector
戻り値:
this * v (X,Y,0,1)
static void TransformProjection | ( | ref Matrix4 | m,
 |  | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to TransformProjection(ref Vector4, out Vector4)

引数:
m | matrix
v | vector
result | m * v ( divided by W )
void TransformProjection | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  |

result = this * v ( divided by W )

引数:
v | vector
result | this * v ( divided by W )
static Vector3 TransformProjection | ( | Matrix4 | m,
 |  | Vector3 | v
 | ) |  | [static]

static function equivalent to TransformProjection(Vector3)

引数:
m | matrix
v | vector
戻り値:
m * v ( divided by W )
static Vector4 TransformProjection | ( | Matrix4 | m,
 |  | Vector4 | v
 | ) |  | [static]

static function equivalent to TransformProjection(Vector4)

引数:
m | matrix
v | vector
戻り値:
m * v ( divided by W )
void TransformProjection | ( | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  |

result = this * v ( divided by W )

引数:
v | vector
result | this * v ( divided by W )
Vector3 TransformProjection ( Vector3 v )

return this * v ( divided by W )

引数:
v vector
戻り値:
this * v ( divided by W )
void TransformProjection | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  |

result = this * v ( divided by W )

引数:
v | vector
result | this * v ( divided by W )
Vector4 TransformProjection ( Vector4 v )

return this * v ( divided by W )

引数:
v vector
戻り値:
this * v ( divided by W )
static void TransformProjection | ( | ref Matrix4 | m,
 |  | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to TransformProjection(ref Vector2, out Vector2)

引数:
m | matrix
v | vector
result | m * v ( divided by W )
static void TransformProjection | ( | ref Matrix4 | m,
 |  | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to TransformProjection(ref Vector3, out Vector3)

引数:
m | matrix
v | vector
result | m * v ( divided by W )
Vector2 TransformProjection ( Vector2 v )

return this * v ( divided by W )

引数:
v vector
戻り値:
this * v ( divided by W )
static Vector2 TransformProjection | ( | Matrix4 | m,
 |  | Vector2 | v
 | ) |  | [static]

static function equivalent to TransformProjection(Vector2)

引数:
m | matrix
v | vector
戻り値:
m * v ( divided by W )
Vector2 TransformVector ( Vector2 v )

return this * v (X,Y,0,0)

引数:
v vector
戻り値:
this * v (X,Y,0,0)
static Vector2 TransformVector | ( | Matrix4 | m,
 |  | Vector2 | v
 | ) |  | [static]

static function equivalent to TransformVector(Vector2)

引数:
m | matrix
v | vector
戻り値:
m * v (X,Y,0,0)
void TransformVector | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  |

result = this * v (X,Y,Z,0)

引数:
v | vector
result | this * v (X,Y,Z,0)
static void TransformVector | ( | ref Matrix4 | m,
 |  | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to TransformVector(ref Vector3, out Vector3)

引数:
m | matrix
v | vector
result | m * v (X,Y,Z,0)
static void TransformVector | ( | ref Matrix4 | m,
 |  | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to TransformVector(ref Vector2, out Vector2)

引数:
m | matrix
v | vector
result | m * v (X,Y,0,0)
static Vector3 TransformVector | ( | Matrix4 | m,
 |  | Vector3 | v
 | ) |  | [static]

static function equivalent to TransformVector(Vector3)

引数:
m | matrix
v | vector
戻り値:
m * v (X,Y,Z,0)
void TransformVector | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  |

result = this * v (X,Y,0,0)

引数:
v | vector
result | this * v (X,Y,0,0)
Vector3 TransformVector ( Vector3 v )

return this * v (X,Y,Z,0)

引数:
v vector
戻り値:
this * v (X,Y,Z,0)
static Matrix4 Translation ( Vector3 translation ) [static]

get a matrix for translating a point

引数:
translation a vector containing the x, y, z translation values
戻り値:
translation matrix
static void Translation | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Matrix4 | result
 | ) |  | [static]

get a matrix for translating a point

引数:
x | x translation
y | y translation
z | z translation
result | translation matrix
static Matrix4 Translation | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

get a matrix for translating a point

引数:
x | x translation
y | y translation
z | z translation
戻り値:
translation matrix
static void Translation | ( | ref Vector2 | translation,
 |  | out Matrix4 | result
 | ) |  | [static]

get a matrix for translating a point

引数:
translation | a vector containing the x, y translation values
result | translation matrix
static Matrix4 Translation ( Vector2 translation ) [static]

get a matrix for translating a point

引数:
translation a vector containing the x, y translation values
戻り値:
translation matrix
static void Translation | ( | ref Vector3 | translation,
 |  | out Matrix4 | result
 | ) |  | [static]

get a matrix for translating a point

引数:
translation | a vector containing the x, y, z translation values
result | translation matrix
static void Transpose | ( | ref Matrix4 | m,
 |  | out Matrix4 | result
 | ) |  | [static]

static function equivalent to Transpose(out Matrix4)

引数:
m | matrix
result | matrix transpose
Matrix4 Transpose ( )

get the transpose of the matrix

戻り値:
matrix transpose
static Matrix4 Transpose ( Matrix4 m ) [static]

static function equivalent to Transpose()

引数:
m matrix
戻り値:
matrix transpose
void Transpose ( out Matrix4 result )

get the transpose of the matrix

引数:
result matrix transpose

変数

readonly Matrix4 Identity = new Matrix4(Vector4.UnitX, Vector4.UnitY, Vector4.UnitZ, Vector4.UnitW) [static]

identity matrix

float M11

column 1, element 1

float M12

column 1, element 2

float M13

column 1, element 3

float M14

column 1, element 4

float M21

column 2, element 1

float M22

column 2, element 2

float M23

column 2, element 3

float M24

column 2, element 4

float M31

column 3, element 1

float M32

column 3, element 2

float M33

column 3, element 3

float M34

column 3, element 4

float M41

column 4, element 1

float M42

column 4, element 2

float M43

column 4, element 3

float M44

column 4, element 4

readonly Matrix4 Zero = new Matrix4(Vector4.Zero, Vector4.Zero, Vector4.Zero, Vector4.Zero) [static]

a matrix of all zeroes

プロパティ

Vector3 AxisW [get, set]

XYZ components of ColumnW.

Vector3 AxisX [get, set]

XYZ components of ColumnX.

Vector3 AxisY [get, set]

XYZ components of ColumnY.

Vector3 AxisZ [get, set]

XYZ components of ColumnZ.

Vector4 ColumnW [get, set]

the fourth column in the matrix

Vector4 ColumnX [get, set]

the first column in the matrix

Vector4 ColumnY [get, set]

the second column in the matrix

Vector4 ColumnZ [get, set]

the third column in the matrix

Vector4 RowW [get, set]

the fourth row in the matrix

Vector4 RowX [get, set]

the first row in the matrix

Vector4 RowY [get, set]

the second row in the matrix

Vector4 RowZ [get, set]

the third row in the matrix


構造体 Quaternion

quaternion [詳細]

すべてのメンバ一覧

Public メソッド

Quaternion (float x, float y, float z, float w)
constructor taking 4 floats
Quaternion (Vector3 xyz, float w)
constructor taking a Vector3 and a scalar float
Quaternion (Vector4 v)
constructor taking a Vector4
float | Length ()
return the length of this quaternion
float | LengthSquared ()
return the length squared of this quaternion
float | Dot (Quaternion q)
dot product
float | Dot (ref Quaternion q)
dot product
Quaternion Normalize ()
return a unit quaternion
void | Normalize (out Quaternion result)
return a unit quaternion
Quaternion Conjugate ()
quaternion conjugate
void | Conjugate (out Quaternion result)
quaternion conjugate
Quaternion Inverse ()
quaternion inverse
void | Inverse (out Quaternion result)
quaternion inverse
Quaternion | Slerp (Quaternion q, float f)
slerp between 2 quaternions
void | Slerp (ref Quaternion q, float f, out Quaternion result)
slerp between 2 quaternions
Quaternion | Lerp (Quaternion q, float f)
lerp between 2 quaternions
void | Lerp (ref Quaternion q, float f, out Quaternion result)
lerp between 2 quaternions
Quaternion Log ()
quaternion log
void | Log (out Quaternion result)
quaternion log
Quaternion Exp ()
quaternion exp
void | Exp (out Quaternion result)
quaternion exp
Quaternion | TurnTo (Quaternion q, float angle)
turn to target quaternion by specified angle
void | TurnTo (ref Quaternion q, float angle, out Quaternion result)
turn to target quaternion by specified angle
float | Angle (Quaternion q)
get the angle between this and the input quaternion
float | Angle (ref Quaternion q)
get the angle between this and the input quaternion
Vector4 | Transform (Vector4 v)
return this * v
void | Transform (ref Vector4 v, out Vector4 result)
result = this * v
Vector3 | Transform (Vector3 v)
return this * v
void | Transform (ref Vector3 v, out Vector3 result)
result = this * v
Vector2 | Transform (Vector2 v)
return this * v
void | Transform (ref Vector2 v, out Vector2 result)
result = this * v
Quaternion | Add (Quaternion q)
return this + q
void | Add (ref Quaternion q, out Quaternion result)
result = this + q
Quaternion | Subtract (Quaternion q)
return this - q
void | Subtract (ref Quaternion q, out Quaternion result)
result = this - q
Quaternion | Multiply (Quaternion q)
return this * q
void | Multiply (ref Quaternion q, out Quaternion result)
result = this * q
Quaternion | Multiply (float f)
return this * f
void | Multiply (float f, out Quaternion result)
result = this * f
Quaternion | Divide (float f)
return this / f
void | Divide (float f, out Quaternion result)
result = this / f
Quaternion Negate ()
return -this
void | Negate (out Quaternion result)
result = -this
Vector4 ToVector4 ()
return the quaternion as a Vector4
void | ToVector4 (out Vector4 result)
return the quaternion as a Vector4
Matrix4 ToMatrix4 ()
convert this quaternion to a Matrix4
void | ToMatrix4 (out Matrix4 result)
convert this quaternion to a Matrix4
void | ToAxisAngle (out Vector3 axis, out float angle)
extract the rotation axis and angle from this quaternion
bool | IsUnit (float epsilon)
test if this is a unit quaternion
bool | IsIdentity ()
test if this is an identity quaternion
bool | IsInfinity ()
test if any elements of this are Infinity
bool | IsNaN ()
test if any elements of this are NaN
bool | Equals (Quaternion q, float epsilon)
equality test with an epsilon
bool | Equals (Quaternion q)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of this quaternion
override int | GetHashCode ()
gets the hash code for this vector

Static Public メソッド

static Quaternion | FromMatrix4 (Matrix4 m)
return a quaternion representing a rotation matrix
static void | FromMatrix4 (ref Matrix4 m, out Quaternion result)
return a quaternion representing a rotation matrix
static Quaternion | RotationAxis (Vector3 axis, float angle)
return a quaternion representing a rotation about an arbitrary axis
static void | RotationAxis (ref Vector3 axis, float angle, out Quaternion result)
return a quaternion representing a rotation about an arbitrary axis
static Quaternion | RotationX (float angle)
return a quaternion representing a rotation about the x axis
static void | RotationX (float angle, out Quaternion result)
return a quaternion representing a rotation about the x axis
static Quaternion | RotationY (float angle)
return a quaternion representing a rotation about the y axis
static void | RotationY (float angle, out Quaternion result)
return a quaternion representing a rotation about the y axis
static Quaternion | RotationZ (float angle)
return a quaternion representing a rotation about the z axis
static void | RotationZ (float angle, out Quaternion result)
return a quaternion representing a rotation about the z axis
static Quaternion | RotationZyx (float x, float y, float z)
create a new quaternion from three euler angles
static void | RotationZyx (float x, float y, float z, out Quaternion result)
create a new quaternion from three euler angles
static Quaternion | RotationZyx (Vector3 angles)
create a new quaternion from three euler angles
static void | RotationZyx (ref Vector3 angles, out Quaternion result)
create a new quaternion from three euler angles
static Quaternion | RotationYxz (float x, float y, float z)
create a new quaternion from three euler angles
static void | RotationYxz (float x, float y, float z, out Quaternion result)
create a new quaternion from three euler angles
static Quaternion | RotationYxz (Vector3 angles)
create a new quaternion from three euler angles
static void | RotationYxz (ref Vector3 angles, out Quaternion result)
create a new quaternion from three euler angles
static Quaternion | RotationXzy (float x, float y, float z)
create a new quaternion from three euler angles
static void | RotationXzy (float x, float y, float z, out Quaternion result)
create a new quaternion from three euler angles
static Quaternion | RotationXzy (Vector3 angles)
create a new quaternion from three euler angles
static void | RotationXzy (ref Vector3 angles, out Quaternion result)
create a new quaternion from three euler angles
static Quaternion | RotationXyz (float x, float y, float z)
create a new quaternion from three euler angles
static void | RotationXyz (float x, float y, float z, out Quaternion result)
create a new quaternion from three euler angles
static Quaternion | RotationXyz (Vector3 angles)
create a new quaternion from three euler angles
static void | RotationXyz (ref Vector3 angles, out Quaternion result)
create a new quaternion from three euler angles
static Quaternion | RotationYzx (float x, float y, float z)
create a new quaternion from three euler angles
static void | RotationYzx (float x, float y, float z, out Quaternion result)
create a new quaternion from three euler angles
static Quaternion | RotationYzx (Vector3 angles)
create a new quaternion from three euler angles
static void | RotationYzx (ref Vector3 angles, out Quaternion result)
create a new quaternion from three euler angles
static Quaternion | RotationZxy (float x, float y, float z)
create a new quaternion from three euler angles
static void | RotationZxy (float x, float y, float z, out Quaternion result)
create a new quaternion from three euler angles
static Quaternion | RotationZxy (Vector3 angles)
create a new quaternion from three euler angles
static void | RotationZxy (ref Vector3 angles, out Quaternion result)
create a new quaternion from three euler angles
static float | Length (Quaternion q)
static function equivalent to Length()
static float | Length (ref Quaternion q)
static function equivalent to Length()
static float | LengthSquared (Quaternion q)
static function equivalent to LengthSquared()
static float | LengthSquared (ref Quaternion q)
static function equivalent to LengthSquared()
static float | Dot (Quaternion q1, Quaternion q2)
static function equivalent to Dot(Quaternion)
static float | Dot (ref Quaternion q1, ref Quaternion q2)
static function equivalent to Dot(ref Quaternion)
static Quaternion | Normalize (Quaternion q)
static function equivalent to Normalize()
static void | Normalize (ref Quaternion q, out Quaternion result)
static function equivalent to Normalize(out Quaternion)
static Quaternion | Conjugate (Quaternion q)
static function equivalent to Conjugate()
static void | Conjugate (ref Quaternion q, out Quaternion result)
static function equivalent to Conjugate(out Quaternion)
static Quaternion | Inverse (Quaternion q)
static function equivalent to Inverse()
static void | Inverse (ref Quaternion q, out Quaternion result)
static function equivalent to Inverse(out Quaternion)
static Quaternion | Slerp (Quaternion q1, Quaternion q2, float f)
static function equivalent to Slerp(Quaternion, float)
static void | Slerp (ref Quaternion q1, ref Quaternion q2, float f, out Quaternion result)
static function equivalent to Slerp(ref Quaternion, float, out Quaternion)
static Quaternion | Lerp (Quaternion q1, Quaternion q2, float f)
static function equivalent to Lerp(Quaternion, float)
static void | Lerp (ref Quaternion q1, ref Quaternion q2, float f, out Quaternion result)
static function equivalent to Lerp(ref Quaternion, float, out Quaternion)
static Quaternion | Log (Quaternion q)
static function equivalent to Log()
static void | Log (ref Quaternion q, out Quaternion result)
static function equivalent to Log(out Quaternion)
static Quaternion | Exp (Quaternion q)
static function equivalent to Exp()
static void | Exp (ref Quaternion q, out Quaternion result)
static function equivalent to Exp(out Quaternion)
static Quaternion | TurnTo (Quaternion q1, Quaternion q2, float angle)
static function equivalent to TurnTo(Quaternion, float)
static void | TurnTo (ref Quaternion q1, ref Quaternion q2, float angle, out Quaternion result)
static function equivalent to TurnTo(ref Quaternion, float, out Quaternion)
static float | Angle (Quaternion q1, Quaternion q2)
static function equivalent to Angle(Quaternion)
static float | Angle (ref Quaternion q1, ref Quaternion q2)
static function equivalent to Angle(ref Quaternion)
static Vector4 | Transform (Quaternion q, Vector4 v)
static function equivalent to Transform(Vector4)
static void | Transform (ref Quaternion q, ref Vector4 v, out Vector4 result)
static function equivalent to Transform(ref Vector4, out Vector4)
static Vector3 | Transform (Quaternion q, Vector3 v)
static function equivalent to Transform(Vector3)
static void | Transform (ref Quaternion q, ref Vector3 v, out Vector3 result)
static function equivalent to Transform(ref Vector3, out Vector3)
static Vector2 | Transform (Quaternion q, Vector2 v)
static function equivalent to Transform(Vector2)
static void | Transform (ref Quaternion q, ref Vector2 v, out Vector2 result)
static function equivalent to Transform(ref Vector2, out Vector2)
static Quaternion | Add (Quaternion q1, Quaternion q2)
static function equivalent to Add(Quaternion)
static void | Add (ref Quaternion q1, ref Quaternion q2, out Quaternion result)
static function equivalent to Add(ref Quaternion, out Quaternion)
static Quaternion | Subtract (Quaternion q1, Quaternion q2)
static function equivalent to Subtract(Quaternion)
static void | Subtract (ref Quaternion q1, ref Quaternion q2, out Quaternion result)
static function equivalent to Subtract(ref Quaternion, out Quaternion)
static Quaternion | Multiply (Quaternion q1, Quaternion q2)
static function equivalent to Multiply(Quaternion)
static void | Multiply (ref Quaternion q1, ref Quaternion q2, out Quaternion result)
static function equivalent to Multiply(ref Quaternion, out Quaternion)
static Quaternion | Multiply (Quaternion q, float f)
static function equivalent to Multiply(float)
static void | Multiply (ref Quaternion q, float f, out Quaternion result)
static function equivalent to Multiply(float, out Quaternion)
static Quaternion | Divide (Quaternion q, float f)
static function equivalent to Divide(float)
static void | Divide (ref Quaternion q, float f, out Quaternion result)
static function equivalent to Divide(float, out Quaternion)
static Quaternion | Negate (Quaternion q)
static function equivalent to Negate()
static void | Negate (ref Quaternion q, out Quaternion result)
static function equivalent to Negate(out Quaternion)
static bool | operator== (Quaternion q1, Quaternion q2)
equality operator
static bool | operator!= (Quaternion q1, Quaternion q2)
not equals operator
static Quaternion | operator+ (Quaternion q1, Quaternion q2)
addition operator
static Quaternion | operator- (Quaternion q1, Quaternion q2)
subtraction operator
static Quaternion | operator- (Quaternion q)
unary minus operator
static Quaternion | operator* (Quaternion q1, Quaternion q2)
multiplication operator
static Quaternion | operator* (Quaternion q, float f)
multiply a quaternion by a scalar float
static Quaternion | operator* (float f, Quaternion q)
multiply a quaternion by a scalar float
static Quaternion | operator/ (Quaternion q, float f)
division operator

Public 変数

float | X
X.
float | Y
Y.
float | Z
Z.
float | W
W.

Static Public 変数

static readonly Quaternion | Identity = new Quaternion(0.0f, 0.0f, 0.0f, 1.0f)
identity quaternion

説明

quaternion

コンストラクタとデストラクタ

Quaternion | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | float | w
 | ) |  |

constructor taking 4 floats

引数:
x | x value to init with
y | y value to init with
z | z value to init with
w | w value to init with
Quaternion | ( | Vector3 | xyz,
 |  | float | w
 | ) |  |

constructor taking a Vector3 and a scalar float

引数:
xyz | the x, y, z values to init with
w | the w value to init with
Quaternion ( Vector4 v )

constructor taking a Vector4

引数:
v the vector to init with

メソッド

Quaternion Add ( Quaternion q )

return this + q

引数:
q quaternion
戻り値:
this + q
void Add | ( | ref Quaternion | q,
 |  | out Quaternion | result
 | ) |  |

result = this + q

引数:
q | quaternion
result | this + q
static Quaternion Add | ( | Quaternion | q1,
 |  | Quaternion | q2
 | ) |  | [static]

static function equivalent to Add(Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
戻り値:
q1 + q2
static void Add | ( | ref Quaternion | q1,
 |  | ref Quaternion | q2,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Add(ref Quaternion, out Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
result | q1 + q2
float Angle ( ref Quaternion q )

get the angle between this and the input quaternion

引数:
q the quaternion to get the angle to
戻り値:
the angle between this and q
static float Angle | ( | Quaternion | q1,
 |  | Quaternion | q2
 | ) |  | [static]

static function equivalent to Angle(Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
戻り値:
the angle between q1 and q2
float Angle ( Quaternion q )

get the angle between this and the input quaternion

引数:
q the quaternion to get the angle to
戻り値:
the angle between this and v
static float Angle | ( | ref Quaternion | q1,
 |  | ref Quaternion | q2
 | ) |  | [static]

static function equivalent to Angle(ref Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
戻り値:
the angle between q1 and q2
Quaternion Conjugate ( )

quaternion conjugate

戻り値:
quaternion conjugate
void Conjugate ( out Quaternion result )

quaternion conjugate

引数:
result quaternion conjugate
static void Conjugate | ( | ref Quaternion | q,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Conjugate(out Quaternion)

引数:
q | quaternion
result | quaternion conjugate
static Quaternion Conjugate ( Quaternion q ) [static]

static function equivalent to Conjugate()

引数:
q quaternion
戻り値:
quaternion conjugate
Quaternion Divide ( float f )

return this / f

引数:
f scalar
戻り値:
this / f
static void Divide | ( | ref Quaternion | q,
 |  | float | f,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Divide(float, out Quaternion)

引数:
q | quaternion
f | scalar
result | q / f
void Divide | ( | float | f,
 |  | out Quaternion | result
 | ) |  |

result = this / f

引数:
f | scalar
result | this / f
static Quaternion Divide | ( | Quaternion | q,
 |  | float | f
 | ) |  | [static]

static function equivalent to Divide(float)

引数:
q | quaternion
f | scalar
戻り値:
q / f
float Dot ( ref Quaternion q )

dot product

引数:
q quaternion to take the dot product with
戻り値:
dot product of this and q
static float Dot | ( | Quaternion | q1,
 |  | Quaternion | q2
 | ) |  | [static]

static function equivalent to Dot(Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
戻り値:
dot product of q1 and q2
static float Dot | ( | ref Quaternion | q1,
 |  | ref Quaternion | q2
 | ) |  | [static]

static function equivalent to Dot(ref Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
戻り値:
dot product of q1 and q2
float Dot ( Quaternion q )

dot product

引数:
q quaternion to take the dot product with
戻り値:
dot product of this and q
bool Equals | ( | Quaternion | q,
 |  | float | epsilon
 | ) |  |

equality test with an epsilon

引数:
q | the quaternion to compare this to
epsilon | the epsilon to use in comparison
戻り値:
true if for every element n, abs(this[n] - q[n]) <= epsilon, false otherwise
bool Equals ( Quaternion q )

equality test

引数:
q the quaternion to compare this to
戻り値:
true if this == q, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
Quaternion Exp ( )

quaternion exp

戻り値:
quaternion exp
void Exp ( out Quaternion result )

quaternion exp

引数:
result quaternion exp
static Quaternion Exp ( Quaternion q ) [static]

static function equivalent to Exp()

引数:
q quaternion
戻り値:
quaternion exp
static void Exp | ( | ref Quaternion | q,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Exp(out Quaternion)

引数:
q | quaternion
result | quaternion exp
static Quaternion FromMatrix4 ( Matrix4 m ) [static]

return a quaternion representing a rotation matrix

引数:
m matrix to form the quaternion out of
戻り値:
a quaternion representing a rotation matrix
static void FromMatrix4 | ( | ref Matrix4 | m,
 |  | out Quaternion | result
 | ) |  | [static]

return a quaternion representing a rotation matrix

引数:
m | matrix to form the quaternion out of
result | a quaternion representing a rotation matrix
override int GetHashCode ( )

gets the hash code for this vector

戻り値:
integer hash code
Quaternion Inverse ( )

quaternion inverse

戻り値:
quaternion inverse
void Inverse ( out Quaternion result )

quaternion inverse

引数:
result quaternion inverse
static Quaternion Inverse ( Quaternion q ) [static]

static function equivalent to Inverse()

引数:
q quaternion
戻り値:
quaternion inverse
static void Inverse | ( | ref Quaternion | q,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Inverse(out Quaternion)

引数:
q | quaternion
result | quaternion inverse
bool IsIdentity ( )

test if this is an identity quaternion

戻り値:
true if this is an identity quaternion, false otherwise
bool IsInfinity ( )

test if any elements of this are Infinity

戻り値:
true if any elements of this are Infinity, false otherwise
bool IsNaN ( )

test if any elements of this are NaN

戻り値:
true if any elements of this are NaN, false otherwise
bool IsUnit ( float epsilon )

test if this is a unit quaternion

引数:
epsilon epsilon used in testing
戻り値:
true if this is a unit quaternion, false otherwise
static float Length ( Quaternion q ) [static]

static function equivalent to Length()

引数:
q quaternion
戻り値:
the length of quaternion
static float Length ( ref Quaternion q ) [static]

static function equivalent to Length()

引数:
q quaternion
戻り値:
the length of quaternion
float Length ( )

return the length of this quaternion

戻り値:
the length of this quaternion
float LengthSquared ( )

return the length squared of this quaternion

戻り値:
the length squared of this quaternion
static float LengthSquared ( Quaternion q ) [static]

static function equivalent to LengthSquared()

引数:
q quaternion
戻り値:
the length squared of quaternion
static float LengthSquared ( ref Quaternion q ) [static]

static function equivalent to LengthSquared()

引数:
q quaternion
戻り値:
the length squared of quaternion
Quaternion Lerp | ( | Quaternion | q,
 |  | float | f
 | ) |  |

lerp between 2 quaternions

引数:
q | second quaternion
f | lerp amount
戻り値:
lerp between this and q
static Quaternion Lerp | ( | Quaternion | q1,
 |  | Quaternion | q2,
 |  | float | f
 | ) |  | [static]

static function equivalent to Lerp(Quaternion, float)

引数:
q1 | quaternion 1
q2 | quaternion 2
f | lerp amount
戻り値:
lerp between q1 and q2
static void Lerp | ( | ref Quaternion | q1,
 |  | ref Quaternion | q2,
 |  | float | f,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Lerp(ref Quaternion, float, out Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
f | lerp amount
result | lerp between q1 and q2
void Lerp | ( | ref Quaternion | q,
 |  | float | f,
 |  | out Quaternion | result
 | ) |  |

lerp between 2 quaternions

引数:
q | second quaternion
f | lerp amount
result | lerp between this and q
void Log ( out Quaternion result )

quaternion log

引数:
result quaternion log
static Quaternion Log ( Quaternion q ) [static]

static function equivalent to Log()

引数:
q quaternion
戻り値:
quaternion log
static void Log | ( | ref Quaternion | q,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Log(out Quaternion)

引数:
q | quaternion
result | quaternion log
Quaternion Log ( )

quaternion log

戻り値:
quaternion log
Quaternion Multiply ( Quaternion q )

return this * q

引数:
q quaternion
戻り値:
this * q
void Multiply | ( | ref Quaternion | q,
 |  | out Quaternion | result
 | ) |  |

result = this * q

引数:
q | quaternion
result | this * q
Quaternion Multiply ( float f )

return this * f

引数:
f scalar
戻り値:
this * f
void Multiply | ( | float | f,
 |  | out Quaternion | result
 | ) |  |

result = this * f

引数:
f | scalar
result | this * f
static void Multiply | ( | ref Quaternion | q,
 |  | float | f,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Multiply(float, out Quaternion)

引数:
q | quaternion
f | scalar
result | q * f
static Quaternion Multiply | ( | Quaternion | q1,
 |  | Quaternion | q2
 | ) |  | [static]

static function equivalent to Multiply(Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
戻り値:
q1 * q2
static Quaternion Multiply | ( | Quaternion | q,
 |  | float | f
 | ) |  | [static]

static function equivalent to Multiply(float)

引数:
q | quaternion
f | scalar
戻り値:
q * f
static void Multiply | ( | ref Quaternion | q1,
 |  | ref Quaternion | q2,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Multiply(ref Quaternion, out Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
result | q1 * q2
static Quaternion Negate ( Quaternion q ) [static]

static function equivalent to Negate()

引数:
q quaternion
戻り値:
-q
static void Negate | ( | ref Quaternion | q,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Negate(out Quaternion)

引数:
q | quaternion
result | -q
Quaternion Negate ( )

return -this

戻り値:
-this
void Negate ( out Quaternion result )

result = -this

引数:
result -this
Quaternion Normalize ( )

return a unit quaternion

戻り値:
this as a unit quaternion
static Quaternion Normalize ( Quaternion q ) [static]

static function equivalent to Normalize()

引数:
q quaternion
戻り値:
q as a unit quaternion
static void Normalize | ( | ref Quaternion | q,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Normalize(out Quaternion)

引数:
q | quaternion
result | q as a unit quaternion
void Normalize ( out Quaternion result )

return a unit quaternion

引数:
result this as a unit quaternion
static bool operator!= | ( | Quaternion | q1,
 |  | Quaternion | q2
 | ) |  | [static]

not equals operator

引数:
q1 | first quaternion to compare
q2 | second quaternion to compare
戻り値:
true if q1 != q2, false otherwise
static Quaternion operator* | ( | Quaternion | q1,
 |  | Quaternion | q2
 | ) |  | [static]

multiplication operator

引数:
q1 | first value to multiply
q2 | second value to multiply
戻り値:
q1 * q2
static Quaternion operator* | ( | float | f,
 |  | Quaternion | q
 | ) |  | [static]

multiply a quaternion by a scalar float

引数:
f | float to multiply by
q | quaternion to multiply
戻り値:
f * q
static Quaternion operator* | ( | Quaternion | q,
 |  | float | f
 | ) |  | [static]

multiply a quaternion by a scalar float

引数:
q | quaternion to multiply
f | float to multiply by
戻り値:
q * f
static Quaternion operator+ | ( | Quaternion | q1,
 |  | Quaternion | q2
 | ) |  | [static]

addition operator

引数:
q1 | first quaternion to add
q2 | second quaternion to add
戻り値:
q1 + q2
static Quaternion operator- | ( | Quaternion | q1,
 |  | Quaternion | q2
 | ) |  | [static]

subtraction operator

引数:
q1 | value to subtract from
q2 | value to subtract
戻り値:
q1 - q2
static Quaternion operator- ( Quaternion q ) [static]

unary minus operator

引数:
q quaternion to negate
戻り値:
unary minus applied to each member of q
static Quaternion operator/ | ( | Quaternion | q,
 |  | float | f
 | ) |  | [static]

division operator

引数:
q | quaternion to divide
f | scalar float value to divide by
戻り値:
q / f
static bool operator== | ( | Quaternion | q1,
 |  | Quaternion | q2
 | ) |  | [static]

equality operator

引数:
q1 | first quaternion to compare
q2 | second quaternion to compare
戻り値:
true if q1 == q2, false otherwise
static Quaternion RotationAxis | ( | Vector3 | axis,
 |  | float | angle
 | ) |  | [static]

return a quaternion representing a rotation about an arbitrary axis

引数:
axis | the axis to rotate about
angle | the angle to rotate
戻り値:
a quaternion representing a rotation about an arbitrary axis
static void RotationAxis | ( | ref Vector3 | axis,
 |  | float | angle,
 |  | out Quaternion | result
 | ) |  | [static]

return a quaternion representing a rotation about an arbitrary axis

引数:
axis | the axis to rotate about
angle | the angle to rotate
result | a quaternion representing a rotation about an arbitrary axis
static Quaternion RotationX ( float angle ) [static]

return a quaternion representing a rotation about the x axis

引数:
angle the angle to rotate by
戻り値:
a quaternion representing a rotation about the x axis
static void RotationX | ( | float | angle,
 |  | out Quaternion | result
 | ) |  | [static]

return a quaternion representing a rotation about the x axis

引数:
angle | the angle to rotate by
result | a quaternion representing a rotation about the x axis
static Quaternion RotationXyz | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
x | x angle
y | y angle
z | z angle
戻り値:
a new quaternion from the three euler angles
static void RotationXyz | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Quaternion | result
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
x | x angle
y | y angle
z | z angle
result | a new quaternion from the three euler angles
static Quaternion RotationXyz ( Vector3 angles ) [static]

create a new quaternion from three euler angles

引数:
angles the x, y, z euler angles used to create the quaternion
戻り値:
a new quaternion from the three euler angles
static void RotationXyz | ( | ref Vector3 | angles,
 |  | out Quaternion | result
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
angles | the x, y, z euler angles used to create the quaternion
result | a new quaternion from the three euler angles
static Quaternion RotationXzy | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
x | x angle
y | y angle
z | z angle
戻り値:
a new quaternion from the three euler angles
static void RotationXzy | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Quaternion | result
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
x | x angle
y | y angle
z | z angle
result | a new quaternion from the three euler angles
static void RotationXzy | ( | ref Vector3 | angles,
 |  | out Quaternion | result
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
angles | the x, z, y euler angles used to create the quaternion
result | a new quaternion from the three euler angles
static Quaternion RotationXzy ( Vector3 angles ) [static]

create a new quaternion from three euler angles

引数:
angles the x, z, y euler angles used to create the quaternion
戻り値:
a new quaternion from the three euler angles
static void RotationY | ( | float | angle,
 |  | out Quaternion | result
 | ) |  | [static]

return a quaternion representing a rotation about the y axis

引数:
angle | the angle to rotate by
result | a quaternion representing a rotation about the y axis
static Quaternion RotationY ( float angle ) [static]

return a quaternion representing a rotation about the y axis

引数:
angle the angle to rotate by
戻り値:
a quaternion representing a rotation about the y axis
static void RotationYxz | ( | ref Vector3 | angles,
 |  | out Quaternion | result
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
angles | the y, x, z euler angles used to create the quaternion
result | a new quaternion from the three euler angles
static Quaternion RotationYxz ( Vector3 angles ) [static]

create a new quaternion from three euler angles

引数:
angles the y, x, z euler angles used to create the quaternion
戻り値:
a new quaternion from the three euler angles
static void RotationYxz | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Quaternion | result
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
x | x angle
y | y angle
z | z angle
result | a new quaternion from the three euler angles
static Quaternion RotationYxz | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
x | x angle
y | y angle
z | z angle
戻り値:
a new quaternion from the three euler angles
static Quaternion RotationYzx | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
x | x angle
y | y angle
z | z angle
戻り値:
a new quaternion from the three euler angles
static void RotationYzx | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Quaternion | result
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
x | x angle
y | y angle
z | z angle
result | a new quaternion from the three euler angles
static void RotationYzx | ( | ref Vector3 | angles,
 |  | out Quaternion | result
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
angles | the y, z, x euler angles used to create the quaternion
result | a new quaternion from the three euler angles
static Quaternion RotationYzx ( Vector3 angles ) [static]

create a new quaternion from three euler angles

引数:
angles the y, z, x euler angles used to create the quaternion
戻り値:
a new quaternion from the three euler angles
static void RotationZ | ( | float | angle,
 |  | out Quaternion | result
 | ) |  | [static]

return a quaternion representing a rotation about the z axis

引数:
angle | the angle to rotate by
result | a quaternion representing a rotation about the z axis
static Quaternion RotationZ ( float angle ) [static]

return a quaternion representing a rotation about the z axis

引数:
angle the angle to rotate by
戻り値:
a quaternion representing a rotation about the z axis
static Quaternion RotationZxy ( Vector3 angles ) [static]

create a new quaternion from three euler angles

引数:
angles the z, x, y euler angles used to create the quaternion
戻り値:
a new quaternion from the three euler angles
static Quaternion RotationZxy | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
x | x angle
y | y angle
z | z angle
戻り値:
a new quaternion from the three euler angles
static void RotationZxy | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Quaternion | result
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
x | x angle
y | y angle
z | z angle
result | a new quaternion from the three euler angles
static void RotationZxy | ( | ref Vector3 | angles,
 |  | out Quaternion | result
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
angles | the z, x, y euler angles used to create the quaternion
result | a new quaternion from the three euler angles
static Quaternion RotationZyx | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
x | x angle
y | y angle
z | z angle
戻り値:
a new quaternion from the three euler angles
static Quaternion RotationZyx ( Vector3 angles ) [static]

create a new quaternion from three euler angles

引数:
angles the z, y, x euler angles used to create the quaternion
戻り値:
a new quaternion from the three euler angles
static void RotationZyx | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | out Quaternion | result
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
x | x angle
y | y angle
z | z angle
result | a new quaternion from the three euler angles
static void RotationZyx | ( | ref Vector3 | angles,
 |  | out Quaternion | result
 | ) |  | [static]

create a new quaternion from three euler angles

引数:
angles | the z, y, x euler angles used to create the quaternion
result | a new quaternion from the three euler angles
static void Slerp | ( | ref Quaternion | q1,
 |  | ref Quaternion | q2,
 |  | float | f,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Slerp(ref Quaternion, float, out Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
f | slerp amount
result | slerp between q1 and q2
Quaternion Slerp | ( | Quaternion | q,
 |  | float | f
 | ) |  |

slerp between 2 quaternions

引数:
q | second quaternion
f | slerp amount
戻り値:
slerp between this and q
static Quaternion Slerp | ( | Quaternion | q1,
 |  | Quaternion | q2,
 |  | float | f
 | ) |  | [static]

static function equivalent to Slerp(Quaternion, float)

引数:
q1 | quaternion 1
q2 | quaternion 2
f | slerp amount
戻り値:
slerp between q1 and q2
void Slerp | ( | ref Quaternion | q,
 |  | float | f,
 |  | out Quaternion | result
 | ) |  |

slerp between 2 quaternions

引数:
q | second quaternion
f | slerp amount
result | slerp between this and q
Quaternion Subtract ( Quaternion q )

return this - q

引数:
q quaternion
戻り値:
this - q
static Quaternion Subtract | ( | Quaternion | q1,
 |  | Quaternion | q2
 | ) |  | [static]

static function equivalent to Subtract(Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
戻り値:
q1 - q2
void Subtract | ( | ref Quaternion | q,
 |  | out Quaternion | result
 | ) |  |

result = this - q

引数:
q | quaternion
result | this - q
static void Subtract | ( | ref Quaternion | q1,
 |  | ref Quaternion | q2,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to Subtract(ref Quaternion, out Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
result | q1 - q2
void ToAxisAngle | ( | out Vector3 | axis,
 |  | out float | angle
 | ) |  |

extract the rotation axis and angle from this quaternion

引数:
axis | the rotation axis
angle | the rotation angle
void ToMatrix4 ( out Matrix4 result )

convert this quaternion to a Matrix4

引数:
result Matrix4 representation of this quaternion
Matrix4 ToMatrix4 ( )

convert this quaternion to a Matrix4

戻り値:
Matrix4 representation of this quaternion
override string ToString ( )

get the string representation of this quaternion

戻り値:
the string representation of this quaternion
void ToVector4 ( out Vector4 result )

return the quaternion as a Vector4

引数:
result the quaternion as a Vector4
Vector4 ToVector4 ( )

return the quaternion as a Vector4

戻り値:
the quaternion as a Vector4
static void Transform | ( | ref Quaternion | q,
 |  | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Transform(ref Vector4, out Vector4)

引数:
q | quaternion
v | vector
result | q * v
static void Transform | ( | ref Quaternion | q,
 |  | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Transform(ref Vector3, out Vector3)

引数:
q | quaternion
v | vector
result | q * v
Vector3 Transform ( Vector3 v )

return this * v

引数:
v vector
戻り値:
this * v

>

Vector2 Transform ( Vector2 v )

return this * v

引数:
v vector
戻り値:
this * v

>

void Transform | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  |

result = this * v

引数:
v | vector
result | this * v
static Vector3 Transform | ( | Quaternion | q,
 |  | Vector3 | v
 | ) |  | [static]

static function equivalent to Transform(Vector3)

引数:
q | quaternion
v | vector
戻り値:
q * v
void Transform | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  |

result = this * v

引数:
v | vector
result | this * v
void Transform | ( | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  |

result = this * v

引数:
v | vector
result | this * v
static void Transform | ( | ref Quaternion | q,
 |  | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Transform(ref Vector2, out Vector2)

引数:
q | quaternion
v | vector
result | q * v
static Vector2 Transform | ( | Quaternion | q,
 |  | Vector2 | v
 | ) |  | [static]

static function equivalent to Transform(Vector2)

引数:
q | quaternion
v | vector
戻り値:
q * v
Vector4 Transform ( Vector4 v )

return this * v

引数:
v vector
戻り値:
this * v

>

static Vector4 Transform | ( | Quaternion | q,
 |  | Vector4 | v
 | ) |  | [static]

static function equivalent to Transform(Vector4)

引数:
q | quaternion
v | vector
戻り値:
q * v
static Quaternion TurnTo | ( | Quaternion | q1,
 |  | Quaternion | q2,
 |  | float | angle
 | ) |  | [static]

static function equivalent to TurnTo(Quaternion, float)

引数:
q1 | quaternion 1
q2 | quaternion 2
angle | step angle
戻り値:
a new quaternion turned to target quaternion by specified angle
Quaternion TurnTo | ( | Quaternion | q,
 |  | float | angle
 | ) |  |

turn to target quaternion by specified angle

引数:
q | target quaternion
angle | step angle
戻り値:
a new quaternion turned to target quaternion by specified angle
static void TurnTo | ( | ref Quaternion | q1,
 |  | ref Quaternion | q2,
 |  | float | angle,
 |  | out Quaternion | result
 | ) |  | [static]

static function equivalent to TurnTo(ref Quaternion, float, out Quaternion)

引数:
q1 | quaternion 1
q2 | quaternion 2
angle | step angle
result | a new quaternion turned to target quaternion by specified angle
void TurnTo | ( | ref Quaternion | q,
 |  | float | angle,
 |  | out Quaternion | result
 | ) |  |

turn to target quaternion by specified angle

引数:
q | target quaternion
angle | step angle
result | a new quaternion turned to target quaternion by specified angle

変数

readonly Quaternion Identity = new Quaternion(0.0f, 0.0f, 0.0f, 1.0f) [static]

identity quaternion

float W

W.

float X

X.

float Y

Y.

float Z

Z.


構造体 Rectangle

rectangle [詳細]

すべてのメンバ一覧

Public メソッド

Rectangle (float x, float y, float width, float height)
constructor taking 4 floats
Rectangle (Vector2 position, Vector2 size)
constructor taking a two Vector2s
Rectangle (Vector4 v)
constructor taking a Vector4
Rectangle Inverse ()
rectangle inverse
void | Inverse (out Rectangle result)
rectangle inverse
Rectangle | Lerp (Rectangle r, float f)
lerp between 2 rectangles
void | Lerp (ref Rectangle r, float f, out Rectangle result)
lerp between 2 rectangles
Vector2 | TransformPoint (Vector2 v)
return this * v (X,Y,0,1)
void | TransformPoint (ref Vector2 v, out Vector2 result)
result = this * v (X,Y,0,1)
Vector2 | TransformVector (Vector2 v)
return this * v (X,Y,0,0)
void | TransformVector (ref Vector2 v, out Vector2 result)
result = this * v (X,Y,0,0)
Rectangle | Add (Rectangle r)
return this + r
void | Add (ref Rectangle r, out Rectangle result)
result = this + r
Rectangle | Subtract (Rectangle r)
return this - r
void | Subtract (ref Rectangle r, out Rectangle result)
result = this - r
Rectangle | Multiply (Rectangle r)
return this * r
void | Multiply (ref Rectangle r, out Rectangle result)
result = this * r
Rectangle | Multiply (float f)
return this * f
void | Multiply (float f, out Rectangle result)
result = this * f
Rectangle | Divide (float f)
return this / f
void | Divide (float f, out Rectangle result)
result = this / f
Rectangle Negate ()
return -this
void | Negate (out Rectangle result)
result = -this
Vector4 ToVector4 ()
return the rectangle as a Vector4
void | ToVector4 (out Vector4 result)
return the rectangle as a Vector4
Matrix4 ToMatrix4 ()
convert this rectangle to a Matrix4
void | ToMatrix4 (out Matrix4 result)
convert this rectangle to a Matrix4
bool | IsIdentity ()
test if this is an identity rectangle
bool | IsInfinity ()
test if any elements of this are Infinity
bool | IsNaN ()
test if any elements of this are NaN
bool | Equals (Rectangle r, float epsilon)
equality test with an epsilon
bool | Equals (Rectangle r)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of this rectangle
override int | GetHashCode ()
gets the hash code for this vector

Static Public メソッド

static Rectangle | FromMatrix4 (Matrix4 m)
return a rectangle representing a 2D translation/scale matrix
static void | FromMatrix4 (ref Matrix4 m, out Rectangle result)
return a rectangle representing a 2D translation/scale matrix
static Rectangle | Inverse (Rectangle r)
static function equivalent to Inverse()
static void | Inverse (ref Rectangle r, out Rectangle result)
static function equivalent to Inverse(out Rectangle)
static Rectangle | Lerp (Rectangle r1, Rectangle r2, float f)
static function equivalent to Lerp(Rectangle, float)
static void | Lerp (ref Rectangle r1, ref Rectangle r2, float f, out Rectangle result)
static function equivalent to Lerp(ref Rectangle, float, out Rectangle)
static Vector2 | TransformPoint (Rectangle r, Vector2 v)
static function equivalent to TransformPoint(Vector2)
static void | TransformPoint (ref Rectangle r, ref Vector2 v, out Vector2 result)
static function equivalent to TransformPoint(ref Vector2, out Vector2)
static Vector2 | TransformVector (Rectangle r, Vector2 v)
static function equivalent to TransformVector(Vector2)
static void | TransformVector (ref Rectangle r, ref Vector2 v, out Vector2 result)
static function equivalent to TransformVector(ref Vector2, out Vector2)
static Rectangle | Add (Rectangle r1, Rectangle r2)
static function equivalent to Add(Rectangle)
static void | Add (ref Rectangle r1, ref Rectangle r2, out Rectangle result)
static function equivalent to Add(ref Rectangle, out Rectangle)
static Rectangle | Subtract (Rectangle r1, Rectangle r2)
static function equivalent to Subtract(Rectangle)
static void | Subtract (ref Rectangle r1, ref Rectangle r2, out Rectangle result)
static function equivalent to Subtract(ref Rectangle, out Rectangle)
static Rectangle | Multiply (Rectangle r1, Rectangle r2)
static function equivalent to Multiply(Rectangle)
static void | Multiply (ref Rectangle r1, ref Rectangle r2, out Rectangle result)
static function equivalent to Multiply(ref Rectangle, out Rectangle)
static Rectangle | Multiply (Rectangle r, float f)
static function equivalent to Multiply(float)
static void | Multiply (ref Rectangle r, float f, out Rectangle result)
static function equivalent to Multiply(float, out Rectangle)
static Rectangle | Divide (Rectangle r, float f)
static function equivalent to Divide(float)
static void | Divide (ref Rectangle r, float f, out Rectangle result)
static function equivalent to Divide(float, out Rectangle)
static Rectangle | Negate (Rectangle r)
static function equivalent to Negate()
static void | Negate (ref Rectangle r, out Rectangle result)
static function equivalent to Negate(out Rectangle)
static bool | operator== (Rectangle r1, Rectangle r2)
equality operator
static bool | operator!= (Rectangle r1, Rectangle r2)
not equals operator
static Rectangle | operator+ (Rectangle r1, Rectangle r2)
addition operator
static Rectangle | operator- (Rectangle r1, Rectangle r2)
subtraction operator
static Rectangle | operator- (Rectangle r)
unary minus operator
static Rectangle | operator* (Rectangle r1, Rectangle r2)
multiplication operator
static Rectangle | operator* (Rectangle r, float f)
multiply a rectangle by a scalar float
static Rectangle | operator* (float f, Rectangle r)
multiply a rectangle by a scalar float
static Rectangle | operator/ (Rectangle r, float f)
division operator

Public 変数

float | X
X.
float | Y
Y.
float | Width
Width.
float | Height
Height.

Static Public 変数

static readonly Rectangle | Zero = new Rectangle(0.0f, 0.0f, 0.0f, 0.0f)
a rectangle of all zeroes
static readonly Rectangle | Identity = new Rectangle(0.0f, 0.0f, 1.0f, 1.0f)
identity rectangle

プロパティ

Vector2 | Position [get, set]
the base position of the rectangle
Vector2 | Size [get, set]
the size dimensions of the rectangle

説明

rectangle

コンストラクタとデストラクタ

Rectangle | ( | float | x,
 |  | float | y,
 |  | float | width,
 |  | float | height
 | ) |  |

constructor taking 4 floats

引数:
x | x value to init with
y | y value to init with
width | width value to init with
height | height value to init with
Rectangle | ( | Vector2 | position,
 |  | Vector2 | size
 | ) |  |

constructor taking a two Vector2s

引数:
position | the x, y values to init with
size | the width, height value to init with
Rectangle ( Vector4 v )

constructor taking a Vector4

引数:
v the vector to init with

メソッド

Rectangle Add ( Rectangle r )

return this + r

引数:
r rectangle
戻り値:
this + r
void Add | ( | ref Rectangle | r,
 |  | out Rectangle | result
 | ) |  |

result = this + r

引数:
r | rectangle
result | this + r
static Rectangle Add | ( | Rectangle | r1,
 |  | Rectangle | r2
 | ) |  | [static]

static function equivalent to Add(Rectangle)

引数:
r1 | rectangle 1
r2 | rectangle 2
戻り値:
r1 + r2
static void Add | ( | ref Rectangle | r1,
 |  | ref Rectangle | r2,
 |  | out Rectangle | result
 | ) |  | [static]

static function equivalent to Add(ref Rectangle, out Rectangle)

引数:
r1 | rectangle 1
r2 | rectangle 2
result | r1 + r2
Rectangle Divide ( float f )

return this / f

引数:
f scalar
戻り値:
this / f
void Divide | ( | float | f,
 |  | out Rectangle | result
 | ) |  |

result = this / f

引数:
f | scalar
result | this / f
static Rectangle Divide | ( | Rectangle | r,
 |  | float | f
 | ) |  | [static]

static function equivalent to Divide(float)

引数:
r | rectangle
f | scalar
戻り値:
r / f
static void Divide | ( | ref Rectangle | r,
 |  | float | f,
 |  | out Rectangle | result
 | ) |  | [static]

static function equivalent to Divide(float, out Rectangle)

引数:
r | rectangle
f | scalar
result | r / f
bool Equals | ( | Rectangle | r,
 |  | float | epsilon
 | ) |  |

equality test with an epsilon

引数:
r | the rectangle to compare this to
epsilon | the epsilon to use in comparison
戻り値:
true if for every element n, abs(this[n] - r[n]) <= epsilon, false otherwise
bool Equals ( Rectangle r )

equality test

引数:
r the rectangle to compare this to
戻り値:
true if this == r, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
static Rectangle FromMatrix4 ( Matrix4 m ) [static]

return a rectangle representing a 2D translation/scale matrix

引数:
m matrix to form the rectangle out of
戻り値:
a rectangle representing a rectangle matrix
static void FromMatrix4 | ( | ref Matrix4 | m,
 |  | out Rectangle | result
 | ) |  | [static]

return a rectangle representing a 2D translation/scale matrix

引数:
m | matrix to form the rectangle out of
result | a rectangle representing a rotation matrix
override int GetHashCode ( )

gets the hash code for this vector

戻り値:
integer hash code
void Inverse ( out Rectangle result )

rectangle inverse

引数:
result rectangle inverse
static Rectangle Inverse ( Rectangle r ) [static]

static function equivalent to Inverse()

引数:
r rectangle
戻り値:
rectangle inverse
static void Inverse | ( | ref Rectangle | r,
 |  | out Rectangle | result
 | ) |  | [static]

static function equivalent to Inverse(out Rectangle)

引数:
r | rectangle
result | rectangle inverse
Rectangle Inverse ( )

rectangle inverse

戻り値:
rectangle inverse
bool IsIdentity ( )

test if this is an identity rectangle

戻り値:
true if this is an identity rectangle, false otherwise
bool IsInfinity ( )

test if any elements of this are Infinity

戻り値:
true if any elements of this are Infinity, false otherwise
bool IsNaN ( )

test if any elements of this are NaN

戻り値:
true if any elements of this are NaN, false otherwise
void Lerp | ( | ref Rectangle | r,
 |  | float | f,
 |  | out Rectangle | result
 | ) |  |

lerp between 2 rectangles

引数:
r | second rectangle
f | lerp amount
result | lerp between this and r
static Rectangle Lerp | ( | Rectangle | r1,
 |  | Rectangle | r2,
 |  | float | f
 | ) |  | [static]

static function equivalent to Lerp(Rectangle, float)

引数:
r1 | rectangle 1
r2 | rectangle 2
f | lerp amount
戻り値:
lerp between r1 and r2
static void Lerp | ( | ref Rectangle | r1,
 |  | ref Rectangle | r2,
 |  | float | f,
 |  | out Rectangle | result
 | ) |  | [static]

static function equivalent to Lerp(ref Rectangle, float, out Rectangle)

引数:
r1 | rectangle 1
r2 | rectangle 2
f | lerp amount
result | lerp between r1 and r2
Rectangle Lerp | ( | Rectangle | r,
 |  | float | f
 | ) |  |

lerp between 2 rectangles

引数:
r | second rectangle
f | lerp amount
戻り値:
lerp between this and r
static void Multiply | ( | ref Rectangle | r,
 |  | float | f,
 |  | out Rectangle | result
 | ) |  | [static]

static function equivalent to Multiply(float, out Rectangle)

引数:
r | rectangle
f | scalar
result | r * f
void Multiply | ( | float | f,
 |  | out Rectangle | result
 | ) |  |

result = this * f

引数:
f | scalar
result | this * f
static Rectangle Multiply | ( | Rectangle | r1,
 |  | Rectangle | r2
 | ) |  | [static]

static function equivalent to Multiply(Rectangle)

引数:
r1 | rectangle 1
r2 | rectangle 2
戻り値:
r1 * r2
static void Multiply | ( | ref Rectangle | r1,
 |  | ref Rectangle | r2,
 |  | out Rectangle | result
 | ) |  | [static]

static function equivalent to Multiply(ref Rectangle, out Rectangle)

引数:
r1 | rectangle 1
r2 | rectangle 2
result | r1 * r2
static Rectangle Multiply | ( | Rectangle | r,
 |  | float | f
 | ) |  | [static]

static function equivalent to Multiply(float)

引数:
r | rectangle
f | scalar
戻り値:
r * f
Rectangle Multiply ( Rectangle r )

return this * r

引数:
r rectangle
戻り値:
this * r
void Multiply | ( | ref Rectangle | r,
 |  | out Rectangle | result
 | ) |  |

result = this * r

引数:
r | rectangle
result | this * r
Rectangle Multiply ( float f )

return this * f

引数:
f scalar
戻り値:
this * f
Rectangle Negate ( )

return -this

戻り値:
-this
void Negate ( out Rectangle result )

result = -this

引数:
result -this
static Rectangle Negate ( Rectangle r ) [static]

static function equivalent to Negate()

引数:
r rectangle
戻り値:
-r
static void Negate | ( | ref Rectangle | r,
 |  | out Rectangle | result
 | ) |  | [static]

static function equivalent to Negate(out Rectangle)

引数:
r | rectangle
result | -r
static bool operator!= | ( | Rectangle | r1,
 |  | Rectangle | r2
 | ) |  | [static]

not equals operator

引数:
r1 | first rectangle to compare
r2 | second rectangle to compare
戻り値:
true if r1 != r2, false otherwise
static Rectangle operator* | ( | Rectangle | r1,
 |  | Rectangle | r2
 | ) |  | [static]

multiplication operator

引数:
r1 | first value to multiply
r2 | second value to multiply
戻り値:
r1 * r2
static Rectangle operator* | ( | Rectangle | r,
 |  | float | f
 | ) |  | [static]

multiply a rectangle by a scalar float

引数:
r | rectangle to multiply
f | float to multiply by
戻り値:
r * f
static Rectangle operator* | ( | float | f,
 |  | Rectangle | r
 | ) |  | [static]

multiply a rectangle by a scalar float

引数:
f | float to multiply by
r | rectangle to multiply
戻り値:
f * r
static Rectangle operator+ | ( | Rectangle | r1,
 |  | Rectangle | r2
 | ) |  | [static]

addition operator

引数:
r1 | first rectangle to add
r2 | second rectangle to add
戻り値:
r1 + r2
static Rectangle operator- | ( | Rectangle | r1,
 |  | Rectangle | r2
 | ) |  | [static]

subtraction operator

引数:
r1 | value to subtract from
r2 | value to subtract
戻り値:
r1 - r2
static Rectangle operator- ( Rectangle r ) [static]

unary minus operator

引数:
r rectangle to negate
戻り値:
unary minus applied to each member of r
static Rectangle operator/ | ( | Rectangle | r,
 |  | float | f
 | ) |  | [static]

division operator

引数:
r | rectangle to divide
f | scalar float value to divide by
戻り値:
r / f
static bool operator== | ( | Rectangle | r1,
 |  | Rectangle | r2
 | ) |  | [static]

equality operator

引数:
r1 | first rectangle to compare
r2 | second rectangle to compare
戻り値:
true if r1 == r2, false otherwise
static void Subtract | ( | ref Rectangle | r1,
 |  | ref Rectangle | r2,
 |  | out Rectangle | result
 | ) |  | [static]

static function equivalent to Subtract(ref Rectangle, out Rectangle)

引数:
r1 | rectangle 1
r2 | rectangle 2
result | r1 - r2
void Subtract | ( | ref Rectangle | r,
 |  | out Rectangle | result
 | ) |  |

result = this - r

引数:
r | rectangle
result | this - r
Rectangle Subtract ( Rectangle r )

return this - r

引数:
r rectangle
戻り値:
this - r
static Rectangle Subtract | ( | Rectangle | r1,
 |  | Rectangle | r2
 | ) |  | [static]

static function equivalent to Subtract(Rectangle)

引数:
r1 | rectangle 1
r2 | rectangle 2
戻り値:
r1 - r2
Matrix4 ToMatrix4 ( )

convert this rectangle to a Matrix4

戻り値:
Matrix4 representation of this rectangle
void ToMatrix4 ( out Matrix4 result )

convert this rectangle to a Matrix4

引数:
result Matrix4 representation of this rectangle
override string ToString ( )

get the string representation of this rectangle

戻り値:
the string representation of this rectangle
Vector4 ToVector4 ( )

return the rectangle as a Vector4

戻り値:
the rectangle as a Vector4
void ToVector4 ( out Vector4 result )

return the rectangle as a Vector4

引数:
result the rectangle as a Vector4
void TransformPoint | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  |

result = this * v (X,Y,0,1)

引数:
v | vector
result | this * v (X,Y,0,1)
Vector2 TransformPoint ( Vector2 v )

return this * v (X,Y,0,1)

引数:
v vector
戻り値:
this * v (X,Y,0,1)
static void TransformPoint | ( | ref Rectangle | r,
 |  | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to TransformPoint(ref Vector2, out Vector2)

引数:
r | rectangle
v | vector
result | r * v (X,Y,0,1)
static Vector2 TransformPoint | ( | Rectangle | r,
 |  | Vector2 | v
 | ) |  | [static]

static function equivalent to TransformPoint(Vector2)

引数:
r | rectangle
v | vector
戻り値:
r * v (X,Y,0,1)
static void TransformVector | ( | ref Rectangle | r,
 |  | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to TransformVector(ref Vector2, out Vector2)

引数:
r | rectangle
v | vector
result | r * v (X,Y,0,0)
Vector2 TransformVector ( Vector2 v )

return this * v (X,Y,0,0)

引数:
v vector
戻り値:
this * v (X,Y,0,0)
static Vector2 TransformVector | ( | Rectangle | r,
 |  | Vector2 | v
 | ) |  | [static]

static function equivalent to TransformVector(Vector2)

引数:
r | rectangle
v | vector
戻り値:
r * v (X,Y,0,0)
void TransformVector | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  |

result = this * v (X,Y,0,0)

引数:
v | vector
result | this * v (X,Y,0,0)

変数

float Height

Height.

readonly Rectangle Identity = new Rectangle(0.0f, 0.0f, 1.0f, 1.0f) [static]

identity rectangle

float Width

Width.

float X

X.

float Y

Y.

readonly Rectangle Zero = new Rectangle(0.0f, 0.0f, 0.0f, 0.0f) [static]

a rectangle of all zeroes

プロパティ

Vector2 Position [get, set]

the base position of the rectangle

Vector2 Size [get, set]

the size dimensions of the rectangle


構造体 Rgb565

16 bit color struct with 5 bits for R, 6 bits for G, and 5 bits for G [詳細]

すべてのメンバ一覧

Public メソッド

Rgb565 (ushort bits)
constructor taking ushort data
Rgb565 (Rgba rgba)
constructor taking a 32 bit color
Rgba ToRgba ()
return the color as a 32 bit color
bool | Equals (Rgb565 c)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of color value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Rgb565 c1, Rgb565 c2)
equality operator
static bool | operator!= (Rgb565 c1, Rgb565 c2)
not equals operator

Public 変数

ushort | Bits
color data

説明

16 bit color struct with 5 bits for R, 6 bits for G, and 5 bits for G

コンストラクタとデストラクタ

Rgb565 ( ushort bits )

constructor taking ushort data

引数:
bits bits to initialize with
Rgb565 ( Rgba rgba )

constructor taking a 32 bit color

引数:
rgba the color to init with

メソッド

bool Equals ( Rgb565 c )

equality test

引数:
c the color to compare this to
戻り値:
true if this == rgba, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Rgb565 | c1,
 |  | Rgb565 | c2
 | ) |  | [static]

not equals operator

引数:
c1 | color 1
c2 | color 2
戻り値:
true if c 1 != c 2, false otherwise
static bool operator== | ( | Rgb565 | c1,
 |  | Rgb565 | c2
 | ) |  | [static]

equality operator

引数:
c1 | color 1
c2 | color 2
戻り値:
true if color 1 == color 2, false otherwise
Rgba ToRgba ( )

return the color as a 32 bit color

戻り値:
the color as a 32 bit color
override string ToString ( )

get the string representation of color value

戻り値:
the string representation of color value

変数

ushort Bits

color data


構造体 Rgba

32 bit color struct, with 8 bits per channel [詳細]

すべてのメンバ一覧

Public メソッド

Rgba (int r, int g, int b, int a)
constructor taking 4 integers
Rgba (Vector4 v)
constructor taking a Vector4
Vector4 ToVector4 ()
return the color as a Vector4
bool | Equals (Rgba c)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of color value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Rgba c1, Rgba c2)
equality operator
static bool | operator!= (Rgba c1, Rgba c2)
not equals operator

Public 変数

byte | R
red
byte | G
green
byte | B
blue
byte | A
alpha

説明

32 bit color struct, with 8 bits per channel

コンストラクタとデストラクタ

Rgba | ( | int | r,
 |  | int | g,
 |  | int | b,
 |  | int | a
 | ) |  |

constructor taking 4 integers

引数:
r | red
g | green
b | blue
a | alpha
Rgba ( Vector4 v )

constructor taking a Vector4

引数:
v the vector to init with

メソッド

bool Equals ( Rgba c )

equality test

引数:
c the color to compare this to
戻り値:
true if this == c, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Rgba | c1,
 |  | Rgba | c2
 | ) |  | [static]

not equals operator

引数:
c1 | color 1
c2 | color 2
戻り値:
true if c 1 != c 2, false otherwise
static bool operator== | ( | Rgba | c1,
 |  | Rgba | c2
 | ) |  | [static]

equality operator

引数:
c1 | color 1
c2 | color 2
戻り値:
true if color 1 == color 2, false otherwise
override string ToString ( )

get the string representation of color value

戻り値:
the string representation of color value
Vector4 ToVector4 ( )

return the color as a Vector4

戻り値:
the color as a Vector4

変数

byte A

alpha

byte B

blue

byte G

green

byte R

red


構造体 Rgba4444

16 bit color struct with 4 bits per channel [詳細]

すべてのメンバ一覧

Public メソッド

Rgba4444 (ushort bits)
constructor taking ushort data
Rgba4444 (Rgba rgba)
constructor taking a 32 bit color
Rgba ToRgba ()
return the color as a 32 bit color
bool | Equals (Rgba4444 c)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of color value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Rgba4444 c1, Rgba4444 c2)
equality operator
static bool | operator!= (Rgba4444 c1, Rgba4444 c2)
not equals operator

Public 変数

ushort | Bits
color data

説明

16 bit color struct with 4 bits per channel

コンストラクタとデストラクタ

Rgba4444 ( ushort bits )

constructor taking ushort data

引数:
bits bits to initialize with
Rgba4444 ( Rgba rgba )

constructor taking a 32 bit color

引数:
rgba the color to init with

メソッド

bool Equals ( Rgba4444 c )

equality test

引数:
c the color to compare this to
戻り値:
true if this == rgba, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Rgba4444 | c1,
 |  | Rgba4444 | c2
 | ) |  | [static]

not equals operator

引数:
c1 | color 1
c2 | color 2
戻り値:
true if c 1 != c 2, false otherwise
static bool operator== | ( | Rgba4444 | c1,
 |  | Rgba4444 | c2
 | ) |  | [static]

equality operator

引数:
c1 | color 1
c2 | color 2
戻り値:
true if color 1 == color 2, false otherwise
Rgba ToRgba ( )

return the color as a 32 bit color

戻り値:
the color as a 32 bit color
override string ToString ( )

get the string representation of color value

戻り値:
the string representation of color value

変数

ushort Bits

color data


構造体 Rgba5551

16 bit color struct with 5 bits per channel for R, G, and B. and 1 bit for A [詳細]

すべてのメンバ一覧

Public メソッド

Rgba5551 (ushort bits)
constructor taking ushort data
Rgba5551 (Rgba rgba)
constructor taking a 32 bit color
Rgba ToRgba ()
return the color as a 32 bit color
bool | Equals (Rgba5551 c)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of color value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Rgba5551 c1, Rgba5551 c2)
equality operator
static bool | operator!= (Rgba5551 c1, Rgba5551 c2)
not equals operator

Public 変数

ushort | Bits
color data

説明

16 bit color struct with 5 bits per channel for R, G, and B. and 1 bit for A

コンストラクタとデストラクタ

Rgba5551 ( ushort bits )

constructor taking ushort data

引数:
bits bits to initialize with
Rgba5551 ( Rgba rgba )

constructor taking a 32 bit color

引数:
rgba the color to init with

メソッド

bool Equals ( Rgba5551 c )

equality test

引数:
c the color to compare this to
戻り値:
true if this == rgba, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Rgba5551 | c1,
 |  | Rgba5551 | c2
 | ) |  | [static]

not equals operator

引数:
c1 | color 1
c2 | color 2
戻り値:
true if c 1 != c 2, false otherwise
static bool operator== | ( | Rgba5551 | c1,
 |  | Rgba5551 | c2
 | ) |  | [static]

equality operator

引数:
c1 | color 1
c2 | color 2
戻り値:
true if color 1 == color 2, false otherwise
Rgba ToRgba ( )

return the color as a 32 bit color

戻り値:
the color as a 32 bit color
override string ToString ( )

get the string representation of color value

戻り値:
the string representation of color value

変数

ushort Bits

color data


構造体 Short2

vector of 2 signed shorts [詳細]

すべてのメンバ一覧

Public メソッド

Short2 (int x, int y)
constructor taking 2 scalar integers
Short2 (Vector2 v)
constructor taking a Vector2
Vector2 ToVector2 ()
return the vector as a Vector2
bool | Equals (Short2 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Short2 v1, Short2 v2)
equality operator
static bool | operator!= (Short2 v1, Short2 v2)
not equals operator

Public 変数

short | X
X.
short | Y
Y.

説明

vector of 2 signed shorts

コンストラクタとデストラクタ

Short2 | ( | int | x,
 |  | int | y
 | ) |  |

constructor taking 2 scalar integers

引数:
x | x value to init with
y | y value to init with
Short2 ( Vector2 v )

constructor taking a Vector2

引数:
v the vector to init with

メソッド

bool Equals ( Short2 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Short2 | v1,
 |  | Short2 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Short2 | v1,
 |  | Short2 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector2 ToVector2 ( )

return the vector as a Vector2

戻り値:
the vector as a Vector2

変数

short X

X.

short Y

Y.


構造体 Short2N

vector of 2 normalized signed shorts [詳細]

すべてのメンバ一覧

Public メソッド

Short2N (float x, float y)
constructor taking 2 scalar floats
Short2N (Vector2 v)
constructor taking a Vector2
Vector2 ToVector2 ()
return the vector as a Vector2
bool | Equals (Short2N v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Short2N v1, Short2N v2)
equality operator
static bool | operator!= (Short2N v1, Short2N v2)
not equals operator

Public 変数

ShortN X
X.
ShortN Y
Y.

説明

vector of 2 normalized signed shorts

コンストラクタとデストラクタ

Short2N | ( | float | x,
 |  | float | y
 | ) |  |

constructor taking 2 scalar floats

引数:
x | x value to init with
y | y value to init with
Short2N ( Vector2 v )

constructor taking a Vector2

引数:
v the vector to init with

メソッド

bool Equals ( Short2N v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Short2N | v1,
 |  | Short2N | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Short2N | v1,
 |  | Short2N | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector2 ToVector2 ( )

return the vector as a Vector2

戻り値:
the vector as a Vector2

変数

ShortN X

X.

ShortN Y

Y.


構造体 Short3

vector of 3 signed shorts [詳細]

すべてのメンバ一覧

Public メソッド

Short3 (int x, int y, int z)
constructor taking 3 scalar integers
Short3 (Vector3 v)
constructor taking a Vector3
Vector3 ToVector3 ()
return the vector as a Vector3
bool | Equals (Short3 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Short3 v1, Short3 v2)
equality operator
static bool | operator!= (Short3 v1, Short3 v2)
not equals operator

Public 変数

short | X
X.
short | Y
Y.
short | Z
Z.

説明

vector of 3 signed shorts

コンストラクタとデストラクタ

Short3 | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |

constructor taking 3 scalar integers

引数:
x | x value to init with
y | y value to init with
z | z value to init with
Short3 ( Vector3 v )

constructor taking a Vector3

引数:
v the vector to init with

メソッド

bool Equals ( Short3 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Short3 | v1,
 |  | Short3 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Short3 | v1,
 |  | Short3 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector3 ToVector3 ( )

return the vector as a Vector3

戻り値:
the vector as a Vector3

変数

short X

X.

short Y

Y.

short Z

Z.


構造体 Short3N

vector of 3 normalized signed shorts [詳細]

すべてのメンバ一覧

Public メソッド

Short3N (float x, float y, float z)
constructor taking 3 scalar floats
Short3N (Vector3 v)
constructor taking a Vector3
Vector3 ToVector3 ()
return the vector as a Vector3
bool | Equals (Short3N v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Short3N v1, Short3N v2)
equality operator
static bool | operator!= (Short3N v1, Short3N v2)
not equals operator

Public 変数

ShortN X
X.
ShortN Y
Y.
ShortN Z
Z.

説明

vector of 3 normalized signed shorts

コンストラクタとデストラクタ

Short3N | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  |

constructor taking 3 scalar floats

引数:
x | x value to init with
y | y value to init with
z | z value to init with
Short3N ( Vector3 v )

constructor taking a Vector3

引数:
v the vector to init with

メソッド

bool Equals ( Short3N v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Short3N | v1,
 |  | Short3N | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Short3N | v1,
 |  | Short3N | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector3 ToVector3 ( )

return the vector as a Vector3

戻り値:
the vector as a Vector3

変数

ShortN X

X.

ShortN Y

Y.

ShortN Z

Z.


構造体 Short4

vector of 4 signed shorts [詳細]

すべてのメンバ一覧

Public メソッド

Short4 (int x, int y, int z, int w)
constructor taking 4 scalar integers
Short4 (Vector4 v)
constructor taking a Vector4
Vector4 ToVector4 ()
return the vector as a Vector4
bool | Equals (Short4 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Short4 v1, Short4 v2)
equality operator
static bool | operator!= (Short4 v1, Short4 v2)
not equals operator

Public 変数

short | X
X.
short | Y
Y.
short | Z
Z.
short | W
W.

説明

vector of 4 signed shorts

コンストラクタとデストラクタ

Short4 | ( | int | x,
 |  | int | y,
 |  | int | z,
 |  | int | w
 | ) |  |

constructor taking 4 scalar integers

引数:
x | x value to init with
y | y value to init with
z | z value to init with
w | w value to init with
Short4 ( Vector4 v )

constructor taking a Vector4

引数:
v the vector to init with

メソッド

bool Equals ( Short4 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Short4 | v1,
 |  | Short4 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Short4 | v1,
 |  | Short4 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector4 ToVector4 ( )

return the vector as a Vector4

戻り値:
the vector as a Vector4

変数

short W

W.

short X

X.

short Y

Y.

short Z

Z.


構造体 Short4N

vector of 4 normalized signed shorts [詳細]

すべてのメンバ一覧

Public メソッド

Short4N (float x, float y, float z, float w)
constructor taking 4 scalar floats
Short4N (Vector4 v)
constructor taking a Vector4
Vector4 ToVector4 ()
return the vector as a Vector4
bool | Equals (Short4N v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (Short4N v1, Short4N v2)
equality operator
static bool | operator!= (Short4N v1, Short4N v2)
not equals operator

Public 変数

ShortN X
X.
ShortN Y
Y.
ShortN Z
Z.
ShortN W
W.

説明

vector of 4 normalized signed shorts

コンストラクタとデストラクタ

Short4N | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | float | w
 | ) |  |

constructor taking 4 scalar floats

引数:
x | x value to init with
y | y value to init with
z | z value to init with
w | w value to init with
Short4N ( Vector4 v )

constructor taking a Vector4

引数:
v the vector to init with

メソッド

bool Equals ( Short4N v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | Short4N | v1,
 |  | Short4N | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | Short4N | v1,
 |  | Short4N | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector4 ToVector4 ( )

return the vector as a Vector4

戻り値:
the vector as a Vector4

変数

ShortN W

W.

ShortN X

X.

ShortN Y

Y.

ShortN Z

Z.


構造体 ShortN

a scalar normalized signed short [詳細]

すべてのメンバ一覧

Public メソッド

ShortN (float f)
constructor taking a float to convert to normalized signed short
float | ToFloat ()
return the float value of this
bool | Equals (ShortN v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of float value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (ShortN v1, ShortN v2)
equality operator
static bool | operator!= (ShortN v1, ShortN v2)
not equals operator
static implicit | operator float (ShortN v)
float casting operator
static | operator ShortN (float f)
normalized signed short casting operator

Public 変数

short | Bits
the short data

説明

a scalar normalized signed short

コンストラクタとデストラクタ

ShortN ( float f )

constructor taking a float to convert to normalized signed short

引数:
f the float to convert

メソッド

bool Equals ( ShortN v )

equality test

引数:
v the value to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static implicit operator float ( ShortN v ) [static]

float casting operator

引数:
v the value to convert to float
戻り値:
the float value
static operator ShortN ( float f ) [explicit, static]

normalized signed short casting operator

引数:
f the float to convert to normalized signed short
戻り値:
the normalized signed short value
static bool operator!= | ( | ShortN | v1,
 |  | ShortN | v2
 | ) |  | [static]

not equals operator

引数:
v1 | value 1
v2 | value 2
戻り値:
true if value 1 != value 2, false otherwise
static bool operator== | ( | ShortN | v1,
 |  | ShortN | v2
 | ) |  | [static]

equality operator

引数:
v1 | value 1
v2 | value 2
戻り値:
true if value 1 == value 2, false otherwise
float ToFloat ( )

return the float value of this

戻り値:
the float value of this
override string ToString ( )

get the string representation of float value

戻り値:
the string representation of float value

変数

short Bits

the short data


構造体 UByte2

vector of 2 unsigned shorts [詳細]

すべてのメンバ一覧

Public メソッド

UByte2 (int x, int y)
constructor taking 2 scalar integers
UByte2 (Vector2 v)
constructor taking a Vector2
Vector2 ToVector2 ()
return the vector as a Vector2
bool | Equals (UByte2 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UByte2 v1, UByte2 v2)
equality operator
static bool | operator!= (UByte2 v1, UByte2 v2)
not equals operator

Public 変数

byte | X
X.
byte | Y
Y.

説明

vector of 2 unsigned shorts

コンストラクタとデストラクタ

UByte2 | ( | int | x,
 |  | int | y
 | ) |  |

constructor taking 2 scalar integers

引数:
x | x value to init with
y | y value to init with
UByte2 ( Vector2 v )

constructor taking a Vector2

引数:
v the vector to init with

メソッド

bool Equals ( UByte2 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | UByte2 | v1,
 |  | UByte2 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | UByte2 | v1,
 |  | UByte2 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector2 ToVector2 ( )

return the vector as a Vector2

戻り値:
the vector as a Vector2

変数

byte X

X.

byte Y

Y.


構造体 UByte2N

vector of 2 normalized unsigned bytes [詳細]

すべてのメンバ一覧

Public メソッド

UByte2N (float x, float y)
constructor taking 2 scalar floats
UByte2N (Vector2 v)
constructor taking a Vector2
Vector2 ToVector2 ()
return the vector as a Vector2
bool | Equals (UByte2N v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UByte2N v1, UByte2N v2)
equality operator
static bool | operator!= (UByte2N v1, UByte2N v2)
not equals operator

Public 変数

UByteN X
X.
UByteN Y
Y.

説明

vector of 2 normalized unsigned bytes

コンストラクタとデストラクタ

UByte2N | ( | float | x,
 |  | float | y
 | ) |  |

constructor taking 2 scalar floats

引数:
x | x value to init with
y | y value to init with
UByte2N ( Vector2 v )

constructor taking a Vector2

引数:
v the vector to init with

メソッド

bool Equals ( UByte2N v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | UByte2N | v1,
 |  | UByte2N | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | UByte2N | v1,
 |  | UByte2N | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector2 ToVector2 ( )

return the vector as a Vector2

戻り値:
the vector as a Vector2

変数

UByteN X

X.

UByteN Y

Y.


構造体 UByte3

vector of 3 unsigned shorts [詳細]

すべてのメンバ一覧

Public メソッド

UByte3 (int x, int y, int z)
constructor taking 3 scalar integers
UByte3 (Vector3 v)
constructor taking a Vector3
Vector3 ToVector3 ()
return the vector as a Vector3
bool | Equals (UByte3 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UByte3 v1, UByte3 v2)
equality operator
static bool | operator!= (UByte3 v1, UByte3 v2)
not equals operator

Public 変数

byte | X
X.
byte | Y
Y.
byte | Z
Z.

説明

vector of 3 unsigned shorts

コンストラクタとデストラクタ

UByte3 | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |

constructor taking 3 scalar integers

引数:
x | x value to init with
y | y value to init with
z | z value to init with
UByte3 ( Vector3 v )

constructor taking a Vector3

引数:
v the vector to init with

メソッド

bool Equals ( UByte3 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | UByte3 | v1,
 |  | UByte3 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | UByte3 | v1,
 |  | UByte3 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector3 ToVector3 ( )

return the vector as a Vector3

戻り値:
the vector as a Vector3

変数

byte X

X.

byte Y

Y.

byte Z

Z.


構造体 UByte3N

vector of 3 normalized unsigned bytes [詳細]

すべてのメンバ一覧

Public メソッド

UByte3N (float x, float y, float z)
constructor taking 3 scalar floats
UByte3N (Vector3 v)
constructor taking a Vector3
Vector3 ToVector3 ()
return the vector as a Vector3
bool | Equals (UByte3N v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UByte3N v1, UByte3N v2)
equality operator
static bool | operator!= (UByte3N v1, UByte3N v2)
not equals operator

Public 変数

UByteN X
X.
UByteN Y
Y.
UByteN Z
Z.

説明

vector of 3 normalized unsigned bytes

コンストラクタとデストラクタ

UByte3N | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  |

constructor taking 3 scalar floats

引数:
x | x value to init with
y | y value to init with
z | z value to init with
UByte3N ( Vector3 v )

constructor taking a Vector3

引数:
v the vector to init with

メソッド

bool Equals ( UByte3N v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | UByte3N | v1,
 |  | UByte3N | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | UByte3N | v1,
 |  | UByte3N | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector3 ToVector3 ( )

return the vector as a Vector3

戻り値:
the vector as a Vector3

変数

UByteN X

X.

UByteN Y

Y.

UByteN Z

Z.


構造体 UByte4

vector of 4 unsigned bytes [詳細]

すべてのメンバ一覧

Public メソッド

UByte4 (int x, int y, int z, int w)
constructor taking 4 scalar integers
UByte4 (Vector4 v)
constructor taking a Vector4
Vector4 ToVector4 ()
return the vector as a Vector4
bool | Equals (UByte4 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UByte4 v1, UByte4 v2)
equality operator
static bool | operator!= (UByte4 v1, UByte4 v2)
not equals operator

Public 変数

byte | X
X.
byte | Y
Y.
byte | Z
Z.
byte | W
W.

説明

vector of 4 unsigned bytes

コンストラクタとデストラクタ

UByte4 | ( | int | x,
 |  | int | y,
 |  | int | z,
 |  | int | w
 | ) |  |

constructor taking 4 scalar integers

引数:
x | x value to init with
y | y value to init with
z | z value to init with
w | w value to init with
UByte4 ( Vector4 v )

constructor taking a Vector4

引数:
v the vector to init with

メソッド

bool Equals ( UByte4 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | UByte4 | v1,
 |  | UByte4 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | UByte4 | v1,
 |  | UByte4 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector4 ToVector4 ( )

return the vector as a Vector4

戻り値:
the vector as a Vector4

変数

byte W

W.

byte X

X.

byte Y

Y.

byte Z

Z.


構造体 UByte4N

vector of 4 normalized unsigned bytes [詳細]

すべてのメンバ一覧

Public メソッド

UByte4N (float x, float y, float z, float w)
constructor taking 4 scalar floats
UByte4N (Vector4 v)
constructor taking a Vector4
Vector4 ToVector4 ()
return the vector as a Vector4
bool | Equals (UByte4N v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UByte4N v1, UByte4N v2)
equality operator
static bool | operator!= (UByte4N v1, UByte4N v2)
not equals operator

Public 変数

UByteN X
X.
UByteN Y
Y.
UByteN Z
Z.
UByteN W
W.

説明

vector of 4 normalized unsigned bytes

コンストラクタとデストラクタ

UByte4N | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | float | w
 | ) |  |

constructor taking 4 scalar floats

引数:
x | x value to init with
y | y value to init with
z | z value to init with
w | w value to init with
UByte4N ( Vector4 v )

constructor taking a Vector4

引数:
v the vector to init with

メソッド

bool Equals ( UByte4N v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | UByte4N | v1,
 |  | UByte4N | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | UByte4N | v1,
 |  | UByte4N | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector4 ToVector4 ( )

return the vector as a Vector4

戻り値:
the vector as a Vector4

変数

UByteN W

W.

UByteN X

X.

UByteN Y

Y.

UByteN Z

Z.


構造体 UByteN

a scalar normalized unsigned byte [詳細]

すべてのメンバ一覧

Public メソッド

UByteN (float f)
constructor taking a float to convert to normalized unsigned byte
float | ToFloat ()
return the float value of this
bool | Equals (UByteN v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of float value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UByteN v1, UByteN v2)
equality operator
static bool | operator!= (UByteN v1, UByteN v2)
not equals operator
static implicit | operator float (UByteN v)
float casting operator
static | operator UByteN (float f)
normalized unsigned byte casting operator

Public 変数

byte | Bits
the byte data

説明

a scalar normalized unsigned byte

コンストラクタとデストラクタ

UByteN ( float f )

constructor taking a float to convert to normalized unsigned byte

引数:
f the float to convert

メソッド

bool Equals ( UByteN v )

equality test

引数:
v the value to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static implicit operator float ( UByteN v ) [static]

float casting operator

引数:
v the value to convert to float
戻り値:
the float value
static operator UByteN ( float f ) [explicit, static]

normalized unsigned byte casting operator

引数:
f the float to convert to normalized unsigned byte
戻り値:
the normalized unsigned byte value
static bool operator!= | ( | UByteN | v1,
 |  | UByteN | v2
 | ) |  | [static]

not equals operator

引数:
v1 | value 1
v2 | value 2
戻り値:
true if value 1 != value 2, false otherwise
static bool operator== | ( | UByteN | v1,
 |  | UByteN | v2
 | ) |  | [static]

equality operator

引数:
v1 | value 1
v2 | value 2
戻り値:
true if value 1 == value 2, false otherwise
float ToFloat ( )

return the float value of this

戻り値:
the float value of this
override string ToString ( )

get the string representation of float value

戻り値:
the string representation of float value

変数

byte Bits

the byte data


構造体 UShort2

vector of 2 unsigned shorts [詳細]

すべてのメンバ一覧

Public メソッド

UShort2 (int x, int y)
constructor taking 2 scalar integers
UShort2 (Vector2 v)
constructor taking a Vector2
Vector2 ToVector2 ()
return the vector as a Vector2
bool | Equals (UShort2 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UShort2 v1, UShort2 v2)
equality operator
static bool | operator!= (UShort2 v1, UShort2 v2)
not equals operator

Public 変数

ushort | X
X.
ushort | Y
Y.

説明

vector of 2 unsigned shorts

コンストラクタとデストラクタ

UShort2 | ( | int | x,
 |  | int | y
 | ) |  |

constructor taking 2 scalar integers

引数:
x | x value to init with
y | y value to init with
UShort2 ( Vector2 v )

constructor taking a Vector2

引数:
v the vector to init with

メソッド

bool Equals ( UShort2 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | UShort2 | v1,
 |  | UShort2 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | UShort2 | v1,
 |  | UShort2 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector2 ToVector2 ( )

return the vector as a Vector2

戻り値:
the vector as a Vector2

変数

ushort X

X.

ushort Y

Y.


構造体 UShort2N

vector of 2 normalized unsigned shorts [詳細]

すべてのメンバ一覧

Public メソッド

UShort2N (float x, float y)
constructor taking 2 scalar floats
UShort2N (Vector2 v)
constructor taking a Vector2
Vector2 ToVector2 ()
return the vector as a Vector2
bool | Equals (UShort2N v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UShort2N v1, UShort2N v2)
equality operator
static bool | operator!= (UShort2N v1, UShort2N v2)
not equals operator

Public 変数

UShortN X
X.
UShortN Y
Y.

説明

vector of 2 normalized unsigned shorts

コンストラクタとデストラクタ

UShort2N | ( | float | x,
 |  | float | y
 | ) |  |

constructor taking 2 scalar floats

引数:
x | x value to init with
y | y value to init with
UShort2N ( Vector2 v )

constructor taking a Vector2

引数:
v the vector to init with

メソッド

bool Equals ( UShort2N v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | UShort2N | v1,
 |  | UShort2N | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | UShort2N | v1,
 |  | UShort2N | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector2 ToVector2 ( )

return the vector as a Vector2

戻り値:
the vector as a Vector2

変数

UShortN X

X.

UShortN Y

Y.


構造体 UShort3

vector of 3 unsigned shorts [詳細]

すべてのメンバ一覧

Public メソッド

UShort3 (int x, int y, int z)
constructor taking 3 scalar integers
UShort3 (Vector3 v)
constructor taking a Vector3
Vector3 ToVector3 ()
return the vector as a Vector3
bool | Equals (UShort3 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UShort3 v1, UShort3 v2)
equality operator
static bool | operator!= (UShort3 v1, UShort3 v2)
not equals operator

Public 変数

ushort | X
X.
ushort | Y
Y.
ushort | Z
Z.

説明

vector of 3 unsigned shorts

コンストラクタとデストラクタ

UShort3 | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |

constructor taking 3 scalar integers

引数:
x | x value to init with
y | y value to init with
z | z value to init with
UShort3 ( Vector3 v )

constructor taking a Vector3

引数:
v the vector to init with

メソッド

bool Equals ( UShort3 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | UShort3 | v1,
 |  | UShort3 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | UShort3 | v1,
 |  | UShort3 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector3 ToVector3 ( )

return the vector as a Vector3

戻り値:
the vector as a Vector3

変数

ushort X

X.

ushort Y

Y.

ushort Z

Z.


構造体 UShort3N

vector of 3 normalized unsigned shorts [詳細]

すべてのメンバ一覧

Public メソッド

UShort3N (float x, float y, float z)
constructor taking 3 scalar floats
UShort3N (Vector3 v)
constructor taking a Vector3
Vector3 ToVector3 ()
return the vector as a Vector3
bool | Equals (UShort3N v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UShort3N v1, UShort3N v2)
equality operator
static bool | operator!= (UShort3N v1, UShort3N v2)
not equals operator

Public 変数

UShortN X
X.
UShortN Y
Y.
UShortN Z
Z.

説明

vector of 3 normalized unsigned shorts

コンストラクタとデストラクタ

UShort3N | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  |

constructor taking 3 scalar floats

引数:
x | x value to init with
y | y value to init with
z | z value to init with
UShort3N ( Vector3 v )

constructor taking a Vector3

引数:
v the vector to init with

メソッド

bool Equals ( UShort3N v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | UShort3N | v1,
 |  | UShort3N | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | UShort3N | v1,
 |  | UShort3N | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector3 ToVector3 ( )

return the vector as a Vector3

戻り値:
the vector as a Vector3

変数

UShortN X

X.

UShortN Y

Y.

UShortN Z

Z.


構造体 UShort4

vector of 4 unsigned shorts [詳細]

すべてのメンバ一覧

Public メソッド

UShort4 (int x, int y, int z, int w)
constructor taking 4 scalar integers
UShort4 (Vector4 v)
constructor taking a Vector4
Vector4 ToVector4 ()
return the vector as a Vector4
bool | Equals (UShort4 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UShort4 v1, UShort4 v2)
equality operator
static bool | operator!= (UShort4 v1, UShort4 v2)
not equals operator

Public 変数

ushort | X
X.
ushort | Y
Y.
ushort | Z
Z.
ushort | W
W.

説明

vector of 4 unsigned shorts

コンストラクタとデストラクタ

UShort4 | ( | int | x,
 |  | int | y,
 |  | int | z,
 |  | int | w
 | ) |  |

constructor taking 4 scalar integers

引数:
x | x value to init with
y | y value to init with
z | z value to init with
w | w value to init with
UShort4 ( Vector4 v )

constructor taking a Vector4

引数:
v the vector to init with

メソッド

bool Equals ( UShort4 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | UShort4 | v1,
 |  | UShort4 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | UShort4 | v1,
 |  | UShort4 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector4 ToVector4 ( )

return the vector as a Vector4

戻り値:
the vector as a Vector4

変数

ushort W

W.

ushort X

X.

ushort Y

Y.

ushort Z

Z.


構造体 UShort4N

vector of 4 normalized unsigned shorts [詳細]

すべてのメンバ一覧

Public メソッド

UShort4N (float x, float y, float z, float w)
constructor taking 4 scalar floats
UShort4N (Vector4 v)
constructor taking a Vector4
Vector4 ToVector4 ()
return the vector as a Vector4
bool | Equals (UShort4N v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of vector value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UShort4N v1, UShort4N v2)
equality operator
static bool | operator!= (UShort4N v1, UShort4N v2)
not equals operator

Public 変数

UShortN X
X.
UShortN Y
Y.
UShortN Z
Z.
UShortN W
W.

説明

vector of 4 normalized unsigned shorts

コンストラクタとデストラクタ

UShort4N | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | float | w
 | ) |  |

constructor taking 4 scalar floats

引数:
x | x value to init with
y | y value to init with
z | z value to init with
w | w value to init with
UShort4N ( Vector4 v )

constructor taking a Vector4

引数:
v the vector to init with

メソッド

bool Equals ( UShort4N v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static bool operator!= | ( | UShort4N | v1,
 |  | UShort4N | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if v 1 != v 2, false otherwise
static bool operator== | ( | UShort4N | v1,
 |  | UShort4N | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
override string ToString ( )

get the string representation of vector value

戻り値:
the string representation of vector value
Vector4 ToVector4 ( )

return the vector as a Vector4

戻り値:
the vector as a Vector4

変数

UShortN W

W.

UShortN X

X.

UShortN Y

Y.

UShortN Z

Z.


構造体 UShortN

a scalar normalized unsigned short [詳細]

すべてのメンバ一覧

Public メソッド

UShortN (float f)
constructor taking a float to convert to normalized unsigned short
float | ToFloat ()
return the float value of this
bool | Equals (UShortN v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of float value
override int | GetHashCode ()
gets the hash code for this

Static Public メソッド

static bool | operator== (UShortN v1, UShortN v2)
equality operator
static bool | operator!= (UShortN v1, UShortN v2)
not equals operator
static implicit | operator float (UShortN v)
float casting operator
static | operator UShortN (float f)
normalized unsigned short casting operator

Public 変数

ushort | Bits
the short data

説明

a scalar normalized unsigned short

コンストラクタとデストラクタ

UShortN ( float f )

constructor taking a float to convert to normalized unsigned short

引数:
f the float to convert

メソッド

bool Equals ( UShortN v )

equality test

引数:
v the value to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this

戻り値:
integer hash code
static implicit operator float ( UShortN v ) [static]

float casting operator

引数:
v the value to convert to float
戻り値:
the float value
static operator UShortN ( float f ) [explicit, static]

normalized unsigned short casting operator

引数:
f the float to convert to normalized unsigned short
戻り値:
the normalized unsigned short value
static bool operator!= | ( | UShortN | v1,
 |  | UShortN | v2
 | ) |  | [static]

not equals operator

引数:
v1 | value 1
v2 | value 2
戻り値:
true if value 1 != value 2, false otherwise
static bool operator== | ( | UShortN | v1,
 |  | UShortN | v2
 | ) |  | [static]

equality operator

引数:
v1 | value 1
v2 | value 2
戻り値:
true if value 1 == value 2, false otherwise
float ToFloat ( )

return the float value of this

戻り値:
the float value of this
override string ToString ( )

get the string representation of float value

戻り値:
the string representation of float value

変数

ushort Bits

the short data


構造体 Vector2

vector of 2 floats [詳細]

すべてのメンバ一覧

Public メソッド

Vector2 (float x, float y)
constructor taking two floats
Vector2 (float f)
constructor taking one float
float | Length ()
return the length of this vector
float | LengthSquared ()
return the length squared of this vector
float | Distance (Vector2 v)
get the distance between this and another vector
float | Distance (ref Vector2 v)
get the distance between this and another vector
float | DistanceSquared (Vector2 v)
get the distance squared between this and another vector
float | DistanceSquared (ref Vector2 v)
get the distance squared between this and another vector
float | Dot (Vector2 v)
dot product of this and v
float | Dot (ref Vector2 v)
dot product of this and v
float | Determinant (Vector2 v)
return the determinant of the 2x2 matrix formed by this and v
float | Determinant (ref Vector2 v)
return the determinant of the 2x2 matrix formed by this and v
Vector2 Normalize ()
return this vector normalized
void | Normalize (out Vector2 result)
return this vector normalized
Vector2 Abs ()
element wise absolute value
void | Abs (out Vector2 result)
element wise absolute value
Vector2 | Min (Vector2 v)
element wise min
void | Min (ref Vector2 v, out Vector2 result)
element wise min
Vector2 | Min (float f)
element wise min
void | Min (float f, out Vector2 result)
element wise min
Vector2 | Max (Vector2 v)
element wise max
void | Max (ref Vector2 v, out Vector2 result)
element wise max
Vector2 | Max (float f)
element wise max
void | Max (float f, out Vector2 result)
element wise max
Vector2 | Clamp (Vector2 min, Vector2 max)
element wise clamp
void | Clamp (ref Vector2 min, ref Vector2 max, out Vector2 result)
element wise clamp
Vector2 | Clamp (float min, float max)
element wise clamp
void | Clamp (float min, float max, out Vector2 result)
element wise clamp
Vector2 | Repeat (Vector2 min, Vector2 max)
element wise repeat
void | Repeat (ref Vector2 min, ref Vector2 max, out Vector2 result)
element wise repeat
Vector2 | Repeat (float min, float max)
element wise repeat
void | Repeat (float min, float max, out Vector2 result)
element wise repeat
Vector2 | Lerp (Vector2 v, float f)
lerp between this and the other vector
void | Lerp (ref Vector2 v, float f, out Vector2 result)
lerp between this and the other vector
Vector2 | Slerp (Vector2 v, float f)
slerp between this and the other vector
void | Slerp (ref Vector2 v, float f, out Vector2 result)
slerp between this and the other vector
Vector2 | MoveTo (Vector2 v, float length)
move to target vector by specified length
void | MoveTo (ref Vector2 v, float length, out Vector2 result)
move to target vector by specified angle
Vector2 | TurnTo (Vector2 v, float angle)
turn to target vector by specified angle
void | TurnTo (ref Vector2 v, float angle, out Vector2 result)
turn to target vector by specified angle
float | Angle (Vector2 v)
return the angle between this and v
float | Angle (ref Vector2 v)
return the angle between this and v
Vector2 | Rotate (float angle)
return this vector rotated by angle
void | Rotate (float angle, out Vector2 result)
return this vector rotated by angle
Vector2 | Rotate (Vector2 rotation)
return this vector rotated by angle
void | Rotate (ref Vector2 rotation, out Vector2 result)
return this vector rotated by angle
Vector2 | Reflect (Vector2 normal)
return this vector reflected about normal
void | Reflect (ref Vector2 normal, out Vector2 result)
return this vector reflected about normal
Vector2 Perpendicular ()
return a vector perpendicular to this
void | Perpendicular (out Vector2 result)
return this rotated by +pi/2
Vector2 | ProjectOnLine (Vector2 point, Vector2 direction)
project this onto the line (point,direction)
void | ProjectOnLine (ref Vector2 point, ref Vector2 direction, out Vector2 result)
project this onto the line (point,direction)
Vector2 | Add (Vector2 v)
return this + v
void | Add (ref Vector2 v, out Vector2 result)
result = this + v
Vector2 | Subtract (Vector2 v)
return this - v
void | Subtract (ref Vector2 v, out Vector2 result)
result = this - v
Vector2 | Multiply (Vector2 v)
return this * v
void | Multiply (ref Vector2 v, out Vector2 result)
result = this * v
Vector2 | Multiply (float f)
return this * f
void | Multiply (float f, out Vector2 result)
result = this * f
Vector2 | Divide (Vector2 v)
return this / v
void | Divide (ref Vector2 v, out Vector2 result)
result = this / v
Vector2 | Divide (float f)
return this / f
void | Divide (float f, out Vector2 result)
result = this / f
Vector2 Negate ()
return -this
void | Negate (out Vector2 result)
result = -this
bool | IsUnit (float epsilon)
unit vector test
bool | IsZero ()
test if all elements of this are zero
bool | IsOne ()
test if all elements of this are one
bool | IsInfinity ()
test if any elements of this are Infinity
bool | IsNaN ()
test if any of the elements of this are NaN
bool | Equals (Vector2 v, float epsilon)
equality test with an epsilon
bool | Equals (Vector2 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
convert vector to string
override int | GetHashCode ()
gets the hash code for this vector

Static Public メソッド

static Vector2 | Rotation (float angle)
return a new vector that breaks a rotation angle into its x and y components
static void | Rotation (float angle, out Vector2 result)
return a new vector that breaks a rotation angle into its x and y components
static float | Length (Vector2 v)
static function equivalent to Length()
static float | Length (ref Vector2 v)
static function equivalent to Length()
static float | LengthSquared (Vector2 v)
static function equivalent to LengthSquared()
static float | LengthSquared (ref Vector2 v)
static function equivalent to LengthSquared()
static float | Distance (Vector2 v1, Vector2 v2)
static function equivalent to Distance(Vector2)
static float | Distance (ref Vector2 v1, ref Vector2 v2)
static function equivalent to Distance(ref Vector2)
static float | DistanceSquared (Vector2 v1, Vector2 v2)
static function equivalent to DistanceSquared(Vector2)
static float | DistanceSquared (ref Vector2 v1, ref Vector2 v2)
static function equivalent to DistanceSquared(ref Vector2)
static float | Dot (Vector2 v1, Vector2 v2)
static function equivalent to Dot(Vector2)
static float | Dot (ref Vector2 v1, ref Vector2 v2)
static function equivalent to Dot(ref Vector2)
static float | Determinant (Vector2 v1, Vector2 v2)
static function equivalent to Determinant(Vector2 v)
static float | Determinant (ref Vector2 v1, ref Vector2 v2)
static function equivalent to Determinant(ref Vector2 v)
static Vector2 | Normalize (Vector2 v)
static function equivalent to Normalize()
static void | Normalize (ref Vector2 v, out Vector2 result)
static function equivalent to Normalize(out Vector2)
static Vector2 | Abs (Vector2 v)
static function equivalent to Abs()
static void | Abs (ref Vector2 v, out Vector2 result)
static function equivalent to Abs(out Vector2)
static Vector2 | Min (Vector2 v1, Vector2 v2)
static function equivalent to Min(Vector2)
static void | Min (ref Vector2 v1, ref Vector2 v2, out Vector2 result)
static function equivalent to Min(ref Vector2, out Vector2)
static Vector2 | Min (Vector2 v, float f)
static function equivalent to Min(float)
static void | Min (ref Vector2 v, float f, out Vector2 result)
static function equivalent to Min(float, out Vector2)
static Vector2 | Max (Vector2 v1, Vector2 v2)
static function equivalent to Max(Vector2)
static void | Max (ref Vector2 v1, ref Vector2 v2, out Vector2 result)
static function equivalent to Max(ref Vector2, out Vector2)
static Vector2 | Max (Vector2 v, float f)
static function equivalent to Max(float)
static void | Max (ref Vector2 v, float f, out Vector2 result)
static function equivalent to Max(float, out Vector2)
static Vector2 | Clamp (Vector2 v, Vector2 min, Vector2 max)
static function equivalent to Clamp(Vector2, Vector2)
static void | Clamp (ref Vector2 v, ref Vector2 min, ref Vector2 max, out Vector2 result)
static function equivalent to Clamp(ref Vector2, ref Vector2, out Vector2)
static Vector2 | Clamp (Vector2 v, float min, float max)
static function equivalent to Clamp(float, float)
static void | Clamp (ref Vector2 v, float min, float max, out Vector2 result)
static function equivalent to Clamp(float, float, out Vector2)
static Vector2 | Repeat (Vector2 v, Vector2 min, Vector2 max)
static function equivalent to Repeat(Vector2, Vector2)
static void | Repeat (ref Vector2 v, ref Vector2 min, ref Vector2 max, out Vector2 result)
static function equivalent to Repeat(ref Vector2, ref Vector2, out Vector2)
static Vector2 | Repeat (Vector2 v, float min, float max)
static function equivalent to Repeat(float, float)
static void | Repeat (ref Vector2 v, float min, float max, out Vector2 result)
static function equivalent to Repeat(float, float, out Vector2)
static Vector2 | Lerp (Vector2 v1, Vector2 v2, float f)
static function equivalent to Lerp(Vector2, float)
static void | Lerp (ref Vector2 v1, ref Vector2 v2, float f, out Vector2 result)
static function equivalent to Lerp(ref Vector2, float, out Vector2)
static Vector2 | Slerp (Vector2 v1, Vector2 v2, float f)
static function equivalent to Slerp(Vector2, float)
static void | Slerp (ref Vector2 v1, ref Vector2 v2, float f, out Vector2 result)
static function equivalent to Slerp(ref Vector2, float, out Vector2)
static Vector2 | MoveTo (Vector2 v1, Vector2 v2, float length)
static function equivalent to MoveTo(Vector2, float)
static void | MoveTo (ref Vector2 v1, ref Vector2 v2, float length, out Vector2 result)
static function equivalent to MoveTo(ref Vector2, float, out Vector2)
static Vector2 | TurnTo (Vector2 v1, Vector2 v2, float angle)
static function equivalent to TurnTo(Vector2, float)
static void | TurnTo (ref Vector2 v1, ref Vector2 v2, float angle, out Vector2 result)
static function equivalent to TurnTo(ref Vector2, float, out Vector2)
static float | Angle (Vector2 v1, Vector2 v2)
static function equivalent to Angle(Vector2)
static float | Angle (ref Vector2 v1, ref Vector2 v2)
static function equivalent to Angle(ref Vector2)
static Vector2 | Rotate (Vector2 v, float angle)
static function equivalent to Rotate(float)
static void | Rotate (ref Vector2 v, float angle, out Vector2 result)
static function equivalent to Rotate(float, out Vector2)
static Vector2 | Rotate (Vector2 v, Vector2 rotation)
static function equivalent to Rotate(Vector2)
static void | Rotate (ref Vector2 v, ref Vector2 rotation, out Vector2 result)
static function equivalent to Rotate(ref Vector2, out Vector2)
static Vector2 | Reflect (Vector2 v, Vector2 normal)
static function equivalent to Reflect(Vector2)
static void | Reflect (ref Vector2 v, ref Vector2 normal, out Vector2 result)
static function equivalent to Reflect(ref Vector2, out Vector2)
static Vector2 | Perpendicular (Vector2 v)
static function equivalent to Perpendicular()
static void | Perpendicular (ref Vector2 v, out Vector2 result)
static function equivalent to Perpendicular(out Vector2)
static Vector2 | ProjectOnLine (Vector2 v, Vector2 point, Vector2 direction)
static function equivalent to ProjectOnLine(Vector2, Vector2)
static void | ProjectOnLine (ref Vector2 v, ref Vector2 point, ref Vector2 direction, out Vector2 result)
static function equivalent to ProjectOnLine(ref Vector2, ref Vector2, out Vector2)
static Vector2 | Add (Vector2 v1, Vector2 v2)
static function equivalent to Add(Vector2)
static void | Add (ref Vector2 v1, ref Vector2 v2, out Vector2 result)
static function equivalent to Add(ref Vector2, out Vector2)
static Vector2 | Subtract (Vector2 v1, Vector2 v2)
static function equivalent to Subtract(Vector2)
static void | Subtract (ref Vector2 v1, ref Vector2 v2, out Vector2 result)
static function equivalent to Subtract(ref Vector2, out Vector2)
static Vector2 | Multiply (Vector2 v1, Vector2 v2)
static function equivalent to Multiply(Vector2)
static void | Multiply (ref Vector2 v1, ref Vector2 v2, out Vector2 result)
static function equivalent to Multiply(ref Vector2, out Vector2)
static Vector2 | Multiply (Vector2 v, float f)
static function equivalent to Multiply(float)
static void | Multiply (ref Vector2 v, float f, out Vector2 result)
static function equivalent to Multiply(float, out Vector2)
static Vector2 | Divide (Vector2 v1, Vector2 v2)
static function equivalent to Divide(Vector2)
static void | Divide (ref Vector2 v1, ref Vector2 v2, out Vector2 result)
static function equivalent to Divide(ref Vector2, out Vector2)
static Vector2 | Divide (Vector2 v, float f)
static function equivalent to Divide(float)
static void | Divide (ref Vector2 v, float f, out Vector2 result)
static function equivalent to Divide(float, out Vector2)
static Vector2 | Negate (Vector2 v)
static function equivalent to Negate()
static void | Negate (ref Vector2 v, out Vector2 result)
static function equivalent to Negate(out Vector2)
static bool | operator== (Vector2 v1, Vector2 v2)
equality operator
static bool | operator!= (Vector2 v1, Vector2 v2)
not equals operator
static Vector2 | operator+ (Vector2 v1, Vector2 v2)
vector addition operator
static Vector2 | operator+ (Vector2 v, float f)
adds a scalar float to each element of a vector
static Vector2 | operator+ (float f, Vector2 v)
adds a scalar float to each element of a vector
static Vector2 | operator- (Vector2 v1, Vector2 v2)
vector subtraction operator
static Vector2 | operator- (Vector2 v, float f)
subtract a scalar float from each element of a vector
static Vector2 | operator- (float f, Vector2 v)
creates a new vector consisting of {f, f}, and then subtracts v from it
static Vector2 | operator- (Vector2 v)
unary minus operator
static Vector2 | operator* (Vector2 v1, Vector2 v2)
multiplication operator
static Vector2 | operator* (Vector2 v, float f)
multiply each element of vector by scalar float
static Vector2 | operator* (float f, Vector2 v)
multiply each element of vector by scalar float
static Vector2 | operator/ (Vector2 v1, Vector2 v2)
division operator
static Vector2 | operator/ (Vector2 v, float f)
divide each element of a vector by a scalar float
static Vector2 | operator/ (float f, Vector2 v)
create a new vector consisting of {f, f} and divide it by vec

Public 変数

float | X
x
float | Y
y

Static Public 変数

static readonly Vector2 | Zero = new Vector2(0.0f, 0.0f)
return a new vector with x and y set to 0 and 0
static readonly Vector2 | One = new Vector2(1.0f, 1.0f)
return a new vector with x and y set to 1 and 1
static readonly Vector2 | UnitX = new Vector2(1.0f, 0.0f)
return a new vector with x and y set to 1 and 0
static readonly Vector2 | UnitY = new Vector2(0.0f, 1.0f)
return a new vector with x and y set to 0 and 1

プロパティ

float | R [get, set]
Red.
float | G [get, set]
Green.
Vector2 | Xx [get]
Vector2 | Yx [get, set]
Vector2 | Xy [get, set]
Vector2 | Yy [get]
Vector3 | Xy0 [get]
returns a 3 element vector consisting of the current vector with the z component set to 0
Vector3 | Xy1 [get]
return a 3 element vector consisting of the current vector with the z component set to 1
Vector4 | Xy00 [get]
return a 4 element vector consisting of the current vector with the z and w components set to 0 and 0
Vector4 | Xy01 [get]
return a 4 element vector consisting of the current vector with the z and w components set to 0 and 1
Vector4 | Xy10 [get]
return a 4 element vector consisting of the current vector with the z and w components set to 1 and 0
Vector4 | Xy11 [get]
return a 4 element vector consisting of the current vector with the z and w components set to 1 and 1

説明

vector of 2 floats

コンストラクタとデストラクタ

Vector2 | ( | float | x,
 |  | float | y
 | ) |  |

constructor taking two floats

引数:
x | x
y | y
Vector2 ( float f )

constructor taking one float

引数:
f f

メソッド

Vector2 Abs ( )

element wise absolute value

戻り値:
element wise absolute value of this
static Vector2 Abs ( Vector2 v ) [static]

static function equivalent to Abs()

引数:
v vector
戻り値:
element wise absolute value of v
static void Abs | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Abs(out Vector2)

引数:
v | vector
result | element wise absolute value of v
void Abs ( out Vector2 result )

element wise absolute value

引数:
result element wise absolute value of this
static Vector2 Add | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

static function equivalent to Add(Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
v1 + v2
static void Add | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Add(ref Vector2, out Vector2)

引数:
v1 | vector 1
v2 | vector 2
result | v1 + v2
Vector2 Add ( Vector2 v )

return this + v

引数:
v vector
戻り値:
this + v
void Add | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  |

result = this + v

引数:
v | vector
result | this + v
float Angle ( Vector2 v )

return the angle between this and v

引数:
v vector to get the angle with
戻り値:
the angle between this and v
float Angle ( ref Vector2 v )

return the angle between this and v

引数:
v vector to get the angle with
戻り値:
the angle between this and v
static float Angle | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

static function equivalent to Angle(Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the angle between v1 and v2
static float Angle | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2
 | ) |  | [static]

static function equivalent to Angle(ref Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the angle between v1 and v2
Vector2 Clamp | ( | Vector2 | min,
 |  | Vector2 | max
 | ) |  |

element wise clamp

引数:
min | min values to clamp against
max | max values to clamp against
戻り値:
a new vector consisting of each element of this clamped between min and max
void Clamp | ( | ref Vector2 | min,
 |  | ref Vector2 | max,
 |  | out Vector2 | result
 | ) |  |

element wise clamp

引数:
min | min values to clamp against
max | max values to clamp against
result | a new vector consisting of each element of this clamped between min and max
Vector2 Clamp | ( | float | min,
 |  | float | max
 | ) |  |

element wise clamp

引数:
min | min value to clamp against
max | max value to clamp against
戻り値:
a new vector consisting of each element of this clamped between min and max
static Vector2 Clamp | ( | Vector2 | v,
 |  | Vector2 | min,
 |  | Vector2 | max
 | ) |  | [static]

static function equivalent to Clamp(Vector2, Vector2)

引数:
v | vector
min | min values to clamp against
max | max values to clamp against
戻り値:
a new vector consisting of each element of v clamped between min and max
static void Clamp | ( | ref Vector2 | v,
 |  | ref Vector2 | min,
 |  | ref Vector2 | max,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Clamp(ref Vector2, ref Vector2, out Vector2)

引数:
v | vector
min | min values to clamp against
max | max values to clamp against
result | a new vector consisting of each element of v clamped between min and max
static Vector2 Clamp | ( | Vector2 | v,
 |  | float | min,
 |  | float | max
 | ) |  | [static]

static function equivalent to Clamp(float, float)

引数:
v | vector
min | min value to clamp against
max | max value to clamp against
戻り値:
a new vector consisting of each element of v clamped between min and max
void Clamp | ( | float | min,
 |  | float | max,
 |  | out Vector2 | result
 | ) |  |

element wise clamp

引数:
min | min value to clamp against
max | max value to clamp against
result | a new vector consisting of each element of this clamped between min and max
static void Clamp | ( | ref Vector2 | v,
 |  | float | min,
 |  | float | max,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Clamp(float, float, out Vector2)

引数:
v | vector
min | min value to clamp against
max | max value to clamp against
result | a new vector consisting of each element of v clamped between min and max
float Determinant ( ref Vector2 v )

return the determinant of the 2x2 matrix formed by this and v

引数:
v vector used to form the 2x2 matrix to take the determinant of
戻り値:
the determinant of the 2x2 matrix formed by this and v
static float Determinant | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

static function equivalent to Determinant(Vector2 v)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the determinant of the 2x2 matrix formed by v1 and v2
static float Determinant | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2
 | ) |  | [static]

static function equivalent to Determinant(ref Vector2 v)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the determinant of the 2x2 matrix formed by v1 and v2
float Determinant ( Vector2 v )

return the determinant of the 2x2 matrix formed by this and v

引数:
v vector used to form the 2x2 matrix to take the determinant of
戻り値:
the determinant of the 2x2 matrix formed by this and v
float Distance ( ref Vector2 v )

get the distance between this and another vector

引数:
v the vector to get the distance to
戻り値:
the distance bwteen this and the other vector
static float Distance | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

static function equivalent to Distance(Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the distance bwteen v1 and v2
static float Distance | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2
 | ) |  | [static]

static function equivalent to Distance(ref Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the distance bwteen v1 and v2
float Distance ( Vector2 v )

get the distance between this and another vector

引数:
v the vector to get the distance to
戻り値:
the distance bwteen this and the other vector
float DistanceSquared ( Vector2 v )

get the distance squared between this and another vector

引数:
v the vector to get the distance squared to
戻り値:
the distance between this and the other vector squared
static float DistanceSquared | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

static function equivalent to DistanceSquared(Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the distance between v1 and v2 squared
static float DistanceSquared | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2
 | ) |  | [static]

static function equivalent to DistanceSquared(ref Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the distance between v1 and v2 squared
float DistanceSquared ( ref Vector2 v )

get the distance squared between this and another vector

引数:
v the vector to get the distance squared to
戻り値:
the distance between this and the other vector squared
static Vector2 Divide | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

static function equivalent to Divide(Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
v1 / v2
static void Divide | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Divide(ref Vector2, out Vector2)

引数:
v1 | vector 1
v2 | vector 2
result | v1 / v2
static Vector2 Divide | ( | Vector2 | v,
 |  | float | f
 | ) |  | [static]

static function equivalent to Divide(float)

引数:
v | vector
f | scalar
戻り値:
v / f
static void Divide | ( | ref Vector2 | v,
 |  | float | f,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Divide(float, out Vector2)

引数:
v | vector
f | scalar
result | v / f
Vector2 Divide ( Vector2 v )

return this / v

引数:
v vector
戻り値:
this / v
void Divide | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  |

result = this / v

引数:
v | vector
result | this / v
Vector2 Divide ( float f )

return this / f

引数:
f scalar
戻り値:
this / f
void Divide | ( | float | f,
 |  | out Vector2 | result
 | ) |  |

result = this / f

引数:
f | scalar
result | this / f
float Dot ( ref Vector2 v )

dot product of this and v

引数:
v vector to take the dot product with
戻り値:
dot product of this and v
static float Dot | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

static function equivalent to Dot(Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
dot product of v1 and v2
static float Dot | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2
 | ) |  | [static]

static function equivalent to Dot(ref Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
dot product of v1 and v2
float Dot ( Vector2 v )

dot product of this and v

引数:
v vector to take the dot product with
戻り値:
dot product of this and v
bool Equals | ( | Vector2 | v,
 |  | float | epsilon
 | ) |  |

equality test with an epsilon

引数:
v | the vector to compare this to
epsilon | the epsilon to use in comparison
戻り値:
true if for every element n, abs(this[n] - v[n]) <= epsilon, false otherwise
bool Equals ( Vector2 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this vector

戻り値:
integer hash code
bool IsInfinity ( )

test if any elements of this are Infinity

戻り値:
true if any elements of this are Infinity, false otherwise
bool IsNaN ( )

test if any of the elements of this are NaN

戻り値:
true is any elements of this are NaN, false otherwise
bool IsOne ( )

test if all elements of this are one

戻り値:
true if all elements of this are one, false otherwise
bool IsUnit ( float epsilon )

unit vector test

引数:
epsilon epsilon used to test
戻り値:
true if the absolute value of the vector length minus one is <= epsilon, false otherwise
bool IsZero ( )

test if all elements of this are zero

戻り値:
true if all elements of this are zero, false otherwise
static float Length ( Vector2 v ) [static]

static function equivalent to Length()

引数:
v vector
戻り値:
the length of the vector
static float Length ( ref Vector2 v ) [static]

static function equivalent to Length()

引数:
v vector
戻り値:
the length of the vector
float Length ( )

return the length of this vector

戻り値:
the length of this vector
float LengthSquared ( )

return the length squared of this vector

戻り値:
the length squared of this vector
static float LengthSquared ( Vector2 v ) [static]

static function equivalent to LengthSquared()

引数:
v vector
戻り値:
the length squared of the vector
static float LengthSquared ( ref Vector2 v ) [static]

static function equivalent to LengthSquared()

引数:
v vector
戻り値:
the length squared of the vector
void Lerp | ( | ref Vector2 | v,
 |  | float | f,
 |  | out Vector2 | result
 | ) |  |

lerp between this and the other vector

引数:
v | the other vector to lerp to
f | lerp amount
result | a Vector2 where each element is the result of lerping f between the corresponding elements of this and other
static Vector2 Lerp | ( | Vector2 | v1,
 |  | Vector2 | v2,
 |  | float | f
 | ) |  | [static]

static function equivalent to Lerp(Vector2, float)

引数:
v1 | vector 1
v2 | vector 2
f | lerp amount
戻り値:
a Vector2 where each element is the result of lerping f between the corresponding elements of v1 and v2
static void Lerp | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2,
 |  | float | f,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Lerp(ref Vector2, float, out Vector2)

引数:
v1 | vector 1
v2 | vector 2
f | lerp amount
result | a Vector2 where each element is the result of lerping f between the corresponding elements of v1 and v2
Vector2 Lerp | ( | Vector2 | v,
 |  | float | f
 | ) |  |

lerp between this and the other vector

引数:
v | the other vector to lerp to
f | lerp amount
戻り値:
a Vector2 where each element is the result of lerping f between the corresponding elements of this and other
Vector2 Max ( Vector2 v )

element wise max

引数:
v vector to compare to this
戻り値:
the max of this and v
void Max | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  |

element wise max

引数:
v | vector to compare to this
result | the max of this and v
Vector2 Max ( float f )

element wise max

引数:
f scalar to compare to this
戻り値:
the max of this and f
void Max | ( | float | f,
 |  | out Vector2 | result
 | ) |  |

element wise max

引数:
f | scalar to compare to this
result | the max of this and f
static Vector2 Max | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

static function equivalent to Max(Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the max of v1 and v2
static void Max | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Max(ref Vector2, out Vector2)

引数:
v1 | vector 1
v2 | vector 2
result | the max of v1 and v2
static Vector2 Max | ( | Vector2 | v,
 |  | float | f
 | ) |  | [static]

static function equivalent to Max(float)

引数:
v | vector
f | scalar
戻り値:
the max of v and f
static void Max | ( | ref Vector2 | v,
 |  | float | f,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Max(float, out Vector2)

引数:
v | vector
f | scalar
result | the max of v and f
void Min | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  |

element wise min

引数:
v | vector to compare to this
result | the min of this and v
void Min | ( | float | f,
 |  | out Vector2 | result
 | ) |  |

element wise min

引数:
f | scalar to compare to this
result | the min of this and f
static Vector2 Min | ( | Vector2 | v,
 |  | float | f
 | ) |  | [static]

static function equivalent to Min(float)

引数:
v | vector
f | scalar
戻り値:
the min of v and f
Vector2 Min ( float f )

element wise min

引数:
f scalar to compare to this
戻り値:
the min of this and f
static Vector2 Min | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

static function equivalent to Min(Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the min of v1 and v2
static void Min | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Min(ref Vector2, out Vector2)

引数:
v1 | vector 1
v2 | vector 2
result | the min of v1 and v2
static void Min | ( | ref Vector2 | v,
 |  | float | f,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Min(float, out Vector2)

引数:
v | vector
f | scalar
result | the min of v and f
Vector2 Min ( Vector2 v )

element wise min

引数:
v vector to compare to this
戻り値:
the min of this and v
Vector2 MoveTo | ( | Vector2 | v,
 |  | float | length
 | ) |  |

move to target vector by specified length

引数:
v | target vector
length | step length
戻り値:
a new vector moved to target vector by specified length
void MoveTo | ( | ref Vector2 | v,
 |  | float | length,
 |  | out Vector2 | result
 | ) |  |

move to target vector by specified angle

引数:
v | target vector
length | step length
result | a new vector moved to target vector by specified length
static Vector2 MoveTo | ( | Vector2 | v1,
 |  | Vector2 | v2,
 |  | float | length
 | ) |  | [static]

static function equivalent to MoveTo(Vector2, float)

引数:
v1 | vector 1
v2 | vector 2
length | step length
戻り値:
a new vector moved to target vector by specified length
static void MoveTo | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2,
 |  | float | length,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to MoveTo(ref Vector2, float, out Vector2)

引数:
v1 | vector 1
v2 | vector 2
length | step length
result | a new vector moved to target vector by specified length
static Vector2 Multiply | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

static function equivalent to Multiply(Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
v1 * v2
static void Multiply | ( | ref Vector2 | v,
 |  | float | f,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Multiply(float, out Vector2)

引数:
v | vector
f | scalar
result | v * f
static void Multiply | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Multiply(ref Vector2, out Vector2)

引数:
v1 | vector 1
v2 | vector 2
result | v1 * v2
Vector2 Multiply ( Vector2 v )

return this * v

引数:
v vector
戻り値:
this * v
static Vector2 Multiply | ( | Vector2 | v,
 |  | float | f
 | ) |  | [static]

static function equivalent to Multiply(float)

引数:
v | vector
f | scalar
戻り値:
v * f
void Multiply | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  |

result = this * v

引数:
v | vector
result | this * v
Vector2 Multiply ( float f )

return this * f

引数:
f scalar
戻り値:
this * f
void Multiply | ( | float | f,
 |  | out Vector2 | result
 | ) |  |

result = this * f

引数:
f | scalar
result | this * f
void Negate ( out Vector2 result )

result = -this

引数:
result -this
static Vector2 Negate ( Vector2 v ) [static]

static function equivalent to Negate()

引数:
v vector
戻り値:
-v
static void Negate | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Negate(out Vector2)

引数:
v | vector
result | -v
Vector2 Negate ( )

return -this

戻り値:
-this
Vector2 Normalize ( )

return this vector normalized

戻り値:
this vector normalized
static Vector2 Normalize ( Vector2 v ) [static]

static function equivalent to Normalize()

引数:
v vector
戻り値:
the vector normalized
static void Normalize | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Normalize(out Vector2)

引数:
v | vector
result | the vector normalized
void Normalize ( out Vector2 result )

return this vector normalized

引数:
result this vector normalized
static bool operator!= | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 != vector 2, false otherwise
static Vector2 operator* | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

multiplication operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
vector 1 * vector 2
static Vector2 operator* | ( | float | f,
 |  | Vector2 | v
 | ) |  | [static]

multiply each element of vector by scalar float

引数:
f | the scalar to multiply each element of the vector by
v | the vector to multiply
戻り値:
a new vector consisting of each element of vector multiplied by f
static Vector2 operator* | ( | Vector2 | v,
 |  | float | f
 | ) |  | [static]

multiply each element of vector by scalar float

引数:
v | the vector to multiply
f | the scalar to multiply each element of the vector by
戻り値:
a new vector consisting of each element of vector multiplied by f
static Vector2 operator+ | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

vector addition operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
vector 1 + vector 2
static Vector2 operator+ | ( | Vector2 | v,
 |  | float | f
 | ) |  | [static]

adds a scalar float to each element of a vector

引数:
v | the vector to add
f | the scalar float to add each element of the vector
戻り値:
a new vector with f added to each element of v
static Vector2 operator+ | ( | float | f,
 |  | Vector2 | v
 | ) |  | [static]

adds a scalar float to each element of a vector

引数:
f | the scalar float to add each element of the vector
v | the vector to add
戻り値:
a new vector with f added to each element of v
static Vector2 operator- | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

vector subtraction operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
vector 1 - vector 2
static Vector2 operator- | ( | Vector2 | v,
 |  | float | f
 | ) |  | [static]

subtract a scalar float from each element of a vector

引数:
v | the vector to subtract from
f | the scalar float to subtract from each element of the vector
戻り値:
a new vector with f subtracted from each element of v
static Vector2 operator- | ( | float | f,
 |  | Vector2 | v
 | ) |  | [static]

creates a new vector consisting of {f, f}, and then subtracts v from it

引数:
f | the scalar that we subtract v from
v | the vector to subtract
戻り値:
a new vector consisting of v subtracted from the vector {f, f}
static Vector2 operator- ( Vector2 v ) [static]

unary minus operator

引数:
v the vector to negate
戻り値:
unary minus applied to each member of v
static Vector2 operator/ | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

division operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
vector 1 / vector 2
static Vector2 operator/ | ( | Vector2 | v,
 |  | float | f
 | ) |  | [static]

divide each element of a vector by a scalar float

引数:
v | the vector to divide by scalar
f | the scalar to divide by
戻り値:
a new Vector2 consisting of each element of v divided by f
static Vector2 operator/ | ( | float | f,
 |  | Vector2 | v
 | ) |  | [static]

create a new vector consisting of {f, f} and divide it by vec

引数:
f | the scalar to divide by vector
v | the vector to divide by
戻り値:
a new vector {f, f} divided by v
static bool operator== | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
static Vector2 Perpendicular ( Vector2 v ) [static]

static function equivalent to Perpendicular()

引数:
v vector
戻り値:
a vector perpendicular to v
static void Perpendicular | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Perpendicular(out Vector2)

引数:
v | vector
result | a vector perpendicular to v
void Perpendicular ( out Vector2 result )

return this rotated by +pi/2

引数:
result return this rotated by +pi/2 (this is different from Vector3.Perpendicular)
Vector2 Perpendicular ( )

return a vector perpendicular to this

戻り値:
a vector perpendicular to this
static void ProjectOnLine | ( | ref Vector2 | v,
 |  | ref Vector2 | point,
 |  | ref Vector2 | direction,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to ProjectOnLine(ref Vector2, ref Vector2, out Vector2)

引数:
v | vector
point | point of the line to project onto
direction | direction of the line to project onto
result | projection of v onto the line (point,direction)
void ProjectOnLine | ( | ref Vector2 | point,
 |  | ref Vector2 | direction,
 |  | out Vector2 | result
 | ) |  |

project this onto the line (point,direction)

引数:
point | point of the line to project onto
direction | direction of the line to project onto
result | projection of this onto the line (point,direction)
Vector2 ProjectOnLine | ( | Vector2 | point,
 |  | Vector2 | direction
 | ) |  |

project this onto the line (point,direction)

引数:
point | point of the line to project onto
direction | direction of the line to project onto
戻り値:
projection of this onto the line (point,direction)
static Vector2 ProjectOnLine | ( | Vector2 | v,
 |  | Vector2 | point,
 |  | Vector2 | direction
 | ) |  | [static]

static function equivalent to ProjectOnLine(Vector2, Vector2)

引数:
v | vector
point | point of the line to project onto
direction | direction of the line to project onto
戻り値:
projection of v onto the line (point,direction)
static void Reflect | ( | ref Vector2 | v,
 |  | ref Vector2 | normal,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Reflect(ref Vector2, out Vector2)

引数:
v | vector
normal | the vector to reflect about
result | the vector reflected about normal
Vector2 Reflect ( Vector2 normal )

return this vector reflected about normal

引数:
normal the vector to reflect about
戻り値:
this vector reflected about normal
void Reflect | ( | ref Vector2 | normal,
 |  | out Vector2 | result
 | ) |  |

return this vector reflected about normal

引数:
normal | the vector to reflect about
result | this vector reflected about normal
static Vector2 Reflect | ( | Vector2 | v,
 |  | Vector2 | normal
 | ) |  | [static]

static function equivalent to Reflect(Vector2)

引数:
v | vector
normal | the vector to reflect about
戻り値:
the vector reflected about normal
Vector2 Repeat | ( | float | min,
 |  | float | max
 | ) |  |

element wise repeat

引数:
min | min value to repeat over
max | max value to repeat over
戻り値:
a new vector consisting of each element of this repeated between min and max
void Repeat | ( | ref Vector2 | min,
 |  | ref Vector2 | max,
 |  | out Vector2 | result
 | ) |  |

element wise repeat

引数:
min | min values to repeat over
max | max values to repeat over
result | a new vector consisting of each element of this repeated between min and max
Vector2 Repeat | ( | Vector2 | min,
 |  | Vector2 | max
 | ) |  |

element wise repeat

引数:
min | min values to repeat over
max | max values to repeat over
戻り値:
a new vector consisting of each element of this repeated between min and max
static Vector2 Repeat | ( | Vector2 | v,
 |  | float | min,
 |  | float | max
 | ) |  | [static]

static function equivalent to Repeat(float, float)

引数:
v | vector
min | min value to repeat over
max | max value to repeat over
戻り値:
a new vector consisting of each element of v repeated between min and max
static void Repeat | ( | ref Vector2 | v,
 |  | ref Vector2 | min,
 |  | ref Vector2 | max,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Repeat(ref Vector2, ref Vector2, out Vector2)

引数:
v | vector
min | min values to repeat over
max | max values to repeat over
result | a new vector consisting of each element of v repeated between min and max
static void Repeat | ( | ref Vector2 | v,
 |  | float | min,
 |  | float | max,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Repeat(float, float, out Vector2)

引数:
v | vector
min | min value to repeat over
max | max value to repeat over
result | a new vector consisting of each element of v repeated between min and max
static Vector2 Repeat | ( | Vector2 | v,
 |  | Vector2 | min,
 |  | Vector2 | max
 | ) |  | [static]

static function equivalent to Repeat(Vector2, Vector2)

引数:
v | vector
min | min values to repeat over
max | max values to repeat over
戻り値:
a new vector consisting of each element of v repeated between min and max
void Repeat | ( | float | min,
 |  | float | max,
 |  | out Vector2 | result
 | ) |  |

element wise repeat

引数:
min | min value to repeat over
max | max value to repeat over
result | a new vector consisting of each element of this repeated between min and max
static void Rotate | ( | ref Vector2 | v,
 |  | ref Vector2 | rotation,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Rotate(ref Vector2, out Vector2)

引数:
v | vector
rotation | a vector containing the cos and sin of the angle to rotate by
result | the vector rotated by angle
static Vector2 Rotate | ( | Vector2 | v,
 |  | Vector2 | rotation
 | ) |  | [static]

static function equivalent to Rotate(Vector2)

引数:
v | vector
rotation | a vector containing the cos and sin of the angle to rotate by
戻り値:
the vector rotated by angle
void Rotate | ( | ref Vector2 | rotation,
 |  | out Vector2 | result
 | ) |  |

return this vector rotated by angle

引数:
rotation | a vector containing the cos and sin of the angle to rotate by
result | this vector rotated by angle
Vector2 Rotate ( Vector2 rotation )

return this vector rotated by angle

引数:
rotation a vector containing the cos and sin of the angle to rotate by
戻り値:
this vector rotated by angle
Vector2 Rotate ( float angle )

return this vector rotated by angle

引数:
angle angle to rotate by
戻り値:
this vector rotated by angle
void Rotate | ( | float | angle,
 |  | out Vector2 | result
 | ) |  |

return this vector rotated by angle

引数:
angle | angle to rotate by
result | this vector rotated by angle
static Vector2 Rotate | ( | Vector2 | v,
 |  | float | angle
 | ) |  | [static]

static function equivalent to Rotate(float)

引数:
v | vector
angle | angle to rotate by
戻り値:
the vector rotated by angle
static void Rotate | ( | ref Vector2 | v,
 |  | float | angle,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Rotate(float, out Vector2)

引数:
v | vector
angle | angle to rotate by
result | the vector rotated by angle
static void Rotation | ( | float | angle,
 |  | out Vector2 | result
 | ) |  | [static]

return a new vector that breaks a rotation angle into its x and y components

引数:
angle | the rotation angle
result | a new vector that breaks a rotation angle into its x and y components
static Vector2 Rotation ( float angle ) [static]

return a new vector that breaks a rotation angle into its x and y components

引数:
angle the rotation angle
戻り値:
a new vector that breaks a rotation angle into its x and y components
static Vector2 Slerp | ( | Vector2 | v1,
 |  | Vector2 | v2,
 |  | float | f
 | ) |  | [static]

static function equivalent to Slerp(Vector2, float)

引数:
v1 | vector 1
v2 | vector 2
f | slerp amount
戻り値:
slerp between v1 and v2
static void Slerp | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2,
 |  | float | f,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Slerp(ref Vector2, float, out Vector2)

引数:
v1 | vector 1
v2 | vector 2
f | slerp amount
result | slerp between v1 and v2
Vector2 Slerp | ( | Vector2 | v,
 |  | float | f
 | ) |  |

slerp between this and the other vector

引数:
v | the other vector to slerp to
f | slerp amount
戻り値:
slerp between this and v
void Slerp | ( | ref Vector2 | v,
 |  | float | f,
 |  | out Vector2 | result
 | ) |  |

slerp between this and the other vector

引数:
v | the other vector to slerp to
f | slerp amount
result | slerp between this and v
static void Subtract | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to Subtract(ref Vector2, out Vector2)

引数:
v1 | vector 1
v2 | vector 2
result | v1 - v2
static Vector2 Subtract | ( | Vector2 | v1,
 |  | Vector2 | v2
 | ) |  | [static]

static function equivalent to Subtract(Vector2)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
v1 - v2
Vector2 Subtract ( Vector2 v )

return this - v

引数:
v vector
戻り値:
this - v
void Subtract | ( | ref Vector2 | v,
 |  | out Vector2 | result
 | ) |  |

result = this - v

引数:
v | vector
result | this - v
override string ToString ( )

convert vector to string

戻り値:
string representation of the vector
Vector2 TurnTo | ( | Vector2 | v,
 |  | float | angle
 | ) |  |

turn to target vector by specified angle

引数:
v | target vector
angle | step angle
戻り値:
a new vector turned to target vector by specified angle
static void TurnTo | ( | ref Vector2 | v1,
 |  | ref Vector2 | v2,
 |  | float | angle,
 |  | out Vector2 | result
 | ) |  | [static]

static function equivalent to TurnTo(ref Vector2, float, out Vector2)

引数:
v1 | vector 1
v2 | vector 2
angle | step angle
result | a new vector turned to target vector by specified angle
void TurnTo | ( | ref Vector2 | v,
 |  | float | angle,
 |  | out Vector2 | result
 | ) |  |

turn to target vector by specified angle

引数:
v | target vector
angle | step angle
result | a new vector turned to target vector by specified angle
static Vector2 TurnTo | ( | Vector2 | v1,
 |  | Vector2 | v2,
 |  | float | angle
 | ) |  | [static]

static function equivalent to TurnTo(Vector2, float)

引数:
v1 | vector 1
v2 | vector 2
angle | step angle
戻り値:
a new vector turned to target vector by specified angle

変数

readonly Vector2 One = new Vector2(1.0f, 1.0f) [static]

return a new vector with x and y set to 1 and 1

戻り値:
a new vector with x and y set to 1 and 1
readonly Vector2 UnitX = new Vector2(1.0f, 0.0f) [static]

return a new vector with x and y set to 1 and 0

戻り値:
a new vector with x and y set to 1 and 0
readonly Vector2 UnitY = new Vector2(0.0f, 1.0f) [static]

return a new vector with x and y set to 0 and 1

戻り値:
a new vector with x and y set to 0 and 1
float X

x

float Y

y

readonly Vector2 Zero = new Vector2(0.0f, 0.0f) [static]

return a new vector with x and y set to 0 and 0

戻り値:
a new vector with x and y set to 0 and 0

プロパティ

float G [get, set]

Green.

float R [get, set]

Red.

Vector2 Xx [get]

return a new vector consisting of the current vector's x, x values

戻り値:
a new vector consisting of the current vector's x, x values
Vector2 Xy [get, set]

return a new vector consisting of, or set, the current vector's x, y values

戻り値:
a new vector consisting of the current vector's x, y values
Vector3 Xy0 [get]

returns a 3 element vector consisting of the current vector with the z component set to 0

戻り値:
a 3 element vector consisting of the current vector with the z component set to 0
Vector4 Xy00 [get]

return a 4 element vector consisting of the current vector with the z and w components set to 0 and 0

戻り値:
a 4 element vector consisting of the current vector with the z and w components set to 0 and 0
Vector4 Xy01 [get]

return a 4 element vector consisting of the current vector with the z and w components set to 0 and 1

戻り値:
a 4 element vector consisting of the current vector with the z and w components set to 0 and 1
Vector3 Xy1 [get]

return a 3 element vector consisting of the current vector with the z component set to 1

戻り値:
a 3 element vector consisting of the current vector with the z component set to 1
Vector4 Xy10 [get]

return a 4 element vector consisting of the current vector with the z and w components set to 1 and 0

戻り値:
a 4 element vector consisting of the current vector with the z and w components set to 1 and 0
Vector4 Xy11 [get]

return a 4 element vector consisting of the current vector with the z and w components set to 1 and 1

戻り値:
a 4 element vector consisting of the current vector with the z and w components set to 1 and 1
Vector2 Yx [get, set]

return a new vector consisting of, or set, the current vector's y, x values

戻り値:
a new vector consisting of the current vector's y, x values
Vector2 Yy [get]

return a new vector consisting of the current vector's y, y values

戻り値:
a new vector consisting of the current vector's y, y values


構造体 Vector3

vector of 3 floats [詳細]

すべてのメンバ一覧

Public メソッド

Vector3 (float x, float y, float z)
constructor taking three floats
Vector3 (Vector2 xy, float z)
constructor taking a Vector2 and a float
Vector3 (float f)
constructor taking one float
float | Length ()
return the length of this vector
float | LengthSquared ()
return the length squared of this vector
float | Distance (Vector3 v)
get the distance between this and another vector
float | Distance (ref Vector3 v)
get the distance between this and another vector
float | DistanceSquared (Vector3 v)
get the distance squared between this and another vector
float | DistanceSquared (ref Vector3 v)
get the distance squared between this and another vector
float | Dot (Vector3 v)
dot product of this and v
float | Dot (ref Vector3 v)
dot product of this and v
Vector3 | Cross (Vector3 v)
cross product
void | Cross (ref Vector3 v, out Vector3 result)
cross product
Vector3 Normalize ()
return this vector normalized
void | Normalize (out Vector3 result)
return this vector normalized
Vector3 Abs ()
element wise absolute value
void | Abs (out Vector3 result)
element wise absolute value
Vector3 | Min (Vector3 v)
element wise min
void | Min (ref Vector3 v, out Vector3 result)
element wise min
Vector3 | Min (float f)
element wise min
void | Min (float f, out Vector3 result)
element wise min
Vector3 | Max (Vector3 v)
element wise max
void | Max (ref Vector3 v, out Vector3 result)
element wise max
Vector3 | Max (float f)
element wise max
void | Max (float f, out Vector3 result)
element wise max
Vector3 | Clamp (Vector3 min, Vector3 max)
element wise clamp
void | Clamp (ref Vector3 min, ref Vector3 max, out Vector3 result)
element wise clamp
Vector3 | Clamp (float min, float max)
element wise clamp
void | Clamp (float min, float max, out Vector3 result)
element wise clamp
Vector3 | Repeat (Vector3 min, Vector3 max)
element wise repeat
void | Repeat (ref Vector3 min, ref Vector3 max, out Vector3 result)
element wise repeat
Vector3 | Repeat (float min, float max)
element wise repeat
void | Repeat (float min, float max, out Vector3 result)
element wise repeat
Vector3 | Lerp (Vector3 v, float f)
lerp between this and the other vector
void | Lerp (ref Vector3 v, float f, out Vector3 result)
lerp between this and the other vector
Vector3 | Slerp (Vector3 v, float f)
slerp between this and the other vector
void | Slerp (ref Vector3 v, float f, out Vector3 result)
slerp between this and the other vector
Vector3 | MoveTo (Vector3 v, float length)
move to target vector by specified length
void | MoveTo (ref Vector3 v, float length, out Vector3 result)
move to target vector by specified length
Vector3 | TurnTo (Vector3 v, float angle)
turn to target vector by specified angle
void | TurnTo (ref Vector3 v, float angle, out Vector3 result)
turn to target vector by specified angle
float | Angle (Vector3 v)
get the angle between this and the input vector
float | Angle (ref Vector3 v)
get the angle between this and the input vector
Vector3 | RotateX (float angle)
rotate this around the x axis by an angle
void | RotateX (float angle, out Vector3 result)
rotate this around the x axis by an angle
Vector3 | RotateX (Vector2 rotation)
rotate this around the x axis by an angle
void | RotateX (ref Vector2 rotation, out Vector3 result)
rotate this around the x axis by an angle
Vector3 | RotateY (float angle)
rotate this around the y axis by an angle
void | RotateY (float angle, out Vector3 result)
rotate this around the y axis by an angle
Vector3 | RotateY (Vector2 rotation)
rotate this around the y axis by an angle
void | RotateY (ref Vector2 rotation, out Vector3 result)
rotate this around the y axis by an angle
Vector3 | RotateZ (float angle)
rotate this around the z axis by an angle
void | RotateZ (float angle, out Vector3 result)
rotate this around the z axis by an angle
Vector3 | RotateZ (Vector2 rotation)
rotate this around the z axis by an angle
void | RotateZ (ref Vector2 rotation, out Vector3 result)
rotate this around the z axis by an angle
Vector3 | Reflect (Vector3 normal)
return this vector reflected about normal
void | Reflect (ref Vector3 normal, out Vector3 result)
return this vector reflected about normal
Vector3 Perpendicular ()
return a vector perpendicular to this
void | Perpendicular (out Vector3 result)
return a vector perpendicular to this
Vector3 | ProjectOnLine (Vector3 point, Vector3 direction)
project this vector onto the line (point,direction)
void | ProjectOnLine (ref Vector3 point, ref Vector3 direction, out Vector3 result)
project this vector onto the line (point,direction)
Vector3 | Add (Vector3 v)
return this + v
void | Add (ref Vector3 v, out Vector3 result)
result = this + v
Vector3 | Subtract (Vector3 v)
return this - v
void | Subtract (ref Vector3 v, out Vector3 result)
result = this - v
Vector3 | Multiply (Vector3 v)
return this * v
void | Multiply (ref Vector3 v, out Vector3 result)
result = this * v
Vector3 | Multiply (float f)
return this * f
void | Multiply (float f, out Vector3 result)
result = this * f
Vector3 | Divide (Vector3 v)
return this / v
void | Divide (ref Vector3 v, out Vector3 result)
result = this / v
Vector3 | Divide (float f)
return this / f
void | Divide (float f, out Vector3 result)
result = this / f
Vector3 Negate ()
return -this
void | Negate (out Vector3 result)
result = -this
bool | IsUnit (float epsilon)
unit vector test
bool | IsZero ()
test if all elements of this are zero
bool | IsOne ()
test if all elements of this are one
bool | IsInfinity ()
test if any elements of this are Infinity
bool | IsNaN ()
test if any elements of this are NaN
bool | Equals (Vector3 v, float epsilon)
equality test with an epsilon
bool | Equals (Vector3 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
return the string representation of this
override int | GetHashCode ()
gets the hash code for this vector

Static Public メソッド

static float | Length (Vector3 v)
static function equivalent to Length()
static float | Length (ref Vector3 v)
static function equivalent to Length()
static float | LengthSquared (Vector3 v)
static function equivalent to LengthSquared()
static float | LengthSquared (ref Vector3 v)
static function equivalent to LengthSquared()
static float | Distance (Vector3 v1, Vector3 v2)
static function equivalent to Distance(Vector3)
static float | Distance (ref Vector3 v1, ref Vector3 v2)
static function equivalent to Distance(ref Vector3)
static float | DistanceSquared (Vector3 v1, Vector3 v2)
static function equivalent to DistanceSquared(Vector3)
static float | DistanceSquared (ref Vector3 v1, ref Vector3 v2)
static function equivalent to DistanceSquared(ref Vector3)
static float | Dot (Vector3 v1, Vector3 v2)
static function equivalent to Dot(Vector3)
static float | Dot (ref Vector3 v1, ref Vector3 v2)
static function equivalent to Dot(ref Vector3)
static Vector3 | Cross (Vector3 v1, Vector3 v2)
static function equivalent to Cross(Vector3)
static void | Cross (ref Vector3 v1, ref Vector3 v2, out Vector3 result)
static function equivalent to Cross(ref Vector3, out Vector3)
static Vector3 | Normalize (Vector3 v)
static function equivalent to Normalize()
static void | Normalize (ref Vector3 v, out Vector3 result)
static function equivalent to Normalize(out Vector3)
static Vector3 | Abs (Vector3 v)
static function equivalent to Abs()
static void | Abs (ref Vector3 v, out Vector3 result)
static function equivalent to Abs(out Vector3)
static Vector3 | Min (Vector3 v1, Vector3 v2)
static function equivalent to Min(Vector3)
static void | Min (ref Vector3 v1, ref Vector3 v2, out Vector3 result)
static function equivalent to Min(ref Vector3, out Vector3)
static Vector3 | Min (Vector3 v, float f)
static function equivalent to Min(float)
static void | Min (ref Vector3 v, float f, out Vector3 result)
static function equivalent to Min(float, out Vector3)
static Vector3 | Max (Vector3 v1, Vector3 v2)
static function equivalent to Max(Vector3)
static void | Max (ref Vector3 v1, ref Vector3 v2, out Vector3 result)
static function equivalent to Max(ref Vector3, out Vector3)
static Vector3 | Max (Vector3 v, float f)
static function equivalent to Max(float)
static void | Max (ref Vector3 v, float f, out Vector3 result)
static function equivalent to Max(float, out Vector3)
static Vector3 | Clamp (Vector3 v, Vector3 min, Vector3 max)
static function equivalent to Clamp(Vector3, Vector3)
static void | Clamp (ref Vector3 v, ref Vector3 min, ref Vector3 max, out Vector3 result)
static function equivalent to Clamp(ref Vector3, ref Vector3, out Vector3)
static Vector3 | Clamp (Vector3 v, float min, float max)
static function equivalent to Clamp(float, float)
static void | Clamp (ref Vector3 v, float min, float max, out Vector3 result)
static function equivalent to Clamp(float, float, out Vector3)
static Vector3 | Repeat (Vector3 v, Vector3 min, Vector3 max)
static function equivalent to Repeat(Vector3, Vector3)
static void | Repeat (ref Vector3 v, ref Vector3 min, ref Vector3 max, out Vector3 result)
static function equivalent to Repeat(ref Vector3, ref Vector3, out Vector3)
static Vector3 | Repeat (Vector3 v, float min, float max)
static function equivalent to Repeat(float, float)
static void | Repeat (ref Vector3 v, float min, float max, out Vector3 result)
static function equivalent to Repeat(float, float, out Vector3)
static Vector3 | Lerp (Vector3 v1, Vector3 v2, float f)
static function equivalent to Lerp(Vector3, float)
static void | Lerp (ref Vector3 v1, ref Vector3 v2, float f, out Vector3 result)
static function equivalent to Lerp(ref Vector3, float, out Vector3)
static Vector3 | Slerp (Vector3 v1, Vector3 v2, float f)
static function equivalent to Slerp(Vector3, float)
static void | Slerp (ref Vector3 v1, ref Vector3 v2, float f, out Vector3 result)
static function equivalent to Slerp(ref Vector3, float, out Vector3)
static Vector3 | MoveTo (Vector3 v1, Vector3 v2, float length)
static function equivalent to MoveTo(Vector3, float)
static void | MoveTo (ref Vector3 v1, ref Vector3 v2, float length, out Vector3 result)
static function equivalent to MoveTo(ref Vector3, float, out Vector3)
static Vector3 | TurnTo (Vector3 v1, Vector3 v2, float angle)
static function equivalent to TurnTo(Vector3, float)
static void | TurnTo (ref Vector3 v1, ref Vector3 v2, float angle, out Vector3 result)
static function equivalent to TurnTo(ref Vector3, float, out Vector3)
static float | Angle (Vector3 v1, Vector3 v2)
static function equivalent to Angle(Vector3)
static float | Angle (ref Vector3 v1, ref Vector3 v2)
static function equivalent to Angle(ref Vector3)
static Vector3 | RotateX (Vector3 v, float angle)
static function equivalent to RotateX(float)
static void | RotateX (ref Vector3 v, float angle, out Vector3 result)
static function equivalent to RotateX(float, out Vector3)
static Vector3 | RotateX (Vector3 v, Vector2 rotation)
static function equivalent to RotateX(Vector2)
static void | RotateX (ref Vector3 v, ref Vector2 rotation, out Vector3 result)
static function equivalent to RotateX(ref Vector2, out Vector3)
static Vector3 | RotateY (Vector3 v, float angle)
static function equivalent to RotateY(float)
static void | RotateY (ref Vector3 v, float angle, out Vector3 result)
static function equivalent to RotateY(float, out Vector3)
static Vector3 | RotateY (Vector3 v, Vector2 rotation)
static function equivalent to RotateY(Vector2)
static void | RotateY (ref Vector3 v, ref Vector2 rotation, out Vector3 result)
static function equivalent to RotateY(ref Vector2, out Vector3)
static Vector3 | RotateZ (Vector3 v, float angle)
static function equivalent to RotateZ(float)
static void | RotateZ (ref Vector3 v, float angle, out Vector3 result)
static function equivalent to RotateZ(float, out Vector3)
static Vector3 | RotateZ (Vector3 v, Vector2 rotation)
static function equivalent to RotateZ(Vector2)
static void | RotateZ (ref Vector3 v, ref Vector2 rotation, out Vector3 result)
static function equivalent to RotateZ(ref Vector2, out Vector3)
static Vector3 | Reflect (Vector3 v, Vector3 normal)
static function equivalent to Reflect(Vector3)
static void | Reflect (ref Vector3 v, ref Vector3 normal, out Vector3 result)
static function equivalent to Reflect(ref Vector3, out Vector3)
static Vector3 | Perpendicular (Vector3 v)
static function equivalent to Perpendicular()
static void | Perpendicular (ref Vector3 v, out Vector3 result)
static function equivalent to Perpendicular(out Vector3)
static Vector3 | ProjectOnLine (Vector3 v, Vector3 point, Vector3 direction)
static function equivalent to ProjectOnLine(Vector3, Vector3)
static void | ProjectOnLine (ref Vector3 v, ref Vector3 point, ref Vector3 direction, out Vector3 result)
static function equivalent to ProjectOnLine(ref Vector3, ref Vector3, out Vector3)
static Vector3 | Add (Vector3 v1, Vector3 v2)
static function equivalent to Add(Vector3)
static void | Add (ref Vector3 v1, ref Vector3 v2, out Vector3 result)
static function equivalent to Add(ref Vector3, out Vector3)
static Vector3 | Subtract (Vector3 v1, Vector3 v2)
static function equivalent to Subtract(Vector3)
static void | Subtract (ref Vector3 v1, ref Vector3 v2, out Vector3 result)
static function equivalent to Subtract(ref Vector3, out Vector3)
static Vector3 | Multiply (Vector3 v1, Vector3 v2)
static function equivalent to Multiply(Vector3)
static void | Multiply (ref Vector3 v1, ref Vector3 v2, out Vector3 result)
static function equivalent to Multiply(ref Vector3, out Vector3)
static Vector3 | Multiply (Vector3 v, float f)
static function equivalent to Multiply(float)
static void | Multiply (ref Vector3 v, float f, out Vector3 result)
static function equivalent to Multiply(float, out Vector3)
static Vector3 | Divide (Vector3 v1, Vector3 v2)
static function equivalent to Divide(Vector3)
static void | Divide (ref Vector3 v1, ref Vector3 v2, out Vector3 result)
static function equivalent to Divide(ref Vector3, out Vector3)
static Vector3 | Divide (Vector3 v, float f)
static function equivalent to Divide(float)
static void | Divide (ref Vector3 v, float f, out Vector3 result)
static function equivalent to Divide(float, out Vector3)
static Vector3 | Negate (Vector3 v)
static function equivalent to Negate()
static void | Negate (ref Vector3 v, out Vector3 result)
static function equivalent to Negate(out Vector3)
static bool | operator== (Vector3 v1, Vector3 v2)
equality operator
static bool | operator!= (Vector3 v1, Vector3 v2)
not equals operator
static Vector3 | operator+ (Vector3 v1, Vector3 v2)
vector addition operator
static Vector3 | operator+ (Vector3 v, float f)
adds a scalar float to each element of a vector
static Vector3 | operator+ (float f, Vector3 v)
adds a scalar float to each element of a vector
static Vector3 | operator- (Vector3 v1, Vector3 v2)
vector subtraction operator
static Vector3 | operator- (Vector3 v, float f)
subtract a scalar float from each element of a vector
static Vector3 | operator- (float f, Vector3 v)
creates a new vector consisting of {f, f, f}, and then subtracts v from it
static Vector3 | operator- (Vector3 v)
unary minus operator
static Vector3 | operator* (Vector3 v1, Vector3 v2)
multiplication operator
static Vector3 | operator* (Vector3 v, float f)
multiply each element of vector by scalar float
static Vector3 | operator* (float f, Vector3 v)
multiply each element of vector by scalar float
static Vector3 | operator/ (Vector3 v1, Vector3 v2)
division operator
static Vector3 | operator/ (Vector3 v, float f)
divide each element of a vector by a scalar float
static Vector3 | operator/ (float f, Vector3 v)
create a new vector consisting of {f, f, f} and divide it by vec

Public 変数

float | X
X.
float | Y
Y.
float | Z
Z.

Static Public 変数

static readonly Vector3 | Zero = new Vector3(0.0f, 0.0f, 0.0f)
return a vector of all zeros
static readonly Vector3 | One = new Vector3(1.0f, 1.0f, 1.0f)
return a vector of all ones
static readonly Vector3 | UnitX = new Vector3(1.0f, 0.0f, 0.0f)
return a Vector3 with the x component set to one, and all others set to zero
static readonly Vector3 | UnitY = new Vector3(0.0f, 1.0f, 0.0f)
return a Vector3 with the y component set to one, and all others set to zero
static readonly Vector3 | UnitZ = new Vector3(0.0f, 0.0f, 1.0f)
return a Vector3 with the z component set to one, and all others set to zero

プロパティ

float | R [get, set]
Red.
float | G [get, set]
Green.
float | B [get, set]
Blue.
Vector3 | Xxx [get]
Vector3 | Yxx [get]
Vector3 | Zxx [get]
Vector3 | Xyx [get]
Vector3 | Yyx [get]
Vector3 | Zyx [get, set]
Vector3 | Xzx [get]
Vector3 | Yzx [get, set]
Vector3 | Zzx [get]
Vector3 | Xxy [get]
Vector3 | Yxy [get]
Vector3 | Zxy [get, set]
Vector3 | Xyy [get]
Vector3 | Yyy [get]
Vector3 | Zyy [get]
Vector3 | Xzy [get, set]
Vector3 | Yzy [get]
Vector3 | Zzy [get]
Vector3 | Xxz [get]
Vector3 | Yxz [get, set]
Vector3 | Zxz [get]
Vector3 | Xyz [get, set]
Vector3 | Yyz [get]
Vector3 | Zyz [get]
Vector3 | Xzz [get]
Vector3 | Yzz [get]
Vector3 | Zzz [get]
Vector2 | Xx [get]
Vector2 | Yx [get, set]
Vector2 | Zx [get, set]
Vector2 | Xy [get, set]
Vector2 | Yy [get]
Vector2 | Zy [get, set]
Vector2 | Xz [get, set]
Vector2 | Yz [get, set]
Vector2 | Zz [get]
Vector4 | Xyz0 [get]
return a 4 element vector consisting of the current vector with the w component set to 0
Vector4 | Xyz1 [get]
return a 4 element vector consisting of the current vector with the w component set to 1

説明

vector of 3 floats

コンストラクタとデストラクタ

Vector3 | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  |

constructor taking three floats

引数:
x | x value to initialize with
y | y value to initialize with
z | z value to initialize with
Vector3 | ( | Vector2 | xy,
 |  | float | z
 | ) |  |

constructor taking a Vector2 and a float

引数:
xy | x and y values to initialize with
z | z value to initialize with
Vector3 ( float f )

constructor taking one float

引数:
f f

メソッド

Vector3 Abs ( )

element wise absolute value

戻り値:
element wise absolute value of this
void Abs ( out Vector3 result )

element wise absolute value

引数:
result element wise absolute value of this
static Vector3 Abs ( Vector3 v ) [static]

static function equivalent to Abs()

引数:
v vector
戻り値:
element wise absolute value of v
static void Abs | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Abs(out Vector3)

引数:
v | vector
result | element wise absolute value of v
static Vector3 Add | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

static function equivalent to Add(Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
v1 + v2
static void Add | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Add(ref Vector3, out Vector3)

引数:
v1 | vector 1
v2 | vector 2
result | v1 + v2
Vector3 Add ( Vector3 v )

return this + v

引数:
v vector
戻り値:
this + v
void Add | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  |

result = this + v

引数:
v | vector
result | this + v
float Angle ( Vector3 v )

get the angle between this and the input vector

引数:
v the vector to get the angle to
戻り値:
the angle between this and v
float Angle ( ref Vector3 v )

get the angle between this and the input vector

引数:
v the vector to get the angle to
戻り値:
the angle between this and v
static float Angle | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

static function equivalent to Angle(Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the angle between v1 and v2
static float Angle | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2
 | ) |  | [static]

static function equivalent to Angle(ref Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the angle between v1 and v2
Vector3 Clamp | ( | Vector3 | min,
 |  | Vector3 | max
 | ) |  |

element wise clamp

引数:
min | min values to clamp against
max | max values to clamp against
戻り値:
a new vector consisting of each element of this clamped between min and max
void Clamp | ( | ref Vector3 | min,
 |  | ref Vector3 | max,
 |  | out Vector3 | result
 | ) |  |

element wise clamp

引数:
min | min values to clamp against
max | max values to clamp against
result | a new vector consisting of each element of this clamped between min and max
Vector3 Clamp | ( | float | min,
 |  | float | max
 | ) |  |

element wise clamp

引数:
min | min value to clamp against
max | max value to clamp against
戻り値:
a new vector consisting of each element of this clamped between min and max
void Clamp | ( | float | min,
 |  | float | max,
 |  | out Vector3 | result
 | ) |  |

element wise clamp

引数:
min | min value to clamp against
max | max value to clamp against
result | a new vector consisting of each element of this clamped between min and max
static Vector3 Clamp | ( | Vector3 | v,
 |  | Vector3 | min,
 |  | Vector3 | max
 | ) |  | [static]

static function equivalent to Clamp(Vector3, Vector3)

引数:
v | vector
min | min values to clamp against
max | max values to clamp against
戻り値:
a new vector consisting of each element of v clamped between min and max
static void Clamp | ( | ref Vector3 | v,
 |  | ref Vector3 | min,
 |  | ref Vector3 | max,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Clamp(ref Vector3, ref Vector3, out Vector3)

引数:
v | vector
min | min values to clamp against
max | max values to clamp against
result | a new vector consisting of each element of v clamped between min and max
static Vector3 Clamp | ( | Vector3 | v,
 |  | float | min,
 |  | float | max
 | ) |  | [static]

static function equivalent to Clamp(float, float)

引数:
v | vector
min | min value to clamp against
max | max value to clamp against
戻り値:
a new vector consisting of each element of v clamped between min and max
static void Clamp | ( | ref Vector3 | v,
 |  | float | min,
 |  | float | max,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Clamp(float, float, out Vector3)

引数:
v | vector
min | min value to clamp against
max | max value to clamp against
result | a new vector consisting of each element of v clamped between min and max
void Cross | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  |

cross product

引数:
v | vector to take the cross product with
result | cross product of this and v
static Vector3 Cross | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

static function equivalent to Cross(Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
cross product of v1 and v2
static void Cross | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Cross(ref Vector3, out Vector3)

引数:
v1 | vector 1
v2 | vector 2
result | cross product of v1 and v2
Vector3 Cross ( Vector3 v )

cross product

引数:
v vector to take the cross product with
戻り値:
cross product of this and v
float Distance ( ref Vector3 v )

get the distance between this and another vector

引数:
v the vector to get the distance to
戻り値:
the distance bwteen this and the other vector
static float Distance | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

static function equivalent to Distance(Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the distance bwteen v1 and v2
static float Distance | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2
 | ) |  | [static]

static function equivalent to Distance(ref Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the distance bwteen v1 and v2
float Distance ( Vector3 v )

get the distance between this and another vector

引数:
v the vector to get the distance to
戻り値:
the distance bwteen this and the other vector
float DistanceSquared ( Vector3 v )

get the distance squared between this and another vector

引数:
v the vector to get the distance squared to
戻り値:
the distance between this and the other vector squared
static float DistanceSquared | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

static function equivalent to DistanceSquared(Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the distance between v1 and v2 squared
static float DistanceSquared | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2
 | ) |  | [static]

static function equivalent to DistanceSquared(ref Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the distance between v1 and v2 squared
float DistanceSquared ( ref Vector3 v )

get the distance squared between this and another vector

引数:
v the vector to get the distance squared to
戻り値:
the distance between this and the other vector squared
Vector3 Divide ( Vector3 v )

return this / v

引数:
v vector
戻り値:
this / v
Vector3 Divide ( float f )

return this / f

引数:
f scalar
戻り値:
this / f
void Divide | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  |

result = this / v

引数:
v | vector
result | this / v
void Divide | ( | float | f,
 |  | out Vector3 | result
 | ) |  |

result = this / f

引数:
f | scalar
result | this / f
static Vector3 Divide | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

static function equivalent to Divide(Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
v1 / v2
static void Divide | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Divide(ref Vector3, out Vector3)

引数:
v1 | vector 1
v2 | vector 2
result | v1 / v2
static Vector3 Divide | ( | Vector3 | v,
 |  | float | f
 | ) |  | [static]

static function equivalent to Divide(float)

引数:
v | vector
f | scalar
戻り値:
v / f
static void Divide | ( | ref Vector3 | v,
 |  | float | f,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Divide(float, out Vector3)

引数:
v | vector
f | scalar
result | v / f
float Dot ( ref Vector3 v )

dot product of this and v

引数:
v vector to take the dot product with
戻り値:
dot product of this and v
static float Dot | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

static function equivalent to Dot(Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
dot product of v1 and v2
static float Dot | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2
 | ) |  | [static]

static function equivalent to Dot(ref Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
dot product of v1 and v2
float Dot ( Vector3 v )

dot product of this and v

引数:
v vector to take the dot product with
戻り値:
dot product of this and v
bool Equals | ( | Vector3 | v,
 |  | float | epsilon
 | ) |  |

equality test with an epsilon

引数:
v | the vector to compare this to
epsilon | the epsilon to use in comparison
戻り値:
true if for every element n, abs(this[n] - v[n]) <= epsilon, false otherwise
bool Equals ( Vector3 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this vector

戻り値:
integer hash code
bool IsInfinity ( )

test if any elements of this are Infinity

戻り値:
true if any elements of this are Infinity, false otherwise
bool IsNaN ( )

test if any elements of this are NaN

戻り値:
true if any elements of this are NaN, false otherwise
bool IsOne ( )

test if all elements of this are one

戻り値:
true if all elements of this are one, false otherwise
bool IsUnit ( float epsilon )

unit vector test

引数:
epsilon epsilon used to test
戻り値:
true if the absolute value of the vector length minus one is <= epsilon, false otherwise
bool IsZero ( )

test if all elements of this are zero

戻り値:
true if all elements of this are zero, false otherwise
static float Length ( Vector3 v ) [static]

static function equivalent to Length()

引数:
v vector
戻り値:
the length of the vector
static float Length ( ref Vector3 v ) [static]

static function equivalent to Length()

引数:
v vector
戻り値:
the length of the vector
float Length ( )

return the length of this vector

戻り値:
the length of this vector
float LengthSquared ( )

return the length squared of this vector

戻り値:
the length squared of this vector
static float LengthSquared ( Vector3 v ) [static]

static function equivalent to LengthSquared()

引数:
v vector
戻り値:
the length squared of the vector
static float LengthSquared ( ref Vector3 v ) [static]

static function equivalent to LengthSquared()

引数:
v vector
戻り値:
the length squared of the vector
void Lerp | ( | ref Vector3 | v,
 |  | float | f,
 |  | out Vector3 | result
 | ) |  |

lerp between this and the other vector

引数:
v | the other vector to lerp to
f | lerp amount
result | a Vector3 where each element is the result of lerping f between the corresponding elements of this and other
static Vector3 Lerp | ( | Vector3 | v1,
 |  | Vector3 | v2,
 |  | float | f
 | ) |  | [static]

static function equivalent to Lerp(Vector3, float)

引数:
v1 | vector 1
v2 | vector 2
f | lerp amount
戻り値:
a Vector3 where each element is the result of lerping f between the corresponding elements of v1 and v2
static void Lerp | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2,
 |  | float | f,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Lerp(ref Vector3, float, out Vector3)

引数:
v1 | vector 1
v2 | vector 2
f | lerp amount
result | a Vector3 where each element is the result of lerping f between the corresponding elements of v1 and v2
Vector3 Lerp | ( | Vector3 | v,
 |  | float | f
 | ) |  |

lerp between this and the other vector

引数:
v | the other vector to lerp to
f | lerp amount
戻り値:
a Vector3 where each element is the result of lerping f between the corresponding elements of this and other
Vector3 Max ( Vector3 v )

element wise max

引数:
v vector to compare to this
戻り値:
the max of this and v
void Max | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  |

element wise max

引数:
v | vector to compare to this
result | the max of this and v
Vector3 Max ( float f )

element wise max

引数:
f scalar to compare to this
戻り値:
the max of this and f
void Max | ( | float | f,
 |  | out Vector3 | result
 | ) |  |

element wise max

引数:
f | scalar to compare to this
result | the max of this and f
static Vector3 Max | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

static function equivalent to Max(Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the max of v1 and v2
static void Max | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Max(ref Vector3, out Vector3)

引数:
v1 | vector 1
v2 | vector 2
result | the max of v1 and v2
static Vector3 Max | ( | Vector3 | v,
 |  | float | f
 | ) |  | [static]

static function equivalent to Max(float)

引数:
v | vector
f | scalar
戻り値:
the max of v and f
static void Max | ( | ref Vector3 | v,
 |  | float | f,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Max(float, out Vector3)

引数:
v | vector
f | scalar
result | the max of v and f
void Min | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  |

element wise min

引数:
v | vector to compare to this
result | the min of this and v
Vector3 Min ( float f )

element wise min

引数:
f scalar to compare to this
戻り値:
the min of this and f
void Min | ( | float | f,
 |  | out Vector3 | result
 | ) |  |

element wise min

引数:
f | scalar to compare to this
result | the min of this and f
static Vector3 Min | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

static function equivalent to Min(Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the min of v1 and v2
static void Min | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Min(ref Vector3, out Vector3)

引数:
v1 | vector 1
v2 | vector 2
result | the min of v1 and v2
static Vector3 Min | ( | Vector3 | v,
 |  | float | f
 | ) |  | [static]

static function equivalent to Min(float)

引数:
v | vector
f | scalar
戻り値:
the min of v and f
static void Min | ( | ref Vector3 | v,
 |  | float | f,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Min(float, out Vector3)

引数:
v | vector
f | scalar
result | the min of v and f
Vector3 Min ( Vector3 v )

element wise min

引数:
v vector to compare to this
戻り値:
the min of this and v
Vector3 MoveTo | ( | Vector3 | v,
 |  | float | length
 | ) |  |

move to target vector by specified length

引数:
v | target vector
length | step length
戻り値:
a new vector moved to target vector by specified length
void MoveTo | ( | ref Vector3 | v,
 |  | float | length,
 |  | out Vector3 | result
 | ) |  |

move to target vector by specified length

引数:
v | target vector
length | step length
result | a new vector moved to target vector by specified length
static Vector3 MoveTo | ( | Vector3 | v1,
 |  | Vector3 | v2,
 |  | float | length
 | ) |  | [static]

static function equivalent to MoveTo(Vector3, float)

引数:
v1 | vector 1
v2 | vector 2
length | step length
戻り値:
a new vector moved to target vector by specified length
static void MoveTo | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2,
 |  | float | length,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to MoveTo(ref Vector3, float, out Vector3)

引数:
v1 | vector 1
v2 | vector 2
length | step length
result | a new vector moved to target vector by specified length
void Multiply | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  |

result = this * v

引数:
v | vector
result | this * v
Vector3 Multiply ( float f )

return this * f

引数:
f scalar
戻り値:
this * f
void Multiply | ( | float | f,
 |  | out Vector3 | result
 | ) |  |

result = this * f

引数:
f | scalar
result | this * f
static void Multiply | ( | ref Vector3 | v,
 |  | float | f,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Multiply(float, out Vector3)

引数:
v | vector
f | scalar
result | v * f
static void Multiply | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Multiply(ref Vector3, out Vector3)

引数:
v1 | vector 1
v2 | vector 2
result | v1 * v2
static Vector3 Multiply | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

static function equivalent to Multiply(Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
v1 * v2
static Vector3 Multiply | ( | Vector3 | v,
 |  | float | f
 | ) |  | [static]

static function equivalent to Multiply(float)

引数:
v | vector
f | scalar
戻り値:
v * f
Vector3 Multiply ( Vector3 v )

return this * v

引数:
v vector
戻り値:
this * v
void Negate ( out Vector3 result )

result = -this

引数:
result -this
Vector3 Negate ( )

return -this

戻り値:
-this
static Vector3 Negate ( Vector3 v ) [static]

static function equivalent to Negate()

引数:
v vector
戻り値:
-v
static void Negate | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Negate(out Vector3)

引数:
v | vector
result | -v
Vector3 Normalize ( )

return this vector normalized

戻り値:
this vector normalized
static Vector3 Normalize ( Vector3 v ) [static]

static function equivalent to Normalize()

引数:
v vector
戻り値:
the vector normalized
void Normalize ( out Vector3 result )

return this vector normalized

引数:
result this vector normalized
static void Normalize | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Normalize(out Vector3)

引数:
v | vector
result | the vector normalized
static bool operator!= | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 != vector 2, false otherwise
static Vector3 operator* | ( | Vector3 | v,
 |  | float | f
 | ) |  | [static]

multiply each element of vector by scalar float

引数:
v | the vector to multiply
f | the scalar to multiply each element of the vector by
戻り値:
a new vector consisting of each element of vector multiplied by f
static Vector3 operator* | ( | float | f,
 |  | Vector3 | v
 | ) |  | [static]

multiply each element of vector by scalar float

引数:
f | the scalar to multiply each element of the vector by
v | the vector to multiply
戻り値:
a new vector consisting of each element of vector multiplied by f
static Vector3 operator* | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

multiplication operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
vector 1 * vector 2
static Vector3 operator+ | ( | float | f,
 |  | Vector3 | v
 | ) |  | [static]

adds a scalar float to each element of a vector

引数:
f | the scalar float to add each element of the vector
v | the vector to add
戻り値:
a new vector with f added to each element of v
static Vector3 operator+ | ( | Vector3 | v,
 |  | float | f
 | ) |  | [static]

adds a scalar float to each element of a vector

引数:
v | the vector to add
f | the scalar float to add each element of the vector
戻り値:
a new vector with f added to each element of v
static Vector3 operator+ | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

vector addition operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
vector 1 + vector 2
static Vector3 operator- | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

vector subtraction operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
vector 1 - vector 2
static Vector3 operator- | ( | float | f,
 |  | Vector3 | v
 | ) |  | [static]

creates a new vector consisting of {f, f, f}, and then subtracts v from it

引数:
f | the scalar that we subtract v from
v | the vector to subtract
戻り値:
a new vector consisting of v subtracted from the vector {f, f, f}
static Vector3 operator- | ( | Vector3 | v,
 |  | float | f
 | ) |  | [static]

subtract a scalar float from each element of a vector

引数:
v | the vector to subtract from
f | the scalar float to subtract from each element of the vector
戻り値:
a new vector with f subtracted from each element of v
static Vector3 operator- ( Vector3 v ) [static]

unary minus operator

引数:
v the vector to negate
戻り値:
unary minus applied to each member of v
static Vector3 operator/ | ( | float | f,
 |  | Vector3 | v
 | ) |  | [static]

create a new vector consisting of {f, f, f} and divide it by vec

引数:
f | the scalar to divide by vector
v | the vector to divide by
戻り値:
a new vector {f, f, f} divided by v
static Vector3 operator/ | ( | Vector3 | v,
 |  | float | f
 | ) |  | [static]

divide each element of a vector by a scalar float

引数:
v | the vector to divide by scalar
f | the scalar to divide by
戻り値:
a new Vector3 consisting of each element of v divided by f
static Vector3 operator/ | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

division operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
vector 1 / vector 2
static bool operator== | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
static Vector3 Perpendicular ( Vector3 v ) [static]

static function equivalent to Perpendicular()

引数:
v vector
戻り値:
a vector perpendicular to v
static void Perpendicular | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Perpendicular(out Vector3)

引数:
v | vector
result | a vector perpendicular to v
Vector3 Perpendicular ( )

return a vector perpendicular to this

戻り値:
a vector perpendicular to this
void Perpendicular ( out Vector3 result )

return a vector perpendicular to this

引数:
result a vector perpendicular to this
static void ProjectOnLine | ( | ref Vector3 | v,
 |  | ref Vector3 | point,
 |  | ref Vector3 | direction,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to ProjectOnLine(ref Vector3, ref Vector3, out Vector3)

引数:
v | vector
point | line start point
direction | line direction
result | the vector projected onto the line (point,direction)
Vector3 ProjectOnLine | ( | Vector3 | point,
 |  | Vector3 | direction
 | ) |  |

project this vector onto the line (point,direction)

引数:
point | line start point
direction | line direction
戻り値:
this vector projected onto the line (point,direction)
static Vector3 ProjectOnLine | ( | Vector3 | v,
 |  | Vector3 | point,
 |  | Vector3 | direction
 | ) |  | [static]

static function equivalent to ProjectOnLine(Vector3, Vector3)

引数:
v | vector
point | line start point
direction | line direction
戻り値:
the vector projected onto the line (point,direction)
void ProjectOnLine | ( | ref Vector3 | point,
 |  | ref Vector3 | direction,
 |  | out Vector3 | result
 | ) |  |

project this vector onto the line (point,direction)

引数:
point | line start point
direction | line direction
result | this vector projected onto the line (point,direction)
static Vector3 Reflect | ( | Vector3 | v,
 |  | Vector3 | normal
 | ) |  | [static]

static function equivalent to Reflect(Vector3)

引数:
v | vector
normal | the vector to reflect about
戻り値:
the vector reflected about normal
Vector3 Reflect ( Vector3 normal )

return this vector reflected about normal

引数:
normal the vector to reflect about
戻り値:
this vector reflected about normal
static void Reflect | ( | ref Vector3 | v,
 |  | ref Vector3 | normal,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Reflect(ref Vector3, out Vector3)

引数:
v | vector
normal | the vector to reflect about
result | the vector reflected about normal
void Reflect | ( | ref Vector3 | normal,
 |  | out Vector3 | result
 | ) |  |

return this vector reflected about normal

引数:
normal | the vector to reflect about
result | this vector reflected about normal
void Repeat | ( | ref Vector3 | min,
 |  | ref Vector3 | max,
 |  | out Vector3 | result
 | ) |  |

element wise repeat

引数:
min | min values to repeat over
max | max values to repeat over
result | a new vector consisting of each element of this repeated between min and max
static void Repeat | ( | ref Vector3 | v,
 |  | float | min,
 |  | float | max,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Repeat(float, float, out Vector3)

引数:
v | vector
min | min value to repeat over
max | max value to repeat over
result | a new vector consisting of each element of v repeated between min and max
static Vector3 Repeat | ( | Vector3 | v,
 |  | float | min,
 |  | float | max
 | ) |  | [static]

static function equivalent to Repeat(float, float)

引数:
v | vector
min | min value to repeat over
max | max value to repeat over
戻り値:
a new vector consisting of each element of v repeated between min and max
void Repeat | ( | float | min,
 |  | float | max,
 |  | out Vector3 | result
 | ) |  |

element wise repeat

引数:
min | min value to repeat over
max | max value to repeat over
result | a new vector consisting of each element of this repeated between min and max
Vector3 Repeat | ( | Vector3 | min,
 |  | Vector3 | max
 | ) |  |

element wise repeat

引数:
min | min values to repeat over
max | max values to repeat over
戻り値:
a new vector consisting of each element of this repeated between min and max
Vector3 Repeat | ( | float | min,
 |  | float | max
 | ) |  |

element wise repeat

引数:
min | min value to repeat over
max | max value to repeat over
戻り値:
a new vector consisting of each element of this repeated between min and max
static Vector3 Repeat | ( | Vector3 | v,
 |  | Vector3 | min,
 |  | Vector3 | max
 | ) |  | [static]

static function equivalent to Repeat(Vector3, Vector3)

引数:
v | vector
min | min values to repeat over
max | max values to repeat over
戻り値:
a new vector consisting of each element of v repeated between min and max
static void Repeat | ( | ref Vector3 | v,
 |  | ref Vector3 | min,
 |  | ref Vector3 | max,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Repeat(ref Vector3, ref Vector3, out Vector3)

引数:
v | vector
min | min values to repeat over
max | max values to repeat over
result | a new vector consisting of each element of v repeated between min and max
Vector3 RotateX ( Vector2 rotation )

rotate this around the x axis by an angle

引数:
rotation a vector containing the cos and sin of the angle to rotate by
戻り値:
the rotated vector
Vector3 RotateX ( float angle )

rotate this around the x axis by an angle

引数:
angle angle to rotate by
戻り値:
the rotated vector
void RotateX | ( | float | angle,
 |  | out Vector3 | result
 | ) |  |

rotate this around the x axis by an angle

引数:
angle | angle to rotate by
result | the rotated vector
void RotateX | ( | ref Vector2 | rotation,
 |  | out Vector3 | result
 | ) |  |

rotate this around the x axis by an angle

引数:
rotation | a vector containing the cos and sin of the angle to rotate by
result | the rotated vector
static void RotateX | ( | ref Vector3 | v,
 |  | float | angle,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to RotateX(float, out Vector3)

引数:
v | vector
angle | angle to rotate by
result | the rotated vector
static Vector3 RotateX | ( | Vector3 | v,
 |  | Vector2 | rotation
 | ) |  | [static]

static function equivalent to RotateX(Vector2)

引数:
v | vector
rotation | a vector containing the cos and sin of the angle to rotate by
戻り値:
the rotated vector
static void RotateX | ( | ref Vector3 | v,
 |  | ref Vector2 | rotation,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to RotateX(ref Vector2, out Vector3)

引数:
v | vector
rotation | a vector containing the cos and sin of the angle to rotate by
result | the rotated vector
static Vector3 RotateX | ( | Vector3 | v,
 |  | float | angle
 | ) |  | [static]

static function equivalent to RotateX(float)

引数:
v | vector
angle | angle to rotate by
戻り値:
the rotated vector
Vector3 RotateY ( Vector2 rotation )

rotate this around the y axis by an angle

引数:
rotation a vector containing the cos and sin of the angle to rotate by
戻り値:
the rotated vector
static void RotateY | ( | ref Vector3 | v,
 |  | ref Vector2 | rotation,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to RotateY(ref Vector2, out Vector3)

引数:
v | vector
rotation | a vector containing the cos and sin of the angle to rotate by
result | the rotated vector
void RotateY | ( | float | angle,
 |  | out Vector3 | result
 | ) |  |

rotate this around the y axis by an angle

引数:
angle | angle to rotate by
result | the rotated vector
Vector3 RotateY ( float angle )

rotate this around the y axis by an angle

引数:
angle angle to rotate by
戻り値:
the rotated vector
static Vector3 RotateY | ( | Vector3 | v,
 |  | float | angle
 | ) |  | [static]

static function equivalent to RotateY(float)

引数:
v | vector
angle | angle to rotate by
戻り値:
the rotated vector
void RotateY | ( | ref Vector2 | rotation,
 |  | out Vector3 | result
 | ) |  |

rotate this around the y axis by an angle

引数:
rotation | a vector containing the cos and sin of the angle to rotate by
result | the rotated vector
static void RotateY | ( | ref Vector3 | v,
 |  | float | angle,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to RotateY(float, out Vector3)

引数:
v | vector
angle | angle to rotate by
result | the rotated vector
static Vector3 RotateY | ( | Vector3 | v,
 |  | Vector2 | rotation
 | ) |  | [static]

static function equivalent to RotateY(Vector2)

引数:
v | vector
rotation | a vector containing the cos and sin of the angle to rotate by
戻り値:
the rotated vector
Vector3 RotateZ ( Vector2 rotation )

rotate this around the z axis by an angle

引数:
rotation a vector containing the cos and sin of the angle to rotate by
戻り値:
the rotated vector
static Vector3 RotateZ | ( | Vector3 | v,
 |  | Vector2 | rotation
 | ) |  | [static]

static function equivalent to RotateZ(Vector2)

引数:
v | vector
rotation | a vector containing the cos and sin of the angle to rotate by
戻り値:
the rotated vector
static void RotateZ | ( | ref Vector3 | v,
 |  | ref Vector2 | rotation,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to RotateZ(ref Vector2, out Vector3)

引数:
v | vector
rotation | a vector containing the cos and sin of the angle to rotate by
result | the rotated vector
static void RotateZ | ( | ref Vector3 | v,
 |  | float | angle,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to RotateZ(float, out Vector3)

引数:
v | vector
angle | angle to rotate by
result | the rotated vector
Vector3 RotateZ ( float angle )

rotate this around the z axis by an angle

引数:
angle angle to rotate by
戻り値:
the rotated vector
static Vector3 RotateZ | ( | Vector3 | v,
 |  | float | angle
 | ) |  | [static]

static function equivalent to RotateZ(float)

引数:
v | vector
angle | angle to rotate by
戻り値:
the rotated vector
void RotateZ | ( | ref Vector2 | rotation,
 |  | out Vector3 | result
 | ) |  |

rotate this around the z axis by an angle

引数:
rotation | a vector containing the cos and sin of the angle to rotate by
result | the rotated vector
void RotateZ | ( | float | angle,
 |  | out Vector3 | result
 | ) |  |

rotate this around the z axis by an angle

引数:
angle | angle to rotate by
result | the rotated vector
static Vector3 Slerp | ( | Vector3 | v1,
 |  | Vector3 | v2,
 |  | float | f
 | ) |  | [static]

static function equivalent to Slerp(Vector3, float)

引数:
v1 | vector 1
v2 | vector 2
f | slerp amount
戻り値:
slerp between v1 and v2
Vector3 Slerp | ( | Vector3 | v,
 |  | float | f
 | ) |  |

slerp between this and the other vector

引数:
v | the other vector to slerp to
f | slerp amount
戻り値:
slerp between this and v
void Slerp | ( | ref Vector3 | v,
 |  | float | f,
 |  | out Vector3 | result
 | ) |  |

slerp between this and the other vector

引数:
v | the other vector to slerp to
f | slerp amount
result | slerp between this and v
static void Slerp | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2,
 |  | float | f,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Slerp(ref Vector3, float, out Vector3)

引数:
v1 | vector 1
v2 | vector 2
f | slerp amount
result | slerp between v1 and v2
static void Subtract | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to Subtract(ref Vector3, out Vector3)

引数:
v1 | vector 1
v2 | vector 2
result | v1 - v2
void Subtract | ( | ref Vector3 | v,
 |  | out Vector3 | result
 | ) |  |

result = this - v

引数:
v | vector
result | this - v
Vector3 Subtract ( Vector3 v )

return this - v

引数:
v vector
戻り値:
this - v
static Vector3 Subtract | ( | Vector3 | v1,
 |  | Vector3 | v2
 | ) |  | [static]

static function equivalent to Subtract(Vector3)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
v1 - v2
override string ToString ( )

return the string representation of this

戻り値:
the string representation of this
static Vector3 TurnTo | ( | Vector3 | v1,
 |  | Vector3 | v2,
 |  | float | angle
 | ) |  | [static]

static function equivalent to TurnTo(Vector3, float)

引数:
v1 | vector 1
v2 | vector 2
angle | step angle
戻り値:
a new vector turned to target vector by specified angle
void TurnTo | ( | ref Vector3 | v,
 |  | float | angle,
 |  | out Vector3 | result
 | ) |  |

turn to target vector by specified angle

引数:
v | target vector
angle | step angle
result | a new vector turned to target vector by specified angle
static void TurnTo | ( | ref Vector3 | v1,
 |  | ref Vector3 | v2,
 |  | float | angle,
 |  | out Vector3 | result
 | ) |  | [static]

static function equivalent to TurnTo(ref Vector3, float, out Vector3)

引数:
v1 | vector 1
v2 | vector 2
angle | step angle
result | a new vector turned to target vector by specified angle
Vector3 TurnTo | ( | Vector3 | v,
 |  | float | angle
 | ) |  |

turn to target vector by specified angle

引数:
v | target vector
angle | step angle
戻り値:
a new vector turned to target vector by specified angle

変数

readonly Vector3 One = new Vector3(1.0f, 1.0f, 1.0f) [static]

return a vector of all ones

戻り値:
a vector of all ones
readonly Vector3 UnitX = new Vector3(1.0f, 0.0f, 0.0f) [static]

return a Vector3 with the x component set to one, and all others set to zero

戻り値:
a Vector3 with the x component set to one, and all others set to zero
readonly Vector3 UnitY = new Vector3(0.0f, 1.0f, 0.0f) [static]

return a Vector3 with the y component set to one, and all others set to zero

戻り値:
a Vector3 with the y component set to one, and all others set to zero
readonly Vector3 UnitZ = new Vector3(0.0f, 0.0f, 1.0f) [static]

return a Vector3 with the z component set to one, and all others set to zero

戻り値:
a Vector3 with the z component set to one, and all others set to zero
float X

X.

float Y

Y.

float Z

Z.

readonly Vector3 Zero = new Vector3(0.0f, 0.0f, 0.0f) [static]

return a vector of all zeros

戻り値:
a vector of all zeros

プロパティ

float B [get, set]

Blue.

float G [get, set]

Green.

float R [get, set]

Red.

Vector2 Xx [get]

return a new vector consisting of the current vector's x, x values

戻り値:
a new vector consisting of the current vector's x, x values
Vector3 Xxx [get]

return a new vector consisting of the current vector's x, x, x values

戻り値:
a new vector consisting of the current vector's x, x, x values
Vector3 Xxy [get]

return a new vector consisting of the current vector's x, x, y values

戻り値:
a new vector consisting of the current vector's x, x, y values
Vector3 Xxz [get]

return a new vector consisting of the current vector's x, x, z values

戻り値:
a new vector consisting of the current vector's x, x, z values
Vector2 Xy [get, set]

return a new vector consisting of, or set, the current vector's x, y values

戻り値:
a new vector consisting of the current vector's x, y values
Vector3 Xyx [get]

return a new vector consisting of the current vector's x, y, x values

戻り値:
a new vector consisting of the current vector's x, y, x values
Vector3 Xyy [get]

return a new vector consisting of the current vector's x, y, y values

戻り値:
a new vector consisting of the current vector's x, y, y values
Vector3 Xyz [get, set]

return a new vector consisting of, or set, the current vector's x, y, z values

戻り値:
a new vector consisting of the current vector's x, y, z values
Vector4 Xyz0 [get]

return a 4 element vector consisting of the current vector with the w component set to 0

戻り値:
a 4 element vector consisting of the current vector with the w component set to 0
Vector4 Xyz1 [get]

return a 4 element vector consisting of the current vector with the w component set to 1

戻り値:
a 4 element vector consisting of the current vector with the w component set to 1
Vector2 Xz [get, set]

return a new vector consisting of, or set, the current vector's x, z values

戻り値:
a new vector consisting of the current vector's x, z values
Vector3 Xzx [get]

return a new vector consisting of the current vector's x, z, x values

戻り値:
a new vector consisting of the current vector's x, z, x values
Vector3 Xzy [get, set]

return a new vector consisting of, or set, the current vector's x, z, y values

戻り値:
a new vector consisting of the current vector's x, z, y values
Vector3 Xzz [get]

return a new vector consisting of the current vector's x, z, z values

戻り値:
a new vector consisting of the current vector's x, z, z values
Vector2 Yx [get, set]

return a new vector consisting of, or set, the current vector's y, x values

戻り値:
a new vector consisting of the current vector's y, x values
Vector3 Yxx [get]

return a new vector consisting of the current vector's y, x, x values

戻り値:
a new vector consisting of the current vector's y, x, x values
Vector3 Yxy [get]

return a new vector consisting of the current vector's y, x, y values

戻り値:
a new vector consisting of the current vector's y, x, y values
Vector3 Yxz [get, set]

return a new vector consisting of, or set, the current vector's y, x, z values

戻り値:
a new vector consisting of the current vector's y, x, z values
Vector2 Yy [get]

return a new vector consisting of the current vector's y, y values

戻り値:
a new vector consisting of the current vector's y, y values
Vector3 Yyx [get]

return a new vector consisting of the current vector's y, y, x values

戻り値:
a new vector consisting of the current vector's y, y, x values
Vector3 Yyy [get]

return a new vector consisting of the current vector's y, y, y values

戻り値:
a new vector consisting of the current vector's y, y, y values
Vector3 Yyz [get]

return a new vector consisting of the current vector's y, y, z values

戻り値:
a new vector consisting of the current vector's y, y, z values
Vector2 Yz [get, set]

return a new vector consisting of, or set, the current vector's y, z values

戻り値:
a new vector consisting of the current vector's y, z values
Vector3 Yzx [get, set]

return a new vector consisting of, or set, the current vector's y, z, x values

戻り値:
a new vector consisting of the current vector's y, z, x values
Vector3 Yzy [get]

return a new vector consisting of the current vector's y, z, y values

戻り値:
a new vector consisting of the current vector's y, z, y values
Vector3 Yzz [get]

return a new vector consisting of the current vector's y, z, z values

戻り値:
a new vector consisting of the current vector's y, z, z values
Vector2 Zx [get, set]

return a new vector consisting of, or set, the current vector's z, x values

戻り値:
a new vector consisting of the current vector's z, x values
Vector3 Zxx [get]

return a new vector consisting of the current vector's z, x, x values

戻り値:
a new vector consisting of the current vector's z, x, x values
Vector3 Zxy [get, set]

return a new vector consisting of, or set, the current vector's z, x, y values

戻り値:
a new vector consisting of the current vector's z, x, y values
Vector3 Zxz [get]

return a new vector consisting of the current vector's z, x, z values

戻り値:
a new vector consisting of the current vector's z, x, z values
Vector2 Zy [get, set]

return a new vector consisting of, or set, the current vector's z, y values

戻り値:
a new vector consisting of the current vector's z, y values
Vector3 Zyx [get, set]

return a new vector consisting of, or set, the current vector's z, y, x values

戻り値:
a new vector consisting of the current vector's z, y, x values
Vector3 Zyy [get]

return a new vector consisting of the current vector's z, y, y values

戻り値:
a new vector consisting of the current vector's z, y, y values
Vector3 Zyz [get]

return a new vector consisting of the current vector's z, y, z values

戻り値:
a new vector consisting of the current vector's z, y, z values
Vector2 Zz [get]

return a new vector consisting of the current vector's z, z values

戻り値:
a new vector consisting of the current vector's z, z values
Vector3 Zzx [get]

return a new vector consisting of the current vector's z, z, x values

戻り値:
a new vector consisting of the current vector's z, z, x values
Vector3 Zzy [get]

return a new vector consisting of the current vector's z, z, y values

戻り値:
a new vector consisting of the current vector's z, z, y values
Vector3 Zzz [get]

return a new vector consisting of the current vector's z, z, z values

戻り値:
a new vector consisting of the current vector's z, z, z values


構造体 Vector4

vector of 4 floats [詳細]

すべてのメンバ一覧

Public メソッド

Vector4 (float x, float y, float z, float w)
constructor taking 4 scalar floats
Vector4 (Vector3 xyz, float w)
constructor taking a Vector3 and a scalar float
Vector4 (Vector2 xy, float z, float w)
constructor taking a Vector2 and two scalar floats
Vector4 (Vector2 xy, Vector2 zw)
constructor taking two Vector2s
Vector4 (float f)
constructor taking one float
float | Length ()
return the length of this vector
float | LengthSquared ()
return the length squared of this vector
float | Distance (Vector4 v)
get the distance between this and another vector
float | Distance (ref Vector4 v)
get the distance between this and another vector
float | DistanceSquared (Vector4 v)
get the distance squared between this and another vector
float | DistanceSquared (ref Vector4 v)
get the distance squared between this and another vector
float | Dot (Vector4 v)
dot product of this and v
float | Dot (ref Vector4 v)
dot product of this and v
Vector4 Normalize ()
return this vector normalized
void | Normalize (out Vector4 result)
return this vector normalized
Vector4 Abs ()
element wise absolute value
void | Abs (out Vector4 result)
element wise absolute value
Vector4 | Min (Vector4 v)
element wise min
void | Min (ref Vector4 v, out Vector4 result)
element wise min
Vector4 | Min (float f)
element wise min
void | Min (float f, out Vector4 result)
element wise min
Vector4 | Max (Vector4 v)
element wise max
void | Max (ref Vector4 v, out Vector4 result)
element wise max
Vector4 | Max (float f)
element wise max
void | Max (float f, out Vector4 result)
element wise max
Vector4 | Clamp (Vector4 min, Vector4 max)
element wise clamp
void | Clamp (ref Vector4 min, ref Vector4 max, out Vector4 result)
element wise clamp
Vector4 | Clamp (float min, float max)
element wise clamp
void | Clamp (float min, float max, out Vector4 result)
element wise clamp
Vector4 | Repeat (Vector4 min, Vector4 max)
element wise repeat
void | Repeat (ref Vector4 min, ref Vector4 max, out Vector4 result)
element wise repeat
Vector4 | Repeat (float min, float max)
element wise repeat
void | Repeat (float min, float max, out Vector4 result)
element wise repeat
Vector4 | Lerp (Vector4 v, float f)
lerp between this and the other vector
void | Lerp (ref Vector4 v, float f, out Vector4 result)
lerp between this and the other vector
Vector4 | MoveTo (Vector4 v, float length)
move to target vector by specified length
void | MoveTo (ref Vector4 v, float length, out Vector4 result)
move to target vector by specified length
Vector4 | Add (Vector4 v)
return this + v
void | Add (ref Vector4 v, out Vector4 result)
result = this + v
Vector4 | Subtract (Vector4 v)
return this - v
void | Subtract (ref Vector4 v, out Vector4 result)
result = this - v
Vector4 | Multiply (Vector4 v)
return this * v
void | Multiply (ref Vector4 v, out Vector4 result)
result = this * v
Vector4 | Multiply (float f)
return this * f
void | Multiply (float f, out Vector4 result)
result = this * f
Vector4 | Divide (Vector4 v)
return this / v
void | Divide (ref Vector4 v, out Vector4 result)
result = this / v
Vector4 | Divide (float f)
return this / f
void | Divide (float f, out Vector4 result)
result = this / f
Vector4 Negate ()
return -this
void | Negate (out Vector4 result)
result = -this
bool | IsUnit (float epsilon)
unit vector test
bool | IsZero ()
test if all elements of this are zero
bool | IsOne ()
test if all elements of this are one
bool | IsInfinity ()
test if any elements of this are Infinity
bool | IsNaN ()
test if any elements of this are NaN
bool | Equals (Vector4 v, float epsilon)
equality test with an epsilon
bool | Equals (Vector4 v)
equality test
override bool | Equals (Object o)
equality test
override string | ToString ()
get the string representation of this vector
override int | GetHashCode ()
gets the hash code for this vector

Static Public メソッド

static float | Length (Vector4 v)
static function equivalent to Length()
static float | Length (ref Vector4 v)
static function equivalent to Length()
static float | LengthSquared (Vector4 v)
static function equivalent to LengthSquared()
static float | LengthSquared (ref Vector4 v)
static function equivalent to LengthSquared()
static float | Distance (Vector4 v1, Vector4 v2)
static function equivalent to Distance(Vector4)
static float | Distance (ref Vector4 v1, ref Vector4 v2)
static function equivalent to Distance(ref Vector4)
static float | DistanceSquared (Vector4 v1, Vector4 v2)
static function equivalent to DistanceSquared(Vector4)
static float | DistanceSquared (ref Vector4 v1, ref Vector4 v2)
static function equivalent to DistanceSquared(ref Vector4)
static float | Dot (Vector4 v1, Vector4 v2)
static function equivalent to Dot(Vector4)
static float | Dot (ref Vector4 v1, ref Vector4 v2)
static function equivalent to Dot(ref Vector4)
static Vector4 | Normalize (Vector4 v)
static function equivalent to Normalize()
static void | Normalize (ref Vector4 v, out Vector4 result)
static function equivalent to Normalize(out Vector4)
static Vector4 | Abs (Vector4 v)
static function equivalent to Abs()
static void | Abs (ref Vector4 v, out Vector4 result)
static function equivalent to Abs(out Vector4)
static Vector4 | Min (Vector4 v1, Vector4 v2)
static function equivalent to Min(Vector4)
static void | Min (ref Vector4 v1, ref Vector4 v2, out Vector4 result)
static function equivalent to Min(ref Vector4, out Vector4)
static Vector4 | Min (Vector4 v, float f)
static function equivalent to Min(float)
static void | Min (ref Vector4 v, float f, out Vector4 result)
static function equivalent to Min(float, out Vector4)
static Vector4 | Max (Vector4 v1, Vector4 v2)
static function equivalent to Max(Vector4)
static void | Max (ref Vector4 v1, ref Vector4 v2, out Vector4 result)
static function equivalent to Max(ref Vector4, out Vector4)
static Vector4 | Max (Vector4 v, float f)
static function equivalent to Max(float)
static void | Max (ref Vector4 v, float f, out Vector4 result)
static function equivalent to Max(float, out Vector4)
static Vector4 | Clamp (Vector4 v, Vector4 min, Vector4 max)
static function equivalent to Clamp(Vector4, Vector4)
static void | Clamp (ref Vector4 v, ref Vector4 min, ref Vector4 max, out Vector4 result)
static function equivalent to Clamp(ref Vector4, ref Vector4, out Vector4)
static Vector4 | Clamp (Vector4 v, float min, float max)
static function equivalent to Clamp(float, float)
static void | Clamp (ref Vector4 v, float min, float max, out Vector4 result)
static function equivalent to Clamp(float, float, out Vector4)
static Vector4 | Repeat (Vector4 v, Vector4 min, Vector4 max)
static function equivalent to Repeat(Vector4, Vector4)
static void | Repeat (ref Vector4 v, ref Vector4 min, ref Vector4 max, out Vector4 result)
static function equivalent to Repeat(ref Vector4, ref Vector4, out Vector4)
static Vector4 | Repeat (Vector4 v, float min, float max)
static function equivalent to Repeat(float, float)
static void | Repeat (ref Vector4 v, float min, float max, out Vector4 result)
static function equivalent to Repeat(float, float, out Vector4)
static Vector4 | Lerp (Vector4 v1, Vector4 v2, float f)
static function equivalent to Lerp(Vector4, float)
static void | Lerp (ref Vector4 v1, ref Vector4 v2, float f, out Vector4 result)
static function equivalent to Lerp(ref Vector4, float, out Vector4)
static Vector4 | MoveTo (Vector4 v1, Vector4 v2, float length)
static function equivalent to MoveTo(Vector4, float)
static void | MoveTo (ref Vector4 v1, ref Vector4 v2, float length, out Vector4 result)
static function equivalent to MoveTo(ref Vector4, float, out Vector4)
static Vector4 | Add (Vector4 v1, Vector4 v2)
static function equivalent to Add(Vector4)
static void | Add (ref Vector4 v1, ref Vector4 v2, out Vector4 result)
static function equivalent to Add(ref Vector4, out Vector4)
static Vector4 | Subtract (Vector4 v1, Vector4 v2)
static function equivalent to Subtract(Vector4)
static void | Subtract (ref Vector4 v1, ref Vector4 v2, out Vector4 result)
static function equivalent to Subtract(ref Vector4, out Vector4)
static Vector4 | Multiply (Vector4 v1, Vector4 v2)
static function equivalent to Multiply(Vector4)
static void | Multiply (ref Vector4 v1, ref Vector4 v2, out Vector4 result)
static function equivalent to Multiply(ref Vector4, out Vector4)
static Vector4 | Multiply (Vector4 v, float f)
static function equivalent to Multiply(float)
static void | Multiply (ref Vector4 v, float f, out Vector4 result)
static function equivalent to Multiply(float, out Vector4)
static Vector4 | Divide (Vector4 v1, Vector4 v2)
static function equivalent to Divide(Vector4)
static void | Divide (ref Vector4 v1, ref Vector4 v2, out Vector4 result)
static function equivalent to Divide(ref Vector4, out Vector4)
static Vector4 | Divide (Vector4 v, float f)
static function equivalent to Divide(float)
static void | Divide (ref Vector4 v, float f, out Vector4 result)
static function equivalent to Divide(float, out Vector4)
static Vector4 | Negate (Vector4 v)
static function equivalent to Negate()
static void | Negate (ref Vector4 v, out Vector4 result)
static function equivalent to Negate(out Vector4)
static bool | operator== (Vector4 v1, Vector4 v2)
equality operator
static bool | operator!= (Vector4 v1, Vector4 v2)
not equals operator
static Vector4 | operator+ (Vector4 v1, Vector4 v2)
vector addition operator
static Vector4 | operator+ (Vector4 v, float f)
adds a scalar float to each element of a vector
static Vector4 | operator+ (float f, Vector4 v)
adds a scalar float to each element of a vector
static Vector4 | operator- (Vector4 v1, Vector4 v2)
vector subtraction operator
static Vector4 | operator- (Vector4 v, float f)
subtract a scalar float from each element of a vector
static Vector4 | operator- (float f, Vector4 v)
creates a new vector consisting of {f, f, f, f}, and then subtracts v from it
static Vector4 | operator- (Vector4 v)
unary minus operator
static Vector4 | operator* (Vector4 v1, Vector4 v2)
multiplication operator
static Vector4 | operator* (Vector4 v, float f)
multiply each element of vector by scalar float
static Vector4 | operator* (float f, Vector4 v)
multiply each element of vector by scalar float
static Vector4 | operator/ (Vector4 v1, Vector4 v2)
division operator
static Vector4 | operator/ (Vector4 v, float f)
divide each element of a vector by a scalar float
static Vector4 | operator/ (float f, Vector4 v)
create a new vector consisting of {f, f, f, f} and divide it by vec

Public 変数

float | X
X.
float | Y
Y.
float | Z
Z.
float | W
W.

Static Public 変数

static readonly Vector4 | Zero = new Vector4(0.0f, 0.0f, 0.0f, 0.0f)
return a new vector of all zeros
static readonly Vector4 | One = new Vector4(1.0f, 1.0f, 1.0f, 1.0f)
return a new vector of all ones
static readonly Vector4 | UnitX = new Vector4(1.0f, 0.0f, 0.0f, 0.0f)
return a new vector of all zeros with only the x value set to one
static readonly Vector4 | UnitY = new Vector4(0.0f, 1.0f, 0.0f, 0.0f)
return a new vector of all zeros with only the y value set to one
static readonly Vector4 | UnitZ = new Vector4(0.0f, 0.0f, 1.0f, 0.0f)
return a new vector of all zeros with only the z value set to one
static readonly Vector4 | UnitW = new Vector4(0.0f, 0.0f, 0.0f, 1.0f)
return a new vector of all zeros with only the w value set to one

プロパティ

float | R [get, set]
Red.
float | G [get, set]
Green.
float | B [get, set]
Blue.
float | A [get, set]
Alpha.
Vector4 | Xxxx [get]
Vector4 | Yxxx [get]
Vector4 | Zxxx [get]
Vector4 | Wxxx [get]
Vector4 | Xyxx [get]
Vector4 | Yyxx [get]
Vector4 | Zyxx [get]
Vector4 | Wyxx [get]
Vector4 | Xzxx [get]
Vector4 | Yzxx [get]
Vector4 | Zzxx [get]
Vector4 | Wzxx [get]
Vector4 | Xwxx [get]
Vector4 | Ywxx [get]
Vector4 | Zwxx [get]
Vector4 | Wwxx [get]
Vector4 | Xxyx [get]
Vector4 | Yxyx [get]
Vector4 | Zxyx [get]
Vector4 | Wxyx [get]
Vector4 | Xyyx [get]
Vector4 | Yyyx [get]
Vector4 | Zyyx [get]
Vector4 | Wyyx [get]
Vector4 | Xzyx [get]
Vector4 | Yzyx [get]
Vector4 | Zzyx [get]
Vector4 | Wzyx [get, set]
Vector4 | Xwyx [get]
Vector4 | Ywyx [get]
Vector4 | Zwyx [get, set]
Vector4 | Wwyx [get]
Vector4 | Xxzx [get]
Vector4 | Yxzx [get]
Vector4 | Zxzx [get]
Vector4 | Wxzx [get]
Vector4 | Xyzx [get]
Vector4 | Yyzx [get]
Vector4 | Zyzx [get]
Vector4 | Wyzx [get, set]
Vector4 | Xzzx [get]
Vector4 | Yzzx [get]
Vector4 | Zzzx [get]
Vector4 | Wzzx [get]
Vector4 | Xwzx [get]
Vector4 | Ywzx [get, set]
Vector4 | Zwzx [get]
Vector4 | Wwzx [get]
Vector4 | Xxwx [get]
Vector4 | Yxwx [get]
Vector4 | Zxwx [get]
Vector4 | Wxwx [get]
Vector4 | Xywx [get]
Vector4 | Yywx [get]
Vector4 | Zywx [get, set]
Vector4 | Wywx [get]
Vector4 | Xzwx [get]
Vector4 | Yzwx [get, set]
Vector4 | Zzwx [get]
Vector4 | Wzwx [get]
Vector4 | Xwwx [get]
Vector4 | Ywwx [get]
Vector4 | Zwwx [get]
Vector4 | Wwwx [get]
Vector4 | Xxxy [get]
Vector4 | Yxxy [get]
Vector4 | Zxxy [get]
Vector4 | Wxxy [get]
Vector4 | Xyxy [get]
Vector4 | Yyxy [get]
Vector4 | Zyxy [get]
Vector4 | Wyxy [get]
Vector4 | Xzxy [get]
Vector4 | Yzxy [get]
Vector4 | Zzxy [get]
Vector4 | Wzxy [get, set]
Vector4 | Xwxy [get]
Vector4 | Ywxy [get]
Vector4 | Zwxy [get, set]
Vector4 | Wwxy [get]
Vector4 | Xxyy [get]
Vector4 | Yxyy [get]
Vector4 | Zxyy [get]
Vector4 | Wxyy [get]
Vector4 | Xyyy [get]
Vector4 | Yyyy [get]
Vector4 | Zyyy [get]
Vector4 | Wyyy [get]
Vector4 | Xzyy [get]
Vector4 | Yzyy [get]
Vector4 | Zzyy [get]
Vector4 | Wzyy [get]
Vector4 | Xwyy [get]
Vector4 | Ywyy [get]
Vector4 | Zwyy [get]
Vector4 | Wwyy [get]
Vector4 | Xxzy [get]
Vector4 | Yxzy [get]
Vector4 | Zxzy [get]
Vector4 | Wxzy [get, set]
Vector4 | Xyzy [get]
Vector4 | Yyzy [get]
Vector4 | Zyzy [get]
Vector4 | Wyzy [get]
Vector4 | Xzzy [get]
Vector4 | Yzzy [get]
Vector4 | Zzzy [get]
Vector4 | Wzzy [get]
Vector4 | Xwzy [get, set]
Vector4 | Ywzy [get]
Vector4 | Zwzy [get]
Vector4 | Wwzy [get]
Vector4 | Xxwy [get]
Vector4 | Yxwy [get]
Vector4 | Zxwy [get, set]
Vector4 | Wxwy [get]
Vector4 | Xywy [get]
Vector4 | Yywy [get]
Vector4 | Zywy [get]
Vector4 | Wywy [get]
Vector4 | Xzwy [get, set]
Vector4 | Yzwy [get]
Vector4 | Zzwy [get]
Vector4 | Wzwy [get]
Vector4 | Xwwy [get]
Vector4 | Ywwy [get]
Vector4 | Zwwy [get]
Vector4 | Wwwy [get]
Vector4 | Xxxz [get]
Vector4 | Yxxz [get]
Vector4 | Zxxz [get]
Vector4 | Wxxz [get]
Vector4 | Xyxz [get]
Vector4 | Yyxz [get]
Vector4 | Zyxz [get]
Vector4 | Wyxz [get, set]
Vector4 | Xzxz [get]
Vector4 | Yzxz [get]
Vector4 | Zzxz [get]
Vector4 | Wzxz [get]
Vector4 | Xwxz [get]
Vector4 | Ywxz [get, set]
Vector4 | Zwxz [get]
Vector4 | Wwxz [get]
Vector4 | Xxyz [get]
Vector4 | Yxyz [get]
Vector4 | Zxyz [get]
Vector4 | Wxyz [get, set]
Vector4 | Xyyz [get]
Vector4 | Yyyz [get]
Vector4 | Zyyz [get]
Vector4 | Wyyz [get]
Vector4 | Xzyz [get]
Vector4 | Yzyz [get]
Vector4 | Zzyz [get]
Vector4 | Wzyz [get]
Vector4 | Xwyz [get, set]
Vector4 | Ywyz [get]
Vector4 | Zwyz [get]
Vector4 | Wwyz [get]
Vector4 | Xxzz [get]
Vector4 | Yxzz [get]
Vector4 | Zxzz [get]
Vector4 | Wxzz [get]
Vector4 | Xyzz [get]
Vector4 | Yyzz [get]
Vector4 | Zyzz [get]
Vector4 | Wyzz [get]
Vector4 | Xzzz [get]
Vector4 | Yzzz [get]
Vector4 | Zzzz [get]
Vector4 | Wzzz [get]
Vector4 | Xwzz [get]
Vector4 | Ywzz [get]
Vector4 | Zwzz [get]
Vector4 | Wwzz [get]
Vector4 | Xxwz [get]
Vector4 | Yxwz [get, set]
Vector4 | Zxwz [get]
Vector4 | Wxwz [get]
Vector4 | Xywz [get, set]
Vector4 | Yywz [get]
Vector4 | Zywz [get]
Vector4 | Wywz [get]
Vector4 | Xzwz [get]
Vector4 | Yzwz [get]
Vector4 | Zzwz [get]
Vector4 | Wzwz [get]
Vector4 | Xwwz [get]
Vector4 | Ywwz [get]
Vector4 | Zwwz [get]
Vector4 | Wwwz [get]
Vector4 | Xxxw [get]
Vector4 | Yxxw [get]
Vector4 | Zxxw [get]
Vector4 | Wxxw [get]
Vector4 | Xyxw [get]
Vector4 | Yyxw [get]
Vector4 | Zyxw [get, set]
Vector4 | Wyxw [get]
Vector4 | Xzxw [get]
Vector4 | Yzxw [get, set]
Vector4 | Zzxw [get]
Vector4 | Wzxw [get]
Vector4 | Xwxw [get]
Vector4 | Ywxw [get]
Vector4 | Zwxw [get]
Vector4 | Wwxw [get]
Vector4 | Xxyw [get]
Vector4 | Yxyw [get]
Vector4 | Zxyw [get, set]
Vector4 | Wxyw [get]
Vector4 | Xyyw [get]
Vector4 | Yyyw [get]
Vector4 | Zyyw [get]
Vector4 | Wyyw [get]
Vector4 | Xzyw [get, set]
Vector4 | Yzyw [get]
Vector4 | Zzyw [get]
Vector4 | Wzyw [get]
Vector4 | Xwyw [get]
Vector4 | Ywyw [get]
Vector4 | Zwyw [get]
Vector4 | Wwyw [get]
Vector4 | Xxzw [get]
Vector4 | Yxzw [get, set]
Vector4 | Zxzw [get]
Vector4 | Wxzw [get]
Vector4 | Xyzw [get, set]
Vector4 | Yyzw [get]
Vector4 | Zyzw [get]
Vector4 | Wyzw [get]
Vector4 | Xzzw [get]
Vector4 | Yzzw [get]
Vector4 | Zzzw [get]
Vector4 | Wzzw [get]
Vector4 | Xwzw [get]
Vector4 | Ywzw [get]
Vector4 | Zwzw [get]
Vector4 | Wwzw [get]
Vector4 | Xxww [get]
Vector4 | Yxww [get]
Vector4 | Zxww [get]
Vector4 | Wxww [get]
Vector4 | Xyww [get]
Vector4 | Yyww [get]
Vector4 | Zyww [get]
Vector4 | Wyww [get]
Vector4 | Xzww [get]
Vector4 | Yzww [get]
Vector4 | Zzww [get]
Vector4 | Wzww [get]
Vector4 | Xwww [get]
Vector4 | Ywww [get]
Vector4 | Zwww [get]
Vector4 | Wwww [get]
Vector3 | Xxx [get]
Vector3 | Yxx [get]
Vector3 | Zxx [get]
Vector3 | Wxx [get]
Vector3 | Xyx [get]
Vector3 | Yyx [get]
Vector3 | Zyx [get, set]
Vector3 | Wyx [get, set]
Vector3 | Xzx [get]
Vector3 | Yzx [get, set]
Vector3 | Zzx [get]
Vector3 | Wzx [get, set]
Vector3 | Xwx [get]
Vector3 | Ywx [get, set]
Vector3 | Zwx [get, set]
Vector3 | Wwx [get]
Vector3 | Xxy [get]
Vector3 | Yxy [get]
Vector3 | Zxy [get, set]
Vector3 | Wxy [get, set]
Vector3 | Xyy [get]
Vector3 | Yyy [get]
Vector3 | Zyy [get]
Vector3 | Wyy [get]
Vector3 | Xzy [get, set]
Vector3 | Yzy [get]
Vector3 | Zzy [get]
Vector3 | Wzy [get, set]
Vector3 | Xwy [get, set]
Vector3 | Ywy [get]
Vector3 | Zwy [get, set]
Vector3 | Wwy [get]
Vector3 | Xxz [get]
Vector3 | Yxz [get, set]
Vector3 | Zxz [get]
Vector3 | Wxz [get, set]
Vector3 | Xyz [get, set]
Vector3 | Yyz [get]
Vector3 | Zyz [get]
Vector3 | Wyz [get, set]
Vector3 | Xzz [get]
Vector3 | Yzz [get]
Vector3 | Zzz [get]
Vector3 | Wzz [get]
Vector3 | Xwz [get, set]
Vector3 | Ywz [get, set]
Vector3 | Zwz [get]
Vector3 | Wwz [get]
Vector3 | Xxw [get]
Vector3 | Yxw [get, set]
Vector3 | Zxw [get, set]
Vector3 | Wxw [get]
Vector3 | Xyw [get, set]
Vector3 | Yyw [get]
Vector3 | Zyw [get, set]
Vector3 | Wyw [get]
Vector3 | Xzw [get, set]
Vector3 | Yzw [get, set]
Vector3 | Zzw [get]
Vector3 | Wzw [get]
Vector3 | Xww [get]
Vector3 | Yww [get]
Vector3 | Zww [get]
Vector3 | Www [get]
Vector2 | Xx [get]
Vector2 | Yx [get, set]
Vector2 | Zx [get, set]
Vector2 | Wx [get, set]
Vector2 | Xy [get, set]
Vector2 | Yy [get]
Vector2 | Zy [get, set]
Vector2 | Wy [get, set]
Vector2 | Xz [get, set]
Vector2 | Yz [get, set]
Vector2 | Zz [get]
Vector2 | Wz [get, set]
Vector2 | Xw [get, set]
Vector2 | Yw [get, set]
Vector2 | Zw [get, set]
Vector2 | Ww [get]
Vector4 | Xyz0 [get]
return a 4 element vector consisting of the current vector with the w component set to 0
Vector4 | Xyz1 [get]
return a 4 element vector consisting of the current vector with the w component set to 1

説明

vector of 4 floats

コンストラクタとデストラクタ

Vector4 | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | float | w
 | ) |  |

constructor taking 4 scalar floats

引数:
x | x value to init with
y | y value to init with
z | z value to init with
w | w value to init with
Vector4 | ( | Vector3 | xyz,
 |  | float | w
 | ) |  |

constructor taking a Vector3 and a scalar float

引数:
xyz | xyz value to init with
w | w value to init with
Vector4 | ( | Vector2 | xy,
 |  | float | z,
 |  | float | w
 | ) |  |

constructor taking a Vector2 and two scalar floats

引数:
xy | xy values to init with
z | z value to init with
w | w value to init with
Vector4 | ( | Vector2 | xy,
 |  | Vector2 | zw
 | ) |  |

constructor taking two Vector2s

引数:
xy | xy values to init with
zw | zw values to init with
Vector4 ( float f )

constructor taking one float

引数:
f f

メソッド

Vector4 Abs ( )

element wise absolute value

戻り値:
element wise absolute value of this
static Vector4 Abs ( Vector4 v ) [static]

static function equivalent to Abs()

引数:
v vector
戻り値:
element wise absolute value of v
static void Abs | ( | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Abs(out Vector4)

引数:
v | vector
result | element wise absolute value of v
void Abs ( out Vector4 result )

element wise absolute value

引数:
result element wise absolute value of this
Vector4 Add ( Vector4 v )

return this + v

引数:
v vector
戻り値:
this + v
void Add | ( | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  |

result = this + v

引数:
v | vector
result | this + v
static Vector4 Add | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

static function equivalent to Add(Vector4)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
v1 + v2
static void Add | ( | ref Vector4 | v1,
 |  | ref Vector4 | v2,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Add(ref Vector4, out Vector4)

引数:
v1 | vector 1
v2 | vector 2
result | v1 + v2
Vector4 Clamp | ( | Vector4 | min,
 |  | Vector4 | max
 | ) |  |

element wise clamp

引数:
min | min values to clamp against
max | max values to clamp against
戻り値:
a new vector consisting of each element of this clamped between min and max
static Vector4 Clamp | ( | Vector4 | v,
 |  | Vector4 | min,
 |  | Vector4 | max
 | ) |  | [static]

static function equivalent to Clamp(Vector4, Vector4)

引数:
v | vector
min | min values to clamp against
max | max values to clamp against
戻り値:
a new vector consisting of each element of v clamped between min and max
static void Clamp | ( | ref Vector4 | v,
 |  | ref Vector4 | min,
 |  | ref Vector4 | max,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Clamp(ref Vector4, ref Vector4, out Vector4)

引数:
v | vector
min | min values to clamp against
max | max values to clamp against
result | a new vector consisting of each element of v clamped between min and max
static Vector4 Clamp | ( | Vector4 | v,
 |  | float | min,
 |  | float | max
 | ) |  | [static]

static function equivalent to Clamp(float, float)

引数:
v | vector
min | min value to clamp against
max | max value to clamp against
戻り値:
a new vector consisting of each element of v clamped between min and max
static void Clamp | ( | ref Vector4 | v,
 |  | float | min,
 |  | float | max,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Clamp(float, float, out Vector4)

引数:
v | vector
min | min value to clamp against
max | max value to clamp against
result | a new vector consisting of each element of v clamped between min and max
Vector4 Clamp | ( | float | min,
 |  | float | max
 | ) |  |

element wise clamp

引数:
min | min value to clamp against
max | max value to clamp against
戻り値:
a new vector consisting of each element of this clamped between min and max
void Clamp | ( | ref Vector4 | min,
 |  | ref Vector4 | max,
 |  | out Vector4 | result
 | ) |  |

element wise clamp

引数:
min | min values to clamp against
max | max values to clamp against
result | a new vector consisting of each element of this clamped between min and max
void Clamp | ( | float | min,
 |  | float | max,
 |  | out Vector4 | result
 | ) |  |

element wise clamp

引数:
min | min value to clamp against
max | max value to clamp against
result | a new vector consisting of each element of this clamped between min and max
float Distance ( ref Vector4 v )

get the distance between this and another vector

引数:
v the vector to get the distance to
戻り値:
the distance bwteen this and the other vector
float Distance ( Vector4 v )

get the distance between this and another vector

引数:
v the vector to get the distance to
戻り値:
the distance bwteen this and the other vector
static float Distance | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

static function equivalent to Distance(Vector4)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the distance bwteen v1 and v2
static float Distance | ( | ref Vector4 | v1,
 |  | ref Vector4 | v2
 | ) |  | [static]

static function equivalent to Distance(ref Vector4)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the distance bwteen v1 and v2
static float DistanceSquared | ( | ref Vector4 | v1,
 |  | ref Vector4 | v2
 | ) |  | [static]

static function equivalent to DistanceSquared(ref Vector4)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the distance between v1 and v2 squared
float DistanceSquared ( Vector4 v )

get the distance squared between this and another vector

引数:
v the vector to get the distance squared to
戻り値:
the distance between this and the other vector squared
float DistanceSquared ( ref Vector4 v )

get the distance squared between this and another vector

引数:
v the vector to get the distance squared to
戻り値:
the distance between this and the other vector squared
static float DistanceSquared | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

static function equivalent to DistanceSquared(Vector4)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the distance between v1 and v2 squared
Vector4 Divide ( Vector4 v )

return this / v

引数:
v vector
戻り値:
this / v
void Divide | ( | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  |

result = this / v

引数:
v | vector
result | this / v
Vector4 Divide ( float f )

return this / f

引数:
f scalar
戻り値:
this / f
void Divide | ( | float | f,
 |  | out Vector4 | result
 | ) |  |

result = this / f

引数:
f | scalar
result | this / f
static Vector4 Divide | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

static function equivalent to Divide(Vector4)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
v1 / v2
static void Divide | ( | ref Vector4 | v1,
 |  | ref Vector4 | v2,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Divide(ref Vector4, out Vector4)

引数:
v1 | vector 1
v2 | vector 2
result | v1 / v2
static Vector4 Divide | ( | Vector4 | v,
 |  | float | f
 | ) |  | [static]

static function equivalent to Divide(float)

引数:
v | vector
f | scalar
戻り値:
v / f
static void Divide | ( | ref Vector4 | v,
 |  | float | f,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Divide(float, out Vector4)

引数:
v | vector
f | scalar
result | v / f
static float Dot | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

static function equivalent to Dot(Vector4)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
dot product of v1 and v2
static float Dot | ( | ref Vector4 | v1,
 |  | ref Vector4 | v2
 | ) |  | [static]

static function equivalent to Dot(ref Vector4)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
dot product of v1 and v2
float Dot ( ref Vector4 v )

dot product of this and v

引数:
v vector to take the dot product with
戻り値:
dot product of this and v
float Dot ( Vector4 v )

dot product of this and v

引数:
v vector to take the dot product with
戻り値:
dot product of this and v
bool Equals | ( | Vector4 | v,
 |  | float | epsilon
 | ) |  |

equality test with an epsilon

引数:
v | the vector to compare this to
epsilon | the epsilon to use in comparison
戻り値:
true if for every element n, abs(this[n] - v[n]) <= epsilon, false otherwise
bool Equals ( Vector4 v )

equality test

引数:
v the vector to compare this to
戻り値:
true if this == v, false otherwise
override bool Equals ( Object o )

equality test

引数:
o the object to compare this to
戻り値:
true if this == o, false otherwise
override int GetHashCode ( )

gets the hash code for this vector

戻り値:
integer hash code
bool IsInfinity ( )

test if any elements of this are Infinity

戻り値:
true if any elements are Infinity, false otherwise
bool IsNaN ( )

test if any elements of this are NaN

戻り値:
true if any elements of this are NaN, false otherwise
bool IsOne ( )

test if all elements of this are one

戻り値:
true if all elements of this are one, false otherwise
bool IsUnit ( float epsilon )

unit vector test

引数:
epsilon epsilon used to test
戻り値:
true if the absolute value of the vector length minus one is <= epsilon, false otherwise
bool IsZero ( )

test if all elements of this are zero

戻り値:
true if all elements of this are zero, false otherwise
float Length ( )

return the length of this vector

戻り値:
the length of this vector
static float Length ( Vector4 v ) [static]

static function equivalent to Length()

引数:
v vector
戻り値:
the length of the vector
static float Length ( ref Vector4 v ) [static]

static function equivalent to Length()

引数:
v vector
戻り値:
the length of the vector
float LengthSquared ( )

return the length squared of this vector

戻り値:
the length squared of this vector
static float LengthSquared ( Vector4 v ) [static]

static function equivalent to LengthSquared()

引数:
v vector
戻り値:
the length squared of the vector
static float LengthSquared ( ref Vector4 v ) [static]

static function equivalent to LengthSquared()

引数:
v vector
戻り値:
the length squared of the vector
static Vector4 Lerp | ( | Vector4 | v1,
 |  | Vector4 | v2,
 |  | float | f
 | ) |  | [static]

static function equivalent to Lerp(Vector4, float)

引数:
v1 | vector 1
v2 | vector 2
f | lerp amount
戻り値:
a Vector4 where each element is the result of lerping f between the corresponding elements of v1 and v2
static void Lerp | ( | ref Vector4 | v1,
 |  | ref Vector4 | v2,
 |  | float | f,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Lerp(ref Vector4, float, out Vector4)

引数:
v1 | vector 1
v2 | vector 2
f | lerp amount
result | a Vector4 where each element is the result of lerping f between the corresponding elements of v1 and v2
Vector4 Lerp | ( | Vector4 | v,
 |  | float | f
 | ) |  |

lerp between this and the other vector

引数:
v | the other vector to lerp to
f | lerp amount
戻り値:
a Vector4 where each element is the result of lerping f between the corresponding elements of this and other
void Lerp | ( | ref Vector4 | v,
 |  | float | f,
 |  | out Vector4 | result
 | ) |  |

lerp between this and the other vector

引数:
v | the other vector to lerp to
f | lerp amount
result | a Vector4 where each element is the result of lerping f between the corresponding elements of this and other
static Vector4 Max | ( | Vector4 | v,
 |  | float | f
 | ) |  | [static]

static function equivalent to Max(float)

引数:
v | vector
f | scalar
戻り値:
the max of v and f
Vector4 Max ( Vector4 v )

element wise max

引数:
v vector to compare to this
戻り値:
the max of this and v
static Vector4 Max | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

static function equivalent to Max(Vector4)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the max of v1 and v2
void Max | ( | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  |

element wise max

引数:
v | vector to compare to this
result | the max of this and v
static void Max | ( | ref Vector4 | v1,
 |  | ref Vector4 | v2,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Max(ref Vector4, out Vector4)

引数:
v1 | vector 1
v2 | vector 2
result | the max of v1 and v2
Vector4 Max ( float f )

element wise max

引数:
f scalar to compare to this
戻り値:
the max of this and f
void Max | ( | float | f,
 |  | out Vector4 | result
 | ) |  |

element wise max

引数:
f | scalar to compare to this
result | the max of this and f
static void Max | ( | ref Vector4 | v,
 |  | float | f,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Max(float, out Vector4)

引数:
v | vector
f | scalar
result | the max of v and f
void Min | ( | float | f,
 |  | out Vector4 | result
 | ) |  |

element wise min

引数:
f | scalar to compare to this
result | the min of this and f
static Vector4 Min | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

static function equivalent to Min(Vector4)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
the min of v1 and v2
static Vector4 Min | ( | Vector4 | v,
 |  | float | f
 | ) |  | [static]

static function equivalent to Min(float)

引数:
v | vector
f | scalar
戻り値:
the min of v and f
static void Min | ( | ref Vector4 | v1,
 |  | ref Vector4 | v2,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Min(ref Vector4, out Vector4)

引数:
v1 | vector 1
v2 | vector 2
result | the min of v1 and v2
Vector4 Min ( Vector4 v )

element wise min

引数:
v vector to compare to this
戻り値:
the min of this and v
static void Min | ( | ref Vector4 | v,
 |  | float | f,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Min(float, out Vector4)

引数:
v | vector
f | scalar
result | the min of v and f
void Min | ( | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  |

element wise min

引数:
v | vector to compare to this
result | the min of this and v
Vector4 Min ( float f )

element wise min

引数:
f scalar to compare to this
戻り値:
the min of this and f
void MoveTo | ( | ref Vector4 | v,
 |  | float | length,
 |  | out Vector4 | result
 | ) |  |

move to target vector by specified length

引数:
v | target vector
length | step length
result | a new vector moved to target vector by specified length
static Vector4 MoveTo | ( | Vector4 | v1,
 |  | Vector4 | v2,
 |  | float | length
 | ) |  | [static]

static function equivalent to MoveTo(Vector4, float)

引数:
v1 | vector 1
v2 | vector 2
length | step length
戻り値:
a new vector moved to target vector by specified length
static void MoveTo | ( | ref Vector4 | v1,
 |  | ref Vector4 | v2,
 |  | float | length,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to MoveTo(ref Vector4, float, out Vector4)

引数:
v1 | vector 1
v2 | vector 2
length | step length
result | a new vector moved to target vector by specified length
Vector4 MoveTo | ( | Vector4 | v,
 |  | float | length
 | ) |  |

move to target vector by specified length

引数:
v | target vector
length | step length
戻り値:
a new vector moved to target vector by specified length
Vector4 Multiply ( Vector4 v )

return this * v

引数:
v vector
戻り値:
this * v
static void Multiply | ( | ref Vector4 | v,
 |  | float | f,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Multiply(float, out Vector4)

引数:
v | vector
f | scalar
result | v * f
void Multiply | ( | float | f,
 |  | out Vector4 | result
 | ) |  |

result = this * f

引数:
f | scalar
result | this * f
static void Multiply | ( | ref Vector4 | v1,
 |  | ref Vector4 | v2,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Multiply(ref Vector4, out Vector4)

引数:
v1 | vector 1
v2 | vector 2
result | v1 * v2
static Vector4 Multiply | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

static function equivalent to Multiply(Vector4)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
v1 * v2
void Multiply | ( | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  |

result = this * v

引数:
v | vector
result | this * v
Vector4 Multiply ( float f )

return this * f

引数:
f scalar
戻り値:
this * f
static Vector4 Multiply | ( | Vector4 | v,
 |  | float | f
 | ) |  | [static]

static function equivalent to Multiply(float)

引数:
v | vector
f | scalar
戻り値:
v * f
static Vector4 Negate ( Vector4 v ) [static]

static function equivalent to Negate()

引数:
v vector
戻り値:
-v
void Negate ( out Vector4 result )

result = -this

引数:
result -this
static void Negate | ( | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Negate(out Vector4)

引数:
v | vector
result | -v
Vector4 Negate ( )

return -this

戻り値:
-this
static Vector4 Normalize ( Vector4 v ) [static]

static function equivalent to Normalize()

引数:
v vector
戻り値:
the vector normalized
static void Normalize | ( | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Normalize(out Vector4)

引数:
v | vector
result | the vector normalized
void Normalize ( out Vector4 result )

return this vector normalized

引数:
result this vector normalized
Vector4 Normalize ( )

return this vector normalized

戻り値:
this vector normalized
static bool operator!= | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

not equals operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 != vector 2, false otherwise
static Vector4 operator* | ( | float | f,
 |  | Vector4 | v
 | ) |  | [static]

multiply each element of vector by scalar float

引数:
f | the scalar to multiply each element of the vector by
v | the vector to multiply
戻り値:
a new vector consisting of each element of vector multiplied by f
static Vector4 operator* | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

multiplication operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
vector 1 * vector 2
static Vector4 operator* | ( | Vector4 | v,
 |  | float | f
 | ) |  | [static]

multiply each element of vector by scalar float

引数:
v | the vector to multiply
f | the scalar to multiply each element of the vector by
戻り値:
a new vector consisting of each element of vector multiplied by f
static Vector4 operator+ | ( | Vector4 | v,
 |  | float | f
 | ) |  | [static]

adds a scalar float to each element of a vector

引数:
v | the vector to add
f | the scalar float to add each element of the vector
戻り値:
a new vector with f added to each element of v
static Vector4 operator+ | ( | float | f,
 |  | Vector4 | v
 | ) |  | [static]

adds a scalar float to each element of a vector

引数:
f | the scalar float to add each element of the vector
v | the vector to add
戻り値:
a new vector with f added to each element of v
static Vector4 operator+ | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

vector addition operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
vector 1 + vector 2
static Vector4 operator- | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

vector subtraction operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
vector 1 - vector 2
static Vector4 operator- ( Vector4 v ) [static]

unary minus operator

引数:
v vector to negate
戻り値:
unary minus applied to each member of v
static Vector4 operator- | ( | float | f,
 |  | Vector4 | v
 | ) |  | [static]

creates a new vector consisting of {f, f, f, f}, and then subtracts v from it

引数:
f | the scalar that we subtract v from
v | the vector to subtract
戻り値:
a new vector consisting of v subtracted from the vector {f, f, f, f}
static Vector4 operator- | ( | Vector4 | v,
 |  | float | f
 | ) |  | [static]

subtract a scalar float from each element of a vector

引数:
v | the vector to subtract from
f | the scalar float to subtract from each element of the vector
戻り値:
a new vector with f subtracted from each element of v
static Vector4 operator/ | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

division operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
vector 1 / vector 2
static Vector4 operator/ | ( | Vector4 | v,
 |  | float | f
 | ) |  | [static]

divide each element of a vector by a scalar float

引数:
v | the vector to divide by scalar
f | the scalar to divide by
戻り値:
a new Vector4 consisting of each element of v divided by f
static Vector4 operator/ | ( | float | f,
 |  | Vector4 | v
 | ) |  | [static]

create a new vector consisting of {f, f, f, f} and divide it by vec

引数:
f | the scalar to divide by vector
v | the vector to divide by
戻り値:
a new vector {f, f, f, f} divided by v
static bool operator== | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

equality operator

引数:
v1 | vector 1
v2 | vector 2
戻り値:
true if vector 1 == vector 2, false otherwise
static Vector4 Repeat | ( | Vector4 | v,
 |  | Vector4 | min,
 |  | Vector4 | max
 | ) |  | [static]

static function equivalent to Repeat(Vector4, Vector4)

引数:
v | vector
min | min values to repeat over
max | max values to repeat over
戻り値:
a new vector consisting of each element of v repeated between min and max
Vector4 Repeat | ( | float | min,
 |  | float | max
 | ) |  |

element wise repeat

引数:
min | min value to repeat over
max | max value to repeat over
戻り値:
a new vector consisting of each element of this repeated between min and max
void Repeat | ( | ref Vector4 | min,
 |  | ref Vector4 | max,
 |  | out Vector4 | result
 | ) |  |

element wise repeat

引数:
min | min values to repeat over
max | max values to repeat over
result | a new vector consisting of each element of this repeated between min and max
static void Repeat | ( | ref Vector4 | v,
 |  | float | min,
 |  | float | max,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Repeat(float, float, out Vector4)

引数:
v | vector
min | min value to repeat over
max | max value to repeat over
result | a new vector consisting of each element of v repeated between min and max
static void Repeat | ( | ref Vector4 | v,
 |  | ref Vector4 | min,
 |  | ref Vector4 | max,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Repeat(ref Vector4, ref Vector4, out Vector4)

引数:
v | vector
min | min values to repeat over
max | max values to repeat over
result | a new vector consisting of each element of v repeated between min and max
static Vector4 Repeat | ( | Vector4 | v,
 |  | float | min,
 |  | float | max
 | ) |  | [static]

static function equivalent to Repeat(float, float)

引数:
v | vector
min | min value to repeat over
max | max value to repeat over
戻り値:
a new vector consisting of each element of v repeated between min and max
Vector4 Repeat | ( | Vector4 | min,
 |  | Vector4 | max
 | ) |  |

element wise repeat

引数:
min | min values to repeat over
max | max values to repeat over
戻り値:
a new vector consisting of each element of this repeated between min and max
void Repeat | ( | float | min,
 |  | float | max,
 |  | out Vector4 | result
 | ) |  |

element wise repeat

引数:
min | min value to repeat over
max | max value to repeat over
result | a new vector consisting of each element of this repeated between min and max
static void Subtract | ( | ref Vector4 | v1,
 |  | ref Vector4 | v2,
 |  | out Vector4 | result
 | ) |  | [static]

static function equivalent to Subtract(ref Vector4, out Vector4)

引数:
v1 | vector 1
v2 | vector 2
result | v1 - v2
Vector4 Subtract ( Vector4 v )

return this - v

引数:
v vector
戻り値:
this - v
static Vector4 Subtract | ( | Vector4 | v1,
 |  | Vector4 | v2
 | ) |  | [static]

static function equivalent to Subtract(Vector4)

引数:
v1 | vector 1
v2 | vector 2
戻り値:
v1 - v2
void Subtract | ( | ref Vector4 | v,
 |  | out Vector4 | result
 | ) |  |

result = this - v

引数:
v | vector
result | this - v
override string ToString ( )

get the string representation of this vector

戻り値:
the string representation of this vector

変数

readonly Vector4 One = new Vector4(1.0f, 1.0f, 1.0f, 1.0f) [static]

return a new vector of all ones

戻り値:
a new vector of all ones
readonly Vector4 UnitW = new Vector4(0.0f, 0.0f, 0.0f, 1.0f) [static]

return a new vector of all zeros with only the w value set to one

戻り値:
a new vector of all zeros with only the w value set to one
readonly Vector4 UnitX = new Vector4(1.0f, 0.0f, 0.0f, 0.0f) [static]

return a new vector of all zeros with only the x value set to one

戻り値:
a new vector of all zeros with only the x value set to one
readonly Vector4 UnitY = new Vector4(0.0f, 1.0f, 0.0f, 0.0f) [static]

return a new vector of all zeros with only the y value set to one

戻り値:
a new vector of all zeros with only the y value set to one
readonly Vector4 UnitZ = new Vector4(0.0f, 0.0f, 1.0f, 0.0f) [static]

return a new vector of all zeros with only the z value set to one

戻り値:
a new vector of all zeros with only the z value set to one
float W

W.

float X

X.

float Y

Y.

float Z

Z.

readonly Vector4 Zero = new Vector4(0.0f, 0.0f, 0.0f, 0.0f) [static]

return a new vector of all zeros

戻り値:
a new vector of all zeros

プロパティ

float A [get, set]

Alpha.

float B [get, set]

Blue.

float G [get, set]

Green.

float R [get, set]

Red.

Vector2 Ww [get]

return a new vector consisting of the current vector's w, w values

戻り値:
a new vector consisting of the current vector's w, w values
Vector3 Www [get]

return a new vector consisting of the current vector's w, w, w values

戻り値:
a new vector consisting of the current vector's w, w, w values
Vector4 Wwww [get]

return a new vector consisting of the current vector's w, w, w, w values

戻り値:
a new vector consisting of the current vector's w, w, w, w values
Vector4 Wwwx [get]

return a new vector consisting of the current vector's w, w, w, x values

戻り値:
a new vector consisting of the current vector's w, w, w, x values
Vector4 Wwwy [get]

return a new vector consisting of the current vector's w, w, w, y values

戻り値:
a new vector consisting of the current vector's w, w, w, y values
Vector4 Wwwz [get]

return a new vector consisting of the current vector's w, w, w, z values

戻り値:
a new vector consisting of the current vector's w, w, w, z values
Vector3 Wwx [get]

return a new vector consisting of the current vector's w, w, x values

戻り値:
a new vector consisting of the current vector's w, w, x values
Vector4 Wwxw [get]

return a new vector consisting of the current vector's w, w, x, w values

戻り値:
a new vector consisting of the current vector's w, w, x, w values
Vector4 Wwxx [get]

return a new vector consisting of the current vector's w, w, x, x values

戻り値:
a new vector consisting of the current vector's w, w, x, x values
Vector4 Wwxy [get]

return a new vector consisting of the current vector's w, w, x, y values

戻り値:
a new vector consisting of the current vector's w, w, x, y values
Vector4 Wwxz [get]

return a new vector consisting of the current vector's w, w, x, z values

戻り値:
a new vector consisting of the current vector's w, w, x, z values
Vector3 Wwy [get]

return a new vector consisting of the current vector's w, w, y values

戻り値:
a new vector consisting of the current vector's w, w, y values
Vector4 Wwyw [get]

return a new vector consisting of the current vector's w, w, y, w values

戻り値:
a new vector consisting of the current vector's w, w, y, w values
Vector4 Wwyx [get]

return a new vector consisting of the current vector's w, w, y, x values

戻り値:
a new vector consisting of the current vector's w, w, y, x values
Vector4 Wwyy [get]

return a new vector consisting of the current vector's w, w, y, y values

戻り値:
a new vector consisting of the current vector's w, w, y, y values
Vector4 Wwyz [get]

return a new vector consisting of the current vector's w, w, y, z values

戻り値:
a new vector consisting of the current vector's w, w, y, z values
Vector3 Wwz [get]

return a new vector consisting of the current vector's w, w, z values

戻り値:
a new vector consisting of the current vector's w, w, z values
Vector4 Wwzw [get]

return a new vector consisting of the current vector's w, w, z, w values

戻り値:
a new vector consisting of the current vector's w, w, z, w values
Vector4 Wwzx [get]

return a new vector consisting of the current vector's w, w, z, x values

戻り値:
a new vector consisting of the current vector's w, w, z, x values
Vector4 Wwzy [get]

return a new vector consisting of the current vector's w, w, z, y values

戻り値:
a new vector consisting of the current vector's w, w, z, y values
Vector4 Wwzz [get]

return a new vector consisting of the current vector's w, w, z, z values

戻り値:
a new vector consisting of the current vector's w, w, z, z values
Vector2 Wx [get, set]

return a new vector consisting of, or set, the current vector's w, x values

戻り値:
a new vector consisting of the current vector's w, x values
Vector3 Wxw [get]

return a new vector consisting of the current vector's w, x, w values

戻り値:
a new vector consisting of the current vector's w, x, w values
Vector4 Wxww [get]

return a new vector consisting of the current vector's w, x, w, w values

戻り値:
a new vector consisting of the current vector's w, x, w, w values
Vector4 Wxwx [get]

return a new vector consisting of the current vector's w, x, w, x values

戻り値:
a new vector consisting of the current vector's w, x, w, x values
Vector4 Wxwy [get]

return a new vector consisting of the current vector's w, x, w, y values

戻り値:
a new vector consisting of the current vector's w, x, w, y values
Vector4 Wxwz [get]

return a new vector consisting of the current vector's w, x, w, z values

戻り値:
a new vector consisting of the current vector's w, x, w, z values
Vector3 Wxx [get]

return a new vector consisting of the current vector's w, x, x values

戻り値:
a new vector consisting of the current vector's w, x, x values
Vector4 Wxxw [get]

return a new vector consisting of the current vector's w, x, x, w values

戻り値:
a new vector consisting of the current vector's w, x, x, w values
Vector4 Wxxx [get]

return a new vector consisting of the current vector's w, x, x, x values

戻り値:
a new vector consisting of the current vector's w, x, x, x values
Vector4 Wxxy [get]

return a new vector consisting of the current vector's w, x, x, y values

戻り値:
a new vector consisting of the current vector's w, x, x, y values
Vector4 Wxxz [get]

return a new vector consisting of the current vector's w, x, x, z values

戻り値:
a new vector consisting of the current vector's w, x, x, z values
Vector3 Wxy [get, set]

return a new vector consisting of, or set, the current vector's w, x, y values

戻り値:
a new vector consisting of the current vector's w, x, y values
Vector4 Wxyw [get]

return a new vector consisting of the current vector's w, x, y, w values

戻り値:
a new vector consisting of the current vector's w, x, y, w values
Vector4 Wxyx [get]

return a new vector consisting of the current vector's w, x, y, x values

戻り値:
a new vector consisting of the current vector's w, x, y, x values
Vector4 Wxyy [get]

return a new vector consisting of the current vector's w, x, y, y values

戻り値:
a new vector consisting of the current vector's w, x, y, y values
Vector4 Wxyz [get, set]

return a new vector consisting of, or set, the current vector's w, x, y, z values

戻り値:
a new vector consisting of the current vector's w, x, y, z values
Vector3 Wxz [get, set]

return a new vector consisting of, or set, the current vector's w, x, z values

戻り値:
a new vector consisting of the current vector's w, x, z values
Vector4 Wxzw [get]

return a new vector consisting of the current vector's w, x, z, w values

戻り値:
a new vector consisting of the current vector's w, x, z, w values
Vector4 Wxzx [get]

return a new vector consisting of the current vector's w, x, z, x values

戻り値:
a new vector consisting of the current vector's w, x, z, x values
Vector4 Wxzy [get, set]

return a new vector consisting of, or set, the current vector's w, x, z, y values

戻り値:
a new vector consisting of the current vector's w, x, z, y values
Vector4 Wxzz [get]

return a new vector consisting of the current vector's w, x, z, z values

戻り値:
a new vector consisting of the current vector's w, x, z, z values
Vector2 Wy [get, set]

return a new vector consisting of, or set, the current vector's w, y values

戻り値:
a new vector consisting of the current vector's w, y values
Vector3 Wyw [get]

return a new vector consisting of the current vector's w, y, w values

戻り値:
a new vector consisting of the current vector's w, y, w values
Vector4 Wyww [get]

return a new vector consisting of the current vector's w, y, w, w values

戻り値:
a new vector consisting of the current vector's w, y, w, w values
Vector4 Wywx [get]

return a new vector consisting of the current vector's w, y, w, x values

戻り値:
a new vector consisting of the current vector's w, y, w, x values
Vector4 Wywy [get]

return a new vector consisting of the current vector's w, y, w, y values

戻り値:
a new vector consisting of the current vector's w, y, w, y values
Vector4 Wywz [get]

return a new vector consisting of the current vector's w, y, w, z values

戻り値:
a new vector consisting of the current vector's w, y, w, z values
Vector3 Wyx [get, set]

return a new vector consisting of, or set, the current vector's w, y, x values

戻り値:
a new vector consisting of the current vector's w, y, x values
Vector4 Wyxw [get]

return a new vector consisting of the current vector's w, y, x, w values

戻り値:
a new vector consisting of the current vector's w, y, x, w values
Vector4 Wyxx [get]

return a new vector consisting of the current vector's w, y, x, x values

戻り値:
a new vector consisting of the current vector's w, y, x, x values
Vector4 Wyxy [get]

return a new vector consisting of the current vector's w, y, x, y values

戻り値:
a new vector consisting of the current vector's w, y, x, y values
Vector4 Wyxz [get, set]

return a new vector consisting of, or set, the current vector's w, y, x, z values

戻り値:
a new vector consisting of the current vector's w, y, x, z values
Vector3 Wyy [get]

return a new vector consisting of the current vector's w, y, y values

戻り値:
a new vector consisting of the current vector's w, y, y values
Vector4 Wyyw [get]

return a new vector consisting of the current vector's w, y, y, w values

戻り値:
a new vector consisting of the current vector's w, y, y, w values
Vector4 Wyyx [get]

return a new vector consisting of the current vector's w, y, y, x values

戻り値:
a new vector consisting of the current vector's w, y, y, x values
Vector4 Wyyy [get]

return a new vector consisting of the current vector's w, y, y, y values

戻り値:
a new vector consisting of the current vector's w, y, y, y values
Vector4 Wyyz [get]

return a new vector consisting of the current vector's w, y, y, z values

戻り値:
a new vector consisting of the current vector's w, y, y, z values
Vector3 Wyz [get, set]

return a new vector consisting of, or set, the current vector's w, y, z values

戻り値:
a new vector consisting of the current vector's w, y, z values
Vector4 Wyzw [get]

return a new vector consisting of the current vector's w, y, z, w values

戻り値:
a new vector consisting of the current vector's w, y, z, w values
Vector4 Wyzx [get, set]

return a new vector consisting of, or set, the current vector's w, y, z, x values

戻り値:
a new vector consisting of the current vector's w, y, z, x values
Vector4 Wyzy [get]

return a new vector consisting of the current vector's w, y, z, y values

戻り値:
a new vector consisting of the current vector's w, y, z, y values
Vector4 Wyzz [get]

return a new vector consisting of the current vector's w, y, z, z values

戻り値:
a new vector consisting of the current vector's w, y, z, z values
Vector2 Wz [get, set]

return a new vector consisting of, or set, the current vector's w, z values

戻り値:
a new vector consisting of the current vector's w, z values
Vector3 Wzw [get]

return a new vector consisting of the current vector's w, z, w values

戻り値:
a new vector consisting of the current vector's w, z, w values
Vector4 Wzww [get]

return a new vector consisting of the current vector's w, z, w, w values

戻り値:
a new vector consisting of the current vector's w, z, w, w values
Vector4 Wzwx [get]

return a new vector consisting of the current vector's w, z, w, x values

戻り値:
a new vector consisting of the current vector's w, z, w, x values
Vector4 Wzwy [get]

return a new vector consisting of the current vector's w, z, w, y values

戻り値:
a new vector consisting of the current vector's w, z, w, y values
Vector4 Wzwz [get]

return a new vector consisting of the current vector's w, z, w, z values

戻り値:
a new vector consisting of the current vector's w, z, w, z values
Vector3 Wzx [get, set]

return a new vector consisting of, or set, the current vector's w, z, x values

戻り値:
a new vector consisting of the current vector's w, z, x values
Vector4 Wzxw [get]

return a new vector consisting of the current vector's w, z, x, w values

戻り値:
a new vector consisting of the current vector's w, z, x, w values
Vector4 Wzxx [get]

return a new vector consisting of the current vector's w, z, x, x values

戻り値:
a new vector consisting of the current vector's w, z, x, x values
Vector4 Wzxy [get, set]

return a new vector consisting of, or set, the current vector's w, z, x, y values

戻り値:
a new vector consisting of the current vector's w, z, x, y values
Vector4 Wzxz [get]

return a new vector consisting of the current vector's w, z, x, z values

戻り値:
a new vector consisting of the current vector's w, z, x, z values
Vector3 Wzy [get, set]

return a new vector consisting of, or set, the current vector's w, z, y values

戻り値:
a new vector consisting of the current vector's w, z, y values
Vector4 Wzyw [get]

return a new vector consisting of the current vector's w, z, y, w values

戻り値:
a new vector consisting of the current vector's w, z, y, w values
Vector4 Wzyx [get, set]

return a new vector consisting of, or set, the current vector's w, z, y, x values

戻り値:
a new vector consisting of the current vector's w, z, y, x values
Vector4 Wzyy [get]

return a new vector consisting of the current vector's w, z, y, y values

戻り値:
a new vector consisting of the current vector's w, z, y, y values
Vector4 Wzyz [get]

return a new vector consisting of the current vector's w, z, y, z values

戻り値:
a new vector consisting of the current vector's w, z, y, z values
Vector3 Wzz [get]

return a new vector consisting of the current vector's w, z, z values

戻り値:
a new vector consisting of the current vector's w, z, z values
Vector4 Wzzw [get]

return a new vector consisting of the current vector's w, z, z, w values

戻り値:
a new vector consisting of the current vector's w, z, z, w values
Vector4 Wzzx [get]

return a new vector consisting of the current vector's w, z, z, x values

戻り値:
a new vector consisting of the current vector's w, z, z, x values
Vector4 Wzzy [get]

return a new vector consisting of the current vector's w, z, z, y values

戻り値:
a new vector consisting of the current vector's w, z, z, y values
Vector4 Wzzz [get]

return a new vector consisting of the current vector's w, z, z, z values

戻り値:
a new vector consisting of the current vector's w, z, z, z values
Vector2 Xw [get, set]

return a new vector consisting of, or set, the current vector's x, w values

戻り値:
a new vector consisting of the current vector's x, w values
Vector3 Xww [get]

return a new vector consisting of the current vector's x, w, w values

戻り値:
a new vector consisting of the current vector's x, w, w values
Vector4 Xwww [get]

return a new vector consisting of the current vector's x, w, w, w values

戻り値:
a new vector consisting of the current vector's x, w, w, w values
Vector4 Xwwx [get]

return a new vector consisting of the current vector's x, w, w, x values

戻り値:
a new vector consisting of the current vector's x, w, w, x values
Vector4 Xwwy [get]

return a new vector consisting of the current vector's x, w, w, y values

戻り値:
a new vector consisting of the current vector's x, w, w, y values
Vector4 Xwwz [get]

return a new vector consisting of the current vector's x, w, w, z values

戻り値:
a new vector consisting of the current vector's x, w, w, z values
Vector3 Xwx [get]

return a new vector consisting of the current vector's x, w, x values

戻り値:
a new vector consisting of the current vector's x, w, x values
Vector4 Xwxw [get]

return a new vector consisting of the current vector's x, w, x, w values

戻り値:
a new vector consisting of the current vector's x, w, x, w values
Vector4 Xwxx [get]

return a new vector consisting of the current vector's x, w, x, x values

戻り値:
a new vector consisting of the current vector's x, w, x, x values
Vector4 Xwxy [get]

return a new vector consisting of the current vector's x, w, x, y values

戻り値:
a new vector consisting of the current vector's x, w, x, y values
Vector4 Xwxz [get]

return a new vector consisting of the current vector's x, w, x, z values

戻り値:
a new vector consisting of the current vector's x, w, x, z values
Vector3 Xwy [get, set]

return a new vector consisting of, or set, the current vector's x, w, y values

戻り値:
a new vector consisting of the current vector's x, w, y values
Vector4 Xwyw [get]

return a new vector consisting of the current vector's x, w, y, w values

戻り値:
a new vector consisting of the current vector's x, w, y, w values
Vector4 Xwyx [get]

return a new vector consisting of the current vector's x, w, y, x values

戻り値:
a new vector consisting of the current vector's x, w, y, x values
Vector4 Xwyy [get]

return a new vector consisting of the current vector's x, w, y, y values

戻り値:
a new vector consisting of the current vector's x, w, y, y values
Vector4 Xwyz [get, set]

return a new vector consisting of, or set, the current vector's x, w, y, z values

戻り値:
a new vector consisting of the current vector's x, w, y, z values
Vector3 Xwz [get, set]

return a new vector consisting of, or set, the current vector's x, w, z values

戻り値:
a new vector consisting of the current vector's x, w, z values
Vector4 Xwzw [get]

return a new vector consisting of the current vector's x, w, z, w values

戻り値:
a new vector consisting of the current vector's x, w, z, w values
Vector4 Xwzx [get]

return a new vector consisting of the current vector's x, w, z, x values

戻り値:
a new vector consisting of the current vector's x, w, z, x values
Vector4 Xwzy [get, set]

return a new vector consisting of, or set, the current vector's x, w, z, y values

戻り値:
a new vector consisting of the current vector's x, w, z, y values
Vector4 Xwzz [get]

return a new vector consisting of the current vector's x, w, z, z values

戻り値:
a new vector consisting of the current vector's x, w, z, z values
Vector2 Xx [get]

return a new vector consisting of the current vector's x, x values

戻り値:
a new vector consisting of the current vector's x, x values
Vector3 Xxw [get]

return a new vector consisting of the current vector's x, x, w values

戻り値:
a new vector consisting of the current vector's x, x, w values
Vector4 Xxww [get]

return a new vector consisting of the current vector's x, x, w, w values

戻り値:
a new vector consisting of the current vector's x, x, w, w values
Vector4 Xxwx [get]

return a new vector consisting of the current vector's x, x, w, x values

戻り値:
a new vector consisting of the current vector's x, x, w, x values
Vector4 Xxwy [get]

return a new vector consisting of the current vector's x, x, w, y values

戻り値:
a new vector consisting of the current vector's x, x, w, y values
Vector4 Xxwz [get]

return a new vector consisting of the current vector's x, x, w, z values

戻り値:
a new vector consisting of the current vector's x, x, w, z values
Vector3 Xxx [get]

return a new vector consisting of the current vector's x, x, x values

戻り値:
a new vector consisting of the current vector's x, x, x values
Vector4 Xxxw [get]

return a new vector consisting of the current vector's x, x, x, w values

戻り値:
a new vector consisting of the current vector's x, x, x, w values
Vector4 Xxxx [get]

return a new vector consisting of the current vector's x, x, x, x values

戻り値:
a new vector consisting of the current vector's x, x, x, x values
Vector4 Xxxy [get]

return a new vector consisting of the current vector's x, x, x, y values

戻り値:
a new vector consisting of the current vector's x, x, x, y values
Vector4 Xxxz [get]

return a new vector consisting of the current vector's x, x, x, z values

戻り値:
a new vector consisting of the current vector's x, x, x, z values
Vector3 Xxy [get]

return a new vector consisting of the current vector's x, x, y values

戻り値:
a new vector consisting of the current vector's x, x, y values
Vector4 Xxyw [get]

return a new vector consisting of the current vector's x, x, y, w values

戻り値:
a new vector consisting of the current vector's x, x, y, w values
Vector4 Xxyx [get]

return a new vector consisting of the current vector's x, x, y, x values

戻り値:
a new vector consisting of the current vector's x, x, y, x values
Vector4 Xxyy [get]

return a new vector consisting of the current vector's x, x, y, y values

戻り値:
a new vector consisting of the current vector's x, x, y, y values
Vector4 Xxyz [get]

return a new vector consisting of the current vector's x, x, y, z values

戻り値:
a new vector consisting of the current vector's x, x, y, z values
Vector3 Xxz [get]

return a new vector consisting of the current vector's x, x, z values

戻り値:
a new vector consisting of the current vector's x, x, z values
Vector4 Xxzw [get]

return a new vector consisting of the current vector's x, x, z, w values

戻り値:
a new vector consisting of the current vector's x, x, z, w values
Vector4 Xxzx [get]

return a new vector consisting of the current vector's x, x, z, x values

戻り値:
a new vector consisting of the current vector's x, x, z, x values
Vector4 Xxzy [get]

return a new vector consisting of the current vector's x, x, z, y values

戻り値:
a new vector consisting of the current vector's x, x, z, y values
Vector4 Xxzz [get]

return a new vector consisting of the current vector's x, x, z, z values

戻り値:
a new vector consisting of the current vector's x, x, z, z values
Vector2 Xy [get, set]

return a new vector consisting of, or set, the current vector's x, y values

戻り値:
a new vector consisting of the current vector's x, y values
Vector3 Xyw [get, set]

return a new vector consisting of, or set, the current vector's x, y, w values

戻り値:
a new vector consisting of the current vector's x, y, w values
Vector4 Xyww [get]

return a new vector consisting of the current vector's x, y, w, w values

戻り値:
a new vector consisting of the current vector's x, y, w, w values
Vector4 Xywx [get]

return a new vector consisting of the current vector's x, y, w, x values

戻り値:
a new vector consisting of the current vector's x, y, w, x values
Vector4 Xywy [get]

return a new vector consisting of the current vector's x, y, w, y values

戻り値:
a new vector consisting of the current vector's x, y, w, y values
Vector4 Xywz [get, set]

return a new vector consisting of, or set, the current vector's x, y, w, z values

戻り値:
a new vector consisting of the current vector's x, y, w, z values
Vector3 Xyx [get]

return a new vector consisting of the current vector's x, y, x values

戻り値:
a new vector consisting of the current vector's x, y, x values
Vector4 Xyxw [get]

return a new vector consisting of the current vector's x, y, x, w values

戻り値:
a new vector consisting of the current vector's x, y, x, w values
Vector4 Xyxx [get]

return a new vector consisting of the current vector's x, y, x, x values

戻り値:
a new vector consisting of the current vector's x, y, x, x values
Vector4 Xyxy [get]

return a new vector consisting of the current vector's x, y, x, y values

戻り値:
a new vector consisting of the current vector's x, y, x, y values
Vector4 Xyxz [get]

return a new vector consisting of the current vector's x, y, x, z values

戻り値:
a new vector consisting of the current vector's x, y, x, z values
Vector3 Xyy [get]

return a new vector consisting of the current vector's x, y, y values

戻り値:
a new vector consisting of the current vector's x, y, y values
Vector4 Xyyw [get]

return a new vector consisting of the current vector's x, y, y, w values

戻り値:
a new vector consisting of the current vector's x, y, y, w values
Vector4 Xyyx [get]

return a new vector consisting of the current vector's x, y, y, x values

戻り値:
a new vector consisting of the current vector's x, y, y, x values
Vector4 Xyyy [get]

return a new vector consisting of the current vector's x, y, y, y values

戻り値:
a new vector consisting of the current vector's x, y, y, y values
Vector4 Xyyz [get]

return a new vector consisting of the current vector's x, y, y, z values

戻り値:
a new vector consisting of the current vector's x, y, y, z values
Vector3 Xyz [get, set]

return a new vector consisting of, or set, the current vector's x, y, z values

戻り値:
a new vector consisting of the current vector's x, y, z values
Vector4 Xyz0 [get]

return a 4 element vector consisting of the current vector with the w component set to 0

戻り値:
a 4 element vector consisting of the current vector with the w component set to 0
Vector4 Xyz1 [get]

return a 4 element vector consisting of the current vector with the w component set to 1

戻り値:
a 4 element vector consisting of the current vector with the w component set to 1
Vector4 Xyzw [get, set]

return a new vector consisting of, or set, the current vector's x, y, z, w values

戻り値:
a new vector consisting of the current vector's x, y, z, w values
Vector4 Xyzx [get]

return a new vector consisting of the current vector's x, y, z, x values

戻り値:
a new vector consisting of the current vector's x, y, z, x values
Vector4 Xyzy [get]

return a new vector consisting of the current vector's x, y, z, y values

戻り値:
a new vector consisting of the current vector's x, y, z, y values
Vector4 Xyzz [get]

return a new vector consisting of the current vector's x, y, z, z values

戻り値:
a new vector consisting of the current vector's x, y, z, z values
Vector2 Xz [get, set]

return a new vector consisting of, or set, the current vector's x, z values

戻り値:
a new vector consisting of the current vector's x, z values
Vector3 Xzw [get, set]

return a new vector consisting of, or set, the current vector's x, z, w values

戻り値:
a new vector consisting of the current vector's x, z, w values
Vector4 Xzww [get]

return a new vector consisting of the current vector's x, z, w, w values

戻り値:
a new vector consisting of the current vector's x, z, w, w values
Vector4 Xzwx [get]

return a new vector consisting of the current vector's x, z, w, x values

戻り値:
a new vector consisting of the current vector's x, z, w, x values
Vector4 Xzwy [get, set]

return a new vector consisting of, or set, the current vector's x, z, w, y values

戻り値:
a new vector consisting of the current vector's x, z, w, y values
Vector4 Xzwz [get]

return a new vector consisting of the current vector's x, z, w, z values

戻り値:
a new vector consisting of the current vector's x, z, w, z values
Vector3 Xzx [get]

return a new vector consisting of the current vector's x, z, x values

戻り値:
a new vector consisting of the current vector's x, z, x values
Vector4 Xzxw [get]

return a new vector consisting of the current vector's x, z, x, w values

戻り値:
a new vector consisting of the current vector's x, z, x, w values
Vector4 Xzxx [get]

return a new vector consisting of the current vector's x, z, x, x values

戻り値:
a new vector consisting of the current vector's x, z, x, x values
Vector4 Xzxy [get]

return a new vector consisting of the current vector's x, z, x, y values

戻り値:
a new vector consisting of the current vector's x, z, x, y values
Vector4 Xzxz [get]

return a new vector consisting of the current vector's x, z, x, z values

戻り値:
a new vector consisting of the current vector's x, z, x, z values
Vector3 Xzy [get, set]

return a new vector consisting of, or set, the current vector's x, z, y values

戻り値:
a new vector consisting of the current vector's x, z, y values
Vector4 Xzyw [get, set]

return a new vector consisting of, or set, the current vector's x, z, y, w values

戻り値:
a new vector consisting of the current vector's x, z, y, w values
Vector4 Xzyx [get]

return a new vector consisting of the current vector's x, z, y, x values

戻り値:
a new vector consisting of the current vector's x, z, y, x values
Vector4 Xzyy [get]

return a new vector consisting of the current vector's x, z, y, y values

戻り値:
a new vector consisting of the current vector's x, z, y, y values
Vector4 Xzyz [get]

return a new vector consisting of the current vector's x, z, y, z values

戻り値:
a new vector consisting of the current vector's x, z, y, z values
Vector3 Xzz [get]

return a new vector consisting of the current vector's x, z, z values

戻り値:
a new vector consisting of the current vector's x, z, z values
Vector4 Xzzw [get]

return a new vector consisting of the current vector's x, z, z, w values

戻り値:
a new vector consisting of the current vector's x, z, z, w values
Vector4 Xzzx [get]

return a new vector consisting of the current vector's x, z, z, x values

戻り値:
a new vector consisting of the current vector's x, z, z, x values
Vector4 Xzzy [get]

return a new vector consisting of the current vector's x, z, z, y values

戻り値:
a new vector consisting of the current vector's x, z, z, y values
Vector4 Xzzz [get]

return a new vector consisting of the current vector's x, z, z, z values

戻り値:
a new vector consisting of the current vector's x, z, z, z values
Vector2 Yw [get, set]

return a new vector consisting of, or set, the current vector's y, w values

戻り値:
a new vector consisting of the current vector's y, w values
Vector3 Yww [get]

return a new vector consisting of the current vector's y, w, w values

戻り値:
a new vector consisting of the current vector's y, w, w values
Vector4 Ywww [get]

return a new vector consisting of the current vector's y, w, w, w values

戻り値:
a new vector consisting of the current vector's y, w, w, w values
Vector4 Ywwx [get]

return a new vector consisting of the current vector's y, w, w, x values

戻り値:
a new vector consisting of the current vector's y, w, w, x values
Vector4 Ywwy [get]

return a new vector consisting of the current vector's y, w, w, y values

戻り値:
a new vector consisting of the current vector's y, w, w, y values
Vector4 Ywwz [get]

return a new vector consisting of the current vector's y, w, w, z values

戻り値:
a new vector consisting of the current vector's y, w, w, z values
Vector3 Ywx [get, set]

return a new vector consisting of, or set, the current vector's y, w, x values

戻り値:
a new vector consisting of the current vector's y, w, x values
Vector4 Ywxw [get]

return a new vector consisting of the current vector's y, w, x, w values

戻り値:
a new vector consisting of the current vector's y, w, x, w values
Vector4 Ywxx [get]

return a new vector consisting of the current vector's y, w, x, x values

戻り値:
a new vector consisting of the current vector's y, w, x, x values
Vector4 Ywxy [get]

return a new vector consisting of the current vector's y, w, x, y values

戻り値:
a new vector consisting of the current vector's y, w, x, y values
Vector4 Ywxz [get, set]

return a new vector consisting of, or set, the current vector's y, w, x, z values

戻り値:
a new vector consisting of the current vector's y, w, x, z values
Vector3 Ywy [get]

return a new vector consisting of the current vector's y, w, y values

戻り値:
a new vector consisting of the current vector's y, w, y values
Vector4 Ywyw [get]

return a new vector consisting of the current vector's y, w, y, w values

戻り値:
a new vector consisting of the current vector's y, w, y, w values
Vector4 Ywyx [get]

return a new vector consisting of the current vector's y, w, y, x values

戻り値:
a new vector consisting of the current vector's y, w, y, x values
Vector4 Ywyy [get]

return a new vector consisting of the current vector's y, w, y, y values

戻り値:
a new vector consisting of the current vector's y, w, y, y values
Vector4 Ywyz [get]

return a new vector consisting of the current vector's y, w, y, z values

戻り値:
a new vector consisting of the current vector's y, w, y, z values
Vector3 Ywz [get, set]

return a new vector consisting of, or set, the current vector's y, w, z values

戻り値:
a new vector consisting of the current vector's y, w, z values
Vector4 Ywzw [get]

return a new vector consisting of the current vector's y, w, z, w values

戻り値:
a new vector consisting of the current vector's y, w, z, w values
Vector4 Ywzx [get, set]

return a new vector consisting of, or set, the current vector's y, w, z, x values

戻り値:
a new vector consisting of the current vector's y, w, z, x values
Vector4 Ywzy [get]

return a new vector consisting of the current vector's y, w, z, y values

戻り値:
a new vector consisting of the current vector's y, w, z, y values
Vector4 Ywzz [get]

return a new vector consisting of the current vector's y, w, z, z values

戻り値:
a new vector consisting of the current vector's y, w, z, z values
Vector2 Yx [get, set]

return a new vector consisting of, or set, the current vector's y, x values

戻り値:
a new vector consisting of the current vector's y, x values
Vector3 Yxw [get, set]

return a new vector consisting of, or set, the current vector's y, x, w values

戻り値:
a new vector consisting of the current vector's y, x, w values
Vector4 Yxww [get]

return a new vector consisting of the current vector's y, x, w, w values

戻り値:
a new vector consisting of the current vector's y, x, w, w values
Vector4 Yxwx [get]

return a new vector consisting of the current vector's y, x, w, x values

戻り値:
a new vector consisting of the current vector's y, x, w, x values
Vector4 Yxwy [get]

return a new vector consisting of the current vector's y, x, w, y values

戻り値:
a new vector consisting of the current vector's y, x, w, y values
Vector4 Yxwz [get, set]

return a new vector consisting of, or set, the current vector's y, x, w, z values

戻り値:
a new vector consisting of the current vector's y, x, w, z values
Vector3 Yxx [get]

return a new vector consisting of the current vector's y, x, x values

戻り値:
a new vector consisting of the current vector's y, x, x values
Vector4 Yxxw [get]

return a new vector consisting of the current vector's y, x, x, w values

戻り値:
a new vector consisting of the current vector's y, x, x, w values
Vector4 Yxxx [get]

return a new vector consisting of the current vector's y, x, x, x values

戻り値:
a new vector consisting of the current vector's y, x, x, x values
Vector4 Yxxy [get]

return a new vector consisting of the current vector's y, x, x, y values

戻り値:
a new vector consisting of the current vector's y, x, x, y values
Vector4 Yxxz [get]

return a new vector consisting of the current vector's y, x, x, z values

戻り値:
a new vector consisting of the current vector's y, x, x, z values
Vector3 Yxy [get]

return a new vector consisting of the current vector's y, x, y values

戻り値:
a new vector consisting of the current vector's y, x, y values
Vector4 Yxyw [get]

return a new vector consisting of the current vector's y, x, y, w values

戻り値:
a new vector consisting of the current vector's y, x, y, w values
Vector4 Yxyx [get]

return a new vector consisting of the current vector's y, x, y, x values

戻り値:
a new vector consisting of the current vector's y, x, y, x values
Vector4 Yxyy [get]

return a new vector consisting of the current vector's y, x, y, y values

戻り値:
a new vector consisting of the current vector's y, x, y, y values
Vector4 Yxyz [get]

return a new vector consisting of the current vector's y, x, y, z values

戻り値:
a new vector consisting of the current vector's y, x, y, z values
Vector3 Yxz [get, set]

return a new vector consisting of, or set, the current vector's y, x, z values

戻り値:
a new vector consisting of the current vector's y, x, z values
Vector4 Yxzw [get, set]

return a new vector consisting of, or set, the current vector's y, x, z, w values

戻り値:
a new vector consisting of the current vector's y, x, z, w values
Vector4 Yxzx [get]

return a new vector consisting of the current vector's y, x, z, x values

戻り値:
a new vector consisting of the current vector's y, x, z, x values
Vector4 Yxzy [get]

return a new vector consisting of the current vector's y, x, z, y values

戻り値:
a new vector consisting of the current vector's y, x, z, y values
Vector4 Yxzz [get]

return a new vector consisting of the current vector's y, x, z, z values

戻り値:
a new vector consisting of the current vector's y, x, z, z values
Vector2 Yy [get]

return a new vector consisting of the current vector's y, y values

戻り値:
a new vector consisting of the current vector's y, y values
Vector3 Yyw [get]

return a new vector consisting of the current vector's y, y, w values

戻り値:
a new vector consisting of the current vector's y, y, w values
Vector4 Yyww [get]

return a new vector consisting of the current vector's y, y, w, w values

戻り値:
a new vector consisting of the current vector's y, y, w, w values
Vector4 Yywx [get]

return a new vector consisting of the current vector's y, y, w, x values

戻り値:
a new vector consisting of the current vector's y, y, w, x values
Vector4 Yywy [get]

return a new vector consisting of the current vector's y, y, w, y values

戻り値:
a new vector consisting of the current vector's y, y, w, y values
Vector4 Yywz [get]

return a new vector consisting of the current vector's y, y, w, z values

戻り値:
a new vector consisting of the current vector's y, y, w, z values
Vector3 Yyx [get]

return a new vector consisting of the current vector's y, y, x values

戻り値:
a new vector consisting of the current vector's y, y, x values
Vector4 Yyxw [get]

return a new vector consisting of the current vector's y, y, x, w values

戻り値:
a new vector consisting of the current vector's y, y, x, w values
Vector4 Yyxx [get]

return a new vector consisting of the current vector's y, y, x, x values

戻り値:
a new vector consisting of the current vector's y, y, x, x values
Vector4 Yyxy [get]

return a new vector consisting of the current vector's y, y, x, y values

戻り値:
a new vector consisting of the current vector's y, y, x, y values
Vector4 Yyxz [get]

return a new vector consisting of the current vector's y, y, x, z values

戻り値:
a new vector consisting of the current vector's y, y, x, z values
Vector3 Yyy [get]

return a new vector consisting of the current vector's y, y, y values

戻り値:
a new vector consisting of the current vector's y, y, y values
Vector4 Yyyw [get]

return a new vector consisting of the current vector's y, y, y, w values

戻り値:
a new vector consisting of the current vector's y, y, y, w values
Vector4 Yyyx [get]

return a new vector consisting of the current vector's y, y, y, x values

戻り値:
a new vector consisting of the current vector's y, y, y, x values
Vector4 Yyyy [get]

return a new vector consisting of the current vector's y, y, y, y values

戻り値:
a new vector consisting of the current vector's y, y, y, y values
Vector4 Yyyz [get]

return a new vector consisting of the current vector's y, y, y, z values

戻り値:
a new vector consisting of the current vector's y, y, y, z values
Vector3 Yyz [get]

return a new vector consisting of the current vector's y, y, z values

戻り値:
a new vector consisting of the current vector's y, y, z values
Vector4 Yyzw [get]

return a new vector consisting of the current vector's y, y, z, w values

戻り値:
a new vector consisting of the current vector's y, y, z, w values
Vector4 Yyzx [get]

return a new vector consisting of the current vector's y, y, z, x values

戻り値:
a new vector consisting of the current vector's y, y, z, x values
Vector4 Yyzy [get]

return a new vector consisting of the current vector's y, y, z, y values

戻り値:
a new vector consisting of the current vector's y, y, z, y values
Vector4 Yyzz [get]

return a new vector consisting of the current vector's y, y, z, z values

戻り値:
a new vector consisting of the current vector's y, y, z, z values
Vector2 Yz [get, set]

return a new vector consisting of, or set, the current vector's y, z values

戻り値:
a new vector consisting of the current vector's y, z values
Vector3 Yzw [get, set]

return a new vector consisting of, or set, the current vector's y, z, w values

戻り値:
a new vector consisting of the current vector's y, z, w values
Vector4 Yzww [get]

return a new vector consisting of the current vector's y, z, w, w values

戻り値:
a new vector consisting of the current vector's y, z, w, w values
Vector4 Yzwx [get, set]

return a new vector consisting of, or set, the current vector's y, z, w, x values

戻り値:
a new vector consisting of the current vector's y, z, w, x values
Vector4 Yzwy [get]

return a new vector consisting of the current vector's y, z, w, y values

戻り値:
a new vector consisting of the current vector's y, z, w, y values
Vector4 Yzwz [get]

return a new vector consisting of the current vector's y, z, w, z values

戻り値:
a new vector consisting of the current vector's y, z, w, z values
Vector3 Yzx [get, set]

return a new vector consisting of, or set, the current vector's y, z, x values

戻り値:
a new vector consisting of the current vector's y, z, x values
Vector4 Yzxw [get, set]

return a new vector consisting of, or set, the current vector's y, z, x, w values

戻り値:
a new vector consisting of the current vector's y, z, x, w values
Vector4 Yzxx [get]

return a new vector consisting of the current vector's y, z, x, x values

戻り値:
a new vector consisting of the current vector's y, z, x, x values
Vector4 Yzxy [get]

return a new vector consisting of the current vector's y, z, x, y values

戻り値:
a new vector consisting of the current vector's y, z, x, y values
Vector4 Yzxz [get]

return a new vector consisting of the current vector's y, z, x, z values

戻り値:
a new vector consisting of the current vector's y, z, x, z values
Vector3 Yzy [get]

return a new vector consisting of the current vector's y, z, y values

戻り値:
a new vector consisting of the current vector's y, z, y values
Vector4 Yzyw [get]

return a new vector consisting of the current vector's y, z, y, w values

戻り値:
a new vector consisting of the current vector's y, z, y, w values
Vector4 Yzyx [get]

return a new vector consisting of the current vector's y, z, y, x values

戻り値:
a new vector consisting of the current vector's y, z, y, x values
Vector4 Yzyy [get]

return a new vector consisting of the current vector's y, z, y, y values

戻り値:
a new vector consisting of the current vector's y, z, y, y values
Vector4 Yzyz [get]

return a new vector consisting of the current vector's y, z, y, z values

戻り値:
a new vector consisting of the current vector's y, z, y, z values
Vector3 Yzz [get]

return a new vector consisting of the current vector's y, z, z values

戻り値:
a new vector consisting of the current vector's y, z, z values
Vector4 Yzzw [get]

return a new vector consisting of the current vector's y, z, z, w values

戻り値:
a new vector consisting of the current vector's y, z, z, w values
Vector4 Yzzx [get]

return a new vector consisting of the current vector's y, z, z, x values

戻り値:
a new vector consisting of the current vector's y, z, z, x values
Vector4 Yzzy [get]

return a new vector consisting of the current vector's y, z, z, y values

戻り値:
a new vector consisting of the current vector's y, z, z, y values
Vector4 Yzzz [get]

return a new vector consisting of the current vector's y, z, z, z values

戻り値:
a new vector consisting of the current vector's y, z, z, z values
Vector2 Zw [get, set]

return a new vector consisting of, or set, the current vector's z, w values

戻り値:
a new vector consisting of the current vector's z, w values
Vector3 Zww [get]

return a new vector consisting of the current vector's z, w, w values

戻り値:
a new vector consisting of the current vector's z, w, w values
Vector4 Zwww [get]

return a new vector consisting of the current vector's z, w, w, w values

戻り値:
a new vector consisting of the current vector's z, w, w, w values
Vector4 Zwwx [get]

return a new vector consisting of the current vector's z, w, w, x values

戻り値:
a new vector consisting of the current vector's z, w, w, x values
Vector4 Zwwy [get]

return a new vector consisting of the current vector's z, w, w, y values

戻り値:
a new vector consisting of the current vector's z, w, w, y values
Vector4 Zwwz [get]

return a new vector consisting of the current vector's z, w, w, z values

戻り値:
a new vector consisting of the current vector's z, w, w, z values
Vector3 Zwx [get, set]

return a new vector consisting of, or set, the current vector's z, w, x values

戻り値:
a new vector consisting of the current vector's z, w, x values
Vector4 Zwxw [get]

return a new vector consisting of the current vector's z, w, x, w values

戻り値:
a new vector consisting of the current vector's z, w, x, w values
Vector4 Zwxx [get]

return a new vector consisting of the current vector's z, w, x, x values

戻り値:
a new vector consisting of the current vector's z, w, x, x values
Vector4 Zwxy [get, set]

return a new vector consisting of, or set, the current vector's z, w, x, y values

戻り値:
a new vector consisting of the current vector's z, w, x, y values
Vector4 Zwxz [get]

return a new vector consisting of the current vector's z, w, x, z values

戻り値:
a new vector consisting of the current vector's z, w, x, z values
Vector3 Zwy [get, set]

return a new vector consisting of, or set, the current vector's z, w, y values

戻り値:
a new vector consisting of the current vector's z, w, y values
Vector4 Zwyw [get]

return a new vector consisting of the current vector's z, w, y, w values

戻り値:
a new vector consisting of the current vector's z, w, y, w values
Vector4 Zwyx [get, set]

return a new vector consisting of, or set, the current vector's z, w, y, x values

戻り値:
a new vector consisting of the current vector's z, w, y, x values
Vector4 Zwyy [get]

return a new vector consisting of the current vector's z, w, y, y values

戻り値:
a new vector consisting of the current vector's z, w, y, y values
Vector4 Zwyz [get]

return a new vector consisting of the current vector's z, w, y, z values

戻り値:
a new vector consisting of the current vector's z, w, y, z values
Vector3 Zwz [get]

return a new vector consisting of the current vector's z, w, z values

戻り値:
a new vector consisting of the current vector's z, w, z values
Vector4 Zwzw [get]

return a new vector consisting of the current vector's z, w, z, w values

戻り値:
a new vector consisting of the current vector's z, w, z, w values
Vector4 Zwzx [get]

return a new vector consisting of the current vector's z, w, z, x values

戻り値:
a new vector consisting of the current vector's z, w, z, x values
Vector4 Zwzy [get]

return a new vector consisting of the current vector's z, w, z, y values

戻り値:
a new vector consisting of the current vector's z, w, z, y values
Vector4 Zwzz [get]

return a new vector consisting of the current vector's z, w, z, z values

戻り値:
a new vector consisting of the current vector's z, w, z, z values
Vector2 Zx [get, set]

return a new vector consisting of, or set, the current vector's z, x values

戻り値:
a new vector consisting of the current vector's z, x values
Vector3 Zxw [get, set]

return a new vector consisting of, or set, the current vector's z, x, w values

戻り値:
a new vector consisting of the current vector's z, x, w values
Vector4 Zxww [get]

return a new vector consisting of the current vector's z, x, w, w values

戻り値:
a new vector consisting of the current vector's z, x, w, w values
Vector4 Zxwx [get]

return a new vector consisting of the current vector's z, x, w, x values

戻り値:
a new vector consisting of the current vector's z, x, w, x values
Vector4 Zxwy [get, set]

return a new vector consisting of, or set, the current vector's z, x, w, y values

戻り値:
a new vector consisting of the current vector's z, x, w, y values
Vector4 Zxwz [get]

return a new vector consisting of the current vector's z, x, w, z values

戻り値:
a new vector consisting of the current vector's z, x, w, z values
Vector3 Zxx [get]

return a new vector consisting of the current vector's z, x, x values

戻り値:
a new vector consisting of the current vector's z, x, x values
Vector4 Zxxw [get]

return a new vector consisting of the current vector's z, x, x, w values

戻り値:
a new vector consisting of the current vector's z, x, x, w values
Vector4 Zxxx [get]

return a new vector consisting of the current vector's z, x, x, x values

戻り値:
a new vector consisting of the current vector's z, x, x, x values
Vector4 Zxxy [get]

return a new vector consisting of the current vector's z, x, x, y values

戻り値:
a new vector consisting of the current vector's z, x, x, y values
Vector4 Zxxz [get]

return a new vector consisting of the current vector's z, x, x, z values

戻り値:
a new vector consisting of the current vector's z, x, x, z values
Vector3 Zxy [get, set]

return a new vector consisting of, or set, the current vector's z, x, y values

戻り値:
a new vector consisting of the current vector's z, x, y values
Vector4 Zxyw [get, set]

return a new vector consisting of, or set, the current vector's z, x, y, w values

戻り値:
a new vector consisting of the current vector's z, x, y, w values
Vector4 Zxyx [get]

return a new vector consisting of the current vector's z, x, y, x values

戻り値:
a new vector consisting of the current vector's z, x, y, x values
Vector4 Zxyy [get]

return a new vector consisting of the current vector's z, x, y, y values

戻り値:
a new vector consisting of the current vector's z, x, y, y values
Vector4 Zxyz [get]

return a new vector consisting of the current vector's z, x, y, z values

戻り値:
a new vector consisting of the current vector's z, x, y, z values
Vector3 Zxz [get]

return a new vector consisting of the current vector's z, x, z values

戻り値:
a new vector consisting of the current vector's z, x, z values
Vector4 Zxzw [get]

return a new vector consisting of the current vector's z, x, z, w values

戻り値:
a new vector consisting of the current vector's z, x, z, w values
Vector4 Zxzx [get]

return a new vector consisting of the current vector's z, x, z, x values

戻り値:
a new vector consisting of the current vector's z, x, z, x values
Vector4 Zxzy [get]

return a new vector consisting of the current vector's z, x, z, y values

戻り値:
a new vector consisting of the current vector's z, x, z, y values
Vector4 Zxzz [get]

return a new vector consisting of the current vector's z, x, z, z values

戻り値:
a new vector consisting of the current vector's z, x, z, z values
Vector2 Zy [get, set]

return a new vector consisting of, or set, the current vector's z, y values

戻り値:
a new vector consisting of the current vector's z, y values
Vector3 Zyw [get, set]

return a new vector consisting of, or set, the current vector's z, y, w values

戻り値:
a new vector consisting of the current vector's z, y, w values
Vector4 Zyww [get]

return a new vector consisting of the current vector's z, y, w, w values

戻り値:
a new vector consisting of the current vector's z, y, w, w values
Vector4 Zywx [get, set]

return a new vector consisting of, or set, the current vector's z, y, w, x values

戻り値:
a new vector consisting of the current vector's z, y, w, x values
Vector4 Zywy [get]

return a new vector consisting of the current vector's z, y, w, y values

戻り値:
a new vector consisting of the current vector's z, y, w, y values
Vector4 Zywz [get]

return a new vector consisting of the current vector's z, y, w, z values

戻り値:
a new vector consisting of the current vector's z, y, w, z values
Vector3 Zyx [get, set]

return a new vector consisting of, or set, the current vector's z, y, x values

戻り値:
a new vector consisting of the current vector's z, y, x values
Vector4 Zyxw [get, set]

return a new vector consisting of, or set, the current vector's z, y, x, w values

戻り値:
a new vector consisting of the current vector's z, y, x, w values
Vector4 Zyxx [get]

return a new vector consisting of the current vector's z, y, x, x values

戻り値:
a new vector consisting of the current vector's z, y, x, x values
Vector4 Zyxy [get]

return a new vector consisting of the current vector's z, y, x, y values

戻り値:
a new vector consisting of the current vector's z, y, x, y values
Vector4 Zyxz [get]

return a new vector consisting of the current vector's z, y, x, z values

戻り値:
a new vector consisting of the current vector's z, y, x, z values
Vector3 Zyy [get]

return a new vector consisting of the current vector's z, y, y values

戻り値:
a new vector consisting of the current vector's z, y, y values
Vector4 Zyyw [get]

return a new vector consisting of the current vector's z, y, y, w values

戻り値:
a new vector consisting of the current vector's z, y, y, w values
Vector4 Zyyx [get]

return a new vector consisting of the current vector's z, y, y, x values

戻り値:
a new vector consisting of the current vector's z, y, y, x values
Vector4 Zyyy [get]

return a new vector consisting of the current vector's z, y, y, y values

戻り値:
a new vector consisting of the current vector's z, y, y, y values
Vector4 Zyyz [get]

return a new vector consisting of the current vector's z, y, y, z values

戻り値:
a new vector consisting of the current vector's z, y, y, z values
Vector3 Zyz [get]

return a new vector consisting of the current vector's z, y, z values

戻り値:
a new vector consisting of the current vector's z, y, z values
Vector4 Zyzw [get]

return a new vector consisting of the current vector's z, y, z, w values

戻り値:
a new vector consisting of the current vector's z, y, z, w values
Vector4 Zyzx [get]

return a new vector consisting of the current vector's z, y, z, x values

戻り値:
a new vector consisting of the current vector's z, y, z, x values
Vector4 Zyzy [get]

return a new vector consisting of the current vector's z, y, z, y values

戻り値:
a new vector consisting of the current vector's z, y, z, y values
Vector4 Zyzz [get]

return a new vector consisting of the current vector's z, y, z, z values

戻り値:
a new vector consisting of the current vector's z, y, z, z values
Vector2 Zz [get]

return a new vector consisting of the current vector's z, z values

戻り値:
a new vector consisting of the current vector's z, z values
Vector3 Zzw [get]

return a new vector consisting of the current vector's z, z, w values

戻り値:
a new vector consisting of the current vector's z, z, w values
Vector4 Zzww [get]

return a new vector consisting of the current vector's z, z, w, w values

戻り値:
a new vector consisting of the current vector's z, z, w, w values
Vector4 Zzwx [get]

return a new vector consisting of the current vector's z, z, w, x values

戻り値:
a new vector consisting of the current vector's z, z, w, x values
Vector4 Zzwy [get]

return a new vector consisting of the current vector's z, z, w, y values

戻り値:
a new vector consisting of the current vector's z, z, w, y values
Vector4 Zzwz [get]

return a new vector consisting of the current vector's z, z, w, z values

戻り値:
a new vector consisting of the current vector's z, z, w, z values
Vector3 Zzx [get]

return a new vector consisting of the current vector's z, z, x values

戻り値:
a new vector consisting of the current vector's z, z, x values
Vector4 Zzxw [get]

return a new vector consisting of the current vector's z, z, x, w values

戻り値:
a new vector consisting of the current vector's z, z, x, w values
Vector4 Zzxx [get]

return a new vector consisting of the current vector's z, z, x, x values

戻り値:
a new vector consisting of the current vector's z, z, x, x values
Vector4 Zzxy [get]

return a new vector consisting of the current vector's z, z, x, y values

戻り値:
a new vector consisting of the current vector's z, z, x, y values
Vector4 Zzxz [get]

return a new vector consisting of the current vector's z, z, x, z values

戻り値:
a new vector consisting of the current vector's z, z, x, z values
Vector3 Zzy [get]

return a new vector consisting of the current vector's z, z, y values

戻り値:
a new vector consisting of the current vector's z, z, y values
Vector4 Zzyw [get]

return a new vector consisting of the current vector's z, z, y, w values

戻り値:
a new vector consisting of the current vector's z, z, y, w values
Vector4 Zzyx [get]

return a new vector consisting of the current vector's z, z, y, x values

戻り値:
a new vector consisting of the current vector's z, z, y, x values
Vector4 Zzyy [get]

return a new vector consisting of the current vector's z, z, y, y values

戻り値:
a new vector consisting of the current vector's z, z, y, y values
Vector4 Zzyz [get]

return a new vector consisting of the current vector's z, z, y, z values

戻り値:
a new vector consisting of the current vector's z, z, y, z values
Vector3 Zzz [get]

return a new vector consisting of the current vector's z, z, z values

戻り値:
a new vector consisting of the current vector's z, z, z values
Vector4 Zzzw [get]

return a new vector consisting of the current vector's z, z, z, w values

戻り値:
a new vector consisting of the current vector's z, z, z, w values
Vector4 Zzzx [get]

return a new vector consisting of the current vector's z, z, z, x values

戻り値:
a new vector consisting of the current vector's z, z, z, x values
Vector4 Zzzy [get]

return a new vector consisting of the current vector's z, z, z, y values

戻り値:
a new vector consisting of the current vector's z, z, z, y values
Vector4 Zzzz [get]

return a new vector consisting of the current vector's z, z, z, z values

戻り値:
a new vector consisting of the current vector's z, z, z, z values


パッケージ Sce.PlayStation.HighLevel.GameEngine2D

パッケージ

package | Base

構成

class | ActionBase
全てのアクションの基底クラス。 [詳細]
class | ActionWithDuration
有限の期間を持つアクションの基底クラス。 抽象クラス。 [詳細]
class | CallFunc
指定した関数を呼び出す、ワンショットアクション。 [詳細]
class | DelayTime
指定した期間ののち終了する、待機アクション。 [詳細]
class | ActionTweenGeneric
汎用的な補間アクションの基底クラス。set/get 関数をセットします。 抽象クラス。 [詳細]
class | ActionTweenGenericVector2
ActionTweenGenericVector2 はスタート値からターゲット値に移行する、シンプルなwiseブレンドを行います。 [詳細]
class | ActionTweenGenericVector4
ActionTweenGenericVector4 はスタート値からターゲット値に移行する、シンプルなwiseブレンドを行います。 [詳細]
class | ActionTweenGenericVector2Scale
ActionTweenGenericVector2Scale は ActionTweenGenericVector2 に似ていますが、 スケール値 (乗法) で実行します。 [詳細]
class | ActionTweenGenericVector2Rotation
ActionTweenGenericVector2Rotation は単位ベクトルを補間します。単位ベクトルは回転で補間します。 [詳細]
class | MoveBy
オフセットの値を現在の位置に徐々に加算していくアクション。 [詳細]
class | MoveTo
指定した目標に徐々に移動するアクション。 [詳細]
class | ScaleBy
現在のスケールに徐々に追加のスケールを追加していくアクション。 [詳細]
class | ScaleTo
指定した値へスケールを徐々にセットしていくアクション。 [詳細]
class | SkewBy
現在のスキュー値に徐々にオフセット値を加算していくアクション。 [詳細]
class | SkewTo
指定した値へ徐々にスキューをセットしていくアクション。 [詳細]
class | RotateBy
現在の回転値に徐々にオフセット値を加算していくアクション。 [詳細]
class | RotateTo
指定した値へ徐々に回転値をセットしていくアクション。 [詳細]
class | TintBy
徐々に色を加算していくアクション。 [詳細]
class | TintTo
指定した値に徐々に色をセットしていくアクション。 [詳細]
class | Sequence
順番に、他の一連のアクションを実行するためのアクション。 [詳細]
class | RepeatForever
他のアクションを永続的に繰り返すアクション。 [詳細]
class | Repeat
アクションを回数指定で繰り返すアクション。 [詳細]
class | ActionManager
ActionManager は Node のアクションを管理するシングルトンオブジェクトです。 メインの Update ループは Director.Update() で呼び出されます。 [詳細]
class | DebugFlags
フラグのビットは Director.Instance.DebugFlags によって使用されます。 デフォルトでは、全てオフです。 [詳細]
class | Director
Director はシーンスタックを管理し、Scheduler と ActionManager の update ループを呼び出すシングルトンです。 開発者自身が独自にメインループを実装する場合、開発者はUpdate / Render / PostSwap 関数をメインループの中で呼び出さなければなりません。 また Director は、グラフィックスコンテキスト (GL) 、SpriteRenderer オブジェクト ( 主に内部的に利用されますが、開発者が直接使うこともできます )、 デバッグ情報を描画する DrawHelpers を保持します。 [詳細]
class | Label
テキストのプリミティブを描画します。2つのタイプのフォントデータをサポートしています:

  • SpriteRenderer に埋め込まれたデバッグフォント。
  • FontMap オブジェクトを使ったもの。
[詳細]
class | Node
ノードは全てのシーングラフノードの基底クラスです。標準的な2D変換行列、子のリスト、親へのハンドラを持ちます。ノードは多くとも1つの親をもつことができます。 [詳細]
class | Plane3D
Plane3D ノードは、シーングラフ内で、ある程度まで3Dの方向性を許可します。 それは、タッチ座標を扱う方法をいくぶんか複雑にします。なのでシーン階層に Plane3D を含んでいる場合、直接 Director.Instance.CurrentScene.Camera.GetTouchPos() を使う代わりに、Plane3D 空間(すべてサブノード)で点を得るのに Node.GetTouchPos() を使うことを確認してください。 [詳細]
class | ParticleSystem
シンプルなパーティクルシステムエフェクト。 [詳細]
class | Particles
ひとつの ParticleSystem を シーングラフノードにラップしたパーティクルクラス。 [詳細]
class | Scene
Scene クラスはシーングラフのルートノードタイプです。 シーンスタックを操作するため Director シングルトンを使い、現在のシーンは Director.Instance.CurrentScene でアクセスします。 2つのシーンが画面遷移のためブレンディングされるときを除き、アクティブになるシーンはひとつだけです。 [詳細]
class | Scheduler
Scheduler は、開発者が登録する update 関数に関連した Node を管理するシングルトンです。 スケジュールされた関数は毎フレーム呼び出されます。または、開発者は特別な間隔で呼び出すこともできます。 Scheduler の update ループは Director.Update() の内部で呼び出されます。 [詳細]
class | SpriteBase
単一のスプライトノードの規定クラス。抽象クラスです。 [詳細]
class | SpriteUV
SpriteUVは、手動で UV を設定するスプライトです。 UV は TRS オブジェクトとして格納されます。 SpriteUVを別個で描画すると、処理が重くなるので注意してください。可能な限り、SpriteList の子として利用してください。 [詳細]
class | SpriteTile
SpriteTile は、TextureInfo 内のタイルインデックス (1D または 2D) を指定する形式のスプライトです。 別個で描画すると、処理が重くなるので注意してください。可能な限り、SpriteList の子として利用してください。 [詳細]
class | SpriteList
描画呼び出しやステートのセットアップの呼び出し回数を削減するため、スプライトを一括して描画します。 SpriteUV や SpriteTile オブジェクトを AddChild() で SpriteList の子として追加するだけで、一括描画を可能にします。 ただし、スプライトの TextureInfo, BlendMode, Color のプロパティは無視されます。それらのプロパティは親の SpriteList に依存します。 [詳細]
struct | RawSpriteTile
RawSpriteTileList で使用される構造体。 [詳細]
class | RawSpriteTileList
描画呼び出しや、ステートのセットアップの回数を減らすため、スプライトを一括して描画します。 SpriteListとは違い、Node オブジェクトのリストを保持する代わりに、より軽いRawSpriteTileのリストを保持します。 これは Node として利用可能な SpriteRenderer のラップです。 [詳細]
class | TransitionScene
画面遷移ノードのための基底クラス。これらのノードは2つのシーンを視覚的に遷移させます。 遷移中は、両方のシーンを Updateし、描画します。 [詳細]
class | TransitionFadeBase
フェイドの画面遷移を行う基底クラス。 両方のシーンをオフスクリーンで描画する必要があります。 [詳細]
class | TransitionSolidFade
TransitionSolidFade は、次のシーンをフェイドする前に、現在のシーンを黒にフェイドします。 [詳細]
class | TransitionCrossFade
TransitionCrossFade は 2つのシーンをクロスフェードさせるために、ブレンドを使います。 フェイドのコントロールに DTween を使うことができます。 [詳細]
class | TransitionDirectionalFade
TransitionDirectionalFade は2つのシーンをクロスフェードさせるのに、変換ブレンドマスクを使います。 クロスフェードのラインは、開発者が指定した方向に沿って動作し、古いシーンが新しいシーンに置き換わります。 [詳細]

関数

delegate void | DSchedulerFunc (float dt)
デリゲート型の関数です。Scheduler は Node.Updateのシグニチャに一致するように追加してください。 関数名の検索と削除を行うため、匿名の関数は使用できません。
delegate float | DTween (float t)
デリゲート型。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
構成

パッケージ Sce.PlayStation.HighLevel.GameEngine2D.Base

構成

class | Camera2D
2Dビューの設定とナビゲーション。 行列のスタックとルーラーと軸の描画には GraphicsContextAlpha と DrawHelpers をお使いください。 [詳細]
class | Frustum
Camera2DとCamera3Dによって使用される視錐台 (Frustum) のオブジェクト。 透視変換に利用します。 [詳細]
class | Camera3D
基本的な3Dカメラ。 [詳細]
class | DrawHelpers
2D/3Dの基本的な描画関数を提供します。このクラスは主にデバッグシェーダーを使った ImmediateMode のオブジェクトです。 パフォーマンスが良くないため、デバッグ以外の用途で DrawHelpers を使用することは推奨しません。 [詳細]
class | EmbeddedDebugFontData
スクリーン用デバッグプリントのための、埋め込みフォントデータ。 [詳細]
class | FontMap
Fontオブジェクトと使用予定のすべての文字を含むテキストを指定して、フォントマップは、文字を格納したTexture2Dオブジェクトと対応するUVテーブルを作成します。このデータは、GameEngine2Dのさまざまなテキスト描画関数で使用されます。 [詳細]
struct | BlendMode
BlendMode はブレンドステート(BlendFunc+'enabled' bool)をラップし、扱いやすい名称として提供します。 [詳細]
class | GraphicsContextAlpha
行列スタックと他の関数でSce.PlayStation.Core.Graphics.GraphicsContextを強化します。 [詳細]
class | Colors
名前の付いた色の定数。 [詳細]
interface | ICamera
Camera2D と Camera3D 用の共通インターフェース。 [詳細]
class | ImmediateMode
イミーディエイトモードの頂点配列は、ImmBegin()/ImmVertex()/ImmEnd()などのOpenGLスタイルのインターフェースを使い、どのフレームでも描画できます。 [詳細]
class | ImmediateModeQuads
ImmediateModeQuads はクワッドの描画を扱うために、ImmediateModeをラップしています。 このクラスはSpriteRenderer や他の場所で使用されます。 [詳細]
class | Input2
Sce.PlayStation.Core.Inputをラップしたクラス。 [詳細]
class | Math
数学/ベクトルライブラリ用に拡張した Math クラス。 [詳細]
struct | Vector2i
Vector2 のint版。 [詳細]
struct | Vector3i
Vector3 の int版。 [詳細]
interface | ICollisionBasics
Bounds2, Sphere2, ConvexPoly2 の共通インターフェース。 [詳細]
struct | Bounds2
An axis aligned box class in 2D. [詳細]
struct | Plane2
A plane class in 2D. [詳細]
struct | Sphere2
A sphere class in 2D. [詳細]
struct | ConvexPoly2
A convex polygon class in 2D. [詳細]
struct | Matrix3
2Dを扱うための 3x3の行列。 [詳細]
class | MatrixStack
OpenGLに似た、シンプルな変換行列のスタックです。直交行列を扱うための工夫がなされています。 [詳細]
class | PitchRoll
ピッチ/ロール回転のヘルパーオブジェクト/関数。 Pitch(x) -> roll(y)の順に回転します。 ロールは-pi, pi、ピッチは-pi/2,pi/2です。 [詳細]
class | RollPitch
Pitch/roll 回転のヘルパーオブジェクト/関数。 Roll(y) -> pitch(x)の順に回転します。 ピッチは-pi, pi、ロールは-pi/2,pi/2です。 [詳細]
class | SpriteRenderer
SpriteRendererは、単純なBeginSprites / AddSprite X N / EndSprite APIでのスプライトの一括描画をラップします。 また、FontMap を使ったテキスト描画関数を提供します。 [詳細]
class | TextureInfo
TextureInfoは、Texture2Dオブジェクトを保持し、関連付けられたタイルのUVデータをキャッシュします。 タイルの転送元領域はテクスチャ全体である必要はなく、UV領域内の任意の大きさのボックスで指定することができます。 TextureInfoは、渡されるTexture2Dオブジェクトの所有権を取得し、Dispose関数で破棄します。 [詳細]
class | Timer
シンプルなタイマー。 [詳細]
struct | TRS
TRSはシーングラフの専門用語です。TRSは平行移動/回転/スケールの2D変換行列を標準的な方法で格納するのために使用されています。 また、向きをもった境界ボックスを定義します。 TRSはスプライトの配置/サイズとスプライトUVの両方を格納するためにも使用します。 [詳細]


クラス Camera2D

2Dビューの設定とナビゲーション。 行列のスタックとルーラーと軸の描画には GraphicsContextAlpha と DrawHelpers をお使いください。 [詳細]

Camera2Dに対する継承グラフ
ICamera

すべてのメンバ一覧

Public メソッド

Camera2D (GraphicsContextAlpha gl, DrawHelpers draw_helpers)
コンストラクタ。
void | SetViewX (Vector2 support, Vector2 center)
ビューの中心と、スケールと回転を決定するXサポートベクトルを指定することにより、2Dビューを定義します。
void | SetViewY (Vector2 support, Vector2 center)
ビューの中心と、スケールと回転を決定するYサポートベクトルを指定することにより、2Dビューを定義します。 Yサポートベクトルは、ビューのワールド座標系で表現される、画面の中心からスクリーンの上端の中央に向かうベクトルです。
void | SetViewFromWidthAndCenter (float width, Vector2 center)
ビューの中心 ( スクリーンの中心であるワールド座標系の点 ) とスクリーンの幅を指定することにより、2Dビューを定義します。 このメソッドは、SetViewX( new Vector2(width*0.5f,0.0f), center ) を行うのと同じです。
void | SetViewFromHeightAndCenter (float height, Vector2 center)
ビューの中心 ( スクリーンの中心であるワールド座標系の点 ) とスクリーンの幅を指定することにより、2Dビューを決定します。 このメソッドは、SetViewY( new Vector2(0.0f,height*0.5f), center )を行うのと同じです。
void | SetViewFromHeightAndBottomLeft (float height, Vector2 bottom_left)
スクリーンの左下のワールド座標と、スクリーンの高さを指定することにより、2Dビューを定義します。
void | SetViewFromWidthAndBottomLeft (float width, Vector2 bottom_left)
スクリーンの左下のワールド座標系と、スクリーンの幅を指定することにより、2Dビューを定義します。
void | SetViewFromViewport ()
ピクセルの座標系で、ビューポートに相当する2Dビューを作成します。 左下が (0,0)、右上がスクリーンのサイズになります。
void | SetAspectFromViewport ()
アスペクト比を更新するため、現在のビューポートを読みます。
Vector2 X ()
スクリーン中央、画面右端の中央に位置する、ワールドベクトル。 アスペクト比が反映されています。
Vector2 Y ()
スクリーン中央、画面上端の中央に位置する、ワールドベクトル。 アスペクト比が反映されています。3d LookAtを使った場合、これはupベクトルの方向にもなります。
Bounds2 CalcBounds ()
スクリーン上でワールドの視界部分の境界(ワールド座標系で)を計算します。 これは、スクリーンのカリング（例えばDrawRulersで使用されます）に使用することができます。 回転がない場合、境界はスクリーンに正確に一致します。
Matrix4 GetTransform ()
Matrix4として、カメラ変換行列 ( 正規直交位置行列 ) を計算します。 GetTransform.InverseOrthonormal（）はビュー行列スタックにプッシュします。
Matrix3 NormalizedToWorldMatrix ()
Matrix3として、正規化したワールド行列を返します。
Vector2 | NormalizedToWorld (Vector2 bottom_left_minus_1_minus_1_top_left_1_1_normalized_screen_pos)
正規化されたスクリーン座標系（-1 - > 1）の点として与えられた、ワールド位置を返します。
Vector2 | GetTouchPos (int nth=0, bool prev=false)
ワールド座標系で引数 nth のタッチ位置を返します。 prev フラグは内部的に使用されます。
void | Navigate (int control)
デバッグ用のナビゲーション : タッチインターフェースのドラッグ/ズームに使用します。
void | Push ()
行列スタック上のすべての必要な行列をプッシュします。
void | Pop ()
行列スタックからすべてのカメラ行列をポップします。
void | DebugDraw (float step)
座標系の矢印とともに、ルーラーの間隔 1、灰色のグリッドと黒の軸でデフォルトのグリッドを描画します。 DebugDraw（）は内部的にプッシュ（）/ポップ（）を呼び出さないことに注意してください。カメラのPush()/Pop()は、開発者が呼び出してください。
float | GetPixelSize ()
現在のビューポートのサイズに基づいて、ワールド座標における"スクリーンピクセル"のサイズを取得します。 例えば、スプライトやフォントを1:1で描画するために必要なスケールファクターを決定するために使用することができます。
void | SetTouchPlaneMatrix (Matrix4 mat)
GetTouchPos（）によって使用される、3次元平面の向きを設定します。3次元のみ対応しています。

プロパティ

Vector2 | Center [get, set]
スクリーン中央に位置するワールド位置。
float | Aspect [get, set]
幅/高さ のアスペクト比。
float | Znear [get, set]
プロジェクションのnear Z値。
float | Zfar [get, set]
プロジェクションのfar Z値。

説明

2Dビューの設定とナビゲーション。 行列のスタックとルーラーと軸の描画には GraphicsContextAlpha と DrawHelpers をお使いください。

コンストラクタとデストラクタ

Camera2D | ( | GraphicsContextAlpha | gl,
 |  | DrawHelpers | draw_helpers
 | ) |  |

コンストラクタ。

引数:
gl | 行列スタックに必要な参照。
draw_helpers | デバッグ描画に必要な参照。

メソッド

void SetViewFromHeightAndCenter | ( | float | height,
 |  | Vector2 | center
 | ) |  |

ビューの中心 ( スクリーンの中心であるワールド座標系の点 ) とスクリーンの幅を指定することにより、2Dビューを決定します。 このメソッドは、SetViewY( new Vector2(0.0f,height*0.5f), center )を行うのと同じです。

このメソッドの呼び出しだけで、カメラを定義することができます。 SetViewFromHeightAndCenter（幅は自動的にアスペクト比から推定されます）必要はありません。

void SetViewFromWidthAndCenter | ( | float | width,
 |  | Vector2 | center
 | ) |  |

ビューの中心 ( スクリーンの中心であるワールド座標系の点 ) とスクリーンの幅を指定することにより、2Dビューを定義します。 このメソッドは、SetViewX( new Vector2(width*0.5f,0.0f), center ) を行うのと同じです。

このメソッドの呼び出しだけで、カメラを定義することができます。 SetViewFromHeightAndCenter（幅は自動的にアスペクト比から推定されます）は必要はありません。


クラス Camera3D

基本的な3Dカメラ。 [詳細]

Camera3Dに対する継承グラフ
ICamera

すべてのメンバ一覧

Public メソッド

Camera3D (GraphicsContextAlpha gl, DrawHelpers draw_helpers)
コンストラクタ。
void | SetFromCamera2D (Camera2D cam2d)
カメラを配置し、2D並行投影ビューに正確にあうように透視変換をセットします。全てのスプライトが Z=0 の平面に描画されているとき、デフォルトになります。
void | SetAspectFromViewport ()
現在のビューポートに基づき、アスペクト比を更新します。
Matrix4 GetTransform ()
Matrix4としてカメラ変換行列（位置行列）を計算します。 GetTransform().InverseOrthonormal() はビュー行列スタックにプッシュするものです。 正規直交行列を返します。
void | Push ()
行列スタックに必要な全ての行列をプッシュします。
void | Pop ()
行列スタックから全てのカメラ行列をポップします。
void | DebugDraw (float step)
標準的なデバッググリッドを描画します。 DebugDraw() は内部的にPush()/Pop()を呼び出さないことに注意してください。カメラのPush()/Pop()は、開発者が呼び出してください。
Vector2 | NormalizedToWorld (Vector2 bottom_left_minus_1_minus_1_top_left_1_1_normalized_screen_pos)
Camera3D.NormalizedToWorldは有効な位置を返しません。なぜなら、それはray/planeの交差であるからです。 Camera2D.NormalizedToWorldとは違うことに、注意してください。
Vector2 | GetTouchPos (int nth=0, bool prev=false)
ワールド座標で引数 nthのタッチ位置を返します。'prev'フラグは内部的に使用します。
Bounds2 CalcBounds ()
SetFromCamera2Dによって設定された、直近の境界を返します。
void | SetViewFromViewport ()
ピクセルサイズ (平面 z =0) のスクリーン境界を最大にする、3Dビューを作成します。正確に3次元視錐台と一致します。視点からz=0平面への距離は、現在のFrustum.FovY値に基づいて計算されます。
float | GetPixelSize ()
現在のビューポートのサイズに基づいて、ワールド座標における'スクリーンピクセル'のサイズを取得します。 例えば、スプライトやフォントを1:1で描画するために必要なスケールファクターを決定するために使用することができます。 SetFromCamera2Dによって設定された最新のBounds2を使用しています。
void | Navigate (int control)
デバッグ用カメラのナビゲーション。
void | SetTouchPlaneMatrix (Matrix4 mat)
GetTouchPos と NormalizedToWorldで使用される、モデル平面行列を設定します。

Public 変数

Vector3 Eye
視点位置。
Vector3 Center
ビューの中央/ターゲットの位置。
Vector3 Up
上方向のベクトル。
Frustum Frustum
透視変換の錐台。
Matrix4 | TouchPlaneMatrix = Matrix4.Identity
このモデル行列はNormalizedToWorld/ GetTouchPosで使用されます。レイトレースのタッチ方向に対して、2D平面を定義します。

説明

基本的な3Dカメラ。

コンストラクタとデストラクタ

Camera3D | ( | GraphicsContextAlpha | gl,
 |  | DrawHelpers | draw_helpers
 | ) |  |

コンストラクタ。

引数:
gl | 行列スタックに必要な参照。
draw_helpers | デバッグ用描画に必要な参照。

メソッド

Vector2 NormalizedToWorld ( Vector2 bottom_left_minus_1_minus_1_top_left_1_1_normalized_screen_pos )

Camera3D.NormalizedToWorldは有効な位置を返しません。なぜなら、それはray/planeの交差であるからです。 Camera2D.NormalizedToWorldとは違うことに、注意してください。

返り値は、2D、タッチ平面のローカル座標内の位置座標として返されます。 この関数は、どの平面と交差しているかを知るために、TouchPlaneMatrixプロパティを使います。そのため、TouchPlaneMatrixを前もって設定しておく必要があります。(設定にはNode.NormalizedToWorldを使用してください)

ICameraを実装しています。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Colors
Static Public 変数

クラス Colors

名前の付いた色の定数。 [詳細]

すべてのメンバ一覧

Static Public 変数

static Vector4 | Black = new Vector4(0,0,0,1)
0,0,0,1
static Vector4 | Red = new Vector4(1,0,0,1)
1,0,0,1
static Vector4 | Green = new Vector4(0,1,0,1)
0,1,0,1
static Vector4 | Yellow = new Vector4(1,1,0,1)
1,1,0,1
static Vector4 | Blue = new Vector4(0,0,1,1)
0,0,1,1
static Vector4 | Magenta = new Vector4(1,0,1,1)
1,0,1,1
static Vector4 | Cyan = new Vector4(0,1,1,1)
0,1,1,1
static Vector4 | White = new Vector4(1,1,1,1)
1,1,1,1
static Vector4 | Lime = new Vector4(0.5f,1.0f,0.0f,1.0f)
0.5,1,0,1
static Vector4 | LightBlue = new Vector4(0.0f,0.5f,1.0f,1.0f)
0,0.5,1,1
static Vector4 | Pink = new Vector4(1.0f,0.0f,0.5f,1.0f)
1,0,0.5,1
static Vector4 | Orange = new Vector4(1.0f,0.5f,0.0f,1.0f)
1,0.5,0,1
static Vector4 | LightCyan = new Vector4(0.0f,1.0f,0.5f,1.0f)
0,1,0.5,1
static Vector4 | Purple = new Vector4(0.5f,0.0f,1.0f,1.0f)
0.5,0,1,1
static Vector4 | Grey05 = new Vector4(0.05f,0.05f,0.05f,1.0f)
0.05,0.05,0.05,1
static Vector4 | Grey10 = new Vector4(0.1f,0.1f,0.1f,1.0f)
0.1,0.1,0.1,1
static Vector4 | Grey20 = new Vector4(0.2f,0.2f,0.2f,1.0f)
0.2,0.2,0.2,1
static Vector4 | Grey30 = new Vector4(0.3f,0.3f,0.3f,1.0f)
0.3,0.3,0.3,1
static Vector4 | Grey40 = new Vector4(0.4f,0.4f,0.4f,1.0f)
0.4,0.4,0.4,1
static Vector4 | Grey50 = new Vector4(0.5f,0.5f,0.5f,1.0f)
0.5,0.5,0.5,1
static Vector4 | Grey60 = new Vector4(0.6f,0.6f,0.6f,1.0f)
0.6,0.6,0.6,1
static Vector4 | Grey70 = new Vector4(0.7f,0.7f,0.7f,1.0f)
0.7,0.7,0.7,1
static Vector4 | Grey80 = new Vector4(0.8f,0.8f,0.8f,1.0f)
0.8,0.8,0.8,1
static Vector4 | Grey90 = new Vector4(0.9f,0.9f,0.9f,1.0f)
0.9,0.9,0.9,1

説明

名前の付いた色の定数。

変数

Vector4 Black = new Vector4(0,0,0,1) [static]

0,0,0,1

Vector4 Blue = new Vector4(0,0,1,1) [static]

0,0,1,1

Vector4 Cyan = new Vector4(0,1,1,1) [static]

0,1,1,1

Vector4 Green = new Vector4(0,1,0,1) [static]

0,1,0,1

Vector4 Grey05 = new Vector4(0.05f,0.05f,0.05f,1.0f) [static]

0.05,0.05,0.05,1

Vector4 Grey10 = new Vector4(0.1f,0.1f,0.1f,1.0f) [static]

0.1,0.1,0.1,1

Vector4 Grey20 = new Vector4(0.2f,0.2f,0.2f,1.0f) [static]

0.2,0.2,0.2,1

Vector4 Grey30 = new Vector4(0.3f,0.3f,0.3f,1.0f) [static]

0.3,0.3,0.3,1

Vector4 Grey40 = new Vector4(0.4f,0.4f,0.4f,1.0f) [static]

0.4,0.4,0.4,1

Vector4 Grey50 = new Vector4(0.5f,0.5f,0.5f,1.0f) [static]

0.5,0.5,0.5,1

Vector4 Grey60 = new Vector4(0.6f,0.6f,0.6f,1.0f) [static]

0.6,0.6,0.6,1

Vector4 Grey70 = new Vector4(0.7f,0.7f,0.7f,1.0f) [static]

0.7,0.7,0.7,1

Vector4 Grey80 = new Vector4(0.8f,0.8f,0.8f,1.0f) [static]

0.8,0.8,0.8,1

Vector4 Grey90 = new Vector4(0.9f,0.9f,0.9f,1.0f) [static]

0.9,0.9,0.9,1

Vector4 LightBlue = new Vector4(0.0f,0.5f,1.0f,1.0f) [static]

0,0.5,1,1

Vector4 LightCyan = new Vector4(0.0f,1.0f,0.5f,1.0f) [static]

0,1,0.5,1

Vector4 Lime = new Vector4(0.5f,1.0f,0.0f,1.0f) [static]

0.5,1,0,1

Vector4 Magenta = new Vector4(1,0,1,1) [static]

1,0,1,1

Vector4 Orange = new Vector4(1.0f,0.5f,0.0f,1.0f) [static]

1,0.5,0,1

Vector4 Pink = new Vector4(1.0f,0.0f,0.5f,1.0f) [static]

1,0,0.5,1

Vector4 Purple = new Vector4(0.5f,0.0f,1.0f,1.0f) [static]

0.5,0,1,1

Vector4 Red = new Vector4(1,0,0,1) [static]

1,0,0,1

Vector4 White = new Vector4(1,1,1,1) [static]

1,1,1,1

Vector4 Yellow = new Vector4(1,1,0,1) [static]

1,1,0,1


クラス DrawHelpers

2D/3Dの基本的な描画関数を提供します。このクラスは主にデバッグシェーダーを使った ImmediateMode のオブジェクトです。 パフォーマンスが良くないため、デバッグ以外の用途で DrawHelpers を使用することは推奨しません。 [詳細]

すべてのメンバ一覧

構成

class | ArrowParams
DrawArrow に渡される矢印のパラメータ。 [詳細]
struct | Vertex
DrawHelpers で使用される頂点 (V4F_C4F)。 [詳細]

Public メソッド

DrawHelpers (GraphicsContextAlpha gl, uint max_vertices)
void | Dispose ()
Dispose の実装。
void | ImmBegin (DrawMode mode, uint max_vertices_intended)
新しいイミーディエイトプリミティブを開始します。
void | ImmVertex (Vertex v)
頂点を現在のプリミティブに追加します。
void | ImmVertex (Vector4 pos)
直近のSetColor() で設定された色を使い、現在のプリミティブに頂点を追加します。
void | ImmVertex (Vector2 pos)
直近のSetColor() で設定された色を使い、現在のプリミティブに頂点を追加します。 (z,w) は (0,1)でセットします。
void | ImmEnd ()
現在のプリミティブを終了します。この関数は、実際の描画呼び出しをトリガー(引き起こし)します。
void | ShaderPush ()
ShaderPush() は現在のMVP行列を読み、現在のシェーダーをセットします。 DrawHelpers ではネストで処理できます。シェーダーのパラメータは内部的に更新されます。
void | ShaderPop ()
シェーダーをポップします。 ShaderPush()の回数は、ShaderPush()の回数に一致しなければなりません。
void | SetColor (Vector4 value)
次の ImmVertex の呼び出しで使われる色をセットします。
void | DrawBounds2Fill (Bounds2 bounds)
四角形を描画します。
void | DrawBounds2 (Bounds2 bounds)
線で四角形を描画します。
void | DrawConvexPoly2 (ConvexPoly2 convex_poly)
凸ポリゴンを描画します。
void | DrawDisk (Vector2 center, float radius, uint n)
塗りつぶした円盤を描画します。
void | DrawCircle (Vector2 center, float radius, uint n)
塗りつぶした円を描画します。
void | DrawCoordinateSystem2D (Matrix3 mat, ArrowParams ap=null)
矢印を使用し、変換行列であらわされる座標系を描画します。 xのベクトルは赤色の矢印で表され、yのベクトルは、緑の矢印で表されます。
void | DrawCoordinateSystem2D ()
x軸とy軸に矢印を描画します。xの矢印は赤 (1,0,0)であり、yの矢印は緑 (0,1,0)です。
void | DrawArrow (Vector2 start_point, Vector2 end_point, ArrowParams ap)
2Dの矢印を描画します。 いくつかの矢印を描画する必要があり、かつ、描画呼び出しの数を制限したい場合には、この関数は ImmBegin()/ ImmEnd()でラップすることができます。 各矢印は、多くとも9頂点を消費します。
void | DrawLineSegment (Vector2 A, Vector2 B)
ひとつの線分を描画します。処理が重いので、多くの線を描画する場合、この関数は使用しないでください。
void | DrawInfiniteLine (Vector2 A, Vector2 v)
単一の線分を描画します。この関数は処理が重いため、多くの線を描画する場合、この関数の使用は避けてください。
void | DrawRulers (Bounds2 bounds, float step_x, float step_y)
指定された矩形内に、垂直および水平の線を等間隔で描画します。 step_x, step_y を小さくすると、より多くのラインプリミティブが生成されるため、イミーディエイト描画モードの頂点バッファが容易にあふれてしまします。そのため、引数の指定には注意してください。
void | DrawAxis (Bounds2 clipping_bounds, float thickness)
厚みのある軸線（x = 0 と y= 0 ライン）を描画します。
void | DrawDefaultGrid (Bounds2 clipping_bounds, Vector2 step, Vector4 rulers_color, Vector4 axis_color)
この関数は、引数'clipping_bounds'の内部に、'step'の値で規則的に垂直・水平の線を描画します。 また、厚みのある2つの軸線を描画します。描画されるすべての線が'clipping_bounds'でクリップされます。 ルーラーを描画するとき、ブレンドモードは変更されません。軸線を描画するとき、ブレンドはDisableになっています。
void | DrawDefaultGrid (Bounds2 clipping_bounds, float step)
デフォルトの色/ブレンドを使ったDrawDefaultGrid()。

プロパティ

bool | Disposed [get]
このオブジェクトが破棄されていれば、trueを返します。

説明

2D/3Dの基本的な描画関数を提供します。このクラスは主にデバッグシェーダーを使った ImmediateMode のオブジェクトです。 パフォーマンスが良くないため、デバッグ以外の用途で DrawHelpers を使用することは推奨しません。

コンストラクタとデストラクタ

DrawHelpers | ( | GraphicsContextAlpha | gl,
 |  | uint | max_vertices
 | ) |  |
引数:
gl | コアグラフィックスのコンテキスト。
max_vertices | この DrawHelpers オブジェクトを使って、1フレームで描画する頂点の最大数。

メソッド

void DrawArrow | ( | Vector2 | start_point,
 |  | Vector2 | end_point,
 |  | ArrowParams | ap
 | ) |  |

2Dの矢印を描画します。 いくつかの矢印を描画する必要があり、かつ、描画呼び出しの数を制限したい場合には、この関数は ImmBegin()/ ImmEnd()でラップすることができます。 各矢印は、多くとも9頂点を消費します。

引数:
start_point | 矢印の開始位置。
end_point | 矢印の先端。
ap | 矢印の幾何情報。
void DrawCircle | ( | Vector2 | center,
 |  | float | radius,
 |  | uint | n
 | ) |  |

塗りつぶした円を描画します。

引数:
center | 中心。
radius | 半径。
n | 分割数。
void DrawDefaultGrid | ( | Bounds2 | clipping_bounds,
 |  | Vector2 | step,
 |  | Vector4 | rulers_color,
 |  | Vector4 | axis_color
 | ) |  |

この関数は、引数'clipping_bounds'の内部に、'step'の値で規則的に垂直・水平の線を描画します。 また、厚みのある2つの軸線を描画します。描画されるすべての線が'clipping_bounds'でクリップされます。 ルーラーを描画するとき、ブレンドモードは変更されません。軸線を描画するとき、ブレンドはDisableになっています。

引数:
clipping_bounds | クリッピングの矩形。
step | ルーラーの間隔。
rulers_color | ルーラーの色。
axis_color | 軸線の色。
void DrawDisk | ( | Vector2 | center,
 |  | float | radius,
 |  | uint | n
 | ) |  |

塗りつぶした円盤を描画します。

引数:
center | 中心。
radius | 半径。
n | 分割数。


クラス DrawHelpers.ArrowParams

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • DrawHelpers
  • ArrowParams
Public メソッド | Public 変数

クラス DrawHelpers.ArrowParams

DrawArrow に渡される矢印のパラメータ。 [詳細]

すべてのメンバ一覧

Public メソッド

ArrowParams (float r=1.0f)
コンストラクタ。

Public 変数

float | HeadRadius
矢印の頭部のベースの長さ。
float | HeadLen
矢印の頭部の長さ。
float | BodyRadius
矢印の本体の半径。
float | Scale
HeadRadius、HeadLen、BodyRadiusに適用されるスケール要素。
uint | HalfMask
矢印の半分を表示します。
float | Offset
矢印の終点は、垂直方向に沿ってオフセットすることができます。

説明

DrawArrow に渡される矢印のパラメータ。


構造体 DrawHelpers.Vertex

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • DrawHelpers
  • Vertex
Public メソッド | Public 変数

構造体 DrawHelpers.Vertex

DrawHelpers で使用される頂点 (V4F_C4F)。 [詳細]

すべてのメンバ一覧

Public メソッド

Vertex (Vector4 pos, Vector4 col)
コンストラクタ。
Vertex (Vector2 pos, Vector4 col)
コンストラクタ。

Public 変数

Vector4 Position
頂点位置。2D位置は、(z,w) を (0,1)に設定します。
Vector4 Color
色。各要素は 0,1の範囲で設定してください(クランプ処理は行われません)。

説明

DrawHelpers で使用される頂点 (V4F_C4F)。

コンストラクタとデストラクタ

Vertex | ( | Vector2 | pos,
 |  | Vector4 | col
 | ) |  |

コンストラクタ。

引数:
pos | (z,w)を(0,1)の設定し、位置を3Dに拡張します。
col | 色。


クラス EmbeddedDebugFontData

スクリーン用デバッグプリントのための、埋め込みフォントデータ。 [詳細]

すべてのメンバ一覧

Static Public メソッド

static Texture2D | CreateTexture ()
フォントデータの Texture2D オブジェクトを作成します。作成したテクスチャは呼び出し側が破棄してください。

Static Public 変数

static Vector2i | CharSizei = new Vector2i( 8, 8 )
ピクセル単位の文字のサイズ。固定サイズのフォントです。
static Vector2 | CharSizef = CharSizei.Vector2()
ピクセル単位の、Vector2での文字のサイズ。

プロパティ

static int | NumChars [get]
このフォントで利用できるアスキー文字の数。' 'から始まります。

説明

スクリーン用デバッグプリントのための、埋め込みフォントデータ。


クラス FontMap

Fontオブジェクトと使用予定のすべての文字を含むテキストを指定して、フォントマップは、文字を格納したTexture2Dオブジェクトと対応するUVテーブルを作成します。このデータは、GameEngine2Dのさまざまなテキスト描画関数で使用されます。 [詳細]

すべてのメンバ一覧

構成

struct | CharData
単一文字のUVデータ。 [詳細]

Public メソッド

FontMap (Font font, int fontmap_width=512)
アスキー文字のフォントマップを作成します。
FontMap (Font font, string charset, int fontmap_width=512)
void | Dispose ()
破棄します。
void | Initialize (Font font, string charset, int fontmap_width=512)
bool | TryGetCharData (char c, out CharData cdata)
引数 'c' の文字を描画するのに必要な CharDataを取得します。

Public 変数

Texture2D Texture
全ての文字を含む、フォントテクスチャ。
Dictionary< char, CharData > | CharSet
文字に対応するCharData (UVとサイズデータ)。
float | CharPixelHeight
ピクセル単位のモズの高さ。すべての文字は同じ高さです。

Static Public 変数

static string | AsciiCharSet = " !\"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\]^_`abcdefghijklmnopqrstuvwxyz{|}~"
アスキー文字を文字列としてセットします。

プロパティ

bool | Disposed [get]
このオブジェクトが破棄されていれば、trueを返します。

説明

Fontオブジェクトと使用予定のすべての文字を含むテキストを指定して、フォントマップは、文字を格納したTexture2Dオブジェクトと対応するUVテーブルを作成します。このデータは、GameEngine2Dのさまざまなテキスト描画関数で使用されます。

コンストラクタとデストラクタ

FontMap | ( | Font | font,
 |  | int | fontmap_width = 512
 | ) |  |

アスキー文字のフォントマップを作成します。

引数:
font | 文字を描画するための使用するフォント。フォントマップは、このFontオブジェクトを破棄することに注意してください。
fontmap_width | テクスチャで使用される内部の幅。高さはすべての文字が収まるように自動的に調整されます。
FontMap | ( | Font | font,
 |  | string | charset,
 |  | int | fontmap_width = 512
 | ) |  |
引数:
font | 文字を描画するための使用するフォント。フォントマップは、このFontオブジェクトを破棄することに注意してください。
charset | このFontMapでテキストを描画するときに必要な全ての文字を含む文字列。
fontmap_width | テクスチャによって使用される内部的な値 (高さは自動で調整されます)。

メソッド

void Initialize | ( | Font | font,
 |  | string | charset,
 |  | int | fontmap_width = 512
 | ) |  |
引数:
font | 文字を描画するための使用するフォント。フォントマップは、このFontオブジェクトを破棄することに注意してください。
charset | このFontMapでテキストを描画するときに必要な全ての文字を含む文字列。
fontmap_width | テクスチャによって使用される内部的な値 (高さは自動で調整されます)。


構造体 FontMap.CharData

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • FontMap
  • CharData
Public 変数

構造体 FontMap.CharData

単一文字のUVデータ。 [詳細]

すべてのメンバ一覧

Public 変数

Bounds2 UV
フォントマップのテクスチャ内のUV。
Vector2 PixelSize
この文字のピクセルサイズ (フォントに依存します)。

説明

単一文字のUVデータ。


クラス Frustum

Camera2DとCamera3Dによって使用される視錐台 (Frustum) のオブジェクト。 透視変換に利用します。 [詳細]

すべてのメンバ一覧

Public メソッド

Frustum ()
コンストラクタ。
Vector4 | GetPoint (Vector2 screen_normalized_pos, float z)
正規化されたスクリーン座標（左下（-1,1）と右上（1,1））の位置とz値から、ビュー空間内の対応する3D位置を返します。

Public 変数

float | Aspect = 1.0f
幅/高さ のアスペクト比。
float | Znear = 0.1f
プロジェクションの near Z値。
float | Zfar = 1000.0f
プロジェクションの far Z値。

プロパティ

Matrix4 | Matrix [get]
行列としてのプロジェクション。
float | FovX [get, set]
X軸に沿ったビューのフィールド。 このプロパティを使用してビューのフィールドを設定した場合、Xはこの錐台のメインの視野方向となり、FovY値の正しさは、アスペクトの値に依存します。
float | FovY [get, set]
Y軸に沿ったビューのフィールド。 このプロパティを使用してビューのフィールドを設定した場合、Yはこの錐台のメインの視野方向となり、FovY値の正しさは、アスペクトの値に依存します。

説明

Camera2DとCamera3Dによって使用される視錐台 (Frustum) のオブジェクト。 透視変換に利用します。


クラス GraphicsContextAlpha

行列スタックと他の関数でSce.PlayStation.Core.Graphics.GraphicsContextを強化します。 [詳細]

すべてのメンバ一覧

構成

class | DebugStats_
現時点では、DebugStats は DrawArrays の呼び出し回数のみ保持します。 [詳細]

Public メソッド

GraphicsContextAlpha (Sce.PlayStation.Core.Graphics.GraphicsContext context=null)
コンストラクタ。
void | Dispose ()
Disposeの実装。
Matrix4 GetMVP ()
GetMVP() は ProjectionMatrix.Get() * ViewMatrix.Get() * ModelMatrix.Get() へのショートカットです。
float | GetAspect ()
GetAspect() はビューポートのアスペクト比 ( width/height ) を返すショートカットです。
Bounds2 GetViewportf ()
この関数は、Bounds2 オブジェクトとして、ビューポートを返します。
void | SetDepthMask (bool write)
writeで深度値をマスクします。
void | SetBlendMode (BlendMode mode)
ブレンドモードを設定します。

Static Public メソッド

static Texture2D | CreateTextureUnicolor (uint color)
同じ色でピクセルを塗りつぶした、小さなテクスチャを作成します。
static Texture2D | CreateTextureFromFont (string text, Font font, uint color=0xffffffff)
Fontオブジェクトとtextを指定し、textを表すテクスチャを作成します。

Public 変数

MatrixStack ModelMatrix
OpenGLに似た、モデル行列スタック。
MatrixStack ViewMatrix
OpenGLに似た、ビュー行列のスタック。
MatrixStack ProjectionMatrix
OpenGLに似た、プロジェクション行列スタック。
DebugStats_ DebugStats
シンプルなプロファイリングのためのDebugStats。

プロパティ

Sce.PlayStation.Core.Graphics.GraphicsContext | Context [get]
コアグラフィックスのコンテキスト。
bool | Disposed [get]
このオブジェクトが破棄されていれば、trueを返します。
TextureInfo | WhiteTextureInfo [get]
全てのピクセルを 0xffffffffにセットした、小さな白いテクスチャを、TextureInfoとして返します。

説明

行列スタックと他の関数でSce.PlayStation.Core.Graphics.GraphicsContextを強化します。


クラス GraphicsContextAlpha.DebugStats_

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • GraphicsContextAlpha
  • DebugStats_
Public 変数

クラス GraphicsContextAlpha.DebugStats_

現時点では、DebugStats は DrawArrays の呼び出し回数のみ保持します。 [詳細]

すべてのメンバ一覧

Public 変数

uint DrawArraysCount = 0
GameEngine2D ライブラリで呼び出される DrawArraysの回数 (開発者自身の呼び出しは含みません)。 DrawArraysは重い関数なので、このカウンタは役に立つプロファイル情報です。

説明

現時点では、DebugStats は DrawArrays の呼び出し回数のみ保持します。


クラス テンプレート ImmediateMode< T >

イミーディエイトモードの頂点配列は、ImmBegin()/ImmVertex()/ImmEnd()などのOpenGLスタイルのインターフェースを使い、どのフレームでも描画できます。 [詳細]

すべてのメンバ一覧

Public メソッド

ImmediateMode (GraphicsContextAlpha gl, uint max_vertices, ushort[] indices, int vertices_per_primitive, int indices_per_primitive, params VertexFormat[] formats)
ImmediateModeのコンストラクタです。
void | Dispose ()
Disposeの実装。
void | ImmBegin (DrawMode mode, uint max_vertices_intended)
描画プリミティブの開始。
void | ImmVertex (T vertex)
頂点を追加します。ImmBeginとImmEndの間で呼ぶ必要があります。
void | ImmEnd ()
描画プリミティブを終了し、描画処理を行います。
void | ImmEndIndexing ()
ImmediateMode のコンストラクタに渡される引数'vertices_per_primitive' and 'indices_per_primitive' を使った、ImmEndの特別なバージョンです。すべてのプリミティブは同じ数の頂点を消費することを想定しています。

プロパティ

bool | Disposed [get]
このオブジェクトが破棄されている場合、trueを返します。
bool | ImmActive [get]
ImmBegin()/ImmEnd()の間で呼ばれると、trueを返します。
uint | MaxVertices [get]
フレームごとに追加可能な、最大(合計)頂点数を返します。

説明

template<T>
class Sce::PlayStation::HighLevel::GameEngine2D::Base::ImmediateMode< T >

イミーディエイトモードの頂点配列は、ImmBegin()/ImmVertex()/ImmEnd()などのOpenGLスタイルのインターフェースを使い、どのフレームでも描画できます。

メソッド

void ImmBegin | ( | DrawMode | mode,
 |  | uint | max_vertices_intended
 | ) |  |

描画プリミティブの開始。

引数:
mode | 描画プリミティブのタイプ。
max_vertices_intended | 描画予定の最大頂点数。
ImmediateMode | ( | GraphicsContextAlpha | gl,
 |  | uint | max_vertices,
 |  | ushort[] | indices,
 |  | int | vertices_per_primitive,
 |  | int | indices_per_primitive,
 |  | params VertexFormat[] | formats
 | ) |  |

ImmediateModeのコンストラクタです。

インデックスがnullでない場合は、vertices_per_primitiveとindices_per_primitiveは、以下の制約に従う必要があります。

  • vertices_per_primitiveは0であってはならない
  • indices_per_primitiveは0であってはならない
  • max_verticesはvertices_per_primitiveの倍数でなければなりません
  • indices.Lengthはindices_per_primitiveの倍数でなければなりません
  • max_vertices/ vertices_per_primitiveはindices.Length/ indices_per_primitiveに等しくなければなりません

これらの制約のいずれかが満たされていない場合、コンストラクタは警告を出します。

ImmediateModeは、Common.OnSwap() でインクリメントされるフレームカウンタに依存していることに注意してください。 GameEngine2D.Directorを使用する流れでは、Common.OnSwap()はDirector.Instance.PostSwap()の内部で呼ばれてるようになっています。 ImmediateModeを "スタンドアローン"を使用する場合でも、GameEngine2Dのフレームカウンタがインクリメントされているか確認するため、毎フレームCommon.OnSwap()を呼び出す必要があります。（呼び出されないと、メモリリークが発生します)。

引数:
gl | コアグラフィックスのコンテキスト。
max_vertices | 1フレームあたりの最大頂点数。
indices | インデックスの配列 (nullでも可)。静的な設定を仮定しています。
vertices_per_primitive | インデックスがnullでない場合、これは各ImmBeginが持つ予定の頂点数に設定する必要があります。インデックスがnullの場合は、0に設定されています。
indices_per_primitive | インデックスがnullでない場合、これは各プリミティブごとに描画したいインデックスの数に設定する必要があります。インデックスがnullの場合は、0に設定されています。
formats | VertexBufferに渡される頂点フォーマット。


クラス テンプレート ImmediateModeQuads< T >

ImmediateModeQuads はクワッドの描画を扱うために、ImmediateModeをラップしています。 このクラスはSpriteRenderer や他の場所で使用されます。 [詳細]

すべてのメンバ一覧

Public メソッド

ImmediateModeQuads (GraphicsContextAlpha gl, uint max_quads, params VertexFormat[] formats)
コンストラクタ。
void | Dispose ()
Disposeの実装。
void | ImmBeginQuads (uint num_quads)
描画のため、nクワッドを登録する準備をします。
void | ImmAddQuad (T v0, T v1, T v2, T v3)
クワッドの追加。
void | ImmAddQuad (T[] v)
クワッドの追加
void | ImmEndQuads ()
最後のImmBeginQuads以降に追加された全てのクワッドを描画します。

プロパティ

bool | Disposed [get]
このオブジェクトが破棄されていれば、trueを返します。
uint | MaxQuads [get]
フレームごとに追加可能なクワッドの最大数(合計)を返します。

説明

template<T>
class Sce::PlayStation::HighLevel::GameEngine2D::Base::ImmediateModeQuads< T >

ImmediateModeQuads はクワッドの描画を扱うために、ImmediateModeをラップしています。 このクラスはSpriteRenderer や他の場所で使用されます。

メソッド

void ImmAddQuad | ( | T | v0,
 |  | T | v1,
 |  | T | v2,
 |  | T | v3
 | ) |  |

クワッドの追加。

v2----v3

| |

v0----v1

void ImmAddQuad ( T[] v )

クワッドの追加

v[2]----v[3]

| |

v[0]----v[1]

void ImmBeginQuads ( uint num_quads )

描画のため、nクワッドを登録する準備をします。

引数:
num_quads 追加する予定のクワッドの最大数。


クラス Input2

Sce.PlayStation.Core.Inputをラップしたクラス。 [詳細]

すべてのメンバ一覧

構成

struct | ButtonState
ボタンのデータ構造体は Input.GamePad、Input.Touch、Keyboardなどのヘルパーラップで共有されます。 [詳細]
class | GamePad
Input.GamePad (button bits) をラップしたクラス。 [詳細]
class | GamePadData
Input.GamePadData をラップしたクラス。 [詳細]
class | Touch
Input.Touch をラップしたクラス。 [詳細]
class | TouchData
Input.TouchData をラップしたクラス。 [詳細]

プロパティ

static TouchData | Touch00 [get]
Touch.GetData(0)[0] のエイリアス(別名)。
static GamePadData | GamePad0 [get]
GamePad.GetData(0) のエイリアス。

説明

Sce.PlayStation.Core.Inputをラップしたクラス。

例:

if ( Input2.GamePad.GetData(0).Left.Down ) // ゲームパッドの左ボタンが押されている。

if ( Input2.GamePad0.Left.Down ) // 上記と同じですが、GamePad.GetData(0)のエイリアス(別名) 'GamePad0' を使用しています。

if ( Input2.GamePad0.Square.Release ) // ゲームパッドの□ボタンが離された瞬間。

if ( Input2.Keyboard0.Left.Press ) // キーボードの左キーが押された瞬間。

if ( Input2.Keyboard0.S.On ) // キーボードのSキーが1フレーム以上押され続けている。


クラス Input2.GamePad

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Input2
  • GamePad
Static Public メソッド

クラス Input2.GamePad

Input.GamePad (button bits) をラップしたクラス。 [詳細]

すべてのメンバ一覧

Static Public メソッド

static GamePadData GetData (uint deviceIndex=0)

説明

Input.GamePad (button bits) をラップしたクラス。

メソッド

static GamePadData GetData ( uint deviceIndex = 0 ) [static]


クラス Input2.GamePadData

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Input2
  • GamePadData
Public メソッド | Public 変数

クラス Input2.GamePadData

Input.GamePadData をラップしたクラス。 [詳細]

すべてのメンバ一覧

Public メソッド

void | SetData (Sce.PlayStation.Core.Input.GamePadData data)
デフォルトでは、Sce.PlayStation.HighLevel.GameEngine2D.Base.Input2は、単に自動的に入力データを取得しますが、この動作をオーバーライドして、データを手動で設定することができます。 Skipフラグをtrueにセットすると、すべてのタッチ・ボタンの入力は Sce.PlayStation.HighLevel.GameEngine2D.Base.Input2内で無視されるようになります。 いったん SetData を呼び出すと、手動/外部コントローラのふるまいを永続的に可能にします。

Public 変数

ButtonState | Left = ButtonState.Default
ButtonState | Up = ButtonState.Default
ButtonState | Right = ButtonState.Default
ButtonState | Down = ButtonState.Default
ButtonState | Square = ButtonState.Default
ButtonState | Triangle = ButtonState.Default
ButtonState | Circle = ButtonState.Default
ButtonState | Cross = ButtonState.Default
ButtonState | Start = ButtonState.Default
ButtonState | Select = ButtonState.Default
ButtonState | L = ButtonState.Default
ButtonState | R = ButtonState.Default
Vector2 Dpad = GameEngine2D.Base.Math._00
Vector2 | AnalogLeft = new Vector2()
Vector2 | AnalogRight = new Vector2()

説明

Input.GamePadData をラップしたクラス。

変数

Vector2 AnalogLeft = new Vector2()
Vector2 AnalogRight = new Vector2()
ButtonState Circle = ButtonState.Default
ButtonState Cross = ButtonState.Default
ButtonState Down = ButtonState.Default
Vector2 Dpad = GameEngine2D.Base.Math._00
ButtonState L = ButtonState.Default
ButtonState Left = ButtonState.Default
ButtonState R = ButtonState.Default
ButtonState Right = ButtonState.Default
ButtonState Select = ButtonState.Default
ButtonState Square = ButtonState.Default
ButtonState Start = ButtonState.Default
ButtonState Triangle = ButtonState.Default
ButtonState Up = ButtonState.Default


クラス Input2.Touch

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Input2
  • Touch
Static Public メソッド | プロパティ

クラス Input2.Touch

Input.Touch をラップしたクラス。 [詳細]

すべてのメンバ一覧

Static Public メソッド

static TouchData[] | GetData (uint deviceIndex=0)

プロパティ

static int | MaxTouch [get]

説明

Input.Touch をラップしたクラス。

メソッド

static TouchData [] GetData ( uint deviceIndex = 0 ) [static]

プロパティ

int MaxTouch [static, get]


クラス Input2.TouchData

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Input2
  • TouchData
プロパティ

クラス Input2.TouchData

Input.TouchData をラップしたクラス。 [詳細]

すべてのメンバ一覧

プロパティ

Vector2 | Pos [get]
グラフィックスシステムとの一貫性を保つために、この関数は正規化された画面座標でのタッチ位置を返します。 : 左下（-1,1）、右上（1,1）。
bool | Down [get]
このフレームでタッチしている場合、trueを返します。
bool | Press [get]
前のフレームでタッチしておらず、このフレームでタッチしている場合、trueを返します。
bool | On [get]
前のフレームでタッチしており、このフレームでもタッチしている場合、trueを返します。
bool | Release [get]
前のフレームでタッチしており、このフレームでタッチしていない場合、trueを返します。

説明

Input.TouchData をラップしたクラス。


構造体 Input2.ButtonState

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Input2
  • ButtonState
プロパティ

構造体 Input2.ButtonState

ボタンのデータ構造体は Input.GamePad、Input.Touch、Keyboardなどのヘルパーラップで共有されます。 [詳細]

すべてのメンバ一覧

プロパティ

bool | Down [get]
このフレームでボタンが押されているなら、trueを返します。
bool | Press [get]
前のフレームでボタンが押されておらず、このフレームでボタンが押されているなら、trueを返します。
bool | On [get]
前のフレームでもボタンが押されており、このフレームでボタンが押されている場合、trueを返します。
bool | Release [get]
前のフレームでボタンを押しており、このフレームで押されていない場合、trueを返します。

説明

ボタンのデータ構造体は Input.GamePad、Input.Touch、Keyboardなどのヘルパーラップで共有されます。


クラス Math

数学/ベクトルライブラリ用に拡張した Math クラス。 [詳細]

すべてのメンバ一覧

構成

class | RandGenerator
System.Randomをラップし、ベクトルの乱数生成を拡張したクラス。 [詳細]

Static Public メソッド

static Matrix4 | LookAt (Vector3 eye, Vector3 center, Vector3 _Up)
カメラのルックアット行列を計算します。ベクトル（視点、中央）を-zにマップし（OpenGLはZを下向きにみるので）、上方向をyにマップします。
static void | TranslationRotationScale (ref Matrix3 ret, Vector2 translation, Vector2 rotation, Vector2 scale)
Matrix3 TRS 行列の高速ビルド。
static float | Det (Vector2 value1, Vector2 value2)
static float | Sign (float x)
xの符号を返します。xが0.0fなら0.0fを返します。
static Vector2 | Perp (Vector2 value)
pi/2で回転した値を返します。
static Vector4 | SetAlpha (Vector4 value, float w)
アルファ値を設定します。(数学式でインライン化することができます)
static float | SafeAcos (float x)
SafeAcos xが[-1,1]の範囲内にあることをチェックし、イプシロンによってオフになるなら、それをクランプします。
static float | Angle (Vector2 value)
(1,0)と引数 valueのなす2Dの絶対角を、-pi～piの範囲で返します。
static Vector2 | Rotate (Vector2 point, float angle, Vector2 pivot)
'pivot'を中心に、角度 ' angle'(ラジアン)で 'point'を回転します。
static float | Deg2Rad (float value)
度数をラジアンに変換します。
static float | Rad2Deg (float value)
ラジアンを度数に変換します。
static Vector2 | Deg2Rad (Vector2 value)
度数をラジアンに変換します。
static Vector2 | Rad2Deg (Vector2 value)
ラジアンを度数に変換します。
static float | Lerp (float a, float b, float x)
線形補間。
static Vector2 | Lerp (Vector2 a, Vector2 b, float x)
線形補間。
static Vector3 | Lerp (Vector3 a, Vector3 b, float x)
線形補間。
static Vector4 | Lerp (Vector4 a, Vector4 b, float x)
線形補間。
static Vector2 | LerpUnitVectors (Vector2 va, Vector2 vb, float x)
2つの単位ベクトルで線形補間を行います。補間はパスの短い側で行います。
static float | LerpAngles (float a, float b, float x)
引数の2つの角度で線形補間を行います。補間はパスの短い側で行います。
static float | Sin (uint period, float phase, uint mstime)
uint型の値をとる、安全なサイン関数。
static float | Sin (ulong period, float phase, ulong mstime)
ulong型の値をとる、安全なサイン関数。
static float | Linear (float x)
この関数は単なる f(x)=x です。Tween関数として渡すとき、コードをより明快にするため定義されています。
static float | PowerfulScurve (float x, float p1, float p2)
制御可能な曲線であり、少ないコードでカーブのイン/アウト多項式を容易に行うことができます。
static float | PowEaseIn (float x, float p)
Ease in curve using Pow.
static float | PowEaseOut (float x, float p)
Ease out curve using Pow.
static float | PowEaseInOut (float x, float p)
PowEaseIn/PowEaseOut mirrored around 0.5,0.5.
static float | ExpEaseOut (float x, float a)
Ease out curve using a 1-exp(-a*x) exponential, but normalized so that we reach 1 when x=1.
static float | ExpEaseIn (float x, float a)
Ease in curve using an exponential.
static float | BackEaseIn (float x, float a)
BackEaseIn function (see http://www.robertpenner.com)
static float | BackEaseOut (float x, float a)
BackEaseOut function (see http://www.robertpenner.com)
static float | BackEaseInOut (float x, float p)
BackEaseIn/BackEaseOut mirrored around 0.5,0.5.
static float | Impulse (float x, float b)
Impulse function (source Inigo Quilez).
static float | ShockWave (float d, float time, float wave_half_width, float wave_speed, float wave_fade, float d_scale)
Travelling wave function.
static int | Log2 (int v)
Return the log of v in base 2.
static bool | IsPowerOf2 (int i)
'i'が2のべき乗である場合、trueを返します。
static int | GreatestOrEqualPowerOf2 (int i)
引数 i に大きい側で最も近い、もしくは等しい2のべき乗を返します。
static Vector2 | ClosestSegmentPoint (Vector2 P, Vector2 A, Vector2 B)
Return the closest point to P that's on segment [A,B].

Static Public 変数

static Vector2i | _00i = new Vector2i(0,0)
static Vector2i | _10i = new Vector2i(1,0)
static Vector2i | _01i = new Vector2i(0,1)
static Vector2i | _11i = new Vector2i(1,1)
static Vector3i | _000i = new Vector3i(0,0,0)
static Vector3i | _100i = new Vector3i(1,0,0)
static Vector3i | _010i = new Vector3i(0,1,0)
static Vector3i | _110i = new Vector3i(1,1,0)
static Vector3i | _001i = new Vector3i(0,0,1)
static Vector3i | _101i = new Vector3i(1,0,1)
static Vector3i | _011i = new Vector3i(0,1,1)
static Vector3i | _111i = new Vector3i(1,1,1)
static Vector2 | _00 = new Vector2(0.0f,0.0f)
static Vector2 | _10 = new Vector2(1.0f,0.0f)
static Vector2 | _01 = new Vector2(0.0f,1.0f)
static Vector2 | _11 = new Vector2(1.0f,1.0f)
static Vector3 | _000 = new Vector3(0.0f,0.0f,0.0f)
static Vector3 | _100 = new Vector3(1.0f,0.0f,0.0f)
static Vector3 | _010 = new Vector3(0.0f,1.0f,0.0f)
static Vector3 | _110 = new Vector3(1.0f,1.0f,0.0f)
static Vector3 | _001 = new Vector3(0.0f,0.0f,1.0f)
static Vector3 | _101 = new Vector3(1.0f,0.0f,1.0f)
static Vector3 | _011 = new Vector3(0.0f,1.0f,1.0f)
static Vector3 | _111 = new Vector3(1.0f,1.0f,1.0f)
static Vector4 | _0000 = new Vector4(0.0f,0.0f,0.0f,0.0f)
static Vector4 | _1000 = new Vector4(1.0f,0.0f,0.0f,0.0f)
static Vector4 | _0100 = new Vector4(0.0f,1.0f,0.0f,0.0f)
static Vector4 | _1100 = new Vector4(1.0f,1.0f,0.0f,0.0f)
static Vector4 | _0010 = new Vector4(0.0f,0.0f,1.0f,0.0f)
static Vector4 | _1010 = new Vector4(1.0f,0.0f,1.0f,0.0f)
static Vector4 | _0110 = new Vector4(0.0f,1.0f,1.0f,0.0f)
static Vector4 | _1110 = new Vector4(1.0f,1.0f,1.0f,0.0f)
static Vector4 | _0001 = new Vector4(0.0f,0.0f,0.0f,1.0f)
static Vector4 | _1001 = new Vector4(1.0f,0.0f,0.0f,1.0f)
static Vector4 | _0101 = new Vector4(0.0f,1.0f,0.0f,1.0f)
static Vector4 | _1101 = new Vector4(1.0f,1.0f,0.0f,1.0f)
static Vector4 | _0011 = new Vector4(0.0f,0.0f,1.0f,1.0f)
static Vector4 | _1011 = new Vector4(1.0f,0.0f,1.0f,1.0f)
static Vector4 | _0111 = new Vector4(0.0f,1.0f,1.0f,1.0f)
static Vector4 | _1111 = new Vector4(1.0f,1.0f,1.0f,1.0f)
static Vector4 | UV_TransformIdentity = new Vector4( 0.0f, 0.0f, 1.0f, 1.0f )
UV transform stored as (offset, scale) in a Vector4.
static Vector4 | UV_TransformFlipV = new Vector4( 0.0f, 1.0f, 1.0f, -1.0f )
UV transform stored as (offset, scale) in a Vector4 UV_TransformFlipV v into 1-v, and leaves u unchanged.

プロパティ

static float | Pi [get]
static float | TwicePi [get]
2pi
static float | HalfPi [get]
pi/2

説明

数学/ベクトルライブラリ用に拡張した Math クラス。

メソッド

static float Det | ( | Vector2 | value1,
 |  | Vector2 | value2
 | ) |  | [static]

2つのベクトルの行列式を返します。

static float PowEaseInOut | ( | float | x,
 |  | float | p
 | ) |  | [static]

PowEaseIn/PowEaseOut mirrored around 0.5,0.5.

Same exponent in and out.

static float PowerfulScurve | ( | float | x,
 |  | float | p1,
 |  | float | p2
 | ) |  | [static]

制御可能な曲線であり、少ないコードでカーブのイン/アウト多項式を容易に行うことができます。

引数:
x | Asssumed to be in 0,1.
p1 | Controls the ease in exponent (if >1).
p2 | Controls the ease out exponent (if >1.),(p1,p2)=(1,1) just gives f(x)=x

変数

Vector2 _00 = new Vector2(0.0f,0.0f) [static]
Vector3 _000 = new Vector3(0.0f,0.0f,0.0f) [static]
Vector4 _0000 = new Vector4(0.0f,0.0f,0.0f,0.0f) [static]
Vector4 _0001 = new Vector4(0.0f,0.0f,0.0f,1.0f) [static]
Vector3i _000i = new Vector3i(0,0,0) [static]
Vector3 _001 = new Vector3(0.0f,0.0f,1.0f) [static]
Vector4 _0010 = new Vector4(0.0f,0.0f,1.0f,0.0f) [static]
Vector4 _0011 = new Vector4(0.0f,0.0f,1.0f,1.0f) [static]
Vector3i _001i = new Vector3i(0,0,1) [static]
Vector2i _00i = new Vector2i(0,0) [static]
Vector2 _01 = new Vector2(0.0f,1.0f) [static]
Vector3 _010 = new Vector3(0.0f,1.0f,0.0f) [static]
Vector4 _0100 = new Vector4(0.0f,1.0f,0.0f,0.0f) [static]
Vector4 _0101 = new Vector4(0.0f,1.0f,0.0f,1.0f) [static]
Vector3i _010i = new Vector3i(0,1,0) [static]
Vector3 _011 = new Vector3(0.0f,1.0f,1.0f) [static]
Vector4 _0110 = new Vector4(0.0f,1.0f,1.0f,0.0f) [static]
Vector4 _0111 = new Vector4(0.0f,1.0f,1.0f,1.0f) [static]
Vector3i _011i = new Vector3i(0,1,1) [static]
Vector2i _01i = new Vector2i(0,1) [static]
Vector2 _10 = new Vector2(1.0f,0.0f) [static]
Vector3 _100 = new Vector3(1.0f,0.0f,0.0f) [static]
Vector4 _1000 = new Vector4(1.0f,0.0f,0.0f,0.0f) [static]
Vector4 _1001 = new Vector4(1.0f,0.0f,0.0f,1.0f) [static]
Vector3i _100i = new Vector3i(1,0,0) [static]
Vector3 _101 = new Vector3(1.0f,0.0f,1.0f) [static]
Vector4 _1010 = new Vector4(1.0f,0.0f,1.0f,0.0f) [static]
Vector4 _1011 = new Vector4(1.0f,0.0f,1.0f,1.0f) [static]
Vector3i _101i = new Vector3i(1,0,1) [static]
Vector2i _10i = new Vector2i(1,0) [static]
Vector2 _11 = new Vector2(1.0f,1.0f) [static]
Vector3 _110 = new Vector3(1.0f,1.0f,0.0f) [static]
Vector4 _1100 = new Vector4(1.0f,1.0f,0.0f,0.0f) [static]
Vector4 _1101 = new Vector4(1.0f,1.0f,0.0f,1.0f) [static]
Vector3i _110i = new Vector3i(1,1,0) [static]
Vector3 _111 = new Vector3(1.0f,1.0f,1.0f) [static]
Vector4 _1110 = new Vector4(1.0f,1.0f,1.0f,0.0f) [static]
Vector4 _1111 = new Vector4(1.0f,1.0f,1.0f,1.0f) [static]
Vector3i _111i = new Vector3i(1,1,1) [static]
Vector2i _11i = new Vector2i(1,1) [static]
Vector4 UV_TransformIdentity = new Vector4( 0.0f, 0.0f, 1.0f, 1.0f ) [static]

UV transform stored as (offset, scale) in a Vector4.

offset=0,0 scale=1,1 means identity.

プロパティ

float HalfPi [static, get]

pi/2

float Pi [static, get]
float TwicePi [static, get]

2pi


クラス Math.RandGenerator

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Math
  • RandGenerator
Public メソッド | Public 変数

クラス Math.RandGenerator

System.Randomをラップし、ベクトルの乱数生成を拡張したクラス。 [詳細]

すべてのメンバ一覧

Public メソッド

RandGenerator (int seed=0)
float | NextFloat0_1 ()
0～1のランダムな浮動小数点数を返します。
float | NextFloatMinus1_1 ()
-1～1のランダムな浮動小数点数を返します。
float | NextFloat (float mi, float ma)
mi～maのランダムな浮動小数点を返します。
Vector2 NextVector2Minus1_1 ()
-1～1のランダムな Vector2 を返します。
Vector2 | NextVector2 (Vector2 mi, Vector2 ma)
mi～maのランダムな Vector2 を返します。
Vector2 | NextVector2 (float mi, float ma)
mi～maのランダムな Vector2 を返します。
Vector3 | NextVector3 (Vector3 mi, Vector3 ma)
mi～maのランダムな Vector3 を返します。
Vector4 | NextVector4 (Vector4 mi, Vector4 ma)
mi～maのランダムな Vector4 を返します。
Vector4 | NextVector4 (float mi, float ma)
mi～maのランダムな Vector4 を返します。

Public 変数

System.Random | Random
生の乱数生成器。

説明

System.Randomをラップし、ベクトルの乱数生成を拡張したクラス。

コンストラクタとデストラクタ

RandGenerator ( int seed = 0 )


クラス MatrixStack

OpenGLに似た、シンプルな変換行列のスタックです。直交行列を扱うための工夫がなされています。 [詳細]

すべてのメンバ一覧

Public メソッド

MatrixStack (uint capacity)
コンストラクタ。
void | Push ()
現在トップにある行列をコピーして、スタックにプッシュします。
void | Pop ()
トップの行列をポップします。
void | Mul (Matrix4 mat)
引数の 'mat' でトップの行列を右側から乗算します。
void | Mul1 (Matrix4 mat)
直交行列 'mat' でトップの行列を右側から乗算します。もし行列が正規直交行列であることがわかっていれば、Mul()のかわりに Mul1()を使うことができます。正規直交行列で演算し続ける限り、逆計算はより速くなります。
void | Set (Matrix4 mat)
行列スタックのトップに、現在の行列をセットします。
void | Set1 (Matrix4 mat)
正規直交行列を設定します。行列が正規直交であることが事前にわかっている場合、Set()の代わりにSet1()を使用することができます。正規直交行列で演算する限り、逆数計算はより速くなります。
Matrix4 Get ()
現在、行列スタックのトップの行列を取得します。
Matrix4 GetInverse ()
キャッシュされた逆行列を必要に応じて更新し、返します。
void | SetIdentity ()
トップの行列に単位行列をセットします。
void | RotateX (float angle)
トップの行列をX軸まわりで回転させます。
void | RotateY (float angle)
トップの行列をY軸まわりで回転させます。
void | RotateZ (float angle)
トップの行列をZ軸まわりで回転させます。
void | Rotate (Vector3 axis, float angle)
開発者が指定した軸で、トップの行列を回転させます。
void | Scale (Vector3 value)
トップの行列をスケールさせます。
void | Translate (Vector3 value)
トップの行列を平行移動させます。

プロパティ

uint | Tag [get]
Tag は一番上の行列の内容が変化したとき、インクリメントされる数値です。
uint | Size [get]
現在のスタックのサイズ。
uint | Capacity [get]
最大スタックサイズ。

説明

OpenGLに似た、シンプルな変換行列のスタックです。直交行列を扱うための工夫がなされています。

コンストラクタとデストラクタ

MatrixStack ( uint capacity )

コンストラクタ。

引数:
capacity スタックの最大の深さ。


クラス PitchRoll

ピッチ/ロール回転のヘルパーオブジェクト/関数。 Pitch(x) -> roll(y)の順に回転します。 ロールは-pi, pi、ピッチは-pi/2,pi/2です。 [詳細]

すべてのメンバ一覧

Public メソッド

PitchRoll ()
PitchRoll (Vector2 v)
PitchRoll (Vector3 v)
Vector3 ToVector ()
Matrix4 ToMatrix ()

Static Public メソッド

static Vector2 | FromVector (Vector3 v)
ピッチ x とロール y を返します。
static Vector3 | ToVector (Vector2 a)
ロール -> ピッチで回転させた z=(0,0,1)を返します。

Public 変数

Vector2 Data
x: ピッチ y: ロール (ラジアン)

説明

ピッチ/ロール回転のヘルパーオブジェクト/関数。 Pitch(x) -> roll(y)の順に回転します。 ロールは-pi, pi、ピッチは-pi/2,pi/2です。

コンストラクタとデストラクタ

PitchRoll ( )
PitchRoll ( Vector2 v )
PitchRoll ( Vector3 v )

メソッド

Matrix4 ToMatrix ( )
Vector3 ToVector ( )


クラス RollPitch

Pitch/roll 回転のヘルパーオブジェクト/関数。 Roll(y) -> pitch(x)の順に回転します。 ピッチは-pi, pi、ロールは-pi/2,pi/2です。 [詳細]

すべてのメンバ一覧

Public メソッド

RollPitch ()
RollPitch (Vector2 v)
RollPitch (Vector3 v)
Vector3 ToVector ()
Matrix4 ToMatrix ()

Static Public メソッド

static Vector2 | FromVector (Vector3 v)
ピッチ x、ロール yを返します。
static Vector3 | ToVector (Vector2 a)
ロール -> ピッチで回転させる z=(0,0,1)を返します。

Public 変数

Vector2 Data
x:ピッチ、y:ロール (ラジアン)。

説明

Pitch/roll 回転のヘルパーオブジェクト/関数。 Roll(y) -> pitch(x)の順に回転します。 ピッチは-pi, pi、ロールは-pi/2,pi/2です。

コンストラクタとデストラクタ

RollPitch ( )
RollPitch ( Vector2 v )
RollPitch ( Vector3 v )

メソッド

Matrix4 ToMatrix ( )
Vector3 ToVector ( )


クラス SpriteRenderer

SpriteRendererは、単純なBeginSprites / AddSprite X N / EndSprite APIでのスプライトの一括描画をラップします。 また、FontMap を使ったテキスト描画関数を提供します。 [詳細]

すべてのメンバ一覧

構成

class | DefaultFontShader_
Fontのデフォルトのシェーダー。 [詳細]
class | DefaultShader_
スプライトのデフォルトのシェーダー：色によって変調されたテクスチャ。 [詳細]
interface | ISpriteShader
開発者によって設定されるシェーダープログラムのインターフェース。 [詳細]

Public メソッド

SpriteRenderer (GraphicsContextAlpha gl, uint max_sprites)
コンストラクタ。
void | Dispose ()
Dispose の実装。
Bounds2 | DrawTextDebug (string str, Vector2 bottom_left_start_pos, float char_height, bool draw=true, ISpriteShader shader=null)
DrawDebugTextは、埋め込まれた小さなフォントを使って、スクリーン上に文字を表示します。 DrawDebugTextは簡易的なフォントデータであるため、アスキー文字にしか対応していません ( ' '(32) から '~'(126)までの文字)。 アスキー文字以外の文字は'?'で表示されます。例えば「こんにちは」は "?????" と表示されます。
Bounds2 | DrawTextWithFontMap (string str, Vector2 bottom_left_start_pos, float char_height, bool draw, FontMap fontmap, ISpriteShader shader)
FontMapオブジェクトを使ったテキスト描画関数。
Bounds2 | DrawTextWithFontMap (string str, Vector2 bottom_left_start_pos, float char_height, bool draw, FontMap fontmap)
このテキスト描画関数は FontMap オブジェクトと SpriteRenderer の DefaultShader を使用します。
void | BeginSprites (TextureInfo texture_info, ISpriteShader shader, int num_sprites)
スプライトの一括描画を開始します。
void | BeginSprites (TextureInfo texture_info, int num_sprites)
スプライトの一括描画を開始します。
void | EndSprites ()
スプライトの一括描画を終了します。
void | AddSprite (ref TRS quad, Vector2i tile_index)
スプライトの一括描画処理にスプライトを追加します。 BeginSprites と EndSprites の間で呼び出してください。
void | AddSprite (ref TRS quad, Vector2i tile_index, ref Matrix3 mat)
スプライトの一括描画処理にスプライトを追加します。 BeginSprites と EndSprites の間で呼び出してください。
void | AddSprite (ref TRS quad, ref TRS uv)
スプライトの一括描画処理にスプライトを追加します。 BeginSprites と EndSprites の間で呼び出してください。
void | AddSprite (ref TRS quad, ref TRS uv, ref Matrix3 mat)
スプライトの一括描画処理にスプライトを追加します。 BeginSprites と EndSprites の間で呼び出してください。
void | AddSprite (Vector2 bottom_left_start_pos, Vector2 x, Bounds2 uv_bounds)
スプライトの一括描画処理にスプライトを追加します。 BeginSprites と EndSprites の間で呼び出してください。 ひとつのベクトルでスプライトの向きとスケールを決定します。
void | AddSprite (Vector4 v0, Vector4 v1, Vector4 v2, Vector4 v3)
スプライトの一括描画処理にスプライトを追加します。 BeginSprites と EndSprites の間で呼び出してください。 このバージョンでは、開発者は Vector4 で4つの頂点を指定します。Vector4の xy は 頂点の位置であり、 zw は UV です。

Public 変数

bool | FlipU = false
描画される全てのスプライト/クワッドのU座標を水平に反転するフラグ。
bool | FlipV = false
描画される全てのスプライト/クワッドのV座標を垂直に反転するフラグ。

プロパティ

DefaultShader_ | DefaultShader [get]
SpriteRenderer によって使用されるデフォルトのシェーダー。
DefaultFontShader_ | DefaultFontShader [get]
SpriteRenderer によって使用される、Fontのためのデフォルトのシェーダー。
bool | Disposed [get]
オブジェクトが破棄されている場合、trueを返します。

説明

SpriteRendererは、単純なBeginSprites / AddSprite X N / EndSprite APIでのスプライトの一括描画をラップします。 また、FontMap を使ったテキスト描画関数を提供します。

メソッド

void AddSprite | ( | ref TRS | quad,
 |  | Vector2i | tile_index
 | ) |  |

スプライトの一括描画処理にスプライトを追加します。 BeginSprites と EndSprites の間で呼び出してください。

引数:
quad | スプライトの幾何情報。
tile_index | タイルインデックスで指定する、スプライトのUV。
void AddSprite | ( | ref TRS | quad,
 |  | Vector2i | tile_index,
 |  | ref Matrix3 | mat
 | ) |  |

スプライトの一括描画処理にスプライトを追加します。 BeginSprites と EndSprites の間で呼び出してください。

引数:
quad | スプライトの幾何情報。
tile_index | タイルインデックスで指定する、スプライトのUV。
mat | スプライトごとの変換行列。
void AddSprite | ( | ref TRS | quad,
 |  | ref TRS | uv
 | ) |  |

スプライトの一括描画処理にスプライトを追加します。 BeginSprites と EndSprites の間で呼び出してください。

引数:
quad | スプライトの幾何情報。
uv | TRSオブジェクトで指定するスプライトのUV。
void AddSprite | ( | ref TRS | quad,
 |  | ref TRS | uv,
 |  | ref Matrix3 | mat
 | ) |  |

スプライトの一括描画処理にスプライトを追加します。 BeginSprites と EndSprites の間で呼び出してください。

引数:
quad | スプライトの幾何情報。
uv | TRSオブジェクトで指定するスプライトのUV。
mat | スプライトごとの変換行列。
void AddSprite | ( | Vector2 | bottom_left_start_pos,
 |  | Vector2 | x,
 |  | Bounds2 | uv_bounds
 | ) |  |

スプライトの一括描画処理にスプライトを追加します。 BeginSprites と EndSprites の間で呼び出してください。 ひとつのベクトルでスプライトの向きとスケールを決定します。

引数:
x | スプライトの下端の長さと方向。
bottom_left_start_pos | スプライトの左下の点。
uv_bounds | UVの境界 ( UV領域内のBounds2)。
void BeginSprites | ( | TextureInfo | texture_info,
 |  | int | num_sprites
 | ) |  |

スプライトの一括描画を開始します。

引数:
texture_info | テクスチャオブジェクト。
num_sprites | 描画するスプライトの最大数。
void BeginSprites | ( | TextureInfo | texture_info,
 |  | ISpriteShader | shader,
 |  | int | num_sprites
 | ) |  |

スプライトの一括描画を開始します。

引数:
texture_info | テクスチャオブジェクト。
shader | シェーダーオブジェクト。
num_sprites | 描画するスプライトの最大数。
Bounds2 DrawTextDebug | ( | string | str,
 |  | Vector2 | bottom_left_start_pos,
 |  | float | char_height,
 |  | bool | draw = true,
 |  | ISpriteShader | shader = null
 | ) |  |

DrawDebugTextは、埋め込まれた小さなフォントを使って、スクリーン上に文字を表示します。 DrawDebugTextは簡易的なフォントデータであるため、アスキー文字にしか対応していません ( ' '(32) から '~'(126)までの文字)。 アスキー文字以外の文字は'?'で表示されます。例えば「こんにちは」は "?????" と表示されます。

引数:
str | 描画するテキスト。
bottom_left_start_pos | ワールド空間/ユニット内での、テキスト矩形の左下の点。
char_height | ワールド空間/ユニット内での文字の高さ。
draw | falseを指定した場合、何も描画せず、テキストによって使用される Bound2 を返します。
shader | シェーダーを指定しない場合、DefaultFontShader が使用されます。
戻り値:
描画されたテキストでカバーされた矩形領域。実際に描画する前に矩形領域を知りたい場合、draw=trueで呼び出してください。
Bounds2 DrawTextWithFontMap | ( | string | str,
 |  | Vector2 | bottom_left_start_pos,
 |  | float | char_height,
 |  | bool | draw,
 |  | FontMap | fontmap
 | ) |  |

このテキスト描画関数は FontMap オブジェクトと SpriteRenderer の DefaultShader を使用します。

引数:
str | 描画するテキスト。
bottom_left_start_pos | ワールド空間/ユニット内での、テキスト矩形の左下。
char_height | ワールド空間/ユニット内での文字の高さ。
draw | falseを指定した場合、何も描画せず、テキストによって使用された Bound2 を返します。
fontmap | フォントマップのオブジェクト (テクスチャを保持します)。
Bounds2 DrawTextWithFontMap | ( | string | str,
 |  | Vector2 | bottom_left_start_pos,
 |  | float | char_height,
 |  | bool | draw,
 |  | FontMap | fontmap,
 |  | ISpriteShader | shader
 | ) |  |

FontMapオブジェクトを使ったテキスト描画関数。

引数:
str | 描画するテキスト。
bottom_left_start_pos | ワールド空間/units内でのテキスト矩形の左下の点。
char_height | ワールド空間/units内での文字の高さ。
draw | falseを指定した場合、何も描画せず、テキストによって使用された Bound2 を返します。
fontmap | フォントマップのオブジェクト (テクスチャを保持します)。
shader | SpriteRenderer.DefaultFontShader のデフォルトシェーダー。


クラス SpriteRenderer.DefaultFontShader_

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • SpriteRenderer
  • DefaultFontShader_
Public メソッド

クラス SpriteRenderer.DefaultFontShader_

Fontのデフォルトのシェーダー。 [詳細]

SpriteRenderer.DefaultFontShader_に対する継承グラフ
SpriteRenderer.ISpriteShader

すべてのメンバ一覧

Public メソッド

void | Dispose ()
Disposeの実装。
ShaderProgram GetShaderProgram ()
ShaderProgram オブジェクトを取得します。
void | SetMVP (ref Matrix4 value)
プロジェクション行列 * ビュー行列 * モデル行列。
void | SetColor (ref Vector4 value)
グローバルカラー。
void | SetUVTransform (ref Vector4 value)
UVの変換を設定します。Xy内のオフセット、Zwのスケール、(0,0,1,1)はUVが変更されないことを意味します。 シェーダーコードの例：transformed_uv = UVTransform.xy + UV * UVTransform.zw.

説明

Fontのデフォルトのシェーダー。


クラス SpriteRenderer.DefaultShader_

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • SpriteRenderer
  • DefaultShader_
Public メソッド

クラス SpriteRenderer.DefaultShader_

スプライトのデフォルトのシェーダー：色によって変調されたテクスチャ。 [詳細]

SpriteRenderer.DefaultShader_に対する継承グラフ
SpriteRenderer.ISpriteShader

すべてのメンバ一覧

Public メソッド

void | Dispose ()
Disposeの実装。
ShaderProgram GetShaderProgram ()
ShaderProgram オブジェクトを取得します。
void | SetMVP (ref Matrix4 value)
プロジェクション行列 * ビュー行列 * モデル行列。
void | SetColor (ref Vector4 value)
グローバルカラー。
void | SetUVTransform (ref Vector4 value)
UVの変換を設定します。Xy内のオフセット、Zwのスケール、(0,0,1,1)はUVが変更されないことを意味します。 シェーダーコードの例：transformed_uv = UVTransform.xy + UV * UVTransform.zw.

説明

スプライトのデフォルトのシェーダー：色によって変調されたテクスチャ。


インタフェース SpriteRenderer.ISpriteShader

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • SpriteRenderer
  • ISpriteShader
Public メソッド

インタフェース SpriteRenderer.ISpriteShader

開発者によって設定されるシェーダープログラムのインターフェース。 [詳細]

SpriteRenderer.ISpriteShaderに対する継承グラフ
SpriteRenderer.DefaultFontShader_ SpriteRenderer.DefaultShader_

すべてのメンバ一覧

Public メソッド

void | SetMVP (ref Matrix4 value)
プロジェクション行列 * ビュー行列 * モデル行列。
void | SetColor (ref Vector4 value)
グローバルカラー。
void | SetUVTransform (ref Vector4 value)
UVの変換を設定します。Xy内のオフセット、Zwのスケール、(0,0,1,1)はUVが変更されないことを意味します。 シェーダーコードの例：transformed_uv = UVTransform.xy + UV * UVTransform.zw.
ShaderProgram GetShaderProgram ()
ShaderProgram オブジェクトを取得します。

説明

開発者によって設定されるシェーダープログラムのインターフェース。


クラス TextureInfo

TextureInfoは、Texture2Dオブジェクトを保持し、関連付けられたタイルのUVデータをキャッシュします。 タイルの転送元領域はテクスチャ全体である必要はなく、UV領域内の任意の大きさのボックスで指定することができます。 TextureInfoは、渡されるTexture2Dオブジェクトの所有権を取得し、Dispose関数で破棄します。 [詳細]

すべてのメンバ一覧

構成

class | CachedTileData
各タイルのキャッシュされたUV情報。 [詳細]

Public メソッド

CachedTileData | GetCachedTiledData (ref Vector2i tile_index)
引数で指定されたタイルのCachedTileData（タイルのUV情報が含まれている）を返します。
TextureInfo ()
コンストラクタ。
TextureInfo (string filename)
コンストラクタ。
TextureInfo (Texture2D texture)
コンストラクタ。 注意: TextureInfoは、このコンストラクタに渡されるTexture2Dの所有権を取得し、Disposeでそれを破棄します。
TextureInfo (Texture2D texture, Vector2i num_tiles)
コンストラクタ。 注意: TextureInfoは、このコンストラクタに渡されるTexture2Dの所有権を取得し、Disposeでそれを破棄します。
TextureInfo (Texture2D texture, Vector2i num_tiles, TRS source_area)
コンストラクタ。 注意: TextureInfoは、このコンストラクタに渡されるTexture2Dの所有権を取得し、Disposeでそれを破棄します。
void | Dispose ()
オブジェクトの破棄。
void | Initialize (Texture2D texture, Vector2i num_tiles, TRS source_area)
TextureInfoコンストラクタによって呼び出される、実質的な初期化関数。

Public 変数

Texture2D Texture
テクスチャのオブジェクト。
Vector2 TileSizeInUV
UV単位でタイルのサイズを返します。
Vector2i NumTiles
タイルグリッドの数を返します。

プロパティ

Vector2 | TextureSizef [get]
ピクセル単位のテクスチャのサイズをVector2で返します。
Vector2i | TextureSizei [get]
ピクセル単位のテクスチャのサイズをVector2iで返します。
Vector2 | TileSizeInPixelsf [get]
ピクセル単位のタイルサイズを、Vector2で返します。すべてのタイルは同じサイズを持っています。
bool | Disposed [get]
このオブジェクトが破棄されている場合、trueを返します。

説明

TextureInfoは、Texture2Dオブジェクトを保持し、関連付けられたタイルのUVデータをキャッシュします。 タイルの転送元領域はテクスチャ全体である必要はなく、UV領域内の任意の大きさのボックスで指定することができます。 TextureInfoは、渡されるTexture2Dオブジェクトの所有権を取得し、Dispose関数で破棄します。

コンストラクタとデストラクタ

TextureInfo | ( | Texture2D | texture,
 |  | Vector2i | num_tiles
 | ) |  |

コンストラクタ。 注意: TextureInfoは、このコンストラクタに渡されるTexture2Dの所有権を取得し、Disposeでそれを破棄します。

引数:
texture | テクスチャ。
num_tiles | xとyのタイル分割数。
TextureInfo | ( | Texture2D | texture,
 |  | Vector2i | num_tiles,
 |  | TRS | source_area
 | ) |  |

コンストラクタ。 注意: TextureInfoは、このコンストラクタに渡されるTexture2Dの所有権を取得し、Disposeでそれを破棄します。

引数:
texture | テクスチャ。
num_tiles | xとyのタイル分割数。
source_area | UV領域内の転送元矩形。この矩形内を分割してタイルを構築します。左下が(0,0)になります。

メソッド

void Initialize | ( | Texture2D | texture,
 |  | Vector2i | num_tiles,
 |  | TRS | source_area
 | ) |  |

TextureInfoコンストラクタによって呼び出される、実質的な初期化関数。

引数:
texture | テクスチャ。
num_tiles | セル内のタイル数。水平方向と垂直方向の数を指定します。
source_area | UV領域内の転送元矩形。この矩形内を分割してタイルを構築します。左下が(0,0)になります。


クラス TextureInfo.CachedTileData

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • TextureInfo
  • CachedTileData
Public 変数

クラス TextureInfo.CachedTileData

各タイルのキャッシュされたUV情報。 [詳細]

すべてのメンバ一覧

Public 変数

Vector2 UV_00
左下のUVポイント。
Vector2 UV_10
右下のUVポイント。
Vector2 UV_01
左上のUVポイント。
Vector2 UV_11
右上のUVポイント。

説明

各タイルのキャッシュされたUV情報。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Timer
Public メソッド

クラス Timer

シンプルなタイマー。 [詳細]

すべてのメンバ一覧

Public メソッド

Timer ()
Timerのコンストラクタ。
void | Reset ()
タイマーをリセットします。
double | Milliseconds ()
コンストラクタが呼び出された瞬間、または Reset()が呼び出された瞬間からの経過時間をミリ秒単位で返します。
double | Seconds ()
コンストラクタが呼び出された瞬間、または Reset()が呼び出された瞬間からの経過時間を秒単位で返します。

説明

シンプルなタイマー。


クラス TRS.Local

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • TRS
  • Local
Static Public 変数

クラス TRS.Local

エイリアス。一般的にCenteringに渡すために使用します。 [詳細]

すべてのメンバ一覧

Static Public 変数

static Vector2 | TopLeft = new Vector2(0.0f,1.0f)
static Vector2 | MiddleLeft = new Vector2(0.0f,0.5f)
static Vector2 | BottomLeft = new Vector2(0.0f,0.0f)
static Vector2 | TopCenter = new Vector2(0.5f,1.0f)
static Vector2 | Center = new Vector2(0.5f,0.5f)
static Vector2 | BottomCenter = new Vector2(0.5f,0.0f)
static Vector2 | TopRight = new Vector2(1.0f,1.0f)
static Vector2 | MiddleRight = new Vector2(1.0f,0.5f)
static Vector2 | BottomRight = new Vector2(1.0f,0.0f)

説明

エイリアス。一般的にCenteringに渡すために使用します。

変数

Vector2 BottomCenter = new Vector2(0.5f,0.0f) [static]
Vector2 BottomLeft = new Vector2(0.0f,0.0f) [static]
Vector2 BottomRight = new Vector2(1.0f,0.0f) [static]
Vector2 Center = new Vector2(0.5f,0.5f) [static]
Vector2 MiddleLeft = new Vector2(0.0f,0.5f) [static]
Vector2 MiddleRight = new Vector2(1.0f,0.5f) [static]
Vector2 TopCenter = new Vector2(0.5f,1.0f) [static]
Vector2 TopLeft = new Vector2(0.0f,1.0f) [static]
Vector2 TopRight = new Vector2(1.0f,1.0f) [static]


構造体 BlendMode

BlendMode はブレンドステート(BlendFunc+'enabled' bool)をラップし、扱いやすい名称として提供します。 [詳細]

すべてのメンバ一覧

Public メソッド

BlendMode (bool enabled, BlendFunc blend_func)
コンストラクタ。

Public 変数

bool | Enabled
ブレンド enabled フラグ。
BlendFunc BlendFunc
ブレンド関数。

Static Public 変数

static BlendMode | None = new BlendMode( false, new BlendFunc( BlendFuncMode.Add, BlendFuncFactor.One, BlendFuncFactor.One ) )
アルファなしブレンド:dst = src
static BlendMode | Normal = new BlendMode( true, new BlendFunc( BlendFuncMode.Add, BlendFuncFactor.SrcAlpha, BlendFuncFactor.OneMinusSrcAlpha ) )
普通のアルファブレンド : dst = lerp( dst, src, src.a )
static BlendMode | Additive = new BlendMode( true, new BlendFunc( BlendFuncMode.Add, BlendFuncFactor.One, BlendFuncFactor.One ) )
加算アルファブレンド : dst = dst + src
static BlendMode | Multiplicative = new BlendMode( true, new BlendFunc( BlendFuncMode.Add, BlendFuncFactor.DstColor, BlendFuncFactor.Zero ) )
乗算アルファブレンド : dst = dst * src
static BlendMode | PremultipliedAlpha = new BlendMode( true, new BlendFunc( BlendFuncMode.Add, BlendFuncFactor.One, BlendFuncFactor.OneMinusSrcAlpha ) )
乗算済みアルファブレンド : dst = dst * (1-src.a ) + src

説明

BlendMode はブレンドステート(BlendFunc+'enabled' bool)をラップし、扱いやすい名称として提供します。


構造体 Bounds2

An axis aligned box class in 2D. [詳細]

Bounds2に対する継承グラフ
ICollisionBasics

すべてのメンバ一覧

Public メソッド

bool | IsEmpty ()
Return true if the size is (0,0).
Bounds2 (Vector2 min, Vector2 max)
Bounds2 constructor.
Bounds2 (Vector2 point)
Bounds2 constructor.
bool | Overlaps (Bounds2 bounds)
Return true if this and 'bounds' overlap.
Bounds2 | Intersection (Bounds2 bounds)
Return the Bounds2 resulting from the intersection of 2 bounds.
Bounds2 | Scale (Vector2 scale, Vector2 center)
Scale bounds around a given pivot.
void | Add (Vector2 point)
Add the contribution of 'point' to this Bounds2.
void | Add (Bounds2 bounds)
Add the contribution of 'bounds' to this Bounds2.
override string | ToString ()
Return the string representation of this Bounds2.
bool | IsInside (Vector2 point)
Return true if 'point' is inside the primitive (in its negative space).
void | ClosestSurfacePoint (Vector2 point, out Vector2 ret, out float sign)
Return the closest point to 'point' that lies on the surface of the primitive.
float | SignedDistance (Vector2 point)
Return the signed distance (penetration distance) from 'point' to the surface of the primitive.
bool | NegativeClipSegment (ref Vector2 A, ref Vector2 B)
Assuming the primitive is convex, clip the segment AB against the primitive.
Bounds2 OutrageousYTopBottomSwap ()
Swap y coordinates for top and bottom, handy for hacking uvs in system that use 0,0 as top left.
Bounds2 OutrageousYVCoordFlip ()
Similar to OutrageousYTopBottomSwap, but instead of swapping top and bottom y, it just does y=1-y.

Static Public メソッド

static Bounds2 | SafeBounds (Vector2 min, Vector2 max)
Create a Bounds2 that goes through 2 points, the min and max are recalculated.
static Bounds2 | CenteredSquare (float h)
Return a box that goes from (-h,-h) to (h,h).
static Bounds2 | operator+ (Bounds2 bounds, Vector2 value)
Translate bounds.
static Bounds2 | operator- (Bounds2 bounds, Vector2 value)
Translate bounds.

Public 変数

Vector2 Min
Minimum point (lower left).
Vector2 Max
Maximum point (upper right)

Static Public 変数

static Bounds2 | Zero = new Bounds2( new Vector2(0.0f,0.0f), new Vector2(0.0f,0.0f) )
(0,0) -> (0,0) box.
static Bounds2 | Quad0_1 = new Bounds2( new Vector2(0.0f,0.0f), new Vector2(1.0f,1.0f) )
(0,0) -> (1,1) box.
static Bounds2 | QuadMinus1_1 = new Bounds2( new Vector2(-1.0f,-1.0f), new Vector2(1.0f,1.0f) )
(-1,-1) -> (1,1) box.

プロパティ

float | Aspect [get]
The Width/Height ratio.
Vector2 | Center [get]
The center of the bounds (Max+Min)/2.
Vector2 | Size [get]
The Size the bounds (Max-Min).
Vector2 | Point00 [get]
The bottom left point (which is also Min).
Vector2 | Point11 [get]
The top right point (which is also Max).
Vector2 | Point10 [get]
The bottom right point.
Vector2 | Point01 [get]
The top left point.

説明

An axis aligned box class in 2D.

コンストラクタとデストラクタ

Bounds2 | ( | Vector2 | min,
 |  | Vector2 | max
 | ) |  |

Bounds2 constructor.

All functions in Bounds2 assume that Min is less or equal Max. If it is not the case, the user takes responsability for it. SafeBounds will ensure this is the case whatever the input is, but the default constructor will just blindly takes anything the user passes without trying to fix it.

引数:
min | The bottom left point. Min is set to that value without further checking.
max | The top right point. Max is set to that value without further checking.
Bounds2 ( Vector2 point )

Bounds2 constructor.

Return a zero size bounds. You can then use Add to expand it.

引数:
point Location of the Bounds2.

メソッド

static Bounds2 CenteredSquare ( float h ) [static]

Return a box that goes from (-h,-h) to (h,h).

We don't check for sign.

引数:
h Half size of the square.
void ClosestSurfacePoint | ( | Vector2 | point,
 |  | out Vector2 | ret,
 |  | out float | sign
 | ) |  |

Return the closest point to 'point' that lies on the surface of the primitive.

If that point is inside the primitive, sign is negative.

ICollisionBasicsを実装しています。

bool NegativeClipSegment | ( | ref Vector2 | A,
 |  | ref Vector2 | B
 | ) |  |

Assuming the primitive is convex, clip the segment AB against the primitive.

Return false if AB is entirely in positive halfspace, else clip against negative space and return true.

ICollisionBasicsを実装しています。

Bounds2 OutrageousYTopBottomSwap ( )

Swap y coordinates for top and bottom, handy for hacking uvs in system that use 0,0 as top left.

Also, this will generate an invalid Bounds2 and all functions in that class will break (intersections, add etc.)

Functions like Point00, Point10 etc can still be used.

Bounds2 OutrageousYVCoordFlip ( )

Similar to OutrageousYTopBottomSwap, but instead of swapping top and bottom y, it just does y=1-y.

Same comment as OutrageousYTopBottomSwap.

static Bounds2 SafeBounds | ( | Vector2 | min,
 |  | Vector2 | max
 | ) |  | [static]

Create a Bounds2 that goes through 2 points, the min and max are recalculated.

引数:
min | First point.
max | Second point.
Bounds2 Scale | ( | Vector2 | scale,
 |  | Vector2 | center
 | ) |  |

Scale bounds around a given pivot.

引数:
scale | Amount of scale.
center | Scale center.


構造体 ConvexPoly2

A convex polygon class in 2D. [詳細]

ConvexPoly2に対する継承グラフ
ICollisionBasics

すべてのメンバ一覧

Public メソッド

ConvexPoly2 (Vector2[] points)
ConvexPoly2 constructor.
void | MakeBox (Bounds2 bounds)
void | MakeRegular (uint num, float r)
uint | Size ()
Return the number of vertices (or faces)
Vector2 | GetPoint (int index)
Get a vertex position.
Vector2 | GetNormal (int index)
Get the normal vector of a face of this poly.
Plane2 | GetPlane (int index)
Get the plane formed by a face of this poly.
Bounds2 CalcBounds ()
Calculate the bounds of this poly.
Vector2 CalcCenter ()
Calculate the gravity center of this poly.
float | CalcArea ()
Calculate the area of this convex poly.
bool | IsInside (Vector2 point)
Return true if 'point' is inside the primitive (in its negative space).
void | ClosestSurfacePoint (Vector2 point, out Vector2 ret, out float sign)
Return the closest point to 'point' that lies on the surface of the primitive.
float | SignedDistance (Vector2 point)
Return the signed distance (penetration distance) from 'point' to the surface of the primitive.
void | Translate (Vector2 dx, ConvexPoly2 poly)
bool | NegativeClipSegment (ref Vector2 A, ref Vector2 B)
Assuming the primitive is convex, clip the segment AB against the primitive.

Public 変数

Plane2[] Planes
The convex poly is stored as a list of planes assumed to define a convex region.

プロパティ

Sphere2 | Sphere [get]
Bounding sphere, centered at center of mass.

説明

A convex polygon class in 2D.

コンストラクタとデストラクタ

ConvexPoly2 ( Vector2[] points )

ConvexPoly2 constructor.

Assumes input points define a convex region.

メソッド

void ClosestSurfacePoint | ( | Vector2 | point,
 |  | out Vector2 | ret,
 |  | out float | sign
 | ) |  |

Return the closest point to 'point' that lies on the surface of the primitive.

If that point is inside the primitive, sign is negative.

ICollisionBasicsを実装しています。

Vector2 GetNormal ( int index )

Get the normal vector of a face of this poly.

引数:
index The face index.
Plane2 GetPlane ( int index )

Get the plane formed by a face of this poly.

引数:
index The face index.
Vector2 GetPoint ( int index )

Get a vertex position.

引数:
index The vertex index.
void MakeBox ( Bounds2 bounds )
void MakeRegular | ( | uint | num,
 |  | float | r
 | ) |  |
bool NegativeClipSegment | ( | ref Vector2 | A,
 |  | ref Vector2 | B
 | ) |  |

Assuming the primitive is convex, clip the segment AB against the primitive.

Return false if AB is entirely in positive halfspace, else clip against negative space and return true.

ICollisionBasicsを実装しています。

void Translate | ( | Vector2 | dx,
 |  | ConvexPoly2 | poly
 | ) |  |

変数

Plane2 [] Planes

The convex poly is stored as a list of planes assumed to define a convex region.

Plane base points are also polygon vertices.


構造体 Matrix3

2Dを扱うための 3x3の行列。 [詳細]

すべてのメンバ一覧

Public メソッド

Matrix3 (Vector3 valx, Vector3 valy, Vector3 valz)
コンストラクタ。
Matrix3 Transpose ()
転置行列を返します。
float | Determinant ()
行列式を返します。
Matrix3 Inverse ()
逆行列を返します。
Matrix3 InverseOrthonormal ()
行列がTxR (直交) であると仮定した、特別な逆行列。
Matrix4 Matrix4 ()
この行列が変換行列 ( 最後の行が 0,0,1など)であると仮定して、それのMatrix4バージョンを返す。
string | GetCoordSysError ()
isCoordSys（）によって返された最後のエラーを、文字列として取得します。
bool | IsOrthonormal (float epsilon)
行列が、有効な右手座標系で、直交する2次元座標系を表す場合、trueを返します。
bool | Equals (ref Matrix3 m, float epsilon)
等価テスト。
bool | Equals (ref Matrix3 m)
等価テスト。
override string | ToString ()
値を文字列化して返す。

Static Public メソッド

static Vector3 | operator* (Matrix3 m, Vector3 v)
行列/ベクトルの乗算。
static Matrix3 | operator* (Matrix3 m1, Matrix3 m2)
行列/行列の乗算。
static Matrix3 | Translation (Vector2 value)
平行移動行列を返します。
static Matrix3 | Scale (Vector2 value)
スケール行列を返します。
static Matrix3 | Skew (Vector2 value)
歪(skew)行列を返します。
static Matrix3 | Rotation (Vector2 unit_vector)
回転行列を返します。
static Matrix3 | Rotation (float angle)
回転行列を返します。
static Matrix3 | TRS (Vector2 translation, Vector2 unit_vector, Vector2 scale)
平行移動 * 回転 * スケール の変換行列を返します。

Public 変数

Vector3 X
1番目の列。
Vector3 Y
2番目の列。
Vector3 Z
3番目の列。

Static Public 変数

static Matrix3 | Identity
単位行列を返します。
static Matrix3 | Zero
全ての要素を0にセットした行列を返します。

説明

2Dを扱うための 3x3の行列。

コンストラクタとデストラクタ

Matrix3 | ( | Vector3 | valx,
 |  | Vector3 | valy,
 |  | Vector3 | valz
 | ) |  |

コンストラクタ。

引数:
valx | 1番目の列。
valy | 2番目の列。
valz | 3番目の列。

メソッド

static Matrix3 Rotation ( float angle ) [static]

回転行列を返します。

引数:
angle ラジアンの回転角。
static Matrix3 Rotation ( Vector2 unit_vector ) [static]

回転行列を返します。

引数:
unit_vector (cos(angle),sin(angle)) 単位ベクトル。 回転させたい角度を指定します。
static Matrix3 Skew ( Vector2 value ) [static]

歪(skew)行列を返します。

引数:
value (tan(skewx),tan(skewy)) ベクトル。skewx と skewy は歪の角度です。
static Matrix3 TRS | ( | Vector2 | translation,
 |  | Vector2 | unit_vector,
 |  | Vector2 | scale
 | ) |  | [static]

平行移動 * 回転 * スケール の変換行列を返します。

引数:
translation | 平行移動の量。
unit_vector | (cos(angle),sin(angle)) 単位ベクトル。 回転させたい角度を指定します。
scale | スケーリング。


構造体 Plane2

A plane class in 2D. [詳細]

Plane2に対する継承グラフ
ICollisionBasics

すべてのメンバ一覧

Public メソッド

Plane2 (Vector2 a_base, Vector2 a_unit_normal)
Plane2 constructor.
bool | IsInside (Vector2 point)
Return true if 'point' is inside the primitive (in its negative space).
void | ClosestSurfacePoint (Vector2 point, out Vector2 ret, out float sign)
Return the closest point to 'point' that lies on the surface of the primitive.
float | SignedDistance (Vector2 point)
Return the signed distance (penetration distance) from 'point' to the surface of the primitive.
Vector2 | Project (Vector2 point)
Project a point on this plane.
bool | NegativeClipSegment (ref Vector2 A, ref Vector2 B)
Assuming the primitive is convex, clip the segment AB against the primitive.

Public 変数

Vector2 Base
A base point on the plane.
Vector2 UnitNormal
The plane normal vector, assumed to be unit length.

説明

A plane class in 2D.

メソッド

void ClosestSurfacePoint | ( | Vector2 | point,
 |  | out Vector2 | ret,
 |  | out float | sign
 | ) |  |

Return the closest point to 'point' that lies on the surface of the primitive.

If that point is inside the primitive, sign is negative.

ICollisionBasicsを実装しています。

bool NegativeClipSegment | ( | ref Vector2 | A,
 |  | ref Vector2 | B
 | ) |  |

Assuming the primitive is convex, clip the segment AB against the primitive.

Return false if AB is entirely in positive halfspace, else clip against negative space and return true.

ICollisionBasicsを実装しています。

変数

Vector2 UnitNormal

The plane normal vector, assumed to be unit length.

If this is not the case, some functions will have undefined behaviour.


構造体 Sphere2

A sphere class in 2D. [詳細]

Sphere2に対する継承グラフ
ICollisionBasics

すべてのメンバ一覧

Public メソッド

Sphere2 (Vector2 center, float radius)
Sphere2 constructor.
bool | IsInside (Vector2 point)
Return true if 'point' is inside the primitive (in its negative space).
void | ClosestSurfacePoint (Vector2 point, out Vector2 ret, out float sign)
Return the closest point to 'point' that lies on the surface of the primitive.
float | SignedDistance (Vector2 point)
Return the signed distance (penetration distance) from 'point' to the surface of the primitive.
bool | NegativeClipSegment (ref Vector2 A, ref Vector2 B)
Assuming the primitive is convex, clip the segment AB against the primitive.

Public 変数

Vector2 Center
Sphere center.
float | Radius
Sphere radius.

説明

A sphere class in 2D.

メソッド

void ClosestSurfacePoint | ( | Vector2 | point,
 |  | out Vector2 | ret,
 |  | out float | sign
 | ) |  |

Return the closest point to 'point' that lies on the surface of the primitive.

If that point is inside the primitive, sign is negative.

ICollisionBasicsを実装しています。

bool NegativeClipSegment | ( | ref Vector2 | A,
 |  | ref Vector2 | B
 | ) |  |

Assuming the primitive is convex, clip the segment AB against the primitive.

Return false if AB is entirely in positive halfspace, else clip against negative space and return true.

ICollisionBasicsを実装しています。


構造体 TRS

TRSはシーングラフの専門用語です。TRSは平行移動/回転/スケールの2D変換行列を標準的な方法で格納するのために使用されています。 また、向きをもった境界ボックスを定義します。 TRSはスプライトの配置/サイズとスプライトUVの両方を格納するためにも使用します。 [詳細]

すべてのメンバ一覧

構成

class | Local
エイリアス。一般的にCenteringに渡すために使用します。 [詳細]

Public メソッド

void | Rotate (float angle)
角度を指定してオブジェクトを回転させます。
void | Rotate (Vector2 rotation)
角度を指定してオブジェクトを回転させます。
TRS (Bounds2 a_bounds)
Bounds2からの変換 : a_bounds.Min は T になり、a_bounds.Size は Sになります(回転なし)。
Bounds2 Bounds2 ()
Bounds2に変換します。回転がある場合は、エンドポイントが一致しないことに注意してください。しかし、すべてのケースで、返された境界は完全にTRSを含んでいます。
void | Centering (Vector2 normalized_pos)
入力で与えられる、正規化された点が（0,0）になるようにTRSを変換します。TRS.Localで事前に定義され、正規化された点です。
override string | ToString ()

Static Public メソッド

static TRS | Tile (Vector2i num_tiles, Vector2i tile_index, TRS source_area)
タイル数とタイルのインデックスを指定し、引数 source_area からサブ領域を取得します。 一般的にsource_areaはQuad0_1（単位クワッド、全体のテクスチャを意味する）になります。 タイルのテクスチャ内で、指定されたタイルのUV情報を返します。

Public 変数

Vector2 T
平行移動。
Vector2 R
回転。単位ベクトル (cos,sin) として格納します。
Vector2 S
スケール (またはサイズ)。

Static Public 変数

static TRS | Quad0_1
（0,0）（1,1）からなる単位クワッドをカバーするTRS。
static TRS | QuadMinus1_1
（-1,-1）（1,1）からなるクワッドをカバーするTRS。

プロパティ

Vector2 | X [get]
左下から右下に向かう、サポートXベクトル。
Vector2 | Y [get]
左下から左上に向かう、サポートYベクトル。
Vector2 | Point00 [get]
ロカール座標での左下の点 (基準点), (0,0)。
Vector2 | Point10 [get]
ロカール座標での右下の点 (1,0)。
Vector2 | Point01 [get]
ロカール座標での左上の点 (0,1)。
Vector2 | Point11 [get]
ロカール座標での右上の点 (1,1)。
Vector2 | Center [get]
このTRSによって定義された向きを持ったボックスの中心を返します。
Vector2 | RotationNormalize [get, set]
RotationNormalize は Rotation に似ています。しかし RotationNormalize は誤差の蓄積を防ぐために、単位ベクトルを正規化します。
float | Angle [get, set]
このプロパティは角度で回転を設定/取得します。これは重い処理であり、通常角度の不連続性の問題をもたらします。角度は常に格納され、-pi,piの範囲で値を返します。

説明

TRSはシーングラフの専門用語です。TRSは平行移動/回転/スケールの2D変換行列を標準的な方法で格納するのために使用されています。 また、向きをもった境界ボックスを定義します。 TRSはスプライトの配置/サイズとスプライトUVの両方を格納するためにも使用します。

メソッド

void Centering ( Vector2 normalized_pos )

入力で与えられる、正規化された点が（0,0）になるようにTRSを変換します。TRS.Localで事前に定義され、正規化された点です。

引数:
normalized_pos 新しい中心になる、正規化された位置。たとえば、実際のサイズ、位置、TRSの向きに関係なく、( 0.5, 0.5 ) はTRSの中心を表しています。 ( 0, 0 )は左下の点、( 1, 1 )は右上の点です。
void Rotate ( Vector2 rotation )

角度を指定してオブジェクトを回転させます。

引数:
rotation 回転を表す(cos(angle),sin(angle))の単位ベクトル。

This lets you precompute the cos,sin needed during rotation.

void Rotate ( float angle )

角度を指定してオブジェクトを回転させます。

引数:
angle Rotation angle in radian.
override string ToString ( )


構造体 Vector2i

Vector2 のint版。 [詳細]

すべてのメンバ一覧

Public メソッド

Vector2i (int x, int y)
コンストラクタ。
Vector2 Vector2 ()
floatのVector2 型に変換して値を返します。
Vector2i | Max (Vector2i value)
要素単位の最大値。
Vector2i | Min (Vector2i value)
要素単位の最小値。
Vector2i | Clamp (Vector2i min, Vector2i max)
引数の範囲でクランプ処理を行います。
Vector2i | ClampIndex (Vector2i n)
Element wise index clamp.
Vector2i | WrapIndex (Vector2i n)
Element wise index wrap.
int | Product ()
要素の積、 X*Y を返します。
bool | Equals (Vector2i v)
等価テスト。
override bool | Equals (Object o)
等価テスト。
override string | ToString ()
このベクトルの文字列表現を返します。
override int | GetHashCode ()
このベクトルのハッシュコードを返します。

Static Public メソッド

static Vector2i | operator+ (Vector2i a, Vector2i value)
要素単位の加算。
static Vector2i | operator- (Vector2i a, Vector2i value)
要素単位の減算。
static Vector2i | operator* (Vector2i a, Vector2i value)
要素単位の乗算。
static Vector2i | operator* (Vector2i a, int value)
要素単位の乗算。
static Vector2i | operator* (int value, Vector2i a)
要素単位の乗算。
static Vector2i | operator/ (Vector2i a, Vector2i value)
要素単位の除算。
static Vector2i | operator- (Vector2i a)
単項マイナス演算子。
static bool | operator== (Vector2i a, Vector2i value)
全ての要素が等しい場合、true を返します。
static bool | operator!= (Vector2i a, Vector2i value)
少なくとも1つの要素が等しくない場合、trueを返します。

Public 変数

int | X
X.
int | Y
Y.

プロパティ

Vector2i | Yx [get]

説明

Vector2 のint版。

メソッド

Vector2i ClampIndex ( Vector2i n )

Element wise index clamp.

X is clamped to [0,n.X-1] Y is clamped to [0,n.Y-1]

引数:
n The 2d size "this" components must be clamped against. The components of n are assumed to be positive (values of n.X or n.Y negative or zero will result in undefined behaviour).
Vector2i WrapIndex ( Vector2i n )

Element wise index wrap.

X wraps around [0,n.X-1] Y wraps around [0,n.Y-1] This's (X,Y) is assumed to be a 2d index in a 2d table of size (n.X,n.Y). If X or Y are not in the valid array range, they are wrapped around [0,n.X-1] and [0,n.Y-1] respectively (-1 becomes n-1, n becomes 0, n+1 becomes 1 etc), else their value is unchanged.

引数:
n The 2d size "this" components must be wrapped around. The components of n are assumed to be positive (values of n.X or n.Y negative or zero will result in undefined behaviour).

変数

int X

X.

int Y

Y.

プロパティ

Vector2i Yx [get]


構造体 Vector3i

Vector3 の int版。 [詳細]

すべてのメンバ一覧

Public メソッド

Vector3i (int x, int y, int z)
コンストラクタ。
Vector3i (Vector2i xy, int z)
コンストラクタ。
Vector3 Vector3 ()
floatのVector3 型に変換して値を返します。
Vector3i | Max (Vector3i value)
要素単位の最大値。
Vector3i | Min (Vector3i value)
要素単位の最小値。
Vector3i | Clamp (Vector3i min, Vector3i max)
要素単位のクランプ処理。
Vector3i | ClampIndex (Vector3i n)
Element wise index clamp.
Vector3i | WrapIndex (Vector3i n)
Element wise index wrap.
int | Product ()
要素の積、X * Y * Z を返します。
bool | Equals (Vector3i v)
等価テスト。
override bool | Equals (Object o)
等価テスト。
override string | ToString ()
このベクトルの文字列表現を返します。
override int | GetHashCode ()
このベクトルのハッシュコードを返します。

Static Public メソッド

static Vector3i | operator+ (Vector3i a, Vector3i value)
要素単位の加算。
static Vector3i | operator- (Vector3i a, Vector3i value)
要素単位の減算。
static Vector3i | operator* (Vector3i a, Vector3i value)
要素単位の乗算。
static Vector3i | operator/ (Vector3i a, Vector3i value)
要素単位の除算。
static bool | operator== (Vector3i a, Vector3i value)
すべての要素が等しい場合、trueを返します。
static bool | operator!= (Vector3i a, Vector3i value)
少なくとも1つの要素が等しくない場合、trueを返します。

Public 変数

int | X
X.
int | Y
Y.
int | Z
Z.

プロパティ

Vector2i | Xx [get]
Vector2i | Xy [get]
Vector2i | Xz [get]
Vector2i | Yx [get]
Vector2i | Yy [get]
Vector2i | Yz [get]
Vector2i | Zx [get]
Vector2i | Zy [get]
Vector2i | Zz [get]
Vector3i | Xxx [get]
Vector3i | Xxy [get]
Vector3i | Xxz [get]
Vector3i | Xyx [get]
Vector3i | Xyy [get]
Vector3i | Xyz [get]
Vector3i | Xzx [get]
Vector3i | Xzy [get]
Vector3i | Xzz [get]
Vector3i | Yxx [get]
Vector3i | Yxy [get]
Vector3i | Yxz [get]
Vector3i | Yyx [get]
Vector3i | Yyy [get]
Vector3i | Yyz [get]
Vector3i | Yzx [get]
Vector3i | Yzy [get]
Vector3i | Yzz [get]
Vector3i | Zxx [get]
Vector3i | Zxy [get]
Vector3i | Zxz [get]
Vector3i | Zyx [get]
Vector3i | Zyy [get]
Vector3i | Zyz [get]
Vector3i | Zzx [get]
Vector3i | Zzy [get]
Vector3i | Zzz [get]

説明

Vector3 の int版。

メソッド

Vector3i ClampIndex ( Vector3i n )

Element wise index clamp.

X is clamped to [0,n.X-1] Y is clamped to [0,n.Y-1] Z is clamped to [0,n.Z-1]

引数:
n The 3d size "this" components must be clamped against. The components of n are assumed to be positive (values of n.X, n.Y or n.Z negative or zero will result in undefined behaviour).
Vector3i WrapIndex ( Vector3i n )

Element wise index wrap.

X wraps around [0,n.X-1] Y wraps around [0,n.Y-1] Z wraps around [0,n.Z-1] This's (X,Y,Z) is assumed to be a 3d index in a 3d table of size (n.X,n.Y.n.Z). If X, Y or Z are not in the valid array range, they are wrapped around [0,n.X-1], [0,n.Y-1], [0,n.Z-1] respectively (-1 becomes n-1, n becomes 0, n+1 becomes 1 etc), else their value is unchanged.

引数:
n The 2d size "this" components must be wrapped around. The components of n are assumed to be positive (values of n.X, n.Y or n.Z negative or zero will result in undefined behaviour).

変数

int X

X.

int Y

Y.

int Z

Z.

プロパティ

Vector2i Xx [get]
Vector3i Xxx [get]
Vector3i Xxy [get]
Vector3i Xxz [get]
Vector2i Xy [get]
Vector3i Xyx [get]
Vector3i Xyy [get]
Vector3i Xyz [get]
Vector2i Xz [get]
Vector3i Xzx [get]
Vector3i Xzy [get]
Vector3i Xzz [get]
Vector2i Yx [get]
Vector3i Yxx [get]
Vector3i Yxy [get]
Vector3i Yxz [get]
Vector2i Yy [get]
Vector3i Yyx [get]
Vector3i Yyy [get]
Vector3i Yyz [get]
Vector2i Yz [get]
Vector3i Yzx [get]
Vector3i Yzy [get]
Vector3i Yzz [get]
Vector2i Zx [get]
Vector3i Zxx [get]
Vector3i Zxy [get]
Vector3i Zxz [get]
Vector2i Zy [get]
Vector3i Zyx [get]
Vector3i Zyy [get]
Vector3i Zyz [get]
Vector2i Zz [get]
Vector3i Zzx [get]
Vector3i Zzy [get]
Vector3i Zzz [get]


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • ICamera
Public メソッド

インタフェース ICamera

Camera2D と Camera3D 用の共通インターフェース。 [詳細]

ICameraに対する継承グラフ
Camera2D Camera3D

すべてのメンバ一覧

Public メソッド

void | SetAspectFromViewport ()
ビューポートからアスペクト比を読み、その値からカメラプロジェクションのデータを更新します。
void | Push ()
スタック上の全ての行列をプッシュし、Projection と View を設定します。
void | Pop ()
スタックから全ての行列をポップします。
Matrix4 GetTransform ()
Matrix4としてカメラ変換行列（並行位置行列）を返します。 GetTransform().InverseOrthonormal() はビュー行列スタックにプッシュするものです。
void | DebugDraw (float step)
デバッグ用にワールドのグリッドと、ワールド座標系を描画します。 DebugDraw() は内部的にPush()/Pop()を呼び出さないことに注意してください。カメラのPush()/Pop()は、開発者が呼び出してください。
void | Navigate (int control)
デバッグ用ナビゲーションのための入力を処理します。
void | SetViewFromViewport ()
スクリーンの左下がワールドの point(0,0)、スクリーンの右上が point(スクリーンの幅, スクリーンの高さ) に一致するよう、カメラビューを設定します。
Vector2 | NormalizedToWorld (Vector2 bottom_left_minus_1_minus_1_top_left_1_1_normalized_screen_pos)
正規化されたスクリーンの座標系 (-1 -> 1)で与えられた点を、対応するワールドの位置で返します。
Vector2 | GetTouchPos (int nth=0, bool prev=false)
ワールド座標系での引数 'nth' のタッチ位置を返します。'prev' フラグは内部的に使用します。
Bounds2 CalcBounds ()
スクリーン上で現在表示可能なワールドの境界を計算します。この関数は2Dのみ対応しています。(3Dに拡張予定です)。
float | GetPixelSize ()
現在のビューポートのサイズに基づいて、ワールド座標における"スクリーンピクセル"のサイズを取得します。 例えば、スプライトやフォントを1:1で描画するために必要なスケールファクターを決定するために使用することができます。 この関数は2Dのみ対応しています。(3Dに拡張予定です)。
void | SetTouchPlaneMatrix (Matrix4 mat)
GetTouchPos（）によって使用される、3次元平面の向きを設定します。3次元のみ対応しています。

説明

Camera2D と Camera3D 用の共通インターフェース。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • ICollisionBasics
Public メソッド

インタフェース ICollisionBasics

Bounds2, Sphere2, ConvexPoly2 の共通インターフェース。 [詳細]

ICollisionBasicsに対する継承グラフ
Bounds2 ConvexPoly2 Plane2 Sphere2

すべてのメンバ一覧

Public メソッド

bool | IsInside (Vector2 point)
Return true if 'point' is inside the primitive (in its negative space).
void | ClosestSurfacePoint (Vector2 point, out Vector2 ret, out float sign)
Return the closest point to 'point' that lies on the surface of the primitive.
float | SignedDistance (Vector2 point)
Return the signed distance (penetration distance) from 'point' to the surface of the primitive.
bool | NegativeClipSegment (ref Vector2 A, ref Vector2 B)
Assuming the primitive is convex, clip the segment AB against the primitive.

説明

Bounds2, Sphere2, ConvexPoly2 の共通インターフェース。

メソッド

void ClosestSurfacePoint | ( | Vector2 | point,
 |  | out Vector2 | ret,
 |  | out float | sign
 | ) |  |

Return the closest point to 'point' that lies on the surface of the primitive.

If that point is inside the primitive, sign is negative.

Bounds2, Plane2, Sphere2, と ConvexPoly2で実装されています。

bool NegativeClipSegment | ( | ref Vector2 | A,
 |  | ref Vector2 | B
 | ) |  |

Assuming the primitive is convex, clip the segment AB against the primitive.

Return false if AB is entirely in positive halfspace, else clip against negative space and return true.

Bounds2, Plane2, Sphere2, と ConvexPoly2で実装されています。


クラス ActionBase

全てのアクションの基底クラス。 [詳細]

ActionBaseに対する継承グラフ
ActionWithDuration CallFunc Repeat RepeatForever Sequence ActionTweenGeneric< T > DelayTime ActionTweenGenericVector2 ActionTweenGenericVector2Rotation ActionTweenGenericVector2Scale ActionTweenGenericVector4 MoveBy MoveTo SkewBy SkewTo RotateBy RotateTo ScaleBy ScaleTo TintBy TintTo

すべてのメンバ一覧

Public メソッド

virtual void | Run ()
アクションをキック (実行) します。
virtual void | Stop ()
アクションを停止します (いくつかのアクションは自動で停止します)。
virtual void | Update (float dt)
毎フレーム呼び出される、このアクションのUpdate関数。

Public 変数

int | Tag
このアクションを検索するために使用するタグ値。

プロパティ

bool | IsRunning [get]
このアクションがアクティブの場合、IsRunning は true になります。
Node | Target [get]
このアクションによって影響を受けるノード。

説明

全てのアクションの基底クラス。


クラス ActionManager

ActionManager は Node のアクションを管理するシングルトンオブジェクトです。 メインの Update ループは Director.Update() で呼び出されます。 [詳細]

すべてのメンバ一覧

Public メソッド

void | AddAction (ActionBase action, Node target)
ActionManager にアクションを追加します。
void | RemoveAllActions ()
全てのアクションを削除します。
void | RemoveAllActionsFromTarget (Node target)
引数 'target' のノードを含む、全てのアクションを削除します。
void | RemoveAction (ActionBase action)
ひとつのアクションを削除します。
void | RemoveActionByTag (int tag, Node target)
引数 tag からアクションを見つけ、削除します。
ActionBase | GetActionByTag (int tag, Node target, int ith=0)
引数 tag からアクションを取得します。
int | NumRunningActions (Node target)
引数'target'のノードを含む、アクションの数をカウントします。
int | NumRunningActions ()
実行中のアクションの総数をカウントします。
void | Dump ()
デバッグ情報を出力します。(将来変更される可能性があります)

プロパティ

static ActionManager | Instance [get]
ActionManager のシングルトン。

説明

ActionManager は Node のアクションを管理するシングルトンオブジェクトです。 メインの Update ループは Director.Update() で呼び出されます。


クラス テンプレート ActionTweenGeneric< T >

汎用的な補間アクションの基底クラス。set/get 関数をセットします。 抽象クラス。 [詳細]

ActionTweenGeneric< T >に対する継承グラフ
ActionWithDuration ActionBase ActionTweenGenericVector2 ActionTweenGenericVector2Rotation ActionTweenGenericVector2Scale ActionTweenGenericVector4 MoveBy MoveTo SkewBy SkewTo RotateBy RotateTo ScaleBy ScaleTo TintBy TintTo

すべてのメンバ一覧

Public メソッド

delegate void | DSet (T value)
set関数のデリゲート。
delegate T | DGet ()
get関数のデリゲート。
ActionTweenGeneric ()
コンストラクタ。
ActionTweenGeneric (DGet dget, DSet dset)
コンストラクタ。
override void | Run ()
アクションをキックします。
override void | Update (float dt)
Update関数。

Public 変数

T | TargetValue
ターゲットの値。
bool | IsRelative = false
trueの場合、ターゲットの値はオフセットです。
DTween | Tween = (t) => Math.PowEaseOut(t,4.0f)
Tween/補間の関数。基本的に xが0から1になるとき、f(x)が0から1になる f(x)です。
DSet | Set
tweenを実行しているとき、現在の値をセットする関数。
DGet | Get
tweenを実行しているとき、現在の値を取得する関数。

説明

template<T>
class Sce::PlayStation::HighLevel::GameEngine2D::ActionTweenGeneric< T >

汎用的な補間アクションの基底クラス。set/get 関数をセットします。 抽象クラス。

変数

DTween Tween = (t) => Math.PowEaseOut(t,4.0f)

Tween/補間の関数。基本的に xが0から1になるとき、f(x)が0から1になる f(x)です。

DTween を設定可能な関数の例です。

(t) => Math.Linear(t);

(t) => Math.ExpEaseIn(t,1.0f);

(t) => Math.ExpEaseOut(t,1.0f);

(t) => Math.PowEaseIn(t,4.0f);

(t) => Math.PowEaseOut(t,4.0f);

(t) => Math.PowEaseInOut(t,4.0f);

(t) => Math.BackEaseIn(t,1.0f);

(t) => Math.BackEaseOut(t,1.0f);

(t) => Math.BackEaseInOut(t,1.0f);

(t) => Math.PowerfulScurve(t,3.7f,3.7f);

(t) => Math.Impulse(t,10.0f);

(t) => FMath.Sin(t*Math.Pi*0.5f); // for sin curve tween

tweenの詳細については、cocos2dのドキュメントを参考にしてください。

http://www.robertpenner.com/easing/easing_demo.html

http://www.robertpenner.com/easing/penner_chapter7_tweening.pdf


クラス ActionTweenGenericVector2

ActionTweenGenericVector2 はスタート値からターゲット値に移行する、シンプルなwiseブレンドを行います。 [詳細]

ActionTweenGenericVector2に対する継承グラフ
ActionTweenGeneric< T > ActionWithDuration ActionBase MoveBy MoveTo SkewBy SkewTo

すべてのメンバ一覧

説明

ActionTweenGenericVector2 はスタート値からターゲット値に移行する、シンプルなwiseブレンドを行います。


クラス ActionTweenGenericVector2Rotation

ActionTweenGenericVector2Rotation は単位ベクトルを補間します。単位ベクトルは回転で補間します。 [詳細]

ActionTweenGenericVector2Rotationに対する継承グラフ
ActionTweenGeneric< T > ActionWithDuration ActionBase RotateBy RotateTo

すべてのメンバ一覧

説明

ActionTweenGenericVector2Rotation は単位ベクトルを補間します。単位ベクトルは回転で補間します。


クラス ActionTweenGenericVector2Scale

ActionTweenGenericVector2Scale は ActionTweenGenericVector2 に似ていますが、 スケール値 (乗法) で実行します。 [詳細]

ActionTweenGenericVector2Scaleに対する継承グラフ
ActionTweenGeneric< T > ActionWithDuration ActionBase ScaleBy ScaleTo

すべてのメンバ一覧

説明

ActionTweenGenericVector2Scale は ActionTweenGenericVector2 に似ていますが、 スケール値 (乗法) で実行します。


クラス ActionTweenGenericVector4

ActionTweenGenericVector4 はスタート値からターゲット値に移行する、シンプルなwiseブレンドを行います。 [詳細]

ActionTweenGenericVector4に対する継承グラフ
ActionTweenGeneric< T > ActionWithDuration ActionBase TintBy TintTo

すべてのメンバ一覧

説明

ActionTweenGenericVector4 はスタート値からターゲット値に移行する、シンプルなwiseブレンドを行います。


クラス ActionWithDuration

有限の期間を持つアクションの基底クラス。 抽象クラス。 [詳細]

ActionWithDurationに対する継承グラフ
ActionBase ActionTweenGeneric< T > DelayTime ActionTweenGenericVector2 ActionTweenGenericVector2Rotation ActionTweenGenericVector2Scale ActionTweenGenericVector4 MoveBy MoveTo SkewBy SkewTo RotateBy RotateTo ScaleBy ScaleTo TintBy TintTo

すべてのメンバ一覧

Public メソッド

override void | Run ()
アクションをキックします。

Public 変数

float | Duration = 0.0f
秒単位でのアクションの期間。

説明

有限の期間を持つアクションの基底クラス。 抽象クラス。


クラス CallFunc

指定した関数を呼び出す、ワンショットアクション。 [詳細]

CallFuncに対する継承グラフ
ActionBase

すべてのメンバ一覧

Public メソッド

CallFunc (System.Action func)
コンストラクタ。
override void | Update (float dt)
Update関数。

Public 変数

System.Action | Func
このアクションが呼び出す関数。

説明

指定した関数を呼び出す、ワンショットアクション。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • DebugFlags
Static Public 変数

クラス DebugFlags

フラグのビットは Director.Instance.DebugFlags によって使用されます。 デフォルトでは、全てオフです。 [詳細]

すべてのメンバ一覧

Static Public 変数

static uint | DrawTransform = 1
それぞれのノードの変換行列を赤い矢印+緑の矢印として描画します。
static uint | DrawPivot = 2
すべてのノードの中心軸を表示します。
static uint | DrawContentLocalBounds = 4
GetlContentLocalBounds で定義されるノードの、コンテントローカル境界を表示します。 コンテントローカル境界は親によって変換されることを注意してください。
static uint | DrawContentWorldBounds = 8
GetlContentLocalBounds で定義されるノードの、コンテントワールド境界を表示します。
static uint | DrawGrid = 16
軸を黒、ルーラーを灰色で、デバッグワールドグリッドを描画します。
static uint | Navigate = 32
デバッグカメラナビゲーションを使用可にします(カメラ2Dのみ動作します)。

説明

フラグのビットは Director.Instance.DebugFlags によって使用されます。 デフォルトでは、全てオフです。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • DelayTime
Public メソッド

クラス DelayTime

指定した期間ののち終了する、待機アクション。 [詳細]

DelayTimeに対する継承グラフ
ActionWithDuration ActionBase

すべてのメンバ一覧

Public メソッド

DelayTime ()
コンストラクタ。
DelayTime (float duration)
コンストラクタ。
override void | Run ()
このアクションをキックします。
override void | Update (float dt)
Update関数。

説明

指定した期間ののち終了する、待機アクション。

コンストラクタとデストラクタ

DelayTime ( float duration )

コンストラクタ。

引数:
duration 秒単位での待機時間。


クラス Director

Director はシーンスタックを管理し、Scheduler と ActionManager の update ループを呼び出すシングルトンです。 開発者自身が独自にメインループを実装する場合、開発者はUpdate / Render / PostSwap 関数をメインループの中で呼び出さなければなりません。 また Director は、グラフィックスコンテキスト (GL) 、SpriteRenderer オブジェクト ( 主に内部的に利用されますが、開発者が直接使うこともできます )、 デバッグ情報を描画する DrawHelpers を保持します。 [詳細]

すべてのメンバ一覧

Public メソッド

void | Dispose ()
Dispose の実装。
void | ReplaceScene (Scene new_scene)
現在のシーンを他のシーンに置き換えます。
void | PushScene (Scene new_scene)
新しいシーンをシーンスタックにプッシュします。
void | PopScene ()
シーンスタック (前のシーン) のトップのシーンをポップします。
void | Pause ()
一時停止します。
void | Resume ()
void | Dump ()
デバッグ情報を出力します(内容は将来変更される場合があります)。
void | Update ()
メインのステップ関数です。1フレームに1度呼び出す必要があります。
void | Render ()
メインの描画関数です。1フレームに1度呼び出す必要があります。
void | PostSwap ()
スワップコールバック関数。SwapBuffers() の後に呼び出す必要があります。
void | RunWithScene (Scene scene, bool manual_loop=false)
システムにどの Scene オブジェクトをスタートさせるのか伝えるために、開発者はこの関数を1度呼び出さなければなりません。

Static Public メソッド

static void | Initialize (uint sprites_capacity=500, uint draw_helpers_capacity=400, Sce.PlayStation.Core.Graphics.GraphicsContext context=null)
GameEngine2D を初期化します。
static void | Terminate ()
GameEngine2D の終了処理。

Public 変数

GraphicsContextAlpha GL
グラフィックスコンテキスト + 行列スタック。
SpriteRenderer SpriteRenderer
メインの SpriteRenderer オブジェクト。
DrawHelpers DrawHelpers
デバッグ描画のための描画ヘルパー。
uint | DebugFlags = 0
ログ、デバッグ描画、カメラナビゲーションなどを有効にするデバッグフラグ。

プロパティ

double | DirectorTime [get]
Update が呼ばれるたびにインクリメントされるタイマー。
static Director | Instance [get]
Director のシングルトン。
Scene | CurrentScene [get]
現在実行している Scene オブジェクトを取得します。

説明

Director はシーンスタックを管理し、Scheduler と ActionManager の update ループを呼び出すシングルトンです。 開発者自身が独自にメインループを実装する場合、開発者はUpdate / Render / PostSwap 関数をメインループの中で呼び出さなければなりません。 また Director は、グラフィックスコンテキスト (GL) 、SpriteRenderer オブジェクト ( 主に内部的に利用されますが、開発者が直接使うこともできます )、 デバッグ情報を描画する DrawHelpers を保持します。

メソッド

static void Initialize | ( | uint | sprites_capacity = 500,
 |  | uint | draw_helpers_capacity = 400,
 |  | Sce.PlayStation.Core.Graphics.GraphicsContext | context = null
 | ) |  | [static]

GameEngine2D を初期化します。

引数:
sprites_capacity | SpriteRenderer のコンストラクタに渡されるスプライトの最大数。
draw_helpers_capacity | DrawHelpers で使用する頂点の最大数。
context | コアグラフィックスコンテキスト。
void Resume ( )

再開します。

void RunWithScene | ( | Scene | scene,
 |  | bool | manual_loop = false
 | ) |  |

システムにどの Scene オブジェクトをスタートさせるのか伝えるために、開発者はこの関数を1度呼び出さなければなりません。

引数:
scene | 実行するシーン。
manual_loop | trueをセットすると、メインループを開始しません ( 開発者はそれを実装する必要があります)。


クラス Label

テキストのプリミティブを描画します。2つのタイプのフォントデータをサポートしています:

  • SpriteRenderer に埋め込まれたデバッグフォント。
  • FontMap オブジェクトを使ったもの。
[詳細]

Labelに対する継承グラフ
Node

すべてのメンバ一覧

Public メソッド

Label ()
コンストラクタ。
Label (string text, FontMap fontmap=null)
コンストラクタ。
override void | Draw ()
描画関数。
override bool | GetlContentLocalBounds (ref Bounds2 bounds)
ローカル空間での、テキストを囲む Bounds2 オブジェクトを返します。
Bounds2 GetlContentLocalBounds ()
ローカル空間での、テキストを囲む Bounds2 オブジェクトを返します。

Public 変数

string | Text = ""
表示するテキスト。
Vector4 | Color = Colors.White
テキストの色。
BlendMode | BlendMode = BlendMode.Normal
テキストのブレンドモード。
float | HeightScale = 1.0f
描画中、文字のピクセル単位の高さに適用されるスケール係数。
FontMap FontMap
この Label を表示するのに使用されるフォントマップ(文字のセットに一致する必要があります)。
SpriteRenderer.ISpriteShader | Shader = (SpriteRenderer.ISpriteShader)Director.Instance.SpriteRenderer.DefaultFontShader
開発者は、任意のシェーダーをセットすることができます。 Label クラスは開発者がセットしたシェーダーを 破棄しないので注意してください。

プロパティ

float | CharWorldHeight [get]
ワールド座標系 = FontHeight * HeightScale での文字の高さ。

説明

テキストのプリミティブを描画します。2つのタイプのフォントデータをサポートしています:

  • SpriteRenderer に埋め込まれたデバッグフォント。
  • FontMap オブジェクトを使ったもの。

コンストラクタとデストラクタ

Label | ( | string | text,
 |  | FontMap | fontmap = null
 | ) |  |

コンストラクタ。

引数:
text | 描画するテキスト。
fontmap | テキストの描画に使用するフォントデータ。 null の場合、埋め込まれているデバッグフォントを使用します。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • MoveBy
Public メソッド

クラス MoveBy

オフセットの値を現在の位置に徐々に加算していくアクション。 [詳細]

MoveByに対する継承グラフ
ActionTweenGenericVector2 ActionTweenGeneric< T > ActionWithDuration ActionBase

すべてのメンバ一覧

Public メソッド

MoveBy (Vector2 target, float duration)
コンストラクタ。

説明

オフセットの値を現在の位置に徐々に加算していくアクション。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • MoveTo
Public メソッド

クラス MoveTo

指定した目標に徐々に移動するアクション。 [詳細]

MoveToに対する継承グラフ
ActionTweenGenericVector2 ActionTweenGeneric< T > ActionWithDuration ActionBase

すべてのメンバ一覧

Public メソッド

MoveTo (Vector2 target, float duration)
コンストラクタ。

説明

指定した目標に徐々に移動するアクション。


クラス Node

ノードは全てのシーングラフノードの基底クラスです。標準的な2D変換行列、子のリスト、親へのハンドラを持ちます。ノードは多くとも1つの親をもつことができます。 [詳細]

Nodeに対する継承グラフ
Label Particles Plane3D RawSpriteTileList Scene SpriteBase SpriteList TransitionScene SpriteTile SpriteUV TransitionFadeBase TransitionCrossFade TransitionDirectionalFade TransitionSolidFade

すべてのメンバ一覧

Public メソッド

void | Rotate (float angle)
引数 'angle' でオブジェクトを回転します。 この関数は単に Rotation / Angle プロパティに影響を与えることに注意してください。( Pivot や Positionに関わらず、角度をインクリメントします。それらのすべては GetTransform() で結合されます。) 変換行列の構築の詳細は、GetTransform() を参考にしてください。
void | Rotate (Vector2 rotation)
単位ベクトル 'rotation' として渡される角度でオブジェクトを回転します。 これで、回転中に必要な cos,sinを事前に計算できます。 この関数は Rotation/Angle プロパティに影響を与えることに注意してください。( Pivot や Positionに関わらず、角度をインクリメントします。それらのすべては GetTransform() で結合されます。) 変換行列の構築の詳細は、GetTransform() を参考にしてください。
delegate void | DDraw ()
AdHocDraw で使用されるデリゲート型。
Node ()
コンストラクタ。
virtual void | PushTransform ()
ノードとその子を描画する前にこの関数が呼び出されます。
virtual void | PopTransform ()
ノードとその子が描画されたあとにこの関数が呼び出されます。
virtual void | OnEnter ()
シーンが Director.Instance によって開始されたとき、この関数が呼び出されます。
delegate void | DOnExitEvent ()
OnExit() イベントのデリゲート。
virtual void | OnExit ()
シーンを終了したり、子が RemoveChild() や RemoveAllChildren() で明示的に削除されたとき、この関数が呼び出されます。
void | RegisterDisposeOnExitRecursive ()
すべてのサブツリー(このノードを含む)を再帰し、すべての破棄可能なオブジェクトに Dispose() 関数を登録します。 実行しているオブジェクトが Dispose() してないことを最初に確認し、Cleanupを呼び出します。
void | RegisterDisposeOnExit (System.IDisposable disposable)
このノードの OnExit()関数内に、Dispose() の呼び出しを登録します。 例えば、いくつかのオブジェクト(TextureInfo, FontMap, など)で Dispose() を行いたいときや、 Scene ノードを終了するときです。
void | AddChild (Node child, int order)
子に描画プロパティを追加します。
void | AddChild (Node child)
現在の順序を使って、このノードに子を追加します。
void | RemoveChild (Node child, bool do_cleanup)
このノードから子を削除します。
void | RemoveAllChildren (bool do_cleanup)
この関数は、全ての子に対して、RemoveChild( dispose_flags )を呼び出すのと、等価です。
delegate bool | DVisitor (Node node, int depth)
巡回メソッドに渡す関数の型。
virtual void | Traverse (DVisitor visitor, int depth)
このノードの引数 'visitor'関数を呼び出し、かつこのノードの全ての子を再帰的に呼び出します。 visitor が false を返した場合、巡回を中断します。
virtual void | DrawHierarchy ()
この関数は、 Director によってのみ呼び出されます。しかし、PushTransform, Draw, PopTransform は上書きすることができます。
virtual void | Draw ()
PushTransform / PopTransform 内の描画を実行します。
virtual void | Update (float dt)
Update 関数。 Director は1フレームあたりと経過時間あたりで、この関数を何度呼び出すか決定します。 現時点では、Update 関数は、フレーム経過時間をそのまま使って、一度呼び出されています。
virtual void | DebugDrawContentLocalBounds ()
ノードのローカル空間内に、ローカルコンテントの境界と中心軸を描画します。 普通は、この関数を上書きする必要はありません。 GetlContentLocalBounds()を上書きし、例えば DebugFlags.DrawContentLocalBounds が設定されたとき、この関数はそれを表示します。
void | DebugDrawTransform ()
親ノードのローカル空間内での、ローカル座標系を描画します。
void | RunAction (ActionBase action)
このノードのアクションを開始します。
void | StopAllActions ()
このノードの全てのアクションを停止します。
void | StopAction (ActionBase action)
このノードのアクションを停止します。
void | StopActionByTag (int tag)
tag の値で、このノード内で実行している最初のアクションを検索し、停止/削除します。
ActionBase | GetActionByTag (int tag, int ith=0)
このノード内で、実行している 'tag' の 'ith' アクションを返します。
int | NumRunningActions ()
このノード内で、実行しているアクションの数を取得します。
virtual void | Cleanup ()
このノード内の、全てのアクションとスケジュールされた関数を再帰的に停止します。
void | ScheduleUpdate (int priority=Scheduler.DefaultPriority)
スケジューラにこのノードのUpdate関数を登録します。update関数は全てのフレームで呼び出されます。
void | UnscheduleUpdate ()
スケジューラからUpdate関数を削除します。
void | Schedule (DSchedulerFunc func, int priority=Scheduler.DefaultPriority)
引数のノード関数 'func' をスケジュールします。関数は全てのフレームで呼び出されます。
void | ScheduleInterval (DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority)
引数のノード関数 'func' を、引数 'interval'の間隔で呼び出されるようにスケジュールします。
void | Unschedule (DSchedulerFunc func)
引数のノード関数 'func'をアンスケジュールします。
void | UnscheduleAll ()
このノードに関連する全ての関数をアンスケジュールします。
void | ResumeSchedulerAndActions ()
SchedulerPaused と ActionsPaused に true をセットします。
void | PauseSchedulerAndActions ()
SchedulerPaused と ActionsPaused に false をセットします、。
Matrix3 GetTransform ()
親空間で表現される、このノードの変換行列を返します。
Matrix3 GetTransformInverse ()
このノードの変換行列の逆行列を取得します。
Matrix3 GetWorldTransform ()
ワールド/親 シーン空間で表される、このノードの変換行列を返します。
Matrix3 CalcWorldTransformInverse ()
このノードのワールド変換行列の逆行列を取得します。
Vector2 | LocalToWorld (Vector2 local_point)
LocalToWorld は ( GetWorldTransform() * local_point.Xy1 ).Xy と同じものを返します。
Vector2 | WorldToLocal (Vector2 world_point)
( CalcWorldTransformInverse() * world_point.Xy1 ).Xy と同じものを返します。 ノードのローカル空間はその幾何情報を定義した空間です。 すなわち、1レベル下の GetWorldTransform() 。
virtual bool | GetlContentLocalBounds (ref Bounds2 bounds)
ノード空間内(再帰なし)で、このノードのみのコンテント/幾何情報の境界を取得します。 任意のコンテントを持たないノードは単に false を返します。
virtual bool | GetContentWorldBounds (ref Bounds2 bounds)
ワールド空間(再帰なし)で、このノードのみのコンテントの境界を取得します。 任意のコンテントを持たないノードは単に false を返します。その場合、境界は扱えません。
bool | IsWorldPointInsideContentLocalBounds (Vector2 world_position)
引数'world_position'が、向きをもったコンテントの境界ボックス内にある場合、trueを返します。
virtual void | FindParentPlane (ref Matrix4 mat)
Plane3D ノードが見つかるまで、親の階層構造に従い、 Plane3D の平面行列に 'mat' をセットします。
Vector2 | GetTouchPos (int nth=0, bool prev=false)
Like Director.Instance.CurrentScene.Camera.GetTouchPos に似ていますが、シーングラフ内の祖先に Plane3D が存在したときのケースを扱います。

Public 変数

float | VertexZ
VectorZ は描画中、Z座標としての値のセットです。デフォルトでは、ortho ビューは Z範囲[-1, 1]を示し、任意で Camera.Znear と Camera.Zfar をセットします。
bool | Visible
Visible が false の場合、このノードとその子は描画されません。
ICamera | Camera = null
シーン内には通常ひとつのカメラしか配置されていないことの対応策として、 Node.Camera を使うことができます。 Node.Camera が設定されている場合、このノードまでの全ての変換行列は無視され、Node.Camera は、このノードを描画するたびに、プッシュ/ポップされます。
string | Name
開発者用の識別子。

Static Public 変数

static float | DebugDrawTransformScale = 1.0f
矢印を描画する DebugDrawTransform によって使用されるスケール係数。 デフォルトではこの値は1.0fで、矢印の単位の長さは、スクリーン上で長さ1にあたります。 スクリーン上で表示されるゲームの世界では大きすぎるので、長さ1の矢印は、1ピクセル以下であるかもしれず、それらが描画されていても見ることができないかもしれません。 その場合、DebugDrawTransform でそれらをスケールすることができます。

プロパティ

Vector2 | Position [get, set]
変換行列の構築に関しての詳細は、GetTransform() を参考にしてください。
Vector2 | Rotation [get, set]
Rotation は (cos,sin)の単位ベクトルとして直接格納されます。
Vector2 | RotationNormalize [get, set]
RotationNormalize は Rotation に似ていますが、正規化を行います。 これにより、蓄積される計算誤差で単位ベクトルがドリフトするのを防ぎます。 変換行列の構築の詳細は、GetTransform() を参考にしてください。
float | Angle [get, set]
このプロパティを使うと、回転を角度として set/getすることができます。 この処理は重く、角度の不連続の問題を引き起こします。角度は常に格納され、かつ -pi,piの範囲で値を返します。 変換行列の構築の詳細は、GetTransform() を参考にしてください。
Vector2 | Scale [get, set]
変換行列の構築の詳細は、GetTransform() を参考にしてください。
Vector2 | Skew [get, set]
変換行列の構築の詳細は、GetTransform() を参考にしてください。
Vector2 | Pivot [get, set]
Pivot はスケールや回転に使用される中心軸です。そして Node のローカル '正規化' 空間として表現されます。 例えば、スケールに関わりなく、(0.5, 0.5)は常にオブジェクトの中心です。 変換行列の構築の詳細は、GetTransform() を参考にしてください。
Node | Parent [get]
シーングラフ内の親ノードです。ひとつのノードは、多くともひとつの親ノードの子になります。
List< Node > | Children [get]
子ノードのリスト。
Camera2D | Camera2D [get]
Camera2D としてのカメラを取得するためのショートカット。
Camera3D | Camera3D [get]
Camera3D としてのカメラを取得するためのショートカット。
bool | IsRunning [get]
このノードが OnEnter()/OnExit() 呼び出しの合間である時、このプロパティは true になります。
int | Order [get]
ReorderChild() または AddChild() でセットされた描画順序の値。
bool | ActionsPaused [get, set]
このノードに関連する全てのアクションを、このフラグのon/offで一時停止させることができます。
bool | SchedulerPaused [get, set]
このノードに関連するスケジュールされた全ての関数を、このフラグのon/offで一時停止させることができます。

イベント

DDraw | AdHocDraw
セットされた場合、baseの描画関数内でAdHocDrawが呼び出されます。 描画関数の定義のためにクラスを派生させずに、シンプルなシーンをセットアップするために使用されます。
DOnExitEvent | OnExitEvents
OnExit が呼び出された時、実行するイベントのリスト。 実行されたあと、リストはクリアされます。

説明

ノードは全てのシーングラフノードの基底クラスです。標準的な2D変換行列、子のリスト、親へのハンドラを持ちます。ノードは多くとも1つの親をもつことができます。

メソッド

void AddChild | ( | Node | child,
 |  | int | order
 | ) |  |

子に描画プロパティを追加します。

引数:
child | 追加する子ノード。
order | 追加するノードの描画プロパティ。描画順序は数値順に行われます。 負の数のプロパティはこの子が親より前に描画されることを意味します。 正の数のプロパティは親より後に描画されます。
Matrix3 GetTransform ( )

親空間で表現される、このノードの変換行列を返します。

ノードの変換行列は、位置、スケール、歪み、回転/角度/ RotationNormalize、ピボットプロパティでアクセスされるデータを用いて形成されます。変換行列は次のものと等価です:

Matrix3.Translation( Position ) Matrix3.Translation( Pivot ) Matrix3.Rotation( Rotation ) Matrix3.Scale( Scale ) Matrix3.Skew( Skew ) Matrix3.Translation( -Pivot )

変換行列で返されるのは、純粋な2D変換であることに注意してください。 VertexZ は PushTransform 関数で別々に適用されます。

void RemoveChild | ( | Node | child,
 |  | bool | do_cleanup
 | ) |  |

このノードから子を削除します。

引数:
child | 削除する子。
do_cleanup | 削除するノードで Cleanup を呼び出す。
virtual void Update ( float dt ) [virtual]

Update 関数。 Director は1フレームあたりと経過時間あたりで、この関数を何度呼び出すか決定します。 現時点では、Update 関数は、フレーム経過時間をそのまま使って、一度呼び出されています。

引数:
dt 1秒あたりの経過時間。

Particlesで再定義されています。

プロパティ

Vector2 Rotation [get, set]

Rotation は (cos,sin)の単位ベクトルとして直接格納されます。

変換行列の構築に関しての詳細は、GetTransform() を参考にしてください。


クラス Particles

ひとつの ParticleSystem を シーングラフノードにラップしたパーティクルクラス。 [詳細]

Particlesに対する継承グラフ
Node

すべてのメンバ一覧

Public メソッド

Particles (int max_particles)
コンストラクタ。コンストラクタが ScheduleUpdate() を呼び出すことに注意してください。
override void | Update (float dt)
Update関数。
override void | Draw ()
描画関数。
void | Dispose ()
Disposeの実装。

Public 変数

ParticleSystem ParticleSystem
この Particles によって使用される、実質的な ParticleSystem オブジェクト。

説明

ひとつの ParticleSystem を シーングラフノードにラップしたパーティクルクラス。

コンストラクタとデストラクタ

Particles ( int max_particles )

コンストラクタ。コンストラクタが ScheduleUpdate() を呼び出すことに注意してください。

引数:
max_particles このパーティクルシステムの最大パーティクル数。


クラス ParticleSystem

シンプルなパーティクルシステムエフェクト。 [詳細]

すべてのメンバ一覧

構成

class | EmitterParams
このクラスは、パーティクルの初期化に必要な全てのパラメータを再グループ化します。 ランダムの範囲を与えるため、多くの値は分散しています(-Var の接尾辞)。 分散が "相対"値（-RelVarの接尾辞）である場合、0,1の間の値が期待されています。 例: 0.2f は、作成時に対応する値は -+20でランダム化されることを意味します。 [詳細]
interface | IParticleShader
ParticleSystem のシェーダーインターフェース。 [詳細]
class | Particle
CreateParticle で返される、パーティクルオブジェクト。 [詳細]
class | ParticleShaderDefault
デフォルトのシェーダー。テクスチャの色は変調されます。 [詳細]
class | SimulationParams
SimulationParams は、Update と Draw で必要とされる全てのパラメータを、再グループ化します。 [詳細]

Public メソッド

ParticleSystem (int max_particles)
コンストラクタ。
void | Dispose ()
Disposeの実装。
Particle | CreateParticle (bool skip_auto_init=false)
Emit パラメータを使って自動で作成されるパーティクル。 必要に応じて作成でき、開発者がパーティクルを初期化できます。
void | Update (float dt)
Update関数。
void | Draw ()
描画関数。

Static Public メソッド

static void | Terminate ()
静的リソースの破棄。

Public 変数

TextureInfo TextureInfo
このパーティクルシステムのテクスチャ情報。全てのパーティクルは同じイメージを使用します。
Vector4 | Color = Colors.White
パーティクルシステムのためのグローバルな乗算色。
BlendMode | BlendMode = BlendMode.Normal
パーティクルによって使用されるブレンドモード。
EmitterParams Emit
パラメータは、パーティクルの放出とパラメータの初期化の管理に使用します。
SimulationParams Simulation
シミュレーションのコントロールに使われるパラメータ。
Matrix3 | RenderTransform = Matrix3.Identity
パーティクルシステムを描画するためのモデルビュー行列
IParticleShader Shader
開発者がセットすることのできる外部シェーダー。 Label クラスは開発者がセットしたシェーダーを破棄しません。(ParticleSystem.DefaultShaderは除く)

プロパティ

int | MaxParticles [get]
システムが取り扱うパーティクルの数。
int | ParticlesCount [get]
生存しているパーティクルの数。
bool | IsFull [get]
アクティブなパーティクルが最大数に達すると、trueを返します。
static ParticleShaderDefault | DefaultShader [get]
パーティクルシステムのデフォルトシェーダー ( texture * color )。
bool | Disposed [get]
このオブジェクトが破棄されていれば、trueを返します。

説明

シンプルなパーティクルシステムエフェクト。

コンストラクタとデストラクタ

ParticleSystem ( int max_particles )

コンストラクタ。

引数:
max_particles パーティクルシステムのパーティクルの最大数。

メソッド

Particle CreateParticle ( bool skip_auto_init = false )

Emit パラメータを使って自動で作成されるパーティクル。 必要に応じて作成でき、開発者がパーティクルを初期化できます。

引数:
skip_auto_init falseなら、作成されたパーティクルを Emit パラメータを使って初期化します。パーティクルは毎フレーム、ランダムに作成されます。 ( 開始時にランダムの分散を使用した場合)。
戻り値:
作成されたパーティクルのハンドラ。

変数

Matrix3 RenderTransform = Matrix3.Identity

パーティクルシステムを描画するためのモデルビュー行列

RenderTransform は ローカルの幾何情報を描画するため、基底クラスの Node.GetTransform() を上書きします。


クラス ParticleSystem.EmitterParams

このクラスは、パーティクルの初期化に必要な全てのパラメータを再グループ化します。 ランダムの範囲を与えるため、多くの値は分散しています(-Var の接尾辞)。 分散が "相対"値（-RelVarの接尾辞）である場合、0,1の間の値が期待されています。 例: 0.2f は、作成時に対応する値は -+20でランダム化されることを意味します。 [詳細]

すべてのメンバ一覧

Public メソッド

EmitterParams ()
コンストラクタ。
string | ToString (string prefix)
EmitterParams の文字列表現を返します。

Public 変数

Matrix3 | Transform = Matrix3.Identity
生成される位置・速度・角度はこの行列によって変換されます。
Matrix3 | TransformForVelocityEstimate = Matrix3.Identity
速度と角速度の推定に使用する変換行列。
float | ForwardMomentum = 0.0f
作成したパーティクルに追加する速度のコントロール。
float | AngularMomentun = 0.0f
作成したパーティクルに追加する角速度のコントロール。
float | WaitTime = 1.0f
次のパーティクルが生成されるまで待機する時間。秒単位。
float | WaitTimeRelVar = 0.15f
待機時間の分散 (相対)。
float | LifeSpan = 5.0f
作成されたパーティクルの寿命。秒単位。
float | LifeSpanRelVar
寿命の長さの分散(相対)。
Vector2 Position = GameEngine2D.Base.Math._00
作成されたパーティクルの初期位置 ( InLocalSpaceも参考にしてください )。
Vector2 | PositionVar = GameEngine2D.Base.Math._11 * 1.5f
位置の分散。
Vector2 Velocity = GameEngine2D.Base.Math._01
作成したパーティクルの初期速度 ( InLocalSpaceも参考にしてください )。
Vector2 | VelocityVar = GameEngine2D.Base.Math._11 * 0.2f
速度の分散。
float | AngularVelocity
作成したパーティクルの初期角速度。ラジアン単位 ( InLocalSpaceも参考にしてください )。
float | AngularVelocityVar
AngularVelocityの分散。
float | Angle
作成したパーティクルの初期回転角度。ラジアン単位 ( InLocalSpaceも参考にしてください )。
float | AngleVar
角度の分散。
Vector4 | ColorStart = Colors.White
作成したパーティクルの初期色。
Vector4 ColorStartVar = GameEngine2D.Base.Math._0000
初期色の分散。
Vector4 | ColorEnd = Colors.White
寿命に達したときのパーティクルの色。
Vector4 ColorEndVar = GameEngine2D.Base.Math._0000
ColorEndの分散。
float | ScaleStart = 1.0f
作成したパーティクルの初期サイズ。
float | ScaleStartRelVar
ScaleStartの分散。
float | ScaleEnd = 1.0f
寿命に達したときの粒子のサイズ。
float | ScaleEndRelVar
ScaleEndの分散。

説明

このクラスは、パーティクルの初期化に必要な全てのパラメータを再グループ化します。 ランダムの範囲を与えるため、多くの値は分散しています(-Var の接尾辞)。 分散が "相対"値（-RelVarの接尾辞）である場合、0,1の間の値が期待されています。 例: 0.2f は、作成時に対応する値は -+20でランダム化されることを意味します。

メソッド

string ToString ( string prefix )

EmitterParams の文字列表現を返します。

引数:
prefix それぞれの行の最初に追加される接頭辞の文字列。


クラス ParticleSystem.Particle

CreateParticle で返される、パーティクルオブジェクト。 [詳細]

すべてのメンバ一覧

Public メソッド

override string | ToString ()
このパーティクルの文字列表現を返します。

Public 変数

Vector2 Position
位置。
Vector2 Velocity
速度。
float | Age
年齢 (Age)。 ( Age >= LifeSpan でパーティクルは死亡します)。
float | LifeSpan
寿命。
float | LifeSpanRcp
寿命 (LifeSpan) の逆数。自動の初期化を使わない場合、この値に1.0f/LifeSpanをセットすることを確認してください。
float | Angle
回転角。
float | AngularVelocity
角速度。
float | ScaleStart
Age=0.0時のスケール。
float | ScaleDelta
ScaleDelta は ( scale_end - ScaleStart ) / LifeSpan で初期化する必要があります。
Vector4 ColorStart
Age=0.0時の色。
Vector4 ColorDelta
ColorDelta は ( color_end - ColorStart ) / LifeSpan で初期化する必要があります。

プロパティ

float | Scale [get]
スケール。
Vector4 | Color [get]
色。
bool | Dead [get]
パーティクルが生きているかチェックします。

説明

CreateParticle で返される、パーティクルオブジェクト。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ParticleSystem
  • ParticleShaderDefault
Public メソッド

クラス ParticleSystem.ParticleShaderDefault

デフォルトのシェーダー。テクスチャの色は変調されます。 [詳細]

ParticleSystem.ParticleShaderDefaultに対する継承グラフ
ParticleSystem.IParticleShader

すべてのメンバ一覧

Public メソッド

void | Dispose ()
Disposeの実装。
ShaderProgram GetShaderProgram ()
シェーダーの ShaderProgram オブジェクトを返します。
void | SetMVP (ref Matrix4 value)
Projection * View * Model 行列の設定。
void | SetColor (ref Vector4 value)
グローバルカラーの設定。

説明

デフォルトのシェーダー。テクスチャの色は変調されます。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ParticleSystem
  • SimulationParams
Public 変数

クラス ParticleSystem.SimulationParams

SimulationParams は、Update と Draw で必要とされる全てのパラメータを、再グループ化します。 [詳細]

すべてのメンバ一覧

Public 変数

float | Friction = 0.99f
全てのパーティクルに適用される摩擦。
Vector2 GravityDirection = -GameEngine2D.Base.Math._01
重力の方向 (単位ベクトル)。
float | Gravity = 0.8f
重力量。
Vector2 WindDirection
風の方向。
float | Wind
風量。
float | BrownianScale = 5.0f
各パーティクルに追加するブラウン運動の量です。 各パーティクルに対し、毎フレーム、異なったランダム方向を風に追加します。 ガス/塵のエフェクトを追加することができます。
float | Fade = 0.1f
Fade の値は、0,1の範囲の値です。この値は、パーティクルがフェイドイン/フェイドアウトする速さ(つまり死亡する時期)をコントロールします。 パーティクルの色のアルファ値は、対称フェイドカーブで乗算します。 Fade はフェイドスタートとフェイドエンドの長さです。 例えば、Fade が0.25であれば、粒子はその年齢の25％で完全に見えるようになります。

説明

SimulationParams は、Update と Draw で必要とされる全てのパラメータを、再グループ化します。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ParticleSystem
  • IParticleShader
Public メソッド

インタフェース ParticleSystem.IParticleShader

ParticleSystem のシェーダーインターフェース。 [詳細]

ParticleSystem.IParticleShaderに対する継承グラフ
ParticleSystem.ParticleShaderDefault

すべてのメンバ一覧

Public メソッド

void | SetMVP (ref Matrix4 value)
Projection * View * Model 行列の設定。
void | SetColor (ref Vector4 value)
グローバルカラーの設定。
ShaderProgram GetShaderProgram ()
シェーダーの ShaderProgram オブジェクトを返します。

説明

ParticleSystem のシェーダーインターフェース。


クラス Plane3D

Plane3D ノードは、シーングラフ内で、ある程度まで3Dの方向性を許可します。 それは、タッチ座標を扱う方法をいくぶんか複雑にします。なのでシーン階層に Plane3D を含んでいる場合、直接 Director.Instance.CurrentScene.Camera.GetTouchPos() を使う代わりに、Plane3D 空間(すべてサブノード)で点を得るのに Node.GetTouchPos() を使うことを確認してください。 [詳細]

Plane3Dに対する継承グラフ
Node

すべてのメンバ一覧

Public メソッド

Plane3D ()
コンストラクタ。デフォルトはz=0 平面(単位行列)。 詳細は ModelMatrix のコメントを参照してください。
Plane3D (Matrix4 modelmatrix)
コンストラクタ。
override void | PushTransform ()
ノードとその子を描画する前にこの関数が呼び出されます。
override void | FindParentPlane (ref Matrix4 mat)
注意: FindParentPlane は最初に見つかった Plane3D で停止します。 ツリーの枝で、複数の Plane3D ノードを持っていないという前提です。

Public 変数

Matrix4 | ModelMatrix = Matrix4.Identity
この平面のための"変換行列"です。 平面は基点と法線で定義されます。しかし我々は平面を座標系(スタックにプッシュできる行列)としても使用するため、平面を行列として格納します。

説明

Plane3D ノードは、シーングラフ内で、ある程度まで3Dの方向性を許可します。 それは、タッチ座標を扱う方法をいくぶんか複雑にします。なのでシーン階層に Plane3D を含んでいる場合、直接 Director.Instance.CurrentScene.Camera.GetTouchPos() を使う代わりに、Plane3D 空間(すべてサブノード)で点を得るのに Node.GetTouchPos() を使うことを確認してください。

コンストラクタとデストラクタ

Plane3D ( Matrix4 modelmatrix )

コンストラクタ。

引数:
modelmatrix 平面にセットする ModelMatrix の値。 詳細は ModelMatrix のコメントを参照してください。

変数

Matrix4 ModelMatrix = Matrix4.Identity

この平面のための"変換行列"です。 平面は基点と法線で定義されます。しかし我々は平面を座標系(スタックにプッシュできる行列)としても使用するため、平面を行列として格納します。

3D平面は、 ModelMatrix によって変換される z=0の '単位行列' 平面として定義されます。それは、ModelMatrix.ColumnZ が 平面の法線ベクトルであり、ModelMatrix.ColumnWは平面の任意の点として表されます。

ModelMatrix は右手座標系、直交座標系(チェックはありません)に設定されていることを前提にしています。

ModelMatrix.ColumnX、ModelMatrix.ColumnY、ModelMatrix.ColumnZは、単位長さの各々は、お互いにすべて垂直であることを意味します。 ModelMatrix.ColumnXとModelMatrix.ColumnYの外積はModelMatrix.ColumnZと同じ方向です。 ModelMatrix のデフォルト値は Matrix4.Identity (z=0 平面) です。 この行列は変換スタックにあるかのように使用されます。


クラス RawSpriteTileList

描画呼び出しや、ステートのセットアップの回数を減らすため、スプライトを一括して描画します。 SpriteListとは違い、Node オブジェクトのリストを保持する代わりに、より軽いRawSpriteTileのリストを保持します。 これは Node として利用可能な SpriteRenderer のラップです。 [詳細]

RawSpriteTileListに対する継承グラフ
Node

すべてのメンバ一覧

Public メソッド

RawSpriteTileList (TextureInfo texture_info)
コンストラクタ。 TextureInfo はコンストラクタで必ず指定しなければなりません。
override void | Draw ()
描画関数。スプライトリスト内で全てのスプライトを描画します。
Vector2 CalcSizeInPixels ()
タイルサイズとテクスチャのサイズに基づき、ピクセル単位で相当するサイズを返します。 例えば、bob.Quad.S = bob.CalcSizeInPixels()のように使います。

Public 変数

List< RawSpriteTile > | Sprites = new List< RawSpriteTile >()
描画可能な RawSpriteTile オブジェクトのリスト。
Vector4 | Color = Colors.White
Children リスト内の全てのスプライトで使用される色。
BlendMode | BlendMode = BlendMode.Normal
Children リスト内の全てのスプライトで使用されるブレンドモード。
TextureInfo TextureInfo
Children リスト内の全てのスプライトで使用される TextureInfoオブジェクト。
SpriteRenderer.ISpriteShader | Shader = (SpriteRenderer.ISpriteShader)Director.Instance.SpriteRenderer.DefaultShader
Children リスト内の全てのスプライトで使用されるシェーダー。

説明

描画呼び出しや、ステートのセットアップの回数を減らすため、スプライトを一括して描画します。 SpriteListとは違い、Node オブジェクトのリストを保持する代わりに、より軽いRawSpriteTileのリストを保持します。 これは Node として利用可能な SpriteRenderer のラップです。


クラス Repeat

アクションを回数指定で繰り返すアクション。 [詳細]

Repeatに対する継承グラフ
ActionBase

すべてのメンバ一覧

Public メソッド

Repeat (ActionBase inner_action, int times)
コンストラクタ。
override void | Run ()
このアクションをキックします。
override void | Stop ()
このアクションを停止します。
override void | Update (float dt)
Update 関数。

Public 変数

ActionBase InnerAction
繰り返すアクション。
int | Times = 0
繰り返す回数。

説明

アクションを回数指定で繰り返すアクション。

コンストラクタとデストラクタ

Repeat | ( | ActionBase | inner_action,
 |  | int | times
 | ) |  |

コンストラクタ。

引数:
inner_action | 繰り返すアクション。
times | 繰り返す回数。


クラス RepeatForever

他のアクションを永続的に繰り返すアクション。 [詳細]

RepeatForeverに対する継承グラフ
ActionBase

すべてのメンバ一覧

Public メソッド

override void | Run ()
アクションをキックします。
override void | Stop ()
アクションを停止します。
override void | Update (float dt)
Update 関数。

Public 変数

ActionBase InnerAction
繰り返しのアクション。

説明

他のアクションを永続的に繰り返すアクション。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • RotateBy
Public メソッド

クラス RotateBy

現在の回転値に徐々にオフセット値を加算していくアクション。 [詳細]

RotateByに対する継承グラフ
ActionTweenGenericVector2Rotation ActionTweenGeneric< T > ActionWithDuration ActionBase

すべてのメンバ一覧

Public メソッド

RotateBy (Vector2 target, float duration)
コンストラクタ。

説明

現在の回転値に徐々にオフセット値を加算していくアクション。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • RotateTo
Public メソッド

クラス RotateTo

指定した値へ徐々に回転値をセットしていくアクション。 [詳細]

RotateToに対する継承グラフ
ActionTweenGenericVector2Rotation ActionTweenGeneric< T > ActionWithDuration ActionBase

すべてのメンバ一覧

Public メソッド

RotateTo (Vector2 target, float duration)
コンストラクタ。

説明

指定した値へ徐々に回転値をセットしていくアクション。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ScaleBy
Public メソッド

クラス ScaleBy

現在のスケールに徐々に追加のスケールを追加していくアクション。 [詳細]

ScaleByに対する継承グラフ
ActionTweenGenericVector2Scale ActionTweenGeneric< T > ActionWithDuration ActionBase

すべてのメンバ一覧

Public メソッド

ScaleBy (Vector2 target, float duration)
コンストラクタ。

説明

現在のスケールに徐々に追加のスケールを追加していくアクション。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ScaleTo
Public メソッド

クラス ScaleTo

指定した値へスケールを徐々にセットしていくアクション。 [詳細]

ScaleToに対する継承グラフ
ActionTweenGenericVector2Scale ActionTweenGeneric< T > ActionWithDuration ActionBase

すべてのメンバ一覧

Public メソッド

ScaleTo (Vector2 target, float duration)
コンストラクタ。

説明

指定した値へスケールを徐々にセットしていくアクション。


クラス Scene

Scene クラスはシーングラフのルートノードタイプです。 シーンスタックを操作するため Director シングルトンを使い、現在のシーンは Director.Instance.CurrentScene でアクセスします。 2つのシーンが画面遷移のためブレンディングされるときを除き、アクティブになるシーンはひとつだけです。 [詳細]

Sceneに対する継承グラフ
Node TransitionScene TransitionFadeBase TransitionCrossFade TransitionDirectionalFade TransitionSolidFade

すべてのメンバ一覧

Public メソッド

Scene ()
コンストラクタ。
override void | OnEnter ()
シーンが Director によって開始された時、この関数が呼び出されます。
override void | OnExit ()
シーンの OnExit はデフォルトで Cleanup() 呼び出します。
virtual bool | IsTransitionScene ()
シーンが TransitionScene タイプである場合、trueを返します。

Public 変数

bool | NoClear = false
通常、シーンは内部的な描画関数内でスクリーンをクリアします。 開発者はこの NoClear を trueに設定することで、自動クリアを抑制することができます。 自動クリアを無効にした場合、いくつかの TransitionScene の効果が正常に動作しないことに注意してください。 ( いくつかの画面遷移は、2つの遷移するシーンを、ブレンドのためオフスクリーンで描画する必要があるためです。)
float | DrawGridStep = -1.0f
DebugFlags.DrawGrid が Director.Instance.DebugFlags に設定されているときに描画される、デバッググリッドのセルサイズ。 値が -1.0f（デフォルト）である場合、デバッググリッドセルのサイズが、 DrawGridAutoStepMaxCells での分割数以上を表示しないよう、自動的に調整されます。
float | DrawGridAutoStepMaxCells = 32
DrawGridStepが-1に設定されている場合、デバッググリッドのセルサイズは自動的に計算されます。 ズームアウトすると、DrawGridAutoStepMaxCellsの分割よりも多くならないように、2のべき乗でセルサイズが増加します。

プロパティ

double | SceneTime [get]
シーンの開始時から経過した時間の総計。秒単位。

説明

Scene クラスはシーングラフのルートノードタイプです。 シーンスタックを操作するため Director シングルトンを使い、現在のシーンは Director.Instance.CurrentScene でアクセスします。 2つのシーンが画面遷移のためブレンディングされるときを除き、アクティブになるシーンはひとつだけです。

また、シーンはメインカメラを保持しています。

変数

float DrawGridAutoStepMaxCells = 32

DrawGridStepが-1に設定されている場合、デバッググリッドのセルサイズは自動的に計算されます。 ズームアウトすると、DrawGridAutoStepMaxCellsの分割よりも多くならないように、2のべき乗でセルサイズが増加します。

警告：あまりにも多くこの値を増やすと、非常に多くの線が描画されることにつながり、 DrawHelpers のイミーディエイトモードで使用する頂点配列をオーバーフローしてしまう可能性があります。 自動的に計算されたステップサイズが 2 ^ 15より大きくなった場合、デバッググリッドの描画を停止します。


クラス Scheduler

Scheduler は、開発者が登録する update 関数に関連した Node を管理するシングルトンです。 スケジュールされた関数は毎フレーム呼び出されます。または、開発者は特別な間隔で呼び出すこともできます。 Scheduler の update ループは Director.Update() の内部で呼び出されます。 [詳細]

すべてのメンバ一覧

Public メソッド

void | Schedule (Node target, DSchedulerFunc func, float interval, bool paused, int priority=DefaultPriority)
スケジューラに Node 関数を登録します。
void | Unschedule (Node target, DSchedulerFunc func)
スケジューラから関数を削除します。
void | UnscheduleAll (Node target)
スケジューラから指定されたノードに関連する全ての関数を削除します。
void | UnscheduleAll ()
スケジューラから全ての関数を削除します。
void | ScheduleUpdateForTarget (Node target, int priority, bool paused)
ノードの Update 関数を毎フレーム呼び出すようにスケジュールします。
void | UnscheduleUpdateForTarget (Node target)
スケジューラから Node の Update 関数を削除します。
void | Dump ()
デバッグ情報を出力します。(将来変更される可能性があります)

プロパティ

static Scheduler | Instance [get]
スケジューラのシングルトン。

説明

Scheduler は、開発者が登録する update 関数に関連した Node を管理するシングルトンです。 スケジュールされた関数は毎フレーム呼び出されます。または、開発者は特別な間隔で呼び出すこともできます。 Scheduler の update ループは Director.Update() の内部で呼び出されます。

メソッド

void Schedule | ( | Node | target,
 |  | DSchedulerFunc | func,
 |  | float | interval,
 |  | bool | paused,
 |  | int | priority = DefaultPriority
 | ) |  |

スケジューラに Node 関数を登録します。

引数:
target | スケジュール関数を登録する対象ノード。
func | スケジュール関数。
interval | 関数が呼び出される期間 (秒単位)。0なら毎フレーム呼び出されます。
paused | スケジューラを一時停止します。
void ScheduleUpdateForTarget | ( | Node | target,
 |  | int | priority,
 |  | bool | paused
 | ) |  |

ノードの Update 関数を毎フレーム呼び出すようにスケジュールします。

引数:
target | 対象ノード。
priority | スケジューラ内の Update 関数の優先順位。
paused | 一時停止状態にします。
void Unschedule | ( | Node | target,
 |  | DSchedulerFunc | func
 | ) |  |

スケジューラから関数を削除します。

引数:
target | 削除する関数をもった対象ノード。
func | 削除する関数。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Sequence
Public メソッド

クラス Sequence

順番に、他の一連のアクションを実行するためのアクション。 [詳細]

Sequenceに対する継承グラフ
ActionBase

すべてのメンバ一覧

Public メソッド

Sequence ()
コンストラクタ。
void | Add (ActionBase action)
引数の action をアクションシーケンスに追加します。
override void | Run ()
アクションをキックします。
override void | Stop ()
アクションを停止します。
override void | Update (float dt)
Update 関数。

説明

順番に、他の一連のアクションを実行するためのアクション。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • SkewBy
Public メソッド

クラス SkewBy

現在のスキュー値に徐々にオフセット値を加算していくアクション。 [詳細]

SkewByに対する継承グラフ
ActionTweenGenericVector2 ActionTweenGeneric< T > ActionWithDuration ActionBase

すべてのメンバ一覧

Public メソッド

SkewBy (Vector2 target, float duration)
コンストラクタ。

説明

現在のスキュー値に徐々にオフセット値を加算していくアクション。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • SkewTo
Public メソッド

クラス SkewTo

指定した値へ徐々にスキューをセットしていくアクション。 [詳細]

SkewToに対する継承グラフ
ActionTweenGenericVector2 ActionTweenGeneric< T > ActionWithDuration ActionBase

すべてのメンバ一覧

Public メソッド

SkewTo (Vector2 target, float duration)
コンストラクタ。

説明

指定した値へ徐々にスキューをセットしていくアクション。


クラス SpriteBase

単一のスプライトノードの規定クラス。抽象クラスです。 [詳細]

SpriteBaseに対する継承グラフ
Node SpriteTile SpriteUV

すべてのメンバ一覧

Public メソッド

abstract Vector2 | CalcSizeInPixels ()
ピクセル単位でこのスプライトのサイズを返します。
SpriteBase ()
コンストラクタ。
SpriteBase (TextureInfo texture_info)
コンストラクタ。
override void | Draw ()
描画関数 ( 処理が重い、別個の描画 )。
override bool | GetlContentLocalBounds (ref Bounds2 bounds)
ローカルの境界は、このスプライトのクワッドを含む最小の Bounds2 です。回転がない場合、クワッドそれ自体 ( スプライトの矩形) と同じです。
Bounds2 GetlContentLocalBounds ()
ローカルの境界は、このスプライトのクワッドを含む最小の Bounds2 です。回転がない場合、クワッドそれ自体 ( スプライトの矩形) と同じです。
void | MakeFullScreen ()
スクリーン全体を覆うようにスプライトのクワッドを延ばします。 CurrentScene.Camera を使用しているため、シーンを set/started している必要があります。
void | CenterSprite ()
スプライトの中心が Node の中心になるように、スプライトの幾何情報を変更します。
void | CenterSprite (Vector2 new_center)
スプライトの幾何情報の中心を変更します。

Public 変数

TRS | Quad = TRS.Quad0_1
ノードのローカル空間内のスプライト幾何情報。TRS は矩形の向きを定義します。
bool | FlipU = false
trueなら、スプライトのUVが水平方向に反転します。
bool | FlipV = false
trueなら、スプライトのUVが垂直方向に反転します。
Vector4 | Color = Colors.White
スプライトの色。
BlendMode | BlendMode = BlendMode.Normal
ブレンドモード。
TextureInfo TextureInfo
このプロパティは、スプライトが別個 ( つまり SpriteList でない) に描画されるときのみ、使用されます。 スプライトが SpriteList で使用されている場合、後の SpriteList の TextureInfo が使用されます。
SpriteRenderer.ISpriteShader | Shader = (SpriteRenderer.ISpriteShader)Director.Instance.SpriteRenderer.DefaultShader
シェーダー。

説明

単一のスプライトノードの規定クラス。抽象クラスです。


クラス SpriteList

描画呼び出しやステートのセットアップの呼び出し回数を削減するため、スプライトを一括して描画します。 SpriteUV や SpriteTile オブジェクトを AddChild() で SpriteList の子として追加するだけで、一括描画を可能にします。 ただし、スプライトの TextureInfo, BlendMode, Color のプロパティは無視されます。それらのプロパティは親の SpriteList に依存します。 [詳細]

SpriteListに対する継承グラフ
Node

すべてのメンバ一覧

Public メソッド

SpriteList (TextureInfo texture_info)
コンストラクタ。 TextureInfo はコンストラクタで必ず指定しなければなりません。
override void | DrawHierarchy ()
この関数は、 Director によってのみ呼び出されます。しかし、PushTransform, Draw, PopTransform は上書きすることができます。

Public 変数

bool | EnableLocalTransform = true
EnableLocalTransform フラグがtrueの場合、子のスプライトのローカル変換行列が使われます。 その場合、頂点は CPU 上で変換します。
Vector4 | Color = Colors.White
Children リスト内の全てのスプライトで使用される色。
BlendMode | BlendMode = BlendMode.Normal
Children リスト内の全てのスプライトで使用されるブレンドモード。
TextureInfo TextureInfo
Children リスト内の全てのスプライトで使用される TextureInfo オブジェクト。
SpriteRenderer.ISpriteShader | Shader = (SpriteRenderer.ISpriteShader)Director.Instance.SpriteRenderer.DefaultShader
Children リスト内の全てのスプライトで使用されるシェーダー。

説明

描画呼び出しやステートのセットアップの呼び出し回数を削減するため、スプライトを一括して描画します。 SpriteUV や SpriteTile オブジェクトを AddChild() で SpriteList の子として追加するだけで、一括描画を可能にします。 ただし、スプライトの TextureInfo, BlendMode, Color のプロパティは無視されます。それらのプロパティは親の SpriteList に依存します。

変数

bool EnableLocalTransform = true

EnableLocalTransform フラグがtrueの場合、子のスプライトのローカル変換行列が使われます。 その場合、頂点は CPU 上で変換します。

CPU処理の節約のため、ローカル変換行列を無視するために、この挙動を OFF にすることができます。 その場合、スプライトの位置はクワッドに依存します。

EnableLocalTransform=false の場合、Position, Scale, Skew, Pivot は無視されます。


クラス SpriteTile

SpriteTile は、TextureInfo 内のタイルインデックス (1D または 2D) を指定する形式のスプライトです。 別個で描画すると、処理が重くなるので注意してください。可能な限り、SpriteList の子として利用してください。 [詳細]

SpriteTileに対する継承グラフ
SpriteBase Node

すべてのメンバ一覧

Public メソッド

SpriteTile ()
コンストラクタ。 TileIndex2D はデフォルトで (0,0)にセットされます。
SpriteTile (TextureInfo texture_info)
コンストラクタ。 TileIndex2D はデフォルトで (0,0)にセットされます。
SpriteTile (TextureInfo texture_info, Vector2i index)
コンストラクタ。 TileIndex2D はデフォルトで (0,0)にセットされます。
SpriteTile (TextureInfo texture_info, int index)
コンストラクタ。
override Vector2 | CalcSizeInPixels ()
UVとテクスチャのサイズに基づき、ピクセル単位で相当するサイズを返します。 例えば、bob.Quad.S = bob.CalcSizeInPixels()のように使います。

Public 変数

Vector2i | TileIndex2D = new Vector2i(0,0)
TileIndex2D はこのスプライトに使われる UV を定義します。 2次元でタイルのインデックスを指定します。

プロパティ

int | TileIndex1D [get, set]
TileIndex2D の代わりに、アニメーションの用途などで1次元のインデックスを使うこともできます。 その場合には、set/get の計算がTextureInfoに依存してしまうので、TextureInfoが正しく設定されている必要があります。

説明

SpriteTile は、TextureInfo 内のタイルインデックス (1D または 2D) を指定する形式のスプライトです。 別個で描画すると、処理が重くなるので注意してください。可能な限り、SpriteList の子として利用してください。

コンストラクタとデストラクタ

SpriteTile | ( | TextureInfo | texture_info,
 |  | Vector2i | index
 | ) |  |

コンストラクタ。 TileIndex2D はデフォルトで (0,0)にセットされます。

引数:
texture_info | タイルのテクスチャオブジェクト。
index | 2次元のタイルインデックス。(0,0) は左下のタイルです。
SpriteTile | ( | TextureInfo | texture_info,
 |  | int | index
 | ) |  |

コンストラクタ。

引数:
texture_info | タイルのテクスチャオブジェクト。
index | 1次元のタイルインデックス。インデックスは左下のタイルから始まります(2Dでは (0,0)にあたる)。


クラス SpriteUV

SpriteUVは、手動で UV を設定するスプライトです。 UV は TRS オブジェクトとして格納されます。 SpriteUVを別個で描画すると、処理が重くなるので注意してください。可能な限り、SpriteList の子として利用してください。 [詳細]

SpriteUVに対する継承グラフ
SpriteBase Node

すべてのメンバ一覧

Public メソッド

SpriteUV ()
コンストラクタ。
SpriteUV (TextureInfo texture_info)
コンストラクタ。
override Vector2 | CalcSizeInPixels ()
UVとテクスチャの寸法に基づいて、ピクセル単位で対応するサイズを返します。 例えば、bob.Quad.S = bob.CalcSizeInPixels().

Public 変数

TRS | UV = TRS.Quad0_1
TRS として UV を指定します。UV領域内で矩形の向きを定義できます。

説明

SpriteUVは、手動で UV を設定するスプライトです。 UV は TRS オブジェクトとして格納されます。 SpriteUVを別個で描画すると、処理が重くなるので注意してください。可能な限り、SpriteList の子として利用してください。

メソッド

override Vector2 CalcSizeInPixels ( ) [virtual]

UVとテクスチャの寸法に基づいて、ピクセル単位で対応するサイズを返します。 例えば、bob.Quad.S = bob.CalcSizeInPixels().

といった処理が行えます。 UV が Quad0_1 ( 0,1 単位クワッド ) の場合、ピクセル単位のテクスチャサイズを返します。

SpriteBaseを実装しています。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • TintBy
Public メソッド

クラス TintBy

徐々に色を加算していくアクション。 [詳細]

TintByに対する継承グラフ
ActionTweenGenericVector4 ActionTweenGeneric< T > ActionWithDuration ActionBase

すべてのメンバ一覧

Public メソッド

TintBy (Vector4 target, float duration)
コンストラクタ。

説明

徐々に色を加算していくアクション。


  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • TintTo
Public メソッド

クラス TintTo

指定した値に徐々に色をセットしていくアクション。 [詳細]

TintToに対する継承グラフ
ActionTweenGenericVector4 ActionTweenGeneric< T > ActionWithDuration ActionBase

すべてのメンバ一覧

Public メソッド

TintTo (Vector4 target, float duration)
コンストラクタ。

説明

指定した値に徐々に色をセットしていくアクション。


クラス TransitionCrossFade

TransitionCrossFade は 2つのシーンをクロスフェードさせるために、ブレンドを使います。 フェイドのコントロールに DTween を使うことができます。 [詳細]

TransitionCrossFadeに対する継承グラフ
TransitionFadeBase TransitionScene Scene Node

すべてのメンバ一覧

Public メソッド

TransitionCrossFade (Scene next_scene)
コンストラクタ。
override void | Draw ()
描画関数。

Public 変数

DTween | Tween = ( x ) => GameEngine2D.Base.Math.PowEaseOut( x, 4.0f )
DTween.

説明

TransitionCrossFade は 2つのシーンをクロスフェードさせるために、ブレンドを使います。 フェイドのコントロールに DTween を使うことができます。


クラス TransitionDirectionalFade

TransitionDirectionalFade は2つのシーンをクロスフェードさせるのに、変換ブレンドマスクを使います。 クロスフェードのラインは、開発者が指定した方向に沿って動作し、古いシーンが新しいシーンに置き換わります。 [詳細]

TransitionDirectionalFadeに対する継承グラフ
TransitionFadeBase TransitionScene Scene Node

すべてのメンバ一覧

Public メソッド

TransitionDirectionalFade (Scene next_scene)
コンストラクタ。
override void | Draw ()
描画関数。

Static Public メソッド

static new void | Terminate ()
静的リソースの破棄。

Public 変数

float | Width = 0.75f
遷移ゾーンの幅(正規化された値。おおむね 0,1の範囲。)
Vector2 Direction = GameEngine2D.Base.Math._10
移動方向。
DTween | Tween = ( x ) => GameEngine2D.Base.Math.PowEaseOut( x, 4.0f )
DTween.

説明

TransitionDirectionalFade は2つのシーンをクロスフェードさせるのに、変換ブレンドマスクを使います。 クロスフェードのラインは、開発者が指定した方向に沿って動作し、古いシーンが新しいシーンに置き換わります。


クラス TransitionFadeBase

フェイドの画面遷移を行う基底クラス。 両方のシーンをオフスクリーンで描画する必要があります。 [詳細]

TransitionFadeBaseに対する継承グラフ
TransitionScene Scene Node TransitionCrossFade TransitionDirectionalFade TransitionSolidFade

すべてのメンバ一覧

Public メソッド

TransitionFadeBase (Scene next_scene)
コンストラクタ。
override void | OnEnter ()
シーンが Director によって開始された時、この関数が呼び出されます。
override void | Draw ()
描画関数。

Static Public メソッド

static void | Terminate ()
静的なリソースを破棄します。

説明

フェイドの画面遷移を行う基底クラス。 両方のシーンをオフスクリーンで描画する必要があります。


クラス TransitionScene

画面遷移ノードのための基底クラス。これらのノードは2つのシーンを視覚的に遷移させます。 遷移中は、両方のシーンを Updateし、描画します。 [詳細]

TransitionSceneに対する継承グラフ
Scene Node TransitionFadeBase TransitionCrossFade TransitionDirectionalFade TransitionSolidFade

すべてのメンバ一覧

Public メソッド

override bool | IsTransitionScene ()
TransitionSceneから派生する全てのシーンで、trueを返します。
TransitionScene (Scene next_scene)
コンストラクタ。
override void | OnEnter ()
シーンが Director によって開始された時、この関数が呼び出されます。

Public 変数

Scene PreviousScene
遷移前のシーン。
Scene NextScene
遷移先のシーン。
float | Duration = 0.0f
秒単位での遷移間隔。
bool | KeepRendering = true
trueの場合、遷移中、両方のシーンを更新します (処理は重くなります)。

プロパティ

float | FadeCompletion [get]

説明

画面遷移ノードのための基底クラス。これらのノードは2つのシーンを視覚的に遷移させます。 遷移中は、両方のシーンを Updateし、描画します。

プロパティ

float FadeCompletion [get]

フェイドの完了度合い。[0,1]の範囲。


クラス TransitionSolidFade

TransitionSolidFade は、次のシーンをフェイドする前に、現在のシーンを黒にフェイドします。 [詳細]

TransitionSolidFadeに対する継承グラフ
TransitionFadeBase TransitionScene Scene Node

すべてのメンバ一覧

Public メソッド

TransitionSolidFade (Scene next_scene)
コンストラクタ。
override void | Draw ()
描画関数。

Public 変数

DTween | Tween = ( x ) => GameEngine2D.Base.Math.PowEaseInOut( x, 4.0f )
DTween.

説明

TransitionSolidFade は、次のシーンをフェイドする前に、現在のシーンを黒にフェイドします。


構造体 RawSpriteTile

RawSpriteTileList で使用される構造体。 [詳細]

すべてのメンバ一覧

Public メソッド

RawSpriteTile (TRS positioning, Vector2i tile_index, bool flipu=false, bool flipv=false)
コンストラクタ。

Public 変数

TRS Quad
スプライトの幾何情報 (位置、回転、スケールで矩形を定義します)。
Vector2i TileIndex2D
タイルインデックス。
bool | FlipU
trueの場合、スプライトのUVは水平方向に反転します。
bool | FlipV
trueの場合、スプライトのUVは垂直方向に反転します。

説明

RawSpriteTileList で使用される構造体。


パッケージ Sce.PlayStation.HighLevel.Model

構成

class | BasicModel
モデルを表すクラス [詳細]
class | BasicBone
モデルのボーンを表すクラス [詳細]
class | BasicPart
モデルのパートを表すクラス [詳細]
class | BasicMesh
モデルのメッシュを表すクラス [詳細]
class | BasicArrays
モデルの頂点配列を表すクラス [詳細]
class | BasicMaterial
モデルのマテリアルを表すクラス [詳細]
class | BasicLayer
モデルのレイヤーを表すクラス [詳細]
class | BasicTexture
モデルのテクスチャを表すクラス [詳細]
class | BasicMotion
モデルのモーションを表すクラス [詳細]
class | BasicFCurve
モデルの関数カーブを表すクラス [詳細]
class | BasicProgram
基本プログラムを表すクラス [詳細]
class | BasicParameters
基本プログラムのパラメータを表すクラス [詳細]
class | BasicProgramContainer
プログラムコンテナを表すクラス [詳細]
class | BasicTextureContainer
テクスチャコンテナを表すクラス [詳細]

列挙型

enum | BasicMotionRepeatMode { Hold, Cycle }

モーションの繰り返しモード

[詳細]
enum BasicFCurveInterpType {
Constant, Linear, Hermite, Cubic,
Slerp
}

アニメーションの補間タイプ

[詳細]
enum | BasicFCurveTargetType { None, Bone, Material, Texture }

アニメーションのターゲットタイプ

[詳細]
enum BasicFCurveChannelType {
None, Visibility, Translation, Rotation,
Scaling, Diffuse, Specular, Emission,
Ambient, Opacity, Shininess, UVTranslation,
UVScaling
}

アニメーションのチャンネルタイプ

[詳細]
enum | BasicEnableMode { Lighting = 0x00000001, Fog = 0x00000002 }

有効または無効にするシェーダー機能

[詳細]

列挙型

enum BasicEnableMode

有効または無効にするシェーダー機能

列挙型の値:
Lighting

ライティング

Fog

フォグ

enum BasicFCurveChannelType

アニメーションのチャンネルタイプ

列挙型の値:
None

なし

Visibility

ボーンのビジビリティ

Translation

ボーンの移動量

Rotation

ボーンの回転量

Scaling

ボーンのスケーリング

Diffuse

マテリアルのディフューズカラー

Specular

マテリアルのスペキュラーカラー

Emission

マテリアルのエミッションカラー

Ambient

マテリアルのアンビエントカラー

Opacity

マテリアルの不透明度

Shininess

マテリアルの輝度

UVTranslation

テクスチャ座標の移動量

UVScaling

テクスチャ座標のスケーリング

enum BasicFCurveInterpType

アニメーションの補間タイプ

列挙型の値:
Constant

定数補間

Linear

線形補間

Hermite

エルミート補間

Cubic

キュービック補間

Slerp

球面線形補間

enum BasicFCurveTargetType

アニメーションのターゲットタイプ

列挙型の値:
None

なし

Bone

ボーン

Material

マテリアル

Texture

テクスチャ

enum BasicMotionRepeatMode

モーションの繰り返しモード

列挙型の値:
Hold

単発再生

Cycle

繰り返し再生


クラス BasicArrays

モデルの頂点配列を表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicArrays ()
頂点配列を作成する

Public 変数

VertexBuffer VertexBuffer
頂点バッファ

説明

モデルの頂点配列を表すクラス


クラス BasicBone

モデルのボーンを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicBone ()
ボーンを作成する

Public 変数

string | Name
ボーンの名前
Vector4 BoundingSphere
バウンディングスフィア
int | ParentBone
親ボーンの番号
int | Visibility
ビジビリティ
int[] | DrawParts
描画パートの番号
int[] | BlendBones
スキニングの影響ボーンの番号
Matrix4[] BlendOffsets
スキニングのオフセット行列
Vector3 Pivot
ピボット位置
Vector3 Translation
移動量
Quaternion Rotation
回転量
Vector3 Scaling
スケーリング
Matrix4 WorldMatrix
ワールド行列

説明

モデルのボーンを表すクラス


クラス BasicFCurve

モデルの関数カーブを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicFCurve ()
関数カーブを作成する

Public 変数

int | DimCount
次元数
int | KeyCount
キー数
BasicFCurveInterpType InterpType
アニメーションの補間タイプ
BasicFCurveTargetType TargetType
アニメーションのターゲットタイプ
BasicFCurveChannelType ChannelType
アニメーションのチャンネルタイプ
int | ChannelOption
アニメーションのチャンネルオプション
int | TargetIndex
アニメーションのターゲット番号
float[] | KeyFrames
キーフレームの配列

説明

モデルの関数カーブを表すクラス


クラス BasicLayer

モデルのレイヤーを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicLayer ()
レイヤーを作成する

Public 変数

int Texture
テクスチャの番号

説明

モデルのレイヤーを表すクラス


クラス BasicMaterial

モデルのマテリアルを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicMaterial ()
マテリアルを作成する

Public 変数

string | Name
マテリアルの名前
int | Program
プログラムの番号
string | FileName
プログラムのファイル名
Vector3 Diffuse
ディフューズカラー
Vector3 Specular
スペキュラーカラー
Vector3 Ambient
アンビエントカラー
Vector3 Emission
エミッションカラー
float | Opacity
不透明度
float | Shininess
輝度
BasicLayer[] Layers
マテリアルに含まれるレイヤーの配列

説明

モデルのマテリアルを表すクラス


クラス BasicMesh

モデルのメッシュを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicMesh ()
メッシュを作成する

Public 変数

int | Material
マテリアルの番号
int | Arrays
頂点配列の番号
int[] | BlendIndices
スキニングの行列番号
Primitive[] Primitives
プリミティブの配列

説明

モデルのメッシュを表すクラス


クラス BasicModel

モデルを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicModel (string fileName, int index=0)
モデルを作成する(ファイルから)
BasicModel (byte[] fileImage, int index=0)
モデルを作成する(ファイルイメージから)
void | Dispose ()
モデルのアンマネージドリソースを解放する
void | BindPrograms (BasicProgramContainer container)
モデルにプログラムを関連づける
void | BindTextures (BasicTextureContainer container)
モデルにテクスチャを関連づける
void | SetWorldMatrix (ref Matrix4 world)
ワールド行列を設定する
void | SetCurrentMotion (int index, float delay=0.0f)
カレントモーションを設定する
void | Animate (float step)
モデルのアニメーションを計算する
void | Update ()
モデルの行列を更新する
void | Draw (GraphicsContext graphics)
モデルを描画する
void | Draw (GraphicsContext graphics, BasicProgram program)
モデルを描画する (指定されたプログラムで)

Public 変数

string | Name
モデルの名前
Vector4 BoundingSphere
バウンディングスフィア
Matrix4 WorldMatrix
ワールド行列
int | CurrentMotion
カレントモーション番号
float | TransitionDelay
モーション遷移遅延時間 (単位＝秒)
BasicBone[] Bones
モデルに含まれるボーンの配列
BasicPart[] Parts
モデルに含まれるパートの配列
BasicMaterial[] Materials
モデルに含まれるマテリアルの配列
BasicTexture[] Textures
モデルに含まれるテクスチャの配列
BasicMotion[] Motions
モデルに含まれるモーションの配列
BasicProgram[] Programs
モデルに含まれるプログラムの配列

説明

モデルを表すクラス

コンストラクタとデストラクタ

BasicModel | ( | string | fileName,
 |  | int | index = 0
 | ) |  |

モデルを作成する(ファイルから)

引数:
fileName | ファイル名
index | ファイル内のモデル番号
BasicModel | ( | byte[] | fileImage,
 |  | int | index = 0
 | ) |  |

モデルを作成する(ファイルイメージから)

引数:
fileImage | ファイルイメージ
index | ファイル内のモデル番号

メソッド

void Animate ( float step )

モデルのアニメーションを計算する

引数:
step ステップ時間 (単位＝秒)
void BindPrograms ( BasicProgramContainer container )

モデルにプログラムを関連づける

引数:
container プログラムコンテナ
void BindTextures ( BasicTextureContainer container )

モデルにテクスチャを関連づける

引数:
container テクスチャコンテナ
void Draw ( GraphicsContext graphics )

モデルを描画する

引数:
graphics グラフィックスコンテキスト
void Draw | ( | GraphicsContext | graphics,
 |  | BasicProgram | program
 | ) |  |

モデルを描画する (指定されたプログラムで)

引数:
graphics | グラフィックスコンテキスト
program | 指定されたプログラム
void SetCurrentMotion | ( | int | index,
 |  | float | delay = 0.0f
 | ) |  |

カレントモーションを設定する

引数:
index | モーション番号
delay | 遅延時間 (単位＝秒)
void SetWorldMatrix ( ref Matrix4 world )

ワールド行列を設定する

引数:
world ワールド行列


クラス BasicMotion

モデルのモーションを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicMotion ()
モーションを作成する

Public 変数

string | Name
モーションの名前
float | FrameStart
開始フレーム
float | FrameEnd
終了フレーム
float | FrameRate
フレームレート
BasicMotionRepeatMode FrameRepeat
繰り返しモード
float | Frame
現在のフレーム
float | Weight
現在のブレンド係数
BasicFCurve[] FCurves
モーションに含まれる関数カーブの配列

説明

モデルのモーションを表すクラス


  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicParameters
Public メソッド

クラス BasicParameters

基本プログラムのパラメータを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicParameters ()
パラメータを作成する
void | Enable (BasicEnableMode mode, bool status)
指定されたシェーダー機能を有効または無効にする
bool | IsEnabled (BasicEnableMode mode)
指定されたシェーダー機能が有効かどうかを取得する
void | SetProjectionMatrix (ref Matrix4 projection)
プロジェクション行列を設定する
void | SetViewMatrix (ref Matrix4 view)
ビュー行列を設定する
void | SetWorldCount (int count)
ワールド行列の数を設定する
void | SetWorldMatrix (int index, ref Matrix4 world)
ワールド行列を設定する
void | SetLightCount (int count)
ライトの数を設定する
void | SetLightDirection (int index, ref Vector3 direction)
ライトの方向ベクトルを設定する
void | SetLightDiffuse (int index, ref Vector3 diffuse)
ライトのディフューズカラーを設定する
void | SetLightSpecular (int index, ref Vector3 specular)
ライトのスペキュラカラーを設定する
void | SetLightAmbient (ref Vector3 ambient)
ライトのアンビエントカラーを設定する
void | SetFogRange (float start, float end)
フォグの範囲を設定する
void | SetFogColor (ref Vector3 color)
フォグのカラーを設定する
void | SetMaterialDiffuse (ref Vector3 diffuse)
マテリアルのディフューズカラーを設定する
void | SetMaterialSpecular (ref Vector3 specular)
マテリアルのスペキュラーカラーを設定する
void | SetMaterialAmbient (ref Vector3 ambient)
マテリアルのアンビエントカラーを設定する
void | SetMaterialEmission (ref Vector3 emission)
マテリアルのエミッションカラーを設定する
void | SetMaterialOpacity (float opacity)
マテリアルの不透明度を設定する
void | SetMaterialShininess (float shininess)
マテリアルの輝度を設定する
void | SetPositionOffset (float transX, float transY, float transZ, float scale)
頂点ポジション座標のオフセットを設定する
void | SetTexCoordOffset (int index, float transU, float transV, float scaleU, float scaleV)
頂点テクスチャ座標のオフセットを設定する
void | SetVertexWeightCount (int count)
頂点ウェイトの数を設定する

説明

基本プログラムのパラメータを表すクラス

メソッド

void Enable | ( | BasicEnableMode | mode,
 |  | bool | status
 | ) |  |

指定されたシェーダー機能を有効または無効にする

引数:
mode | 有効または無効にするシェーダー機能
status | 有効ならばtrue
bool IsEnabled ( BasicEnableMode mode )

指定されたシェーダー機能が有効かどうかを取得する

引数:
mode 有効または無効にするシェーダー機能
void SetFogColor ( ref Vector3 color )

フォグのカラーを設定する

引数:
color カラー
void SetFogRange | ( | float | start,
 |  | float | end
 | ) |  |

フォグの範囲を設定する

引数:
start | 開始距離
end | 終了距離
void SetLightAmbient ( ref Vector3 ambient )

ライトのアンビエントカラーを設定する

引数:
ambient アンビエントカラー
void SetLightCount ( int count )

ライトの数を設定する

引数:
count ライトの数 (0～3)
void SetLightDiffuse | ( | int | index,
 |  | ref Vector3 | diffuse
 | ) |  |

ライトのディフューズカラーを設定する

引数:
index | ライトの番号 (0～2)
diffuse | ディフューズカラー
void SetLightDirection | ( | int | index,
 |  | ref Vector3 | direction
 | ) |  |

ライトの方向ベクトルを設定する

引数:
index | ライトの番号 (0～2)
direction | 方向ベクトル
void SetLightSpecular | ( | int | index,
 |  | ref Vector3 | specular
 | ) |  |

ライトのスペキュラカラーを設定する

引数:
index | ライトの番号 (0～2)
specular | スペキュラカラー
void SetMaterialAmbient ( ref Vector3 ambient )

マテリアルのアンビエントカラーを設定する

引数:
ambient アンビエントカラー
void SetMaterialDiffuse ( ref Vector3 diffuse )

マテリアルのディフューズカラーを設定する

引数:
diffuse ディフューズカラー
void SetMaterialEmission ( ref Vector3 emission )

マテリアルのエミッションカラーを設定する

引数:
emission エミッションカラー
void SetMaterialOpacity ( float opacity )

マテリアルの不透明度を設定する

引数:
opacity 不透明度
void SetMaterialShininess ( float shininess )

マテリアルの輝度を設定する

引数:
shininess 輝度
void SetMaterialSpecular ( ref Vector3 specular )

マテリアルのスペキュラーカラーを設定する

引数:
specular スペキュラーカラー
void SetPositionOffset | ( | float | transX,
 |  | float | transY,
 |  | float | transZ,
 |  | float | scale
 | ) |  |

頂点ポジション座標のオフセットを設定する

引数:
transX | X 移動量
transY | Y 移動量
transZ | Z 移動量
scale | スケーリング
void SetProjectionMatrix ( ref Matrix4 projection )

プロジェクション行列を設定する

引数:
projection プロジェクション行列
void SetTexCoordOffset | ( | int | index,
 |  | float | transU,
 |  | float | transV,
 |  | float | scaleU,
 |  | float | scaleV
 | ) |  |

頂点テクスチャ座標のオフセットを設定する

引数:
index | テクスチャ座標の番号 (つねに 0)
transU | U 移動量
transV | V 移動量
scaleU | U スケーリング
scaleV | V スケーリング
void SetVertexWeightCount ( int count )

頂点ウェイトの数を設定する

引数:
count 頂点ウェイトの数 (0～4)
void SetViewMatrix ( ref Matrix4 view )

ビュー行列を設定する

引数:
view ビュー行列
void SetWorldCount ( int count )

ワールド行列の数を設定する

引数:
count ワールド行列の数 (1～16)
void SetWorldMatrix | ( | int | index,
 |  | ref Matrix4 | world
 | ) |  |

ワールド行列を設定する

引数:
index | ワールド行列の番号 (0～15)
world | ワールド行列


クラス BasicPart

モデルのパートを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicPart ()
パートを作成する

Public 変数

string Name
パートの名前
BasicMesh[] Meshes
パートに含まれるメッシュの配列
BasicArrays[] Arrays
パートに含まれる頂点配列の配列

説明

モデルのパートを表すクラス


クラス BasicProgram

基本プログラムを表すクラス [詳細]

BasicProgramに対する継承グラフ
ShaderProgram

すべてのメンバ一覧

Public メソッド

BasicProgram (BasicParameters parameters=null)
プログラムを作成する
BasicProgram (string vpFileName, string fpFileName=null, BasicParameters parameters=null)
プログラムを作成する (ファイルから)
override Object | ShallowClone ()
プログラムを複製する
new void | Dispose ()
プログラムのアンマネージメントリソースを解放する

Protected メソッド

BasicProgram (BasicProgram program)
プログラムを複製する
override void | UpdateShader ()
シェーダーの状態を更新する

プロパティ

BasicParameters | Parameters [get, set]
パラメータ

説明

基本プログラムを表すクラス

コンストラクタとデストラクタ

BasicProgram ( BasicParameters parameters = null )

プログラムを作成する

引数:
parameters パラメータ (nullならば新規作成)
BasicProgram | ( | string | vpFileName,
 |  | string | fpFileName = null,
 |  | BasicParameters | parameters = null
 | ) |  |

プログラムを作成する (ファイルから)

引数:
vpFileName | 頂点シェーダーのファイル名
fpFileName | フラグメントシェーダーのファイル名（nullならばvpFileNameを使用）
parameters | パラメータ (nullならば新規作成)

指定されたファイルからシェーダープログラムを作成します。利用可能なファイルフォーマットは CGX です。なお、指定するシェーダーは、HighLevel.Modelのソースコードに含まれる既定のシェーダーと互換性をもち、同じユニフォーム変数やアトリビュート変数が宣言されている必要があります。

BasicProgram ( BasicProgram program ) [protected]

プログラムを複製する

引数:
program プログラム

プログラムを複製します。複製されたプログラムはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

メソッド

override Object ShallowClone ( ) [virtual]

プログラムを複製する

戻り値:
プログラムの複製

プログラムを複製します。複製されたプログラムはアンマネージドリソースを共有します。すべての複製に対して Dispose() が呼び出されたとき、共有されたアンマネージドリソースが解放されます。

ShaderProgramを再定義しています。

override void UpdateShader ( ) [protected, virtual]

シェーダーの状態を更新する

プリミティブ描画前にグラフィックスコンテキストから呼び出される仮想関数です。この関数はクラス内にキャッシュされた状態をシェーダーに反映する場合に使用します。

ShaderProgramを再定義しています。


クラス BasicProgramContainer

プログラムコンテナを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicProgramContainer (BasicParameters parameters=null)
プログラムコンテナを作成する
void | Dispose ()
プログラムコンテナのアンマネージドリソースを解放する
void | Add (string key, BasicProgram program)
プログラムを登録する
BasicProgram | Find (string key)
プログラムを検索する

Public 変数

BasicParameters Parameters
共有パラメータ

説明

プログラムコンテナを表すクラス

コンストラクタとデストラクタ

BasicProgramContainer ( BasicParameters parameters = null )

プログラムコンテナを作成する

引数:
parameters 共有パラメータ (nullならば共有をおこなわない)

メソッド

void Add | ( | string | key,
 |  | BasicProgram | program
 | ) |  |

プログラムを登録する

引数:
key | 検索キー
program | プログラム
BasicProgram Find ( string key )

プログラムを検索する

引数:
key 検索キー
戻り値:
プログラム (nullならば検索失敗)


クラス BasicTexture

モデルのテクスチャを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicTexture ()
テクスチャを作成する

Public 変数

string | Name
テクスチャの名前
Texture Texture
使用するテクスチャ
string | FileName
使用するテクスチャのファイル名
Vector2 UVTranslation
UV 座標の移動量
Vector2 UVScaling
UV 座標のスケーリング

説明

モデルのテクスチャを表すクラス


  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicTextureContainer
Public メソッド

クラス BasicTextureContainer

テクスチャコンテナを表すクラス [詳細]

すべてのメンバ一覧

Public メソッド

BasicTextureContainer ()
テクスチャコンテナを作成する
void | Dispose ()
テクスチャコンテナのアンマネージドリソースを解放する
void | Add (string key, Texture texture)
テクスチャを登録する
Texture | Find (string key)
テクスチャを検索する

説明

テクスチャコンテナを表すクラス

メソッド

void Add | ( | string | key,
 |  | Texture | texture
 | ) |  |

テクスチャを登録する

引数:
key | 検索キー
texture | テクスチャ
Texture Find ( string key )

テクスチャを検索する

引数:
key 検索キー
戻り値:
テクスチャ (nullならば検索失敗)


パッケージ Sce.PlayStation.HighLevel.Physics2D

構成

class | PhysicsBody
多くのプロパティを利用して剛体を定義する [詳細]
struct | PhysicsSolverPair
衝突した剛体ペアの衝突情報を保持している [詳細]
class | PhysicsScene
２Ｄ物理シミュレーションのシーン [詳細]
class | PhysicsShape
全ての形状は凸形状としてセットされます [詳細]
class | PhysicsJoint
ジョイント [詳細]
struct | RayHit
レイキャスト用のレイ情報 [詳細]
class | PhysicsSpring
スプリング [詳細]
class | PhysicsUtility
Physics2Dのためのユーティリティクラス [詳細]

列挙型

enum | BodyType { Dynamic, Kinematic, Static, Trigger }

剛体がダイナミック、キネマティック、スタティックかトリガーを指定する

[詳細]

列挙型

enum BodyType

剛体がダイナミック、キネマティック、スタティックかトリガーを指定する

列挙型の値:
Dynamic

一般的なダイナミック剛体

Kinematic

キネマティック剛体

しばらく動かないが、何かのイベントで人為的に動かされるようになる
質量は無限大と仮定して計算されるので、衝突時には常に相手を跳ね返す

Static

スタティック剛体

最初から最後まで動くことがない

Trigger

トリガー剛体

衝突反発はないが、衝突判定はある


クラス PhysicsBody

多くのプロパティを利用して剛体を定義する [詳細]

すべてのメンバ一覧

Public メソッド

PhysicsBody ()
デフォルトコンスタラクタ
PhysicsBody (PhysicsBody body)
コピーコンストラクタ
PhysicsBody (PhysicsShape conv, float m)
コンストラクタ
void | Clear ()
全てのメンバをクリアする
void | CopyBody (PhysicsBody body)
全てのメンバをコピーする
void | MoveTo (Vector2 pt, float rt, float dt)
位置、回転、並進速度、回転速度をアップデートする
bool | InsideBody (Vector2 pos, PhysicsShape con)
頂点が剛体の領域に含まれるかどうか
void | SetBodyStatic ()
剛体をスタティック剛体にセット
void | SetBodyKinematic ()
剛体をキネマティック剛体にセット
void | SetBodyTrigger ()
剛体をトリガー剛体に設定する
void | BackToDynamic ()
キネマティック剛体をダイナミック剛体に戻す
void | WakeUpDynamic ()
スリープ状態のダイナミック剛体を起こす
void | WakeUpKinematic ()
スリープ状態のキネマティック剛体を起こす
bool | IsKinematicOrStatic ()
剛体がキネマティックまたはスタティック剛体であるかを判定する
bool | IsKinematic ()
剛体がキネマティックであるかを判定する
bool | IsStatic ()
剛体がスタティックであるかを判定する
bool | IsDynamic ()
剛体がダイナミックであるかを判定する
bool | IsTrigger ()
剛体がトリガーであるかを判定する
void | ApplyForce (Vector2 power)
重心に力を加える
void | ApplyForce (Vector2 power, Vector2 pos, bool isGlobal=true)
任意の点に力を加える
void | ApplyTorque (float rotPower)
剛体にトルクを加える

Static Public メソッド

static Vector2 | MergeBody (PhysicsBody[] bodyList, uint[] indexList, uint num, PhysicsShape[] sceneShapes, uint[] map, bool flag=true)
剛体のマージ
static Vector2 | MergeBodyWithPos (PhysicsBody[] bodyList, uint[] indexList, uint num, PhysicsShape[] sceneShapes, uint[] map, Vector2 pos)
重心の設定を行う剛体のマージ

Public 変数

Vector2 | position = new Vector2(0, 0)
剛体の位置
float | rotation = 0.0f
剛体の回転角度
Vector2 | velocity = new Vector2(0, 0)
剛体の並進速度
float | angularVelocity = 0.0f
剛体の回転速度
Vector2 | localPosition = new Vector2(0, 0)
コンパウンド形状の場合のローカル位置
float | localRotation = 0.0f
コンパウンド形状の場合のローカル回転角度
Vector2 | acceleration = new Vector2(0, 0)
剛体の並進加速度
Vector2 | force = new Vector2(0, 0)
剛体にかかる重力を除く外力
float | torque = 0.0f
剛体にかかる重力を除くトルク
float | mass = 0.0f
剛体の質量
float | invMass = 0.0f
剛体の質量の逆数
float | inertia = 0.0f
剛体のテンソル
float | invInertia = 0.0f
剛体のテンソルの逆数
Vector2 | width = new Vector2(0, 0)
剛体の初期位置、回転角度に対するAABBバウンディングボックス
Vector2 | aabbMin = new Vector2(0, 0)
毎フレームアップデートされるAABBバウンディングボックスの左下位置
Vector2 | aabbMax = new Vector2(0, 0)
毎フレームアップデートされるAABBバウンディングボックスの右上位置
bool | broadCollide = false
Broad Phase衝突判定の結果
bool | narrowCollide = false
Narrow Phase衝突判定の結果
uint | shapeIndex = 0
剛体の形状のインデックス
uint | collisionFilter = 0
剛体のcollisionフィルター
uint | groupFilter = 0xFFFFFFFF
剛体のgroupフィルター
float | airFriction = 0.0f
Integrate Phaseで考慮される空気摩擦係数
float | colFriction = 0.0f
Solver Phaseで考慮される衝突摩擦係数
bool | sleep = false
スリープ状態、真ならシミュレーションで考慮されない
uint | sleepCount = 0
スリープ状態に入るかをチェックするカウンター
bool | picking = true
シミュレーション中にピッキングを可能にするかどうか
float | oldMass = 0.0f
剛体の前の質量
float | oldInvMass = 0.0f
剛体の前の質量の逆数
float | oldInertia = 0.0f
剛体の前のテンソル
float | oldInvInertia = 0.0f
剛体の前のテンソルの逆数
float | penetrationRepulse = 0.2f
めり込みに対する反発力の加速係数
float | penetLimit = 0.03f
めり込みに対する許容度
float | tangentFriction = 0.3f
反発に対する接線方向の摩擦係数
float | restitutionCoeff = 0.0f
反発に対する反発係数
object | userData = null
ユーザーデータへの参照

プロパティ

Vector2 | Position [get, set]
setter and getter of position
float | Rotation [get, set]
setter and getter of position
Vector2 | Velocity [get, set]
setter and getter of velocity
float | AngularVelocity [get, set]
setter and getter of angular velocity
Vector2 | LocalPosition [get, set]
setter and getter of local position
float | LocalRotation [get, set]
setter and getter of local rotation
Vector2 | Acceleration [get, set]
setter and getter of acceleration
Vector2 | Force [get, set]
setter and getter of force
float | Torque [get, set]
setter and getter of torque
float | Mass [get, set]
setter and getter of mass
float | InvMass [get, set]
setter and getter of inverse mass
float | Inertia [get, set]
setter and getter of inertia tensor
float | InvInertia [get, set]
setter and getter of inverse inertia tensor
Vector2 | Width [get, set]
setter and getter of Width
Vector2 | AabbMin [get, set]
setter and getter of AaabbMin
Vector2 | AabbMax [get, set]
setter and getter of aabbMax
bool | BroadCollide [get]
getter of broadCollide
bool | NarrowCollide [get]
getter of narrowCollide
uint | ShapeIndex [get, set]
setter and getter of shape index
uint | CollisionFilter [get, set]
setter and getter of collisionFilter
uint | GroupFilter [get, set]
setter and getter of groupFilter
float | AirFriction [get, set]
setter and getter of airFriction
float | ColFriction [get, set]
setter and getter of airFriction
bool | Sleep [get, set]
setter and getter of sleep
uint | SleepCount [get, set]
setter and getter of sleepCount
bool | Picking [get, set]
setter and getter of picking
BodyType | Type [get, set]
setter and getter of type
float | PenetrationRepulse [get, set]
setter and getter of penetrationRepulse
float | PenetLimit [get, set]
setter and getter of penetLimit
float | TangentFriction [get, set]
setter and getter of tangentFriction
float | RestitutionCoeff [get, set]
setter and getter of restitutionCoeff
object | UserData [get, set]
setter and getter of userData

説明

多くのプロパティを利用して剛体を定義する

コンストラクタとデストラクタ

PhysicsBody ( PhysicsBody body )

コピーコンストラクタ

引数:
body コピー元の剛体
PhysicsBody | ( | PhysicsShape | conv,
 |  | float | m
 | ) |  |

コンストラクタ

引数:
conv | 剛体の形状
m | 剛体の質量

メソッド

void ApplyForce ( Vector2 power )

重心に力を加える

引数:
power 与えられる力

ダイナミック剛体のみに有効

void ApplyForce | ( | Vector2 | power,
 |  | Vector2 | pos,
 |  | bool | isGlobal = true
 | ) |  |

任意の点に力を加える

引数:
power | 与えられる力
pos | 力の位置
isGlobal | 力の位置がグローバル座標かローカル座標かを示す。デフォルトはグローバル座標

ダイナミック剛体のみに有効

void ApplyTorque ( float rotPower )

剛体にトルクを加える

引数:
rotPower 与えられるトルク

ダイナミック剛体のみに有効

void BackToDynamic ( )

キネマティック剛体をダイナミック剛体に戻す

キネマティック剛体をダイナミック剛体に戻し、必要な情報を元の変数にセットする

bool InsideBody | ( | Vector2 | pos,
 |  | PhysicsShape | con
 | ) |  |

頂点が剛体の領域に含まれるかどうか

引数:
pos | 与えられた頂点
con | 剛体の形状
戻り値:
頂点が剛体の領域に入って入れば、真を返す
static Vector2 MergeBody | ( | PhysicsBody[] | bodyList,
 |  | uint[] | indexList,
 |  | uint | num,
 |  | PhysicsShape[] | sceneShapes,
 |  | uint[] | map,
 |  | bool | flag = true
 | ) |  | [static]

剛体のマージ

複数の剛体 (コンパウンド形状)をマージするために、インデックスが昇順で与えられている

引数:
bodyList | シーンの剛体リスト
indexList | マージするための剛体のインデックスリスト
num | マージするための剛体の数
sceneShapes | シーンの形状リスト
map | コンパウンド形状対応マップ
flag | 剛体の位置をマージ後に再調整するかどうか
static Vector2 MergeBodyWithPos | ( | PhysicsBody[] | bodyList,
 |  | uint[] | indexList,
 |  | uint | num,
 |  | PhysicsShape[] | sceneShapes,
 |  | uint[] | map,
 |  | Vector2 | pos
 | ) |  | [static]

重心の設定を行う剛体のマージ

複数の剛体 (コンパウンド形状)をマージするために、インデックスが昇順で与えられている

引数:
bodyList | シーンの剛体リスト
indexList | マージするための剛体のインデックスリスト
num | マージするための剛体の数
sceneShapes | シーンの形状リスト
map | コンパウンド形状対応マップ
pos | マージした剛体の重心
void MoveTo | ( | Vector2 | pt,
 |  | float | rt,
 |  | float | dt
 | ) |  |

位置、回転、並進速度、回転速度をアップデートする

引数:
pt | 剛体の新しい位置
rt | 剛体の新しい回転
dt | タイムステップ

剛体の新しい位置と回転を与えて、自動的に並進速度、回転速度を計算して設定します
位置、回転、並進速度、回転速度がこの関数によってセットされます 主にキネマティック剛体に対して使用し、スタティック剛体には使用できません

void SetBodyKinematic ( )

剛体をキネマティック剛体にセット

剛体をキネマティック剛体に設定,必要な情報を変数に保存する

void SetBodyStatic ( )

剛体をスタティック剛体にセット

剛体は一度スタティック剛体にセットされるとダイナミック剛体には戻せない

void WakeUpDynamic ( )

スリープ状態のダイナミック剛体を起こす

sleep = false; sleepCount = 0;　と同じ

void WakeUpKinematic ( )

スリープ状態のキネマティック剛体を起こす

キネマティック剛体を動かす時にはスリープ状態から起こさないと正しく衝突判定が行われません
sleep = false; sleepCount = 0;　と同じ

変数

float inertia = 0.0f

剛体のテンソル

剛体のテンソルはテンソルの逆数と同期していないといけない

float invInertia = 0.0f

剛体のテンソルの逆数

剛体のテンソルの逆数はテンソルと同期していないといけない

float invMass = 0.0f

剛体の質量の逆数

剛体の質量の逆数は質量と同期していないといけない

float mass = 0.0f

剛体の質量

剛体の質量は質量の逆数と同期していないといけない

float penetLimit = 0.03f

めり込みに対する許容度

この値を有効にするにはPhysicsSceneのuniquePropertyをfalseにする必要あり

float penetrationRepulse = 0.2f

めり込みに対する反発力の加速係数

この値を有効にするにはPhysicsSceneのuniquePropertyをfalseにする必要あり

float restitutionCoeff = 0.0f

反発に対する反発係数

この値を有効にするにはPhysicsSceneのuniquePropertyをfalseにする必要あり

float tangentFriction = 0.3f

反発に対する接線方向の摩擦係数

この値を有効にするにはPhysicsSceneのuniquePropertyをfalseにする必要あり

object userData = null

ユーザーデータへの参照

参照先データはユーザーによって適切に管理される必要があります


クラス PhysicsJoint

ジョイント [詳細]

すべてのメンバ一覧

Public メソッド

PhysicsJoint (PhysicsBody body1, PhysicsBody body2, Vector2 anchor, uint index1, uint index2)
ジョイントコンストラクタ
void | CopyJoint (PhysicsJoint jnt)
ジョイントの値をコピーする

Public 変数

uint | totalIndex
ジョイントの合成インデックス
Vector2 | localAnchor1 = new Vector2(0, 0)
接続点のbodyAから見たときの相対位置
Vector2 | localAnchor2 = new Vector2(0, 0)
接続点のbodyBから見たときの相対位置
Vector2 | axis1Lim = new Vector2(1, 0)
ジョイントの制御軸１
Vector2 | axis2Lim = new Vector2(0, 1)
ジョイントの制御軸２
float | angleLim = 1.0f
ジョイントの回転制御
float | friction = 0.001f
ジョイントの摩擦
float | axis1Lower = 0.0f
併進移動の下限値
float | axis1Upper = 0.0f
併進移動の上限値
float | axis2Lower = 0.0f
併進移動の下限値
float | axis2Upper = 0.0f
併進移動の上限値
float | angleLower = 0.0f
回転の下限値
float | angleUpper = 0.0f
回転の上限値
float | impulseRotMotor = 0.0f
回転に与えられる外からのインパルス
Vector2 | impulseLinearMotor = new Vector2(0, 0)
並進に与えられる外からのインパルス

プロパティ

uint | TotalIndex [get, set]
setter and getter of totalIndex
Vector2 | LocalAnchor1 [get, set]
setter and getter of localAnchor1
Vector2 | LocalAnchor2 [get, set]
setter and getter of LocalAnchor2
Vector2 | Axis1Lim [get, set]
setter and getter of axis1Lim
Vector2 | Axis2Lim [get, set]
setter and getter of axis2Lim
float | AngleLim [get, set]
setter and getter of angleLim
float | Friction [get, set]
setter and getter of friction
float | Axis1Lower [get, set]
setter and getter of axis1Lower
float | Axis1Upper [get, set]
setter and getter of axis1Upper
float | Axis2Lower [get, set]
setter and getter of axis2Lower
float | Axis2Upper [get, set]
setter and getter of axis2Upper
float | AngleLower [get, set]
setter and getter of angleLower
float | AngleUpper [get, set]
setter and getter of angleUpper
Vector2 | ImpulseLinearMotor [get, set]
setter and getter of linear impulse of joint
float | ImpulseRotMotor [get, set]
setter and getter of rotational impulse of joint
Vector2 | ImpulseLinear [get]
ジョイントの撃力並進成分
float | ImpulseRot [get]
ジョイントの撃力回転成分

説明

ジョイント

コンストラクタとデストラクタ

PhysicsJoint | ( | PhysicsBody | body1,
 |  | PhysicsBody | body2,
 |  | Vector2 | anchor,
 |  | uint | index1,
 |  | uint | index2
 | ) |  |

ジョイントコンストラクタ

引数:
body1 | ジョイントに接続された一方の剛体
body2 | ジョイントに接続されたもう一方の剛体
anchor | ジョイントの接続点
index1 | 剛体１のインデックス
index2 | 剛体２のインデックス

メソッド

void CopyJoint ( PhysicsJoint jnt )

ジョイントの値をコピーする

引数:
jnt ジョイント

変数

float angleLim = 1.0f

ジョイントの回転制御

angleLim [0.0f - 1.0f]
回転のロック angleLim=1.0f
回転のフリー angleLim=0.0f
[0.0f - 1.0f]以外の値をセットした場合は自動的に端の値にセットされます

Vector2 axis1Lim = new Vector2(1, 0)

ジョイントの制御軸１

ジョイントの制御軸１は制御軸２と直行している必要がある
axis1Lim = new Vector2(1, 0) はＸ方向の移動をロックする
正規化されたベクトルであるとき、方向移動を完全にロックする

Vector2 axis2Lim = new Vector2(0, 1)

ジョイントの制御軸２

ジョイントの制御軸２は制御軸１と直行している必要がある
axis1Lim = new Vector2(1, 0) はＹ方向の移動をロックする
正規化されたベクトルであるとき、方向移動を完全にロックする

float friction = 0.001f

ジョイントの摩擦

ジョイントの回転を最終的にストップするには摩擦が必要であり, 摩擦がないのであれば、ボールジョイントはずっと回転し続けてしまう


クラス PhysicsScene

２Ｄ物理シミュレーションのシーン [詳細]

すべてのメンバ一覧

Public 型

enum | BroadOpType { Or, And }

collisionFilterとgroupFilterの組み合わせを変更する

[詳細]
enum | SleepAlgorithmType { BroadphaseBase, NarrowphaseBase }

スリープ状態をチェックする際のアルゴリズムをスイッチする

[詳細]

Public メソッド

bool | RaycastHit (ref RayHit ray)
レイキャストチェック
bool | RaycastHit (ref RayHit ray, uint collisionFilter, uint groupFilter)
レイキャストチェック
PhysicsScene ()
  シーンコンストラクタ
void | Simulate ()
シミュレートする
void | Simulate (int click_index, Vector2 click_pos, Vector2 diff_pos)
シミュレートする
PhysicsShape | AddSphereShape (float radius)
シーンに球形状を追加する
PhysicsShape | AddBoxShape (Vector2 width)
シーンにボックス形状を追加する
PhysicsShape | AddConvexShape (Vector2[] pos, int num)
シーンに凸形状を追加する
PhysicsShape | AddConvexHullShape (Vector2[] pos, int num)
シーンにランダム頂点列による凸包形状を追加する
PhysicsShape | AddLineChainShape (Vector2[] pos, int num)
シーンに接続したライン形状生成を追加する
PhysicsBody | AddBody (int shapeIndex, float mass)
剛体をシーンに追加する
PhysicsBody | AddBody (PhysicsShape shape, float mass)
剛体をシーンに追加する
Vector2 | MergeCompound (PhysicsBody[] bodyList, int num, bool flag=true)
剛体のマージ
PhysicsJoint | AddJoint (int bodyIndex1, int bodyIndex2, Vector2 anchorPos)
ジョイントをシーンに追加する
PhysicsJoint | AddJoint (PhysicsBody body1, PhysicsBody body2, Vector2 anchorPos)
ジョイントをシーンに追加する
PhysicsSpring | AddSpring (int bodyIndex1, int bodyIndex2, Vector2 anchorPos1, Vector2 anchorPos2)
ジョイントをシーンに追加する
PhysicsSpring | AddSpring (PhysicsBody body1, PhysicsBody body2, Vector2 anchorPos1, Vector2 anchorPos2)
スプリングをシーンに追加する
int | DeleteJoint (int index)
ジョイント削除
int | DeleteJoint (PhysicsJoint joint)
ジョイント削除
int | DeleteSpring (int index)
スプリング削除
int | DeleteSpring (PhysicsSpring spring)
スプリング削除
int | DeleteBody (int index)
剛体削除
int | DeleteBody (PhysicsBody body)
剛体削除
bool | QueryContact (uint index1, uint index2)
２つの剛体の間に衝突があったかどうかの記録を調べる
bool | QueryContact (PhysicsBody body1, PhysicsBody body2)
２つの剛体の間に衝突があったかどうかの記録を調べる
int | QueryContactTrigger (uint index, uint[] indexlist)
トリガー剛体と他の剛体の間に衝突があったかチェックする
int | GetShapeIndex (PhysicsShape shape)
衝突形状のインデックスを調べる
int | GetBodyIndex (PhysicsBody body)
剛体のインデックスを調べる
int | GetJointIndex (PhysicsJoint joint)
ジョイントのインデックスを調べる
int | GetSpringIndex (PhysicsSpring spring)
スプリングのインデックスを調べる
PhysicsShape | GetShape (int index)
衝突形状を得る
PhysicsBody | GetBody (int index)
剛体を得る
PhysicsJoint | GetJoint (int index)
ジョイントを得る
PhysicsSpring | GetSpring (int index)
スプリングを得る
void | AddIgnorePair (uint index1, uint index2)
衝突を無視するペアをリストに加える
void | AddIgnorePair (PhysicsBody body1, PhysicsBody body2)
衝突を無視するペアをリストに加える
void | RemoveIgnorePair (uint index1, uint index2)
衝突を無視するペアをリストから削除する
void | RemoveIgnorePair (PhysicsBody body1, PhysicsBody body2)
衝突を無視するペアをリストから削除する
bool | CheckOutOfBound (PhysicsBody body)
  シミュレーションエリアを出たかどうかをチェック、出ていたらシミュレーションに考慮されない
int | CheckPicking (ref Vector2 click_pos, ref Vector2 diff_pos, bool rigorous_check)
タッチポイントの下にある剛体を探す
int | CheckForcePicking (ref Vector2 click_pos, ref Vector2 diff_pos, bool rigorous_check)
タッチポイントの下にある剛体を探す
virtual void | InitScene ()
シーンの初期化を定義する
virtual void | ReleaseScene ()
デバッグレンダリングリソースを含む、リソースの解放をここで定義する
virtual void | KeyboardFunc (GamePadButtons ePad)
ゲームパッドイベントの扱いを定義
virtual void | UpdateFuncAfterSim ()
ポストシミュレーション処理, 衝突情報に基づく処理などを定義する
virtual void | UpdateFuncBeforeSim ()
プレシミュレーション処理, 位置情報に基づき、外力を加えるなどの処理を定義する
virtual void | DrawAllBody (ref GraphicsContext graphics, ref ShaderProgram program, Matrix4 rendering_scale, int click_index)
レンダリングをユーザーが定義する
virtual void | DrawAdditionalInfo (ref GraphicsContext graphics, ref ShaderProgram program, Matrix4 rendering_scale)
デバッグレンダリングをユーザーが定義する

Public 変数

int | numBody = 0
シーン中の剛体数
int | numJoint = 0
シーン中のジョイント数
int | numSpring = 0
シーン中のスプリング数
int | numShape = 0
シーン中の形状数
int | numBroadPair = 0
broad phase衝突判定により衝突可能性のあるペア数
int | numPhysicsSolverPair = 0
narrow phase衝突判定により衝突するペア数
int | numOldPhysicsSolverPair = 0
前のnarrow phase衝突判定により衝突するペア数
PhysicsBody[] | sceneBodies = new PhysicsBody[maxBody]
シーン中の剛体リスト
PhysicsShape[] | sceneShapes = new PhysicsShape[maxShape]
シーン中の形状リスト
uint[] | broadPair = new uint[maxContacts]
シーン中のbroad phase衝突ペアリスト
PhysicsSolverPair[] | solverPair = new PhysicsSolverPair[maxContacts]
シーン中の衝突ペアリスト
PhysicsJoint[] | sceneJoints = new PhysicsJoint[maxJoint]
シーン中のジョイントリスト
PhysicsSpring[] | sceneSprings = new PhysicsSpring[maxSpring]
シーン中のスプリングリスト
uint[] | compoundMap = new uint[maxBody]
  コンパウンド形状対応マップ
float | simDt = 1.0f/60.0f
シミュレーションのタイムステップ
Vector2 | gravity = new Vector2(0, -9.8f)
シーン中の重力加速度
Vector2 | sceneMin = new Vector2(-1000.0f, -1000.0f)
シミュレーションエリアの境界
Vector2 | sceneMax = new Vector2(1000.0f, 1000.0f)
シミュレーションエリアの境界
ulong | sceneFrame = 0
このシーンのシミュレーションが始まってからのフレーム数
string | sceneName = "Scene made by Physics2DEngine"
シミュレーションのシーン名
int | numIgnorePair = 0
シーン中の衝突を無視するペアの数
uint[] | ignorePair = new uint[maxIgnore]
シーン中の衝突を無視するペアリスト
bool | printPerf = false
シミュレーション中の各計算フェーズのパフォーマンスを出力する
bool | uniqueProperty = true
シーン特性にユニークな値を使うか
float | penetrationRepulse = 0.2f
めり込みに対する反発力の加速係数
float | penetLimit = 0.03f
めり込みに対する許容度
float | tangentFriction = 0.3f
反発に対する接線方向の摩擦係数
float | restitutionCoeff = 0.0f
反発に対する反発係数
SleepAlgorithmType | sleepAlgorithm = SleepAlgorithmType.BroadphaseBase
スリープアルゴリズムがブロードフェーズによるか、ナローフェーズによるか
BroadOpType filterOp
filterOp

プロパティ

int | NumBody [get, set]
setter and getter of numBody
int | NumJoint [get, set]
setter and getter of numJoint
int | NumSpring [get, set]
setter and getter of numSpring
int | NumShape [get, set]
setter and getter of numShape
int | NumBroadPair [get, set]
setter and getter of numBroadPair
int | NumPhysicsSolverPair [get, set]
setter and getter of numPhysicsSolverPair
int | NumOldPhysicsSolverPair [get, set]
setter and getter of numOldPhysicsSolverPair
PhysicsBody[] | SceneBodies [get, set]
setter and getter of sceneBodies
PhysicsShape[] | SceneShapes [get, set]
setter and getter of sceneShapes
PhysicsJoint[] | SceneJoints [get, set]
setter and getter of sceneJoints
PhysicsSpring[] | SceneSprings [get, set]
setter and getter of sceneSprings
float | SimDt [get, set]
setter and getter of simDt
Vector2 | Gravity [get, set]
setter and getter of gravity
Vector2 | SceneMin [get, set]
setter and getter of sceneMin
Vector2 | SceneMax [get, set]
setter and getter of sceneMax
ulong | SceneFrame [get, set]
setter and getter of sceneFrame
string | SceneName [get, set]
setter and getter of sceneName
int | NumIgnorePair [get, set]
setter and getter of numIgnorePair
uint[] | IgnorePair [get, set]
setter and getter of ignorePair
bool | PrintPerf [get, set]
setter and getter of printPerf
bool | UniqueProperty [get, set]
setter and getter of uniqueProperty
float | PenetrationRepulse [get, set]
setter and getter of penetrationRepulse
float | PenetLimit [get, set]
setter and getter of penetLimit
float | TangentFriction [get, set]
setter and getter of tangentFriction
float | RestitutionCoeff [get, set]
setter and getter of restitutionCoeff
BroadOpType | FilterOp [get, set]
setter and getter of filterOp
uint[] | CompoundMap [get, set]
setter and getter of compoundMap
PhysicsSolverPair[] | SolverPair [get]
getter of solverPair
uint[] | BroadPair [get]
getter of broadPair
SleepAlgorithmType | SleepAlgorithm [get, set]
setter and getter of sleepAlgorithm

説明

２Ｄ物理シミュレーションのシーン

列挙型

enum BroadOpType

collisionFilterとgroupFilterの組み合わせを変更する

列挙型の値:
Or

OR操作

And

AND操作

enum SleepAlgorithmType

スリープ状態をチェックする際のアルゴリズムをスイッチする

列挙型の値:
BroadphaseBase

broadphase collisionに基づいて

NarrowphaseBase

narrowphase collisionに基づいて

メソッド

PhysicsBody AddBody | ( | int | shapeIndex,
 |  | float | mass
 | ) |  |

剛体をシーンに追加する

引数:
shapeIndex | 衝突形状のインデックス
mass | 質量
戻り値:
  剛体への参照

シーンの剛体数が自動的にインクリメントされる

PhysicsBody AddBody | ( | PhysicsShape | shape,
 |  | float | mass
 | ) |  |

剛体をシーンに追加する

引数:
shape | 衝突形状へのリファレンス
mass | 質量
戻り値:
  剛体への参照

シーンの剛体数が自動的にインクリメントされる

PhysicsShape AddBoxShape ( Vector2 width )

シーンにボックス形状を追加する

引数:
width ボックスの半分の縦横長さ

縦横長さではなく、縦横半分の長さである
シーンの衝突形状数が自動的にインクリメントされる

PhysicsShape AddConvexHullShape | ( | Vector2[] | pos,
 |  | int | num
 | ) |  |

シーンにランダム頂点列による凸包形状を追加する

引数:
pos | ランダムな頂点列
num | 頂点数

頂点リストの数の最大は３０個
シーンの衝突形状数が自動的にインクリメントされる

PhysicsShape AddConvexShape | ( | Vector2[] | pos,
 |  | int | num
 | ) |  |

シーンに凸形状を追加する

引数:
pos | 凸形状の頂点リスト
num | 頂点リストの数

頂点リストの数の最大は３０個
シーンの衝突形状数が自動的にインクリメントされる

void AddIgnorePair | ( | uint | index1,
 |  | uint | index2
 | ) |  |

衝突を無視するペアをリストに加える

引数:
index1 | 剛体ペアの一方
index2 | 剛体ペアのもう一方
void AddIgnorePair | ( | PhysicsBody | body1,
 |  | PhysicsBody | body2
 | ) |  |

衝突を無視するペアをリストに加える

引数:
body1 | 剛体ペアの一方
body2 | 剛体ペアのもう一方
PhysicsJoint AddJoint | ( | int | bodyIndex1,
 |  | int | bodyIndex2,
 |  | Vector2 | anchorPos
 | ) |  |

ジョイントをシーンに追加する

引数:
bodyIndex1 | 剛体ペアの一方のインデックス
bodyIndex2 | 剛体ペアのもう一方のインデックス
anchorPos | ジョイントのアンカーポイント
戻り値:
  ジョイントへの参照

シーンのジョイント数が自動的にインクリメントされる

PhysicsJoint AddJoint | ( | PhysicsBody | body1,
 |  | PhysicsBody | body2,
 |  | Vector2 | anchorPos
 | ) |  |

ジョイントをシーンに追加する

引数:
body1 | 剛体ペアの一方のインデックス
body2 | 剛体ペアのもう一方のインデックス
anchorPos | ジョイントのアンカーポイント
戻り値:
  ジョイントへの参照

シーンのジョイント数が自動的にインクリメントされる

PhysicsShape AddLineChainShape | ( | Vector2[] | pos,
 |  | int | num
 | ) |  |

シーンに接続したライン形状生成を追加する

引数:
pos | ライン形状の頂点リスト
num | 頂点リストの数

頂点リストの数の最大は３０個であり、また、これによって作れるのは静的剛体のみです
シーンの衝突形状数が自動的にインクリメントされる

PhysicsShape AddSphereShape ( float radius )

シーンに球形状を追加する

引数:
radius 球の半径

シーンの衝突形状数が自動的にインクリメントされる

PhysicsSpring AddSpring | ( | PhysicsBody | body1,
 |  | PhysicsBody | body2,
 |  | Vector2 | anchorPos1,
 |  | Vector2 | anchorPos2
 | ) |  |

スプリングをシーンに追加する

引数:
body1 | 剛体ペアの一方のインデックス
body2 | 剛体ペアのもう一方のインデックス
anchorPos1 | スプリングのアンカーポイントの１つ
anchorPos2 | スプリングのアンカーポイントのもう１つ
戻り値:
  スプリングへの参照

シーンのスプリング数が自動的にインクリメントされる

PhysicsSpring AddSpring | ( | int | bodyIndex1,
 |  | int | bodyIndex2,
 |  | Vector2 | anchorPos1,
 |  | Vector2 | anchorPos2
 | ) |  |

ジョイントをシーンに追加する

引数:
bodyIndex1 | 剛体ペアの一方のインデックス
bodyIndex2 | 剛体ペアのもう一方のインデックス
anchorPos | ジョイントのアンカーポイント
戻り値:
  ジョイントへの参照

シーンのジョイント数が自動的にインクリメントされる

int CheckForcePicking | ( | ref Vector2 | click_pos,
 |  | ref Vector2 | diff_pos,
 |  | bool | rigorous_check
 | ) |  |

タッチポイントの下にある剛体を探す

引数:
click_pos | タッチポイント
diff_pos | 剛体中心とタッチポイントの差
rigorous_check | 厳密なチェックを行うかどうか
戻り値:
タッチされている剛体があれば、そのインデックスをなければ-1を返す
剛体がStaticであってもピッキングデータを返すことに注意
bool CheckOutOfBound ( PhysicsBody body )

  シミュレーションエリアを出たかどうかをチェック、出ていたらシミュレーションに考慮されない

引数:
body 　剛体
戻り値:
シミュレーションエリア外なら真を返す
int CheckPicking | ( | ref Vector2 | click_pos,
 |  | ref Vector2 | diff_pos,
 |  | bool | rigorous_check
 | ) |  |

タッチポイントの下にある剛体を探す

引数:
click_pos | タッチポイント
diff_pos | 剛体中心とタッチポイントの差
rigorous_check | 厳密なチェックを行うかどうか
戻り値:
タッチされている剛体があれば、そのインデックスをなければ-1を返す
int DeleteBody ( int index )

剛体削除

引数:
index 剛体インデックス
戻り値:
  剛体の総数

シミュレーション内で使用しているキャッシュデータの再構築が必要になるために計算負荷がかかります
同フレームで多くの剛体を削除する場合は注意が必要で、削除でなくシミュレーション領域外へ置くなどの方法も検討してください
Compound剛体を削除する場合は、compound剛体に関わる剛体が全て削除されます

int DeleteBody ( PhysicsBody body )

剛体削除

引数:
body 剛体への参照
戻り値:
  剛体の総数

シミュレーション内で使用しているキャッシュデータの再構築が必要になるために計算負荷がかかります
同フレームで多くの剛体を削除する場合は注意が必要で、削除でなくシミュレーション領域外へ置くなどの方法も検討してください
Compound剛体を削除する場合は、compound剛体に関わる剛体が全て削除されます

int DeleteJoint ( int index )

ジョイント削除

引数:
index ジョイントのインデックス
戻り値:
  削除後のジョイントの総数
int DeleteJoint ( PhysicsJoint joint )

ジョイント削除

引数:
joint ジョイントへの参照
戻り値:
  削除後のジョイントの総数
int DeleteSpring ( PhysicsSpring spring )

スプリング削除

引数:
spring スプリングへの参照
戻り値:
  削除後のスプリングの総数
int DeleteSpring ( int index )

スプリング削除

引数:
index スプリングのインデックス
戻り値:
  削除後のスプリングの総数
virtual void DrawAdditionalInfo | ( | ref GraphicsContext | graphics,
 |  | ref ShaderProgram | program,
 |  | Matrix4 | rendering_scale
 | ) |  | [virtual]

デバッグレンダリングをユーザーが定義する

引数:
graphics | グラフィックスコンテキスト
program | シェーダープログラム
rendering_scale | レンダリングスケール
virtual void DrawAllBody | ( | ref GraphicsContext | graphics,
 |  | ref ShaderProgram | program,
 |  | Matrix4 | rendering_scale,
 |  | int | click_index
 | ) |  | [virtual]

レンダリングをユーザーが定義する

引数:
graphics | グラフィックスコンテキスト
program | シェーダープログラム
rendering_scale | レンダリングスケール
click_index | クリックした剛体インデックス
PhysicsBody GetBody ( int index )

剛体を得る

引数:
index 剛体のインデックス
戻り値:
見つからない時はnullが返される
int GetBodyIndex ( PhysicsBody body )

剛体のインデックスを調べる

引数:
body 剛体
戻り値:
見つからない時は-1が返される
PhysicsJoint GetJoint ( int index )

ジョイントを得る

引数:
index ジョイントのインデックス
戻り値:
見つからない時はnullが返される
int GetJointIndex ( PhysicsJoint joint )

ジョイントのインデックスを調べる

引数:
joint ジョイント
戻り値:
見つからない時は-1が返される
PhysicsShape GetShape ( int index )

衝突形状を得る

引数:
index 衝突形状のインデックス
戻り値:
見つからない時はnullが返される
int GetShapeIndex ( PhysicsShape shape )

衝突形状のインデックスを調べる

引数:
shape 衝突形状
戻り値:
見つからない時は-1が返される
PhysicsSpring GetSpring ( int index )

スプリングを得る

引数:
index スプリングのインデックス
戻り値:
見つからない時はnullが返される
int GetSpringIndex ( PhysicsSpring spring )

スプリングのインデックスを調べる

引数:
spring スプリング
戻り値:
見つからない時は-1が返される
virtual void KeyboardFunc ( GamePadButtons ePad ) [virtual]

ゲームパッドイベントの扱いを定義

引数:
ePad ゲームパッド入力
Vector2 MergeCompound | ( | PhysicsBody[] | bodyList,
 |  | int | num,
 |  | bool | flag = true
 | ) |  |

剛体のマージ

複数の剛体 (コンパウンド形状)をマージするために、インデックスが昇順で与えられている

引数:
bodyList | シーンの剛体リスト
num | マージするための剛体の数
flag | 剛体の位置をマージ後に再調整するかどうか
bool QueryContact | ( | uint | index1,
 |  | uint | index2
 | ) |  |

２つの剛体の間に衝突があったかどうかの記録を調べる

引数:
index1 | 剛体ペアの一方
index2 | 剛体ペアのもう一方
戻り値:
  剛体ペアに衝突があった記録があれば真を返す
bool QueryContact | ( | PhysicsBody | body1,
 |  | PhysicsBody | body2
 | ) |  |

２つの剛体の間に衝突があったかどうかの記録を調べる

引数:
body1 | 剛体ペアの一方
body2 | 剛体ペアのもう一方
戻り値:
  剛体ペアに衝突があった記録があれば真を返す
int QueryContactTrigger | ( | uint | index,
 |  | uint[] | indexlist
 | ) |  |

トリガー剛体と他の剛体の間に衝突があったかチェックする

引数:
index | トリガー剛体のインデックス
indexlist | トリガー剛体との衝突を検出された剛体インデックスが格納される
戻り値:
  トリガー剛体との衝突を検出された剛体の数
bool RaycastHit | ( | ref RayHit | ray,
 |  | uint | collisionFilter,
 |  | uint | groupFilter
 | ) |  |

レイキャストチェック

引数:
ray | レイキャスト用のレイ情報
collisionFilter | 通常の衝突判定と同様のコリジョンフィルター
groupFilter | 通常の衝突判定と同様のグループフィルター
戻り値:
レイの交差があるかないかを返す
bool RaycastHit ( ref RayHit ray )

レイキャストチェック

引数:
ray レイキャスト用のレイ情報
戻り値:
レイの交差があるかないかを返す
void RemoveIgnorePair | ( | PhysicsBody | body1,
 |  | PhysicsBody | body2
 | ) |  |

衝突を無視するペアをリストから削除する

引数:
body1 | 剛体ペアの一方
body2 | 剛体ペアのもう一方
void RemoveIgnorePair | ( | uint | index1,
 |  | uint | index2
 | ) |  |

衝突を無視するペアをリストから削除する

引数:
index1 | 剛体ペアの一方
index2 | 剛体ペアのもう一方
void Simulate | ( | int | click_index,
 |  | Vector2 | click_pos,
 |  | Vector2 | diff_pos
 | ) |  |

シミュレートする

引数:
click_index | クリックした剛体のインデックス
click_pos | クリックした位置
diff_pos | クリックした位置と剛体の中心の差

クリックによる影響を剛体に与えたい場合のシミュレート関数

変数

uint [] compoundMap = new uint[maxBody]

  コンパウンド形状対応マップ

internal use only

BroadOpType filterOp

filterOp

ORとANDのcollision and group filter の組み合わせを変更する

プロパティ

uint [] BroadPair [get]

getter of broadPair

setter is not provided

PhysicsSolverPair [] SolverPair [get]

getter of solverPair

setter is not provided


クラス PhysicsShape

全ての形状は凸形状としてセットされます [詳細]

すべてのメンバ一覧

Public メソッド

PhysicsShape ()
デフォルトコンストラクタ
PhysicsShape (float radius)
球生成
PhysicsShape (Vector2 width)
ボックス生成
PhysicsShape (Vector2[] pos, int num)
凸形状生成
PhysicsShape (Vector2[] pos, int num, bool flag)
接続したライン形状生成
PhysicsShape (PhysicsShape con)
コピー形状生成

Static Public メソッド

static PhysicsShape | CreateConvexHull (Vector2[] vertList, int num)
ランダム頂点から凸包を生成します

Public 変数

int | numVert
頂点数
Vector2[] | vertList = new Vector2[30]
頂点リスト
uint | hint
PhysicsShapeに対するヒント

プロパティ

int | NumVert [get, set]
setter and getter of numVert
Vector2[] | VertList [get, set]
setter and getter of vertList
uint | Hint [get, set]
setter and getter of hint

説明

全ての形状は凸形状としてセットされます

コンストラクタとデストラクタ

PhysicsShape ( float radius )

球生成

引数:
radius 球の半径
PhysicsShape ( Vector2 width )

ボックス生成

引数:
width ボックスの半分の縦横長さ

縦横長さではなく、縦横半分の長さである

PhysicsShape | ( | Vector2[] | pos,
 |  | int | num
 | ) |  |

凸形状生成

引数:
pos | 凸形状の頂点リスト
num | 頂点リストの数

頂点リストの数の最大は３０個

PhysicsShape | ( | Vector2[] | pos,
 |  | int | num,
 |  | bool | flag
 | ) |  |

接続したライン形状生成

引数:
pos | ライン形状の頂点リスト
num | 頂点リストの数
flag | trueを常に与える

頂点リストの数の最大は３０個であり、また、これによって作れるのは静的剛体のみです

PhysicsShape ( PhysicsShape con )

コピー形状生成

引数:
con 剛体の形状

メソッド

static PhysicsShape CreateConvexHull | ( | Vector2[] | vertList,
 |  | int | num
 | ) |  | [static]

ランダム頂点から凸包を生成します

引数:
vertList | ランダムな頂点列
num | 頂点数
戻り値:
凸形状

変数

uint hint

PhysicsShapeに対するヒント

PhysicsShapeの対称性を判定している hint=1は形状が対称性を有していないケースで, hint=2は形状が対称性を有している, 任意に凸形状を指定した場合、球とボックスの場合を除いて、シミュレーション速度を上げるため、 適切にこの変数を指定することが望ましい

Vector2 [] vertList = new Vector2[30]

頂点リスト

頂点リスト、最大で３０点まで、numVert = 0 は 球を表す特別なケースで最初の点のＸ座標に半径が記録されている


クラス PhysicsSpring

スプリング [詳細]

すべてのメンバ一覧

Public メソッド

PhysicsSpring (PhysicsBody body1, PhysicsBody body2, Vector2 anchor1, Vector2 anchor2, uint index1, uint index2)
スプリングコンストラクタ
void | CopySpring (PhysicsSpring jnt)
スプリングの値をコピー
uint | GetIndex1 ()
GetIndex1.
uint | GetIndex2 ()
GetIndex2.

Public 変数

uint | totalIndex
スプリングの合成インデックス
Vector2 | localAnchor1 = new Vector2(0, 0)
接続点のbodyAから見たときの相対位置
Vector2 | localAnchor2 = new Vector2(0, 0)
接続点のbodyBから見たときの相対位置
float | distance = 0.0f
元の接続点間の距離
float | currentDistance = 0.0f
現在の接続点間の距離
float | elastic = 10.0f
スプリング係数
float | dumping = 0.4f
速度減衰係数

プロパティ

uint | TotalIndex [get, set]
setter and getter of totalIndex
Vector2 | LocalAnchor1 [get, set]
setter and getter of localAnchor1
Vector2 | LocalAnchor2 [get, set]
setter and getter of localAnchor2
float | Distance [get, set]
setter and getter of distance
float | CurrentDistance [get, set]
setter and getter of currentDistance
float | Elastic [get, set]
setter and getter of elastic
float | Dumping [get, set]
setter and getter of dumping

説明

スプリング

コンストラクタとデストラクタ

PhysicsSpring | ( | PhysicsBody | body1,
 |  | PhysicsBody | body2,
 |  | Vector2 | anchor1,
 |  | Vector2 | anchor2,
 |  | uint | index1,
 |  | uint | index2
 | ) |  |

スプリングコンストラクタ

引数:
body1 | スプリングに接続された一方の剛体
body2 | スプリングに接続されたもう一方の剛体
anchor1 | スプリングの接続点１
anchor2 | スプリングの接続点２
index1 | 剛体１のインデックス
index2 | 剛体２のインデックス

メソッド

void CopySpring ( PhysicsSpring jnt )

スプリングの値をコピー

引数:
jnt スプリング
uint GetIndex1 ( )

GetIndex1.

GetIndex1

uint GetIndex2 ( )

GetIndex2.

GetIndex2

変数

float dumping = 0.4f

速度減衰係数

振動による計算不安定性を取り除くため


クラス PhysicsUtility

Physics2Dのためのユーティリティクラス [詳細]

すべてのメンバ一覧

Static Public メソッド

static uint | UnpackIdx1 (uint val)
合成のインデックスから１番目のインデックスを取り出す
static uint | UnpackIdx2 (uint val)
合成のインデックスから２番目のインデックスを取り出す
static uint | PackIdx (uint val1, uint val2)
２つのインデックスからシフト演算と和を取って合成のインデックスを計算する
static uint | SwapIdx (uint val)
合成のインデックスの１番目と２番目を入れ替える
static float | GetRadian (float angle)
Degreeからラジアンへの変換
static float | GetRadianMod (float angle)
ラジアン角度を[-Pi, Pi]の範囲に変換する

Public 変数

const float | Pi = 3.14159265f
Physics2D計算内で使用するPi.
const float | FltMax = 1E+37f
Physics2D計算内で使用するFltMax.

説明

Physics2Dのためのユーティリティクラス

メソッド

static float GetRadian ( float angle ) [static]

Degreeからラジアンへの変換

引数:
angle Degreeでの角度
static float GetRadianMod ( float angle ) [static]

ラジアン角度を[-Pi, Pi]の範囲に変換する

引数:
angle ラジアンでの角度
static uint PackIdx | ( | uint | val1,
 |  | uint | val2
 | ) |  | [static]

２つのインデックスからシフト演算と和を取って合成のインデックスを計算する

引数:
val1 | １番目のインデックス
val2 | ２番目のインデックス
戻り値:
合成のインデックス
static uint SwapIdx ( uint val ) [static]

合成のインデックスの１番目と２番目を入れ替える

引数:
val PhysicsSolverPairなどの合成のインデックス
戻り値:
入れ替えた合成インデックス
static uint UnpackIdx1 ( uint val ) [static]

合成のインデックスから１番目のインデックスを取り出す

引数:
val PhysicsSolverPairなどの合成のインデックス
戻り値:
１番目のインデックス
static uint UnpackIdx2 ( uint val ) [static]

合成のインデックスから２番目のインデックスを取り出す

引数:
val PhysicsSolverPairなどの合成のインデックス
戻り値:
２番目のインデックス


構造体 PhysicsSolverPair

衝突した剛体ペアの衝突情報を保持している [詳細]

すべてのメンバ一覧

Public メソッド

uint | GetIndexA ()
ペアの剛体Ａのインデックスを返す
uint | GetIndexB ()
ペアの剛体Ｂのインデックスを返す
float | GetImpulseNormal ()
法線方向の撃力を返す
float | GetImpulseTangent ()
接線方向の撃力を返す

Public 変数

uint | totalIndex
シフト演算と和によって合成されたペアのインデックス
Vector2 normal
反発法線方向
Vector2 resA
bodyAに対して見た時の衝突点
Vector2 resB
bodyBに対して見た時の衝突点

プロパティ

uint | TotalIndex [get, set]
setter and getter of totalIndex
Vector2 | Normal [get, set]
setter and getter of normal
Vector2 | ResA [get, set]
setter and getter of resA
Vector2 | ResB [get, set]
setter and getter of resB

説明

衝突した剛体ペアの衝突情報を保持している


構造体 RayHit

レイキャスト用のレイ情報 [詳細]

すべてのメンバ一覧

Public 変数

Vector2 start
レイのスタート地点
Vector2 end
レイの終了地点
Vector2 hit
レイの衝突地点
int | hitIndex
レイの衝突する剛体のインデックス
float | depth
レイの衝突深さ
float | ratio
レイの衝突割合

プロパティ

Vector2 | Start [get, set]
setter and getter of start
Vector2 | End [get, set]
setter and getter of end
Vector2 | Hit [get, set]
setter and getter of hit
int | HitIndex [get, set]
setter and getter of hitIndex
float | Depth [get, set]
setter and getter of depth
float | Ratio [get, set]
setter and getter of ratio

説明

レイキャスト用のレイ情報


パッケージ Sce.PlayStation.HighLevel.UI

構成

class | AnimationImageBox
画像切り替えによるアニメーションの表示ウィジェット [詳細]
class | AnimationUtility
アニメーション用のユーティリティ [詳細]
class | BunjeeJumpEffect
ウィジェットが上から落ちてきて少し跳ねて止まるエフェクト [詳細]
class | BusyIndicator
進行状況を表示するウィジェット [詳細]
class | Button
ボタンウィジェット [詳細]
class | TextShadowSettings
文字列の影の設定情報 [詳細]
class | CustomButtonImageSettings
ボタンのカスタマイズ画像の設定情報 [詳細]
class | CheckBox
チェックボックスウィジェット [詳細]
class | CustomCheckBoxImageSettings
カスタマイズ画像の設定情報 [詳細]
class | ContainerWidget
コンテナ機能を持つウィジェット [詳細]
class | CrossFadeTransition
クロスフェードトランジション [詳細]
class | DatePicker
日付を選択するためのウィジェット [詳細]
class | DatePickerValueChangedEventArgs
DatePicker の値が変更されたときのイベント引数 [詳細]
class | DelayedExecutor
ある時間が経過した後に処理を行うエフェクト [詳細]
class | Dialog
モーダルダイアログ [詳細]
class | DialogEventArgs
ダイアログイベント引数 [詳細]
class | DoubleTapGestureDetector
ダブルタップ検出器 [詳細]
class | DoubleTapEventArgs
ダブルタップイベント引数 [詳細]
class | DragGestureDetector
ドラッグ検出器 [詳細]
class | DragEventArgs
ドラッグイベント引数 [詳細]
class | EditableText
編集可能なテキストウィジェット [詳細]
class | TextChangedEventArgs
テキストを変更したときのイベント引数 [詳細]
class | Effect
ウィジェットまたはエレメントに適用するアニメーションの基底クラス [詳細]
class | FadeInEffect
フェードインエフェクト [詳細]
class | FadeOutEffect
フェードアウトエフェクト [詳細]
class | FlickGestureDetector
フリック検出器 [詳細]
class | FlickEventArgs
フリックイベント引数 [詳細]
class | FlipBoardEffect
真ん中で折れるエフェクト [詳細]
class | FlipBoardTransition
真ん中で折れるトランジション [詳細]
class | FocusChangedEventArgs
FocusChangedイベント引数 [詳細]
class | FocusCustomSettings
フォーカスのカスタム設定 [詳細]
class | GestureDetector
ジェスチャ検出機構の基底クラス [詳細]
class | GestureEventArgs
ジェスチャイベント引数の基底クラス [詳細]
class | GridListPanel
複数の行と列を持つリストウィジェット [詳細]
class | ImageAsset
画像アセットクラス [詳細]
class | ImageBox
画像を表示するウィジェット [詳細]
class | JumpFlipEffect
画面手前にジャンプし反転して切り替わるエフェクト [詳細]
class | JumpFlipTransition
画面手前にジャンプし反転して切り替わるトランジション [詳細]
class | KeyEvent
キーイベント情報 [詳細]
class | KeyEventArgs
キーイベント引数 [詳細]
class | Label
文字列を表示するウィジェット [詳細]
class | ListPanel
複数の行を持つリストウィジェット [詳細]
class | ListSection
リストのセクション用のコンテナ部品 [詳細]
class | ListSectionCollection
セクションのコレクション [詳細]
class | ListPanelItem
リストのアイテム用のコンテナウィジェット [詳細]
class | ListPanelItemSelectChangedEventArgs
リストアイテムが選択された場合に呼び出されるイベント引数 [詳細]
class | LiveFlipPanel
イベントにより回転するコンテナウィジェット [詳細]
class | LiveJumpPanel
子ウィジェットが画面手前にジャンプするコンテナウィジェット。 [詳細]
class | LiveListPanel
アイテムが不規則な配置でスクロールするリストウィジェット [詳細]
class | LiveScrollPanel
形状が歪みながらスクロールするコンテナウィジェット [詳細]
class | LiveSphere
球体型のウィジェット [詳細]
class | LiveSpringPanel
加速度センサーやパネルの動きに応じて子ウィジェットが揺れるパネル [詳細]
class | LongPressGestureDetector
ロングプレス検出器 [詳細]
class | LongPressEventArgs
ロングプレスイベント引数 [詳細]
class | MessageDialog
警告のメッセージ等を表示するための特殊化されたモーダルダイアログ [詳細]
class | MessageDialogButtonEventArgs
メッセージダイアログのイベント引数 [詳細]
class | MotionEvent
モーションイベントクラス [詳細]
class | MotionEventArgs
モーションイベント引数 [詳細]
class | MoveEffect
現在の位置から指定した位置に移動するエフェクト [詳細]
struct | NinePatchMargin
９パッチ情報を格納するための構造体 [詳細]
class | PagePanel
ページ単位でスクロールするコンテナウィジェット [詳細]
class | Panel
コンテナの機能を持つウィジェット [詳細]
class | PinchGestureDetector
ピンチ検出器 [詳細]
class | PinchEventArgs
ピンチイベント引数 [詳細]
class | PopupList
複数の選択肢から１つを選択するためのウィジェット [詳細]
class | PopupListItemCollection
PopupListのListItems用コレクション [詳細]
class | PopupSelectionChangedEventArgs
PopupList の選択中のアイテムが変わったときに呼ばれるイベント引数 [詳細]
class | PopupListItemsChangedEventArgs
PopupListのListItemsChangedイベント引数 [詳細]
class | PressStateChangedEventArgs
PressStateChangedイベント引数 [詳細]
class | ProgressBar
進捗の度合いを表示するウィジェット [詳細]
class | PushTransition
新しいシーンが古いシーンを押しだすトランジション [詳細]
class | RootUIElement
エレメントツリーのルート [詳細]
class | RootWidget
ウィジェットツリーのルート [詳細]
class | Scene
画面 [詳細]
class | UpdateEventArgs
更新処理イベントのデータが格納されているクラス [詳細]
class | ScrollBar
画面のスクロール位置を把握するためのウィジェット [詳細]
class | ScrollPanel
スクロール可能な領域を持つコンテナウィジェット [詳細]
class | SlideInEffect
画面の外から現在の位置まで平行移動するエフェクト [詳細]
class | SlideOutEffect
現在の位置から画面の外まで平行移動するエフェクト [詳細]
class | Slider
数値などの調整を行うためのウィジェット [詳細]
class | SliderValueChangeEventArgs
現在の位置が変化したときのイベント引数 [詳細]
class | SlideTransition
平行移動してシーンを切り替えるトランジション [詳細]
class | TapGestureDetector
タップ検出器 [詳細]
class | TapEventArgs
タップイベント引数 [詳細]
class | TiltDropEffect
下方向へ落ちるエフェクト [詳細]
class | TiltDropTransition
下方向へ落ちるトランジション [詳細]
class | TimePicker
時刻を選択するためのウィジェット [詳細]
class | TimePickerValueChangedEventArgs
TimePicker の値が変更されたときのイベント引数 [詳細]
class | TouchEvent
タッチイベントクラス [詳細]
class | TouchEventArgs
タッチイベント引数 [詳細]
class | TouchEventCollection
複数のタッチイベントをまとめて保持するクラス [詳細]
class | Transition
シーンに適用するアニメーションの基底クラス [詳細]
class | UIAnimationPlayer
uia 形式のアニメーションを再生するクラス [詳細]
struct | UIColor
色を扱う構造体 [詳細]
class | UIDebug
UI Toolkit のデバッグに使用するユーティリティクラス [詳細]
class | UIElement
描画要素の基底クラス [詳細]
class | UIFont
UIで使用するフォントクラス [詳細]
class | UIMotion
uim 形式のモーションを再生するクラス [詳細]
class | UIPrimitive
プリミティブ [詳細]
class | UIPrimitiveUtility
プリミティブのユーティリティ [詳細]
class | UIPrimitiveVertex
UIPrimitiveが管理する頂点データ [詳細]
class | UISprite
複数の矩形をまとめて描画する [詳細]
class | UISpriteUnit
UISpriteが管理する矩形データ [詳細]
class | UISpriteUtility
スプライトのユーティリティ [詳細]
class | UISystem
UI Toolkitのシステム全体の管理を行うクラス [詳細]
class | Widget
ウィジェットの基底クラス [詳細]
class | ZoomEffect
現在のスケールから指定したスケールに拡大または縮小するエフェクト [詳細]

列挙型

enum | ButtonStyle { Default = 0, Custom }

ボタンの種類

[詳細]
enum | CheckBoxStyle { CheckBox = 0, RadioButton, Custom }

チェックボックスの種類

[詳細]
enum | CrossFadeTransitionInterpolator { Linear = 0, EaseOutQuad, Custom }

補間関数

[詳細]
enum | DialogBackgroundStyle { Default = 0, Custom }

ダイアログの背景の種類

[詳細]
enum | DialogResult { Ok = 0, Cancel }

ダイアログ結果

[詳細]
enum DragDirection {
All = 0, Vertical, Horizontal, LimitedVertical,
LimitedHorizontal
}

DragGestureの判定方向

[詳細]
enum | FourWayDirection { Up = 0, Down, Left, Right }

上下左右の４つ方向

[詳細]
enum | EffectUpdateResponse { Continue = 0, Finish }

エフェクトの更新の応答

[詳細]
enum | FadeInEffectInterpolator { Linear = 0, EaseOutQuad, Custom }

FadeInEffect用の補間関数

[詳細]
enum | FadeOutEffectInterpolator { Linear = 0, EaseOutQuad, Custom }

FadeOutEffect用の補間関数

[詳細]
enum | FlickDirection { All = 0, Vertical, Horizontal }

フリックの方向

[詳細]
enum | FlipBoardEffectInterpolator { Default = 0, Custom }

FlipBoardEffect用の補間関数の種類

[詳細]
enum | FlipBoardTransitionInterpolator { Default = 0, Custom }

FlipBoardTransition用の補間関数の種類

[詳細]
enum FocusStyle {
RoundedCorner = 0, Rectangle, Circle, ListItem,
None
}

フォーカスの表示スタイル

[詳細]
enum GestureDetectorResponse {
None = 0, UndetectedAndContinue, DetectedAndContinue, DetectedAndStop,
FailedAndStop
}

GestureDetectorのタッチイベント配信応答

[詳細]
enum | GridListScrollOrientation { Horizontal = 0, Vertical }

スクロール方向

[詳細]
enum SystemImageAsset {
ButtonBackgroundNormal = 0, ButtonBackgroundPressed, ButtonBackgroundDisabled, CheckBoxCheckedNormal,
CheckBoxUncheckedNormal, CheckBoxCheckedPressed, CheckBoxUncheckedPressed, CheckBoxCheckedDisabled,
CheckBoxUncheckedDisabled, RadioButtonCheckedNormal, RadioButtonUncheckedNormal, RadioButtonCheckedPressed,
RadioButtonUncheckedPressed, RadioButtonCheckedDisabled, RadioButtonUncheckedDisabled, SliderHorizontalBaseNormal,
SliderHorizontalBaseDisabled, SliderHorizontalBarNormal, SliderHorizontalBarDisabled, SliderHorizontalHandleNormal,
SliderHorizontalHandlePressed, SliderHorizontalHandleDisabled, SliderVerticalBaseNormal, SliderVerticalBaseDisabled,
SliderVerticalBarNormal, SliderVerticalBarDisabled, SliderVerticalHandleNormal, SliderVerticalHandlePressed,
SliderVerticalHandleDisabled, ProgressBarBase, ProgressBarNormal, ProgressBarAccelerator,
ScrollBarHorizontalBackground, ScrollBarHorizontalBar, ScrollBarVerticalBackground, ScrollBarVerticalBar,
EditableTextBackgroundNormal, EditableTextBackgroundDisabled, BusyIndicator, DialogBackground,
PagePanelNormal, PagePanelActive, ListPanelSeparatorTop, ListPanelSeparatorBottom,
ListPanelSectionSeparator, MessageDialogBackground, MessageDialogSeparator, SpinBoxBase,
SpinBoxCenter, PopupListBackgroundNormal, PopupListBackgroundPressed, PopupListBackgroundDisabled,
PopupListItemFocus, BackButtonBackgroundNormal, BackButtonBackgroundDisabled, BackButtonBackgroundPressed,
NavigationBarBackground, FocusRoundedCorner, FocusRectangle, FocusCircle,
FocusListItem
}

システム画像アセット

[詳細]
enum ImageScaleType {
Center = 0, Stretch, AspectInside, AspectOutside,
NinePatch
}

画像のスケール

[詳細]
enum | JumpFlipEffectAxis { X = 0, Y }

JumpFlipEffectの回転軸

[詳細]
enum | JumpFlipTransitionSpeed { Fast = 0, Slow }

回転の速度

[詳細]
enum | JumpFlipTransitionRotateDirection { ClockWise = 0, CounterClockWise }

JumpFlipの回転方向

[詳細]
enum KeyEventType {
Up = 0, Down, LongPress, Repeat,
EachFrameRepeat, Cancel
}

キーイベントの種別

[詳細]
enum KeyType {
None = 0, Left, Up, Right,
Down, Enter, Back, Square,
Triangle, Start, Select, L,
R
}

キーの種別

[詳細]
enum | HorizontalAlignment { Left = 0, Center, Right }

水平方向のアラインメント

[詳細]
enum | VerticalAlignment { Top = 0, Middle, Bottom }

垂直方向のアラインメント

[詳細]
enum TextTrimming {
None = 0, Character, Word, EllipsisCharacter,
EllipsisWord
}

文字列のトリミング方法

[詳細]
enum | LineBreak { Character = 0, Word, Hyphenation, AtCode }

文字列の改行方法

[詳細]
enum SpringType {
AngleAxisX = 0, AngleAxisY = 1, AngleAxisZ = 2, PositionX = 3,
PositionY = 4, PositionZ = 5, All = 6
}

LiveSpringPanelのバネの種類

[詳細]
enum | MessageDialogStyle { Ok = 0, OkCancel }

メッセージダイアログの種類

[詳細]
enum | MessageDialogResult { Ok = 0, Cancel }

メッセージダイアログのボタンの種別

[詳細]
enum MoveEffectInterpolator {
Linear = 0, EaseOutQuad, Overshoot, Elastic,
Custom
}

MoveEffect用の補間関数

[詳細]
enum | PressState { Normal = 0, Pressed = 1, Disabled = 2 }

プレス状態

[詳細]
enum PressStateChangedReason {
TouchDown, TouchLeave, TouchEnter, TouchUp,
KeyDown, KeyUp, Cancel, ChangePressStateProperty,
ChangeEnabledProperty
}

プレス状態の変更理由

[詳細]
enum | PressStateTouchLeaveBehavior { ResumeByTouchEnter = 0, KeepPressed, End }

タッチが領域の内側から外側に移動した場合のプレス状態の挙動

[詳細]
enum | ProgressBarStyle { Normal = 0, Animation }

プログレスバーの種類

[詳細]
enum PushTransitionInterpolator {
Linear = 0, EaseOutQuad, Overshoot, Elastic,
Custom
}

補間関数

[詳細]
enum | ScrollBarOrientation { Horizontal = 0, Vertical }

スクロールバーの方向

[詳細]
enum | ScrollBarVisibility { Visible = 0, ScrollableVisible, ScrollingVisible, Invisible }

スクロールバーの見え方

[詳細]
enum | ShaderType { SolidFill = 0, Texture = 1, TextTexture = 2, OffscreenTexture = ShaderType.Texture }

シェーダープログラムの種類

[詳細]
enum InternalShaderType {
SolidFill = 0, TextureRgba = 1, TextureAlpha = 2, PremultipliedTexture = 3,
TextureAlphaShadow = 4, LiveScrollPanel = 5, LiveSphere = 6, _count
}
enum SlideInEffectInterpolator {
Linear = 0, EaseOutQuad, Overshoot, Elastic,
Custom
}

SlideInEffect用の補間関数

[詳細]
enum SlideOutEffectInterpolator {
Linear = 0, EaseOutQuad, Overshoot, Elastic,
Custom
}

SlideOutEffect用の補間関数

[詳細]
enum | SliderOrientation { Horizontal = 0, Vertical }

スライダーの方向

[詳細]
enum | MoveTarget { NextScene = 0, CurrentScene }

動作対象のシーン

[詳細]
enum SlideTransitionInterpolator {
Linear = 0, EaseOutQuad, Overshoot, Elastic,
Custom
}

補間関数

[詳細]
enum TouchEventType {
Up = 0, Down, Move, Enter,
Leave, None
}

タッチイベントの種別

[詳細]
enum | TransitionUpdateResponse { Continue = 0, Finish }

トランジションの更新の応答

[詳細]
enum | BlendMode { Half = 0, Add, Premultiplied, Off }

ブレンドモード

[詳細]
enum TransitionDrawOrder {
CurrentScene = 0, NextScene, TransitionUIElement, CS_NS,
CS_TE, NS_CS, NS_TE, TE_CS,
TE_NS, CS_NS_TE, CS_TE_NS, NS_CS_TE,
NS_TE_CS, TE_CS_NS, TE_NS_CS
}

トランジション中の描画順序

[詳細]
enum | LayoutOrientation { Horizontal = 0, Vertical }

レイアウトの方向

[詳細]
enum PivotType {
TopLeft = 0x00, TopCenter = 0x01, TopRight = 0x02, MiddleLeft = 0x10,
MiddleCenter = 0x11, MiddleRight = 0x12, BottomLeft = 0x20, BottomCenter = 0x21,
BottomRight = 0x22
}

ピボットの種別

[詳細]
enum Anchors {
None = 0x00, Top = 0x01, Bottom = 0x02, Height = 0x04,
Left = 0x10, Right = 0x20, Width = 0x40
}

アンカーの種別

[詳細]
enum ZoomEffectInterpolator {
Linear = 0, EaseOutQuad, Overshoot, Elastic,
Custom
}

ZoomEffect用の補間関数

[詳細]

関数

delegate float | AnimationInterpolator (float from, float to, float ratio)
Effect、Transition用アニメーション補間関数のデリゲート
delegate ListPanelItem | ListItemCreator ()
アイテムを作成するメソッドのデリゲート
delegate void | ListItemUpdater (ListPanelItem item)
アイテムを更新するメソッドのデリゲート

列挙型

enum Anchors

アンカーの種別

列挙型の値:
None

なし

Top

上固定

Bottom

下固定

Height

高さ固定

Left

左固定

Right

右固定

Width

幅固定

enum BlendMode

ブレンドモード

列挙型の値:
Half

ソースのアルファ成分の乗算によるブレンド

Add

加算によるブレンド

Premultiplied

プリマルチプライドアルファのブレンド

Widget.RenderToTextureにより作成されたテクスチャを描画するための特殊なブレンドモード。

Off

ブレンドを行わない（不透明）

enum ButtonStyle

ボタンの種類

列挙型の値:
Default

デフォルト

Custom

カスタマイズ

enum CheckBoxStyle

チェックボックスの種類

列挙型の値:
CheckBox

チェックボックス

RadioButton

ラジオボタン

Custom

カスタマイズ

enum CrossFadeTransitionInterpolator

補間関数

列挙型の値:
Linear

線形補間

EaseOutQuad

イージング（二次）

Custom

カスタム

enum DialogBackgroundStyle

ダイアログの背景の種類

列挙型の値:
Default

デフォルト

Custom

カスタマイズ

enum DialogResult

ダイアログ結果

列挙型の値:
Ok

OK.

Cancel

キャンセル

この値は、明示的に設定された場合以外に、Backボタンおよびダイアログの外をタッチしてダイアログを閉じた場合に設定されます。

enum DragDirection

DragGestureの判定方向

列挙型の値:
All

全方向判定する

Vertical

垂直方向のみ判定する

Horizontal

水平方向のみ判定する

LimitedVertical

垂直方向のみ判定し、水平方向に移動した場合はその時点で判定を終了する

LimitedHorizontal

水平方向のみ判定し、垂直方向に移動した場合はその時点で判定を終了する

enum EffectUpdateResponse

エフェクトの更新の応答

列挙型の値:
Continue

エフェクトの更新を継続する。

Finish

エフェクトの更新を終了する。

enum FadeInEffectInterpolator

FadeInEffect用の補間関数

列挙型の値:
Linear

線形補間

EaseOutQuad

イージング（二次）

Custom

カスタム

enum FadeOutEffectInterpolator

FadeOutEffect用の補間関数

列挙型の値:
Linear

線形補間

EaseOutQuad

イージング（二次）

Custom

カスタム

enum FlickDirection

フリックの方向

列挙型の値:
All

全方向

Vertical

垂直方向

Horizontal

水平方向

enum FlipBoardEffectInterpolator

FlipBoardEffect用の補間関数の種類

列挙型の値:
Default

線形補間

Custom

カスタム

enum FlipBoardTransitionInterpolator

FlipBoardTransition用の補間関数の種類

列挙型の値:
Default

線形補間

Custom

カスタム

enum FocusStyle

フォーカスの表示スタイル

列挙型の値:
RoundedCorner

角が丸い四角形

Rectangle

四角形

Circle

円形

ListItem

リストアイテム

None

表示しない

enum FourWayDirection

上下左右の４つ方向

エフェクトの移動方向などに使用される。

列挙型の値:
Up

上方向

Down

下方向

Left

左方向

Right

右方向

enum GestureDetectorResponse

GestureDetectorのタッチイベント配信応答

列挙型の値:
None

初期状態

Systemで設定する値なのでOnTouchEventの戻り値では使用しないこと。OnTouchEventの戻り値で使用した場合はFailedAndStopと同じ扱いとする。

UndetectedAndContinue

ジェスチャ未検出。タッチイベント配信は継続。

DetectedAndContinue

ジェスチャ検出済。タッチイベント配信は継続。

DetectedAndStop

ジェスチャ検出済。タッチイベント配信は終了。

FailedAndStop

ジェスチャ検出失敗。タッチイベント配信は終了。

enum GridListScrollOrientation

スクロール方向

列挙型の値:
Horizontal

水平方向

Vertical

垂直方向

enum HorizontalAlignment

水平方向のアラインメント

列挙型の値:
Left

左揃え

Center

中央揃え

Right

右揃え

enum ImageScaleType

画像のスケール

列挙型の値:
Center

スケールなしで画像を中央に表示する。

Stretch

アスペクト比を無視して埋める。

AspectInside

アスペクト比固定で内側に接する。

AspectOutside

アスペクト固定で外側に接する。

NinePatch

９パッチでスケーリングする。

enum InternalShaderType
列挙型の値:
SolidFill

単色塗り

TextureRgba

テクスチャ描画

TextureAlpha

テキスト描画

PremultipliedTexture

オフスクリーンテクスチャの描画（RenderToTextureで描画したテクスチャ）

TextureAlphaShadow

影付きのテキスト描画

LiveScrollPanel

LiveScrollPanel専用

LiveSphere

LiveSphere専用

_count

dummy

enum JumpFlipEffectAxis

JumpFlipEffectの回転軸

列挙型の値:
X

X軸

Y

Y軸

enum JumpFlipTransitionRotateDirection

JumpFlipの回転方向

列挙型の値:
ClockWise

時計回り

CounterClockWise

反時計回り

enum JumpFlipTransitionSpeed

回転の速度

列挙型の値:
Fast

高速

Slow

低速

enum KeyEventType

キーイベントの種別

列挙型の値:
Up

離された

Down

押された

LongPress

長押し

Repeat

連続押し

EachFrameRepeat

毎フレームごとのリピート

Cancel

キャンセル

enum KeyType

キーの種別

列挙型の値:
None

None.

Left

方向キーの左

Up

方向キーの上

Right

方向キーの右

Down

方向キーの下

Enter

Enter ボタン

○または×ボタン

Back

Back ボタン

○または×ボタン

Square

□ ボタン

Triangle

△ ボタン

Start

STARTボタン

Select

SELECTボタン

L

L ボタン

R

R ボタン

enum LayoutOrientation

レイアウトの方向

列挙型の値:
Horizontal

水平方向

Vertical

垂直方向

enum LineBreak

文字列の改行方法

列挙型の値:
Character

文字単位

Word

単語単位

Hyphenation

文字単位でハイフンを入れる。

AtCode

改行文字で改行する。

enum MessageDialogResult

メッセージダイアログのボタンの種別

列挙型の値:
Ok

OKボタン

Cancel

Cancelボタン

enum MessageDialogStyle

メッセージダイアログの種類

列挙型の値:
Ok

OKボタンのメッセージダイアログ

OkCancel

OK・Cancelボタンのメッセージダイアログ

enum MoveEffectInterpolator

MoveEffect用の補間関数

列挙型の値:
Linear

線形補間

EaseOutQuad

イージング（二次）

Overshoot

オーバーシュート

Elastic

振動

Custom

カスタム

enum MoveTarget

動作対象のシーン

列挙型の値:
NextScene

次のシーン

CurrentScene

現在のシーン

enum PivotType

ピボットの種別

列挙型の値:
TopLeft

左上

TopCenter

上

TopRight

右上

MiddleLeft

左

MiddleCenter

中央

MiddleRight

右

BottomLeft

左下

BottomCenter

下

BottomRight

右下

enum PressState

プレス状態

列挙型の値:
Normal

通常

Pressed

プレス

Disabled

無効

enum PressStateChangedReason

プレス状態の変更理由

列挙型の値:
TouchDown

タッチダウン

TouchLeave

タッチが領域の内側から外側に移動した

TouchEnter

タッチが領域の外側から内側に移動した

TouchUp

タッチアップ

KeyDown

キーダウン

KeyUp

キーアップ

Cancel

キャンセルされた、または ResetState が呼ばれた

ChangePressStateProperty

PressStateプロパティが変更された

ChangeEnabledProperty

Enabledプロパティが変更された

enum PressStateTouchLeaveBehavior

タッチが領域の内側から外側に移動した場合のプレス状態の挙動

列挙型の値:
ResumeByTouchEnter

指が範囲外にでるとNormalになるが、指を離さずに範囲外に戻るとまたPress状態に戻る

KeepPressed

指が範囲外にドラッグされてもPress状態を維持する

End

指が一度範囲外にでるとNormalになり、再タッチするまでPress状態にはならない

enum ProgressBarStyle

プログレスバーの種類

列挙型の値:
Normal

標準

Animation

アニメーションつき

enum PushTransitionInterpolator

補間関数

列挙型の値:
Linear

線形補間

EaseOutQuad

イージング（二次）

Overshoot

オーバーシュート

Elastic

振動

Custom

カスタム

enum ScrollBarOrientation

スクロールバーの方向

列挙型の値:
Horizontal

水平方向

Vertical

垂直方向

enum ScrollBarVisibility

スクロールバーの見え方

列挙型の値:
Visible

常に表示

ScrollableVisible

スクロールできるなら表示

ScrollingVisible

スクロール中のみ表示

Invisible

常に非表示

enum ShaderType

シェーダープログラムの種類

列挙型の値:
SolidFill

単色塗り、または頂点カラーの描画

Texture

通常のテクスチャ描画 (RGBAフォーマットのテクスチャ)

TextTexture

テキストの描画 (Alphaフォーマットのテクスチャ)

OffscreenTexture

オフスクリーンテクスチャの描画（RenderToTextureで描画したテクスチャ）

enum SlideInEffectInterpolator

SlideInEffect用の補間関数

列挙型の値:
Linear

線形補間

EaseOutQuad

イージング（二次）

Overshoot

オーバーシュート

Elastic

振動

Custom

カスタム

enum SlideOutEffectInterpolator

SlideOutEffect用の補間関数

列挙型の値:
Linear

線形補間

EaseOutQuad

イージング（二次）

Overshoot

オーバーシュート

Elastic

振動

Custom

カスタム

enum SliderOrientation

スライダーの方向

列挙型の値:
Horizontal

水平方向

Vertical

垂直方向

enum SlideTransitionInterpolator

補間関数

列挙型の値:
Linear

線形補間

EaseOutQuad

イージング（二次）

Overshoot

オーバーシュート

Elastic

振動

Custom

カスタム

enum SpringType

LiveSpringPanelのバネの種類

列挙型の値:
AngleAxisX

X軸回転に作用するバネ

AngleAxisY

Y軸回転に作用するバネ

AngleAxisZ

Z軸回転に作用するバネ

PositionX

X軸方向の移動に作用するバネ

PositionY

Y軸方向の移動に作用するバネ

PositionZ

Z軸方向の移動に作用するバネ

All

すべてのバネ

enum SystemImageAsset

システム画像アセット

列挙型の値:
ButtonBackgroundNormal

通常時のボタン

ButtonBackgroundPressed

押下時のボタン

ButtonBackgroundDisabled

無効時のボタン

CheckBoxCheckedNormal

通常時のチェックボックス（チェック状態）

CheckBoxUncheckedNormal

通常時のチェックボックス（未チェック状態）

CheckBoxCheckedPressed

押下時のチェックボックス（チェック状態）

CheckBoxUncheckedPressed

押下時のチェックボックス（未チェック状態）

CheckBoxCheckedDisabled

無効時のチェックボックス（チェック状態）

CheckBoxUncheckedDisabled

無効時のチェックボックス（未チェック状態）

RadioButtonCheckedNormal

通常時のラジオボタン（選択状態）

RadioButtonUncheckedNormal

通常時のラジオボタン（未選択状態）

RadioButtonCheckedPressed

押下時のラジオボタン（選択状態）

RadioButtonUncheckedPressed

押下時のラジオボタン（未選択状態）

RadioButtonCheckedDisabled

無効時のラジオボタン（選択状態）

RadioButtonUncheckedDisabled

無効時のラジオボタン（未選択状態）

SliderHorizontalBaseNormal

有効時のスライダーのベース（水平方向）

SliderHorizontalBaseDisabled

無効時のスライダーのベース（水平方向）

SliderHorizontalBarNormal

有効時のスライダーのバー（水平方向）

SliderHorizontalBarDisabled

無効時のスライダーのバー（水平方向）

SliderHorizontalHandleNormal

通常時のスライダーのハンドル（水平方向）

SliderHorizontalHandlePressed

押下時のスライダーのハンドル（水平方向）

SliderHorizontalHandleDisabled

無効時のスライダーのハンドル（水平方向）

SliderVerticalBaseNormal

有効時のスライダーのベース（垂直方向）

SliderVerticalBaseDisabled

無効時のスライダーのベース（垂直方向）

SliderVerticalBarNormal

有効時のスライダーのバー（垂直方向）

SliderVerticalBarDisabled

無効時のスライダーのバー（垂直方向）

SliderVerticalHandleNormal

通常時のスライダーのハンドル（垂直方向）

SliderVerticalHandlePressed

押下時のスライダーのハンドル（垂直方向）

SliderVerticalHandleDisabled

無効時のスライダーのハンドル（垂直方向）

ProgressBarBase

プログレスバーのベース

ProgressBarNormal

標準のプログレスバー

ProgressBarAccelerator

アニメーション付きのプログレスバー

ScrollBarHorizontalBackground

スクロールバーの背景（水平方向）

ScrollBarHorizontalBar

スクロールバー（水平方向）

ScrollBarVerticalBackground

スクロールバーの背景（垂直方向）

ScrollBarVerticalBar

スクロールバー（垂直方向）

EditableTextBackgroundNormal

有効時のエディットテキストの背景

EditableTextBackgroundDisabled

無効時のエディットテキストの背景

BusyIndicator

ビジーインジケータ

DialogBackground

ダイアログの背景

PagePanelNormal

非表示中のページパネルのページ

PagePanelActive

表示中のページパネルのページ

ListPanelSeparatorTop

リストアイテムのセパレータ（上端）

ListPanelSeparatorBottom

リストアイテムのセパレータ（下端）

ListPanelSectionSeparator

セクション

MessageDialogBackground

メッセージダイアログの背景

MessageDialogSeparator

メッセージダイアログのセパレータ

SpinBoxBase

スピンボックスの背景

SpinBoxCenter

スピンボックスの中央

PopupListBackgroundNormal

通常時のポップアップリストの背景

PopupListBackgroundPressed

押下時のポップアップリストの背景

PopupListBackgroundDisabled

無効時のポップアップリストの背景

PopupListItemFocus

ポップアップリストの項目のフォーカス

BackButtonBackgroundNormal

通常時のバックボタン

BackButtonBackgroundDisabled

無効時のバックボタン

BackButtonBackgroundPressed

押下時のバックボタン

NavigationBarBackground

ナビゲーションバーの背景

FocusRoundedCorner

角が丸い四角形のフォーカス

FocusRectangle

四角形のフォーカス

FocusCircle

円形のフォーカス

FocusListItem

リストアイテムのフォーカス

enum TextTrimming

文字列のトリミング方法

列挙型の値:
None

トリミングなし（文字の途中で切る）

Character

文字単位でトリミング

Word

単語単位でトリミング

EllipsisCharacter

文字単位でトリミングして省略記号（...）を挿入

EllipsisWord

単語単位でトリミングして省略記号（...）を挿入

enum TouchEventType

タッチイベントの種別

列挙型の値:
Up

離された

Down

押された

Move

移動した

Enter

領域の外側から内側に移動した

Leave

領域の内側から外側に移動した

None

無効

enum TransitionDrawOrder

トランジション中の描画順序

列挙型の値:
CurrentScene

CurrentSceneのみを描画する。

NextScene

NextSceneのみを描画する。

TransitionUIElement

TransitionUIElementのみを描画する。

CS_NS

CurrentScene、NextSceneの順に描画する。

CS_TE

CurrentScene、TransitionUIElementの順に描画する。

NS_CS

NextScene、CurrentSceneの順に描画する。

NS_TE

NextScene、TransitionUIElementの順に描画する。

TE_CS

TransitionUIElement、CurrentSceneの順に描画する。

TE_NS

TransitionUIElement、NextSceneの順に描画する。

CS_NS_TE

CurrentScene、NextScene、TransitionUIElementの順に描画する。

CS_TE_NS

CurrentScene、TransitionUIElement、NextSceneの順に描画する。

NS_CS_TE

NextScene、CurrentScene、TransitionUIElementの順に描画する。

NS_TE_CS

NextScene、TransitionUIElement、CurrentSceneの順に描画する。

TE_CS_NS

TransitionUIElement、CurrentScene、NextSceneの順に描画する。

TE_NS_CS

TransitionUIElement、NextScene、CurrentSceneの順に描画する。

enum TransitionUpdateResponse

トランジションの更新の応答

列挙型の値:
Continue

トランジションの更新を継続する。

Finish

トランジションの更新を終了する。

enum VerticalAlignment

垂直方向のアラインメント

列挙型の値:
Top

上揃え

Middle

中央揃え

Bottom

下揃え

enum ZoomEffectInterpolator

ZoomEffect用の補間関数

列挙型の値:
Linear

線形補間

EaseOutQuad

イージング（二次）

Overshoot

オーバーシュート

Elastic

振動

Custom

カスタム

関数

delegate float Sce.PlayStation.HighLevel.UI.AnimationInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  |

Effect、Transition用アニメーション補間関数のデリゲート

開始値(from)から終了値(to)までを割合(ratio)を用いて補間する。戻り値は、ratio = 0のときfrom、ratio = 1のときtoである必要がある。ただし、0 < ratio < 1では戻り値が必ずしもfromからtoの間に収まっている必要はない。

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
delegate ListPanelItem Sce.PlayStation.HighLevel.UI.ListItemCreator ( )

アイテムを作成するメソッドのデリゲート

戻り値:
アイテム
delegate void Sce.PlayStation.HighLevel.UI.ListItemUpdater ( ListPanelItem item )

アイテムを更新するメソッドのデリゲート

引数:
item アイテム


クラス AnimationImageBox

画像切り替えによるアニメーションの表示ウィジェット [詳細]

AnimationImageBoxに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

AnimationImageBox ()
コンストラクタ
void | Start ()
アニメーションを開始する。
void | Stop ()
アニメーションを停止する。

Protected メソッド

override void | OnUpdate (float elapsedTime)
更新処理
internal override void | Render ()
シーングラフを描画する。

プロパティ

int | FrameWidth [get, set]
１フレームあたりの画像の幅を取得・設定する。
int | FrameHeight [get, set]
１フレームあたりの画像の高さを取得・設定する。
int | FrameCount [get, set]
フレームの総数を取得・設定する。
float | FrameInterval [get, set]
フレーム更新間隔を取得・設定する。（ミリ秒）
ImageAsset | Image [get, set]
画像を取得・設定する。

説明

画像切り替えによるアニメーションの表示ウィジェット

メソッド

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

プロパティ

ImageAsset Image [get, set]

画像を取得・設定する。

画像はフレーム順に「左から右へ」「上から下へ」並べて指定する。２次元で並べる場合は横方向優先とする。


  • Sce
  • PlayStation
  • HighLevel
  • UI
  • AnimationUtility
Static Public メソッド

クラス AnimationUtility

アニメーション用のユーティリティ [詳細]

すべてのメンバ一覧

Static Public メソッド

static float | LinearInterpolator (float from, float to, float ratio)
線形補間関数
static float | EaseInQuadInterpolator (float from, float to, float ratio)
二次関数によるイーズイン補間
static float | EaseOutQuadInterpolator (float from, float to, float ratio)
二次関数によるイーズアウト補間
static float | EaseInOutQuadInterpolator (float from, float to, float ratio)
二次関数によるイーズインアウト補間
static float | EaseOutInQuadInterpolator (float from, float to, float ratio)
二次関数によるイーズアウトイン補間
static float | EaseInCubicInterpolator (float from, float to, float ratio)
三次関数によるイーズイン補間
static float | EaseOutCubicInterpolator (float from, float to, float ratio)
三次関数によるイーズアウト補間
static float | EaseInOutCubicInterpolator (float from, float to, float ratio)
三次関数によるイーズインアウト補間
static float | EaseOutInCubicInterpolator (float from, float to, float ratio)
三次関数によるイーズアウトイン補間
static float | EaseInQuartInterpolator (float from, float to, float ratio)
四次関数によるイーズイン補間
static float | EaseOutQuartInterpolator (float from, float to, float ratio)
四次関数によるイーズアウト補間
static float | EaseInOutQuartInterpolator (float from, float to, float ratio)
四次関数によるイーズインアウト補間
static float | EaseOutInQuartInterpolator (float from, float to, float ratio)
四次関数によるイーズアウトイン補間
static float | EaseInQuintInterpolator (float from, float to, float ratio)
五次関数によるイーズイン補間
static float | EaseOutQuintInterpolator (float from, float to, float ratio)
五次関数によるイーズアウト補間
static float | EaseInOutQuintInterpolator (float from, float to, float ratio)
五次関数によるイーズインアウト補間
static float | EaseOutInQuintInterpolator (float from, float to, float ratio)
五次関数によるイーズアウトイン補間
static float | EaseInSineInterpolator (float from, float to, float ratio)
サイン関数によるイーズイン補間
static float | EaseOutSineInterpolator (float from, float to, float ratio)
サイン関数によるイーズアウト補間
static float | EaseInOutSineInterpolator (float from, float to, float ratio)
サイン関数によるイーズインアウト補間
static float | EaseOutInSineInterpolator (float from, float to, float ratio)
サイン関数によるイーズアウトイン補間
static float | EaseInExpoInterpolator (float from, float to, float ratio)
累乗関数によるイーズイン補間
static float | EaseOutExpoInterpolator (float from, float to, float ratio)
累乗関数によるイーズアウト補間
static float | EaseInOutExpoInterpolator (float from, float to, float ratio)
累乗関数によるイーズインアウト補間
static float | EaseOutInExpoInterpolator (float from, float to, float ratio)
累乗関数によるイーズアウトイン補間
static float | EaseInCircInterpolator (float from, float to, float ratio)
円関数によるイーズイン補間
static float | EaseOutCircInterpolator (float from, float to, float ratio)
円関数によるイーズアウト補間
static float | EaseInOutCircInterpolator (float from, float to, float ratio)
円関数によるイーズインアウト補間
static float | EaseOutInCircInterpolator (float from, float to, float ratio)
円関数によるイーズアウトイン補間
static float | ElasticInterpolator (float from, float to, float ratio)
弾性(Elastic)関数による補間
static float | UndershootInterpolator (float from, float to, float ratio)
アンダーシュート関数による補間
static float | OvershootInterpolator (float from, float to, float ratio)
オーバーシュート関数による補間
static float | BounceInterpolator (float from, float to, float ratio)
跳ね返り(Bounce)関数による補間
static float | FlipBounceInterpolator (float from, float to, float ratio)
FlipBoardの標準的な補間関数

説明

アニメーション用のユーティリティ

EffectおよびTransitionに使用できるアニメーション補間関数

メソッド

static float BounceInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

跳ね返り(Bounce)関数による補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInCircInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

円関数によるイーズイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInCubicInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

三次関数によるイーズイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInExpoInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

累乗関数によるイーズイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInOutCircInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

円関数によるイーズインアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInOutCubicInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

三次関数によるイーズインアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInOutExpoInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

累乗関数によるイーズインアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInOutQuadInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

二次関数によるイーズインアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInOutQuartInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

四次関数によるイーズインアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInOutQuintInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

五次関数によるイーズインアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInOutSineInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

サイン関数によるイーズインアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInQuadInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

二次関数によるイーズイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInQuartInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

四次関数によるイーズイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInQuintInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

五次関数によるイーズイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseInSineInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

サイン関数によるイーズイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutCircInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

円関数によるイーズアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutCubicInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

三次関数によるイーズアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutExpoInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

累乗関数によるイーズアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutInCircInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

円関数によるイーズアウトイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutInCubicInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

三次関数によるイーズアウトイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutInExpoInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

累乗関数によるイーズアウトイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutInQuadInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

二次関数によるイーズアウトイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutInQuartInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

四次関数によるイーズアウトイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutInQuintInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

五次関数によるイーズアウトイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutInSineInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

サイン関数によるイーズアウトイン補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutQuadInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

二次関数によるイーズアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutQuartInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

四次関数によるイーズアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float EaseOutQuintInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

五次関数によるイーズアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合(0.0f～1.0f)
戻り値:
補間結果
static float EaseOutSineInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

サイン関数によるイーズアウト補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float ElasticInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

弾性(Elastic)関数による補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float FlipBounceInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

FlipBoardの標準的な補間関数

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float LinearInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

線形補間関数

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float OvershootInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

オーバーシュート関数による補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果
static float UndershootInterpolator | ( | float | from,
 |  | float | to,
 |  | float | ratio
 | ) |  | [static]

アンダーシュート関数による補間

引数:
from | 開始値
to | 終了値
ratio | 割合（０～１）
戻り値:
補間結果


クラス BunjeeJumpEffect

ウィジェットが上から落ちてきて少し跳ねて止まるエフェクト [詳細]

BunjeeJumpEffectに対する継承グラフ
Effect

すべてのメンバ一覧

Public メソッド

BunjeeJumpEffect ()
コンストラクタ
BunjeeJumpEffect (Widget widget, float elasticity)
コンストラクタ

Static Public メソッド

static BunjeeJumpEffect | CreateAndStart (Widget widget, float elasticity)
インスタンスを作成しエフェクトを開始する。

Protected メソッド

override void | OnStart ()
開始処理
override EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | Elasticity [get, set]
弾性率を取得・設定する。（０～１）

説明

ウィジェットが上から落ちてきて少し跳ねて止まるエフェクト

"Little Big Planet"のメニュー画面風エフェクト

コンストラクタとデストラクタ

BunjeeJumpEffect | ( | Widget | widget,
 |  | float | elasticity
 | ) |  |

コンストラクタ

引数:
widget | エフェクト対象のウィジェット
elasticity | 弾性率（０～１）

メソッド

static BunjeeJumpEffect CreateAndStart | ( | Widget | widget,
 |  | float | elasticity
 | ) |  | [static]

インスタンスを作成しエフェクトを開始する。

引数:
widget | エフェクト対象のウィジェット
elasticity | 弾性率（０～１）
戻り値:
エフェクトのインスタンス
override EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
エフェクトの更新の応答

Effectを実装しています。


クラス BusyIndicator

進行状況を表示するウィジェット [詳細]

BusyIndicatorに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

BusyIndicator ()
コンストラクタ
BusyIndicator (bool autoStart)
コンストラクタ
void | Start ()
アニメーションを開始する。
void | Stop ()
アニメーションを停止する。

Protected メソッド

override void | DisposeSelf ()
使用されているリソースを解放する。

プロパティ

override float | Width [get, set]
幅を取得する。
override float | Height [get, set]
高さを取得する。

説明

進行状況を表示するウィジェット

コンストラクタとデストラクタ

BusyIndicator ( bool autoStart )

コンストラクタ

引数:
autoStart 初期化直後にアニメーションを開始するかどうか。初期値はFalse。

プロパティ

override float Height [get, set]

高さを取得する。

設定された値は無視される。

Widgetを再定義しています。

override float Width [get, set]

幅を取得する。

設定された値は無視される。

Widgetを再定義しています。


クラス Button

ボタンウィジェット [詳細]

Buttonに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

Button ()
コンストラクタ

Protected メソッド

override void | OnPressStateChanged (PressStateChangedEventArgs e)
プレス状態が変化したときに呼び出される
override void | DisposeSelf ()
使用されているリソースを解放する。
override void | OnUpdate (float elapsedTime)
更新処理

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
string | Text [get, set]
文字列を取得・設定する。
ButtonStyle | Style [get, set]
ボタンの種類を取得・設定する。
ImageAsset | IconImage [get, set]
アイコン画像を取得・設定する。
UIFont | TextFont [get, set]
文字列のフォントを取得・設定する。
TextTrimming | TextTrimming [get, set]
文字列のトリミング方法を取得・設定する。
UIColor | TextColor [get, set]
文字列の色を取得・設定する。
TextShadowSettings | TextShadow [get, set]
文字列の影を取得・設定する。
HorizontalAlignment | HorizontalAlignment [get, set]
文字列またはアイコン画像の水平方向のアライメントを取得・設定する。
VerticalAlignment | VerticalAlignment [get, set]
文字列またはアイコン画像の垂直方向のアライメントを取得・設定する。
CustomButtonImageSettings | CustomImage [get, set]
カスタマイズ画像を取得・設定する。
UIColor | BackgroundFilterColor [get, set]
背景画像に乗算する色を取得・設定する。

イベント

EventHandler< TouchEventArgs > | ButtonAction
ボタンアクション発火時に呼び出されるハンドラ

説明

ボタンウィジェット

アイコン画像と１行テキストを設定することが可能。形状のカスタマイズが可能。

メソッド

override void OnPressStateChanged ( PressStateChangedEventArgs e ) [protected, virtual]

プレス状態が変化したときに呼び出される

引数:
e イベント引数

Widgetを再定義しています。

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

プロパティ

ImageAsset IconImage [get, set]

アイコン画像を取得・設定する。

nullが設定された場合、設定されている文字列を表示する。


クラス CheckBox

チェックボックスウィジェット [詳細]

CheckBoxに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

CheckBox ()
コンストラクタ

Protected メソッド

override void | OnPressStateChanged (PressStateChangedEventArgs e)
プレス状態が変化したときに呼び出される
override void | DisposeSelf ()
使用されているリソースを解放する。
internal override void | Render ()
シーングラフを描画する。

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
bool | Checked [get, set]
チェックの状態を取得・設定する。
CheckBoxStyle | Style [get, set]
チェックボックスの種類を取得・設定する。
CustomCheckBoxImageSettings | CustomCheckBoxImage [get, set]
カスタマイズ画像を取得・設定する。

イベント

EventHandler< TouchEventArgs > | CheckedChanged
チェックの状態が変化したときに呼ばれるハンドラ

説明

チェックボックスウィジェット

形状のカスタマイズが可能。

メソッド

override void OnPressStateChanged ( PressStateChangedEventArgs e ) [protected, virtual]

プレス状態が変化したときに呼び出される

引数:
e イベント引数

Widgetを再定義しています。


クラス ContainerWidget

コンテナ機能を持つウィジェット [詳細]

ContainerWidgetに対する継承グラフ
Widget Dialog GridListPanel ListPanel LiveScrollPanel Panel RootWidget ScrollPanel MessageDialog ListPanelItem LiveJumpPanel LiveSpringPanel UIAnimationPlayer

すべてのメンバ一覧

Public メソッド

ContainerWidget ()
コンストラクタ
virtual new void | AddChildFirst (Widget child)
子ウィジェットを先頭に追加する。
virtual new void | AddChildLast (Widget child)
子ウィジェットを末尾に追加する。
virtual new void | InsertChildBefore (Widget child, Widget nextChild)
指定した子ウィジェットの直前に挿入する。
virtual new void | InsertChildAfter (Widget child, Widget prevChild)
指定した子ウィジェットの直後に挿入する。
virtual new void | RemoveChild (Widget child)
指定された子ウィジェットを削除する。

プロパティ

virtual new IEnumerable< Widget > | Children [get]
子ウィジェットを取得する。
bool | EnabledChildrenAnchors [get, set]
子ウィジェットをAnchorsに従ってリサイズするかどうかの値を設定・取得する
override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。

説明

コンテナ機能を持つウィジェット

子ウィジェットを追加することができ、ウィジェットの親子関係を形成することができる。

メソッド

virtual new void AddChildFirst ( Widget child ) [virtual]

子ウィジェットを先頭に追加する。

引数:
child 追加する子ウィジェット

既に追加されている場合は先頭に移動する。

Widgetを再定義しています。

LiveScrollPanel, LiveSpringPanel, と ScrollPanelで再定義されています。

virtual new void AddChildLast ( Widget child ) [virtual]

子ウィジェットを末尾に追加する。

引数:
child 追加する子ウィジェット

既に追加されている場合は末尾に移動する。

Widgetを再定義しています。

LiveScrollPanel, LiveSpringPanel, と ScrollPanelで再定義されています。

virtual new void InsertChildAfter | ( | Widget | child,
 |  | Widget | prevChild
 | ) |  | [virtual]

指定した子ウィジェットの直後に挿入する。

引数:
child | 挿入する子ウィジェット
prevChild | 挿入する子ウィジェットの直前となる子ウィジェット

既に追加されている場合は指定した子ウィジェットの直後に移動する。

Widgetを再定義しています。

LiveScrollPanel, LiveSpringPanel, と ScrollPanelで再定義されています。

virtual new void InsertChildBefore | ( | Widget | child,
 |  | Widget | nextChild
 | ) |  | [virtual]

指定した子ウィジェットの直前に挿入する。

引数:
child | 挿入する子ウィジェット
nextChild | 挿入する子ウィジェットの直後となる子ウィジェット

既に追加されている場合は指定した子ウィジェットの直前に移動する。

Widgetを再定義しています。

LiveScrollPanel, LiveSpringPanel, と ScrollPanelで再定義されています。

virtual new void RemoveChild ( Widget child ) [virtual]

指定された子ウィジェットを削除する。

引数:
child 削除するウィジェット

存在しないウィジェットを指定した場合は何も行われない。

Widgetを再定義しています。

LiveScrollPanel, LiveSpringPanel, と ScrollPanelで再定義されています。

プロパティ

virtual new IEnumerable<Widget> Children [get]

子ウィジェットを取得する。

コレクションを反復処理する列挙子を返す。

Widgetを再定義しています。

LiveScrollPanel, と ScrollPanelで再定義されています。


クラス CrossFadeTransition

クロスフェードトランジション [詳細]

CrossFadeTransitionに対する継承グラフ
Transition

すべてのメンバ一覧

Public メソッド

CrossFadeTransition ()
コンストラクタ
CrossFadeTransition (float time, CrossFadeTransitionInterpolator interpolator)
コンストラクタ

Protected メソッド

override void | OnStart ()
開始処理
override TransitionUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | Time [get, set]
持続時間を取得・設定する。（ミリ秒）
CrossFadeTransitionInterpolator | Interpolator [get, set]
補間関数の種類を取得・設定する。
AnimationInterpolator | CustomNextSceneInterpolator [get, set]
NextScene カスタムの補間関数を設定する。
AnimationInterpolator | CustomCurrentSceneInterpolator [get, set]
CurrentScene のカスタム補間関数を設定する。
bool | NextSceneFront [get, set]
NextScene を前面に表示するかどうかを取得・設定する。

説明

クロスフェードトランジション

古いシーンの上で、新しいシーンが透明から不透明へと変化する。

コンストラクタとデストラクタ

CrossFadeTransition | ( | float | time,
 |  | CrossFadeTransitionInterpolator | interpolator
 | ) |  |

コンストラクタ

引数:
time | 持続時間（ミリ秒）
interpolator | 補間関数

メソッド

override TransitionUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
トランジションの更新の応答

Transitionを実装しています。


クラス CustomButtonImageSettings

ボタンのカスタマイズ画像の設定情報 [詳細]

すべてのメンバ一覧

Public メソッド

CustomButtonImageSettings ()
コンストラクタ

プロパティ

ImageAsset | BackgroundNormalImage [get, set]
通常時の背景のカスタマイズ画像を取得・設定する。
ImageAsset | BackgroundPressedImage [get, set]
押下時の背景のカスタマイズ画像を取得・設定する。
ImageAsset | BackgroundDisabledImage [get, set]
無効時の背景のカスタマイズ画像を取得・設定する。
NinePatchMargin | BackgroundNinePatchMargin [get, set]
背景のカスタマイズ画像の９パッチ情報を取得・設定する。

説明

ボタンのカスタマイズ画像の設定情報


クラス CustomCheckBoxImageSettings

カスタマイズ画像の設定情報 [詳細]

すべてのメンバ一覧

Public メソッド

CustomCheckBoxImageSettings ()
コンストラクタ

プロパティ

ImageAsset | NormalUncheckedImage [get, set]
通常時の未チェックのカスタマイズ画像を取得・設定する。
ImageAsset | NormalCheckedImage [get, set]
通常時のチェック済のカスタマイズ画像を取得・設定する。
ImageAsset | PressedUncheckedImage [get, set]
押下時の未チェックのカスタマイズ画像を取得・設定する。
ImageAsset | PressedCheckedImage [get, set]
押下時のチェック済のカスタマイズ画像を取得・設定する。
ImageAsset | DisabledUncheckedImage [get, set]
無効時の未チェックのカスタマイズ画像を取得・設定する。
ImageAsset | DisabledCheckedImage [get, set]
無効時のチェック済のカスタマイズ画像を取得・設定する。

説明

カスタマイズ画像の設定情報


クラス DatePicker

日付を選択するためのウィジェット [詳細]

DatePickerに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

DatePicker ()
コンストラクタ
override bool | HitTest (Vector2 screenPoint)
ヒットテストハンドラ

プロパティ

override float | Width [get, set]
幅を取得する。
override float | Height [get, set]
高さを取得する。
override bool | PriorityHit [get, set]
優先してタッチに反応するかどうかを取得・設定する。
int | MinYear [get, set]
年の最小値を取得・設定する。
int | MaxYear [get, set]
年の最大値を取得・設定する。
int | Year [get, set]
年を取得・設定する。
int | Month [get, set]
月を取得・設定する。
int | Day [get, set]
日を取得・設定する。
DateTime | Date [get, set]
日付をDateTime構造体で取得・設定する。

イベント

EventHandler
< DatePickerValueChangedEventArgs > 		ValueChanged
値が変更されたときに発行されるイベント

説明

日付を選択するためのウィジェット

メソッド

override bool HitTest ( Vector2 screenPoint ) [virtual]

ヒットテストハンドラ

引数:
screenPoint スクリーン座標系での位置
戻り値:
ヒットしている場合はtrue。ヒットしていない場合はfalse。

Widgetを再定義しています。

プロパティ

override float Height [get, set]

高さを取得する。

設定された値は無視される。

Widgetを再定義しています。

override float Width [get, set]

幅を取得する。

設定された値は無視される。

Widgetを再定義しています。


クラス DatePickerValueChangedEventArgs

DatePicker の値が変更されたときのイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

DatePickerValueChangedEventArgs ()
コンストラクタ
override string | ToString ()
文字列を取得する。

プロパティ

int | NewYear [get, set]
今回選択された年
int | NewMonth [get, set]
今回選択された月
int | NewDay [get, set]
今回選択された日
int | OldYear [get, set]
前回選択されていた年
int | OldMonth [get, set]
前回選択されていた月
int | OldDay [get, set]
前回選択されていた日

説明

DatePicker の値が変更されたときのイベント引数

メソッド

override string ToString ( )

文字列を取得する。

戻り値:
変換された文字列


クラス DelayedExecutor

ある時間が経過した後に処理を行うエフェクト [詳細]

DelayedExecutorに対する継承グラフ
Effect

すべてのメンバ一覧

Public メソッド

DelayedExecutor ()
コンストラクタ
DelayedExecutor (float time, Action action)
コンストラクタ

Static Public メソッド

static DelayedExecutor | CreateAndStart (float time, Action action)
インスタンスを作成しエフェクトを開始する。

Protected メソッド

override void | OnStart ()
開始処理
override EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | Time [get, set]
遅延時間を取得・設定する。（ミリ秒）
Action | Action [get, set]
動作させる処理のデリゲートを取得・設定する。

説明

ある時間が経過した後に処理を行うエフェクト

コンストラクタとデストラクタ

DelayedExecutor | ( | float | time,
 |  | Action | action
 | ) |  |

コンストラクタ

引数:
time | 遅延時間（ミリ秒）
action | 動作させる処理

メソッド

static DelayedExecutor CreateAndStart | ( | float | time,
 |  | Action | action
 | ) |  | [static]

インスタンスを作成しエフェクトを開始する。

引数:
time | 遅延時間（ミリ秒）
action | 動作させる処理
戻り値:
エフェクトのインスタンス
override EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
エフェクトの更新の応答

Effectを実装しています。

プロパティ

float Time [get, set]

遅延時間を取得・設定する。（ミリ秒）

処理の実行タイミングは、設定した時間が経過した後の最初のフレームになる。0の場合は次のフレームとなる。


クラス Dialog

モーダルダイアログ [詳細]

Dialogに対する継承グラフ
ContainerWidget Widget MessageDialog

すべてのメンバ一覧

Public メソッド

Dialog ()
コンストラクタ
Dialog (Effect showEffect, Effect hideEffect)
コンストラクタ
void | Show ()
ダイアログを表示する。
void | Show (Effect effect)
ダイアログを表示する。
void | Hide ()
ダイアログを非表示にする。
void | Hide (Effect effect)
ダイアログを非表示にする。

Protected メソッド

override void | DisposeSelf ()
使用されているリソースを解放する。
internal override void | Render ()
シーングラフを描画する。

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
Effect | ShowEffect [get, set]
ダイアログを表示するときのエフェクトを取得・設定する。nullの場合はエフェクトを使用しない。
Effect | HideEffect [get, set]
ダイアログを非表示にするときのエフェクトを取得・設定する。nullの場合はエフェクトを使用しない。
DialogBackgroundStyle | BackgroundStyle [get, set]
ダイアログの背景の種類を取得・設定する。
ImageAsset | CustomBackgroundImage [get, set]
ダイアログの背景画像を取得・設定する。
NinePatchMargin | CustomBackgroundNinePatchMargin [get, set]
ダイアログの背景画像の9PatchMarginを取得・設定する。
UIColor | CustomBackgroundColor [get, set]
ダイアログの背景色を取得・設定する。
UIColor | BackgroundFilterColor [get, set]
背景画像に乗算する色を取得・設定する。
bool | HideOnTouchOutside [get, set]
ダイアログの外をタッチされたときにダイアログを閉じるかどうか
Widget | DefaultFocusWidget [get, set]
最初にフォーカスが当たるウィジェット
DialogResult | Result [get, set]
ダイアログ結果を取得・設定する

イベント

EventHandler | Showing
ダイアログが表示されるときに発行するイベント
EventHandler | Shown
ダイアログが表示されたときに発行するイベント
EventHandler< DialogEventArgs > | Hiding
ダイアログが消えるときに発行するイベント
EventHandler< DialogEventArgs > | Hidden
ダイアログが消えたときに発行するイベント

説明

モーダルダイアログ

任意の部品を載せることができる。

メソッド

void Hide ( Effect effect )

ダイアログを非表示にする。

引数:
effect ダイアログを表示する時のエフェクト
void Show ( Effect effect )

ダイアログを表示する。

引数:
effect ダイアログを表示する時のエフェクト

プロパティ

UIColor CustomBackgroundColor [get, set]

ダイアログの背景色を取得・設定する。

BackgroundStyle が Custom の場合のみ有効。

ImageAsset CustomBackgroundImage [get, set]

ダイアログの背景画像を取得・設定する。

BackgroundStyle が Custom の場合のみ有効。nullを設定した場合は背景画像を表示しない。

NinePatchMargin CustomBackgroundNinePatchMargin [get, set]

ダイアログの背景画像の9PatchMarginを取得・設定する。

BackgroundStyle が Custom で CustomBackgroundImage が設定されている場合のみ有効。

Widget DefaultFocusWidget [get, set]

最初にフォーカスが当たるウィジェット

nullの場合は既定のウィジェットになります。

イベント

EventHandler<DialogEventArgs> Hidden

ダイアログが消えたときに発行するイベント

HideEffectが設定されている場合は、Effectが終了したときに発行する。

EventHandler<DialogEventArgs> Hiding

ダイアログが消えるときに発行するイベント

HideEffectが設定されている場合は、Effectが開始される前に発行する。

EventHandler Showing

ダイアログが表示されるときに発行するイベント

ShowEffectが設定されている場合は、Effectが開始される前に発行する。

EventHandler Shown

ダイアログが表示されたときに発行するイベント

ShowEffectが設定されている場合は、Effectが終了したときに発行する。


クラス DialogEventArgs

ダイアログイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

DialogEventArgs (DialogResult result)
コンストラクタ

プロパティ

bool | CancelHide [get, set]
Hide処理をキャンセルするかどうかを設定する
DialogResult | Result [get, set]
ダイアログ結果

説明

ダイアログイベント引数

コンストラクタとデストラクタ

DialogEventArgs ( DialogResult result )

コンストラクタ

引数:
result ダイアログ結果

プロパティ

bool CancelHide [get, set]

Hide処理をキャンセルするかどうかを設定する

Hidingイベントでこのプロパティをtrueにすると、ダイアログの閉じる処理をキャンセルすることができます。 このプロパティは、Hiddenイベントでは無視されます。


クラス DoubleTapEventArgs

ダブルタップイベント引数 [詳細]

DoubleTapEventArgsに対する継承グラフ
GestureEventArgs

すべてのメンバ一覧

Public メソッド

DoubleTapEventArgs (Widget source, Vector2 worldPosition, Vector2 localPosition)
コンストラクタ

プロパティ

Vector2 | WorldPosition [get, set]
ワールド（スクリーン）座標系での位置を取得する。
Vector2 | LocalPosition [get, set]
ローカル座標系での位置を取得する。

説明

ダブルタップイベント引数

コンストラクタとデストラクタ

DoubleTapEventArgs | ( | Widget | source,
 |  | Vector2 | worldPosition,
 |  | Vector2 | localPosition
 | ) |  |

コンストラクタ

引数:
source | イベント発生元ウィジェット
worldPosition | ワールド（スクリーン）座標系での位置
localPosition | ローカル座標系での位置


クラス DoubleTapGestureDetector

ダブルタップ検出器 [詳細]

DoubleTapGestureDetectorに対する継承グラフ
GestureDetector

すべてのメンバ一覧

Public メソッド

DoubleTapGestureDetector ()
コンストラクタ

Protected メソッド

internal override
GestureDetectorResponse 		OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントを配信する。
internal override void | OnResetState ()
ジェスチャ解析の状態をリセットする。

プロパティ

float | MaxDistance [get, set]
最初のdownの位置からの最大許容距離を取得・設定する。
float | MaxPressDuration [get, set]
downからupまでの最大時間を取得・設定する。（ミリ秒）
float | MaxNextPressDuration [get, set]
upからdownまでの最大時間を取得・設定する。（ミリ秒）

イベント

EventHandler< DoubleTapEventArgs > | DoubleTapDetected
ダブルタップイベントハンドラ

説明

ダブルタップ検出器

メソッド

internal override GestureDetectorResponse OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントを配信する。

引数:
touchEvents タッチイベント
戻り値:
タッチイベント配信の応答

GestureDetectorを実装しています。


クラス DragEventArgs

ドラッグイベント引数 [詳細]

DragEventArgsに対する継承グラフ
GestureEventArgs

すべてのメンバ一覧

Public メソッド

DragEventArgs (Widget source, Vector2 worldPosition, Vector2 localPosition, Vector2 distance)
コンストラクタ

プロパティ

Vector2 | WorldPosition [get, set]
ワールド（スクリーン）座標系での位置を取得する。
Vector2 | LocalPosition [get, set]
ローカル座標系での位置を取得する。
Vector2 | Distance [get, set]
前回のイベントからの移動距離（ベクトル）を取得する

説明

ドラッグイベント引数

コンストラクタとデストラクタ

DragEventArgs | ( | Widget | source,
 |  | Vector2 | worldPosition,
 |  | Vector2 | localPosition,
 |  | Vector2 | distance
 | ) |  |

コンストラクタ

引数:
source | イベント発生元ウィジェット
worldPosition | ワールド（スクリーン）座標系での位置
localPosition | ローカル座標系での位置
distance | 移動距離

プロパティ

Vector2 Distance [get, set]

前回のイベントからの移動距離（ベクトル）を取得する

この値は、DragGestureDetector.DetectDirection の値に関係なく、水平垂直両方向の移動距離となります。 DragStartDetectedイベントではタッチダウン位置からの距離、DragDetectedイベントでは1フレーム前のタッチ位置からの距離となります。


クラス DragGestureDetector

ドラッグ検出器 [詳細]

DragGestureDetectorに対する継承グラフ
GestureDetector

すべてのメンバ一覧

Public メソッド

DragGestureDetector ()
コンストラクタ

Protected メソッド

internal override
GestureDetectorResponse 		OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントを配信する。
internal override void | OnResetState ()
ジェスチャ解析の状態をリセットする。

プロパティ

float | MaxDistance [get, set]
最大移動距離を取得・設定する。
DragDirection | Direction [get, set]
ドラッグジェスチャの判定方向を取得・設定する

イベント

EventHandler< DragEventArgs > | DragDetected
ドラッグイベントハンドラ
EventHandler< DragEventArgs > | DragStartDetected
ドラッグ開始のイベントハンドラ
EventHandler< DragEventArgs > | DragEndDetected
ドラッグ終了のイベントハンドラ

説明

ドラッグ検出器

メソッド

internal override GestureDetectorResponse OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントを配信する。

引数:
touchEvents タッチイベント
戻り値:
タッチイベント配信の応答

GestureDetectorを実装しています。

イベント

EventHandler<DragEventArgs> DragDetected

ドラッグイベントハンドラ

初回のDragDetectedイベントはDragStartDetectedイベントの次のフレームから発行されます。 ドラッグ操作が開始すると、タッチアップか他のジェスチャディテクタによって終了させられるまで、移動距離にかかわらず毎フレーム発行します。


クラス EditableText

編集可能なテキストウィジェット [詳細]

EditableTextに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

EditableText ()
コンストラクタ

Protected メソッド

override void | DisposeSelf ()
使用されているリソースを解放する。
override void | OnPressStateChanged (PressStateChangedEventArgs e)
プレス状態が変化したときに呼び出される
override void | OnUpdate (float elapsedTime)
更新処理
internal override void | Render ()
シーングラフを描画する。

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
string | Text [get, set]
文字列を取得・設定する。
UIFont | Font [get, set]
文字列のフォントを取得・設定する。
UIColor | TextColor [get, set]
文字列の色を取得・設定する。
string | DefaultText [get, set]
デフォルトの文字列を取得・設定する。
UIFont | DefaultFont [get, set]
デフォルトの文字列のフォントを取得・設定する。
UIColor | DefaultTextColor [get, set]
デフォルトの文字列の色を取得・設定する。
TextShadowSettings | TextShadow [get, set]
文字列の影を取得・設定する。
HorizontalAlignment | HorizontalAlignment [get, set]
文字列またはアイコン画像の水平方向のアライメントを取得・設定する。
VerticalAlignment | VerticalAlignment [get, set]
文字列またはアイコン画像の垂直方向のアライメントを取得・設定する。
LineBreak | LineBreak [get, set]
文字列の改行方法を取得・設定する。
TextTrimming | TextTrimming [get, set]
文字列のトリミング方法を取得・設定する。
float | LineGap [get, set]
行間を取得・設定する。
TextInputMode | TextInputMode [get, set]
テキスト入力の動作モードを取得・設定する。

イベント

EventHandler
< TextChangedEventArgs > 		TextChanged
Textプロパティが変更された場合に発行するイベント

説明

編集可能なテキストウィジェット

メソッド

override void OnPressStateChanged ( PressStateChangedEventArgs e ) [protected, virtual]

プレス状態が変化したときに呼び出される

引数:
e イベント引数

Widgetを再定義しています。

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

プロパティ

float LineGap [get, set]

行間を取得・設定する。

初期値は０


クラス Effect

ウィジェットまたはエレメントに適用するアニメーションの基底クラス [詳細]

Effectに対する継承グラフ
BunjeeJumpEffect DelayedExecutor FadeInEffect FadeOutEffect FlipBoardEffect JumpFlipEffect MoveEffect SlideInEffect SlideOutEffect TiltDropEffect UIMotion ZoomEffect

すべてのメンバ一覧

Public メソッド

Effect ()
コンストラクタ
void | Start ()
エフェクトを開始する。
void | Stop ()
エフェクトを停止する
void | Pause ()
エフェクトを中断する
void | Resume ()
エフェクトを再開する

Protected メソッド

abstract void | OnStart ()
開始処理
abstract EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
abstract void | OnStop ()
停止処理
virtual void | OnPause ()
中断処理
virtual void | OnResume ()
再開処理
virtual void | OnRepeat ()
リピート処理

プロパティ

float | TotalElapsedTime [get, set]
エフェクトを開始してからの経過時間を取得する。（ミリ秒）
bool | Playing [get, set]
エフェクト中かどうかを取得する。
bool | Paused [get, set]
エフェクトが中断されているかどうかを取得する。
bool | Repeating [get, set]
エフェクトをリピート再生するかどうかを取得・設定する。
Widget | Widget [get, set]
エフェクト対象のウィジェットを取得・設定する。

イベント

EventHandler< EventArgs > | EffectStopped
エフェクトを停止したときに呼び出されるハンドラ

説明

ウィジェットまたはエレメントに適用するアニメーションの基底クラス

メソッド

virtual void OnPause ( ) [protected, virtual]

中断処理

派生クラスで中断処理を実装する。

virtual void OnRepeat ( ) [protected, virtual]

リピート処理

派生クラスでリピート処理を実装する。

UIMotionで再定義されています。

virtual void OnResume ( ) [protected, virtual]

再開処理

派生クラスで再開処理を実装する。

abstract void OnStart ( ) [protected, pure virtual]

開始処理

派生クラスで開始処理を実装する。

BunjeeJumpEffect, DelayedExecutor, FadeInEffect, FadeOutEffect, FlipBoardEffect, JumpFlipEffect, MoveEffect, SlideInEffect, SlideOutEffect, TiltDropEffect, UIMotion, と ZoomEffectで実装されています。

abstract void OnStop ( ) [protected, pure virtual]

停止処理

派生クラスで停止処理を実装する。

BunjeeJumpEffect, DelayedExecutor, FadeInEffect, FadeOutEffect, FlipBoardEffect, JumpFlipEffect, MoveEffect, SlideInEffect, SlideOutEffect, TiltDropEffect, UIMotion, と ZoomEffectで実装されています。

abstract EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, pure virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
エフェクトの更新の応答

派生クラスで更新処理を実装する。

BunjeeJumpEffect, DelayedExecutor, FadeInEffect, FadeOutEffect, FlipBoardEffect, JumpFlipEffect, MoveEffect, SlideInEffect, SlideOutEffect, TiltDropEffect, UIMotion, と ZoomEffectで実装されています。

void Pause ( )

エフェクトを中断する

エフェクトが再生中(Playing==true)でなければ何も行いません。

void Resume ( )

エフェクトを再開する

エフェクトが一時停止中(Paused==true)でなければ何も行いません。

void Start ( )

エフェクトを開始する。

開始中(Playing==true)、一時停止中(Paused==true)は何も行いません。

void Stop ( )

エフェクトを停止する

エフェクトが停止中の場合は何も行いません。 一時停止中の場合は停止させます。

UIMotionで再定義されています。


クラス FadeInEffect

フェードインエフェクト [詳細]

FadeInEffectに対する継承グラフ
Effect

すべてのメンバ一覧

Public メソッド

FadeInEffect ()
コンストラクタ
FadeInEffect (Widget widget, float time, FadeInEffectInterpolator interpolator)
コンストラクタ

Static Public メソッド

static FadeInEffect | CreateAndStart (Widget widget, float time, FadeInEffectInterpolator interpolator)
インスタンスを作成しエフェクトを開始する。

Protected メソッド

override void | OnStart ()
開始処理
override EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | Time [get, set]
持続時間を取得・設定する。（ミリ秒）
FadeInEffectInterpolator | Interpolator [get, set]
補間関数の種類を取得・設定する。
AnimationInterpolator | CustomInterpolator [get, set]
カスタムの補間関数を設定する。

説明

フェードインエフェクト

透明から不透明（設定されているアルファ値）まで変化する。

コンストラクタとデストラクタ

FadeInEffect | ( | Widget | widget,
 |  | float | time,
 |  | FadeInEffectInterpolator | interpolator
 | ) |  |

コンストラクタ

引数:
widget | エフェクトの対象となるウィジェット
time | 持続時間（ミリ秒）
interpolator | 補間関数

メソッド

static FadeInEffect CreateAndStart | ( | Widget | widget,
 |  | float | time,
 |  | FadeInEffectInterpolator | interpolator
 | ) |  | [static]

インスタンスを作成しエフェクトを開始する。

引数:
widget | エフェクト対象のウィジェット
time | 持続時間（ミリ秒）
interpolator | 補間関数
戻り値:
エフェクトのインスタンス
override EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
エフェクトの更新の応答

Effectを実装しています。


クラス FadeOutEffect

フェードアウトエフェクト [詳細]

FadeOutEffectに対する継承グラフ
Effect

すべてのメンバ一覧

Public メソッド

FadeOutEffect ()
コンストラクタ
FadeOutEffect (Widget widget, float time, FadeOutEffectInterpolator interpolator)
コンストラクタ

Static Public メソッド

static FadeOutEffect | CreateAndStart (Widget widget, float time, FadeOutEffectInterpolator interpolator)
インスタンスを作成しエフェクトを開始する。

Protected メソッド

override void | OnStart ()
開始処理
override EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | Time [get, set]
持続時間を取得・設定する。（ミリ秒）
FadeOutEffectInterpolator | Interpolator [get, set]
補間関数の種類を取得・設定する。
AnimationInterpolator | CustomInterpolator [get, set]
カスタムの補間関数を設定する。

説明

フェードアウトエフェクト

不透明（設定されているアルファ値）から透明まで変化する。

コンストラクタとデストラクタ

FadeOutEffect | ( | Widget | widget,
 |  | float | time,
 |  | FadeOutEffectInterpolator | interpolator
 | ) |  |

コンストラクタ

引数:
widget | エフェクトの対象となるウィジェット
time | 持続時間（ミリ秒）
interpolator | 補間関数

メソッド

static FadeOutEffect CreateAndStart | ( | Widget | widget,
 |  | float | time,
 |  | FadeOutEffectInterpolator | interpolator
 | ) |  | [static]

インスタンスを作成しエフェクトを開始する。

引数:
widget | エフェクトの対象となるウィジェット
time | 持続時間（ミリ秒）
interpolator | 補間関数
override EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
エフェクトの更新の応答

Effectを実装しています。


クラス FlickEventArgs

フリックイベント引数 [詳細]

FlickEventArgsに対する継承グラフ
GestureEventArgs

すべてのメンバ一覧

Public メソッド

FlickEventArgs (Widget source, Vector2 worldPosition, Vector2 localPosition, Vector2 flickSpeed)
コンストラクタ

プロパティ

Vector2 | WorldPosition [get, set]
ワールド（スクリーン）座標系での位置を取得する。
Vector2 | LocalPosition [get, set]
ローカル座標系での位置を取得する。
Vector2 | Speed [get, set]
フリックの速度を取得する。（ピクセル/秒）

説明

フリックイベント引数

コンストラクタとデストラクタ

FlickEventArgs | ( | Widget | source,
 |  | Vector2 | worldPosition,
 |  | Vector2 | localPosition,
 |  | Vector2 | flickSpeed
 | ) |  |

コンストラクタ

引数:
source | イベント発生元ウィジェット
worldPosition | ワールド（スクリーン）座標系での位置
localPosition | ローカル座標系での位置
flickSpeed | フリックの速度

プロパティ

Vector2 Speed [get, set]

フリックの速度を取得する。（ピクセル/秒）

この値は、FlickGestureDetector.Direction の値にかかわらず、水平垂直両方向の速度ベクトルとなります。


クラス FlickGestureDetector

フリック検出器 [詳細]

FlickGestureDetectorに対する継承グラフ
GestureDetector

すべてのメンバ一覧

Public メソッド

FlickGestureDetector ()
コンストラクタ

Protected メソッド

internal override
GestureDetectorResponse 		OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントを配信する。
internal override void | OnResetState ()
ジェスチャ解析の状態をリセットする。

プロパティ

float | MinSpeed [get, set]
フリックとして判定する最小速度を取得・設定する。（ピクセル/秒）
float | MaxSpeed [get, set]
フリック速度の最大値を取得・設定する。（ピクセル/秒）
FlickDirection | Direction [get, set]
検出するフリックの方向を取得・設定する。

イベント

EventHandler< FlickEventArgs > | FlickDetected
フリックイベントハンドラ

説明

フリック検出器

メソッド

internal override GestureDetectorResponse OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントを配信する。

引数:
touchEvents タッチイベント
戻り値:
タッチイベント配信の応答

GestureDetectorを実装しています。

プロパティ

float MaxSpeed [get, set]

フリック速度の最大値を取得・設定する。（ピクセル/秒）

FlickDetectedイベント発生時にフリック速度の絶対値がこの値以上であった場合、フリック速度にこの値が設定されます。


クラス FlipBoardEffect

真ん中で折れるエフェクト [詳細]

FlipBoardEffectに対する継承グラフ
Effect

すべてのメンバ一覧

Public メソッド

FlipBoardEffect ()
コンストラクタ
FlipBoardEffect (Widget currentWidget, Widget nextWidget)
コンストラクタ

Static Public メソッド

static FlipBoardEffect | CreateAndStart (Widget currentWidget, Widget nextWidget)
インスタンスを作成しエフェクトを開始する。

Protected メソッド

override void | OnStart ()
開始処理
override EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

Widget | NextWidget [get, set]
次に表示するウィジェットを取得・設定する。
FlipBoardEffectInterpolator | Interpolator [get, set]
補間関数の種類を取得・設定する。
AnimationInterpolator | CustomInterpolator [get, set]
カスタムの補間関数を取得・設定する。
float | Time [get, set]
アニメーションの時間を取得・設定する。（ミリ秒）

説明

真ん中で折れるエフェクト

裏に新しいウィジェットが現れる。空港の掲示板風表現

コンストラクタとデストラクタ

FlipBoardEffect | ( | Widget | currentWidget,
 |  | Widget | nextWidget
 | ) |  |

コンストラクタ

引数:
currentWidget | 表示中のウィジェット
nextWidget | 次に表示するウィジェット

メソッド

static FlipBoardEffect CreateAndStart | ( | Widget | currentWidget,
 |  | Widget | nextWidget
 | ) |  | [static]

インスタンスを作成しエフェクトを開始する。

引数:
currentWidget | 表示中のウィジェット
nextWidget | 次に表示するウィジェット
戻り値:
エフェクトのインスタンス
override EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
エフェクトの更新の応答

Effectを実装しています。


クラス FlipBoardTransition

真ん中で折れるトランジション [詳細]

FlipBoardTransitionに対する継承グラフ
Transition

すべてのメンバ一覧

Public メソッド

FlipBoardTransition ()
コンストラクタ

Protected メソッド

override void | OnStart ()
開始処理
override TransitionUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

FlipBoardEffectInterpolator | Interpolator [get, set]
補間関数の種類を取得・設定する。
AnimationInterpolator | CustomInterpolator [get, set]
カスタムの補間関数を設定する。
float | Time [get, set]
アニメーションの時間を取得・設定する。（ミリ秒）

説明

真ん中で折れるトランジション

裏に新しいシーンが現れる。空港の掲示板風表現

メソッド

override TransitionUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
トランジションの更新の応答

Transitionを実装しています。


クラス FocusChangedEventArgs

FocusChangedイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

FocusChangedEventArgs (bool focused)
コンストラクタ

プロパティ

bool Focused [get, set]
フォーカスが設定されたかどうかを取得する

説明

FocusChangedイベント引数

コンストラクタとデストラクタ

FocusChangedEventArgs ( bool focused )

コンストラクタ

引数:
focused フォーカスが設定されたかどうか


  • Sce
  • PlayStation
  • HighLevel
  • UI
  • FocusCustomSettings
プロパティ

クラス FocusCustomSettings

フォーカスのカスタム設定 [詳細]

すべてのメンバ一覧

プロパティ

Widget | LeftCandidate [get, set]
対象ウィジェットで左キーを押した場合のフォーカスの移動先ウィジェットを取得・設定する
Widget | RightCandidate [get, set]
対象ウィジェットで右キーを押した場合のフォーカスの移動先ウィジェットを取得・設定する
Widget | UpCandidate [get, set]
対象ウィジェットで上キーを押した場合のフォーカスの移動先ウィジェットを取得・設定する
Widget | DownCandidate [get, set]
対象ウィジェットで下キーを押した場合のフォーカスの移動先ウィジェットを取得・設定する
Rectangle | SearchHintRectangle [get, set]
フォーカスを検索する場合の矩形を取得・設定する
bool | HideFocusImage [get, set]
フォーカスイメージを非表示にするかどうか取得・設定する
Rectangle | FocusImageRectangle [get, set]
フォーカスを表示する際の矩形(位置とサイズ)を取得・設定する
ImageAsset | FocusImage [get, set]
フォーカスのカスタムイメージを取得・設定する
NinePatchMargin | FocusImageNinePatchMargin [get, set]
フォーカスのカスタムイメージの9パッチマージンを取得・設定する
int | FocusImagePadding [get, set]
フォーカスのカスタムイメージを外側に広げる大きさを取得・設定する

説明

フォーカスのカスタム設定

各メンバは、デフォルト値(nullまたはゼロ)であれば標準の設定に沿って処理を行います。

プロパティ

Widget DownCandidate [get, set]

対象ウィジェットで下キーを押した場合のフォーカスの移動先ウィジェットを取得・設定する

値が null もしくは 同一のシーン上に存在しないウィジェットの場合は標準のフォーカス検索が行われます。 指定したウィジェットはFocusable、Visible、Enabledプロパティおよび表示範囲内にあるかにかかわらずフォーカスが設定されます。

ImageAsset FocusImage [get, set]

フォーカスのカスタムイメージを取得・設定する

nullの場合はデフォルトのフォーカスイメージを使用します。

NinePatchMargin FocusImageNinePatchMargin [get, set]

フォーカスのカスタムイメージの9パッチマージンを取得・設定する

FocusImage が null の場合はこの値は無視されます。

int FocusImagePadding [get, set]

フォーカスのカスタムイメージを外側に広げる大きさを取得・設定する

FocusImage が null の場合はこの値は無視されます。

Rectangle FocusImageRectangle [get, set]

フォーカスを表示する際の矩形(位置とサイズ)を取得・設定する

サイズが0以下の場合は対象ウィジェット自身のサイズを使用します。 位置とサイズは対象ウィジェット自身のローカル座標で指定します。

bool HideFocusImage [get, set]

フォーカスイメージを非表示にするかどうか取得・設定する

true の場合は標準またはカスタムのフォーカスイメージを表示しないようにします。

Widget LeftCandidate [get, set]

対象ウィジェットで左キーを押した場合のフォーカスの移動先ウィジェットを取得・設定する

値が null もしくは 同一のシーン上に存在しないウィジェットの場合は標準のフォーカス検索が行われます。 指定したウィジェットはFocusable、Visible、Enabledプロパティおよび表示範囲内にあるかにかかわらずフォーカスが設定されます。

Widget RightCandidate [get, set]

対象ウィジェットで右キーを押した場合のフォーカスの移動先ウィジェットを取得・設定する

値が null もしくは 同一のシーン上に存在しないウィジェットの場合は標準のフォーカス検索が行われます。 指定したウィジェットはFocusable、Visible、Enabledプロパティおよび表示範囲内にあるかにかかわらずフォーカスが設定されます。

Rectangle SearchHintRectangle [get, set]

フォーカスを検索する場合の矩形を取得・設定する

サイズが0以下の場合は対象ウィジェット自身のサイズを使用します。 位置とサイズは対象ウィジェット自身のローカル座標で指定します。

Widget UpCandidate [get, set]

対象ウィジェットで上キーを押した場合のフォーカスの移動先ウィジェットを取得・設定する

値が null もしくは 同一のシーン上に存在しないウィジェットの場合は標準のフォーカス検索が行われます。 指定したウィジェットはFocusable、Visible、Enabledプロパティおよび表示範囲内にあるかにかかわらずフォーカスが設定されます。


クラス GestureDetector

ジェスチャ検出機構の基底クラス [詳細]

GestureDetectorに対する継承グラフ
DoubleTapGestureDetector DragGestureDetector FlickGestureDetector LongPressGestureDetector PinchGestureDetector TapGestureDetector

すべてのメンバ一覧

Public メソッド

GestureDetector ()
コンストラクタ

Protected メソッド

abstract internal
GestureDetectorResponse 		OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントを配信する。
abstract internal void | OnResetState ()
ジェスチャ検出の状態をリセットする。

プロパティ

GestureDetectorResponse | State [get, set]
GestureDetectorの状態を取得する。
Widget | TargetWidget [get, set]
ジェスチャ検出対象のウィジェットを取得する

説明

ジェスチャ検出機構の基底クラス

メソッド

abstract internal GestureDetectorResponse OnTouchEvent ( TouchEventCollection touchEvents ) [protected, pure virtual]

タッチイベントを配信する。

引数:
touchEvents タッチイベント
戻り値:
タッチイベント配信の応答

DoubleTapGestureDetector, DragGestureDetector, FlickGestureDetector, LongPressGestureDetector, PinchGestureDetector, と TapGestureDetectorで実装されています。

プロパティ

GestureDetectorResponse State [get, set]

GestureDetectorの状態を取得する。

前回のOnTouchEventで返却されたGestureDetectorResponseを取得することができる。OnResetStateが呼ばれるとNoneが設定される。


クラス GestureEventArgs

ジェスチャイベント引数の基底クラス [詳細]

GestureEventArgsに対する継承グラフ
DoubleTapEventArgs DragEventArgs FlickEventArgs LongPressEventArgs PinchEventArgs TapEventArgs

すべてのメンバ一覧

Public メソッド

GestureEventArgs (Widget source)
コンストラクタ

プロパティ

Widget Source [get, set]
イベント発生元ウィジェット

説明

ジェスチャイベント引数の基底クラス


クラス GridListPanel

複数の行と列を持つリストウィジェット [詳細]

GridListPanelに対する継承グラフ
ContainerWidget Widget

すべてのメンバ一覧

Public メソッド

GridListPanel (GridListScrollOrientation scrollOrientation)
コンストラクタ
void | StartItemRequest ()
アイテムの要求を開始する。
ListPanelItem | GetListItem (int index)
指定したインデックスのアイテムを取得する。
void | ScrollTo (int itemIndex, float pixelOffset, bool withAnimation)
指定したアイテムの位置までスクロールする。
void | ScrollTo (int itemIndex, bool withAnimation)
指定したアイテムの位置までスクロールする。
void | SetListItemCreator (ListItemCreator creator)
アイテムを作成するメソッドを登録する。
void | SetListItemUpdater (ListItemUpdater updater)
アイテムを更新するメソッドを登録する。

Protected メソッド

internal override void | OnPreviewKeyEvent (KeyEvent keyEvent)
事前キーイベントのハンドラ
internal override void | OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントハンドラ
internal override void | OnResetState ()
状態リセットハンドラ
override void | OnUpdate (float elapsedTime)
更新処理

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
GridListScrollOrientation | ScrollOrientation [get, set]
スクロール方向を取得する。
UIColor | BackgroundColor [get, set]
背景色を取得・設定する。
float | ItemWidth [get, set]
アイテムの幅を取得・設定する。
float | ItemHeight [get, set]
アイテムの高さを取得・設定する。
float | ItemVerticalGap [get, set]
アイテムの行間を取得・設定する。
float | ItemHorizontalGap [get, set]
アイテムの列間を取得・設定する。
ScrollBarVisibility | ScrollBarVisibility [get, set]
スクロールバーの見え方を取得・設定する。
bool | SnapScroll [get, set]
アイテムごとに停止するかを取得・設定する。
int | ItemIndex [get]
表示領域の左上のアイテムのインデックスを取得する。
float | ItemPixelOffset [get]
表示領域の左上のアイテムのずれを取得する。（ピクセル）
int | ItemCount [get, set]
アイテムの総数を取得・設定する。

イベント

EventHandler
< ListPanelItemSelectChangedEventArgs > 		SelectItemChanged
アイテムが選択された場合に呼び出されるイベント
EventHandler< TouchEventArgs > | Scrolling
スクロール中に呼び出されるハンドラ

説明

複数の行と列を持つリストウィジェット

コンストラクタとデストラクタ

GridListPanel ( GridListScrollOrientation scrollOrientation )

コンストラクタ

引数:
scrollOrientation スクロール方向

メソッド

ListPanelItem GetListItem ( int index )

指定したインデックスのアイテムを取得する。

引数:
index アイテムのインデックス
戻り値:
アイテム（nullが返ることがある。）
internal override void OnPreviewKeyEvent ( KeyEvent keyEvent ) [protected, virtual]

事前キーイベントのハンドラ

引数:
keyEvent キーイベント

Widgetを再定義しています。

internal override void OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントハンドラ

引数:
touchEvents タッチイベント

Widgetを再定義しています。

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

void ScrollTo | ( | int | itemIndex,
 |  | bool | withAnimation
 | ) |  |

指定したアイテムの位置までスクロールする。

引数:
itemIndex | アイテムのインデックス
withAnimation | アニメーションするかどうか
void ScrollTo | ( | int | itemIndex,
 |  | float | pixelOffset,
 |  | bool | withAnimation
 | ) |  |

指定したアイテムの位置までスクロールする。

引数:
itemIndex | アイテムのインデックス
pixelOffset | アイテムのずれ（ピクセル）
withAnimation | アニメーションするかどうか
void SetListItemCreator ( ListItemCreator creator )

アイテムを作成するメソッドを登録する。

引数:
creator アイテムを作成するメソッド
void SetListItemUpdater ( ListItemUpdater updater )

アイテムを更新するメソッドを登録する。

引数:
updater アイテムを更新するメソッド

プロパティ

float ItemHeight [get, set]

アイテムの高さを取得・設定する。

例外:
ArgumentOutOfRangeException アイテムの高さとアイテムの行間の合計がリストの高さより大きい
float ItemHorizontalGap [get, set]

アイテムの列間を取得・設定する。

例外:
ArgumentOutOfRangeException アイテムの列間とアイテムの幅の合計がリストの幅より大きい
int ItemIndex [get]

表示領域の左上のアイテムのインデックスを取得する。

アイテムは行間と列間を含む。

float ItemVerticalGap [get, set]

アイテムの行間を取得・設定する。

例外:
ArgumentOutOfRangeException アイテムの行間とアイテムの高さの合計がリストの高さより大きい
float ItemWidth [get, set]

アイテムの幅を取得・設定する。

例外:
ArgumentOutOfRangeException アイテムの幅とアイテムの列間の合計がリストの幅より大きい


クラス ImageAsset

画像アセットクラス [詳細]

すべてのメンバ一覧

Public メソッド

ImageAsset (string filename, bool asyncLoad)
指定した画像ファイルから新しいインスタンスを生成する
ImageAsset (string filename)
指定した画像ファイルから新しいインスタンスを生成する
ImageAsset (SystemImageAsset name)
指定したシステム画像アセットの新しいインスタンスを生成する
ImageAsset (Texture2D texture)
指定した既存のテクスチャから新しいインスタンスを生成する
ImageAsset (Image image, PixelFormat format)
指定した既存のイメージから新しいインスタンスを生成する
ImageAsset (Image image)
指定した既存のイメージから新しいインスタンスを生成する
ImageAsset (string filename, bool asyncLoad, bool scaledPixelDensity)
指定した画像ファイルから新しいインスタンスを生成する
ImageAsset (Texture2D texture, bool scaledPixelDensity)
指定した既存のテクスチャから新しいインスタンスを生成する
ImageAsset (Image image, PixelFormat format, bool scaledPixelDensity)
指定した既存のイメージから新しいインスタンスを生成する
ImageAsset (Image image, bool scaledPixelDensity)
指定した既存のイメージから新しいインスタンスを生成する
Texture2D CloneTexture ()
テクスチャの複製を取得
void | WaitForLoad ()
ファイルが読み込まれるまで待機する
void | Dispose ()
使用されているリソースを解放する
bool | UnloadFromCache ()
画像ファイルから読み込んだImageAssetのキャッシュを削除する

Static Public メソッド

static void | WaitForLoadAll ()
非同期で読み込んでいるすべての画像が読み込まれるまで待機する
static bool | UnloadFromCache (string filename)
ファイルから読み込んだImageAssetのキャッシュを削除する

プロパティ

bool | Ready [get]
画像アセットの読み込みが完了したかどうかを取得する
int | Width [get]
画像アセットの幅を取得する
int | Height [get]
画像アセットの高さを取得する
string | FilePath [get]
画像ファイルのパスを取得する

説明

画像アセットクラス

テクスチャの読み込みなどを隠蔽するクラスです。 画像ファイルの非同期の読み込みやキャッシュをサポートします。 画像ファイルから ImageAsset を作成した場合は、テクスチャがキャッシュされます。 このキャッシュにより、同一ファイル名の ImageAsset を作成した場合、テクスチャのアンマネージドリソースは共有されます。 なお、キャッシュは Dispose やガーベージコレクションだけでは解放されません。 使用しなくなった ImageAsset は UnloadFromCache を呼び出したあと、同一画像ファイルのImageAssetすべての Dispose を呼び出してください。

コンストラクタとデストラクタ

ImageAsset | ( | string | filename,
 |  | bool | asyncLoad
 | ) |  |

指定した画像ファイルから新しいインスタンスを生成する

一度読み込むとキャッシュされます。使用しなくなった場合は UnloadFromCache を呼び出してください。

引数:
filename | 画像ファイル名
asyncLoad | 非同期で読み込むかどうか
ImageAsset ( string filename )

指定した画像ファイルから新しいインスタンスを生成する

同期で読み込みます。一度読み込むとキャッシュされます。使用しなくなった場合は UnloadFromCache を呼び出してください。

引数:
filename 画像ファイル名
ImageAsset ( SystemImageAsset name )

指定したシステム画像アセットの新しいインスタンスを生成する

標準のウィジェットなどに使用される画像アセットです。非同期で読み込みます。

引数:
name システム画像アセット
ImageAsset ( Texture2D texture )

指定した既存のテクスチャから新しいインスタンスを生成する

キャッシュはされません。ImageAsset内ではテクスチャの ShallowClone を保持するため、引数で指定したテクスチャのインスタンスは必要に応じて Dispose してください。

引数:
texture テクスチャ
ImageAsset | ( | Image | image,
 |  | PixelFormat | format
 | ) |  |

指定した既存のイメージから新しいインスタンスを生成する

キャッシュはされません。引数で指定したイメージのインスタンスは必要に応じて Dispose してください。

引数:
image | 既存の画像
format | 指定した既存の画像のピクセルフォーマット
ImageAsset ( Image image )

指定した既存のイメージから新しいインスタンスを生成する

キャッシュはされません。引数で指定したイメージのインスタンスは必要に応じて Dispose してください。

引数:
image 既存の画像
ImageAsset | ( | string | filename,
 |  | bool | asyncLoad,
 |  | bool | scaledPixelDensity
 | ) |  |

指定した画像ファイルから新しいインスタンスを生成する

一度読み込むとキャッシュされます。使用しなくなった場合は UnloadFromCache を呼び出してください。

引数:
filename | 画像ファイル名
asyncLoad | 非同期で読み込むかどうか
scaledPixelDensity | ピクセル密度に応じてスケールするかどうか
ImageAsset | ( | Texture2D | texture,
 |  | bool | scaledPixelDensity
 | ) |  |

指定した既存のテクスチャから新しいインスタンスを生成する

キャッシュはされません。ImageAsset内ではテクスチャの ShallowClone を保持するため、引数で指定したテクスチャのインスタンスは必要に応じて Dispose してください。

引数:
texture | テクスチャ
scaledPixelDensity | ピクセル密度に応じてスケールするかどうか
ImageAsset | ( | Image | image,
 |  | PixelFormat | format,
 |  | bool | scaledPixelDensity
 | ) |  |

指定した既存のイメージから新しいインスタンスを生成する

キャッシュはされません。引数で指定したイメージのインスタンスは必要に応じて Dispose してください。

引数:
image | 既存の画像
format | 指定した既存の画像のピクセルフォーマット
scaledPixelDensity | ピクセル密度に応じてスケールするかどうか
ImageAsset | ( | Image | image,
 |  | bool | scaledPixelDensity
 | ) |  |

指定した既存のイメージから新しいインスタンスを生成する

キャッシュはされません。引数で指定したイメージのインスタンスは必要に応じて Dispose してください。

引数:
image | 既存の画像
scaledPixelDensity | ピクセル密度に応じてスケールするかどうか

メソッド

Texture2D CloneTexture ( )

テクスチャの複製を取得

テクスチャのShallowCloneを返します。非同期読み込みで、まだテクスチャの読み込みが完了していない場合はnullを返します。

void Dispose ( )

使用されているリソースを解放する

このインスタンスが保持しているテクスチャの Dispose を呼びます。 画像ファイルから読み込んだImageAssetの場合、キャッシュされているテクスチャは解放されません。 完全に解放するためには UnloadFromCache を呼び出す必要があります。

bool UnloadFromCache ( )

画像ファイルから読み込んだImageAssetのキャッシュを削除する

キャッシュされているテクスチャを解放します。 キャッシュ内のテクスチャのみ解放されるので、このインスタンスは引き続き使用することができます。 対象のテクスチャのアンマネージドリソースをガーベージコレクションを待たずに解放するには、Dispose を呼ぶ必要があります。

戻り値:
false:キャッシュに存在していなかった
static bool UnloadFromCache ( string filename ) [static]

ファイルから読み込んだImageAssetのキャッシュを削除する

引数:
filename ファイル名
戻り値:
false:キャッシュに存在していなかった
void WaitForLoad ( )

ファイルが読み込まれるまで待機する

同期で読み込んだ場合やすでに読み込みが完了している場合はすぐに戻ります。

プロパティ

string FilePath [get]

画像ファイルのパスを取得する

ファイルから生成していない場合は null が返ります。

int Height [get]

画像アセットの高さを取得する

非同期読み込みでまだ読み込まれていない場合は0を返します。

bool Ready [get]

画像アセットの読み込みが完了したかどうかを取得する

画像ファイル以外や同期で読み込んだ場合は true が返ります。

int Width [get]

画像アセットの幅を取得する

非同期読み込みでまだ読み込まれていない場合は0を返します


クラス ImageBox

画像を表示するウィジェット [詳細]

ImageBoxに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

ImageBox ()
コンストラクタ

Protected メソッド

internal override void | Render ()
シーングラフを描画する。

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
ImageAsset | Image [get, set]
画像を取得・設定する。
NinePatchMargin | NinePatchMargin [get, set]
画像の９パッチ情報を取得・設定する。
ImageScaleType | ImageScaleType [get, set]
画像のスケールを取得・設定する。
ImageRect | CropArea [get, set]
画像のクリップ領域を取得・設定する。
BlendMode | BlendMode [get, set]
ブレンドモードを取得・設定する。

説明

画像を表示するウィジェット

プロパティ

ImageRect CropArea [get, set]

画像のクリップ領域を取得・設定する。

全て０の場合はクリップしない。ImageScaleTypeと同時に設定されている場合クリップした画像をスケーリングする。

NinePatchMargin NinePatchMargin [get, set]

画像の９パッチ情報を取得・設定する。

ImageScaleTypeがNinePatchの場合にのみ有効となる。


クラス JumpFlipEffect

画面手前にジャンプし反転して切り替わるエフェクト [詳細]

JumpFlipEffectに対する継承グラフ
Effect

すべてのメンバ一覧

Public メソッド

JumpFlipEffect ()
コンストラクタ
JumpFlipEffect (Widget currentWidget, Widget nextWidget)
コンストラクタ

Static Public メソッド

static JumpFlipEffect | CreateAndStart (Widget currentWidget, Widget nextWidget)
インスタンスを作成しエフェクトを開始する。

Protected メソッド

override void | OnStart ()
開始処理
override EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

Widget | NextWidget [get, set]
次に表示するウィジェットを取得・設定する。
int | Revolution [get, set]
回転数を取得・設定する。（半回転＝1）
float | JumpHeight [get, set]
ジャンプの高さを取得・設定する。
float | Time [get, set]
エフェクトの時間を取得・設定する。
float | JumpDelay [get, set]
回転開始までの時間を取得・設定する。
float | ToDegreeDelay [get, set]
回転開始時の角度を取得・設定する。
JumpFlipEffectAxis | RotationAxis [get, set]
回転軸を取得・設定する。

説明

画面手前にジャンプし反転して切り替わるエフェクト

表面が古いウィジェットで裏面が新しいウィジェットとなる。それぞれ同じサイズとする。ジャンプして反転しながら新しい位置に落ちていくことも可能。

コンストラクタとデストラクタ

JumpFlipEffect | ( | Widget | currentWidget,
 |  | Widget | nextWidget
 | ) |  |

コンストラクタ

引数:
currentWidget | 表示中のウィジェット
nextWidget | 次に表示するウィジェット

メソッド

static JumpFlipEffect CreateAndStart | ( | Widget | currentWidget,
 |  | Widget | nextWidget
 | ) |  | [static]

インスタンスを作成しエフェクトを開始する。

引数:
currentWidget | 表示中のウィジェット
nextWidget | 次に表示するウィジェット
戻り値:
エフェクトのインスタンス
override EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
エフェクトの更新の応答

Effectを実装しています。


クラス JumpFlipTransition

画面手前にジャンプし反転して切り替わるトランジション [詳細]

JumpFlipTransitionに対する継承グラフ
Transition

すべてのメンバ一覧

Public メソッド

JumpFlipTransition ()
コンストラクタ

Protected メソッド

override void | OnStart ()
開始処理
override TransitionUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

JumpFlipTransitionSpeed | Speed [get, set]
回転の速度を取得・設定する。
JumpFlipTransitionRotateDirection | RotateDirection [get, set]
回転の方向を取得・設定する。

説明

画面手前にジャンプし反転して切り替わるトランジション

メソッド

override TransitionUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
トランジションの更新の応答

Transitionを実装しています。


クラス KeyEvent

キーイベント情報 [詳細]

すべてのメンバ一覧

Public メソッド

KeyEvent ()
コンストラクタ
KeyEvent (KeyType keyType, KeyEventType keyEventType, TimeSpan time, TimeSpan downTime)
コンストラクタ
KeyEvent (KeyType keyType, KeyEventType keyEventType, TimeSpan time, TimeSpan downTime, bool enabledEachFrame)
コンストラクタ

プロパティ

KeyEventType | KeyEventType [get, set]
キーイベントの種別を取得・設定する。
KeyType | KeyType [get, set]
キーの種別を取得・設定する。
TimeSpan | Time [get, set]
イベントが発生した時刻を取得・設定する。
TimeSpan | DownTime [get, set]
キーが押された時刻を取得・設定する。
bool | Forward [get, set]
イベントをフォワードするかどうかを取得・設定する。初期値はFalse。
bool | Handled [get, set]
イベントが処理済みかどうかを取得・設定する
bool | EnabledEachFrameRepeat [get, set]
毎フレームごとのキーリピートイベントを有効にするかどうかを取得・設定する

説明

キーイベント情報

コンストラクタとデストラクタ

KeyEvent | ( | KeyType | keyType,
 |  | KeyEventType | keyEventType,
 |  | TimeSpan | time,
 |  | TimeSpan | downTime
 | ) |  |

コンストラクタ

引数:
keyType | キーの種別
keyEventType | キーイベントの種別
time | イベントが発生した時刻
downTime | キーが押された時刻
KeyEvent | ( | KeyType | keyType,
 |  | KeyEventType | keyEventType,
 |  | TimeSpan | time,
 |  | TimeSpan | downTime,
 |  | bool | enabledEachFrame
 | ) |  |

コンストラクタ

引数:
keyType | キーの種別
keyEventType | キーイベントの種別
time | イベントが発生した時刻
downTime | キーが押された時刻
enabledEachFrame

プロパティ

bool EnabledEachFrameRepeat [get, set]

毎フレームごとのキーリピートイベントを有効にするかどうかを取得・設定する

この値を true に設定すると、次のフレームから KeyEventType が EachFrameRepeat のイベントが毎フレーム配信されるようになります。 この値は現在の KeyType に対してのみ有効で、キーが押されている間は値が保持されますが、キーが離されると false にリセットされます。


クラス KeyEventArgs

キーイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

KeyEventArgs (KeyEvent keyEvent)
コンストラクタ

プロパティ

TimeSpan | DownTime [get, set]
キーが押された時刻を取得・設定する。
KeyType | KeyType [get, set]
キーの種別を取得・設定する。
KeyEventType | KeyEventType [get, set]
キーイベントの種別を取得・設定する。
bool | Forward [get, set]
キーイベント引数に含まれるキーイベントをフォワードするかどうかを取得・設定する。初期値はFalse。
bool | Handled [get, set]
イベントが処理済みかどうかを取得・設定する
bool | EnabledEachFrameRepeat [get, set]
毎フレームごとのキーリピートイベントを有効にするかどうかを取得・設定する

説明

キーイベント引数

プロパティ

bool EnabledEachFrameRepeat [get, set]

毎フレームごとのキーリピートイベントを有効にするかどうかを取得・設定する

この値を true に設定すると、次のフレームから KeyEventType が EachFrameRepeat のイベントが毎フレーム配信されるようになります。 この値は現在の KeyType に対してのみ有効で、キーが押されている間は値が保持されますが、キーが離されると false にリセットされます。


クラス Label

文字列を表示するウィジェット [詳細]

Labelに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

Label ()
コンストラクタ

Protected メソッド

override void | DisposeSelf ()
使用されているリソースを解放する。
internal override void | Render ()
シーングラフを描画する。

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
string | Text [get, set]
文字列を取得・設定する。
UIFont | Font [get, set]
文字列のフォントを取得・設定する。
UIColor | TextColor [get, set]
文字列の色を取得・設定する。
TextShadowSettings | TextShadow [get, set]
文字列の影の情報を取得・設定する。
UIColor | BackgroundColor [get, set]
背景色を取得・設定する。
HorizontalAlignment | HorizontalAlignment [get, set]
水平方向のアラインメント取得・設定する。
VerticalAlignment | VerticalAlignment [get, set]
垂直方向のアラインメントを取得・設定する。
LineBreak | LineBreak [get, set]
文字列の改行方法を取得・設定する。
TextTrimming | TextTrimming [get, set]
文字列のトリミング方法を取得・設定する。
float | LineGap [get, set]
行間を取得・設定する。
float | TextHeight [get]
テキストの高さ

説明

文字列を表示するウィジェット

プロパティ

float LineGap [get, set]

行間を取得・設定する。

初期値は０

float TextHeight [get]

テキストの高さ

現在の設定でテキストを描画した場合の複数行文字列の高さ(pixel)です。描画される文字列は現在の幅、LineBreakで折り返されます。


クラス ListPanel

複数の行を持つリストウィジェット [詳細]

ListPanelに対する継承グラフ
ContainerWidget Widget

すべてのメンバ一覧

Public メソッド

ListPanel ()
コンストラクタ
void | SetListItemCreator (ListItemCreator creator)
アイテムを作成するメソッドを登録する。
void | SetListItemUpdater (ListItemUpdater updater)
アイテムを更新するメソッドを登録する。
void | Move (float moveDistance)
指定した距離移動する。負数を指定した場合は上へ、正数を指定した場合は下へ移動する。
void | UpdateItems ()
現在表示中のすべてのアイテムを更新する。
ListPanelItem | GetListItem (int index)
指定したインデックスのアイテムを取得する
ListPanelItem | GetListItem (int sectionIndex, int indexInSection)
指定したインデックスのアイテムを取得する

Protected メソッド

internal override void | OnResetState ()
状態リセットハンドラ
internal override void | OnPreviewKeyEvent (KeyEvent keyEvent)
事前キーイベントのハンドラ
internal override void | OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントハンドラ
override void | OnUpdate (float elapsedTime)
更新処理

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
UIColor | BackgroundColor [get, set]
背景色を取得・設定する。
ListSectionCollection | Sections [get, set]
セクションのコレクションを取得・設定する。
int | AllItemCount [get]
アイテムの総数を取得する。
bool | ShowSection [get, set]
セクションを表示するかどうかを取得・設定する。
bool | ShowEmptySection [get, set]
空のセクションを表示するかどうかを取得・設定する。
bool | ShowItemBorder [get, set]
アイテムの境界画像を表示するかどうかを取得・設定する。
ScrollBarVisibility | ScrollBarVisibility [get, set]
スクロールバーの見え方を取得・設定する。
UIFont | SectionFont [get, set]
セクションのフォントを取得・設定する。
UIColor | SectionTextColor [get, set]
セクションのテキストカラーを取得・設定する。
UIColor | SectionBackgroundColor [get, set]
セクションの背景色を取得・設定する。

イベント

EventHandler
< ListPanelItemSelectChangedEventArgs > 		SelectItemChanged
アイテムが選択された場合に呼び出されるイベント

説明

複数の行を持つリストウィジェット

グループ化機能とインデックス機能がある。アイテムの内容を自由にカスタマイズできる。

メソッド

ListPanelItem GetListItem ( int index )

指定したインデックスのアイテムを取得する

表示範囲内にないインデックスを指定した場合はnullが返されます。

引数:
index リスト全体でのアイテムインデックス
戻り値:
アイテム
ListPanelItem GetListItem | ( | int | sectionIndex,
 |  | int | indexInSection
 | ) |  |

指定したインデックスのアイテムを取得する

表示範囲内にないインデックスを指定した場合はnullが返されます。

引数:
sectionIndex | セクションのインデックス
indexInSection | セクション内でのアイテムインデックス
戻り値:
アイテム
void Move ( float moveDistance )

指定した距離移動する。負数を指定した場合は上へ、正数を指定した場合は下へ移動する。

引数:
moveDistance 移動距離(pixel)
internal override void OnPreviewKeyEvent ( KeyEvent keyEvent ) [protected, virtual]

事前キーイベントのハンドラ

引数:
keyEvent キーイベント

Widgetを再定義しています。

internal override void OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントハンドラ

引数:
touchEvents タッチイベント

Widgetを再定義しています。

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

void SetListItemCreator ( ListItemCreator creator )

アイテムを作成するメソッドを登録する。

引数:
creator アイテムを作成するメソッド
void SetListItemUpdater ( ListItemUpdater updater )

アイテムを更新するメソッドを登録する。

引数:
updater アイテムを更新するメソッド


クラス ListPanelItem

リストのアイテム用のコンテナウィジェット [詳細]

ListPanelItemに対する継承グラフ
Panel ContainerWidget Widget

すべてのメンバ一覧

Public メソッド

ListPanelItem ()
コンストラクタ

Protected メソッド

override void | DisposeSelf ()
使用されているリソースを解放する。
override void | OnPressStateChanged (PressStateChangedEventArgs e)
プレス状態が変化したときに呼び出される

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
virtual int | Index [get, set]
リスト全体でのインデックスを取得する。
virtual int | IndexInSection [get, set]
セクション内でのインデックスを取得する。
int | SectionIndex [get, set]
セクションのインデックスを取得する。

説明

リストのアイテム用のコンテナウィジェット

メソッド

override void OnPressStateChanged ( PressStateChangedEventArgs e ) [protected, virtual]

プレス状態が変化したときに呼び出される

引数:
e イベント引数

Widgetを再定義しています。

プロパティ

override float Height [get, set]

高さを取得・設定する。

具象クラスまたはコールバックからのみ値を変更することができる。

Panelを再定義しています。

virtual int Index [get, set]

リスト全体でのインデックスを取得する。

初期値は-1

virtual int IndexInSection [get, set]

セクション内でのインデックスを取得する。

ListPanelでのみ使用する。初期値は-1

int SectionIndex [get, set]

セクションのインデックスを取得する。

ListPanelでのみ使用する。初期値は-1

override float Width [get, set]

幅を取得・設定する。

ListPanelクラスからのみ値を変更することができる。

Panelを再定義しています。


クラス ListPanelItemSelectChangedEventArgs

リストアイテムが選択された場合に呼び出されるイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

ListPanelItemSelectChangedEventArgs ()
コンストラクタ
ListPanelItemSelectChangedEventArgs (ListPanelItem item)
コンストラクタ

プロパティ

int | Index [get, set]
選択されたアイテムのインデックス
virtual int | IndexInSection [get, set]
セクションのインデックス
int | SectionIndex [get, set]
セクション内のインデックス

説明

リストアイテムが選択された場合に呼び出されるイベント引数

コンストラクタとデストラクタ

ListPanelItemSelectChangedEventArgs ( ListPanelItem item )

コンストラクタ

引数:
item アイテム

プロパティ

virtual int IndexInSection [get, set]

セクションのインデックス

このプロパティはListPanelの時にのみ有効です。

int SectionIndex [get, set]

セクション内のインデックス

このプロパティはListPanelの時にのみ有効です。


クラス ListSection

リストのセクション用のコンテナ部品 [詳細]

すべてのメンバ一覧

Public メソッド

ListSection ()
コンストラクタ
ListSection (string title, int itemCount)
コンストラクタ

プロパティ

string | Title [get, set]
セクションのタイトルを取得・設定する。
int | ItemCount [get, set]
セクションに登録されているアイテムの数を取得・設定する。

イベント

EventHandler< EventArgs > | ItemChanged
セクションに登録されているアイテムが変わった時のイベント

説明

リストのセクション用のコンテナ部品

コンストラクタとデストラクタ

ListSection | ( | string | title,
 |  | int | itemCount
 | ) |  |

コンストラクタ

引数:
title | セクションのタイトル
itemCount | セクションに登録されているアイテムの数


クラス ListSectionCollection

セクションのコレクション [詳細]

すべてのメンバ一覧

Public メソッド

ListSectionCollection ()
コンストラクタ
int | IndexOf (ListSection section)
指定したセクションのインデックスを取得する。
void | Insert (int index, ListSection section)
指定したインデックスの位置にセクションを挿入する。
void | RemoveAt (int index)
指定したインデックスにあるセクションを削除する。
void | Add (ListSection section)
セクションを追加する。
void | Clear ()
すべてのセクションを削除する。
bool | Contains (ListSection section)
特定のセクションが格納されているかどうかを判断する。
void | CopyTo (ListSection[] array, int arrayIndex)
セクションを配列にコピーする。
bool | Remove (ListSection section)
最初に見つかった特定のセクションを削除する。

プロパティ

int | AllItemCount [get]
セクションに登録されているアイテムの総数を取得する。
ListSection | this [int index] [get, set]
指定したインデックスにあるセクションを取得・設定する。
int | Count [get]
セクションの数を取得する。
bool | IsReadOnly [get]
読み取り専用かどうかを取得する。

イベント

EventHandler< EventArgs > | ItemsChanged
内容が変化したときに呼び出されるハンドラ

説明

セクションのコレクション

メソッド

void Add ( ListSection section )

セクションを追加する。

引数:
section 追加するセクション
bool Contains ( ListSection section )

特定のセクションが格納されているかどうかを判断する。

引数:
section 検索するセクション
戻り値:
検索するセクションが存在する場合はtrueそれ以外の場合はfalse。
void CopyTo | ( | ListSection[] | array,
 |  | int | arrayIndex
 | ) |  |

セクションを配列にコピーする。

引数:
array | セクションがコピーされる１次元の配列
arrayIndex | コピーの開始位置となる配列のインデックス
int IndexOf ( ListSection section )

指定したセクションのインデックスを取得する。

引数:
section 検索するセクション
戻り値:
検索するセクションが存在する場合はそのインデックス。それ以外の場合は -1。
void Insert | ( | int | index,
 |  | ListSection | section
 | ) |  |

指定したインデックスの位置にセクションを挿入する。

引数:
index | 挿入する位置のインデックス。
section | 挿入するセクション
bool Remove ( ListSection section )

最初に見つかった特定のセクションを削除する。

引数:
section 削除するセクション
戻り値:
削除するセクションが存在する場合はtrue。それ以外の場合はfalse。
void RemoveAt ( int index )

指定したインデックスにあるセクションを削除する。

引数:
index 削除するセクションのインデックス

プロパティ

ListSection this[int index] [get, set]

指定したインデックスにあるセクションを取得・設定する。

引数:
index 取得するセクションのインデックス
戻り値:
指定したインデックスにあるセクション


クラス LiveFlipPanel

イベントにより回転するコンテナウィジェット [詳細]

LiveFlipPanelに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

LiveFlipPanel ()
コンストラクタ
void | Start ()
アニメーションを開始する。
void | Stop ()
アニメーションを停止する。
void | Stop (bool withAnimate)
アニメーションを停止する。

Protected メソッド

override void | DisposeSelf ()
使用されているリソースを解放する。
internal override void | OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントハンドラ
internal override void | OnResetState ()
状態リセットハンドラ
override void | OnUpdate (float elapsedTime)
更新処理

プロパティ

int | FlipCount [get, set]
回転数を取得・設定する。（半回転＝1）
bool | TouchEnabled [get, set]
タッチ操作（ドラッグ、フリック）を有効にするかどうかを取得・設定する。
override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
Panel | FrontPanel [get, set]
表面のパネルを取得・設定する
Panel | BackPanel [get, set]
裏面のパネルを取得・設定する

説明

イベントにより回転するコンテナウィジェット

メソッド

internal override void OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントハンドラ

引数:
touchEvents タッチイベント

Widgetを再定義しています。

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

void Stop ( bool withAnimate )

アニメーションを停止する。

引数:
withAnimate アニメーションするかどうか


クラス LiveJumpPanel

子ウィジェットが画面手前にジャンプするコンテナウィジェット。 [詳細]

LiveJumpPanelに対する継承グラフ
Panel ContainerWidget Widget

すべてのメンバ一覧

Public メソッド

LiveJumpPanel ()
コンストラクタ
void | Jump ()
ジャンプを開始する。
void | Jump (float x, float y)
ジャンプを開始する。

Protected メソッド

override void | OnUpdate (float elapsedTime)
更新処理

プロパティ

float | JumpHeight [get, set]
ジャンプする高さを取得・設定する。
float | JumpDelayTime [get, set]
それぞれの子ウィジェットがジャンプするまでの遅延時間を取得・設定する。（ミリ秒/ピクセル）
float | JumpTime [get, set]
各子ウィジェットがジャンプして最初に着地するまでの時間を取得・設定する。（ミリ秒）
float | TiltAngle [get, set]
子ウィジェットの最大傾き角度を取得・設定する。（ラジアン）

説明

子ウィジェットが画面手前にジャンプするコンテナウィジェット。

指定した位置に近いウィジェットから順番にジャンプさせることができます。

メソッド

void Jump | ( | float | x,
 |  | float | y
 | ) |  |

ジャンプを開始する。

引数:
x | ローカル座標系でのX座標
y | ローカル座標系でのY座標
override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

プロパティ

float JumpDelayTime [get, set]

それぞれの子ウィジェットがジャンプするまでの遅延時間を取得・設定する。（ミリ秒/ピクセル）

ジャンプ中心から子ウィジェットまでの距離に対して、１ピクセルあたり何ミリ秒遅れるかを指定できる。


クラス LiveListPanel

アイテムが不規則な配置でスクロールするリストウィジェット [詳細]

LiveListPanelに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

LiveListPanel ()
コンストラクタ
void | StartItemRequest ()
アイテムの要求を開始する。
void | SetListItemCreator (ListItemCreator creator)
アイテムを作成するメソッドを登録する。
void | SetListItemUpdater (ListItemUpdater updater)
アイテムを更新するメソッドを登録する。

Protected メソッド

override void | OnUpdate (float elapsedTime)
更新処理
internal override void | OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントハンドラ
internal override void | OnResetState ()
状態リセットハンドラ
internal override void | OnPreviewKeyEvent (KeyEvent keyEvent)
事前キーイベントのハンドラ

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
UIColor | BackgroundColor [get, set]
背景色を取得・設定する。
float | ItemHeight [get, set]
アイテムの高さを取得・設定する。
float | ItemWidth [get, set]
アイテムの高さを取得・設定する。
int | ItemCount [get, set]
アイテムの総数を取得・設定する。
float | ItemVerticalGap [get, set]
アイテムの行間を取得・取得する。
ScrollBarVisibility | ScrollBarVisibility [get, set]
スクロールバーの見え方を取得・設定する。
float | ItemTiltAngle [get, set]
アイテムの最大傾き（ラジアン）。
float | ItemSlideInTime [get, set]
項目が横から入ってくるのにかかる時間（ミリ秒）。
float | ItemSlideInHeight [get, set]
項目が横から入ってくるときのZの高さ。
float | ItemSlideInTiltAngle [get, set]
項目が横から入ってくるときのY軸の角度。
float | ItemSlideInOffset [get, set]
項目が横から入ってくるときの水平方向のオフセット。

説明

アイテムが不規則な配置でスクロールするリストウィジェット

メソッド

internal override void OnPreviewKeyEvent ( KeyEvent keyEvent ) [protected, virtual]

事前キーイベントのハンドラ

引数:
keyEvent キーイベント

Widgetを再定義しています。

internal override void OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントハンドラ

引数:
touchEvents タッチイベント

Widgetを再定義しています。

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

void SetListItemCreator ( ListItemCreator creator )

アイテムを作成するメソッドを登録する。

引数:
creator アイテムを作成するメソッド
void SetListItemUpdater ( ListItemUpdater updater )

アイテムを更新するメソッドを登録する。

引数:
updater アイテムを更新するメソッド


クラス LiveScrollPanel

形状が歪みながらスクロールするコンテナウィジェット [詳細]

LiveScrollPanelに対する継承グラフ
ContainerWidget Widget

すべてのメンバ一覧

Public メソッド

LiveScrollPanel ()
コンストラクタ
override void | AddChildFirst (Widget child)
子ウィジェットを先頭に追加する。
override void | AddChildLast (Widget child)
子ウィジェットを末尾に追加する。
override void | InsertChildBefore (Widget child, Widget nextChild)
指定した子ウィジェットの直前に挿入する。
override void | InsertChildAfter (Widget child, Widget prevChild)
指定した子ウィジェットの直後に挿入する。
override void | RemoveChild (Widget child)
指定された子ウィジェットを削除する。

Protected メソッド

internal override void | OnResetState ()
状態をリセットする。
override void | DisposeSelf ()
使用されているリソースを解放する。
override void | OnUpdate (float elapsedTime)
更新処理
internal override void | OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントハンドラ

プロパティ

float | Elasticity [get, set]
ゆがみの弾性率を取得・設定する。
override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
float | PanelX [get, set]
親の座標系でのパネルのX座標を取得・設定する。
float | PanelY [get, set]
親の座標系でのパネルのY座標を取得・設定する。
float | PanelWidth [get, set]
パネルの幅を取得・設定する。
float | PanelHeight [get, set]
パネルの高さを取得・設定する。
float | MaxTextureWidth [get, set]
テクスチャの幅の最大値を取得・設定する。
float | MaxTextureHeight [get, set]
テクスチャの高さの最大値を取得・設定する。
UIColor | PanelColor [get, set]
パネルの色を取得・設定する。
bool | HorizontalScroll [get, set]
水平方向のスクロールをするかどうかを取得・設定する。
bool | VerticalScroll [get, set]
垂直方向のスクロールをするかどうかを取得・設定する。
override IEnumerable< Widget > | Children [get]
子ウィジェットを取得する。

説明

形状が歪みながらスクロールするコンテナウィジェット

メソッド

override void AddChildFirst ( Widget child ) [virtual]

子ウィジェットを先頭に追加する。

引数:
child 追加する子ウィジェット

既に追加されている場合は先頭に移動する。

ContainerWidgetを再定義しています。

override void AddChildLast ( Widget child ) [virtual]

子ウィジェットを末尾に追加する。

引数:
child 追加する子ウィジェット

既に追加されている場合は末尾に移動する。

ContainerWidgetを再定義しています。

override void InsertChildAfter | ( | Widget | child,
 |  | Widget | prevChild
 | ) |  | [virtual]

指定した子ウィジェットの直後に挿入する。

引数:
child | 挿入する子ウィジェット
prevChild | 挿入する子ウィジェットの直前となる子ウィジェット

既に追加されている場合は指定した子ウィジェットの直後に移動する。

ContainerWidgetを再定義しています。

override void InsertChildBefore | ( | Widget | child,
 |  | Widget | nextChild
 | ) |  | [virtual]

指定した子ウィジェットの直前に挿入する。

引数:
child | 挿入する子ウィジェット
nextChild | 挿入する子ウィジェットの直後となる子ウィジェット

既に追加されている場合は指定した子ウィジェットの直前に移動する。

ContainerWidgetを再定義しています。

internal override void OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントハンドラ

引数:
touchEvents タッチイベント

Widgetを再定義しています。

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

elapsedTimeが10秒以上の場合、更新処理はスキップされます。

Widgetを再定義しています。

override void RemoveChild ( Widget child ) [virtual]

指定された子ウィジェットを削除する。

引数:
child 削除する子ウィジェット

ContainerWidgetを再定義しています。

プロパティ

override IEnumerable<Widget> Children [get]

子ウィジェットを取得する。

コレクションを反復処理する列挙子を返す。

ContainerWidgetを再定義しています。

float Elasticity [get, set]

ゆがみの弾性率を取得・設定する。

0より大きい値で、大きくなればゆれが大きくなる。初期値は1。


クラス LiveSphere

球体型のウィジェット [詳細]

LiveSphereに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

LiveSphere ()
コンストラクタ
override void | SetSize (float width, float height)
サイズを設定する。
void | Start ()
回転させる。
void | Stop ()
回転を止める。
void | Stop (bool withAnimate)
回転を止める

Protected メソッド

internal override void | OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントハンドラ
internal override void | OnResetState ()
状態リセットハンドラ
override void | OnUpdate (float elapsedTime)
更新処理

プロパティ

int | TurnCount [get, set]
回転数を取得・設定する。（半回転＝１）
float | ZAxis [get, set]
Z軸回転の角度(ラジアン)を取得・設定する。
float | YAxis [get, set]
y軸回転の角度(ラジアン)を取得・設定する。
bool | TouchEnabled [get, set]
タッチ操作（ドラッグ、フリック）を有効にするかどうかを取得・設定する。
bool | ToggleEnabled [get, set]
トグル操作を有効にするかどうかを取得・設定する。
override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
ImageAsset | Image [get, set]
画像を取得・設定する。
bool | FrontFace [get]
球の前面が表示されているかどうかを取得する。

イベント

EventHandler< TouchEventArgs > | ButtonAction
ボタンアクション発火時に呼び出されるハンドラ

説明

球体型のウィジェット

フリックで回転させることが出来る。

メソッド

internal override void OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントハンドラ

引数:
touchEvents タッチイベント

Widgetを再定義しています。

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

override void SetSize | ( | float | width,
 |  | float | height
 | ) |  | [virtual]

サイズを設定する。

球の直径は Width と Height の小さいほうの値になり、中央に表示される。

引数:
width | 幅
height | 高さ

Widgetを再定義しています。

void Stop ( bool withAnimate )

回転を止める

引数:
withAnimate 停止時にスナップのアニメーションをするかどうかを決定するフラグ

プロパティ

override float Height [get, set]

高さを取得・設定する。

球の直径は Width と Height の小さいほうの値になり、中央に表示される。

Widgetを再定義しています。

override float Width [get, set]

幅を取得・設定する。

球の直径は Width と Height の小さいほうの値になり、中央に表示される。

Widgetを再定義しています。


クラス LiveSpringPanel

加速度センサーやパネルの動きに応じて子ウィジェットが揺れるパネル [詳細]

LiveSpringPanelに対する継承グラフ
Panel ContainerWidget Widget

すべてのメンバ一覧

Public メソッド

LiveSpringPanel ()
コンストラクタ
override void | AddChildFirst (Widget child)
子ウィジェットを先頭に追加する。
override void | AddChildLast (Widget child)
子ウィジェットを末尾に追加する。
override void | InsertChildBefore (Widget child, Widget nextChild)
指定した子ウィジェットの直前に挿入する。
override void | InsertChildAfter (Widget child, Widget prevChild)
指定した子ウィジェットの直後に挿入する。
override void | RemoveChild (Widget child)
指定された子ウィジェットを削除する。
void | SetDampingConstant (Widget widget, SpringType type, float dampingConstant)
バネの減衰定数（揺れが収束までの早さ）を設定する。
float | GetDampingConstant (Widget widget, SpringType type)
バネの減衰定数（揺れが収束までの早さ）を取得する。
void | SetSpringConstant (Widget widget, SpringType type, float springConstant)
バネ定数（バネが元の位置に戻ろうとする強さ）を設定する。
float | GetSpringConstant (Widget widget, SpringType type)
バネ定数（バネが元の位置に戻ろうとする強さ）を取得する。
void | SetDisplacement (Widget widget, SpringType type, float displacement)
バネの変化量（初期位置からのずれ）を設定する。
float | GetDisplacement (Widget widget, SpringType type)
バネの変化量（初期位置からのずれ）を取得する。
void | AddAcceleraton (float x, float y, float z)
子ウィジェットに加速度を加える

Protected メソッド

override void | OnUpdate (float elapsedTime)
更新処理
internal override void | OnMotionEvent (MotionEvent motionEvent)
モーションイベントハンドラ

プロパティ

bool | ReflectSensorAcceleration [get, set]
加速度センサーの値を子ウィジェットの動きに反映させるかどうかを取得・設定する。
bool | ReflectMotionAcceleration [get, set]
パネルの動きを子ウィジェットの動きに反映させるかどうかを取得・設定する。

説明

加速度センサーやパネルの動きに応じて子ウィジェットが揺れるパネル

メソッド

void AddAcceleraton | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  |

子ウィジェットに加速度を加える

引数:
x | X方向の加速度
y | Y方向の加速度
z | Z方向の加速度
override void AddChildFirst ( Widget child ) [virtual]

子ウィジェットを先頭に追加する。

引数:
child 追加する子ウィジェット

既に追加されている場合は先頭に移動する。

ContainerWidgetを再定義しています。

override void AddChildLast ( Widget child ) [virtual]

子ウィジェットを末尾に追加する。

引数:
child 追加する子ウィジェット

既に追加されている場合は末尾に移動する。

ContainerWidgetを再定義しています。

float GetDampingConstant | ( | Widget | widget,
 |  | SpringType | type
 | ) |  |

バネの減衰定数（揺れが収束までの早さ）を取得する。

0以上、1以下の値で、大きくなればゆれが収束するまでの時間が短くなる。デフォルトは0.2。

引数:
widget | 減衰定数を取得するウィジェット
type | 減衰定数を取得するバネの種類
float GetDisplacement | ( | Widget | widget,
 |  | SpringType | type
 | ) |  |

バネの変化量（初期位置からのずれ）を取得する。

引数:
widget | 変化量を取得するウィジェット
type | 変化量を取得するバネの種類
float GetSpringConstant | ( | Widget | widget,
 |  | SpringType | type
 | ) |  |

バネ定数（バネが元の位置に戻ろうとする強さ）を取得する。

0以上、1以下の値で、大きくなればゆれが小さくなる。デフォルトは0.3。

引数:
widget | バネ定数を取得するウィジェット
type | バネ定数を取得するバネの種類
override void InsertChildAfter | ( | Widget | child,
 |  | Widget | prevChild
 | ) |  | [virtual]

指定した子ウィジェットの直後に挿入する。

引数:
child | 挿入する子ウィジェット
prevChild | 挿入する子ウィジェットの直前となる子ウィジェット

既に追加されている場合は指定した子ウィジェットの直後に移動する。

ContainerWidgetを再定義しています。

override void InsertChildBefore | ( | Widget | child,
 |  | Widget | nextChild
 | ) |  | [virtual]

指定した子ウィジェットの直前に挿入する。

引数:
child | 挿入する子ウィジェット
nextChild | 挿入する子ウィジェットの直後となる子ウィジェット

既に追加されている場合は指定した子ウィジェットの直前に移動する。

ContainerWidgetを再定義しています。

internal override void OnMotionEvent ( MotionEvent motionEvent ) [protected, virtual]

モーションイベントハンドラ

引数:
motionEvent モーションイベント

Widgetを再定義しています。

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

override void RemoveChild ( Widget child ) [virtual]

指定された子ウィジェットを削除する。

引数:
child 削除するウィジェット

ContainerWidgetを再定義しています。

void SetDampingConstant | ( | Widget | widget,
 |  | SpringType | type,
 |  | float | dampingConstant
 | ) |  |

バネの減衰定数（揺れが収束までの早さ）を設定する。

0以上、1以下の値で、大きくなればゆれが収束するまでの時間が短くなる。デフォルトは0.2。

引数:
widget | 減衰定数を設定するウィジェット。nullを指定するとすべてのウィジェットの減衰定数を変更する。
type | 減衰定数を設定するバネの種類。SpringType.Allを指定するとすべてのバネの減衰定数を変更する。
dampingConstant | 減衰定数
void SetDisplacement | ( | Widget | widget,
 |  | SpringType | type,
 |  | float | displacement
 | ) |  |

バネの変化量（初期位置からのずれ）を設定する。

引数:
widget | 変化量を設定するウィジェット
type | 変化量を設定するバネの種類
displacement | 変化量
void SetSpringConstant | ( | Widget | widget,
 |  | SpringType | type,
 |  | float | springConstant
 | ) |  |

バネ定数（バネが元の位置に戻ろうとする強さ）を設定する。

0以上、1以下の値で、大きくなればゆれが小さくなる。デフォルトは0.3。

引数:
widget | バネ定数を設定するウィジェット。nullを指定するとすべてのWidgetのバネ定数を変更する。
type | バネ定数を設定するバネの種類。SpringType.Allを指定するとすべてのバネの減衰定数を変更する。
springConstant | バネ定数


クラス LongPressEventArgs

ロングプレスイベント引数 [詳細]

LongPressEventArgsに対する継承グラフ
GestureEventArgs

すべてのメンバ一覧

Public メソッド

LongPressEventArgs (Widget source, Vector2 worldPosition, Vector2 localPosition, float elapsedTime)
コンストラクタ

プロパティ

Vector2 | WorldPosition [get, set]
ワールド（スクリーン）座標系での位置を取得する。
Vector2 | LocalPosition [get, set]
ローカル座標系での位置を取得する。
float | ElapsedTime [get, set]
経過時間を取得・設定する。（ミリ秒）

説明

ロングプレスイベント引数

コンストラクタとデストラクタ

LongPressEventArgs | ( | Widget | source,
 |  | Vector2 | worldPosition,
 |  | Vector2 | localPosition,
 |  | float | elapsedTime
 | ) |  |

コンストラクタ

引数:
source | イベント発生元ウィジェット
worldPosition | ワールド（スクリーン）座標系での位置
localPosition | ローカル座標系での位置
elapsedTime | 経過時間


クラス LongPressGestureDetector

ロングプレス検出器 [詳細]

LongPressGestureDetectorに対する継承グラフ
GestureDetector

すべてのメンバ一覧

Public メソッド

LongPressGestureDetector ()
コンストラクタ

Protected メソッド

internal override
GestureDetectorResponse 		OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントを配信する。
internal override void | OnResetState ()
ジェスチャ解析の状態をリセットする。

プロパティ

float | MaxDistance [get, set]
最初のdownの位置からの最大許容距離を取得・設定する。
float | MinPressDuration [get, set]
ロングプレスを検出するまでの最小時間を取得・設定する。（ミリ秒）

イベント

EventHandler< LongPressEventArgs > | LongPressDetected
ロングプレスイベントハンドラ

説明

ロングプレス検出器

メソッド

internal override GestureDetectorResponse OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントを配信する。

引数:
touchEvents タッチイベント
戻り値:
タッチイベント配信の応答

GestureDetectorを実装しています。


クラス MessageDialog

警告のメッセージ等を表示するための特殊化されたモーダルダイアログ [詳細]

MessageDialogに対する継承グラフ
Dialog ContainerWidget Widget

すべてのメンバ一覧

Public メソッド

MessageDialog ()
コンストラクタ
MessageDialog (MessageDialogStyle style, string title, string message)
コンストラクタ

Static Public メソッド

static MessageDialog | CreateAndShow (MessageDialogStyle style, string title, string message)
MessageDialog のインスタンスを生成し表示する。

Protected メソッド

internal override void | Render ()
シーングラフを描画する。
override void | DisposeSelf ()
使用されているリソースを解放する。

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
String | Message [get, set]
メッセージを取得・設定する。
String | Title [get, set]
タイトルを取得・設定する。
bool | ShowTitle [get, set]
タイトルを表示するかどうかを取得・設定する。
MessageDialogStyle | Style [get, set]
メッセージダイアログの種類を取得・設定する。

イベント

EventHandler
< MessageDialogButtonEventArgs > 		ButtonPressed
メッセージダイアログのボタンの押下時に呼び出されるハンドラ

説明

警告のメッセージ等を表示するための特殊化されたモーダルダイアログ

コンストラクタとデストラクタ

MessageDialog | ( | MessageDialogStyle | style,
 |  | string | title,
 |  | string | message
 | ) |  |

コンストラクタ

引数:
style | メッセージダイアログの種類
title | タイトルの文字列
message | メッセージの文字列

メソッド

static MessageDialog CreateAndShow | ( | MessageDialogStyle | style,
 |  | string | title,
 |  | string | message
 | ) |  | [static]

MessageDialog のインスタンスを生成し表示する。

引数:
style | メッセージダイアログの種類
title | タイトルの文字列
message | メッセージの文字列


クラス MessageDialogButtonEventArgs

メッセージダイアログのイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

MessageDialogButtonEventArgs (MessageDialogResult result)
コンストラクタ

プロパティ

MessageDialogResult Result [get]
メッセージダイアログのボタンの種別を取得する。

説明

メッセージダイアログのイベント引数


クラス MotionEvent

モーションイベントクラス [詳細]

すべてのメンバ一覧

Public メソッド

MotionEvent ()
コンストラクタ

プロパティ

Vector3 | Acceleration [get, set]
加速度を取得・設定する。
Vector3 | AngularVelocity [get, set]
角速度を取得・設定する。
TimeSpan | Time [get, set]
イベントが発生した時刻を取得・設定する。

説明

モーションイベントクラス


クラス MotionEventArgs

モーションイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

MotionEventArgs ()
コンストラクタ
MotionEventArgs (MotionEvent motionEvent)
コンストラクタ

プロパティ

Vector3 | Acceleration [get, set]
加速度を取得・設定する。
Vector3 | AngularVelocity [get, set]
角速度を取得・設定する。

説明

モーションイベント引数

コンストラクタとデストラクタ

MotionEventArgs ( MotionEvent motionEvent )

コンストラクタ

引数:
motionEvent モーションセンサー情報


クラス MoveEffect

現在の位置から指定した位置に移動するエフェクト [詳細]

MoveEffectに対する継承グラフ
Effect

すべてのメンバ一覧

Public メソッド

MoveEffect ()
コンストラクタ
MoveEffect (Widget widget, float time, float x, float y, MoveEffectInterpolator interpolator)
コンストラクタ

Static Public メソッド

static MoveEffect | CreateAndStart (Widget widget, float time, float x, float y, MoveEffectInterpolator interpolator)
インスタンスを作成しエフェクトを開始する。

Protected メソッド

override void | OnStart ()
開始処理
override EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | Time [get, set]
持続時間を取得・設定する。（ミリ秒）
float | X [get, set]
親の座標系での移動先のX座標を取得・設定する。
float | Y [get, set]
親の座標系での移動先のY座標を取得・設定する。
MoveEffectInterpolator | Interpolator [get, set]
補間関数の種類を取得・設定する。
AnimationInterpolator | CustomInterpolator [get, set]
カスタムの補間関数を取得・設定する。

説明

現在の位置から指定した位置に移動するエフェクト

コンストラクタとデストラクタ

MoveEffect | ( | Widget | widget,
 |  | float | time,
 |  | float | x,
 |  | float | y,
 |  | MoveEffectInterpolator | interpolator
 | ) |  |

コンストラクタ

引数:
widget | エフェクトの対象となるウィジェット
time | 持続時間（ミリ秒）
x | 親の座標系での移動先のX座標
y | 親の座標系での移動先のY座標
interpolator | 補間関数

メソッド

static MoveEffect CreateAndStart | ( | Widget | widget,
 |  | float | time,
 |  | float | x,
 |  | float | y,
 |  | MoveEffectInterpolator | interpolator
 | ) |  | [static]

インスタンスを作成しエフェクトを開始する。

引数:
widget | エフェクト対象のウィジェット
time | 持続時間（ミリ秒）
x | 親の座標系での移動先のX座標
y | 親の座標系での移動先のY座標
interpolator | 補間関数
戻り値:
エフェクトのインスタンス
override EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Effectを実装しています。


クラス PagePanel

ページ単位でスクロールするコンテナウィジェット [詳細]

PagePanelに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

PagePanel ()
コンストラクタ
int | AddPage ()
末尾のページを追加する。
int | AddPage (Panel panel)
末尾のページを追加する。
int | InsertPage (int index, Panel panel)
指定したページ番号の位置にパネルを挿入する。
void | InsertPage (int index)
指定したページ番号の位置にページを挿入する。
bool | RemovePage (Panel panel)
指定したページを削除する
void | RemovePageAt (int index)
指定したページ番号のページを削除する。
Panel | GetPage (int index)
指定したページのパネルを取得する。
void | ScrollTo (int index, bool withAnimation)
指定したページの位置までスクロールする。

Protected メソッド

override void | DisposeSelf ()
使用されているリソースを解放する。
override void | OnUpdate (float elapsedTime)
更新処理
internal override void | OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントハンドラ
internal override void | OnResetState ()
状態リセットハンドラ
internal override void | OnPreviewKeyEvent (KeyEvent keyEvent)
事前キーイベントのハンドラ

プロパティ

int | PageCount [get]
ページ数を取得する。
int | CurrentPageIndex [get, set]
現在のページ番号を取得・設定する。
override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
override bool | Focusable [get, set]
フォーカスが当たるかどうかを取得・設定する

説明

ページ単位でスクロールするコンテナウィジェット

複数のパネルで構成される。

メソッド

int AddPage ( Panel panel )

末尾のページを追加する。

引数:
panel 追加するPanelオブジェクト
Panel GetPage ( int index )

指定したページのパネルを取得する。

引数:
index 取得するページのインデックス
戻り値:
パネル
int InsertPage | ( | int | index,
 |  | Panel | panel
 | ) |  |

指定したページ番号の位置にパネルを挿入する。

引数:
index | ページを挿入する位置（０～）
panel | 挿入するページのPanelオブジェクト
例外:
ArgumentOutOfRangeException | indexが0未満かPageCountより大きい
ArgumentNullException | panelがnull
void InsertPage ( int index )

指定したページ番号の位置にページを挿入する。

引数:
index ページを挿入する位置（０～）
例外:
ArgumentOutOfRangeException indexが0未満かPageCountより大きい
internal override void OnPreviewKeyEvent ( KeyEvent keyEvent ) [protected, virtual]

事前キーイベントのハンドラ

引数:
keyEvent キーイベント

Widgetを再定義しています。

internal override void OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントハンドラ

引数:
touchEvents タッチイベント

Widgetを再定義しています。

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

bool RemovePage ( Panel panel )

指定したページを削除する

引数:
panel 削除するページ
戻り値:
panelが正常に削除された場合はtrue。それ以外はfalse。panelが見つからなかった場合もfalseを返す。
void RemovePageAt ( int index )

指定したページ番号のページを削除する。

引数:
index 削除するページ番号(０～)
例外:
ArgumentOutOfRangeException indexが0未満かPageCount以上
void ScrollTo | ( | int | index,
 |  | bool | withAnimation
 | ) |  |

指定したページの位置までスクロールする。

引数:
index | ページのインデックス
withAnimation | アニメーションするかどうか


クラス Panel

コンテナの機能を持つウィジェット [詳細]

Panelに対する継承グラフ
ContainerWidget Widget ListPanelItem LiveJumpPanel LiveSpringPanel UIAnimationPlayer

すべてのメンバ一覧

Public メソッド

Panel ()
コンストラクタ

Protected メソッド

internal override void | OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントハンドラ

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
virtual UIColor | BackgroundColor [get, set]
背景色を取得・設定する。
new bool | Clip [get, set]
子ウィジェエットをクリップするかどうかを取得・設定する。

説明

コンテナの機能を持つウィジェット

背景色を設定することができる

メソッド

internal override void OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントハンドラ

引数:
touchEvents タッチイベント

Widgetを再定義しています。


クラス PinchEventArgs

ピンチイベント引数 [詳細]

PinchEventArgsに対する継承グラフ
GestureEventArgs

すべてのメンバ一覧

Public メソッド

PinchEventArgs (Widget source, float distance, float scale, float angle, Vector2 worldCenter, Vector2 localCenter)
コンストラクタ

プロパティ

float | Distance [get, set]
ピンチしている指間の距離を取得する。
float | Scale [get, set]
ピンチ倍率を取得する。
float | Angle [get, set]
ピンチ角度を取得する。
Vector2 | WorldCenterPosition [get, set]
ワールド（スクリーン）座標系での位置を取得する。
Vector2 | LocalCenterPosition [get, set]
ローカル座標系におけるピンチの中心座標を取得する。

説明

ピンチイベント引数

コンストラクタとデストラクタ

PinchEventArgs | ( | Widget | source,
 |  | float | distance,
 |  | float | scale,
 |  | float | angle,
 |  | Vector2 | worldCenter,
 |  | Vector2 | localCenter
 | ) |  |

コンストラクタ

引数:
source | イベント発生元ウィジェット
distance | ピンチ距離
scale | ピンチ倍率
angle | ピンチ角度
worldCenter | ピンチのワールド（スクリーン）座標系での中心座標
localCenter | ピンチのローカル座標系での中心座標

プロパティ

float Angle [get, set]

ピンチ角度を取得する。

ピンチが開始された時の指の角度を基準とした値

float Scale [get, set]

ピンチ倍率を取得する。

ピンチが開始された時の指間の距離を基準とした値


クラス PinchGestureDetector

ピンチ検出器 [詳細]

PinchGestureDetectorに対する継承グラフ
GestureDetector

すべてのメンバ一覧

Public メソッド

PinchGestureDetector ()
コンストラクタ

Protected メソッド

internal override
GestureDetectorResponse 		OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントを配信する。
internal override void | OnResetState ()
ジェスチャ解析の状態をリセットする。

プロパティ

float | MinPinchDistance [get, set]
最小ピンチ距離を取得・設定する。

イベント

EventHandler< PinchEventArgs > | PinchDetected
ピンチイベントハンドラ
EventHandler< PinchEventArgs > | PinchStartDetected
ピンチ開始のイベントハンドラ
EventHandler< PinchEventArgs > | PinchEndDetected
ピンチ終了のイベントハンドラ

説明

ピンチ検出器

メソッド

internal override GestureDetectorResponse OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントを配信する。

引数:
touchEvents タッチイベント
戻り値:
タッチイベント配信の応答

GestureDetectorを実装しています。

プロパティ

float MinPinchDistance [get, set]

最小ピンチ距離を取得・設定する。

2本downしてから2本の相対距離がMinPinchDirection以上変化したらピンチを検出する。


クラス PopupList

複数の選択肢から１つを選択するためのウィジェット [詳細]

PopupListに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

PopupList ()
コンストラクタ

Protected メソッド

override void | DisposeSelf ()
使用されているリソースを解放する。
override void | OnPressStateChanged (PressStateChangedEventArgs e)
プレス状態が変化したときに呼び出される

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
string | ListTitle [get, set]
リストのタイトルを取得・設定する。
UIFont | Font [get, set]
文字列のフォントを取得・設定する。
UIColor | TextColor [get, set]
文字列の色を取得・設定する。
TextShadowSettings | TextShadow [get, set]
文字列の影の情報を取得・設定する。
TextTrimming | TextTrimming [get, set]
文字列のトリミング方法を取得・設定する。
UIFont | ListItemFont [get, set]
リストアイテムのフォントを取得・設定する。
UIColor | ListItemTextColor [get, set]
リストアイテムのテキストカラーを取得・設定する。
UIFont | ListTitleFont [get, set]
リストタイトルのフォントを取得・設定する。
UIColor | ListTitleTextColor [get, set]
リストタイトルのテキストカラーを取得・設定する。
int | SelectedIndex [get, set]
選択されたListItemのIndex
PopupListItemCollection | ListItems [get, set]
リストのアイテムの文字列を取得・設定する。

イベント

EventHandler
< PopupSelectionChangedEventArgs > 		SelectionChanged
選択中のアイテムが変わったときに呼ばれるイベント
EventHandler
< PopupListItemsChangedEventArgs > 		ListItemsChanged
ListItemsプロパティの内容が変更されたときに呼ばれるイベント

説明

複数の選択肢から１つを選択するためのウィジェット

モーダルダイアログでリストが表示される

メソッド

override void OnPressStateChanged ( PressStateChangedEventArgs e ) [protected, virtual]

プレス状態が変化したときに呼び出される

引数:
e イベント引数

Widgetを再定義しています。


クラス PopupListItemCollection

PopupListのListItems用コレクション [詳細]

すべてのメンバ一覧

Public メソッド

PopupListItemCollection ()
コンストラクタ
PopupListItemCollection (IEnumerable< string > items)
コンストラクタ
void | AddRange (IEnumerable< String > items)
複数の項目を末尾に追加する
void | InsertRange (int index, IEnumerable< String > items)
指定したインデックスの位置に複数の項目を挿入する。
int | IndexOf (String item)
指定した項目のインデックスを取得する。
void | Insert (int index, String item)
指定したインデックスの位置に項目を挿入する。
void | RemoveAt (int index)
指定したインデックスにある項目を削除する。
IEnumerator< String > | GetEnumerator ()
コレクションを反復処理する列挙子を返す。
void | Add (String item)
項目
void | Clear ()
すべての項目を削除する。
bool | Contains (String item)
すべての項目を削除する。
void | CopyTo (String[] array, int arrayIndex)
項目を配列にコピーする。
bool | Remove (String item)
最初に見つかった特定の項目を削除する。

プロパティ

String | this [int index] [get, set]
指定したインデックスにある項目を取得・設定する。
int | Count [get]
項目数を取得する。
bool | IsReadOnly [get]
読み取り専用かどうかを取得する。

説明

PopupListのListItems用コレクション

コンストラクタとデストラクタ

PopupListItemCollection ( IEnumerable< string > items )

コンストラクタ

引数:
items 初期値

メソッド

void Add ( String item )

項目

引数:
item 項目
void AddRange ( IEnumerable< String > items )

複数の項目を末尾に追加する

引数:
items 追加する項目のリスト
void CopyTo | ( | String[] | array,
 |  | int | arrayIndex
 | ) |  |

項目を配列にコピーする。

引数:
array | 項目がコピーされるString配列
arrayIndex | コピーの開始位置となる配列のインデックス
IEnumerator<String> GetEnumerator ( )

コレクションを反復処理する列挙子を返す。

戻り値:
コレクションを反復処理するために使用できるIEnumeratorオブジェクト
int IndexOf ( String item )

指定した項目のインデックスを取得する。

引数:
item 検索する文字列
戻り値:
検索する文字列が存在する場合はそのインデックス。それ以外の場合は -1。
void Insert | ( | int | index,
 |  | String | item
 | ) |  |

指定したインデックスの位置に項目を挿入する。

引数:
index | 挿入する位置のインデックス。
item | 挿入する項目
void InsertRange | ( | int | index,
 |  | IEnumerable< String > | items
 | ) |  |

指定したインデックスの位置に複数の項目を挿入する。

引数:
index | 挿入する位置のインデックス。
items | 挿入する項目のリスト
bool Remove ( String item )

最初に見つかった特定の項目を削除する。

引数:
item 削除する項目
戻り値:
削除するセクションが存在する場合はtrue。それ以外の場合はfalse。
void RemoveAt ( int index )

指定したインデックスにある項目を削除する。

引数:
index 削除する項目のインデックス

プロパティ

String this[int index] [get, set]

指定したインデックスにある項目を取得・設定する。

引数:
index 項目のインデックス
戻り値:
指定したインデックスにある項目


  • Sce
  • PlayStation
  • HighLevel
  • UI
  • PopupListItemsChangedEventArgs
Public メソッド

クラス PopupListItemsChangedEventArgs

PopupListのListItemsChangedイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

PopupListItemsChangedEventArgs ()
コンストラクタ

説明

PopupListのListItemsChangedイベント引数


クラス PopupSelectionChangedEventArgs

PopupList の選択中のアイテムが変わったときに呼ばれるイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

PopupSelectionChangedEventArgs (int oldIndex, int newIndex)
PopupList の選択中のアイテムが変わったときのイベント

プロパティ

int | OldIndex [get]
前回選択されていたアイテムのインデックス
int | NewIndex [get]
今回選択されていたアイテムのインデックス

説明

PopupList の選択中のアイテムが変わったときに呼ばれるイベント引数

コンストラクタとデストラクタ

PopupSelectionChangedEventArgs | ( | int | oldIndex,
 |  | int | newIndex
 | ) |  |

PopupList の選択中のアイテムが変わったときのイベント

引数:
oldIndex | 前回選択されていたアイテムのインデックス
newIndex | 今回選択されていたアイテムのインデックス


クラス PressStateChangedEventArgs

PressStateChangedイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

PressStateChangedEventArgs (PressStateChangedReason reason, PressState newState, PressState oldState)
コンストラクタ

プロパティ

PressState | NewState [get, set]
変更後のプレス状態
PressState | OldState [get, set]
変更前のプレス状態
PressStateChangedReason | ChangedReason [get, set]
変更理由

説明

PressStateChangedイベント引数

コンストラクタとデストラクタ

PressStateChangedEventArgs | ( | PressStateChangedReason | reason,
 |  | PressState | newState,
 |  | PressState | oldState
 | ) |  |

コンストラクタ

引数:
reason | 変更理由
newState | 変更後のプレス状態
oldState | 変更前のプレス状態


クラス ProgressBar

進捗の度合いを表示するウィジェット [詳細]

ProgressBarに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

ProgressBar ()
コンストラクタ

Protected メソッド

override void | DisposeSelf ()
使用されているリソースを解放する。
override void | OnUpdate (float elapsedTime)
更新処理

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得する。
float | Progress [get, set]
進捗の度合いを取得・設定する。
ProgressBarStyle | Style [get, set]
プログレスバーの種類を取得・設定する。

説明

進捗の度合いを表示するウィジェット

メソッド

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

プロパティ

override float Height [get, set]

高さを取得する。

設定された値は無視される。

Widgetを再定義しています。


クラス PushTransition

新しいシーンが古いシーンを押しだすトランジション [詳細]

PushTransitionに対する継承グラフ
Transition

すべてのメンバ一覧

Public メソッド

PushTransition ()
コンストラクタ
PushTransition (float time, FourWayDirection direction, PushTransitionInterpolator interpolator)
コンストラクタ

Protected メソッド

override void | OnStart ()
開始処理
override TransitionUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | Time [get, set]
持続時間を取得・設定する。（ミリ秒）
FourWayDirection | MoveDirection [get, set]
トランジションの移動方向を取得・設定する。
PushTransitionInterpolator | Interpolator [get, set]
補間関数の種類を取得・設定する。
AnimationInterpolator | CustomInterpolator [get, set]
カスタムの補間関数を取得・設定する。

説明

新しいシーンが古いシーンを押しだすトランジション

コンストラクタとデストラクタ

PushTransition | ( | float | time,
 |  | FourWayDirection | direction,
 |  | PushTransitionInterpolator | interpolator
 | ) |  |

コンストラクタ

引数:
time | 持続時間（ミリ秒）
direction | トランジションの移動方向
interpolator | 補間関数

メソッド

override TransitionUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Transitionを実装しています。


クラス RootUIElement

エレメントツリーのルート [詳細]

RootUIElementに対する継承グラフ
UIElement

すべてのメンバ一覧

Public メソッド

RootUIElement (Widget parentWidget)
コンストラクタ

Protected メソッド

internal override void SetupFinalAlpha ()
最終的なアルファ値を計算する。

説明

エレメントツリーのルート

各ウィジェットが１つ持つ。


クラス RootWidget

ウィジェットツリーのルート [詳細]

RootWidgetに対する継承グラフ
ContainerWidget Widget

すべてのメンバ一覧

Public メソッド

override bool | HitTest (Vector2 screenPoint)
通常のシーンのRootWidgetはヒットしないため常にfalseを返す

プロパティ

override float | X [get, set]
親の座標系でのX座標を取得する。
override float | Y [get, set]
親の座標系でのY座標を取得する。
override float | Width [get, set]
幅を取得する。
override float | Height [get, set]
高さを取得する。
override Matrix4 | Transform3D [get, set]
親の座標系への変換行列を取得する。

説明

ウィジェットツリーのルート

各シーンが１つ持つ。コンテナ機能を持つ。

メソッド

override bool HitTest ( Vector2 screenPoint ) [virtual]

通常のシーンのRootWidgetはヒットしないため常にfalseを返す

引数:
screenPoint スクリーン座標系での位置
戻り値:
通常はfalse

Widgetを再定義しています。

プロパティ

override float Height [get, set]

高さを取得する。

設定された値は無視される。

ContainerWidgetを再定義しています。

override Matrix4 Transform3D [get, set]

親の座標系への変換行列を取得する。

設定された値は無視される。

Widgetを再定義しています。

override float Width [get, set]

幅を取得する。

設定された値は無視される。

ContainerWidgetを再定義しています。

override float X [get, set]

親の座標系でのX座標を取得する。

設定された値は無視される。

Widgetを再定義しています。

override float Y [get, set]

親の座標系でのY座標を取得する。

設定された値は無視される。

Widgetを再定義しています。


クラス Scene

画面 [詳細]

FocusScene, ModalScene, と NavigationSceneに継承されています。

すべてのメンバ一覧

Public メソッド

Scene ()
コンストラクタ

Protected メソッド

virtual void | OnUpdate (float elapsedTime)
毎フレームの更新処理のハンドラ
virtual internal void | OnShowing ()
画面が表示されるときに呼ばれるイベントハンドラ
virtual internal void | OnShown ()
画面が表示されたとき発行するイベントハンドラ
virtual internal void | OnHiding ()
画面が消えるときに呼ばれるイベントハンドラ
virtual internal void | OnHidden ()
画面が消えたときに呼ばれるイベントハンドラ

プロパティ

string | Title [get, set]
シーンのタイトルを取得・設定する。
RootWidget | RootWidget [get]
ウィジェットツリーのルートを取得する。
Transition | Transition [get, set]
トランジションを取得・設定する。
bool | ShowNavigationBar [get, set]
ナビゲーションバーを表示するかどうかを取得・設定する。
bool | Visible [get, set]
表示するかどうかを取得・設定する。
float | DesignWidth [get, set]
レイアウト用のシーンの初期幅を取得・設定する。
float | DesignHeight [get, set]
レイアウト用のシーンの初期高さを取得・設定する。
Widget | FocusWidget [get, set]
現在このシーンでフォーカスが当たっているウィジェットを取得する
Widget | DefaultFocusWidget [get, set]
最初にフォーカスが当たるウィジェット

イベント

EventHandler< UpdateEventArgs > | Updated
毎フレームの更新時のイベント
EventHandler | Showing
画面が表示されるときに発行するイベント
EventHandler | Shown
画面が表示されたときに発行するイベント
EventHandler | Hiding
画面が消えるときに発行するイベント
EventHandler | Hidden
画面が消えたときに発行するイベント

説明

画面

メソッド

virtual internal void OnHidden ( ) [protected, virtual]

画面が消えたときに呼ばれるイベントハンドラ

Transitionが設定されている場合は、Transitionが終了したときに呼ばれる。Overrideする場合はメソッド内で基本クラスのメソッドを呼び出すこと。

virtual internal void OnHiding ( ) [protected, virtual]

画面が消えるときに呼ばれるイベントハンドラ

Transitionが設定されている場合は、Transitionが開始される前に呼ばれる。Overrideする場合はメソッド内で基本クラスのメソッドを呼び出すこと。

virtual internal void OnShowing ( ) [protected, virtual]

画面が表示されるときに呼ばれるイベントハンドラ

Transitionが設定されている場合は、Transitionが開始される前に呼ばれる。Overrideする場合はメソッド内で基本クラスのメソッドを呼び出すこと。

virtual internal void OnShown ( ) [protected, virtual]

画面が表示されたとき発行するイベントハンドラ

Transitionが設定されている場合は、Transitionが終了したときに呼ばれる。Overrideする場合はメソッド内で基本クラスのメソッドを呼び出すこと。

virtual void OnUpdate ( float elapsedTime ) [protected, virtual]

毎フレームの更新処理のハンドラ

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

プロパティ

Widget DefaultFocusWidget [get, set]

最初にフォーカスが当たるウィジェット

nullの場合は既定のウィジェットになります。

イベント

EventHandler Hidden

画面が消えたときに発行するイベント

Transitionが設定されている場合は、Transitionが終了したときに発行する。

EventHandler Hiding

画面が消えるときに発行するイベント

Transitionが設定されている場合は、Transitionが開始される前に発行する。

EventHandler Showing

画面が表示されるときに発行するイベント

Transitionが設定されている場合は、Transitionが開始される前に発行する。

EventHandler Shown

画面が表示されたときに発行するイベント

Transitionが設定されている場合は、Transitionが終了したときに発行する。


クラス ScrollBar

画面のスクロール位置を把握するためのウィジェット [詳細]

ScrollBarに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

ScrollBar (ScrollBarOrientation orientation)
コンストラクタ

Protected メソッド

override void | DisposeSelf ()
使用されているリソースを解放する。

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
float | Length [get, set]
全体のサイズを取得・設定する。
ScrollBarOrientation | Orientation [get, set]
スクロールバーの方向を取得する。
float | BarPosition [get, set]
バーの位置を取得・設定する。
float | BarLength [get, set]
バーの長さを取得・設定する。

説明

画面のスクロール位置を把握するためのウィジェット

ユーザーが操作することはできない。

コンストラクタとデストラクタ

ScrollBar ( ScrollBarOrientation orientation )

コンストラクタ

引数:
orientation スクロールバーの方向


クラス ScrollPanel

スクロール可能な領域を持つコンテナウィジェット [詳細]

ScrollPanelに対する継承グラフ
ContainerWidget Widget

すべてのメンバ一覧

Public メソッド

ScrollPanel ()
コンストラクタ
override void | AddChildFirst (Widget child)
子ウィジェットを先頭に追加する。
override void | AddChildLast (Widget child)
子ウィジェットを末尾に追加する。
override void | InsertChildBefore (Widget child, Widget nextChild)
指定した子ウィジェットの直前に挿入する。
override void | InsertChildAfter (Widget child, Widget prevChild)
指定した子ウィジェットの直後に挿入する。
override void | RemoveChild (Widget child)
指定された子ウィジェットを削除する。
void | ScrollTo (float x, float y, bool withAnimation)
指定した位置へスクロールする

Protected メソッド

internal override void | OnPreviewKeyEvent (KeyEvent keyEvent)
事前キーイベントのハンドラ
override void | OnUpdate (float elapsedTime)
更新処理
internal override void | OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントハンドラ

プロパティ

override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
float | PanelX [get, set]
親の座標系でのパネルのX座標を取得・設定する。
float | PanelY [get, set]
親の座標系でのパネルのY座標を取得・設定する。
float | PanelWidth [get, set]
パネルの幅を取得・設定する。
float | PanelHeight [get, set]
パネルの高さを取得・設定する。
UIColor | PanelColor [get, set]
パネルの色を取得・設定する。
ScrollBarVisibility | ScrollBarVisibility [get, set]
スクロールバーの見え方を取得・設定する。
bool | HorizontalScroll [get, set]
水平方向のスクロールをするかどうかを取得・設定する。
bool | VerticalScroll [get, set]
垂直方向のスクロールをするかどうかを取得・設定する。
override IEnumerable< Widget > | Children [get]
子ウィジェットを取得する。
override bool | Focusable [get, set]
フォーカスが当たるかどうかを取得・設定する

説明

スクロール可能な領域を持つコンテナウィジェット

メソッド

override void AddChildFirst ( Widget child ) [virtual]

子ウィジェットを先頭に追加する。

引数:
child 追加する子ウィジェット

既に追加されている場合は先頭に移動する。

ContainerWidgetを再定義しています。

override void AddChildLast ( Widget child ) [virtual]

子ウィジェットを末尾に追加する。

引数:
child 追加する子ウィジェット

既に追加されている場合は末尾に移動する。

ContainerWidgetを再定義しています。

override void InsertChildAfter | ( | Widget | child,
 |  | Widget | prevChild
 | ) |  | [virtual]

指定した子ウィジェットの直後に挿入する。

引数:
child | 挿入する子ウィジェット
prevChild | 挿入する子ウィジェットの直前となる子ウィジェット

既に追加されている場合は指定した子ウィジェットの直後に移動する。

ContainerWidgetを再定義しています。

override void InsertChildBefore | ( | Widget | child,
 |  | Widget | nextChild
 | ) |  | [virtual]

指定した子ウィジェットの直前に挿入する。

引数:
child | 挿入する子ウィジェット
nextChild | 挿入する子ウィジェットの直後となる子ウィジェット

既に追加されている場合は指定した子ウィジェットの直前に移動する。

ContainerWidgetを再定義しています。

internal override void OnPreviewKeyEvent ( KeyEvent keyEvent ) [protected, virtual]

事前キーイベントのハンドラ

引数:
keyEvent キーイベント

Widgetを再定義しています。

internal override void OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントハンドラ

引数:
touchEvents タッチイベント

Widgetを再定義しています。

override void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

Widgetを再定義しています。

override void RemoveChild ( Widget child ) [virtual]

指定された子ウィジェットを削除する。

引数:
child 削除する子ウィジェット

ContainerWidgetを再定義しています。

void ScrollTo | ( | float | x,
 |  | float | y,
 |  | bool | withAnimation
 | ) |  |

指定した位置へスクロールする

スクロールできない方向は無視されます。

引数:
x | 右上の内部パネルのX座標。PanelX と正負が反転した値となる。
y | 右上の内部パネルのY座標。PanelY と正負が反転した値となる。
withAnimation | アニメーションするかどうか

プロパティ

override IEnumerable<Widget> Children [get]

子ウィジェットを取得する。

コレクションを反復処理する列挙子を返す。

ContainerWidgetを再定義しています。


クラス SlideInEffect

画面の外から現在の位置まで平行移動するエフェクト [詳細]

SlideInEffectに対する継承グラフ
Effect

すべてのメンバ一覧

Public メソッド

SlideInEffect ()
コンストラクタ
SlideInEffect (Widget widget, float time, FourWayDirection direction, SlideInEffectInterpolator interpolator)
コンストラクタ

Static Public メソッド

static SlideInEffect | CreateAndStart (Widget widget, float time, FourWayDirection direction, SlideInEffectInterpolator interpolator)
インスタンスを作成しエフェクトを開始する。

Protected メソッド

override void | OnStart ()
開始処理
override EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | Time [get, set]
持続時間を取得・設定する。（ミリ秒）
FourWayDirection | MoveDirection [get, set]
エフェクトの移動方向を取得・設定する。
SlideInEffectInterpolator | Interpolator [get, set]
補間関数の種類を取得・設定する。
AnimationInterpolator | CustomInterpolator [get, set]
カスタムの補間関数を取得・設定する。

説明

画面の外から現在の位置まで平行移動するエフェクト

コンストラクタとデストラクタ

SlideInEffect | ( | Widget | widget,
 |  | float | time,
 |  | FourWayDirection | direction,
 |  | SlideInEffectInterpolator | interpolator
 | ) |  |

コンストラクタ

引数:
widget | エフェクト対象のウィジェット
time | 持続時間（ミリ秒）
direction | エフェクトの移動方向
interpolator | 補間関数

メソッド

static SlideInEffect CreateAndStart | ( | Widget | widget,
 |  | float | time,
 |  | FourWayDirection | direction,
 |  | SlideInEffectInterpolator | interpolator
 | ) |  | [static]

インスタンスを作成しエフェクトを開始する。

引数:
widget | エフェクト対象のウィジェット
time | 持続時間（ミリ秒）
direction | エフェクトの移動方向
interpolator | 補間関数
戻り値:
エフェクトのインスタンス
override EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
エフェクトの更新の応答

Effectを実装しています。


クラス SlideOutEffect

現在の位置から画面の外まで平行移動するエフェクト [詳細]

SlideOutEffectに対する継承グラフ
Effect

すべてのメンバ一覧

Public メソッド

SlideOutEffect ()
コンストラクタ
SlideOutEffect (Widget widget, float time, FourWayDirection direction, SlideOutEffectInterpolator interpolator)
コンストラクタ

Static Public メソッド

static SlideOutEffect | CreateAndStart (Widget widget, float time, FourWayDirection direction, SlideOutEffectInterpolator interpolator)
インスタンスを作成しエフェクトを開始する。

Protected メソッド

override void | OnStart ()
開始処理
override EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | Time [get, set]
持続時間を取得・設定する。（ミリ秒）
FourWayDirection | MoveDirection [get, set]
エフェクトの移動方向を取得・設定する。
SlideOutEffectInterpolator | Interpolator [get, set]
補間関数の種類を取得・設定する。
AnimationInterpolator | CustomInterpolator [get, set]
カスタムの補間関数を取得・設定する。

説明

現在の位置から画面の外まで平行移動するエフェクト

コンストラクタとデストラクタ

SlideOutEffect | ( | Widget | widget,
 |  | float | time,
 |  | FourWayDirection | direction,
 |  | SlideOutEffectInterpolator | interpolator
 | ) |  |

コンストラクタ

引数:
widget | エフェクト対象のウィジェット
time | 持続時間（ミリ秒）
direction | エフェクトの移動方向
interpolator | 補間関数

メソッド

static SlideOutEffect CreateAndStart | ( | Widget | widget,
 |  | float | time,
 |  | FourWayDirection | direction,
 |  | SlideOutEffectInterpolator | interpolator
 | ) |  | [static]

インスタンスを作成しエフェクトを開始する。

引数:
widget | エフェクト対象のウィジェット
time | 持続時間（ミリ秒）
direction | エフェクトの移動方向
interpolator | 補間関数
戻り値:
エフェクトのインスタンス
override EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
エフェクトの更新の応答

Effectを実装しています。


クラス Slider

数値などの調整を行うためのウィジェット [詳細]

Sliderに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

Slider ()
コンストラクタ

Protected メソッド

internal override void | OnTouchEvent (Sce.PlayStation.HighLevel.UI.TouchEventCollection touchEvents)
タッチイベントハンドラ
internal override void | OnPreviewKeyEvent (KeyEvent keyEvent)
事前キーイベントのハンドラ
override void | DisposeSelf ()
使用されているリソースを解放する。
internal override void | OnFocusChanged (FocusChangedEventArgs args)
このウィジェットがフォーカスを取得または喪失したときに呼び出される

プロパティ

SliderOrientation | Orientation [get, set]
スライダーの方向を取得・設定する。
bool | FillValue [get, set]
緑色のバーを表示するかどうかを取得・設定する。
float | Value [get, set]
現在の位置を取得・設定する。
float | MinValue [get, set]
最小値を取得・設定する。
float | MaxValue [get, set]
最大値を取得・設定する。
bool | ValueChangeEventEnabled [get, set]
現在の位置が変化したときのイベントを有効にするかどうかを取得・設定する。
override bool | Enabled [get, set]
機能を有効にするかどうかを取得・設定する。
override float | Width [get, set]
幅を取得・設定する。
override float | Height [get, set]
高さを取得・設定する。
override bool | PriorityHit [get, set]
優先してタッチに反応するかどうかを取得・設定する。
float | Step [get, set]
Valueの離散値

イベント

EventHandler
< SliderValueChangeEventArgs > 		ValueChanging
現在の位置が変化しているときに呼び出されるハンドラ
EventHandler
< SliderValueChangeEventArgs > 		ValueChanged
現在の位置が変化したときに呼び出されるハンドラ

説明

数値などの調整を行うためのウィジェット

メソッド

internal override void OnPreviewKeyEvent ( KeyEvent keyEvent ) [protected, virtual]

事前キーイベントのハンドラ

引数:
keyEvent キーイベント

Widgetを再定義しています。

internal override void OnTouchEvent ( Sce.PlayStation.HighLevel.UI.TouchEventCollection touchEvents ) [protected]

タッチイベントハンドラ

引数:
touchEvents タッチイベント

プロパティ

override float Height [get, set]

高さを取得・設定する。

OrientationがHorizontalの場合、設定された値は無視される。

Widgetを再定義しています。

float Step [get, set]

Valueの離散値

0を指定するとValueは連続的な値になる。正の値を指定すると、Valueのとりうる値はMinValue+Step*n（nは整数）とMaxValueになる。

override float Width [get, set]

幅を取得・設定する。

OrientationがVerticalの場合、設定された値は無視される。

Widgetを再定義しています。


クラス SliderValueChangeEventArgs

現在の位置が変化したときのイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

SliderValueChangeEventArgs (float value)
コンストラクタ

プロパティ

float Value [get]
現在の位置を取得する。

説明

現在の位置が変化したときのイベント引数


クラス SlideTransition

平行移動してシーンを切り替えるトランジション [詳細]

SlideTransitionに対する継承グラフ
Transition

すべてのメンバ一覧

Public メソッド

SlideTransition ()
コンストラクタ
SlideTransition (float time, FourWayDirection direction, MoveTarget moveTarget, SlideTransitionInterpolator interpolator)
コンストラクタ

Protected メソッド

override void | OnStart ()
開始処理
override TransitionUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | Time [get, set]
持続時間を取得・設定する。（ミリ秒）
FourWayDirection | MoveDirection [get, set]
トランジションの移動方向を取得・設定する。
MoveTarget | MoveTarget [get, set]
スライドするシーンがCurrentSceneかNextSceneかを取得・設定する
SlideTransitionInterpolator | Interpolator [get, set]
補間関数の種類を取得・設定する。
AnimationInterpolator | CustomInterpolator [get, set]
カスタムの補間関数を設定する。

説明

平行移動してシーンを切り替えるトランジション

MoveTargetプロパティにNextSceneを指定した場合、NextSceneが前面、CurrentSceneが背面になり、NextSceneがMoveDirectionプロパティで指定した方向にスライドインします。 MoveTargetプロパティにCurrentSceneを指定した場合、CurrentSceneが前面、NextSceneが背面になり、CurrentSceneがMoveDirectionプロパティで指定した方向にスライドアウトします。

コンストラクタとデストラクタ

SlideTransition | ( | float | time,
 |  | FourWayDirection | direction,
 |  | MoveTarget | moveTarget,
 |  | SlideTransitionInterpolator | interpolator
 | ) |  |

コンストラクタ

引数:
time | 持続時間（ミリ秒）
direction | トランジションの移動方向
moveTarget | 重ね合わせの優先度
interpolator | 補間関数

メソッド

override TransitionUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
トランジションの更新の応答

Transitionを実装しています。


クラス TapEventArgs

タップイベント引数 [詳細]

TapEventArgsに対する継承グラフ
GestureEventArgs

すべてのメンバ一覧

Public メソッド

TapEventArgs (Widget source, Vector2 worldPosition, Vector2 localPosition)
コンストラクタ

プロパティ

Vector2 | WorldPosition [get, set]
ワールド（スクリーン）座標系での位置を取得する。
Vector2 | LocalPosition [get, set]
ローカル座標系での位置を取得する。

説明

タップイベント引数

コンストラクタとデストラクタ

TapEventArgs | ( | Widget | source,
 |  | Vector2 | worldPosition,
 |  | Vector2 | localPosition
 | ) |  |

コンストラクタ

引数:
source | イベント発生元ウィジェット
worldPosition | ワールド（スクリーン）座標系での位置
localPosition | ローカル座標系での位置


クラス TapGestureDetector

タップ検出器 [詳細]

TapGestureDetectorに対する継承グラフ
GestureDetector

すべてのメンバ一覧

Public メソッド

TapGestureDetector ()
コンストラクタ

Protected メソッド

internal override
GestureDetectorResponse 		OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントを配信する。
internal override void | OnResetState ()
ジェスチャ解析の状態をリセットする。

プロパティ

float | MaxDistance [get, set]
最初のdownの位置からの最大許容距離を取得・設定する。
float | MaxPressDuration [get, set]
downからupまでの最大時間を取得・設定する。（ミリ秒）

イベント

EventHandler< TapEventArgs > | TapDetected
タップイベントハンドラ

説明

タップ検出器

メソッド

internal override GestureDetectorResponse OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントを配信する。

引数:
touchEvents タッチイベント
戻り値:
タッチイベント配信の応答

GestureDetectorを実装しています。


クラス TextChangedEventArgs

テキストを変更したときのイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

TextChangedEventArgs (string oldText, string newText)
コンストラクタ

プロパティ

string | NewText [get]
変更後のテキスト
string | OldText [get]
変更前のテキスト

説明

テキストを変更したときのイベント引数

コンストラクタとデストラクタ

TextChangedEventArgs | ( | string | oldText,
 |  | string | newText
 | ) |  |

コンストラクタ

引数:
oldText | 変更前のテキスト
newText | 変更後のテキスト


クラス TextShadowSettings

文字列の影の設定情報 [詳細]

すべてのメンバ一覧

Public メソッド

TextShadowSettings ()
コンストラクタ

プロパティ

UIColor | Color [get, set]
文字列の影の色を取得・設定する。
float | HorizontalOffset [get, set]
文字列の影の水平方向のオフセット位置を取得・設定する。
float | VerticalOffset [get, set]
文字列の影の垂直方向のオフセット位置を取得・設定する。

説明

文字列の影の設定情報


クラス TiltDropEffect

下方向へ落ちるエフェクト [詳細]

TiltDropEffectに対する継承グラフ
Effect

すべてのメンバ一覧

Public メソッド

TiltDropEffect ()
コンストラクタ
TiltDropEffect (Widget widget)
コンストラクタ

Static Public メソッド

static TiltDropEffect | CreateAndStart (Widget widget)
インスタンスを作成しエフェクトを開始する。

Protected メソッド

override void | OnStart ()
開始処理
override EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | DropDirection [get, set]
落ちる方向（ラジアン）を取得・設定する。
float | Speed [get, set]
エフェクトの速度を取得・設定する。1.0 が標準速度。

説明

下方向へ落ちるエフェクト

コンストラクタとデストラクタ

TiltDropEffect ( Widget widget )

コンストラクタ

引数:
widget エフェクト対象のウィジェット

メソッド

static TiltDropEffect CreateAndStart ( Widget widget ) [static]

インスタンスを作成しエフェクトを開始する。

引数:
widget エフェクト対象のウィジェット
戻り値:
エフェクトのインスタンス
override EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
エフェクトの更新の応答

Effectを実装しています。

プロパティ

float DropDirection [get, set]

落ちる方向（ラジアン）を取得・設定する。

下方向が0。


クラス TiltDropTransition

下方向へ落ちるトランジション [詳細]

TiltDropTransitionに対する継承グラフ
Transition

すべてのメンバ一覧

Public メソッド

TiltDropTransition ()
コンストラクタ

Protected メソッド

override void | OnStart ()
開始処理
override TransitionUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | DropDirection [get, set]
落ちる方向（ラジアン）を取得・設定する。
float | Speed [get, set]
落とす速度を取得・設定する。1.0 が標準速度。

説明

下方向へ落ちるトランジション

新しいシーンが後ろから現れる

メソッド

override TransitionUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
トランジションの更新の応答

Transitionを実装しています。

プロパティ

float DropDirection [get, set]

落ちる方向（ラジアン）を取得・設定する。

下方向が0。


クラス TimePicker

時刻を選択するためのウィジェット [詳細]

TimePickerに対する継承グラフ
Widget

すべてのメンバ一覧

Public メソッド

TimePicker ()
コンストラクタ
override bool | HitTest (Vector2 screenPoint)
ヒットテストハンドラ

プロパティ

override float | Width [get, set]
幅を取得する。
override float | Height [get, set]
高さを取得する。
override bool | PriorityHit [get, set]
優先してタッチに反応するかどうかを取得・設定する。
int | Hour [get, set]
時間（24時間表記）を取得・設定する。
int | Minute [get, set]
分を取得・設定する。
DateTime | Time [get, set]
時間をDateTime構造体で取得・設定する。

イベント

EventHandler
< TimePickerValueChangedEventArgs > 		ValueChanged
値が変更されたときに発行されるイベント

説明

時刻を選択するためのウィジェット

メソッド

override bool HitTest ( Vector2 screenPoint ) [virtual]

ヒットテストハンドラ

引数:
screenPoint スクリーン座標系での位置
戻り値:
ヒットしている場合はtrue。ヒットしていない場合はfalse。

Widgetを再定義しています。

プロパティ

override float Height [get, set]

高さを取得する。

設定された値は無視される。

Widgetを再定義しています。

DateTime Time [get, set]

時間をDateTime構造体で取得・設定する。

設定時に時間と分以外は無視され、取得時の日付は1年1月1日になります。

override float Width [get, set]

幅を取得する。

設定された値は無視される。

Widgetを再定義しています。


クラス TimePickerValueChangedEventArgs

TimePicker の値が変更されたときのイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

TimePickerValueChangedEventArgs ()
コンストラクタ
override string | ToString ()
文字列を取得する。

プロパティ

int | NewHour [get, set]
今回選択された時間
int | NewMinute [get, set]
今回選択された分
int | OldHour [get, set]
前回選択されていた時間
int | OldMinute [get, set]
前回選択されていた分

説明

TimePicker の値が変更されたときのイベント引数

メソッド

override string ToString ( )

文字列を取得する。

戻り値:
変換された文字列


クラス TouchEvent

タッチイベントクラス [詳細]

すべてのメンバ一覧

Public メソッド

TouchEvent ()
コンストラクタ

プロパティ

Widget | Source [get, set]
実際にタッチされたウィジェット。
Vector2 | WorldPosition [get, set]
ワールド（スクリーン）座標系での位置を取得・設定する。
Vector2 | LocalPosition [get, set]
ローカル座標系での位置を取得・設定する。
TimeSpan | Time [get, set]
イベントが発生した時刻を取得・設定する。
TouchEventType | Type [get, set]
タッチイベントの種類を取得・設定する。
int | FingerID [get, set]
指のIDを取得・設定する。

説明

タッチイベントクラス

プロパティ

Widget Source [get, set]

実際にタッチされたウィジェット。

子ウィジェットのタッチイベントをフックした場合に、どの子ウィジェットに対するタッチイベントだったのかを判定する場合などに用います。


クラス TouchEventArgs

タッチイベント引数 [詳細]

すべてのメンバ一覧

Public メソッド

TouchEventArgs (TouchEventCollection touchEvents)
コンストラクタ

プロパティ

TouchEventCollection | TouchEvents [get, set]
ウィジェットに配信された全てのタッチイベントを取得する。
bool | Forward [get, set]
タッチイベント引数に含まれるタッチイベントをフォワードするかどうかを取得・設定する。初期値はFalse。

説明

タッチイベント引数


クラス TouchEventCollection

複数のタッチイベントをまとめて保持するクラス [詳細]

すべてのメンバ一覧

Public メソッド

TouchEventCollection ()
コンストラクタ
TouchEvent | GetTouchEventByID (int id)
指定した指のIDのタッチイベントを取得する。
int | Add (TouchEvent touchEvent)
タッチイベントを追加する。
void | Insert (int index, TouchEvent touchEvent)
指定したインデックス位置にタッチイベントを追加する。
int | IndexOf (TouchEvent touchEvent)
指定したタッチイベントのインデックスを取得する。
void | Remove (TouchEvent touchEvent)
指定したタッチイベントを削除する。
bool | Contains (TouchEvent touchEvent)
指定したタッチイベントが含まれているかどうかを取得する。

プロパティ

TouchEvent | this [int index] [get, set]
インデクサー
TouchEvent | PrimaryTouchEvent [get, set]
ウィジェットに最初に触れた指のタッチイベントを取得する。
bool | Forward [get, set]
コレクションに含まれるタッチイベントをフォワードするかどうかを取得・設定する。初期値はFalse。

説明

複数のタッチイベントをまとめて保持するクラス

メソッド

int Add ( TouchEvent touchEvent )

タッチイベントを追加する。

引数:
touchEvent タッチイベント
bool Contains ( TouchEvent touchEvent )

指定したタッチイベントが含まれているかどうかを取得する。

引数:
touchEvent タッチイベント
戻り値:
含まれているかどうか
TouchEvent GetTouchEventByID ( int id )

指定した指のIDのタッチイベントを取得する。

引数:
id 指のID
戻り値:
タッチイベント
int IndexOf ( TouchEvent touchEvent )

指定したタッチイベントのインデックスを取得する。

引数:
touchEvent タッチイベント
戻り値:
インデックス
void Insert | ( | int | index,
 |  | TouchEvent | touchEvent
 | ) |  |

指定したインデックス位置にタッチイベントを追加する。

引数:
index | インデックス
touchEvent | タッチイベント
void Remove ( TouchEvent touchEvent )

指定したタッチイベントを削除する。

引数:
touchEvent タッチイベント


クラス Transition

シーンに適用するアニメーションの基底クラス [詳細]

Transitionに対する継承グラフ
CrossFadeTransition FlipBoardTransition JumpFlipTransition PushTransition SlideTransition TiltDropTransition

すべてのメンバ一覧

Public メソッド

Transition ()
コンストラクタ

Protected メソッド

abstract void | OnStart ()
開始処理
abstract TransitionUpdateResponse | OnUpdate (float elapsedTime)
更新処理
abstract void | OnStop ()
停止処理
ImageAsset GetCurrentSceneRenderedImage ()
CurrentScene をオフスクリーンレンダリングしたImageAssetを生成する。
ImageAsset GetNextSceneRenderedImage ()
NextScene をオフスクリーンレンダリングしたImageAssetを生成する。

プロパティ

float | TotalElapsedTime [get, set]
トランジションを開始してからの経過時間を取得する。（ミリ秒）
TransitionDrawOrder | DrawOrder [get, set]
トランジション中の描画順序を取得・設定する。
Scene | NextScene [get]
次に表示するシーンを取得する。
RootUIElement | TransitionUIElement [get]
トランジション中にのみ使用可能なエレメントツリーのルートを取得する。

イベント

EventHandler< EventArgs > | TransitionStopped
トランジション終了時に呼び出されるハンドラ

説明

シーンに適用するアニメーションの基底クラス

メソッド

ImageAsset GetCurrentSceneRenderedImage ( ) [protected]

CurrentScene をオフスクリーンレンダリングしたImageAssetを生成する。

戻り値:
オフスクリーンレンダリングしたImageAsset
ImageAsset GetNextSceneRenderedImage ( ) [protected]

NextScene をオフスクリーンレンダリングしたImageAssetを生成する。

戻り値:
オフスクリーンレンダリングしたImageAsset
abstract void OnStart ( ) [protected, pure virtual]

開始処理

派生クラスで開始処理を実装する。

CrossFadeTransition, FlipBoardTransition, JumpFlipTransition, PushTransition, SlideTransition, と TiltDropTransitionで実装されています。

abstract void OnStop ( ) [protected, pure virtual]

停止処理

派生クラスで停止処理を実装する。

CrossFadeTransition, FlipBoardTransition, JumpFlipTransition, PushTransition, SlideTransition, と TiltDropTransitionで実装されています。

abstract TransitionUpdateResponse OnUpdate ( float elapsedTime ) [protected, pure virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
トランジションの更新の応答

派生クラスで更新処理を実装する。

CrossFadeTransition, FlipBoardTransition, JumpFlipTransition, PushTransition, SlideTransition, と TiltDropTransitionで実装されています。


クラス UIAnimationPlayer

uia 形式のアニメーションを再生するクラス [詳細]

UIAnimationPlayerに対する継承グラフ
Panel ContainerWidget Widget

すべてのメンバ一覧

Public メソッド

UIAnimationPlayer (string filePath)
コンストラクタ
void | Play ()
アニメーションを再生する。
void | Stop ()
アニメーションを停止する。
void | Pause ()
アニメーションを中断する。
void | Resume ()
アニメーションを再開する。
void | ReplaceWidget (string name, Widget widget)
ウィジェットを置き換える。

Static Public メソッド

static UIAnimationPlayer | CreateAndPlay (string filePath)
uia ファイルからUIAnimationPlayerを生成し、アニメーションを再生する。

Protected メソッド

override void | DisposeSelf ()
このウィジェットの所有するアンマネージドリソースを解放する

プロパティ

bool | Playing [get]
アニメーション中かどうかを取得する。
bool | Paused [get]
アニメーションが中断されているかどうかを取得する。
bool | Repeating [get, set]
アニメーションをリピート再生するかどうかを取得・設定する。

イベント

EventHandler< EventArgs > | AnimationStopped
アニメーションを停止したときに呼び出されるハンドラ

説明

uia 形式のアニメーションを再生するクラス

コンストラクタとデストラクタ

UIAnimationPlayer ( string filePath )

コンストラクタ

引数:
filePath uia ファイルのパス

メソッド

static UIAnimationPlayer CreateAndPlay ( string filePath ) [static]

uia ファイルからUIAnimationPlayerを生成し、アニメーションを再生する。

引数:
filePath uia ファイルのパス
戻り値:
UIAnimationPlayerのインスタンス
void ReplaceWidget | ( | string | name,
 |  | Widget | widget
 | ) |  |

ウィジェットを置き換える。

引数:
name | 削除するウィジェット名
widget | 追加するウィジェット


クラス UIDebug

UI Toolkit のデバッグに使用するユーティリティクラス [詳細]

すべてのメンバ一覧

Static Public メソッド

static void | Assert (bool condition)
条件がfalseの場合、コンソール画面にアサーションの失敗のメッセージを出力する
static void | Assert (bool condition, string message)
条件がfalseの場合、コンソール画面にアサーションの失敗のメッセージを出力する
static void | Assert (bool condition, string message, string detailMessage)
条件がfalseの場合、コンソール画面にアサーションの失敗のメッセージを出力する
static void | Assert (bool condition, string message, string detailMessageFormat, params Object[] args)
条件がfalseの場合、コンソール画面にアサーションの失敗のメッセージを出力する
static void | ExportAllImageAsset ()
キャッシュされているImageAssetをすべて画像ファイルに出力します。
static void | EnableRecordUncachedTexture ()
キャッシュされないImageAssetもExportAllImageAssetで出力できるようにする
static void | ExportImageAsset (ImageAsset imageAsset, string filename)
ImageAssetを画像ファイルに出力する
static void | DumpSceneGraph (string filename)
現在のシーンのウィジェットと描画要素のツリー、および各要素のプロパティをXMLとしてダンプする

プロパティ

static string | ImageExportAlbumName [get, set]
ImageAssetをExportする際のアルバム名を設定、取得する

説明

UI Toolkit のデバッグに使用するユーティリティクラス

このクラスのほとんどのメソッドは、条件付きコンパイル シンボルに "DEBUG" が定義されている場合にのみ動作します。

メソッド

static void Assert ( bool condition ) [static]

条件がfalseの場合、コンソール画面にアサーションの失敗のメッセージを出力する

"DEBUG" コンパイルシンボルが定義されていない場合は、このメソッドの呼び出しは無視されます。

引数:
condition 条件
static void Assert | ( | bool | condition,
 |  | string | message
 | ) |  | [static]

条件がfalseの場合、コンソール画面にアサーションの失敗のメッセージを出力する

"DEBUG" コンパイルシンボルが定義されていない場合は、このメソッドの呼び出しは無視されます。

引数:
condition | 条件
message | メッセージ
static void Assert | ( | bool | condition,
 |  | string | message,
 |  | string | detailMessageFormat,
 |  | params Object[] | args
 | ) |  | [static]

条件がfalseの場合、コンソール画面にアサーションの失敗のメッセージを出力する

"DEBUG" コンパイルシンボルが定義されていない場合は、このメソッドの呼び出しは無視されます。

引数:
condition | 条件
message | メッセージ
detailMessageFormat | 詳細なメッセージの書式文字列
args | >詳細なメッセージの書式パラメータ
static void Assert | ( | bool | condition,
 |  | string | message,
 |  | string | detailMessage
 | ) |  | [static]

条件がfalseの場合、コンソール画面にアサーションの失敗のメッセージを出力する

"DEBUG" コンパイルシンボルが定義されていない場合は、このメソッドの呼び出しは無視されます。

引数:
condition | 条件
message | メッセージ
detailMessage | 詳細なメッセージ
static void DumpSceneGraph ( string filename ) [static]

現在のシーンのウィジェットと描画要素のツリー、および各要素のプロパティをXMLとしてダンプする

filenameにnullを指定した場合はコンソール画面に出力します。 出力されるXMLのフォーマットは暫定です。また、すべてのプロパティメンバが出力されるわけではありません。 "DEBUG" コンパイルシンボルが定義されていない場合は、このメソッドの呼び出しは無視されます。

引数:
filename 出力するファイル名(nullの場合はコンソール画面に出力)
static void EnableRecordUncachedTexture ( ) [static]

キャッシュされないImageAssetもExportAllImageAssetで出力できるようにする

このメソッドはUISystem.Initializeを呼び出す前に呼び出すことができます。 "DEBUG" コンパイルシンボルが定義されていない場合は、このメソッドの呼び出しは無視されます。

static void ExportAllImageAsset ( ) [static]

キャッシュされているImageAssetをすべて画像ファイルに出力します。

"DEBUG" コンパイルシンボルが定義されていない場合は、このメソッドの呼び出しは無視されます。

static void ExportImageAsset | ( | ImageAsset | imageAsset,
 |  | string | filename
 | ) |  | [static]

ImageAssetを画像ファイルに出力する

"DEBUG" コンパイルシンボルが定義されていない場合は、このメソッドの呼び出しは無視されます。

引数:
imageAsset | 出力するImageAsset
filename | ファイル名


クラス UIElement

描画要素の基底クラス [詳細]

UIElementに対する継承グラフ
RootUIElement UIPrimitive UISprite

すべてのメンバ一覧

Public メソッド

UIElement ()
コンストラクタ
void | Dispose ()
このUIElement、および子UIElementの所有するアンマネージドリソースを解放する
void | SetPosition (float x, float y)
親の座標系での位置を設定する。
void | AddChildFirst (UIElement child)
子エレメントを先頭に追加する。
void | AddChildLast (UIElement child)
子エレメントを末尾に追加する。
void | InsertChildBefore (UIElement child, UIElement nextChild)
指定した子エレメントを直前に挿入する。
void | InsertChildAfter (UIElement child, UIElement prevChild)
指定した子エレメントを直後に挿入する。
void | RemoveChild (UIElement child)
指定された子エレメントを削除する。

Protected メソッド

virtual void | Dispose (bool disposing)
このUIElement、および子UIElementの所有するアンマネージドリソースを解放する
virtual void | DisposeSelf ()
このUIElementの所有するアンマネージドリソースを解放する
Texture2D GetTexture ()
テクスチャを取得する
virtual internal void | SetupDrawState ()
描画状態を設定する。
virtual internal void | Render ()
エレメントを描画する。
virtual internal void | SetupFinalAlpha ()
最終的なアルファ値を計算する。
internal void | SetupSortValue ()
Zソートで使用する値を設定する。

プロパティ

float | X [get, set]
親の座標系でのX座標を取得・設定する。
float | Y [get, set]
親の座標系でのY座標を取得・設定する。
float | Alpha [get, set]
透明度を取得・設定する。（０～１）
bool | Visible [get, set]
表示するかどうかを取得・設定する。
TextureFilterMode | TextureFilterMode [get, set]
テクスチャフィルタのモードを取得・設定する。
TextureWrapMode | TextureWrapMode [get, set]
テクスチャラップのモードを取得・設定する。
ImageAsset | Image [get, set]
画像を取得・設定する。
bool | ZSort [get, set]
Zソートするかどうかを取得・設定する。
UIElement | Parent [get]
親エレメントを取得する。
IEnumerable< UIElement > | Children [get]
子エレメントを取得する。
BlendMode | BlendMode [get, set]
ブレンドモードを取得・設定する。
Matrix4 | Transform3D [get, set]
親の座標系への変換行列を取得・設定する。
float | ZSortOffset [get, set]
Zソートオフセットを取得・設定する。
bool | Culling [get, set]
カリングするかどうかを取得・設定する。
ShaderType | ShaderType [get, set]
シェーダープログラムを取得・設定する。
Matrix4 | LocalToWorld [get]
ローカル座標系からワールド座標系に変換する行列を取得する。

説明

描画要素の基底クラス

各ウィジェットの下にシーングラフを構成する。

メソッド

void AddChildFirst ( UIElement child )

子エレメントを先頭に追加する。

引数:
child 追加する子エレメント

既に追加されている場合は先頭に移動する。

void AddChildLast ( UIElement child )

子エレメントを末尾に追加する。

引数:
child 追加する子エレメント

既に追加されている場合は末尾に移動する。

virtual void Dispose ( bool disposing ) [protected, virtual]

このUIElement、および子UIElementの所有するアンマネージドリソースを解放する

親UIElementから自身を削除し、子UIElementに対して DisposeSelf() を再帰的に呼び出します。 派生クラスで Dispose を実装する場合は DisposeSelf() をオーバーライドしてください。

引数:
disposing Dispose() から呼び出された場合 true
void Dispose ( )

このUIElement、および子UIElementの所有するアンマネージドリソースを解放する

このUIElementとそのツリー以下のすべてのUIElementを再帰的に解放します。 一度 Dispose() が呼ばれたUIElementは再利用することはできません。 UIElement派生クラスで Dispose が必要なオブジェクトを作成した場合は、 DisposeSelf() をオーバーライドしてそれらの Dispose を呼ばなければなりません。

virtual void DisposeSelf ( ) [protected, virtual]

このUIElementの所有するアンマネージドリソースを解放する

このメソッドは Dispose() からその子UIElementに対して再帰的に呼び出されます。 派生クラスで Dispose が必要なオブジェクトを作成した場合は、 このメソッドをオーバーライドしてそれらの Dispose を呼ばなければなりません。

UIPrimitive, と UISpriteで再定義されています。

Texture2D GetTexture ( ) [protected]

テクスチャを取得する

戻り値:
テクスチャ
void InsertChildAfter | ( | UIElement | child,
 |  | UIElement | prevChild
 | ) |  |

指定した子エレメントを直後に挿入する。

引数:
child | 挿入する子エレメント
prevChild | 挿入する子エレメントの直前となる子エレメント

既に追加されている場合は指定した子エレメントの直後に移動する。

void InsertChildBefore | ( | UIElement | child,
 |  | UIElement | nextChild
 | ) |  |

指定した子エレメントを直前に挿入する。

引数:
child | 挿入する子エレメント
nextChild | 挿入する子エレメントの直後となる子エレメント

既に追加されている場合は指定した子エレメントの直前に移動する。

void RemoveChild ( UIElement child )

指定された子エレメントを削除する。

引数:
child 削除する子エレメント
void SetPosition | ( | float | x,
 |  | float | y
 | ) |  |

親の座標系での位置を設定する。

引数:
x | 親の座標系でのX座標
y | 親の座標系でのY座標

プロパティ

float Alpha [get, set]

透明度を取得・設定する。（０～１）

すべての子要素に透明度が乗算されて表示される。

IEnumerable<UIElement> Children [get]

子エレメントを取得する。

コレクションを反復処理する列挙子を返す。


クラス UIFont

UIで使用するフォントクラス [詳細]

すべてのメンバ一覧

Public メソッド

UIFont ()
UIFont のコンストラクタ (UIのデフォルト値から作成)
UIFont (string filename, int size, FontStyle style)
UIFont のコンストラクタ(ファイル名とサイズとスタイルから)
UIFont (FontAlias alias, int size, FontStyle style)
UIFont のコンストラクタ(別名とサイズとスタイルから)
Font GetFont ()
UIFont から Core.Imaging.Font クラスを取得します
override int | GetHashCode ()
ハッシュコードを返す
override bool | Equals (object obj)
対象と自分自身が等価かどうか
bool | Equals (UIFont uifont)
対象と自分自身が等価かどうか
override string | ToString ()
文字列を返す

Static Public メソッド

static void | ClearCache ()
キャッシュされている Core.Imaging.Font クラスのオブジェクトをすべて解放します。

プロパティ

string | FileName [get, set]
フォントのファイル名
FontAlias | AliasName [get, set]
フォントの別名
int | Size [get, set]
フォントサイズ
FontStyle | Style [get, set]
フォントスタイル

説明

UIで使用するフォントクラス

システム内で Core.Imaging.Font クラスのオブジェクトを生成しキャッシュします。 UISystem にピクセル密度が設定されている場合はフォントサイズもピクセル密度に応じてスケールされます。

コンストラクタとデストラクタ

UIFont | ( | string | filename,
 |  | int | size,
 |  | FontStyle | style
 | ) |  |

UIFont のコンストラクタ(ファイル名とサイズとスタイルから)

引数:
filename | フォントのファイル名
size | サイズ
style | スタイル
例外:
ArgumentOutOfRangeException size が 1～1024 の範囲外です。

引数 size は 1～1024 の範囲に収まっている必要があります。またフォントによって小さすぎるサイズで生成できない場合があります。

UIFont | ( | FontAlias | alias,
 |  | int | size,
 |  | FontStyle | style
 | ) |  |

UIFont のコンストラクタ(別名とサイズとスタイルから)

引数:
alias | フォントの別名
size | サイズ
style | スタイル
例外:
ArgumentOutOfRangeException size が 1～1024 の範囲外です。

引数 size は 1～1024 の範囲に収まっている必要があります。またフォントによって小さすぎるサイズで生成できない場合があります。

メソッド

override bool Equals ( object obj )

対象と自分自身が等価かどうか

引数:
obj 比較対象
戻り値:
比較結果
bool Equals ( UIFont uifont )

対象と自分自身が等価かどうか

引数:
uifont 比較対象
戻り値:
比較結果
Font GetFont ( )

UIFont から Core.Imaging.Font クラスを取得します

キャッシュされている Core.Imaging.Font の ShallowClone を返します。

戻り値:
Font オブジェクト
override int GetHashCode ( )

ハッシュコードを返す

戻り値:
ハッシュコード
override string ToString ( )

文字列を返す

戻り値:
"フォント名, フォントスタイル, フォントサイズ" 形式の文字列

プロパティ

FontAlias AliasName [get, set]

フォントの別名

FileName が null の場合のみこの値が使用されます。

string FileName [get, set]

フォントのファイル名

null が設定されている場合は AliasName の値が使用されます。 フォントファイルが正しいかどうかの評価は初めて描画される時に行われます。

int Size [get, set]

フォントサイズ

引数 size は 1～1024 の範囲に収まっている必要があります。またフォントによって小さすぎるサイズで生成できない場合があります。

例外:
ArgumentOutOfRangeException size が 1～1024 の範囲外です。


クラス UIMotion

uim 形式のモーションを再生するクラス [詳細]

UIMotionに対する継承グラフ
Effect

すべてのメンバ一覧

Public メソッド

UIMotion (Widget widget, string filePath)
コンストラクタ
new void | Stop ()
エフェクトを停止する。

Static Public メソッド

static UIMotion | CreateAndStart (Widget widget, string filePath)
uim ファイルからUIMotionを生成し、エフェクトを開始する。

Protected メソッド

override void | OnStart ()
開始処理
override EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理
override void | OnRepeat ()
リピート処理

説明

uim 形式のモーションを再生するクラス

コンストラクタとデストラクタ

UIMotion | ( | Widget | widget,
 |  | string | filePath
 | ) |  |

コンストラクタ

引数:
widget | エフェクト対象のウィジェット
filePath | uim ファイルのパス

メソッド

static UIMotion CreateAndStart | ( | Widget | widget,
 |  | string | filePath
 | ) |  | [static]

uim ファイルからUIMotionを生成し、エフェクトを開始する。

引数:
widget | エフェクト対象のウィジェット
filePath | uim ファイルのパス
戻り値:
UIMotionのインスタンス
override void OnRepeat ( ) [protected, virtual]

リピート処理

派生クラスでリピート処理を実装する。

Effectを再定義しています。

override EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
エフェクトの更新の応答

Effectを実装しています。


クラス UIPrimitive

プリミティブ [詳細]

UIPrimitiveに対する継承グラフ
UIElement

すべてのメンバ一覧

Public メソッド

UIPrimitive (DrawMode drawMode, int maxVertexCount)
コンストラクタ
UIPrimitive (DrawMode drawMode, int maxVertexCount, int maxIndexCount)
コンストラクタ
void | SetIndices (ushort[] indices)
インデックス配列を設定する。
UIPrimitiveVertex | GetVertex (int index)
頂点を取得する。

Protected メソッド

override void | DisposeSelf ()
このUIPrimitiveで使用されているアンマネージドリソースを解放する。
internal override void | Render ()
プリミティブを描画する。

プロパティ

DrawMode | DrawMode [get, set]
描画モードを取得・設定する。
int | VertexCount [get, set]
頂点数を取得・設定する。
int | MaxVertexCount [get, set]
頂点数の最大値を取得する。
int | MaxIndexCount [get]
インデックス数の最大値を取得する。
int | IndexCount [get, set]
インデックス数を取得・設定する。

説明

プリミティブ

コンストラクタとデストラクタ

UIPrimitive | ( | DrawMode | drawMode,
 |  | int | maxVertexCount
 | ) |  |

コンストラクタ

引数:
drawMode | 描画モード
maxVertexCount | 頂点の数
UIPrimitive | ( | DrawMode | drawMode,
 |  | int | maxVertexCount,
 |  | int | maxIndexCount
 | ) |  |

コンストラクタ

引数:
drawMode | 描画モード
maxVertexCount | 頂点の数
maxIndexCount | インデックスの数（０ならばインデックス配列を使用しない）

メソッド

UIPrimitiveVertex GetVertex ( int index )

頂点を取得する。

引数:
index インデックス
戻り値:
頂点
void SetIndices ( ushort[] indices )

インデックス配列を設定する。

引数:
indices インデックス配列

プロパティ

int IndexCount [get, set]

インデックス数を取得・設定する。

例外:
ArgumentOutOfRangeException 負、もしくは MaxIndexCount より大きい値が設定されている。
int VertexCount [get, set]

頂点数を取得・設定する。

例外:
ArgumentOutOfRangeException 負、もしくはMaxVertexCountより大きい値が設定されている。


  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UIPrimitiveUtility
Static Public メソッド

クラス UIPrimitiveUtility

プリミティブのユーティリティ [詳細]

すべてのメンバ一覧

Static Public メソッド

static void | SetupNinePatch (UIPrimitive primitive, float width, float height, float offsetX, float offsetY, NinePatchMargin ninePatchMargin)
画像の９パッチ情報をプリミティブに適用する。
static void | SetupNinePatch (UIPrimitive primitive, float width, float height, float offsetX, float offsetY, ImageRect imageRect, NinePatchMargin ninePatchMargin)
画像の９パッチ情報をプリミティブに適用する。
static void | SetupHorizontalThreePatch (UIPrimitive primitive, float width, float height, float offsetX, float offsetY, float leftMargin, float rightMargin)
画像の水平方向の３パッチ情報をプリミティブに適用する。
static void | SetupVerticalThreePatch (UIPrimitive primitive, float width, float height, float offsetX, float offsetY, float topMargin, float bottomMargin)
画像の垂直方向の３パッチ情報をプリミティブに適用する。

説明

プリミティブのユーティリティ

メソッド

static void SetupHorizontalThreePatch | ( | UIPrimitive | primitive,
 |  | float | width,
 |  | float | height,
 |  | float | offsetX,
 |  | float | offsetY,
 |  | float | leftMargin,
 |  | float | rightMargin
 | ) |  | [static]

画像の水平方向の３パッチ情報をプリミティブに適用する。

引数:
primitive | プリミティブ
width | 描画先の幅
height | 描画先の高さ
offsetX | 描画先のX座標のオフセット位置
offsetY | 描画先のY座標のオフセット位置
leftMargin | 画像の左端のマージン
rightMargin | 画像の右端のマージン
static void SetupNinePatch | ( | UIPrimitive | primitive,
 |  | float | width,
 |  | float | height,
 |  | float | offsetX,
 |  | float | offsetY,
 |  | ImageRect | imageRect,
 |  | NinePatchMargin | ninePatchMargin
 | ) |  | [static]

画像の９パッチ情報をプリミティブに適用する。

引数:
primitive | プリミティブ
width | 描画先の幅
height | 描画先の高さ
offsetX | 描画先のX座標のオフセット位置
offsetY | 描画先のY座標のオフセット位置
imageRect | 画像の表示領域
ninePatchMargin | ９パッチ情報
例外:
ArgumentOutOfRangeException プリミティブの最大頂点数、もしくは最大インデックス数が足りない。
static void SetupNinePatch | ( | UIPrimitive | primitive,
 |  | float | width,
 |  | float | height,
 |  | float | offsetX,
 |  | float | offsetY,
 |  | NinePatchMargin | ninePatchMargin
 | ) |  | [static]

画像の９パッチ情報をプリミティブに適用する。

引数:
primitive | プリミティブ
width | 描画先の幅
height | 描画先の高さ
offsetX | 描画先のX座標のオフセット位置
offsetY | 描画先のY座標のオフセット位置
ninePatchMargin | ９パッチ情報
例外:
ArgumentOutOfRangeException プリミティブの最大頂点数、もしくは最大インデックス数が足りない。
static void SetupVerticalThreePatch | ( | UIPrimitive | primitive,
 |  | float | width,
 |  | float | height,
 |  | float | offsetX,
 |  | float | offsetY,
 |  | float | topMargin,
 |  | float | bottomMargin
 | ) |  | [static]

画像の垂直方向の３パッチ情報をプリミティブに適用する。

引数:
primitive | プリミティブ
width | 描画先の幅
height | 描画先の高さ
offsetX | 描画先のX座標のオフセット位置
offsetY | 描画先のY座標のオフセット位置
topMargin | 画像の上端のマージン
bottomMargin | 画像の下端のマージン


クラス UIPrimitiveVertex

UIPrimitiveが管理する頂点データ [詳細]

すべてのメンバ一覧

Public メソッド

UIPrimitiveVertex ()
コンストラクタ
void | SetPosition (float x, float y)
親の座標系での位置を設定する。
void | SetPosition (float x, float y, float z)
親の座標系での位置を設定する。

プロパティ

float | X [get, set]
親の座標系でのX座標を取得・設定する。
float | Y [get, set]
親の座標系でのY座標を取得・設定する。
float | Z [get, set]
親の座標系でのZ座標を取得・設定する。
float | U [get, set]
横方向のテクスチャ座標を取得・設定する。
float | V [get, set]
縦方向のテクスチャ座標を取得・設定する。
UIColor | Color [get, set]
頂点の色を取得・設定する。
Vector3 | Position3D [get, set]
位置を取得・設定する。

説明

UIPrimitiveが管理する頂点データ

メソッド

void SetPosition | ( | float | x,
 |  | float | y
 | ) |  |

親の座標系での位置を設定する。

引数:
x | 親の座標系でのX座標
y | 親の座標系でのY座標
void SetPosition | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  |

親の座標系での位置を設定する。

引数:
x | 親の座標系でのX座標
y | 親の座標系でのY座標
z | 親の座標系でのZ座標


クラス UISprite

複数の矩形をまとめて描画する [詳細]

UISpriteに対する継承グラフ
UIElement

すべてのメンバ一覧

Public メソッド

UISprite (int maxUnitCount)
コンストラクタ
UISpriteUnit | GetUnit (int index)
矩形を取得する。

Protected メソッド

override void | DisposeSelf ()
このUISpriteで使用されているアンマネージドリソースを解放する。
internal override void | Render ()
矩形を描画する。

プロパティ

int | UnitCount [get, set]
表示する矩形の数を取得・設定する。
int | MaxUnitCount [get, set]
矩形の最大数を取得する。

説明

複数の矩形をまとめて描画する

UI作成時に最も多用されるクラス

コンストラクタとデストラクタ

UISprite ( int maxUnitCount )

コンストラクタ

引数:
maxUnitCount 矩形の最大数（1～）

maxUnitCountは1以上の値にクランプされる。

メソッド

UISpriteUnit GetUnit ( int index )

矩形を取得する。

引数:
index 取得する矩形のインデックス
戻り値:
矩形

プロパティ

int UnitCount [get, set]

表示する矩形の数を取得・設定する。

例外:
ArgumentOutOfRangeException 負、もしくは MaxUnitCount より大きい値が設定されている。


クラス UISpriteUnit

UISpriteが管理する矩形データ [詳細]

すべてのメンバ一覧

Public メソッド

UISpriteUnit ()
コンストラクタ
void | SetPosition (float x, float y)
親の座標系での位置を設定する。
void | SetSize (float width, float height)
サイズを設定する。

プロパティ

float | X [get, set]
親の座標系でのX座標を取得・設定する。
float | Y [get, set]
親の座標系でのY座標を取得・設定する。
float | Z [get, set]
親の座標系でのZ座標を取得・設定する。
float | Width [get, set]
幅を取得・設定する。
float | Height [get, set]
高さを取得・設定する。
float | U1 [get, set]
左位置のテクスチャ座標を取得・設定する。
float | V1 [get, set]
上位置のテクスチャ座標を取得・設定する。
float | U2 [get, set]
右位置のテクスチャ座標を取得・設定する。
float | V2 [get, set]
下位置テクスチャ座標を取得・設定する。
UIColor | Color [get, set]
頂点の色を取得・設定する。
Vector3 | Position3D [get, set]
位置を取得・設定する。

説明

UISpriteが管理する矩形データ

メソッド

void SetPosition | ( | float | x,
 |  | float | y
 | ) |  |

親の座標系での位置を設定する。

引数:
x | 親の座標系でのX座標
y | 親の座標系でのY座標
void SetSize | ( | float | width,
 |  | float | height
 | ) |  |

サイズを設定する。

引数:
width | 幅
height | 高さ


  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UISpriteUtility
Static Public メソッド

クラス UISpriteUtility

スプライトのユーティリティ [詳細]

すべてのメンバ一覧

Static Public メソッド

static void | SetupNinePatch (UISprite sprite, float width, float height, float offsetX, float offsetY, NinePatchMargin ninePatchMargin)
画像の９パッチ情報をスプライトに適用する。
static void | SetupHorizontalThreePatch (UISprite sprite, float width, float height, float leftMargin, float rightMargin)
画像の水平方向の３パッチ情報をスプライトに適用する。

説明

スプライトのユーティリティ

メソッド

static void SetupHorizontalThreePatch | ( | UISprite | sprite,
 |  | float | width,
 |  | float | height,
 |  | float | leftMargin,
 |  | float | rightMargin
 | ) |  | [static]

画像の水平方向の３パッチ情報をスプライトに適用する。

引数:
sprite | スプライト
width | 描画先の幅
height | 描画先の高さ
leftMargin | 画像の左端のマージン
rightMargin | 画像の右端のマージン
static void SetupNinePatch | ( | UISprite | sprite,
 |  | float | width,
 |  | float | height,
 |  | float | offsetX,
 |  | float | offsetY,
 |  | NinePatchMargin | ninePatchMargin
 | ) |  | [static]

画像の９パッチ情報をスプライトに適用する。

引数:
sprite | スプライト
width | 描画先の幅
height | 描画先の高さ
offsetX | 描画先のX座標のオフセット位置
offsetY | 描画先のY座標のオフセット位置
ninePatchMargin | ９パッチ情報


クラス UISystem

UI Toolkitのシステム全体の管理を行うクラス [詳細]

すべてのメンバ一覧

Static Public メソッド

static void | Initialize (GraphicsContext graphics)
初期化する。
static void | Initialize (GraphicsContext graphics, float pixelDensity)
初期化する。
static void | Terminate ()
終了する。
static void | Update (List< TouchData > touchDataList)
UIシステム全体を更新する。
static void | Update (List< TouchData > touchDataList, ref GamePadData gamePadData)
UIシステム全体を更新する。
static void | Update (List< TouchData > touchDataList, ref MotionData motionData)
UIシステム全体を更新する。
static void | Update (List< TouchData > touchDataList, ref GamePadData gamePadData, ref MotionData motionData)
UIシステム全体を更新する。
static Widget | FindHitWidget (Vector2 screenPoint)
指定した座標に存在するウィジェットを探す。
static void | CancelKeyEvents ()
現在のキーイベントをすべてキャンセルする
static void | Render ()
UIを描画する。
static void | SetScene (Scene newScene)
シーンを切り替える。
static void | SetScene (Scene newScene, Transition transition)
シーンを切り替える。
static void | PushScene (Scene newScene)
現在のシーンをシーンスタックにプッシュし、シーンを切り替える。
static void | PopScene ()
シーンスタックに最後にプッシュしたシーンに切り替える。
static ShaderProgram | GetShaderProgram (ShaderType type)
シェーダープログラムを取得する。
static void | ResetStateAll ()
全てのウィジェットの状態をリセットする。

プロパティ

static Widget | KeyReceiverWidget [get, set]
キー入力イベントを受けるウィジェットを取得・設定する。
static GamePadData | GamePadData [get, set]
ゲームパッド情報を取得する。
static MotionData | MotionData [get, set]
モーションセンサーの情報を取得する。
static int | FramebufferWidth [get, set]
フレームバッファの幅を取得する。
static int | FramebufferHeight [get, set]
フレームバッファの高さを取得する。
static float | PixelDensity [get]
ピクセル密度を取得する
static Scene | CurrentScene [get, set]
現在表示中のシーンを取得する。
static Transition | ScenePushTransition [get, set]
シーンがプッシュされる時のトランジションを取得・設定する。
static Transition | ScenePopTransition [get, set]
シーンがポップされる時のトランジションを取得・設定する。
static GraphicsContext | GraphicsContext [get, set]
グラフィックスコンテキストを取得する。
static Matrix4 | ViewProjectionMatrix [get, set]
プロジェクション行列を取得する。
static TimeSpan | CurrentTime [get, set]
システムの経過時間を取得する。
static float | KeyLongPressTime [get, set]
キーが押されてからLongPressキーイベントが発行されるまでの時間（ミリ秒）を取得、設定する
static float | KeyRepeatStartTime [get, set]
キーが押されてからRepeatキーイベントが初めて発行されるまでの時間（ミリ秒）を取得、設定する
static float | KeyRepeatIntervalTime [get, set]
Repeatキーイベントが発行される間隔（ミリ秒）を取得、設定する
static float | FocusTimeout [get, set]
無操作時にフォーカスを非アクティブにするまでの時間（ミリ秒）を取得・設定する
static bool | FocusActive [get, set]
フォーカスが現在アクティブかどうかを取得・設定する
static bool | EnabledFocus [get, set]
フォーカス機能を有効にするかどうかを取得・設定する
static bool | SuppressFocusKeyEvent [get, set]
フォーカスのキーイベント配信を一時停止させるかどうかを取得・設定する
static UIColor | FocusFilterColor [get, set]
フォーカスイメージに乗算する色を取得・設定する
static BlendMode | FocusBlendMode [get, set]
フォーカスイメージのブレンドモードを取得・設定する

説明

UI Toolkitのシステム全体の管理を行うクラス

メソッド

static Widget FindHitWidget ( Vector2 screenPoint ) [static]

指定した座標に存在するウィジェットを探す。

戻り値:
見つかったウィジェット。見つからなかった場合はnull。
引数:
screenPoint スクリーン座標系での座標
static ShaderProgram GetShaderProgram ( ShaderType type ) [static]

シェーダープログラムを取得する。

引数:
type シェーダープログラムの種類
戻り値:
シェーダープログラム
static void Initialize ( GraphicsContext graphics ) [static]

初期化する。

引数:
graphics グラフィックスコンテキスト
static void Initialize | ( | GraphicsContext | graphics,
 |  | float | pixelDensity
 | ) |  | [static]

初期化する。

引数:
graphics | グラフィックスコンテキスト
pixelDensity | ピクセル密度
例外:
ArgumentOutOfRangeException pixelDensity が 0.5～4 の範囲外です。
static void PushScene ( Scene newScene ) [static]

現在のシーンをシーンスタックにプッシュし、シーンを切り替える。

引数:
newScene 新しいシーン
static void ResetStateAll ( ) [static]

全てのウィジェットの状態をリセットする。

ウィジェットに登録しているGestureDetectorの状態もリセットされる。

static void SetScene ( Scene newScene ) [static]

シーンを切り替える。

引数:
newScene 新しいシーン
static void SetScene | ( | Scene | newScene,
 |  | Transition | transition
 | ) |  | [static]

シーンを切り替える。

引数:
newScene | 新しいシーン
transition | トランジション
static void Update ( List< TouchData > touchDataList ) [static]

UIシステム全体を更新する。

引数:
touchDataList タッチ情報のリスト
static void Update | ( | List< TouchData > | touchDataList,
 |  | ref GamePadData | gamePadData
 | ) |  | [static]

UIシステム全体を更新する。

引数:
touchDataList | タッチ情報のリスト
gamePadData | ゲームパッド情報
static void Update | ( | List< TouchData > | touchDataList,
 |  | ref MotionData | motionData
 | ) |  | [static]

UIシステム全体を更新する。

引数:
touchDataList | タッチ情報のリスト
motionData | モーションセンサー情報
static void Update | ( | List< TouchData > | touchDataList,
 |  | ref GamePadData | gamePadData,
 |  | ref MotionData | motionData
 | ) |  | [static]

UIシステム全体を更新する。

引数:
touchDataList | タッチ情報のリスト
gamePadData | ゲームパッド情報
motionData | モーションセンサー情報

プロパティ

GraphicsContext GraphicsContext [static, get, set]

グラフィックスコンテキストを取得する。

戻り値:
グラフィックスコンテキスト
Widget KeyReceiverWidget [static, get, set]

キー入力イベントを受けるウィジェットを取得・設定する。

nullを指定した場合、キーイベントは無視される。


クラス UpdateEventArgs

更新処理イベントのデータが格納されているクラス [詳細]

すべてのメンバ一覧

Public メソッド

UpdateEventArgs (float elapsedTime)
コンストラクタ

プロパティ

float ElapsedTime [get]
前回のUpdateからの経過時間（ミリ秒）を取得する。

説明

更新処理イベントのデータが格納されているクラス

コンストラクタとデストラクタ

UpdateEventArgs ( float elapsedTime )

コンストラクタ

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）


クラス Widget

ウィジェットの基底クラス [詳細]

Widgetに対する継承グラフ
AnimationImageBox BusyIndicator Button CheckBox ContainerWidget DatePicker EditableText ImageBox Label LiveFlipPanel LiveListPanel LiveSphere PagePanel PopupList ProgressBar ScrollBar Slider TimePicker

すべてのメンバ一覧

Public メソッド

Widget ()
コンストラクタ
void | Dispose ()
このウィジェット、および子ウィジェットの所有するアンマネージドリソースを解放する
virtual void | SetPosition (float x, float y)
親の座標系での位置を設定する。
virtual void | SetSize (float width, float height)
サイズを設定する。
void | SetFocus (bool active)
自分自身にフォーカスをあてる
virtual bool | HitTest (Vector2 screenPoint)
指定した座標でこのウィジェットがヒットするかどうかを取得する
Vector2 | ConvertScreenToLocal (Vector2 screenPoint)
指定した座標をスクリーン座標系からローカル座標系に変換する。
Vector2 | ConvertScreenToLocal (float screenX, float screenY)
指定した座標をスクリーン座標系からローカル座標系に変換する。
Vector2 | ConvertLocalToScreen (Vector2 localPoint)
指定した座標をローカル座標系からスクリーン座標系に変換する。
Vector2 | ConvertLocalToScreen (float localX, float localY)
指定した座標をローカル座標系からスクリーン座標系に変換する。
Vector2 | ConvertLocalToOtherWidget (Vector2 localPoint, Widget targetWidget)
指定した座標を自身のローカル座標系から他のWidgetのローカル座標系に変換する。
Vector2 | ConvertLocalToOtherWidget (float x, float y, Widget targetWidget)
指定した座標を自身のローカル座標系から他のWidgetのローカル座標系に変換する。
void | RenderToTexture (Texture2D texture)
テクスチャへ描画する。
void | RenderToTexture (Texture2D texture, Matrix4 transform)
テクスチャへ描画する。
void | RenderToFrameBuffer (FrameBuffer frameBuffer)
フレームバッファへ描画する。
void | RenderToFrameBuffer (FrameBuffer frameBuffer, Matrix4 transform)
フレームバッファへ描画する。
bool | AddGestureDetector (GestureDetector gestureDetector)
ジェスチャー検出機構を追加する。
bool | RemoveGestureDetector (GestureDetector gestureDetector)
ジェスチャ検出機能を削除する。
override string | ToString ()
文字列を返す

Protected メソッド

virtual void | Dispose (bool disposing)
このウィジェット、および子ウィジェットの所有するアンマネージドリソースを解放する
virtual void | DisposeSelf ()
このウィジェットの所有するアンマネージドリソースを解放する
void | AddChildFirst (Widget child)
子ウィジェットを先頭に追加する。
void | AddChildLast (Widget child)
子ウィジェットを末尾に追加する。
void | InsertChildBefore (Widget child, Widget nextChild)
指定した子ウィジェットの直前に挿入する。
void | InsertChildAfter (Widget child, Widget prevChild)
指定した子ウィジェットの直後に挿入する。
void | RemoveChild (Widget child)
指定された子ウィジェットを削除する。
virtual internal void | OnTouchEvent (TouchEventCollection touchEvents)
タッチイベントハンドラ
virtual internal void | OnKeyEvent (KeyEvent keyEvent)
キーイベントハンドラ
virtual internal void | OnPreviewKeyEvent (KeyEvent keyEvent)
事前キーイベントのハンドラ
internal Widget | SearchNextFocus (FourWayDirection direction)
次にフォーカスの当たるウィジェットを探す
internal Widget | SearchNextFocusFromChild (FourWayDirection direction, Widget currentFocusWidget)
自分の子ウィジェット（子孫を含む）の中から次にフォーカスの当たるウィジェットを探す
virtual internal void | OnMotionEvent (MotionEvent motionEvent)
モーションイベントハンドラ
virtual internal void | OnResetState ()
状態リセットハンドラ
virtual void | OnUpdate (float elapsedTime)
更新処理
virtual internal void | Render ()
シーングラフを描画する。
internal void | ResetState (bool includeSelf)
自分以下の全ウィジェットの状態をリセットする。
virtual internal void | SetupFinalAlpha ()
最終的なアルファ値を計算する。
internal virtual void | OnFocusChanged (FocusChangedEventArgs args)
このウィジェットがフォーカスを取得または喪失したときに呼び出される
virtual void | OnPressStateChanged (PressStateChangedEventArgs e)
プレス状態が変化したときに呼び出される

プロパティ

String | Name [get, set]
ウィジェットの名前を取得・設定する。
internal RootUIElement | RootUIElement [get]
エレメントツリーのルートを取得する。
virtual float | X [get, set]
親の座標系でのX座標を取得・設定する。
virtual float | Y [get, set]
親の座標系でのY座標を取得・設定する。
virtual float | Width [get, set]
幅を取得・設定する。
virtual float | Height [get, set]
高さを取得・設定する。
virtual Matrix4 | Transform3D [get, set]
親の座標系への変換行列を取得・設定する。
virtual float | Alpha [get, set]
透明度を取得・設定する。（０～１）
virtual PivotType | PivotType [get, set]
ウィジェットの原点を取得・設定する。
virtual bool | ZSort [get, set]
Zソートするかどうかを取得・設定する。
virtual float | ZSortOffset [get, set]
Zソートオフセットを取得・設定する。
virtual Anchors | Anchors [get, set]
親のリサイズ時にどこを固定するかを取得・設定する。
virtual bool | Visible [get, set]
表示するかどうかを取得・設定する。
virtual bool | TouchResponse [get, set]
子ウィジェットも含めてタッチイベントに応答するかを取得・設定する。
internal bool | Clip [get, set]
子要素(Widget、UIElement)をクリップするかどうかを取得・設定する。
internal bool | HookChildTouchEvent [get, set]
子ウィジェットのタッチイベントをフックするかどうかを取得・設定する。
Widget | Parent [get]
親ウィジェットを取得する。
IEnumerable< Widget > | Children [get]
子ウィジェットを取得する。
bool | Focused [get]
現在自分にフォーカスが当たっているかどうかを取得する
Matrix4 | LocalToWorld [get]
ローカル座標系からワールド座標系に変換する行列を取得する。
virtual bool | PriorityHit [get, set]
優先してタッチに反応するかどうかを取得・設定する。
virtual bool | Focusable [get, set]
フォーカスが当たるかどうかを取得・設定する
virtual FocusCustomSettings | FocusCustomSettings [get, set]
フォーカスの設定情報を取得・設定する
FocusStyle | FocusStyle [get, set]
フォーカスの表示スタイルを取得・設定する
bool | Pressable [get, set]
タッチやキーでプレスできるかどうかを取得・設定する
virtual PressState | PressState [get, set]
このウィジェットが押されているかどうかの状態を取得・設定する
PressStateTouchLeaveBehavior | TouchLeaveBehavior [get, set]
タッチが領域の内側から外側に移動した場合のプレス状態の挙動を取得・設定する
virtual bool | Enabled [get, set]
機能を有効にするかどうかを取得・設定する

イベント

EventHandler< TouchEventArgs > | TouchEventReceived
タッチイベントを受け取ったときに呼び出されるハンドラ
EventHandler< KeyEventArgs > | KeyEventReceived
キーイベントを受け取ったときに呼び出されるハンドラ
EventHandler< KeyEventArgs > | PreviewKeyEventReceived
事前キーイベントを受け取ったときに呼び出されるハンドラ
EventHandler< MotionEventArgs > | MotionEventReceived
モーションイベントを受け取ったときに呼び出されるハンドラ
EventHandler
< FocusChangedEventArgs > 		FocusChanged
このウィジェットがフォーカスを取得または喪失したときに呼び出されるイベント

説明

ウィジェットの基底クラス

メソッド

void AddChildFirst ( Widget child ) [protected]

子ウィジェットを先頭に追加する。

引数:
child 追加する子ウィジェット

既に追加されている場合は先頭に移動する。

ContainerWidget, LiveScrollPanel, LiveSpringPanel, と ScrollPanelで再定義されています。

void AddChildLast ( Widget child ) [protected]

子ウィジェットを末尾に追加する。

引数:
child 追加する子ウィジェット

既に追加されている場合は末尾に移動する。

ContainerWidget, LiveScrollPanel, LiveSpringPanel, と ScrollPanelで再定義されています。

bool AddGestureDetector ( GestureDetector gestureDetector )

ジェスチャー検出機構を追加する。

引数:
gestureDetector ジェスチャ検出機構
例外:
ArgumentNullException GestureDetectorがnull
戻り値:
追加できたかどうか
Vector2 ConvertLocalToOtherWidget | ( | Vector2 | localPoint,
 |  | Widget | targetWidget
 | ) |  |

指定した座標を自身のローカル座標系から他のWidgetのローカル座標系に変換する。

戻り値:
targetWidget のローカル座標系に変換された座標
引数:
targetWidget | 変換先の Widget
localPoint | 自身のローカル座標系の座標
Vector2 ConvertLocalToOtherWidget | ( | float | x,
 |  | float | y,
 |  | Widget | targetWidget
 | ) |  |

指定した座標を自身のローカル座標系から他のWidgetのローカル座標系に変換する。

戻り値:
targetWidget のローカル座標系に変換された座標
引数:
targetWidget | 変換先の Widget
x | 自身のローカル座標系の座標 X
y | 自身のローカル座標系の座標 Y
Vector2 ConvertLocalToScreen ( Vector2 localPoint )

指定した座標をローカル座標系からスクリーン座標系に変換する。

戻り値:
スクリーン座標系に変換された座標
引数:
localPoint ーカル座標系の座標
Vector2 ConvertLocalToScreen | ( | float | localX,
 |  | float | localY
 | ) |  |

指定した座標をローカル座標系からスクリーン座標系に変換する。

戻り値:
スクリーン座標系に変換された座標
引数:
localX | ローカル座標系の座標 X
localY | ローカル座標系の座標 Y
Vector2 ConvertScreenToLocal ( Vector2 screenPoint )

指定した座標をスクリーン座標系からローカル座標系に変換する。

戻り値:
ローカル座標系に変換された座標
引数:
screenPoint スクリーン座標系の座標
Vector2 ConvertScreenToLocal | ( | float | screenX,
 |  | float | screenY
 | ) |  |

指定した座標をスクリーン座標系からローカル座標系に変換する。

戻り値:
ローカル座標系に変換された座標
引数:
screenX | スクリーン座標系の座標 X
screenY | スクリーン座標系の座標 Y
virtual void Dispose ( bool disposing ) [protected, virtual]

このウィジェット、および子ウィジェットの所有するアンマネージドリソースを解放する

親ウィジェットから自身を削除し、子ウィジェットに対して DisposeSelf() を再帰的に呼び出します。 派生クラスでDisposeを実装する場合は DisposeSelf() をオーバーライドしてください。

引数:
disposing Dispose() から呼び出された場合 true
void Dispose ( )

このウィジェット、および子ウィジェットの所有するアンマネージドリソースを解放する

このウィジェットとそのツリー以下のすべてのウィジェット、およびそれぞれの RootUIElement のツリーに所属するすべての UIElement を再帰的に解放します。 一度 Dispose() が呼ばれたウィジェットは再利用することはできません。 ウィジェット派生クラスでツリーに所属しないウィジェットやUIElement、その他の Dispose が必要なオブジェクトを作成した場合は、 DisposeSelf() をオーバーライドしてそれらの Dispose を呼ばなければなりません。

virtual void DisposeSelf ( ) [protected, virtual]

このウィジェットの所有するアンマネージドリソースを解放する

このメソッドは Dispose() からその子ウィジェットに対して再帰的に呼び出されます。 ウィジェット派生クラスでツリーに所属しないウィジェットやUIElement、その他の Dispose が必要なオブジェクトを作成した場合は、 このメソッドをオーバーライドしてそれらの Dispose を呼ばなければなりません。

BusyIndicator, Button, CheckBox, Dialog, EditableText, Label, ListPanelItem, LiveFlipPanel, LiveScrollPanel, MessageDialog, PagePanel, PopupList, ProgressBar, ScrollBar, Slider, と UIAnimationPlayerで再定義されています。

virtual bool HitTest ( Vector2 screenPoint ) [virtual]

指定した座標でこのウィジェットがヒットするかどうかを取得する

引数:
screenPoint スクリーン座標系での位置
戻り値:
ヒットしている場合はtrue。ヒットしていない場合はfalse。

DatePicker, RootWidget, と TimePickerで再定義されています。

void InsertChildAfter | ( | Widget | child,
 |  | Widget | prevChild
 | ) |  | [protected]

指定した子ウィジェットの直後に挿入する。

引数:
child | 挿入する子ウィジェット
prevChild | 挿入する子ウィジェットの直前となる子ウィジェット

既に追加されている場合は指定した子ウィジェットの直後に移動する。

ContainerWidget, LiveScrollPanel, LiveSpringPanel, と ScrollPanelで再定義されています。

void InsertChildBefore | ( | Widget | child,
 |  | Widget | nextChild
 | ) |  | [protected]

指定した子ウィジェットの直前に挿入する。

引数:
child | 挿入する子ウィジェット
nextChild | 挿入する子ウィジェットの直後となる子ウィジェット

既に追加されている場合は指定した子ウィジェットの直前に移動する。

ContainerWidget, LiveScrollPanel, LiveSpringPanel, と ScrollPanelで再定義されています。

virtual internal void OnKeyEvent ( KeyEvent keyEvent ) [protected, virtual]

キーイベントハンドラ

引数:
keyEvent キーイベント
virtual internal void OnMotionEvent ( MotionEvent motionEvent ) [protected, virtual]

モーションイベントハンドラ

引数:
motionEvent モーションイベント

LiveSpringPanelで再定義されています。

virtual void OnPressStateChanged ( PressStateChangedEventArgs e ) [protected, virtual]

プレス状態が変化したときに呼び出される

引数:
e イベント引数

Button, CheckBox, EditableText, ListPanelItem, と PopupListで再定義されています。

virtual internal void OnPreviewKeyEvent ( KeyEvent keyEvent ) [protected, virtual]

事前キーイベントのハンドラ

引数:
keyEvent キーイベント

GridListPanel, ListPanel, LiveListPanel, PagePanel, ScrollPanel, と Sliderで再定義されています。

virtual internal void OnTouchEvent ( TouchEventCollection touchEvents ) [protected, virtual]

タッチイベントハンドラ

引数:
touchEvents タッチイベント

GridListPanel, ListPanel, LiveFlipPanel, LiveListPanel, LiveScrollPanel, LiveSphere, PagePanel, Panel, と ScrollPanelで再定義されています。

virtual void OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）

AnimationImageBox, Button, EditableText, GridListPanel, ListPanel, LiveFlipPanel, LiveJumpPanel, LiveListPanel, LiveScrollPanel, LiveSphere, LiveSpringPanel, PagePanel, ProgressBar, と ScrollPanelで再定義されています。

void RemoveChild ( Widget child ) [protected]

指定された子ウィジェットを削除する。

引数:
child 削除する子ウィジェット

ContainerWidget, LiveScrollPanel, LiveSpringPanel, と ScrollPanelで再定義されています。

bool RemoveGestureDetector ( GestureDetector gestureDetector )

ジェスチャ検出機能を削除する。

引数:
gestureDetector ジェスチャ検出機構
例外:
ArgumentNullException GestureDetectorがnull
戻り値:
削除できたかどうか
void RenderToFrameBuffer ( FrameBuffer frameBuffer )

フレームバッファへ描画する。

引数:
frameBuffer フレームバッファ
void RenderToFrameBuffer | ( | FrameBuffer | frameBuffer,
 |  | Matrix4 | transform
 | ) |  |

フレームバッファへ描画する。

引数:
frameBuffer | フレームバッファ
transform | 変換行列
void RenderToTexture ( Texture2D texture )

テクスチャへ描画する。

引数:
texture 2Dのテクスチャ
void RenderToTexture | ( | Texture2D | texture,
 |  | Matrix4 | transform
 | ) |  |

テクスチャへ描画する。

引数:
texture | 2Dのテクスチャ
transform | 変換行列
internal void ResetState ( bool includeSelf ) [protected]

自分以下の全ウィジェットの状態をリセットする。

引数:
includeSelf 自分をリセットする場合はtrue。自分をリセットしない場合はfalse。
internal Widget SearchNextFocus ( FourWayDirection direction ) [protected]

次にフォーカスの当たるウィジェットを探す

引数:
direction 方向キーの方向
戻り値:
見つからない場合は null
internal Widget SearchNextFocusFromChild | ( | FourWayDirection | direction,
 |  | Widget | currentFocusWidget
 | ) |  | [protected]

自分の子ウィジェット（子孫を含む）の中から次にフォーカスの当たるウィジェットを探す

自分自身は検索対象から除きます。

引数:
direction | 方向キーの方向
currentFocusWidget | 現在フォーカスのあるウィジェット
戻り値:
見つからない場合は null
void SetFocus ( bool active )

自分自身にフォーカスをあてる

引数:
active true: フォーカスをアクティブにする false: 現状維持

Focusable、Visible、Enabledプロパティおよび表示範囲内にあるかにかかわらずフォーカスを設定します。 active を true に設定した場合でも、所属するSceneがフォーカス対象のSceneでない場合はフォーカスがアクティブになりません。

virtual void SetPosition | ( | float | x,
 |  | float | y
 | ) |  | [virtual]

親の座標系での位置を設定する。

引数:
x | 親の座標系でのX座標
y | 親の座標系でのY座標
virtual void SetSize | ( | float | width,
 |  | float | height
 | ) |  | [virtual]

サイズを設定する。

引数:
width | 幅
height | 高さ

LiveSphereで再定義されています。

override string ToString ( )

文字列を返す

戻り値:
"Name : 型名" 形式の文字列（Nameプロパティが設定されている場合）

プロパティ

virtual float Alpha [get, set]

透明度を取得・設定する。（０～１）

すべての子Widgetに透明度が乗算されて表示される。

IEnumerable<Widget> Children [get, protected]

子ウィジェットを取得する。

コレクションを反復処理する列挙子を返す。

ContainerWidget, LiveScrollPanel, と ScrollPanelで再定義されています。

internal bool Clip [get, set, protected]

子要素(Widget、UIElement)をクリップするかどうかを取得・設定する。

クリップ領域は2次元の座標として計算される。

Panelで再定義されています。

virtual bool Focusable [get, set]

フォーカスが当たるかどうかを取得・設定する

親ウィジェットが false でも、子ウィジェットが true であれば子ウィジェットにフォーカスが当たる可能性があります。

PagePanel, と ScrollPanelで再定義されています。

String Name [get, set]

ウィジェットの名前を取得・設定する。

このプロパティはアプリケーションで任意に使用可能。

virtual PivotType PivotType [get, set]

ウィジェットの原点を取得・設定する。

移動、回転、スケーリングするときの中心となる点。

PressStateTouchLeaveBehavior TouchLeaveBehavior [get, set, protected]

タッチが領域の内側から外側に移動した場合のプレス状態の挙動を取得・設定する

この値は Pressable プロパティがtrueの場合のみ有効です。


クラス ZoomEffect

現在のスケールから指定したスケールに拡大または縮小するエフェクト [詳細]

ZoomEffectに対する継承グラフ
Effect

すべてのメンバ一覧

Public メソッド

ZoomEffect ()
コンストラクタ
ZoomEffect (Widget widget, float time, float scale, ZoomEffectInterpolator interpolator)
コンストラクタ

Static Public メソッド

static ZoomEffect | CreateAndStart (Widget widget, float time, float scale, ZoomEffectInterpolator interpolator)
インスタンスを作成しエフェクトを開始する。

Protected メソッド

override void | OnStart ()
開始処理
override EffectUpdateResponse | OnUpdate (float elapsedTime)
更新処理
override void | OnStop ()
停止処理

プロパティ

float | TargetScaleX [get, set]
目標のX方向のスケールを取得・設定する。（等倍＝１）
float | TargetScaleY [get, set]
目標のY方向のスケールを取得・設定する。（等倍＝１）
float | TargetScaleZ [get, set]
目標のZ方向のスケールを取得・設定する。（等倍＝１）
float | Time [get, set]
アニメーションの時間を取得・設定する。（ミリ秒）
ZoomEffectInterpolator | Interpolator [get, set]
補間関数の種類を取得・設定する。
AnimationInterpolator | CustomInterpolator [get, set]
カスタムの補間関数を取得・設定する。

説明

現在のスケールから指定したスケールに拡大または縮小するエフェクト

コンストラクタとデストラクタ

ZoomEffect | ( | Widget | widget,
 |  | float | time,
 |  | float | scale,
 |  | ZoomEffectInterpolator | interpolator
 | ) |  |

コンストラクタ

引数:
widget | エフェクトの対象となるウィジェット
time | 持続時間（ミリ秒）
scale | 目標のスケール
interpolator | 補間関数

メソッド

static ZoomEffect CreateAndStart | ( | Widget | widget,
 |  | float | time,
 |  | float | scale,
 |  | ZoomEffectInterpolator | interpolator
 | ) |  | [static]

インスタンスを作成しエフェクトを開始する。

引数:
widget | エフェクト対象のウィジェット
time | 持続時間（ミリ秒）
scale | 目標のスケール
interpolator | 補間関数
戻り値:
エフェクトのインスタンス
override EffectUpdateResponse OnUpdate ( float elapsedTime ) [protected, virtual]

更新処理

引数:
elapsedTime 前回のUpdateからの経過時間（ミリ秒）
戻り値:
エフェクトの更新の応答

Effectを実装しています。


構造体 NinePatchMargin

９パッチ情報を格納するための構造体 [詳細]

すべてのメンバ一覧

Public メソッド

NinePatchMargin (int left, int top, int right, int bottom)
コンストラクタ

Public 変数

int | Left
左方向のマージン
int | Top
上方向のマージン
int | Right
右方向のマージン
int | Bottom
下方向のマージン

Static Public 変数

static readonly NinePatchMargin | Zero = new NinePatchMargin()
各メンバの値が0のインスタンス

説明

９パッチ情報を格納するための構造体

コンストラクタとデストラクタ

NinePatchMargin | ( | int | left,
 |  | int | top,
 |  | int | right,
 |  | int | bottom
 | ) |  |

コンストラクタ

引数:
left | 左方向のマージン
top | 上方向のマージン
right | 右方向のマージン
bottom | 下方向のマージン


構造体 UIColor

色を扱う構造体 [詳細]

すべてのメンバ一覧

Public メソッド

UIColor (float r, float g, float b, float a)
コンストラクタ
override bool | Equals (object obj)
対象と自分自身が等価かどうか
bool | Equals (UIColor color)
対象と自分自身が等価かどうか
override int | GetHashCode ()
ハッシュコードを返す
override string | ToString ()
文字列を返す

Static Public メソッド

static | operator Sce.PlayStation.Core.Vector4 (UIColor color)
UIColorからVector4への明示的型変換
static | operator UIColor (Sce.PlayStation.Core.Vector4 vec)
Vector4からUIColorへの明示的型変換
static bool | operator== (UIColor color1, UIColor color2)
比較演算子==
static bool | operator!= (UIColor color1, UIColor color2)
比較演算子!=

Public 変数

float | R
R値
float | G
G値
float | B
B値
float | A
アルファ値

説明

色を扱う構造体

コンストラクタとデストラクタ

UIColor | ( | float | r,
 |  | float | g,
 |  | float | b,
 |  | float | a
 | ) |  |

コンストラクタ

引数:
r | R値(0.0f-1.0f)
g | G値(0.0f-1.0f)
b | B値(0.0f-1.0f)
a | アルファ値(0.0f-1.0f)

メソッド

override string ToString ( )

文字列を返す

戻り値:
"R=0.0000 G=0.0000 B=0.0000 A=0.0000" 形式の文字列


サンプル一覧

Contents

  • サンプルリスト

サンプルリスト

パッケージ | サンプル名 | 概要
Core | MathSample | 数学関数の利用サンプルです。
Graphics | TriangleSample | 三角ポリゴンの表示サンプルです。
 | TextureSample | テクスチャの表示サンプルです。
 | SpriteSample | スプライトの表示サンプルです。
 | SpriteSample2 | スプライトの表示サンプルです。インスタンス描画を使用しています。
 | SpriteSample3 | スプライトを使用してテキストを表示するサンプルです。
 | PrimitiveSample | 各描画プリミティブの表示サンプルです。
 | PixelBufferSample | FrameBufferクラスを用いたオフスクリーンレンダリングのサンプルです。
 | ShaderCatalogSample | いくつかの基本的なシェーダーのサンプルです。
Audio | BgmPlayerSample | BGM再生のサンプルです。
 | SoundPlayerSample | SE再生のサンプルです。
Input | GamePadSample | ゲームパッドでの操作サンプルです。
 | MotionSample | 加速度センサーでの操作サンプルです。
 | TouchSample | タッチパネルでの操作サンプルです。
Imaging | FontSample | フォント表示のサンプルです。
 | ImageSample | Imageクラスの利用サンプルです。
Environment | ClipboardSample | クリップボードの利用サンプルです。
 | DialogSample | 文字入力ダイアログの利用サンプルです。
 | ShellSample | 他のアプリケーションを起動するサンプルです。
 | SystemEventsSample | システムイベントの取得サンプルです。
 | SystemParametersSample | システムパラメータの取得サンプルです。
 | StorageSample | ファイル保存や削除を行うサンプルです。
 | PersistentMemorySample | 永続的なメモリ領域を利用するサンプルです。
Network | HttpSample | HTTP通信のサンプルです。
 | SocketSample | ソケット通信のサンプルです。
 | TwitterSample | Twitterアプリケーションサンプルです。
 | TwitterStreamingSample | Twitterストリーミングアプリケーションサンプルです。
Services | InAppPurchaseSample | アプリ内課金の基本的なサンプルです。API 関数を単純にボタンで呼び出します。
 | InAppPurchaseSample2 | アプリ内課金の標準的なサンプルです。標準的な処理シーケンスを実装しています。
Device | CameraPreviewSample | カメラストリーミングを表示するサンプルです。
 | CameraImportSample | スナップショットを撮影するためのダイアログ機能のサンプルです。
 | PhotoImportSample | 写真選択ダイアログ機能のサンプルです。
 | LocationStateSample | 位置情報取得のサンプルです。
Script | LuaSample | LuaInterfaceを使用した、タッチパネルでの操作サンプルです。
 | LuaTriangleSample | LuaInterfaceを使用した、三角ポリゴンの表示サンプルです。
GameEngine2D | HelloSprite | GameEngine2Dで画面にスプライトを１つ表示するサンプルです。
 | FeatureCatalog | GameEngine2Dの様々な機能を確認できるサンプルです。
 | ActionGameDemo | GameEngine2Dを使った、サイドビューアクションタイプのデモゲームです。
 | PuzzleGameDemo | GameEngine2Dを使った、パズルタイプのデモゲームです。
UI Toolkit | HelloWorld | UI Toolkitで画面に文字列を表示するサンプルです。
 | UICatalog | UI Toolkitで利用可能なウィジェットとアニメーション効果を確認できるサンプルです。
 | Overlay | ３次元グラフィックスにUI Toolkitによる描画を重ねあわせたサンプルです。
 | UIAnimation | UIMotion / UIAnimationPlayer の使用方法を示すサンプルです。
 | ScreenOrientation | 画面の向きを変更するサンプルです。
 | UIToolkit_template | UI Toolkitを利用する際のテンプレートとなるサンプルです。
 | DemoClock | 時計アプリケーションのサンプルです。UI Composerでレイアウトを行っています。
 | DemoGameUI | ゲーム画面とUI Toolkitを組み合わせて利用する方法を示すサンプルです。
 | DemoWeather | 天気予報を表示するアプリケーションのサンプルです。
 | DemoRssReader | RSSリーダーのアプリケーションサンプルです。
 | DemoCalendarMaker | カレンダーを埋め込んだ壁紙を作成するアプリケーションサンプルです。
Model | BasicModelSample | モデルデータのロードと表示を行うサンプルです。
 | BasicProgramSample | 基本シェーダーのサンプルです。
Physics2D | Physics2DSample | ２次元物理シミュレーションのサンプルです。
 | WithGameEngine2D | Physics2DをGameEngine2Dと協調させるサンプルです。
 | Physics2DThread | Physics2Dをメインスレッドとは別のスレッドで動作させるサンプルです。
Tutorial | Tutorial | プログラムガイドで使用するサンプルです。
 | SpriteBuffer | 多数のスプライトを表示するサンプルです。
Tips | SoundDelaySample | サウンド遅延に関するデバイス互換性問題を示すサンプルです。
 | TouchDelaySample | タッチパネル遅延に関するデバイス互換性問題を示すサンプルです。
 | LoadingThreadSample | マルチコア CPU の活用によるパフォーマンス改善を示すサンプルです。
 | SpriteThreadSample | マルチコア CPU の活用によるパフォーマンス改善を示すサンプルです。
Demo | ShootingDemo | 横スクロールシューティングのデモゲームです。
 | FlightDemo | モーションセンサーで飛行機を操縦するデモゲームです。
 | RpgDemo | アクションRPG風のデモゲームです。
 | BallMazeDemo | モーションセンサーを使ってボールを転がして、ゴールまで導くデモゲームです。
 | BrickSmashDemo | 円形に配置されたブロック崩しのデモゲームです。
 | SpaceRocksDemo | 隕石を避けつつ破壊するデモゲームです。
 | Physics2dDemo | ２次元物理シミュレーションのデモゲームです。
 | DefenseDemo | タワーを配置し基地を防衛するシミュレーションデモゲームです。
lib | SampleLib | 各サンプルで共通的に利用され、各サンプルの主機能とは直接関係のないコードです。


MathSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

数学関数の利用サンプルです。

スクリーンショット

動作詳細

以下のメソッドで計算を行い、結果をコンソール画面に出力します。
使用クラス | 使用メソッド
Matrix4 | Matrix4( float ... )
 | Matrix4( Vector4 ... )
 | Identity
 | operator*( Matrix4, Matrix4 )
 | Translation( float, float, float )
 | RotationX( float )
 | RotationY( float )
 | RotationZ( float )
 | RotationYxz( float, float, float )
 | Scale( float, float, float )
 | Perspective( float ... )
 | Frustum( float ... )
 | Ortho( float ... )
 | LookAt( Vector3, Vector3, Vector3 )
 | Inverse()
 | Transpose()
 | TransformPoint( Vector3 )
 | TransformVector( Vector3 )
 | AxisX AxisY ...
Vector3 | Vector3( float ... )
 | Zero One ...
 | operator+( Vector3, Vector3 )
 | operator-( Vector3, Vector3 )
 | operator*( Vector3, Vector3 )
 | operator/( Vector3, Vector3 )
 | Dot( Vector3 )
 | Cross( Vector3 )
 | Length()
 | Normalize()
 | Distance( Vector3 )
 | Angle( Vector3 )
 | Clamp( float, float )
 | Repeat( float, float )
 | Lerp( Vector3, float )
 | Slerp( Vector3, float )
 | Xyz Zyx ...
Quaternion | Quaternion( float ... )
 | Identity
 | operator*( Quaternion, Quaternion )
 | Dot( Quaternion )
 | Length()
 | Normalize()
 | Inverse()
 | Conjugate()
 | Angle( Quaternion )
 | Slerp( Quaternion, float )
 | RotationX( float )
 | RotationY( float )
 | RotationZ( float )
 | RotationYxz( float, float, float )
 | ToMatrix4()
 | FromMatrix4( Matrix4 )


BgmPlayerSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

BGM再生のサンプルです。

スクリーンショット

動作詳細

サウンドの再生/停止/一時停止/再開/ボリューム変更を行います。

"Play"ボタンをタップするとサウンドが再生されます。

"Stop"ボタンをタップするとサウンドが停止します。

"Pause"ボタンをタップするとサウンドが一時停止します。

"Resume"ボタンをタップすると一時停止したサウンドの再生が再開されます。

"Volume"部分の矩形をタップすると、タップした位置に再生ボリュームが変更されます。

グレーアウトしたボタンは操作できません。


SoundPlayerSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

SE再生のサンプルです。

スクリーンショット

動作詳細

4種のSEを個別に再生/停止/ボリューム変更します。

"Play"をタップすると対応したSEが再生されます。

"Stop"をタップすると対応したSEが停止されます。

右側"Volume"部分の矩形をタップすると、対応したSEの再生ボリュームがタップした位置に変更されます。


ClipboardSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

クリップボードの利用サンプルです。

スクリーンショット

動作詳細

クリップボードへの文字のセット、及びクリップボードからの文字の取得を行います。

左上矩形をタップすると文字入力ダイアログが開きます。

"Copy"をタップすると入力した文字列をクリップボードにコピーします。

"Paste"をタップすると右下グレーアウトした矩形にクリップボードの内容が貼り付けられます。


DialogSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

文字入力ダイアログの利用サンプルです。

スクリーンショット

動作詳細

中央の矩形をタップすると文字入力ダイアログが開きます。

ダイアログでOKした場合は、入力した文字列が矩形に表示されます。


ShellSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

ブラウザの起動サンプルです。

スクリーンショット

動作詳細

"Browser"をタップするとブラウザ起動をします。

URLは以下で固定となっています。

http://www.playstation.com/psm/developer/


SystemEventsSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

システムイベントの取得サンプルです。

スクリーンショット

動作詳細

Minimized/Restored のイベントを取得し、コンソール画面へ出力をします。

アプリとしての操作は特になく、最小化/復元を行いコンソール画面の出力結果を確認してください。

ただし現時点では、Simulator の環境では、アプリケーションの最小化を行うと即座に終了してしまうため、Minimized/Restored のイベントを実際に確認することはできません。


SystemParametersSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

システムパラメータの取得サンプルです。

スクリーンショット

動作詳細

GamePadButtonMeaning / Language / YesNoLayout の3つのパラメータを取得し表示します。

アプリ起動と共に上記表示を行うため、ユーザー操作はありません。


StorageSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

ファイル保存や削除を行うサンプルです。

スクリーンショット

動作詳細

テキストボックスに文字列が入力された状態で Write ボタンを押下すると

テキストボックスに入力されたデータがファイルに保存されます。

Read ボタンを押下するとファイルからデータがロードされ、テキストボックスに反映されます。

ファイル存在時に Delete ボタンを押下するとファイルが削除されます。


PersistentMemorySample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

永続的なメモリ領域を利用するサンプルです。

スクリーンショット

動作詳細

「ボタンのオン、オフ、テキストダイアログにテキスト、スライダーの変化量」

などの情報が変化した場合、その情報を永続的なメモリ領域に書き込みます。

サンプルを終了し、再度サンプルを起動すると前回の情報が保持されている状態で起動します。


TriangleSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

三角ポリゴンの表示サンプルです。

スクリーンショット

動作詳細

テクスチャマッピングと頂点カラーが適用された三角ポリゴン1枚を表示します。

ポリゴンは反時計回りに自動的に回転します。


TextureSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

テクスチャの表示サンプルです。

スクリーンショット

動作詳細

いろいろな形式の画像ファイルからテクスチャを作成します。上下ボタンでテクスチャの切り替えを行います。

画面に表示される情報は、以下のとおりです。

  • FileName : 画像ファイル名
  • FileSize : 画像ファイルサイズ
  • MemSize : テクスチャをロードするのに必要なメモリサイズ
  • LoadTime : 画像ファイルをロードするのに要した時間
  • LoadTime(Plain) : コンテンツ保護を無効にした時のロード時間

DDS ファイルには DXT 圧縮が適用可能です。それにより、ファイルサイズ、メモリサイズ、ロード時間を改善することができます。

なお現在のバージョンでは、ピクセルフォーマットが DXT の場合、幅と高さは２のべき乗である必要があります。


SpriteSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

スプライトの表現を行うサンプルです。

スクリーンショット

動作詳細

板ポリゴンにテクスチャを貼り、平行投影を用いてスプライト機能を表現します。

スプライトは直線的に移動し、画面端で反射します。

左右ボタンでスプライトの増減を行い、上下ボタンで全スプライトの拡大/縮小を行います。

○ボタンではスプライトの回転/回転停止を行います。


SpriteSample2

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

スプライトの表現を行うサンプルです。インスタンス描画を使用しています。

スクリーンショット

動作詳細

SpriteSample と似たサンプルですが、インスタンス描画を使用して CPU 負荷を軽減しています。

SpriteSample では 4*N 頂点の VertexBuffer が使用され、スプライトの全ての頂点座標がそれに格納されています。一方このサンプルでは 4 頂点の VertexBuffer と N 頂点の VertexBuffer が使用され、スプライトの形状と位置が別々に格納されています。更新されるデータ量の削減により、CPU 負荷が軽減されます。

インスタンス描画の詳細は、以下の API リファレンスを参照してください。

  • GraphicsContext.DrawArraysInstanced(DrawMode,int,int,int,int)
  • VertexBuffer.VertexBuffer(int,int,int,VertexFormat[])


SpriteSample3

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

スプライトを使用したテキスト表示サンプルです。

スクリーンショット

動作詳細

このサンプルでは単純なフォントマップを作成し、そのフォントマップが適用されたスプライトを使用してテキスト文字を表示しています。

左右ボタンでテキストの増減を行い、上下ボタンで全テキストの拡大/縮小を行います。

○ボタンではテキストアニメーションの再生/停止を行います。


PrimitiveSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

各描画プリミティブの表示サンプルです。

スクリーンショット

動作詳細

各描画プリミティブを表示します。

左右ボタン又は画面タップでプリミティブの種類を変更します。

画面タップは右ボタン押下と同様の動作になります。

プリミティブには以下の種類があります。

  • Point List
  • Line List
  • Line Strip
  • Triangle List
  • Triangle Strip
  • Triangle Fan


PixelBufferSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

FrameBufferクラスを用いたオフスクリーンレンダリングのサンプルです。

スクリーンショット

動作詳細

FrameBufferクラスを利用してオフスクリーンレンダリングした結果をTextureとして描画します。

見た目はTriangleSampleと同様ですが、表示方法が異なります。


ShaderCatalogSample

Contents

  • 概要
  • シェーダーリスト
  • スクリーンショット
  • 動作詳細
  • 操作

概要

いくつかの基本的なシェーダーのサンプルです。

シェーダーリスト

シェーダーサンプル名 | 概要
simple | 射影空間への変換行列を指定し、頂点の位置を変換します。
vertex lighting | ランバート照明モデルを利用して、頂点単位のライティングを行います。
gouraud | ランバート照明モデル及びフォン鏡面反射モデルを利用してVertex単位で頂点カラーを計算し、グーローシェーディングを行います。
phong | ランバート照明モデル及びフォン鏡面反射モデルを利用してFlagment単位でのシェーディングを行います。
glossmap | 8bitグロスマップを鏡面反射光の係数として、ランバート照明モデル及びフォン鏡面反射モデルを利用してFlagment単位でのシェーディングを行います。
texture | マップとして設定したテクスチャのテクセルの値をそのまま描画します。
multitexture | マップA/マップBのテクセル値を乗算(Modulate)して描画します。
toon | 1次元テクスチャを用いた階調レンダリングの対応のみ行い、輪郭抽出は行いません。 ランバート照明モデルを1値(輝度)として計算し、輝度の強度を階調マップのU値として用います。
fog | 頂点シェーダーで視点と頂点の距離を測り、計算したFog色の強さを頂点カラーに設定します。
bumpmap | 法線マップのテクセル値を用いて法線ベクトルを計算し、Flagment単位でのシェーディングを行います。
projection shadow | 2パスのレンダリングを行います。 1パス目では、光源位置にカメラを置いて投影バッファのレンダリングを行います。 2パス目では、シャドウバッファを地面モデルにプロジェクションを行いながらシーンのレンダリングを行います。

スクリーンショット

simple

vertex lighting

gouraud

phong

glossmap

texture

multitexture

toon

fog

bumpmap

projection shadow

動作詳細

各シェーダーを利用して、モデルと地面が表示されます。

地面はフラットなポリゴンになっています。

光源の出るシェーダーでは光源の位置を表すモデルが表示され、自動的にWorldのY軸を中心に回転します。

操作

横ドラッグでモデルをY軸回転します。

縦ドラッグでモデルをX軸回転します。

左右ボタンまたは画面タップでシェーダーを切り替えます。

画面タップは右ボタンと同様の動作になります。

各シェーダーとも、同様の操作です。


FontSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

フォント表示のサンプルです。

スクリーンショット

動作詳細

8ptから3pt刻みで以下の文字列が並べられます。

Xpt / Regular / Bold / Italic / BoldItalic / こんにちは

上記文字列はそれぞれの文字スタイルで表示されます。

画面外へはみ出した場合のクリップ処理などは行っていません。


ImageSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

Imageクラスの利用サンプルです。

スクリーンショット

動作詳細

Imageからテクスチャ生成をして表示します。

左から、

  • Imageを単純にテクスチャとして表示したもの
  • DrawImageを使って、Imageに別のImageを書き込んだものをテクスチャとして表示したもの
  • Cropを使ってImageの一部を切り取ったものをテクスチャとして表示したもの

という3つの画像を表示しています。

起動すると自動的に上記画像を表示するので、操作は特にありません。


GamePadSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

ゲームパッドの操作サンプルです。

スクリーンショット

動作詳細

パッドの各ボタンを押下すると、対応したボタンが"ON"表示に切り替わります。

アナログパッドを操作した場合は、入力されたX,Y値が数値で表示されます。


MotionSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

加速度センサーでの操作サンプルです。

スクリーンショット

動作詳細

端末の動きに合わせて、加速度及び角速度の値を出力します。


TouchSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

タッチパネルでの操作サンプルです。

スクリーンショット

動作詳細

タッチされた部分に塗りつぶしの円/正方形を描きます。

フロントタッチパネルの場合は円を、リアタッチパネルの場合は正方形を描きます。

円/正方形の色は (TouchData.ID % 4) の値により赤/緑/青/黄となります。

円のサイズは半径 96pix, 正方形のサイズは一辺 144pix で固定となっています。


HttpSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

HTTP通信のサンプルです。

スクリーンショット

動作詳細

ConnectボタンをタップするとHTTP通信を開始します。

通信するURLは以下で固定となっています。

http://www.scei.co.jp/index_e.html

通信中はConnectボタンはグレーアウトされ操作できません。

通信が完了すると、ResponseCodeとContentLengthとData内容を表示します。

Data内容についてはテキストで最大1024Byteまで表示されます。


SocketSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • 操作

概要

ソケット通信のサンプルです。

スクリーンショット

動作詳細

画面左側に表示を行うスレッドと、画面右側に表示を行うスレッドの2つのスレッド間でソケット通信を行います。

ソケット通信により左右にある赤と青の矩形の位置を一致させます。

左側スレッドはサーバ役となり None / Listen / Connected の3つのステータスが存在します。

右側スレッドはクライアント役となり None / Connecting / Connected の3つのステータスが存在します。

ステータスが Connected のスレッドはボタン表示が Disconnect に変わります。

切断を認識した場合は、None の状態に戻ります。

操作

"Listen"をタップすることで、左側スレッドが待受け状態になります。

"Connect"をタップすることで、右側スレッドから左側スレッドに接続を開始します。

左右とも Connected になっている間、赤青の矩形位置が一致します。

左側では赤矩形をタップでき、右側では赤矩形をタップできます。


TwitterSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • 制限事項

概要

TwitterSampleは、Twitterライブラリ"TweetSharp"を用いてTwitterへのツイート、トレンド取得などの操作をUI Toolkitで構成したサンプルプログラムです。本サンプルプログラムでは、以下の操作が行うことができます。

・OAuth認証

・ツイート(メッセージを投稿)

・ツイート・リツイート・返信の表示

・認証ユーザー情報(アカウント)の表示

・トレンド表示

・検索

TweetSharp のソースコードは %SCE_PSM_DATA%/source/TweetSharp に格納されています。TweetSharp の詳細については https://github.com/danielcrenna/tweetsharp を参照してください。サンプルのソースコード内で "TweetSharp"という単語を検索すれば、実際にどのように使用されているかが確認できます。

スクリーンショット

動作詳細

OAuth認証を行うためにConsumerKeyとConsumerSecretを取得します。

Twitter DevelopersでTwitterのアプリケーションを作成し、TwitterのConsumerKeyとConsumerSecretをApplication.cs の下記の定数に定義してビルドをします。

TWITTER_CONSUMER_KEY

TWITTER_CONSUMER_SECRET

図1 ログイン画面

ログイン画面(図1)は、起動直後の画面です。"Login"をタップするとブラウザが開き、連携アプリの認証を求められます。"連携アプリを認証"をクリックし遷移先の画面のPIN番号を控えます。

図2 PIN番号画面

PIN番号画面(図2)では、ブラウザで表示されたPIN番号を入力します。PIN番号を入力して"OK"をタップすると認証が完了しホーム画面(図3)が表示します。

図3 ホーム画面

ホーム画面(図3)は"Home"をタップして遷移します。ホーム画面では、認証ユーザーとその友達のリツイートを含む最新のつぶやきを表示します。

図4 つながり画面

つながり画面(図4)は"Connect"をタップして遷移します。つながり画面では、認証ユーザーとその友達を含む返信を表示します。

図5 トレンド画面

トレンド画面(図5)は"Discover"をタップして遷移します。トレンド画面では、認証ユーザーがプロフィールで設定している場所から、その地域で多くつぶやかれている単語を表示します。トレンド画面に表示する時刻およびアイコンは暫定のものです。

図6 アカウント画面

アカウント画面(図6)は"Me"をタップして遷移します。アカウント画面では、認証ユーザーの情報とツイートを表示します。

図7 検索画面

検索画面(図7)は画面上部のテキストエリアに検索したい文字を入力後"Search"をタップして遷移します。検索画面では、ユーザー検索(検索文字を含むユーザーを検索)か、ツイート検索(検索文字を含むツイートを検索)を選択後、"OK"をタップして検索します。

画面上部のテキストエリアにツイートしたい言葉を入力すると、画面上部のテキストエリア横にツイート可能な残りの文字数が表示します。(最大140文字)

画面上部のテキストエリアにツイートしたい言葉を入力後、"Tweet"をタップするとツイートします。"SIGN OUT"をタップすると、現在ログインしているユーザー情報が削除されログイン画面へ遷移します。

制限事項

Proxyサーバー経由でインターネットにアクセスするネットワーク環境では、Windowsのみ正しく動作します。

PlayStation(R)Vitaでは、ログイン画面で"Login"をタップしてもブラウザが開きません。


TwitterStreamingSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • 制限事項

概要

TwitterStreamingSample、twitterライブラリ"TweetSharp"を用いてストリーミングAPIによるツイートの閲覧を行うサンプルプログラムです。本サンプルプログラムでは、以下の内容ができます。

・OAuth認証

・ツイートのストリーミング表示

TweetSharp のソースコードは %SCE_PSM_DATA%/source/TweetSharp に格納されています。TweetSharp の詳細については https://github.com/danielcrenna/tweetsharp を参照してください。サンプルのソースコード内で "TweetSharp"という単語を検索すれば、実際にどのように使用されているかが確認できます。

スクリーンショット

動作詳細

OAuth認証を行うためにConsumerKeyとConsumerSecretを取得します。

Twitter DevelopersでTwitterのアプリケーションを作成し、TwitterのConsumerKeyとConsumerSecretをApplication.cs の下記の定数に定義してビルドをします。

TWITTER_CONSUMER_KEY

TWITTER_CONSUMER_SECRET

図1 ログイン画面

ログイン画面(図1)は、起動直後の画面です。"Login"をタップするとブラウザが開き、連携アプリの認証を求められます。"連携アプリを認証"をクリックし遷移先の画面のPIN番号を控えます。

図2 PIN番号画面

PIN番号画面(図2)では、ブラウザで表示されたPIN番号を入力します。PIN番号を入力して"OK"をタップすると認証が完了しホーム画面(図3)が表示します。

図3 ホーム画面

ホーム画面(図3)ではStreamingAPIで取得した最新のつぶやきを表示します。設定画面による設定をしていない場合、何も表示しません。

図4 設定画面

設定画面(図4)は"Setting"をタップして遷移します。設定画面では、StreamingAPIで取得するパラメータの設定を行います。"OK"をタップすると、ツイートを取得します。

本サンプルプログラムでは、ストリーミングAPIのPublicStreams「statuses/filter」を使用してツイートの取得をしています。設定画面で設定可能なパラメータは以下の通りです。

・track・・・指定したキーワードを含むつぶやきを表示します。キーワードはカンマ区切りで指定可能。(デフォルトに「soccer」を設定しています)

・locations・・・位置情報つきTweetsの場合、指定した場所を絞込んで取得します。（デフォルトに「San Francisco」を設定しています）

・stall_warnings・・・"True"を指定することでWarningsをデータとして取得します。（デフォルトに「Empty」を設定しています）

パラメータの詳細は https://dev.twitter.com/docs/streaming-apis/parameters を参照してください。また、"SIGN OUT"をタップすると、現在ログインしているユーザー情報が削除されログイン画面へ遷移します。

制限事項

Proxyサーバー経由でインターネットにアクセスするネットワーク環境では、Windowsのみ正しく動作します。

PlayStation(R)Vitaでは、ログイン画面で"Login"をタップしてもブラウザが開きません。


CameraPreviewSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

カメラプレビューのサンプルです。

スクリーンショット

動作詳細

ゲームパッドの各ボタンを使用することで以下の操作を行うことができます。

  • ○ボタンを押すと映像データの表示を開始します。
  • △ボタンを押すと映像データの表示を停止します。
  • □ボタンを押すと画面上に各種情報を表示をするかしないかを切り替えます。
  • ×ボタンを押すと映像データの表示を停止して使用しているカメラを閉じます。
  • R ボタンを押すと写真を撮影します。
  • L ボタンを押すと使用するカメラを順番に切り替えます。
  • Left ボタン / Right ボタンを押すとリアルタイムに表示する映像データの解像度を切り替えます。
  • Up ボタン / Down ボタンを押すと撮影する写真の解像度を切り替えます。

画面上に表示される情報は以下の内容です。

  • 画面描画のフレームレート
  • 映像データ取り込みのフレームレート
  • 取り込んだフレームの番号
  • カメラの動作状態
  • 撮影した写真のファイルのパス
  • 表示している映像データの解像度
  • 撮影する写真の解像度


CameraImportSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

写真撮影ダイアログの利用サンプルです。

スクリーンショット

動作詳細

画面右下部の矩形をタップすると写真撮影ダイアログが開きます。

ダイアログで写真撮影された場合は、撮影結果の写真画像が画面に表示されます。


PhotoImportSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

写真選択ダイアログの利用サンプルです。

スクリーンショット

動作詳細

画面右下部の矩形をタップすると写真選択ダイアログが開きます。

ダイアログで写真選択された場合は、選択結果の写真が画面に表示されます。


LocationStateSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

ロケーション取得サンプルです。

ロケーション情報を取得するには、Publishing Utilityの [Metadata]パネル - [Common Property] - [Location] でtrueを選択してください。

スクリーンショット

動作詳細

ロケーション情報を取得し表示します。

ロケーション情報は以下のとおりです。

  • Latitude ：緯度
  • Longitude：経度
  • Altitude ：高度
  • Speed ：移動速度
  • Device ：ロケーション情報を取得することが可能なデバイス
  • Accuracy ：水平誤差
  • Direction：進行方向
  • Received Date & Time：ロケーション情報を取得した日時


InAppPurchaseSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

アプリ内課金の基本的なサンプルです。API 関数を単純にボタンで呼び出します。

スクリーンショット

動作詳細

購入可能なプロダクトのリストが、中央に表示されます。

プロダクトのリストは app.xml に記述されており、Publishing Utility で編集することができます。

ここで表示される情報は以下の通りです。

  • Label : アプリケーションが識別するためのラベル
  • Name : ユーザーに対して表示するための名前
  • Price : ユーザーに対して表示するための価格
  • Ticket : 通常型プロダクトの購入ステータス、または消費型プロダクトの消費可能カウント

なお、開発者環境では価格文字列にラベル文字列が格納されますのでご注意ください。これは価格表示の間違いを避けるための予防措置です。

リスト上のチェックボタンを押すことで、プロダクトを選択できます。

以下のボタンを押すことで、API 関数を呼び出すことができます。

  • GetProductInfo ボタン : プロダクト情報を取得します (プロダクト選択は不要)
  • GetTicketInfo ボタン : チケット情報を取得します (プロダクト選択は不要)
  • Purchase ボタン : プロダクトを購入します
  • Consume ボタン : チケットを消費します

最初に GetProductInfo と GetTicketInfo を実行してください。GetProductInfo 関数は、プロダクトの詳細情報をサーバーから取得します。GetTicketInfo 関数は、購入ずみの権利情報をサーバーから取得します。プロダクトの購入やチケットの消費をおこなうためには、あらかじめこれらの情報が取得されている必要があります。

次にプロダクトを選択して、Purchase や Consume を実行してください。Purchase 関数は、プロダクトの購入をおこないます。Consume 関数は、購入ずみの消費型プロダクトの権利を消費します。これらの処理が成功したとき、アプリがユーザーにプロダクトの使用権を付与します。


InAppPurchaseSample2

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

アプリ内課金の標準的なサンプルです。標準的な処理シーケンスを実装しています。

スクリーンショット

動作詳細

最初のシーンでボタンを押すと、アプリ内課金のシーンが表示されます。

購入可能なプロダクトのリストが、中央に表示されます。リスト上のラジオボタンを押すことで、プロダクトを選択できます。

なお、開発者環境では価格文字列にラベル文字列が格納されますのでご注意ください。これは価格表示の間違いを避けるための予防措置です。

以下のボタンを押すことで、アプリ内課金の操作を実行することができます。

  • Purchase ボタン : プロダクトを購入します
  • Consume ボタン : チケットを消費します
  • Back ボタン : 前のシーンに戻ります

このサンプルでは、以下の処理シーケンスが実装されています。

  • GetProductInfo と GetTicketInfo は自動的に呼び出されます。それらが失敗した場合、エラーメッセージが表示され前のシーンに戻ります。
  • Purchase や Consume が成功した場合、報告メッセージが表示されます。それらが失敗した場合、結果の判定は保留されます。
  • その後 GetTicketInfo が成功したとき、あらためて結果が判定され、報告メッセージが表示されます。


HelloSprite

Contents

  • Overview
  • Screen Shot
  • Operation Details

Overview

このサンプルは以下の点を解説します:

  • GameEngine2D のセットアップ方法
  • スプライトのセットアップと描画の方法
  • 手動によるメインループのなかで GameEngine2D を呼び出す方法
  • GameEngine2D にアプリケーションから入力データを渡す方法

EASY_SETUP が定義されると、RunWithScene のなかでメインループを実行します。 また、EASY_SETUP が定義されていない 且つ EXTERNAL_INPUT が定義されると、外部の入力データを使用します。

Screen Shot

Operation Details

外部の入力データを使用する場合のみ、

  • ×ボタン: メインループを抜ける。


FeatureCatalog

Contents

  • 概要
  • スクリーンショット
  • 操作の詳細

概要

このサンプルではGameEngine2D APIのさまざまな機能を例示しています。

test: Action

画面の左側に表示されているボタンを押すと、画面中央のスプライトに対して「アクション」の実行を行います。

test: Pivot

ここでは、Pivot(旋回軸)が変化したとき、スプライトのスケーリングと回転がどのように変化するかを示しています。

test: SpriteList

回転するスプライトの描画を例示しています。ここではSpriteListの子として描画しています。

test: Sprites

回転するスプライトの描画を例示しています。ここではスプライトを別個に描画しています。

スプライトを別個に描画するのは、SpriteListよりもはるかに遅く、非効率です（ただし、各スプライトは、別個に色を持つというメリットがあります)。

test: Plane3D

中央のラベルをクリックすると、デフォルトの2Dカメラと、傾斜したPlane3Dオブジェクトである3次元カメラが切り替わります。 タッチされた線をPlane3Dの傾斜ModelMatrix平面行列と交差させるため、ラベルの取得は3Dで行われます。

Camera3D.CalcBounds（）によって返された2次元境界は青色で示され、Camera2D.CalcBounds（）にマッチしています。

さらに、Labelオブジェクトを移動させる機能があります。このサンプルでは、テキストを取得し、ドラッグすることができます。

test: Game scene

「プラネットキュート」のアセットを利用し、簡単なアニメーションを追加して、ゲームシーンを作成しています。

http://www.lostgarden.com/2007/05/dancs-miraculously-flexible-game.html

このシーンは、後ろから前へ、下から上へ描画を行う、小さな3Dボクセルの世界です。この方法で描画命令の呼び出しを制限しています。

影のスプライトは、アセット内のデータに記述されたルールと周囲のセルにもとづいて、動的に更新されています。

test: Forest scene

「プラネットキュート」の木をランダムに配置し、簡単なゲームシーンを表示しています。 また、シーングラフのNodeBase変換行列の歪曲 (skew) を使って、風のアニメーションを行っています。

test: Particles

ParticleSystemオブジェクトを示しています。マウス/指でドラッグすることもできます。

test: Isometric scene

このサンプルは、等幅タイルで構成されたゲーム世界を表示しています。ここでは次のサイトのデータを利用しています。

http://opengameart.org/content/isometric-64x64-outside-tileset

このシーンは、必要最小限のボクセル/等幅のタイルエディタを使用して構築されています。

test: Multitouch

画面をタッチすると、同時に複数のタッチポイントが表示され、それぞれが異なる色の軌跡を残しながらドラッグされます。 それぞれの軌跡の幾何情報は2Dグリッドで、以前の場所の情報を保持しています。 PCシミュレータでは一つの赤い軌跡、Xperiaは4つの異なる軌跡をもち、Vitaは6つの異なる軌跡を持っています。

スクリーンショット

操作の詳細

すべてのサンプルで、タッチ入力を使用しています。

"マルチタッチ"のテストのみ、マルチタッチ入力を使用しています

□+方向ボタン：デバッグカメラのナビゲーション：DebugFlags.Navigateがコードで設定されている場合、パン（XY変換）。

△+方向ボタン：デバッグカメラのナビゲーション：DebugFlags.Navigateがコードで設定されている場合、ズーム（Z変換）。


ActionGameDemo

Contents

  • 概要
  • ゲームのゴール
  • 登場人物
  • スクリーンショット
  • 操作の詳細

概要

このサンプルはGameEngine2Dを利用した、横視点アクションゲームのデモです。

ゲームのゴール

ゲームの目的は、一般の生活と同じように、できるだけ長く死を避けることです。しかし、Awesomealot卿の世界ではバスやはしご、稲妻が存在しないので、長く生き延びることは、実際の生活の中よりも、ずっと簡単です。

長く生き延びることが最優先ですが、第二の目標はできるだけ多くのモンスターを倒すことです。 聖剣エクスカリバーを使ったり、パブでの喧嘩のようにビールを投げたりして、モンスターを倒してください。 モンスターの打倒に成功すると、この世界で生き延びる助けになります。

モンスターは、あなたに倒されて、金貨を差し出すことを喜んでいるように見えます。 金貨の贈り物を拒否すると失礼になるので、できるだけ多くを収集する必要があります。

最後のヒント：死なないようにしてください。

注：モンスターは人間ではありません。彼らを殺してもOKです。ただし、あまりにも不当にそれを行うと、RSPM（Royal Society for the Protection of Monsters:モンスターの保護のための王立協会）とのトラブルに巻き込まれる可能性があります。 なので、彼らの飢えた攻撃から身を守るために、大虐殺をおこなった、と主張するとよいでしょう。

余計なヒントでしたか？

登場人物

Awesomealot卿

名ばかりの英雄。聖剣エクスカリバーを携え、目立つために金鎧を身に着けている。

グリーンスライム

目のついた、ベトベトした緑のボール。ジャンプが好きです。

レッドスライム

赤のボール。怠惰なのでジャンプせず、回転して動き回る。混乱すると爆発する。

コウモリ

エクスカリバーの攻撃が届かないところをギリギリで飛び回る、迷惑なコウモリ。

ゾンビ

世界で最も愚かなゾンビ。脳みそのかわりにお茶を飲む。

スクリーンショット

操作の詳細

方向キー：移動

□ボタン：エクスカリバーを使う

×ボタン：ジャンプ

○ボタン：ビールを投げる


ベジ・ロワイヤル

Contents

  • 概要
  • 目標
  • 操作方法
  • 得点
  • ウォーターモード
  • スクリーンショット
  • 操作の詳細

概要

このサンプルはGameEngine2Dを利用したパズルゲームのデモです。

目標

ベジ・ロワイヤルの目標は、3つ以上の行または列を、同じタイプの野菜で一致させることです。ボード上の野菜を、一致するように、任意の隣接した野菜と入れ替えることができます。一致しない限り、野菜は入れ替えできません。一致した野菜はクリアされ、空いたスペースを埋めるために野菜が落ちてきます。

操作方法

ボード上の野菜を入れ替えるには、ひとつの野菜をタッチし、それから入れ替える野菜をタッチします。

あるいは、野菜を移動させたい方向にスライドさせます。

"ウォーターモード"では、画面をタッチすると水をかけ、サイズを大きくします（詳細は下記参照）。

得点

三つ以上の野菜が一致したとき、得点が入ります。より多くの野菜が一致すると、より高い得点が入ります。 同時に複数一致すると、より多くのスコアが入り、一致が連続するとコンボとなり、より大きなスコアが入ります。 大きな野菜のほうが高い得点が入ります。

ウォーターモード

得点を得ると、 "ウォーターバー"が埋まっていきます。それがいっぱいになると、ゲームは "ウォーターモード"に入ります。

ウォーターモードでは、スクリーンをタッチすることで、野菜に水をかけ、サイズを大きくします。大きな野菜は、一致したとき得点がより多く入ります。

スクリーンショット

操作の詳細

スクリーンのタッチ : 野菜の選択 / 野菜の入れ替え / 野菜に水をかける。

フリック : 野菜をフリックした方向に入れ替えます。


Physics2DSample

Contents

  • 概要
  • スクリーンショット
  • パッケージ構成
  • サンプルの説明
    • Basic Scene
    • Game Scene
    • Tutorial Scene
  • 物理サンプルのビルド
  • 物理エンジン本体のビルド
  • 動作詳細
  • 変更点
  • 今後変更予定の項目
  • 制限事項
    • 　衝突判定が不安定になる場合
    • 　衝突判定が失敗する場合
    • 　ジョイント計算が不安定になる場合

概要

２次元物理シミュレーションのサンプルです。

基本的な形状（ボックス、円、凸包）、複合形状（基本形状の組み合わせ）の衝突処理、および、ジョイント計算を行うことができます。

基本的な使用の方法についてはサンプルとして示してあります。

スクリーンショット

パッケージ構成

[ Sample Code ]

sample\Physics2D\Physics2DSample
|
|---MainTest.cs                       Main function
|
+---BasicScene                        Basic scene samples
|
+---GameScene                         Applied scene samples
|
+---TutorialScene                     Tutorial scene samples
|
+---shaders                           Shader files are required for this sample
|
|---Physics2DSample.sln               Solution file to build samples

[ Source Code ]

source\Physics2D
|
|---Physics2D.sln                     Solution file to build the library

サンプルの説明

Basic Scene

  • PrimitiveScene

    ボックス、円、凸包の動的、静的、Kinematic的な剛体の生成方法を示したシーンです。

  • CompoundScene

    複合形状の剛体の生成方法を示したシーンです。

  • JointScene

    固定、回転、スライダージョイントの生成方法を示したシーンです。

  • PyramidStackScene

    ボックス剛体がスタック状に配置されたシーンです。

  • SmallScaleScene

    物体のスケールが速度の感覚に影響を与えることを示したシーンです。

Game Scene

  • AirHockeyScene

    エアーホッケーゲームのサンプルシーンです。

  • HammerThrowerScene

    ハンマーを投げるゲームのサンプルシーンです。

  • PinBallScene

    ピンボールゲームのサンプルシーンです。

Tutorial Scene

  • DifferentMassScene

    異なる質量だけど同じ速度のサンプルシーンです。

  • MassUnstableScene

    質量差によってシミュレーションに不安定が生じるサンプルシーンです。

  • LargeSmallScene

    同じ質量でも長さスケールが違うことによって見た目の速度感が変わるサンプルシーンです。

  • CreateConvexScene

    基本的な凸包の剛体を生成するサンプルシーンです。

  • SleepWakeupScene

    SleepとWakeupをどのように使用するかを示したサンプルシーンです。

  • CollisionFilterScene

    Collision Filter属性の使い方を示したサンプルシーンです。

  • GroupFilterScene

    Group Filter属性の使い方を示したサンプルシーンです。

  • CollisionGroupScene

    Collision Filter属性とGroup Filter属性の両方を同時に使用したサンプルシーンです。

  • BallJointScene

    基本的なボールジョイントを生成するサンプルシーンです。

  • SliderJointScene

    基本的なスライダージョイントを生成するサンプルシーンです。

  • AnyDirSliderScene

    任意方向のスライダージョイントを生成するサンプルシーンです。

  • FixedOrStaticScene

    固定ジョイントと静的なオブジェクトを比較したサンプルシーンです。

  • ChainJointScene

    基本的なチェーンをジョイントで生成するサンプルシーンです。

  • WheelMakeScene

    複合形状とボールジョイントを用いて水車風オブジェクトを生成するサンプルシーンです。

  • QueryContactScene

    Contact Queryを用いて衝突情報を得るサンプルシーンです。

  • CreateCompoundScene

    基本的な複合形状の剛体を生成するサンプルシーンです。

  • ScenePropertyScene

    シーン特性の指定の仕方を示したサンプルシーンです。

  • NonCenterJointScene

    ジョイントの中心点をいろいろに設定できることを示したサンプルシーンです。

  • TriggerObjectScene

    Triggerオブジェクトの基本的な生成方法を示したサンプルシーンです。

  • CompoundBallanceScene

    重心の位置が中心にない複合形状のサンプルシーンです。

  • ChangeTensorScene

    慣性テンソルをデフォルト計算から変更したサンプルシーンです。

  • CreateRagdollScene

    Ragdollの基本的な生成方法を示したサンプルシーンです。

  • SimulationAreaScene

    シミュレーション領域の設定を示したサンプルシーンです。

  • LineChainScene

    ライン形状の基本的な生成方法を示したサンプルシーンです。

  • VehicleMakeScene

    Vehicleの基本的な生成方法を示したサンプルシーンです。

  • TextureWithScene

    剛体にテクスチャが貼られているサンプルシーンです。

  • JointRotatingScene

    移動制限のある少し複雑なジョイントを生成するサンプルシーンです。

  • KinematicObjectScene

    Kinematic剛体の基本的な使用方法を示したサンプルシーンです。

  • AnimationWithScene

    剛体にテクスチャアニメーションが貼られているサンプルシーンです。

  • SpriteBatchWithScene

    剛体にバッチ処理されたテクスチャアニメーションが貼られているサンプルシーンです。

  • RayCastScene

    Raycastの基本的な生成方法を示したサンプルシーンです。

  • ChainJointScene

    基本的なチェーンをスプリングで生成するサンプルシーンです。

  • JointSoftbodyScene

    ジョイントを使用してソフトボディを生成するサンプルシーンです。

物理サンプルのビルド

  Physics2DSample.slnを開いてビルドをしてください。エンジン本体ライブラリは既にビルド済みのものが、Sce.PlayStation.HighLevel.Physics2D.dllとしてSDK内に入っています。

物理エンジン本体のビルド

  エンジン本体に修正を加えてビルドするにはPhysics2D.slnを開いてビルドをしてください。また再ビルドしたDLLを利用するには物理サンプルのビルド用のソリューションPhysics2DSample.slnの参照先が生成したDLLになるように変更、またはアセンブリ参照でなくプロジェクト参照に変更をしてください。

動作詳細

  各サンプルによって動作が異なります。

  詳しい操作方法についてはサンプルソースコード中にある説明を参照してください。

変更点

今回の主な変更点は以下の通りです。

  • Simulate APIの引数に変更を加えました
  • 新しいサンプルシーンが追加になりました
  • より簡易な剛体、ジョイントなどのセットアップ方法が追加になりました
  • シンプルなレイキャストの機能が加わりました
  • スプリングの機能が加わりました
  • ジョイント削除、剛体削除のAPIが追加されましたが、計算負荷がかかることがあるために使用には気をつけてください
  • シミュレーション内部での計算順序がIntegrage,Broadphase,Narrowphase,SolverからBroadphase,Narrowphase,Solver,Integrageに変更になりました
  • 計算順序変更によりScene::UpdateFuncBeforeSimやScene:UpdateFuncAfterSim、および剛体のスリープ状態の扱いによっては調整が必要になる可能性があります
  • 前バージョンと同じ挙動を再現したい場合は、前バージョンのPhysics2Dエンジンのソースコードを用いてください
  • アルゴリズムのわずかな修正でも物理挙動が変わる可能性がありますので、Physics2DエンジンのソースコードをSDKのアップデート前に保存しておくことをお勧めします

今後変更予定の項目

  変数名として先頭が小文字の変数と大文字の変数の両方をユーザーからアクセスできるように設定してありますが、 　今後のバージョンで大文字のみに変更する可能性があります。 　例）シーンの剛体数はnumBodyまたはNumBodyで取得可能 ===> NumBodyに将来のバージョンで統一

制限事項

  以下のような計算ではシミュレーションが不安定になる可能性があります。

  衝突判定が不安定になる場合

  • 極端に小さいスケール、大きなスケールの世界をシミュレーションした場合
  • スケール（質量、長さ）が大きく異なる物体同士が衝突した場合
  • 重力加速度のスケールをデフォルトの値から変更して、かなり大きくした場合
  • 質量中心の設定が形状の中心（頂点座標の平均位置）から大きくずれている場合
  • Convex形状として、Convexでない頂点列を与えた場合
  • 物体を大量に高く積み上げた場合

  衝突判定が失敗する場合

  • 剛体の速度が極端に大きい、または、剛体に与えられる力が極端に大きいため、他の剛体を貫通する場合

  ジョイント計算が不安定になる場合

  • 質量の大きな物体をジョイントに接続した場合
  • ジョイントの拘束で繋がっている物体同士が非常に近くに設置され、衝突が常に生じている場合
  • 質量の大きな物体が固定ジョイント（ボールジョイント固定）で拘束された物体に衝突した場合

上記で述べたケース以外にも計算が不安定になる場合がありますが、各々のケースにおける詳細な 設定の注意点については、TutorialSceneにあるサンプルのコメントを参考にしてください。


WithGameEngine2D

Contents

  • 概要
  • スクリーンショット
  • パッケージ構成
  • サンプルの説明
    • Sample Scene
  • 物理サンプルのビルド
  • 動作詳細

概要

２次元物理シミュレーションのサンプルです。

Physics2DをGameEngine2Dと協調して動作させるための設定方法を示したサンプルです。

基本的なPhysics2Dの使用方法についてはPhysics2DSampleを参照してください。

スクリーンショット

パッケージ構成

[ Sample Code ]

sample\Physics2D\WithGameEngine2D
|
|---AppMain.cs                        Main function
|
|---StackMotionScene.cs               Scene sample
|
+---shaders                           Shader files are required for this sample
|
+---data                              Texture files are required for this sample
|
|---WithGameEngine2D.sln     Solution file to build samples

サンプルの説明

Sample Scene

  • StackMotionScene

    ボックスのスタックが落下するシーンです。

物理サンプルのビルド

  WithGameEngine2D.slnを開いてビルドをしてください。

動作詳細

  詳しい操作方法についてはサンプルソースコード中にある説明を参照してください。


Physics2DThread

Contents

  • 概要
  • スクリーンショット
  • パッケージ構成
  • サンプルの説明
    • Sample Scene
  • 物理サンプルのビルド
  • 動作詳細
  • 注意事項

概要

２次元物理シミュレーションのサンプルです。

Physics2Dのために別スレッドを生成してシミュレーションと他の処理が同時に実行できる方法を示したサンプルです。

基本的なPhysics2Dの使用方法についてはPhysics2DSampleを参照してください。

スクリーンショット

パッケージ構成

[ Sample Code ]

sample\Physics2D\Physics2DThread
|
|---MainTest.cs                       Main function
|
|---TextureWithPrimitive.cs           Scene sample
|
|---TextureWithStack.cs               Scene sample
|
+---shaders                           Shader files are required for this sample
|
+---data                              Texture files are required for this sample
|
|---Physics2DThread.sln               Solution file to build samples

サンプルの説明

Sample Scene

  • TextureWithPrimitive

    複数のプリミティブ剛体が落下するシーンです。

  • TextureWithStack

    ボックス剛体がスタック状に配置されたシーンです。

物理サンプルのビルド

  Physics2DThread.slnを開いてビルドをしてください。

動作詳細

  詳しい操作方法についてはサンプルソースコード中にある説明を参照してください。

注意事項

  • マルチスレッドを利用することでCPUが1コアのデバイスではパフォーマンスが低下する可能性があります
  • シミュレーションを実行中には剛体の位置が変化しますので、描画をするスレッドでは剛体の１フレーム前のデータを利用する必要があります
  • 剛体のデータを変更するスレッドでは剛体データにアクセスする前に排他処理を行う必要があります


HelloWorld

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

UI Toolkitで画面に文字列を表示するサンプルです。

スクリーンショット

動作詳細

Labelウィジェットを利用して、画面に"Hello World"という文字列を表示します。


UICatalog

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

UI Toolkitで利用可能なウィジェット、Liveウィジェット、トランジション、エフェクトを確認することができます。

スクリーンショット

動作詳細

図1 メイン画面

起動直後のメイン画面(図1)では、上部の３つのボタンをタップすることで、画面中央に表示する項目をウィジェット、Liveウィジェット、エフェクトのどれにするかを切り替えることができます。 画面下部から1つ項目を選びタップすると、個々のウィジェット/エフェクトの詳細画面(図2)に遷移します。

図2 詳細画面

図2はImageBoxの詳細画面の例です。詳細画面では画面中央でウィジェットやエフェクトの動作を確認することができます。 上部の"Previous", "Next"と表示されているボタンをタップすることで、他のウィジェットやエフェクトの詳細画面に遷移します。また、Topと表示されているボタンをタップすることでメイン画面に戻ります。 "Transition Setting"と表示されているボタンをタップすると、トランジションの種類を変更することができます。


Overlay

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

３次元グラフィックスにUI Toolkitによる描画を重ねあわせたサンプルです。

スクリーンショット

動作詳細

画面右下のボタンをタップすると、３次元グラフィックス上にUI Toolkitで作成したダイアログが表示されます。


UIAnimation

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

UIMotion / UIAnimationPlayer の使用方法を示すサンプルです。

スクリーンショット

動作詳細

画面上部に表示されているコントロールパネルを使って、アニメーションの選択、再生、停止、中断、再開、リピートなどを行うことができます。


ScreenOrientation

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

画面の向きを変更するサンプルです。

スクリーンショット

動作詳細

トップ画面(図1)の4つのボタンのいずれかを押すと、対応した向きの画面(図2)が表示されます。

図1 トップ画面

図2 対応した向きの画面


UIToolkit_template

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

UI Toolkitを利用する際のテンプレートとなるサンプルです。

スクリーンショット

動作詳細

UI Toolkitを利用するためのテンプレートサンプルで、特に画面に表示は行っていません。


DemoClock

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

UI Toolkitで作成した時計アプリケーションのサンプルです。UI Composerでレイアウトを行っています。

スクリーンショット

動作詳細

フリック操作で、表示するタイムゾーン(都市)を変更することができます。また、右下のボタンをタップすると、時計の種類を切り替えるためのダイアログが表示されます。


DemoGameUI

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

ゲームのメニュー画面などのGUIをUI Toolkitで構成したサンプルです。

スクリーンショット

動作詳細

図1 タイトル画面

タイトル画面(図1)は、起動直後の画面です。 "Start"をタップするとゲーム画面(図2)に遷移します。 "Ranking","Help"をタップするとダイアログが表示されますが暫定のものです。

図2 ゲーム画面

ゲーム画面(図2)では、犬の3Dモデル以外をUI Toolkitで描画しています。 左下のボタンをタップするとポーズ画面(図3)に遷移します。 右下のボタンは動作しません。

図3 ポーズ画面

ポーズ画面(図3)では、"Continue"をタップするとゲーム画面に遷移します。 "Return Title"をタップするとタイトル画面に遷移します。 "Ranking","Help"をタップするとダイアログが表示されますが暫定のものです。


DemoWeather

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

UI Toolkitで天気予報を表示するアプリケーションを構成したサンプルです。

スクリーンショット

動作詳細

世界地図上に表示されるアイコンをタップすることで、各都市の天気予報の詳細を参照することが可能です。 何も操作せずにしばらく経過すると、世界地図が自動的にスクロールします。 天気予報のデータはダミーデータです。


DemoRssReader

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

UI Toolkit で構成した"Rss Reader"のサンプルアプリケーションです。

スクリーンショット

動作詳細

画面左側にRSSの配信ソースの一覧が表示されます。 RSSの配信ソースの1つをタップすると、右側にそのRSS内の記事一覧リストが表示されます。 記事一覧リストから1つをタップすると、その記事のタイトルと本文を表示するダイアログが表示されます。


DemoCalendarMaker

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

カレンダーを埋め込んだ壁紙を作成するアプリケーションサンプルです。

スクリーンショット

動作詳細

起動後、"Make Calendar"と表示されている部分をタップすると、画面1に遷移します(図1)。

図1 [画面1] 背景選択

画面1では、作成する壁紙の背景画像を選択出来ます。 右側に表示される画像一覧から一つをタップすると、画面2に遷移します(図2)。

図2 [画面2] 背景の調整

画面2では、選択した背景画像の位置とサイズを調整できます。 ドラッグ操作で背景画像の位置を、ピンチ操作でサイズを調整できます。 右下のOKボタンをタップすると画面3に遷移します(図3)。

図3 [画面3] カレンダー選択

画面3では、背景画像の上に表示するカレンダーの種類を選択することができます。 表示させたいカレンダーをタップすると画面4に遷移します(図4)。

図4 [画面4] カレンダー調整

画面4では、カレンダーを表示する位置をドラッグ操作で調整できます。 右下のOKボタンをタップすると画面5に遷移します。

図5 [画面5] 作成する壁紙の確認

画面5では作成する壁紙の確認を促すダイアログが表示されます。 OKボタンをタップすると保存されます(現在の実装では実際には保存されません)。

図6 [画面6] 壁紙一覧

起動直後の画面から"WallPaper"と表示されている部分をタップすると画面6に遷移します。 画面6では作成した壁紙の一覧を参照することができます(現在の実装ではあらかじめ用意されている画像のみ参照することができます)。


BasicProgramSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

基本シェーダーのサンプルです。

スクリーンショット

動作詳細

ライティングやフォグなどの基本的な機能を持つシェーダーを使用して球を表示します。

球は反時計回りに自動的に回転します。


BasicModelSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

モデルデータのロードと表示を行うサンプルです。

スクリーンショット

動作詳細

モデルデータをファイルから読み込んで表示します。

モデルデータはアニメーションを再生しながら自動的に回転します。


Tutorial

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

プログラミングガイドで使用する2Dシューティングのサンプルです。

スクリーンショット

動作詳細

方向キー : 移動

○×ボタン : 攻撃

Lボタンを押しながらRボタンを押すと、デバッグフォントの表示を切り替えます。


SpriteBuffer

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

多くのスプライトを表示するテストサンプルです。(Tutorial/Sample09_01)

  • SpriteBufferクラスを利用しています。スプライトを頂点バッファにためてからDrawArrays()を呼び出し、描画の効率化を行っています。
  • 一体化したテクスチャを利用し、SetTexture()の変更回数を抑えています。
  • このサンプルの画像データは以下のサイトのものを利用させていただきました。
  • 制作者：ハムコロ様
  • 配付元：http://homepage2.nifty.com/hamcorossam

スクリーンショット

動作詳細

方向キー : 移動

○ボタン : 弾の発射。

△ボタン : 表示されている弾を消去します。

Lボタンを押しながらRボタンを押すと、デバッグフォントの表示を切り替えます。


SoundDelaySample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

サウンドの遅延を計測するサンプルです。

スクリーンショット

動作詳細

サウンド再生時刻に対する、実際のサウンド出力の遅延を計測します。

サウンドにあわせて、オブジェクトの動きのタイミングを調整してください。

サウンドの遅延はデバイスによって大きく異なる場合があり、良好なデバイスでは 50 ms 未満になりますが、一部のデバイスでは 200 ms 程度になることもあります。タイミングが重要なアプリには、設定メニューなどを用意することもご検討ください。


TouchDelaySample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

タッチパネルの遅延を計測するサンプルです。

スクリーンショット

動作詳細

実際のタッチパネル入力に対する、タッチ検出の遅延を計測します。

オブジェクトが床につく瞬間に、画面をタップしてください。

タッチパネルの遅延はデバイスによって大きく異なる場合があり、良好なデバイスでは 50 ms 未満になりますが、一部のデバイスでは 100 ms 程度になることもあります。タイミングが重要なアプリには、設定メニューなどを用意することもご検討ください。


LoadingThreadSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

マルチコア CPU の活用によるテクスチャ読み込みのパフォーマンス改善を示すサンプルです。

スクリーンショット

動作詳細

画面上のボタンを押すと 100 個のテクスチャをロードしてその時にかかった時間を表示します。

テクスチャは 10 個の画像ファイルからランダムに生成されます ( 256x256 32bit PNG 形式 )。

ロード方法を 3 つのボタンで選択することができます。

  • Batch : テクスチャを一度にロードします。
  • Sequential : テクスチャを１つずつロードします。
  • Multithreaded : テクスチャをマルチスレッドでロードします。

PS Vita のようにマルチコア CPU を持つデバイスでは、マルチスレッドを使用することで、テクスチャ読み込みのパフォーマンスが改善する可能性があります。

アプリケーションがスレッディング機能を使用する場合は、以下の点にご注意ください。

  • Sce.PlayStation.Core.Graphics API は、サブスレッドで呼び出すことができません。
  • System.Threading.Tasks API は、現在のバージョンの SDK ではいくつか問題があります。
  • アプリケーションでデッドロックが起きないことを、十分に確かめてください。
  • シングルコア CPU を持つデバイスには、特にご注意ください。


SpriteThreadSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細

概要

マルチコア CPU の活用によるスプライトアニメーションのパフォーマンス改善を示すサンプルです。

スクリーンショット

動作詳細

このサンプルはスプライトサンプルとほぼ同じですが ( sample/Graphics/SpriteSample ) スプライトアニメーションにマルチスレッドが使用されている点が唯一異なります。

PS Vita のようにマルチコア CPU を持つデバイスでは、マルチスレッドを使用することで、スプライトアニメーションのように大量の単純な計算の CPU 時間を短縮できる可能性があります。

（ただし現在スレッドが不定期に 100 ミリ秒ほどの間ストールする問題があります。このサンプルコードをそのままリアルタイム用途に利用することはできませんのでご注意ください。）


ShootingDemo

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • 操作方法

概要

横スクロールシューティングのデモゲームです。

スクリーンショット

動作詳細

ゲームパッドで宇宙船を操縦して、敵の弾を回避しながら敵を攻撃してください。

操作方法

方向ボタン : 移動

○×ボタン : 攻撃

□△ボタン : 連射攻撃


FlightDemo

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • 操作方法

概要

モーションセンサで飛行機を操縦するデモゲームです。

スクリーンショット

動作詳細

モーションセンサで飛行機を操縦して、制限時間内にコースを周ってください。

操作方法

モーションセンサ : 旋回

タッチパネル : 加速と減速


RpgDemo

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • 操作方法

概要

アクションRPG風のデモゲームです。

スクリーンショット

動作詳細

ゲームパッドやタッチで主人公を操って、島を探検しながら魔物を退治してください。

操作方法

ゲームパッド

  • 方向ボタン : 移動
  • ○ボタン : 攻撃
  • ×ボタン : ジャンプ
  • ＬＲボタン : カメラ回転

タッチ

  • 地面をタッチ : その位置に向かって移動
  • 敵をタッチ : その敵に接近して攻撃
  • 空をタッチ : 前方向に移動
  • ２回タッチ : 移動停止
  • 縦フリック : 縦切り
  • 横フリック : 横切り
  • １人称モードでフリック : 魔法を発射
  • ２本指でスライド : カメラの回転
  • ２本指でピンチ : カメラと主人公の距離の変更

※ カメラが主人公に近づくと、１人称モードに切り替わります。


BallMazeDemo

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • 操作方法

概要

モーションセンサを使ってボールを転がして、ゴールまで導くデモゲームです。

スクリーンショット

動作詳細

モーションセンサでボールを転がして、できるだけ早くゴールに運んでください。

操作方法

モーションセンサ : ボールを転がす


BrickSmashDemo

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • 操作方法

概要

円形に配置されたブロック崩しのデモゲームです。

スクリーンショット

動作詳細

タッチパネルでパドルを操って、ボールをぶつけてブロックを壊してください。

操作方法

タッチパネル : パドルを移動


SpaceRocksDemo

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • 操作方法

概要

隕石を避けつつ破壊するデモゲームです。

スクリーンショット

動作詳細

ゲームパッドで宇宙船を操縦して、破片を回避しながら隕石を破壊してください。

操作方法

方向ボタン : 回転

×ボタン : 攻撃

Ｒボタン : 加速


Physics2dDemo

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • 操作方法

概要

    作業員を投げ飛ばし、ステージ上に配置されているオブジェクトを壊すデモゲームです。

    このデモゲームは Physics2D ライブラリを使用しています。

スクリーンショット

動作詳細

ステージ毎にスコアが設定されていますので、そのスコアを超えるようにしてください。

操作方法

タッチパネル : パンダをタッチすると投げる準備を始めます。そのままドラッグすると投げる方向が赤いラインで表示され、センサから指を離すと作業員を投げます。


DefenseDemo

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • 操作方法

概要

兵器を配置し、敵の進行を食い止めるデモゲームです。

スクリーンショット

動作詳細

進行してくる敵を破壊するとポイントが加算され、より強い兵器を配置することができます。

操作方法

タッチパネル : 画面下部のパネルからタワーをドラッグし、配置可能箇所にドロップします。

１本指ドラッグで、カメラ移動が出来ます。

２本指ドラッグで、カメラ回転が出来ます。

ピンチイン/アウトで、拡大縮小が出来ます。


LuaSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • LuaInterfaceの基本動作

概要

LuaInterfaceを使用した、タッチパネルでの操作サンプルです。

LuaInterface は C#とLuaとのインターフェイスを取り持ち、LuaからCLRにアクセスできるようにするパッケージです。

LuaInterface のソースコードは %SCE_PSM_DATA%/source/LuaInterface に格納されています。

詳細については、http://penlight.luaforge.net/project-pages/penlight/packages/LuaInterface/ を参照してください。

スクリーンショット

動作詳細

タッチされた部分に塗りつぶしの円を描きます。

円の色は Touch毎に赤/緑/青/黄を繰り返します。

円のサイズは半径 120pix で固定となっています。

LuaInterfaceの基本動作

C#とLuaとの相互関連は、下記コード部分をご参照下さい。

C# 側

[1] 初期処理

lua = new Lua();

[2] C#関数のLuaへの登録

lua.RegisterFunction("FillCircle", null, typeof(LuaSample).GetMethod("FillCircle"));

[3] Luaファイルの読込・解析

lua.DoFile("/Application/touch.lua");

[4] Lua関数の呼出し

lua.GetFunction("OnTouch").Call(pointX, pointY, isDown);

[5] Lua変数の参照

var titleString = Convert.ToString(lua["TitleString"]); var colorIndex = Convert.ToInt32(lua["ColorIndex"]);

Lua 側

[1] Lua関数の定義

function OnTouch(pointX, pointY, isDown)

[2] 登録されたC#関数の呼出し

FillCircle(ColorList[ColorIndex], pointX, pointY, 120)


LuaTriangleSample

Contents

  • 概要
  • スクリーンショット
  • 動作詳細
  • LuaからCLRへのアクセス
  • 注意事項

概要

LuaInterfaceを使用した、三角ポリゴンの表示サンプルです。

Lua のプログラムから PSM SDK API を直接呼出す方法を示しています。

スクリーンショット

動作詳細

テクスチャマッピングと頂点カラーが適用された三角ポリゴン1枚を表示します。

ポリゴンは反時計回りに自動的に回転します。

LuaからCLRへのアクセス

LuaからCLRへのアクセスは、下記コード部分をご参照下さい。

[1] Assemblyのロード

luanet.load_assembly('Sce.PlayStation.Core')

[2] 型のインポート

GraphicsContext = luanet.import_type "Sce.PlayStation.Core.Graphics.GraphicsContext"

[3] GraphicsContextの取得

graphics = GraphicsContext()

[4] Graphics Methodの呼出し

graphics:Clear()

注意事項

[1] C# で SampleLibとの参照関係を明示する為に、次の文を挿入しています。

var dummy = typeof(Sample.SampleDraw);

[2] Lua でタイプのインポートが必要です。

[3] Lua で呼出すメソッドのオーバーロード解決が必要です。

[4] Lua でガベージコレクションが必要です。


SampleLib

Contents

  • 概要
  • 各機能概要

概要

各サンプルで共通的に利用され、各サンプルの主機能とは直接関係のないコードです。

各機能概要

含まれているクラスと概要は以下のようになっています。
クラス | 概要
SampleDraw | 後述のSpriteの描画や基本的な2D描画機能をまとめたクラスです。
SampleSprite | スプライト機能の簡単な実装です。
SampleButton | ボタン機能の簡単な実装です。
SampleSlider | スライダー機能の簡単な実装です。
SampleWidget | ウィジェット機能の簡単な実装です。
SampleTimer | タイマー機能の簡単な実装です。


構成

クラス、構造体、共用体、インタフェースの説明です。
AccountInformation | アカウント情報をあらわす static クラス
Shell.Action | システム機能の呼び出し内容を表す構造体
ActionBase | 全てのアクションの基底クラス。
ActionManager | ActionManager は Node のアクションを管理するシングルトンオブジェクトです。 メインの Update ループは Director.Update() で呼び出されます。
ActionTweenGeneric< T > | 汎用的な補間アクションの基底クラス。set/get 関数をセットします。 抽象クラス。
ActionTweenGenericVector2 | ActionTweenGenericVector2 はスタート値からターゲット値に移行する、シンプルなwiseブレンドを行います。
ActionTweenGenericVector2Rotation | ActionTweenGenericVector2Rotation は単位ベクトルを補間します。単位ベクトルは回転で補間します。
ActionTweenGenericVector2Scale | ActionTweenGenericVector2Scale は ActionTweenGenericVector2 に似ていますが、 スケール値 (乗法) で実行します。
ActionTweenGenericVector4 | ActionTweenGenericVector4 はスタート値からターゲット値に移行する、シンプルなwiseブレンドを行います。
ActionWithDuration | 有限の期間を持つアクションの基底クラス。 抽象クラス。
AnimationImageBox | 画像切り替えによるアニメーションの表示ウィジェット
AnimationUtility | アニメーション用のユーティリティ
DrawHelpers.ArrowParams | DrawArrow に渡される矢印のパラメータ。
BasicArrays | モデルの頂点配列を表すクラス
BasicBone | モデルのボーンを表すクラス
BasicFCurve | モデルの関数カーブを表すクラス
BasicLayer | モデルのレイヤーを表すクラス
BasicMaterial | モデルのマテリアルを表すクラス
BasicMesh | モデルのメッシュを表すクラス
BasicModel | モデルを表すクラス
BasicMotion | モデルのモーションを表すクラス
BasicParameters | 基本プログラムのパラメータを表すクラス
BasicPart | モデルのパートを表すクラス
BasicProgram | 基本プログラムを表すクラス
BasicProgramContainer | プログラムコンテナを表すクラス
BasicTexture | モデルのテクスチャを表すクラス
BasicTextureContainer | テクスチャコンテナを表すクラス
Bgm | 音楽データ
BgmPlayer | 音楽再生機能を提供するクラス
BlendFunc | アルファブレンド関数を表す構造体
BlendMode | BlendMode はブレンドステート(BlendFunc+'enabled' bool)をラップし、扱いやすい名称として提供します。
Bounds2 | An axis aligned box class in 2D
BunjeeJumpEffect | ウィジェットが上から落ちてきて少し跳ねて止まるエフェクト
BusyIndicator | 進行状況を表示するウィジェット
Button | ボタンウィジェット
Input2.ButtonState | ボタンのデータ構造体は Input.GamePad、Input.Touch、Keyboardなどのヘルパーラップで共有されます。
Byte2 | Vector of 2 signed bytes
Byte2N | Vector of 2 normalized signed bytes
Byte3 | Vector of 3 signed bytes
Byte3N | Vector of 3 normalized signed bytes
Byte4 | Vector of 4 signed bytes
Byte4N | Vector of 4 normalized signed bytes
ByteN | Scalar normalized signed byte
TextureInfo.CachedTileData | 各タイルのキャッシュされたUV情報。
CallFunc | 指定した関数を呼び出す、ワンショットアクション。
Camera | カメラを表すクラス
Camera2D | 2Dビューの設定とナビゲーション。 行列のスタックとルーラーと軸の描画には GraphicsContextAlpha と DrawHelpers をお使いください。
Camera3D | 基本的な3Dカメラ。
CameraImportDialog | 写真を撮影するコモンダイアログクラス
CameraInfo | カメラの詳細情報
CameraSize | カメラの画像の解像度
FontMap.CharData | 単一文字のUVデータ。
CharMetrics | 文字ごとのメトリクス情報
CheckBox | チェックボックスウィジェット
Clipboard | クリップボードにアクセスするためのクラス
ColorBuffer | カラーバッファを表すクラス
Colors | 名前の付いた色の定数。
ContainerWidget | コンテナ機能を持つウィジェット
ConvexPoly2 | A convex polygon class in 2D
CrossFadeTransition | クロスフェードトランジション
CullFace | バックフェースカリングを表す構造体
CustomButtonImageSettings | ボタンのカスタマイズ画像の設定情報
CustomCheckBoxImageSettings | カスタマイズ画像の設定情報
DatePicker | 日付を選択するためのウィジェット
DatePickerValueChangedEventArgs | DatePicker の値が変更されたときのイベント引数
DebugFlags | フラグのビットは Director.Instance.DebugFlags によって使用されます。 デフォルトでは、全てオフです。
GraphicsContextAlpha.DebugStats_ | 現時点では、DebugStats は DrawArrays の呼び出し回数のみ保持します。
SpriteRenderer.DefaultFontShader_ | Fontのデフォルトのシェーダー。
SpriteRenderer.DefaultShader_ | スプライトのデフォルトのシェーダー：色によって変調されたテクスチャ。
DelayedExecutor | ある時間が経過した後に処理を行うエフェクト
DelayTime | 指定した期間ののち終了する、待機アクション。
DepthBuffer | デプスバッファを表すクラス
DepthFunc | デプステスト関数を表す構造体
Dialog | モーダルダイアログ
DialogEventArgs | ダイアログイベント引数
Director | Director はシーンスタックを管理し、Scheduler と ActionManager の update ループを呼び出すシングルトンです。 開発者自身が独自にメインループを実装する場合、開発者はUpdate / Render / PostSwap 関数をメインループの中で呼び出さなければなりません。 また Director は、グラフィックスコンテキスト (GL) 、SpriteRenderer オブジェクト ( 主に内部的に利用されますが、開発者が直接使うこともできます )、 デバッグ情報を描画する DrawHelpers を保持します。
DoubleTapEventArgs | ダブルタップイベント引数
DoubleTapGestureDetector | ダブルタップ検出器
DragEventArgs | ドラッグイベント引数
DragGestureDetector | ドラッグ検出器
DrawHelpers | 2D/3Dの基本的な描画関数を提供します。このクラスは主にデバッグシェーダーを使った ImmediateMode のオブジェクトです。 パフォーマンスが良くないため、デバッグ以外の用途で DrawHelpers を使用することは推奨しません。
EditableText | 編集可能なテキストウィジェット
Effect | ウィジェットまたはエレメントに適用するアニメーションの基底クラス
EmbeddedDebugFontData | スクリーン用デバッグプリントのための、埋め込みフォントデータ。
ParticleSystem.EmitterParams | このクラスは、パーティクルの初期化に必要な全てのパラメータを再グループ化します。 ランダムの範囲を与えるため、多くの値は分散しています(-Var の接尾辞)。 分散が "相対"値（-RelVarの接尾辞）である場合、0,1の間の値が期待されています。 例: 0.2f は、作成時に対応する値は -+20でランダム化されることを意味します。
FadeInEffect | フェードインエフェクト
FadeOutEffect | フェードアウトエフェクト
FlickEventArgs | フリックイベント引数
FlickGestureDetector | フリック検出器
FlipBoardEffect | 真ん中で折れるエフェクト
FlipBoardTransition | 真ん中で折れるトランジション
FMath | Math wrapper and convenience functions
FocusChangedEventArgs | FocusChangedイベント引数
FocusCustomSettings | フォーカスのカスタム設定
Font | フォント
FontMap | Fontオブジェクトと使用予定のすべての文字を含むテキストを指定して、フォントマップは、文字を格納したTexture2Dオブジェクトと対応するUVテーブルを作成します。このデータは、GameEngine2Dのさまざまなテキスト描画関数で使用されます。
FontMetrics | フォントのメトリクス情報
FrameBuffer | フレームバッファを表すクラス
Camera.FrameChangedEventArgs | ストリームの画像のフレームが変化したときに発生するイベントで渡される引数クラス
Frustum | Camera2DとCamera3Dによって使用される視錐台 (Frustum) のオブジェクト。 透視変換に利用します。
GamePad | ゲームパッドデバイスを表すクラス
Input2.GamePad | Input.GamePad (button bits) をラップしたクラス。
GamePadData | ゲームパッドのデータ
Input2.GamePadData | Input.GamePadData をラップしたクラス。
GestureDetector | ジェスチャ検出機構の基底クラス
GestureEventArgs | ジェスチャイベント引数の基底クラス
GraphicsCaps | グラフィクス能力を表すクラス
GraphicsContext | グラフィクスコンテキストを表すクラス
GraphicsContextAlpha | 行列スタックと他の関数でSce.PlayStation.Core.Graphics.GraphicsContextを強化します。
GridListPanel | 複数の行と列を持つリストウィジェット
Half | Scalar half
Half2 | Vector of 2 halfs
Half3 | Vector of 3 halfs
Half4 | Vector of 4 halfs
ICamera | Camera2D と Camera3D 用の共通インターフェース。
ICollisionBasics | Bounds2, Sphere2, ConvexPoly2 の共通インターフェース。
ICommonDialog | コモンダイアログ共通のインターフェース
Image | 画像
ImageAsset | 画像アセットクラス
ImageBox | 画像を表示するウィジェット
ImageColor | 画素の色
ImagePosition | 画像の中の座標 (左上原点)
ImageRect | 画像の中の矩形領域
ImageSize | 画像のサイズ
ImmediateMode< T > | イミーディエイトモードの頂点配列は、ImmBegin()/ImmVertex()/ImmEnd()などのOpenGLスタイルのインターフェースを使い、どのフレームでも描画できます。
ImmediateModeQuads< T > | ImmediateModeQuads はクワッドの描画を扱うために、ImmediateModeをラップしています。 このクラスはSpriteRenderer や他の場所で使用されます。
InAppPurchaseDialog | アプリ内課金を処理するためのダイアログをあらわすクラス
InAppPurchaseProduct | アプリ内課金で購入可能なプロダクトをあらわすクラス
InAppPurchaseProductList | アプリ内課金で購入可能なプロダクトのリストをあらわすクラス
Input2 | Sce.PlayStation.Core.Inputをラップしたクラス。
ParticleSystem.IParticleShader | ParticleSystem のシェーダーインターフェース。
SpriteRenderer.ISpriteShader | 開発者によって設定されるシェーダープログラムのインターフェース。
JumpFlipEffect | 画面手前にジャンプし反転して切り替わるエフェクト
JumpFlipTransition | 画面手前にジャンプし反転して切り替わるトランジション
KeyEvent | キーイベント情報
KeyEventArgs | キーイベント引数
Label テキストのプリミティブを描画します。2つのタイプのフォントデータをサポートしています:

  • SpriteRenderer に埋め込まれたデバッグフォント。
  • FontMap オブジェクトを使ったもの。
Label | 文字列を表示するウィジェット
ListPanel | 複数の行を持つリストウィジェット
ListPanelItem | リストのアイテム用のコンテナウィジェット
ListPanelItemSelectChangedEventArgs | リストアイテムが選択された場合に呼び出されるイベント引数
ListSection | リストのセクション用のコンテナ部品
ListSectionCollection | セクションのコレクション
LiveFlipPanel | イベントにより回転するコンテナウィジェット
LiveJumpPanel | 子ウィジェットが画面手前にジャンプするコンテナウィジェット。
LiveListPanel | アイテムが不規則な配置でスクロールするリストウィジェット
LiveScrollPanel | 形状が歪みながらスクロールするコンテナウィジェット
LiveSphere | 球体型のウィジェット
LiveSpringPanel | 加速度センサーやパネルの動きに応じて子ウィジェットが揺れるパネル
TRS.Local | エイリアス。一般的にCenteringに渡すために使用します。
Location | 位置情報を表すクラス
LocationData | 位置情報
LongPressEventArgs | ロングプレスイベント引数
LongPressGestureDetector | ロングプレス検出器
Math | 数学/ベクトルライブラリ用に拡張した Math クラス。
Matrix3 | 2Dを扱うための 3x3の行列。
Matrix4 | Matrix of 16 floats
MatrixStack | OpenGLに似た、シンプルな変換行列のスタックです。直交行列を扱うための工夫がなされています。
MessageDialog | 警告のメッセージ等を表示するための特殊化されたモーダルダイアログ
MessageDialogButtonEventArgs | メッセージダイアログのイベント引数
MinimizedEventArgs | 最小化イベントで渡ってくるデータ
Motion | モーションセンサーを表すクラス
MotionData | モーションセンサーのデータ
MotionEvent | モーションイベントクラス
MotionEventArgs | モーションイベント引数
MoveBy | オフセットの値を現在の位置に徐々に加算していくアクション。
MoveEffect | 現在の位置から指定した位置に移動するエフェクト
MoveTo | 指定した目標に徐々に移動するアクション。
Network | スコアボード使用をハンドルするネットワーク クラス
NetworkRequest | ネットワーク リクエスト クラス
NetworkResponse | ネットワーク レスポンス クラス
NetworkStreamReader | ストリーム リーダー クラス
NinePatchMargin | ９パッチ情報を格納するための構造体
Node | ノードは全てのシーングラフノードの基底クラスです。標準的な2D変換行列、子のリスト、親へのハンドラを持ちます。ノードは多くとも1つの親をもつことができます。
PagePanel | ページ単位でスクロールするコンテナウィジェット
Panel | コンテナの機能を持つウィジェット
ParticleSystem.Particle | CreateParticle で返される、パーティクルオブジェクト。
Particles | ひとつの ParticleSystem を シーングラフノードにラップしたパーティクルクラス。
ParticleSystem.ParticleShaderDefault | デフォルトのシェーダー。テクスチャの色は変調されます。
ParticleSystem | シンプルなパーティクルシステムエフェクト。
PersistentMemory | 永続的なメモリ領域を提供するクラス
PhotoImportDialog | 写真を選択するコモンダイアログクラス
PhysicsBody | 多くのプロパティを利用して剛体を定義する
PhysicsJoint | ジョイント
PhysicsScene | ２Ｄ物理シミュレーションのシーン
PhysicsShape | 全ての形状は凸形状としてセットされます
PhysicsSolverPair | 衝突した剛体ペアの衝突情報を保持している
PhysicsSpring | スプリング
PhysicsUtility | Physics2Dのためのユーティリティクラス
Camera.PictureStateChangedEventArgs | 写真の撮影状況が変化したときに発生するイベントで渡される引数クラス
PinchEventArgs | ピンチイベント引数
PinchGestureDetector | ピンチ検出器
PitchRoll | ピッチ/ロール回転のヘルパーオブジェクト/関数。 Pitch(x) -> roll(y)の順に回転します。 ロールは-pi, pi、ピッチは-pi/2,pi/2です。
PixelBuffer | ピクセルバッファを表す基底クラス
Plane2 | A plane class in 2D
Plane3D | Plane3D ノードは、シーングラフ内で、ある程度まで3Dの方向性を許可します。 それは、タッチ座標を扱う方法をいくぶんか複雑にします。なのでシーン階層に Plane3D を含んでいる場合、直接 Director.Instance.CurrentScene.Camera.GetTouchPos() を使う代わりに、Plane3D 空間(すべてサブノード)で点を得るのに Node.GetTouchPos() を使うことを確認してください。
PolygonOffset | ポリゴンオフセットを表す構造体
PopupList | 複数の選択肢から１つを選択するためのウィジェット
PopupListItemCollection | PopupListのListItems用コレクション
PopupListItemsChangedEventArgs | PopupListのListItemsChangedイベント引数
PopupSelectionChangedEventArgs | PopupList の選択中のアイテムが変わったときに呼ばれるイベント引数
PressStateChangedEventArgs | PressStateChangedイベント引数
Primitive | プリミティブを表す構造体
ProgressBar | 進捗の度合いを表示するウィジェット
PushTransition | 新しいシーンが古いシーンを押しだすトランジション
Quaternion Quaternion
Math.RandGenerator | System.Randomをラップし、ベクトルの乱数生成を拡張したクラス。
RawSpriteTile | RawSpriteTileList で使用される構造体。
RawSpriteTileList | 描画呼び出しや、ステートのセットアップの回数を減らすため、スプライトを一括して描画します。 SpriteListとは違い、Node オブジェクトのリストを保持する代わりに、より軽いRawSpriteTileのリストを保持します。 これは Node として利用可能な SpriteRenderer のラップです。
RayHit | レイキャスト用のレイ情報
Rectangle Rectangle
RenderTarget | レンダリング結果の格納先を表す構造体
Repeat | アクションを回数指定で繰り返すアクション。
RepeatForever | 他のアクションを永続的に繰り返すアクション。
RestoredEventArgs | 最小化からの復帰イベントに渡ってくるデータ
Rgb565 | 16 bit color struct with 5 bits for R, 6 bits for G, and 5 bits for G
Rgba | 32 bit color struct, with 8 bits per channel
Rgba4444 | 16 bit color struct with 4 bits per channel
Rgba5551 | 16 bit color struct with 5 bits per channel for R, G, and B. and 1 bit for A
RollPitch | Pitch/roll 回転のヘルパーオブジェクト/関数。 Roll(y) -> pitch(x)の順に回転します。 ピッチは-pi, pi、ロールは-pi/2,pi/2です。
RootUIElement | エレメントツリーのルート
RootWidget | ウィジェットツリーのルート
RotateBy | 現在の回転値に徐々にオフセット値を加算していくアクション。
RotateTo | 指定した値へ徐々に回転値をセットしていくアクション。
ScaleBy | 現在のスケールに徐々に追加のスケールを追加していくアクション。
ScaleTo | 指定した値へスケールを徐々にセットしていくアクション。
Scene | Scene クラスはシーングラフのルートノードタイプです。 シーンスタックを操作するため Director シングルトンを使い、現在のシーンは Director.Instance.CurrentScene でアクセスします。 2つのシーンが画面遷移のためブレンディングされるときを除き、アクティブになるシーンはひとつだけです。
Scene | 画面
Scheduler | Scheduler は、開発者が登録する update 関数に関連した Node を管理するシングルトンです。 スケジュールされた関数は毎フレーム呼び出されます。または、開発者は特別な間隔で呼び出すこともできます。 Scheduler の update ループは Director.Update() の内部で呼び出されます。
ScrollBar | 画面のスクロール位置を把握するためのウィジェット
ScrollPanel | スクロール可能な領域を持つコンテナウィジェット
Sequence | 順番に、他の一連のアクションを実行するためのアクション。
ShaderProgram | シェーダープログラムを表すクラス
ShaderProgramOption | シェーダープログラムの作成オプションを表すクラス
Shell | システムの機能を呼び出すためのクラス
Short2 | Vector of 2 signed shorts
Short2N | Vector of 2 normalized signed shorts
Short3 | Vector of 3 signed shorts
Short3N | Vector of 3 normalized signed shorts
Short4 | Vector of 4 signed shorts
Short4N | Vector of 4 normalized signed shorts
ShortN | Scalar normalized signed short
ParticleSystem.SimulationParams | SimulationParams は、Update と Draw で必要とされる全てのパラメータを、再グループ化します。
SkewBy | 現在のスキュー値に徐々にオフセット値を加算していくアクション。
SkewTo | 指定した値へ徐々にスキューをセットしていくアクション。
SlideInEffect | 画面の外から現在の位置まで平行移動するエフェクト
SlideOutEffect | 現在の位置から画面の外まで平行移動するエフェクト
Slider | 数値などの調整を行うためのウィジェット
SliderValueChangeEventArgs | 現在の位置が変化したときのイベント引数
SlideTransition | 平行移動してシーンを切り替えるトランジション
Sound | 効果音データ
SoundPlayer | 効果音再生機能を提供するクラス
Sphere2 | A sphere class in 2D
SpriteBase | 単一のスプライトノードの規定クラス。抽象クラスです。
SpriteList | 描画呼び出しやステートのセットアップの呼び出し回数を削減するため、スプライトを一括して描画します。 SpriteUV や SpriteTile オブジェクトを AddChild() で SpriteList の子として追加するだけで、一括描画を可能にします。 ただし、スプライトの TextureInfo, BlendMode, Color のプロパティは無視されます。それらのプロパティは親の SpriteList に依存します。
SpriteRenderer | SpriteRendererは、単純なBeginSprites / AddSprite X N / EndSprite APIでのスプライトの一括描画をラップします。 また、FontMap を使ったテキスト描画関数を提供します。
SpriteTile | SpriteTile は、TextureInfo 内のタイルインデックス (1D または 2D) を指定する形式のスプライトです。 別個で描画すると、処理が重くなるので注意してください。可能な限り、SpriteList の子として利用してください。
SpriteUV | SpriteUVは、手動で UV を設定するスプライトです。 UV は TRS オブジェクトとして格納されます。 SpriteUVを別個で描画すると、処理が重くなるので注意してください。可能な限り、SpriteList の子として利用してください。
StencilFunc | ステンシルテスト関数を表す構造体
StencilOp | ステンシルテスト操作を表す構造体
SystemEvents | システムからのイベントを受け取るためのクラス
SystemMemory | システムのメモリの状態を取得するクラス
SystemParameters | システムのパラメタを受け取るためのクラス
TapEventArgs | タップイベント引数
TapGestureDetector | タップ検出器
TextChangedEventArgs | テキストを変更したときのイベント引数
TextInputDialog | テキスト入力ダイアログ
TextShadowSettings | 文字列の影の設定情報
Texture | テクスチャを表す基底クラス
Texture2D | 2Dテクスチャを表すクラス
TextureCube | キューブテクスチャを表すクラス
TextureFilter | テクスチャフィルタを表す構造体
TextureInfo | TextureInfoは、Texture2Dオブジェクトを保持し、関連付けられたタイルのUVデータをキャッシュします。 タイルの転送元領域はテクスチャ全体である必要はなく、UV領域内の任意の大きさのボックスで指定することができます。 TextureInfoは、渡されるTexture2Dオブジェクトの所有権を取得し、Dispose関数で破棄します。
TextureWrap | テクスチャラップを表す構造体
TiltDropEffect | 下方向へ落ちるエフェクト
TiltDropTransition | 下方向へ落ちるトランジション
TimePicker | 時刻を選択するためのウィジェット
TimePickerValueChangedEventArgs | TimePicker の値が変更されたときのイベント引数
Timer | シンプルなタイマー。
TintBy | 徐々に色を加算していくアクション。
TintTo | 指定した値に徐々に色をセットしていくアクション。
Input2.Touch | Input.Touch をラップしたクラス。
Touch | タッチパネルデバイスを表すクラス
TouchData | タッチパネルの指ひとつ分のタッチ情報
Input2.TouchData | Input.TouchData をラップしたクラス。
TouchEvent | タッチイベントクラス
TouchEventArgs | タッチイベント引数
TouchEventCollection | 複数のタッチイベントをまとめて保持するクラス
Transition | シーンに適用するアニメーションの基底クラス
TransitionCrossFade | TransitionCrossFade は 2つのシーンをクロスフェードさせるために、ブレンドを使います。 フェイドのコントロールに DTween を使うことができます。
TransitionDirectionalFade | TransitionDirectionalFade は2つのシーンをクロスフェードさせるのに、変換ブレンドマスクを使います。 クロスフェードのラインは、開発者が指定した方向に沿って動作し、古いシーンが新しいシーンに置き換わります。
TransitionFadeBase | フェイドの画面遷移を行う基底クラス。 両方のシーンをオフスクリーンで描画する必要があります。
TransitionScene | 画面遷移ノードのための基底クラス。これらのノードは2つのシーンを視覚的に遷移させます。 遷移中は、両方のシーンを Updateし、描画します。
TransitionSolidFade | TransitionSolidFade は、次のシーンをフェイドする前に、現在のシーンを黒にフェイドします。
TRS | TRSはシーングラフの専門用語です。TRSは平行移動/回転/スケールの2D変換行列を標準的な方法で格納するのために使用されています。 また、向きをもった境界ボックスを定義します。 TRSはスプライトの配置/サイズとスプライトUVの両方を格納するためにも使用します。
UByte2 | Vector of 2 unsigned shorts
UByte2N | Vector of 2 normalized unsigned bytes
UByte3 | Vector of 3 unsigned shorts
UByte3N | Vector of 3 normalized unsigned bytes
UByte4 | Vector of 4 unsigned bytes
UByte4N | Vector of 4 normalized unsigned bytes
UByteN | Scalar normalized unsigned byte
UIAnimationPlayer | Uia 形式のアニメーションを再生するクラス
UIColor | 色を扱う構造体
UIDebug | UI Toolkit のデバッグに使用するユーティリティクラス
UIElement | 描画要素の基底クラス
UIFont | UIで使用するフォントクラス
UIMotion | Uim 形式のモーションを再生するクラス
UIPrimitive | プリミティブ
UIPrimitiveUtility | プリミティブのユーティリティ
UIPrimitiveVertex | UIPrimitiveが管理する頂点データ
UISprite | 複数の矩形をまとめて描画する
UISpriteUnit | UISpriteが管理する矩形データ
UISpriteUtility | スプライトのユーティリティ
UISystem | UI Toolkitのシステム全体の管理を行うクラス
UpdateEventArgs | 更新処理イベントのデータが格納されているクラス
UShort2 | Vector of 2 unsigned shorts
UShort2N | Vector of 2 normalized unsigned shorts
UShort3 | Vector of 3 unsigned shorts
UShort3N | Vector of 3 normalized unsigned shorts
UShort4 | Vector of 4 unsigned shorts
UShort4N | Vector of 4 normalized unsigned shorts
UShortN | Scalar normalized unsigned short
Vector2 | Vector of 2 floats
Vector2i | Vector2 のint版。
Vector3 | Vector of 3 floats
Vector3i | Vector3 の int版。
Vector4 | Vector of 4 floats
DrawHelpers.Vertex | DrawHelpers で使用される頂点 (V4F_C4F)。
VertexBuffer | 頂点バッファを表すクラス
Widget | ウィジェットの基底クラス
ZoomEffect | 現在のスケールから指定したスケールに拡大または縮小するエフェクト


構成索引

A | B | C | D | E | F | G | H | I | J | K | L | M | N | P | Q | R | S | T | U | V | W | Z
A
SpriteRenderer::DefaultFontShader_ (Sce.PlayStation.HighLevel.GameEngine2D.Base) JumpFlipEffect (Sce.PlayStation.HighLevel.UI) PopupListItemCollection (Sce.PlayStation.HighLevel.UI) TextChangedEventArgs (Sce.PlayStation.HighLevel.UI)
AccountInformation (Sce.PlayStation.Core.Services) SpriteRenderer::DefaultShader_ (Sce.PlayStation.HighLevel.GameEngine2D.Base) JumpFlipTransition (Sce.PlayStation.HighLevel.UI) PopupListItemsChangedEventArgs (Sce.PlayStation.HighLevel.UI) TextInputDialog (Sce.PlayStation.Core.Environment)
Shell::Action (Sce.PlayStation.Core.Environment) DelayedExecutor (Sce.PlayStation.HighLevel.UI)
K
PopupSelectionChangedEventArgs (Sce.PlayStation.HighLevel.UI) TextShadowSettings (Sce.PlayStation.HighLevel.UI)
ActionBase (Sce.PlayStation.HighLevel.GameEngine2D) DelayTime (Sce.PlayStation.HighLevel.GameEngine2D) KeyEvent (Sce.PlayStation.HighLevel.UI) PressStateChangedEventArgs (Sce.PlayStation.HighLevel.UI) Texture (Sce.PlayStation.Core.Graphics)
ActionManager (Sce.PlayStation.HighLevel.GameEngine2D) DepthBuffer (Sce.PlayStation.Core.Graphics) KeyEventArgs (Sce.PlayStation.HighLevel.UI) Primitive (Sce.PlayStation.Core.Graphics) Texture2D (Sce.PlayStation.Core.Graphics)
ActionTweenGeneric (Sce.PlayStation.HighLevel.GameEngine2D) DepthFunc (Sce.PlayStation.Core.Graphics)
L
ProgressBar (Sce.PlayStation.HighLevel.UI) TextureCube (Sce.PlayStation.Core.Graphics)
ActionTweenGenericVector2 (Sce.PlayStation.HighLevel.GameEngine2D) Dialog (Sce.PlayStation.HighLevel.UI) Label (Sce.PlayStation.HighLevel.UI) PushTransition (Sce.PlayStation.HighLevel.UI) TextureFilter (Sce.PlayStation.Core.Graphics)
ActionTweenGenericVector2Rotation (Sce.PlayStation.HighLevel.GameEngine2D) DialogEventArgs (Sce.PlayStation.HighLevel.UI) Label (Sce.PlayStation.HighLevel.GameEngine2D)
Q
TextureInfo (Sce.PlayStation.HighLevel.GameEngine2D.Base)
ActionTweenGenericVector2Scale (Sce.PlayStation.HighLevel.GameEngine2D) Director (Sce.PlayStation.HighLevel.GameEngine2D) ListPanel (Sce.PlayStation.HighLevel.UI) Quaternion (Sce.PlayStation.Core) TextureWrap (Sce.PlayStation.Core.Graphics)
ActionTweenGenericVector4 (Sce.PlayStation.HighLevel.GameEngine2D) DoubleTapEventArgs (Sce.PlayStation.HighLevel.UI) ListPanelItem (Sce.PlayStation.HighLevel.UI)
R
TiltDropEffect (Sce.PlayStation.HighLevel.UI)
ActionWithDuration (Sce.PlayStation.HighLevel.GameEngine2D) DoubleTapGestureDetector (Sce.PlayStation.HighLevel.UI) ListPanelItemSelectChangedEventArgs (Sce.PlayStation.HighLevel.UI) Math::RandGenerator (Sce.PlayStation.HighLevel.GameEngine2D.Base) TiltDropTransition (Sce.PlayStation.HighLevel.UI)
AnimationImageBox (Sce.PlayStation.HighLevel.UI) DragEventArgs (Sce.PlayStation.HighLevel.UI) ListSection (Sce.PlayStation.HighLevel.UI) RawSpriteTile (Sce.PlayStation.HighLevel.GameEngine2D) TimePicker (Sce.PlayStation.HighLevel.UI)
AnimationUtility (Sce.PlayStation.HighLevel.UI) DragGestureDetector (Sce.PlayStation.HighLevel.UI) ListSectionCollection (Sce.PlayStation.HighLevel.UI) RawSpriteTileList (Sce.PlayStation.HighLevel.GameEngine2D) TimePickerValueChangedEventArgs (Sce.PlayStation.HighLevel.UI)
DrawHelpers::ArrowParams (Sce.PlayStation.HighLevel.GameEngine2D.Base) DrawHelpers (Sce.PlayStation.HighLevel.GameEngine2D.Base) LiveFlipPanel (Sce.PlayStation.HighLevel.UI) RayHit (Sce.PlayStation.HighLevel.Physics2D) Timer (Sce.PlayStation.HighLevel.GameEngine2D.Base)
B
E
LiveJumpPanel (Sce.PlayStation.HighLevel.UI) Rectangle (Sce.PlayStation.Core) TintBy (Sce.PlayStation.HighLevel.GameEngine2D)
BasicArrays (Sce.PlayStation.HighLevel.Model) EditableText (Sce.PlayStation.HighLevel.UI) LiveListPanel (Sce.PlayStation.HighLevel.UI) RenderTarget (Sce.PlayStation.Core.Graphics) TintTo (Sce.PlayStation.HighLevel.GameEngine2D)
BasicBone (Sce.PlayStation.HighLevel.Model) Effect (Sce.PlayStation.HighLevel.UI) LiveScrollPanel (Sce.PlayStation.HighLevel.UI) Repeat (Sce.PlayStation.HighLevel.GameEngine2D) Touch (Sce.PlayStation.Core.Input)
BasicFCurve (Sce.PlayStation.HighLevel.Model) EmbeddedDebugFontData (Sce.PlayStation.HighLevel.GameEngine2D.Base) LiveSphere (Sce.PlayStation.HighLevel.UI) RepeatForever (Sce.PlayStation.HighLevel.GameEngine2D) Input2::Touch (Sce.PlayStation.HighLevel.GameEngine2D.Base)
BasicLayer (Sce.PlayStation.HighLevel.Model) ParticleSystem::EmitterParams (Sce.PlayStation.HighLevel.GameEngine2D) LiveSpringPanel (Sce.PlayStation.HighLevel.UI) RestoredEventArgs (Sce.PlayStation.Core.Environment) Input2::TouchData (Sce.PlayStation.HighLevel.GameEngine2D.Base)
BasicMaterial (Sce.PlayStation.HighLevel.Model)
F
TRS::Local (Sce.PlayStation.HighLevel.GameEngine2D.Base) Rgb565 (Sce.PlayStation.Core) TouchData (Sce.PlayStation.Core.Input)
BasicMesh (Sce.PlayStation.HighLevel.Model) FadeInEffect (Sce.PlayStation.HighLevel.UI) Location (Sce.PlayStation.Core.Device) Rgba (Sce.PlayStation.Core) TouchEvent (Sce.PlayStation.HighLevel.UI)
BasicModel (Sce.PlayStation.HighLevel.Model) FadeOutEffect (Sce.PlayStation.HighLevel.UI) LocationData (Sce.PlayStation.Core.Device) Rgba4444 (Sce.PlayStation.Core) TouchEventArgs (Sce.PlayStation.HighLevel.UI)
BasicMotion (Sce.PlayStation.HighLevel.Model) FlickEventArgs (Sce.PlayStation.HighLevel.UI) LongPressEventArgs (Sce.PlayStation.HighLevel.UI) Rgba5551 (Sce.PlayStation.Core) TouchEventCollection (Sce.PlayStation.HighLevel.UI)
BasicParameters (Sce.PlayStation.HighLevel.Model) FlickGestureDetector (Sce.PlayStation.HighLevel.UI) LongPressGestureDetector (Sce.PlayStation.HighLevel.UI) RollPitch (Sce.PlayStation.HighLevel.GameEngine2D.Base) Transition (Sce.PlayStation.HighLevel.UI)
BasicPart (Sce.PlayStation.HighLevel.Model) FlipBoardEffect (Sce.PlayStation.HighLevel.UI)
M
RootUIElement (Sce.PlayStation.HighLevel.UI) TransitionCrossFade (Sce.PlayStation.HighLevel.GameEngine2D)
BasicProgram (Sce.PlayStation.HighLevel.Model) FlipBoardTransition (Sce.PlayStation.HighLevel.UI) Math (Sce.PlayStation.HighLevel.GameEngine2D.Base) RootWidget (Sce.PlayStation.HighLevel.UI) TransitionDirectionalFade (Sce.PlayStation.HighLevel.GameEngine2D)
BasicProgramContainer (Sce.PlayStation.HighLevel.Model) FMath (Sce.PlayStation.Core) Matrix3 (Sce.PlayStation.HighLevel.GameEngine2D.Base) RotateBy (Sce.PlayStation.HighLevel.GameEngine2D) TransitionFadeBase (Sce.PlayStation.HighLevel.GameEngine2D)
BasicTexture (Sce.PlayStation.HighLevel.Model) FocusChangedEventArgs (Sce.PlayStation.HighLevel.UI) Matrix4 (Sce.PlayStation.Core) RotateTo (Sce.PlayStation.HighLevel.GameEngine2D) TransitionScene (Sce.PlayStation.HighLevel.GameEngine2D)
BasicTextureContainer (Sce.PlayStation.HighLevel.Model) FocusCustomSettings (Sce.PlayStation.HighLevel.UI) MatrixStack (Sce.PlayStation.HighLevel.GameEngine2D.Base)
S
TransitionSolidFade (Sce.PlayStation.HighLevel.GameEngine2D)
Bgm (Sce.PlayStation.Core.Audio) Font (Sce.PlayStation.Core.Imaging) MessageDialog (Sce.PlayStation.HighLevel.UI) ScaleBy (Sce.PlayStation.HighLevel.GameEngine2D) TRS (Sce.PlayStation.HighLevel.GameEngine2D.Base)
BgmPlayer (Sce.PlayStation.Core.Audio) FontMap (Sce.PlayStation.HighLevel.GameEngine2D.Base) MessageDialogButtonEventArgs (Sce.PlayStation.HighLevel.UI) ScaleTo (Sce.PlayStation.HighLevel.GameEngine2D)
U
BlendFunc (Sce.PlayStation.Core.Graphics) FontMetrics (Sce.PlayStation.Core.Imaging) MinimizedEventArgs (Sce.PlayStation.Core.Environment) Scene (Sce.PlayStation.HighLevel.UI) UByte2 (Sce.PlayStation.Core)
BlendMode (Sce.PlayStation.HighLevel.GameEngine2D.Base) FrameBuffer (Sce.PlayStation.Core.Graphics) Motion (Sce.PlayStation.Core.Input) Scene (Sce.PlayStation.HighLevel.GameEngine2D) UByte2N (Sce.PlayStation.Core)
Bounds2 (Sce.PlayStation.HighLevel.GameEngine2D.Base) Camera::FrameChangedEventArgs (Sce.PlayStation.Core.Device) MotionData (Sce.PlayStation.Core.Input) Scheduler (Sce.PlayStation.HighLevel.GameEngine2D) UByte3 (Sce.PlayStation.Core)
BunjeeJumpEffect (Sce.PlayStation.HighLevel.UI) Frustum (Sce.PlayStation.HighLevel.GameEngine2D.Base) MotionEvent (Sce.PlayStation.HighLevel.UI) ScrollBar (Sce.PlayStation.HighLevel.UI) UByte3N (Sce.PlayStation.Core)
BusyIndicator (Sce.PlayStation.HighLevel.UI)
G
MotionEventArgs (Sce.PlayStation.HighLevel.UI) ScrollPanel (Sce.PlayStation.HighLevel.UI) UByte4 (Sce.PlayStation.Core)
Button (Sce.PlayStation.HighLevel.UI) Input2::GamePad (Sce.PlayStation.HighLevel.GameEngine2D.Base) MoveBy (Sce.PlayStation.HighLevel.GameEngine2D) Sequence (Sce.PlayStation.HighLevel.GameEngine2D) UByte4N (Sce.PlayStation.Core)
Input2::ButtonState (Sce.PlayStation.HighLevel.GameEngine2D.Base) GamePad (Sce.PlayStation.Core.Input) MoveEffect (Sce.PlayStation.HighLevel.UI) ShaderProgram (Sce.PlayStation.Core.Graphics) UByteN (Sce.PlayStation.Core)
Byte2 (Sce.PlayStation.Core) Input2::GamePadData (Sce.PlayStation.HighLevel.GameEngine2D.Base) MoveTo (Sce.PlayStation.HighLevel.GameEngine2D) ShaderProgramOption (Sce.PlayStation.Core.Graphics) UIAnimationPlayer (Sce.PlayStation.HighLevel.UI)
Byte2N (Sce.PlayStation.Core) GamePadData (Sce.PlayStation.Core.Input)
N
Shell (Sce.PlayStation.Core.Environment) UIColor (Sce.PlayStation.HighLevel.UI)
Byte3 (Sce.PlayStation.Core) GestureDetector (Sce.PlayStation.HighLevel.UI) Network (Sce.PlayStation.Core.Services) Short2 (Sce.PlayStation.Core) UIDebug (Sce.PlayStation.HighLevel.UI)
Byte3N (Sce.PlayStation.Core) GestureEventArgs (Sce.PlayStation.HighLevel.UI) NetworkRequest (Sce.PlayStation.Core.Services) Short2N (Sce.PlayStation.Core) UIElement (Sce.PlayStation.HighLevel.UI)
Byte4 (Sce.PlayStation.Core) GraphicsCaps (Sce.PlayStation.Core.Graphics) NetworkResponse (Sce.PlayStation.Core.Services) Short3 (Sce.PlayStation.Core) UIFont (Sce.PlayStation.HighLevel.UI)
Byte4N (Sce.PlayStation.Core) GraphicsContext (Sce.PlayStation.Core.Graphics) NetworkStreamReader (Sce.PlayStation.Core.Services) Short3N (Sce.PlayStation.Core) UIMotion (Sce.PlayStation.HighLevel.UI)
ByteN (Sce.PlayStation.Core) GraphicsContextAlpha (Sce.PlayStation.HighLevel.GameEngine2D.Base) NinePatchMargin (Sce.PlayStation.HighLevel.UI) Short4 (Sce.PlayStation.Core) UIPrimitive (Sce.PlayStation.HighLevel.UI)
C
GridListPanel (Sce.PlayStation.HighLevel.UI) Node (Sce.PlayStation.HighLevel.GameEngine2D) Short4N (Sce.PlayStation.Core) UIPrimitiveUtility (Sce.PlayStation.HighLevel.UI)
TextureInfo::CachedTileData (Sce.PlayStation.HighLevel.GameEngine2D.Base)
H
P
ShortN (Sce.PlayStation.Core) UIPrimitiveVertex (Sce.PlayStation.HighLevel.UI)
CallFunc (Sce.PlayStation.HighLevel.GameEngine2D) Half (Sce.PlayStation.Core) PagePanel (Sce.PlayStation.HighLevel.UI) ParticleSystem::SimulationParams (Sce.PlayStation.HighLevel.GameEngine2D) UISprite (Sce.PlayStation.HighLevel.UI)
Camera (Sce.PlayStation.Core.Device) Half2 (Sce.PlayStation.Core) Panel (Sce.PlayStation.HighLevel.UI) SkewBy (Sce.PlayStation.HighLevel.GameEngine2D) UISpriteUnit (Sce.PlayStation.HighLevel.UI)
Camera2D (Sce.PlayStation.HighLevel.GameEngine2D.Base) Half3 (Sce.PlayStation.Core) ParticleSystem::Particle (Sce.PlayStation.HighLevel.GameEngine2D) SkewTo (Sce.PlayStation.HighLevel.GameEngine2D) UISpriteUtility (Sce.PlayStation.HighLevel.UI)
Camera3D (Sce.PlayStation.HighLevel.GameEngine2D.Base) Half4 (Sce.PlayStation.Core) Particles (Sce.PlayStation.HighLevel.GameEngine2D) SlideInEffect (Sce.PlayStation.HighLevel.UI) UISystem (Sce.PlayStation.HighLevel.UI)
CameraImportDialog (Sce.PlayStation.Core.Device)
I
ParticleSystem::ParticleShaderDefault (Sce.PlayStation.HighLevel.GameEngine2D) SlideOutEffect (Sce.PlayStation.HighLevel.UI) UpdateEventArgs (Sce.PlayStation.HighLevel.UI)
CameraInfo (Sce.PlayStation.Core.Device) ICamera (Sce.PlayStation.HighLevel.GameEngine2D.Base) ParticleSystem (Sce.PlayStation.HighLevel.GameEngine2D) Slider (Sce.PlayStation.HighLevel.UI) UShort2 (Sce.PlayStation.Core)
CameraSize (Sce.PlayStation.Core.Device) ICollisionBasics (Sce.PlayStation.HighLevel.GameEngine2D.Base) PersistentMemory (Sce.PlayStation.Core.Environment) SliderValueChangeEventArgs (Sce.PlayStation.HighLevel.UI) UShort2N (Sce.PlayStation.Core)
FontMap::CharData (Sce.PlayStation.HighLevel.GameEngine2D.Base) ICommonDialog (Sce.PlayStation.Core.Environment) PhotoImportDialog (Sce.PlayStation.Core.Device) SlideTransition (Sce.PlayStation.HighLevel.UI) UShort3 (Sce.PlayStation.Core)
CharMetrics (Sce.PlayStation.Core.Imaging) Image (Sce.PlayStation.Core.Imaging) PhysicsBody (Sce.PlayStation.HighLevel.Physics2D) Sound (Sce.PlayStation.Core.Audio) UShort3N (Sce.PlayStation.Core)
CheckBox (Sce.PlayStation.HighLevel.UI) ImageAsset (Sce.PlayStation.HighLevel.UI) PhysicsJoint (Sce.PlayStation.HighLevel.Physics2D) SoundPlayer (Sce.PlayStation.Core.Audio) UShort4 (Sce.PlayStation.Core)
Clipboard (Sce.PlayStation.Core.Environment) ImageBox (Sce.PlayStation.HighLevel.UI) PhysicsScene (Sce.PlayStation.HighLevel.Physics2D) Sphere2 (Sce.PlayStation.HighLevel.GameEngine2D.Base) UShort4N (Sce.PlayStation.Core)
ColorBuffer (Sce.PlayStation.Core.Graphics) ImageColor (Sce.PlayStation.Core.Imaging) PhysicsShape (Sce.PlayStation.HighLevel.Physics2D) SpriteBase (Sce.PlayStation.HighLevel.GameEngine2D) UShortN (Sce.PlayStation.Core)
Colors (Sce.PlayStation.HighLevel.GameEngine2D.Base) ImagePosition (Sce.PlayStation.Core.Imaging) PhysicsSolverPair (Sce.PlayStation.HighLevel.Physics2D) SpriteList (Sce.PlayStation.HighLevel.GameEngine2D)
V
ContainerWidget (Sce.PlayStation.HighLevel.UI) ImageRect (Sce.PlayStation.Core.Imaging) PhysicsSpring (Sce.PlayStation.HighLevel.Physics2D) SpriteRenderer (Sce.PlayStation.HighLevel.GameEngine2D.Base) Vector2 (Sce.PlayStation.Core)
ConvexPoly2 (Sce.PlayStation.HighLevel.GameEngine2D.Base) ImageSize (Sce.PlayStation.Core.Imaging) PhysicsUtility (Sce.PlayStation.HighLevel.Physics2D) SpriteTile (Sce.PlayStation.HighLevel.GameEngine2D) Vector2i (Sce.PlayStation.HighLevel.GameEngine2D.Base)
CrossFadeTransition (Sce.PlayStation.HighLevel.UI) ImmediateMode (Sce.PlayStation.HighLevel.GameEngine2D.Base) Camera::PictureStateChangedEventArgs (Sce.PlayStation.Core.Device) SpriteUV (Sce.PlayStation.HighLevel.GameEngine2D) Vector3 (Sce.PlayStation.Core)
CullFace (Sce.PlayStation.Core.Graphics) ImmediateModeQuads (Sce.PlayStation.HighLevel.GameEngine2D.Base) PinchEventArgs (Sce.PlayStation.HighLevel.UI) StencilFunc (Sce.PlayStation.Core.Graphics) Vector3i (Sce.PlayStation.HighLevel.GameEngine2D.Base)
CustomButtonImageSettings (Sce.PlayStation.HighLevel.UI) InAppPurchaseDialog (Sce.PlayStation.Core.Services) PinchGestureDetector (Sce.PlayStation.HighLevel.UI) StencilOp (Sce.PlayStation.Core.Graphics) Vector4 (Sce.PlayStation.Core)
CustomCheckBoxImageSettings (Sce.PlayStation.HighLevel.UI) InAppPurchaseProduct (Sce.PlayStation.Core.Services) PitchRoll (Sce.PlayStation.HighLevel.GameEngine2D.Base) SystemEvents (Sce.PlayStation.Core.Environment) DrawHelpers::Vertex (Sce.PlayStation.HighLevel.GameEngine2D.Base)
D
InAppPurchaseProductList (Sce.PlayStation.Core.Services) PixelBuffer (Sce.PlayStation.Core.Graphics) SystemMemory (Sce.PlayStation.Core.Environment) VertexBuffer (Sce.PlayStation.Core.Graphics)
DatePicker (Sce.PlayStation.HighLevel.UI) Input2 (Sce.PlayStation.HighLevel.GameEngine2D.Base) Plane2 (Sce.PlayStation.HighLevel.GameEngine2D.Base) SystemParameters (Sce.PlayStation.Core.Environment)
W
DatePickerValueChangedEventArgs (Sce.PlayStation.HighLevel.UI) ParticleSystem::IParticleShader (Sce.PlayStation.HighLevel.GameEngine2D) Plane3D (Sce.PlayStation.HighLevel.GameEngine2D)
T
Widget (Sce.PlayStation.HighLevel.UI)
DebugFlags (Sce.PlayStation.HighLevel.GameEngine2D) SpriteRenderer::ISpriteShader (Sce.PlayStation.HighLevel.GameEngine2D.Base) PolygonOffset (Sce.PlayStation.Core.Graphics) TapEventArgs (Sce.PlayStation.HighLevel.UI)
Z
GraphicsContextAlpha::DebugStats_ (Sce.PlayStation.HighLevel.GameEngine2D.Base)
J
PopupList (Sce.PlayStation.HighLevel.UI) TapGestureDetector (Sce.PlayStation.HighLevel.UI) ZoomEffect (Sce.PlayStation.HighLevel.UI)
A | B | C | D | E | F | G | H | I | J | K | L | M | N | P | Q | R | S | T | U | V | W | Z


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Audio
  • Bgm

Bgm メンバ一覧

これは全メンバの一覧です。Bgm継承メンバも含んでいます。
Bgm(string filename) | Bgm
Bgm(byte[] fileImage) | Bgm
CreatePlayer() | Bgm
Dispose() | Bgm


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Audio
  • BgmPlayer

BgmPlayer メンバ一覧

これは全メンバの一覧です。BgmPlayer継承メンバも含んでいます。
Dispose() | BgmPlayer
Duration | BgmPlayer
Loop | BgmPlayer
LoopEnd | BgmPlayer
LoopStart | BgmPlayer
Pause() | BgmPlayer
Play() | BgmPlayer
PlaybackRate | BgmPlayer
Resume() | BgmPlayer
Status | BgmPlayer
Stop() | BgmPlayer
Time | BgmPlayer
Volume | BgmPlayer


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Audio
  • Sound

Sound メンバ一覧

これは全メンバの一覧です。Sound継承メンバも含んでいます。
CreatePlayer() | Sound
Dispose() | Sound
Sound(string filename) | Sound
Sound(byte[] fileImage) | Sound


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Audio
  • SoundPlayer

SoundPlayer メンバ一覧

これは全メンバの一覧です。SoundPlayer継承メンバも含んでいます。
Dispose() | SoundPlayer
Duration | SoundPlayer
Loop | SoundPlayer
Pan | SoundPlayer
Play() | SoundPlayer
PlaybackRate | SoundPlayer
Status | SoundPlayer
Stop() | SoundPlayer
Time | SoundPlayer
Volume | SoundPlayer


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Device
  • Camera

Camera メンバ一覧

これは全メンバの一覧です。Camera継承メンバも含んでいます。
Camera(int cameraId) | Camera |
CameraState | Camera |
Close() | Camera |
CurrentPreviewImageFormat | Camera |
CurrentPreviewSize | Camera |
Dispose() | Camera |
Dispose(bool disposing) | Camera | [protected]
FrameChanged | Camera |
GetCameraInfo(int cameraId) | Camera | [static]
GetNumberOfCameras() | Camera | [static]
Open() | Camera |
Open(int sizeId) | Camera |
PictureFilename | Camera |
PictureState | Camera |
PictureStateChanged | Camera |
Read() | Camera |
Start() | Camera |
Stop() | Camera |
TakePicture(int sizeId) | Camera |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Device
  • Camera
  • FrameChangedEventArgs

Camera.FrameChangedEventArgs メンバ一覧

これは全メンバの一覧です。Camera.FrameChangedEventArgs継承メンバも含んでいます。
FrameBuffer | Camera.FrameChangedEventArgs
FrameCount | Camera.FrameChangedEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Device
  • Camera
  • PictureStateChangedEventArgs

Camera.PictureStateChangedEventArgs メンバ一覧

これは全メンバの一覧です。Camera.PictureStateChangedEventArgs継承メンバも含んでいます。
PictureState Camera.PictureStateChangedEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Device
  • CameraImportDialog

CameraImportDialog メンバ一覧

これは全メンバの一覧です。CameraImportDialog継承メンバも含んでいます。
Abort() | CameraImportDialog |
CameraImportDialog() | CameraImportDialog |
Dispose() | CameraImportDialog |
Dispose(bool disposing) | CameraImportDialog | [protected, virtual]
Filename | CameraImportDialog |
Open() | CameraImportDialog |
Result | CameraImportDialog |
State | CameraImportDialog |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Device
  • Location

Location メンバ一覧

これは全メンバの一覧です。Location継承メンバも含んでいます。
GetData() | Location | [static]
GetEnableDevices() | Location | [static]
Start() | Location | [static]
Stop() | Location | [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Device
  • PhotoImportDialog

PhotoImportDialog メンバ一覧

これは全メンバの一覧です。PhotoImportDialog継承メンバも含んでいます。
Abort() | PhotoImportDialog |
Dispose() | PhotoImportDialog |
Dispose(bool disposing) | PhotoImportDialog | [protected, virtual]
Filename | PhotoImportDialog |
Open() | PhotoImportDialog |
PhotoImportDialog() | PhotoImportDialog |
Result | PhotoImportDialog |
State | PhotoImportDialog |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Environment
  • Clipboard

Clipboard メンバ一覧

これは全メンバの一覧です。Clipboard継承メンバも含んでいます。
GetText() | Clipboard | [static]
SetText(string text) | Clipboard | [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Environment
  • PersistentMemory

PersistentMemory メンバ一覧

これは全メンバの一覧です。PersistentMemory継承メンバも含んでいます。
Read() | PersistentMemory | [static]
Write(byte[] data) | PersistentMemory | [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Environment
  • Shell

Shell メンバ一覧

これは全メンバの一覧です。Shell継承メンバも含んでいます。
Execute(ref Action action) Shell [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Environment
  • SystemEvents

SystemEvents メンバ一覧

これは全メンバの一覧です。SystemEvents継承メンバも含んでいます。
CheckEvents() | SystemEvents | [static]
MinimizedEventHandler(object sender, MinimizedEventArgs e) | SystemEvents |
OnMinimized | SystemEvents | [static]
OnRestored | SystemEvents | [static]
RestoredEventHandler(object sender, RestoredEventArgs e) | SystemEvents |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Environment
  • SystemMemory

SystemMemory メンバ一覧

これは全メンバの一覧です。SystemMemory継承メンバも含んでいます。
Dump() SystemMemory [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Environment
  • SystemParameters

SystemParameters メンバ一覧

これは全メンバの一覧です。SystemParameters継承メンバも含んでいます。
DisplayDpiX | SystemParameters | [static]
DisplayDpiY | SystemParameters | [static]
GamePadButtonMeaning | SystemParameters | [static]
Language | SystemParameters | [static]
YesNoLayout | SystemParameters | [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Environment
  • TextInputDialog

TextInputDialog メンバ一覧

これは全メンバの一覧です。TextInputDialog継承メンバも含んでいます。
Abort() | TextInputDialog
Dispose() | TextInputDialog
Mode | TextInputDialog
Open() | TextInputDialog
Result | TextInputDialog
State | TextInputDialog
Text | TextInputDialog
TextInputDialog() | TextInputDialog


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • FMath

FMath メンバ一覧

これは全メンバの一覧です。FMath継承メンバも含んでいます。
Abs(float x) | FMath | [static]
Acos(float x) | FMath | [static]
Asin(float x) | FMath | [static]
Atan(float x) | FMath | [static]
Atan2(float x, float y) | FMath | [static]
Ceiling(float x) | FMath | [static]
Clamp(float x, float min, float max) | FMath | [static]
Cos(float x) | FMath | [static]
Degrees(float x) | FMath | [static]
DegToRad | FMath |
E | FMath |
Exp(float x) | FMath | [static]
Floor(float x) | FMath | [static]
Lerp(float x1, float x2, float f) | FMath | [static]
LinearStep(float min, float max, float x) | FMath | [static]
Log(float x) | FMath | [static]
Log10(float x) | FMath | [static]
Max(float x, float y) | FMath | [static]
Min(float x, float y) | FMath | [static]
Mirror(float x, float min, float max) | FMath | [static]
MoveTo(float x1, float x2, float amount) | FMath | [static]
PI | FMath |
Pow(float x, float y) | FMath | [static]
Radians(float x) | FMath | [static]
RadToDeg | FMath |
Repeat(float x, float min, float max) | FMath | [static]
Round(float x) | FMath | [static]
Sign(float x) | FMath | [static]
Sin(float x) | FMath | [static]
SmoothStep(float min, float max, float x) | FMath | [static]
Sqrt(float x) | FMath | [static]
Step(float edge, float x) | FMath | [static]
Tan(float x) | FMath | [static]
Truncate(float x) | FMath | [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • ColorBuffer

ColorBuffer メンバ一覧

これは全メンバの一覧です。ColorBuffer継承メンバも含んでいます。
ColorBuffer(int width, int height, PixelFormat format) | ColorBuffer |
ColorBuffer(ColorBuffer buffer) | ColorBuffer | [protected]
Dispose() | PixelBuffer |
Format | PixelBuffer |
GetMipmapHeight(int level) | PixelBuffer |
GetMipmapWidth(int level) | PixelBuffer |
Height | PixelBuffer |
IsPowerOfTwo | PixelBuffer |
IsRenderable | PixelBuffer |
LevelCount | PixelBuffer |
Option | PixelBuffer |
ShallowClone() | ColorBuffer | [virtual]
Type | PixelBuffer |
Width | PixelBuffer |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • DepthBuffer

DepthBuffer メンバ一覧

これは全メンバの一覧です。DepthBuffer継承メンバも含んでいます。
DepthBuffer(int width, int height, PixelFormat format) | DepthBuffer |
DepthBuffer(DepthBuffer buffer) | DepthBuffer | [protected]
Dispose() | PixelBuffer |
Format | PixelBuffer |
GetMipmapHeight(int level) | PixelBuffer |
GetMipmapWidth(int level) | PixelBuffer |
Height | PixelBuffer |
IsPowerOfTwo | PixelBuffer |
IsRenderable | PixelBuffer |
LevelCount | PixelBuffer |
Option | PixelBuffer |
ShallowClone() | DepthBuffer | [virtual]
Type | PixelBuffer |
Width | PixelBuffer |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • FrameBuffer

FrameBuffer メンバ一覧

これは全メンバの一覧です。FrameBuffer継承メンバも含んでいます。
AspectRatio | FrameBuffer |
ColorFormat | FrameBuffer |
DepthFormat | FrameBuffer |
Dispose() | FrameBuffer |
FrameBuffer() | FrameBuffer |
FrameBuffer(FrameBuffer buffer) | FrameBuffer | [protected]
GetColorTarget() | FrameBuffer |
GetDepthTarget() | FrameBuffer |
Height | FrameBuffer |
MultiSampleMode | FrameBuffer |
Rectangle | FrameBuffer |
SetColorTarget(RenderTarget target) | FrameBuffer |
SetColorTarget(ColorBuffer buffer) | FrameBuffer |
SetColorTarget(Texture2D texture, int level) | FrameBuffer |
SetColorTarget(TextureCube texture, int level, TextureCubeFace cubeFace) | FrameBuffer |
SetDepthTarget(RenderTarget target) | FrameBuffer |
SetDepthTarget(DepthBuffer buffer) | FrameBuffer |
ShallowClone() | FrameBuffer | [virtual]
Status | FrameBuffer |
Width | FrameBuffer |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • GraphicsContext

GraphicsContext メンバ一覧

これは全メンバの一覧です。GraphicsContext継承メンバも含んでいます。
Caps | GraphicsContext |
Clear() | GraphicsContext |
Clear(ClearMask mask) | GraphicsContext |
Disable(EnableMode mode) | GraphicsContext |
Dispose() | GraphicsContext |
DrawArrays(DrawMode mode, int first, int count) | GraphicsContext |
DrawArrays(DrawMode mode, int first, int count, int repeat) | GraphicsContext |
DrawArrays(Primitive[] primitives) | GraphicsContext |
DrawArrays(Primitive[] primitives, int first, int count) | GraphicsContext |
DrawArraysInstanced(DrawMode mode, int first, int count, int instFirst, int instCount) | GraphicsContext |
Enable(EnableMode mode, bool status) | GraphicsContext |
Enable(EnableMode mode) | GraphicsContext |
GetBlendFunc() | GraphicsContext |
GetBlendFuncAlpha() | GraphicsContext |
GetBlendFuncRgb() | GraphicsContext |
GetClearColor() | GraphicsContext |
GetClearDepth() | GraphicsContext |
GetClearStencil() | GraphicsContext |
GetColorMask() | GraphicsContext |
GetCullFace() | GraphicsContext |
GetDepthFunc() | GraphicsContext |
GetDepthRange() | GraphicsContext |
GetEnableMode() | GraphicsContext |
GetFrameBuffer() | GraphicsContext |
GetLineWidth() | GraphicsContext |
GetPolygonOffset() | GraphicsContext |
GetScissor() | GraphicsContext |
GetShaderProgram() | GraphicsContext |
GetStencilFunc() | GraphicsContext |
GetStencilFuncBack() | GraphicsContext |
GetStencilFuncFront() | GraphicsContext |
GetStencilOp() | GraphicsContext |
GetStencilOpBack() | GraphicsContext |
GetStencilOpFront() | GraphicsContext |
GetTexture(int index) | GraphicsContext |
GetVertexBuffer(int index) | GraphicsContext |
GetViewport() | GraphicsContext |
GraphicsContext() | GraphicsContext |
GraphicsContext(int width, int height, PixelFormat colorFormat, PixelFormat depthFormat, MultiSampleMode multiSampleMode) | GraphicsContext |
IsEnabled(EnableMode mode) | GraphicsContext |
ReadPixels(byte[] pixels, PixelFormat format, int sx, int sy, int sw, int sh) | GraphicsContext |
ReadPixels(Texture2D texture, int level, int dx, int dy, int sx, int sy, int sw, int sh) | GraphicsContext |
ReadPixels(TextureCube texture, int level, TextureCubeFace cubeFace, int dx, int dy, int sx, int sy, int sw, int sh) | GraphicsContext |
Screen | GraphicsContext |
ScreenSizes | GraphicsContext | [static]
SetBlendFunc(BlendFunc func) | GraphicsContext |
SetBlendFunc(BlendFuncMode mode, BlendFuncFactor srcFactor, BlendFuncFactor dstFactor) | GraphicsContext |
SetBlendFuncAlpha(BlendFunc func) | GraphicsContext |
SetBlendFuncAlpha(BlendFuncMode mode, BlendFuncFactor srcFactor, BlendFuncFactor dstFactor) | GraphicsContext |
SetBlendFuncRgb(BlendFunc func) | GraphicsContext |
SetBlendFuncRgb(BlendFuncMode mode, BlendFuncFactor srcFactor, BlendFuncFactor dstFactor) | GraphicsContext |
SetClearColor(Vector4 color) | GraphicsContext |
SetClearColor(float r, float g, float b, float a) | GraphicsContext |
SetClearColor(int r, int g, int b, int a) | GraphicsContext |
SetClearDepth(float depth) | GraphicsContext |
SetClearStencil(int stencil) | GraphicsContext |
SetColorMask(ColorMask mask) | GraphicsContext |
SetCullFace(CullFace face) | GraphicsContext |
SetCullFace(CullFaceMode mode, CullFaceDirection direction) | GraphicsContext |
SetDepthFunc(DepthFunc func) | GraphicsContext |
SetDepthFunc(DepthFuncMode mode, bool writeMask) | GraphicsContext |
SetDepthRange(Vector2 range) | GraphicsContext |
SetDepthRange(float min, float max) | GraphicsContext |
SetEnableMode(EnableMode mode) | GraphicsContext |
SetFrameBuffer(FrameBuffer buffer) | GraphicsContext |
SetLineWidth(float width) | GraphicsContext |
SetPolygonOffset(PolygonOffset offset) | GraphicsContext |
SetPolygonOffset(float factor, float units) | GraphicsContext |
SetScissor(ImageRect rectangle) | GraphicsContext |
SetScissor(int x, int y, int w, int h) | GraphicsContext |
SetShaderProgram(ShaderProgram program) | GraphicsContext |
SetStencilFunc(StencilFunc func) | GraphicsContext |
SetStencilFunc(StencilFuncMode mode, int reference, int readMask, int writeMask) | GraphicsContext |
SetStencilFuncBack(StencilFunc func) | GraphicsContext |
SetStencilFuncBack(StencilFuncMode mode, int reference, int readMask, int writeMask) | GraphicsContext |
SetStencilFuncFront(StencilFunc func) | GraphicsContext |
SetStencilFuncFront(StencilFuncMode mode, int reference, int readMask, int writeMask) | GraphicsContext |
SetStencilOp(StencilOp op) | GraphicsContext |
SetStencilOp(StencilOpMode fail, StencilOpMode zFail, StencilOpMode zPass) | GraphicsContext |
SetStencilOpBack(StencilOp op) | GraphicsContext |
SetStencilOpBack(StencilOpMode fail, StencilOpMode zFail, StencilOpMode zPass) | GraphicsContext |
SetStencilOpFront(StencilOp op) | GraphicsContext |
SetStencilOpFront(StencilOpMode fail, StencilOpMode zFail, StencilOpMode zPass) | GraphicsContext |
SetTexture(int index, Texture texture) | GraphicsContext |
SetVertexBuffer(int index, VertexBuffer buffer) | GraphicsContext |
SetViewport(ImageRect rectangle) | GraphicsContext |
SetViewport(int x, int y, int w, int h) | GraphicsContext |
SwapBuffers() | GraphicsContext |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • PixelBuffer

PixelBuffer メンバ一覧

これは全メンバの一覧です。PixelBuffer継承メンバも含んでいます。
Dispose() | PixelBuffer |
Format | PixelBuffer |
GetMipmapHeight(int level) | PixelBuffer |
GetMipmapWidth(int level) | PixelBuffer |
Height | PixelBuffer |
IsPowerOfTwo | PixelBuffer |
IsRenderable | PixelBuffer |
LevelCount | PixelBuffer |
Option | PixelBuffer |
ShallowClone() | PixelBuffer | [virtual]
Type | PixelBuffer |
Width | PixelBuffer |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • ShaderProgram

ShaderProgram メンバ一覧

これは全メンバの一覧です。ShaderProgram継承メンバも含んでいます。
AttributeCount | ShaderProgram |
Dispose() | ShaderProgram |
FindAttribute(string name) | ShaderProgram |
FindUniform(string name) | ShaderProgram |
GetAttributeBinding(int index) | ShaderProgram |
GetAttributeName(int index) | ShaderProgram |
GetAttributeSize(int index) | ShaderProgram |
GetAttributeStream(int index) | ShaderProgram |
GetAttributeType(int index) | ShaderProgram |
GetUniformBinding(int index) | ShaderProgram |
GetUniformName(int index) | ShaderProgram |
GetUniformSize(int index) | ShaderProgram |
GetUniformTexture(int index) | ShaderProgram |
GetUniformType(int index) | ShaderProgram |
SetAttributeBinding(int index, string name) | ShaderProgram |
SetAttributeStream(int index, int stream) | ShaderProgram |
SetAttributeValue(int index, params float[] value) | ShaderProgram |
SetUniformBinding(int index, string name) | ShaderProgram |
SetUniformValue(int index, ref Matrix4 value) | ShaderProgram |
SetUniformValue(int index, ref Vector4 value) | ShaderProgram |
SetUniformValue(int index, ref Vector3 value) | ShaderProgram |
SetUniformValue(int index, ref Vector2 value) | ShaderProgram |
SetUniformValue(int index, float value) | ShaderProgram |
SetUniformValue(int index, int value) | ShaderProgram |
SetUniformValue(int index, float[] value) | ShaderProgram |
SetUniformValue(int index, int[] value) | ShaderProgram |
SetUniformValue(int index, int offset, ref Matrix4 value) | ShaderProgram |
SetUniformValue(int index, int offset, ref Vector4 value) | ShaderProgram |
SetUniformValue(int index, int offset, ref Vector3 value) | ShaderProgram |
SetUniformValue(int index, int offset, ref Vector2 value) | ShaderProgram |
SetUniformValue(int index, int offset, float value) | ShaderProgram |
SetUniformValue(int index, int offset, int value) | ShaderProgram |
SetUniformValue(int index, int offset, float[] value) | ShaderProgram |
SetUniformValue(int index, int offset, int[] value) | ShaderProgram |
SetUniformValue(int index, Matrix4[] value, int to, int from, int count) | ShaderProgram |
SetUniformValue(int index, Vector4[] value, int to, int from, int count) | ShaderProgram |
SetUniformValue(int index, Vector3[] value, int to, int from, int count) | ShaderProgram |
SetUniformValue(int index, Vector2[] value, int to, int from, int count) | ShaderProgram |
SetUniformValue(int index, float[] value, int to, int from, int count) | ShaderProgram |
SetUniformValue(int index, int[] value, int to, int from, int count) | ShaderProgram |
ShaderProgram(string fileName) | ShaderProgram |
ShaderProgram(string vpFileName, string fpFileName) | ShaderProgram |
ShaderProgram(string fileName, ShaderProgramOption option) | ShaderProgram |
ShaderProgram(string vpFileName, string fpFileName, ShaderProgramOption option) | ShaderProgram |
ShaderProgram(byte[] fileImage) | ShaderProgram |
ShaderProgram(byte[] vpFileImage, byte[] fpFileImage) | ShaderProgram |
ShaderProgram(byte[] fileImage, ShaderProgramOption option) | ShaderProgram |
ShaderProgram(byte[] vpFileImage, byte[] fpFileImage, ShaderProgramOption option) | ShaderProgram |
ShaderProgram(ShaderProgram program) | ShaderProgram | [protected]
ShallowClone() | ShaderProgram | [virtual]
SwapShader(ShaderProgram program) | ShaderProgram | [protected]
UniformCount | ShaderProgram |
UpdateShader() | ShaderProgram | [protected, virtual]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • ShaderProgramOption

ShaderProgramOption メンバ一覧

これは全メンバの一覧です。ShaderProgramOption継承メンバも含んでいます。
ConstantValues | ShaderProgramOption
ShaderProgramOption() | ShaderProgramOption


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • Texture2D

Texture2D メンバ一覧

これは全メンバの一覧です。Texture2D継承メンバも含んでいます。
Dispose() | PixelBuffer |
Format | PixelBuffer |
GenerateMipmap() | Texture2D |
GetFilter() | Texture |
GetMaxAnisotropy() | Texture |
GetMipmapHeight(int level) | PixelBuffer |
GetMipmapWidth(int level) | PixelBuffer |
GetWrap() | Texture |
Height | PixelBuffer |
IsPowerOfTwo | PixelBuffer |
IsRenderable | PixelBuffer |
LevelCount | PixelBuffer |
Option | PixelBuffer |
SetFilter(TextureFilter filter) | Texture |
SetFilter(TextureFilterMode mode) | Texture |
SetFilter(TextureFilterMode mag, TextureFilterMode min, TextureFilterMode mip) | Texture |
SetMaxAnisotropy(float anisotropy) | Texture |
SetPixels(int level, Array pixels) | Texture2D |
SetPixels(int level, Array pixels, int dx, int dy, int dw, int dh) | Texture2D |
SetPixels(int level, Array pixels, int offset, int pitch) | Texture2D |
SetPixels(int level, Array pixels, PixelFormat format) | Texture2D |
SetPixels(int level, Array pixels, PixelFormat format, int offset, int pitch, int dx, int dy, int dw, int dh) | Texture2D |
SetWrap(TextureWrap wrap) | Texture |
SetWrap(TextureWrapMode mode) | Texture |
SetWrap(TextureWrapMode s, TextureWrapMode t) | Texture |
ShallowClone() | Texture2D | [virtual]
Texture2D(int width, int height, bool mipmap, PixelFormat format) | Texture2D |
Texture2D(int width, int height, bool mipmap, PixelFormat format, PixelBufferOption option) | Texture2D |
Texture2D(string fileName, bool mipmap) | Texture2D |
Texture2D(string fileName, bool mipmap, PixelFormat format) | Texture2D |
Texture2D(byte[] fileImage, bool mipmap) | Texture2D |
Texture2D(byte[] fileImage, bool mipmap, PixelFormat format) | Texture2D |
Texture2D(Texture2D texture) | Texture2D | [protected]
Type | PixelBuffer |
Width | PixelBuffer |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • Texture

Texture メンバ一覧

これは全メンバの一覧です。Texture継承メンバも含んでいます。
Dispose() | PixelBuffer |
Format | PixelBuffer |
GetFilter() | Texture |
GetMaxAnisotropy() | Texture |
GetMipmapHeight(int level) | PixelBuffer |
GetMipmapWidth(int level) | PixelBuffer |
GetWrap() | Texture |
Height | PixelBuffer |
IsPowerOfTwo | PixelBuffer |
IsRenderable | PixelBuffer |
LevelCount | PixelBuffer |
Option | PixelBuffer |
SetFilter(TextureFilter filter) | Texture |
SetFilter(TextureFilterMode mode) | Texture |
SetFilter(TextureFilterMode mag, TextureFilterMode min, TextureFilterMode mip) | Texture |
SetMaxAnisotropy(float anisotropy) | Texture |
SetWrap(TextureWrap wrap) | Texture |
SetWrap(TextureWrapMode mode) | Texture |
SetWrap(TextureWrapMode s, TextureWrapMode t) | Texture |
ShallowClone() | Texture | [virtual]
Type | PixelBuffer |
Width | PixelBuffer |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • TextureCube

TextureCube メンバ一覧

これは全メンバの一覧です。TextureCube継承メンバも含んでいます。
Dispose() | PixelBuffer |
Format | PixelBuffer |
GenerateMipmap() | TextureCube |
GetFilter() | Texture |
GetMaxAnisotropy() | Texture |
GetMipmapHeight(int level) | PixelBuffer |
GetMipmapWidth(int level) | PixelBuffer |
GetWrap() | Texture |
Height | PixelBuffer |
IsPowerOfTwo | PixelBuffer |
IsRenderable | PixelBuffer |
LevelCount | PixelBuffer |
Option | PixelBuffer |
SetFilter(TextureFilter filter) | Texture |
SetFilter(TextureFilterMode mode) | Texture |
SetFilter(TextureFilterMode mag, TextureFilterMode min, TextureFilterMode mip) | Texture |
SetMaxAnisotropy(float anisotropy) | Texture |
SetPixels(int level, TextureCubeFace cubeFace, Array pixels) | TextureCube |
SetPixels(int level, TextureCubeFace cubeFace, Array pixels, int dx, int dy, int dw, int dh) | TextureCube |
SetPixels(int level, TextureCubeFace cubeFace, Array pixels, int offset, int pitch) | TextureCube |
SetPixels(int level, TextureCubeFace cubeFace, Array pixels, PixelFormat format) | TextureCube |
SetPixels(int level, TextureCubeFace cubeFace, Array pixels, PixelFormat format, int offset, int pitch, int dx, int dy, int dw, int dh) | TextureCube |
SetWrap(TextureWrap wrap) | Texture |
SetWrap(TextureWrapMode mode) | Texture |
SetWrap(TextureWrapMode s, TextureWrapMode t) | Texture |
ShallowClone() | TextureCube | [virtual]
TextureCube(int width, bool mipmap, PixelFormat format) | TextureCube |
TextureCube(int width, bool mipmap, PixelFormat format, PixelBufferOption option) | TextureCube |
TextureCube(string fileName, bool mipmap) | TextureCube |
TextureCube(string fileName, bool mipmap, PixelFormat format) | TextureCube |
TextureCube(byte[] fileImage, bool mipmap) | TextureCube |
TextureCube(byte[] fileImage, bool mipmap, PixelFormat format) | TextureCube |
TextureCube(TextureCube texture) | TextureCube | [protected]
Type | PixelBuffer |
Width | PixelBuffer |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • VertexBuffer

VertexBuffer メンバ一覧

これは全メンバの一覧です。VertexBuffer継承メンバも含んでいます。
Dispose() | VertexBuffer |
Formats | VertexBuffer |
IndexCount | VertexBuffer |
InstanceDivisor | VertexBuffer |
SetIndices(ushort[] indices) | VertexBuffer |
SetIndices(ushort[] indices, int to, int from, int count) | VertexBuffer |
SetVertices(Array vertices) | VertexBuffer |
SetVertices(Array vertices, int to, int from, int count) | VertexBuffer |
SetVertices(int stream, Array vertices) | VertexBuffer |
SetVertices(int stream, Array vertices, int to, int from, int count) | VertexBuffer |
SetVertices(int stream, Array vertices, int offset, int stride) | VertexBuffer |
SetVertices(int stream, Array vertices, VertexFormat format, Vector4 trans, Vector4 scale) | VertexBuffer |
SetVertices(int stream, Array vertices, VertexFormat format, Vector4 trans, Vector4 scale, int offset, int stride, int to, int from, int count) | VertexBuffer |
ShallowClone() | VertexBuffer | [virtual]
StreamCount | VertexBuffer |
VertexBuffer(int vertexCount, params VertexFormat[] formats) | VertexBuffer |
VertexBuffer(int vertexCount, int indexCount, params VertexFormat[] formats) | VertexBuffer |
VertexBuffer(int vertexCount, int indexCount, int instDivisor, params VertexFormat[] formats) | VertexBuffer |
VertexBuffer(VertexBuffer buffer) | VertexBuffer | [protected]
VertexCount | VertexBuffer |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Imaging
  • Font

Font メンバ一覧

これは全メンバの一覧です。Font継承メンバも含んでいます。
Dispose() | Font |
Font(string filename, int size, FontStyle style) | Font |
Font(FontAlias alias, int size, FontStyle style) | Font |
Font(Font font) | Font | [protected]
GetTextMetrics(string text) | Font |
GetTextMetrics(string text, int offset, int len) | Font |
GetTextWidth(string text) | Font |
GetTextWidth(string text, int offset, int len) | Font |
Metrics | Font |
Name | Font |
ShallowClone() | Font | [virtual]
Size | Font |
Style | Font |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Imaging
  • Image

Image メンバ一覧

これは全メンバの一覧です。Image継承メンバも含んでいます。
Crop(ImageRect rect) | Image |
Decode() | Image |
DecodeSize | Image |
Dispose() | Image |
DrawImage(Image source, ImagePosition position) | Image |
DrawRectangle(ImageColor color, ImageRect rect) | Image |
DrawText(string text, ImageColor color, Font font, ImagePosition position) | Image |
DrawText(string text, int offset, int len, ImageColor color, Font font, ImagePosition position) | Image |
Export(string albumname, string filename) | Image |
Image(string filename) | Image |
Image(byte[] fileImage) | Image |
Image(ImageMode mode, ImageSize size, ImageColor color) | Image |
Image(ImageMode mode, ImageSize size, byte[] buffer) | Image |
Image(Image image) | Image | [protected]
ReadBuffer(byte[] buffer) | Image |
Resize(ImageSize size) | Image |
SaveAs(string path) | Image |
ShallowClone() | Image | [virtual]
Size | Image |
ToBuffer() | Image |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Input
  • GamePad

GamePad メンバ一覧

これは全メンバの一覧です。GamePad継承メンバも含んでいます。
GetData(int deviceIndex) GamePad [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Input
  • Motion

Motion メンバ一覧

これは全メンバの一覧です。Motion継承メンバも含んでいます。
GetData(int deviceIndex) Motion [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Input
  • Touch

Touch メンバ一覧

これは全メンバの一覧です。Touch継承メンバも含んでいます。
GetData(int deviceIndex) | Touch | [static]
GetRearTouchData(int deviceIndex) | Touch | [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Services
  • AccountInformation

AccountInformation メンバ一覧

これは全メンバの一覧です。AccountInformation継承メンバも含んでいます。
UniqueID AccountInformation [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Services
  • InAppPurchaseDialog

InAppPurchaseDialog メンバ一覧

これは全メンバの一覧です。InAppPurchaseDialog継承メンバも含んでいます。
Abort() | InAppPurchaseDialog
Arguments | InAppPurchaseDialog
Command | InAppPurchaseDialog
Consume(string label) | InAppPurchaseDialog
Dispose() | InAppPurchaseDialog
GetProductInfo(string[] labels) | InAppPurchaseDialog
GetTicketInfo() | InAppPurchaseDialog
InAppPurchaseDialog() | InAppPurchaseDialog
IsProductInfoComplete | InAppPurchaseDialog
IsTicketInfoComplete | InAppPurchaseDialog
Open() | InAppPurchaseDialog
ProductList | InAppPurchaseDialog
Purchase(string label) | InAppPurchaseDialog
Result | InAppPurchaseDialog
State | InAppPurchaseDialog


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Services
  • InAppPurchaseProduct

InAppPurchaseProduct メンバ一覧

これは全メンバの一覧です。InAppPurchaseProduct継承メンバも含んでいます。
ConsumableTicketCount | InAppPurchaseProduct
IsTicketValid | InAppPurchaseProduct
Label | InAppPurchaseProduct
Name | InAppPurchaseProduct
Price | InAppPurchaseProduct
TicketType | InAppPurchaseProduct


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Services
  • InAppPurchaseProductList

InAppPurchaseProductList メンバ一覧

これは全メンバの一覧です。InAppPurchaseProductList継承メンバも含んでいます。
Contains(string label) | InAppPurchaseProductList
Count | InAppPurchaseProductList
GetEnumerator() | InAppPurchaseProductList
IndexOf(string label) | InAppPurchaseProductList
this | InAppPurchaseProductList


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Services
  • Network

Network メンバ一覧

これは全メンバの一覧です。Network継承メンバも含んでいます。
AuthGetTicket() | Network | [static]
CreateRequest(NetworkRequestType type, string function, string json) | Network | [static]
Initialize(string applicationToken) | Network | [static]
ServerTicket | Network | [static]
State | Network | [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Services
  • NetworkRequest

NetworkRequest メンバ一覧

これは全メンバの一覧です。NetworkRequest継承メンバも含んでいます。
BeginGetResponse(AsyncCallback callback) | NetworkRequest
Dispose() | NetworkRequest
EndGetResponse(IAsyncResult result) | NetworkRequest
GetResponse() | NetworkRequest


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Services
  • NetworkResponse

NetworkResponse メンバ一覧

これは全メンバの一覧です。NetworkResponse継承メンバも含んでいます。
Dispose() | NetworkResponse
GetStreamReader() | NetworkResponse


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Services
  • NetworkStreamReader

NetworkStreamReader メンバ一覧

これは全メンバの一覧です。NetworkStreamReader継承メンバも含んでいます。
Close() | NetworkStreamReader
Dispose() | NetworkStreamReader
Read(byte[] buffer, int offset, int count) | NetworkStreamReader
ReadToEnd() | NetworkStreamReader


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ActionBase

ActionBase メンバ一覧

これは全メンバの一覧です。ActionBase継承メンバも含んでいます。
IsRunning | ActionBase |
Run() | ActionBase | [virtual]
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
Update(float dt) | ActionBase | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ActionManager

ActionManager メンバ一覧

これは全メンバの一覧です。ActionManager継承メンバも含んでいます。
AddAction(ActionBase action, Node target) | ActionManager |
Dump() | ActionManager |
GetActionByTag(int tag, Node target, int ith=0) | ActionManager |
Instance | ActionManager | [static]
NumRunningActions(Node target) | ActionManager |
NumRunningActions() | ActionManager |
RemoveAction(ActionBase action) | ActionManager |
RemoveActionByTag(int tag, Node target) | ActionManager |
RemoveAllActions() | ActionManager |
RemoveAllActionsFromTarget(Node target) | ActionManager |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ActionTweenGeneric

ActionTweenGeneric< T > メンバ一覧

これは全メンバの一覧です。ActionTweenGeneric< T >継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ActionTweenGenericVector2

ActionTweenGenericVector2 メンバ一覧

これは全メンバの一覧です。ActionTweenGenericVector2継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ActionTweenGenericVector2Rotation

ActionTweenGenericVector2Rotation メンバ一覧

これは全メンバの一覧です。ActionTweenGenericVector2Rotation継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ActionTweenGenericVector2Scale

ActionTweenGenericVector2Scale メンバ一覧

これは全メンバの一覧です。ActionTweenGenericVector2Scale継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ActionTweenGenericVector4

ActionTweenGenericVector4 メンバ一覧

これは全メンバの一覧です。ActionTweenGenericVector4継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ActionWithDuration

ActionWithDuration メンバ一覧

これは全メンバの一覧です。ActionWithDuration継承メンバも含んでいます。
Duration | ActionWithDuration |
IsRunning | ActionBase |
Run() | ActionWithDuration | [virtual]
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
Update(float dt) | ActionBase | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Camera2D

Camera2D メンバ一覧

これは全メンバの一覧です。Camera2D継承メンバも含んでいます。
Aspect | Camera2D
CalcBounds() | Camera2D
Camera2D(GraphicsContextAlpha gl, DrawHelpers draw_helpers) | Camera2D
Center | Camera2D
DebugDraw(float step) | Camera2D
GetPixelSize() | Camera2D
GetTouchPos(int nth=0, bool prev=false) | Camera2D
GetTransform() | Camera2D
Navigate(int control) | Camera2D
NormalizedToWorld(Vector2 bottom_left_minus_1_minus_1_top_left_1_1_normalized_screen_pos) | Camera2D
NormalizedToWorldMatrix() | Camera2D
Pop() | Camera2D
Push() | Camera2D
SetAspectFromViewport() | Camera2D
SetTouchPlaneMatrix(Matrix4 mat) | Camera2D
SetViewFromHeightAndBottomLeft(float height, Vector2 bottom_left) | Camera2D
SetViewFromHeightAndCenter(float height, Vector2 center) | Camera2D
SetViewFromViewport() | Camera2D
SetViewFromWidthAndBottomLeft(float width, Vector2 bottom_left) | Camera2D
SetViewFromWidthAndCenter(float width, Vector2 center) | Camera2D
SetViewX(Vector2 support, Vector2 center) | Camera2D
SetViewY(Vector2 support, Vector2 center) | Camera2D
X() | Camera2D
Y() | Camera2D
Zfar | Camera2D
Znear | Camera2D


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Camera3D

Camera3D メンバ一覧

これは全メンバの一覧です。Camera3D継承メンバも含んでいます。
CalcBounds() | Camera3D
Camera3D(GraphicsContextAlpha gl, DrawHelpers draw_helpers) | Camera3D
Center | Camera3D
DebugDraw(float step) | Camera3D
Eye | Camera3D
Frustum | Camera3D
GetPixelSize() | Camera3D
GetTouchPos(int nth=0, bool prev=false) | Camera3D
GetTransform() | Camera3D
Navigate(int control) | Camera3D
NormalizedToWorld(Vector2 bottom_left_minus_1_minus_1_top_left_1_1_normalized_screen_pos) | Camera3D
Pop() | Camera3D
Push() | Camera3D
SetAspectFromViewport() | Camera3D
SetFromCamera2D(Camera2D cam2d) | Camera3D
SetTouchPlaneMatrix(Matrix4 mat) | Camera3D
SetViewFromViewport() | Camera3D
TouchPlaneMatrix | Camera3D
Up | Camera3D


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Colors

Colors メンバ一覧

これは全メンバの一覧です。Colors継承メンバも含んでいます。
Black | Colors | [static]
Blue | Colors | [static]
Cyan | Colors | [static]
Green | Colors | [static]
Grey05 | Colors | [static]
Grey10 | Colors | [static]
Grey20 | Colors | [static]
Grey30 | Colors | [static]
Grey40 | Colors | [static]
Grey50 | Colors | [static]
Grey60 | Colors | [static]
Grey70 | Colors | [static]
Grey80 | Colors | [static]
Grey90 | Colors | [static]
LightBlue | Colors | [static]
LightCyan | Colors | [static]
Lime | Colors | [static]
Magenta | Colors | [static]
Orange | Colors | [static]
Pink | Colors | [static]
Purple | Colors | [static]
Red | Colors | [static]
White | Colors | [static]
Yellow | Colors | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • DrawHelpers

DrawHelpers メンバ一覧

これは全メンバの一覧です。DrawHelpers継承メンバも含んでいます。
Dispose() | DrawHelpers
Disposed | DrawHelpers
DrawArrow(Vector2 start_point, Vector2 end_point, ArrowParams ap) | DrawHelpers
DrawAxis(Bounds2 clipping_bounds, float thickness) | DrawHelpers
DrawBounds2(Bounds2 bounds) | DrawHelpers
DrawBounds2Fill(Bounds2 bounds) | DrawHelpers
DrawCircle(Vector2 center, float radius, uint n) | DrawHelpers
DrawConvexPoly2(ConvexPoly2 convex_poly) | DrawHelpers
DrawCoordinateSystem2D(Matrix3 mat, ArrowParams ap=null) | DrawHelpers
DrawCoordinateSystem2D() | DrawHelpers
DrawDefaultGrid(Bounds2 clipping_bounds, Vector2 step, Vector4 rulers_color, Vector4 axis_color) | DrawHelpers
DrawDefaultGrid(Bounds2 clipping_bounds, float step) | DrawHelpers
DrawDisk(Vector2 center, float radius, uint n) | DrawHelpers
DrawHelpers(GraphicsContextAlpha gl, uint max_vertices) | DrawHelpers
DrawInfiniteLine(Vector2 A, Vector2 v) | DrawHelpers
DrawLineSegment(Vector2 A, Vector2 B) | DrawHelpers
DrawRulers(Bounds2 bounds, float step_x, float step_y) | DrawHelpers
ImmBegin(DrawMode mode, uint max_vertices_intended) | DrawHelpers
ImmEnd() | DrawHelpers
ImmVertex(Vertex v) | DrawHelpers
ImmVertex(Vector4 pos) | DrawHelpers
ImmVertex(Vector2 pos) | DrawHelpers
SetColor(Vector4 value) | DrawHelpers
ShaderPop() | DrawHelpers
ShaderPush() | DrawHelpers


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • DrawHelpers
  • ArrowParams

DrawHelpers.ArrowParams メンバ一覧

これは全メンバの一覧です。DrawHelpers.ArrowParams継承メンバも含んでいます。
ArrowParams(float r=1.0f) | DrawHelpers.ArrowParams
BodyRadius | DrawHelpers.ArrowParams
HalfMask | DrawHelpers.ArrowParams
HeadLen | DrawHelpers.ArrowParams
HeadRadius | DrawHelpers.ArrowParams
Offset | DrawHelpers.ArrowParams
Scale | DrawHelpers.ArrowParams


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • EmbeddedDebugFontData

EmbeddedDebugFontData メンバ一覧

これは全メンバの一覧です。EmbeddedDebugFontData継承メンバも含んでいます。
CharSizef | EmbeddedDebugFontData | [static]
CharSizei | EmbeddedDebugFontData | [static]
CreateTexture() | EmbeddedDebugFontData | [static]
NumChars | EmbeddedDebugFontData | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • FontMap

FontMap メンバ一覧

これは全メンバの一覧です。FontMap継承メンバも含んでいます。
AsciiCharSet | FontMap | [static]
CharPixelHeight | FontMap |
CharSet | FontMap |
Dispose() | FontMap |
Disposed | FontMap |
FontMap(Font font, int fontmap_width=512) | FontMap |
FontMap(Font font, string charset, int fontmap_width=512) | FontMap |
Initialize(Font font, string charset, int fontmap_width=512) | FontMap |
Texture | FontMap |
TryGetCharData(char c, out CharData cdata) | FontMap |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Frustum

Frustum メンバ一覧

これは全メンバの一覧です。Frustum継承メンバも含んでいます。
Aspect | Frustum
FovX | Frustum
FovY | Frustum
Frustum() | Frustum
GetPoint(Vector2 screen_normalized_pos, float z) | Frustum
Matrix | Frustum
Zfar | Frustum
Znear | Frustum


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • GraphicsContextAlpha

GraphicsContextAlpha メンバ一覧

これは全メンバの一覧です。GraphicsContextAlpha継承メンバも含んでいます。
Context | GraphicsContextAlpha |
CreateTextureFromFont(string text, Font font, uint color=0xffffffff) | GraphicsContextAlpha | [static]
CreateTextureUnicolor(uint color) | GraphicsContextAlpha | [static]
DebugStats | GraphicsContextAlpha |
Dispose() | GraphicsContextAlpha |
Disposed | GraphicsContextAlpha |
GetAspect() | GraphicsContextAlpha |
GetMVP() | GraphicsContextAlpha |
GetViewportf() | GraphicsContextAlpha |
GraphicsContextAlpha(Sce.PlayStation.Core.Graphics.GraphicsContext context=null) | GraphicsContextAlpha |
ModelMatrix | GraphicsContextAlpha |
ProjectionMatrix | GraphicsContextAlpha |
SetBlendMode(BlendMode mode) | GraphicsContextAlpha |
SetDepthMask(bool write) | GraphicsContextAlpha |
ViewMatrix | GraphicsContextAlpha |
WhiteTextureInfo | GraphicsContextAlpha |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • GraphicsContextAlpha
  • DebugStats_

GraphicsContextAlpha.DebugStats_ メンバ一覧

これは全メンバの一覧です。GraphicsContextAlpha.DebugStats_継承メンバも含んでいます。
DrawArraysCount GraphicsContextAlpha.DebugStats_


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • ImmediateMode

ImmediateMode< T > メンバ一覧

これは全メンバの一覧です。ImmediateMode< T >継承メンバも含んでいます。
Dispose() | ImmediateMode< T >
Disposed | ImmediateMode< T >
ImmActive | ImmediateMode< T >
ImmBegin(DrawMode mode, uint max_vertices_intended) | ImmediateMode< T >
ImmediateMode(GraphicsContextAlpha gl, uint max_vertices, ushort[] indices, int vertices_per_primitive, int indices_per_primitive, params VertexFormat[] formats) | ImmediateMode< T >
ImmEnd() | ImmediateMode< T >
ImmEndIndexing() | ImmediateMode< T >
ImmVertex(T vertex) | ImmediateMode< T >
MaxVertices | ImmediateMode< T >


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • ImmediateModeQuads

ImmediateModeQuads< T > メンバ一覧

これは全メンバの一覧です。ImmediateModeQuads< T >継承メンバも含んでいます。
Dispose() | ImmediateModeQuads< T >
Disposed | ImmediateModeQuads< T >
ImmAddQuad(T v0, T v1, T v2, T v3) | ImmediateModeQuads< T >
ImmAddQuad(T[] v) | ImmediateModeQuads< T >
ImmBeginQuads(uint num_quads) | ImmediateModeQuads< T >
ImmediateModeQuads(GraphicsContextAlpha gl, uint max_quads, params VertexFormat[] formats) | ImmediateModeQuads< T >
ImmEndQuads() | ImmediateModeQuads< T >
MaxQuads | ImmediateModeQuads< T >


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Input2

Input2 メンバ一覧

これは全メンバの一覧です。Input2継承メンバも含んでいます。
GamePad0 | Input2 | [static]
Touch00 | Input2 | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Input2
  • GamePad

Input2.GamePad メンバ一覧

これは全メンバの一覧です。Input2.GamePad継承メンバも含んでいます。
GetData(uint deviceIndex=0) Input2.GamePad [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Input2
  • GamePadData

Input2.GamePadData メンバ一覧

これは全メンバの一覧です。Input2.GamePadData継承メンバも含んでいます。
AnalogLeft | Input2.GamePadData
AnalogRight | Input2.GamePadData
Circle | Input2.GamePadData
Cross | Input2.GamePadData
Down | Input2.GamePadData
Dpad | Input2.GamePadData
L | Input2.GamePadData
Left | Input2.GamePadData
R | Input2.GamePadData
Right | Input2.GamePadData
Select | Input2.GamePadData
SetData(Sce.PlayStation.Core.Input.GamePadData data) | Input2.GamePadData
Square | Input2.GamePadData
Start | Input2.GamePadData
Triangle | Input2.GamePadData
Up | Input2.GamePadData


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Input2
  • Touch

Input2.Touch メンバ一覧

これは全メンバの一覧です。Input2.Touch継承メンバも含んでいます。
GetData(uint deviceIndex=0) | Input2.Touch | [static]
MaxTouch | Input2.Touch | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Input2
  • TouchData

Input2.TouchData メンバ一覧

これは全メンバの一覧です。Input2.TouchData継承メンバも含んでいます。
Down | Input2.TouchData
On | Input2.TouchData
Pos | Input2.TouchData
Press | Input2.TouchData
Release | Input2.TouchData


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Math

Math メンバ一覧

これは全メンバの一覧です。Math継承メンバも含んでいます。
_00 | Math | [static]
_000 | Math | [static]
_0000 | Math | [static]
_0001 | Math | [static]
_000i | Math | [static]
_001 | Math | [static]
_0010 | Math | [static]
_0011 | Math | [static]
_001i | Math | [static]
_00i | Math | [static]
_01 | Math | [static]
_010 | Math | [static]
_0100 | Math | [static]
_0101 | Math | [static]
_010i | Math | [static]
_011 | Math | [static]
_0110 | Math | [static]
_0111 | Math | [static]
_011i | Math | [static]
_01i | Math | [static]
_10 | Math | [static]
_100 | Math | [static]
_1000 | Math | [static]
_1001 | Math | [static]
_100i | Math | [static]
_101 | Math | [static]
_1010 | Math | [static]
_1011 | Math | [static]
_101i | Math | [static]
_10i | Math | [static]
_11 | Math | [static]
_110 | Math | [static]
_1100 | Math | [static]
_1101 | Math | [static]
_110i | Math | [static]
_111 | Math | [static]
_1110 | Math | [static]
_1111 | Math | [static]
_111i | Math | [static]
_11i | Math | [static]
Angle(Vector2 value) | Math | [static]
BackEaseIn(float x, float a) | Math | [static]
BackEaseInOut(float x, float p) | Math | [static]
BackEaseOut(float x, float a) | Math | [static]
ClosestSegmentPoint(Vector2 P, Vector2 A, Vector2 B) | Math | [static]
Deg2Rad(float value) | Math | [static]
Deg2Rad(Vector2 value) | Math | [static]
Det(Vector2 value1, Vector2 value2) | Math | [static]
ExpEaseIn(float x, float a) | Math | [static]
ExpEaseOut(float x, float a) | Math | [static]
GreatestOrEqualPowerOf2(int i) | Math | [static]
HalfPi | Math | [static]
Impulse(float x, float b) | Math | [static]
IsPowerOf2(int i) | Math | [static]
Lerp(float a, float b, float x) | Math | [static]
Lerp(Vector2 a, Vector2 b, float x) | Math | [static]
Lerp(Vector3 a, Vector3 b, float x) | Math | [static]
Lerp(Vector4 a, Vector4 b, float x) | Math | [static]
LerpAngles(float a, float b, float x) | Math | [static]
LerpUnitVectors(Vector2 va, Vector2 vb, float x) | Math | [static]
Linear(float x) | Math | [static]
Log2(int v) | Math | [static]
LookAt(Vector3 eye, Vector3 center, Vector3 _Up) | Math | [static]
Perp(Vector2 value) | Math | [static]
Pi | Math | [static]
PowEaseIn(float x, float p) | Math | [static]
PowEaseInOut(float x, float p) | Math | [static]
PowEaseOut(float x, float p) | Math | [static]
PowerfulScurve(float x, float p1, float p2) | Math | [static]
Rad2Deg(float value) | Math | [static]
Rad2Deg(Vector2 value) | Math | [static]
Rotate(Vector2 point, float angle, Vector2 pivot) | Math | [static]
SafeAcos(float x) | Math | [static]
SetAlpha(Vector4 value, float w) | Math | [static]
ShockWave(float d, float time, float wave_half_width, float wave_speed, float wave_fade, float d_scale) | Math | [static]
Sign(float x) | Math | [static]
Sin(uint period, float phase, uint mstime) | Math | [static]
Sin(ulong period, float phase, ulong mstime) | Math | [static]
TranslationRotationScale(ref Matrix3 ret, Vector2 translation, Vector2 rotation, Vector2 scale) | Math | [static]
TwicePi | Math | [static]
UV_TransformFlipV | Math | [static]
UV_TransformIdentity | Math | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Math
  • RandGenerator

Math.RandGenerator メンバ一覧

これは全メンバの一覧です。Math.RandGenerator継承メンバも含んでいます。
NextFloat(float mi, float ma) | Math.RandGenerator
NextFloat0_1() | Math.RandGenerator
NextFloatMinus1_1() | Math.RandGenerator
NextVector2(Vector2 mi, Vector2 ma) | Math.RandGenerator
NextVector2(float mi, float ma) | Math.RandGenerator
NextVector2Minus1_1() | Math.RandGenerator
NextVector3(Vector3 mi, Vector3 ma) | Math.RandGenerator
NextVector4(Vector4 mi, Vector4 ma) | Math.RandGenerator
NextVector4(float mi, float ma) | Math.RandGenerator
RandGenerator(int seed=0) | Math.RandGenerator
Random | Math.RandGenerator


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • MatrixStack

MatrixStack メンバ一覧

これは全メンバの一覧です。MatrixStack継承メンバも含んでいます。
Capacity | MatrixStack
Get() | MatrixStack
GetInverse() | MatrixStack
MatrixStack(uint capacity) | MatrixStack
Mul(Matrix4 mat) | MatrixStack
Mul1(Matrix4 mat) | MatrixStack
Pop() | MatrixStack
Push() | MatrixStack
Rotate(Vector3 axis, float angle) | MatrixStack
RotateX(float angle) | MatrixStack
RotateY(float angle) | MatrixStack
RotateZ(float angle) | MatrixStack
Scale(Vector3 value) | MatrixStack
Set(Matrix4 mat) | MatrixStack
Set1(Matrix4 mat) | MatrixStack
SetIdentity() | MatrixStack
Size | MatrixStack
Tag | MatrixStack
Translate(Vector3 value) | MatrixStack


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • PitchRoll

PitchRoll メンバ一覧

これは全メンバの一覧です。PitchRoll継承メンバも含んでいます。
Data | PitchRoll |
FromVector(Vector3 v) | PitchRoll | [static]
PitchRoll() | PitchRoll |
PitchRoll(Vector2 v) | PitchRoll |
PitchRoll(Vector3 v) | PitchRoll |
ToMatrix() | PitchRoll |
ToVector(Vector2 a) | PitchRoll | [static]
ToVector() | PitchRoll |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • RollPitch

RollPitch メンバ一覧

これは全メンバの一覧です。RollPitch継承メンバも含んでいます。
Data | RollPitch |
FromVector(Vector3 v) | RollPitch | [static]
RollPitch() | RollPitch |
RollPitch(Vector2 v) | RollPitch |
RollPitch(Vector3 v) | RollPitch |
ToMatrix() | RollPitch |
ToVector(Vector2 a) | RollPitch | [static]
ToVector() | RollPitch |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • SpriteRenderer

SpriteRenderer メンバ一覧

これは全メンバの一覧です。SpriteRenderer継承メンバも含んでいます。
AddSprite(ref TRS quad, Vector2i tile_index) | SpriteRenderer
AddSprite(ref TRS quad, Vector2i tile_index, ref Matrix3 mat) | SpriteRenderer
AddSprite(ref TRS quad, ref TRS uv) | SpriteRenderer
AddSprite(ref TRS quad, ref TRS uv, ref Matrix3 mat) | SpriteRenderer
AddSprite(Vector2 bottom_left_start_pos, Vector2 x, Bounds2 uv_bounds) | SpriteRenderer
AddSprite(Vector4 v0, Vector4 v1, Vector4 v2, Vector4 v3) | SpriteRenderer
BeginSprites(TextureInfo texture_info, ISpriteShader shader, int num_sprites) | SpriteRenderer
BeginSprites(TextureInfo texture_info, int num_sprites) | SpriteRenderer
DefaultFontShader | SpriteRenderer
DefaultShader | SpriteRenderer
Dispose() | SpriteRenderer
Disposed | SpriteRenderer
DrawTextDebug(string str, Vector2 bottom_left_start_pos, float char_height, bool draw=true, ISpriteShader shader=null) | SpriteRenderer
DrawTextWithFontMap(string str, Vector2 bottom_left_start_pos, float char_height, bool draw, FontMap fontmap, ISpriteShader shader) | SpriteRenderer
DrawTextWithFontMap(string str, Vector2 bottom_left_start_pos, float char_height, bool draw, FontMap fontmap) | SpriteRenderer
EndSprites() | SpriteRenderer
FlipU | SpriteRenderer
FlipV | SpriteRenderer
SpriteRenderer(GraphicsContextAlpha gl, uint max_sprites) | SpriteRenderer


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • SpriteRenderer
  • DefaultFontShader_

SpriteRenderer.DefaultFontShader_ メンバ一覧

これは全メンバの一覧です。SpriteRenderer.DefaultFontShader_継承メンバも含んでいます。
Dispose() | SpriteRenderer.DefaultFontShader_
GetShaderProgram() | SpriteRenderer.DefaultFontShader_
SetColor(ref Vector4 value) | SpriteRenderer.DefaultFontShader_
SetMVP(ref Matrix4 value) | SpriteRenderer.DefaultFontShader_
SetUVTransform(ref Vector4 value) | SpriteRenderer.DefaultFontShader_


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • SpriteRenderer
  • DefaultShader_

SpriteRenderer.DefaultShader_ メンバ一覧

これは全メンバの一覧です。SpriteRenderer.DefaultShader_継承メンバも含んでいます。
Dispose() | SpriteRenderer.DefaultShader_
GetShaderProgram() | SpriteRenderer.DefaultShader_
SetColor(ref Vector4 value) | SpriteRenderer.DefaultShader_
SetMVP(ref Matrix4 value) | SpriteRenderer.DefaultShader_
SetUVTransform(ref Vector4 value) | SpriteRenderer.DefaultShader_


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • TextureInfo

TextureInfo メンバ一覧

これは全メンバの一覧です。TextureInfo継承メンバも含んでいます。
Dispose() | TextureInfo
Disposed | TextureInfo
GetCachedTiledData(ref Vector2i tile_index) | TextureInfo
Initialize(Texture2D texture, Vector2i num_tiles, TRS source_area) | TextureInfo
NumTiles | TextureInfo
Texture | TextureInfo
TextureInfo() | TextureInfo
TextureInfo(string filename) | TextureInfo
TextureInfo(Texture2D texture) | TextureInfo
TextureInfo(Texture2D texture, Vector2i num_tiles) | TextureInfo
TextureInfo(Texture2D texture, Vector2i num_tiles, TRS source_area) | TextureInfo
TextureSizef | TextureInfo
TextureSizei | TextureInfo
TileSizeInPixelsf | TextureInfo
TileSizeInUV | TextureInfo


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • TextureInfo
  • CachedTileData

TextureInfo.CachedTileData メンバ一覧

これは全メンバの一覧です。TextureInfo.CachedTileData継承メンバも含んでいます。
UV_00 | TextureInfo.CachedTileData
UV_01 | TextureInfo.CachedTileData
UV_10 | TextureInfo.CachedTileData
UV_11 | TextureInfo.CachedTileData


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Timer

Timer メンバ一覧

これは全メンバの一覧です。Timer継承メンバも含んでいます。
Milliseconds() | Timer
Reset() | Timer
Seconds() | Timer
Timer() | Timer


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • TRS
  • Local

TRS.Local メンバ一覧

これは全メンバの一覧です。TRS.Local継承メンバも含んでいます。
BottomCenter | TRS.Local | [static]
BottomLeft | TRS.Local | [static]
BottomRight | TRS.Local | [static]
Center | TRS.Local | [static]
MiddleLeft | TRS.Local | [static]
MiddleRight | TRS.Local | [static]
TopCenter | TRS.Local | [static]
TopLeft | TRS.Local | [static]
TopRight | TRS.Local | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • CallFunc

CallFunc メンバ一覧

これは全メンバの一覧です。CallFunc継承メンバも含んでいます。
CallFunc(System.Action func) | CallFunc |
Func | CallFunc |
IsRunning | ActionBase |
Run() | ActionBase | [virtual]
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
Update(float dt) | CallFunc | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • DebugFlags

DebugFlags メンバ一覧

これは全メンバの一覧です。DebugFlags継承メンバも含んでいます。
DrawContentLocalBounds | DebugFlags | [static]
DrawContentWorldBounds | DebugFlags | [static]
DrawGrid | DebugFlags | [static]
DrawPivot | DebugFlags | [static]
DrawTransform | DebugFlags | [static]
Navigate | DebugFlags | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • DelayTime

DelayTime メンバ一覧

これは全メンバの一覧です。DelayTime継承メンバも含んでいます。
DelayTime() | DelayTime |
DelayTime(float duration) | DelayTime |
Duration | ActionWithDuration |
IsRunning | ActionBase |
Run() | DelayTime | [virtual]
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
Update(float dt) | DelayTime | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Director

Director メンバ一覧

これは全メンバの一覧です。Director継承メンバも含んでいます。
CurrentScene | Director |
DebugFlags | Director |
DirectorTime | Director |
Dispose() | Director |
DrawHelpers | Director |
Dump() | Director |
GL | Director |
Initialize(uint sprites_capacity=500, uint draw_helpers_capacity=400, Sce.PlayStation.Core.Graphics.GraphicsContext context=null) | Director | [static]
Instance | Director | [static]
Pause() | Director |
PopScene() | Director |
PostSwap() | Director |
PushScene(Scene new_scene) | Director |
Render() | Director |
ReplaceScene(Scene new_scene) | Director |
Resume() | Director |
RunWithScene(Scene scene, bool manual_loop=false) | Director |
SpriteRenderer | Director |
Terminate() | Director | [static]
Update() | Director |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Label

Label メンバ一覧

これは全メンバの一覧です。Label継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
BlendMode | Label |
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
CharWorldHeight | Label |
Children | Node |
Cleanup() | Node | [virtual]
Color | Label |
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | Label | [virtual]
DrawHierarchy() | Node | [virtual]
DVisitor(Node node, int depth) | Node |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
FontMap | Label |
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | Label | [virtual]
GetlContentLocalBounds() | Label |
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
HeightScale | Label |
IsRunning | Node |
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
Label() | Label |
Label(string text, FontMap fontmap=null) | Label |
LocalToWorld(Vector2 local_point) | Node |
Name | Node |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | Node | [virtual]
OnExit() | Node | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PushTransform() | Node | [virtual]
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Shader | Label |
Skew | Node |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
Text | Label |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • MoveBy

MoveBy メンバ一覧

これは全メンバの一覧です。MoveBy継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
MoveBy(Vector2 target, float duration) | MoveBy |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • MoveTo

MoveTo メンバ一覧

これは全メンバの一覧です。MoveTo継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
MoveTo(Vector2 target, float duration) | MoveTo |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Node

Node メンバ一覧

これは全メンバの一覧です。Node継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
Children | Node |
Cleanup() | Node | [virtual]
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | Node | [virtual]
DrawHierarchy() | Node | [virtual]
DVisitor(Node node, int depth) | Node |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | Node | [virtual]
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
LocalToWorld(Vector2 local_point) | Node |
Name | Node |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | Node | [virtual]
OnExit() | Node | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PushTransform() | Node | [virtual]
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Skew | Node |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Particles

Particles メンバ一覧

これは全メンバの一覧です。Particles継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
Children | Node |
Cleanup() | Node | [virtual]
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
Dispose() | Particles |
DOnExitEvent() | Node |
Draw() | Particles | [virtual]
DrawHierarchy() | Node | [virtual]
DVisitor(Node node, int depth) | Node |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | Node | [virtual]
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
LocalToWorld(Vector2 local_point) | Node |
Name | Node |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | Node | [virtual]
OnExit() | Node | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
Particles(int max_particles) | Particles |
ParticleSystem | Particles |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PushTransform() | Node | [virtual]
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Skew | Node |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Particles | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ParticleSystem

ParticleSystem メンバ一覧

これは全メンバの一覧です。ParticleSystem継承メンバも含んでいます。
BlendMode | ParticleSystem |
Color | ParticleSystem |
CreateParticle(bool skip_auto_init=false) | ParticleSystem |
DefaultShader | ParticleSystem | [static]
Dispose() | ParticleSystem |
Disposed | ParticleSystem |
Draw() | ParticleSystem |
Emit | ParticleSystem |
IsFull | ParticleSystem |
MaxParticles | ParticleSystem |
ParticlesCount | ParticleSystem |
ParticleSystem(int max_particles) | ParticleSystem |
RenderTransform | ParticleSystem |
Shader | ParticleSystem |
Simulation | ParticleSystem |
Terminate() | ParticleSystem | [static]
TextureInfo | ParticleSystem |
Update(float dt) | ParticleSystem |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ParticleSystem
  • EmitterParams

ParticleSystem.EmitterParams メンバ一覧

これは全メンバの一覧です。ParticleSystem.EmitterParams継承メンバも含んでいます。
Angle | ParticleSystem.EmitterParams
AngleVar | ParticleSystem.EmitterParams
AngularMomentun | ParticleSystem.EmitterParams
AngularVelocity | ParticleSystem.EmitterParams
AngularVelocityVar | ParticleSystem.EmitterParams
ColorEnd | ParticleSystem.EmitterParams
ColorEndVar | ParticleSystem.EmitterParams
ColorStart | ParticleSystem.EmitterParams
ColorStartVar | ParticleSystem.EmitterParams
EmitterParams() | ParticleSystem.EmitterParams
ForwardMomentum | ParticleSystem.EmitterParams
LifeSpan | ParticleSystem.EmitterParams
LifeSpanRelVar | ParticleSystem.EmitterParams
Position | ParticleSystem.EmitterParams
PositionVar | ParticleSystem.EmitterParams
ScaleEnd | ParticleSystem.EmitterParams
ScaleEndRelVar | ParticleSystem.EmitterParams
ScaleStart | ParticleSystem.EmitterParams
ScaleStartRelVar | ParticleSystem.EmitterParams
ToString(string prefix) | ParticleSystem.EmitterParams
Transform | ParticleSystem.EmitterParams
TransformForVelocityEstimate | ParticleSystem.EmitterParams
Velocity | ParticleSystem.EmitterParams
VelocityVar | ParticleSystem.EmitterParams
WaitTime | ParticleSystem.EmitterParams
WaitTimeRelVar | ParticleSystem.EmitterParams


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ParticleSystem
  • Particle

ParticleSystem.Particle メンバ一覧

これは全メンバの一覧です。ParticleSystem.Particle継承メンバも含んでいます。
Age | ParticleSystem.Particle
Angle | ParticleSystem.Particle
AngularVelocity | ParticleSystem.Particle
Color | ParticleSystem.Particle
ColorDelta | ParticleSystem.Particle
ColorStart | ParticleSystem.Particle
Dead | ParticleSystem.Particle
LifeSpan | ParticleSystem.Particle
LifeSpanRcp | ParticleSystem.Particle
Position | ParticleSystem.Particle
Scale | ParticleSystem.Particle
ScaleDelta | ParticleSystem.Particle
ScaleStart | ParticleSystem.Particle
ToString() | ParticleSystem.Particle
Velocity | ParticleSystem.Particle


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ParticleSystem
  • ParticleShaderDefault

ParticleSystem.ParticleShaderDefault メンバ一覧

これは全メンバの一覧です。ParticleSystem.ParticleShaderDefault継承メンバも含んでいます。
Dispose() | ParticleSystem.ParticleShaderDefault
GetShaderProgram() | ParticleSystem.ParticleShaderDefault
SetColor(ref Vector4 value) | ParticleSystem.ParticleShaderDefault
SetMVP(ref Matrix4 value) | ParticleSystem.ParticleShaderDefault


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ParticleSystem
  • SimulationParams

ParticleSystem.SimulationParams メンバ一覧

これは全メンバの一覧です。ParticleSystem.SimulationParams継承メンバも含んでいます。
BrownianScale | ParticleSystem.SimulationParams
Fade | ParticleSystem.SimulationParams
Friction | ParticleSystem.SimulationParams
Gravity | ParticleSystem.SimulationParams
GravityDirection | ParticleSystem.SimulationParams
Wind | ParticleSystem.SimulationParams
WindDirection | ParticleSystem.SimulationParams


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Plane3D

Plane3D メンバ一覧

これは全メンバの一覧です。Plane3D継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
Children | Node |
Cleanup() | Node | [virtual]
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | Node | [virtual]
DrawHierarchy() | Node | [virtual]
DVisitor(Node node, int depth) | Node |
FindParentPlane(ref Matrix4 mat) | Plane3D | [virtual]
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | Node | [virtual]
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
LocalToWorld(Vector2 local_point) | Node |
ModelMatrix | Plane3D |
Name | Node |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | Node | [virtual]
OnExit() | Node | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
Plane3D() | Plane3D |
Plane3D(Matrix4 modelmatrix) | Plane3D |
PopTransform() | Node | [virtual]
Position | Node |
PushTransform() | Plane3D | [virtual]
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Skew | Node |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • RawSpriteTileList

RawSpriteTileList メンバ一覧

これは全メンバの一覧です。RawSpriteTileList継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
BlendMode | RawSpriteTileList |
CalcSizeInPixels() | RawSpriteTileList |
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
Children | Node |
Cleanup() | Node | [virtual]
Color | RawSpriteTileList |
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | RawSpriteTileList | [virtual]
DrawHierarchy() | Node | [virtual]
DVisitor(Node node, int depth) | Node |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | Node | [virtual]
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
LocalToWorld(Vector2 local_point) | Node |
Name | Node |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | Node | [virtual]
OnExit() | Node | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PushTransform() | Node | [virtual]
RawSpriteTileList(TextureInfo texture_info) | RawSpriteTileList |
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Shader | RawSpriteTileList |
Skew | Node |
Sprites | RawSpriteTileList |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
TextureInfo | RawSpriteTileList |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Repeat

Repeat メンバ一覧

これは全メンバの一覧です。Repeat継承メンバも含んでいます。
InnerAction | Repeat |
IsRunning | ActionBase |
Repeat(ActionBase inner_action, int times) | Repeat |
Run() | Repeat | [virtual]
Stop() | Repeat | [virtual]
Tag | ActionBase |
Target | ActionBase |
Times | Repeat |
Update(float dt) | Repeat | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • RepeatForever

RepeatForever メンバ一覧

これは全メンバの一覧です。RepeatForever継承メンバも含んでいます。
InnerAction | RepeatForever |
IsRunning | ActionBase |
Run() | RepeatForever | [virtual]
Stop() | RepeatForever | [virtual]
Tag | ActionBase |
Target | ActionBase |
Update(float dt) | RepeatForever | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • RotateBy

RotateBy メンバ一覧

これは全メンバの一覧です。RotateBy継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
RotateBy(Vector2 target, float duration) | RotateBy |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • RotateTo

RotateTo メンバ一覧

これは全メンバの一覧です。RotateTo継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
RotateTo(Vector2 target, float duration) | RotateTo |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ScaleBy

ScaleBy メンバ一覧

これは全メンバの一覧です。ScaleBy継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
Run() | ActionTweenGeneric< T > | [virtual]
ScaleBy(Vector2 target, float duration) | ScaleBy |
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ScaleTo

ScaleTo メンバ一覧

これは全メンバの一覧です。ScaleTo継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
Run() | ActionTweenGeneric< T > | [virtual]
ScaleTo(Vector2 target, float duration) | ScaleTo |
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Scene

Scene メンバ一覧

これは全メンバの一覧です。Scene継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
Children | Node |
Cleanup() | Node | [virtual]
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | Node | [virtual]
DrawGridAutoStepMaxCells | Scene |
DrawGridStep | Scene |
DrawHierarchy() | Node | [virtual]
DVisitor(Node node, int depth) | Node |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | Node | [virtual]
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsTransitionScene() | Scene | [virtual]
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
LocalToWorld(Vector2 local_point) | Node |
Name | Node |
NoClear | Scene |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | Scene | [virtual]
OnExit() | Scene | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PushTransform() | Node | [virtual]
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Scene() | Scene |
SceneTime | Scene |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Skew | Node |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Scheduler

Scheduler メンバ一覧

これは全メンバの一覧です。Scheduler継承メンバも含んでいます。
Dump() | Scheduler |
Instance | Scheduler | [static]
Schedule(Node target, DSchedulerFunc func, float interval, bool paused, int priority=DefaultPriority) | Scheduler |
ScheduleUpdateForTarget(Node target, int priority, bool paused) | Scheduler |
Unschedule(Node target, DSchedulerFunc func) | Scheduler |
UnscheduleAll(Node target) | Scheduler |
UnscheduleAll() | Scheduler |
UnscheduleUpdateForTarget(Node target) | Scheduler |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Sequence

Sequence メンバ一覧

これは全メンバの一覧です。Sequence継承メンバも含んでいます。
Add(ActionBase action) | Sequence |
IsRunning | ActionBase |
Run() | Sequence | [virtual]
Sequence() | Sequence |
Stop() | Sequence | [virtual]
Tag | ActionBase |
Target | ActionBase |
Update(float dt) | Sequence | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • SkewBy

SkewBy メンバ一覧

これは全メンバの一覧です。SkewBy継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
SkewBy(Vector2 target, float duration) | SkewBy |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • SkewTo

SkewTo メンバ一覧

これは全メンバの一覧です。SkewTo継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
SkewTo(Vector2 target, float duration) | SkewTo |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • SpriteBase

SpriteBase メンバ一覧

これは全メンバの一覧です。SpriteBase継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
BlendMode | SpriteBase |
CalcSizeInPixels() | SpriteBase | [pure virtual]
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
CenterSprite() | SpriteBase |
CenterSprite(Vector2 new_center) | SpriteBase |
Children | Node |
Cleanup() | Node | [virtual]
Color | SpriteBase |
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | SpriteBase | [virtual]
DrawHierarchy() | Node | [virtual]
DVisitor(Node node, int depth) | Node |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
FlipU | SpriteBase |
FlipV | SpriteBase |
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | SpriteBase | [virtual]
GetlContentLocalBounds() | SpriteBase |
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
LocalToWorld(Vector2 local_point) | Node |
MakeFullScreen() | SpriteBase |
Name | Node |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | Node | [virtual]
OnExit() | Node | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PushTransform() | Node | [virtual]
Quad | SpriteBase |
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Shader | SpriteBase |
Skew | Node |
SpriteBase() | SpriteBase |
SpriteBase(TextureInfo texture_info) | SpriteBase |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
TextureInfo | SpriteBase |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • SpriteList

SpriteList メンバ一覧

これは全メンバの一覧です。SpriteList継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
BlendMode | SpriteList |
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
Children | Node |
Cleanup() | Node | [virtual]
Color | SpriteList |
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | Node | [virtual]
DrawHierarchy() | SpriteList | [virtual]
DVisitor(Node node, int depth) | Node |
EnableLocalTransform | SpriteList |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | Node | [virtual]
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
LocalToWorld(Vector2 local_point) | Node |
Name | Node |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | Node | [virtual]
OnExit() | Node | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PushTransform() | Node | [virtual]
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Shader | SpriteList |
Skew | Node |
SpriteList(TextureInfo texture_info) | SpriteList |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
TextureInfo | SpriteList |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • SpriteTile

SpriteTile メンバ一覧

これは全メンバの一覧です。SpriteTile継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
BlendMode | SpriteBase |
CalcSizeInPixels() | SpriteTile | [virtual]
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
CenterSprite() | SpriteBase |
CenterSprite(Vector2 new_center) | SpriteBase |
Children | Node |
Cleanup() | Node | [virtual]
Color | SpriteBase |
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | SpriteBase | [virtual]
DrawHierarchy() | Node | [virtual]
DVisitor(Node node, int depth) | Node |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
FlipU | SpriteBase |
FlipV | SpriteBase |
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | SpriteBase | [virtual]
GetlContentLocalBounds() | SpriteBase |
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
LocalToWorld(Vector2 local_point) | Node |
MakeFullScreen() | SpriteBase |
Name | Node |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | Node | [virtual]
OnExit() | Node | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PushTransform() | Node | [virtual]
Quad | SpriteBase |
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Shader | SpriteBase |
Skew | Node |
SpriteBase() | SpriteBase |
SpriteBase(TextureInfo texture_info) | SpriteBase |
SpriteTile() | SpriteTile |
SpriteTile(TextureInfo texture_info) | SpriteTile |
SpriteTile(TextureInfo texture_info, Vector2i index) | SpriteTile |
SpriteTile(TextureInfo texture_info, int index) | SpriteTile |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
TextureInfo | SpriteBase |
TileIndex1D | SpriteTile |
TileIndex2D | SpriteTile |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • SpriteUV

SpriteUV メンバ一覧

これは全メンバの一覧です。SpriteUV継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
BlendMode | SpriteBase |
CalcSizeInPixels() | SpriteUV | [virtual]
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
CenterSprite() | SpriteBase |
CenterSprite(Vector2 new_center) | SpriteBase |
Children | Node |
Cleanup() | Node | [virtual]
Color | SpriteBase |
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | SpriteBase | [virtual]
DrawHierarchy() | Node | [virtual]
DVisitor(Node node, int depth) | Node |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
FlipU | SpriteBase |
FlipV | SpriteBase |
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | SpriteBase | [virtual]
GetlContentLocalBounds() | SpriteBase |
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
LocalToWorld(Vector2 local_point) | Node |
MakeFullScreen() | SpriteBase |
Name | Node |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | Node | [virtual]
OnExit() | Node | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PushTransform() | Node | [virtual]
Quad | SpriteBase |
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Shader | SpriteBase |
Skew | Node |
SpriteBase() | SpriteBase |
SpriteBase(TextureInfo texture_info) | SpriteBase |
SpriteUV() | SpriteUV |
SpriteUV(TextureInfo texture_info) | SpriteUV |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
TextureInfo | SpriteBase |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
UV | SpriteUV |
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • TintBy

TintBy メンバ一覧

これは全メンバの一覧です。TintBy継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
TintBy(Vector4 target, float duration) | TintBy |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • TintTo

TintTo メンバ一覧

これは全メンバの一覧です。TintTo継承メンバも含んでいます。
ActionTweenGeneric() | ActionTweenGeneric< T > |
ActionTweenGeneric(DGet dget, DSet dset) | ActionTweenGeneric< T > |
DGet() | ActionTweenGeneric< T > |
DSet(T value) | ActionTweenGeneric< T > |
Duration | ActionWithDuration |
Get | ActionTweenGeneric< T > |
IsRelative | ActionTweenGeneric< T > |
IsRunning | ActionBase |
Run() | ActionTweenGeneric< T > | [virtual]
Set | ActionTweenGeneric< T > |
Stop() | ActionBase | [virtual]
Tag | ActionBase |
Target | ActionBase |
TargetValue | ActionTweenGeneric< T > |
TintTo(Vector4 target, float duration) | TintTo |
Tween | ActionTweenGeneric< T > |
Update(float dt) | ActionTweenGeneric< T > | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • TransitionCrossFade

TransitionCrossFade メンバ一覧

これは全メンバの一覧です。TransitionCrossFade継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
Children | Node |
Cleanup() | Node | [virtual]
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | TransitionCrossFade | [virtual]
DrawGridAutoStepMaxCells | Scene |
DrawGridStep | Scene |
DrawHierarchy() | Node | [virtual]
Duration | TransitionScene |
DVisitor(Node node, int depth) | Node |
FadeCompletion | TransitionScene |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | Node | [virtual]
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsTransitionScene() | TransitionScene | [virtual]
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
KeepRendering | TransitionScene |
LocalToWorld(Vector2 local_point) | Node |
Name | Node |
NextScene | TransitionScene |
NoClear | Scene |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | TransitionFadeBase | [virtual]
OnExit() | Scene | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PreviousScene | TransitionScene |
PushTransform() | Node | [virtual]
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Scene() | Scene |
SceneTime | Scene |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Skew | Node |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
Terminate() | TransitionFadeBase | [static]
TransitionCrossFade(Scene next_scene) | TransitionCrossFade |
TransitionFadeBase(Scene next_scene) | TransitionFadeBase |
TransitionScene(Scene next_scene) | TransitionScene |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Tween | TransitionCrossFade |
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • TransitionDirectionalFade

TransitionDirectionalFade メンバ一覧

これは全メンバの一覧です。TransitionDirectionalFade継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
Children | Node |
Cleanup() | Node | [virtual]
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
Direction | TransitionDirectionalFade |
DOnExitEvent() | Node |
Draw() | TransitionDirectionalFade | [virtual]
DrawGridAutoStepMaxCells | Scene |
DrawGridStep | Scene |
DrawHierarchy() | Node | [virtual]
Duration | TransitionScene |
DVisitor(Node node, int depth) | Node |
FadeCompletion | TransitionScene |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | Node | [virtual]
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsTransitionScene() | TransitionScene | [virtual]
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
KeepRendering | TransitionScene |
LocalToWorld(Vector2 local_point) | Node |
Name | Node |
NextScene | TransitionScene |
NoClear | Scene |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | TransitionFadeBase | [virtual]
OnExit() | Scene | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PreviousScene | TransitionScene |
PushTransform() | Node | [virtual]
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Scene() | Scene |
SceneTime | Scene |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Skew | Node |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
Terminate() | TransitionDirectionalFade | [static]
TransitionDirectionalFade(Scene next_scene) | TransitionDirectionalFade |
TransitionFadeBase(Scene next_scene) | TransitionFadeBase |
TransitionScene(Scene next_scene) | TransitionScene |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Tween | TransitionDirectionalFade |
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
Width | TransitionDirectionalFade |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • TransitionFadeBase

TransitionFadeBase メンバ一覧

これは全メンバの一覧です。TransitionFadeBase継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
Children | Node |
Cleanup() | Node | [virtual]
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | TransitionFadeBase | [virtual]
DrawGridAutoStepMaxCells | Scene |
DrawGridStep | Scene |
DrawHierarchy() | Node | [virtual]
Duration | TransitionScene |
DVisitor(Node node, int depth) | Node |
FadeCompletion | TransitionScene |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | Node | [virtual]
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsTransitionScene() | TransitionScene | [virtual]
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
KeepRendering | TransitionScene |
LocalToWorld(Vector2 local_point) | Node |
Name | Node |
NextScene | TransitionScene |
NoClear | Scene |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | TransitionFadeBase | [virtual]
OnExit() | Scene | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PreviousScene | TransitionScene |
PushTransform() | Node | [virtual]
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Scene() | Scene |
SceneTime | Scene |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Skew | Node |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
Terminate() | TransitionFadeBase | [static]
TransitionFadeBase(Scene next_scene) | TransitionFadeBase |
TransitionScene(Scene next_scene) | TransitionScene |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • TransitionScene

TransitionScene メンバ一覧

これは全メンバの一覧です。TransitionScene継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
Children | Node |
Cleanup() | Node | [virtual]
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | Node | [virtual]
DrawGridAutoStepMaxCells | Scene |
DrawGridStep | Scene |
DrawHierarchy() | Node | [virtual]
Duration | TransitionScene |
DVisitor(Node node, int depth) | Node |
FadeCompletion | TransitionScene |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | Node | [virtual]
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsTransitionScene() | TransitionScene | [virtual]
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
KeepRendering | TransitionScene |
LocalToWorld(Vector2 local_point) | Node |
Name | Node |
NextScene | TransitionScene |
NoClear | Scene |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | TransitionScene | [virtual]
OnExit() | Scene | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PreviousScene | TransitionScene |
PushTransform() | Node | [virtual]
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Scene() | Scene |
SceneTime | Scene |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Skew | Node |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
TransitionScene(Scene next_scene) | TransitionScene |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • TransitionSolidFade

TransitionSolidFade メンバ一覧

これは全メンバの一覧です。TransitionSolidFade継承メンバも含んでいます。
ActionsPaused | Node |
AddChild(Node child, int order) | Node |
AddChild(Node child) | Node |
AdHocDraw | Node |
Angle | Node |
CalcWorldTransformInverse() | Node |
Camera | Node |
Camera2D | Node |
Camera3D | Node |
Children | Node |
Cleanup() | Node | [virtual]
DDraw() | Node |
DebugDrawContentLocalBounds() | Node | [virtual]
DebugDrawTransform() | Node |
DebugDrawTransformScale | Node | [static]
DOnExitEvent() | Node |
Draw() | TransitionSolidFade | [virtual]
DrawGridAutoStepMaxCells | Scene |
DrawGridStep | Scene |
DrawHierarchy() | Node | [virtual]
Duration | TransitionScene |
DVisitor(Node node, int depth) | Node |
FadeCompletion | TransitionScene |
FindParentPlane(ref Matrix4 mat) | Node | [virtual]
GetActionByTag(int tag, int ith=0) | Node |
GetContentWorldBounds(ref Bounds2 bounds) | Node | [virtual]
GetlContentLocalBounds(ref Bounds2 bounds) | Node | [virtual]
GetTouchPos(int nth=0, bool prev=false) | Node |
GetTransform() | Node |
GetTransformInverse() | Node |
GetWorldTransform() | Node |
IsRunning | Node |
IsTransitionScene() | TransitionScene | [virtual]
IsWorldPointInsideContentLocalBounds(Vector2 world_position) | Node |
KeepRendering | TransitionScene |
LocalToWorld(Vector2 local_point) | Node |
Name | Node |
NextScene | TransitionScene |
NoClear | Scene |
Node() | Node |
NumRunningActions() | Node |
OnEnter() | TransitionFadeBase | [virtual]
OnExit() | Scene | [virtual]
OnExitEvents | Node |
Order | Node |
Parent | Node |
PauseSchedulerAndActions() | Node |
Pivot | Node |
PopTransform() | Node | [virtual]
Position | Node |
PreviousScene | TransitionScene |
PushTransform() | Node | [virtual]
RegisterDisposeOnExit(System.IDisposable disposable) | Node |
RegisterDisposeOnExitRecursive() | Node |
RemoveAllChildren(bool do_cleanup) | Node |
RemoveChild(Node child, bool do_cleanup) | Node |
ResumeSchedulerAndActions() | Node |
Rotate(float angle) | Node |
Rotate(Vector2 rotation) | Node |
Rotation | Node |
RotationNormalize | Node |
RunAction(ActionBase action) | Node |
Scale | Node |
Scene() | Scene |
SceneTime | Scene |
Schedule(DSchedulerFunc func, int priority=Scheduler.DefaultPriority) | Node |
ScheduleInterval(DSchedulerFunc func, float interval, int priority=Scheduler.DefaultPriority) | Node |
SchedulerPaused | Node |
ScheduleUpdate(int priority=Scheduler.DefaultPriority) | Node |
Skew | Node |
StopAction(ActionBase action) | Node |
StopActionByTag(int tag) | Node |
StopAllActions() | Node |
Terminate() | TransitionFadeBase | [static]
TransitionFadeBase(Scene next_scene) | TransitionFadeBase |
TransitionScene(Scene next_scene) | TransitionScene |
TransitionSolidFade(Scene next_scene) | TransitionSolidFade |
Traverse(DVisitor visitor, int depth) | Node | [virtual]
Tween | TransitionSolidFade |
Unschedule(DSchedulerFunc func) | Node |
UnscheduleAll() | Node |
UnscheduleUpdate() | Node |
Update(float dt) | Node | [virtual]
VertexZ | Node |
Visible | Node |
WorldToLocal(Vector2 world_point) | Node |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicArrays

BasicArrays メンバ一覧

これは全メンバの一覧です。BasicArrays継承メンバも含んでいます。
BasicArrays() | BasicArrays
VertexBuffer | BasicArrays


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicBone

BasicBone メンバ一覧

これは全メンバの一覧です。BasicBone継承メンバも含んでいます。
BasicBone() | BasicBone
BlendBones | BasicBone
BlendOffsets | BasicBone
BoundingSphere | BasicBone
DrawParts | BasicBone
Name | BasicBone
ParentBone | BasicBone
Pivot | BasicBone
Rotation | BasicBone
Scaling | BasicBone
Translation | BasicBone
Visibility | BasicBone
WorldMatrix | BasicBone


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicFCurve

BasicFCurve メンバ一覧

これは全メンバの一覧です。BasicFCurve継承メンバも含んでいます。
BasicFCurve() | BasicFCurve
ChannelOption | BasicFCurve
ChannelType | BasicFCurve
DimCount | BasicFCurve
InterpType | BasicFCurve
KeyCount | BasicFCurve
KeyFrames | BasicFCurve
TargetIndex | BasicFCurve
TargetType | BasicFCurve


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicLayer

BasicLayer メンバ一覧

これは全メンバの一覧です。BasicLayer継承メンバも含んでいます。
BasicLayer() | BasicLayer
Texture | BasicLayer


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicMaterial

BasicMaterial メンバ一覧

これは全メンバの一覧です。BasicMaterial継承メンバも含んでいます。
Ambient | BasicMaterial
BasicMaterial() | BasicMaterial
Diffuse | BasicMaterial
Emission | BasicMaterial
FileName | BasicMaterial
Layers | BasicMaterial
Name | BasicMaterial
Opacity | BasicMaterial
Program | BasicMaterial
Shininess | BasicMaterial
Specular | BasicMaterial


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicMesh

BasicMesh メンバ一覧

これは全メンバの一覧です。BasicMesh継承メンバも含んでいます。
Arrays | BasicMesh
BasicMesh() | BasicMesh
BlendIndices | BasicMesh
Material | BasicMesh
Primitives | BasicMesh


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicModel

BasicModel メンバ一覧

これは全メンバの一覧です。BasicModel継承メンバも含んでいます。
Animate(float step) | BasicModel
BasicModel(string fileName, int index=0) | BasicModel
BasicModel(byte[] fileImage, int index=0) | BasicModel
BindPrograms(BasicProgramContainer container) | BasicModel
BindTextures(BasicTextureContainer container) | BasicModel
Bones | BasicModel
BoundingSphere | BasicModel
CurrentMotion | BasicModel
Dispose() | BasicModel
Draw(GraphicsContext graphics) | BasicModel
Draw(GraphicsContext graphics, BasicProgram program) | BasicModel
Materials | BasicModel
Motions | BasicModel
Name | BasicModel
Parts | BasicModel
Programs | BasicModel
SetCurrentMotion(int index, float delay=0.0f) | BasicModel
SetWorldMatrix(ref Matrix4 world) | BasicModel
Textures | BasicModel
TransitionDelay | BasicModel
Update() | BasicModel
WorldMatrix | BasicModel


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicMotion

BasicMotion メンバ一覧

これは全メンバの一覧です。BasicMotion継承メンバも含んでいます。
BasicMotion() | BasicMotion
FCurves | BasicMotion
Frame | BasicMotion
FrameEnd | BasicMotion
FrameRate | BasicMotion
FrameRepeat | BasicMotion
FrameStart | BasicMotion
Name | BasicMotion
Weight | BasicMotion


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicParameters

BasicParameters メンバ一覧

これは全メンバの一覧です。BasicParameters継承メンバも含んでいます。
BasicParameters() | BasicParameters
Enable(BasicEnableMode mode, bool status) | BasicParameters
IsEnabled(BasicEnableMode mode) | BasicParameters
SetFogColor(ref Vector3 color) | BasicParameters
SetFogRange(float start, float end) | BasicParameters
SetLightAmbient(ref Vector3 ambient) | BasicParameters
SetLightCount(int count) | BasicParameters
SetLightDiffuse(int index, ref Vector3 diffuse) | BasicParameters
SetLightDirection(int index, ref Vector3 direction) | BasicParameters
SetLightSpecular(int index, ref Vector3 specular) | BasicParameters
SetMaterialAmbient(ref Vector3 ambient) | BasicParameters
SetMaterialDiffuse(ref Vector3 diffuse) | BasicParameters
SetMaterialEmission(ref Vector3 emission) | BasicParameters
SetMaterialOpacity(float opacity) | BasicParameters
SetMaterialShininess(float shininess) | BasicParameters
SetMaterialSpecular(ref Vector3 specular) | BasicParameters
SetPositionOffset(float transX, float transY, float transZ, float scale) | BasicParameters
SetProjectionMatrix(ref Matrix4 projection) | BasicParameters
SetTexCoordOffset(int index, float transU, float transV, float scaleU, float scaleV) | BasicParameters
SetVertexWeightCount(int count) | BasicParameters
SetViewMatrix(ref Matrix4 view) | BasicParameters
SetWorldCount(int count) | BasicParameters
SetWorldMatrix(int index, ref Matrix4 world) | BasicParameters


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicPart

BasicPart メンバ一覧

これは全メンバの一覧です。BasicPart継承メンバも含んでいます。
Arrays | BasicPart
BasicPart() | BasicPart
Meshes | BasicPart
Name | BasicPart


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicProgram

BasicProgram メンバ一覧

これは全メンバの一覧です。BasicProgram継承メンバも含んでいます。
AttributeCount | ShaderProgram |
BasicProgram(BasicParameters parameters=null) | BasicProgram |
BasicProgram(string vpFileName, string fpFileName=null, BasicParameters parameters=null) | BasicProgram |
BasicProgram(BasicProgram program) | BasicProgram | [protected]
Dispose() | BasicProgram |
FindAttribute(string name) | ShaderProgram |
FindUniform(string name) | ShaderProgram |
GetAttributeBinding(int index) | ShaderProgram |
GetAttributeName(int index) | ShaderProgram |
GetAttributeSize(int index) | ShaderProgram |
GetAttributeStream(int index) | ShaderProgram |
GetAttributeType(int index) | ShaderProgram |
GetUniformBinding(int index) | ShaderProgram |
GetUniformName(int index) | ShaderProgram |
GetUniformSize(int index) | ShaderProgram |
GetUniformTexture(int index) | ShaderProgram |
GetUniformType(int index) | ShaderProgram |
Parameters | BasicProgram |
SetAttributeBinding(int index, string name) | ShaderProgram |
SetAttributeStream(int index, int stream) | ShaderProgram |
SetAttributeValue(int index, params float[] value) | ShaderProgram |
SetUniformBinding(int index, string name) | ShaderProgram |
SetUniformValue(int index, ref Matrix4 value) | ShaderProgram |
SetUniformValue(int index, ref Vector4 value) | ShaderProgram |
SetUniformValue(int index, ref Vector3 value) | ShaderProgram |
SetUniformValue(int index, ref Vector2 value) | ShaderProgram |
SetUniformValue(int index, float value) | ShaderProgram |
SetUniformValue(int index, int value) | ShaderProgram |
SetUniformValue(int index, float[] value) | ShaderProgram |
SetUniformValue(int index, int[] value) | ShaderProgram |
SetUniformValue(int index, int offset, ref Matrix4 value) | ShaderProgram |
SetUniformValue(int index, int offset, ref Vector4 value) | ShaderProgram |
SetUniformValue(int index, int offset, ref Vector3 value) | ShaderProgram |
SetUniformValue(int index, int offset, ref Vector2 value) | ShaderProgram |
SetUniformValue(int index, int offset, float value) | ShaderProgram |
SetUniformValue(int index, int offset, int value) | ShaderProgram |
SetUniformValue(int index, int offset, float[] value) | ShaderProgram |
SetUniformValue(int index, int offset, int[] value) | ShaderProgram |
SetUniformValue(int index, Matrix4[] value, int to, int from, int count) | ShaderProgram |
SetUniformValue(int index, Vector4[] value, int to, int from, int count) | ShaderProgram |
SetUniformValue(int index, Vector3[] value, int to, int from, int count) | ShaderProgram |
SetUniformValue(int index, Vector2[] value, int to, int from, int count) | ShaderProgram |
SetUniformValue(int index, float[] value, int to, int from, int count) | ShaderProgram |
SetUniformValue(int index, int[] value, int to, int from, int count) | ShaderProgram |
ShaderProgram(string fileName) | ShaderProgram |
ShaderProgram(string vpFileName, string fpFileName) | ShaderProgram |
ShaderProgram(string fileName, ShaderProgramOption option) | ShaderProgram |
ShaderProgram(string vpFileName, string fpFileName, ShaderProgramOption option) | ShaderProgram |
ShaderProgram(byte[] fileImage) | ShaderProgram |
ShaderProgram(byte[] vpFileImage, byte[] fpFileImage) | ShaderProgram |
ShaderProgram(byte[] fileImage, ShaderProgramOption option) | ShaderProgram |
ShaderProgram(byte[] vpFileImage, byte[] fpFileImage, ShaderProgramOption option) | ShaderProgram |
ShaderProgram(ShaderProgram program) | ShaderProgram | [protected]
ShallowClone() | BasicProgram | [virtual]
SwapShader(ShaderProgram program) | ShaderProgram | [protected]
UniformCount | ShaderProgram |
UpdateShader() | BasicProgram | [protected, virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicProgramContainer

BasicProgramContainer メンバ一覧

これは全メンバの一覧です。BasicProgramContainer継承メンバも含んでいます。
Add(string key, BasicProgram program) | BasicProgramContainer
BasicProgramContainer(BasicParameters parameters=null) | BasicProgramContainer
Dispose() | BasicProgramContainer
Find(string key) | BasicProgramContainer
Parameters | BasicProgramContainer


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicTexture

BasicTexture メンバ一覧

これは全メンバの一覧です。BasicTexture継承メンバも含んでいます。
BasicTexture() | BasicTexture
FileName | BasicTexture
Name | BasicTexture
Texture | BasicTexture
UVScaling | BasicTexture
UVTranslation | BasicTexture


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Model
  • BasicTextureContainer

BasicTextureContainer メンバ一覧

これは全メンバの一覧です。BasicTextureContainer継承メンバも含んでいます。
Add(string key, Texture texture) | BasicTextureContainer
BasicTextureContainer() | BasicTextureContainer
Dispose() | BasicTextureContainer
Find(string key) | BasicTextureContainer


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Physics2D
  • PhysicsBody

PhysicsBody メンバ一覧

これは全メンバの一覧です。PhysicsBody継承メンバも含んでいます。
aabbMax | PhysicsBody |
AabbMax | PhysicsBody |
aabbMin | PhysicsBody |
AabbMin | PhysicsBody |
Acceleration | PhysicsBody |
acceleration | PhysicsBody |
airFriction | PhysicsBody |
AirFriction | PhysicsBody |
AngularVelocity | PhysicsBody |
angularVelocity | PhysicsBody |
ApplyForce(Vector2 power) | PhysicsBody |
ApplyForce(Vector2 power, Vector2 pos, bool isGlobal=true) | PhysicsBody |
ApplyTorque(float rotPower) | PhysicsBody |
BackToDynamic() | PhysicsBody |
broadCollide | PhysicsBody |
BroadCollide | PhysicsBody |
Clear() | PhysicsBody |
colFriction | PhysicsBody |
ColFriction | PhysicsBody |
collisionFilter | PhysicsBody |
CollisionFilter | PhysicsBody |
CopyBody(PhysicsBody body) | PhysicsBody |
force | PhysicsBody |
Force | PhysicsBody |
groupFilter | PhysicsBody |
GroupFilter | PhysicsBody |
Inertia | PhysicsBody |
inertia | PhysicsBody |
InsideBody(Vector2 pos, PhysicsShape con) | PhysicsBody |
InvInertia | PhysicsBody |
invInertia | PhysicsBody |
invMass | PhysicsBody |
InvMass | PhysicsBody |
IsDynamic() | PhysicsBody |
IsKinematic() | PhysicsBody |
IsKinematicOrStatic() | PhysicsBody |
IsStatic() | PhysicsBody |
IsTrigger() | PhysicsBody |
localPosition | PhysicsBody |
LocalPosition | PhysicsBody |
LocalRotation | PhysicsBody |
localRotation | PhysicsBody |
mass | PhysicsBody |
Mass | PhysicsBody |
MergeBody(PhysicsBody[] bodyList, uint[] indexList, uint num, PhysicsShape[] sceneShapes, uint[] map, bool flag=true) | PhysicsBody | [static]
MergeBodyWithPos(PhysicsBody[] bodyList, uint[] indexList, uint num, PhysicsShape[] sceneShapes, uint[] map, Vector2 pos) | PhysicsBody | [static]
MoveTo(Vector2 pt, float rt, float dt) | PhysicsBody |
narrowCollide | PhysicsBody |
NarrowCollide | PhysicsBody |
oldInertia | PhysicsBody |
oldInvInertia | PhysicsBody |
oldInvMass | PhysicsBody |
oldMass | PhysicsBody |
PenetLimit | PhysicsBody |
penetLimit | PhysicsBody |
PenetrationRepulse | PhysicsBody |
penetrationRepulse | PhysicsBody |
PhysicsBody() | PhysicsBody |
PhysicsBody(PhysicsBody body) | PhysicsBody |
PhysicsBody(PhysicsShape conv, float m) | PhysicsBody |
Picking | PhysicsBody |
picking | PhysicsBody |
Position | PhysicsBody |
position | PhysicsBody |
restitutionCoeff | PhysicsBody |
RestitutionCoeff | PhysicsBody |
rotation | PhysicsBody |
Rotation | PhysicsBody |
SetBodyKinematic() | PhysicsBody |
SetBodyStatic() | PhysicsBody |
SetBodyTrigger() | PhysicsBody |
ShapeIndex | PhysicsBody |
shapeIndex | PhysicsBody |
sleep | PhysicsBody |
Sleep | PhysicsBody |
SleepCount | PhysicsBody |
sleepCount | PhysicsBody |
tangentFriction | PhysicsBody |
TangentFriction | PhysicsBody |
Torque | PhysicsBody |
torque | PhysicsBody |
Type | PhysicsBody |
userData | PhysicsBody |
UserData | PhysicsBody |
Velocity | PhysicsBody |
velocity | PhysicsBody |
WakeUpDynamic() | PhysicsBody |
WakeUpKinematic() | PhysicsBody |
width | PhysicsBody |
Width | PhysicsBody |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Physics2D
  • PhysicsJoint

PhysicsJoint メンバ一覧

これは全メンバの一覧です。PhysicsJoint継承メンバも含んでいます。
angleLim | PhysicsJoint
AngleLim | PhysicsJoint
angleLower | PhysicsJoint
AngleLower | PhysicsJoint
angleUpper | PhysicsJoint
AngleUpper | PhysicsJoint
Axis1Lim | PhysicsJoint
axis1Lim | PhysicsJoint
Axis1Lower | PhysicsJoint
axis1Lower | PhysicsJoint
Axis1Upper | PhysicsJoint
axis1Upper | PhysicsJoint
Axis2Lim | PhysicsJoint
axis2Lim | PhysicsJoint
Axis2Lower | PhysicsJoint
axis2Lower | PhysicsJoint
axis2Upper | PhysicsJoint
Axis2Upper | PhysicsJoint
CopyJoint(PhysicsJoint jnt) | PhysicsJoint
Friction | PhysicsJoint
friction | PhysicsJoint
ImpulseLinear | PhysicsJoint
impulseLinearMotor | PhysicsJoint
ImpulseLinearMotor | PhysicsJoint
ImpulseRot | PhysicsJoint
impulseRotMotor | PhysicsJoint
ImpulseRotMotor | PhysicsJoint
LocalAnchor1 | PhysicsJoint
localAnchor1 | PhysicsJoint
LocalAnchor2 | PhysicsJoint
localAnchor2 | PhysicsJoint
PhysicsJoint(PhysicsBody body1, PhysicsBody body2, Vector2 anchor, uint index1, uint index2) | PhysicsJoint
TotalIndex | PhysicsJoint
totalIndex | PhysicsJoint


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Physics2D
  • PhysicsScene

PhysicsScene メンバ一覧

これは全メンバの一覧です。PhysicsScene継承メンバも含んでいます。
AddBody(int shapeIndex, float mass) | PhysicsScene |
AddBody(PhysicsShape shape, float mass) | PhysicsScene |
AddBoxShape(Vector2 width) | PhysicsScene |
AddConvexHullShape(Vector2[] pos, int num) | PhysicsScene |
AddConvexShape(Vector2[] pos, int num) | PhysicsScene |
AddIgnorePair(uint index1, uint index2) | PhysicsScene |
AddIgnorePair(PhysicsBody body1, PhysicsBody body2) | PhysicsScene |
AddJoint(int bodyIndex1, int bodyIndex2, Vector2 anchorPos) | PhysicsScene |
AddJoint(PhysicsBody body1, PhysicsBody body2, Vector2 anchorPos) | PhysicsScene |
AddLineChainShape(Vector2[] pos, int num) | PhysicsScene |
AddSphereShape(float radius) | PhysicsScene |
AddSpring(int bodyIndex1, int bodyIndex2, Vector2 anchorPos1, Vector2 anchorPos2) | PhysicsScene |
AddSpring(PhysicsBody body1, PhysicsBody body2, Vector2 anchorPos1, Vector2 anchorPos2) | PhysicsScene |
BroadOpType Enum | PhysicsScene |
broadPair | PhysicsScene |
BroadPair | PhysicsScene |
CheckForcePicking(ref Vector2 click_pos, ref Vector2 diff_pos, bool rigorous_check) | PhysicsScene |
CheckOutOfBound(PhysicsBody body) | PhysicsScene |
CheckPicking(ref Vector2 click_pos, ref Vector2 diff_pos, bool rigorous_check) | PhysicsScene |
CompoundMap | PhysicsScene |
compoundMap | PhysicsScene |
DeleteBody(int index) | PhysicsScene |
DeleteBody(PhysicsBody body) | PhysicsScene |
DeleteJoint(int index) | PhysicsScene |
DeleteJoint(PhysicsJoint joint) | PhysicsScene |
DeleteSpring(int index) | PhysicsScene |
DeleteSpring(PhysicsSpring spring) | PhysicsScene |
DrawAdditionalInfo(ref GraphicsContext graphics, ref ShaderProgram program, Matrix4 rendering_scale) | PhysicsScene | [virtual]
DrawAllBody(ref GraphicsContext graphics, ref ShaderProgram program, Matrix4 rendering_scale, int click_index) | PhysicsScene | [virtual]
FilterOp | PhysicsScene |
filterOp | PhysicsScene |
GetBody(int index) | PhysicsScene |
GetBodyIndex(PhysicsBody body) | PhysicsScene |
GetJoint(int index) | PhysicsScene |
GetJointIndex(PhysicsJoint joint) | PhysicsScene |
GetShape(int index) | PhysicsScene |
GetShapeIndex(PhysicsShape shape) | PhysicsScene |
GetSpring(int index) | PhysicsScene |
GetSpringIndex(PhysicsSpring spring) | PhysicsScene |
gravity | PhysicsScene |
Gravity | PhysicsScene |
IgnorePair | PhysicsScene |
ignorePair | PhysicsScene |
InitScene() | PhysicsScene | [virtual]
KeyboardFunc(GamePadButtons ePad) | PhysicsScene | [virtual]
MergeCompound(PhysicsBody[] bodyList, int num, bool flag=true) | PhysicsScene |
numBody | PhysicsScene |
NumBody | PhysicsScene |
numBroadPair | PhysicsScene |
NumBroadPair | PhysicsScene |
NumIgnorePair | PhysicsScene |
numIgnorePair | PhysicsScene |
numJoint | PhysicsScene |
NumJoint | PhysicsScene |
numOldPhysicsSolverPair | PhysicsScene |
NumOldPhysicsSolverPair | PhysicsScene |
numPhysicsSolverPair | PhysicsScene |
NumPhysicsSolverPair | PhysicsScene |
NumShape | PhysicsScene |
numShape | PhysicsScene |
NumSpring | PhysicsScene |
numSpring | PhysicsScene |
PenetLimit | PhysicsScene |
penetLimit | PhysicsScene |
PenetrationRepulse | PhysicsScene |
penetrationRepulse | PhysicsScene |
PhysicsScene() | PhysicsScene |
PrintPerf | PhysicsScene |
printPerf | PhysicsScene |
QueryContact(uint index1, uint index2) | PhysicsScene |
QueryContact(PhysicsBody body1, PhysicsBody body2) | PhysicsScene |
QueryContactTrigger(uint index, uint[] indexlist) | PhysicsScene |
RaycastHit(ref RayHit ray) | PhysicsScene |
RaycastHit(ref RayHit ray, uint collisionFilter, uint groupFilter) | PhysicsScene |
ReleaseScene() | PhysicsScene | [virtual]
RemoveIgnorePair(uint index1, uint index2) | PhysicsScene |
RemoveIgnorePair(PhysicsBody body1, PhysicsBody body2) | PhysicsScene |
restitutionCoeff | PhysicsScene |
RestitutionCoeff | PhysicsScene |
sceneBodies | PhysicsScene |
SceneBodies | PhysicsScene |
SceneFrame | PhysicsScene |
sceneFrame | PhysicsScene |
sceneJoints | PhysicsScene |
SceneJoints | PhysicsScene |
SceneMax | PhysicsScene |
sceneMax | PhysicsScene |
SceneMin | PhysicsScene |
sceneMin | PhysicsScene |
SceneName | PhysicsScene |
sceneName | PhysicsScene |
sceneShapes | PhysicsScene |
SceneShapes | PhysicsScene |
sceneSprings | PhysicsScene |
SceneSprings | PhysicsScene |
SimDt | PhysicsScene |
simDt | PhysicsScene |
Simulate() | PhysicsScene |
Simulate(int click_index, Vector2 click_pos, Vector2 diff_pos) | PhysicsScene |
SleepAlgorithm | PhysicsScene |
sleepAlgorithm | PhysicsScene |
SleepAlgorithmType Enum | PhysicsScene |
SolverPair | PhysicsScene |
solverPair | PhysicsScene |
TangentFriction | PhysicsScene |
tangentFriction | PhysicsScene |
UniqueProperty | PhysicsScene |
uniqueProperty | PhysicsScene |
UpdateFuncAfterSim() | PhysicsScene | [virtual]
UpdateFuncBeforeSim() | PhysicsScene | [virtual]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Physics2D
  • PhysicsShape

PhysicsShape メンバ一覧

これは全メンバの一覧です。PhysicsShape継承メンバも含んでいます。
CreateConvexHull(Vector2[] vertList, int num) | PhysicsShape | [static]
hint | PhysicsShape |
Hint | PhysicsShape |
NumVert | PhysicsShape |
numVert | PhysicsShape |
PhysicsShape() | PhysicsShape |
PhysicsShape(float radius) | PhysicsShape |
PhysicsShape(Vector2 width) | PhysicsShape |
PhysicsShape(Vector2[] pos, int num) | PhysicsShape |
PhysicsShape(Vector2[] pos, int num, bool flag) | PhysicsShape |
PhysicsShape(PhysicsShape con) | PhysicsShape |
VertList | PhysicsShape |
vertList | PhysicsShape |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Physics2D
  • PhysicsSpring

PhysicsSpring メンバ一覧

これは全メンバの一覧です。PhysicsSpring継承メンバも含んでいます。
CopySpring(PhysicsSpring jnt) | PhysicsSpring
currentDistance | PhysicsSpring
CurrentDistance | PhysicsSpring
distance | PhysicsSpring
Distance | PhysicsSpring
dumping | PhysicsSpring
Dumping | PhysicsSpring
Elastic | PhysicsSpring
elastic | PhysicsSpring
GetIndex1() | PhysicsSpring
GetIndex2() | PhysicsSpring
LocalAnchor1 | PhysicsSpring
localAnchor1 | PhysicsSpring
LocalAnchor2 | PhysicsSpring
localAnchor2 | PhysicsSpring
PhysicsSpring(PhysicsBody body1, PhysicsBody body2, Vector2 anchor1, Vector2 anchor2, uint index1, uint index2) | PhysicsSpring
TotalIndex | PhysicsSpring
totalIndex | PhysicsSpring


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Physics2D
  • PhysicsUtility

PhysicsUtility メンバ一覧

これは全メンバの一覧です。PhysicsUtility継承メンバも含んでいます。
FltMax | PhysicsUtility |
GetRadian(float angle) | PhysicsUtility | [static]
GetRadianMod(float angle) | PhysicsUtility | [static]
PackIdx(uint val1, uint val2) | PhysicsUtility | [static]
Pi | PhysicsUtility |
SwapIdx(uint val) | PhysicsUtility | [static]
UnpackIdx1(uint val) | PhysicsUtility | [static]
UnpackIdx2(uint val) | PhysicsUtility | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • AnimationImageBox

AnimationImageBox メンバ一覧

これは全メンバの一覧です。AnimationImageBox継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
AnimationImageBox() | AnimationImageBox |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
FrameCount | AnimationImageBox |
FrameHeight | AnimationImageBox |
FrameInterval | AnimationImageBox |
FrameWidth | AnimationImageBox |
Height | Widget |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
Image | AnimationImageBox |
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | AnimationImageBox | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | AnimationImageBox | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Start() | AnimationImageBox |
Stop() | AnimationImageBox |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | Widget |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • AnimationUtility

AnimationUtility メンバ一覧

これは全メンバの一覧です。AnimationUtility継承メンバも含んでいます。
BounceInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInCircInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInCubicInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInExpoInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInOutCircInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInOutCubicInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInOutExpoInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInOutQuadInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInOutQuartInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInOutQuintInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInOutSineInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInQuadInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInQuartInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInQuintInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseInSineInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutCircInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutCubicInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutExpoInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutInCircInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutInCubicInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutInExpoInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutInQuadInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutInQuartInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutInQuintInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutInSineInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutQuadInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutQuartInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutQuintInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
EaseOutSineInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
ElasticInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
FlipBounceInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
LinearInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
OvershootInterpolator(float from, float to, float ratio) | AnimationUtility | [static]
UndershootInterpolator(float from, float to, float ratio) | AnimationUtility | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • BunjeeJumpEffect

BunjeeJumpEffect メンバ一覧

これは全メンバの一覧です。BunjeeJumpEffect継承メンバも含んでいます。
BunjeeJumpEffect() | BunjeeJumpEffect |
BunjeeJumpEffect(Widget widget, float elasticity) | BunjeeJumpEffect |
CreateAndStart(Widget widget, float elasticity) | BunjeeJumpEffect | [static]
Effect() | Effect |
EffectStopped | Effect |
Elasticity | BunjeeJumpEffect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | Effect | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | BunjeeJumpEffect | [protected, virtual]
OnStop() | BunjeeJumpEffect | [protected, virtual]
OnUpdate(float elapsedTime) | BunjeeJumpEffect | [protected, virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
Start() | Effect |
Stop() | Effect |
TotalElapsedTime | Effect |
Widget | Effect |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • BusyIndicator

BusyIndicator メンバ一覧

これは全メンバの一覧です。BusyIndicator継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BusyIndicator() | BusyIndicator |
BusyIndicator(bool autoStart) | BusyIndicator |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | BusyIndicator | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | BusyIndicator |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Start() | BusyIndicator |
Stop() | BusyIndicator |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | BusyIndicator |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • Button

Button メンバ一覧

これは全メンバの一覧です。Button継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BackgroundFilterColor | Button |
Button() | Button |
ButtonAction | Button |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
CustomImage | Button |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Button | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | Button |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
HorizontalAlignment | Button |
IconImage | Button |
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Button | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Button | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Style | Button |
Text | Button |
TextColor | Button |
TextFont | Button |
TextShadow | Button |
TextTrimming | Button |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
VerticalAlignment | Button |
Visible | Widget |
Widget() | Widget |
Width | Button |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • CheckBox

CheckBox メンバ一覧

これは全メンバの一覧です。CheckBox継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
CheckBox() | CheckBox |
Checked | CheckBox |
CheckedChanged | CheckBox |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
CustomCheckBoxImage | CheckBox |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | CheckBox | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | CheckBox |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | CheckBox | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | CheckBox | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Style | CheckBox |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | CheckBox |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • ContainerWidget

ContainerWidget メンバ一覧

これは全メンバの一覧です。ContainerWidget継承メンバも含んでいます。
AddChildFirst(Widget child) | ContainerWidget | [virtual]
AddChildLast(Widget child) | ContainerWidget | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
Children | ContainerWidget |
Clip | Widget | [protected]
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | ContainerWidget |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | ContainerWidget | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | ContainerWidget | [virtual]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | ContainerWidget | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | ContainerWidget |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • CrossFadeTransition

CrossFadeTransition メンバ一覧

これは全メンバの一覧です。CrossFadeTransition継承メンバも含んでいます。
CrossFadeTransition() | CrossFadeTransition |
CrossFadeTransition(float time, CrossFadeTransitionInterpolator interpolator) | CrossFadeTransition |
CustomCurrentSceneInterpolator | CrossFadeTransition |
CustomNextSceneInterpolator | CrossFadeTransition |
DrawOrder | Transition | [protected]
GetCurrentSceneRenderedImage() | Transition | [protected]
GetNextSceneRenderedImage() | Transition | [protected]
Interpolator | CrossFadeTransition |
NextScene | Transition | [protected]
NextSceneFront | CrossFadeTransition |
OnStart() | CrossFadeTransition | [protected, virtual]
OnStop() | CrossFadeTransition | [protected, virtual]
OnUpdate(float elapsedTime) | CrossFadeTransition | [protected, virtual]
Time | CrossFadeTransition |
TotalElapsedTime | Transition |
Transition() | Transition |
TransitionStopped | Transition |
TransitionUIElement | Transition | [protected]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • CustomButtonImageSettings

CustomButtonImageSettings メンバ一覧

これは全メンバの一覧です。CustomButtonImageSettings継承メンバも含んでいます。
BackgroundDisabledImage | CustomButtonImageSettings
BackgroundNinePatchMargin | CustomButtonImageSettings
BackgroundNormalImage | CustomButtonImageSettings
BackgroundPressedImage | CustomButtonImageSettings
CustomButtonImageSettings() | CustomButtonImageSettings


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • CustomCheckBoxImageSettings

CustomCheckBoxImageSettings メンバ一覧

これは全メンバの一覧です。CustomCheckBoxImageSettings継承メンバも含んでいます。
CustomCheckBoxImageSettings() | CustomCheckBoxImageSettings
DisabledCheckedImage | CustomCheckBoxImageSettings
DisabledUncheckedImage | CustomCheckBoxImageSettings
NormalCheckedImage | CustomCheckBoxImageSettings
NormalUncheckedImage | CustomCheckBoxImageSettings
PressedCheckedImage | CustomCheckBoxImageSettings
PressedUncheckedImage | CustomCheckBoxImageSettings


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • DatePicker

DatePicker メンバ一覧

これは全メンバの一覧です。DatePicker継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Date | DatePicker |
DatePicker() | DatePicker |
Day | DatePicker |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | DatePicker |
HitTest(Vector2 screenPoint) | DatePicker | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MaxYear | DatePicker |
MinYear | DatePicker |
Month | DatePicker |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | DatePicker |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
ValueChanged | DatePicker |
Visible | Widget |
Widget() | Widget |
Width | DatePicker |
X | Widget |
Y | Widget |
Year | DatePicker |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • DatePickerValueChangedEventArgs

DatePickerValueChangedEventArgs メンバ一覧

これは全メンバの一覧です。DatePickerValueChangedEventArgs継承メンバも含んでいます。
DatePickerValueChangedEventArgs() | DatePickerValueChangedEventArgs
NewDay | DatePickerValueChangedEventArgs
NewMonth | DatePickerValueChangedEventArgs
NewYear | DatePickerValueChangedEventArgs
OldDay | DatePickerValueChangedEventArgs
OldMonth | DatePickerValueChangedEventArgs
OldYear | DatePickerValueChangedEventArgs
ToString() | DatePickerValueChangedEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • DelayedExecutor

DelayedExecutor メンバ一覧

これは全メンバの一覧です。DelayedExecutor継承メンバも含んでいます。
Action | DelayedExecutor |
CreateAndStart(float time, Action action) | DelayedExecutor | [static]
DelayedExecutor() | DelayedExecutor |
DelayedExecutor(float time, Action action) | DelayedExecutor |
Effect() | Effect |
EffectStopped | Effect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | Effect | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | DelayedExecutor | [protected, virtual]
OnStop() | DelayedExecutor | [protected, virtual]
OnUpdate(float elapsedTime) | DelayedExecutor | [protected, virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
Start() | Effect |
Stop() | Effect |
Time | DelayedExecutor |
TotalElapsedTime | Effect |
Widget | Effect |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • Dialog

Dialog メンバ一覧

これは全メンバの一覧です。Dialog継承メンバも含んでいます。
AddChildFirst(Widget child) | ContainerWidget | [virtual]
AddChildLast(Widget child) | ContainerWidget | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BackgroundFilterColor | Dialog |
BackgroundStyle | Dialog |
Children | ContainerWidget |
Clip | Widget | [protected]
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
CustomBackgroundColor | Dialog |
CustomBackgroundImage | Dialog |
CustomBackgroundNinePatchMargin | Dialog |
DefaultFocusWidget | Dialog |
Dialog() | Dialog |
Dialog(Effect showEffect, Effect hideEffect) | Dialog |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Dialog | [protected, virtual]
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | Dialog |
Hidden | Dialog |
Hide() | Dialog |
Hide(Effect effect) | Dialog |
HideEffect | Dialog |
HideOnTouchOutside | Dialog |
Hiding | Dialog |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | ContainerWidget | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | ContainerWidget | [virtual]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | ContainerWidget | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Dialog | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
Result | Dialog |
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Show() | Dialog |
Show(Effect effect) | Dialog |
ShowEffect | Dialog |
Showing | Dialog |
Shown | Dialog |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | Dialog |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • DialogEventArgs

DialogEventArgs メンバ一覧

これは全メンバの一覧です。DialogEventArgs継承メンバも含んでいます。
CancelHide | DialogEventArgs
DialogEventArgs(DialogResult result) | DialogEventArgs
Result | DialogEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • DoubleTapEventArgs

DoubleTapEventArgs メンバ一覧

これは全メンバの一覧です。DoubleTapEventArgs継承メンバも含んでいます。
DoubleTapEventArgs(Widget source, Vector2 worldPosition, Vector2 localPosition) | DoubleTapEventArgs
GestureEventArgs(Widget source) | GestureEventArgs
LocalPosition | DoubleTapEventArgs
Source | GestureEventArgs
WorldPosition | DoubleTapEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • DoubleTapGestureDetector

DoubleTapGestureDetector メンバ一覧

これは全メンバの一覧です。DoubleTapGestureDetector継承メンバも含んでいます。
DoubleTapDetected | DoubleTapGestureDetector |
DoubleTapGestureDetector() | DoubleTapGestureDetector |
GestureDetector() | GestureDetector |
MaxDistance | DoubleTapGestureDetector |
MaxNextPressDuration | DoubleTapGestureDetector |
MaxPressDuration | DoubleTapGestureDetector |
OnResetState() | DoubleTapGestureDetector | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | DoubleTapGestureDetector | [protected, virtual]
State | GestureDetector |
TargetWidget | GestureDetector |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • DragEventArgs

DragEventArgs メンバ一覧

これは全メンバの一覧です。DragEventArgs継承メンバも含んでいます。
Distance | DragEventArgs
DragEventArgs(Widget source, Vector2 worldPosition, Vector2 localPosition, Vector2 distance) | DragEventArgs
GestureEventArgs(Widget source) | GestureEventArgs
LocalPosition | DragEventArgs
Source | GestureEventArgs
WorldPosition | DragEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • DragGestureDetector

DragGestureDetector メンバ一覧

これは全メンバの一覧です。DragGestureDetector継承メンバも含んでいます。
Direction | DragGestureDetector |
DragDetected | DragGestureDetector |
DragEndDetected | DragGestureDetector |
DragGestureDetector() | DragGestureDetector |
DragStartDetected | DragGestureDetector |
GestureDetector() | GestureDetector |
MaxDistance | DragGestureDetector |
OnResetState() | DragGestureDetector | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | DragGestureDetector | [protected, virtual]
State | GestureDetector |
TargetWidget | GestureDetector |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • EditableText

EditableText メンバ一覧

これは全メンバの一覧です。EditableText継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
DefaultFont | EditableText |
DefaultText | EditableText |
DefaultTextColor | EditableText |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | EditableText | [protected, virtual]
EditableText() | EditableText |
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Font | EditableText |
Height | EditableText |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
HorizontalAlignment | EditableText |
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LineBreak | EditableText |
LineGap | EditableText |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | EditableText | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | EditableText | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | EditableText | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Text | EditableText |
TextChanged | EditableText |
TextColor | EditableText |
TextInputMode | EditableText |
TextShadow | EditableText |
TextTrimming | EditableText |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
VerticalAlignment | EditableText |
Visible | Widget |
Widget() | Widget |
Width | EditableText |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • Effect

Effect メンバ一覧

これは全メンバの一覧です。Effect継承メンバも含んでいます。
Effect() | Effect |
EffectStopped | Effect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | Effect | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | Effect | [protected, pure virtual]
OnStop() | Effect | [protected, pure virtual]
OnUpdate(float elapsedTime) | Effect | [protected, pure virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
Start() | Effect |
Stop() | Effect |
TotalElapsedTime | Effect |
Widget | Effect |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • FadeInEffect

FadeInEffect メンバ一覧

これは全メンバの一覧です。FadeInEffect継承メンバも含んでいます。
CreateAndStart(Widget widget, float time, FadeInEffectInterpolator interpolator) | FadeInEffect | [static]
CustomInterpolator | FadeInEffect |
Effect() | Effect |
EffectStopped | Effect |
FadeInEffect() | FadeInEffect |
FadeInEffect(Widget widget, float time, FadeInEffectInterpolator interpolator) | FadeInEffect |
Interpolator | FadeInEffect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | Effect | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | FadeInEffect | [protected, virtual]
OnStop() | FadeInEffect | [protected, virtual]
OnUpdate(float elapsedTime) | FadeInEffect | [protected, virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
Start() | Effect |
Stop() | Effect |
Time | FadeInEffect |
TotalElapsedTime | Effect |
Widget | Effect |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • FadeOutEffect

FadeOutEffect メンバ一覧

これは全メンバの一覧です。FadeOutEffect継承メンバも含んでいます。
CreateAndStart(Widget widget, float time, FadeOutEffectInterpolator interpolator) | FadeOutEffect | [static]
CustomInterpolator | FadeOutEffect |
Effect() | Effect |
EffectStopped | Effect |
FadeOutEffect() | FadeOutEffect |
FadeOutEffect(Widget widget, float time, FadeOutEffectInterpolator interpolator) | FadeOutEffect |
Interpolator | FadeOutEffect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | Effect | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | FadeOutEffect | [protected, virtual]
OnStop() | FadeOutEffect | [protected, virtual]
OnUpdate(float elapsedTime) | FadeOutEffect | [protected, virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
Start() | Effect |
Stop() | Effect |
Time | FadeOutEffect |
TotalElapsedTime | Effect |
Widget | Effect |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • FlickEventArgs

FlickEventArgs メンバ一覧

これは全メンバの一覧です。FlickEventArgs継承メンバも含んでいます。
FlickEventArgs(Widget source, Vector2 worldPosition, Vector2 localPosition, Vector2 flickSpeed) | FlickEventArgs
GestureEventArgs(Widget source) | GestureEventArgs
LocalPosition | FlickEventArgs
Source | GestureEventArgs
Speed | FlickEventArgs
WorldPosition | FlickEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • FlickGestureDetector

FlickGestureDetector メンバ一覧

これは全メンバの一覧です。FlickGestureDetector継承メンバも含んでいます。
Direction | FlickGestureDetector |
FlickDetected | FlickGestureDetector |
FlickGestureDetector() | FlickGestureDetector |
GestureDetector() | GestureDetector |
MaxSpeed | FlickGestureDetector |
MinSpeed | FlickGestureDetector |
OnResetState() | FlickGestureDetector | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | FlickGestureDetector | [protected, virtual]
State | GestureDetector |
TargetWidget | GestureDetector |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • FlipBoardEffect

FlipBoardEffect メンバ一覧

これは全メンバの一覧です。FlipBoardEffect継承メンバも含んでいます。
CreateAndStart(Widget currentWidget, Widget nextWidget) | FlipBoardEffect | [static]
CustomInterpolator | FlipBoardEffect |
Effect() | Effect |
EffectStopped | Effect |
FlipBoardEffect() | FlipBoardEffect |
FlipBoardEffect(Widget currentWidget, Widget nextWidget) | FlipBoardEffect |
Interpolator | FlipBoardEffect |
NextWidget | FlipBoardEffect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | Effect | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | FlipBoardEffect | [protected, virtual]
OnStop() | FlipBoardEffect | [protected, virtual]
OnUpdate(float elapsedTime) | FlipBoardEffect | [protected, virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
Start() | Effect |
Stop() | Effect |
Time | FlipBoardEffect |
TotalElapsedTime | Effect |
Widget | Effect |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • FlipBoardTransition

FlipBoardTransition メンバ一覧

これは全メンバの一覧です。FlipBoardTransition継承メンバも含んでいます。
CustomInterpolator | FlipBoardTransition |
DrawOrder | Transition | [protected]
FlipBoardTransition() | FlipBoardTransition |
GetCurrentSceneRenderedImage() | Transition | [protected]
GetNextSceneRenderedImage() | Transition | [protected]
Interpolator | FlipBoardTransition |
NextScene | Transition | [protected]
OnStart() | FlipBoardTransition | [protected, virtual]
OnStop() | FlipBoardTransition | [protected, virtual]
OnUpdate(float elapsedTime) | FlipBoardTransition | [protected, virtual]
Time | FlipBoardTransition |
TotalElapsedTime | Transition |
Transition() | Transition |
TransitionStopped | Transition |
TransitionUIElement | Transition | [protected]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • FocusChangedEventArgs

FocusChangedEventArgs メンバ一覧

これは全メンバの一覧です。FocusChangedEventArgs継承メンバも含んでいます。
FocusChangedEventArgs(bool focused) | FocusChangedEventArgs
Focused | FocusChangedEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • FocusCustomSettings

FocusCustomSettings メンバ一覧

これは全メンバの一覧です。FocusCustomSettings継承メンバも含んでいます。
DownCandidate | FocusCustomSettings
FocusImage | FocusCustomSettings
FocusImageNinePatchMargin | FocusCustomSettings
FocusImagePadding | FocusCustomSettings
FocusImageRectangle | FocusCustomSettings
HideFocusImage | FocusCustomSettings
LeftCandidate | FocusCustomSettings
RightCandidate | FocusCustomSettings
SearchHintRectangle | FocusCustomSettings
UpCandidate | FocusCustomSettings


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • GestureDetector

GestureDetector メンバ一覧

これは全メンバの一覧です。GestureDetector継承メンバも含んでいます。
GestureDetector() | GestureDetector |
OnResetState() | GestureDetector | [protected, pure virtual]
OnTouchEvent(TouchEventCollection touchEvents) | GestureDetector | [protected, pure virtual]
State | GestureDetector |
TargetWidget | GestureDetector |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • GestureEventArgs

GestureEventArgs メンバ一覧

これは全メンバの一覧です。GestureEventArgs継承メンバも含んでいます。
GestureEventArgs(Widget source) | GestureEventArgs
Source | GestureEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • GridListPanel

GridListPanel メンバ一覧

これは全メンバの一覧です。GridListPanel継承メンバも含んでいます。
AddChildFirst(Widget child) | ContainerWidget | [virtual]
AddChildLast(Widget child) | ContainerWidget | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BackgroundColor | GridListPanel |
Children | ContainerWidget |
Clip | Widget | [protected]
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
GetListItem(int index) | GridListPanel |
GridListPanel(GridListScrollOrientation scrollOrientation) | GridListPanel |
Height | GridListPanel |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | ContainerWidget | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | ContainerWidget | [virtual]
ItemCount | GridListPanel |
ItemHeight | GridListPanel |
ItemHorizontalGap | GridListPanel |
ItemIndex | GridListPanel |
ItemPixelOffset | GridListPanel |
ItemVerticalGap | GridListPanel |
ItemWidth | GridListPanel |
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | GridListPanel | [protected, virtual]
OnResetState() | GridListPanel | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | GridListPanel | [protected, virtual]
OnUpdate(float elapsedTime) | GridListPanel | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | ContainerWidget | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
ScrollBarVisibility | GridListPanel |
Scrolling | GridListPanel |
ScrollOrientation | GridListPanel |
ScrollTo(int itemIndex, float pixelOffset, bool withAnimation) | GridListPanel |
ScrollTo(int itemIndex, bool withAnimation) | GridListPanel |
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SelectItemChanged | GridListPanel |
SetFocus(bool active) | Widget |
SetListItemCreator(ListItemCreator creator) | GridListPanel |
SetListItemUpdater(ListItemUpdater updater) | GridListPanel |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
SnapScroll | GridListPanel |
StartItemRequest() | GridListPanel |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | GridListPanel |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • ImageAsset

ImageAsset メンバ一覧

これは全メンバの一覧です。ImageAsset継承メンバも含んでいます。
CloneTexture() | ImageAsset |
Dispose() | ImageAsset |
FilePath | ImageAsset |
Height | ImageAsset |
ImageAsset(string filename, bool asyncLoad) | ImageAsset |
ImageAsset(string filename) | ImageAsset |
ImageAsset(SystemImageAsset name) | ImageAsset |
ImageAsset(Texture2D texture) | ImageAsset |
ImageAsset(Image image, PixelFormat format) | ImageAsset |
ImageAsset(Image image) | ImageAsset |
ImageAsset(string filename, bool asyncLoad, bool scaledPixelDensity) | ImageAsset |
ImageAsset(Texture2D texture, bool scaledPixelDensity) | ImageAsset |
ImageAsset(Image image, PixelFormat format, bool scaledPixelDensity) | ImageAsset |
ImageAsset(Image image, bool scaledPixelDensity) | ImageAsset |
Ready | ImageAsset |
UnloadFromCache() | ImageAsset |
UnloadFromCache(string filename) | ImageAsset | [static]
WaitForLoad() | ImageAsset |
WaitForLoadAll() | ImageAsset | [static]
Width | ImageAsset |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • ImageBox

ImageBox メンバ一覧

これは全メンバの一覧です。ImageBox継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BlendMode | ImageBox |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
CropArea | ImageBox |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | ImageBox |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
Image | ImageBox |
ImageBox() | ImageBox |
ImageScaleType | ImageBox |
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
NinePatchMargin | ImageBox |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | ImageBox | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | ImageBox |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • JumpFlipEffect

JumpFlipEffect メンバ一覧

これは全メンバの一覧です。JumpFlipEffect継承メンバも含んでいます。
CreateAndStart(Widget currentWidget, Widget nextWidget) | JumpFlipEffect | [static]
Effect() | Effect |
EffectStopped | Effect |
JumpDelay | JumpFlipEffect |
JumpFlipEffect() | JumpFlipEffect |
JumpFlipEffect(Widget currentWidget, Widget nextWidget) | JumpFlipEffect |
JumpHeight | JumpFlipEffect |
NextWidget | JumpFlipEffect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | Effect | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | JumpFlipEffect | [protected, virtual]
OnStop() | JumpFlipEffect | [protected, virtual]
OnUpdate(float elapsedTime) | JumpFlipEffect | [protected, virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
Revolution | JumpFlipEffect |
RotationAxis | JumpFlipEffect |
Start() | Effect |
Stop() | Effect |
Time | JumpFlipEffect |
ToDegreeDelay | JumpFlipEffect |
TotalElapsedTime | Effect |
Widget | Effect |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • JumpFlipTransition

JumpFlipTransition メンバ一覧

これは全メンバの一覧です。JumpFlipTransition継承メンバも含んでいます。
DrawOrder | Transition | [protected]
GetCurrentSceneRenderedImage() | Transition | [protected]
GetNextSceneRenderedImage() | Transition | [protected]
JumpFlipTransition() | JumpFlipTransition |
NextScene | Transition | [protected]
OnStart() | JumpFlipTransition | [protected, virtual]
OnStop() | JumpFlipTransition | [protected, virtual]
OnUpdate(float elapsedTime) | JumpFlipTransition | [protected, virtual]
RotateDirection | JumpFlipTransition |
Speed | JumpFlipTransition |
TotalElapsedTime | Transition |
Transition() | Transition |
TransitionStopped | Transition |
TransitionUIElement | Transition | [protected]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • KeyEvent

KeyEvent メンバ一覧

これは全メンバの一覧です。KeyEvent継承メンバも含んでいます。
DownTime | KeyEvent
EnabledEachFrameRepeat | KeyEvent
Forward | KeyEvent
Handled | KeyEvent
KeyEvent() | KeyEvent
KeyEvent(KeyType keyType, KeyEventType keyEventType, TimeSpan time, TimeSpan downTime) | KeyEvent
KeyEvent(KeyType keyType, KeyEventType keyEventType, TimeSpan time, TimeSpan downTime, bool enabledEachFrame) | KeyEvent
KeyEventType | KeyEvent
KeyType | KeyEvent
Time | KeyEvent


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • KeyEventArgs

KeyEventArgs メンバ一覧

これは全メンバの一覧です。KeyEventArgs継承メンバも含んでいます。
DownTime | KeyEventArgs
EnabledEachFrameRepeat | KeyEventArgs
Forward | KeyEventArgs
Handled | KeyEventArgs
KeyEventArgs(KeyEvent keyEvent) | KeyEventArgs
KeyEventType | KeyEventArgs
KeyType | KeyEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • Label

Label メンバ一覧

これは全メンバの一覧です。Label継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BackgroundColor | Label |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Label | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Font | Label |
Height | Label |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
HorizontalAlignment | Label |
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
Label() | Label |
LineBreak | Label |
LineGap | Label |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Label | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Text | Label |
TextColor | Label |
TextHeight | Label |
TextShadow | Label |
TextTrimming | Label |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
VerticalAlignment | Label |
Visible | Widget |
Widget() | Widget |
Width | Label |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • ListPanel

ListPanel メンバ一覧

これは全メンバの一覧です。ListPanel継承メンバも含んでいます。
AddChildFirst(Widget child) | ContainerWidget | [virtual]
AddChildLast(Widget child) | ContainerWidget | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
AllItemCount | ListPanel |
Alpha | Widget |
Anchors | Widget |
BackgroundColor | ListPanel |
Children | ContainerWidget |
Clip | Widget | [protected]
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
GetListItem(int index) | ListPanel |
GetListItem(int sectionIndex, int indexInSection) | ListPanel |
Height | ListPanel |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | ContainerWidget | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | ContainerWidget | [virtual]
KeyEventReceived | Widget |
ListPanel() | ListPanel |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Move(float moveDistance) | ListPanel |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | ListPanel | [protected, virtual]
OnResetState() | ListPanel | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | ListPanel | [protected, virtual]
OnUpdate(float elapsedTime) | ListPanel | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | ContainerWidget | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
ScrollBarVisibility | ListPanel |
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SectionBackgroundColor | ListPanel |
SectionFont | ListPanel |
Sections | ListPanel |
SectionTextColor | ListPanel |
SelectItemChanged | ListPanel |
SetFocus(bool active) | Widget |
SetListItemCreator(ListItemCreator creator) | ListPanel |
SetListItemUpdater(ListItemUpdater updater) | ListPanel |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
ShowEmptySection | ListPanel |
ShowItemBorder | ListPanel |
ShowSection | ListPanel |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
UpdateItems() | ListPanel |
Visible | Widget |
Widget() | Widget |
Width | ListPanel |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • ListPanelItem

ListPanelItem メンバ一覧

これは全メンバの一覧です。ListPanelItem継承メンバも含んでいます。
AddChildFirst(Widget child) | ContainerWidget | [virtual]
AddChildLast(Widget child) | ContainerWidget | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BackgroundColor | Panel |
Children | ContainerWidget |
Clip | Panel |
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | ListPanelItem | [protected, virtual]
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | ListPanelItem |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
Index | ListPanelItem |
IndexInSection | ListPanelItem |
InsertChildAfter(Widget child, Widget prevChild) | ContainerWidget | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | ContainerWidget | [virtual]
KeyEventReceived | Widget |
ListPanelItem() | ListPanelItem |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | ListPanelItem | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Panel | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Panel() | Panel |
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | ContainerWidget | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SectionIndex | ListPanelItem |
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | ListPanelItem |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • ListPanelItemSelectChangedEventArgs

ListPanelItemSelectChangedEventArgs メンバ一覧

これは全メンバの一覧です。ListPanelItemSelectChangedEventArgs継承メンバも含んでいます。
Index | ListPanelItemSelectChangedEventArgs
IndexInSection | ListPanelItemSelectChangedEventArgs
ListPanelItemSelectChangedEventArgs() | ListPanelItemSelectChangedEventArgs
ListPanelItemSelectChangedEventArgs(ListPanelItem item) | ListPanelItemSelectChangedEventArgs
SectionIndex | ListPanelItemSelectChangedEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • ListSection

ListSection メンバ一覧

これは全メンバの一覧です。ListSection継承メンバも含んでいます。
ItemChanged | ListSection
ItemCount | ListSection
ListSection() | ListSection
ListSection(string title, int itemCount) | ListSection
Title | ListSection


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • ListSectionCollection

ListSectionCollection メンバ一覧

これは全メンバの一覧です。ListSectionCollection継承メンバも含んでいます。
Add(ListSection section) | ListSectionCollection
AllItemCount | ListSectionCollection
Clear() | ListSectionCollection
Contains(ListSection section) | ListSectionCollection
CopyTo(ListSection[] array, int arrayIndex) | ListSectionCollection
Count | ListSectionCollection
IndexOf(ListSection section) | ListSectionCollection
Insert(int index, ListSection section) | ListSectionCollection
IsReadOnly | ListSectionCollection
ItemsChanged | ListSectionCollection
ListSectionCollection() | ListSectionCollection
Remove(ListSection section) | ListSectionCollection
RemoveAt(int index) | ListSectionCollection
this | ListSectionCollection


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • LiveFlipPanel

LiveFlipPanel メンバ一覧

これは全メンバの一覧です。LiveFlipPanel継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BackPanel | LiveFlipPanel |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | LiveFlipPanel | [protected, virtual]
Enabled | Widget |
FlipCount | LiveFlipPanel |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
FrontPanel | LiveFlipPanel |
Height | LiveFlipPanel |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LiveFlipPanel() | LiveFlipPanel |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | LiveFlipPanel | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | LiveFlipPanel | [protected, virtual]
OnUpdate(float elapsedTime) | LiveFlipPanel | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Start() | LiveFlipPanel |
Stop() | LiveFlipPanel |
Stop(bool withAnimate) | LiveFlipPanel |
ToString() | Widget |
TouchEnabled | LiveFlipPanel |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | LiveFlipPanel |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • LiveJumpPanel

LiveJumpPanel メンバ一覧

これは全メンバの一覧です。LiveJumpPanel継承メンバも含んでいます。
AddChildFirst(Widget child) | ContainerWidget | [virtual]
AddChildLast(Widget child) | ContainerWidget | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BackgroundColor | Panel |
Children | ContainerWidget |
Clip | Panel |
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | Panel |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | ContainerWidget | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | ContainerWidget | [virtual]
Jump() | LiveJumpPanel |
Jump(float x, float y) | LiveJumpPanel |
JumpDelayTime | LiveJumpPanel |
JumpHeight | LiveJumpPanel |
JumpTime | LiveJumpPanel |
KeyEventReceived | Widget |
LiveJumpPanel() | LiveJumpPanel |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Panel | [protected, virtual]
OnUpdate(float elapsedTime) | LiveJumpPanel | [protected, virtual]
Panel() | Panel |
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | ContainerWidget | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
TiltAngle | LiveJumpPanel |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | Panel |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • LiveListPanel

LiveListPanel メンバ一覧

これは全メンバの一覧です。LiveListPanel継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BackgroundColor | LiveListPanel |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | LiveListPanel |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
ItemCount | LiveListPanel |
ItemHeight | LiveListPanel |
ItemSlideInHeight | LiveListPanel |
ItemSlideInOffset | LiveListPanel |
ItemSlideInTiltAngle | LiveListPanel |
ItemSlideInTime | LiveListPanel |
ItemTiltAngle | LiveListPanel |
ItemVerticalGap | LiveListPanel |
ItemWidth | LiveListPanel |
KeyEventReceived | Widget |
LiveListPanel() | LiveListPanel |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | LiveListPanel | [protected, virtual]
OnResetState() | LiveListPanel | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | LiveListPanel | [protected, virtual]
OnUpdate(float elapsedTime) | LiveListPanel | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
ScrollBarVisibility | LiveListPanel |
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetListItemCreator(ListItemCreator creator) | LiveListPanel |
SetListItemUpdater(ListItemUpdater updater) | LiveListPanel |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
StartItemRequest() | LiveListPanel |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | LiveListPanel |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • LiveScrollPanel

LiveScrollPanel メンバ一覧

これは全メンバの一覧です。LiveScrollPanel継承メンバも含んでいます。
AddChildFirst(Widget child) | LiveScrollPanel | [virtual]
AddChildLast(Widget child) | LiveScrollPanel | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
Children | LiveScrollPanel |
Clip | Widget | [protected]
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | LiveScrollPanel | [protected, virtual]
Elasticity | LiveScrollPanel |
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | LiveScrollPanel |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
HorizontalScroll | LiveScrollPanel |
InsertChildAfter(Widget child, Widget prevChild) | LiveScrollPanel | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | LiveScrollPanel | [virtual]
KeyEventReceived | Widget |
LiveScrollPanel() | LiveScrollPanel |
LocalToWorld | Widget |
MaxTextureHeight | LiveScrollPanel |
MaxTextureWidth | LiveScrollPanel |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | LiveScrollPanel | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | LiveScrollPanel | [protected, virtual]
OnUpdate(float elapsedTime) | LiveScrollPanel | [protected, virtual]
PanelColor | LiveScrollPanel |
PanelHeight | LiveScrollPanel |
PanelWidth | LiveScrollPanel |
PanelX | LiveScrollPanel |
PanelY | LiveScrollPanel |
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | LiveScrollPanel | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
VerticalScroll | LiveScrollPanel |
Visible | Widget |
Widget() | Widget |
Width | LiveScrollPanel |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • LiveSphere

LiveSphere メンバ一覧

これは全メンバの一覧です。LiveSphere継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
ButtonAction | LiveSphere |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
FrontFace | LiveSphere |
Height | LiveSphere |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
Image | LiveSphere |
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LiveSphere() | LiveSphere |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | LiveSphere | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | LiveSphere | [protected, virtual]
OnUpdate(float elapsedTime) | LiveSphere | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | LiveSphere | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Start() | LiveSphere |
Stop() | LiveSphere |
Stop(bool withAnimate) | LiveSphere |
ToggleEnabled | LiveSphere |
ToString() | Widget |
TouchEnabled | LiveSphere |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
TurnCount | LiveSphere |
Visible | Widget |
Widget() | Widget |
Width | LiveSphere |
X | Widget |
Y | Widget |
YAxis | LiveSphere |
ZAxis | LiveSphere |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • LiveSpringPanel

LiveSpringPanel メンバ一覧

これは全メンバの一覧です。LiveSpringPanel継承メンバも含んでいます。
AddAcceleraton(float x, float y, float z) | LiveSpringPanel |
AddChildFirst(Widget child) | LiveSpringPanel | [virtual]
AddChildLast(Widget child) | LiveSpringPanel | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BackgroundColor | Panel |
Children | ContainerWidget |
Clip | Panel |
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
GetDampingConstant(Widget widget, SpringType type) | LiveSpringPanel |
GetDisplacement(Widget widget, SpringType type) | LiveSpringPanel |
GetSpringConstant(Widget widget, SpringType type) | LiveSpringPanel |
Height | Panel |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | LiveSpringPanel | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | LiveSpringPanel | [virtual]
KeyEventReceived | Widget |
LiveSpringPanel() | LiveSpringPanel |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | LiveSpringPanel | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Panel | [protected, virtual]
OnUpdate(float elapsedTime) | LiveSpringPanel | [protected, virtual]
Panel() | Panel |
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
ReflectMotionAcceleration | LiveSpringPanel |
ReflectSensorAcceleration | LiveSpringPanel |
RemoveChild(Widget child) | LiveSpringPanel | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetDampingConstant(Widget widget, SpringType type, float dampingConstant) | LiveSpringPanel |
SetDisplacement(Widget widget, SpringType type, float displacement) | LiveSpringPanel |
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetSpringConstant(Widget widget, SpringType type, float springConstant) | LiveSpringPanel |
SetupFinalAlpha() | Widget | [protected, virtual]
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | Panel |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • LongPressEventArgs

LongPressEventArgs メンバ一覧

これは全メンバの一覧です。LongPressEventArgs継承メンバも含んでいます。
ElapsedTime | LongPressEventArgs
GestureEventArgs(Widget source) | GestureEventArgs
LocalPosition | LongPressEventArgs
LongPressEventArgs(Widget source, Vector2 worldPosition, Vector2 localPosition, float elapsedTime) | LongPressEventArgs
Source | GestureEventArgs
WorldPosition | LongPressEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • LongPressGestureDetector

LongPressGestureDetector メンバ一覧

これは全メンバの一覧です。LongPressGestureDetector継承メンバも含んでいます。
GestureDetector() | GestureDetector |
LongPressDetected | LongPressGestureDetector |
LongPressGestureDetector() | LongPressGestureDetector |
MaxDistance | LongPressGestureDetector |
MinPressDuration | LongPressGestureDetector |
OnResetState() | LongPressGestureDetector | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | LongPressGestureDetector | [protected, virtual]
State | GestureDetector |
TargetWidget | GestureDetector |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • MessageDialog

MessageDialog メンバ一覧

これは全メンバの一覧です。MessageDialog継承メンバも含んでいます。
AddChildFirst(Widget child) | ContainerWidget | [virtual]
AddChildLast(Widget child) | ContainerWidget | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BackgroundFilterColor | Dialog |
BackgroundStyle | Dialog |
ButtonPressed | MessageDialog |
Children | ContainerWidget |
Clip | Widget | [protected]
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
CreateAndShow(MessageDialogStyle style, string title, string message) | MessageDialog | [static]
CustomBackgroundColor | Dialog |
CustomBackgroundImage | Dialog |
CustomBackgroundNinePatchMargin | Dialog |
DefaultFocusWidget | Dialog |
Dialog() | Dialog |
Dialog(Effect showEffect, Effect hideEffect) | Dialog |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | MessageDialog | [protected, virtual]
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | MessageDialog |
Hidden | Dialog |
Hide() | Dialog |
Hide(Effect effect) | Dialog |
HideEffect | Dialog |
HideOnTouchOutside | Dialog |
Hiding | Dialog |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | ContainerWidget | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | ContainerWidget | [virtual]
KeyEventReceived | Widget |
LocalToWorld | Widget |
Message | MessageDialog |
MessageDialog() | MessageDialog |
MessageDialog(MessageDialogStyle style, string title, string message) | MessageDialog |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | ContainerWidget | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | MessageDialog | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
Result | Dialog |
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Show() | Dialog |
Show(Effect effect) | Dialog |
ShowEffect | Dialog |
Showing | Dialog |
Shown | Dialog |
ShowTitle | MessageDialog |
Style | MessageDialog |
Title | MessageDialog |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | MessageDialog |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • MessageDialogButtonEventArgs

MessageDialogButtonEventArgs メンバ一覧

これは全メンバの一覧です。MessageDialogButtonEventArgs継承メンバも含んでいます。
MessageDialogButtonEventArgs(MessageDialogResult result) | MessageDialogButtonEventArgs
Result | MessageDialogButtonEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • MotionEvent

MotionEvent メンバ一覧

これは全メンバの一覧です。MotionEvent継承メンバも含んでいます。
Acceleration | MotionEvent
AngularVelocity | MotionEvent
MotionEvent() | MotionEvent
Time | MotionEvent


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • MotionEventArgs

MotionEventArgs メンバ一覧

これは全メンバの一覧です。MotionEventArgs継承メンバも含んでいます。
Acceleration | MotionEventArgs
AngularVelocity | MotionEventArgs
MotionEventArgs() | MotionEventArgs
MotionEventArgs(MotionEvent motionEvent) | MotionEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • MoveEffect

MoveEffect メンバ一覧

これは全メンバの一覧です。MoveEffect継承メンバも含んでいます。
CreateAndStart(Widget widget, float time, float x, float y, MoveEffectInterpolator interpolator) | MoveEffect | [static]
CustomInterpolator | MoveEffect |
Effect() | Effect |
EffectStopped | Effect |
Interpolator | MoveEffect |
MoveEffect() | MoveEffect |
MoveEffect(Widget widget, float time, float x, float y, MoveEffectInterpolator interpolator) | MoveEffect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | Effect | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | MoveEffect | [protected, virtual]
OnStop() | MoveEffect | [protected, virtual]
OnUpdate(float elapsedTime) | MoveEffect | [protected, virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
Start() | Effect |
Stop() | Effect |
Time | MoveEffect |
TotalElapsedTime | Effect |
Widget | Effect |
X | MoveEffect |
Y | MoveEffect |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • PagePanel

PagePanel メンバ一覧

これは全メンバの一覧です。PagePanel継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
AddPage() | PagePanel |
AddPage(Panel panel) | PagePanel |
Alpha | Widget |
Anchors | Widget |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
CurrentPageIndex | PagePanel |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | PagePanel | [protected, virtual]
Enabled | Widget |
Focusable | PagePanel |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
GetPage(int index) | PagePanel |
Height | PagePanel |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
InsertPage(int index, Panel panel) | PagePanel |
InsertPage(int index) | PagePanel |
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | PagePanel | [protected, virtual]
OnResetState() | PagePanel | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | PagePanel | [protected, virtual]
OnUpdate(float elapsedTime) | PagePanel | [protected, virtual]
PageCount | PagePanel |
PagePanel() | PagePanel |
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
RemovePage(Panel panel) | PagePanel |
RemovePageAt(int index) | PagePanel |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
ScrollTo(int index, bool withAnimation) | PagePanel |
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | PagePanel |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • Panel

Panel メンバ一覧

これは全メンバの一覧です。Panel継承メンバも含んでいます。
AddChildFirst(Widget child) | ContainerWidget | [virtual]
AddChildLast(Widget child) | ContainerWidget | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BackgroundColor | Panel |
Children | ContainerWidget |
Clip | Panel |
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | Panel |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | ContainerWidget | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | ContainerWidget | [virtual]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Panel | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Panel() | Panel |
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | ContainerWidget | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | Panel |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • PinchEventArgs

PinchEventArgs メンバ一覧

これは全メンバの一覧です。PinchEventArgs継承メンバも含んでいます。
Angle | PinchEventArgs
Distance | PinchEventArgs
GestureEventArgs(Widget source) | GestureEventArgs
LocalCenterPosition | PinchEventArgs
PinchEventArgs(Widget source, float distance, float scale, float angle, Vector2 worldCenter, Vector2 localCenter) | PinchEventArgs
Scale | PinchEventArgs
Source | GestureEventArgs
WorldCenterPosition | PinchEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • PinchGestureDetector

PinchGestureDetector メンバ一覧

これは全メンバの一覧です。PinchGestureDetector継承メンバも含んでいます。
GestureDetector() | GestureDetector |
MinPinchDistance | PinchGestureDetector |
OnResetState() | PinchGestureDetector | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | PinchGestureDetector | [protected, virtual]
PinchDetected | PinchGestureDetector |
PinchEndDetected | PinchGestureDetector |
PinchGestureDetector() | PinchGestureDetector |
PinchStartDetected | PinchGestureDetector |
State | GestureDetector |
TargetWidget | GestureDetector |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • PopupList

PopupList メンバ一覧

これは全メンバの一覧です。PopupList継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | PopupList | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Font | PopupList |
Height | PopupList |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
ListItemFont | PopupList |
ListItems | PopupList |
ListItemsChanged | PopupList |
ListItemTextColor | PopupList |
ListTitle | PopupList |
ListTitleFont | PopupList |
ListTitleTextColor | PopupList |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | PopupList | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Parent | Widget |
PivotType | Widget |
PopupList() | PopupList |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SelectedIndex | PopupList |
SelectionChanged | PopupList |
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
TextColor | PopupList |
TextShadow | PopupList |
TextTrimming | PopupList |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | PopupList |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • PopupListItemCollection

PopupListItemCollection メンバ一覧

これは全メンバの一覧です。PopupListItemCollection継承メンバも含んでいます。
Add(String item) | PopupListItemCollection
AddRange(IEnumerable< String > items) | PopupListItemCollection
Clear() | PopupListItemCollection
Contains(String item) | PopupListItemCollection
CopyTo(String[] array, int arrayIndex) | PopupListItemCollection
Count | PopupListItemCollection
GetEnumerator() | PopupListItemCollection
IndexOf(String item) | PopupListItemCollection
Insert(int index, String item) | PopupListItemCollection
InsertRange(int index, IEnumerable< String > items) | PopupListItemCollection
IsReadOnly | PopupListItemCollection
PopupListItemCollection() | PopupListItemCollection
PopupListItemCollection(IEnumerable< string > items) | PopupListItemCollection
Remove(String item) | PopupListItemCollection
RemoveAt(int index) | PopupListItemCollection
this | PopupListItemCollection


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • PopupListItemsChangedEventArgs

PopupListItemsChangedEventArgs メンバ一覧

これは全メンバの一覧です。PopupListItemsChangedEventArgs継承メンバも含んでいます。
PopupListItemsChangedEventArgs() PopupListItemsChangedEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • PopupSelectionChangedEventArgs

PopupSelectionChangedEventArgs メンバ一覧

これは全メンバの一覧です。PopupSelectionChangedEventArgs継承メンバも含んでいます。
NewIndex | PopupSelectionChangedEventArgs
OldIndex | PopupSelectionChangedEventArgs
PopupSelectionChangedEventArgs(int oldIndex, int newIndex) | PopupSelectionChangedEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • PressStateChangedEventArgs

PressStateChangedEventArgs メンバ一覧

これは全メンバの一覧です。PressStateChangedEventArgs継承メンバも含んでいます。
ChangedReason | PressStateChangedEventArgs
NewState | PressStateChangedEventArgs
OldState | PressStateChangedEventArgs
PressStateChangedEventArgs(PressStateChangedReason reason, PressState newState, PressState oldState) | PressStateChangedEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • ProgressBar

ProgressBar メンバ一覧

これは全メンバの一覧です。ProgressBar継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | ProgressBar | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | ProgressBar |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | ProgressBar | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
Progress | ProgressBar |
ProgressBar() | ProgressBar |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Style | ProgressBar |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | ProgressBar |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • PushTransition

PushTransition メンバ一覧

これは全メンバの一覧です。PushTransition継承メンバも含んでいます。
CustomInterpolator | PushTransition |
DrawOrder | Transition | [protected]
GetCurrentSceneRenderedImage() | Transition | [protected]
GetNextSceneRenderedImage() | Transition | [protected]
Interpolator | PushTransition |
MoveDirection | PushTransition |
NextScene | Transition | [protected]
OnStart() | PushTransition | [protected, virtual]
OnStop() | PushTransition | [protected, virtual]
OnUpdate(float elapsedTime) | PushTransition | [protected, virtual]
PushTransition() | PushTransition |
PushTransition(float time, FourWayDirection direction, PushTransitionInterpolator interpolator) | PushTransition |
Time | PushTransition |
TotalElapsedTime | Transition |
Transition() | Transition |
TransitionStopped | Transition |
TransitionUIElement | Transition | [protected]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • RootUIElement

RootUIElement メンバ一覧

これは全メンバの一覧です。RootUIElement継承メンバも含んでいます。
AddChildFirst(UIElement child) | UIElement |
AddChildLast(UIElement child) | UIElement |
Alpha | UIElement |
BlendMode | UIElement |
Children | UIElement |
Culling | UIElement |
Dispose() | UIElement |
Dispose(bool disposing) | UIElement | [protected, virtual]
DisposeSelf() | UIElement | [protected, virtual]
GetTexture() | UIElement | [protected]
Image | UIElement |
InsertChildAfter(UIElement child, UIElement prevChild) | UIElement |
InsertChildBefore(UIElement child, UIElement nextChild) | UIElement |
LocalToWorld | UIElement |
Parent | UIElement |
RemoveChild(UIElement child) | UIElement |
Render() | UIElement | [protected, virtual]
RootUIElement(Widget parentWidget) | RootUIElement |
SetPosition(float x, float y) | UIElement |
SetupDrawState() | UIElement | [protected, virtual]
SetupFinalAlpha() | RootUIElement | [protected, virtual]
SetupSortValue() | UIElement | [protected]
ShaderType | UIElement |
TextureFilterMode | UIElement |
TextureWrapMode | UIElement |
Transform3D | UIElement |
UIElement() | UIElement |
Visible | UIElement |
X | UIElement |
Y | UIElement |
ZSort | UIElement |
ZSortOffset | UIElement |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • RootWidget

RootWidget メンバ一覧

これは全メンバの一覧です。RootWidget継承メンバも含んでいます。
AddChildFirst(Widget child) | ContainerWidget | [virtual]
AddChildLast(Widget child) | ContainerWidget | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
Children | ContainerWidget |
Clip | Widget | [protected]
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | RootWidget |
HitTest(Vector2 screenPoint) | RootWidget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | ContainerWidget | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | ContainerWidget | [virtual]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | ContainerWidget | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | RootWidget |
Visible | Widget |
Widget() | Widget |
Width | RootWidget |
X | RootWidget |
Y | RootWidget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • Scene

Scene メンバ一覧

これは全メンバの一覧です。Scene継承メンバも含んでいます。
DefaultFocusWidget | Scene |
DesignHeight | Scene |
DesignWidth | Scene |
FocusWidget | Scene |
Hidden | Scene |
Hiding | Scene |
OnHidden() | Scene | [protected, virtual]
OnHiding() | Scene | [protected, virtual]
OnShowing() | Scene | [protected, virtual]
OnShown() | Scene | [protected, virtual]
OnUpdate(float elapsedTime) | Scene | [protected, virtual]
RootWidget | Scene |
Scene() | Scene |
Showing | Scene |
Shown | Scene |
ShowNavigationBar | Scene |
Title | Scene |
Transition | Scene |
Updated | Scene |
Visible | Scene |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • ScrollBar

ScrollBar メンバ一覧

これは全メンバの一覧です。ScrollBar継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
BarLength | ScrollBar |
BarPosition | ScrollBar |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | ScrollBar | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | ScrollBar |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
Length | ScrollBar |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Orientation | ScrollBar |
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
ScrollBar(ScrollBarOrientation orientation) | ScrollBar |
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | ScrollBar |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • ScrollPanel

ScrollPanel メンバ一覧

これは全メンバの一覧です。ScrollPanel継承メンバも含んでいます。
AddChildFirst(Widget child) | ScrollPanel | [virtual]
AddChildLast(Widget child) | ScrollPanel | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
Children | ScrollPanel |
Clip | Widget | [protected]
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | ScrollPanel |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | ScrollPanel |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
HorizontalScroll | ScrollPanel |
InsertChildAfter(Widget child, Widget prevChild) | ScrollPanel | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | ScrollPanel | [virtual]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | ScrollPanel | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | ScrollPanel | [protected, virtual]
OnUpdate(float elapsedTime) | ScrollPanel | [protected, virtual]
PanelColor | ScrollPanel |
PanelHeight | ScrollPanel |
PanelWidth | ScrollPanel |
PanelX | ScrollPanel |
PanelY | ScrollPanel |
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | ScrollPanel | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
ScrollBarVisibility | ScrollPanel |
ScrollPanel() | ScrollPanel |
ScrollTo(float x, float y, bool withAnimation) | ScrollPanel |
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
VerticalScroll | ScrollPanel |
Visible | Widget |
Widget() | Widget |
Width | ScrollPanel |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • SlideInEffect

SlideInEffect メンバ一覧

これは全メンバの一覧です。SlideInEffect継承メンバも含んでいます。
CreateAndStart(Widget widget, float time, FourWayDirection direction, SlideInEffectInterpolator interpolator) | SlideInEffect | [static]
CustomInterpolator | SlideInEffect |
Effect() | Effect |
EffectStopped | Effect |
Interpolator | SlideInEffect |
MoveDirection | SlideInEffect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | Effect | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | SlideInEffect | [protected, virtual]
OnStop() | SlideInEffect | [protected, virtual]
OnUpdate(float elapsedTime) | SlideInEffect | [protected, virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
SlideInEffect() | SlideInEffect |
SlideInEffect(Widget widget, float time, FourWayDirection direction, SlideInEffectInterpolator interpolator) | SlideInEffect |
Start() | Effect |
Stop() | Effect |
Time | SlideInEffect |
TotalElapsedTime | Effect |
Widget | Effect |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • SlideOutEffect

SlideOutEffect メンバ一覧

これは全メンバの一覧です。SlideOutEffect継承メンバも含んでいます。
CreateAndStart(Widget widget, float time, FourWayDirection direction, SlideOutEffectInterpolator interpolator) | SlideOutEffect | [static]
CustomInterpolator | SlideOutEffect |
Effect() | Effect |
EffectStopped | Effect |
Interpolator | SlideOutEffect |
MoveDirection | SlideOutEffect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | Effect | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | SlideOutEffect | [protected, virtual]
OnStop() | SlideOutEffect | [protected, virtual]
OnUpdate(float elapsedTime) | SlideOutEffect | [protected, virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
SlideOutEffect() | SlideOutEffect |
SlideOutEffect(Widget widget, float time, FourWayDirection direction, SlideOutEffectInterpolator interpolator) | SlideOutEffect |
Start() | Effect |
Stop() | Effect |
Time | SlideOutEffect |
TotalElapsedTime | Effect |
Widget | Effect |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • Slider

Slider メンバ一覧

これは全メンバの一覧です。Slider継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Slider | [protected, virtual]
Enabled | Slider |
FillValue | Slider |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | Slider |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MaxValue | Slider |
MinValue | Slider |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Slider | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Slider | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(Sce.PlayStation.HighLevel.UI.TouchEventCollection touchEvents) | Slider | [protected]
Sce::PlayStation::HighLevel::UI::Widget.OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Orientation | Slider |
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Slider |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Slider() | Slider |
Step | Slider |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Value | Slider |
ValueChanged | Slider |
ValueChangeEventEnabled | Slider |
ValueChanging | Slider |
Visible | Widget |
Widget() | Widget |
Width | Slider |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • SliderValueChangeEventArgs

SliderValueChangeEventArgs メンバ一覧

これは全メンバの一覧です。SliderValueChangeEventArgs継承メンバも含んでいます。
SliderValueChangeEventArgs(float value) | SliderValueChangeEventArgs
Value | SliderValueChangeEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • SlideTransition

SlideTransition メンバ一覧

これは全メンバの一覧です。SlideTransition継承メンバも含んでいます。
CustomInterpolator | SlideTransition |
DrawOrder | Transition | [protected]
GetCurrentSceneRenderedImage() | Transition | [protected]
GetNextSceneRenderedImage() | Transition | [protected]
Interpolator | SlideTransition |
MoveDirection | SlideTransition |
MoveTarget | SlideTransition |
NextScene | Transition | [protected]
OnStart() | SlideTransition | [protected, virtual]
OnStop() | SlideTransition | [protected, virtual]
OnUpdate(float elapsedTime) | SlideTransition | [protected, virtual]
SlideTransition() | SlideTransition |
SlideTransition(float time, FourWayDirection direction, MoveTarget moveTarget, SlideTransitionInterpolator interpolator) | SlideTransition |
Time | SlideTransition |
TotalElapsedTime | Transition |
Transition() | Transition |
TransitionStopped | Transition |
TransitionUIElement | Transition | [protected]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • TapEventArgs

TapEventArgs メンバ一覧

これは全メンバの一覧です。TapEventArgs継承メンバも含んでいます。
GestureEventArgs(Widget source) | GestureEventArgs
LocalPosition | TapEventArgs
Source | GestureEventArgs
TapEventArgs(Widget source, Vector2 worldPosition, Vector2 localPosition) | TapEventArgs
WorldPosition | TapEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • TapGestureDetector

TapGestureDetector メンバ一覧

これは全メンバの一覧です。TapGestureDetector継承メンバも含んでいます。
GestureDetector() | GestureDetector |
MaxDistance | TapGestureDetector |
MaxPressDuration | TapGestureDetector |
OnResetState() | TapGestureDetector | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | TapGestureDetector | [protected, virtual]
State | GestureDetector |
TapDetected | TapGestureDetector |
TapGestureDetector() | TapGestureDetector |
TargetWidget | GestureDetector |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • TextChangedEventArgs

TextChangedEventArgs メンバ一覧

これは全メンバの一覧です。TextChangedEventArgs継承メンバも含んでいます。
NewText | TextChangedEventArgs
OldText | TextChangedEventArgs
TextChangedEventArgs(string oldText, string newText) | TextChangedEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • TextShadowSettings

TextShadowSettings メンバ一覧

これは全メンバの一覧です。TextShadowSettings継承メンバも含んでいます。
Color | TextShadowSettings
HorizontalOffset | TextShadowSettings
TextShadowSettings() | TextShadowSettings
VerticalOffset | TextShadowSettings


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • TiltDropEffect

TiltDropEffect メンバ一覧

これは全メンバの一覧です。TiltDropEffect継承メンバも含んでいます。
CreateAndStart(Widget widget) | TiltDropEffect | [static]
DropDirection | TiltDropEffect |
Effect() | Effect |
EffectStopped | Effect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | Effect | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | TiltDropEffect | [protected, virtual]
OnStop() | TiltDropEffect | [protected, virtual]
OnUpdate(float elapsedTime) | TiltDropEffect | [protected, virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
Speed | TiltDropEffect |
Start() | Effect |
Stop() | Effect |
TiltDropEffect() | TiltDropEffect |
TiltDropEffect(Widget widget) | TiltDropEffect |
TotalElapsedTime | Effect |
Widget | Effect |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • TiltDropTransition

TiltDropTransition メンバ一覧

これは全メンバの一覧です。TiltDropTransition継承メンバも含んでいます。
DrawOrder | Transition | [protected]
DropDirection | TiltDropTransition |
GetCurrentSceneRenderedImage() | Transition | [protected]
GetNextSceneRenderedImage() | Transition | [protected]
NextScene | Transition | [protected]
OnStart() | TiltDropTransition | [protected, virtual]
OnStop() | TiltDropTransition | [protected, virtual]
OnUpdate(float elapsedTime) | TiltDropTransition | [protected, virtual]
Speed | TiltDropTransition |
TiltDropTransition() | TiltDropTransition |
TotalElapsedTime | Transition |
Transition() | Transition |
TransitionStopped | Transition |
TransitionUIElement | Transition | [protected]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • TimePicker

TimePicker メンバ一覧

これは全メンバの一覧です。TimePicker継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | TimePicker |
HitTest(Vector2 screenPoint) | TimePicker | [virtual]
HookChildTouchEvent | Widget | [protected]
Hour | TimePicker |
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LocalToWorld | Widget |
Minute | TimePicker |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | TimePicker |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Time | TimePicker |
TimePicker() | TimePicker |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
ValueChanged | TimePicker |
Visible | Widget |
Widget() | Widget |
Width | TimePicker |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • TimePickerValueChangedEventArgs

TimePickerValueChangedEventArgs メンバ一覧

これは全メンバの一覧です。TimePickerValueChangedEventArgs継承メンバも含んでいます。
NewHour | TimePickerValueChangedEventArgs
NewMinute | TimePickerValueChangedEventArgs
OldHour | TimePickerValueChangedEventArgs
OldMinute | TimePickerValueChangedEventArgs
TimePickerValueChangedEventArgs() | TimePickerValueChangedEventArgs
ToString() | TimePickerValueChangedEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • TouchEvent

TouchEvent メンバ一覧

これは全メンバの一覧です。TouchEvent継承メンバも含んでいます。
FingerID | TouchEvent
LocalPosition | TouchEvent
Source | TouchEvent
Time | TouchEvent
TouchEvent() | TouchEvent
Type | TouchEvent
WorldPosition | TouchEvent


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • TouchEventArgs

TouchEventArgs メンバ一覧

これは全メンバの一覧です。TouchEventArgs継承メンバも含んでいます。
Forward | TouchEventArgs
TouchEventArgs(TouchEventCollection touchEvents) | TouchEventArgs
TouchEvents | TouchEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • TouchEventCollection

TouchEventCollection メンバ一覧

これは全メンバの一覧です。TouchEventCollection継承メンバも含んでいます。
Add(TouchEvent touchEvent) | TouchEventCollection
Contains(TouchEvent touchEvent) | TouchEventCollection
Forward | TouchEventCollection
GetTouchEventByID(int id) | TouchEventCollection
IndexOf(TouchEvent touchEvent) | TouchEventCollection
Insert(int index, TouchEvent touchEvent) | TouchEventCollection
PrimaryTouchEvent | TouchEventCollection
Remove(TouchEvent touchEvent) | TouchEventCollection
this | TouchEventCollection
TouchEventCollection() | TouchEventCollection


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • Transition

Transition メンバ一覧

これは全メンバの一覧です。Transition継承メンバも含んでいます。
DrawOrder | Transition | [protected]
GetCurrentSceneRenderedImage() | Transition | [protected]
GetNextSceneRenderedImage() | Transition | [protected]
NextScene | Transition | [protected]
OnStart() | Transition | [protected, pure virtual]
OnStop() | Transition | [protected, pure virtual]
OnUpdate(float elapsedTime) | Transition | [protected, pure virtual]
TotalElapsedTime | Transition |
Transition() | Transition |
TransitionStopped | Transition |
TransitionUIElement | Transition | [protected]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UIAnimationPlayer

UIAnimationPlayer メンバ一覧

これは全メンバの一覧です。UIAnimationPlayer継承メンバも含んでいます。
AddChildFirst(Widget child) | ContainerWidget | [virtual]
AddChildLast(Widget child) | ContainerWidget | [virtual]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
AnimationStopped | UIAnimationPlayer |
BackgroundColor | Panel |
Children | ContainerWidget |
Clip | Panel |
ContainerWidget() | ContainerWidget |
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
CreateAndPlay(string filePath) | UIAnimationPlayer | [static]
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | UIAnimationPlayer | [protected, virtual]
Enabled | Widget |
EnabledChildrenAnchors | ContainerWidget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | Panel |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | ContainerWidget | [virtual]
InsertChildBefore(Widget child, Widget nextChild) | ContainerWidget | [virtual]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Panel | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Panel() | Panel |
Parent | Widget |
Pause() | UIAnimationPlayer |
Paused | UIAnimationPlayer |
PivotType | Widget |
Play() | UIAnimationPlayer |
Playing | UIAnimationPlayer |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | ContainerWidget | [virtual]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
Repeating | UIAnimationPlayer |
ReplaceWidget(string name, Widget widget) | UIAnimationPlayer |
ResetState(bool includeSelf) | Widget | [protected]
Resume() | UIAnimationPlayer |
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
Stop() | UIAnimationPlayer |
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
UIAnimationPlayer(string filePath) | UIAnimationPlayer |
Visible | Widget |
Widget() | Widget |
Width | Panel |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UIDebug

UIDebug メンバ一覧

これは全メンバの一覧です。UIDebug継承メンバも含んでいます。
Assert(bool condition) | UIDebug | [static]
Assert(bool condition, string message) | UIDebug | [static]
Assert(bool condition, string message, string detailMessage) | UIDebug | [static]
Assert(bool condition, string message, string detailMessageFormat, params Object[] args) | UIDebug | [static]
DumpSceneGraph(string filename) | UIDebug | [static]
EnableRecordUncachedTexture() | UIDebug | [static]
ExportAllImageAsset() | UIDebug | [static]
ExportImageAsset(ImageAsset imageAsset, string filename) | UIDebug | [static]
ImageExportAlbumName | UIDebug | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UIElement

UIElement メンバ一覧

これは全メンバの一覧です。UIElement継承メンバも含んでいます。
AddChildFirst(UIElement child) | UIElement |
AddChildLast(UIElement child) | UIElement |
Alpha | UIElement |
BlendMode | UIElement |
Children | UIElement |
Culling | UIElement |
Dispose() | UIElement |
Dispose(bool disposing) | UIElement | [protected, virtual]
DisposeSelf() | UIElement | [protected, virtual]
GetTexture() | UIElement | [protected]
Image | UIElement |
InsertChildAfter(UIElement child, UIElement prevChild) | UIElement |
InsertChildBefore(UIElement child, UIElement nextChild) | UIElement |
LocalToWorld | UIElement |
Parent | UIElement |
RemoveChild(UIElement child) | UIElement |
Render() | UIElement | [protected, virtual]
SetPosition(float x, float y) | UIElement |
SetupDrawState() | UIElement | [protected, virtual]
SetupFinalAlpha() | UIElement | [protected, virtual]
SetupSortValue() | UIElement | [protected]
ShaderType | UIElement |
TextureFilterMode | UIElement |
TextureWrapMode | UIElement |
Transform3D | UIElement |
UIElement() | UIElement |
Visible | UIElement |
X | UIElement |
Y | UIElement |
ZSort | UIElement |
ZSortOffset | UIElement |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UIFont

UIFont メンバ一覧

これは全メンバの一覧です。UIFont継承メンバも含んでいます。
AliasName | UIFont |
ClearCache() | UIFont | [static]
Equals(object obj) | UIFont |
Equals(UIFont uifont) | UIFont |
FileName | UIFont |
GetFont() | UIFont |
GetHashCode() | UIFont |
Size | UIFont |
Style | UIFont |
ToString() | UIFont |
UIFont() | UIFont |
UIFont(string filename, int size, FontStyle style) | UIFont |
UIFont(FontAlias alias, int size, FontStyle style) | UIFont |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UIMotion

UIMotion メンバ一覧

これは全メンバの一覧です。UIMotion継承メンバも含んでいます。
CreateAndStart(Widget widget, string filePath) | UIMotion | [static]
Effect() | Effect |
EffectStopped | Effect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | UIMotion | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | UIMotion | [protected, virtual]
OnStop() | UIMotion | [protected, virtual]
OnUpdate(float elapsedTime) | UIMotion | [protected, virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
Start() | Effect |
Stop() | UIMotion |
TotalElapsedTime | Effect |
UIMotion(Widget widget, string filePath) | UIMotion |
Widget | Effect |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UIPrimitive

UIPrimitive メンバ一覧

これは全メンバの一覧です。UIPrimitive継承メンバも含んでいます。
AddChildFirst(UIElement child) | UIElement |
AddChildLast(UIElement child) | UIElement |
Alpha | UIElement |
BlendMode | UIElement |
Children | UIElement |
Culling | UIElement |
Dispose() | UIElement |
Dispose(bool disposing) | UIElement | [protected, virtual]
DisposeSelf() | UIPrimitive | [protected, virtual]
DrawMode | UIPrimitive |
GetTexture() | UIElement | [protected]
GetVertex(int index) | UIPrimitive |
Image | UIElement |
IndexCount | UIPrimitive |
InsertChildAfter(UIElement child, UIElement prevChild) | UIElement |
InsertChildBefore(UIElement child, UIElement nextChild) | UIElement |
LocalToWorld | UIElement |
MaxIndexCount | UIPrimitive |
MaxVertexCount | UIPrimitive |
Parent | UIElement |
RemoveChild(UIElement child) | UIElement |
Render() | UIPrimitive | [protected, virtual]
SetIndices(ushort[] indices) | UIPrimitive |
SetPosition(float x, float y) | UIElement |
SetupDrawState() | UIElement | [protected, virtual]
SetupFinalAlpha() | UIElement | [protected, virtual]
SetupSortValue() | UIElement | [protected]
ShaderType | UIElement |
TextureFilterMode | UIElement |
TextureWrapMode | UIElement |
Transform3D | UIElement |
UIElement() | UIElement |
UIPrimitive(DrawMode drawMode, int maxVertexCount) | UIPrimitive |
UIPrimitive(DrawMode drawMode, int maxVertexCount, int maxIndexCount) | UIPrimitive |
VertexCount | UIPrimitive |
Visible | UIElement |
X | UIElement |
Y | UIElement |
ZSort | UIElement |
ZSortOffset | UIElement |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UIPrimitiveUtility

UIPrimitiveUtility メンバ一覧

これは全メンバの一覧です。UIPrimitiveUtility継承メンバも含んでいます。
SetupHorizontalThreePatch(UIPrimitive primitive, float width, float height, float offsetX, float offsetY, float leftMargin, float rightMargin) | UIPrimitiveUtility | [static]
SetupNinePatch(UIPrimitive primitive, float width, float height, float offsetX, float offsetY, NinePatchMargin ninePatchMargin) | UIPrimitiveUtility | [static]
SetupNinePatch(UIPrimitive primitive, float width, float height, float offsetX, float offsetY, ImageRect imageRect, NinePatchMargin ninePatchMargin) | UIPrimitiveUtility | [static]
SetupVerticalThreePatch(UIPrimitive primitive, float width, float height, float offsetX, float offsetY, float topMargin, float bottomMargin) | UIPrimitiveUtility | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UIPrimitiveVertex

UIPrimitiveVertex メンバ一覧

これは全メンバの一覧です。UIPrimitiveVertex継承メンバも含んでいます。
Color | UIPrimitiveVertex
Position3D | UIPrimitiveVertex
SetPosition(float x, float y) | UIPrimitiveVertex
SetPosition(float x, float y, float z) | UIPrimitiveVertex
U | UIPrimitiveVertex
UIPrimitiveVertex() | UIPrimitiveVertex
V | UIPrimitiveVertex
X | UIPrimitiveVertex
Y | UIPrimitiveVertex
Z | UIPrimitiveVertex


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UISprite

UISprite メンバ一覧

これは全メンバの一覧です。UISprite継承メンバも含んでいます。
AddChildFirst(UIElement child) | UIElement |
AddChildLast(UIElement child) | UIElement |
Alpha | UIElement |
BlendMode | UIElement |
Children | UIElement |
Culling | UIElement |
Dispose() | UIElement |
Dispose(bool disposing) | UIElement | [protected, virtual]
DisposeSelf() | UISprite | [protected, virtual]
GetTexture() | UIElement | [protected]
GetUnit(int index) | UISprite |
Image | UIElement |
InsertChildAfter(UIElement child, UIElement prevChild) | UIElement |
InsertChildBefore(UIElement child, UIElement nextChild) | UIElement |
LocalToWorld | UIElement |
MaxUnitCount | UISprite |
Parent | UIElement |
RemoveChild(UIElement child) | UIElement |
Render() | UISprite | [protected, virtual]
SetPosition(float x, float y) | UIElement |
SetupDrawState() | UIElement | [protected, virtual]
SetupFinalAlpha() | UIElement | [protected, virtual]
SetupSortValue() | UIElement | [protected]
ShaderType | UIElement |
TextureFilterMode | UIElement |
TextureWrapMode | UIElement |
Transform3D | UIElement |
UIElement() | UIElement |
UISprite(int maxUnitCount) | UISprite |
UnitCount | UISprite |
Visible | UIElement |
X | UIElement |
Y | UIElement |
ZSort | UIElement |
ZSortOffset | UIElement |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UISpriteUnit

UISpriteUnit メンバ一覧

これは全メンバの一覧です。UISpriteUnit継承メンバも含んでいます。
Color | UISpriteUnit
Height | UISpriteUnit
Position3D | UISpriteUnit
SetPosition(float x, float y) | UISpriteUnit
SetSize(float width, float height) | UISpriteUnit
U1 | UISpriteUnit
U2 | UISpriteUnit
UISpriteUnit() | UISpriteUnit
V1 | UISpriteUnit
V2 | UISpriteUnit
Width | UISpriteUnit
X | UISpriteUnit
Y | UISpriteUnit
Z | UISpriteUnit


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UISpriteUtility

UISpriteUtility メンバ一覧

これは全メンバの一覧です。UISpriteUtility継承メンバも含んでいます。
SetupHorizontalThreePatch(UISprite sprite, float width, float height, float leftMargin, float rightMargin) | UISpriteUtility | [static]
SetupNinePatch(UISprite sprite, float width, float height, float offsetX, float offsetY, NinePatchMargin ninePatchMargin) | UISpriteUtility | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UISystem

UISystem メンバ一覧

これは全メンバの一覧です。UISystem継承メンバも含んでいます。
CancelKeyEvents() | UISystem | [static]
CurrentScene | UISystem | [static]
CurrentTime | UISystem | [static]
EnabledFocus | UISystem | [static]
FindHitWidget(Vector2 screenPoint) | UISystem | [static]
FocusActive | UISystem | [static]
FocusBlendMode | UISystem | [static]
FocusFilterColor | UISystem | [static]
FocusTimeout | UISystem | [static]
FramebufferHeight | UISystem | [static]
FramebufferWidth | UISystem | [static]
GamePadData | UISystem | [static]
GetShaderProgram(ShaderType type) | UISystem | [static]
GraphicsContext | UISystem | [static]
Initialize(GraphicsContext graphics) | UISystem | [static]
Initialize(GraphicsContext graphics, float pixelDensity) | UISystem | [static]
KeyLongPressTime | UISystem | [static]
KeyReceiverWidget | UISystem | [static]
KeyRepeatIntervalTime | UISystem | [static]
KeyRepeatStartTime | UISystem | [static]
MotionData | UISystem | [static]
PixelDensity | UISystem | [static]
PopScene() | UISystem | [static]
PushScene(Scene newScene) | UISystem | [static]
Render() | UISystem | [static]
ResetStateAll() | UISystem | [static]
ScenePopTransition | UISystem | [static]
ScenePushTransition | UISystem | [static]
SetScene(Scene newScene) | UISystem | [static]
SetScene(Scene newScene, Transition transition) | UISystem | [static]
SuppressFocusKeyEvent | UISystem | [static]
Terminate() | UISystem | [static]
Update(List< TouchData > touchDataList) | UISystem | [static]
Update(List< TouchData > touchDataList, ref GamePadData gamePadData) | UISystem | [static]
Update(List< TouchData > touchDataList, ref MotionData motionData) | UISystem | [static]
Update(List< TouchData > touchDataList, ref GamePadData gamePadData, ref MotionData motionData) | UISystem | [static]
ViewProjectionMatrix | UISystem | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UpdateEventArgs

UpdateEventArgs メンバ一覧

これは全メンバの一覧です。UpdateEventArgs継承メンバも含んでいます。
ElapsedTime | UpdateEventArgs
UpdateEventArgs(float elapsedTime) | UpdateEventArgs


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • Widget

Widget メンバ一覧

これは全メンバの一覧です。Widget継承メンバも含んでいます。
AddChildFirst(Widget child) | Widget | [protected]
AddChildLast(Widget child) | Widget | [protected]
AddGestureDetector(GestureDetector gestureDetector) | Widget |
Alpha | Widget |
Anchors | Widget |
Children | Widget | [protected]
Clip | Widget | [protected]
ConvertLocalToOtherWidget(Vector2 localPoint, Widget targetWidget) | Widget |
ConvertLocalToOtherWidget(float x, float y, Widget targetWidget) | Widget |
ConvertLocalToScreen(Vector2 localPoint) | Widget |
ConvertLocalToScreen(float localX, float localY) | Widget |
ConvertScreenToLocal(Vector2 screenPoint) | Widget |
ConvertScreenToLocal(float screenX, float screenY) | Widget |
Dispose() | Widget |
Dispose(bool disposing) | Widget | [protected, virtual]
DisposeSelf() | Widget | [protected, virtual]
Enabled | Widget |
Focusable | Widget |
FocusChanged | Widget |
FocusCustomSettings | Widget |
Focused | Widget |
FocusStyle | Widget |
Height | Widget |
HitTest(Vector2 screenPoint) | Widget | [virtual]
HookChildTouchEvent | Widget | [protected]
InsertChildAfter(Widget child, Widget prevChild) | Widget | [protected]
InsertChildBefore(Widget child, Widget nextChild) | Widget | [protected]
KeyEventReceived | Widget |
LocalToWorld | Widget |
MotionEventReceived | Widget |
Name | Widget |
OnFocusChanged(FocusChangedEventArgs args) | Widget | [protected, virtual]
OnKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnMotionEvent(MotionEvent motionEvent) | Widget | [protected, virtual]
OnPressStateChanged(PressStateChangedEventArgs e) | Widget | [protected, virtual]
OnPreviewKeyEvent(KeyEvent keyEvent) | Widget | [protected, virtual]
OnResetState() | Widget | [protected, virtual]
OnTouchEvent(TouchEventCollection touchEvents) | Widget | [protected, virtual]
OnUpdate(float elapsedTime) | Widget | [protected, virtual]
Parent | Widget |
PivotType | Widget |
Pressable | Widget | [protected]
PressState | Widget | [protected]
PreviewKeyEventReceived | Widget |
PriorityHit | Widget |
RemoveChild(Widget child) | Widget | [protected]
RemoveGestureDetector(GestureDetector gestureDetector) | Widget |
Render() | Widget | [protected, virtual]
RenderToFrameBuffer(FrameBuffer frameBuffer) | Widget |
RenderToFrameBuffer(FrameBuffer frameBuffer, Matrix4 transform) | Widget |
RenderToTexture(Texture2D texture) | Widget |
RenderToTexture(Texture2D texture, Matrix4 transform) | Widget |
ResetState(bool includeSelf) | Widget | [protected]
RootUIElement | Widget | [protected]
SearchNextFocus(FourWayDirection direction) | Widget | [protected]
SearchNextFocusFromChild(FourWayDirection direction, Widget currentFocusWidget) | Widget | [protected]
SetFocus(bool active) | Widget |
SetPosition(float x, float y) | Widget | [virtual]
SetSize(float width, float height) | Widget | [virtual]
SetupFinalAlpha() | Widget | [protected, virtual]
ToString() | Widget |
TouchEventReceived | Widget |
TouchLeaveBehavior | Widget | [protected]
TouchResponse | Widget |
Transform3D | Widget |
Visible | Widget |
Widget() | Widget |
Width | Widget |
X | Widget |
Y | Widget |
ZSort | Widget |
ZSortOffset | Widget |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • ZoomEffect

ZoomEffect メンバ一覧

これは全メンバの一覧です。ZoomEffect継承メンバも含んでいます。
CreateAndStart(Widget widget, float time, float scale, ZoomEffectInterpolator interpolator) | ZoomEffect | [static]
CustomInterpolator | ZoomEffect |
Effect() | Effect |
EffectStopped | Effect |
Interpolator | ZoomEffect |
OnPause() | Effect | [protected, virtual]
OnRepeat() | Effect | [protected, virtual]
OnResume() | Effect | [protected, virtual]
OnStart() | ZoomEffect | [protected, virtual]
OnStop() | ZoomEffect | [protected, virtual]
OnUpdate(float elapsedTime) | ZoomEffect | [protected, virtual]
Pause() | Effect |
Paused | Effect |
Playing | Effect |
Repeating | Effect |
Resume() | Effect |
Start() | Effect |
Stop() | Effect |
TargetScaleX | ZoomEffect |
TargetScaleY | ZoomEffect |
TargetScaleZ | ZoomEffect |
Time | ZoomEffect |
TotalElapsedTime | Effect |
Widget | Effect |
ZoomEffect() | ZoomEffect |
ZoomEffect(Widget widget, float time, float scale, ZoomEffectInterpolator interpolator) | ZoomEffect |


クラス階層

この継承一覧はおおまかにはソートされていますが、完全にアルファベット順でソートされてはいません。
  • AccountInformation
  • Shell.Action
  • ActionBase
    • ActionWithDuration
      • ActionTweenGeneric< T >
        • ActionTweenGenericVector2
          • MoveBy
          • MoveTo
          • SkewBy
          • SkewTo
        • ActionTweenGenericVector2Rotation
          • RotateBy
          • RotateTo
        • ActionTweenGenericVector2Scale
          • ScaleBy
          • ScaleTo
        • ActionTweenGenericVector4
          • TintBy
          • TintTo
      • DelayTime
    • CallFunc
    • Repeat
    • RepeatForever
    • Sequence
  • ActionManager
  • AnimationUtility
  • DrawHelpers.ArrowParams
  • BasicArrays
  • BasicBone
  • BasicFCurve
  • BasicLayer
  • BasicMaterial
  • BasicMesh
  • BasicModel
  • BasicMotion
  • BasicParameters
  • BasicPart
  • BasicProgramContainer
  • BasicTexture
  • BasicTextureContainer
  • Bgm
  • BgmPlayer
  • BlendFunc
  • BlendMode
  • Input2.ButtonState
  • Byte2
  • Byte2N
  • Byte3
  • Byte3N
  • Byte4
  • Byte4N
  • ByteN
  • TextureInfo.CachedTileData
  • Camera
  • CameraInfo
  • CameraSize
  • FontMap.CharData
  • CharMetrics
  • Clipboard
  • Colors
  • CullFace
  • CustomButtonImageSettings
  • CustomCheckBoxImageSettings
  • DatePickerValueChangedEventArgs
  • DebugFlags
  • GraphicsContextAlpha.DebugStats_
  • DepthFunc
  • DialogEventArgs
  • Director
  • DrawHelpers
  • Effect
    • BunjeeJumpEffect
    • DelayedExecutor
    • FadeInEffect
    • FadeOutEffect
    • FlipBoardEffect
    • JumpFlipEffect
    • MoveEffect
    • SlideInEffect
    • SlideOutEffect
    • TiltDropEffect
    • UIMotion
    • ZoomEffect
  • EmbeddedDebugFontData
  • ParticleSystem.EmitterParams
  • FMath
  • FocusChangedEventArgs
  • FocusCustomSettings
  • Font
  • FontMap
  • FontMetrics
  • FrameBuffer
  • Camera.FrameChangedEventArgs
  • Frustum
  • GamePad
  • Input2.GamePad
  • GamePadData
  • Input2.GamePadData
  • GestureDetector
    • DoubleTapGestureDetector
    • DragGestureDetector
    • FlickGestureDetector
    • LongPressGestureDetector
    • PinchGestureDetector
    • TapGestureDetector
  • GestureEventArgs
    • DoubleTapEventArgs
    • DragEventArgs
    • FlickEventArgs
    • LongPressEventArgs
    • PinchEventArgs
    • TapEventArgs
  • GraphicsCaps
  • GraphicsContext
  • GraphicsContextAlpha
  • Half
  • Half2
  • Half3
  • Half4
  • ICamera
    • Camera2D
    • Camera3D
  • ICollisionBasics
    • Bounds2
    • ConvexPoly2
    • Plane2
    • Sphere2
  • ICommonDialog
    • CameraImportDialog
    • PhotoImportDialog
    • TextInputDialog
    • InAppPurchaseDialog
  • Image
  • ImageAsset
  • ImageColor
  • ImagePosition
  • ImageRect
  • ImageSize
  • ImmediateMode< T >
  • ImmediateModeQuads< T >
  • InAppPurchaseProduct
  • InAppPurchaseProductList
  • Input2
  • ParticleSystem.IParticleShader
    • ParticleSystem.ParticleShaderDefault
  • SpriteRenderer.ISpriteShader
    • SpriteRenderer.DefaultFontShader_
    • SpriteRenderer.DefaultShader_
  • KeyEvent
  • KeyEventArgs
  • ListPanelItemSelectChangedEventArgs
  • ListSection
  • ListSectionCollection
  • TRS.Local
  • Location
  • LocationData
  • Math
  • Matrix3
  • Matrix4
  • MatrixStack
  • MessageDialogButtonEventArgs
  • MinimizedEventArgs
  • Motion
  • MotionData
  • MotionEvent
  • MotionEventArgs
  • Network
  • NetworkRequest
  • NetworkResponse
  • NetworkStreamReader
  • NinePatchMargin
  • Node
    • Label
    • Particles
    • Plane3D
    • RawSpriteTileList
    • Scene
      • TransitionScene
        • TransitionFadeBase
          • TransitionCrossFade
          • TransitionDirectionalFade
          • TransitionSolidFade
    • SpriteBase
      • SpriteTile
      • SpriteUV
    • SpriteList
  • ParticleSystem.Particle
  • ParticleSystem
  • PersistentMemory
  • PhysicsBody
  • PhysicsJoint
  • PhysicsScene
  • PhysicsShape
  • PhysicsSolverPair
  • PhysicsSpring
  • PhysicsUtility
  • Camera.PictureStateChangedEventArgs
  • PitchRoll
  • PixelBuffer
    • ColorBuffer
    • DepthBuffer
    • Texture
      • Texture2D
      • TextureCube
  • PolygonOffset
  • PopupListItemCollection
  • PopupListItemsChangedEventArgs
  • PopupSelectionChangedEventArgs
  • PressStateChangedEventArgs
  • Primitive
  • Quaternion
  • Math.RandGenerator
  • RawSpriteTile
  • RayHit
  • Rectangle
  • RenderTarget
  • RestoredEventArgs
  • Rgb565
  • Rgba
  • Rgba4444
  • Rgba5551
  • RollPitch
  • Scene
  • Scheduler
  • ShaderProgram
    • BasicProgram
  • ShaderProgramOption
  • Shell
  • Short2
  • Short2N
  • Short3
  • Short3N
  • Short4
  • Short4N
  • ShortN
  • ParticleSystem.SimulationParams
  • SliderValueChangeEventArgs
  • Sound
  • SoundPlayer
  • SpriteRenderer
  • StencilFunc
  • StencilOp
  • SystemEvents
  • SystemMemory
  • SystemParameters
  • TextChangedEventArgs
  • TextShadowSettings
  • TextureFilter
  • TextureInfo
  • TextureWrap
  • TimePickerValueChangedEventArgs
  • Timer
  • Input2.Touch
  • Touch
  • TouchData
  • Input2.TouchData
  • TouchEvent
  • TouchEventArgs
  • TouchEventCollection
  • Transition
    • CrossFadeTransition
    • FlipBoardTransition
    • JumpFlipTransition
    • PushTransition
    • SlideTransition
    • TiltDropTransition
  • TRS
  • UByte2
  • UByte2N
  • UByte3
  • UByte3N
  • UByte4
  • UByte4N
  • UByteN
  • UIColor
  • UIDebug
  • UIElement
    • RootUIElement
    • UIPrimitive
    • UISprite
  • UIFont
  • UIPrimitiveUtility
  • UIPrimitiveVertex
  • UISpriteUnit
  • UISpriteUtility
  • UISystem
  • UpdateEventArgs
  • UShort2
  • UShort2N
  • UShort3
  • UShort3N
  • UShort4
  • UShort4N
  • UShortN
  • Vector2
  • Vector2i
  • Vector3
  • Vector3i
  • Vector4
  • DrawHelpers.Vertex
  • VertexBuffer
  • Widget
    • AnimationImageBox
    • BusyIndicator
    • Button
    • CheckBox
    • ContainerWidget
      • Dialog
        • MessageDialog
      • GridListPanel
      • ListPanel
      • LiveScrollPanel
      • Panel
        • ListPanelItem
        • LiveJumpPanel
        • LiveSpringPanel
        • UIAnimationPlayer
      • RootWidget
      • ScrollPanel
    • DatePicker
    • EditableText
    • ImageBox
    • Label
    • LiveFlipPanel
    • LiveListPanel
    • LiveSphere
    • PagePanel
    • PopupList
    • ProgressBar
    • ScrollBar
    • Slider
    • TimePicker


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Environment
  • ICommonDialog

ICommonDialog メンバ一覧

これは全メンバの一覧です。ICommonDialog継承メンバも含んでいます。
Abort() | ICommonDialog
Open() | ICommonDialog
Result | ICommonDialog
State | ICommonDialog


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • ICamera

ICamera メンバ一覧

これは全メンバの一覧です。ICamera継承メンバも含んでいます。
CalcBounds() | ICamera
DebugDraw(float step) | ICamera
GetPixelSize() | ICamera
GetTouchPos(int nth=0, bool prev=false) | ICamera
GetTransform() | ICamera
Navigate(int control) | ICamera
NormalizedToWorld(Vector2 bottom_left_minus_1_minus_1_top_left_1_1_normalized_screen_pos) | ICamera
Pop() | ICamera
Push() | ICamera
SetAspectFromViewport() | ICamera
SetTouchPlaneMatrix(Matrix4 mat) | ICamera
SetViewFromViewport() | ICamera


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • ICollisionBasics

ICollisionBasics メンバ一覧

これは全メンバの一覧です。ICollisionBasics継承メンバも含んでいます。
ClosestSurfacePoint(Vector2 point, out Vector2 ret, out float sign) | ICollisionBasics
IsInside(Vector2 point) | ICollisionBasics
NegativeClipSegment(ref Vector2 A, ref Vector2 B) | ICollisionBasics
SignedDistance(Vector2 point) | ICollisionBasics


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • SpriteRenderer
  • ISpriteShader

SpriteRenderer.ISpriteShader メンバ一覧

これは全メンバの一覧です。SpriteRenderer.ISpriteShader継承メンバも含んでいます。
GetShaderProgram() | SpriteRenderer.ISpriteShader
SetColor(ref Vector4 value) | SpriteRenderer.ISpriteShader
SetMVP(ref Matrix4 value) | SpriteRenderer.ISpriteShader
SetUVTransform(ref Vector4 value) | SpriteRenderer.ISpriteShader


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • ParticleSystem
  • IParticleShader

ParticleSystem.IParticleShader メンバ一覧

これは全メンバの一覧です。ParticleSystem.IParticleShader継承メンバも含んでいます。
GetShaderProgram() | ParticleSystem.IParticleShader
SetColor(ref Vector4 value) | ParticleSystem.IParticleShader
SetMVP(ref Matrix4 value) | ParticleSystem.IParticleShader


パッケージ

これはパッケージ一覧です。
Sce.PlayStation.Core
Sce.PlayStation.Core.Audio
Sce.PlayStation.Core.Device
Sce.PlayStation.Core.Environment
Sce.PlayStation.Core.Graphics
Sce.PlayStation.Core.Imaging
Sce.PlayStation.Core.Input
Sce.PlayStation.Core.Services
Sce.PlayStation.HighLevel.GameEngine2D
Sce.PlayStation.HighLevel.GameEngine2D.Base
Sce.PlayStation.HighLevel.Model
Sce.PlayStation.HighLevel.Physics2D
Sce.PlayStation.HighLevel.UI


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Byte2

Byte2 メンバ一覧

これは全メンバの一覧です。Byte2継承メンバも含んでいます。
Byte2(int x, int y) | Byte2 |
Byte2(Vector2 v) | Byte2 |
Equals(Byte2 v) | Byte2 |
Equals(Object o) | Byte2 |
GetHashCode() | Byte2 |
operator!=(Byte2 v1, Byte2 v2) | Byte2 | [static]
operator==(Byte2 v1, Byte2 v2) | Byte2 | [static]
ToString() | Byte2 |
ToVector2() | Byte2 |
X | Byte2 |
Y | Byte2 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Byte2N

Byte2N メンバ一覧

これは全メンバの一覧です。Byte2N継承メンバも含んでいます。
Byte2N(float x, float y) | Byte2N |
Byte2N(Vector2 v) | Byte2N |
Equals(Byte2N v) | Byte2N |
Equals(Object o) | Byte2N |
GetHashCode() | Byte2N |
operator!=(Byte2N v1, Byte2N v2) | Byte2N | [static]
operator==(Byte2N v1, Byte2N v2) | Byte2N | [static]
ToString() | Byte2N |
ToVector2() | Byte2N |
X | Byte2N |
Y | Byte2N |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Byte3

Byte3 メンバ一覧

これは全メンバの一覧です。Byte3継承メンバも含んでいます。
Byte3(int x, int y, int z) | Byte3 |
Byte3(Vector3 v) | Byte3 |
Equals(Byte3 v) | Byte3 |
Equals(Object o) | Byte3 |
GetHashCode() | Byte3 |
operator!=(Byte3 v1, Byte3 v2) | Byte3 | [static]
operator==(Byte3 v1, Byte3 v2) | Byte3 | [static]
ToString() | Byte3 |
ToVector3() | Byte3 |
X | Byte3 |
Y | Byte3 |
Z | Byte3 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Byte3N

Byte3N メンバ一覧

これは全メンバの一覧です。Byte3N継承メンバも含んでいます。
Byte3N(float x, float y, float z) | Byte3N |
Byte3N(Vector3 v) | Byte3N |
Equals(Byte3N v) | Byte3N |
Equals(Object o) | Byte3N |
GetHashCode() | Byte3N |
operator!=(Byte3N v1, Byte3N v2) | Byte3N | [static]
operator==(Byte3N v1, Byte3N v2) | Byte3N | [static]
ToString() | Byte3N |
ToVector3() | Byte3N |
X | Byte3N |
Y | Byte3N |
Z | Byte3N |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Byte4

Byte4 メンバ一覧

これは全メンバの一覧です。Byte4継承メンバも含んでいます。
Byte4(int x, int y, int z, int w) | Byte4 |
Byte4(Vector4 v) | Byte4 |
Equals(Byte4 v) | Byte4 |
Equals(Object o) | Byte4 |
GetHashCode() | Byte4 |
operator!=(Byte4 v1, Byte4 v2) | Byte4 | [static]
operator==(Byte4 v1, Byte4 v2) | Byte4 | [static]
ToString() | Byte4 |
ToVector4() | Byte4 |
W | Byte4 |
X | Byte4 |
Y | Byte4 |
Z | Byte4 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Byte4N

Byte4N メンバ一覧

これは全メンバの一覧です。Byte4N継承メンバも含んでいます。
Byte4N(float x, float y, float z, float w) | Byte4N |
Byte4N(Vector4 v) | Byte4N |
Equals(Byte4N v) | Byte4N |
Equals(Object o) | Byte4N |
GetHashCode() | Byte4N |
operator!=(Byte4N v1, Byte4N v2) | Byte4N | [static]
operator==(Byte4N v1, Byte4N v2) | Byte4N | [static]
ToString() | Byte4N |
ToVector4() | Byte4N |
W | Byte4N |
X | Byte4N |
Y | Byte4N |
Z | Byte4N |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • ByteN

ByteN メンバ一覧

これは全メンバの一覧です。ByteN継承メンバも含んでいます。
Bits | ByteN |
ByteN(float f) | ByteN |
Equals(ByteN v) | ByteN |
Equals(Object o) | ByteN |
GetHashCode() | ByteN |
operator ByteN(float f) | ByteN | [explicit, static]
operator float(ByteN v) | ByteN | [static]
operator!=(ByteN v1, ByteN v2) | ByteN | [static]
operator==(ByteN v1, ByteN v2) | ByteN | [static]
ToFloat() | ByteN |
ToString() | ByteN |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Device
  • CameraInfo

CameraInfo メンバ一覧

これは全メンバの一覧です。CameraInfo継承メンバも含んでいます。
Facing | CameraInfo
SupportedPictureSizes | CameraInfo
SupportedPreviewSizes | CameraInfo


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Device
  • CameraSize

CameraSize メンバ一覧

これは全メンバの一覧です。CameraSize継承メンバも含んでいます。
CameraSize(int width, int height) | CameraSize
Height | CameraSize
Width | CameraSize


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Device
  • LocationData

LocationData メンバ一覧

これは全メンバの一覧です。LocationData継承メンバも含んでいます。
Accuracy | LocationData
Altitude | LocationData
Bearing | LocationData
DeviceType | LocationData
HasAccuracy | LocationData
HasAltitude | LocationData
HasBearing | LocationData
HasLatitude | LocationData
HasLongitude | LocationData
HasSpeed | LocationData
HasTime | LocationData
Latitude | LocationData
Longitude | LocationData
Speed | LocationData
Time | LocationData


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Environment
  • Shell
  • Action

Shell.Action メンバ一覧

これは全メンバの一覧です。Shell.Action継承メンバも含んでいます。
BrowserAction(string url) Shell.Action [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • BlendFunc

BlendFunc メンバ一覧

これは全メンバの一覧です。BlendFunc継承メンバも含んでいます。
BlendFunc(BlendFuncMode mode, BlendFuncFactor srcFactor, BlendFuncFactor dstFactor) | BlendFunc
DstFactor | BlendFunc
Mode | BlendFunc
Set(BlendFuncMode mode, BlendFuncFactor srcFactor, BlendFuncFactor dstFactor) | BlendFunc
SrcFactor | BlendFunc


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • CullFace

CullFace メンバ一覧

これは全メンバの一覧です。CullFace継承メンバも含んでいます。
CullFace(CullFaceMode mode, CullFaceDirection direction) | CullFace
Direction | CullFace
Mode | CullFace
Set(CullFaceMode mode, CullFaceDirection direction) | CullFace


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • DepthFunc

DepthFunc メンバ一覧

これは全メンバの一覧です。DepthFunc継承メンバも含んでいます。
DepthFunc(DepthFuncMode mode, bool writeMask) | DepthFunc
Mode | DepthFunc
Set(DepthFuncMode mode, bool writeMask) | DepthFunc
WriteMask | DepthFunc


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • GraphicsCaps

GraphicsCaps メンバ一覧

これは全メンバの一覧です。GraphicsCaps継承メンバも含んでいます。
MaxAliasedLineWidth | GraphicsCaps
MaxAliasedPointSize | GraphicsCaps
MaxCubeMapTextureSize | GraphicsCaps
MaxFragmentUniformVectors | GraphicsCaps
MaxRenderbufferSize | GraphicsCaps
MaxTextureImageUnits | GraphicsCaps
MaxTextureMaxAnisotropy | GraphicsCaps
MaxTextureSize | GraphicsCaps
MaxVaryingVectors | GraphicsCaps
MaxVertexAttribs | GraphicsCaps
MaxVertexUniformVectors | GraphicsCaps
MaxViewportHeight | GraphicsCaps
MaxViewportWidth | GraphicsCaps
MinAliasedLineWidth | GraphicsCaps
MinAliasedPointSize | GraphicsCaps
SupportDepth24 | GraphicsCaps
SupportPackedDepthStencil | GraphicsCaps
SupportRgb8Rgba8 | GraphicsCaps
SupportTextureFilterAnisotropic | GraphicsCaps
SupportTextureHalfFloat | GraphicsCaps
SupportTextureHalfFloatLinear | GraphicsCaps
SupportVertexHalfFloat | GraphicsCaps


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • PolygonOffset

PolygonOffset メンバ一覧

これは全メンバの一覧です。PolygonOffset継承メンバも含んでいます。
Factor | PolygonOffset
PolygonOffset(float factor, float units) | PolygonOffset
Set(float factor, float units) | PolygonOffset
Units | PolygonOffset


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • Primitive

Primitive メンバ一覧

これは全メンバの一覧です。Primitive継承メンバも含んでいます。
Count | Primitive
First | Primitive
Mode | Primitive
Primitive(DrawMode mode, int first, int count, int userData) | Primitive
Set(DrawMode mode, int first, int count, int userData) | Primitive
UserData | Primitive


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • RenderTarget

RenderTarget メンバ一覧

これは全メンバの一覧です。RenderTarget継承メンバも含んでいます。
Buffer | RenderTarget
CubeFace | RenderTarget
Level | RenderTarget
RenderTarget(ColorBuffer buffer) | RenderTarget
RenderTarget(DepthBuffer buffer) | RenderTarget
RenderTarget(Texture2D texture, int level) | RenderTarget
RenderTarget(TextureCube texture, int level, TextureCubeFace cubeFace) | RenderTarget
Set(ColorBuffer buffer) | RenderTarget
Set(DepthBuffer buffer) | RenderTarget
Set(Texture2D texture, int level) | RenderTarget
Set(TextureCube texture, int level, TextureCubeFace cubeFace) | RenderTarget


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • StencilFunc

StencilFunc メンバ一覧

これは全メンバの一覧です。StencilFunc継承メンバも含んでいます。
Mode | StencilFunc
ReadMask | StencilFunc
Reference | StencilFunc
Set(StencilFuncMode mode, int reference, int readMask, int writeMask) | StencilFunc
StencilFunc(StencilFuncMode mode, int reference, int readMask, int writeMask) | StencilFunc
WriteMask | StencilFunc


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • StencilOp

StencilOp メンバ一覧

これは全メンバの一覧です。StencilOp継承メンバも含んでいます。
Fail | StencilOp
Set(StencilOpMode fail, StencilOpMode zFail, StencilOpMode zPass) | StencilOp
StencilOp(StencilOpMode fail, StencilOpMode zFail, StencilOpMode zPass) | StencilOp
ZFail | StencilOp
ZPass | StencilOp


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • TextureFilter

TextureFilter メンバ一覧

これは全メンバの一覧です。TextureFilter継承メンバも含んでいます。
Mag | TextureFilter
Min | TextureFilter
Mip | TextureFilter
Set(TextureFilterMode mag, TextureFilterMode min, TextureFilterMode mip) | TextureFilter
TextureFilter(TextureFilterMode mag, TextureFilterMode min, TextureFilterMode mip) | TextureFilter


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Graphics
  • TextureWrap

TextureWrap メンバ一覧

これは全メンバの一覧です。TextureWrap継承メンバも含んでいます。
S | TextureWrap
Set(TextureWrapMode s, TextureWrapMode t) | TextureWrap
T | TextureWrap
TextureWrap(TextureWrapMode s, TextureWrapMode t) | TextureWrap


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Half2

Half2 メンバ一覧

これは全メンバの一覧です。Half2継承メンバも含んでいます。
Equals(Half2 v) | Half2 |
Equals(Object o) | Half2 |
GetHashCode() | Half2 |
Half2(float x, float y) | Half2 |
Half2(Vector2 v) | Half2 |
operator!=(Half2 v1, Half2 v2) | Half2 | [static]
operator==(Half2 v1, Half2 v2) | Half2 | [static]
ToString() | Half2 |
ToVector2() | Half2 |
X | Half2 |
Y | Half2 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Half3

Half3 メンバ一覧

これは全メンバの一覧です。Half3継承メンバも含んでいます。
Equals(Half3 v) | Half3 |
Equals(Object o) | Half3 |
GetHashCode() | Half3 |
Half3(float x, float y, float z) | Half3 |
Half3(Vector3 v) | Half3 |
operator!=(Half3 v1, Half3 v2) | Half3 | [static]
operator==(Half3 v1, Half3 v2) | Half3 | [static]
ToString() | Half3 |
ToVector3() | Half3 |
X | Half3 |
Y | Half3 |
Z | Half3 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Half4

Half4 メンバ一覧

これは全メンバの一覧です。Half4継承メンバも含んでいます。
Equals(Half4 v) | Half4 |
Equals(Object o) | Half4 |
GetHashCode() | Half4 |
Half4(float x, float y, float z, float w) | Half4 |
Half4(Vector4 v) | Half4 |
operator!=(Half4 v1, Half4 v2) | Half4 | [static]
operator==(Half4 v1, Half4 v2) | Half4 | [static]
ToString() | Half4 |
ToVector4() | Half4 |
W | Half4 |
X | Half4 |
Y | Half4 |
Z | Half4 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Half

Half メンバ一覧

これは全メンバの一覧です。Half継承メンバも含んでいます。
Bits | Half |
Equals(Half h) | Half |
Equals(Object o) | Half |
GetHashCode() | Half |
Half(float f) | Half |
operator float(Half h) | Half | [static]
operator Half(float f) | Half | [explicit, static]
operator!=(Half h1, Half h2) | Half | [static]
operator==(Half h1, Half h2) | Half | [static]
ToFloat() | Half |
ToString() | Half |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Imaging
  • CharMetrics

CharMetrics メンバ一覧

これは全メンバの一覧です。CharMetrics継承メンバも含んでいます。
Height | CharMetrics
HorizontalAdvance | CharMetrics
HorizontalBearingX | CharMetrics
HorizontalBearingY | CharMetrics
Width | CharMetrics
X | CharMetrics
Y | CharMetrics


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Imaging
  • FontMetrics

FontMetrics メンバ一覧

これは全メンバの一覧です。FontMetrics継承メンバも含んでいます。
Ascent | FontMetrics
Descent | FontMetrics
Height | FontMetrics
Leading | FontMetrics


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Imaging
  • ImageColor

ImageColor メンバ一覧

これは全メンバの一覧です。ImageColor継承メンバも含んでいます。
A | ImageColor
B | ImageColor
G | ImageColor
ImageColor(int r, int g, int b, int a) | ImageColor
R | ImageColor


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Imaging
  • ImagePosition

ImagePosition メンバ一覧

これは全メンバの一覧です。ImagePosition継承メンバも含んでいます。
ImagePosition(int x, int y) | ImagePosition
X | ImagePosition
Y | ImagePosition


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Imaging
  • ImageRect

ImageRect メンバ一覧

これは全メンバの一覧です。ImageRect継承メンバも含んでいます。
Height | ImageRect
ImageRect(int x, int y, int width, int height) | ImageRect
Width | ImageRect
X | ImageRect
Y | ImageRect


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Imaging
  • ImageSize

ImageSize メンバ一覧

これは全メンバの一覧です。ImageSize継承メンバも含んでいます。
Height | ImageSize
ImageSize(int width, int height) | ImageSize
Width | ImageSize


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Input
  • GamePadData

GamePadData メンバ一覧

これは全メンバの一覧です。GamePadData継承メンバも含んでいます。
AnalogLeftX | GamePadData
AnalogLeftY | GamePadData
AnalogRightX | GamePadData
AnalogRightY | GamePadData
Buttons | GamePadData
ButtonsDown | GamePadData
ButtonsPrev | GamePadData
ButtonsUp | GamePadData
Skip | GamePadData


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Input
  • MotionData

MotionData メンバ一覧

これは全メンバの一覧です。MotionData継承メンバも含んでいます。
Acceleration | MotionData
AngularVelocity | MotionData
Skip | MotionData


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Input
  • TouchData

TouchData メンバ一覧

これは全メンバの一覧です。TouchData継承メンバも含んでいます。
ID | TouchData
Skip | TouchData
Status | TouchData
X | TouchData
Y | TouchData


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Matrix4

Matrix4 メンバ一覧

これは全メンバの一覧です。Matrix4継承メンバも含んでいます。
Add(Matrix4 m) | Matrix4 |
Add(ref Matrix4 m, out Matrix4 result) | Matrix4 |
Add(Matrix4 m1, Matrix4 m2) | Matrix4 | [static]
Add(ref Matrix4 m1, ref Matrix4 m2, out Matrix4 result) | Matrix4 | [static]
AxisW | Matrix4 |
AxisX | Matrix4 |
AxisY | Matrix4 |
AxisZ | Matrix4 |
ColumnW | Matrix4 |
ColumnX | Matrix4 |
ColumnY | Matrix4 |
ColumnZ | Matrix4 |
Determinant() | Matrix4 |
Determinant(Matrix4 m) | Matrix4 | [static]
Determinant(ref Matrix4 m) | Matrix4 | [static]
Divide(float f) | Matrix4 |
Divide(float f, out Matrix4 result) | Matrix4 |
Divide(Matrix4 m, float f) | Matrix4 | [static]
Divide(ref Matrix4 m, float f, out Matrix4 result) | Matrix4 | [static]
Equals(Matrix4 m, float epsilon) | Matrix4 |
Equals(Matrix4 m) | Matrix4 |
Equals(Object o) | Matrix4 |
Frustum(float l, float r, float b, float t, float n, float f) | Matrix4 | [static]
Frustum(float l, float r, float b, float t, float n, float f, out Matrix4 result) | Matrix4 | [static]
GetHashCode() | Matrix4 |
Identity | Matrix4 | [static]
Inverse() | Matrix4 |
Inverse(out Matrix4 result) | Matrix4 |
Inverse(Matrix4 m) | Matrix4 | [static]
Inverse(ref Matrix4 m, out Matrix4 result) | Matrix4 | [static]
InverseAffine() | Matrix4 |
InverseAffine(out Matrix4 result) | Matrix4 |
InverseAffine(Matrix4 m) | Matrix4 | [static]
InverseAffine(ref Matrix4 m, out Matrix4 result) | Matrix4 | [static]
InverseOrthonormal() | Matrix4 |
InverseOrthonormal(out Matrix4 result) | Matrix4 |
InverseOrthonormal(Matrix4 m) | Matrix4 | [static]
InverseOrthonormal(ref Matrix4 m, out Matrix4 result) | Matrix4 | [static]
IsIdentity() | Matrix4 |
IsInfinity() | Matrix4 |
IsNaN() | Matrix4 |
IsOrthonormal(float epsilon) | Matrix4 |
LookAt(Vector3 eye, Vector3 center, Vector3 up) | Matrix4 | [static]
LookAt(ref Vector3 eye, ref Vector3 center, ref Vector3 up, out Matrix4 result) | Matrix4 | [static]
M11 | Matrix4 |
M12 | Matrix4 |
M13 | Matrix4 |
M14 | Matrix4 |
M21 | Matrix4 |
M22 | Matrix4 |
M23 | Matrix4 |
M24 | Matrix4 |
M31 | Matrix4 |
M32 | Matrix4 |
M33 | Matrix4 |
M34 | Matrix4 |
M41 | Matrix4 |
M42 | Matrix4 |
M43 | Matrix4 |
M44 | Matrix4 |
Matrix4(float m11, float m12, float m13, float m14, float m21, float m22, float m23, float m24, float m31, float m32, float m33, float m34, float m41, float m42, float m43, float m44) | Matrix4 |
Matrix4(Vector4 x, Vector4 y, Vector4 z, Vector4 w) | Matrix4 |
Matrix4(Vector3 x, Vector3 y, Vector3 z, Vector3 w) | Matrix4 |
Multiply(Matrix4 m) | Matrix4 |
Multiply(ref Matrix4 m, out Matrix4 result) | Matrix4 |
Multiply(float f) | Matrix4 |
Multiply(float f, out Matrix4 result) | Matrix4 |
Multiply(Matrix4 m1, Matrix4 m2) | Matrix4 | [static]
Multiply(ref Matrix4 m1, ref Matrix4 m2, out Matrix4 result) | Matrix4 | [static]
Multiply(Matrix4 m, float f) | Matrix4 | [static]
Multiply(ref Matrix4 m, float f, out Matrix4 result) | Matrix4 | [static]
MultiplyAffine(Matrix4 m) | Matrix4 |
MultiplyAffine(ref Matrix4 m, out Matrix4 result) | Matrix4 |
MultiplyAffine(Matrix4 m1, Matrix4 m2) | Matrix4 | [static]
MultiplyAffine(ref Matrix4 m1, ref Matrix4 m2, out Matrix4 result) | Matrix4 | [static]
Negate() | Matrix4 |
Negate(out Matrix4 result) | Matrix4 |
Negate(Matrix4 m) | Matrix4 | [static]
Negate(ref Matrix4 m, out Matrix4 result) | Matrix4 | [static]
operator!=(Matrix4 m1, Matrix4 m2) | Matrix4 | [static]
operator*(Matrix4 m1, Matrix4 m2) | Matrix4 | [static]
operator*(Matrix4 m, float f) | Matrix4 | [static]
operator*(float f, Matrix4 m) | Matrix4 | [static]
operator*(Matrix4 m, Vector4 v) | Matrix4 | [static]
operator+(Matrix4 m1, Matrix4 m2) | Matrix4 | [static]
operator-(Matrix4 m1, Matrix4 m2) | Matrix4 | [static]
operator-(Matrix4 m) | Matrix4 | [static]
operator/(Matrix4 m, float f) | Matrix4 | [static]
operator==(Matrix4 m1, Matrix4 m2) | Matrix4 | [static]
Ortho(float l, float r, float b, float t, float n, float f) | Matrix4 | [static]
Ortho(float l, float r, float b, float t, float n, float f, out Matrix4 result) | Matrix4 | [static]
Orthonormalize() | Matrix4 |
Orthonormalize(out Matrix4 result) | Matrix4 |
Orthonormalize(Matrix4 m) | Matrix4 | [static]
Orthonormalize(ref Matrix4 m, out Matrix4 result) | Matrix4 | [static]
Perspective(float fovy, float aspect, float n, float f) | Matrix4 | [static]
Perspective(float fovy, float aspect, float n, float f, out Matrix4 result) | Matrix4 | [static]
RotationAxis(Vector3 axis, float angle) | Matrix4 | [static]
RotationAxis(ref Vector3 axis, float angle, out Matrix4 result) | Matrix4 | [static]
RotationX(float angle) | Matrix4 | [static]
RotationX(float angle, out Matrix4 result) | Matrix4 | [static]
RotationXyz(float x, float y, float z) | Matrix4 | [static]
RotationXyz(float x, float y, float z, out Matrix4 result) | Matrix4 | [static]
RotationXyz(Vector3 angles) | Matrix4 | [static]
RotationXyz(ref Vector3 angles, out Matrix4 result) | Matrix4 | [static]
RotationXzy(float x, float y, float z) | Matrix4 | [static]
RotationXzy(float x, float y, float z, out Matrix4 result) | Matrix4 | [static]
RotationXzy(Vector3 angles) | Matrix4 | [static]
RotationXzy(ref Vector3 angles, out Matrix4 result) | Matrix4 | [static]
RotationY(float angle) | Matrix4 | [static]
RotationY(float angle, out Matrix4 result) | Matrix4 | [static]
RotationYxz(float x, float y, float z) | Matrix4 | [static]
RotationYxz(float x, float y, float z, out Matrix4 result) | Matrix4 | [static]
RotationYxz(Vector3 angles) | Matrix4 | [static]
RotationYxz(ref Vector3 angles, out Matrix4 result) | Matrix4 | [static]
RotationYzx(float x, float y, float z) | Matrix4 | [static]
RotationYzx(float x, float y, float z, out Matrix4 result) | Matrix4 | [static]
RotationYzx(Vector3 angles) | Matrix4 | [static]
RotationYzx(ref Vector3 angles, out Matrix4 result) | Matrix4 | [static]
RotationZ(float angle) | Matrix4 | [static]
RotationZ(float angle, out Matrix4 result) | Matrix4 | [static]
RotationZxy(float x, float y, float z) | Matrix4 | [static]
RotationZxy(float x, float y, float z, out Matrix4 result) | Matrix4 | [static]
RotationZxy(Vector3 angles) | Matrix4 | [static]
RotationZxy(ref Vector3 angles, out Matrix4 result) | Matrix4 | [static]
RotationZyx(float x, float y, float z) | Matrix4 | [static]
RotationZyx(float x, float y, float z, out Matrix4 result) | Matrix4 | [static]
RotationZyx(Vector3 angles) | Matrix4 | [static]
RotationZyx(ref Vector3 angles, out Matrix4 result) | Matrix4 | [static]
RowW | Matrix4 |
RowX | Matrix4 |
RowY | Matrix4 |
RowZ | Matrix4 |
Scale(float x, float y, float z) | Matrix4 | [static]
Scale(float x, float y, float z, out Matrix4 result) | Matrix4 | [static]
Scale(Vector3 scale) | Matrix4 | [static]
Scale(ref Vector3 scale, out Matrix4 result) | Matrix4 | [static]
Scale(Vector2 scale) | Matrix4 | [static]
Scale(ref Vector2 scale, out Matrix4 result) | Matrix4 | [static]
Subtract(Matrix4 m) | Matrix4 |
Subtract(ref Matrix4 m, out Matrix4 result) | Matrix4 |
Subtract(Matrix4 m1, Matrix4 m2) | Matrix4 | [static]
Subtract(ref Matrix4 m1, ref Matrix4 m2, out Matrix4 result) | Matrix4 | [static]
ToString() | Matrix4 |
Transform(Vector4 v) | Matrix4 |
Transform(ref Vector4 v, out Vector4 result) | Matrix4 |
Transform(Matrix4 m, Vector4 v) | Matrix4 | [static]
Transform(ref Matrix4 m, ref Vector4 v, out Vector4 result) | Matrix4 | [static]
Transformation(Vector3 translation, Quaternion rotation, Vector3 scale) | Matrix4 | [static]
Transformation(ref Vector3 translation, ref Quaternion rotation, ref Vector3 scale, out Matrix4 result) | Matrix4 | [static]
Transformation(Vector2 translation, float rotation, Vector2 scale) | Matrix4 | [static]
Transformation(ref Vector2 translation, float rotation, ref Vector2 scale, out Matrix4 result) | Matrix4 | [static]
Transformation(Vector3 translation, Vector3 scale) | Matrix4 | [static]
Transformation(ref Vector3 translation, ref Vector3 scale, out Matrix4 result) | Matrix4 | [static]
Transformation(Vector2 translation, Vector2 scale) | Matrix4 | [static]
Transformation(ref Vector2 translation, ref Vector2 scale, out Matrix4 result) | Matrix4 | [static]
TransformPoint(Vector3 v) | Matrix4 |
TransformPoint(ref Vector3 v, out Vector3 result) | Matrix4 |
TransformPoint(Vector2 v) | Matrix4 |
TransformPoint(ref Vector2 v, out Vector2 result) | Matrix4 |
TransformPoint(Matrix4 m, Vector3 v) | Matrix4 | [static]
TransformPoint(ref Matrix4 m, ref Vector3 v, out Vector3 result) | Matrix4 | [static]
TransformPoint(Matrix4 m, Vector2 v) | Matrix4 | [static]
TransformPoint(ref Matrix4 m, ref Vector2 v, out Vector2 result) | Matrix4 | [static]
TransformProjection(Vector4 v) | Matrix4 |
TransformProjection(ref Vector4 v, out Vector4 result) | Matrix4 |
TransformProjection(Vector3 v) | Matrix4 |
TransformProjection(ref Vector3 v, out Vector3 result) | Matrix4 |
TransformProjection(Vector2 v) | Matrix4 |
TransformProjection(ref Vector2 v, out Vector2 result) | Matrix4 |
TransformProjection(Matrix4 m, Vector4 v) | Matrix4 | [static]
TransformProjection(ref Matrix4 m, ref Vector4 v, out Vector4 result) | Matrix4 | [static]
TransformProjection(Matrix4 m, Vector3 v) | Matrix4 | [static]
TransformProjection(ref Matrix4 m, ref Vector3 v, out Vector3 result) | Matrix4 | [static]
TransformProjection(Matrix4 m, Vector2 v) | Matrix4 | [static]
TransformProjection(ref Matrix4 m, ref Vector2 v, out Vector2 result) | Matrix4 | [static]
TransformVector(Vector3 v) | Matrix4 |
TransformVector(ref Vector3 v, out Vector3 result) | Matrix4 |
TransformVector(Vector2 v) | Matrix4 |
TransformVector(ref Vector2 v, out Vector2 result) | Matrix4 |
TransformVector(Matrix4 m, Vector3 v) | Matrix4 | [static]
TransformVector(ref Matrix4 m, ref Vector3 v, out Vector3 result) | Matrix4 | [static]
TransformVector(Matrix4 m, Vector2 v) | Matrix4 | [static]
TransformVector(ref Matrix4 m, ref Vector2 v, out Vector2 result) | Matrix4 | [static]
Translation(float x, float y, float z) | Matrix4 | [static]
Translation(float x, float y, float z, out Matrix4 result) | Matrix4 | [static]
Translation(Vector3 translation) | Matrix4 | [static]
Translation(ref Vector3 translation, out Matrix4 result) | Matrix4 | [static]
Translation(Vector2 translation) | Matrix4 | [static]
Translation(ref Vector2 translation, out Matrix4 result) | Matrix4 | [static]
Transpose() | Matrix4 |
Transpose(out Matrix4 result) | Matrix4 |
Transpose(Matrix4 m) | Matrix4 | [static]
Transpose(ref Matrix4 m, out Matrix4 result) | Matrix4 | [static]
Zero | Matrix4 | [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Quaternion

Quaternion メンバ一覧

これは全メンバの一覧です。Quaternion継承メンバも含んでいます。
Add(Quaternion q) | Quaternion |
Add(ref Quaternion q, out Quaternion result) | Quaternion |
Add(Quaternion q1, Quaternion q2) | Quaternion | [static]
Add(ref Quaternion q1, ref Quaternion q2, out Quaternion result) | Quaternion | [static]
Angle(Quaternion q) | Quaternion |
Angle(ref Quaternion q) | Quaternion |
Angle(Quaternion q1, Quaternion q2) | Quaternion | [static]
Angle(ref Quaternion q1, ref Quaternion q2) | Quaternion | [static]
Conjugate() | Quaternion |
Conjugate(out Quaternion result) | Quaternion |
Conjugate(Quaternion q) | Quaternion | [static]
Conjugate(ref Quaternion q, out Quaternion result) | Quaternion | [static]
Divide(float f) | Quaternion |
Divide(float f, out Quaternion result) | Quaternion |
Divide(Quaternion q, float f) | Quaternion | [static]
Divide(ref Quaternion q, float f, out Quaternion result) | Quaternion | [static]
Dot(Quaternion q) | Quaternion |
Dot(ref Quaternion q) | Quaternion |
Dot(Quaternion q1, Quaternion q2) | Quaternion | [static]
Dot(ref Quaternion q1, ref Quaternion q2) | Quaternion | [static]
Equals(Quaternion q, float epsilon) | Quaternion |
Equals(Quaternion q) | Quaternion |
Equals(Object o) | Quaternion |
Exp() | Quaternion |
Exp(out Quaternion result) | Quaternion |
Exp(Quaternion q) | Quaternion | [static]
Exp(ref Quaternion q, out Quaternion result) | Quaternion | [static]
FromMatrix4(Matrix4 m) | Quaternion | [static]
FromMatrix4(ref Matrix4 m, out Quaternion result) | Quaternion | [static]
GetHashCode() | Quaternion |
Identity | Quaternion | [static]
Inverse() | Quaternion |
Inverse(out Quaternion result) | Quaternion |
Inverse(Quaternion q) | Quaternion | [static]
Inverse(ref Quaternion q, out Quaternion result) | Quaternion | [static]
IsIdentity() | Quaternion |
IsInfinity() | Quaternion |
IsNaN() | Quaternion |
IsUnit(float epsilon) | Quaternion |
Length() | Quaternion |
Length(Quaternion q) | Quaternion | [static]
Length(ref Quaternion q) | Quaternion | [static]
LengthSquared() | Quaternion |
LengthSquared(Quaternion q) | Quaternion | [static]
LengthSquared(ref Quaternion q) | Quaternion | [static]
Lerp(Quaternion q, float f) | Quaternion |
Lerp(ref Quaternion q, float f, out Quaternion result) | Quaternion |
Lerp(Quaternion q1, Quaternion q2, float f) | Quaternion | [static]
Lerp(ref Quaternion q1, ref Quaternion q2, float f, out Quaternion result) | Quaternion | [static]
Log() | Quaternion |
Log(out Quaternion result) | Quaternion |
Log(Quaternion q) | Quaternion | [static]
Log(ref Quaternion q, out Quaternion result) | Quaternion | [static]
Multiply(Quaternion q) | Quaternion |
Multiply(ref Quaternion q, out Quaternion result) | Quaternion |
Multiply(float f) | Quaternion |
Multiply(float f, out Quaternion result) | Quaternion |
Multiply(Quaternion q1, Quaternion q2) | Quaternion | [static]
Multiply(ref Quaternion q1, ref Quaternion q2, out Quaternion result) | Quaternion | [static]
Multiply(Quaternion q, float f) | Quaternion | [static]
Multiply(ref Quaternion q, float f, out Quaternion result) | Quaternion | [static]
Negate() | Quaternion |
Negate(out Quaternion result) | Quaternion |
Negate(Quaternion q) | Quaternion | [static]
Negate(ref Quaternion q, out Quaternion result) | Quaternion | [static]
Normalize() | Quaternion |
Normalize(out Quaternion result) | Quaternion |
Normalize(Quaternion q) | Quaternion | [static]
Normalize(ref Quaternion q, out Quaternion result) | Quaternion | [static]
operator!=(Quaternion q1, Quaternion q2) | Quaternion | [static]
operator*(Quaternion q1, Quaternion q2) | Quaternion | [static]
operator*(Quaternion q, float f) | Quaternion | [static]
operator*(float f, Quaternion q) | Quaternion | [static]
operator+(Quaternion q1, Quaternion q2) | Quaternion | [static]
operator-(Quaternion q1, Quaternion q2) | Quaternion | [static]
operator-(Quaternion q) | Quaternion | [static]
operator/(Quaternion q, float f) | Quaternion | [static]
operator==(Quaternion q1, Quaternion q2) | Quaternion | [static]
Quaternion(float x, float y, float z, float w) | Quaternion |
Quaternion(Vector3 xyz, float w) | Quaternion |
Quaternion(Vector4 v) | Quaternion |
RotationAxis(Vector3 axis, float angle) | Quaternion | [static]
RotationAxis(ref Vector3 axis, float angle, out Quaternion result) | Quaternion | [static]
RotationX(float angle) | Quaternion | [static]
RotationX(float angle, out Quaternion result) | Quaternion | [static]
RotationXyz(float x, float y, float z) | Quaternion | [static]
RotationXyz(float x, float y, float z, out Quaternion result) | Quaternion | [static]
RotationXyz(Vector3 angles) | Quaternion | [static]
RotationXyz(ref Vector3 angles, out Quaternion result) | Quaternion | [static]
RotationXzy(float x, float y, float z) | Quaternion | [static]
RotationXzy(float x, float y, float z, out Quaternion result) | Quaternion | [static]
RotationXzy(Vector3 angles) | Quaternion | [static]
RotationXzy(ref Vector3 angles, out Quaternion result) | Quaternion | [static]
RotationY(float angle) | Quaternion | [static]
RotationY(float angle, out Quaternion result) | Quaternion | [static]
RotationYxz(float x, float y, float z) | Quaternion | [static]
RotationYxz(float x, float y, float z, out Quaternion result) | Quaternion | [static]
RotationYxz(Vector3 angles) | Quaternion | [static]
RotationYxz(ref Vector3 angles, out Quaternion result) | Quaternion | [static]
RotationYzx(float x, float y, float z) | Quaternion | [static]
RotationYzx(float x, float y, float z, out Quaternion result) | Quaternion | [static]
RotationYzx(Vector3 angles) | Quaternion | [static]
RotationYzx(ref Vector3 angles, out Quaternion result) | Quaternion | [static]
RotationZ(float angle) | Quaternion | [static]
RotationZ(float angle, out Quaternion result) | Quaternion | [static]
RotationZxy(float x, float y, float z) | Quaternion | [static]
RotationZxy(float x, float y, float z, out Quaternion result) | Quaternion | [static]
RotationZxy(Vector3 angles) | Quaternion | [static]
RotationZxy(ref Vector3 angles, out Quaternion result) | Quaternion | [static]
RotationZyx(float x, float y, float z) | Quaternion | [static]
RotationZyx(float x, float y, float z, out Quaternion result) | Quaternion | [static]
RotationZyx(Vector3 angles) | Quaternion | [static]
RotationZyx(ref Vector3 angles, out Quaternion result) | Quaternion | [static]
Slerp(Quaternion q, float f) | Quaternion |
Slerp(ref Quaternion q, float f, out Quaternion result) | Quaternion |
Slerp(Quaternion q1, Quaternion q2, float f) | Quaternion | [static]
Slerp(ref Quaternion q1, ref Quaternion q2, float f, out Quaternion result) | Quaternion | [static]
Subtract(Quaternion q) | Quaternion |
Subtract(ref Quaternion q, out Quaternion result) | Quaternion |
Subtract(Quaternion q1, Quaternion q2) | Quaternion | [static]
Subtract(ref Quaternion q1, ref Quaternion q2, out Quaternion result) | Quaternion | [static]
ToAxisAngle(out Vector3 axis, out float angle) | Quaternion |
ToMatrix4() | Quaternion |
ToMatrix4(out Matrix4 result) | Quaternion |
ToString() | Quaternion |
ToVector4() | Quaternion |
ToVector4(out Vector4 result) | Quaternion |
Transform(Vector4 v) | Quaternion |
Transform(ref Vector4 v, out Vector4 result) | Quaternion |
Transform(Vector3 v) | Quaternion |
Transform(ref Vector3 v, out Vector3 result) | Quaternion |
Transform(Vector2 v) | Quaternion |
Transform(ref Vector2 v, out Vector2 result) | Quaternion |
Transform(Quaternion q, Vector4 v) | Quaternion | [static]
Transform(ref Quaternion q, ref Vector4 v, out Vector4 result) | Quaternion | [static]
Transform(Quaternion q, Vector3 v) | Quaternion | [static]
Transform(ref Quaternion q, ref Vector3 v, out Vector3 result) | Quaternion | [static]
Transform(Quaternion q, Vector2 v) | Quaternion | [static]
Transform(ref Quaternion q, ref Vector2 v, out Vector2 result) | Quaternion | [static]
TurnTo(Quaternion q, float angle) | Quaternion |
TurnTo(ref Quaternion q, float angle, out Quaternion result) | Quaternion |
TurnTo(Quaternion q1, Quaternion q2, float angle) | Quaternion | [static]
TurnTo(ref Quaternion q1, ref Quaternion q2, float angle, out Quaternion result) | Quaternion | [static]
W | Quaternion |
X | Quaternion |
Y | Quaternion |
Z | Quaternion |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Rectangle

Rectangle メンバ一覧

これは全メンバの一覧です。Rectangle継承メンバも含んでいます。
Add(Rectangle r) | Rectangle |
Add(ref Rectangle r, out Rectangle result) | Rectangle |
Add(Rectangle r1, Rectangle r2) | Rectangle | [static]
Add(ref Rectangle r1, ref Rectangle r2, out Rectangle result) | Rectangle | [static]
Divide(float f) | Rectangle |
Divide(float f, out Rectangle result) | Rectangle |
Divide(Rectangle r, float f) | Rectangle | [static]
Divide(ref Rectangle r, float f, out Rectangle result) | Rectangle | [static]
Equals(Rectangle r, float epsilon) | Rectangle |
Equals(Rectangle r) | Rectangle |
Equals(Object o) | Rectangle |
FromMatrix4(Matrix4 m) | Rectangle | [static]
FromMatrix4(ref Matrix4 m, out Rectangle result) | Rectangle | [static]
GetHashCode() | Rectangle |
Height | Rectangle |
Identity | Rectangle | [static]
Inverse() | Rectangle |
Inverse(out Rectangle result) | Rectangle |
Inverse(Rectangle r) | Rectangle | [static]
Inverse(ref Rectangle r, out Rectangle result) | Rectangle | [static]
IsIdentity() | Rectangle |
IsInfinity() | Rectangle |
IsNaN() | Rectangle |
Lerp(Rectangle r, float f) | Rectangle |
Lerp(ref Rectangle r, float f, out Rectangle result) | Rectangle |
Lerp(Rectangle r1, Rectangle r2, float f) | Rectangle | [static]
Lerp(ref Rectangle r1, ref Rectangle r2, float f, out Rectangle result) | Rectangle | [static]
Multiply(Rectangle r) | Rectangle |
Multiply(ref Rectangle r, out Rectangle result) | Rectangle |
Multiply(float f) | Rectangle |
Multiply(float f, out Rectangle result) | Rectangle |
Multiply(Rectangle r1, Rectangle r2) | Rectangle | [static]
Multiply(ref Rectangle r1, ref Rectangle r2, out Rectangle result) | Rectangle | [static]
Multiply(Rectangle r, float f) | Rectangle | [static]
Multiply(ref Rectangle r, float f, out Rectangle result) | Rectangle | [static]
Negate() | Rectangle |
Negate(out Rectangle result) | Rectangle |
Negate(Rectangle r) | Rectangle | [static]
Negate(ref Rectangle r, out Rectangle result) | Rectangle | [static]
operator!=(Rectangle r1, Rectangle r2) | Rectangle | [static]
operator*(Rectangle r1, Rectangle r2) | Rectangle | [static]
operator*(Rectangle r, float f) | Rectangle | [static]
operator*(float f, Rectangle r) | Rectangle | [static]
operator+(Rectangle r1, Rectangle r2) | Rectangle | [static]
operator-(Rectangle r1, Rectangle r2) | Rectangle | [static]
operator-(Rectangle r) | Rectangle | [static]
operator/(Rectangle r, float f) | Rectangle | [static]
operator==(Rectangle r1, Rectangle r2) | Rectangle | [static]
Position | Rectangle |
Rectangle(float x, float y, float width, float height) | Rectangle |
Rectangle(Vector2 position, Vector2 size) | Rectangle |
Rectangle(Vector4 v) | Rectangle |
Size | Rectangle |
Subtract(Rectangle r) | Rectangle |
Subtract(ref Rectangle r, out Rectangle result) | Rectangle |
Subtract(Rectangle r1, Rectangle r2) | Rectangle | [static]
Subtract(ref Rectangle r1, ref Rectangle r2, out Rectangle result) | Rectangle | [static]
ToMatrix4() | Rectangle |
ToMatrix4(out Matrix4 result) | Rectangle |
ToString() | Rectangle |
ToVector4() | Rectangle |
ToVector4(out Vector4 result) | Rectangle |
TransformPoint(Vector2 v) | Rectangle |
TransformPoint(ref Vector2 v, out Vector2 result) | Rectangle |
TransformPoint(Rectangle r, Vector2 v) | Rectangle | [static]
TransformPoint(ref Rectangle r, ref Vector2 v, out Vector2 result) | Rectangle | [static]
TransformVector(Vector2 v) | Rectangle |
TransformVector(ref Vector2 v, out Vector2 result) | Rectangle |
TransformVector(Rectangle r, Vector2 v) | Rectangle | [static]
TransformVector(ref Rectangle r, ref Vector2 v, out Vector2 result) | Rectangle | [static]
Width | Rectangle |
X | Rectangle |
Y | Rectangle |
Zero | Rectangle | [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Rgb565

Rgb565 メンバ一覧

これは全メンバの一覧です。Rgb565継承メンバも含んでいます。
Bits | Rgb565 |
Equals(Rgb565 c) | Rgb565 |
Equals(Object o) | Rgb565 |
GetHashCode() | Rgb565 |
operator!=(Rgb565 c1, Rgb565 c2) | Rgb565 | [static]
operator==(Rgb565 c1, Rgb565 c2) | Rgb565 | [static]
Rgb565(ushort bits) | Rgb565 |
Rgb565(Rgba rgba) | Rgb565 |
ToRgba() | Rgb565 |
ToString() | Rgb565 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Rgba4444

Rgba4444 メンバ一覧

これは全メンバの一覧です。Rgba4444継承メンバも含んでいます。
Bits | Rgba4444 |
Equals(Rgba4444 c) | Rgba4444 |
Equals(Object o) | Rgba4444 |
GetHashCode() | Rgba4444 |
operator!=(Rgba4444 c1, Rgba4444 c2) | Rgba4444 | [static]
operator==(Rgba4444 c1, Rgba4444 c2) | Rgba4444 | [static]
Rgba4444(ushort bits) | Rgba4444 |
Rgba4444(Rgba rgba) | Rgba4444 |
ToRgba() | Rgba4444 |
ToString() | Rgba4444 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Rgba5551

Rgba5551 メンバ一覧

これは全メンバの一覧です。Rgba5551継承メンバも含んでいます。
Bits | Rgba5551 |
Equals(Rgba5551 c) | Rgba5551 |
Equals(Object o) | Rgba5551 |
GetHashCode() | Rgba5551 |
operator!=(Rgba5551 c1, Rgba5551 c2) | Rgba5551 | [static]
operator==(Rgba5551 c1, Rgba5551 c2) | Rgba5551 | [static]
Rgba5551(ushort bits) | Rgba5551 |
Rgba5551(Rgba rgba) | Rgba5551 |
ToRgba() | Rgba5551 |
ToString() | Rgba5551 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Rgba

Rgba メンバ一覧

これは全メンバの一覧です。Rgba継承メンバも含んでいます。
A | Rgba |
B | Rgba |
Equals(Rgba c) | Rgba |
Equals(Object o) | Rgba |
G | Rgba |
GetHashCode() | Rgba |
operator!=(Rgba c1, Rgba c2) | Rgba | [static]
operator==(Rgba c1, Rgba c2) | Rgba | [static]
R | Rgba |
Rgba(int r, int g, int b, int a) | Rgba |
Rgba(Vector4 v) | Rgba |
ToString() | Rgba |
ToVector4() | Rgba |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Short2

Short2 メンバ一覧

これは全メンバの一覧です。Short2継承メンバも含んでいます。
Equals(Short2 v) | Short2 |
Equals(Object o) | Short2 |
GetHashCode() | Short2 |
operator!=(Short2 v1, Short2 v2) | Short2 | [static]
operator==(Short2 v1, Short2 v2) | Short2 | [static]
Short2(int x, int y) | Short2 |
Short2(Vector2 v) | Short2 |
ToString() | Short2 |
ToVector2() | Short2 |
X | Short2 |
Y | Short2 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Short2N

Short2N メンバ一覧

これは全メンバの一覧です。Short2N継承メンバも含んでいます。
Equals(Short2N v) | Short2N |
Equals(Object o) | Short2N |
GetHashCode() | Short2N |
operator!=(Short2N v1, Short2N v2) | Short2N | [static]
operator==(Short2N v1, Short2N v2) | Short2N | [static]
Short2N(float x, float y) | Short2N |
Short2N(Vector2 v) | Short2N |
ToString() | Short2N |
ToVector2() | Short2N |
X | Short2N |
Y | Short2N |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Short3

Short3 メンバ一覧

これは全メンバの一覧です。Short3継承メンバも含んでいます。
Equals(Short3 v) | Short3 |
Equals(Object o) | Short3 |
GetHashCode() | Short3 |
operator!=(Short3 v1, Short3 v2) | Short3 | [static]
operator==(Short3 v1, Short3 v2) | Short3 | [static]
Short3(int x, int y, int z) | Short3 |
Short3(Vector3 v) | Short3 |
ToString() | Short3 |
ToVector3() | Short3 |
X | Short3 |
Y | Short3 |
Z | Short3 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Short3N

Short3N メンバ一覧

これは全メンバの一覧です。Short3N継承メンバも含んでいます。
Equals(Short3N v) | Short3N |
Equals(Object o) | Short3N |
GetHashCode() | Short3N |
operator!=(Short3N v1, Short3N v2) | Short3N | [static]
operator==(Short3N v1, Short3N v2) | Short3N | [static]
Short3N(float x, float y, float z) | Short3N |
Short3N(Vector3 v) | Short3N |
ToString() | Short3N |
ToVector3() | Short3N |
X | Short3N |
Y | Short3N |
Z | Short3N |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Short4

Short4 メンバ一覧

これは全メンバの一覧です。Short4継承メンバも含んでいます。
Equals(Short4 v) | Short4 |
Equals(Object o) | Short4 |
GetHashCode() | Short4 |
operator!=(Short4 v1, Short4 v2) | Short4 | [static]
operator==(Short4 v1, Short4 v2) | Short4 | [static]
Short4(int x, int y, int z, int w) | Short4 |
Short4(Vector4 v) | Short4 |
ToString() | Short4 |
ToVector4() | Short4 |
W | Short4 |
X | Short4 |
Y | Short4 |
Z | Short4 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Short4N

Short4N メンバ一覧

これは全メンバの一覧です。Short4N継承メンバも含んでいます。
Equals(Short4N v) | Short4N |
Equals(Object o) | Short4N |
GetHashCode() | Short4N |
operator!=(Short4N v1, Short4N v2) | Short4N | [static]
operator==(Short4N v1, Short4N v2) | Short4N | [static]
Short4N(float x, float y, float z, float w) | Short4N |
Short4N(Vector4 v) | Short4N |
ToString() | Short4N |
ToVector4() | Short4N |
W | Short4N |
X | Short4N |
Y | Short4N |
Z | Short4N |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • ShortN

ShortN メンバ一覧

これは全メンバの一覧です。ShortN継承メンバも含んでいます。
Bits | ShortN |
Equals(ShortN v) | ShortN |
Equals(Object o) | ShortN |
GetHashCode() | ShortN |
operator float(ShortN v) | ShortN | [static]
operator ShortN(float f) | ShortN | [explicit, static]
operator!=(ShortN v1, ShortN v2) | ShortN | [static]
operator==(ShortN v1, ShortN v2) | ShortN | [static]
ShortN(float f) | ShortN |
ToFloat() | ShortN |
ToString() | ShortN |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UByte2

UByte2 メンバ一覧

これは全メンバの一覧です。UByte2継承メンバも含んでいます。
Equals(UByte2 v) | UByte2 |
Equals(Object o) | UByte2 |
GetHashCode() | UByte2 |
operator!=(UByte2 v1, UByte2 v2) | UByte2 | [static]
operator==(UByte2 v1, UByte2 v2) | UByte2 | [static]
ToString() | UByte2 |
ToVector2() | UByte2 |
UByte2(int x, int y) | UByte2 |
UByte2(Vector2 v) | UByte2 |
X | UByte2 |
Y | UByte2 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UByte2N

UByte2N メンバ一覧

これは全メンバの一覧です。UByte2N継承メンバも含んでいます。
Equals(UByte2N v) | UByte2N |
Equals(Object o) | UByte2N |
GetHashCode() | UByte2N |
operator!=(UByte2N v1, UByte2N v2) | UByte2N | [static]
operator==(UByte2N v1, UByte2N v2) | UByte2N | [static]
ToString() | UByte2N |
ToVector2() | UByte2N |
UByte2N(float x, float y) | UByte2N |
UByte2N(Vector2 v) | UByte2N |
X | UByte2N |
Y | UByte2N |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UByte3

UByte3 メンバ一覧

これは全メンバの一覧です。UByte3継承メンバも含んでいます。
Equals(UByte3 v) | UByte3 |
Equals(Object o) | UByte3 |
GetHashCode() | UByte3 |
operator!=(UByte3 v1, UByte3 v2) | UByte3 | [static]
operator==(UByte3 v1, UByte3 v2) | UByte3 | [static]
ToString() | UByte3 |
ToVector3() | UByte3 |
UByte3(int x, int y, int z) | UByte3 |
UByte3(Vector3 v) | UByte3 |
X | UByte3 |
Y | UByte3 |
Z | UByte3 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UByte3N

UByte3N メンバ一覧

これは全メンバの一覧です。UByte3N継承メンバも含んでいます。
Equals(UByte3N v) | UByte3N |
Equals(Object o) | UByte3N |
GetHashCode() | UByte3N |
operator!=(UByte3N v1, UByte3N v2) | UByte3N | [static]
operator==(UByte3N v1, UByte3N v2) | UByte3N | [static]
ToString() | UByte3N |
ToVector3() | UByte3N |
UByte3N(float x, float y, float z) | UByte3N |
UByte3N(Vector3 v) | UByte3N |
X | UByte3N |
Y | UByte3N |
Z | UByte3N |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UByte4

UByte4 メンバ一覧

これは全メンバの一覧です。UByte4継承メンバも含んでいます。
Equals(UByte4 v) | UByte4 |
Equals(Object o) | UByte4 |
GetHashCode() | UByte4 |
operator!=(UByte4 v1, UByte4 v2) | UByte4 | [static]
operator==(UByte4 v1, UByte4 v2) | UByte4 | [static]
ToString() | UByte4 |
ToVector4() | UByte4 |
UByte4(int x, int y, int z, int w) | UByte4 |
UByte4(Vector4 v) | UByte4 |
W | UByte4 |
X | UByte4 |
Y | UByte4 |
Z | UByte4 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UByte4N

UByte4N メンバ一覧

これは全メンバの一覧です。UByte4N継承メンバも含んでいます。
Equals(UByte4N v) | UByte4N |
Equals(Object o) | UByte4N |
GetHashCode() | UByte4N |
operator!=(UByte4N v1, UByte4N v2) | UByte4N | [static]
operator==(UByte4N v1, UByte4N v2) | UByte4N | [static]
ToString() | UByte4N |
ToVector4() | UByte4N |
UByte4N(float x, float y, float z, float w) | UByte4N |
UByte4N(Vector4 v) | UByte4N |
W | UByte4N |
X | UByte4N |
Y | UByte4N |
Z | UByte4N |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UByteN

UByteN メンバ一覧

これは全メンバの一覧です。UByteN継承メンバも含んでいます。
Bits | UByteN |
Equals(UByteN v) | UByteN |
Equals(Object o) | UByteN |
GetHashCode() | UByteN |
operator float(UByteN v) | UByteN | [static]
operator UByteN(float f) | UByteN | [explicit, static]
operator!=(UByteN v1, UByteN v2) | UByteN | [static]
operator==(UByteN v1, UByteN v2) | UByteN | [static]
ToFloat() | UByteN |
ToString() | UByteN |
UByteN(float f) | UByteN |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UShort2

UShort2 メンバ一覧

これは全メンバの一覧です。UShort2継承メンバも含んでいます。
Equals(UShort2 v) | UShort2 |
Equals(Object o) | UShort2 |
GetHashCode() | UShort2 |
operator!=(UShort2 v1, UShort2 v2) | UShort2 | [static]
operator==(UShort2 v1, UShort2 v2) | UShort2 | [static]
ToString() | UShort2 |
ToVector2() | UShort2 |
UShort2(int x, int y) | UShort2 |
UShort2(Vector2 v) | UShort2 |
X | UShort2 |
Y | UShort2 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UShort2N

UShort2N メンバ一覧

これは全メンバの一覧です。UShort2N継承メンバも含んでいます。
Equals(UShort2N v) | UShort2N |
Equals(Object o) | UShort2N |
GetHashCode() | UShort2N |
operator!=(UShort2N v1, UShort2N v2) | UShort2N | [static]
operator==(UShort2N v1, UShort2N v2) | UShort2N | [static]
ToString() | UShort2N |
ToVector2() | UShort2N |
UShort2N(float x, float y) | UShort2N |
UShort2N(Vector2 v) | UShort2N |
X | UShort2N |
Y | UShort2N |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UShort3

UShort3 メンバ一覧

これは全メンバの一覧です。UShort3継承メンバも含んでいます。
Equals(UShort3 v) | UShort3 |
Equals(Object o) | UShort3 |
GetHashCode() | UShort3 |
operator!=(UShort3 v1, UShort3 v2) | UShort3 | [static]
operator==(UShort3 v1, UShort3 v2) | UShort3 | [static]
ToString() | UShort3 |
ToVector3() | UShort3 |
UShort3(int x, int y, int z) | UShort3 |
UShort3(Vector3 v) | UShort3 |
X | UShort3 |
Y | UShort3 |
Z | UShort3 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UShort3N

UShort3N メンバ一覧

これは全メンバの一覧です。UShort3N継承メンバも含んでいます。
Equals(UShort3N v) | UShort3N |
Equals(Object o) | UShort3N |
GetHashCode() | UShort3N |
operator!=(UShort3N v1, UShort3N v2) | UShort3N | [static]
operator==(UShort3N v1, UShort3N v2) | UShort3N | [static]
ToString() | UShort3N |
ToVector3() | UShort3N |
UShort3N(float x, float y, float z) | UShort3N |
UShort3N(Vector3 v) | UShort3N |
X | UShort3N |
Y | UShort3N |
Z | UShort3N |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UShort4

UShort4 メンバ一覧

これは全メンバの一覧です。UShort4継承メンバも含んでいます。
Equals(UShort4 v) | UShort4 |
Equals(Object o) | UShort4 |
GetHashCode() | UShort4 |
operator!=(UShort4 v1, UShort4 v2) | UShort4 | [static]
operator==(UShort4 v1, UShort4 v2) | UShort4 | [static]
ToString() | UShort4 |
ToVector4() | UShort4 |
UShort4(int x, int y, int z, int w) | UShort4 |
UShort4(Vector4 v) | UShort4 |
W | UShort4 |
X | UShort4 |
Y | UShort4 |
Z | UShort4 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UShort4N

UShort4N メンバ一覧

これは全メンバの一覧です。UShort4N継承メンバも含んでいます。
Equals(UShort4N v) | UShort4N |
Equals(Object o) | UShort4N |
GetHashCode() | UShort4N |
operator!=(UShort4N v1, UShort4N v2) | UShort4N | [static]
operator==(UShort4N v1, UShort4N v2) | UShort4N | [static]
ToString() | UShort4N |
ToVector4() | UShort4N |
UShort4N(float x, float y, float z, float w) | UShort4N |
UShort4N(Vector4 v) | UShort4N |
W | UShort4N |
X | UShort4N |
Y | UShort4N |
Z | UShort4N |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • UShortN

UShortN メンバ一覧

これは全メンバの一覧です。UShortN継承メンバも含んでいます。
Bits | UShortN |
Equals(UShortN v) | UShortN |
Equals(Object o) | UShortN |
GetHashCode() | UShortN |
operator float(UShortN v) | UShortN | [static]
operator UShortN(float f) | UShortN | [explicit, static]
operator!=(UShortN v1, UShortN v2) | UShortN | [static]
operator==(UShortN v1, UShortN v2) | UShortN | [static]
ToFloat() | UShortN |
ToString() | UShortN |
UShortN(float f) | UShortN |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Vector2

Vector2 メンバ一覧

これは全メンバの一覧です。Vector2継承メンバも含んでいます。
Abs() | Vector2 |
Abs(out Vector2 result) | Vector2 |
Abs(Vector2 v) | Vector2 | [static]
Abs(ref Vector2 v, out Vector2 result) | Vector2 | [static]
Add(Vector2 v) | Vector2 |
Add(ref Vector2 v, out Vector2 result) | Vector2 |
Add(Vector2 v1, Vector2 v2) | Vector2 | [static]
Add(ref Vector2 v1, ref Vector2 v2, out Vector2 result) | Vector2 | [static]
Angle(Vector2 v) | Vector2 |
Angle(ref Vector2 v) | Vector2 |
Angle(Vector2 v1, Vector2 v2) | Vector2 | [static]
Angle(ref Vector2 v1, ref Vector2 v2) | Vector2 | [static]
Clamp(Vector2 min, Vector2 max) | Vector2 |
Clamp(ref Vector2 min, ref Vector2 max, out Vector2 result) | Vector2 |
Clamp(float min, float max) | Vector2 |
Clamp(float min, float max, out Vector2 result) | Vector2 |
Clamp(Vector2 v, Vector2 min, Vector2 max) | Vector2 | [static]
Clamp(ref Vector2 v, ref Vector2 min, ref Vector2 max, out Vector2 result) | Vector2 | [static]
Clamp(Vector2 v, float min, float max) | Vector2 | [static]
Clamp(ref Vector2 v, float min, float max, out Vector2 result) | Vector2 | [static]
Determinant(Vector2 v) | Vector2 |
Determinant(ref Vector2 v) | Vector2 |
Determinant(Vector2 v1, Vector2 v2) | Vector2 | [static]
Determinant(ref Vector2 v1, ref Vector2 v2) | Vector2 | [static]
Distance(Vector2 v) | Vector2 |
Distance(ref Vector2 v) | Vector2 |
Distance(Vector2 v1, Vector2 v2) | Vector2 | [static]
Distance(ref Vector2 v1, ref Vector2 v2) | Vector2 | [static]
DistanceSquared(Vector2 v) | Vector2 |
DistanceSquared(ref Vector2 v) | Vector2 |
DistanceSquared(Vector2 v1, Vector2 v2) | Vector2 | [static]
DistanceSquared(ref Vector2 v1, ref Vector2 v2) | Vector2 | [static]
Divide(Vector2 v) | Vector2 |
Divide(ref Vector2 v, out Vector2 result) | Vector2 |
Divide(float f) | Vector2 |
Divide(float f, out Vector2 result) | Vector2 |
Divide(Vector2 v1, Vector2 v2) | Vector2 | [static]
Divide(ref Vector2 v1, ref Vector2 v2, out Vector2 result) | Vector2 | [static]
Divide(Vector2 v, float f) | Vector2 | [static]
Divide(ref Vector2 v, float f, out Vector2 result) | Vector2 | [static]
Dot(Vector2 v) | Vector2 |
Dot(ref Vector2 v) | Vector2 |
Dot(Vector2 v1, Vector2 v2) | Vector2 | [static]
Dot(ref Vector2 v1, ref Vector2 v2) | Vector2 | [static]
Equals(Vector2 v, float epsilon) | Vector2 |
Equals(Vector2 v) | Vector2 |
Equals(Object o) | Vector2 |
G | Vector2 |
GetHashCode() | Vector2 |
IsInfinity() | Vector2 |
IsNaN() | Vector2 |
IsOne() | Vector2 |
IsUnit(float epsilon) | Vector2 |
IsZero() | Vector2 |
Length() | Vector2 |
Length(Vector2 v) | Vector2 | [static]
Length(ref Vector2 v) | Vector2 | [static]
LengthSquared() | Vector2 |
LengthSquared(Vector2 v) | Vector2 | [static]
LengthSquared(ref Vector2 v) | Vector2 | [static]
Lerp(Vector2 v, float f) | Vector2 |
Lerp(ref Vector2 v, float f, out Vector2 result) | Vector2 |
Lerp(Vector2 v1, Vector2 v2, float f) | Vector2 | [static]
Lerp(ref Vector2 v1, ref Vector2 v2, float f, out Vector2 result) | Vector2 | [static]
Max(Vector2 v) | Vector2 |
Max(ref Vector2 v, out Vector2 result) | Vector2 |
Max(float f) | Vector2 |
Max(float f, out Vector2 result) | Vector2 |
Max(Vector2 v1, Vector2 v2) | Vector2 | [static]
Max(ref Vector2 v1, ref Vector2 v2, out Vector2 result) | Vector2 | [static]
Max(Vector2 v, float f) | Vector2 | [static]
Max(ref Vector2 v, float f, out Vector2 result) | Vector2 | [static]
Min(Vector2 v) | Vector2 |
Min(ref Vector2 v, out Vector2 result) | Vector2 |
Min(float f) | Vector2 |
Min(float f, out Vector2 result) | Vector2 |
Min(Vector2 v1, Vector2 v2) | Vector2 | [static]
Min(ref Vector2 v1, ref Vector2 v2, out Vector2 result) | Vector2 | [static]
Min(Vector2 v, float f) | Vector2 | [static]
Min(ref Vector2 v, float f, out Vector2 result) | Vector2 | [static]
MoveTo(Vector2 v, float length) | Vector2 |
MoveTo(ref Vector2 v, float length, out Vector2 result) | Vector2 |
MoveTo(Vector2 v1, Vector2 v2, float length) | Vector2 | [static]
MoveTo(ref Vector2 v1, ref Vector2 v2, float length, out Vector2 result) | Vector2 | [static]
Multiply(Vector2 v) | Vector2 |
Multiply(ref Vector2 v, out Vector2 result) | Vector2 |
Multiply(float f) | Vector2 |
Multiply(float f, out Vector2 result) | Vector2 |
Multiply(Vector2 v1, Vector2 v2) | Vector2 | [static]
Multiply(ref Vector2 v1, ref Vector2 v2, out Vector2 result) | Vector2 | [static]
Multiply(Vector2 v, float f) | Vector2 | [static]
Multiply(ref Vector2 v, float f, out Vector2 result) | Vector2 | [static]
Negate() | Vector2 |
Negate(out Vector2 result) | Vector2 |
Negate(Vector2 v) | Vector2 | [static]
Negate(ref Vector2 v, out Vector2 result) | Vector2 | [static]
Normalize() | Vector2 |
Normalize(out Vector2 result) | Vector2 |
Normalize(Vector2 v) | Vector2 | [static]
Normalize(ref Vector2 v, out Vector2 result) | Vector2 | [static]
One | Vector2 | [static]
operator!=(Vector2 v1, Vector2 v2) | Vector2 | [static]
operator*(Vector2 v1, Vector2 v2) | Vector2 | [static]
operator*(Vector2 v, float f) | Vector2 | [static]
operator*(float f, Vector2 v) | Vector2 | [static]
operator+(Vector2 v1, Vector2 v2) | Vector2 | [static]
operator+(Vector2 v, float f) | Vector2 | [static]
operator+(float f, Vector2 v) | Vector2 | [static]
operator-(Vector2 v1, Vector2 v2) | Vector2 | [static]
operator-(Vector2 v, float f) | Vector2 | [static]
operator-(float f, Vector2 v) | Vector2 | [static]
operator-(Vector2 v) | Vector2 | [static]
operator/(Vector2 v1, Vector2 v2) | Vector2 | [static]
operator/(Vector2 v, float f) | Vector2 | [static]
operator/(float f, Vector2 v) | Vector2 | [static]
operator==(Vector2 v1, Vector2 v2) | Vector2 | [static]
Perpendicular() | Vector2 |
Perpendicular(out Vector2 result) | Vector2 |
Perpendicular(Vector2 v) | Vector2 | [static]
Perpendicular(ref Vector2 v, out Vector2 result) | Vector2 | [static]
ProjectOnLine(Vector2 point, Vector2 direction) | Vector2 |
ProjectOnLine(ref Vector2 point, ref Vector2 direction, out Vector2 result) | Vector2 |
ProjectOnLine(Vector2 v, Vector2 point, Vector2 direction) | Vector2 | [static]
ProjectOnLine(ref Vector2 v, ref Vector2 point, ref Vector2 direction, out Vector2 result) | Vector2 | [static]
R | Vector2 |
Reflect(Vector2 normal) | Vector2 |
Reflect(ref Vector2 normal, out Vector2 result) | Vector2 |
Reflect(Vector2 v, Vector2 normal) | Vector2 | [static]
Reflect(ref Vector2 v, ref Vector2 normal, out Vector2 result) | Vector2 | [static]
Repeat(Vector2 min, Vector2 max) | Vector2 |
Repeat(ref Vector2 min, ref Vector2 max, out Vector2 result) | Vector2 |
Repeat(float min, float max) | Vector2 |
Repeat(float min, float max, out Vector2 result) | Vector2 |
Repeat(Vector2 v, Vector2 min, Vector2 max) | Vector2 | [static]
Repeat(ref Vector2 v, ref Vector2 min, ref Vector2 max, out Vector2 result) | Vector2 | [static]
Repeat(Vector2 v, float min, float max) | Vector2 | [static]
Repeat(ref Vector2 v, float min, float max, out Vector2 result) | Vector2 | [static]
Rotate(float angle) | Vector2 |
Rotate(float angle, out Vector2 result) | Vector2 |
Rotate(Vector2 rotation) | Vector2 |
Rotate(ref Vector2 rotation, out Vector2 result) | Vector2 |
Rotate(Vector2 v, float angle) | Vector2 | [static]
Rotate(ref Vector2 v, float angle, out Vector2 result) | Vector2 | [static]
Rotate(Vector2 v, Vector2 rotation) | Vector2 | [static]
Rotate(ref Vector2 v, ref Vector2 rotation, out Vector2 result) | Vector2 | [static]
Rotation(float angle) | Vector2 | [static]
Rotation(float angle, out Vector2 result) | Vector2 | [static]
Slerp(Vector2 v, float f) | Vector2 |
Slerp(ref Vector2 v, float f, out Vector2 result) | Vector2 |
Slerp(Vector2 v1, Vector2 v2, float f) | Vector2 | [static]
Slerp(ref Vector2 v1, ref Vector2 v2, float f, out Vector2 result) | Vector2 | [static]
Subtract(Vector2 v) | Vector2 |
Subtract(ref Vector2 v, out Vector2 result) | Vector2 |
Subtract(Vector2 v1, Vector2 v2) | Vector2 | [static]
Subtract(ref Vector2 v1, ref Vector2 v2, out Vector2 result) | Vector2 | [static]
ToString() | Vector2 |
TurnTo(Vector2 v, float angle) | Vector2 |
TurnTo(ref Vector2 v, float angle, out Vector2 result) | Vector2 |
TurnTo(Vector2 v1, Vector2 v2, float angle) | Vector2 | [static]
TurnTo(ref Vector2 v1, ref Vector2 v2, float angle, out Vector2 result) | Vector2 | [static]
UnitX | Vector2 | [static]
UnitY | Vector2 | [static]
Vector2(float x, float y) | Vector2 |
Vector2(float f) | Vector2 |
X | Vector2 |
Xx | Vector2 |
Xy | Vector2 |
Xy0 | Vector2 |
Xy00 | Vector2 |
Xy01 | Vector2 |
Xy1 | Vector2 |
Xy10 | Vector2 |
Xy11 | Vector2 |
Y | Vector2 |
Yx | Vector2 |
Yy | Vector2 |
Zero | Vector2 | [static]


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Vector3

Vector3 メンバ一覧

これは全メンバの一覧です。Vector3継承メンバも含んでいます。
Abs() | Vector3 |
Abs(out Vector3 result) | Vector3 |
Abs(Vector3 v) | Vector3 | [static]
Abs(ref Vector3 v, out Vector3 result) | Vector3 | [static]
Add(Vector3 v) | Vector3 |
Add(ref Vector3 v, out Vector3 result) | Vector3 |
Add(Vector3 v1, Vector3 v2) | Vector3 | [static]
Add(ref Vector3 v1, ref Vector3 v2, out Vector3 result) | Vector3 | [static]
Angle(Vector3 v) | Vector3 |
Angle(ref Vector3 v) | Vector3 |
Angle(Vector3 v1, Vector3 v2) | Vector3 | [static]
Angle(ref Vector3 v1, ref Vector3 v2) | Vector3 | [static]
B | Vector3 |
Clamp(Vector3 min, Vector3 max) | Vector3 |
Clamp(ref Vector3 min, ref Vector3 max, out Vector3 result) | Vector3 |
Clamp(float min, float max) | Vector3 |
Clamp(float min, float max, out Vector3 result) | Vector3 |
Clamp(Vector3 v, Vector3 min, Vector3 max) | Vector3 | [static]
Clamp(ref Vector3 v, ref Vector3 min, ref Vector3 max, out Vector3 result) | Vector3 | [static]
Clamp(Vector3 v, float min, float max) | Vector3 | [static]
Clamp(ref Vector3 v, float min, float max, out Vector3 result) | Vector3 | [static]
Cross(Vector3 v) | Vector3 |
Cross(ref Vector3 v, out Vector3 result) | Vector3 |
Cross(Vector3 v1, Vector3 v2) | Vector3 | [static]
Cross(ref Vector3 v1, ref Vector3 v2, out Vector3 result) | Vector3 | [static]
Distance(Vector3 v) | Vector3 |
Distance(ref Vector3 v) | Vector3 |
Distance(Vector3 v1, Vector3 v2) | Vector3 | [static]
Distance(ref Vector3 v1, ref Vector3 v2) | Vector3 | [static]
DistanceSquared(Vector3 v) | Vector3 |
DistanceSquared(ref Vector3 v) | Vector3 |
DistanceSquared(Vector3 v1, Vector3 v2) | Vector3 | [static]
DistanceSquared(ref Vector3 v1, ref Vector3 v2) | Vector3 | [static]
Divide(Vector3 v) | Vector3 |
Divide(ref Vector3 v, out Vector3 result) | Vector3 |
Divide(float f) | Vector3 |
Divide(float f, out Vector3 result) | Vector3 |
Divide(Vector3 v1, Vector3 v2) | Vector3 | [static]
Divide(ref Vector3 v1, ref Vector3 v2, out Vector3 result) | Vector3 | [static]
Divide(Vector3 v, float f) | Vector3 | [static]
Divide(ref Vector3 v, float f, out Vector3 result) | Vector3 | [static]
Dot(Vector3 v) | Vector3 |
Dot(ref Vector3 v) | Vector3 |
Dot(Vector3 v1, Vector3 v2) | Vector3 | [static]
Dot(ref Vector3 v1, ref Vector3 v2) | Vector3 | [static]
Equals(Vector3 v, float epsilon) | Vector3 |
Equals(Vector3 v) | Vector3 |
Equals(Object o) | Vector3 |
G | Vector3 |
GetHashCode() | Vector3 |
IsInfinity() | Vector3 |
IsNaN() | Vector3 |
IsOne() | Vector3 |
IsUnit(float epsilon) | Vector3 |
IsZero() | Vector3 |
Length() | Vector3 |
Length(Vector3 v) | Vector3 | [static]
Length(ref Vector3 v) | Vector3 | [static]
LengthSquared() | Vector3 |
LengthSquared(Vector3 v) | Vector3 | [static]
LengthSquared(ref Vector3 v) | Vector3 | [static]
Lerp(Vector3 v, float f) | Vector3 |
Lerp(ref Vector3 v, float f, out Vector3 result) | Vector3 |
Lerp(Vector3 v1, Vector3 v2, float f) | Vector3 | [static]
Lerp(ref Vector3 v1, ref Vector3 v2, float f, out Vector3 result) | Vector3 | [static]
Max(Vector3 v) | Vector3 |
Max(ref Vector3 v, out Vector3 result) | Vector3 |
Max(float f) | Vector3 |
Max(float f, out Vector3 result) | Vector3 |
Max(Vector3 v1, Vector3 v2) | Vector3 | [static]
Max(ref Vector3 v1, ref Vector3 v2, out Vector3 result) | Vector3 | [static]
Max(Vector3 v, float f) | Vector3 | [static]
Max(ref Vector3 v, float f, out Vector3 result) | Vector3 | [static]
Min(Vector3 v) | Vector3 |
Min(ref Vector3 v, out Vector3 result) | Vector3 |
Min(float f) | Vector3 |
Min(float f, out Vector3 result) | Vector3 |
Min(Vector3 v1, Vector3 v2) | Vector3 | [static]
Min(ref Vector3 v1, ref Vector3 v2, out Vector3 result) | Vector3 | [static]
Min(Vector3 v, float f) | Vector3 | [static]
Min(ref Vector3 v, float f, out Vector3 result) | Vector3 | [static]
MoveTo(Vector3 v, float length) | Vector3 |
MoveTo(ref Vector3 v, float length, out Vector3 result) | Vector3 |
MoveTo(Vector3 v1, Vector3 v2, float length) | Vector3 | [static]
MoveTo(ref Vector3 v1, ref Vector3 v2, float length, out Vector3 result) | Vector3 | [static]
Multiply(Vector3 v) | Vector3 |
Multiply(ref Vector3 v, out Vector3 result) | Vector3 |
Multiply(float f) | Vector3 |
Multiply(float f, out Vector3 result) | Vector3 |
Multiply(Vector3 v1, Vector3 v2) | Vector3 | [static]
Multiply(ref Vector3 v1, ref Vector3 v2, out Vector3 result) | Vector3 | [static]
Multiply(Vector3 v, float f) | Vector3 | [static]
Multiply(ref Vector3 v, float f, out Vector3 result) | Vector3 | [static]
Negate() | Vector3 |
Negate(out Vector3 result) | Vector3 |
Negate(Vector3 v) | Vector3 | [static]
Negate(ref Vector3 v, out Vector3 result) | Vector3 | [static]
Normalize() | Vector3 |
Normalize(out Vector3 result) | Vector3 |
Normalize(Vector3 v) | Vector3 | [static]
Normalize(ref Vector3 v, out Vector3 result) | Vector3 | [static]
One | Vector3 | [static]
operator!=(Vector3 v1, Vector3 v2) | Vector3 | [static]
operator*(Vector3 v1, Vector3 v2) | Vector3 | [static]
operator*(Vector3 v, float f) | Vector3 | [static]
operator*(float f, Vector3 v) | Vector3 | [static]
operator+(Vector3 v1, Vector3 v2) | Vector3 | [static]
operator+(Vector3 v, float f) | Vector3 | [static]
operator+(float f, Vector3 v) | Vector3 | [static]
operator-(Vector3 v1, Vector3 v2) | Vector3 | [static]
operator-(Vector3 v, float f) | Vector3 | [static]
operator-(float f, Vector3 v) | Vector3 | [static]
operator-(Vector3 v) | Vector3 | [static]
operator/(Vector3 v1, Vector3 v2) | Vector3 | [static]
operator/(Vector3 v, float f) | Vector3 | [static]
operator/(float f, Vector3 v) | Vector3 | [static]
operator==(Vector3 v1, Vector3 v2) | Vector3 | [static]
Perpendicular() | Vector3 |
Perpendicular(out Vector3 result) | Vector3 |
Perpendicular(Vector3 v) | Vector3 | [static]
Perpendicular(ref Vector3 v, out Vector3 result) | Vector3 | [static]
ProjectOnLine(Vector3 point, Vector3 direction) | Vector3 |
ProjectOnLine(ref Vector3 point, ref Vector3 direction, out Vector3 result) | Vector3 |
ProjectOnLine(Vector3 v, Vector3 point, Vector3 direction) | Vector3 | [static]
ProjectOnLine(ref Vector3 v, ref Vector3 point, ref Vector3 direction, out Vector3 result) | Vector3 | [static]
R | Vector3 |
Reflect(Vector3 normal) | Vector3 |
Reflect(ref Vector3 normal, out Vector3 result) | Vector3 |
Reflect(Vector3 v, Vector3 normal) | Vector3 | [static]
Reflect(ref Vector3 v, ref Vector3 normal, out Vector3 result) | Vector3 | [static]
Repeat(Vector3 min, Vector3 max) | Vector3 |
Repeat(ref Vector3 min, ref Vector3 max, out Vector3 result) | Vector3 |
Repeat(float min, float max) | Vector3 |
Repeat(float min, float max, out Vector3 result) | Vector3 |
Repeat(Vector3 v, Vector3 min, Vector3 max) | Vector3 | [static]
Repeat(ref Vector3 v, ref Vector3 min, ref Vector3 max, out Vector3 result) | Vector3 | [static]
Repeat(Vector3 v, float min, float max) | Vector3 | [static]
Repeat(ref Vector3 v, float min, float max, out Vector3 result) | Vector3 | [static]
RotateX(float angle) | Vector3 |
RotateX(float angle, out Vector3 result) | Vector3 |
RotateX(Vector2 rotation) | Vector3 |
RotateX(ref Vector2 rotation, out Vector3 result) | Vector3 |
RotateX(Vector3 v, float angle) | Vector3 | [static]
RotateX(ref Vector3 v, float angle, out Vector3 result) | Vector3 | [static]
RotateX(Vector3 v, Vector2 rotation) | Vector3 | [static]
RotateX(ref Vector3 v, ref Vector2 rotation, out Vector3 result) | Vector3 | [static]
RotateY(float angle) | Vector3 |
RotateY(float angle, out Vector3 result) | Vector3 |
RotateY(Vector2 rotation) | Vector3 |
RotateY(ref Vector2 rotation, out Vector3 result) | Vector3 |
RotateY(Vector3 v, float angle) | Vector3 | [static]
RotateY(ref Vector3 v, float angle, out Vector3 result) | Vector3 | [static]
RotateY(Vector3 v, Vector2 rotation) | Vector3 | [static]
RotateY(ref Vector3 v, ref Vector2 rotation, out Vector3 result) | Vector3 | [static]
RotateZ(float angle) | Vector3 |
RotateZ(float angle, out Vector3 result) | Vector3 |
RotateZ(Vector2 rotation) | Vector3 |
RotateZ(ref Vector2 rotation, out Vector3 result) | Vector3 |
RotateZ(Vector3 v, float angle) | Vector3 | [static]
RotateZ(ref Vector3 v, float angle, out Vector3 result) | Vector3 | [static]
RotateZ(Vector3 v, Vector2 rotation) | Vector3 | [static]
RotateZ(ref Vector3 v, ref Vector2 rotation, out Vector3 result) | Vector3 | [static]
Slerp(Vector3 v, float f) | Vector3 |
Slerp(ref Vector3 v, float f, out Vector3 result) | Vector3 |
Slerp(Vector3 v1, Vector3 v2, float f) | Vector3 | [static]
Slerp(ref Vector3 v1, ref Vector3 v2, float f, out Vector3 result) | Vector3 | [static]
Subtract(Vector3 v) | Vector3 |
Subtract(ref Vector3 v, out Vector3 result) | Vector3 |
Subtract(Vector3 v1, Vector3 v2) | Vector3 | [static]
Subtract(ref Vector3 v1, ref Vector3 v2, out Vector3 result) | Vector3 | [static]
ToString() | Vector3 |
TurnTo(Vector3 v, float angle) | Vector3 |
TurnTo(ref Vector3 v, float angle, out Vector3 result) | Vector3 |
TurnTo(Vector3 v1, Vector3 v2, float angle) | Vector3 | [static]
TurnTo(ref Vector3 v1, ref Vector3 v2, float angle, out Vector3 result) | Vector3 | [static]
UnitX | Vector3 | [static]
UnitY | Vector3 | [static]
UnitZ | Vector3 | [static]
Vector3(float x, float y, float z) | Vector3 |
Vector3(Vector2 xy, float z) | Vector3 |
Vector3(float f) | Vector3 |
X | Vector3 |
Xx | Vector3 |
Xxx | Vector3 |
Xxy | Vector3 |
Xxz | Vector3 |
Xy | Vector3 |
Xyx | Vector3 |
Xyy | Vector3 |
Xyz | Vector3 |
Xyz0 | Vector3 |
Xyz1 | Vector3 |
Xz | Vector3 |
Xzx | Vector3 |
Xzy | Vector3 |
Xzz | Vector3 |
Y | Vector3 |
Yx | Vector3 |
Yxx | Vector3 |
Yxy | Vector3 |
Yxz | Vector3 |
Yy | Vector3 |
Yyx | Vector3 |
Yyy | Vector3 |
Yyz | Vector3 |
Yz | Vector3 |
Yzx | Vector3 |
Yzy | Vector3 |
Yzz | Vector3 |
Z | Vector3 |
Zero | Vector3 | [static]
Zx | Vector3 |
Zxx | Vector3 |
Zxy | Vector3 |
Zxz | Vector3 |
Zy | Vector3 |
Zyx | Vector3 |
Zyy | Vector3 |
Zyz | Vector3 |
Zz | Vector3 |
Zzx | Vector3 |
Zzy | Vector3 |
Zzz | Vector3 |


メンバ一覧

  • Sce
  • PlayStation
  • Core
  • Vector4

Vector4 メンバ一覧

これは全メンバの一覧です。Vector4継承メンバも含んでいます。
A | Vector4 |
Abs() | Vector4 |
Abs(out Vector4 result) | Vector4 |
Abs(Vector4 v) | Vector4 | [static]
Abs(ref Vector4 v, out Vector4 result) | Vector4 | [static]
Add(Vector4 v) | Vector4 |
Add(ref Vector4 v, out Vector4 result) | Vector4 |
Add(Vector4 v1, Vector4 v2) | Vector4 | [static]
Add(ref Vector4 v1, ref Vector4 v2, out Vector4 result) | Vector4 | [static]
B | Vector4 |
Clamp(Vector4 min, Vector4 max) | Vector4 |
Clamp(ref Vector4 min, ref Vector4 max, out Vector4 result) | Vector4 |
Clamp(float min, float max) | Vector4 |
Clamp(float min, float max, out Vector4 result) | Vector4 |
Clamp(Vector4 v, Vector4 min, Vector4 max) | Vector4 | [static]
Clamp(ref Vector4 v, ref Vector4 min, ref Vector4 max, out Vector4 result) | Vector4 | [static]
Clamp(Vector4 v, float min, float max) | Vector4 | [static]
Clamp(ref Vector4 v, float min, float max, out Vector4 result) | Vector4 | [static]
Distance(Vector4 v) | Vector4 |
Distance(ref Vector4 v) | Vector4 |
Distance(Vector4 v1, Vector4 v2) | Vector4 | [static]
Distance(ref Vector4 v1, ref Vector4 v2) | Vector4 | [static]
DistanceSquared(Vector4 v) | Vector4 |
DistanceSquared(ref Vector4 v) | Vector4 |
DistanceSquared(Vector4 v1, Vector4 v2) | Vector4 | [static]
DistanceSquared(ref Vector4 v1, ref Vector4 v2) | Vector4 | [static]
Divide(Vector4 v) | Vector4 |
Divide(ref Vector4 v, out Vector4 result) | Vector4 |
Divide(float f) | Vector4 |
Divide(float f, out Vector4 result) | Vector4 |
Divide(Vector4 v1, Vector4 v2) | Vector4 | [static]
Divide(ref Vector4 v1, ref Vector4 v2, out Vector4 result) | Vector4 | [static]
Divide(Vector4 v, float f) | Vector4 | [static]
Divide(ref Vector4 v, float f, out Vector4 result) | Vector4 | [static]
Dot(Vector4 v) | Vector4 |
Dot(ref Vector4 v) | Vector4 |
Dot(Vector4 v1, Vector4 v2) | Vector4 | [static]
Dot(ref Vector4 v1, ref Vector4 v2) | Vector4 | [static]
Equals(Vector4 v, float epsilon) | Vector4 |
Equals(Vector4 v) | Vector4 |
Equals(Object o) | Vector4 |
G | Vector4 |
GetHashCode() | Vector4 |
IsInfinity() | Vector4 |
IsNaN() | Vector4 |
IsOne() | Vector4 |
IsUnit(float epsilon) | Vector4 |
IsZero() | Vector4 |
Length() | Vector4 |
Length(Vector4 v) | Vector4 | [static]
Length(ref Vector4 v) | Vector4 | [static]
LengthSquared() | Vector4 |
LengthSquared(Vector4 v) | Vector4 | [static]
LengthSquared(ref Vector4 v) | Vector4 | [static]
Lerp(Vector4 v, float f) | Vector4 |
Lerp(ref Vector4 v, float f, out Vector4 result) | Vector4 |
Lerp(Vector4 v1, Vector4 v2, float f) | Vector4 | [static]
Lerp(ref Vector4 v1, ref Vector4 v2, float f, out Vector4 result) | Vector4 | [static]
Max(Vector4 v) | Vector4 |
Max(ref Vector4 v, out Vector4 result) | Vector4 |
Max(float f) | Vector4 |
Max(float f, out Vector4 result) | Vector4 |
Max(Vector4 v1, Vector4 v2) | Vector4 | [static]
Max(ref Vector4 v1, ref Vector4 v2, out Vector4 result) | Vector4 | [static]
Max(Vector4 v, float f) | Vector4 | [static]
Max(ref Vector4 v, float f, out Vector4 result) | Vector4 | [static]
Min(Vector4 v) | Vector4 |
Min(ref Vector4 v, out Vector4 result) | Vector4 |
Min(float f) | Vector4 |
Min(float f, out Vector4 result) | Vector4 |
Min(Vector4 v1, Vector4 v2) | Vector4 | [static]
Min(ref Vector4 v1, ref Vector4 v2, out Vector4 result) | Vector4 | [static]
Min(Vector4 v, float f) | Vector4 | [static]
Min(ref Vector4 v, float f, out Vector4 result) | Vector4 | [static]
MoveTo(Vector4 v, float length) | Vector4 |
MoveTo(ref Vector4 v, float length, out Vector4 result) | Vector4 |
MoveTo(Vector4 v1, Vector4 v2, float length) | Vector4 | [static]
MoveTo(ref Vector4 v1, ref Vector4 v2, float length, out Vector4 result) | Vector4 | [static]
Multiply(Vector4 v) | Vector4 |
Multiply(ref Vector4 v, out Vector4 result) | Vector4 |
Multiply(float f) | Vector4 |
Multiply(float f, out Vector4 result) | Vector4 |
Multiply(Vector4 v1, Vector4 v2) | Vector4 | [static]
Multiply(ref Vector4 v1, ref Vector4 v2, out Vector4 result) | Vector4 | [static]
Multiply(Vector4 v, float f) | Vector4 | [static]
Multiply(ref Vector4 v, float f, out Vector4 result) | Vector4 | [static]
Negate() | Vector4 |
Negate(out Vector4 result) | Vector4 |
Negate(Vector4 v) | Vector4 | [static]
Negate(ref Vector4 v, out Vector4 result) | Vector4 | [static]
Normalize() | Vector4 |
Normalize(out Vector4 result) | Vector4 |
Normalize(Vector4 v) | Vector4 | [static]
Normalize(ref Vector4 v, out Vector4 result) | Vector4 | [static]
One | Vector4 | [static]
operator!=(Vector4 v1, Vector4 v2) | Vector4 | [static]
operator*(Vector4 v1, Vector4 v2) | Vector4 | [static]
operator*(Vector4 v, float f) | Vector4 | [static]
operator*(float f, Vector4 v) | Vector4 | [static]
operator+(Vector4 v1, Vector4 v2) | Vector4 | [static]
operator+(Vector4 v, float f) | Vector4 | [static]
operator+(float f, Vector4 v) | Vector4 | [static]
operator-(Vector4 v1, Vector4 v2) | Vector4 | [static]
operator-(Vector4 v, float f) | Vector4 | [static]
operator-(float f, Vector4 v) | Vector4 | [static]
operator-(Vector4 v) | Vector4 | [static]
operator/(Vector4 v1, Vector4 v2) | Vector4 | [static]
operator/(Vector4 v, float f) | Vector4 | [static]
operator/(float f, Vector4 v) | Vector4 | [static]
operator==(Vector4 v1, Vector4 v2) | Vector4 | [static]
R | Vector4 |
Repeat(Vector4 min, Vector4 max) | Vector4 |
Repeat(ref Vector4 min, ref Vector4 max, out Vector4 result) | Vector4 |
Repeat(float min, float max) | Vector4 |
Repeat(float min, float max, out Vector4 result) | Vector4 |
Repeat(Vector4 v, Vector4 min, Vector4 max) | Vector4 | [static]
Repeat(ref Vector4 v, ref Vector4 min, ref Vector4 max, out Vector4 result) | Vector4 | [static]
Repeat(Vector4 v, float min, float max) | Vector4 | [static]
Repeat(ref Vector4 v, float min, float max, out Vector4 result) | Vector4 | [static]
Subtract(Vector4 v) | Vector4 |
Subtract(ref Vector4 v, out Vector4 result) | Vector4 |
Subtract(Vector4 v1, Vector4 v2) | Vector4 | [static]
Subtract(ref Vector4 v1, ref Vector4 v2, out Vector4 result) | Vector4 | [static]
ToString() | Vector4 |
UnitW | Vector4 | [static]
UnitX | Vector4 | [static]
UnitY | Vector4 | [static]
UnitZ | Vector4 | [static]
Vector4(float x, float y, float z, float w) | Vector4 |
Vector4(Vector3 xyz, float w) | Vector4 |
Vector4(Vector2 xy, float z, float w) | Vector4 |
Vector4(Vector2 xy, Vector2 zw) | Vector4 |
Vector4(float f) | Vector4 |
W | Vector4 |
Ww | Vector4 |
Www | Vector4 |
Wwww | Vector4 |
Wwwx | Vector4 |
Wwwy | Vector4 |
Wwwz | Vector4 |
Wwx | Vector4 |
Wwxw | Vector4 |
Wwxx | Vector4 |
Wwxy | Vector4 |
Wwxz | Vector4 |
Wwy | Vector4 |
Wwyw | Vector4 |
Wwyx | Vector4 |
Wwyy | Vector4 |
Wwyz | Vector4 |
Wwz | Vector4 |
Wwzw | Vector4 |
Wwzx | Vector4 |
Wwzy | Vector4 |
Wwzz | Vector4 |
Wx | Vector4 |
Wxw | Vector4 |
Wxww | Vector4 |
Wxwx | Vector4 |
Wxwy | Vector4 |
Wxwz | Vector4 |
Wxx | Vector4 |
Wxxw | Vector4 |
Wxxx | Vector4 |
Wxxy | Vector4 |
Wxxz | Vector4 |
Wxy | Vector4 |
Wxyw | Vector4 |
Wxyx | Vector4 |
Wxyy | Vector4 |
Wxyz | Vector4 |
Wxz | Vector4 |
Wxzw | Vector4 |
Wxzx | Vector4 |
Wxzy | Vector4 |
Wxzz | Vector4 |
Wy | Vector4 |
Wyw | Vector4 |
Wyww | Vector4 |
Wywx | Vector4 |
Wywy | Vector4 |
Wywz | Vector4 |
Wyx | Vector4 |
Wyxw | Vector4 |
Wyxx | Vector4 |
Wyxy | Vector4 |
Wyxz | Vector4 |
Wyy | Vector4 |
Wyyw | Vector4 |
Wyyx | Vector4 |
Wyyy | Vector4 |
Wyyz | Vector4 |
Wyz | Vector4 |
Wyzw | Vector4 |
Wyzx | Vector4 |
Wyzy | Vector4 |
Wyzz | Vector4 |
Wz | Vector4 |
Wzw | Vector4 |
Wzww | Vector4 |
Wzwx | Vector4 |
Wzwy | Vector4 |
Wzwz | Vector4 |
Wzx | Vector4 |
Wzxw | Vector4 |
Wzxx | Vector4 |
Wzxy | Vector4 |
Wzxz | Vector4 |
Wzy | Vector4 |
Wzyw | Vector4 |
Wzyx | Vector4 |
Wzyy | Vector4 |
Wzyz | Vector4 |
Wzz | Vector4 |
Wzzw | Vector4 |
Wzzx | Vector4 |
Wzzy | Vector4 |
Wzzz | Vector4 |
X | Vector4 |
Xw | Vector4 |
Xww | Vector4 |
Xwww | Vector4 |
Xwwx | Vector4 |
Xwwy | Vector4 |
Xwwz | Vector4 |
Xwx | Vector4 |
Xwxw | Vector4 |
Xwxx | Vector4 |
Xwxy | Vector4 |
Xwxz | Vector4 |
Xwy | Vector4 |
Xwyw | Vector4 |
Xwyx | Vector4 |
Xwyy | Vector4 |
Xwyz | Vector4 |
Xwz | Vector4 |
Xwzw | Vector4 |
Xwzx | Vector4 |
Xwzy | Vector4 |
Xwzz | Vector4 |
Xx | Vector4 |
Xxw | Vector4 |
Xxww | Vector4 |
Xxwx | Vector4 |
Xxwy | Vector4 |
Xxwz | Vector4 |
Xxx | Vector4 |
Xxxw | Vector4 |
Xxxx | Vector4 |
Xxxy | Vector4 |
Xxxz | Vector4 |
Xxy | Vector4 |
Xxyw | Vector4 |
Xxyx | Vector4 |
Xxyy | Vector4 |
Xxyz | Vector4 |
Xxz | Vector4 |
Xxzw | Vector4 |
Xxzx | Vector4 |
Xxzy | Vector4 |
Xxzz | Vector4 |
Xy | Vector4 |
Xyw | Vector4 |
Xyww | Vector4 |
Xywx | Vector4 |
Xywy | Vector4 |
Xywz | Vector4 |
Xyx | Vector4 |
Xyxw | Vector4 |
Xyxx | Vector4 |
Xyxy | Vector4 |
Xyxz | Vector4 |
Xyy | Vector4 |
Xyyw | Vector4 |
Xyyx | Vector4 |
Xyyy | Vector4 |
Xyyz | Vector4 |
Xyz | Vector4 |
Xyz0 | Vector4 |
Xyz1 | Vector4 |
Xyzw | Vector4 |
Xyzx | Vector4 |
Xyzy | Vector4 |
Xyzz | Vector4 |
Xz | Vector4 |
Xzw | Vector4 |
Xzww | Vector4 |
Xzwx | Vector4 |
Xzwy | Vector4 |
Xzwz | Vector4 |
Xzx | Vector4 |
Xzxw | Vector4 |
Xzxx | Vector4 |
Xzxy | Vector4 |
Xzxz | Vector4 |
Xzy | Vector4 |
Xzyw | Vector4 |
Xzyx | Vector4 |
Xzyy | Vector4 |
Xzyz | Vector4 |
Xzz | Vector4 |
Xzzw | Vector4 |
Xzzx | Vector4 |
Xzzy | Vector4 |
Xzzz | Vector4 |
Y | Vector4 |
Yw | Vector4 |
Yww | Vector4 |
Ywww | Vector4 |
Ywwx | Vector4 |
Ywwy | Vector4 |
Ywwz | Vector4 |
Ywx | Vector4 |
Ywxw | Vector4 |
Ywxx | Vector4 |
Ywxy | Vector4 |
Ywxz | Vector4 |
Ywy | Vector4 |
Ywyw | Vector4 |
Ywyx | Vector4 |
Ywyy | Vector4 |
Ywyz | Vector4 |
Ywz | Vector4 |
Ywzw | Vector4 |
Ywzx | Vector4 |
Ywzy | Vector4 |
Ywzz | Vector4 |
Yx | Vector4 |
Yxw | Vector4 |
Yxww | Vector4 |
Yxwx | Vector4 |
Yxwy | Vector4 |
Yxwz | Vector4 |
Yxx | Vector4 |
Yxxw | Vector4 |
Yxxx | Vector4 |
Yxxy | Vector4 |
Yxxz | Vector4 |
Yxy | Vector4 |
Yxyw | Vector4 |
Yxyx | Vector4 |
Yxyy | Vector4 |
Yxyz | Vector4 |
Yxz | Vector4 |
Yxzw | Vector4 |
Yxzx | Vector4 |
Yxzy | Vector4 |
Yxzz | Vector4 |
Yy | Vector4 |
Yyw | Vector4 |
Yyww | Vector4 |
Yywx | Vector4 |
Yywy | Vector4 |
Yywz | Vector4 |
Yyx | Vector4 |
Yyxw | Vector4 |
Yyxx | Vector4 |
Yyxy | Vector4 |
Yyxz | Vector4 |
Yyy | Vector4 |
Yyyw | Vector4 |
Yyyx | Vector4 |
Yyyy | Vector4 |
Yyyz | Vector4 |
Yyz | Vector4 |
Yyzw | Vector4 |
Yyzx | Vector4 |
Yyzy | Vector4 |
Yyzz | Vector4 |
Yz | Vector4 |
Yzw | Vector4 |
Yzww | Vector4 |
Yzwx | Vector4 |
Yzwy | Vector4 |
Yzwz | Vector4 |
Yzx | Vector4 |
Yzxw | Vector4 |
Yzxx | Vector4 |
Yzxy | Vector4 |
Yzxz | Vector4 |
Yzy | Vector4 |
Yzyw | Vector4 |
Yzyx | Vector4 |
Yzyy | Vector4 |
Yzyz | Vector4 |
Yzz | Vector4 |
Yzzw | Vector4 |
Yzzx | Vector4 |
Yzzy | Vector4 |
Yzzz | Vector4 |
Z | Vector4 |
Zero | Vector4 | [static]
Zw | Vector4 |
Zww | Vector4 |
Zwww | Vector4 |
Zwwx | Vector4 |
Zwwy | Vector4 |
Zwwz | Vector4 |
Zwx | Vector4 |
Zwxw | Vector4 |
Zwxx | Vector4 |
Zwxy | Vector4 |
Zwxz | Vector4 |
Zwy | Vector4 |
Zwyw | Vector4 |
Zwyx | Vector4 |
Zwyy | Vector4 |
Zwyz | Vector4 |
Zwz | Vector4 |
Zwzw | Vector4 |
Zwzx | Vector4 |
Zwzy | Vector4 |
Zwzz | Vector4 |
Zx | Vector4 |
Zxw | Vector4 |
Zxww | Vector4 |
Zxwx | Vector4 |
Zxwy | Vector4 |
Zxwz | Vector4 |
Zxx | Vector4 |
Zxxw | Vector4 |
Zxxx | Vector4 |
Zxxy | Vector4 |
Zxxz | Vector4 |
Zxy | Vector4 |
Zxyw | Vector4 |
Zxyx | Vector4 |
Zxyy | Vector4 |
Zxyz | Vector4 |
Zxz | Vector4 |
Zxzw | Vector4 |
Zxzx | Vector4 |
Zxzy | Vector4 |
Zxzz | Vector4 |
Zy | Vector4 |
Zyw | Vector4 |
Zyww | Vector4 |
Zywx | Vector4 |
Zywy | Vector4 |
Zywz | Vector4 |
Zyx | Vector4 |
Zyxw | Vector4 |
Zyxx | Vector4 |
Zyxy | Vector4 |
Zyxz | Vector4 |
Zyy | Vector4 |
Zyyw | Vector4 |
Zyyx | Vector4 |
Zyyy | Vector4 |
Zyyz | Vector4 |
Zyz | Vector4 |
Zyzw | Vector4 |
Zyzx | Vector4 |
Zyzy | Vector4 |
Zyzz | Vector4 |
Zz | Vector4 |
Zzw | Vector4 |
Zzww | Vector4 |
Zzwx | Vector4 |
Zzwy | Vector4 |
Zzwz | Vector4 |
Zzx | Vector4 |
Zzxw | Vector4 |
Zzxx | Vector4 |
Zzxy | Vector4 |
Zzxz | Vector4 |
Zzy | Vector4 |
Zzyw | Vector4 |
Zzyx | Vector4 |
Zzyy | Vector4 |
Zzyz | Vector4 |
Zzz | Vector4 |
Zzzw | Vector4 |
Zzzx | Vector4 |
Zzzy | Vector4 |
Zzzz | Vector4 |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • BlendMode

BlendMode メンバ一覧

これは全メンバの一覧です。BlendMode継承メンバも含んでいます。
Additive | BlendMode | [static]
BlendFunc | BlendMode |
BlendMode(bool enabled, BlendFunc blend_func) | BlendMode |
Enabled | BlendMode |
Multiplicative | BlendMode | [static]
None | BlendMode | [static]
Normal | BlendMode | [static]
PremultipliedAlpha | BlendMode | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Bounds2

Bounds2 メンバ一覧

これは全メンバの一覧です。Bounds2継承メンバも含んでいます。
Add(Vector2 point) | Bounds2 |
Add(Bounds2 bounds) | Bounds2 |
Aspect | Bounds2 |
Bounds2(Vector2 min, Vector2 max) | Bounds2 |
Bounds2(Vector2 point) | Bounds2 |
Center | Bounds2 |
CenteredSquare(float h) | Bounds2 | [static]
ClosestSurfacePoint(Vector2 point, out Vector2 ret, out float sign) | Bounds2 |
Intersection(Bounds2 bounds) | Bounds2 |
IsEmpty() | Bounds2 |
IsInside(Vector2 point) | Bounds2 |
Max | Bounds2 |
Min | Bounds2 |
NegativeClipSegment(ref Vector2 A, ref Vector2 B) | Bounds2 |
operator+(Bounds2 bounds, Vector2 value) | Bounds2 | [static]
operator-(Bounds2 bounds, Vector2 value) | Bounds2 | [static]
OutrageousYTopBottomSwap() | Bounds2 |
OutrageousYVCoordFlip() | Bounds2 |
Overlaps(Bounds2 bounds) | Bounds2 |
Point00 | Bounds2 |
Point01 | Bounds2 |
Point10 | Bounds2 |
Point11 | Bounds2 |
Quad0_1 | Bounds2 | [static]
QuadMinus1_1 | Bounds2 | [static]
SafeBounds(Vector2 min, Vector2 max) | Bounds2 | [static]
Scale(Vector2 scale, Vector2 center) | Bounds2 |
SignedDistance(Vector2 point) | Bounds2 |
Size | Bounds2 |
ToString() | Bounds2 |
Zero | Bounds2 | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • ConvexPoly2

ConvexPoly2 メンバ一覧

これは全メンバの一覧です。ConvexPoly2継承メンバも含んでいます。
CalcArea() | ConvexPoly2
CalcBounds() | ConvexPoly2
CalcCenter() | ConvexPoly2
ClosestSurfacePoint(Vector2 point, out Vector2 ret, out float sign) | ConvexPoly2
ConvexPoly2(Vector2[] points) | ConvexPoly2
GetNormal(int index) | ConvexPoly2
GetPlane(int index) | ConvexPoly2
GetPoint(int index) | ConvexPoly2
IsInside(Vector2 point) | ConvexPoly2
MakeBox(Bounds2 bounds) | ConvexPoly2
MakeRegular(uint num, float r) | ConvexPoly2
NegativeClipSegment(ref Vector2 A, ref Vector2 B) | ConvexPoly2
Planes | ConvexPoly2
SignedDistance(Vector2 point) | ConvexPoly2
Size() | ConvexPoly2
Sphere | ConvexPoly2
Translate(Vector2 dx, ConvexPoly2 poly) | ConvexPoly2


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • DrawHelpers
  • Vertex

DrawHelpers.Vertex メンバ一覧

これは全メンバの一覧です。DrawHelpers.Vertex継承メンバも含んでいます。
Color | DrawHelpers.Vertex
Position | DrawHelpers.Vertex
Vertex(Vector4 pos, Vector4 col) | DrawHelpers.Vertex
Vertex(Vector2 pos, Vector4 col) | DrawHelpers.Vertex


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • FontMap
  • CharData

FontMap.CharData メンバ一覧

これは全メンバの一覧です。FontMap.CharData継承メンバも含んでいます。
PixelSize | FontMap.CharData
UV | FontMap.CharData


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Input2
  • ButtonState

Input2.ButtonState メンバ一覧

これは全メンバの一覧です。Input2.ButtonState継承メンバも含んでいます。
Down | Input2.ButtonState
On | Input2.ButtonState
Press | Input2.ButtonState
Release | Input2.ButtonState


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Matrix3

Matrix3 メンバ一覧

これは全メンバの一覧です。Matrix3継承メンバも含んでいます。
Determinant() | Matrix3 |
Equals(ref Matrix3 m, float epsilon) | Matrix3 |
Equals(ref Matrix3 m) | Matrix3 |
GetCoordSysError() | Matrix3 |
Identity | Matrix3 | [static]
Inverse() | Matrix3 |
InverseOrthonormal() | Matrix3 |
IsOrthonormal(float epsilon) | Matrix3 |
Matrix3(Vector3 valx, Vector3 valy, Vector3 valz) | Matrix3 |
Matrix4() | Matrix3 |
operator*(Matrix3 m, Vector3 v) | Matrix3 | [static]
operator*(Matrix3 m1, Matrix3 m2) | Matrix3 | [static]
Rotation(Vector2 unit_vector) | Matrix3 | [static]
Rotation(float angle) | Matrix3 | [static]
Scale(Vector2 value) | Matrix3 | [static]
Skew(Vector2 value) | Matrix3 | [static]
ToString() | Matrix3 |
Translation(Vector2 value) | Matrix3 | [static]
Transpose() | Matrix3 |
TRS(Vector2 translation, Vector2 unit_vector, Vector2 scale) | Matrix3 | [static]
X | Matrix3 |
Y | Matrix3 |
Z | Matrix3 |
Zero | Matrix3 | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Plane2

Plane2 メンバ一覧

これは全メンバの一覧です。Plane2継承メンバも含んでいます。
Base | Plane2
ClosestSurfacePoint(Vector2 point, out Vector2 ret, out float sign) | Plane2
IsInside(Vector2 point) | Plane2
NegativeClipSegment(ref Vector2 A, ref Vector2 B) | Plane2
Plane2(Vector2 a_base, Vector2 a_unit_normal) | Plane2
Project(Vector2 point) | Plane2
SignedDistance(Vector2 point) | Plane2
UnitNormal | Plane2


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Sphere2

Sphere2 メンバ一覧

これは全メンバの一覧です。Sphere2継承メンバも含んでいます。
Center | Sphere2
ClosestSurfacePoint(Vector2 point, out Vector2 ret, out float sign) | Sphere2
IsInside(Vector2 point) | Sphere2
NegativeClipSegment(ref Vector2 A, ref Vector2 B) | Sphere2
Radius | Sphere2
SignedDistance(Vector2 point) | Sphere2
Sphere2(Vector2 center, float radius) | Sphere2


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • TRS

TRS メンバ一覧

これは全メンバの一覧です。TRS継承メンバも含んでいます。
Angle | TRS |
Bounds2() | TRS |
Center | TRS |
Centering(Vector2 normalized_pos) | TRS |
Point00 | TRS |
Point01 | TRS |
Point10 | TRS |
Point11 | TRS |
Quad0_1 | TRS | [static]
QuadMinus1_1 | TRS | [static]
R | TRS |
Rotate(float angle) | TRS |
Rotate(Vector2 rotation) | TRS |
RotationNormalize | TRS |
S | TRS |
T | TRS |
Tile(Vector2i num_tiles, Vector2i tile_index, TRS source_area) | TRS | [static]
ToString() | TRS |
TRS(Bounds2 a_bounds) | TRS |
X | TRS |
Y | TRS |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Vector2i

Vector2i メンバ一覧

これは全メンバの一覧です。Vector2i継承メンバも含んでいます。
Clamp(Vector2i min, Vector2i max) | Vector2i |
ClampIndex(Vector2i n) | Vector2i |
Equals(Vector2i v) | Vector2i |
Equals(Object o) | Vector2i |
GetHashCode() | Vector2i |
Max(Vector2i value) | Vector2i |
Min(Vector2i value) | Vector2i |
operator!=(Vector2i a, Vector2i value) | Vector2i | [static]
operator*(Vector2i a, Vector2i value) | Vector2i | [static]
operator*(Vector2i a, int value) | Vector2i | [static]
operator*(int value, Vector2i a) | Vector2i | [static]
operator+(Vector2i a, Vector2i value) | Vector2i | [static]
operator-(Vector2i a, Vector2i value) | Vector2i | [static]
operator-(Vector2i a) | Vector2i | [static]
operator/(Vector2i a, Vector2i value) | Vector2i | [static]
operator==(Vector2i a, Vector2i value) | Vector2i | [static]
Product() | Vector2i |
ToString() | Vector2i |
Vector2() | Vector2i |
Vector2i(int x, int y) | Vector2i |
WrapIndex(Vector2i n) | Vector2i |
X | Vector2i |
Y | Vector2i |
Yx | Vector2i |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • Base
  • Vector3i

Vector3i メンバ一覧

これは全メンバの一覧です。Vector3i継承メンバも含んでいます。
Clamp(Vector3i min, Vector3i max) | Vector3i |
ClampIndex(Vector3i n) | Vector3i |
Equals(Vector3i v) | Vector3i |
Equals(Object o) | Vector3i |
GetHashCode() | Vector3i |
Max(Vector3i value) | Vector3i |
Min(Vector3i value) | Vector3i |
operator!=(Vector3i a, Vector3i value) | Vector3i | [static]
operator*(Vector3i a, Vector3i value) | Vector3i | [static]
operator+(Vector3i a, Vector3i value) | Vector3i | [static]
operator-(Vector3i a, Vector3i value) | Vector3i | [static]
operator/(Vector3i a, Vector3i value) | Vector3i | [static]
operator==(Vector3i a, Vector3i value) | Vector3i | [static]
Product() | Vector3i |
ToString() | Vector3i |
Vector3() | Vector3i |
Vector3i(int x, int y, int z) | Vector3i |
Vector3i(Vector2i xy, int z) | Vector3i |
WrapIndex(Vector3i n) | Vector3i |
X | Vector3i |
Xx | Vector3i |
Xxx | Vector3i |
Xxy | Vector3i |
Xxz | Vector3i |
Xy | Vector3i |
Xyx | Vector3i |
Xyy | Vector3i |
Xyz | Vector3i |
Xz | Vector3i |
Xzx | Vector3i |
Xzy | Vector3i |
Xzz | Vector3i |
Y | Vector3i |
Yx | Vector3i |
Yxx | Vector3i |
Yxy | Vector3i |
Yxz | Vector3i |
Yy | Vector3i |
Yyx | Vector3i |
Yyy | Vector3i |
Yyz | Vector3i |
Yz | Vector3i |
Yzx | Vector3i |
Yzy | Vector3i |
Yzz | Vector3i |
Z | Vector3i |
Zx | Vector3i |
Zxx | Vector3i |
Zxy | Vector3i |
Zxz | Vector3i |
Zy | Vector3i |
Zyx | Vector3i |
Zyy | Vector3i |
Zyz | Vector3i |
Zz | Vector3i |
Zzx | Vector3i |
Zzy | Vector3i |
Zzz | Vector3i |


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • GameEngine2D
  • RawSpriteTile

RawSpriteTile メンバ一覧

これは全メンバの一覧です。RawSpriteTile継承メンバも含んでいます。
FlipU | RawSpriteTile
FlipV | RawSpriteTile
Quad | RawSpriteTile
RawSpriteTile(TRS positioning, Vector2i tile_index, bool flipu=false, bool flipv=false) | RawSpriteTile
TileIndex2D | RawSpriteTile


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Physics2D
  • PhysicsSolverPair

PhysicsSolverPair メンバ一覧

これは全メンバの一覧です。PhysicsSolverPair継承メンバも含んでいます。
GetImpulseNormal() | PhysicsSolverPair
GetImpulseTangent() | PhysicsSolverPair
GetIndexA() | PhysicsSolverPair
GetIndexB() | PhysicsSolverPair
normal | PhysicsSolverPair
Normal | PhysicsSolverPair
resA | PhysicsSolverPair
ResA | PhysicsSolverPair
resB | PhysicsSolverPair
ResB | PhysicsSolverPair
TotalIndex | PhysicsSolverPair
totalIndex | PhysicsSolverPair


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • Physics2D
  • RayHit

RayHit メンバ一覧

これは全メンバの一覧です。RayHit継承メンバも含んでいます。
depth | RayHit
Depth | RayHit
End | RayHit
end | RayHit
Hit | RayHit
hit | RayHit
HitIndex | RayHit
hitIndex | RayHit
Ratio | RayHit
ratio | RayHit
start | RayHit
Start | RayHit


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • NinePatchMargin

NinePatchMargin メンバ一覧

これは全メンバの一覧です。NinePatchMargin継承メンバも含んでいます。
Bottom | NinePatchMargin |
Left | NinePatchMargin |
NinePatchMargin(int left, int top, int right, int bottom) | NinePatchMargin |
Right | NinePatchMargin |
Top | NinePatchMargin |
Zero | NinePatchMargin | [static]


メンバ一覧

  • Sce
  • PlayStation
  • HighLevel
  • UI
  • UIColor

UIColor メンバ一覧

これは全メンバの一覧です。UIColor継承メンバも含んでいます。
A | UIColor |
B | UIColor |
Equals(object obj) | UIColor |
Equals(UIColor color) | UIColor |
G | UIColor |
GetHashCode() | UIColor |
operator Sce.PlayStation.Core.Vector4(UIColor color) | UIColor | [explicit, static]
operator UIColor(Sce.PlayStation.Core.Vector4 vec) | UIColor | [explicit, static]
operator!=(UIColor color1, UIColor color2) | UIColor | [static]
operator==(UIColor color1, UIColor color2) | UIColor | [static]
R | UIColor |
ToString() | UIColor |
UIColor(float r, float g, float b, float a) | UIColor |